Welcome

Sandcastle Help File Builder
[image]

Sandcastle Help File Builder Documentation
Welcome
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Welcome to the Sandcastle Help File Builder. Sandcastle, created by Microsoft, is a tool used for creating MSDN-style documentation from .NET assemblies and their associated XML comments files. The current version is the May 2008 release. It is command line based and has no GUI front-end, project management features, or an automated build process like those that you can find in NDoc. The Sandcastle Help File Builder was created to fill in the gaps, provide the missing NDoc-like features that are used most often, and provide graphical and command line based tools to build a help file in an automated fashion. The project is hosted at CodePlex in the Sandcastle Help File Builder project. Go there for the latest release, source code, the issue tracker, and discussion boards.

Tip:

See the Installation Instructions for information about the required set of additional tools that need to be installed, where to get them, and how to make sure everything is configured correctly.

Tip:

If you are new to Sandcastle and the help file builder, see the topics in the Getting Started section to get familiar with it, set up your projects to produce XML comments, and create a help file project.

Benefits and Features

Using the help file builder provides the following advantages:

  • The GUI interface provides an NDoc-like properties window so anyone familiar with NDoc should be quite comfortable using it. In addition, it provides a Visual Studio-like project explorer that lets you manage and edit the files associated with the project.
  • The builder can produce an HTML Help 1.x (.CHM) file, an HTML Help 2.x (.HxS) file, and/or a website.
  • The HTML Help 2.x output includes a valid set of collection files and an H2Reg.exe configuration file to simplify deployment and integration of the help file into existing collections such as those used by Visual Studio.
  • The website output contains an HTML and an ASP.NET index page with tree view that can be used to navigate the table of contents and a full-text index search feature.
  • The settings are saved in a standard MSBuild-format project file and can be built from within the standalone GUI, from the command line using MSBuild, or in a post-build step to a Visual Studio project that runs MSBuild. Support for full Visual Studio integration is planned for a future release.
  • A project file conversion option is provided to convert projects from other third-party tools such as NDoc, DocProject, SandcastleGUI, and the example GUI provided with Sandcastle to the help file builder's MSBuild project format.
  • Visual Studio 2005/2008 solution and project files are supported directly as documentation sources. When the help project is built, the assembly, XML comments file, and reference information is imported from them and used automatically.
  • In addition, both executable (.EXE) and library (.DLL) assemblies can be added individually as documentation sources along with any related XML comments files.
  • Dependency references can also be specified individually. File, GAC, project, and COM references are supported (COM references are supported in the project file but currently cannot be added via the standalone GUI).
  • The builder will automatically locate both Sandcastle and the HTML help compilers by looking at the common environment variables, in the system path, and in the Program Files special folder on all fixed hard drives. Properties are also supplied for you to specify the paths in the off-chance that it cannot locate them automatically.
  • The build process provides full logging and error handling. All output from the build is stored in a log file in the output folder. The log is in XML format and can be ran through an XSL transformation to make it more readable, to highlight warnings and errors, etc.
  • The intermediate files used to create the help file are placed in a working folder beneath an output folder of your choosing. They can be automatically removed after a successful build or kept around for further modifications.
  • Most of the NDoc features have been built into the Sandcastle help file builder including:
    • Definition of project summary and namespace summary comments that will appear in the help file. You can also easily indicate which namespaces to include or exclude from the help file. Support is also included for specifying namespace comments via a NamespaceDoc class within each namespace.
    • The ability to turn off documentation of attributes and various other unwanted API elements.
    • Automatic determination of the default topic for the help file.
    • You have control over the help file name, title, header text, and footer information such as the e-mail address, copyright text, and copyright URL.
  • Support for conceptual content is fully integrated. This allows you to define additional content that appears in the table of contents such as usage notes, tutorials, etc. Conceptual content is created using Microsoft Assistance Markup Language (MAML).
  • Standard HTML files can also be included and merged with the table of contents. A site map file can be used to define the layout.
  • Language selection and localization support is built in. Translations are provided for the help file builder resource files in several languages and information is provided on how to localize the Sandcastle content files.
  • Steps have been taken to make the build process more open so that you have a chance to customize it without having to modify the code for the builder application itself. Custom build process plug-ins are supported that can be used to extend or alter the build process in various ways. Plug-ins supplied with the help file builder include:
    • Additional Content Only - Build help files based on nothing but the conceptual and/or additional content items (no API content).
    • Additional Reference Links - Add additional sources of reference links for third-party libraries or MSDN content that does not appear in your help file.
    • AjaxDoc Builder - Build help files for Atlas script libraries in conjunction with AjaxDoc.
    • Completion Notification - E-mail the build results to someone optionally attaching the log file (raw or transformed via XSL).
    • DBCS Fix for CHM Builds - Fixes the HTML content and runs the Help 1 compiler in the proper locale to overcome its encoding issues.
    • Hierarchical Table of Contents - Used to rearrange the table of contents such that namespaces are nested within their parent namespaces.
    • Output Deployment - Copy the resulting help file to a file share, web server, FTP site, etc.
    • Script# Reflection File Fixer - Fixes up the reflection information file so that Script# assemblies are documented correctly.
    • Table of Contents Exclusion - Used to exclude API members from the table of contents (the members still appear in the help file).
    • Version Builder - Generate version information for the current project and others related to the same product and merge that information into a single help file for all of them.

    The plug-in interface is public and is documented in this help file allowing you to create your own custom plug-ins.

  • Support is included for the <inheritdoc /> tag which allows you to inherit documentation from base types/members. This is implemented via a standalone tool so it can also be used by other third-party tools and build scripts. This tool provides features beyond those found in the build component supplied with Sandcastle.

In addition to the help file builder, the following custom build components are supplied:

  • A code block component that extends the <code> XML comment tag with file inclusion, syntax highlighting, line numbering, collapsible #region and #if/#else/#endif sections, and a copy to clipboard option. This is useable in both reference and conceptual content.
  • A post-transform component that can be used to add a logo image to the header of each page, make some minor adjustments to the syntax section, and add basic version information to the help topics. This is useable in both reference and conceptual content.
  • A "show missing" component that adds "missing" notes for missing summary, returns, param, value, and remarks documentation tags and that can also auto-document constructors.
  • An IntelliSense component used to extract the XML comments into files that can be used for IntelliSense. Only the basic set of tags needed for IntelliSense are exported and only for documented API members. This can greatly reduce the size of the IntelliSense files and removes all private implementation details when only documenting the public API.
  • A help attribute component that can be used to add extra MSHelp:Attr attributes to each generated API topic. This is useful for adding extra DocSet and other attributes to the topics that are not added by the default Sandcastle transformations.
  • A JavaScript declaration syntax generator that can be used for regular JavaScript as well as Script# projects.
  • A Resolve Conceptual Links build component that fixes some bugs in the standard version of the component and also adds some new features.
  • A set of cached build data components that cache key information such as comment, reflection index information, and MSDN URLs across builds in order to speed them up.

The custom build components can also be used outside of the help file builder in other custom build scripts and third-party tools as well.

Note:

This help file was built using the help file builder and demonstrates many of the features that it provides.

See Also

Other Resources

Getting Started
Installation Instructions
Sandcastle Help File Builder Overview
Links to Resources
Version History

Send comments on this topic to Eric@EWoodruff.us

[v1.8.0.2] Copyright © 2006-2009, Eric Woodruff, All rights reserved


License Agreement

[image]

Sandcastle Help File Builder Documentation
License Agreement
Send Feedback

[This is preliminary documentation and is subject to change.]

This topic contains the following sections.

  • Microsoft Public License (Ms-PL)
  • Copyright Notices

Microsoft Public License (Ms-PL)

This license governs use of the accompanying software. If you use the software, you accept this license. If you do not accept the license, do not use the software.

  1. Definitions

    • The terms "reproduce," "reproduction," "derivative works," and "distribution" have the same meaning here as under U.S. copyright law.
    • A "contribution" is the original software, or any additions or changes to the software.
    • A "contributor" is any person that distributes its contribution under this license.
    • "Licensed patents" are a contributor's patent claims that read directly on its contribution.

  2. Grant of Rights

    • (A) Copyright Grant - Subject to the terms of this license, including the license conditions and limitations in section 3, each contributor grants you a non-exclusive, worldwide, royalty-free copyright license to reproduce its contribution, prepare derivative works of its contribution, and distribute its contribution or any derivative works that you create.
    • (B) Patent Grant - Subject to the terms of this license, including the license conditions and limitations in section 3, each contributor grants you a non-exclusive, worldwide, royalty-free license under its licensed patents to make, have made, use, sell, offer for sale, import, and/or otherwise dispose of its contribution in the software or derivative works of the contribution in the software.

  3. Conditions and Limitations

    • (A) No Trademark License - This license does not grant you rights to use any contributors' name, logo, or trademarks.
    • (B) If you bring a patent claim against any contributor over patents that you claim are infringed by the software, your patent license from such contributor to the software ends automatically.
    • (C) If you distribute any portion of the software, you must retain all copyright, patent, trademark, and attribution notices that are present in the software.
    • (D) If you distribute any portion of the software in source code form, you may do so only under this license by including a complete copy of this license with your distribution. If you distribute any portion of the software in compiled or object code form, you may only do so under a license that complies with this license.
    • (E) The software is licensed "as-is." You bear the risk of using it. The contributors give no express warranties, guarantees or conditions. You may have additional consumer rights under your local laws which this license cannot change. To the extent permitted under your local laws, the contributors exclude the implied warranties of merchantability, fitness for a particular purpose and non-infringement.

Copyright Notices

The ICSharpCode.TextEditor is Copyright © 2000-2009 IC#Code, All Rights Reserved.

The Weifen Luo DockPanel Suite is Copyright © 2007-2009 Weifen Luo, All Rights Reserved.

AjaxDoc is Copyright © 2006-2009 Bertrand Le Roy, All Rights Reserved.

Script# is Copyright © 2007-2009 Nikhil Kothari, All Rights Reserved.

SBAppLocale is Copyright © 2005-2009 Steel Bytes, All Rights Reserved.

The code colorizer library is Copyright © 2003-2009, Jonathan de Halleux, All Rights Reserved.

All other code is Copyright © 2006-2009, Eric Woodruff, All Rights Reserved.


Known Issues and Limitations

[image]

Sandcastle Help File Builder Documentation
Known Issues and Limitations
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The following are the known issues and limitations in the current release of the help file builder.

  • This version is a Beta release. It appears to be quite stable and the project for this help file was developed and built with it. However, don't be surprised if you do find a bug or two. If you find any, please report them in the Discussions forum or Issue Tracker at the Sandcastle Help File Builder project on CodePlex. Please be sure to specify the version number you are using to keep the issues separate from the prior releases. Thank you!
  • Not all topics in the help file have been filled in yet to reflect new features and changes in the project system and the build engine. You will recognize these by a "TODO:" comment where the introduction should be or in the topic body. If you need help in one of these areas, please ask in the Discussion area of the Sandcastle Help File Builder project at CodePlex. Please be sure to specify the version number you are using to keep the issues separate from the prior releases.
  • The standalone GUI does not support source control providers.
  • Linked items (file items in which the physical file is located in a folder outside the project's folder) are supported but cannot be added from the standalone GUI.
  • COM object references are supported in the projects but they cannot be added from the standalone GUI.
  • Due to their non-standard format, managed C++ projects are not currently supported as documentation sources or project references. Add the targets and references individually for the time being.
  • The display of editor windows, the Properties window, or the Preview window sometimes gets corrupted such that the content area disappears or is not sized correctly in the tabbed area of the UI. Selecting a different file tab and switching back to the affected tab, closing and reopening the affected file/window, or resizing the width of a docked window to force a repaint will work around the issue.
  • Renaming a folder or file in the Project Explorer will not rename any open document editors associated with the renamed folder or file. If necessary, do a File | Save As to save it in the right location or just close and reopen the file if it has not been changed.
  • A standard tree control is used in the Project Explorer window and does not allow selection of multiple tree nodes. As such, all operations within it only affect the currently selected node.
  • When doing search and replace in a text editor window, the highlight on the found text is not always retained when doing a subsequent search/replace. The cursor is positioned correctly though.
  • When using the dropdown on the editor window's "various elements" toolbar button (shows alert as the default action when first opened), the cursor occassionally disappears from the editor window after the dropdown closes even though it has the focus and text can be entered. Change the focus to another window and back to restore it.

See Also

Other Resources

Version 1.8.0.2 (Beta 2)
Version 1.8.0.1 (Beta 1)
Version 1.8.0.0 (Alpha)
Version History


Getting Started

[image]

Sandcastle Help File Builder Documentation
Getting Started
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The topics in this section will help you install all of the required tools, become familiar with the Sandcastle Help File Builder, and create your first project.

  • Installation Instructions
  • Sandcastle Help File Builder Overview
  • Walkthrough: Enabling and Using XML Comments
  • Walkthrough: Creating Your First Project
  • Project File Converters
  • Relative and Absolute Paths
  • The Log File
  • User Preferences
  • Using the <inheritdoc /> Tag
  • Documenting Web Projects
  • Building Projects Outside the GUI
  • Generating Documentation with Team Build

See Also

Other Resources

Welcome
FAQ
Links to Resources
Version History


Installation Instructions

[image]

Sandcastle Help File Builder Documentation
Installation Instructions
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This topics describes the additional tools that are required to use the Sandcastle Help File Builder along with some general configuration information.

  • Requirements
  • Recommended Additions
  • Optional Items
  • See Also

Requirements

In order to use the Sandcastle Help File Builder, the following additional tools are required and must be installed prior to building a help file:

  • The .NET Framework 3.5 SP1.
  • The latest version of Microsoft's Sandcastle (currently the May 2008 release as of May 31, 2009).
    Note:

    This is the set of documentation tools created by Microsoft. The help file builder uses them to produce the help file topics.

  • The HTML Help Workshop for building HTML Help 1.x (.CHM) help files.
  • The HTML Help 2.x compiler for building HTML Help 2.x (.HxS) help files. This must be downloaded and installed as part of the Visual Studio 2005 SDK or the Visual Studio 2008 SDK.
  • The latest version of the help file builder can always be found at the Sandcastle Help File Builder CodePlex project site.

The tools can be installed in any order. However, be aware that both the Visual Studio 2005 and 2008 SDKs contain outdated versions of Sandcastle. This can cause the DXROOT environment variable used to locate the Sandcastle tools to be incorrect. After installing either SDK, do the following:

  1. Check the user environment variables. If you see a copy of the DXROOT environment variable there, delete it.
  2. If there is a user copy of the PATH environment variable, remove any path to the SDK version of Sandcastle that it contains. If that is all it contains, it can be deleted.
  3. Check the system environment variables to ensure that a DXROOT environment variable does exist and that it points to the correct location of the Microsoft Sandcastle tools (not the help file builder). Usually this will be C:\Program Files\Sandcastle unless you installed it in an alternate location.
Note:

You may need to reboot the system in order for any environment variable changes to take effect.

Recommended Additions

The following tools and patches are optional but you will find them useful and it is highly recommended that they be installed as well.

  • Download the latest community-maintained patches for the Sandcastle presentation styles from the Sandcastle Styles CodePlex project site. This is essential if you will be producing conceptual content as it fixes a number of bugs and adds many new features that will make your conceptual content appear much better.
  • To view HTML Help 2.x files without registering them, you can use the freeware H2 Viewer. You can configure the help file builder to use it for viewing Help 2 output via the User Preferences dialog.
  • To register HTML Help 2.x files both for testing and as part of your product installation, download the shareware tool H2Reg.exe from The Helpware Group.
  • If you are going to document website projects, download the Custom Web Code Providers. These make it easy to document website projects by extracing the XML comments files to a location of your choice when the website is deployed.

Optional Items

The following items are not required to use Sandcastle or the help file builder but you may find them useful.

  • If you are documenting .NET 1.1 applications and need the Help 2 compiler tools, you can download the Visual Studio 2003 Help Integration Toolkit.
  • For a Visual Studio add-in used to create XML comments automatically, check out Roland Weigelt's GhostDoc.
  • If you need to convert HTML additional content topics to MAML, you can download the HTML to MAML Converter utility.

See Also

Other Resources

Getting Started
Links to Resources
Sandcastle Help File Builder Overview
Project File Converters


Sandcastle Help File Builder Overview

[image]

Sandcastle Help File Builder Documentation
Sandcastle Help File Builder Overview
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Sandcastle Help File Builder standalone GUI provides an environment in which you can edit the properties that control the features and appearance of the compiled help file. In addition, it lets you manage various files associated with the help project.

Shown above is the help file builder's main form. The menu bar at the top provides access to the various program options:

  • The File menu provides access to the various project and file related commands such as creating a new project, saving the project, and interacting with the Project Explorer window to manage the files in the project.
  • The Documentation menu contains the commands used to build the help file, view the log file from a build, and view the compiled help in its various formats.
  • The Window menu contains the commands used to show the various task windows and jump to any of the open topic or file editors.
  • The Help menu allows you to open the help file, view the FAQ help topic, and view product version and copyright information.

Many of these options are also available within the individual tabbed windows and docked panes via keyboard shortcuts, context menus, and toolbar buttons. The toolbar just below the menu bar contains buttons for most of the common options. The images on each button correspond to the images on the matching menu option in the menu bar dropdown menus. In addition, it contains two dropdowns: one for the Configuration option and one for the Platform option. These values are used to specify the default configuration and platform values to use when extracting information from Visual Studio project documentation sources when they do not specify a value for themselves in their properties.

The central area of the main form is where you will see the various file editors and task windows. The windows can be dragged around and docked in various locations. Shown above are the two main windows that you will use most often: the Project Explorer Window and the Project Properties Window. If you are at all familiar with either Visual Studio or NDoc, these windows should look and feel quite similar in appearance and usage.

See Also

Other Resources

Getting Started
Installation Instructions
Walkthrough: Enabling and Using XML Comments
Walkthrough: Creating Your First Project
Project Explorer Window
Project Properties Window


Walkthrough: Enabling and Using XML Comments

[image]

Sandcastle Help File Builder Documentation
Walkthrough: Enabling and Using XML Comments
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This walkthrough will describe the steps needed to enable XML comments file output in your Visual Studio projects, provides information on where to get more information on using XML comments to decorate your code, and describes how to open help file builder projects from within Visual Studio.

  • Enabling XML Comments File Generation
  • Decorating Your Code
  • Setting Up Visual Studio to Open a Help File Builder Project File
  • See Also

Enabling XML Comments File Generation

In order to create a help file that contains reference content (API documentation), you must enable XML comments in your Visual Studio projects so that an XML file is generated to contain them when the project is built.

Note:

If you are trying to document a website project, see the Documenting Web Projects topic for some necessary information as they are unlike other Visual Studio projects and require additional steps in order to generate XML comments files.

Tip:

If not using the Visual Studio IDE, the various managed language compilers support a /doc command line option that will produce the XML comments file. See your language compiler command line option documentation for details.

All Projects Except Managed C++ Projects

  1. In the Solution Explorer, right click on the project and select Properties.

  2. Select the Build property page.

    Note:

    The XML comments filename is a configuration option. As such, you can either select the All Configurations option at the top of the page to set the XML comments options for all configurations at the same time or select each configuration individually and repeat the next steps for each one.

  3. In the Output section, check the checkbox next to the Xml documentation file text box and specify a name for the XML file. Although not required, a common convention is to name the XML comments file after the related assembly (except with a .xml extension). The assembly name can be found on the Application property page.

  4. If you have a solution with multiple projects that need to be documented, repeat the above steps for each project in the solution. It is recommended that you give each project's XML comments file a unique name.

If documenting a managed C++ project, the procedure differs and you need to follow these steps instead.

Managed C++ Projects

  1. In the Solution Explorer, right click on the project and select Properties.

  2. Expand the Configuration Properties category and then expand the C/C++ sub-category and select the Output Files option below it.

    Note:

    The XML comments file option is a configuration option. As such, you can either select the All Configurations option at the top of the dialog box to set the XML comments options for all configurations at the same time or select each configuration individually and repeat the next step for each one.

  3. In the Output Files options, change the Generate XML Documentation Files option to Yes (/doc).

  4. By default, the comments file is named after the project target with a .xml extension and is placed in the target folder. If you want to change the name, select the XML Document Generator category below the Configuration Properties category and change the filename using the Output Document File property.

  5. If you have a solution with multiple projects that need to be documented, repeat the above steps for each project in the solution. If you explicitly specify a name for the comments file, it is recommended that you give each project's XML comments file a unique name.

Once the above has been done, Visual Studio will create the XML comments file each time the project is built.

Decorating Your Code

In addition to setting the project option to create the file, you must also add XML comments to your source code. At a minimum, you should add a <summary> tag to each public type and to the public and protected members of those types. There are many other tags available that will help improve the quality of your documentation.

For a comprehensive list of XML documentation tags and a description of their attributes and usage you can download the XML Documentation Comments Guide. Basic information on XML comments and how to use them can also be found at either XML Documentation Comments (C# Programming Guide) or Documenting Your Code with XML (Visual Basic).

Although it is not mentioned in the XML tag documentation, you can use HTML markup within your XML comments to provide additional formatting, embed images, etc. See the FAQ for more information.

Setting Up Visual Studio to Open a Help File Builder Project File

Although it uses an MSBuild project file format, a help file builder project cannot be opened and used directly from within Visual Studio like a normal project. This will require a Visual Studio package that provides such support (one is planned for a future release). In the meantime, a help file builder project can be added to the solution file so that it can be checked into source control and opened from within Visual Studio by launching the standalone GUI. You can add it as a solution item by right clicking on the solution name in the Solution Explorer, selecting Add | Existing Item, and then selecting the help file builder project. It is then added to a Solution Items folder in your solution.

The .shfbproj file extension is registered to be opened with the help file builder's standalone GUI when installed. As such, double-clicking the project file in the solution should open it using the standalone GUI automatically. If this does not happen, you can have Visual Studio open the help file builder project using the GUI rather than its default text editor by doing the following: Right click on the help file builder project and select Open With.... Click Add to add a new program to the list. Enter the path to SandcastleBuilderGUI.exe for your system and enter something like "Sandcastle Help File Builder" for the friendly name. Click OK to save it, and then click Set as Default to make it the default tool for opening the help file builder projects. Click OK to save it. Now, whenever you double-click the help file builder project, it will open in the standalone GUI automatically.

Next Steps

Now that you have enabled XML comments in your project and added some comments to your code, you are ready to create your first help file builder project.

See Also

Other Resources

Getting Started
Installation Instructions
Sandcastle Help File Builder Overview
Walkthrough: Creating Your First Project
Building Projects Outside the GUI
Generating Documentation with Team Build


Walkthrough: Creating Your First Project

[image]

Sandcastle Help File Builder Documentation
Walkthrough: Creating Your First Project
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This walkthrough will guide you through creating your first help file builder project.

Prerequisites

Before creating a help file builder project, be sure that you have installed all of the necessary tools and that you have enabled XML comments in your project and added some comments to your code.

New Projects

Creating a Brand New Project

  1. Select File | New Project

  2. In the Save As dialog box, select the folder in which to save the new project and enter its name. Click Save to create the new project. Once done, the Project Explorer Window and the Project Properties Window will be opened for you.

  3. Ignore the properties window for now and right click on the Documentation Sources node in the Project Explorer. In the context menu, select Add Documentation Source. A documentation source is a file such as an assembly or a Visual Studio solution or project from which information will be extracted to produce API documentation. For this demo, navigate to the help file builder folder and select the SandcastleBuilder.Components.dll assembly.

    Tip:

    When selecting either an assembly or an XML comments file, the help file builder will automatically add the partner file for you (i.e. the XML comments file for the like-named assembly or the assembly for the like-named comments file). Multiple files can also be selected and added in one go or dragged from Windows Explorer and dropped on the Documentation Sources node.

  4. Now we will add a reference assembly to the project. References are assemblies that are dependencies of one or more of the documentation source assemblies. They contain information necessary to create inherited member information for the documented classes but that are themselves not wanted in the API documentation. Right click on the References node and select Add File/Project Reference. For this example, navigate to the help file builder folder and select the ColorizerLibrary.dll.

    Tip:

    Given that solutions and projects are supported as documentation sources, you may find it easier to add them as documentation sources instead of the assemblies, comments, and references that they contain. When a solution or project is used, these items are imported from them automatically at build time.

  5. You are now ready to build a basic help file. Select Documentation | Build Project to do so. The help file builder will open the Output Window and start displaying the messages from the build process. Depending on the number of documentation sources, the number of types and members in them, and some other factors, this can take several minutes or, in extremely large projects, several hours.

    Tip:

    All build warnings and errors are reported with a code value. You can look these values up in the Errors and Warnings section of the help file for information about what they mean and possible solutions to fix the problem.

    Note:

    The build process can consume a lot of memory and, if your system has less than 1GB, it may take much more time to complete a build. Another factor that can affect the build time is the SdkLinkType project property setting. By default, it is set to MSDN which causes the BuildAssembler tool to contact the MSDN web service to resolve links to online content for all .NET Framework types and members. If your internet connection is slow, the resulting build will take longer. See the SdkLinkType property documentation for information on its possible values and the cached build components topic for information on how you can reduce the build time.

    Note:

    When SdkLinkType is set to MSDN, the build may fail if you are behind a proxy server. See the FAQ for the workaround.

  6. Once the build process finishes, you can select the Documentation | View Help File menu option to view the help file. The default View Help File option displays the help format based on which type or types where built (Help 1, Help 2, or website). You can also select a specific help format to view if multiple formats were built as determined by the HelpFileFormat project property.

    Note:

    In order to view HTML Help 2.x files, a separate viewer application is required and must be defined in the User Preferences. See the Installation Instructions for information on how to obtain one.

    Note:

    The ASP.NET website is started using the built-in development web server supplied with .NET 2.0. You can alter the settings used for it via the User Preferences.

If you have been using a different documentation tool, you may be able to create a Sandcastle Help File Builder project based on the other tool's project file.

Create a New Project From Another Project Format

  1. Select File | New Project from Other Format

  2. Select the project format from the dropdown

  3. Enter the project name to be converted or click the "..." button to the right of the textbox to browse for a project to convert.

  4. Enter the folder name in which to place the converted project and its related files or click the "..." button to the right of the textbox to browse for a location. This folder must be different from the folder containing the source project being converted. The folder will be created if it does not exist.

  5. Click the Convert button to perform the project conversion. If successful, the converted project is opened ready for use.

Next Steps

Now that you have created and built your first project, explore the other sections and topics in the help file to learn more about the other features available in the help file builder.

See Also

Other Resources

Getting Started
Walkthrough: Enabling and Using XML Comments
Project File Converters
Project Explorer Window
Project Properties Window
FAQ


Project File Converters

[image]

Sandcastle Help File Builder Documentation
Project File Converters
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

A set of project converters is supplied that can convert help projects in various other documentation tool formats into the help file builder project file format. To convert a project, select the File | New Project from Other Format menu option.

Available Project Converters

All project converters work in a similar fashion. Each requires the name of a project file and a destination folder in which to place the converted project and its related files. The destination folder must be different from the source folder that contains the project file being converted. If it does not exist, it will be created. Select a topic below to learn more about a specific project file converter.

  • SHFB v1.7.0.0 or Earlier Converter
  • NDoc 1.x Converter
  • DocProject 1.x Converter
  • SandcastleGUI 1.x Converter
  • Sandcastle Example GUI Converter

See Also

Other Resources

Getting Started
Sandcastle Help File Builder Overview


SHFB v1.7.0.0 or Earlier Converter

[image]

Sandcastle Help File Builder Documentation
SHFB v1.7.0.0 or Earlier Converter
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to convert project files created using the Sandcastle Help File Builder v1.7.0.0 or earlier to the new MSBuild project file format.

Post-Conversion Review

While significantly different, the new project file format still has all of the same features and project options as the old file format. The main difference that you will notice is that additional content and conceptual content files are now exposed and managed via the Project Explorer. This makes it much easier to manage the files and add new ones. The following are the main differences and some issues that you may encounter with the converted project file:

  • Review all path related properties to ensure that they are still accurate in the new project.

  • Review the Documentation Sources and References project nodes to see that the required items were imported correctly and make any necessary adjustments.

    Tip:

    Given that solutions and projects are supported as documentation sources, you may find it easier to add them as documentation sources instead of the assemblies, comments, and references that they contain. When a solution or project is used, these items are imported from them automatically at build time.

  • Review the configurations for all build components added via the ComponentConfigurations property and the configurations for all plug-ins added via the PlugInConfigurations property. It may be necessary to adjust the paths on file-related options.
  • Not all files can be detected and added to the project (i.e. files referenced in topics such as example code files, the logo file in the Post-Transform component, etc.). If build errors result from missing files, simply add them to the project or adjust the paths and/or filenames as needed.
  • If you were using the Code Block Component, you may need to adjust the path to external source files in the source attribute on the <code> elements.
  • Conceptual content media files are added as project file items. Their BuildAction is set to Image and the additional properties such as the ID and alternate text are stored in the file item properties.
  • Conceptual content tokens are stored in a file that is added to the project and its BuildAction is set to Tokens to indicate that it should be treated as such in the build. The extension on the filename is set to .tokens.
  • If a conceptual content code snippets files is defined, it is added to the project and its BuildAction is set to CodeSnippets to indicate that it should be treated as such in the build. The extension on the filename is changed to .snippets.

  • All additional content files and subfolders are added to the project recursively as file items with default build actions based on the file extensions. If it does not already contain one, you can add a site map to the project and edit it to set the order and layout of the additional content items.

    Tip:

    The help file builder contains full support for conceptual content that uses Microsoft Assistance Markup Language (MAML) to create additional non-API topics such as How-Tos, walkthroughs, etc. You may want to consider switching any additional HTML content to conceptual content to take advantage of its features. See the Conceptual Content topic for more information.

  • Wildcard additional content items are expanded into individual file entries in the new project. As such, you may find that unwanted files have been added to the project (i.e. source control files) that you were not aware of before as they were copied as part of build and may not have been noticed. The extra files can be deleted from the new project.
  • Because the additional content files actually become part of the project and are copied to the project folder, their base path may be different than the destination path specified in the old project. The file's location within the project is used to determine its destination path in the compiled help file. Files at the root end up in the root folder of the compiled help file. Files in subfolders end up in like-named subfolders in the compiled help file. These paths may differ from the old project and you may need to adjust the file locations within the project after conversion to get them where they need to be when the project is built.
  • Conceptual content topics are copied to the project and will have their filename extension changed from .xml to .aml to reflect their actual purpose. Note that the BuildAction on topics files is set to None. This is correct as the content layout file determines which topics are included in the help file at build time.
  • In addition to the filename extension change, the topic ID and revision number are embedded in each converted MAML topic file. Going forward, all conceptual topic files must contain a root <topic> element with id and revisionNumber attributes. This is done to allow the content layout file to reference topics by ID alone and lets topic files move around without you having to update their physical location in the layout files.
  • Any HTML or .topic files found in the conceptual content layout will be modified to include <meta> elements that contain the ID and revision number for the same reason the ID and revision number are added to the conceptual content MAML topic files.

See Also

Other Resources

Project File Converters
Sandcastle Help File Builder Overview
Version 1.8.0.0 (Alpha)


NDoc 1.x Converter

[image]

Sandcastle Help File Builder Documentation
NDoc 1.x Converter
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to convert NDoc project files to the help file builder project file format.

Post-Conversion Review

From its very beginning, the help file builder was written to be a viable replacement for NDoc. As such, almost all of the NDoc project properties have matching help file builder project properties and convert straight across to the equivalent properties in the new project. However, after conversion, the following items will need to be reviewed:

  • Review the Documentation Sources and References project nodes to see that the required items were imported correctly and make any necessary adjustments.

    Tip:

    Given that solutions and projects are supported as documentation sources, you may find it easier to add them as documentation sources instead of the assemblies, comments, and references that they contain. When a solution or project is used, these items are imported from them automatically at build time.

  • All files and subfolders in the folder specified in the NDoc AdditionalContentResourceDirectory property are added recursively to the project as file items. In addition, the files in the FilesToInclude property and the various Help 2 NamedUrlIndex page type related properties are also added to the project as file items. Each file will have a default build action based on its file extension. You can add a site map to the project and edit it to set the order and layout of the additional content HTML files.

    Tip:

    The help file builder contains full support for conceptual content that uses Microsoft Assistance Markup Language (MAML) to create additional non-API topics such as How-Tos, walkthroughs, etc. You may want to consider switching any additional HTML content to conceptual content to take advantage of its features. See the Conceptual Content topic for more information.

  • NDoc project files contain sections for several different documenters that it supported. Since there is no indication as to which is the active documenter, all properties are imported from the MSDN, MSDN-CHM, VS.NET 2003, and MSDN 2003 documenters. If the documenters contain properties that are duplicated in the other documenters, it is possible that the wrong value may end up in the converted project. Review the properties after conversion to be sure that the values that you wanted were used.

See Also

Other Resources

Project File Converters
Sandcastle Help File Builder Overview


DocProject 1.x Converter

[image]

Sandcastle Help File Builder Documentation
DocProject 1.x Converter
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to convert MSBuild project files created with Dave Sexton's DocProject Visual Studio add-in to the help file builder project file format.

Post-Conversion Review

There are several significant differences between DocProject and help file builder project files. However, the conversion process should give you a jumpstart and get you on your way to producing a help file with the new project. The following are some issues that you may encounter:

  • The first thing that you will notice is that there are significantly fewer files and folders in the converted project. This is because the help file builder uses the default set of presentation style files installed with Sandcastle rather than importing them into each project. If you made no changes to those files, you will not see any differences. If you did customize the presentation style files, it is possible that you may see differences in the layout and style of help files built with the converted project. Note that the help file builder contains many project properties that map to the equivalent resource file items that you might have changed in the DocProject version (i.e. the help file title, e-mail address, copyright information, etc.). Such items are not imported so review the project properties and set the equivalent items accordingly.

    If you do need to create a customized version of a presentation style, simply make a clone of the stock presentation style folder found in the C:\Program Files\Sandcastle\Presentation folder and make your changes to it. Be sure to keep the base presentation style name in the new folder name (Prototype, Hana, or VS2005) as certain build steps change based on the style selected and this gives the help file builder the necessary hint it needs to know what to do. Once you create the folder, restart the help file builder and your new folder will appear in the PresentationStyle project property's dropdown.

  • All other project files will be converted to matching file items with an appropriate build action. However, since the converter cannot determine whether or not some files are actually used, the project may contain some leftovers that can be removed during the review.
  • While it does provide a website output format, the help file builder does not currently have an equivalent that matches all of the functionality from the DocProject DocSite project option.
  • The API filtering methods differs significantly and those settings are not converted. Instead, review the options in the help file builder's Visibility Category Properties. These can be used to exclude groups of items and the API Filter Property can be used for finer control over which items are excluded.

  • Review the Documentation Sources and References project nodes to see that the required items were imported correctly and make any necessary adjustments.

    Tip:

    Given that solutions and projects are supported as documentation sources, you may find it easier to add them as documentation sources instead of the assemblies, comments, and references that they contain. When a solution or project is used, these items are imported from them automatically at build time.

  • Conceptual content topics are imported as-is. However the properties from the related companion files are imported and stored in a content layout file. This file can be edited to arrange the topics in the table of contents and specify their properties such as the title, help index keywords, and additional topic-specific help attributes. The file has a .content extension and the BuildAction is set to ContentLayout to indicate that it should be treated as such in the build.
  • If a media content file is found, its content is imported and the images are added as project items. Their BuildAction is set to Image and the additional properties such as the ID and alternate text are stored in the file item properties.
  • Token files are added to the project and their BuildAction is set to Tokens to indicate that they should be treated as such in the build. The extension on the filename is changed to .tokens.
  • Code snippets files are added to the project and their BuildAction is set to CodeSnippets to indicate that they should be treated as such in the build. The extension on the filename is changed to .snippets.
  • If you were using the standalone custom build components that are distributed at the Sandcastle Help File Builder CodePlex project site, you will need to add them to the project. This is done as follows:
    1. Select the ComponentConfigurations property in the Properties window and click the "..." button to the right of the property.
    2. In the Component Configuration dialog that appears, double click on the components that you want to add to the project.
    3. To configure them, select each component in the right-hand list and click the Configure button.
    Note:

    The help file builder includes the Code Block Component and the Post-Transform Component in every project by default via the template configuration files used during the build. You will only need to add them to your projects if you want to override their default configurations.

  • Not all files can be detected and added to the project (i.e. files referenced in topics such as example code files, etc.). If build errors result from missing files, simply add them to the project or adjust the paths and/or filenames as needed.
  • If you were using the Code Block Component in DocProject, you may need to adjust the path to external source files in the source attribute on the <code> elements.

See Also

Other Resources

Project File Converters
Sandcastle Help File Builder Overview


SandcastleGUI 1.x Converter

[image]

Sandcastle Help File Builder Documentation
SandcastleGUI 1.x Converter
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to convert project files created with Steven Smetsers' SandcastleGUI tool to the help file builder project file format.

Post-Conversion Review

Most SandcastleGUI project properties have equivalents in the help file builder and are converted to the matching property and value. The information converted from the following old project properties may need attention after conversion:

  • AssemblyDir - The specified folder is added as a wildcard documentation source which may not be appropriate. If necessary, change it to include only the required assemblies and XML comments files or split it into individual entries in the Documentation Sources project node. Add all dependency assemblies to the References project node so that they are not documented.

    Tip:

    Given that solutions and projects are supported as documentation sources, you may find it easier to add them as documentation sources instead of the assemblies, comments, and references that they contain. When a solution or project is used, these items are imported from them automatically at build time.

  • Logo - This controls the logo that appears in the topic headers. The image will be added to the project file but will not be set as the logo. In order to do this, follow these steps:

    1. Select the ComponentConfigurations property in the Properties window and click the "..." button to the right of the property.
    2. In the Component Configuration dialog that appears, double click on the Post-transform Component in the list on the left to add it to the project.
    3. Select the component in the right-hand list and click the Configure button.
    4. In the configuration dialog, click on the Logo File tab and set the logo properties. See the Post-Transform Component topic for information on the configuration settings.
    Note:

    The converter places the logo file in the root folder of the project. The build component copies the logo file to the .\Images folder in the compiled help file at build time. Since it is not considered content (something that other non-API topic HTML pages will use), the converter sets the BuildAction on the logo file to None.

  • DocDir - All files and subfolders in the indicated folder are added to the project recursively as file items with default build actions based on the file extensions. You can add a site map to the project and edit it to set the order and layout of the additional content items.

    Tip:

    The help file builder contains full support for conceptual content that uses Microsoft Assistance Markup Language (MAML) to create additional non-API topics such as How-Tos, walkthroughs, etc. You may want to consider switching any additional HTML content to conceptual content to take advantage of its features. See the Conceptual Content topic for more information.

The following project properties are not converted:

  • OutputDir - The output directory is left at its default for the help file builder (a .\Help subfolder beneath the project folder). You can specify a different location if needed.
  • Namespaces - By default, all namespaces and members will be documented. To adjust which items are not documented, you can use the Visibility Category Properties to exclude groups of items and/or the API Filter Property for finer control over which items are excluded.

  • CodeHighlighting - By default, the custom code block component is included in all builds to colorize code based on the language. To alter its settings, do the following:

    1. Select the ComponentConfigurations property in the Properties window and click the "..." button to the right of the property.
    2. In the Component Configuration dialog that appears, double click on the Code Block Component in the list on the left to add it to the project to allow overriding the defaults.
    3. Select the component in the right-hand list and click the Configure button.
    4. In the configuration dialog, alter the settings as needed. If the default settings are to your liking, you can remove the component and the default instance will be used.
    Note:

    The Code Block Component offers a significant number of options beyond what was available in SandcastleGUI including the ability to colorize many other languages, add line numbering and collapsible regions, and to import code from working source code files. See the Code Block Component documentation for more information on what you can do with it.

  • TOC - There are some project properties and plug-ins that can be used to customize the table of contents in various ways. See the documentation for the RootNamespaceContainer and RootNamespaceTitle properties as well as the Hierarchical Table of Contents Plug-In and the Table of Contents Exclusion Plug-In.

See Also

Other Resources

Project File Converters
Sandcastle Help File Builder Overview


Sandcastle Example GUI Converter

[image]

Sandcastle Help File Builder Documentation
Sandcastle Example GUI Converter
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to convert MSBuild project files created using the example GUI supplied with Sandcastle to the help file builder project file format.

Post-Conversion Review

The example GUI project files are quite simple and only contain a few options that convert straight across to the equivalent help file builder project properties. After conversion, review the Documentation Sources and References project nodes to see that the required items were imported correctly and make any necessary adjustments.

Tip:

Given that solutions and projects are supported as documentation sources, you may find it easier to add them as documentation sources instead of the assemblies, comments, and references that they contain. When a solution or project is used, these items are imported from them automatically at build time.

See Also

Other Resources

Project File Converters
Sandcastle Help File Builder Overview


Relative and Absolute Paths

[image]

Sandcastle Help File Builder Documentation
Relative and Absolute Paths
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

With a few exceptions, all file and folder path properties in the project options allow you to specify either a relative or an absolute path. All paths default to relative when first entered. This allows you to move the project folder and the paths in the properties will be still be correct when the project is opened again.

You can change this behavior for a particular property by expanding it by clicking the "+" to the left of the property name and setting the IsFixedPath sub-property to true. The path is then displayed as an absolute path and will be saved as such in the project.

In addition, environment variables such as %DXROOT%, %WINDIR%, etc. can be specified in the paths and they will be expanded at build time to the value of the specified environment variable. The path's ExpandedPath sub-property will show you the expanded form based on the current system's settings. The MSBuild-format for environment variables is also supported ($(DXROOT), $(WINDIR), etc.).

The key point to remember is that help file builder projects built either from the standalone GUI or from the command line always expect that relative paths are relative to either the folder in which the project file is located or to the working folder used for the build. The expected relative location is noted in the description of each affected property. A typical folder layout is shown below:

Copy
C:\HelpTest\        Solution folder.
  |
  +-TestAssembly    Application project folder.
  | |
  | +-Bin
  |   |
  |   +-Release     Location of assembly and comment files.
  |
  +-Doc             Help file builder project location.
    |
    + Content       Other optional content folders (i.e. conceptual topics)
    |
    +-Help          The output folder for the help file.
      |
      +-Working     The intermediate working folder used
        |           during the build.
        |
        +-Output    Help file project compilation folder.
          +-html
          +-images
          +-media
          +-scripts
          +-styles

The example above places the help file builder project in the C:\HelpTest\Doc\ folder. As such, the relative path to the assembly that will be documented and its comment file is ..\TestAssembly\Bin\Release\. The default output folder for a project is always .\Help\. If you would prefer the help file to end up in a different location, you can modify it using the OutputPath property.

Caution:

Be aware that if an option is selected that produces a website, the output folder specified by the OutputPath property will be cleared of all of its current content without any prompting before the web site content is copied to it. In other words, don't do something stupid like set it to the root of your C: drive or your desktop folder. The help file builder will check for common special folders to prevent this from happening but always be sure to confirm the folder name that you enter. When producing a Help 1 (CHM) and/or Help 2 (HxS) file without the website output format, the output folder is not cleared.

A similar warning applies to the WorkingPath property. Its content is always cleared unconditionally prior to a build regardless of the help file format selected.

See Also

Other Resources

Getting Started
Sandcastle Help File Builder Overview


The Log File

[image]

Sandcastle Help File Builder Documentation
The Log File
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Each build produces a log file. By default, the log file is called LastBuild.log and can be found in the output folder. You can modify the BuildLogFile project property to rename it and/or store it in a different location. The log will always be present unless the project's KeepLogFile property is set to false and the build succeeds. The log file content is in XML format. This allows you to run it through an XSL transformation to make it more readable, highlight warnings and errors, etc. A default transformation is supplied and can be found under the main help file builder installation folder (.\Templates\TransformBuildLog.xsl).

The Log File Elements

The log file content consists of the following XML elements:

Element | Description
shfbBuild This is the root element that contains all of the build step output. It has four attributes:
  • The product attribute identifies the tool that produced the log (the help file builder utilities assembly).
  • The version attribute identifies the build engine version.
  • The projectFile attribute identifies the project file that was built.
  • The started attribute contains the date and time that the build was started.
buildStep | This element contains the output for an individual build step. The build step is identified in the step attribute and corresponds to an enumeration value from SandcastleBuilder.Utils.BuildEngine..::.BuildStep.
plugIn | This element contains the output from a plug-in that runs inside of a build step. This element will always be nested within a buildStep element and there may be more than one depending on how many plug-ins ran during the given step. The plug-in that ran is identified by the name attribute. The execution behavior of the plug-in is identified by the behavior attribute.

See Also

Other Resources

Getting Started
Building Projects Outside the GUI
Generating Documentation with Team Build


User Preferences

[image]

Sandcastle Help File Builder Documentation
User Preferences
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The User Preferences option on the File menu allows you to set some common non-project application settings. The dialog box contains two tabs. The first is for general preferences and the second is for defining custom content editors for project files.

General Preferences

The general preferences are as follows:

  • HTML Help 2.x Viewer Path - This allows you to specify the path to an external application that can be used to view HTML Help 2.x (.HxS) files. If you need one, see the Installation Instructions for the download location of the H2 Viewer.
  • ASP.NET Development Web Server Port - This allows you to specify the port number to use when starting the built-in .NET 2.0 development web server to view website output using the Index.aspx page. By default, it is set to port 12345. You can alter this if it conflicts with something on your system.
  • Before Building - This lets you specify whether or not the help file builder should save the project and/or modified document windows prior to performing a build or previewing a topic. The options are:
    • Save all changes - Save the project and any modified document editors.
    • Save changes to open documents only - Only open, modified document editors are saved. Changes to the project file are not saved.
    • Prompt to save all changes - You will be asked to save all changes. If documents are not saved, the resulting help file may not contain current information.
    • Don't save any changes - Nothing is saved. The resulting help file may not contain current information if there are unsaved documents.
    Note:

    When opening the topic preview window, the previewed document is always saved regardless of this setting so that it shows current information.

  • Build window verbose logging enabled - This allows you to specify whether or not full logging information is displayed in the output window during a build. It is checked by default. If unchecked, only build step messages are reported during the build. All messages are still written to the log file. This is useful for very large projects where the generated output can consume large quantities of memory.
  • Open help file after successful build - If enabled, the help file will be opened after a successful build. The format opened will depend on the format chosen in the HelpFileFormat project property. Preference is given to Help 1, then Help 2, and finally website output. This option can also be toggled on and off via the Documentation | View Help File menu.
  • Build Output Background/Foreground/Font - These options let you specify the background color, foreground color, and font used in the output window for the build output (the text shown during the build).
  • Text Editor Font - This option lets you set the font used in the text editor windows. The syntax highlighter controls the colors and they are not editable.

Content File Editors

This tab allows you to define custom editors for project files that are not recognized by the standalone GUI as being editable text files based on their filename extension. In such cases, the GUI will look for a custom editor definition and, if found, will launch the associated application. If no custom editor definition is found, the GUI attempts to launch the file using the shell to let it decide how the file should be edited.

To add a new content file editor, click the Add button located next to the upper right corner of the editor list. Select the new entry in the list and use the property grid at the bottom of the tab to alter its settings.

  • Description - Enter a description for the editor.
  • Extensions - Enter a list of filename extensions with which this editor will be associated. If specifying multiple extensions, separate them with a space, semi-colon, period, or a comma.
  • ApplicationPath - Enter the path to the editor application. As with other project properties, this can be an absolute or a relative path and can contain environment variable references for expansion when actually invoked.

  • Arguments - Specify any necessary command line arguments. At the minimum, the $ContentItem macro should be specified so that the file to edit is passed to the application. Enclose arguments in quote marks if the value will contain spaces. Macros that you can use are as follows:

    • $ContentItem - This expands to the full path and filename of the item to be edited.
    • $ProjectFile - This expands to the full path and filename of the current project.
    • $ProjectFolder - This expands to the full path of the current project without the filename.

    Macro names are case-insensitive.

  • StartupFolder - An optional folder name in which the application is started. If left blank, the current project's folder is used. As with the application path, this can be an absolute or relative path and can contain environment variable references for expansion when actually invoked.

To delete an editor definition, select it in the list and click the Delete button located next to the bottom right corner of the editor list.

See Also

Other Resources

Getting Started
Sandcastle Help File Builder Overview


Special Folder Locations

[image]

Sandcastle Help File Builder Documentation
Special Folder Locations
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The help file builder has the ability to utilize third-party custom build components and plug-ins. In addition, the project system allows you to add files based on user-defined template files. Build components and plug-ins can also create configuration or cache files to use across builds if needed. In order to work correctly, each type of file must be located in the correct place.

  • Root Application Data Folders
  • Third-Party Build Components
  • Third-Party Build Process Plug-Ins
  • User Configuration Settings and Cache Files
  • User-Defined File Templates
Note:

None of the folders mentioned below exist by default so you will need to create them yourself. The exception is the root local application data folder. It will be created on first use by the help file builder if referenced by a build component or a plug-in configuration.

Root Application Data Folders

There are two root application data folders (Common Application Data and Local Application Data). These equate to one of the following folders based on your operating system:

Operating System | Folder Location
Vista | Common Application Data: %ProgramData%\EWSoftware\Sandcastle Help File Builder Local Application Data: %LOCALAPPDATA%\EWSoftware\Sandcastle Help File Builder
Windows XP | Common Application Data: %ALLUSERSPROFILE%\Application Data\EWSoftware\Sandcastle Help File Builder Local Application Data Folder: %USERPROFILE%\Local Settings\Application Data\EWSoftware\Sandcastle Help File Builder
Tip:

The {@AppDataFolder} substitution tag will resolve to the root common application data folder for the help file builder. The {@LocalDataFolder} substitution tag will resolve to the root local application data folder for the help file builder.

Third-Party Build Components

Third-party build components that you want to use from within the help file builder via the ComponentConfigurations project property must be placed in the Common Application Data folder. This equates to one of the following folders based on your operating system:

Operating System | Folder Location
Vista | %ProgramData%\EWSoftware\Sandcastle Help File Builder\Build Components
Windows XP | %ALLUSERSPROFILE%\Application Data\EWSoftware\Sandcastle Help File Builder\Build Components

Put the build components and any of their required configuration and supporting files within the noted folder or a subfolder beneath it. These will be shared by all users on the same computer.

Third-Party Build Process Plug-Ins

Third-party build process plug-ins that you want to use from within the help file builder via the PlugInConfigurations project property must be placed in the Common Application Data folder. This equates to one of the following folders based on your operating system:

Operating System | Folder Location
Vista | %ProgramData%\EWSoftware\Sandcastle Help File Builder\Plug-Ins
Windows XP | %ALLUSERSPROFILE%\Application Data\EWSoftware\Sandcastle Help File Builder\Plug-Ins

Put the plug-ins and any of their required configuration and supporting files within the noted folder or a subfolder beneath it. These will be shared by all users on the same computer.

User Configuration Settings and Cache Files

Due to various folder/file permission issues and in order to allow multiple users on the same computer to have their own custom settings and cache files used by build components and plug-ins, these types of files must be stored in the Local Application Data folder (see the Root Application Data Folders section above).

As an example, the cached build components supplied with the help file builder create their cache files in the following location based on the operating system:

Operating System | Folder Location
Vista | %LOCALAPPDATA%\EWSoftware\Sandcastle Help File Builder\Cache
Windows XP | %USERPROFILE%\Local Settings\Application Data\EWSoftware\Sandcastle Help File Builder\Cache

Each user is free to delete such files to get back to a default state without affecting other users on the same computer. Likewise, they can give copies of their settings files to other users for them to place in a like named folder in their settings area to make use of them as well.

User-Defined File Templates

Due to various folder/file permission issues and in order to allow multiple users on the same computer to have their own custom file templates, these types of files must be stored in the Local Application Data folder. This equates to one of the following folders based on your operating system:

Operating System | Folder Location
Vista | %LOCALAPPDATA%\EWSoftware\Sandcastle Help File Builder\Item Templates %LOCALAPPDATA%\EWSoftware\Sandcastle Help File Builder\Conceptual Templates
Windows XP | %USERPROFILE%\Local Settings\Application Data\EWSoftware\Sandcastle Help File Builder\Item Templates %USERPROFILE%\Local Settings\Application Data\EWSoftware\Sandcastle Help File Builder\Conceptual Templates

Use the Item Templates folder to store custom templates for project files such as images, HTML files, stylesheets, script files, tokens, code snippets, or XML files. Use the Conceptual Templates folder to store custom MAML topic template files. These template files appear on the Custom Templates submenus within the project explorer, site map editor, and content layout file editor.

Each user is free to delete such files to get back to a default state without affecting other users on the same computer. Likewise, they can give copies of their template files to other users for them to place in the templates folder in their settings area to make use of them as well.

See Also

Other Resources

Getting Started
Conceptual Content
Build Process Plug-Ins
Custom Build Components


Using the <inheritdoc /> Tag

[image]

Sandcastle Help File Builder Documentation
Using the <inheritdoc /> Tag
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The use of the <inheritdoc /> custom XML comments tag can help minimize the effort required to document complex APIs by allowing common documentation to be inherited from base types/members.

  • Usage and Syntax
  • Root Level Inheritance Rules
  • Nested Inheritance Rules
  • Additional Comment File Sources and IntelliSense
  • Examples
  • See Also

Usage and Syntax

The use of the tag by itself on a member is enough to satisfy the compiler so that it will not issue warnings about missing comments on public members. Using it in conjunction with other tags allows you to inherit common information such as value and parameter descriptions while overriding the inherited documentation for other tags such as <summary> and <remarks>. Documentation can be inherited from any member from classes within your own assemblies or from members of other assemblies as well as the base .NET Framework class library. The syntax of the tag is as follows:

CopyTag Syntax
<inheritdoc [cref="link-ref"] [select="filter-expr"] />
cref="link-ref"
This optional attribute overrides the standard search method to allow documentation inheritance from an alternate user-specified member indicated by the link-ref value.
select="filter-expr"
This optional attribute applies a specified XPath filter expression to the inherited comments. This is useful if you want to limit the inherited documentation to a specific subset of tags or just select a particular instance or set of comments. The expression can be any valid XPath query that will result in a node set.

By making use of the cref and select attributes either by themselves or together, you can fine tune the inheritance of documentation. You can also nest the tag within other tags to further refine the level of inheritance.

Root Level Inheritance Rules

The <inheritdoc /> tag is valid at the root level (i.e. the same level as <summary> tags) on types, interfaces, virtual members, interface member implementations, and constructors. Its use on any other member type will result in no comments being inherited unless a cref attribute is specified. Note that the tag is also valid in project summary and namespace summary comments as long as a cref attribute is specified to indicate from where to inherit the comments. When specified at the root level in a set of XML comments, the documentation search is performed as follows:

  • If an explicit cref attribute is specified, the documentation from the specified namespace/type/member is inherited. If a cref attribute is not specified, the following rules apply.

  • For types and interfaces:

    • Inherit documentation from all base classes working backwards up the inheritance chain.
    • Inherit documentation from all interface implementations (if any) working through them in the order listed in the reflection information file (usually alphabetically).

  • For constructors:

    • Search backwards up the type inheritance chain for a constructor with a matching signature.
    • If a match is found, its documentation is inherited.

  • For virtual members and interface implementations:

    • If the member is an override, documentation is inherited from the member it overrides.
    • If the member is part of an interface, documentation is inherited from the interface member being implemented.
  • Explicit interface implementations will automatically inherit documentation from the interface member that they implement if no documentation is supplied by the user. This is done automatically because these members are by definition private and the compiler will not issue a warning if the user does not supply documentation. As such, you can omit the <inheritdoc /> tag from them unless you want to customize the comments.
  • With or without an explicit cref attribute, if the inherited documentation itself contains <inheritdoc /> tags, they will be expanded recursively working backwards up the inheritance chain.
  • In all cases, if a select attribute is present, it is used to filter the inherited comments based on the specified XPath query.

When inheriting documentation at the root level, if the following tags already exist in the member's comments, the inherited versions are ignored:

  • <example>
  • <exclude>
  • <filterpriority>
  • <preliminary>
  • <summary>
  • <remarks>
  • <returns>
  • <threadsafety>
  • <value>

The <overloads> tag will never be inherited. This prevents the doubling of comments on the overloads page. However, you can inherit the contents of the <overloads> tag using a select attribute with a value of "overloads/*". See below for an example.

All other tags will be inherited unless they match a tag by the same name that contains a cref, href, name, vref, or xref attribute with an identical value in the member's comments. To merge comments in one of the above tags from one or more sources, use one or more nested <inheritdoc /> tags within the given tag. See below for examples.

Be aware that when <param> tags are inherited, the parameter's name in your class's member must match the base member's parameter name. If they do not match, you will not see any inherited documentation for the parameter. Also, if you supply comments for one parameter but omit comments for other parameters in order to inherit their documentation from a base implementation, the compiler will issue a warning. In this case, you can use a #pragma warning directive to disable the warning temporarily or add it to the project settings to disable the warning globally. See below for an example.

Nested Inheritance Rules

The <inheritdoc /> tag can also be nested within other XML comments tags such as <summary>, <remarks>, <example> etc. in order to inherit specific parts of the documentation within those tags. When nested, the same root level inheritance rules apply and will be used to locate the first member with comments from which to inherit documentation. In addition, a filter will be automatically included based on the parent tag or tags within which the <inheritdoc /> tag is nested. The cref and select attributes can also be applied to further qualify how the documentation is inherited. If you do not want to have the parent tags automatically included in the filter, you must supply a select attribute with a rooted XPath query that specifies from where to obtain the comments (i.e. select="/summary/node()").

Additional Comment File Sources and IntelliSense

Additional sources of inherited documentation (i.e. comments from third party class libraries) can be added to the Documentation Sources project node. This allows you to inherit documentation from base class libraries without having to add them as documentated assemblies in your project.

Since the XML comments produced by the compiler are incomplete, it is recommended that you make use of the IntelliSense Component to produce an IntelliSense XML comments file. It will include the fully expanded set of inherited documentation so that Visual Studio can provide useful and accurate API help in the code editor and object browser.

Examples

The following show various examples of using the <inheritdoc /> tag. See the comments within each for details about what the examples are showing.

CopyConstructor Documentation Inheritance
/// <summary>
/// This exception class is thrown by the application if it encounters an
/// unrecoverable error.
/// </summary>
[Serializable]
public class CustomException : Exception
{
    //=====================================================================
    // Methods

    /// <summary>
    /// Default constructor.
    /// </summary>
    /// <overloads>There are four overloads for the constructor</overloads>
    public CustomException()
    {
    }

    /// <inheritdoc />
    public CustomException(string message) : base(message)
    {
        // Inherit documentation from the base Exception class matching
        // this constructor's signature.
    }

    /// <inheritdoc />
    public CustomException(string message, Exception innerException) :
      base(message, innerException)
    {
        // Inherit documentation from the base Exception class matching
        // this constructor's signature.
    }

    /// <inheritdoc />
    protected CustomException(SerializationInfo info,
      StreamingContext context) : base(info, context)
    {
        // Inherit documentation from the base Exception class matching
        // this constructor's signature.
    }
}
CopyInterface Implementation Examples
/// <summary>
/// A class with an explicit interface implementation
/// </summary>
/// <remarks>Note that you must enable the <b>DocumentPrivates</b> and
/// <b>DocumentExplicitInterfaceImplementations</b> SHFB project options
/// in order to see the explicitly implemented members.</remarks>
public class ExplicitImplementation : ICollection, ICloneable, IEnumerable
{
+ICollection Members-    #region ICollection Members

     void ICollection.CopyTo(Array array, int index)
     {
         // Comments are automatically inherited for explicit
         // interface members with no comments.
     }

     int ICollection.Count
     {
         get
         {
             // Comments are automatically inherited for explicit
             // interface members with no comments.
             return 0;
         }
     }

     bool ICollection.IsSynchronized
     {
         get
         {
             // Comments are automatically inherited for explicit
             // interface members with no comments.
             return true;

         }
     }

     /// <inheritdoc />
     /// <remarks>This is a dummy class and always returns null.</remarks>
     object ICollection.SyncRoot
     {
         get
         {
             // In this case, we inherit the <summary> and <returns>
             // comments and add a <remarks> comment.  Because we added
             // comments, we need to specify the <inheritdoc /> tag too.
             return null;
         }
     }

     #endregion

+IEnumerable Members-    #region IEnumerable Members

     /// <inheritdoc />
     /// <returns>This is a dummy class so it throws an exception</returns>
     IEnumerator IEnumerable.GetEnumerator()
     {
         // In this case, we automatically inherit the base interface's
         // <summary> but override the <returns> documentation.  As above,
         // because we specified comments, we have to add the <inheritdoc />
         // tag too.
         throw new Exception("The method or operation is not implemented.");
     }

     #endregion

+ICloneable Members-    #region ICloneable Members

     /// <inheritdoc />
     public object Clone()
     {
         // Not explicitly implemented so we have to tell it to inherit
         // documentation on this one.
         return null;
     }

     #endregion
}
CopyVarious Other Examples
+Base class-#region Base class
 //=========================================================================

 /// <summary>
 /// A base class from which to inherit documentation
 /// </summary>
 /// <remarks>
 /// <para>These remarks are for the base class.</para>
 ///
 /// <para>This information applies to all classes that derive from
 /// <see cref="BaseInheritDoc"/>:
 /// <list type="bullet">
 /// <item><description>Point #1.</description></item>
 /// <item><description>Point #2.</description></item>
 /// <item><description>Point #3.</description></item>
 /// </list>
 /// </para>
 /// </remarks>
 public class BaseInheritDoc
 {
     /// <summary>
     /// Constructor
     /// </summary>
     public BaseInheritDoc()
     {
     }

     /// <summary>
     /// The ToString implementation for BaseInheritDoc
     /// </summary>
     /// <returns>A string representing the object</returns>
     public override string ToString()
     {
         return base.ToString();
     }

     /// <summary>
     /// Summary for the method with an example
     /// </summary>
     /// <returns>True all the time</returns>
     /// <example>
     /// This example is from the base class
     /// <code>
     /// // 'x' is always true
     /// bool x = instance.MethodWithExample();
     /// </code>
     /// </example>
     public virtual bool MethodWithExample()
     {
         return true;
     }

     /// <summary>
     /// The method in the base class has lots of comments.
     /// </summary>
     /// <remarks>Remarks for the base class</remarks>
     /// <param name="x">The parameter</param>
     /// <exception cref="ArgumentException">Thrown if x is zero</exception>
     /// <exception cref="ArgumentOutOfRangeException">Thrown if x is
     /// less than zero.</exception>
     /// <example>
     /// <code>
     /// /// Example goes here
     /// </code>
     /// </example>
     /// <seealso cref="ToString" />
     /// <seealso cref="MethodWithExample"/>
     public virtual void MethodWithLotsOfComments(int x)
     {
     }

     /// <summary>
     /// A method with two examples
     /// </summary>
     /// <example>
     /// <span id="Example 1">
     /// This is example #1:
     /// <code>
     /// // Example #1
     /// </code>
     /// </span>
     /// <span id="Example 2">
     /// This is example #2:
     /// <code>
     /// // Example #2
     /// </code>
     /// </span>
     /// </example>
     protected virtual void MethodWithTwoExamples()
     {
         // By using a <span> with an ID, we can group comments for
         // selection by an override in a derived class.
     }
 }
 #endregion

+Derived class-#region Derived class
 //=========================================================================

 /// <summary>
 /// This is a derived class with inherited documentation.
 /// </summary>
 /// <remarks>This will inherit just the last &lt;para&gt; tag from
 /// the base class's &lt;remarks&gt; tag:
 /// <inheritdoc select="para[last()]" />
 /// </remarks>
 public class DerivedClassWithInheritedDocs : BaseInheritDoc
 {
     // Note in the <remarks> tag above that we can inherit specific
     // parts of a comment tag's text by using an XPath query.  This
     // can allow you to merge comments from various sources into one
     // set of comments in a given tag.  An implied filter that limits
     // the selection to the <remarks> tag is added automatically.  If
     // the select attribute were omitted, the entire set of remarks
     // from the base class would be inherited.

     /// <inheritdoc cref="Object.ToString" />
     public override string ToString()
     {
         // This override ignores the base class comments and uses a
         // cref attribute to obtain the comments from
         // System.Object.ToString instead.
         return base.ToString();
     }

     /// <summary>
     /// This overloaded method does something
     /// </summary>
     /// <param name="p1">The string parameter</param>
     /// <overloads>
     /// <summary>There are two overloads for this method.</summary>
     /// <remarks>These remarks are from the overloads tag on the
     /// first version.</remarks>
     /// </overloads>
     public void OverloadedMethod(string p1)
     {
     }

     #pragma warning disable 1573
     /// <inheritdoc cref="OverloadedMethod(string)" />
     /// <param name="p2">The second string parameter</param>
     public void OverloadedMethod(string p1, string p2)
     {
         // Inherit documentation from the first overload and add
         // comments for the second parameter.

         // Note that because we supplied comments for one parameter
         // but not the other, the compiler will complain.  However,
         // we can shut it up by using a "#pragma warning" directive as
         // shown.
     }

     /// <inheritdoc cref="OverloadedMethod(string)"
     ///     select="param|overloads/*" />
     /// <param name="x">An integer parametr</param>
     public void OverloadedMethod(string p1, int x)
     {
         // This example inherits the comments from the <param> tag on
         // the first version, the content of the <overloads> tag on the
         // first version, and adds comments for the second parameter.
     }
     #pragma warning restore 1573

     /// <summary>
     /// An override of the method with an example
     /// </summary>
     /// <returns>Always returns false</returns>
     /// <example>
     /// <inheritdoc />
     /// <p/>This example applies to the derived class:
     /// <code>
     /// if(derivedInstance.MethodWithExample())
     ///     Console.WriteLine("This is never reached");
     /// </code>
     /// </example>
     public override bool MethodWithExample()
     {
         // The <example> tag inherits the example from the base class
         // and adds a new example of its own.  Again, an implied filter
         // limits the nested tag to inheriting comments from the
         // <example> tag in the base class's comments.

         return false;
     }

     /// <inheritdoc select="summary|remarks|param" />
     public override void MethodWithLotsOfComments(int x)
     {
         // For this override, we don't want all the comments, just those
         // from the <summary>, <remarks>, and <param> tags.
     }

     /// <summary>
     /// This only includes one of the examples
     /// </summary>
     /// <example>
     /// <inheritdoc select="span[@id='Example 2']" />
     /// </example>
     protected override void MethodWithTwoExamples()
     {
         // Here, we use a filter to select a group of comments in
         // a <span> tag from the base member's <example> tag.
     }

     /// <summary>
     /// This uses a shared example from a base member that is not
     /// public and this doesn't override.
     /// </summary>
     /// <example>
     /// <inheritdoc cref="MethodWithTwoExamples"
     ///     select="span[@id='Example 2']" />
     /// </example>
     public void MethodUsingSharedExample()
     {
         // This method uses a cref attribute and a select tag to inherit
         // a specific example from a member to which it has no relation.
     }
 }
 #endregion

See Also

Other Resources

Walkthrough: Enabling and Using XML Comments


Documenting Web Projects

[image]

Sandcastle Help File Builder Documentation
Documenting Web Projects
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This topic contains the following sections.

  • Documenting Web Application and Web Service Application Projects
  • Documenting Website and Web Service Website Projects
  • Automating the Process
  • Usage Notes and Known Issues
  • How The Code Providers Work
  • Conclusion
  • See Also

A question that comes up with some regularity is how to produce a help file from the XML comments in the code for a web project using Sandcastle. There are two types of web project: a web application project and a website project (both include a web service and an AJAX-enabled variant of the project type). A web application project is the simplest to document as it generates a single assembly with a fixed name much like any other non-web project. A website project, however, requires some extra effort to document and has a number of limitations:

  • It does not necessarily generate a single assembly.
  • It only generates assemblies when you actually publish the project.
  • The assembly names may vary from build to build depending on the options you use when publishing the website.
  • There is no project-level option to produce XML comments files. Instead, you have to add a section to the Web.config file to produce them.
  • Even after adding the option to produce XML comments files, there are limitations:
    • If you specify a single comments filename, only the comments from the last assembly compiled will be saved. The VB.NET compiler has a /doc+ option to work around this issue. However, the C# compiler does not so this makes it impossible to fully document a C# website project.
    • The comments files produced using the VB.NET /doc+ option are not placed in the folder to which the project was published. Instead, they are left in the system's temporary ASP.NET folder for the related .NET version (i.e. C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET files so you must locate and retrieve them after each build.

To work around the limitations present when documenting website projects, you can use the custom code providers available at the Sandcastle Styles project website (one for C# and one for VB.NET). By using these code providers, you can specify a folder to which the XML comments files should be copied. This saves you from having to locate and copy them manually and solves the issue of the C# compiler not being able to output one comments file per assembly. Below are instructions for documenting each type of web project and information about how the code providers work.

Documenting Web Application and Web Service Application Projects

As noted, web applications are the easiest to document and do not require the use of the custom code providers. These projects are created in Visual Studio by selecting File | New | Project and then selecting ASP.NET Web Application or ASP.NET Web Service Application from the Web category of your preferred language. Note that these options are only available in Visual Studio 2005 after you install Service Pack 1.

You must enable the XML comments option in your application projects so that an XML comments file is produced when the projects are built. This is done as follows:

  1. In the Solution Explorer, right click on the project and select Properties.
  2. Select the Build property page (C#) or the Compile property page (VB.NET).
  3. The XML comments filename is a per configuration option. As such, you can either select the All Configurations option at the top of the page to set the XML comments options for all configurations at the same time or select each configuration individually and repeat the next step for each one.
  4. For C#, in the Output section, check the checkbox next to the XML documentation file text box and specify a name for the XML comments file. Although not required, a common convention is to name the XML comments file after the related assembly except with a .xml extension. The assembly name can be found on the Application property page.

    For VB.NET, just check the Generate XML documentation file checkbox. It names the file after the assembly automatically.

  5. If you have a solution with multiple web application or web service application projects that need to be documented, repeat the above steps for each project in the solution. If using the Sandcastle Help File Builder, be sure to give each project's XML comments file a unique name as they are copied to a common location for the build. Identically named files would overwrite each other and the documentation in the overwritten files would not appear in the help file.

Once the above has been done, Visual Studio will create the XML comments file each time the project is built. It is placed in the .\bin folder along with the assembly. These can be used in conjunction with your preferred documentation tool to produce a help file.

Documenting Website and Web Service Website Projects

These projects are created in Visual Studio by selecting File | New | Web Site and then selecting ASP.NET Web Site or ASP.NET Web Service from the template dialog box. In order to create XML comments files, you must add the custom code providers to the Web.config file and publish the website. This is done as follows:

  1. If your project does not yet contain one, add a Web.config configuration file.
  2. Add the following <system.codedom> section to the <configuration> section as shown in the example below. You only need to add the <compiler> element for the language that you are using but it will not hurt anything if they are both present.
    CopyExample Code Provider Configurations
    <configuration>
  <system.codedom>
    <compilers>
      <!-- For C# -->
      <compiler language="c#;cs;csharp" extension=".cs"
        compilerOptions="/docpath:C:\Publish\Docs"
        type="EWSoftware.CodeDom.CSharpCodeProviderWithDocs,
              EWSoftware.CodeDom, Version=1.1.0.0, Culture=neutral,
              PublicKeyToken=d633d7d5b41cbb65">
        <!-- NOTE: Change value to "v3.5" for .NET 3.5 projects -->
        <providerOption name="CompilerVersion" value="v2.0"/>
      </compiler>

      <!-- For VB.NET -->
      <compiler language="vb;vbs;visualbasic;vbscript" extension=".vb"
        compilerOptions="/docpath:C:\Publish\Docs"
        type="EWSoftware.CodeDom.VBCodeProviderWithDocs,
              EWSoftware.CodeDom, Version=1.1.0.0, Culture=neutral,
              PublicKeyToken=d633d7d5b41cbb65">
        <!-- NOTE: Change value to "v3.5" for .NET 3.5 projects -->
        <providerOption name="CompilerVersion" value="v2.0"/>
      </compiler>
    </compilers>
  </system.codedom>
</configuration>

    Instead of a /doc option, the custom code providers use a custom /docpath option in the compilerOptions attribute that specifies the fully qualified folder name into which the XML comments files are placed. The folder will be created by the code provider if it does not exist. Any other compiler options that you might need can also be specified in the attribute value separated by a space.

  3. In order to use the code providers, the ASP.NET compiler must be able to find them. You can either copy the EWSoftware.CodeCom.dll assembly into your project's .\bin folder or you can register it in the Global Assembly Cache (GAC) so that it is available to any project. To do so, use the gacutil command line tool as follows replacing the path to the assembly to match the installed location on your system:
    Copy
    gacutil -i \DotNet\Web\WebCodeProviders\Bin\Release\EWSoftware.CodeDom.dll

    To remove the assembly from the Global Assembly Cache, use the gacutil command line tool as follows:

    Copy
    gacutil -u EWSoftware.CodeDom

    You can find a copy of the tool in the Visual Studio installation folder in the .\SDK\v2.0\bin subfolder.

Once the above has been done, you can publish your website. Right click on the project in the Solution Explorer, select Publish Web Site, set the options, and click OK to publish it. When finished, look in the location you specified in the /docpath option and you will find one XML comments file for each assembly that was built for your website. These can be used in conjunction with the assemblies and your preferred documentation tool to produce a help file.

As an alternative to publishing the website, you can use a web deployment project. Add-ins are available at the following locations:

  • Visual Studio 2005 Web Deployment Add-In
  • Visual Studio 2008 Web Deployment Add-In

The Sandcastle Help File Builder version 1.8.0.0 and later supports wildcard documentation sources. As such, just add one entry with the path set to [appPath]\bin\App_*.dll where [appPath] is the path to the published website and another entry with the path set to [docPath]\App_*.xml where [docPath] is the path to the XML comments files.

Since the code providers are not needed after the website is published, you can delete the system.codedom section from the published Web.Config file and delete the assembly from the .\bin folder if you added it to the project for publishing.

Automating the Process

Using the aspnet_compiler tool, it is possible to automate the publishing of a website project. The tool is located in the .NET Framework folder. For .NET 2.0 through 3.5, this is usually C:\Windows\Microsoft.NET\Framework\v2.0.50727. To run it, issue a command similar to the following (lines wrapped for display purposes):

Copy
C:\Windows\Microsoft.NET\Framework\v2.0.50727\aspnet_compiler
    -f -v /MyWebSite
    -p C:\Path\To\MyWebsite C:\Publish\MyWebSite

The -f option tells it to delete any existing content in the target folder (C:\Publish\MyWebsite in the example above). The -v [path] option tells it the virtual path of the website to compile (i.e. the path you use to load it in the web browser). The -p [path] option tells it the physical location of the website related to the virtual path to compile. Using a script, you could for example publish the website, build the help file, replace the Web.config in the published website with one that has had the system.codedom section removed, and delete the code provider assembly if it was copied locally. This is left as an exercise for the reader. The web deployment add-ins noted above support post-build events so they may provide better support for such tasks.

Usage Notes and Known Issues

The following are some known issues and things to be aware of when using the custom code providers.

  • If any part of the XML comments file path contains spaces, enclose it in &quot; entities (i.e. compilerOptions="/docpath:&quot;C:\My Path With Spaces&quot;").
  • Do not use a relative path in the /docpath option. Always use a fully qualified path. When using the project's publish option, the ASP.NET compiler always runs in the .NET Framework folder so your XML comments files will end up in a location relative to it rather than your project's folder if you do.
  • You can specify any folder except one that is under the location to which you publish the website. The act of publishing the website clears the destination folder and, since the comments files are produced first, you will lose them if you place them under it.
  • The code providers will delete any "App_*.xml" files from the specified folder on the first use. This prevents lots of files from accumulating in the comments file folder that contain duplicate information when not using fixed names. It also means that you should publish each website's comments files to a unique folder so that they are not lost if you are publishing and documenting multiple projects.
  • Unless you are using fixed names when publishing, the assembly and comments filenames will change each time you publish the website. As such, use wildcards (App_*.dll and App_*.xml) to specify the files to use in your preferred documentation tool.
  • When using the VB.NET custom code provider, the commonly imported namespaces such as System and Microsoft.VisualBasic are not included automatically for some unknown reason. The custom code provider will add a /imports command line option automatically for most of the common namespaces to work around the problem. If publishing fails due to undefined types when using the custom code providers, simply add a /imports:[Namespace] option to the compilerOptions attribute where "[Namespace]" is the missing namespace. You can generally identify namespaces that may cause problems by checking Web.Config for <namespace> elements in the <pages> configuration section. See below for a list of the common namespaces added automatically by the VB.NET custom code provider. Another workaround to this issue is to add Imports statements to the code for each of the required namespaces rather than relying on the automatically included references.
  • Related to the item above, when the custom code providers are active in the Web.Config file, you may see lots of errors indicated by the red squiggly underline related to missing types while viewing VB.NET code. During development, you can comment out the custom code providers so that this does not happen. As noted, the other workaround is to add an Imports statement to the code that includes the missing namespace that contains the types.

How The Code Providers Work

The custom code providers are actually quite simple. Both the C# and VB.NET custom code providers are identical with the exception of their base class and an extra set of compiler options passed by the VB.NET version. The C# version is shown below.

CopyExample Code Provider
public class CSharpCodeProviderWithDocs : CSharpCodeProvider
{
    public override CompilerResults CompileAssemblyFromDom(
      CompilerParameters options,
      params CodeCompileUnit[] compilationUnits)
    {
        CodeProviderHelper.ReplaceDocPathOption(options, null);
        return base.CompileAssemblyFromDom(options,
            compilationUnits);
    }

    public override CompilerResults CompileAssemblyFromFile(
      CompilerParameters options, params string[] fileNames)
    {
        CodeProviderHelper.ReplaceDocPathOption(options, null);
        return base.CompileAssemblyFromFile(options, fileNames);
    }

    public override CompilerResults CompileAssemblyFromSource(
      CompilerParameters options, params string[] sources)
    {
        CodeProviderHelper.ReplaceDocPathOption(options, null);
        return base.CompileAssemblyFromSource(options, sources);
    }
}

The derived version simply overrides three key methods and, prior to calling the base implementation, calls the CodeProviderHelper.ReplaceDocPathOption method which takes care of updating the compiler options to produce a unique XML comments file for the assembly in the specified folder. It is shown below.

CopyReplace Doc Path Option Method
internal static void ReplaceDocPathOption(
  CompilerParameters options,
  string[] additionalOptions)
{
    Match m;
    string docPath, docFile;

    // Replace /docpath with /doc
    if(!String.IsNullOrEmpty(options.CompilerOptions))
    {
        m = reDocPathOpt.Match(options.CompilerOptions);

        if(m.Success)
        {
            docPath = m.Groups[1].Value.Replace("\"",
                String.Empty);

            if(!Directory.Exists(docPath))
            {
                Directory.CreateDirectory(docPath);
                docFilesPurged = true;
            }
            else
                if(!docFilesPurged)
                {
                    // Purge the comments files from the folder
                    // on the first call.
                    foreach(string file in Directory.GetFiles(
                      docPath, "App_*.xml"))
                        File.Delete(file);

                    docFilesPurged = true;
                }

            docFile = Path.Combine(docPath, Path.GetFileName(
                Path.ChangeExtension(options.OutputAssembly,
                ".xml")));

            options.CompilerOptions = String.Format(
                "{0} /doc:\"{1}\"", reDocPathOpt.Replace(
                options.CompilerOptions, String.Empty), docFile);
        }
    }

    // Append the other options
    if(additionalOptions != null && additionalOptions.Length != 0)
        options.CompilerOptions = String.Concat(
            options.CompilerOptions, " ", String.Join(" ",
            additionalOptions));
}

A regular expression is used to locate the /docpath option. If found, it extracts the folder name and either creates it if it does not exist or deletes all existing "App_*.xml" files in it the first time it is called. It then combines the path with the output assembly's name and a ".xml" extension and replaces the /docpath option with a /doc command line option. If any additional options are passed to the method, they are also appended to the command line options. The VB.NET code provider passes in an extra /imports command line option to specify the following default import namespaces to work around the issue noted earlier:

  • System
  • System.Collections
  • System.Collections.Generic
  • System.Collections.ObjectModel
  • System.Configuration
  • System.Data
  • System.Web
  • System.Web.Configuration
  • System.Web.UI
  • System.Web.UI.HtmlControls
  • System.Web.UI.WebControls
  • System.Web.Util
  • System.Xml
  • Microsoft.VisualBasic

Conclusion

By using the custom code providers and the instructions above, you can now easily produce XML comments files for website projects in order to create help files for them.

See Also

Other Resources

Walkthrough: Enabling and Using XML Comments
Sandcastle
Sandcastle Styles
Sandcastle Help File Builder


Building Projects Outside the GUI

[image]

Sandcastle Help File Builder Documentation
Building Projects Outside the GUI
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Starting with version 1.8.0.0 of the help file builder, the project file uses a standard MSBuild file format. Projects can be built from the command line using the MSBuild executable. As such, the console mode executable used in prior versions of the help file builder has been removed.

This topic contains the following sections.

  • Building From the Command Line
  • Response Files
  • Target Override Files
  • Specifying a Post-Build Event to Build a Help File
  • Other Build Tools
  • See Also

Building From the Command Line

Use MSBuild.exe to build help file builder projects from the command line. It can be found in the %SystemRoot%\Microsoft.NET\Framework\v[version] folder where "[version]" is an appropriate version of the .NET Framework (currently 3.5). All of the usual MSBuild command line options can be used. You can use the /property:n=v option (short form: /p:n=v) to override project property values where "n" is a property name and "v" is the value to use. Below are some common command line option and property overrides not directly represented by a matching help file builder project property. For a full list of MSBuild command line options, see the MSBuild Command Line Reference

Option | Description
/verbosity:[level] or /v:[level]> | Set the overall verbosity level of the build. This controls which messages MSBuild will display. The default is normal which shows informational messages, errors, and warnings.
/p:Verbose=[True|False] | This property value can be specified to control the output from the build process. The default is false to only output build step names as the build is performed. Setting this property value to true will display all output from all build steps. This is equivalent to the information written to the log file.
/p:DumpLogOnFailure=[True|False] | This property value can be specified to control whether or not the log file is dumped to the MSBuild log if the project fails to build. The default is false to not dump the log. Setting this property value to true will dump the log content if the build fails.
/p:Configuration=[configName] | This can be used to specify the Configuration value to use for any solution or project file documentation sources. If not set, it defaults to Debug.
/p:Platform=[configName] | This can be used to specify the Platform value to use for any solution or project file documentation sources. If not set, it defaults to AnyCPU.
/p:CustomBeforeSHFBTargets=[projectFile] | This can be used to specify a custom project file containing property or target overrides that should be evaluated prior to the help file builder's targets. Specify the full path to the project file.
/p:CustomAfterSHFBTargets=[projectFile] | This can be used to specify a custom project file containing property or target overrides that should be evaluated after the help file builder's targets. Specify the full path to the project file.
Note:

Regardless of any verbosity level setting, full output from the build is always saved to the log file. As with the GUI builder, the help file and the log file can be found in the folder specified in the project's OutputPath property after a build.

Prefix options with '-' or '/'. Property values should be enclosed in double quotes if they contain spaces, commas, or other special characters. All relative paths specified on the command line and those in a response file (see below) are relative to the project's path as usual. Below are a couple of example command lines:

CopyNote: Lines wrapped for display purposes
%SystemRoot%\Microsoft.NET\Framework\v3.5\MSBuild.exe
  /p:Configuration=Release HelpFile.shfbproj

%SystemRoot%\Microsoft.NET\Framework\v3.5\MSBuild.exe
        /p:CopyrightText="Copyright \xa9 2006-2007"
        /p:FeedbackEMailAdress="Eric@EWoodruff.us"
        HelpFile.shfbproj
Note:

Property names specified on the command line or in response files are case-insensitive as are simple property values. However, XML-based property values (the collection-based ones) are case-sensitive with regard to the element names. The values of the elements themselves are case-insensitive.

Response Files

In addition to specifying project option overrides on the command line, MSBuild supports response (.rsp) files that contain a complex list of command line options used to build help file projects. Each option can be on a separate line or all options can be on one line. Comment lines are prefaced with a # symbol. The @ switch is used to pass another response file to MSBuild.exe.

Copy
%SystemRoot%\Microsoft.NET\Framework\v3.5\MSBuild.exe @ResponseFile.rsp

Target Override Files

As noted above, the CustomBeforeSHFBTargets and CustomAfterSHFBTargets properties can be set to the names of MSBuild project files containing property and/or target definition overrides. The CustomBeforeSHFBTargets property is useful for specifying overrides for complex properties such as those for build component configurations, plug-in configurations, and API filter settings as you can specify them using normal XML that spans multiple lines. An example override file is shown below:

Important Note:

The paths to the target override files should be fully qualified as relative paths on them are evaluated by MSBuild based on the help file builder's target file location.

CopyExample Override Project File
<Project xmlns="http://schemas.microsoft.com/developer/msbuild/2003">
  <PropertyGroup>
    <HtmlHelpName>TestDoc</HtmlHelpName>
    <CleanIntermediates>True</CleanIntermediates>
    <RootNamespaceTitle>Root Namespace Container</RootNamespaceTitle>
    <PresentationStyle>Hana</PresentationStyle>
    <HelpTitle>Test Help File</HelpTitle>
  </PropertyGroup>
</Project>

The help file builder target definition file contains several targets that can be overridden to define custom behavior that occurs before and after the help file builder build targets. These can be defined in a custom project file specified with the CustomAfterSHFBTargets property.

Note:

These targets are not executed when built from within the standalone help file builder GUI. These are only executed when built using MSBuild.

Target | Purpose
BeforeBuildHelp | This target executes before the help file is built.
AfterBuildHelp | This target executes after the help file is built.
BeforeCleanHelp | This target executes before the prior build's output is cleared.
AfterCleanHelp | This target executes after the prior build's output is cleared.
BeforeRebuildHelp | This target executes before the help file is rebuilt.
AfterRebuildHelp | This target executes after the help file is rebuilt.

Specifying a Post-Build Event to Build a Help File

Currently, help file builder projects are not directly supported as solution project items. However, a post-build event in a Visual Studio project can be used to build them. To do so, right click on a project name in the Solution Explorer, select Properties, and select the Build Events sub-item. Click in the Post-build Event Command Line option to enter the command line to run. You can click the Edit Post-build button to open a dialog with a larger editor and a list of available macros. Below is an example of a common command line script that can be used (lines wrapped for display purposes). Replace the path to the tool with the path where you installed it on your PC. The IF statement prevents building the help file in debug builds where it may not be needed.

CopyNote: Lines wrapped for display purposes
IF "$(ConfigurationName)"=="Debug" Goto Exit

ECHO Building SHFB help file via MSBuild
"$(SystemRoot)\Microsoft.NET\Framework\v3.5\MSBuild.exe"
    /p:CleanIntermediates=True /p:Configuration=Release
    "$(SolutionDir)Doc\SandcastleBuilder.shfbproj"

:Exit

In a solution with multiple projects that are documented by the same help file builder project, the post-build event should be defined on the last project built by Visual Studio. If the projects are documented individually, you can place a post-build event on each one.

Other Build Tools

Other automated build tools also exist. As long as the build tool supports execution of command line based executables with parameters such as MSBuild.exe, you should be able to integrate it with the build process in a similar fashion.

See Also

Other Resources

Getting Started
Generating Documentation with Team Build
The Log File


Generating Documentation with Team Build

[image]

Sandcastle Help File Builder Documentation
Generating Documentation with Team Build
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This topic provides instructions for using the help file builder in conjunction with Team Build to generate documentation for your projects. This information was originally supplied by Tim Dallmann in the MSDN Developer Documentation and Help System forum. It was revised by Jeroen Vos to provide up to date information on using the Sandcastle Help File Builder v1.8.0.0 or later with Visual Studio Team Foundation Server 2008 SP1.

Note:

Since I do not have a copy of Team Build to test against, the information in this topic may not be completely accurate for all users. Also note that a future version of the help file builder will provide a Visual Studio Package that allows integration of help file builder projects into Visual Studio solutions. As such, this information is subject to change.

The Process

The Sandcastle Help File Builder includes a GUI for editing documentation generation properties on the client. The project file is a standard MSBuild project file and can be built from the command line using the MSBuild executable. While Visual Studio does not currently support the file as a true project, it can be added to a Visual Studio solution as a Solution Item and therefore can be added to source control. The output from Sandcastle can be copied with the build script to any location you like. For example, it can be copied to Team Foundation Server and a link to it can be placed on the team's project site.

  1. Download and install Sandcastle, the HTML Help Workshop, and the Sandcastle Help File Builder on your development machine and your build server.

  2. Run the Sandcastle Help File builder and create a new project. Save it in the root folder of your solution.

    • Add the solution or the project files as documentation sources. That way, the help file builder will include all projects and project outputs in the build. If you do not add Visual Studio Solution or project files, make sure the assemblies you want to document are built to the same location relative to the help file builder's project file on your development machine as they are on your build machine. In addition, you can specify the Configuration and Platform project properties in the build script to select the Debug or Release version rather than hard coding the paths to them in the project file.
    • If you used solution or project files as the documentation sources you do not need to worry about dependencies as they are taken care of automatically. However, if you add assemblies or XML comments files as documentation sources you may need to add dependencies manually too. In that case, make sure that the dependencies are located in the same location relative to the help file builder project file on both the development machine and the build machine.
    • You may find that the build fails on the build machine because it cannot find one or more of the tools (the Sandcastle tools such as MRefBuilder or the help compiler). If this occurs, specify the paths to the tools in the help file project's Paths category properties.
    • Set all other project properties as needed.
  3. Add the generated .shfbproj project file to your Visual Studio solution as a Solution Item and check it in.

  4. Modify your build file. This example uses a daily build to generate documentation:

    • Add a GenerateDocumentation target to your build script. This target was chosen because the TFS team meant it to be used specifically for this purpose. This will call the Sandcastle Help File Builder project to create the help files.

      Important Note:

      Because Team Build overrides the OutDir property for all built solutions/projects to point to one folder that will store all build output, you should provide this property to the help file builder project file if Visual Studio solution or project files were specified as the documentation sources. If you do not, the help file builder will look in the wrong place for the assemblies to document.

      Copy
      <Target Name="GenerateDocumentation">
  <!-- Build source code docs -->
  <MSBuild Projects="$(SolutionRoot)\src\MyProjectHelp.shfbproj"
      Properties="Configuration=Release;Platform=AnyCPU;OutDir=$(OutDir)" />
</Target>
      Tip:

      The Configuration and Platform properties can be obtained from predefined Team Build properties as well. However, be aware that the help file builder as well as most Visual Studio projects default to a value of "AnyCPU" for the Platform property whereas Team Build will use "Any CPU" (with as space) as the default.

      See the Building Projects Outside the GUI help topic for details on building a help file builder project manually from the command line.

  5. The following steps are optional and can be used to deploy the help file. This example assumes you are deploying website output to a web server.

    • Add a new web share to your destination server (i.e. the Team Foundation Server). The following example assumes it is called Code Documentation.
    • Make sure the folder properties grant full access to the process user running the build (TFSBuild for example).
    • Add Index.aspx and/or Index.html to the default documents for the site.
    • Place a subfolder within this folder for the project documentation.
    • Add an AfterDropBuild target to your build script to copy all the new help files to the web server:
      Copy
      <Target Name="AfterDropBuild">
  <!-- Delete old source code docs -->
  <CreateItem Include="\\tfsserver\Code Documentation\MyProject\**\*.*">
    <Output TaskParameter="Include" ItemName="DocDeployFiles" />
  </CreateItem>
  <Delete Files="@(DocDeployFiles)" />

  <!-- Copy new source code docs to team system -->
  <CreateItem Include="$(SolutionRoot)\src\Help\**\*.*"
      Exclude="$(SolutionRoot)\src\Help\Working\**\*.*">
    <Output TaskParameter="Include" ItemName="NewDocFiles" />
  </CreateItem>
  <Copy SourceFiles="@(NewDocFiles)"
    DestinationFolder="\\tfsserver\Code Documentation\MyProject\%(NewDocFiles.RecursiveDir)" />
</Target>
      Note:

      You do not need the Exclude attribute for the NewDocFiles property if you set the help file project's CleanIntermediates property to true.

  6. Check in your build script and run it.

You should now have fresh documentation available every day. You can also set up a separate build using a different name that allows you to create new documentation during the day without running all the other items in the daily build. This can be useful if someone adds a lot of new documentation into the code that you want to make available immediately.

See Also

Other Resources

Getting Started
Installation Instructions
Building Projects Outside the GUI


Project Explorer Window

[image]

Sandcastle Help File Builder Documentation
Project Explorer Window
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Project Explorer allows you to add items to the project and manage their related build action and additional properties.

The Project Explorer tree view consists of the following node types:

  • The root project node is always named after the project and lets you add folder and file items to the root folder of the project.
  • The Documentation Sources node is where you will specify the assemblies, XML comments files, and/or solutions and projects that go into the reference (API) content of the help file.
  • The References node is where you specify dependent assemblies that provide base class information for the documented assemblies but themselves do not appear in the help file's table of contents.
  • Folder nodes can be created to organize the file content of the project.
  • File nodes represent conceptual content topics, images, content layout files, and various other supporting files that may or may not be compiled into the help file. Each file has a build action that determines how it is handled during the build process.

Right-clicking a node in the Project Explorer or selecting File | Project Explorer and then a submenu option from it allows you to perform various tasks within the pane such as adding and removing documentation sources, adding and removing references, and adding and removing files and folders. The property grid below the explorer tree view allows you to modify the build action and related properties for the selected file node.

The following keyboard shortcuts can also be used to perform the indicated actions:

  • Context menu key - Show the context menu for the selected item.
  • Delete - Delete the selected item.
  • Enter - Edit the selected file (file nodes only).
  • F2 - Edit the selected node's name (project, folder, and file nodes only).

Double-clicking a file node will also open it for editing.

See Also

Other Resources

Getting Started
Project Properties Window


Documentation Sources

[image]

Sandcastle Help File Builder Documentation
Documentation Sources
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Documentation sources are how you specify the assemblies, XML comments files, and/or solutions and projects that define the reference (API) content of the help file.

Adding a Documentation Source

To add a documentation source, right click on the Documentation Sources project node and select Add Documentation Source... or select File | Project Explorer | Documentation Sources | Add Documentation Source.... An Open File dialog box appears in which you can select one or more DLLs, executables, XML comments files, or Visual Studio solutions/projects associated with the items to document. When adding a DLL or an executable, if an XML comments file with the same name is found, it is also added to the project automatically. Likewise, if you select an XML comments file, a DLL or executable with a matching name is added to the project automatically if it exists. Files can also be dragged and dropped on the node from Windows Explorer.

Note:

If you do not add an associated XML comments file for an assembly, no comments will appear on the documented members in the help file topics that are built.

Tip:

Given that solutions and projects are supported as documentation sources, you may find it easier to add them as documentation sources instead of the assemblies, comments, and references that they contain. When a solution or project is used, these items are imported from them automatically at build time.

Note:

Only add assemblies and projects that you want documented to this project node. Third-party assemblies, interop assemblies, and other dependent DLLs should be added to the project's References node.

Editing a Documentation Source

When selected, each documentation source has the following properties that can be edited in the property grid at the bottom of the Project Explorer window. Some of the properties will only apply to certain types of documenation source as indicated.

  • SourceFile - This can be an individual file or it can contain wildcards (* or ?) to include multiple files. If the extension is a wildcard (i.e *.* or ProjectName.*), it will include any assembly, XML comments file, solution or project that matches the wildcard.
  • IncludeSubFolders - If the SourceFile property contains a wildcard, this property will be used to determine whether all matching files are included from subfolders as well (True) or if just the files in the indicated folder are included (False).
  • Configuration - For Visual Studio solution and project documentation sources, this can be used to indicate that a specific configuration value should be used when extracting assembly, comments file, and reference information. If not set, the global Configuration option setting is used. The default global option value is Debug.
  • Platform - For Visual Studio solution and project documentation sources, this can be used to indicate that a specific platform value should be used when extracting assembly, comments file, and reference information. If not set, the global Platform option setting is used. The default global option value is AnyCPU.

Removing a Documentation Source

To remove a documentation source, right click on it and select the Remove option. This can also be selected from the File | Project Explorer | Documentation Sources menu.

See Also

Other Resources

Project Explorer Window
Project Properties Window


References

[image]

Sandcastle Help File Builder Documentation
References
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The MRefBuilder tool may not resolve references to all assemblies used by a target, especially those found in the Global Assembly Cache (GAC). As such, it needs a hint to find the files and load them when needed (the /dep command line option). The References project node is used to specify a list of dependencies used by the MRefBuilder tool when it generates reflection information for the documentation source assemblies. Dependency information allows inherited members to be listed for a type but the information will not appear in the table of contents of the help file.

Adding a Reference

To add a reference, right click on the References project node and select Add File/Project Reference... or Add GAC Reference.... These options can also be selected from the File | Project Explorer | References menu. Files can also be dragged and dropped on the node from Windows Explorer. The following reference types are supported in the project.

  • File Reference - Select an assembly to use as the reference.
  • Project Reference - Select a Visual Studio project to use as a reference. In this case, the output assembly of the project is used as the reference.
  • GAC Reference - Select an entry from the Global Assembly Cache to use as the reference.
  • COM Reference - COM references are also supported. However, they cannot currently be added via the standalone GUI. As an alternative, you can add the COM-callable wrappers that Visual Studio creates as file references.
Tip:

Given that solutions and projects are supported as documentation sources, you may find it easier to add them as documentation sources instead of the assemblies, comments, and references that they contain. When a solution or project is used, these items are imported from them automatically at build time.

Editing a Reference

When selected, file and project references allow you to edit the HintPath property to specify the referenced file. All other references have read-only properties. To change them, remove them and add the desired references in their place.

Removing a Reference

To remove a reference, right click on it and select the Remove option. This can also be selected from the File | Project Explorer | References menu.

See Also

Other Resources

Project Explorer Window
Project Properties Window


Folder and File Items

[image]

Sandcastle Help File Builder Documentation
Folder and File Items
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Folder nodes can be used to organize the content items in a project. The file nodes represent conceptual content topics, images, content layout files, and various other supporting files that may or may not be compiled into the help file.

  • Adding Folders and Files
    • Add Options
  • Editing a Folder or File Item
  • Removing a Folder or File Item
  • See Also

Adding Folders and Files

To add a folder or file, right click on the root project node or any other folder or file node and select one of the Add menu options. These options can also be selected from the File | Project Explorer | Files menu. Files can also be dragged and dropped on the folder and file nodes from Windows Explorer.

Folders and files added while the root project node or a root file node is selected will be added to the root folder of the project. Folders and files added while a folder item is selected will be added as children of the selected folder. Folders and files added while a child of a folder node is selected will be added as children of the parent folder of the selected item.

Note:

Folders and files become part of the project and will reside in the project folder. Existing files that are not under the project folder are copied to it.

Add Options

The following options can be used to add items to the project:

  • New Item - This lets you add a new file item based on a template. A set of common template files appears in the submenu along with additional submenus containing conceptual content topic templates and custom template files that you can create.
    Tip:

    To add your own custom project template files, place them in the Item Templates folder in the help file builder's Local Application Data folder. To add your own conceptual content topic template files, place them in the Conceptual Templates folder in the help file builder's Local Application Data folder. See the Special Folder Locations topic for more information.

  • New Folder - Add a new folder to the project.
  • Existing Folder - Add an existing folder to the project. If the folder contains subfolders and/or files, they are added to the project recursively as well. The folder must be a child of the project folder or one of its subfolders.
  • Existing Item - Add an existing file to the project. The build action will be set based on the file's extension.
  • Import from Media Content File - This option will add images to the project based on the information in a conceptual content media content file. The images added will have their build action set to Image and their additional properties will be set to the values from the content file. If referenced in conceptual content topics, these image will be copied to the .\Media folder in the resulting help file output.

Editing a Folder or File Item

When selected, folders allow you to edit their name. Changing a folder name changes the parent folder name in all child items as well. All file items have a Name property that lets you edit their name. In addition, they all have a BuildAction property that specifies how the file is treated at build time. Other properties, if any, depend on the selected build action.

Tip:

Files and folders can be dragged and dropped or cut/copied and pasted to move them from one folder to another within the project.

Tip:

To edit the content of a file, double-click it, hit Enter while it is selected, or select the Open option on its context menu.

Removing a Folder or File Item

To remove a folder or file, right click on it and select the Exclude from Project or Delete option. These can also be selected from the File | Project Explorer | Files menu. The Exclude from Project option will remove the item from the project but leaves it on disk. Delete will remove it from the project and permanently deletes it from the disk as well.

Caution:

If a folder is deleted, all child items are deleted recursively as well.

Note:

The project supports linked items as well (adding them is not supported from the standalone GUI). Linked items will have a Remove option rather than a Delete option. This removes them from the project but leaves them on disk in their original location since they may belong to another project.

See Also

Other Resources

Build Actions
Project Explorer Window
Project Properties Window


Build Actions

[image]

Sandcastle Help File Builder Documentation
Build Actions
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

All file project items have a BuildAction property that determines how they will be handled at build time.

  • None
  • Content
  • Image
  • CodeSnippets
  • Tokens
  • ContentLayout
  • SiteMap
  • TopicTransform
  • See Also

None

This is the default build action for all files without a recognized file extension as well as all conceptual content topic files (.aml). Files with this build action are ignored at build time and will not be compiled into the help file.

Note:

To include conceptual content topics in a help file, add a content layout file to the project and use it to set the order and titles of the topics. For images that appear in conceptual content topics, use the Image build action.

Tip:

Setting the build action to None on any file type will cause it to be ignored during the build. This is useful for testing a different content layout while retaining the old file or perhaps creating different content layouts that can be selected by altering the build action to select the one you want for a given build.

Content

This is the default build action for any file that is considered to be HTML-based additional content or a supporting file. File extensions recognized include: .asp, .aspx, .ascx, .config, .css, .htm, .html, .js, .topic, .txt, .bmp, .gif, .jpg, .jpeg, .png

Note:

Content files added to the root project folder will be copied to the root folder of the compiled help file. Files in subfolders will be copied to like-named subfolders in the compiled help file.

Content items have an additional ExcludeFromToc property. If the item represents an HTML file that can appear in the table of contents, it will be excluded if this property is set to True. This only has an effect if there is no site map file in the project. Site map files always take precedence in defining the layout of HTML-based additional content items in the table of contents.

Image

Select this build action for images that appear in conceptual content topics. The ImageId property value is used in the mediaLink and mediaLinkInline MAML elements to reference them. Changes can be made to the image properties such as the file associated with the ID and its AlternateText without having to visit each topic in which it is referenced.

Caution:

The value of the ID assigned to an image should not be changed. If it is, you will be required to manually locate and update the old ID in all topics that reference it.

The CopyToMedia property can be used to specify whether or not the image is copied to the .\Media folder even if not referenced in a media link. The default is False to only copy the image if referenced. Setting it to True is useful if the image is used for other purposes such as in an HTML content file, if used by a custom build component, or if it is only referenced in an externalLink MAML element.

Note:

Image files default to the Content build action when first added to the project. You must select the Image build action if you want to use them in conceptual content.

Unlike topics, image files will retain their name when copied to the media folder. As such, if you add two images from different locations that have the same name, one will overwrite the other when the help file is built.

This build action also causes the file to appear in the Entity References window when Images is selected in it.

CodeSnippets

Selecting this build action identifies the file as a code snippets file. These allows you to define code samples outside of conceptual topic files. Each snippet has a unique ID that can be referenced in multiple topics using a codeReference MAML element so that the snippets do not have to be copied into each one. Files with a .snippets extension are automatically assigned this build action. Multiple snippets files can exist in the project and all will be included in the conceptual content build. This build action also causes the file to appear in the Entity References window when Code Snippets is selected in it.

Tip:

When using the Sandcastle Help File Builder, the Code Block Component offers the same set of features and several others for both inline and external code snippets. In addition, it supports many other languages and can import code from working source code files which allows you to pull in examples from working projects that you can maintain and build without having to update a separate example snippets file. As such, you may prefer to use it rather than manage the code snippets in an XML file.

Tokens

A token is used as a replaceable tag within a conceptual content topic and is represented using a token element. The inner text of the element is a token name. The tokens are defined in a separate token file. They are an easy way to represent common items that you use regularly such as a common phrase or external link. Selecting this build action identifies the file as a token file. Files with a .tokens extension are automatically assigned this build action. Multiple token files can exist in the project and all will be included in the conceptual content build. This build action also causes the file to appear in the Entity References window when Tokens is selected in it.

ContentLayout

This is the default build action for content layout files (those with a .content extension). These are used to define the layout of conceptual content topics in the table of contents and the additional topic properties such as their title, help attributes, and index keywords.

Note:

Without at least one content layout file, no conceptual content will appear in the compiled help file.

Multiple content layout files can appear in a project. Each has a SortOrder property that is used to determine how their root entries are ordered within the overall table of contents. Each content layout and site map file is sorted based on the sort order and their items are then merged into the table of contents in that order.

SiteMap

This is the default build action for site map files (those with a .sitemap extension). These are used to define the layout of HTML-based additional content topics in the table of contents and their title.

Note:

Items referenced in a site map file must have a Content build action.

Unlike conceptual content, HTML-based items in a project will be compiled into the help file if they have a Content build action with or without a site map. In the absence of a site map, the layout of the items in the table of contents is based on the physical folder structure of the items. Files at the root level appear at the root level of the help file. Files in subfolders will appear in like-named subfolders in the help file.

This feature has been deprecated and is only supported for backward compatibility. While it will still be supported and will not be removed, it will not receive any further enhancements. Conceptual content is now the preferred method of adding non-API topics to the help file.

Multiple site map files can appear in a project. Each has a SortOrder property that is used to determine how their root entries are ordered within the overall table of contents. Each content layout and site map file is sorted based on the sort order and their items are then merged into the table of contents in that order.

TopicTransform

Files with a .xsl or a .xslt file extension will get a build action of TopicTransform by default. This feature was used in prior versions of the help file builder to transform .topic files to HTML and give them the look and feel of the API topics.

Note:

Only the first transformation file found at build time will be used. Any others in the project are ignored.

This feature has been deprecated and is only supported for backward compatibility. While it will still be supported and will not be removed, it will not receive any further enhancements. Conceptual content is now the preferred method of adding non-API topics to the help file.

See Also

Other Resources

Folder and File Items
Project Explorer Window
Project Properties Window
Entity References Window


Project Properties Window

[image]

Sandcastle Help File Builder Documentation
Project Properties Window
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

All of the main project properties except documentation sources and references can be edited via the Project Properties window. The options in the property grid are grouped into several categories and are listed alphabetically within them. Most are simple data types and can be edited directly in the text box or dropdown to the right of the property name. Other values, such as ComponentConfigurations are collection-based and use a pop-up editor accessed by clicking the "..." button that appears to the right of the property value when it is selected.

Property Categories

Select a topic below to learn more about the properties in each category.

  • Build Category Properties
  • Comments Category Properties
    • Using NamespaceDoc Classes
    • Sharing Project Summary and Namespace Comments
  • Help File Category Properties
  • HTML Help 1 and HTML Help 2 Category Properties
  • Paths Category Properties
  • Show Missing Tags Category Properties
  • Visibility Category Properties
    • API Filter Property

See Also

Other Resources

Additional Content
Conceptual Content
Project Explorer Window


Build Category Properties

[image]

Sandcastle Help File Builder Documentation
Build Category Properties
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Build category properties control the build process.

  • BuildLogFile
  • CleanIntermediates
  • ComponentConfigurations
  • CppCommentsFixup
  • FrameworkVersion
  • HelpFileFormat
  • KeepLogFile
  • PlugInConfigurations
  • UserDefinedProperties

BuildLogFile

This property is used to specify the location and name of the build log file. If not specified, a default name of LastBuild.log is used and the log file is stored in the same folder as the help file (the location specified by the OutputPath property).

CleanIntermediates

This property is used to specify whether or not intermediate files created during the build are kept after a successful build or are purged. The default is True to purge the files. If not purged, you will find the files in a .\Working folder under the project's output path folder. Files that are placed there include the build scripts, configuration files, and the HTML help compiler project output files (scripts, art, HTML pages, the HTML help project, etc). The intermediate files are always retained if the build fails so that you can examine them to find the cause if necessary.

ComponentConfigurations

This option allows you to select, add, and configure build components for the project that support the help file builder's component configuration method to interactively set their options. See the Custom Build Components topic for information on the ones supplied with the help file builder.

CppCommentsFixup

This option is used to fix some issues with C++ XML comments. The C++ compiler generates non-standard method signatures in the XML comments files in certain situations. The methods affected usually involve generics. The C++ compiler also has problems resolving references to some members if it has not seen them yet. These are prefixed with "!:" which is removed by the fix-up code. If you find some C++ methods that fail to get documented, set this project property to true to have the help file builder attempt to fix them up so that they can be documented.

FrameworkVersion

This property allows you to specify against which .NET Framework version the documentation assemblies where compiled. This affects how the MRefBuilder tool produces the reflection information file. The default is to use the most recent .NET 2.0 version available on the system (currently 2.0.50727). This will also affect which set of .NET Framework comments are included in the build to document all inherited members of your classes. Set this property according to your assemblies' framework version requirements to ensure that the correct reflection information is generated.

HelpFileFormat

This property lets you specify the type of help file to build (HTML Help 1.x, HTML Help 2.x, a website, or various combinations of the three options). The default is to produce an HTML Help 1.x format file.

Caution:

Be aware that if an option is selected that produces a website, the output folder specified by the OutputPath property will be cleared of all of its current content without any prompting before the web site content is copied to it. In other words, don't do something stupid like set it to the root of your C: drive or your desktop folder. When producing a help file alone, the output folder is not cleared.

When producing a website, the following additional files are copied to the root of the output folder.

  • Index.aspx - This page is used to contain the table of contents and the currently selected content page. It uses Ajax to dynamically load child nodes when first expanded and should be more efficient for large help files. It also contains a search option that lets you search for keywords in the help topics and a keyword index. A topic query string parameter can be specified. If set to the path of a page in the website, it will display that page instead of the normal default topic page.
  • FillNode.aspx - This is used by the Ajax calls to dynamically load child nodes for the table of contents.
  • SearchHelp.aspx - This is used by the Ajax calls to search for keywords using the full-text index.
  • Web.config - This contains some necessary namespace declarations for the ASP.NET pages above.
  • Index.html - This page is used to contain the table of contents and the currently selected content page. The table of contents is contained entirely within the page and may not be as efficient for large help files.
  • TOC.css - This is the style sheet used for the index pages.
  • TOC.js - This JavaScript file is used by the index pages. It contains the code used to implement a basic tree view with collapsible and expandable nodes, a splitter bar, and Ajax calls to load child table of contents nodes dynamically and perform keyword searches.
  • WebTOC.xml - This is the XML file used to contain the table of contents information. This file is generated during the build and will contain the same entries as the help file's table of contents in a matching layout.
  • *.gif, *.png, *.bmp - Several image files are copied that represent the collapsed, expanded, and item nodes in the table of contents tree view and the Expand All, Collapse All, and Synch to Content options.
  • .\FTI\*.bin - The FTI folder contains the serialized full-text index data files. The data is split up into multiple files to improve the performance and reduce the amount of information needed when doing a search.

KeepLogFile

This property is used to specify whether or not the log file is kept after a successful build. It is true by default to keep the log file. If set to false, the log file is deleted after a successful build. The log file is always kept after a failed build.

PlugInConfigurations

This option allows you to select, add, and configure plug-ins for the project that are used to alter or extend the build process in various ways. See the Build Process Plug-Ins topic for information on the ones supplied with the help file builder.

UserDefinedProperties

This property allows you to add or edit user-defined project properties. These are custom properties that you can create to hold additional information or for use in substitution tags within other help file builder project properties. User-defined project properties themselves consist of three property values:

  • Name - The name of the project propety. This cannot match the name of an existing help file builder project property, certain reserved MSBuild property names, or the name of an existing user-defined property.

  • Condition - An optional condition that defines when the property will be evaluated and the given value used. This is useful if you have environment variables or other command-line defined properties in your build environment that do not exist on your development PC. In such cases, you can add a condition to define a default value while you test the project. For example, assume you define a property called MyCustomProperty with a value of "Test" and set the condition to '$(MyCustomProperty)' == ''. This is stored in the project file as:

    Copy
    <MyCustomProperty Condition=" '$(MyCustomProperty)' == '' ">Test</MyCustomProperty>

    The property will only be defined in the project using the given value if it does not already have a value defined elsewhere (i.e. from a command line property definition, an environment variable, etc.).

    Caution:

    Entering an invalid Condition value can cause the project to become unloadable. If this occurs, you will need to edit the project file by hand with a text editor to delete the invalid property.

  • Value - This defines the value to use for the property. User-defined property values are not escaped and thus can contain references to other project or MSBuild properties.
Note:

The MSBuild project object does not provide a way to delete or rename project properties. As such, if you need to delete or rename a user-defined property, open the help file builder project in a text editor, locate the element and delete or rename it by hand.

See Also

Other Resources

Project Properties Window


Comments Category Properties

[image]

Sandcastle Help File Builder Documentation
Comments Category Properties
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Comments category properties allow you to specify project summary and namespace summary comments.

ProjectSummary

The ProjectSummary property allows you to enter summary comments that should appear in the root namespaces page of the compiled help file. This is the standard default page unless additional or conceptual content is defined that is marked as the default page. Depending on the presentation style, the Namespaces page is also accessible via the breadcrumb link available at the top of the namespace item help pages in the generated help file. These comments will appear above the list of namespaces and can contain HTML markup (i.e. text formatting, e-mail links, etc.). The comments can also include the <inheritdoc /> tag so that you can import the description or parts of a description from another namespace, type, or member. If no project summary is defined, the page just shows the list of namespaces. Click the "..." button to the right of the property value to open an expanded editor for the comments.

NamespaceSummaries

The NamespaceSummaries property allows you to specify which namespaces should appear in the help file as well as the namespace summaries to display in the root namespaces page and on the help page for each namespace.

When the form is opened, it scans the documentation assemblies for new namespaces and adds them to the list if it finds any. As you select each namespace, the list of assemblies in which it appears is shown to the right and its current description appears in the text box below the lists. Namespaces can be filtered by assembly and/or by entering some text or a regular expression to match and clicking the Apply button. Setting the assembly combo box back to "<All>", clearing the search text, and clicking Apply will redisplay all assemblies.

To edit a namespace summary, select the namespace in the list and edit the comments in the text box at the bottom of the form. The comments can include HTML markup (i.e. bolding, e-mail links, etc). If no summary is defined, a red warning note will appear for the namespace on the root namespaces page and above the namespace content in the help page for the namespace itself. If you build a help file without updating the namespace list, any unknown namespaces will appear in the help file but they will also contain a red warning message indicating that the namespace summary is missing. The warning can be removed by setting the ShowMissingNamespaces project option to false. Namespace summaries also support the <inheritdoc /> tag so that you can import the description or parts of a description from another namespace, type, or member.

Namespaces are never removed from the list even if the namespace no longer appears in one of the documented assemblies. You can remove old namespaces from the list by selecting them and clicking the Delete button. The "(global)" namespace is a special case and, although it can be deleted, it will be added automatically to remove unwanted information that appears in the global namespace.

You may check the namespaces that you want to appear and uncheck those that you do not want to appear. By default, all namespaces in all assemblies are documented with the exception of the global (unnamed) namespace that sometimes appears and contains private module details. This information is automatically merged with the project's ApiFilter settings at build time. To avoid conflicts, you may want to leave all of your namespaces checked here and use the API Filter Property exclusively to manage the namespaces excluded from the documentation.

See Also

Other Resources

Using NamespaceDoc Classes
Sharing Project Summary and Namespace Comments
Project Properties Window


Using NamespaceDoc Classes

[image]

Sandcastle Help File Builder Documentation
Using NamespaceDoc Classes
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Namespace comments can also be specified and maintained in your source code by adding an empty NamespaceDoc class to each namespace. When comments for this class are found in the XML comments files they will be used as the namespace comments. Note that you can use the class and also specify namespace comments in the help file builder project. When this occurs, the project namespace summary comments will be appended to the comments from the NamespaceDoc class comments.

To keep the NamespaceDoc class from appearing in the help file, leave off the public keyword and mark it with a CompilerGenerated attribute. This will cause the class to be automatically ignored when reflection information is generated for the assembly. The following is an example:

CopyC# NamespaceDoc Example
namespace Company.Product.Widgets
{
    /// <summary>
    /// These are the namespace comments for <c>Company.Product.Widgets</c>.
    /// </summary>
    [System.Runtime.CompilerServices.CompilerGeneratedAttribute()]
    class NamespaceDoc
    {
    }
}
CopyVB.NET NamespaceDoc Example
Namespace Company.Product.Widgets
    ''' <summary>
    ''' These are the namespace comments for <c>Company.Product.Widgets</c>.
    ''' </summary>
    <System.Runtime.CompilerServices.CompilerGeneratedAttribute()> _
    Class NamespaceDoc
    End Class
End Namespace

See Also

Other Resources

Comments Category Properties
Sharing Project Summary and Namespace Comments
Project Properties Window


Sharing Project Summary and Namespace Comments

[image]

Sandcastle Help File Builder Documentation
Sharing Project Summary and Namespace Comments
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

If you are documenting multiple, related assemblies but wish to use a separate help file builder project for each assembly, you may want to share project summary and namespace comments between each of the projects and specify a common set of namespaces to exclude from the build. Rather than managing this information in each individual project, you can create a standalone XML comments file to contain the information.

Start by creating an XML comments file like the following and give it a unique name that will not conflict with any other XML comments file in the related projects.

CopySample Project/Namespace XML Comments File
<?xml version="1.0"?>
<doc>
  <assembly>
    <name>_SharedItems_</name>
  </assembly>
  <members>
    <member name="R:Project">
      <summary>
        Shared project summary comments go in here.
      </summary>
    </member>
    <member name="N:">
      <exclude />
      <summary>
        Exclude the global namespace from all projects.
      </summary>
    </member>
    <member name="N:CustomControls.Internal">
      <exclude />
    </member>
    <member name="N:CustomControls.Design">
      <summary>
        Common namespace summary info for the CustomControls.Design
        namespace go here.
      </summary>
    </member>
  </members>
</doc>

Next, do one or more of the following:

  • To specify shared project summary comments, add them to the <summary> tag in the R:Project node. Any project summary comments in the help file projects will be appended to these comments. If you do not have any shared project summary notes, you may remove this node from the file.
  • To exclude a namespace from all shared projects, add a <member> node, set it's name attribute to the namespace name prefixed with "N:", and place an <exclude /> tag in it. Any other tags are optional. The example above would exclude the unnamed global namespace and the CustomControls.Internal namespace from all projects.
  • To specify shared namespace summary comments, add a <member> node, set it's name attribute to the namespace name prefixed with "N:", and add the comments to the <summary> tag in the node. Any namespace summary comments in the help file projects will be appended to these comments.

Once you have created the file, open each project that needs to use it, right click on the Documentation Sources node in the Project Explorer window, select the option to add a documentation source, and select the shared comments file. You may now build your project and the shared comments will be included in it.

See Also

Other Resources

Comments Category Properties
Using NamespaceDoc Classes
Project Properties Window


Help File Category Properties

[image]

Sandcastle Help File Builder Documentation
Help File Category Properties
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Help File category properties control the appearance and features of the generated help topics.

  • ContentPlacement
  • CopyrightHref and CopyrightText
  • FeedbackEMailAddress and FeedbackEMailLinkText
  • FooterText
  • HeaderText
  • HelpTitle
  • HtmlHelpName
  • IndentHtml
  • Language
  • NamingMethod
  • Preliminary
  • PresentationStyle
  • ProjectLinkType
  • RootNamespaceContainer and RootNamespaceTitle
  • SdkLinkType and SdkLinkTarget
  • ShowFeedbackControl
  • SyntaxFilters
Note:

The layout of several of these properties can be customized. See the Customizing the Header and Footer Text topic for information on how to change the layout of these items. Substitution tags such as {@BuildDate} can be specified in many of these properties and will be expanded at build time to the current project property value. See the Customizing the Build Process topic for a list of tags that can be used.

ContentPlacement

This property allows you to define where the additional and/or conceptual content items appear in the table of contents. By default, they will appear above the namespaces. By setting this property to BelowNamespaces, you can make the items appear below the namespace entries in the table of contents.

This property's setting will be ignored if the table of contents is split via a custom tag in one of the additional content files, a site map is defined that specifies a split table of contents, or conceptual content is defined with an entry marked as the split location. In such cases, items prior to the entry with the "split" option will appear before the API content. The item with the "split" option and all items after it will appear below the API content.

CopyrightHref and CopyrightText

These two properties can be used individually or in combination. If only CopyrightHref is specified, a link will appear in the footer of each page for the specified URL. If only the CopyrightText property is specified, that message appears in the footer of each page. If both are specified, a link appears in the footer of each page using the text from the CopyrightText property and the target of the link is set to the URL specified in the CopyrightHref property. The value of the CopyrightText property is treated as plain text. It will be HTML encoded where necessary to resolve issues related to the ampersand character and the XML parser. In addition, you can encode special characters such as the copyright symbol using an escaped hex value (i.e. © = \xA9).

FeedbackEMailAddress and FeedbackEMailLinkText

If an e-mail address is specified in the FeedbackEMailAddress property, an extra message is included in the footer of each page with a message saying "Send comments on this topic to" plus the specified e-mail address or link text. If a FeedbackEMailLinkText value is specified along with a feedback e-mail address, that text will be displayed as the link text rather than the e-mail address. If left blank, the e-mail address will be used. The e-mail address is rendered as a clickable mailto: link and the subject of the e-mail will be set to the title of the help file plus the title of the page in which the link appears.

FooterText

This property can be used to insert an extra message in the footer of each page. By default, it is blank. HTML tags are supported within the text.

HeaderText

This property can be used to insert an extra message in the header of each page. By default, it is blank. HTML tags are supported within the text. See the Preliminary property for a way to mark all topics as preliminary.

HelpTitle

This property is used to set the title for the help file. This text will appear as the title of the help file's window.

HtmlHelpName

This property is used to specify the name of the HTML help file. This name is used during the build process for a couple of other files so be sure that you do not specify a path or an extension on this value. It should only specify the name part of the file. The extension will always be .chm (Help 1) or .HxS (Help 2) and the path is controlled via the OutputPath property.

Note:

For HTML Help 2 builds, this name is used as the collection namespace name. In such cases, spaces in the name are not allowed and, if any are found in the name, the build will fail.

IndentHtml

This is used to indicate whether or not the HTML rendered by BuildAssembler is indented. This is mainly a debugging aid. When set to True, the HTML is indented to make it more readable. Leave it set to False to produce more compact HTML.

Language

This property allows you to specify the language to use for the compiled help file. The default is to use the English language resource files. A shared content file is supplied that contains various item overrides related to the help file builder's project properties. Currently, shared content files for the help file builder are available for several languages. If you specify a language for which a file does not exist, the help file will build but you will see a warning in the build output that the selected language resources could not be found and that it is defaulting to the US English (en-US) language files. For more information on creating additional language resource files, see the Localizing Language Resource Files help topic.

NamingMethod

This property allows you to specify how the help topic filenames will be generated. There are three options:

  • Guid will generate an MD5 hash of the topic ID and format it as a GUID value. The topic ID is the member name from the XML comments file for the item and includes all parameter values for methods. This is the default value and is suitable for most help files. While this guarantees unique topic filenames, it does make it cumbersome to link to help topics from external sources such as application code or web pages that are not part of the help file's additional content as the names are rather long and non-intuitive.
  • MemberName will name each help topic after the member that it represents. To avoid problems with invalid filename characters, " " (space), ":", ".", "`" (0x60), "#", "*", and "?" characters are replaced with an underscore in the member names. Overloaded methods will generate duplicate names. To avoid this problem, all subsequent duplicate names will have a counter added to the end of their name separated by an underscore (i.e. M_Type_Method, M_Type_Method_1, M_Type_Method_2, etc). When this occurs, a message is recorded in the log file. Also note that this may generate extremely long filenames when the full path is included. This may cause the build to fail. If so, try using the next option.
  • HashedMemberName will name each topic using the hash value of the member name in hex format. This results in a much shorter filename, even shorter than the GUID names, but it can still be easily reproduced by an application or ASP.NET web page in order to link to the help topic. The actual member name is used without any of the character replacements noted for the MemberName option. As with the MemberName option, overloaded methods will generate duplicate names. To avoid this problem, all subsequent duplicate names will have a counter added to the end of their name separated by an underscore (i.e. M:Type.Method, M:Type.Method_1, M:Type.Method_2, etc.). When this occurs, a message is recorded in the log file.

Note that each help topic ID will have a prefix denoting what it represents:

  • R: represents the root namespace page. There will always be a single entry named R:Project.
  • N: represents a namespace help topic that lists all of the members of the given namespace.
  • T: represents a type help topic that lists all of the members of the given type.
  • Overload: represents a help topic that lists all of the overloads for a particular class member.
  • F: represents a field member.
  • E: represents an event member.
  • P: represents a property.
  • M: represents a method.

Below are some examples of the member names and their equivalent filenames. The values in the first column would be used for the HashedMemberName option to create the hash value. The second column would be used for the MemberName option. For GUID filenames, the method names in the first column would include parameter information rather than a numeric suffix.

HashedMemberName (value to hash) | MemberName
R:Project | R_Project
N:SandcastleBuilder.Utils | N_SandcastleBuilder_Utils
T:SandcastleBuilder.Utils.BuildProcess | T_SandcastleBuilder_Utils_BuildProcess
Overload:SandcastleBuilder.Utils.BuilderException.#ctor | Overload_SandcastleBuilder_Utils_BuilderException__ctor
F:SandcastleBuilder.Utils.SandcastleProject.DefaultName | F_SandcastleBuilder_Utils_SandcastleProject_DefaultName
E:SandcastleBuilder.Utils.BuildProcess.BuildStepChanged | E_SandcastleBuilder_Utils_BuildProcess_BuildStepChanged
P:SandcastleBuilder.Utils.DependencyItem.DependencyPath | P_SandcastleBuilder_Utils_DependencyItem_DependencyPath
M:SandcastleBuilder.Utils.BuilderException.#ctor M:SandcastleBuilder.Utils.BuilderException.#ctor_1 (overload #1) M:SandcastleBuilder.Utils.BuilderException.#ctor_2 (overload #2) M:SandcastleBuilder.Utils.BuilderException.#ctor_3 (overload #3) | M_SandcastleBuilder_Utils_BuilderException__ctor (note the double underscore before "ctor" due to the "#") M_SandcastleBuilder_Utils_BuilderException__ctor_1 (overload #1) M_SandcastleBuilder_Utils_BuilderException__ctor_2 (overload #2) M_SandcastleBuilder_Utils_BuilderException__ctor_3 (overload #3)

To map a member name to its equivalent filename, you can use code similar to the following. As noted in the code, the HTML files will reside in an html\ folder and will have a .htm extension so be sure to add them to the resulting topic filename.

CopyC# - GUID
// Compute the MD5 hash of the member name.  Assume
// memberName contains the member name of the topic
// to show.
HashAlgorithm md5 = HashAlgorithm.Create("MD5");

byte[] input = Encoding.UTF8.GetBytes(memberName);
byte[] output = md5.ComputeHash(input);

// Format it as a GUID value
Guid pageId = new Guid(output);

// Show the topic in the help file.  Remember to add
// the "html\" folder name and the ".htm" extension.
Help.ShowHelp(parentForm, helpFilePath,
    HelpNavigator.Topic, @"html\" + pageId.ToString() + ".htm");
CopyVB.NET - GUID
' Compute the MD5 hash of the member name.  Assume
' memberName contains the member name of the topic
' to show.
Dim md5 As New HashAlgorithm.Create("MD5")

Dim inputArray() As Byte() = Encoding.UTF8.GetBytes(memberName)
Dim outputArray() As Byte() = md5.ComputeHash(inputArray)

' Format it as a GUID value
Dim pageId As New Guid(outputArray)

' Show the topic in the help file.  Remember to add
' the "html\" folder name and the ".htm" extension.
Help.ShowHelp(parentForm, helpFilePath, _
    HelpNavigator.Topic, "html\" & pageId.ToString() & ".htm")
CopyC# - MemberName
Regex reInvalidChars = new Regex("[ :.`#<>*?]");

// Assume memberName contains the member name of the
// topic to show.
string pageName = reInvalidChars.Replace(
    memberName, "_");

// Show the topic in the help file.  Remember to add
// the "html\" folder name and the ".htm" extension.
Help.ShowHelp(parentForm, helpFilePath,
    HelpNavigator.Topic, @"html\" + pageName + ".htm");
CopyVB.NET - MemberName
Dim reInvalidChars As New Regex("[ :.`#<>*?]")

' Assume memberName contains the member name of the
' topic to show.
Dim pageName As String = reInvalidChars.Replace( _
    memberName, "_")

' Show the topic in the help file.  Remember to add
' the "html\" folder name and the ".htm" extension.
Help.ShowHelp(parentForm, helpFilePath, _
    HelpNavigator.Topic, "html\" & pageName & ".htm")
CopyC# - HashedMemberName
// Assume memberName contains the member name of the
// topic to show.
string pageName = String.Format("{0:X}",
    memberName.GetHashCode());

// Show the topic in the help file.  Remember to add
// the "html\" folder name and the ".htm" extension.
Help.ShowHelp(parentForm, helpFilePath,
    HelpNavigator.Topic, @"html\" + pageName + ".htm");
CopyVB.NET - HashedMemberName
' Assume memberName contains the member name of the
' topic to show.
Dim pageName As String = String.Format("{0:X}", _
    memberName.GetHashCode())

' Show the topic in the help file.  Remember to add
' the "html\" folder name and the ".htm" extension.
Help.ShowHelp(parentForm, helpFilePath, _
    HelpNavigator.Topic, "html\" & pageName & ".htm")

The naming rules are the same for pages generated for the website output. One way to get the URL to use for a page in the website output is to bring up the Index page for the generated website (Index.html or Index.aspx), you can right click on the links in the navigation pane and select Copy Shortcut. Paste that into your web page that you want to link to the selected topic and modify the link by inserting "Index.html?topic=" or "Index.aspx?topic=" immediately in front of the "html/" part of the link. That will bring up the index page and show the selected topic as the default page in the right-hand pane. For example:

Copy
http://www.ewoodruff.us/shfbdocs/Index.aspx?topic=html/1aea789d-b226-4b39-b534-4c97c256fac8.htm
Tip:

Conceptual content topic files are always named using their GUID as the filename with a ".htm" extension and they are always placed in the html/ folder.

Preliminary

When this property is set to True, it will mark all topics in the help file with a large, red message "[This is preliminary documentation and is subject to change.]". This is a quick and easy way to mark documentation for beta software as preliminary and subject to change.

PresentationStyle

This property is used to choose the presentation style that determines the layout and appearance of the help topics. Sandcastle comes with three styles: VS2005 (the default), Prototype, and Hana. The files for each style are located in the .\Presentation folder under the main Sandcastle installation folder.

Tip:

If you create your own styles, place the folders in the same location and the help file builder will detect them automatically and let you select them in the project. Be sure to include one of the default style names in your folder name as certain build steps are performed differently based on the selected style and this will be the hint that the help file builder uses to determine what action to take.

ProjectLinkType

This property is used to define the type of links used to reference other help topics referring to items within the documented assemblies. It can be set to None which renders non-clickable links, Local (the default) which renders normal links defined with anchor tags, or Index which renders HTML Help 2.x style MS-Help links. The Index option is only useful when generating an HTML Help 2.x help file. If you are building multiple help file formats and need to use Index for the Help 2 file, it will need to be placed in a separate project file.

RootNamespaceContainer and RootNamespaceTitle

The RootNamespaceContainer property is used to specify whether or not a root namespace entry is added to the table of contents to act as a container for the namespaces from the documented assemblies. If set to True, a root Namespaces table of contents entry will be created as the container of the namespaces in the documented assemblies. If set to False, the default, the namespaces are listed in the table of contents as root entries. To change the name of the root container from "Namespaces", enter the new name in the RootNamespaceTitle property.

SdkLinkType and SdkLinkTarget

This property is used to define the type of links used to reference other help topics referring to framework (SDK) help topics. It can be set to None which renders non-clickable links, MSDN (the default) which renders links to the online MSDN help content for the topic, or Index which renders HTML Help 2.x style MS-Help links. The Index option is only useful when generating an HTML Help 2.x help file. If you are building multiple help file formats and need to use Index for the Help 2 file, it will need to be placed in a separate project file.

When set to MSDN, the SdkLinkTarget property is used to define where MSDN links will open in the browser. This property has no effect if the link type is set to None or Index. The default value is Blank to open MSDN links in a new window. It can also be set to Self, Parent, or Top which have the same effect of replacing the current window's content with the content of the MSDN topic. The last two are useful when producing web output as they will cause the MSDN links to replace the frameset with the MSDN topic page.

ShowFeedbackControl

If the presentation style supports a feedback control in the page footer, this property can be used to determine whether or not it is actually shown. This property may be obsolete. It was added for the Sandcastle October 2007 CTP. However, as of the January 2008 release, the feedback control is no longer present. As such, this property may be removed at a later date.

SyntaxFilters

This property lets you specify which languages appear in the Syntax section of the help topics and the languages that will appear in the language filter dropdown. It can be set to one language, a combination of languages, All to include them all, Standard (the default) for C#, VB.NET, and C++ only, or None to remove the Syntax section entirely.

See Also

Other Resources

Project Properties Window


HTML Help 1 and HTML Help 2 Category Properties

[image]

Sandcastle Help File Builder Documentation
HTML Help 1 and HTML Help 2 Category Properties
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This topic contains the following sections.

  • HTML Help 1 Category Properties
    • BinaryTOC
    • IncludeFavorites
  • HTML Help 2 Category Properties
    • CollectionTocStyle
    • HelpAttributes
    • HelpFileVersion
    • IncludeStopWordList
    • PlugInNamespaces
  • See Also

HTML Help 1 Category Properties

The HTML Help 1 category properties control the features of HTML Help 1 (CHM) files.

  • BinaryTOC
  • IncludeFavorites

BinaryTOC

When set to True, the default, a binary table of contents is created for the help file. According to the HTML Help Compiler documentation this can significantly reduce the amount of time required to load a very large help document.

IncludeFavorites

If this property is set to True, a Favorites tab will be included in the compiled help file. By default, it is set to false and only the Contents, Index, and Search tabs are available.

HTML Help 2 Category Properties

The HTML Help 2 category properties control the features of HTML Help 2 (HxS) files.

  • CollectionTocStyle
  • HelpAttributes
  • HelpFileVersion
  • IncludeStopWordList
  • PlugInNamespaces
Tip:

For information on Named URL Index support, see the Named URL Index Support topic. For information on deploying Help 2 files, see the Deploying an HTML Help 2 File topic.

CollectionTocStyle

This property is used to set the collection table of contents style used when the help file content is plugged into an HTML Help 2 collection. If set to Hierarchical (the default), the help file's table of contents entries will be grouped under a container node in the merged table of contents. The HelpTitle property setting is used for the container's title. If set to Flat, the help file's table of contents entries will appear at the root level in the merged table of contents.

Note:

This property will not cause the entries in your help file's table of contents to change from flat to hierarchical. To do that, use the Hierarchical Table of Contents Plug-In.

HelpAttributes

This property represents a collection of additional <MSHelp:Attr> attributes that will be added to the XML data island in each generated API help topic. Click the "..." button to the right of the property when it is selected to open the editor. In it, you can enter a name and value for each additional attribute. Click the Default button to add a default set of attributes (DocSet/NETFramework, DocSet/{@HtmlHelpName}, and TargetOS/Windows). If producing an HTML Help 2 file, you should at least add the default attributes so that filtering is supported. When attributes exist in this property, the Help Attributes Component is automatically added to the Sandcastle configuration file at build time.

For the attribute value, you can specify any of the replacement tags to substitute a project setting at build time. For example, when you add the default attributes, a DocSet entry is added with the value set to {@HtmlHelpName} so that the current HTML Help name value is used.

Be aware that the Sandcastle transformations add ApiLocation, ApiType, DevLang, Locale, and TopicType attributes with appropriate values to each generated API topic so there is no need to add them here.

HelpFileVersion

This property is used to specify the version number that will be applied to the help file. The version number appears when you view the properties of the help file in Windows Explorer. You can set it to match the version number of the product to which the help file belongs. The value is a string which allows you to use custom project properties to define the value (i.e. {@Version} or {@Major}.{@Minor}.{@Build}.{@Revision}). The end result must still evaluate to a valid four-part version number. If not, a build error will occur ( BE0066).

IncludeStopWordList

This property is used to specify whether or not the stop word list will be compiled into the help file. The stop word list is used to identify words that should be omitted from the Help 2 full text search index.

PlugInNamespaces

This property is used to specify a comma-separated list of namespaces that the collection will be plugged into when deployed using H2Reg.exe. The default setting will plug the collection into any help namespace starting with ms.vsipcc or ms.vsexpresscc. See the H2Reg documentation for more information on what namespaces can be used and how to specify them.

See Also

Other Resources

Project Properties Window
Named URL Index Support
Deploying an HTML Help 2 File


Named URL Index Support

[image]

Sandcastle Help File Builder Documentation
Named URL Index Support
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This topic contains the following sections.

  • The Named URL Index
  • AboutPageIcon and AboutPageInfo
  • See Also

The Named URL Index

The HTML Help 2 system supports an index called NamedUrlIndex that makes it possible to customize some display aspects of a Help collection such as which page is displayed when a Help collection is first opened. Index terms are added to the data island within the page to specify the options. The most common ones are shown in the table below.

Index Term | Description
AboutPageIcon | The HTML file that displays the Help About image. See below for an example.
AboutPageInfo | The HTML file that displays product information in Help About. See below for an example.
DefaultPage | The page that appears when a user opens a help collection. This is often the same as the home page.
EmptyIndexTerm | The page that displays when a user chooses a keyword index term that has sub-keywords but is not directly associated with a topic itself.
FilterEditPage | Displays a page that can be used to edit help filters.
HomePage | The page that appears when a uses chooses the Home command or button.
NavFailPage | The page that opens if a link to a topic or URL is broken.

To add a term to a conceptual topic, create or open a content layout file and add the topic to it. In the properties for the topic in the layout file, edit the Keywords property. Select the NamedUrlIndex item as the index and enter one of the terms above in the value column. Add one entry for each term that you want to use.

Note:

If you mark a conceptual topic as the default using the layout designer, the DefaultPage and HomePage keywords are added to the topic automatically at build time. As such, you do not need to specify them in the topic's keywords.

To add a term to an HTML file, add a data island to the page's <head> section if it does not already exist and add an <MSHelp:Keyword> entry with the Index attribute set to NamedUrlIndex and the Term attribute set to one of the index terms above. Specify one entry for each term that you want to use. For example:

CopyHTML Page NamedUrlIndex Example
<head>
<title>Welcome</title>
<xml xmlns:msxsl="urn:schemas-microsoft-com:xslt">
    <MSHelp:Keyword Index="K" Term="Welcome" />
    <MSHelp:Keyword Index="NamedUrlIndex" Term="HomePage"/>
    <MSHelp:Keyword Index="NamedUrlIndex" Term="DefaultPage"/>
</xml>
</head>

AboutPageIcon and AboutPageInfo

These two terms are unique. Both are HTML pages but AboutPageIcon is used to display an image in the Document Explorer About box and AboutPageInfo is used to display product information in the Document Explorer About box. Below are examples of each.

CopyAboutPageIcon.html
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2 Final//EN">
<html xmlns:MSHelp="http://msdn.microsoft.com/mshelp">
<head>
  <meta HTTP-EQUIV="Content-Type"
    Content="text/html; charset=Windows-1252">
  <title>About My Product</title>
  <xml>
    <MSHelp:NoSearch />
    <MSHelp:Keyword Index="NamedUrlIndex" Term="AboutPageIcon" />
  </xml>
</head>

<body scroll="no" topmargin="0" rightmargin="0" bottommargin="0"
  leftmargin="0">
    <img src="Media/MyLogo.jpg">
</body>
</html>
CopyAboutPageInfo.html
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2 Final//EN">
<html xmlns:MSHelp="http://msdn.microsoft.com/mshelp" DIR="LTR">
<head>
  <meta HTTP-EQUIV="Content-Type"
    Content="text/html; charset=Windows-1252">
  <title>About My Product</title>
  <xml>
    <MSHelp:NoSearch />
    <MSHelp:Keyword Index="NamedUrlIndex" Term="AboutPageInfo"/>
  </xml>
  <style type="text/css">
    body { font-family: Verdana; font-size: 65%; margin: 5px; width: 100%; }
  </style>
</head>

<body>
    <p/>Here is some info about My Product.
</body>
</html>

The two HTML pages and the associated image file can be added as content items to the project (set the BuildAction on them to Content). The HTML files can be placed in any folder but if not placed in the root folder, adjust the URL to the image as needed. Set the ExcludeFromToc property to false on the HTML pages to ensure that they are excluded from the table of contents when the help file is built. The image should be placed in the .\Media folder.

You can also include the HTML pages using the content layout designer. If done this way, set the Visible property to false on the HTML pages so that they do not appear in the table of contents. If the image you use is also used in conceptual content, set the image's AlwaysCopy property to true so that it is always copied to the .\Media folder even if the reference in the conceptual content goes away or the page is not included in the layout.

See Also

Other Resources

Deploying an HTML Help 2 File
HTML Help 2 Category Properties


Deploying an HTML Help 2 File

[image]

Sandcastle Help File Builder Documentation
Deploying an HTML Help 2 File
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The HTML Help 2 system maintains a registry of all help collections and titles currently installed on a machine. This registry determines what help titles are included in each help collection as well as maintaining references between the help collections.

Unlike HTML Help 1 (CHM) files, an HTML Help 2 title or collection must be registered in order to view it. This makes deploying HTML Help 2 documentation more complex than simply delivering a single file and creating a shortcut to it. While it is possible to create a Windows Installer package to deploy and register help collections and titles, it is a rather lengthy process and it does not always work as well as it should.

The easiest approach to deploying and registering Help 2 collections is to use the shareware tool H2Reg.exe from The Helpware Group. It is a command line tool that can be included by scripted installers as well as Windows Installer packages as a custom action.

When producing an HTML Help 2 file, the help file builder produces a valid set of collection files and creates a configuration file suitable for use by H2Reg.exe. In order to deploy the generated HTML Help 2 files, follow these steps:

  • Set the PlugInNamespaces project property to a comma separated list of one or more namespaces that your collection should be plugged into when deployed. The default setting will plug it into all available collections. See the H2Reg.exe help file for details about the possible values that can be used.
  • Build the help project.
  • Include all of the generated help files as well as the generated configuration file and the H2Reg.exe executable in your installer.
  • During installation, copy the help files, the configuration file, and H2Reg.exe to their installed location.
  • Execute H2Reg.exe with the following syntax:
    Copy
    H2Reg -r "CmdFile=<Path to the configuration file>"
  • During uninstallation, before the help files are removed, execute H2Reg.exe with the following syntax:
    Copy
    H2Reg -u "CmdFile=<Path to the configuration file>"

Your product's installer can create a shortcut to open your Help 2 file by executing the following command (lines wrapped for display purposes):

Copy
"%CommonProgramFiles%\Microsoft Shared\Help\dexplore.exe"
  /helpcol ms-help://MyProduct.Namespace

Substitute your product's namespace for MyProduct.Namespace in the example above.

See Also

Other Resources

Named URL Index Support
HTML Help 2 Category Properties


Paths Category Properties

[image]

Sandcastle Help File Builder Documentation
Paths Category Properties
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Paths category properties define the location of the tools and the output location of the help file.

  • HtmlHelp1xCompilerPath
  • HtmlHelp2xCompilerPath
  • OutputPath
  • SandcastlePath
  • WorkingPath

HtmlHelp1xCompilerPath

This property lets you specify the path to the HTML Help 1.x help compiler (HHC.EXE). By default, the builder will try to locate it automatically by searching the Program Files special folder on all fixed hard drives. As such, you only need to specify the path if the build fails with a message stating that it could not be found.

HtmlHelp2xCompilerPath

This property lets you specify the path to the HTML help 2.x compiler (HXCOMP.EXE). By default, the builder will try to locate it automatically by searching the Program Files special folder on all fixed hard drives. As such, you only need to specify the path if the build fails with a message stating that it could not be found.

OutputPath

This property lets you specify where the compiled help file should be placed. The default is to store it in a folder called .\Help\ relative to the project folder. It is also the location of the temporary .\Working\ folder used to store the generated build files unless it is changed with the WorkingPath property. This property cannot be set to the same value as the WorkingPath property as the working path folder is cleared prior to the build.

Caution:

Be aware that if an option is selected that produces a website, the output folder specified by the OutputPath property will be cleared of all of its current content without any prompting before the web site content is copied to it. In other words, don't do something stupid like set it to the root of your C: drive or your desktop folder. When producing Help 1 and/or Help 2 files, the output folder is not cleared.

SandcastlePath

This property lets you specify the path to Sandcastle. By default, the builder will try to locate it automatically by extracting its location from the DXROOT environment variable, the system path or, if not found there, by searching the Program Files special folder on all fixed hard drives. As such, you only need to specify the path if the build fails with a message stating that it could not be found.

WorkingPath

This property lets you specify an alternate location with a shorter path in which to perform the build if it fails due to long file path names. If not specified, the working folder will be placed under the output path and will be called .\Working. This property cannot be set to the same value as the OutputPath property as the working path folder is cleared prior to the build.

Caution:

Be aware that the working folder specified by the WorkingPath property will be cleared of all of its current content without any prompting before the build begins. In other words, don't do something stupid like set it to the root of your C: drive or your desktop folder.

See Also

Other Resources

Project Properties Window


Show Missing Tags Category Properties

[image]

Sandcastle Help File Builder Documentation
Show Missing Tags Category Properties
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The following properties are available in the Show Missing Tags category. These define for which help topic elements a red "missing" message will appear if the related tag has not been used where needed or contains no text. These can help you locate help topics that need additional work to fully specify the documentation. In addition to the inserted messages, a warning is written to the log file noting the missing item as well.

Tip:

You can simplify your project comments for derived classes, interface implementations, overridden members, and other members with other common comments by making use of the <inheritdoc /> tag.

  • AutoDocumentConstructors
  • ShowMissingIncludeTargets
  • ShowMissingNamespaces
  • ShowMissingParams
  • ShowMissingRemarks
  • ShowMissingReturns
  • ShowMissingSummaries
  • ShowMissingTypeParams
  • ShowMissingValues

AutoDocumentConstructors

This is used to indicate whether or not constructors are automatically documented if they are missing the <summary> tag and for classes with compiler-generated constructors. Set this to True (the default) to automatically add default text for the <summary> tag on constructors that are missing it and for classes with a compiler-generated constructor. If set to false and ShowMissingSummaries is true, a "missing summary" warning will appear instead. A message is also written to the log file when a constructor is auto-documented.

ShowMissingIncludeTargets

This property lets you indicate whether or not a red "missing" message is inserted into each topic in which an include tag is found. This indicates that the target of the include (either the file or the XPath query) could not be found at the time the assembly was compiled. The default is False to ignore include tags.

Note:

If you are writing C# code, invalid include comment tags are easy to find at the time the assembly is built as the compiler issues a warning (CS1589 or CS1592). The VB.NET compiler does not output a warning, nor does it write the invalid tag to the comments file. As such, this option will have no effect in VB.NET generated XML comments files. The same is true for managed C++ generated XML comments files except the compiler does generate a warning (C4637).

By now you're probably wondering "So, what was the point of adding this property?" Well, somebody requested it and I didn't find out it was only useful with C# XML comments files until after I'd done the work and by then I couldn't be bothered to go back and take out all the code and resource items. So, it's there but off by default.

ShowMissingNamespaces

This property lets you indicate whether or not a red "missing" message is inserted into each namespace topic that is missing its namespace comments. The default is True to add the message. Namespace comments can be added using the NamespaceSummaries project property, by using an external XML comments file, or by using a NamespaceDoc class in your code. See the Comments Category Properties for details.

ShowMissingParams

This property lets you indicate whether or not a red "missing" message is inserted into the help topic for each method parameter that is missing its related <param> tag documentation. The default is True to add the message.

ShowMissingRemarks

This property lets you indicate whether or not a red "missing" message is inserted into the help topic if the <remarks> tag has not been specified for the item. The default is False to ignore items with missing or empty <remarks> tags.

ShowMissingReturns

This property lets you indicate whether or not a red "missing" message is inserted into the help topic if the method returns a value and the <returns> tag has not been specified for the item. The default is True to add the message.

ShowMissingSummaries

This property lets you indicate whether or not a red "missing" message is inserted into the help topic if the <summary> tag has not been specified for the item. The default is True to add the message.

ShowMissingTypeParams

This property lets you indicate whether or not a red "missing" message is inserted into the help topic for each generic type or method type parameter that is missing its related <typeparam> tag documentation. The default is True to add the message.

ShowMissingValues

This property lets you indicate whether or not a red "missing" message is inserted into the help topic for property items that are missing the <value> tag documentation. The default is False to ignore properties with missing or empty <value> tags.

See Also

Other Resources

Project Properties Window


Visibility Category Properties

[image]

Sandcastle Help File Builder Documentation
Visibility Category Properties
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The following properties are available in the Visibility category. These control what appears in the help file and can reduce the help content and get rid of unwanted items, especially when documenting internal and private members. Information is written to the log file detailing how each property affected the build.

Note:

Known Limitations

Many of the properties starting with "Document" are applied after the MRefBuilder tool runs. When the DocumentInternals and/or DocumentPrivates options are set to true, setting one or more of the DocumentInherited* options to false may increase the build time on help files with a large number of topics. If you find that the Applying visibility properties step of the build is taking a very long time, you can set these options to true and use the ApiFilter project option to remove the unwanted members. This is generally much more efficient as MRefBuilder removes the items as it is generating the reflection information file. This also applies to some of the other properties in this category. The trade-off is that you must search for and exclude the items manually in the API filter search dialog box.

ApiFilter

This property represents a collection of items that define an API filter for the MRefBuilder tool. The items in this filter define which elements of a namespace or type should be omitted from the generated reflection information file and thus the resulting help file. This is useful for excluding unwanted types and members, especially those generated by the compiler, and inherited base class members. Namespaces excluded in the NamespaceSummaries property and items containing an <exclude /> tag are automatically added to the API filter at build time. If there is a conflict between these items and the API filter, the API filter will take precedence and a warning is written to the log file to note the conflict. See the API Filter Property topic for more details on how to use this property.

DocumentAttributes

When set to false, the default, the help builder will strip all attribute information from the documented items so that they do not appear in the syntax section of each class, property, method, etc. in the compiled help file. When set to true, the attribute information is left intact and will appear in the help file. The attributes ExtensionAttribute, FlagsAttribute, SerializableAttribute, ObsoleteAttribute, and several special attributes used by AjaxDoc and Script# are always included regardless of this property's setting as they provide important information about the types and members to which they are applied or are used by other components such as the syntax generators.

DocumentExplicitInterfaceImplementations

When set to false, the default, explicit interface implementations are removed from the help file. This includes explicit implementations in base classes so that they do not appear in the class members help pages. Set this property to true to include them in the help file.

DocumentInheritedFrameworkInternalMembers

When set to false, the default, all inherited .NET Framework members that have internal (Friend) visibility (any internal members starting with "System." or "Microsoft.") are removed from the class members help pages. This can be useful when documenting internal or private members to help reduce clutter. For this option to work, DocumentInheritedFrameworkMembers and DocumentInternals must also be set to true. When this property is set to true, internal framework members are included.

DocumentInheritedFrameworkMembers

When set to true, the default, all inherited .NET Framework members of the class (any members starting with "System." or "Microsoft.") are listed in the class members help pages. When set to false, all inherited .NET Framework class members are removed from the class members help pages. This can be useful when documenting internal or private members to help reduce clutter. For this option to work, DocumentInheritedMembers must also be set to true. When it is set to false, all framework members are removed.

DocumentInheritedFrameworkPrivateMembers

When set to false, the default, all inherited .NET Framework members that have private visibility (any private members starting with "System." or "Microsoft.") are removed from the class members help pages. This can be useful when documenting internal or private members to help reduce clutter. For this option to work, DocumentInheritedFrameworkMembers and DocumentPrivates must also be set to true. When this property is set to true, private framework members are included.

DocumentInheritedMembers

When set to true, the default, all inherited members of the class are listed in the class members help page. When set to false, all inherited members including inherited .NET Framework class members are removed from the class members help pages. This can be useful when documenting internal or private members to help reduce clutter.

DocumentInternals

When set to false, the default, the help builder will not document any internal (Friend) members of classes in the documentation assemblies. When true, the help builder will add the /internal+ command line option to MRefBuilder so that it does include documentation for internal class members. Because they share a similar visibility, protected internal members will be left in the help file when this is set to true even if the DocumentProtected property is set to false. Also note that this property works independently of the DocumentPrivates property below.

DocumentPrivateFields

When set to false, the default, the help builder will not document any private fields of classes in the documentation assemblies. Since most private fields back properties or represent items such as controls on forms, they usually do not have comments and can significantly clutter the resulting help file with unwanted entries. Leaving this option set to false can eliminate the problem. When set to true, the private fields are included in the help file. To work, the DocumentPrivates property must also be set to true.

DocumentPrivates

When set to false, the default, the help builder will not document any private members of classes in the documentation assemblies. When true, the help builder will add the /internal+ command line option to MRefBuilder so that it does include documentation for private class members. Also note that this property works independently of the DocumentInternals property above.

DocumentProtected

When set to true, the default, the help builder will document all protected and protected internal members of classes in the documentation assemblies. When false, the help builder will remove them from the help file including those inherited from base .NET framework classes (those starting with "System." and "Microsoft."). Because they share a similar visibility, protected internal members will be left in the help file when the DocumentInternals property is set to true even if this property is set to false.

DocumentProtectedInternalAsProtected

When set to false, the default, the help builder will document all protected internal members of classes in the documentation assemblies without modification. When true, the help builder will alter protected internal members so that they are listed as protected only in the help file. If DocumentProtected is set to false, this option is ignored.

DocumentSealedProtected

When set to true, the default, the help builder will document all protected members of sealed classes in the documentation assemblies. When false, the help builder will remove all protected members from sealed classes so that they do not appear in the help file. To work, the DocumentProtected property must also be set to true.

See Also

Other Resources

API Filter Property
Project Properties Window


API Filter Property

[image]

Sandcastle Help File Builder Documentation
API Filter Property
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The API Filter editor provides a form used to choose the API topics that will appear in the help file. It allows you to include or exclude namespaces, types, and members from the documented assemblies as well as those from inherited .NET Framework and third-party dependency assemblies. To access it, select the ApiFilter project property and click the "..." button that appears to the right of the property. When selected, the following dialog box appears.

This topic contains the following sections.

  • The API Tree
  • Including and Excluding Members
  • Searching for Members
  • The Search Options
  • See Also

The API Tree

When first opened, there is a slight delay as a partial build of the project is performed in order to generate a list of the API members that can appear in the help file. A tree view containing the API members appears on the left side of the dialog. The tree contains two root nodes. The first, Documented APIs, contains all members from the documented assemblies that can appear in the help file. This list is based on the current project settings. Members excluded by the other Document* project properties in the Visibility category will not appear here. The second root node, Inherited APIs, lists the base classes from which the documented APIs inherit. This list will include classes from the base .NET Framework and other third-party dependency assemblies. Information from these classes will appear on the member list pages for each of the documented classes. By unchecking items in this set of classes, you can remove unwanted members that may otherwise clutter the member list pages.

You will notice that some tree nodes are in italic text. This indicates that the node cannot be unchecked by you. Hovering the mouse over the node will show a tooltip describing why it cannot be unchecked. The reasons include:

  • It is one of the two root nodes. These are general containers and cannot be unchecked.
  • It is a namespace that contains a set of inherited types from the .NET Framework or a dependency assembly. These namespaces will not be represented in the help file. You may exclude individual inherited classes from the namespace as well as inherited class members to control what information appears in a documented class's member list page.
  • A namespace is excluded via the NamespaceSummaries property or an item is excluded because its XML comments include an <exclude /> tag. This information is merged automatically with the API filter settings. To alter these items, you will need to use the NamespaceSummaries property or remove the tag from the item's XML comments.

An icon appears next to each node that provides information about what it represents and its visibility. These icons correspond to the search options in the upper right side of the dialog. Public members show the basic icons from Namespaces through Fields. Protected, internal, and private members will show a combination of the basic icon plus the appropriate visibility icon. The names of the items will appear as they do in the help file. One difference is that parameter information and any overloaded members are not listed. This is because the API filter only goes by name. Parameter information is not used. As such, if one overloaded member is excluded, all overloaded members are excluded.

Including and Excluding Members

All checked items will appear in the help file. To exclude an item, simply uncheck it. Checking or unchecking a namespace or type will automatically check or uncheck all of its nested members as well. On a similar note, if you uncheck a majority of the members of a namespace or type, you may notice that the parent node is also unchecked. Checking a majority of the members will cause the parent node to also become checked. This behavior is normal and is done to produce a more efficient API filter.

Searching for Members

The search options appear in the upper right side of the dialog. To search for an item, simply type some text in the search text box, set the filter options as needed, and click the Find button. The search results will appear in the list view below the options. The Members Found column lists the name as it will appear in the help file. The Full Name column lists the item's full name including the namespace and type information. The items are grouped by namespace and type in alphabetical order. Documented API matches are listed first followed by matches from the inherited APIs. The search text can be as simple as a fragment of a member name or it can be a regular expression used to find more complex patterns. See The 30 Minute Regex Tutorial for a brief introduction to regular expressions and how to use them. See the .NET Framework Regular Expressions topic on MSDN for complete details about the various regular expression elements and options. A few simple search examples are show in the table below.

Search Expression | Description
project | Find members containing the text "project".
^To | Find members starting with "To".
\d$ | Find members ending with a digit.
s{2}$ | Find members ending with two occurrences of the letter "s" (and/or uppercase "S" as well if case-insensitive).
File(Path|Folder) | Find members containing "File" followed by either "Path" or "Folder".
^FilePath$ | Find members named "FilePath" exactly.
SandcastleBuilder\.Utils.*Project | Find any member in a namespace starting with "SandcastleBuilder.Utils" containing the text "Project" (when the "Fully-qualified" option is enabled).

In the absence of any regular expression operators, the search will return all members containing the specified text as shown in the first example.

The Search Options

The following options affect how the search is performed and the results that it will return. By default, the searches are case-insensitive, only search the member names as displayed in the tree view, and include members of all types and visibility in the results.

Option | Description
Case-sensitive | Check this box to make the searches case-sensitive. By default, searches are case-insensitive.
Fully-qualified | By default, searches only match text in the member name displayed in the tree view. By checking this option, you can search the fully-qualified names instead (full namespace, type, and member name).
Namespaces | Include namespaces in the search results.
Classes | Include classes in the search results.
Structures | Include structures in the search results.
Interfaces | Include interfaces in the search results.
Enumerations | Include enumerations in the search results. Note that you can search for enumerations by name or for members of the enumerated type. The individual members of the enumerated type are classed as fields and do not appear in the tree though.
Delegates | Include delegates in the search results.
Constructors | Include constructors in the search results.
Methods | Include methods in the search results.
Operators | Include operators in the search results (i.e. Equality, Inequality, GreaterThan, etc.).
Properties | Include properties in the search results.
Events | Include events in the search results.
Fields | Include fields in the search results. The individual members of enumerated types are included in this category as well.
Public | Include public members in the search results.
Protected | Include protected members in the search results.
Internal | Include internal members in the search results. These will only be present if the DocumentInternals project property is enabled.
Private | Include private members in the search results. These will only be present if the DocumentPrivates project property is enabled.

Double-clicking on a member in the search results or clicking the Goto button below the list will take you to the selected member in the tree view. You can select multiple members in the search results by clicking and dragging the mouse or by using the keyboard. Clicking Include or Exclude will include (check) or exclude (uncheck) all of the currently selected members in the search results. To clear the API filter and set it back to its default state, click the Reset button.

See Also

Other Resources

Visibility Category Properties
Project Properties Window


Text Editor Window

[image]

Sandcastle Help File Builder Documentation
Text Editor Window
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The general text editor window is used for editing various file types such as MAML topics, HTML files, stylesheets, XML files, etc. It provides various features that make editing the files easier such as color syntax highlighting, automatic closing tag insertion, matching character insertion for quotes and parentheses, and various options to perform common actions such as HTML encoding text and inserting common MAML elements.

Tip:

For most commands that insert MAML elements, both from the toolbar and the keyboard shortcuts, if any text is currently highlighted when the command is executed, the selected text will be wrapped in the inserted element. This also applies when a topic is dragged and dropped from the content layout editor onto selected text to create a link. The selected text will become the link's inner text.

  • Toolbar Options
  • Keyboard Shortcuts
  • Drag and Drop
  • Preview Topic

Toolbar Options

The toolbar at the top of the window provides access to some of the most common options. They are (from left to right):

Text Editor Window
  • Bold - Insert a legacyBold element.
  • Italic - Insert a legacyItalic element.
  • Underline - Insert a legacyUnderline element
  • Code Inline - Insert a codeInline element.
  • Bulleted List - Insert a bulleted list element with two default listItem elements.
  • Numbered List - Insert a numbered list element with two default listItem elements.
  • Table - Insert a table element with a default table header and row.
  • In-page link - Insert a link element with an in-page address target (i.e. the value of another element's address attribute within the same page).
  • External link - Insert an externalLink element for linking to an outside target such as a website.
  • Various elements dropdown - The dropdown will allow you to insert various other common MAML elements. The ones above the divider are block elements. The rest below it are inline elements. If the toolbar button is clicked, the default action is to insert the last selected element from the dropdown. By default, it inserts an alert element.
  • HTML Encode - HTML encode the currently selected text. This is useful for inline code samples within code elements or URLs containing restricted characters such as ampersands.
  • Cut, Copy, and Paste - Standard Windows clipboard cut, copy, and paste operations.
  • Undo and Redo - Undo and redo edits.

Keyboard Shortcuts

The text editor supports various common keyboard shortcuts such as Ctrl+C for copy and Ctrl+V for paste. In addition, the following keyboard shortcuts can be used:

  • Ctrl+B - Insert a legacyBold element.
  • Ctrl+I - Insert a legacyItalic element.
  • Ctrl+U - Insert a legacyUnderline element
  • Ctrl+K - Insert a codeInline element.
  • Ctrl+F - This opens the Find Text tool window. If already open and search text has been entered, hitting Ctrl+F again finds the next occurrence of the search text.
  • Ctrl+H - This opens the Find and Replace tool window. If already open and find and replace text has been entered, hitting Ctrl+H again replaces the last instance found if the cursor is still on it and finds the next occurrence of the search text.
  • Ctrl+G - This opens the Goto Line tool window. Enter a line number and click OK to jump to the specified line number in the document.
  • Tab - If you are within an XML element's opening tag, the closing element will be inserted automatically and the cursor will be placed between them ready to enter the inner text.
  • Matching characters - When you type a double quote, an opening parentheses, an angle bracket ('<'), a square bracket ('['), or a curly brace ('{'), the matching closing character is inserted automatically and the cursor is placed between them.

Drag and Drop

The text editor window also supports drag and drop operations from the Content Layout Editor and the Site Map Editor to insert links to other topics in the project. It also supports drag and drop from the Entity References Window to insert token references, image links, code entity reference links, and code snippet references.

By default, links to MAML topics are inserted as self-closing link elements and will use the topic's title from the content layout file when converted to HTML at build-time. If necessary, you can modify the link element to specify inner text which will be used instead of the title text. Dropping the link on some selected text will automatically make the selected text the inner text of the link.

Preview Topic

When editing a conceptual content MAML topic, the help file builder allows you to quickly see how your edits will look in the help file by previewing the built topic in a separate window. To do so, select the Preview Topic option on the Window menu, click the related main toolbar button, or hit F5. Changes to the active topic and any open content layout files are saved automatically and a quick build of just the conceptual content is performed. If successful, the active topic is displayed so that you can see the effects of recent changes. If the build fails, the build log is displayed so that you can locate and fix the problem (i.e. an ill-formed XML element). Only one preview pane is created and it will be reused if you preview another topic.

To keep the build time down, reference links are disabled and it only displays the selected topic. As such, you will not see a table of contents and code entity reference links will appear as bold text in the rendered topic. However, links to other conceptual topics are enabled and you can click on them to navigate to the selected topics. The Alt+Left and Alt+Right keys can be used to navigate backward and forward if you do click on any of the links.

See Also

Other Resources

Getting Started
Conceptual Content
Entity References Window
Content Layout File Editor
Site Map File Editor


Entity References Window

[image]

Sandcastle Help File Builder Documentation
Entity References Window
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Entity References window allows you to insert MAML elements into conceptual content topics that represent tokens, images, code entities (API members), and code snippets.

Entity References Window

The dropdown in the toolbar allows you to select which type of reference to insert. The button to the right of the dropdown allows you to refresh the selected references if you make changes to the project such as adding a new image or token file. The Find textbox allows you to search for an item by ID. Tokens, images, and code snippets perform a case-insensitive search for the entered ID and select it if found. For code entities, a regular expression search is performed using all member IDs found in the project's XML comments files and the .NET Framework comments files. To insert a reference from the list into a topic, either double-click it or drag and drop it into the topic. The references that can be inserted are as follows:

Tokens
When this is selected, a list of all tokens grouped by their containing token file is shown. In order to be listed, the file must have a BuildAction of Tokens. When inserted into a topic, the selected ID is wrapped in a token element.
Images
When this is selected, a list of all conceptual content image files is shown. To appear, the file must have a BuildAction of Image. When inserted into an HTML file, the image reference will be inserted as an HTML img element. When dropped in a MAML topic, a context menu will appear that lets you insert the reference as a mediaLink, mediaLinkInline, or an externalLink element.
Code Snippets
When this is selected, a list of all code snippets grouped by their containing code snippet file is shown. In order to be listed, the file must have a BuildAction of CodeSnippets. When inserted into a topic, the selected ID is wrapped in a codeReference element.
Code Entities

When this is selected, all XML comments files plus the .NET Framework comments files are indexed to obtain a list of possible API members that can be used as code entity references. Due to the large number of elements, they are not listed. Instead, enter some text or a regular expression in the Find textbox and hit Enter to list all members that match the search text.

When inserted into an HTML file, the entity reference will be inserted as an XML comment see element. Note that these will only be resolved to a clickable link if the item references a member found in your code. It will not create links to .NET Framework members in HTML files. When dropped in a MAML topic, the entity reference will be inserted as a codeEntityReference element. When the help file is built, these will be resolved to links that will take you to the help page for that item (i.e. the API member help page for your classes or MSDN Online help pages for .NET Framework members).

See Also

Other Resources

Getting Started
Build Actions
Conceptual Content


Conceptual and Additional Content

[image]

Sandcastle Help File Builder Documentation
Conceptual and Additional Content
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

In versions of the help file builder prior to version 1.7.0.0, the additional content properties were used to add files to the project to define additional help content that would appear in the table of contents and to add other items such as image files and additional stylesheets. As an alternative to basic HTML files, you could also create XML files with a .topic extension that would be ran through an XSL transformation to give them the basic look and feel of the presentation style that was selected. However, using the basic transformations, the topics lacked several features present in the reference content such as collapsible sections and the language filter and they could not take advantage of build components to resolve links to reference and online content.

Starting with version 1.7.0.0, the help file builder supports conceptual content. This is similar in nature to additional content in that it allows you to add non-reference content to the help file that will appear in the table of contents. However, instead of HTML files or .topic files that contain HTML, conceptual content uses topic files that contain Microsoft Assistance Markup Language (MAML). This is basically XML conforming to a well defined schema that describes the structure of the conceptual content much like XML comments describe the structure of the code comments. There is no layout or style information within the MAML files. Instead, they are ran through a series of XSL transformations using Sandcastle's BuildAssembler tool similar to the reference (API) content so that they match it in appearance and features.

MAML is quite different than HTML but it does offer many of the same capabilities. The main difference is that the XSL transformations are responsible for applying the style and formatting, not the elements in the MAML topics. It does take some getting used to but the end result is well worth it. The look of the conceptual topics is much more consistent with that of the reference topics. As such, preference will be given to conceptual content when adding features to the help file builder. While it will continue to support the older additional content models, they will not receive any further enhancements.

See Also

Other Resources

Conceptual Content
Additional Content


Conceptual Content

[image]

Sandcastle Help File Builder Documentation
Conceptual Content
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Conceptual content is similar in nature to the additional content used in prior versions of the help file builder. It allows you to define non-API documentation that is included in the help file for usage notes, walkthroughs, tutorials, etc. Instead of HTML, conceptual content topics use Microsoft Assistance Markup Language (MAML). This is basically XML conforming to a well defined schema that describes the structure of the conceptual content much like XML comments describe the structure of the code comments. There is no layout or style information within the MAML files. Instead, they are ran through a series of XSL transformations using Sandcastle's BuildAssembler tool similar to the reference (API) content so that they match it in appearance and features. This allows you to utilize the various build components to alter and extend the presentation style of the topics.

Tip:

A guide to using MAML with Sandcastle is available at the Sandcastle Styles project on CodePlex. Click on the Sandcastle MAML Guide link on the main project page to access it.

Tip:

If you need to convert HTML topics to MAML topics, the HTML to MAML Converter is also available at the Sandcastle Styles project website.

Conceptual Content Files

Conceptual content is composed of several different file types within a project. You can use folders within the project to group these files as you see fit.

  • Content layout files define which topics are included in the help file and how they are arranged in the help file's table of contents. Content layout files have a BuildAction of ContentLayout.
  • Topic files contain the MAML that defines each topic. These files should have a BuildAction of None. The build process handles converting the topics to HTML and adding them to the help file based on a content layout file.
  • Image files define image resources used in the conceptual content. These have a BuildAction of Image.
  • Token files allow the definition of common MAML snippets or content used in topic files. These have a BuildAction of Tokens.
  • Code snippets files allow you to define code snippets that will be used in conceptual content topics and are rendered by Sandcastle's ExampleComponent. These have a BuildAction of CodeSnippets. See the MAML Guide for more information on creating code snippets files.

Custom Template Files

The designer uses template files to create new conceptual topics. You can create your own templates for use in the designer by creating a Conceptual Templates folder in the Local Application Data folder. Any MAML (.aml) files found in this folder will be added to the Custom Templates menu option in the Add Sibling Topic and Add Child Topic submenus. See the Special Folder Locations topic for more information.

See Also

Other Resources

Conceptual and Additional Content


Content Layout File Editor

[image]

Sandcastle Help File Builder Documentation
Content Layout File Editor
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Adding a content layout file to the project and setting its BuildAction to ContentLayout allows you to specify the conceptual content topics that will be included in the help file and define their layout in the table of contents.

  • The Content Layout Editor Window
  • Available Commands
  • Keyboard Shortcuts
  • Including HTML Files in the Conceptual Content Layout

The Content Layout Editor Window

You can edit the content layout file from within the help file builder by double-clicking it in the Project Explorer window or by selecting the Open option from its context menu. The content layout editor window is shown below.

Content Layout Editor

The top part of the window shows the table of contents as it is currently defined. Entries can be arranged hierarchically to any number of levels. The bottom part of the form shows the properties for the currently selected entry. You can modify the topic's details at any time. Changes are stored automatically before moving off to another topic in the tree. The content layout file identifies conceptual content topics by their unique ID rather than by filename. As such, you are free to rearrange the topic files in the Project Explorer as you see fit and even change their filenames. As long as you do not change the topic's unique ID, it will be correctly associated with its entry in the content layout file. See the Topic Files topic for a description of each of the topic file properties and how they are used.

The Find textbox at the top of the content editor allows you to locate a topic by its unique ID. Enter the ID and hit Enter. If found, the topic with the given ID will be selected in the content pane.

The tree supports drag and drop to re-order the topics. Simply click and hold the left mouse button on a topic and then drag it to its new location. When you drop it on a topic, it is inserted immediately after the target item. If you hold down the Shift key while dropping an item, it will become a child of the target item.

Tip:

Dragging a topic from the content layout editor and dropping it into an editor window containing a MAML file will create a link to the item in the topic that is being edited. When dropped in other file types, the topic's title is inserted into the file.

Available Commands

The toolbar above the tree is used to add, delete, and re-order the topics. These options are also available in a context menu accessed by right clicking within the tree control. The commands (from left to right) and their associated context menu options perform the following actions:

Mark as Default Topic
This will mark the selected topic as the default topic for the help file. The default topic option acts as a toggle. Click it once on a topic to set it as the default. Clicking it again on the same topic turns it off and no topic will be selected as the default topic. In such cases, the root namespaces page will be the default topic for the help file.
Split Table of Contents
This is used to indicate that the table of contents should be split by the API content. It is only valid on table of contents entries that appear at the root level. All table of contents entries prior to the entry with this marker will appear before the API content. The entry with the marker and all entries following it will appear after the API content.
Move Up
This will move the selected topic up in the order of topics at the same level as the selected topic. Note that moving a topic will also move its sub-topics. Sub-topics will still remain in their given order below the parent topic.
Move Down
This will move the selected topic down in the order of topics at the same level as the selected topic. Note that moving a topic will also move its sub-topics. Sub-topics will still remain in their given order below the parent topic.
Add Sibling Topic

This will add a new topic at the same level as the currently selected topic. The sub-options for this command allow you to add a new topic file, add an existing topic file, add all topic files from an existing folder, or add an empty container node.

Note:

Adding a topic to the content layout file will automatically add its related file to the project if it is not already there. Adding all files from a folder will add all topic files found recursively. The folder structure will be duplicated in the table of contents layout.

Add Child Topic
This will add a new topic as a child of the currently selected topic. The sub-options for this command allow you to add a new topic file, add an existing topic file, add all topic files from an existing folder, or add an empty container node.
Delete

Delete the selected topic and all of its sub-topics.

Note:

Deleting a topic from the content layout file will not delete its related file from the project. Use the Project Explorer to physically delete the file from the project and the file system.

Cut
Cut the selected topic and its sub-topics to the clipboard. A copy of the topic is made and it is then removed from the tree.
Paste
If a topic has been cut to the clipboard, you can click the Paste button to add it to the tree. If you just click the button, the topic is added as a sibling of the currently selected topic immediately following it. If you select the Paste as Child sub-option, the topic is inserted as a child of the selected topic.
Edit File
Edit the selected content file. Double-clicking a topic in the tree will also open it for editing.

The context menu for topics also contains the following additional options:

Associate Topic File
The layout file tracks topics by their unique ID rather than by filename. This option allows you to associate a different topic file with a content layout file entry or add an association to an empty container node.
Clear Topic Association
This option allows you to clear the topic file associated with a content layout file entry converting it into an empty container node. The node will not have a topic associated with it in the compiled help file and simply serves as a container for other topics. It must have at least one child topic defined for it.
Refresh Associations
If you move one or more files around or rename them in the Project Explorer, the currently open content layout file editor will not be aware of these changes. Use this option after making such changes so that the content layout editor refreshes the files associated with each topic. This allows you to open them for editing from the layout editor after moving or renaming them without closing and reopening the layout editor.
Copy as Topic Link
Copy a link to the topic to the clipboard. If pasted into a MAML file, a link element is inserted that will link to the selected topic. If pasted into any other file type, the topic's title is pasted into the file.
Sort Topics
Sort the topics alphabetically by title within the currently selected topic's group.

Keyboard Shortcuts

The following keyboard shortcuts can also be used in the content list to execute the various commands:

  • Context Menu Key - Display the context menu.
  • Delete - Delete the selected topic.
  • Ctrl+U - Move the selected topic up within its group.
  • Ctrl+D - Move the selected topic down within its group.
  • Ctrl+X or Shift+Delete - Cut the selected topic to the clipboard.
  • Ctrl+V or Shift+Insert - Paste the topic on the clipboard as a sibling of the selected topic.
  • Ctrl+Alt+V or Shift+Alt+Insert - Paste the topic on the clipboard as a child of the selected topic.
  • Ctrl+C - Copy a link to the selected topic to the clipboard. Performing a paste operation in a text editor window will insert a link to the copied topic.
  • Ctrl+E - Edit the selected topic.

Including HTML Files in the Conceptual Content Layout

Normally, conceptual content will consist of XML files containing MAML. However, the help file builder also supports including HTML files in the content layout file. If you choose to include HTML files, there are some conditions to be aware of and some requirements to be met:

  • Each HTML topic included in a content layout file must have two meta elements in the head section that define the file's unique ID and revision number. For example:
    Copy
    <head>
  <title>Demo Topic</title>
  <meta name="id" content="64e3dc97-5125-541e-9e84-7f9303e95f27">
  <meta name="revisionNumber" content="1">
</head>
  • While you are free to arrange and name your conceptual topic files in any manner you like to make maintenance easier, all files will end up in the .\html folder and the folder structure will not be replicated.
  • In addition, all files will be named using their unique ID. As such, when referencing other topics in HTML files, you should not include any folder in the links to them and you should use their ID value with a .htm extension as the link target. You can use the drag and drop feature to create links to topics.
Tip:

Unless you have a specific reason for using HTML files, it is recommended that you convert them to MAML. An HTML to MAML converter can be downloaded from the Sandcastle Styles project website.

See Also

Other Resources

Conceptual Content
Topic Files


Topic Files

[image]

Sandcastle Help File Builder Documentation
Topic Files
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Topic files contain Microsoft Assistance Markup Language (MAML) to define non-reference content such as usage notes, walkthroughs, tutorials, etc. MAML topic files have a .aml extension and should have their BuildAction set to None in the Project Explorer. A content layout file is used to determine which topics are included in the compiled help file and sets their layout in the table of contents.

  • Content Layout Properties
  • Topic Filenames and Locations

Content Layout Properties

Each topic is assigned a unique ID that can be referenced in topics using a link MAML element. Changes can be made to the topic properties such as the file associated with the ID and its title text without having to visit each topic in which it is referenced. When creating new topics using the help file builder, templates are used and new ID and revision numbers are assigned automatically.

Note:

The value of the ID assigned to a topic should not be changed. If it is, you will be required to manually locate and update the old ID in all topics that reference it.

Within the content layout editor, each topic contains several properties which are described below.

Property | Description
Id, RevisionNumber, and TopicFilename

These read-only properties display the ID and revision number of the topic and the project file related to the ID. The content layout editor contains options that let you clear the file associated with an entry or associate an existing topic with an entry.

The content layout editor tracks topics by ID rather than by filename. As such, you can rearrange and rename the files in the project without being concerned about updating references to them in the content layout files. As long as the ID remains the same, the same topic will be associated with the entry regardless of where it is moved or what it is named.

If an entry is not associated with a topic file, it will serve as an empty container node for its children and will not display a topic when selected in the help file's table of contents.
Title | This is used as the title for the topic. In addition, it will be used as the table of contents title unless a TocTitle value is specified. It will also be used as the link text unless a LinkText value is specified.
TocTitle | This is used to specify an optional table of contents title for a topic. If not set, the Title value will be used. In some cases, the title may not be appropriate for the table of contents or is too long to be practical. In such cases you can specify shorter or more appropriate text for the table of contents via this property.
LinkText | This property can be used to specify an alternate value to use as the inner text for links. If not set, the Title value will be used. In some cases the title may not be appropriate or may be too long to be practical for links that refer to the topic. In such cases you can specify shorter or more appropriate text for the link via this property. This saves you from having to specify the shorter inner text on each link that uses the topic ID.
Visible | This allows you to specify whether or not a topic will appear in the table of contents. The default is True to show it. If set to False, the topic will be included in the help file but will only be accessible via links in other topics. This is a convenient way of adding content to the help file but limiting the amount of information displayed in the table of contents.
HelpAttributes

This property allows you to add custom MSHelp:Attr attributes to the topic. Attribute values can contain substitution tags which will be converted to their appropriate value at build time.

Tip:

Project-level help attributes in the project HelpAttributes property will be added automatically to each topic at build time and do not need to be added here.

Note:

Attributes will only be added to MAML topics, not HTML files.
Keywords

This property allows you to add MSHelp:Keyword attributes to the help topic to define its index keywords. In the designer for this property, select the index and enter the terms for it. Keyword terms can contain substitution tags which will be converted to their appropriate value at build time.

The most common index used in the "K" index (keywords). The terms consist of one word or a phrase. If you separate two terms with a comma, the first term becomes a group in the index. If that same grouping term appears in other topics, the term that follows the comma in each of them will appear as a child of the grouping term in the help file's index. If your intent is to add two terms to the same index but have them appear as two distinct entries, enter them on two separate rows in the designer.

Tip:

If a topic is marked as the default using the designer, entries for the NamedUrlIndex terms DefaultPage and HomePage are added to it automatically at build time so there is no need to add them via this property.

Note:

Keywords will only be added to MAML topics, not HTML files.

Topic Filenames and Locations

Topic files can be named however you like and can reside in any folder within the project. As such, you can arrange them on disk to match the layout in the table of contents and give them meaningful names to aid in managing them outside of the project and the designer. When the help file is built, all topic files are copied to the help file's .\html folder and are named using their unique ID with a .htm extension. You can use that name to link to the topic from other HTML pages or the XML comments on API members. For example:

CopyLink Examples
Link to a topic from an HTML file in the .\html folder:
<a href="303c996a-2911-4c08-b492-6496c82b3edb.htm">Test Topic</a>

Link to a topic from the root folder:
<a href="html/303c996a-2911-4c08-b492-6496c82b3edb.htm">Test Topic</a>

Link to a topic from another folder:
<a href="../html/303c996a-2911-4c08-b492-6496c82b3edb.htm">Test Topic</a>

See Also

Other Resources

Conceptual Content
Content Layout File Editor


Token Files

[image]

Sandcastle Help File Builder Documentation
Token Files
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

A token is used as a replaceable tag within a conceptual content topic and is represented using a token MAML element. The inner text of the element is a token name. When the help file is built, the token is replaced with its value. They are an easy way to represent common items that you use regularly such as a common phrase or external link. Updating the token's value will cause the new value to be used in all topics in which the token appears.

Token definitions are stored in an XML file. In the help file builder, these files usually have a .tokens extension and will be edited using the editor window shown below. Be sure to set the file's BuildAction to Tokens so that it is included correctly at build time.

Token File Editor

To add a new token, click the Add button. Edit the token name and its content in the fields on the right. The changes to the name and/or content are stored automatically as you move from token to token in the list on the left. To delete a token, click the Delete button.

If you embed MAML elements within a token, you must prefix each element name with "ddue:" (without the quotes) as shown in the example below. If not, the elements are inserted using the default empty namespace and they will not be processed by the Sandcastle transformations.

CopyToken with MAML Elements
<ddue:externalLink>
    <ddue:linkText>Sandcastle Help File Builder</ddue:linkText>
    <ddue:linkUri>http://shfb.codeplex.com</ddue:linkUri>
</ddue:externalLink>

The token value can contain help file builder substitution tag references. See the Customizing the Build Process topic for a list of the possible replacement tag values.

See Also

Other Resources

Conceptual Content


Additional Content

[image]

Sandcastle Help File Builder Documentation
Additional Content
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This topics in this section describe the additional content support provided by the help file builder.

Additional Content Support

Additional content support is similar in nature to the NDoc properties AdditionalContentResourceDirectory, FilesToInclude, RootPageFileName and RootPageTOCName. However, the help builder's implementation provides the following added benefits over NDoc:

  • Files are added to the project directly. The folder structure of the files in the project becomes their layout in the compiled help file. Files at the root of the project are copied to the root of the compiled help file. Files in subfolders are copied recursively to like-named subfolders in the compiled help file.

    Tip:

    By adding a file to the project with a name that matches a stock content file in a folder that matches the folder of the stock content file, you can replace that stock content file. For example, by adding a folder called styles\ to the project and placing a file in that folder called Presentation.css, you can replace the default stylesheet used by the selected presentation style.

  • Additional and conceptual content entries can be placed at the top of the table of contents ahead of the namespace entries or at the bottom after the namespace entries using the project-level ContentPlacement property. The namespace entries can also split the additional content items so that some appear before and some after them using a special tag in one of the files or by using a site map file.
  • If no additional content is present or none is marked as the default topic, the root namespaces page will be selected as the default topic for the help file.

This implementation provides a great deal of flexibility and finer control over the layout of the table of contents and inclusion of additional content items.

Deprecated Features

Note:

The additional content model of adding extra content to a help file has been deprecated. While it will continue to be supported and will not be removed, it will not receive any more features or updates. Going forward, conceptual content is the preferred method of adding non-reference content to the help file. As noted above, the additional content feature can still be use to override stock content and add supporting files to the help file.

  • Code samples in <pre> elements can be colorized.
  • Code samples can be imported using the <code> element and specifying the custom source attribute.
  • For finer control over the layout of the table of contents entries for the additional content, a site map file can be defined. This allows you to create a table of contents structure that differs from the physical folder layout of the additional content items. One or more site map files can be specified by adding them to the project and setting their BuildAction to SiteMap. The SortOrder property on each site map file item can be used to specify the order in which the content from the site maps is merged into the table of contents. Site map files are also editable from within the help file builder's GUI.
  • When no content site map file is specified, all HTML files (*.htm and *.html) and transformable topic files (*.topic, see below) are automatically added to the table of contents unless their ExcludeFromToc property is set to True. Subfolders below the source folder containing HTML files automatically create folder entries in the table of contents. As such, it is fairly simple to create a hierarchy of entries in the help file table of contents based on the folder structure of the additional content items.
  • Files with a .topic extension will be processed using an XSL transformation to convert them to HTML files. If a file is found in the project that has a BuildAction of TopicTransform, that file will be used as the XSL transformation. If no such files exist in the project, a default transform based on the currently selected presentation style will be used instead. See the Topic File Transformation topic for more information.
  • The help file builder scans each HTML file for some special comment tags. The comment tags can be used to indicate the default topic, exclude a file from the table of contents, and set the sort order of items within the table of contents group.
  • The help file builder will also scan the HTML files for XML comment style <see> tags and will replace them with links to the appropriate help file content (i.e. methods, properties, etc).

See Also

Other Resources

Conceptual and Additional Content


Replacing Stock Content

[image]

Sandcastle Help File Builder Documentation
Replacing Stock Content
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

A benefit of the additional content implementation is that it is possible to replace the stock content that appears in each help file. The stock content is copied from the Sandcastle installation folder and consists of the following:

  • The icons\ folder contains stock help file images (i.e. for property icons, method icons, etc).
  • The scripts\ folder contains stock JavaScript files.
  • The styles\ folder contains stock style sheets.

In addition, the html\ folder is created to contain the help pages generated from the documented assemblies and conceptual content. By adding an additional content entry to the project that resides in a like-named folder and has the same filename, you can replace the default entry of the same name. For example, you can customize the style sheet to modify the default font size, change the hyperlink style, etc. To make the custom style sheet replace the stock copy, add a styles\ folder to the project and place a copy of your file in the folder and call it Presentation.css.

See Also

Other Resources

Additional Content


Syntax Highlighting <pre> Tag Content

[image]

Sandcastle Help File Builder Documentation
Syntax Highlighting <pre> Tag Content
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The help file builder allows you to add custom attributes to the <pre> tags in additional content HTML pages to specify how the text should be colorized. The same attributes defined for the code block component can be used on <pre> tags with the exception of the source and region attributes. For the remaining attributes, the lang attribute must appear or they will be ignored. If the keepSeeTags attribute is used, be aware that additional content files can only resolve links to help file topics, not online MSDN content. See the Code Block Component help topic for details. Below is an example.

CopyAs specified in the HTML
<pre lang="cs" numberLines="true" outlining="true"
  title="Example of Syntax Highlighting">
#region Collapsible region
// Test method
public void TestMethod(string s, int x)
{
#if DEBUG
    // Debug code
    x = x + 1;
    s = x.ToString();
#else
    // Release code
    x = x + 5;
    s = x.ToString();
#endif

    Console.WriteLine("The string = " + s);
}
#endregion
</pre>

As rendered with colorizing and collapsible regions:

CopyExample of Syntax Highlighting
 1+Collapsible region 1-#region Collapsible region
 2 // Test method
 3 public void TestMethod(string s, int x)
 4 {
 5 #if DEBUG
 6+... 6-    // Debug code
 7     x = x + 1;
 8     s = x.ToString();
 9 #else
10+...10-    // Release code
11     x = x + 5;
12     s = x.ToString();
13 #endif
14
15     Console.WriteLine("The string = " + s);
16 }
17 #endregion

See Also

Other Resources

Importing and Colorizing Code from Source Files
Additional Content


Importing and Colorizing Code from Source Files

[image]

Sandcastle Help File Builder Documentation
Importing and Colorizing Code from Source Files
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The help file builder allows you to import source code into an additional content HTML page and colorize it using the <code> tag. It supports the same colorizer options as the <pre> tag and the CodeBlockComponent. The main difference is that you specify a required source attribute to specify the source code file and an optional region attribute to limit the code to a defined region of the source file. The tag should be self-closing or should contain no content. The lang attribute must also appear in order to specify the language to use for colorizing the code. All other colorizer attributes are optional. The path specified can be relative. If so, it is always assumed to be relative to the project file's folder. See the Code Block Component help topic for option details. Below are several examples of its use.

Copy
<!-- Import an entire file -->
<code lang="xml" source="..\Test.xml" numberLines="true" title=" "/>

<!-- Import a defined region -->
<code lang="vbnet" source="..\Class1.vb" region="Test Region"
    title="Test region from class" /></code>

<!-- A few more examples -->
<code lang="vbnet" source="..\Class1.vb" region="Embedded snippet"
    title="Test region from method" numberLines="true" />

<code lang="cs" source="..\TestClass.cs" region="Methods"
    numberLines="true" outlining="true" />

<code source="..\GenericClass.cs" lang="cs" > </code>

You can also import multiple code snippets into one common colorized code block by nesting them within a pre tag and including the nested="true" attribute. Nested code tags should be flush left or the leading spaces before the tag will be included before the first line of the imported code block. Only the source and region attributes will be utilized. All other attributes that control colorization of the merged code block will be retrieved from the parent pre tag.

Copy
<pre title="Nested code block example" lang="VB.NET">
<code source="..\Class1.vb" region="Snippet #1" nested="true" />
<code source="..\Class1.vb" region="Snippet #2" nested="true" />
</pre>

Literal code can also be mixed in between the nested code tags.

Copy
<pre title="Nested code block example" lang="VB.NET">
<code source="..\Class1.vb" region="Snippet #1" nested="true" />

' ... Some stuff happens here ...

<code source="..\Class1.vb" region="Snippet #2" nested="true" />
</pre>

See Also

Other Resources

Syntax Highlighting <pre> Tag Content
Additional Content


Linking to Namespace Content

[image]

Sandcastle Help File Builder Documentation
Linking to Namespace Content
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The additional content help text may need to link to other topics in the help file such as help pages for a namespace, class, method, property, etc. To provide this ability, the help file builder will scan each HTML additional content file for XML comment style <see> tags. If found, an attempt is made to convert the tag to a link that takes you to the related help page for the indicated item. Some examples are shown below.

Caution:
Deprecated

The additional content model of adding extra content to a help file has been deprecated. While it will continue to be supported and will not be removed, it will not receive any more features or updates. Going forward, conceptual content is the preferred method of adding non-reference content to the help file. The additional content feature can still be use to override stock content and add supporting files to the help file.

Copy
For a list of all classes, see the
<see cref="N:SandcastleBuilder.Utils">SandcastleBuilder.Utils
Namespace</see> topic.

See the help for <see cref="SomeClass.DoesNotExist"/> for
more information.

In this help file, these are rendered as:

  • For a list of all classes, see the SandcastleBuilder.Utils topic.
  • See the help for SomeClass.DoesNotExist for more information.

The first example uses the supplied inner text as the text for the hyperlink. The second example will use the cref value for the text of the hyperlink. The cref value can be a full or partial identifier for an item in any documented namespace as it appears in the reflection.xml file created by Sandcastle. The page names for the namespace items are generated at build time so the help file builder attempts to match the identifier with an entry in the reflection information XML file in order to obtain the correct filename as the target of the hyperlink. If a prefix is supplied on the identifier such as N: (namespace), T: (type), M: (method), etc. as shown in the first example, an attempt is made to find an entry starting with the identifier. If no prefix is supplied, as shown in the second example, an attempt is made to find a match that ends with the identifier. If neither of those returns a match, it searches for any entry that contains the identifier.

Messages are written to the log file indicating how the link was resolved. If no matches are found, a message appears in the log stating that the identifier could not be found and it will be rendered in bold rather than as a link in the help file as is the case with the second example. If a single best match is found, the log message indicates the fully qualified name that was matched and the tag is converted to a link to the associated page in the help file. If multiple matches are found, the log will include a list of all fully qualified names that contained the identifier and the first entry found will be used as the target of the hyperlink.

If a cref attribute appears in any other HTML tag, it will also be resolved and converted to an href attribute. For example, if you have an image map of a class, you could use cref attributes on the area tags to have them resolve to links to the classes represented by the image areas as in the following example.

Copy
<img src="images/TestClass.jpg" width="300" height="300" alt="TestClass"
    usemap="#TestClass" />

<map id="TestClass" name="TestClass">
  <area shape="rect" coords="10,10,10,20"
    cref="TestClass.Method1" alt="Method1" />
  <area shape="rect" coords="20,20,20,20"
    cref="TestClass.Method2" alt="Method2" />
  <area shape="rect" coords="30,30,30,30"
    cref="TestClass.Method3" alt="Method3" />
</map>

See Also

Other Resources

Additional Content


Project Properties and Shared Content

[image]

Sandcastle Help File Builder Documentation
Project Properties and Shared Content
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The help file builder will resolve references to project properties and to items in the SharedBuilderContent.xml and shared_content.xml files. To substitute project properties in the additional content files, place them in a tag as in the following example.

Caution:
Deprecated

The additional content model of adding extra content to a help file has been deprecated. While it will continue to be supported and will not be removed, it will not receive any more features or updates. Going forward, conceptual content is the preferred method of adding non-reference content to the help file. The additional content feature can still be use to override stock content and add supporting files to the help file.

Copy
<@CopyrightInfo/>
<@FeedbackEMailAddress/>

Full Build Date: <@BuildDate/>
Formatted Build Date: <@BuildDate:MMMM d, yyyy a\t hh:mm tt/>

In this help file, these are rendered as:

  • [v1.8.0.2] Copyright © 2006-2009, Eric Woodruff, All rights reserved (http://www.EWoodruff.us)
  • Eric@EWoodruff.us
  • Full Build Date: 05/31/2009 09:28:00 PM
  • Formatted Build Date: May 31, 2009 at 09:28 PM

Any of the values defined in the Customizing the Build Process topic can be used. The only difference is that you must use angle brackets rather than curly braces in the additional content files.

To include shared content items such as the header, preliminary message, comments, copyright, or footer, use an include item as in this example:

Copy
<include item="header"/>
<include item="preliminary"/>
<include item="footer"/>
<include item="comments"/>
<include item="copyright"/>

Note that for some items such as footer, the comments and copyright items are nested within it so there is no need to specify them separately unless you are customizing the footer area. Another benefit to this feature is that the items will appear in the language selected in the project as well.

See Also

Other Resources

Additional Content


Defining the Table of Contents Layout

[image]

Sandcastle Help File Builder Documentation
Defining the Table of Contents Layout
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The following information only applies if a site map file is not defined in the project. When using a site map file, its layout definition overrides all file-level definitions. See the Site Map File Editor topic for details.

Caution:
Deprecated

The additional content model of adding extra content to a help file has been deprecated. While it will continue to be supported and will not be removed, it will not receive any more features or updates. Going forward, conceptual content is the preferred method of adding non-reference content to the help file. The additional content feature can still be use to override stock content and add supporting files to the help file.

All HTML files copied as additional content will automatically be added to the help file's table of contents. Subfolders will also create folder entries within the table of contents and the HTML files within them become children of the folder entry in the table of contents. This makes it fairly simple to create hierarchical content with matching table of contents entries. The table of contents will mimic the folder structure on disk.

The help file builder scans each HTML file for the following tags and specially formatted comments that allow you to define the related properties of the table of contents entries. They can appear anywhere in the file.

  • <title>Page Title</title> - The value from the title tag in the HTML file is used as the title in the table of contents. If no title tag is found, the filename without the path and extension is used as the title.
  • <!-- @TOCExclude --> - This special comment can be used to exclude the page from the table of contents. The file will still be copied to the output folder but will not appear in the table of contents. Instead, a link to it must exist from another help page. This is also useful for setting the title and sort order on folder entries without associating a page with the folder entry in the table of contents. See below for more information.
  • <!-- @DefaultTopic --> - This special comment is used to indicate that the page should be selected as the default topic for the help file. If multiple pages contain this comment, the last one seen will be used as the default topic. If no additional content items are defined or none are marked as the default topic, the root namespaces page is selected as the default topic.
  • <!-- @SortOrder nnn --> - This special comment is used to set the sort order of the item within the group where "nnn" represents an integer value. The "group" is all other additional content table of contents entries at the same level as the current item. In the absence of a sort order indicator, table of contents entries are sorted alphabetically. By specifying a sort order, you can rearrange the entries in a different order. Items within a group that have the same sort order value will also sort alphabetically. Items without a sort order indicator are placed below those with a sort order indicator and are sorted alphabetically.
  • <!-- @SplitTOC --> - This special comment is used to indicate that the table of contents should be split by the API content. It is only valid on table of contents entries that appear at the root level. All table of contents entries prior to the entry with this tag will appear before the API content. The entry with the tag and all entries following it will appear after the API content.

By default, folder entries in the table of contents will not have any HTML page associated with them and will not show a specific page in the help file when selected. The title will be the folder name and they will be sorted alphabetically within the same group of items below any items that have a sort order indicator. You can control these properties for folder entries by placing an HTML file in the folder that has the same name as the folder (i.e. place a file called OtherContent.html in the OtherContent\ folder to set its properties). If the @TOCExclude comment does not appear in the file, the associated page will be displayed when the folder is selected in the table of contents. Below are a couple of examples:

CopyOtherContent\OtherContent.html
<!-- @TOCExclude -->
<!-- @SortOrder 3 -->
<title>Other Content</title>

The example above sets the sort order and title of the folder entry but does not display anything when the folder is selected as it contains the @TOCExclude comment.

CopyFolderWithPage\FolderWithPage.html
<html>
<head>
<title>Folder Entry with a Content Page</title>
</head>

<!-- @SortOrder 2 -->

<body>
This is a content page for a folder entry in the
table of contents.
</body>
</html>

The example above sets the sort order and title of the folder entry and specifies content that will be displayed when the folder is selected as the @TOCExclude comment is omitted. It could also be made the default topic by adding the @DefaultTopic comment.

See Also

Other Resources

Site Map File Editor
Additional Content


Site Map File Editor

[image]

Sandcastle Help File Builder Documentation
Site Map File Editor
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Adding a site map file to the project and setting its BuildAction to SiteMap allows you to define the table of contents layout for the additional content HTML files. This allows you to specify a layout that is different than the physical folder structure of the content files.

Caution:
Deprecated

The additional content model of adding extra content to a help file has been deprecated. While it will continue to be supported and will not be removed, it will not receive any more features or updates. Going forward, conceptual content is the preferred method of adding non-reference content to the help file. The additional content feature can still be use to override stock content and add supporting files to the help file.

  • The Site Map Editor Window
  • Available Commands
  • Keyboard Shortcuts

The Site Map Editor Window

The structure of the site map file is the same as that used for ASP.NET web sites but it only makes use of the title and url attributes on the siteMapNode elements. In addition, it adds a custom isDefault attribute to the default topic element and a custom splitTOC attribute to the topic where the table of contents should be split with API topics appearing above it. For more information on the structure of site map files, see the MSDN ASP.NET Site Maps topic. You can edit the site map file from within the help file builder by double-clicking it in the Project Explorer window or by selecting the Open option from its context menu. The site map editor window is shown below.

Site Map Editor

The top part of the window shows the table of contents as it is currently defined. Entries can be arranged hierarchically to any number of levels. The bottom part of the form shows the properties for the currently selected entry. You can modify the topic's details at any time. Changes are stored automatically before moving off to another topic in the tree. Files defined in the site map do not have to appear as additional content items in the project. Any files in the site map that are not found in the defined additional content items at build time are copied over to the root output folder automatically.

The tree supports drag and drop to re-order the topics. Simply click and hold the left mouse button on a topic and then drag it to its new location. When you drop it on a topic, it is inserted immediately after the target item. If you hold down the Shift key while dropping an item, it will become a child of the target item.

Tip:

Dragging a topic from the site map editor and dropping it into an editor window containing an HTML file will create a link to the item in the topic that is being edited. When dropped in other file types, the topic's title is inserted into the file.

Available Commands

The toolbar above the tree is used to add, delete, and re-order the topics. These options are also available in a context menu accessed by right clicking within the tree control. The commands (from left to right) and their associated context menu options perform the following actions:

Mark as Default Topic
This will mark the selected topic as the default topic for the help file. The default topic option acts as a toggle. Click it once on a topic to set it as the default. Clicking it again on the same topic turns it off and no topic will be selected as the default topic. In such cases, the root namespaces page will be the default topic for the help file.
Split Table of Contents
This is used to indicate that the table of contents should be split by the API content. It is only valid on table of contents entries that appear at the root level. All table of contents entries prior to the entry with this marker will appear before the API content. The entry with the marker and all entries following it will appear after the API content.
Move Up
This will move the selected topic up in the order of topics at the same level as the selected topic. Note that moving a topic will also move its sub-topics. Sub-topics will still remain in their given order below the parent topic.
Move Down
This will move the selected topic down in the order of topics at the same level as the selected topic. Note that moving a topic will also move its sub-topics. Sub-topics will still remain in their given order below the parent topic.
Add Sibling Topic

This will add a new topic at the same level as the currently selected topic. The sub-options for this command allow you to add a new topic file, add an existing topic file, add all topic files from an existing folder, or add an empty container node.

Note:

Adding a topic to the site map will automatically add its related file to the project if it is not already there. Adding all files from a folder will add all topic files found recursively. The folder structure will be duplicated in the table of contents layout.

Add Child Topic
This will add a new topic as a child of the currently selected topic. The sub-options for this command allow you to add a new topic file, add an existing topic file, add all topic files from an existing folder, or add an empty container node.
Delete

Delete the selected topic and all of its sub-topics.

Note:

Deleting a topic from the site map will not delete its related file from the project. Use the Project Explorer to physically delete the file from the project and the file system.

Cut
Cut the selected topic and its sub-topics to the clipboard. A copy of the topic is made and it is then removed from the tree.
Paste
If a topic has been cut to the clipboard, you can click the Paste button to add it to the tree. If you just click the button, the topic is added as a sibling of the currently selected topic immediately following it. If you select the Paste as Child sub-option, the topic is inserted as a child of the selected topic.
Edit File
Edit the selected content file. Double-clicking a topic in the tree will also open it for editing.

The context menu for topics also contains the following additional options:

Copy as Topic Link
Copy a link to the topic to the clipboard. If pasted into an HTML file, an anchor element is inserted that will link to the selected topic. If pasted into any other file type, the topic's title is pasted into the file.
Sort Topics
Sort the topics alphabetically by title within the currently selected topic's group.

Keyboard Shortcuts

The following keyboard shortcuts can also be used in the content list to execute the various commands:

  • Context Menu Key - Display the context menu.
  • Delete - Delete the selected topic.
  • Ctrl+U - Move the selected topic up within its group.
  • Ctrl+D - Move the selected topic down within its group.
  • Ctrl+X or Shift+Delete - Cut the selected topic to the clipboard.
  • Ctrl+V or Shift+Insert - Paste the topic on the clipboard as a sibling of the selected topic.
  • Ctrl+Alt+V or Shift+Alt+Insert - Paste the topic on the clipboard as a child of the selected topic.
  • Ctrl+C - Copy a link to the selected topic to the clipboard. Performing a paste operation in a text editor window will insert a link to the copied topic.
  • Ctrl+E - Edit the selected topic.

See Also

Other Resources

Additional Content


Topic File Transformation
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This topic describes the topic file transformation option.

Caution:
Deprecated

The additional content model of adding extra content to a help file has been deprecated. While it will continue to be supported and will not be removed, it will not receive any more features or updates. Going forward, conceptual content is the preferred method of adding non-reference content to the help file. The additional content feature can still be use to override stock content and add supporting files to the help file.

Topic File Transformation

When copying additional content files, if a file with a .topic extension is encountered, an attempt is made to transform it into a .html file by running it through an XSL transformation. This allows you to apply a common look and feel to the additional content topics that matches the API topics. The build process tries to locate a file item in the project with a BuildAction of TopicTransform and will use it if found. If left blank, a default transformation is used that is based on the currently selected presentation style. It transforms the topics to give them the same style of header and footer as the API topics. Support is also included for adding a logo to the page header. Additional features such as the language filter are not supported. If you decide that you need to add additional features or replace the transformation, you can do so by creating a file and adding it to the project with a BuildAction of TopicTransform.

The Default Transformations

Three default transformations (Hana.xsl, Prototype.xsl, and VS2005.xsl) are supplied. The .topic files are XML files that contain the following elements.

Element | Description
topic | This is the root element and there should only be one in the file. All other elements are children of this one.
title | This element defines the title for the topic.
headerTitle | This is an optional element that defines the text that appears above the topic title. If not defined, the help file's title is used as defined by the project's HelpTitle property.
logoFile | This element can be used to add an optional logo to the topic. If you do not want a logo, you can omit this element. The filename attribute defines the path to the logo file. This path is the actual path relative to the root of the generated help content. The file itself should be defined as additional content so that it is copied to the appropriate location. For topics in folders, you do not need to add relative path indicators (i.e. ../) as a variable is passed to the transform that will set the appropriate path to the root automatically (see below). The height and width attributes can be used to specify the height and width of the image. If omitted, the image will be displayed using its actual size. By using these attributes, you can scale a larger image down or scale a smaller image up to get a better fit. The altText attribute lets you specify some alternate text that can appear for the image. The placement attribute allows you to specify where the image is placed (to the left, to the right, or above the topic title). When set to above, the alignment attribute specifies how the image is aligned (left, right, or centered).
styleSheet | This element can be used to define an additional stylesheet to include in the transformed topic. This is useful for adding styles for HTML tags that are not present in the selected presentation style's default stylesheet such as h1, h2, etc. The filename attribute identifies the stylesheet and the same comments above regarding the logo file's path and inclusion as additional content apply here as well. If no additional stylesheet is needed, you can omit this element.
xml | This element is used to add an optional XML data island to the topic that defines the HTML Help 2.x collection attributes. If omitted, no data island will be added to the topic. The content of this element is user-defined. Add any necessary HTML Help 2.x attributes that you need for your help file.
bodyText | This element is used to define the body text for the page. It should contain the HTML for the topic's main content.

If you create your own transformation file, you are free to define whatever structure you like for the topic files. The above is just a guideline. Below is an example of a typical topic file for the three default transformations:

CopyExample Topic File
<?xml version="1.0" encoding="utf-8"?>

<!DOCTYPE bodyText [ <!ENTITY nbsp "&#160;"> ]>

<topic xmlns:MSHelp="http://msdn.microsoft.com/mshelp">
    <!-- The page title -->
    <title>Welcome to the Sandcastle Help File Builder</title>
    <!-- Add a logo -->
    <logoFile filename="images/Sandcastle.jpg" altText="Test logo"
        placement="left" alignment="left" />
    <!-- Include an additional stylesheet -->
    <styleSheet filename="Styles/Styles.css" />
    <!-- HTML Help 2.x data island -->
    <xml xmlns:msxsl="urn:schemas-microsoft-com:xslt">
        <MSHelp:Attr Name="AssetID" Value="Test" />
        <MSHelp:Keyword Index="K" Term="IndexKeyword1" />
        <MSHelp:Keyword Index="K" Term="IndexKeyword2" />
        <MSHelp:Attr Name="Locale" Value="en-us"></MSHelp:Attr>
        <MSHelp:Attr Name="Abstract" Value="An abstract for the file" />
    </xml>
    <!-- The body text for the topic -->
    <bodyText>
This is the <b>body text</b> for the additional content page.
    </bodyText>
</topic>

The .NET XML parser will not recognize many of the common HTML entities such as &nbsp; and will throw an exception. In order to handle them, you can use the numeric form rather than the name form (i.e. #&160; for the non-breaking space). The other alternative as shown in the example above is to add a DOCTYPE declaration at the start of the file that defines the unknown entities and the value to which they should be converted. This allows you to use the name form in the body text. Note that you will need to add the DOCTYPE declaration to each topic file that contains the unknown entities.

The pathToRoot Variable

The XSL transformation will be passed a variable called pathToRoot that defines the path to the help file's root folder. This allows you to add script, stylesheet, and image tags that prefix the filename in the tag's attributes with the pathToRoot variables during the transformation. For example:

CopyExample use of pathToRoot
<link rel="stylesheet" type="text/css"
    href="{$pathToRoot}styles/presentation.css" />

<img>
    <xsl:attribute name="src">
        <xsl:value-of select="$pathToRoot"/>
        <xsl:value-of select="@filename"/>
    </xsl:attribute>
</img>

Project Properties and Shared Content

Both the topic files and the XSL transformation files are treated like any other additional content file. As such, they can contain project property replacement tags and shared content item references that will be converted to the matching project property value or shared content item value at build time. See the Project Properties and Shared Content topic for more information.

See Also

Other Resources

Additional Content


Build Process Plug-Ins

[image]

Sandcastle Help File Builder Documentation
Build Process Plug-Ins
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Build process plug-ins can be used to alter or extend the build process in various ways with behavior that is not present in the help file builder by default. Plug-ins can be ran before a build step, after a build step, both before and after a build step, or instead of a build step. The following build process plug-ins are supplied with the help file builder:

  • Additional Content Only Plug-In
  • Additional Reference Links Plug-In
  • AjaxDoc Builder Plug-In
  • Assembly Binding Redirection Plug-In
  • Bibliography Support Plug-In
  • Completion Notification Plug-In
  • DBCS Fix for CHM Builds Plug-In
  • Hierarchical Table of Contents Plug-In
  • Output Deployment Plug-In
  • Script# Reflection File Fixer Plug-In
  • Table of Contents Exclusion Plug-In
  • Version Builder Plug-In
  • XPath Reflection File Filter Plug-In

Selecting and Configuring Build Process Plug-Ins

To select and configure plug-ins, select the PlugInConfigurations project property and click the "..." button to the right of it. The dialog below is then displayed.

Plug-In Configuration Dialog

Available plug-ins are listed on the left. Version, copyright, and description information is shown below the list and will change to reflect the currently selected plug-in. The list on the right displays the plug-ins selected for use in the current project. Double-click a plug-in on the left or click the Add button to add a plug-in to the project. Click the Configure button to configure the plug-in. Click the Delete button to delete a plug-in from the project. The checkboxes next to each project plug-in allow you to enable or disable the plug-in within the project. If disabled, it will remain in the project with its configuration information but it will not be used during a build.

Most plug-ins contain a default configuration but it is most likely not suitable for your project. As such, you should configure each plug-in that you add to the project so that it will work as expected. For information on creating your own build process plug-ins, see the Creating Build Process Plug-Ins topic.

Adding Third-Party Build Components

Third-party plug-ins can also be added by copying their assembly and any supporting files to the .\Plug-Ins folder or a subfolder beneath it in the help file builder's Common Application Data folder. See the Special Folder Locations topic for more information. Refer to the plug-in's documentation for information about its features and configuration options. For a list of current third-party plug-ins, see the Links to Resources topic.

See Also

Other Resources

Creating Build Process Plug-Ins
Project Properties Window


Additional Content Only Plug-In

[image]

Sandcastle Help File Builder Documentation
Additional Content Only Plug-In
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This plug-in can be used to build a help file consisting of nothing but conceptual and additional content items. All documentation sources and references in the project are ignored. Since this results in a much faster build, it is useful for proofreading your additional content without having to build all the API topics.

This plug-in contains no configuration options. It simply suppresses several of the build steps that generate API topics. Since the API topic generation is suppressed, links to API topics in the conceptual and additional content files will be rendered as bold, non-clickable links. All other content features such as colorized code blocks, project and shared content item replacement, etc. are still handled.

See Also

Other Resources

Build Process Plug-Ins


Additional Reference Links Plug-In

[image]

Sandcastle Help File Builder Documentation
Additional Reference Links Plug-In
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This plug-in is used to add additional reference link targets to the Reflection Index Data and Resolve Reference Links build components so that index links can be created to other third party help topics in a Help 2 collection or to additional online MSDN content. Index links are only used by Help 2.x files. The Msdn link type can be used to create links to additional online MSDN content such as for SharePoint libraries, etc. The None link type can also be specified to render the references as non-clickable labels. This may be of use in reducing the number of warnings about unresolved reference links in a build but isn't really needed as unresolved links are automatically rendered as non-clickable labels.

This component is also helpful if you create separate Help 2 files for each assembly in a project. By referencing the other related assembly help projects with this plug-in, you can ensure that the links to API topics in the other help files will work. For example, consider a product consisting of the following assemblies.

  • MyCompany.MyProduct.Base.dll
  • MyCompany.MyProduct.Windows.Forms.dll
  • MyCompany.MyProduct.Web.Controls.dll

The Windows Forms and the Web Controls assemblies both reference types found in the base assembly. If you want to segregate the help for each assembly into its own help file, you can create one help file builder project for each assembly. In the projects for the Windows Forms and the Web Controls assemblies, you would add this plug-in and reference the project for the base assembly.

Configuration Options

The configuration options consist of a list of other projects that will be built and have their reference link information merged with the current project. Note that these will only produce a partial build, enough to generate reflection information. XML comments files for the documented assemblies are optional. A link type is associated with each project in the configuration (Index to produce Help 2.x index links, Msdn to produce URLs that link to online MSDN content, or None to produce non-clickable labels). The order of the projects in the configuration is not relevant.

Since the plug-in uses help file builder projects to generate the reference information, you are free to mix projects built against different .NET framework versions, ones that use different API filters specific to that project, ones that use a different set of dependencies, or that contain other project settings specific to the related project. As noted, the additional projects only go through a partial build, enough to generate reflection information. As such, the following project properties are ignored in the other projects:

  • Build category: CleanIntermediates, ComponentConfigurations, HelpFileFormat
  • Help File category: All properties
  • HTML Help 1 category: All properties
  • HTML Help 2 category: All properties
  • Paths category: HtmlHelp1xCompilerPath, HtmlHelp2xCompilerPath
  • Show Missing Tags category: All properties

XML comments files from the other projects are included in the current project's build so that inherited members are still documented correctly. Where there are XML comments common to multiple projects, those from the current project will always take precedence. As noted above, XML comments files are optional. If omitted, no comments will be associated with the given assembly.

See Also

Other Resources

Build Process Plug-Ins


AjaxDoc Builder Plug-In

[image]

Sandcastle Help File Builder Documentation
AjaxDoc Builder Plug-In
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This plug-in is used to generate XML comments and reflection information for Atlas client script libraries using AjaxDoc that can then be used by the Sandcastle Help File Builder to produce a help file.

This topic contains the following sections.

  • Configuration Options
  • The API Filter
  • AjaxDoc 1.1 Users
  • See Also

Configuration Options

This plug-in will require configuration before it can be used. The configuration options are as follows.

Configuration Option | Description
AjaxDoc URL | Enter the URL used to run AjaxDoc to produce the XML comments and reflection information file. This is also the base URL used to download the generated files.
Project Name | Enter the base name of the project that will produce the XML comments file and reflection information file. Do not include the file extension. This name is used as the project to run and for the names of the resulting files that are downloaded.
Regenerate the output files before downloading them | If this box is checked, the plug-in will invoke AjaxDoc at the supplied URL to generate up to date copies of the output files. If unchecked, it will download the existing copies of the files whether or not they are up to date.
Use default credentials | If this checkbox is checked, the current user's credentials at build time will be used to download the resulting files from the given URL. If running this on a build server and/or authentication is required, uncheck this box and supply a user name and password.
User Name and Password

Use these to enter specific credentials for downloading the resulting files.

Security Note:

The password is stored in the project file in plain text.
Use Proxy Server | If the download of the files fails and you are behind a proxy server, you may need to supply proxy server credentials. Uncheck this box to enter the proxy server name and credentials.
Proxy Server | Enter the name of the proxy server to use.
Use default credentials (Proxy server) | If checked, default credentials for the current user will be passed to the proxy server at build time. If specific credentials are needed, uncheck this box and enter a user name and password.
User Name and Password (Proxy server)

Use these to enter specific credentials for the proxy server.

Security Note:

The password is stored in the project file in plain text.

When using this plug-in, documentation sources and references can be left out as the plug-in will pull the necessary comments file from AjaxDoc. However, you can add additional XML comments files as documentation sources so that you can add comments for the namespaces in the AjaxDoc content or other additional information for the reference topics if you prefer to keep them separate from the project.

Select the JavaScript option in the SyntaxFilters project property so that the declarations in the syntax section of each API topic are rendered in JavaScript.

The API Filter

The AjaxDoc plug-in supports the API filter. It can be used to remove unwanted namespaces, types, and/or members from the help file. See the API Filter Property topic for details on how it can be used. Be aware that since the API filter is generated prior to the XML comments file being downloaded, any members with <exclude /> tags will not be removed unless you have opened the API filter editor and let it create a filter that includes them.

AjaxDoc 1.1 Users

Be aware that AjaxDoc 1.1 has a couple of bugs in it that cause the JScript syntax generator to crash and nested namespaces to appear at both the root level and below their parent namespaces in the table of contents. Check for a newer version or, for a fixed version of the 1.1 version's script that prevents the problems, see this work item at the AjaxDoc site on CodePlex.

See Also

Other Resources

Build Process Plug-Ins


Assembly Binding Redirection Plug-In

[image]

Sandcastle Help File Builder Documentation
Assembly Binding Redirection Plug-In
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This plug-in is used to add assembly binding redirection support to the MRefBuilder configuration file. With this in place, it is possible to document assemblies that use binding redirection to reference assemblies of a different version than the ones they were built against.

Configuring the Plug-In

Once added to the project, this plug-in must be configured. The configuration consists of one or more entries that define how to redirect an assembly reference or an application configuration file from which the settings should be imported. A list box at the top of the configuration dialog box lists the current definitions. Click the Add button to the right of the list box to add a new item. The property grid a the bottom of the dialog box is used to edit each entry's settings. Click the Delete button to the right of the list box to delete an entry.

Configuration Item Options

Each entry consists of the following configuration options:

Option | Description
ConfigurationFile | This option allows you to specify a configuration file from which the binding redirection settings are imported. This should be an application or web configuration file (i.e. App.exe.config or Web.config) that contains an assemblyBinding section that defines the dependent assemblies and how they should be redirected. If specifed, all other configuration options are ignored. The value can contain replacement tags to specify the path to the file (i.e. {@ProjectFolder}..\bin\MyApp.exe.config).
AssemblyName | The assembly name that will be redirected. Specify only the name of the assembly. Do not include a path or extension.
PublicKeyToken | Specify the public key token of the assembly. If left blank, "null" is assumed.
Culture | Specify the culture of the assembly. If left blank, "neutral" is assumed.
OldVersion | Use this to specify the old version that will be redirected. If the OldVersionTo property is left blank, this will be used as the single version to redirect. This can be a version value from 0.0.0.0 to 65535.65535.65535.65535.
OldVersionTo | To redirect a range of assembly versions, enter the starting version number in the OldVersion property and the ending version number in this property. If this property is left blank, only the version specified in OldVersion is redirected. This can be a version value from 0.0.0.0 to 65535.65535.65535.65535.
NewVersion | This defines the new assembly version to which the old versions are redirected.

See Also

Other Resources

Build Process Plug-Ins
Assembly Binding Redirection
assemblyBinding Configuration File Element


Bibliography Support Plug-In

[image]

Sandcastle Help File Builder Documentation
Bibliography Support Plug-In
Example See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This plug-in adds support for the auto-generated bibliography feature that was added to Sandcastle by the Sandcastle Styles patch. The patch must have been applied to Sandcastle in order for this plug-in to work correctly.

Generating a Bibliography

The auto-generated bibliography feature allows an author to create an external bibliography XML file and then share it between multiple topics by specifying short identifiers in cite elements that match one of the references contained in the file. When one or more cite elements are used, Sandcastle will automatically generate a bibliography for the topic in the place that the bibliography element is specified and the cite elements themselves will be replaced with hyperlinks to corresponding bookmarked entries in the bibliography.

Tip:

The bibliography element is typically specified immediately before the relatedTopics section that appears at the bottom of the topic.

To use citations, a bibliography XML file must be created to store the identifiers and entries. A default bibliography file named, bibliography.xml can be found in each presentation style's .\Data folder. The presenation styles are located in the main Sandcastle installation folder in the .\Presentation folder. An example file is also shown below.

Defining Citation Identifiers and Bibliography Entries

  1. If it does not already exist, create a new XML file and add it to the project. The suggested name is bibliography.xml but you can name it what you like. Set the BuildAction to None so that the build ignores it.

  2. Add content similar to the following to the bibliography XML file.

    CopySample Bibliography.xml File
    <?xml version="1.0" encoding="utf-8"?>
<bibliography>
  <reference name="sandcastle activity">
    <title>Sandcastle Activity Statistics</title>
    <author>Microsoft</author>
    <publisher>CodePlex.com</publisher>
    <link>http://Sandcastle.codeplex.com/stats/view</link>
  </reference>
  <reference name="sandcastle styles">
    <title>Sandcastle Styles</title>
    <author>Paul Selormey, Eric Woodruff, Dave Sexton</author>
    <publisher>CodePlex.com</publisher>
    <link>http://SandcastleStyles.codeplex.com</link>
  </reference>
</bibliography>

    The previous example defines a bibliography XML file that contains two reference elements, which can be referred to by cite elements in a MAML topic using the values of the name attributes.

    Tip:

    Reference names are not case-sensitive.

    The title and author elements are required. The publisher and link elements are optional. The only supported content type for each element is plain text.

  3. Add the plug-in to the project's PlugInConfigurations project property. Once added, click the Configure button to specify the path to the bibliography XML file. You can use a replacement tag in the path to specify a special folder such as the project folder (i.e. {@ProjectFolder}Bibliography.xml).

Using the Bibliography in a MAML Topic

  1. Add a bibliography element to the topic, preferably just before the relatedTopics element (see example).

  2. Use cite elements to reference items in the bibliography. The inner text of the element is the value of the name attribute for the entry.

Using the Bibliography in XML Code Comments

  • Use cite elements to reference items in the bibliography. The inner text of the element is the value of the name attribute for the entry. The Sandcastle transformations will add a bibliography section to the API member's page automatically if any cite elements are found.

Example

The following example MAML topic uses multiple cite elements to reference bibliography entries defined in the bibliography.xml file.

Important Note:

The bibliography element is also specified so that a bibliography section is generated automatically near the bottom of the topic.

CopySample Topic with Bibliography
<?xml version="1.0" encoding="utf-8"?>
<topic id="00000000-0000-0000-0000-000000000000" revisionNumber="1">
  <developerConceptualDocument xmlns="http://ddue.schemas.microsoft.com/authoring/2003/5"
    xmlns:xlink="http://www.w3.org/1999/xlink">

    <introduction>
      <para>This topic discusses Sandcastle's popularity.</para>
    </introduction>

    <section>
      <title>Sandcsatle's Popularity</title>

      <content>
        <para>Sandcastle is a popular download<cite>sandcastle activity</cite>.</para>

        <para>Sandcastle Styles<cite>sandcastle styles</cite> adds even more value.</para>

        <para>I expect Sandcastle's popularity<cite>sandcastle activity</cite>
to increase as more community members become aware of its usefulness, with the
help of projects like Sandcastle Styles<cite>sandcastle styles</cite>.</para>
      </content>
    </section>

    <!-- Place the bibliography before the relatedTopics section -->
    <bibliography/>

    <relatedTopics/>
  </developerConceptualDocument>
</topic>

See Also

Other Resources

Build Process Plug-Ins
Sandcastle Styles


Completion Notification Plug-In

[image]

Sandcastle Help File Builder Documentation
Completion Notification Plug-In
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This plug-in is used to send notification of the build completion status via e-mail. The log file can be included as an optional attachment. Configuration options must be defined before it can be used. The configuration options are as follows:

Configuration Option | Description
SMTP Server | Enter the name of the SMTP server used to send the e-mail.
Port # | Enter the port number to use on the server when sending the e-mail.
Use default credentials | If this checkbox is checked, the current user's credentials at build time will be used to send the e-mail. If running this on a build server or if your e-mail server requires authentication, uncheck this box and supply a user name and password.
User Name and Password

Use these to enter specific credentials for sending the e-mail

Security Note:

The password is stored in the project file in plain text.
From E-Mail Address Enter a From e-mail address. If one is not supplied, the address noreply@noreply.com will be used as the sender.
Note:

Some e-mail servers require a valid From address on the e-mail or at least one that comes from the same domain.
Success E-Mail Address | If you want an e-mail sent on a successful build, enter the e-mail address here. If no address is entered, no e-mail will be sent on successful builds.
Failure E-Mail Address | A failure e-mail address is required. This is where the failure notification will be sent.
Attach build log on successful build | Check this box if you would like the build log to be attached to the success e-mail. If unchecked, the log will not be sent.
Attach build log on failed build | Check this box if you would like the build log to be attached to the failure e-mail. If unchecked, the log will not be sent.
Optional XSL Transform | If specified and the log file is to be attached to the e-mail, the log file is ran through the specified transform and the resulting HTML file is attached in its place. If not specified, the raw log file is attached. The default transform can be used by specifying {@SHFBFolder}Templates\TransformBuildLog.xsl.

This plug-in runs after the build has completed and the log file has been closed but before it is deleted if the KeepLogFile option is set to false. Note that because the log file is closed, any failure messages reported by this plug-in as it tries to send the e-mail will not appear in the log file itself.

See Also

Other Resources

Build Process Plug-Ins


DBCS Fix for CHM Builds Plug-In

[image]

Sandcastle Help File Builder Documentation
DBCS Fix for CHM Builds Plug-In
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

DBCS stands for Double Byte Character Set. Several languages, most notably East Asian languages and Russian, cause problems for Help 1.x (CHM) builds because the help compiler is not Unicode-aware. This can cause the table of contents, index, and in some cases the help topics to display incorrect characters. This plug-in is designed to correct these issues.

This topic contains the following sections.

  • Features
  • Method Naming Issues
  • Additional Content Files
  • Language Configuration
  • See Also

Features

The plug-in modifies the topic files and the build in the following ways:

  • It converts unsupported high-order characters to 7-bit ASCII equivalents.
  • It converts several unsupported high-order characters to named entities.
  • It replaces the UTF-8 reference in the CHARSET meta tag in each HTML page with a character set reference appropriate to the selected language.
  • It saves each HTML page using the encoding appropriate to the selected language.
  • It uses the SBAppLocale tool from Steel Bytes to run the Help 1.x compiler under the appropriate locale for the selected language. This saves you from having to manually change the language in your Regional Settings, reboot, and perform the help compile step.

To use the plug-in, add it to the project and configure it. The only option needed is the location of the SBAppLocale.exe application.

Method Naming Issues

Note that if your code uses Unicode characters in the member names, it may not be possible to use the MemberName option for the NamingMethod property. If you receive build errors that indicate that it cannot find certain files and the names do not look correct, change the naming method to use either the GUID or HashedMemberName option.

Additional Content Files

If you add HTML pages as additional content or use a topic transformation file to create HTML additional content pages, you should ensure that a meta tag specifying UTF-8 encoding appears in each file. This will ensure that all additional content pages are also properly encoded if necessary. For example:

CopyExample Character Set Encoding Meta Tag
<head>
<title>My Additional Content<title>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
</head>

Language Configuration

The tool that performs the encoding translation relies on the SandcastleHtmlExtract.config file to provide information about the language locale ID, code page, and character set encoding name. The configuration file is located in the root help file builder installation folder. If the project's locale ID cannot be found in the file, a warning is issued in the log file and a default code page and character set encoding will be used based on the language selected in the project. If the defaults are not appropriate, you can add new entries to the configuration file.

The settings consist of a set of language elements, one for each language identified by locale ID, that specify the settings. The id attribute refers to the locale ID (LCID) for the language. The codepage attribute is the code page to use when determining the encoding for the files based on the given locale ID. The charset attribute value will be written to the HTML files in place of the UTF-8 value when localizing the files for use with the Help 1.x compiler.

If you do add entries to this file, please report them so that they can be added to a future release of the help file builder.

See Also

Other Resources

Build Process Plug-Ins


Hierarchical Table of Contents Plug-In

[image]

Sandcastle Help File Builder Documentation
Hierarchical Table of Contents Plug-In
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This plug-in can be used to rearrange the table of contents such that namespaces are nested within their parent namespaces rather than appearing as a flat list of all namespaces at the root level. The plug-in has two configuration options:

Create containers for common root namespaces with more than [N] part(s)

This option lets you specify at what level container namespace entries should start being created for namespaces with a common root namespace. By default, entries in the table of contents are only created for namespaces with content. For example, consider the following namespaces in a table of contents:

  • MyCompany.MyProduct
  • MyCompany.MyProduct.Web.Controls
  • MyCompany.MyProduct.Web.Design
  • MyCompany.MyProduct.Windows.Forms

Since no classes exist in the MyCompany.MyProduct.Web or MyCompany.MyProduct.Windows namespaces, no namespace entries exists for them. When this option is set to two, the default, the plug-in will create a container namespace in the table of contents called MyCompany.MyProduct.Web and will nest the MyCompany.MyProduct.Web.Controls and MyCompany.MyProduct.Web.Design namespaces beneath it. The created container will have no page associated with it as it just serves to further group the namespaces with a common root name. This will only occur if two or more namespaces would appear. Since there would only be one namespace under MyCompany.MyProduct.Windows, no container entry is created for it.

If set to one, an additional container for the MyCompany namespace would be created at the root level and all of the other namespaces would be nested below it. The MyCompany.MyProduct.Web namespace container would also be created as before. By setting the number to a higher value, you can delay the point at which it creates the containers or prevent it from doing so altogether. For example, if set to three in the above example, the additional MyCompany.MyProduct.Web container would not be created and, since there are no common root namespaces with four or more parts no other additional containers would be created either.

Insert nested namespaces below the parent namespace's content

As its name implies, if this option is checked, the nested namespaces will be inserted below the parent namespace's content. If unchecked, the default, the namespaces are inserted ahead of the parent's content.

See Also

Other Resources

Build Process Plug-Ins


Output Deployment Plug-In

[image]

Sandcastle Help File Builder Documentation
Output Deployment Plug-In
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This plug-in is used to deploy the resulting help file output to a location other than the output folder (i.e. a file share, a web server, an FTP site, etc.). This plug-in will require configuration before it can be used. The configuration options are as follows:

Configuration Option | Description
Delete source files after deploying them | Check this box to delete the source help files after they have been deployed. This option applies to all help file formats built by the project and deployed by the plug-in.
Help file format options | For each help file format (Help 1.x, Help 2.x, and website), you can define a different set of deployment options. Fill in the options for each help file format built by the project. The options are the same for all formats and are described below.

The following options are available for each help file format.

Configuration Option | Description
Target Location

Enter the location to which the help file output should be copied. This can be a file path, a UNC path, or a URL for a website or FTP site. If a relative file path is specified, it will be relative to the project folder.

Note:

HTTP/FTP Limitation: Be aware that there is a limitation when deploying output to an HTTP or FTP URL. Any subfolders in the source website and/or destination URL must already exist in the destination website or FTP site. If not, the deployment will fail. If possible, deploy to a file or UNC path that maps to the URL as they do not have this limitation.

Security Note:

Using HTTP for uploads is not recommended as you must grant write permissions to the folders which is a security risk.
Use default credentials | If this checkbox is checked, the current user's credentials at build time will be used to upload the resulting files to the given URL. If running this on a build server and/or authentication is required, uncheck this box and supply a user name and password.
User Name and Password

Use these to enter specific credentials for uploading the files to the target URL.

Security Note:

The password is stored in the project file in plain text.
Use Proxy Server | If the upload of the files fails and you are behind a proxy server, you may need to supply proxy server credentials. Uncheck this box to enter the proxy server name and credentials.
Proxy Server | Enter the name of the proxy server to use.
Use default credentials (Proxy server) | If checked, default credentials for the current user will be passed to the proxy server at build time. If specific credentials are needed, uncheck this box and enter a user name and password.
User Name and Password (Proxy server)

Use these to enter specific credentials for the proxy server.

Security Note:

The password is stored in the project file in plain text.

You only need to enter information for the help file formats that are built by the project and/or that you want to deploy. If a target location is left blank for any given format, deployment of that format will be skipped.

See Also

Other Resources

Build Process Plug-Ins


Script# Reflection File Fixer Plug-In

[image]

Sandcastle Help File Builder Documentation
Script# Reflection File Fixer Plug-In
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This plug-in is used to modify the reflection information file produced after running MRefBuilder on assemblies created by the Script# compiler so that it is suitable for use in producing a help file. This plug-in contains no configuration options. It simply adds an additional transformation that runs after the reflection information file has been generated that fixes up certain elements in it so that they are documented correctly.

Add the Script# generated assemblies or the Visual Studio project or solution that produces them to the project as documentation sources. If you add the assemblies, be sure to add the necessary Script# dependency assemblies to the References project node. You can find them in the Script# installation folder (C:\Program Files\nStuff\ScriptSharp\v1.0\Framework by default).

You can select the JavaScript option in the SyntaxFilters project property so that the syntax section in the API topics renders the declarations in JavaScript.

See Also

Other Resources

Build Process Plug-Ins


Table of Contents Exclusion Plug-In

[image]

Sandcastle Help File Builder Documentation
Table of Contents Exclusion Plug-In
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This plug-in can be used to exclude API members from the table of contents via the <tocexclude /> XML comment tag. This can simplify the table of contents to show only selected API members. The members that are excluded from the table of contents are accessible from the namespace and class members list pages as well as any other reference links created via <see> and <seealso> tags, etc.

This plug-in contains no configuration options. It simply searches the XML comments files for members that contain a <tocexclude/> tag and removes those members from the table of contents.

If needed, the <tocexclude /> tag can be placed in a namespace summary in the project settings to remove an entire namespace from the table of contents but still leave it's content accessible via other reference links.

See Also

Other Resources

Build Process Plug-Ins


Version Builder Plug-In

[image]

Sandcastle Help File Builder Documentation
Version Builder Plug-In
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This plug-in is used to generate version information for assemblies in the current project and other projects related to the same product that can be merged into the current project's help file topics. Unlike the Version Information Component which only adds the version number for the assembly in which the member appears to the assembly information message in each topic, this plug-in creates a separate Version Information section in each topic that can list one or more frameworks and/or versions in which the member appears. When the plug-in is used, the version number in the assembly information message added by the build component is omitted. Topics such as the namespace list, class member lists, and overloads lists do not contain a version information section.

The configuration options consist of a framework label and a version number for the current project and a list of other projects that will be built and have their API information merged with the current project. Note that these will only produce a partial build, enough to generate reflection information. XML comments files for the documented assemblies are optional. In the configuration, each additional project is assigned a framework label and a version number to uniquely identify it. The framework labels can be identical to the current project or they can be unique or matched between the other projects. The framework label controls how the version information is grouped. Both are free-form text so you can enter any value to identify the framework and version. The order of the projects in the configuration is not relevant. Version information is sorted by version number within framework label at the time the help file is actually built. For example:

  • Current project label: Windows Forms Controls, Version: 2.1
  • Other Project 1 label: Compact Framework Controls, Version: 2.3.1
  • Other Project 2 label: Windows Forms Controls, Version: 1.3.5
  • Other Project 3 label: Compact Framework Controls, Version: 1.3.2

Depending on the presentation style selected, this would produce a Version Information section in each member topic similar to the following:

Version Information

Compact Framework Controls
Supported in: 1.3.2, 2.3.1

Windows Forms Controls
Supported in: 1.3.5, 2.1

If the framework label is common to all versions being documented, you can leave it blank. However, this may affect the display of the version information in some styles such as Prototype which expect to have a framework label value.

Since the plug-in uses help file builder projects to generate the other version information, you are free to mix projects built against different .NET framework versions, ones that use different API filters specific to that version, ones that use a different set of dependencies, or that contain other project settings specific to the related version. As noted, the additional projects only go through a partial build, enough to generate reflection information. As such, the following project properties are ignored in the other projects:

  • Build category: CleanIntermediates, ComponentConfigurations, HelpFileFormat
  • Help File category: All properties
  • HTML Help 1 category: All properties
  • HTML Help 2 category: All properties
  • Paths category: HtmlHelp1xCompilerPath, HtmlHelp2xCompilerPath
  • Show Missing Tags category: All properties

XML comments files from the other versions are included in the current project's build so that members not appearing in all projects are still documented correctly. Where there are XML comments common to multiple versions, those from the current project will always take precedence. As noted above, XML comments files are optional. If omitted, no comments will be associated with the given assembly.

In certain presentation styles such as VS2005, the list pages contain a framework filter in the page header. Hovering the mouse over the filter link displays a popup containing a list of the framework labels. The intended use is to allow you to filter the list to only show members related to the checked frameworks. However, as of the January 2008 release, the Sandcastle transformations use hard-coded .NET framework values rather than the ones specified in the configuration file and the filter will not have any effect. This has been reported and hopefully it will be fixed in a later release of Sandcastle.

See Also

Other Resources

Build Process Plug-Ins


XPath Reflection File Filter Plug-In

[image]

Sandcastle Help File Builder Documentation
XPath Reflection File Filter Plug-In
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This plug-in, based on code submitted by Eyal Post, is used to filter out unwanted information from the reflection information file using XPath queries. While the project's ApiFilter property and the other properties in the Visibility category can provide the most efficient way to remove unwanted class members, they may not always meet everyone's needs. This plug-in allows you to add a set of XPath queries that will be used to search the reflection information file and remove elements that match them.

The list box at the top of the configuration dialog box shows the list of expressions to use. Click the Add button to add a new expression. The default expression on new entries is an example that removes all constructors. Use the text box at the bottom of the form to change it to an expression for your project. As you move from one entry to another, the expression is displayed in the text box for editing. Click the Delete button to delete an expression from the list.

As an example, suppose you wanted to remove all constructors from the help file without having to maintain the API filter each time you added new classes to the project. This could be accomplished by adding the following expressions to the plug-in's configuration:

  • /reflection/apis/api[contains(@id,"#ctor")]
  • /reflection/apis/api/elements/element[contains(@api,"#ctor")]
  • /reflection/apis/api[contains(@id,"#cctor")]
  • /reflection/apis/api/elements/element[contains(@api,"#cctor")]

The first two entries remove the instance constructor entries as well as the elements that appear on the member list pages. The last two remove the corresponding static constructor entries. In the following example, the inherited Object methods are removed from all sealed classes.

  • /reflection/apis/api[apidata/@subgroup="class" and typedata/@sealed="true"]/elements/element[@api="M:System.Object.Equals(System.Object)"]
  • /reflection/apis/api[apidata/@subgroup="class" and typedata/@sealed="true"]/elements/element[@api="M:System.Object.GetHashCode"]
  • /reflection/apis/api[apidata/@subgroup="class" and typedata/@sealed="true"]/elements/element[@api="M:System.Object.GetType"]
  • /reflection/apis/api[apidata/@subgroup="class" and typedata/@sealed="true"]/elements/element[@api="M:System.Object.Finalize"]
  • /reflection/apis/api[apidata/@subgroup="class" and typedata/@sealed="true"]/elements/element[@api="M:System.Object.MemberwiseClone"]
  • /reflection/apis/api[apidata/@subgroup="class" and typedata/@sealed="true"]/elements/element[@api="M:System.Object.ToString"]
Tip:

Set the project's CleanIntermediates property to false and perform a build to obtain a copy of the reflection information file. It can be found in the working folder after the build and will help you determine how to construct the necessary XPath expressions.

See Also

Other Resources

Build Process Plug-Ins


Creating Build Process Plug-Ins

[image]

Sandcastle Help File Builder Documentation
Creating Build Process Plug-Ins
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This topic will walk you through the creation of a plug-in project.

  • Defining the Plug-In Configuration
  • Creating the Project
  • The Plug-In Skeleton Class
  • The SandcastleBuilder.Utils.PlugIn.IPlugIn Interface
    • RunsInPartialBuild
    • ExecutionPoints
    • ConfigurePlugIn
    • Initialize
    • Execute
    • Dispose
  • Execution Notes
  • See Also

Defining the Plug-In Configuration

The first step is to determine what items will appear in the plug-in configuration. The configuration is stored as an XML fragment in the help file builder project file. The root node is always configuration. Define your own elements to contain the plug-in configuration that will be nested within the root element. When first added to a project, the configuration will be empty. Your plug-in should use appropriate default values as needed. It is possible that a plug-in will have no configurable elements. In that case, there is nothing to add to the default configuration. Below is an example of a configuration that is passed to a plug-in.

CopyExample Plug-In Configuration
<configuration>
    <ajaxDoc url="http://localhost:/AjaxDoc/" project="MicrosoftAjax" regenerate="true" />
    <userCredentials useDefault="true" userName="" password="" />
    <proxyCredentials useProxy="false" proxyServer="">
        <userCredentials useDefault="true" userName="" password="" />
    </proxyCredentials>
</configuration>

Creating the Project

This section describes how to create and configure the build process plug-in project. It will describe the process for a C# project but the steps should be fairly similar for a VB.NET project with a few differences in the configuration option titles.

Create the Plug-In Project

  1. In Visual Studio, create a new Class Library project. Once it has been created, right click on the project and select Properties.

  2. In the Application tab, set the assembly name and default namespace as you see fit.

  3. In the Build Events tab, set the Post-build event command line to the following command based on your operating system which will copy the plug-in to the shared application data .\Plug-Ins folder ready for testing (lines wrapped for display purposes):

    CopyWindows Vista
    XCopy /y $(TargetPath) "%ProgramData%\EWSoftware\Sandcastle Help File
Builder\Plug-Ins\"
    CopyWindows XP
    XCopy /y $(TargetPath) "%ALLUSERSPROFILE%\Application Data\
EWSoftware\Sandcastle Help File Builder\Plug-Ins\"

  4. On the Debug tab, set the Start Action to "Start external program" and enter the path to the SandcastleBuilderGUI.exe program. If you installed the help file builder in the default location, this will be C:\Program Files\EWSoftware\Sandcastle Help File Builder\. If not, substitute your path as appropriate.

  5. Select the Signing tab and check the "Sign the assembly" checkbox. Select "<New...>" from the "Choose a strong name key file" dropdown, enter a filename, and click OK to create the key file. You can protect the key file with a password if you like or uncheck the option to create one without a password.

The next task is to add the necessary assembly references.

Adding Assembly References

  1. Right click on the References folder in the project and select "Add Reference...".

  2. Select the Browse tab. Navigate to your Sandcastle Help File Builder installation folder (usually C:\Program Files\EWSoftware\Sandcastle Help File Builder\). Select SandcastleBuilder.Utils.dll and click OK to add it to the references. This contains the base class for the plug-in and some supporting definitions. Once added, view its properties and set the Copy Local option to False. This file is loaded from the help file builder installation folder and should not be copied locally or distributed with the plug-ins.

  3. If you would like to make your plug-ins interactively configurable from the Sandcastle Help File Builder, open the Add Reference dialog and add a reference to System.Windows.Forms from the .NET tab. More information about this will be supplied later.

You can add other necessary references to the project as you develop your plug-in.

The Plug-In Skeleton Class

You are now ready to create the plug-in class itself. Note that multiple plug-ins can reside within the same assembly. Repeat this process for as many plug-ins as you need to create giving each one a unique name. Add a new class to the project and insert the following skeleton code into it. Here again, this will only show C# code. For VB.NET, the structure will be similar but you will have to convert it to the VB.NET syntax. Each part will be covered in detail below.

CopyPlug-In Skeleton
//=============================================================================
// System  : <Your Plug-In Project>
// File    : <YourFileName.cs>
// Author  : <Your Name Here>
// Updated : <--Date-->
// Compiler: Microsoft Visual C#
//
// <A description of the plug-in.>
//
// Version     Date     Who  Comments
// ============================================================================
// 1.0.0.0  <--Date-->  <->  Created the code
//=============================================================================

using System;
using System.Diagnostics;
using System.Reflection;
using System.Windows.Forms;
using System.Xml;
using System.Xml.XPath;

using SandcastleBuilder.Utils;
using SandcastleBuilder.Utils.BuildEngine;
using SandcastleBuilder.Utils.PlugIn;

// TODO: Use your namespace
namespace Test.PlugIns
{
    /// <summary>
    /// TODO: Set your plug-in's class name
    /// </summary>
    public class TestPlugIn : SandcastleBuilder.Utils.PlugIn.IPlugIn
    {
+Private data members-        #region Private data members
         private ExecutionPointCollection executionPoints;

         private BuildProcess builder;
         #endregion

+IPlugIn implementation-        #region IPlugIn implementation
         //=====================================================================
         // IPlugIn implementation

         /// <summary>
         /// This read-only property returns a friendly name for the plug-in
         /// </summary>
         public string Name
         {
             get { return "TODO: Add your plug-in name here"; }
         }

         /// <summary>
         /// This read-only property returns the version of the plug-in
         /// </summary>
         public Version Version
         {
             get
             {
                 // TODO: Edit AssemblyInfo.cs to set your plug-in's version

                 // Use the assembly version
                 Assembly asm = Assembly.GetExecutingAssembly();
                 FileVersionInfo fvi = FileVersionInfo.GetVersionInfo(
                     asm.Location);

                 return new Version(fvi.ProductVersion);
             }
         }

         /// <summary>
         /// This read-only property returns the copyright information for the
         /// plug-in.
         /// </summary>
         public string Copyright
         {
             get
             {
                 // TODO: Edit AssemblyInfo.cs to set your plug-in's copyright

                 // Use the assembly copyright
                 Assembly asm = Assembly.GetExecutingAssembly();
                 AssemblyCopyrightAttribute copyright =
                     (AssemblyCopyrightAttribute)Attribute.GetCustomAttribute(
                         asm, typeof(AssemblyCopyrightAttribute));

                 return copyright.Copyright;
             }
         }

         /// <summary>
         /// This read-only property returns a brief description of the plug-in
         /// </summary>
         public string Description
         {
             get
             {
                 return "TODO: Add your plug-in description here";
             }
         }

         /// <summary>
         /// This read-only property returns true if the plug-in should run in
         /// a partial build or false if it should not.
         /// </summary>
         /// <value>If this returns false, the plug-in will not be loaded when
         /// a partial build is performed.</value>
         public bool RunsInPartialBuild
         {
             // TODO: Set this to true if necessary
             get { return false; }
         }

         /// <summary>
         /// This read-only property returns a collection of execution points
         /// that define when the plug-in should be invoked during the build
         /// process.
         /// </summary>
         public ExecutionPointCollection ExecutionPoints
         {
             get
             {
                 if(executionPoints == null)
                 {
                     executionPoints = new ExecutionPointCollection();

                     // TODO: Modify this to set your execution points
                     executionPoints.Add(new ExecutionPoint(
                         BuildStep.ValidatingDocumentationSources,
                         ExecutionBehaviors.Before));
                 }

                 return executionPoints;
             }
         }

         /// <summary>
         /// This method is used by the Sandcastle Help File Builder to let the
         /// plug-in perform its own configuration.
         /// </summary>
         /// <param name="project">A reference to the active project</param>
         /// <param name="currentConfig">The current configuration XML fragment</param>
         /// <returns>A string containing the new configuration XML fragment</returns>
         /// <remarks>The configuration data will be stored in the help file
         /// builder project.</remarks>
         public string ConfigurePlugIn(SandcastleProject project,
           string currentConfig)
         {
             // TODO: Add and invoke a configuration dialog if you need one.
             MessageBox.Show("This plug-in has no configurable settings",
                 "Build Process Plug-In", MessageBoxButtons.OK,
                 MessageBoxIcon.Information);

             return currentConfig;
         }

         /// <summary>
         /// This method is used to initialize the plug-in at the start of the
         /// build process.
         /// </summary>
         /// <param name="buildProcess">A reference to the current build
         /// process.</param>
         /// <param name="configuration">The configuration data that the plug-in
         /// should use to initialize itself.</param>
         public void Initialize(BuildProcess buildProcess,
           XPathNavigator configuration)
         {
             builder = buildProcess;

             builder.ReportProgress("{0} Version {1}\r\n{2}\r\n",
                 this.Name, this.Version, this.Copyright);

             // TODO: Add your initialization code here such as reading the
             // configuration data.
         }

         /// <summary>
         /// This method is used to execute the plug-in during the build process
         /// </summary>
         /// <param name="context">The current execution context</param>
         public void Execute(ExecutionContext context)
         {
             // TODO: Add your execution code here
         }
         #endregion

+IDisposable implementation-        #region IDisposable implementation
         //=====================================================================
         // IDisposable implementation

         /// <summary>
         /// This handles garbage collection to ensure proper disposal of the
         /// plug-in if not done explicity with <see cref="Dispose()"/>.
         /// </summary>
         ~TestPlugIn()
         {
             // TODO: Change the name of this method to your plug-in name
             this.Dispose(false);
         }

         /// <summary>
         /// This implements the Dispose() interface to properly dispose of
         /// the plug-in object.
         /// </summary>
         /// <overloads>There are two overloads for this method.</overloads>
         public void Dispose()
         {
             this.Dispose(true);
             GC.SuppressFinalize(this);
         }

         /// <summary>
         /// This can be overridden by derived classes to add their own
         /// disposal code if necessary.
         /// </summary>
         /// <param name="disposing">Pass true to dispose of the managed
         /// and unmanaged resources or false to just dispose of the
         /// unmanaged resources.</param>
         protected virtual void Dispose(bool disposing)
         {
             // TODO: Dispose of any resources here if necessary
         }
         #endregion
    }
}

The plug-in is derived from the SandcastleBuilder.Utils.PlugIn..::.IPlugIn interface and consists of several properties and methods that you must implement. These are described below. Review the code above for "TODO:" comments to find sections that need attention such as changing the namespace, class name, etc. If you followed the steps in the Creating the Project section, you can run the project and debug it by setting breakpoints in the plug-in's code.

The SandcastleBuilder.Utils.PlugIn.IPlugIn Interface

The interface consists of a set of descriptive properties ( Name, Version, Copyright, and Description) that provide basic information about the plug-in. The following properties and methods are used to configure the plug-in and execute it during a build.

RunsInPartialBuild

The RunsInPartialBuild property determines whether or not the plug-in runs during a partial build. Partial builds occur when generating the table of contents for the preview dialog and the API Filter editor dialog. In such cases, the plug-in may not be needed. If this property returns false, the plug-in is omitted which can speed up the partial build.

ExecutionPoints

The ExecutionPoints property is probably the most important member of the interface. It returns a collection of ExecutionPoint objects that define at which steps in the build process the plug-in should be ran. Execution points can be set to run before and/or after a build step to supplement the default processing or they can be set to run instead of the build step to completely supress or replace the default processing. See the BuildStep enumeration for a list of the defined build steps.

Each execution point can be assigned a priority. The execution priority is used to determine the order in which the plug-ins will be executed. Those with a higher priority value will be executed before those with a lower value. Those with an identical priority may be executed in any order within their group. If not specified, a default priority of 1,000 is used.

ConfigurePlugIn

The ConfigurePlugIn method is used to configure the plug-in interactively from within the help file builder. The method is passed a string containing the XML fragment that defines the current configuration. It should return a copy of the edited configuration.

Initialize

The Initialize method is used to initialize the plug-in at the start of the build process. It is passed a reference to the current BuildProcess and an XPath navigator containing the plug-in configuration. You should cache a copy of the build process reference for use during execution as it contains many properties and methods that you will find useful.

Execute

The Execute method is called to perform the plug-in processing during the relevant build steps. It is passed an SandcastleBuilder.Utils.PlugIn..::.ExecutionContext object that defines the current execution context. If your plug-in determines that it does not need to run, it should set the ExecutionContext..::.Executed property to false. This is especially important for plug-ins with the InsteadOf behavior. If none run, the default processing will occur.

Dispose

The Dispose method can be used to dispose of any resources used during the build process. If you do not have any resources that need to be disposed of, this method can be left blank.

Execution Notes

There are certain conditions to be aware of when choosing and coding the execution behavior for your plug-in.

  • The earliest execution point for a plug-in is the After behavior with the Initializing step.
  • The Before and InsteadOf behaviors cannot be used with the Initializing, Canceled, or Failed steps.
  • The InsteadOf behavior cannot be used with the FindingTools or Completed steps.
  • The InsteadOf behavior always takes precedence. The build process will not call any plug-ins with Before or After behavior for the step if an InsteadOf plug-in runs. As such, it is up to the plug-in with the InsteadOf behavior to call the ExecuteBeforeStepPlugIns and ExecuteAfterStepPlugIns methods to run them if needed.
  • If the build step involves creating, modifying, or deleting a non-script file or folder, the Before behavior is always executed prior to creating/modifying/deleting the file or folder. Use the After behavior if you need to guarantee that the file or folder exists or you do not want your version overwritten. The exceptions to this rule are MSBuild project files (*.proj) and MRefBuilder.config which are always created prior to running the Before behavior plug-ins. This allows you to modify the script files prior to them being ran.
  • If the build step involves creating, modifying, or deleting a script file or folder and the InsteadOf behavior is used, the plug-in is responsible for creating the script file/folder. All normal processing involving the file/folder including its creation is skipped.
  • The GenerateHelpFormatTableOfContents, GenerateHelpFileIndex, GenerateHelpProject, UpdateTableOfContents, and CompilingHelpFile steps will run once for each help file format selected. You can use the CurrentFormat property to determine the current help file format being built in order to skip or alter the plug-in's processing based on the help file format.
  • Be aware that the Help 1.x index and table of contents files and the website table of contents file are actually generated as part of the ExtractHtmlInfo step. However, the before and after plug-in behaviors for the index and table of contents steps in each of those formats will still be executed.

See Also

Other Resources

Build Process Plug-Ins


Custom Build Components

[image]

Sandcastle Help File Builder Documentation
Custom Build Components
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Custom build components can be used to add additional features to the help topics as they are generated by the Sandcastle BuildAssembler.exe tool and are supported by the help file builder. The following build components are supplied with the help file builder and are pre-configured for you in its configuration file templates:

  • Code Block Component
  • Help Attributes Component
  • JavaScript Declaration Syntax Generator
  • Post-Transform Component
  • Resolve Conceptual Links Component
  • Show Missing Documentation Component
  • Version Information Component

You can override the default configuration for the Code Block Component and the Post-Transform Component as described below. The Help Attributes and Show Missing Documentation components are configured via project properties. The Resolve Conceptual Links and Version Information components have no configurable properties. The JavaScript syntax generator is included automatically when you select the JavaScript option in the SyntaxFilters property. As such, they will not appear in the Component Configuration Dialog.

The following build components are not pre-configured and must be added to the project in order to use them.

  • IntelliSense Component
  • A set of cached build data components that cache key information such as comment, reflection index information, and MSDN URLs across builds in order to speed them up.

Selecting and Configuring Build Components

To select and configure build components, select the ComponentConfigurations project property and click the "..." button to the right of it. The dialog below is then displayed. As noted above, the Code Block Component and Post-Transform Component already exist in the help file builder configuration file templates so you do not need to add them to the project unless you want to override their default configurations.

Build Component Configuration Dialog

Available build components are listed on the left. Version, copyright, and description information is shown below the list and will change to reflected the currently selected component. The list on the right displays the components selected for use in the current project. Double-click a component on the left or click the Add button to add a component to the project. Click the Configure button to configure the component. Click the Delete button to delete a component from the project. The checkboxes next to each project component allow you to enable or disable the component within the project. If disabled, it will remain in the project with its configuration information but it will not be used during a build. As noted above, the Code Block and Post-Transform components appear by default in the help file builder configuration file so if you disable your customized settings, the component will still be used but will revert to the default configuration. Third-party build components contain a default configuration but it may not be suitable for your project. As such, you should configure each component that you add to the project so that it will work as expected.

For information on writing your own custom build components, see the Code Project article Creating Custom Build Components for Sandcastle.

Adding Third-Party Build Components

Third-party build components can also be added by copying their assembly, configuration file, and any supporting files to the .\Build Components folder or a subfolder beneath it in the help file builder's Common Application Data folder. See the Special Folder Locations topic for more information. Refer to the component's documentation for information about its features and configuration options. See the Creating a Component Configuration File topic for information on creating a configuration file for a third-party component that does not have one or to allow configuration of a stock Sandcastle build component. For a list of current third-party build components, see the Links to Resources topic. For a list of current third-party custom build components, see the Links to Resources topic.

See Also

Other Resources

Creating a Component Configuration File
Project Properties Window


Cached Build Components

[image]

Sandcastle Help File Builder Documentation
Cached Build Components
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

There are three custom build components that can be used to cache some key information and potentially speed up the BuildAssembler build step.

  • Cached Framework Comments Index Data - Caches index file information about the location of the framework member comments. Comment file caches are language and version specific so multiple copies may be created based on the project language and framework version settings. The name of the cache file is related to the language and framework version.
  • Cached Reflection Index Data - Caches index file information about the location of the base .NET Framework members in the reflection data files.
  • Cached MSDN URL References - Caches resolved MSDN URLs for the Resolve Reference Links build component when SdkLinkType is set to MSDN. This saves it having to hit the web service in every build to get the same information.

Component Usage

To use these components, select the ComponentConfigurations property in the project and add the three components noted above to your project. The components contain no editable configuration options. If using the build components in your own build scripts or with other build tools, see the Example.config file included with the standalone build component download for an example of how to add the components to the configuration file.

Note:

You must perform at least one build with any project to create the comments and reflection data cache files. The MSDN URL cache is cumulative so you must perform at least one build with each project to which you add it so as to ensure that all URLs for the given project are in the cache. Once built, you can find the cache files in the .\Cache folder located in the EWSoftware\Sandcastle Help File Builder folder in the Local Application Data folder. Under Vista, the local application data folder is usually equivalent to the value of the %LOCALAPPDATA% environment variable value. Under Windows XP, the equivalent is usually %USERPROFILE%\Local Settings\Application Data. To rebuild the cache files, simply delete them from that location.

Usage Benefits

These are some observations made by using the three components in various projects:

  • The first two provide the least benefit and are fairly consistent in the amount of time saved. They benefit small projects with shorter build times the most and, to a certain extent, can be used to offset the rather lengthy initialization time of the Resolve Reference Links component. Nothing could be done to shorten its startup time unfortunately (see below).
  • The cached MSDN URL component can provide a huge performance increase. This will be most evident in control libraries in which the classes are derived from Windows Forms or web controls which have a large number of inherited members thus causing a spike in the number of MSDN lookups that occur. Non-UI projects with base classes that are simpler result in fewer lookups and benefit less.
  • Using the cached MSDN URL component is, after the initial build, almost equivalent to setting the SdkLinkType property to None in regards to build time but adds the benefit of keeping the actual online links in place.
  • That said, the larger the project the less benefit you may see. For example, if your project contains 10,000+ topics, it is already going to run pretty long and the few minutes saved by the cached URLs may end up making little difference in the end.

An attempt was made to try to cache the index information generated when the Resolve Reference Links component initializes but in that case, the information is much more complex and there is so much of it that there was a negative impact on performance. As such, it must still load the index information in the normal fashion when it starts. As noted, you can use the first two cached build components to offset that somewhat.

Example Configurations

The examples given below are taken from the Sandcastle Help File Builder's configuration file templates. When used with it, you may specify various replacement tags such as {@SHFBFolder}, {@LocalDataFolder}, and {@SDKLinks} to insert special folder and project option values into the configuration at build time. If using the component in your own build scripts, replace the tags with an actual absolute or relative path or an appropriate option value.

When documenting a .NET 3.0 or .NET 3.5 assembly, there are several framework comments files. You can add additional cache elements specifying the additional framework comments files. Be sure to give each cacheFile attribute a unique name.

CopyCached Reflection Index Data Example
<!-- Cached Reflection Index Data component.  This should replace
     the first instance of the CopyFromIndexComponent. -->
<component id="Cached Reflection Index Data"
  type="SandcastleBuilder.Components.CachedCopyFromIndexComponent"
  assembly="{@SHFBFolder}SandcastleBuilder.Components.dll">
    <index name="reflection" value="/reflection/apis/api"
       key="@id" cache="10">
        <cache base="{@SandcastlePath}Data\Reflection"
            recurse="true" files="*.xml"
            cacheFile="{@LocalDataFolder}Cache\Reflection.cache"/>
        <data files="reflection.xml" />
    </index>
    <copy name="reflection" source="*" target="/document/reference" />
</component>
CopyCached Framework Comments Index Data Example
<!-- Cached Framework Comments Index Data component.  This should
     replace the third instance of the CopyFromIndexComponent. -->
<component id="Cached Framework Comments Index Data"
  type="SandcastleBuilder.Components.CachedCopyFromIndexComponent"
  assembly="{@SHFBFolder}SandcastleBuilder.Components.dll">
    <index name="comments" value="/doc/members/member"
      key="@name" cache="100">
      <cache files="%SystemRoot%\Microsoft.NET\Framework\v2.0.50727\en\*.xml"
        cacheFile="{@LocalDataFolder}Cache\en_2.0.50727.cache" />
      <data files="ExtraComments.xml" />
      <data files="TestDoc.xml" />
      <data files="_InheritedDocs_.xml" />
    </index>
    <copy name="comments" source="*" target="/document/comments" />
</component>
CopyCached MSDN URL References Example
<!-- Cached MSDN URL references component.  This should replace
     the standard ResolveReferenceLinksComponent2 build component. -->
<component id="Cached MSDN URL References"
  type="SandcastleBuilder.Components.CachedResolveReferenceLinksComponent"
  assembly="{@SHFBFolder}SandcastleBuilder.Components.dll"
  locale="{@Locale}" linkTarget="{@SdkLinkTarget}">
    <cache filename="{@LocalDataFolder}Cache\MsdnUrl.cache" />
    <targets base="{@SandcastlePath}Data\Reflection" recurse="true"
        files="*.xml" type="{@SDKLinks}" />
    <targets files="reflection.xml" type="{@ProjectLinks}" />
</component>

See Also

Other Resources

Custom Build Components


Code Block Component

[image]

Sandcastle Help File Builder Documentation
Code Block Component
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This topic describes the Code Block Component features.

  • Usage Benefits
  • Custom Attributes
  • Literal XML And Other Special Characters
  • Nested Code Tags
  • Example Configuration
  • See Also

Usage Benefits

The Code Block Component is used to extend the functionality of the XML comments <code> tag. It provides the following features:

  • Excess leading whitespace is stripped from the <code> blocks to left-align them correctly.
  • It adds support for optional line numbering.
  • It adds support for optional collapsible regions for code in #region and #if/#else/#endif blocks with support for nested collapsible regions. The C++ and VB.NET equivalents are supported too.
  • A default title can be added based on the language that the code represents.
  • A "Copy" link appears to the right on the title line that allows you to copy the code sample to the clipboard. The code is copied as plain text without the highlighting and line numbers if used.
  • It adds support for reading in an external source file or a defined region of an external source file so that you can keep code samples in a buildable project to test them for correctness and to do away with managing the code samples in the XML comments or include files.
  • Support is provided for nested code tags which allows you to merge code from two or more code snippets into a single code example.
  • C#, VB.NET, C++, J#, JScript.NET, XAML, and JavaScript code blocks can be associated with the language filter to show or hide them based on the language filter setting (VS2005 style only).
  • Syntax highlighting of code blocks in <code> tags. Languages supported include C#, VB.NET, JScript.NET, C++, J#, C, JavaScript, VBScript, XAML, XML, HTML, SQL script, PowerShell script, and Python. An external configuration file is used so that it is possible to extend the colorizer to support other languages. The stylesheet is also replaceable. All of the features noted above are available whether or not you enable the colorizing feature. The code colorizer is a modified and extended version of the one written by Jonathan de Halleux in the Code Project article Multiple Language Syntax Highlighting, Part 2: C# Control. The modified code is available with the source download for the help file builder and the build components.

Custom Attributes

The following attributes can be added to the <code> tag in XML comments. They can be used in any combination with each other with the exception of region and removeRegionMarkers which, if used, must be paired with a source attribute. All attribute names and values are case-sensitive.

The source, region, and removeRegionMarkers Attributes

This feature is based on an idea suggested by Morten Nielsen in the MSDN Documentation Forum. The source attribute is used to specify that the code block's content should be read from an external source code file. If used alone, the entire file is used. The optional region attribute can be used to limit the code to a specific section of the file delimited with the named #region (#pragma region for C++). The #region and #endregion tags are excluded from the extracted section of code.

This is not to be confused with the XML comments <include> tag. This extension is intended to extract code from actual source files. This allows you to manage your code examples in buildable projects to test them for correctness as a project is developed and altered in the future. It also saves you from managing the code in the XML comments and does not require that the code be HTML encoded as it is when written in the comments. The code will be HTML encoded when it is read in for processing. When used, it is assumed that there is no code within the comment tag itself and thus it will always be self-closing. Here are some examples:

Retrieve all code from an external file and use the VB.NET syntax to color it. The path is relative to the basePath configuration element.

Copy
<code source="..\Examples\WholeDemo.vb" lang="vbnet" />

Retrieve a specific #region from an external file.

Copy
<code source="..\Examples\SeveralExamples.vb"
    region="Example 1" lang="vbnet" title="Example #1" />

Note that VB.NET does not allow #Region and #End Region within a method body. Other file types such as XML, XAML, and SQL script do not understand #region statements. However, if you want to extract a region from a VB.NET method body or a section of another file type, you can add the region statements in comments to workaround the limitation. The component will still find it and extract the region.

CopyCommented Region Examples
VB.NET Example
Public Sub SomeMethod()
    ' #Region VB.NET Snippet
    Dim x As Integer

    For x = 1 To 10
        Console.WriteLine(x)
    Next x
    ' #End Region
End Sub

XAML Example
<Style x:Key="SpecialButton" TargetType="{x:Type Button}">
  <Style.Triggers>
    <!-- #region XAML Snippet -->
    <Trigger Property="Button.IsMouseOver" Value="true">
      <Setter Property = "Background" Value="Red"/>
    </Trigger>
    <!-- #endregion -->
  </Style.Triggers>
</Style>

SQL Example
-- #region SQL snippet
Select *
From   tblName
Where  LastName = 'SMITH'
-- #endregion

/* #region Another snippet */
Select *
From   tblName
Where  FirstName = 'JOHN'
/* #endregion */

The removeRegionMarkers attribute can be used to specify whether or not region markers within the imported code file or region are removed. If not specified or set to false, any nested region markers are left in the imported code block. If specified and set to true, nested region markers are removed from the imported code. This is useful for removing nested region markers from larger code samples that contain smaller snippets of code used in other examples. The default setting (false) can be overridden via the component configuration.

The lang or language Attribute

These attributes allows you to override the default language specified in the component's configuration. Either one will have the same effect. Any <code> tag without a lang/language attribute will use the value specified in the component's configuration. For example, if most or all of your code examples are in C#, you can set the default language in the configuration to "cs". If you have an example in VB.NET, you can add lang="vbnet" to colorize that example as VB.NET code. The possible language values in the supplied configuration file are as follows:

Language ID (case-insensitive) | Language Syntax Used
cs, C#, CSharp | C#
cpp, cpp#, C++, CPlusPlus | C++
c | C
EcmaScript, js, JavaScript | JavaScript
jscript, jscript#, jscriptnet, JScript.NET | JScript.NET
VB, VB#, vbnet, VB.NET | VB/VB.NET
vbs, vbscript | VBScript
htm, html, xml, xsl | XML
XAML | XAML
jsharp, J# | J#
sql, sql server, sqlserver | SQL script
pshell, powershell, ps1 | PowerShell script
py, python | Python
Anything else (i.e. "none") | No highlighting
The numberLines Attribute
This attribute allows you to override the default setting in the component's configuration. For example, if the default setting is false to turn off line numbering, you can add numberLines="true" to enable numbering on a specific code example.
The outlining Attribute
This attribute allows you to override the default setting in the component's configuration. For example, if the default setting is false to not add collapsible regions, you can add outlining="true" to enable collapsible regions on a specific code example. Note that if a code block contains no #region or #if blocks, outlining is automatically disabled and it will not reserve space in the margin for the markers.
The keepSeeTags Attribute
When set to true, this attribute allows you to tell the code colorizer to preserve <see> tags within the code so that they can be rendered as clickable links to the related topic. If set to false, the default, any <see> tags within the code will be colorized and passed through as literal text. When using this option, you may find that you need to specify inner text for the <see> tag so that the link text appears as you want it. If the self-closing version of the tag is used, Sandcastle will generally set the link text to the name of the item plus any parameters if it is a generic type or takes parameters which may not be appropriate within a code sample.
The tabSize Attribute
When the code blocks are formatted, tab characters are replaced with a set number of spaces to preserve formatting. This attribute can be used to override the default setting for a language which is specified in the syntax file. For example, if the default tab size for a language is four, adding tabSize="8" will force it to use eight spaces instead. If set to zero, the syntax file setting is used. This attribute sets the default tab size for unknown languages when used in the component's configuration.
The title Attribute
This attribute allows you to add a title that appears before the code block. An example of its use would be to label the example with a description. If omitted and the defaultTitle attribute on the code block component's colorizer element is true, the language name will appear for the title. If it is set to false, no title will appear. If using default titles and you do not want a title on a particular block, set the title attribute to a single space (" ").
The filter Attribute
This attribute allows you to specify whether or not the code block should be connected to the language filter (VS2005 only). If omitted or set to true, the code block will be connected to the appropriate language filter if it is present. If set to false, it is not connected and will remain visible at all times.

Literal XML And Other Special Characters

NDoc had an additional escaped attribute that let you enter literal XML in the code block without having to HTML encode things like the angle brackets. An attempt was made to support that attribute in the code block component. However, the XML document as created by Sandcastle and passed to the component has all inter-element whitespace and line feeds stripped from it. As such, it loses all formatting in the escaped XML and renders it on a single, unbroken line. This made the escaped attribute useless and it was removed. If you want to include XML or other unencoded information you can do one of the following:

  • Utilize the source attribute to read it in from an external file instead.

  • Use a CDATA section to encapsulate the code so that special characters and formatting are preserved. For example:

    CopyCDATA Example
    /// <example>
/// <code lang="xml" title="Example Configuration">
/// <![CDATA[
/// <?xml version="1.0" encoding="utf-8"?>
/// <config>
///   <path>C:\Test\</path>
///   <filespec mask="*.txt" />
/// </config>]]>
/// </code>
/// </example>

    Be sure to start the example code on a new line after the opening "<![CDATA[" tag as shown so that the leading whitespace can be normalized correctly.

    Note:

    The inclusion of a CDATA tag anywhere in the code comments can cause Visual Studio 2005 to lock up when you type an angle bracket within a comment block. If you are affected by this issue, there is a hotfix available at: https://connect.microsoft.com/VisualStudio/Downloads/DownloadDetails.aspx?DownloadID=9646.

Using either of the methods above preserves the formatting and has the same effect as the escaped attribute in NDoc.

Nested Code Tags

You can import multiple code snippets into one common colorized code block by nesting code tags within a parent code tag. On nested code tags, only the source and region attributes will be utilized. All other attributes that control colorization of the merged code block will be retrieved from the parent code tag.

CopyNested Code Tag Example
<code title="Nested code tag example" lang="VB.NET">
    <code source="..\Class1.vb" region="Snippet #1" />
    <code source="..\Class1.vb" region="Snippet #2" />
</code>

Literal code can also be mixed in between the nested code tags. However, there are some limitations. All tags and literal code should be flush left within the parent code tag or you will end up with additional spaces before the first line of each nested code tag. There may still be additional spaces before the literal code. This is caused by the indentation included when the XML comments file is created by the compiler. If this is a problem, move the example to an include file and remove the excess leading whitespace. Use an include tag to bring it into the XML comments. When done this way, the compiler preserves the spacing when writing the example out to the XML comments file.

CopyNested Code Tag Example
<code title="Nested code tag example" lang="VB.NET">
<code source="..\Class1.vb" region="Snippet #1" />

' ... Some stuff happens here ...

<code source="..\Class1.vb" region="Snippet #2" />
</code>

Example Configuration

The following is the default configuration for the code block component. It should be inserted into the configuration file just ahead of the TransformComponent. All attribute names and values are case-sensitive.

Note:

This component must be paired with the PostTransformComponent as it is used to insert the script and stylesheet references in pages that have colorized code. See below for details.

CopyExample Configuration
<!-- Code block component configuration.  This must appear before the
     TransformComponent.  See also: PostTransformComponent. -->
<component type="SandcastleBuilder.Components.CodeBlockComponent"
  assembly="{@SHFBFolder}SandcastleBuilder.Components.dll"
  id="Code Block Component">
    <!-- Base path for relative filenames in source attributes
         (optional) -->
    <basePath value="{@ProjectFolder}" />

    <!-- Connect to language filter (optional).  If omitted,
         language filtering is enabled by default. -->
    <languageFilter value="true" />

    <!-- Allow missing source files (Optional).  If omitted,
         it will generate errors if referenced source files
         are missing. -->
    <allowMissingSource value="false" />

    <!-- Remove region markers from imported code blocks.  If omitted,
         region markers in imported code blocks are left alone. -->
    <removeRegionMarkers value="false" />

    <!-- Code colorizer options (required).
         Attributes:
            Language syntax configuration file (required)
            XSLT style file (required)
            "Copy" image file URL (required)
            Default language (optional)
            Enable line numbering (optional)
            Enable outlining (optional)
            Keep XML comment "see" tags within the code (optional)
            Tab size for unknown lanugages (optional, 0 = use default)
            Use language name as default title (optional) -->
    <colorizer syntaxFile="{@SHFBFolder}Colorizer\highlight.xml"
        styleFile="{@SHFBFolder}Colorizer\highlight.xsl"
        copyImageUrl="../icons/CopyCode.gif"
        language="cs" numberLines="false" outlining="false"
        keepSeeTags="false" tabSize="0" defaultTitle="true" />
</component>

The example given above is taken from the Sandcastle Help File Builder's configuration file. When used with it, you may specify the replacement tag {@SHFBFolder} to insert the help file builder's folder in the file path and the {@ProjectFolder} replacement tag to specify the current project's folder. These are replaced at build time with the appropriate values. These replacement tags can also be specified in the configuration dialog when configuring project-specific configurations for the component from within the help file builder. If using the component in your own build scripts, replace the tags with an actual absolute or relative path.

The basePath element is optional. If specified, it defines the base path to use for relative paths in the source attributes of code blocks. If omitted or left blank, the current folder at build time is assumed to be the base path.

The languageFilter element is optional. If omitted, or if specified and set to true, and the code block's language is C#, VB.NET, C++, or J# it will be connected to the page's language filter so that it is shown or hidden based on the language filter's setting (VS2005 only). If the languageFilter value is set to false, no language filtering will occur and all code blocks will be visible at the same time.

The allowMissingSource element is optional. If omitted, or if specified and set to false, any code block that references a source code file or region within a file will generate an error and stop the build if the source code file or the region in it cannot be found. If specified and set to true, only warnings will be generated and the build will be allowed to run to completion. The code blocks with the missing information will contain an error message referring you to the log file.

The removeRegionMarkers element is option. If omitted, or if specified and set to false, any region markers in imported code blocks are left in the imported code. If specified and set to true, any region markers nested within the imported code file or region are removed. This is useful for getting rid of region markers in code that is used both for a larger example and parts of it that are used in smaller snippet examples. This setting can be overridden by specifying the attribute on individual code elements.

The colorizer element is required along with the syntaxFile, styleFile, and copyImageUrl attributes which define the default syntax definition file, the transformation file used by the colorizer, and the URL to use for the "Copy" image that appears to the right on the title line. The supplied highlight.xml file contains the syntax definitions for the languages supported by the colorizer. The supplied highlight.xsl file defines the XSLT transformation used to convert the parsed code block into the colorized HTML. The copyImageUrl value is the location of the image file to use for the "Copy" link. It should be specified as a path relative to the HTML output folder (normally html\. It does not have to physically exist at the time the component is used. The PostTransformComponent copies an image to the appropriate location. All other attributes are optional. If specified, they define the defaults for code blocks that do not specify the matching attribute. The optional defaultTitle attribute specifies whether or not to use the language name as the title if a specific title is not supplied.

See Also

Other Resources

Post-Transform Component
Custom Build Components


Help Attributes Component

[image]

Sandcastle Help File Builder Documentation
Help Attributes Component
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Help Attributes Component is used to used to insert additional MSHelp:Attr attributes into the XML data island in each generated API help topic. This is useful for adding extra DocSet and other attributes to the topics that are not added by the default Sandcastle transformations. Be aware that the Sandcastle transformations add ApiLocation, ApiType, DevLang, Locale, and TopicType attributes with appropriate values to each generated API topic so there is no need to add them again using this component.

The following is the default configuration for the help attributes component. It should be inserted into the configuration file after the TransformComponent.

CopyExample Configuration
<!-- HTML Help 2 attribute configuration.  This must appear after
     the TransformComponent. -->
<component type="SandcastleBuilder.Components.MSHelpAttrComponent"
  assembly="{@SHFBFolder}SandcastleBuilder.Components.dll">
    <!-- Additional attributes (required) -->
    <attributes>
        <!-- At least one attribute element must be defined.  The
             "name" attribute is required.  The "value" attribute is
             optional. -->
        <attribute name="DocSet" value="NETFramework" / >
        <attribute name="DocSet" value="{@HtmlHelpName}" / >
        <attribute name="TargetOS" value="Windows" / >
    </attributes>
</component>

The example given above is taken from the Sandcastle Help File Builder's configuration file. When used with it, the replacement tag {@SHFBFolder} is used to insert the help file builder's folder in the file path. This is replaced at build time with the appropriate value. If using the component in your own build scripts, replace the tag with a relative or absolute path to the component assembly.

There must be at least one attribute element within the attributes element. Each attribute element has a name and value attribute that specify the name and value of the MSHelp:Attr entry added to each topic.

Tip:

For filtering to work correctly in Help 2 files, you should add the attributes shown in the example above as the minimum set. Replace the "{@HtmlHelpName}" value with the name of your documentation set.

See Also

Other Resources

Custom Build Components


IntelliSense Component

[image]

Sandcastle Help File Builder Documentation
IntelliSense Component
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IntelliSense Component is used to extract the XML comments into files that can be used for IntelliSense. Only the basic set of tags needed for IntelliSense are exported and only for documented API members. This can significantly reduce the size of the XML comments files used for IntelliSense and will remove any details about undocumented API members such as private and internal members unless they are included in the build. When used in conjunction with the Show Missing Documentation Component, this component can be used to produce XML comments files for assemblies that do not currently have one so that you can fill in comments for them.

The following is the default configuration for the IntelliSense component. It should be inserted into the configuration file before the TransformComponent. If you are using the Show Missing Documentation component, you should insert it after that one so that you can get information about missing documentation items as well.

CopyExample Configuration
<!-- IntelliSense component configuration.  This must appear
     before the TransformComponent. -->
<component type="SandcastleBuilder.Components.IntelliSenseComponent"
  assembly="{@SHFBFolder}SandcastleBuilder.Components.dll">
 <!-- Output options (optional)
      Attributes:
         Include Namespaces (false by default)
         Namespaces filename ("Namespaces" if not specified or empty)
         Directory (current folder if not specified or empty) -->
 <output includeNamespaces="false" namespacesFile="Namespaces"
     folder="{@OutputFolder}" />
</component>

The example given above is taken from the Sandcastle Help File Builder's configuration file. When used with it, the replacement tags {@SHFBFolder} and {@OutputFolder} are used to insert the help file builder's folder and the project's output folder in the file paths. These are replaced at build time with the appropriate values. If using the component in your own build scripts, replace the tags with a relative or absolute path to the component assembly and output folder respectively.

The folder attribute identifies the folder in which to place the IntelliSense files. One file is created for each assembly. If set to true, the includeNamespaces option will cause the build component to output project summary and namespace summary comments to a file identified by the namespacesFile attribute in the given output folder. If specified, you should enter only the name and omit any file path and extension. The namespaces file is not used for IntelliSense but can be added to one or more help file builder projects as a common documentation source to share project and namespace summary information betwen projects.

See Also

Other Resources

Custom Build Components


JavaScript Declaration Syntax Generator

[image]

Sandcastle Help File Builder Documentation
JavaScript Declaration Syntax Generator
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The JavaScriptDeclarationSyntaxGenerator is used to add a JavaScript Syntax section to each generated API topic. This version differs from the ScriptSharpDeclarationSyntaxGenerator in that it looks for a <scriptSharp /> element in the <api> node and, if found, only then will it apply the casing rules to the member name. If not present, no casing rules are applied to the member names thus it is suitable for use with regular JavaScript such as that used in AjaxDoc projects.

In order to use this script generator, you should modify the Sandcastle transformation file FixScriptSharp.xsl by adding the following template as the second one in the file. The help file builder uses a modified version of the transformation so that you do not need to apply the change when using it.

CopyFixScriptSharp.xsl Patch
<!-- Add a "scriptSharp" element to each API node so that the
     JavaScript syntax generator will apply the casing rules to
     the member name. -->
<xsl:template match="api">
  <xsl:copy>
    <xsl:apply-templates select="node() | @*" />
    <scriptSharp />
  </xsl:copy>
</xsl:template>

To use the syntax generator, add it to the SyntaxComponent configuration as in the following example:

CopySyntax Generator Example
<component type="Microsoft.Ddue.Tools.SyntaxComponent"
  assembly="%DXROOT%\ProductionTools\BuildComponents.dll">
  <syntax input="/document/reference" output="/document/syntax" />
  <generators>
    <generator type="SandcastleBuilder.Components.JavaScriptDeclarationSyntaxGenerator"
        assembly="C:\SandcastleBuilder\SandcastleBuilder.Components.dll" />
  </generators>
</component>

When using the help file builder, the syntax generator is included automatically when you select the JavaScript option in the SyntaxFilters property.

See Also

Other Resources

Custom Build Components


Post-Transform Component

[image]

Sandcastle Help File Builder Documentation
Post-Transform Component
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Post-Transform Component is used to provide the following additional features to modify the transformed HTML for a help topic:

  • It can insert a logo image at the top of each help topic to the left, right, or above the topic title.
  • It acts as a companion component to the Code Block Component to add the supporting links for the colorizer script and stylesheet only when required.
  • For the Prototype style, it hides the language combo box if only one language appears in the Syntax section.
  • It acts as a companion component to the Version Information Component to add version information to the help topics if used with the help file builder. If used outside the help file builder, a shared content file containing the necessary overrides is needed or a modification is required to the Sandcastle reference content files (see below).

Example Configuration

The following is the default configuration for the post-transform component. All attribute names and values are case-sensitive. It should be inserted into the configuration file right after the TransformComponent. This component can be used by itself if you do not want to use the code block and/or version information components. However, this component is required and must be used if you do use the code block and/or version information components.

If the version information component is used, this component will insert the version information found into the help topic. For the code block component, it adds the script and stylesheet links to the document's <head> section. While they could both be inserted into the first code element by the code block component and would work, the link for the stylesheet is only considered valid HTML if it appears in the <head> section. By using this component to insert it, it keeps the HTML well formed and valid. Since it is inserting the stylesheet link, I placed the code to insert the script element in here as well.

CopyExample Configuration
<!-- Post-transform component configuration.  This must appear after the
     TransformComponent.  See also: CodeBlockComponent. -->
<component type="SandcastleBuilder.Components.PostTransformComponent"
  assembly="{@SHFBFolder}SandcastleBuilder.Components.dll"
  id="Post-transform Component">
    <!-- Code colorizer files (required).
         Attributes:
            Stylesheet file (required)
            Script file (required)
            "Copy" image file (required) -->
    <colorizer stylesheet="{@SHFBFolder}Colorizer\highlight.css"
        scriptFile="{@SHFBFolder}Colorizer\highlight.js"
        copyImage="{@SHFBFolder}Colorizer\CopyCode.gif" />

    <!-- Base output path for the files (required).  This should match
         the parent folder of the output path of the HTML files (see
         SaveComponent). -->
    <outputPath value="Output" />

    <!-- Logo image file (optional).  Filename is required. The height,
         width, altText, placement, and alignment attributes are
         optional. -->
    <logoFile filename="" height="0" width="0" altText=""
        placement="left" alignment="left" />
</component>

The example given above is taken from the Sandcastle Help File Builder's configuration file. When used with it, you may specify the replacement tag {@SHFBFolder} to insert the help file builder's folder in the file path. This is replaced at build time with the appropriate value. This replacement tag can also be specified in the configuration dialog when configuring project-specific configurations for the component from within the help file builder. The same applies to the {@ProjectFolder} replacement tag which can be used in the logo image's filename attribute to insert a reference to the project folder. If using the component in your own build scripts, replace the tags with an actual absolute or relative path. If a relative file path is specified, it will be relative to the current working folder at build time.

The colorizer element defines the files used by the code colorizer script. The stylesheet attribute defines the stylesheet to use for the colorized code. The scriptFile attribute defines the script file containing the JavaScript code used to show and hide the collapsible sections and copy the code to the clipboard (Internet Explorer only). The copyImage attribute defines the image file to use for the "Copy Code" link. The supplied highlight.css, highlight.js, and CopyCode.gif files are used by default. A copy of the image file with an "_h" suffix should also exist if you would like to see a different image when the mouse hovers over the link (i.e. CopyCode_h.gif). If it does not exist, the same image is used for both. You can edit the stylesheet to use different colors for the highlighted code elements. If using the help file builder, you can also add a new stylesheet using the same name to an html\ folder in the project. The project's copy will overwrite the default stylesheet. The same applies to the image files. However, their location is determined by the copyImageUrl attribute in the code block component's configuration.

The outputPath element is used to specify where the stylesheet and script files are to be copied. This should match the parent folder of the path that is used in the SaveComponent that saves the help topic HTML files. By default, it is Output\. The image file is copied to the location specified in the CodeBlockComponent configuration which is relative to this path. See its description for details. The script is copied to the scripts\ folder and the stylesheet is copied to the styles\ folder under this path.

The logoFile element is optional. Using it, you can add a logo image to the header of each help topic page that will appear to the left, right, or above the topic title. If no image file is specified or the element is omitted, no image will appear in the header. The height and width attributes can be used to specify the height and width of the image. If omitted or set to zero, the image will be displayed using its actual size. By using these attributes, you can scale a larger image down or scale a smaller image up to get a better fit. The configuration dialog for the component allows you to select an image and adjust its size with a preview area. The altText attribute lets you specify some alternate text that can appear for the image. The placement attribute allows you to specify where the image is placed (to the left, to the right, or above the topic title). When set to above, the alignment attribute specifies how the image is aligned (left, right, or centered).

Version Information

As noted, the component can insert version information into the topic when used with the VersionInformationComponent. If not used, no version information will be listed. The help file builder contains the necessary modifications to its shared content files to add version information. If you use this component in your own scripts or build tools, you will need to include a copy of this shared content file or modify the Sandcastle reference content files in order to add the version parameter. To do so, add the text "Version: {2}" to the locationInformation entry in the reference_content.xml file for the Prototype, VS2005, and Hana styles and the requirementsAssemblyLayout entry in the reference_content.xml file for the VS2005 and Hana styles.

See Also

Other Resources

Code Block Component
Version Information Component
Custom Build Components


Resolve Conceptual Links Component

[image]

Sandcastle Help File Builder Documentation
Resolve Conceptual Links Component
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

A bug in the standard ResolveConceptualLinksComponent causes any specified inner text on <link> tags to be ignored and instead it always uses the topic's title. This component is a reimplementation that fixes that bug and adds some new features (see below).

Note:

Due to the bug fix, any links you may have in your conceptual content files will start showing the inner text when built using this replacement component. You may need to review your documentation and either remove or update the inner text to something more appropriate on your links.

Usage Benefits

The replacement contains the following features and fixes:

  • Broken links use the None style rather than the Index style so that it is apparant that they do not work.
  • The inner text from the conceptual link is used if specified.
  • On broken links, when the showBrokenLinkText option is true and there is no inner text, the target value is displayed.
  • Conceptual link targets can include an optional anchor name from within the target such as "#Name" (i.e. <link xlink:href="3bdb6eb5-5e23-51c2-0051-3e224f82c201#Section2" />).
  • Unnecessary whitespace is removed from the link text.
  • If the companion file contains a <linkText> element and no inner text is specified, its value will be used for the link text rather than the title. This allows for a shorter title or description to use as the default link text.

Example Configuration

The following is the default configuration for the resolve conceptual links component. It should be inserted into the configuration file after the TransformComponent.

CopyExample Configuration
<component type="SandcastleBuilder.Components.ResolveConceptualLinksComponent"
  assembly="{@SHFBFolder}SandcastleBuilder.Components.dll"
  showBrokenLinkText="true">
    <targets base="xmlComp" type="{@ProjectLinks}" />
</component>

The example given above is taken from the Sandcastle Help File Builder's configuration file. When used with it, the replacement tag {@SHFBFolder} is used to insert the help file builder's folder in the file path. This is replaced at build time with the appropriate value. If using the component in your own build scripts, replace the tag with a relative or absolute path to the component assembly. The {@ProjectLinks} option should be replaced with none, local, or index based on your preferred link type.

See Also

Other Resources

Custom Build Components


Show Missing Documentation Component

[image]

Sandcastle Help File Builder Documentation
Show Missing Documentation Component
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The "show missing documentation" build component is used to add "missing" notes for missing namespace comments and summary, parameter, returns, value, and remarks tags. It can also add default summary documentation for constructors. The functionality in this component used to be integrated with the help file builder itself. However, the XPath queries used to look up the information in the comments files and reflection information file proved to be too slow when used on extremely large builds with tens of thousands of topics. By moving the processing to a build component, the amount of information to search is greatly reduced and the time to add missing item comments is now negligible.

Example Configuration

The following is the default configuration for the "show missing documentation" component. It should be inserted into the configuration file before the TransformComponent. All attribute names and values are case-sensitive.

CopyExample Configuration
<!-- Show missing documentation component configuration.  This must
     appear before the TransformComponent. -->
<component type="SandcastleBuilder.Components.ShowMissingComponent"
  assembly="{@SHFBFolder}SandcastleBuilder.Components.dll">
    <!-- All elements are optional. -->
    <!-- Auto-document constructors (true by default) -->
    <AutoDocumentConstructors value="{@AutoDocumentConstructors}" />

    <!-- Show missing param tags (true by default) -->
    <ShowMissingParams value="{@ShowMissingParams}" />

    <!-- Show missing typeparam tags (true by default) -->
    <ShowMissingTypeParams value="{@ShowMissingTypeParams}" />

    <!-- Show missing remarks tags (false by default) -->
    <ShowMissingRemarks value="{@ShowMissingRemarks}" />

    <!-- Show missing returns tags (true by default) -->
    <ShowMissingReturns value="{@ShowMissingReturns}" />

    <!-- Show missing summary tags (true by default) -->
    <ShowMissingSummaries value="{@ShowMissingSummaries}" />

    <!-- Show missing value tags (false by default) -->
    <ShowMissingValues value="{@ShowMissingValues}" />

    <!-- Show missing namespace comments (true by default) -->
    <ShowMissingNamespaces value="{@ShowMissingNamespaces}" />

    <!-- Show missing include targets (false by default) -->
    <ShowMissingIncludeTargets value="{@ShowMissingIncludeTargets}" />

    <!-- Shared content file containing the localized
         messages (optional) -->
    <contentFile filename="{@WorkingFolder}SharedBuilderContent.xml" />
</component>

The example given above is taken from the Sandcastle Help File Builder's configuration file. When used with it, the replacement tag {@SHFBFolder} is used to insert the help file builder's folder in the file path. This is replaced at build time with the appropriate value. The other elements also use replacement tags that map to the help file builder project options of the same name. If using the component in your own build scripts, replace the tags with actual values. All elements are optional. If not specified, the default value noted in the comment before the element is used.

Localized Messages

If present, contentFile should point to a shared content file that contains the localized auto-documented constructor and "show missing" messages. If omitted, default English language messages are used. The format of the content should be similar to the following (lines wrapped for display purposes):

CopyLocalized Messages Example
<?xml version="1.0" encoding="utf-8"?>
<content xml:space="preserve">
    <!-- SHFB Show Missing Component messages -->
    <item id="shfbAutoDocConstructor">Initializes a new instance
of the &lt;see cref="T:{0}"/&gt; class</item>

    <item id="shfbAutoDocStaticConstructor">Initializes the static
fields of the &lt;see cref="T:{0}"/&gt; class</item>

    <item id="shfbMissingTag">&lt;p style="color:
#dc143c; font-size: 8.5pt; font-weight: bold;"&gt;[Missing
&amp;lt;{0}&amp;gt; documentation for "{1}"]&lt;/p&gt;</item>

    <item id="shfbMissingParamTag">&lt;p style="color:
#dc143c; font-size: 8.5pt; font-weight: bold;"&gt;[Missing
&amp;lt;{0} name="{1}"/&amp;gt; documentation for
"{2}"]&lt;/p&gt;</item>

    <item id="shfbMissingIncludeTarget">&lt;p
style="color: #dc143c; font-size: 8.5pt; font-weight:
bold;"&gt;[Missing &amp;lt;include&amp;gt; target
documentation in '{0}'.  File: '{1}' Path: '{2}']&lt;/p&gt;</item>

</content>

The Sandcastle Help File Builder's content files contain these entries by default. For information on what each of the "show missing" options does, see Show Missing Tags Category Properties help topic.

See Also

Other Resources

Show Missing Tags Category Properties
Custom Build Components


Version Information Component

[image]

Sandcastle Help File Builder Documentation
Version Information Component
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Version Information Component is used to extract version information from the reflection information file and pass it on to the PostTransformComponent so that it can be inserted into the help topic. The functionality in this component used to be integrated with the PostTranformComponent itself. However, looking up the version information after transformation of the topic proved to be too slow. Moving the lookup so that it occurs before transformation allows for an optimized lookup of the version information and the whole reflection file does not need to be loaded thus reducing memory usage for large builds and speeding up the searches for version information.

Note:

This component must be paired with the PostTransformComponent as it is used to insert the version information into the topic after the transformation to HTML.

The following is the default configuration for the version information component. It should be inserted into the configuration file before the TransformComponent.

CopyExample Configuration
<!-- Version information component configuration.  This must appear
     before the TransformComponent.  See also: PostTransformComponent -->
<component type="SandcastleBuilder.Components.VersionInfoComponent"
  assembly="{@SHFBFolder}SandcastleBuilder.Components.dll">
    <!-- Reflection information file for version info (required) -->
    <reflectionFile filename="reflection.xml" />
</component>

The example given above is taken from the Sandcastle Help File Builder's configuration file. When used with it, the replacement tag {@SHFBFolder} is used to insert the help file builder's folder in the file path. This is replaced at build time with the appropriate value. If using the component in your own build scripts, replace the tag with a relative or absolute path to the component assembly. The reflectionFile element is required and should contain the path to the reflection information file.

The help file builder contains the necessary overrides in its shared content files to add version information. If you use this component in your own scripts or build tools, you will need to make a copy of the help file builder's shared content file or modify the Sandcastle reference content files in order to add the version parameter. To do so, add the text "Version: {2}" to the locationInformation entry in the reference_content.xml file for the Prototype, VS2005, and Hana styles and the requirementsAssemblyLayout entry in the reference_content.xml file for the VS2005 and Hana styles.

See Also

Other Resources

Post-Transform Component
Custom Build Components


Creating a Component Configuration File
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This topic describes the parts of a custom build component configuration file and how to create one.

  • Creating a Component Configuration File
  • Component Configuration Elements
    • component
    • description
    • dependencies
    • insert
    • insertConceptual
    • configureMethod
    • defaultConfiguration
    • hidden
  • Making a Stock Build Component Editable
  • See Also

Creating a Component Configuration File

Custom build components can easily be added to the Sandcastle Help File Builder without having to modify its configuration template files. This is accomplished by creating an XML configuration file that describes the custom build component along with how and where it should be merged into the configuration file template at build time. The custom build component assembly, configuration file, and any supporting files are copied into the .\Build Components folder or a subfolder beneath it in the help file builder's Common Application Data folder. See the Special Folder Locations topic for more information. The component configuration files should have a .config file extension. A sample configuration is shown below:

CopySample Custom Build Component Configuration
<?xml version="1.0" encoding="utf-8"?>

<!-- CustomComponent.config example -->
<components>
  <component id="IntelliSense Component"
    type="SandcastleBuilder.Components.IntelliSenseComponent"
    assembly="{@SHFBFolder}SandcastleBuilder.Components.dll">
      <description>This build component is used to extract the XML
comments into files that can be used for IntelliSense.  Only the
basic set of tags needed for IntelliSense are exported and only for
documented API members.</description>

      <dependencies>
          <component id="Show Missing Documentation Component" />
      </dependencies>

      <insert placement="after"
        id="Show Missing Documentation Component" />

      <!-- <insertConceptual /> Not used for this one -->

      <configureMethod name="ConfigureComponent" />

      <defaultConfiguration>
          <output includeNamespaces="false"
            namespacesFile="Namespaces"
            folder="{@OutputFolder}" />
      </defaultConfiguration>
  </component>
</components>

Component Configuration Elements

The root components node contains one or more component nodes that describe the build components. The order of the component definitions is not significant. The help file builder uses this information to merge them with the configuration file at build time and also to allow users to configure them interactively from within the GUI. The Sandcastle Help File Builder supports several replacement tags that can be specified in place of such things as the components folder, the project folder, etc. These will be replaced before use with the physical path associated with the project.

The following sections list the elements and their attributes that make up the definition for a component node.

  • component
  • description
  • dependencies
  • insert
  • insertConceptual
  • configureMethod
  • defaultConfiguration
  • hidden

For a working example of a component configuration file, see the SandcastleBuilder.Components.config file in the help file builder installation folder. It contains a fully commented set of configurations for the custom build components supplied with the help file builder.

component

This element contains all of the other elements. The element itself has three required attributes:

  • The id attribute gives the component a unique ID. This is used in the configuration dialog as a friendly name that is more easily recognized. It is also used by the other elements in the configuration to identify the build component.
  • The type attribute provides the fully qualified type name of the build component.
  • The assembly attribute provides the location of the assembly that contains the indicated type. Normally, you will use the {@ComponentsFolder} replacement tag to represent the path to the .\Build Components folder. However, the assembly can be located in any other location. Just be sure that the path is correct.

description

This element is used to provide a brief description of the build component. This will appear in the configuration dialog when the build component is selected in the list of available build components.

dependencies

This element is used to specify a list of components on which the current component depends. If the indicated components do not exist in the project settings or in the configuration file template already, they will be added automatically with their default configuration at build time. This element can be omitted if there are no dependencies. To specify dependencies, add a nested component element for each one with a single id attribute set to the ID of the required component. Dependent configurations are merged prior to project settings. As such, it is not required that a dependent component appear in the project as well. If it does, the project settings will override the default configuration.

insert

This element is the most important one. It defines where the component configuration is inserted into the reference (API) configuration template file at build time (sandcastle.config). The following attributes can be used to define the placement options.

  • The placement attribute defines where to insert the configuration. It can have one of the following values:

    • start - The configuration is inserted at the start of the configuration file ahead of all others. If multiple build components use this option they are all inserted at the start in no particular order. All other attributes are ignored if this option is used.
    • end - The configuration is inserted at the end of the configuration file after all others. If multiple build components use this option they are all inserted at the end in no particular order. All other attributes are ignored if this option is used.
    • before - The configuration is inserted before the component indicated by the id/type and instance attributes.
    • after - The configuration is inserted after the component indicated by the id/type and instance attributes.
    • replace - The configuration for the custom component replaces a different component in the configuration template indicated by the id/type and instance attributes.
    Note:

    If a component already exists in the configuration file with a matching id attribute it is assumed to be the same component in the correct location and is automatically replaced with the custom configuration.

  • The id attribute can be used to identify another component in the configuration file by ID.
  • The type attribute can be used to identify another component in the configuration file by type name. For example, the stock Sandcastle components do not have IDs in the configuration file template. By specifying their type name, you can merge custom components before or after them without having to assign an ID to them first.
  • The instance attribute can be used to identify a specific instance of a build component in the configuration file. For example, the CopyFromIndex component appears multiple times in the standard configuration file. If you need to merge a custom build component before or after one of these occurrences, you can use this attribute to specify which one. If omitted, the first instance is assumed.

If this element is omitted, the build component will not be useable in reference builds.

insertConceptual

This element is similar to the insert element above. However, it defines where the component configuration is inserted into the conceptual content configuration template file at build time (conceptual.config). It uses the same attributes described above to define the placement options. If omitted, the build component will not be useable in a conceptual content build. If a component has both, like the CodeBlockComponent, it can be used in both build types.

configureMethod

This element can be used to identify the name of the static (shared) method that the help file builder can invoke to configure the component interactively from the project manager GUI. The named method should accept a string as a parameter that contains the current component configuration as an XML fragment and should return a string containing the edited component configuration as an XML fragment. The configuration passed and returned is in the format that is inserted into the configuration file at build time. If the build component does not contain a configure method, this element can be omitted and a default editor will be used. Specify a dash ("-") for the name if the component contains no editable configuration information.

defaultConfiguration

This is used to specify the default configuration for a custom build component. This information is used when the component is added as a dependency and when the component is added to the project and the user does not modify it. You can use the various replacement tags as attribute values. These will be replaced at build time with the appropriate project values.

hidden

This element can be used to hide a component in the help file builder's configuration dialog box. The component will still be merged if it is a dependency but it will not show up in the configuration dialog box so that the user can add it to the project with a custom configuration.

Making a Stock Build Component Editable

By creating a configuration file for one of the stock build components such as ResolveReferenceLinksComponent2 or one of the many other build components that are not included by default, you can add the ability to edit their configurations. Simply create a new configuration file with the necessary information. Since stock build components do not have a configuration method, omit the configureMethod element and the standard editor will be used to allow you to modify the raw XML configuration data.

See Also

Other Resources

Custom Build Components


Errors and Warnings

[image]

Sandcastle Help File Builder Documentation
Errors and Warnings
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The topics in this section contains detailed information about each of the warning and error messages that you may encounter when building a project. Each warning or error contains a code. Use that code to look up the related topic for information about what it means and possible solutions.

  • Build Engine
  • Generate Inherited Documentation
  • HTML Extract
  • MSBuild Tasks
  • Plug-Ins
  • Project File
  • Project File Converters
  • See Also

Build Engine

  • BE0001: Unable to determine presentation style from folder '[folder]'
  • BE0002: Shared builder content for the '[langId]' language could not be found
  • BE0003: Sandcastle shared content for the '[langId]' language could not be found
  • BE0004: MRefBuilder has a version of '[installedVersion]' but version '[expectedVersion]' was expected
  • BE0005: File '[file]' does not contain a 'doc/members' node
  • BE0006: Unable to location any documentation sources for '[source]'
  • BE0007: A project with a higher framework version was found
  • BE0008: Namespace '[namespace]' excluded via namespace comments conflicted with API filter
  • BE0009: '[memberId]' is marked with <exclude /> but conflicted with the API filter
  • BE0010: Image file '[imageFile]' already exists
  • BE0011: Multiple topic transformations found. Using '[file]'
  • BE0012: Error generating namespace summaries (Namespace = [namespace]): [error]
  • BE0013: Possible invalid path '[path]'
  • BE0014: Unable to load source file '[file]'
  • BE0015: Unable to locate start of region '[region]' in source file '[file]'
  • BE0016: Unable to extract region '[region]' in source file '[file]' (missing #endregion?)
  • BE0017: Unexpected error using '[transformFile]' to transform additional content file
  • BE0018: Unable to transform template text '[value]': [error]
  • BE0019: Unable to transform template '[file]': [error]
  • BE0020: Unknown field tag: '[tagName]'
  • BE0021: The project contains a reference to a custom build component '[name]' that could not be found
  • BE0022: Unable to locate the '[name]' build component information
  • BE0023: The project contains a reference to a custom build component '[name]'...
  • BE0024: Unable to add dependent configuration: [name]
  • BE0025: Unable to remove prior build output: [error]
  • BE0026: Unable to determine default topic in '[tocFile]'.
  • BE0027: Error modifying help topic filenames: [error]
  • BE0028: [Plug-in loading error]
  • BE0029: Unexpected error while executing plug-in '[plugInName]': [error]
  • BE0030: The OutputPath and WorkingPath properties cannot be set to the same path
  • BE0031: For HTML Help 2 builds, the HtmlHelpName property cannot contain spaces
  • BE0032: Reflection data files do not exist yet
  • BE0033: No APIs found to document
  • BE0034: The '[propName]' property resolved to '[folder]' which is a reserved folder name
  • BE0035: Could not find the path to the Microsoft Sandcastle documentation compiler tools
  • BE0036: Your version of the Microsoft Sandcastle documentation compiler tools is out of date
  • BE0037: Could not find the path the the HTML 1.x help compiler
  • BE0038: Could not find the path the the HTML 2.x help compiler
  • BE0039: The project does not have any documentation sources defined
  • BE0040: Project assembly does not exist: [assembly]
  • BE0041: Project XML comments file does not exist: [commentsFile]
  • BE0042: You must specify at least one documentation source in the form...
  • BE0043: Unexpected error detected in the last build step
  • BE0044: Error applying Visibility properties: [error]
  • BE0045: Error removing attributes nodes: [error]
  • BE0046: Error removing EII nodes: [error]
  • BE0047: Error removing inherited members: [error]
  • BE0048: Error removing [memberType]: [error]
  • BE0049: Error changed protected internal to protected: [error]
  • BE0050: Error removing protected members from sealed classes: [error]
  • BE0051: The specified project file does not exist: [projectFile]
  • BE0052: One or more token files could not be found
  • BE0053: One or more code snippets files could not be found
  • BE0054: The conceptual topic '[title]' (ID: [id]) does not match any file in the project
  • BE0055: The conceptual topic '[title]' (ID: [id]) must either specify a topic file or it must contains sub-topics
  • BE0056: The conceptual content file '[file]' with ID '[id]' does not exist
  • BE0057: The conceptual content file '[file]' with ID '[id]' is not valid: [error]
  • BE0058: Two conceptual content files have the same ID ({0})
  • BE0059: LCID '[id]' not found in configuration file
  • BE0060: The [itemType] '[item]' contains a comma or '.h' which may cause the Help 1 compiler to fail
  • BE0061: File '[file]' could not be loaded and will not be used as an XML comments file
  • BE0062: No XML comments found. The help file will not contain any member comments
  • BE0063: '[file]' matches a previously copied comments filename
  • BE0064: BUILD CANCELLED BY USER
  • BE0065: BUILD FAILED: [error]
  • BE0066: The HelpFileVersion property value '[value]' is not in the correct format
  • BE0067: Unable to obtain assembly name from project file

Generate Inherited Documentation

  • GID0001: Unexpected error while generating inherited documentation
  • GID0002: No comments found for cref '[cref]' on member '[id]
  • GID0003: Unable to locate API ID '[id]'
  • GID0004: No comments found for member '[id]'
  • GID0005: No comments found for cref '[cref]'
  • GID0006: No comments found for member '[memberId]'
  • GID0007: Ignoring non-XML comments file
  • GID0008: Entries for the key '[id]' occur in both '[file1]' and '[file2]'

HTML Extract

  • SHE0001: LCID '[id]' not found in configuration file
  • SHE0002: Unexpected error: [error]
  • SHE0003: Unexpected error applying command line option
  • SHE0004: The key '[key]' used for '[file]' is already in use

MSBuild Tasks

  • B1X0001: A help compiler path must be specified
  • B1X0002: A help project file must be specified and it must exist
  • B2X0001: A help compiler path must be specified
  • B2X0002: An HTML help base name must be specified
  • BAT0001: A configuration file must be specified and it must exist
  • BAT0002: A manifest file must be specified and it must exist
  • BHT0001: Unable to get executing project
  • BHT0002: Unable to build project '[projectFile]': [error]
  • BHT0003: The specified project file does not exist: [projectFile]
  • BHT0004: An older MSBuild version is being used
  • CT0001: Unable to clean output folder. Reason: [reason]
  • MBT0001: At least one assembly (.dll or .exe) is required for MRefBuilder to parse
  • MBT0002: Unable to generate response file. Reason: [reason]
  • XTT0001: At least one XSL transformation is required
  • XTT0002: An input file must be specified and it must exist
  • XTT0003: An output filename must be specified

Plug-Ins

  • TODO: Add topic links here

Project File

  • PRJ0001: Invalid or missing SchemaVersion
  • PRJ0002: The selected file is for a more recent version
  • PRJ0003: Error reading project from '[file]': [reason]
  • PRJ0004: An attempt was made to set a read-only or ignored property
  • PRJ0005: Unable to parse value '[value]' for property '[property]'
  • PRJ0006: Error saving project to '[file]': [reason]

Project File Converters

  • CVT0001: Unable to parse value '[value]' for property '[name]'
  • CVT0002: An attempt was made to set an unknown or read-only property
  • CVT0003: Invalid or missing schema version
  • CVT0004: Unrecognized schema version
  • CVT0005: Error reading project from '[file]'
  • CVT0006: Error converting content layout file

See Also

Other Resources

Installation Instructions
FAQ
Links to Resources


BE0001: Unable to determine presentation style from folder '[folder]'

[image]

Sandcastle Help File Builder Documentation
BE0001: Unable to determine presentation style from folder '[folder]'
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Warning BE0001: Unable to determine presentation style from folder '[folder]'. Assuming Prototype style.

Cause

The build engine was unable to determine which presentation style is in used based on the selected PresentationStyle property value.

Solution

Sandcastle comes with three default presentation styles: Prototype, Hana, and VS2005. These are located in the %DXROOT%\Presentation folder. You can create additional styles by adding other folders with modified or brand new styles in that location. However, the names of the additional style folders must contain the name of one of the other base styles. The name is case-insensitive and can appear anywhere within the folder name. This is required as certain parts of the Sandcastle build process differ based on the selected presentation style. The base name gives the build process a hint as to how it should handle those parts.

If the folder name does not contain one of the base style names, this warning is issued. To fix the problem, rename the folder so that it does contain one of the base style names.

See Also

Other Resources

Errors and Warnings


BE0002: Shared builder content for the '[langId]' language could not be found

[image]

Sandcastle Help File Builder Documentation
BE0002: Shared builder content for the '[langId]' language could not be found
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Warning BE0002: Shared builder content for the '[langId]' language could not be found. Using 'en-US, English (US)' defaults.

Cause

This warning indicates that a help file builder shared content file does not exist for the selected language.

Solution

If a language resource file does not exist, the US-English defaults are used. If you need resources to appear in the language selected in the project file, you will need to create a shared content file for the selected language. See the Localizing Language Resource Files topic for details. Once done, you can create a work item in the Sandcastle Help File Builder project on CodePlex and attach the translated help file builder resource files so that they can be included in a future release of the help file builder.

Note:

Do not send any translated Sandcastle presentation style files. These are not part of the help file builder and will not be included as part of it.

See Also

Other Resources

Errors and Warnings


BE0003: Sandcastle shared content for the '[langId]' language could not be found

[image]

Sandcastle Help File Builder Documentation
BE0003: Sandcastle shared content for the '[langId]' language could not be found
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Warning BE0003: Sandcastle shared content for the '[langId]' language could not be found. Using 'en-US, English (US)' defaults.

Cause

This warning indicates that a set of Sandcastle shared content files do not exist for the selected language.

Solution

If a set of language resource files do not exist, the US-English defaults are used. If you need resources to appear in the language selected in the project file, you will need to create a set of content files for the selected language. See the Localizing Language Resource Files topic for details.

Note:

While you can send translations of the help file builder shared content files to the Sandcastle Help File Builder project, do not send any translated Sandcastle presentation style files as they are not part of the help file builder and will not be included as part of it.

See Also

Other Resources

Errors and Warnings


BE0004: MRefBuilder has a version of '[installedVersion]' but version '[expectedVersion]' was expected

[image]

Sandcastle Help File Builder Documentation
BE0004: MRefBuilder has a version of '[installedVersion]' but version '[expectedVersion]' was expected
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Warning BE0004: MRefBuilder has a version of '[installedVersion]' but version '[expectedVersion]' was expected. You may need to update your copy of the help file builder.

Cause

This warning occurs when the version of the Microsoft Sandcastle documentation tools found is more recent than the one the help file builder was expecting. The build may complete successfully but you may find that the help file topics are not rendered as expected or contain errors.

Solution

The following information can help solve this problem:

  • Review the Installation Instructions carefully and make sure that you have installed all of the required tools and have the latest version of each. Most importantly, check the Sandcastle Help File Builder project site for an updated release of the help file builder.
  • Check to be sure that a system copy of the DXROOT environment variable exists and that it points to the most recent copy of Sandcastle (usually C:\Program Files\Sandcastle). In addition, make sure that there is no user copy of the DXROOT environment variable. If one does exist, delete it.
  • If the Sandcastle folder exists in the PATH environment variable, ensure that it is correct. Preference is given to the DXROOT variable so this is not a requirement unless the DXROOT value is wrong.
  • If all else fails, manually specify the location of the Sandcastle tools by entering the path in the SandcastlePath project property. This usually needs to be done if performing the build on a build server.
Note:

In all cases above, be sure to specify the path to the Sandcastle tools from Microsoft, NOT the path to the help file builder.

See Also

Other Resources

Errors and Warnings


BE0005: File '[file]' does not contain a 'doc/members' node

[image]

Sandcastle Help File Builder Documentation
BE0005: File '[file]' does not contain a 'doc/members' node
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Warning BE0005: File '[file]' does not contain a 'doc/members' node and will not be used as an XML comments file.

Cause

This warning occurs if an XML file is found during the validation of the documentation sources and it does not contain a doc/members node which is required for an XML comments file.

Solution

This usually occurs when a wildcard is used to find all file in a given location. In certain cases, this may pick up extra XML comments files that are not comments files. These will be ignored. To suppress the warning you can refine the wildcard to only match the needed XML comments files or specify them by name individually.

See Also

Other Resources

Errors and Warnings


BE0006: Unable to location any documentation sources for '[source]'

[image]

Sandcastle Help File Builder Documentation
BE0006: Unable to location any documentation sources for '[source]'
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Warning BE0006: Unable to location any documentation sources for '[source]'

Cause

This warning occurs if a documentation source in the project results in no assemblies, comments files, solutions, or project being found for use in the build.

Solution

Check the SourceFile property in the documentation source to ensure that it is correct.

See Also

Other Resources

Errors and Warnings


BE0007: A project with a higher framework version was found

[image]

Sandcastle Help File Builder Documentation
BE0007: A project with a higher framework version was found
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Warning BE0007: A project with a higher framework version was found. Changing project FrameworkVersion property from '[projectValue]' to '[foundValue]' for the build

Cause

This warning occurs if a project documentation source contains a framework version value higher than the one specified in the help project. To ensure that the correct framework comments are included the highest framework version found will be used for the build.

Solution

To suppress this warning, change the FrameworkVersion project property to match the value noted in the warning.

See Also

Other Resources

Errors and Warnings


BE0008: Namespace '[namespace]' excluded via namespace comments conflicted with API filter

[image]

Sandcastle Help File Builder Documentation
BE0008: Namespace '[namespace]' excluded via namespace comments conflicted with API filter
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Warning BE0008: Namespace '[namespace]' excluded via namespace comments conflicted with API filter setting. Exclusion ignored.

Cause

This warning occurs if a namespace in the NamespaceSummaries project property is marked as excluded but the ApiFilter has it marked as included. In such cases, the API filter wins and the namespace is included in the help file.

Solution

Edit either the NamespaceSummaries property or the ApiFilter property such that the exclusion setting for the indicated namespace matches in both. If you want to exclude an entire namespace, the preferred way is to use the ApiFilter project property. Excluding namespaces via the NamespaceSummaries property is supported for backward compatibility with older projects.

See Also

Other Resources

Errors and Warnings


BE0009: '[memberId]' is marked with <exclude /> but conflicted with the API filter

[image]

Sandcastle Help File Builder Documentation
BE0009: '[memberId]' is marked with <exclude /> but conflicted with the API filter
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Warning BE0009: '[memberId]' is marked with <exclude /> but conflicted with the API filter setting. Exclusion ignored.

Cause

This warning occurs if the indicated API member has an <exclude /> tag in its XML comments but the ApiFilter project property explicitly marks it as included. In such cases, the API filter wins and the member is included in the help file.

Solution

This situation can occur if the member was previously included explicitly in the API filter and the <exclude /> tag was added to its comments at a later date. In order to fix this issue, remove the <exclude /> tag from the member's comments and, if not wanted, mark it as excluded in the help project's ApiFilter property.

See Also

Other Resources

Errors and Warnings


BE0010: Image file '[imageFile]' already exists

[image]

Sandcastle Help File Builder Documentation
BE0010: Image file '[imageFile]' already exists
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Warning BE0010: Image file '[imageFile]' already exists. It will be replaced by '[duplicateFile]'.

Cause

This warning occurs if two conceptual content media files with the same filename but from different source locations are copied to the .\Media folder during the build.

Solution

Although source image files with the same name can reside in different project folders, all conceptual content images are copied to the .\Media folder during the build. As such, like-named files will overwrite each other. If this is an issue, rename one of the files. The image IDs should remain the same or you will have to locate their occurrences in the topics and update them manually.

See Also

Other Resources

Errors and Warnings


BE0011: Multiple topic transformations found. Using '[file]'

[image]

Sandcastle Help File Builder Documentation
BE0011: Multiple topic transformations found. Using '[file]'
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Warning BE0011: Multiple topic transformations found. Using '[file]'

Cause

This warning occurs if a .topic additional content file is found and multiple project file items are found with a BuildAction of TopicTransform.

Solution

In such cases, only the first topic transformation file found will be used to transform the .topic files into HTML. If the wrong file is selected, change the BuildAction on all other transformation files to None so that only the file you want to use is found at build time.

See Also

Other Resources

Errors and Warnings


BE0012: Error generating namespace summaries (Namespace = [namespace]): [error]

[image]

Sandcastle Help File Builder Documentation
BE0012: Error generating namespace summaries (Namespace = [namespace]): [error]
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error BE0012: Error generating namespace summaries (Namespace = [namespace]): [error]

Cause

This error occurs if there is a problem generating namespace summaries for the project.

Solution

This most likely indicates an internal error in the build process. Open a work item in the Sandcastle Help File Builder project at CodePlex containing the details from the error message and attach a small example project with any related files that can be used to duplicate the problem.

See Also

Other Resources

Errors and Warnings


BE0013: Possible invalid path '[path]'

[image]

Sandcastle Help File Builder Documentation
BE0013: Possible invalid path '[path]'
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error BE0013: Possible invalid path '[path]'

Cause

This is caused by a potentially invalid path on a source attribute on a code element in an HTML additional content file.

Solution

The file in which the error occurred will be listed just above the error message in the log file. Load it and search for code elements that import source code from external files. Check the paths to ensure that they are correct and valid.

See Also

Other Resources

Errors and Warnings


BE0014: Unable to load source file '[file]'

[image]

Sandcastle Help File Builder Documentation
BE0014: Unable to load source file '[file]'
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error BE0014: Unable to load source file '[file]'

Cause

This error occurs if the source code file referenced in a source attribute on a code element in an HTML additional content file cannot be loaded.

Solution

Refer to the additional error information following this error message in the log file for information about the possible cause of the problem (i.e. file not found, permission issues, etc.).

See Also

Other Resources

Errors and Warnings


BE0015: Unable to locate start of region '[region]' in source file '[file]'

[image]

Sandcastle Help File Builder Documentation
BE0015: Unable to locate start of region '[region]' in source file '[file]'
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error BE0015: Unable to locate start of region '[region]' in source file '[file]'

Cause

This error occurs if the region referenced in a region attribute on a code element in an HTML additional content file cannot be found within the indicated source code file.

Solution

Check both the code element to be sure that the region specified is correct and the indicated source code file to ensure that the region exists in there and that the names match between the source code file and the additional content file.

See Also

Other Resources

Errors and Warnings


BE0016: Unable to extract region '[region]' in source file '[file]' (missing #endregion?)

[image]

Sandcastle Help File Builder Documentation
BE0016: Unable to extract region '[region]' in source file '[file]' (missing #endregion?)
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error BE0016: Unable to extract region '[region]' in source file '[file]' (missing #endregion?)

Cause

This error occurs if the region referenced in a region attribute on a code element in an HTML additional content file cannot be extracted from the indicated source code file.

Solution

Check both the code element to be sure that the region specified is correct and the indicated source code file to ensure that the region exists in there and that the names match between the source code file and the additional content file. Also ensure that the region defined in the source code file is well formed and has both a start and an end statement to define it.

See Also

Other Resources

Errors and Warnings


BE0017: Unexpected error using '[transformFile]' to transform additional content file

[image]

Sandcastle Help File Builder Documentation
BE0017: Unexpected error using '[transformFile]' to transform additional content file
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error BE0017: Unexpected error using '[transformFile]' to transform additional content file '[inputFile]' to '[outputFile]'. The error is: [error]

Cause

This error occurs if the transformation of a .topic additional content file fails.

Solution

This is a generic catch-all error that occurs if the transformation fails. Refer to the additional error information in the message to locate the cause of the problem and fix it (i.e. ill-formed XML in the input file, an unknown entity name in the input file, an error in the transformation file itself, etc.).

See Also

Other Resources

Errors and Warnings


BE0018: Unable to transform template text '[value]': [error]

[image]

Sandcastle Help File Builder Documentation
BE0018: Unable to transform template text '[value]': [error]
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error BE0018: Unable to transform template text '[value]': [error]

Cause

The specified text contains replacement tags that could not be evaluated or replaced due to the indicated problem.

Solution

The most likely cause is a misspelled replacement tag name or one that is not recognized. Refer to the error message for information about the cause. If you are unable to resolve the issue, open a work item in the Sandcastle Help File Builder project at CodePlex containing the details from the error message and attach a small example project with any related files that can be used to duplicate the problem.

See Also

Other Resources

Errors and Warnings


BE0019: Unable to transform template '[file]': [error]

[image]

Sandcastle Help File Builder Documentation
BE0019: Unable to transform template '[file]': [error]
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error BE0019: Unable to transform template '[file]': [error]

Cause

The specified template file contains replacement tags that could not be evaluated or replaced due to the indicated problem.

Solution

The most likely cause is a misspelled replacement tag name or one that is not recognized. Refer to the error message for information about the cause. If you are unable to resolve the issue, open a work item in the Sandcastle Help File Builder project at CodePlex containing the details from the error message and attach a small example project with any related files that can be used to duplicate the problem.

See Also

Other Resources

Errors and Warnings


BE0020: Unknown field tag: '[tagName]'

[image]

Sandcastle Help File Builder Documentation
BE0020: Unknown field tag: '[tagName]'
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error BE0020: Unknown field tag: '[tagName]'

Cause

This error occurs when an unrecognized replacement tag field name is encountered while transforming a template file or a block of template text.

Solution

The most likely cause is a misspelled replacement tag name or one that is not recognized. Refer to the error message for information about the cause. If you are unable to resolve the issue, open a work item in the Sandcastle Help File Builder project at CodePlex containing the details from the error message and attach a small example project with any related files that can be used to duplicate the problem.

See Also

Other Resources

Errors and Warnings


BE0021: The project contains a reference to a custom build component '[name]' that could not be found

[image]

Sandcastle Help File Builder Documentation
BE0021: The project contains a reference to a custom build component '[name]' that could not be found
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error BE0021: The project contains a reference to a custom build component '[name]' that could not be found

Cause

This error occurs when a build component is specified in the project's ComponentConfigurations property but it could not be found in any of the loaded component definitions.

Solution

This can occur if the build component configuration file is deleted from the system but the build component is still listed in the project. Either remove the component from the ComponentConfigurations property settings or restore the custom build component and its configuration file to the custom build component folder (see the Special Folder Locations topic).

See Also

Other Resources

Errors and Warnings


BE0022: Unable to locate the '[name]' build component information

[image]

Sandcastle Help File Builder Documentation
BE0022: Unable to locate the '[name]' build component information
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error BE0022: Unable to locate the '[name]' build component information

Cause

This error occurs if there is a problem locating a custom build component.

Solution

This most likely indicates an internal error in the build process. Open a work item in the Sandcastle Help File Builder project at CodePlex containing the details from the error message and attach a small example project with any related files that can be used to duplicate the problem.

See Also

Other Resources

Errors and Warnings


BE0023: The project contains a reference to a custom build component '[name]'...

[image]

Sandcastle Help File Builder Documentation
BE0023: The project contains a reference to a custom build component '[name]'...
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error BE0023: The project contains a reference to a custom build component '[name]' that has a dependency '[dependencyName]' that could not be found.

Cause

This error occurs when a build component is specified in the project's ComponentConfigurations property that has a dependency on another build component but the dependency could not be found in any of the loaded component definitions.

Solution

This can occur if the build component configuration file for the dependency is deleted from the system but the build component is still listed in the project. Either remove the component from the ComponentConfigurations property settings or restore the dependency custom build component and its configuration file to the custom build component folder (see the Special Folder Locations topic).

See Also

Other Resources

Errors and Warnings


BE0024: Unable to add dependent configuration: [name]

[image]

Sandcastle Help File Builder Documentation
BE0024: Unable to add dependent configuration: [name]
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error BE0024: Unable to add dependent configuration: [name]

Cause

This error occurs if there is a problem adding a dependency custom build component to the build configuration file.

Solution

This most likely indicates an internal error in the build process. Open a work item in the Sandcastle Help File Builder project at CodePlex containing the details from the error message and attach a small example project with any related files that can be used to duplicate the problem.

See Also

Other Resources

Errors and Warnings


BE0025: Unable to remove prior build output: [error]

[image]

Sandcastle Help File Builder Documentation
BE0025: Unable to remove prior build output: [error]
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error BE0025: Unable to remove prior build output: [error]

Cause

This error occurs at the very start of the build if a prior build's working folder or a prior build's output files cannot be removed.

Solution

The most common cause is that you have the prior build's help file open or another process has the working folder set as its current directory. Close the help file if it is open and/or close any other open processes such as Windows Explorer that may be using the working folder and try the build again.

See Also

Other Resources

Errors and Warnings


BE0026: Unable to determine default topic in '[tocFile]'.

[image]

Sandcastle Help File Builder Documentation
BE0026: Unable to determine default topic in '[tocFile]'.
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error BE0026: Unable to determine default topic in '[tocFile]'. You may need to mark one as the default topic manually.

Cause

This error occurs when the build process is updating the table of contents with entries for additional and conceptual content and it is unable to determine the default topic be extracting it from the indicated table of contents file. This usually occurs when building a help file that does not contain any API reference content.

Solution

Add a site map file (HTML additional content) or a content layout file (conceptual content) to the project and use it to arrange the additional content/conceptual content items. In addition, mark one of the entries as the default topic within the editor for the layout file.

See Also

Other Resources

Errors and Warnings


BE0027: Error modifying help topic filenames: [error]

[image]

Sandcastle Help File Builder Documentation
BE0027: Error modifying help topic filenames: [error]
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error BE0027: Error modifying help topic filenames: [error]

Cause

This error occurs if there is a problem renaming the topic files based on the selected NamingMethod.

Solution

This most likely indicates an internal error in the build process. Open a work item in the Sandcastle Help File Builder project at CodePlex containing the details from the error message and attach a small example project with any related files that can be used to duplicate the problem.

See Also

Other Resources

Errors and Warnings


BE0028: [Plug-in loading error]

[image]

Sandcastle Help File Builder Documentation
BE0028: [Plug-in loading error]
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error BE0028: [Plug-in loading error(s)]

Cause

This is a generic catch-all error that occurs when the build process attempts to load plug-ins for use in the build and one or more of them fails to initialize correctly.

Solution

Since this is a generic catch-all error, you will need to refer to the text of the error message in order to determine the exact cause of the problem. Some common issues include:

  • The plug-in was added to the project but was not configured and the default configuration is not valid for use in a build.
  • The assembly for a plug-in referenced in the project does not exist. Place the assembly in the custom plug-ins folder (see the Special Folder Locations topic).
  • The plug-in assembly is compiled against an earlier version of the help file builder and cannot be loaded. Obtain a newer version of the plug-in assembly.

If you are unable to resolve the issue and the plug-in is one of the standard ones supplied with the help file builder, post a message in the Sandcastle Help File Builder Discussion group asking for help. For all third-party plug-ins, contact the author of the plug-in for assistance.

See Also

Other Resources

Errors and Warnings


BE0029: Unexpected error while executing plug-in '[plugInName]': [error]

[image]

Sandcastle Help File Builder Documentation
BE0029: Unexpected error while executing plug-in '[plugInName]': [error]
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error BE0029: Unexpected error while executing plug-in '[plugInName]': [error]

Cause

This is a generic catch-all error that occurs when the build process attempts to run a plug-in during the build.

Solution

Since this is a generic catch-all error, you will need to refer to the text of the error message in order to determine the exact cause of the problem.

If you are unable to resolve the issue and the plug-in is one of the standard ones supplied with the help file builder, post a message in the Sandcastle Help File Builder Discussion group asking for help. For all third-party plug-ins, contact the author of the plug-in for assistance.

See Also

Other Resources

Errors and Warnings


BE0030: The OutputPath and WorkingPath properties cannot be set to the same path

[image]

Sandcastle Help File Builder Documentation
BE0030: The OutputPath and WorkingPath properties cannot be set to the same path
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error BE0030: The OutputPath and WorkingPath properties cannot be set to the same path.

Cause

This error occurs if the value of the OutputPath and the WorkingPath project property values equate to the same location.

Solution

When a website build is performed, the content of the output path is cleared before the website files are generated. Likewise, when a build completes, the intermediate files in the working folder will be deleted if the CleanIntermediates property is set to true. In either case, this would result in the loss of the output files. To correct the error either clear the WorkingPath property so that it uses a default location for the working files or set it to a folder that is different from the OutputPath property value.

See Also

Other Resources

Errors and Warnings


BE0031: For HTML Help 2 builds, the HtmlHelpName property cannot contain spaces

[image]

Sandcastle Help File Builder Documentation
BE0031: For HTML Help 2 builds, the HtmlHelpName property cannot contain spaces
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error BE0031: For HTML Help 2 builds, the HtmlHelpName property cannot contain spaces as they are not valid in the collection name.

Cause

This error occurs if there are spaces in the HtmlHelpName project property value.

Solution

The HtmlHelpName value is also used as the Help 2 collection name when building a Help 2 file. Spaces are not valid in collection names and must be removed from the property value.

See Also

Other Resources

Errors and Warnings


BE0032: Reflection data files do not exist yet

[image]

Sandcastle Help File Builder Documentation
BE0032: Reflection data files do not exist yet
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error BE0032: Reflection data files do not exist yet

Cause

This error will occur if the %DXROOT%\Data\Reflection folder does not exist.

Solution

The files in that folder are required to document members inherited from base .NET Framework classes. If you get this error, check to be sure that the DXROOT environment variable points to the latest copy of Sandcastle (usually in the C:\Program Files\Sandcastle) folder and that the .\Data\Reflection folder exists beneath it. If it does not, you should reinstall Sandcastle.

Note:

If you do need to recreate the files for some reason (i.e. you install a new .NET Framework release), you can run Start | Programs | Sandcastle Help File Builder | Rebuild Reflection Data.

See Also

Other Resources

Errors and Warnings


BE0033: No APIs found to document

[image]

Sandcastle Help File Builder Documentation
BE0033: No APIs found to document
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error BE0033: No APIs found to document

Cause

This error occurs if no public API members were found to document in the project.

Solution

Check the following conditions which can cause this error:

  • You need to include at least one assembly or Visual Studio solution/project file in the help file project as a documentation source. Add the assembly, solution, or project to the Documentation Sources project node in the Project Explorer window.
  • At least one public class must appear in your code. If all classes are private or internal and must remain that way, set the DocumentPrivates and/or DocumentInternals project property to true so that private/internal members are documented.
  • You need to include at least one namespace to document. Check the NamespaceSummaries and/or the ApiFilter project properties to ensure that at least one item from your code is included. If all are excluded, there will not be anything to document.

See Also

Other Resources

Errors and Warnings


BE0034: The '[propName]' property resolved to '[folder]' which is a reserved folder name

[image]

Sandcastle Help File Builder Documentation
BE0034: The '[propName]' property resolved to '[folder]' which is a reserved folder name
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error BE0034: The '[propName]' property resolved to '[folder]' which is a reserved folder name

Cause

The indicated property's value resolved to a folder which appears to point to the root of a drive or network share, is a well-known folder such as My Documents, is the root project folder, or is a parent of a special folder or the project folder. If used, this would cause all files and folders in that location to be erased which is probably not what you want.

Solution

Set the property's path to a different location that is safe to erase without warning (i.e. a subfolder under the root project folder) or reset it to the default value which will result in a safe path. See the help topic for the indicated property for more information.

See Also

Other Resources

Errors and Warnings


BE0035: Could not find the path to the Microsoft Sandcastle documentation compiler tools

[image]

Sandcastle Help File Builder Documentation
BE0035: Could not find the path to the Microsoft Sandcastle documentation compiler tools
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error BE0035: Could not find the path to the Microsoft Sandcastle documentation compiler tools

Cause

This error occurs when the help file builder cannot locate the Microsoft Sandcastle documentation tools folder.

Solution

The following information can help solve this problem:

  • Review the Installation Instructions carefully and make sure that you have installed all of the required tools and have the latest version of each.
  • Check to be sure that a system copy of the DXROOT environment variable exists and that it points to the most recent copy of Sandcastle (usually C:\Program Files\Sandcastle). In addition, make sure that there is no user copy of the DXROOT environment variable. If one does exist, delete it.
  • If the Sandcastle folder exists in the PATH environment variable, ensure that it is correct. Preference is given to the DXROOT variable so this is not a requirement unless the DXROOT value is wrong.
  • If all else fails, manually specify the location of the Sandcastle tools by entering the path in the SandcastlePath project property. This usually needs to be done if performing the build on a build server.
Note:

In all cases above, be sure to specify the path to the Sandcastle tools from Microsoft, NOT the path to the help file builder.

See Also

Other Resources

Errors and Warnings


BE0036: Your version of the Microsoft Sandcastle documentation compiler tools is out of date

[image]

Sandcastle Help File Builder Documentation
BE0036: Your version of the Microsoft Sandcastle documentation compiler tools is out of date
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error BE0036: Your version of the Microsoft Sandcastle documentation compiler tools is out of date (found '[installedVersion]' but expected '[expectedVersion]').

Cause

This error occurs when the version of the Microsoft Sandcastle documentation tools found is not the most recent version.

Solution

The following information can help solve this problem:

  • Review the Installation Instructions carefully and make sure that you have installed all of the required tools and have the latest version of each.
  • Check to be sure that a system copy of the DXROOT environment variable exists and that it points to the most recent copy of Sandcastle (usually C:\Program Files\Sandcastle). In addition, make sure that there is no user copy of the DXROOT environment variable. If one does exist, delete it.
  • If the Sandcastle folder exists in the PATH environment variable, ensure that it is correct. Preference is given to the DXROOT variable so this is not a requirement unless the DXROOT value is wrong.
  • If all else fails, manually specify the location of the Sandcastle tools by entering the path in the SandcastlePath project property. This usually needs to be done if performing the build on a build server.
Note:

In all cases above, be sure to specify the path to the Sandcastle tools from Microsoft, NOT the path to the help file builder.

See Also

Other Resources

Errors and Warnings


BE0037: Could not find the path the the HTML 1.x help compiler

[image]

Sandcastle Help File Builder Documentation
BE0037: Could not find the path the the HTML 1.x help compiler
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error BE0037: Could not find the path the the HTML 1.x help compiler

Cause

This error occurs when the HTML Help 1.x compiler could not be found in the standard location or anywhere in the Program Files folders on any fixed drive.

Solution

The following information can help solve this problem:

  • Review the Installation Instructions carefully and make sure that you have installed all of the required tools and have the latest version of each.
  • If all else fails, manually specify the location of the HTML Help 1.x compiler by entering the path in the HtmlHelp1xCompilerPath project property. This usually needs to be done if performing the build on a build server.

See Also

Other Resources

Errors and Warnings


BE0038: Could not find the path the the HTML 2.x help compiler

[image]

Sandcastle Help File Builder Documentation
BE0038: Could not find the path the the HTML 2.x help compiler
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error BE0037: Could not find the path the the HTML 2.x help compiler

Cause

This error occurs when the HTML Help 2.x compiler could not be found in the standard location or anywhere in the Program Files folders or Visual Studio SDK folders on any fixed drive.

Solution

The following information can help solve this problem:

  • Review the Installation Instructions carefully and make sure that you have installed all of the required tools and have the latest version of each.
  • If all else fails, manually specify the location of the HTML Help 2.x compiler by entering the path in the HtmlHelp2xCompilerPath project property. This usually needs to be done if performing the build on a build server.

See Also

Other Resources

Errors and Warnings


BE0039: The project does not have any documentation sources defined

[image]

Sandcastle Help File Builder Documentation
BE0039: The project does not have any documentation sources defined
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error BE0039: The project does not have any documentation sources defined

Cause

This error occurs if no documentation sources are defined in the the project and the Additional Content Only plug-in is not present in the project or is disabled.

Solution

Check the following conditions which can cause this error:

  • You need to include at least one assembly or Visual Studio solution/project file in the help file project as a documentation source. Add the assembly, solution, or project to the Documentation Sources project node in the Project Explorer window.
  • If you are trying to build a help file based solely on additional or conceptual content, add the Additional Content Only Plug-In to the project via the PlugInConfigurations project property.
  • If the plug-in is included in the project, make sure that it is enabled by checking the box next to it in the plug-in configuration dialog box.

See Also

Other Resources

Errors and Warnings


BE0040: Project assembly does not exist: [assembly]

[image]

Sandcastle Help File Builder Documentation
BE0040: Project assembly does not exist: [assembly]
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error BE0040: Project assembly does not exist: [assembly]

Cause

This error occurs if the assembly from a project file documenation source cannot be found.

Solution

The most likely cause of this error is that the project has not been built. Build the project so that the assembly exists and then build the help file project. In addition, check the Configuration and Platform settings on the documentation source to ensure that they are selecting the assembly that was built (i.e. Debug or Release). If they are not specified, check the settings in the GUI (if used) or the command line options (if built with MSBuild) for the correct settings. If not specified, they default to Debug and AnyCPU respectively.

See Also

Other Resources

Errors and Warnings


BE0041: Project XML comments file does not exist: [commentsFile]

[image]

Sandcastle Help File Builder Documentation
BE0041: Project XML comments file does not exist: [commentsFile]
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error BE0041: Project XML comments file does not exist: [commentsFile]

Cause

This error occurs if the XML comments file from a project file documenation source cannot be found.

Solution

The most likely cause of this error is that the project has not been built. Build the project so that the comments file exists and then build the help file project. Also ensure that the XML comments file generation option is enabled. In addition, check the Configuration and Platform settings on the documentation source to ensure that they are selecting the assembly that was built (i.e. Debug or Release). If they are not specified, check the settings in the GUI (if used) or the command line options (if built with MSBuild) for the correct settings. If not specified, they default to Debug and AnyCPU respectively.

See Also

Other Resources

Errors and Warnings


BE0042: You must specify at least one documentation source in the form...

[image]

Sandcastle Help File Builder Documentation
BE0042: You must specify at least one documentation source in the form...
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error BE0042: You must specify at least one documentation source in the form of an assembly or a Visual Studio solution/project file

Cause

This error occurs if there are no assembly documentation sources or Visual Studio solution/project documentation sources that contain a useable assembly for reference information.

Solution

Check the following conditions which can cause this error:

  • You need to include at least one assembly or Visual Studio solution/project file in the help file project as a documentation source. Add the assembly, solution, or project to the Documentation Sources project node in the Project Explorer window.
  • If you are trying to build a help file based solely on additional or conceptual content, add the Additional Content Only Plug-In to the project via the PlugInConfigurations project property.
  • If the plug-in is included in the project, make sure that it is enabled by checking the box next to it in the plug-in configuration dialog box.

See Also

Other Resources

Errors and Warnings


BE0043: Unexpected error detected in the last build step

[image]

Sandcastle Help File Builder Documentation
BE0043: Unexpected error detected in the last build step
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error BE0043: Unexpected error detected in last build step. See output above for details.

Cause

This error occurs when a build step fails unexpectedly. This condition is detected by monitoring the build step output for certain keywords that may indicate a failure.

Solution

Review the build log output just prior to the point of this error and look for other error or warning messages that may have contributed to the problem. If you cannot resolve the problem, please post a message in the Sandcastle Help File Builder discussion forum asking for help along with the details from the build log.

See Also

Other Resources

Errors and Warnings


BE0044: Error applying Visibility properties: [error]

[image]

Sandcastle Help File Builder Documentation
BE0044: Error applying Visibility properties: [error]
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error BE0044: Error applying Visibility properties: [error]

Cause

This error occurs if there is a problem applying any of the Visibility category properties to the reflection information.

Solution

This most likely indicates an internal error in the build process. Open a work item in the Sandcastle Help File Builder project at CodePlex containing the details from the error message and attach a small example project with any related files that can be used to duplicate the problem.

See Also

Other Resources

Errors and Warnings


BE0045: Error removing attributes nodes: [error]

[image]

Sandcastle Help File Builder Documentation
BE0045: Error removing attributes nodes: [error]
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error BE0045: Error removing attributes nodes: [error]

Cause

This error occurs if there is a problem removing unwanted attributes from the reflection information.

Solution

This most likely indicates an internal error in the build process. Open a work item in the Sandcastle Help File Builder project at CodePlex containing the details from the error message and attach a small example project with any related files that can be used to duplicate the problem.

See Also

Other Resources

Errors and Warnings


BE0046: Error removing EII nodes: [error]

[image]

Sandcastle Help File Builder Documentation
BE0046: Error removing EII nodes: [error]
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error BE0046: Error removing EII nodes: [error]

Cause

This error occurs if there is a problem removing unwanted explicit interface implementation details from the reflection information.

Solution

This most likely indicates an internal error in the build process. Open a work item in the Sandcastle Help File Builder project at CodePlex containing the details from the error message and attach a small example project with any related files that can be used to duplicate the problem.

See Also

Other Resources

Errors and Warnings


BE0047: Error removing inherited members: [error]

[image]

Sandcastle Help File Builder Documentation
BE0047: Error removing inherited members: [error]
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error BE0047: Error removing inherited members: [error]

Cause

This error occurs if there is a problem removing unwanted inherited members from the reflection information.

Solution

This most likely indicates an internal error in the build process. Open a work item in the Sandcastle Help File Builder project at CodePlex containing the details from the error message and attach a small example project with any related files that can be used to duplicate the problem.

See Also

Other Resources

Errors and Warnings


BE0048: Error removing [memberType]: [error]

[image]

Sandcastle Help File Builder Documentation
BE0048: Error removing [memberType]: [error]
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error BE0048: Error removing [memberType]: [error]

Cause

This error occurs if there is a problem removing unwanted items of the indicated member type from the reflection information.

Solution

This most likely indicates an internal error in the build process. Open a work item in the Sandcastle Help File Builder project at CodePlex containing the details from the error message and attach a small example project with any related files that can be used to duplicate the problem.

See Also

Other Resources

Errors and Warnings


BE0049: Error changed protected internal to protected: [error]

[image]

Sandcastle Help File Builder Documentation
BE0049: Error changed protected internal to protected: [error]
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error BE0049: Error changing protected internal to protected: [error]

Cause

This error occurs if there is a problem converting protected internal members to protected members in the reflection information.

Solution

This most likely indicates an internal error in the build process. Open a work item in the Sandcastle Help File Builder project at CodePlex containing the details from the error message and attach a small example project with any related files that can be used to duplicate the problem.

See Also

Other Resources

Errors and Warnings


BE0050: Error removing protected members from sealed classes: [error]

[image]

Sandcastle Help File Builder Documentation
BE0050: Error removing protected members from sealed classes: [error]
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error BE0050: Error removing protected members from sealed classes: [error]

Cause

This error occurs if there is a problem removing protected members from sealed classes in the reflection information.

Solution

This most likely indicates an internal error in the build process. Open a work item in the Sandcastle Help File Builder project at CodePlex containing the details from the error message and attach a small example project with any related files that can be used to duplicate the problem.

See Also

Other Resources

Errors and Warnings


BE0051: The specified project file does not exist: [projectFile]

[image]

Sandcastle Help File Builder Documentation
BE0051: The specified project file does not exist: [projectFile]
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error BE0051: The specified project file does not exist: [projectFile]

Cause

This error occurs if a documentation source or a project reference refers to a project file that does not exist or a solution documentation source contains a reference to a project file that does not exist.

Solution

Check the documentation sources and references to ensure that the contain references to valid files that do exist. For solution documentation sources, you may need to load them in Visual Studio to determine whether or not they contain valid project references.

See Also

Other Resources

Errors and Warnings


BE0052: One or more token files could not be found

[image]

Sandcastle Help File Builder Documentation
BE0052: One or more token files could not be found
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error BE0052: One or more token files could not be found

Cause

This error occurs if one or more project file items with a BuildAction of TokenFile could not be found on disk.

Solution

Check to be sure that the files physically exist on disk. If the file is no longer used, remove it from the project or change its build action to None so that it is ignored.

See Also

Other Resources

Errors and Warnings


BE0053: One or more code snippets files could not be found

[image]

Sandcastle Help File Builder Documentation
BE0053: One or more code snippets files could not be found
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error BE0053: One or more code snippets files could not be found

Cause

This error occurs if one or more project file items with a BuildAction of CodeSnippets could not be found on disk.

Solution

Check to be sure that the files physically exist on disk. If the file is no longer used, remove it from the project or change its build action to None so that it is ignored.

See Also

Other Resources

Errors and Warnings


BE0054: The conceptual topic '[title]' (ID: [id]) does not match any file in the project

[image]

Sandcastle Help File Builder Documentation
BE0054: The conceptual topic '[title]' (ID: [id]) does not match any file in the project
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error BE0054: The conceptual topic '[title]' (ID: [id]) does not match any file in the project

Cause

This error occurs if a conceptual content layout file contains a reference to a topic with the given ID and title that does not correspond to a conceptual content topic in the project.

Solution

Locate the ID in the conceptual content topic and determine whether or not it should have a file associated with it. If no, use the Clear Topic Association context menu option to remove the file association. If a file is supposed to be associated with it, make sure that a topic file with a .aml extension exists in the project. You can use the Associate Topic File context menu option to connect the topic file to the content layout entry.

See Also

Other Resources

Errors and Warnings


BE0055: The conceptual topic '[title]' (ID: [id]) must either specify a topic file or it must contains sub-topics

[image]

Sandcastle Help File Builder Documentation
BE0055: The conceptual topic '[title]' (ID: [id]) must either specify a topic file or it must contains sub-topics
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error BE0055: The conceptual topic '[title]' (ID: [id]) must either specify a topic file or it must contains sub-topics

Cause

This error occurs if a conceptual content layout file contains an entry that has to file associated with it and does not have any child nodes.

Solution

Container nodes are valid in a content layout file but they must have child nodes in order to make them useful. Either remove the indicated node, associate it with a topic, or add child nodes with topics to it so that it is valid. If you are in the process of creating the file, you can add a placeholder topic to make it valid for the build.

See Also

Other Resources

Errors and Warnings


BE0056: The conceptual content file '[file]' with ID '[id]' does not exist

[image]

Sandcastle Help File Builder Documentation
BE0056: The conceptual content file '[file]' with ID '[id]' does not exist
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error BE0056: The conceptual content file '[file]' with ID '[id]' does not exist

Cause

This error occurs if the indicated topic file with the given ID could not be found on disk.

Solution

Check to be sure that the file exists on disk.

See Also

Other Resources

Errors and Warnings


BE0057: The conceptual content file '[file]' with ID '[id]' is not valid: [error]

[image]

Sandcastle Help File Builder Documentation
BE0057: The conceptual content file '[file]' with ID '[id]' is not valid: [error]
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error BE0057: The conceptual content file '[file]' with ID '[id]' is not valid: [error]

Cause

This error occurs if the given topic file is not valid for some reason (i.e. ill-formed XML, unrecognized entity, etc.).

Solution

Refer to the error message for information about the cause of the problem. The most likely reason is ill-formed XML. In that case the error message will contain the line number and column of the element that caused the problem. This will help you locate and fix the problem.

See Also

Other Resources

Errors and Warnings


BE0058: Two conceptual content files have the same ID ({0})

[image]

Sandcastle Help File Builder Documentation
BE0058: Two conceptual content files have the same ID ({0})
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error BE0058: Two conceptual content files have the same ID ([id]). The file with the duplicate ID is '[file]'

Cause

This error occurs if two conceptual content topics have the same ID. This can happen if you copy and paste a topic to create a new one but forget to give the new file a new unique ID.

Solution

Each conceptual content topic file must have a unique ID. Locate the topics with the duplicate ID and change one of them by giving it a new unique ID value.

Note:

You should probably search for occurrences of the ID in link elements and check to make sure that the links go to the correct topic.

Tip:

If you need to clone a topic, it is usually best to add a new conceptual content topic so that it gets a unique ID and then copy and paste just the content from the introduction element through the relatedTopics element from the source topic into the new topic.

See Also

Other Resources

Errors and Warnings


BE0059: LCID '[id]' not found in configuration file

[image]

Sandcastle Help File Builder Documentation
BE0059: LCID '[id]' not found in configuration file
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Warning BE0059: LCID '[id]' not found in configuration file. Defaulting to ANSI code page value of '[codePage]'.

Cause

This warning appears if the specified locale ID cannot be found in the help file builder's SandcastleHtmlExtract.config file. In such cases, the indicated default ANSI code page value and encoding character set are used instead when updating the table of contents file with entries for the additional and conceptual content.

Solution

This will occur if you select a language for which there is no corresponding language element in the SandcastleHtmlExtract.config file. This file can be found in the help file builder installation folder. You can edit this file to add an element that defines the code page and character set to use for the given locale ID. If you do make an addition, please open a work item at the Sandcastle Help File Builder project on CodePlex to have the change added to the next release of the help file builder.

See Also

Other Resources

Errors and Warnings


BE0060: The [itemType] '[item]' contains a comma or '.h' which may cause the Help 1 compiler to fail

[image]

Sandcastle Help File Builder Documentation
BE0060: The [itemType] '[item]' contains a comma or '.h' which may cause the Help 1 compiler to fail
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Warning BE0060: The [itemType] '[item]' contains a comma or '.h' which may cause the Help 1 compiler to fail.

Cause

This warning is issued if the build process detects the text ".h" or a comma within the value of the indicated item while generating the file list for the Help 1 project file. In such cases, the help compiler may generate spurious HHC3002 and HHC3004 errors reporting that the content files are invalid.

Solution

The HTML Help 1.x compiler has problems interpretting paths and filenames that end with something equal to or starting with ".help" or ".hlp" or that contain ".h" in general (i.e. C:\Project.Help\). Rename the offending folder or filename to remove the period or comma or change the "help" or "hlp" part and try the build again (i.e. C:\Project_Help\, C:\ProjectHelp\, or C:\Project.Docs\). There may also be issues with paths containing commas so you may need to remove them as well if any are present in the path.

See Also

Other Resources

Errors and Warnings


BE0061: File '[file]' could not be loaded and will not be used as an XML comments file

[image]

Sandcastle Help File Builder Documentation
BE0061: File '[file]' could not be loaded and will not be used as an XML comments file
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Warning BE0061: File '[file]' could not be loaded and will not be used as an XML comments file. Error: [error]

Cause

This warning occurs if an XML file is found during the validation of the documentation sources and it could not be loaded for some reason.

Solution

This is a generic catch-all error that occurs if an XML comments file could not be loaded. Refer to the error message for information on how the problem can be resolved. This is a warning so the build will continue. However, if the indicated file does contain comments, they will not appear in the help file.

See Also

Other Resources

Errors and Warnings


BE0062: No XML comments found. The help file will not contain any member comments

[image]

Sandcastle Help File Builder Documentation
BE0062: No XML comments found. The help file will not contain any member comments
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Warning BE0062: No XML comments files found. The help file will not contain any member comments.

Cause

This warning occurs if no XML comments files are found when validating the documentation sources. If this occurs, the assemblies will still be documented but the API topics will not contain any member comments.

Solution

To suppress this warning, specify at least one XML comments file as a documentation source. If you did, verify that you got the name correct and that it exists. If using a solution or project file as the documentation source, verify that the XML comments generation option is enabled in each project.

See Also

Other Resources

Errors and Warnings


BE0063: '[file]' matches a previously copied comments filename

[image]

Sandcastle Help File Builder Documentation
BE0063: '[file]' matches a previously copied comments filename
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Warning BE0008: '[file]' matches a previously copied comments filename. The duplicate will be copied to a unique name to preserve the comments it contains.

Cause

This warning occurs if a duplicate XML comments filename is found while validating the documentation sources.

Solution

The file will be given a unique GUID-based name for the build. To suppress the warning, give the indicated comments file a unique name in the project in which it is defined.

See Also

Other Resources

Errors and Warnings


BE0064: BUILD CANCELLED BY USER

[image]

Sandcastle Help File Builder Documentation
BE0064: BUILD CANCELLED BY USER
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error BE0064: BUILD CANCELLED BY USER

Cause

This is the generic error produced when you cancel a build.

Solution

N/A.

See Also

Other Resources

Errors and Warnings


BE0065: BUILD FAILED: [error]

[image]

Sandcastle Help File Builder Documentation
BE0065: BUILD FAILED: [error]
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error BE0065: BUILD FAILED: [error]

Cause

This is the generic error produced when a build fails for an unexpected reason.

Solution

Review the build log output just prior to the point of this error and look for other error or warning messages that may have contributed to the problem. If you cannot resolve the problem, please post a message in the Sandcastle Help File Builder discussion forum asking for help along with the details from the build log.

See Also

Other Resources

Errors and Warnings


BE0066: The HelpFileVersion property value '[value]' is not in the correct format

[image]

Sandcastle Help File Builder Documentation
BE0066: The HelpFileVersion property value '[value]' is not in the correct format
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error BE0066: The HelpFileVersion property value '[value]' is not in the correct format (#.#.#.#) [additional info]

Cause

The value of the HelpFileVersion property is not valid. Refer to the additional information following the error for the specific problem.

Solution

Edit the value of the HelpFileVersion project property so that it is in an acceptable format with four numeric parts separated by periods. Specify zero for any unused parts (i.e. 1.4.35.0).

See Also

Other Resources

Errors and Warnings


BE0067: Unable to obtain assembly name from project file

[image]

Sandcastle Help File Builder Documentation
BE0067: Unable to obtain assembly name from project file
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error BE0067: Unable to obtain assembly name from project file '[projectFile]' using Configuration '[config]', Platform '[platform]'

Cause

The assembly name was unable to be determined in the specified Visual Studio project file because it does not contain a definition for the indicated configuration and platform value combination.

Solution

Check the following conditions and correct as indicated:

  • Check the configuration and platform values to make sure that you did not misspell them. If misspelled, correct the spelling either on the command line if doing a command line build or in the project's documentation source entry in the Configuration and Platform property settings.
  • If a Configuration or Platform environment variable is defined (the names are case-insensitive), MSBuild will pick up that value and use it as a default if not defined elsewhere. If not needed, delete the environment variables. If they are needed, override their values by specifying the correct value using MSBuild command line options or the Configuration and Platform properties on the documentation source entry for the project.
  • Check the Visual Studio project to ensure that it contains a configuration and platform definition for the specified values. If not, add them using the configuration manager. If not applicable to the project, use the documentation source entry's Configuration and Platform properties to specify the values to use for this particular project.

See Also

Other Resources

Errors and Warnings


GID0001: Unexpected error while generating inherited documentation

[image]

Sandcastle Help File Builder Documentation
GID0001: Unexpected error while generating inherited documentation
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error GID0001: Unexpected error while generating inherited documentation: [error]

Cause

This is a generic catch-all error that occurs if a problem is encountered while generating the inherited documentation comments.

Solution

Since this is a catch-all error, refer to the error description for information about the cause of the error and how you might be able to correct it (i.e. file not found, permission issues, a corrupt file, etc.). If you are unable to solve the problem based on the reported error, open a work item in the Sandcastle Help File Builder project at CodePlex containing the details from the error message. Attach the affected project as an example.

See Also

Other Resources

Errors and Warnings
Using the <inheritdoc /> Tag


GID0002: No comments found for cref '[cref]' on member '[id]

[image]

Sandcastle Help File Builder Documentation
GID0002: No comments found for cref '[cref]' on member '[id]
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Warning GID0002: No comments found for cref '[cref]' on member '[id]'

Cause

This warning will appear of an <inheritDoc /> element specified a cref attribute but the resulting XPath query resulted in no matches.

Solution

Check the cref attribute to be sure that it is correct. In addition, check the comments files to be sure that it contains the elements that are to be selected by the XPath query.

See Also

Other Resources

Errors and Warnings
Using the <inheritdoc /> Tag


GID0003: Unable to locate API ID '[id]'

[image]

Sandcastle Help File Builder Documentation
GID0003: Unable to locate API ID '[id]'
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Warning GID0003: Unable to locate API ID '[id]'

Cause

This warning occurs if the member ID for an element on which an <inheritDoc /> tag appears cannot be found in the reflection information file.

Solution

The possible causes for this warning are as follows:

  • The indicated ID name is misspelled or does not exist. In this, case, you must correct the ID so that it refers to a valid member ID.
  • The indicated member is private or internal and the build is only documenting the public API members. If you want the member included in the help file, you must enable documentation of the private and/or internal members using the DocumentInternals and/or DocumentPrivates project properties. In general, you can ignore these warnings as the members will not appear in the help file anyway.
  • The member has been excluded via an <exclude /> tag or the ApiFilter project property or the namespace has been excluded via the NamespaceSummaries property. If you want the member included, you must remove the <exclude /> tag or enable it in the API filter or namespace summaries. In general, you can ignore these warnings as the members will not appear in the help file anyway.

See Also

Other Resources

Errors and Warnings
Using the <inheritdoc /> Tag


GID0004: No comments found for member '[id]'

[image]

Sandcastle Help File Builder Documentation
GID0004: No comments found for member '[id]'
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Warning GID0004: No comments found for member '[id]'

Cause

No inheritable comments were found for the indicated member ID.

Solution

The possible causes for this warning are as follows:

  • The indicated ID name is misspelled or does not exist. In this, case, you must correct the ID so that it refers to a valid member ID.
  • The member does not represent an item from which comments can be inherited (i.e. not a class, an interface member, a virtual member, etc.).
  • The member's base elements do not contain comments. In this case, you must add comments on the base members so that they can be inherited.
  • If you specified a cref and/or a select attribute check them to make sure that they are accurate and will result in member comments that can be inherited.

See Also

Other Resources

Errors and Warnings
Using the <inheritdoc /> Tag


GID0005: No comments found for cref '[cref]'

[image]

Sandcastle Help File Builder Documentation
GID0005: No comments found for cref '[cref]'
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Warning GID0005: No comments found for cref '[cref]' on member '[memberId]' in '[nestedElement]'

Cause

No inheritable comments were found for the indicated cref value in the nested comment element of the indicated member ID.

Solution

The possible causes for this warning are as follows:

  • The indicated ID name is misspelled or does not exist. In this, case, you must correct the ID so that it refers to a valid member ID.
  • The member does not represent an item from which comments can be inherited (i.e. not a class, an interface member, a virtual member, etc.).
  • The member's base elements do not contain comments. In this case, you must add comments on the base members so that they can be inherited.
  • If you specified a cref and/or a select attribute check them to make sure that they are accurate and will result in member comments that can be inherited.

See Also

Other Resources

Errors and Warnings
Using the <inheritdoc /> Tag


GID0006: No comments found for member '[memberId]'

[image]

Sandcastle Help File Builder Documentation
GID0006: No comments found for member '[memberId]'
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Warning GID0006: No comments found for member '[memberId]' in '[nestedElement]'

Cause

No inheritable comments were found for the nested comment element of the indicated member ID.

Solution

The possible causes for this warning are as follows:

  • The indicated ID name is misspelled or does not exist. In this, case, you must correct the ID so that it refers to a valid member ID.
  • The member does not represent an item from which comments can be inherited (i.e. not a class, an interface member, a virtual member, etc.).
  • The member's base elements do not contain comments. In this case, you must add comments on the base members so that they can be inherited.
  • If you specified a cref and/or a select attribute check them to make sure that they are accurate and will result in member comments that can be inherited.

See Also

Other Resources

Errors and Warnings
Using the <inheritdoc /> Tag


GID0007: Ignoring non-XML comments file

[image]

Sandcastle Help File Builder Documentation
GID0007: Ignoring non-XML comments file
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Warning GID0007: Ignoring non-XML comments file

Cause

This warning occurs if a filename is encountered while indexing comments files that does not have a .xml extension.

Solution

If the file is not an XML comments file, the warning can be ignored. If it is intended to be a n XML comments file, rename it to use a .xml extension.

See Also

Other Resources

Errors and Warnings
Using the <inheritdoc /> Tag


GID0008: Entries for the key '[id]' occur in both '[file1]' and '[file2]'

[image]

Sandcastle Help File Builder Documentation
GID0008: Entries for the key '[id]' occur in both '[file1]' and '[file2]'
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Warning GID0008: Entries for the key '[id]' occur in both '[file1]' and '[file2]'. The entries in '[file2]' will be used.

Cause

This warning occurs if a member ID occurs in more than one comments file. In such cases, the ID and its related comments from the second file will be used rather than those in the first file.

Solution

This warning can usually be safely ignored as it simply means that a subsequent comments file is overriding the comments for the given ID with an alternate set of comments. This can happen frequently in the base .NET Framework classes. If the second set of comments used are not appropriate, you may need to take steps to rearrrange the files, remove the duplicate set of comments, or supply an additional file that further overrides the comments.

See Also

Other Resources

Errors and Warnings
Using the <inheritdoc /> Tag


SHE0001: LCID '[id]' not found in configuration file

[image]

Sandcastle Help File Builder Documentation
SHE0001: LCID '[id]' not found in configuration file
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Warning SHE0001: LCID '[id]' not found in configuration file. Defaulting to ANSI code page value of '[codePage]', encoding charset '[charset]'.

Cause

This warning appears if the specified locale ID cannot be found in the help file builder's SandcastleHtmlExtract.config file. In such cases, the indicated default ANSI code page value and encoding character set are used instead.

Solution

This will occur if you select a language for which there is no corresponding language element in the SandcastleHtmlExtract.config file. This file can be found in the help file builder installation folder. You can edit this file to add an element that defines the code page and character set to use for the given locale ID. If you do make an addition, please open a work item at the Sandcastle Help File Builder project on CodePlex to have the change added to the next release of the help file builder.

See Also

Other Resources

Errors and Warnings


SHE0002: Unexpected error: [error]

[image]

Sandcastle Help File Builder Documentation
SHE0002: Unexpected error: [error]
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error SHE0002: Unexpected error: [error]

Cause

This is a generic catch-all error that occurs if a problem is encountered while trying to extract information from the HTML files or produce the output files.

Solution

Since this is a catch-all error, refer to the error description for information about the cause of the error and how you might be able to correct it (i.e. file not found, permission issues, a corrupt file, etc.). If you are unable to solve the problem based on the reported error, open a work item in the Sandcastle Help File Builder project at CodePlex containing the details from the error message. Attach the affected project as an example.

See Also

Other Resources

Errors and Warnings


SHE0003: Unexpected error applying command line option

[image]

Sandcastle Help File Builder Documentation
SHE0003: Unexpected error applying command line option
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error SHE0003: Unexpected error applying command line option '[option]': [error]

Cause

This is a generic catch-all error that occurs if a problem is encountered while trying to parse the value of a command line option.

Solution

Since this is a catch-all error, refer to the error description for information about the cause of the error and how you might be able to correct it (i.e. bad option value, invalid format, etc.). If you are unable to solve the problem based on the reported error, open a work item in the Sandcastle Help File Builder project at CodePlex containing the details from the error message. Attach the affected project as an example.

See Also

Other Resources

Errors and Warnings


SHE0004: The key '[key]' used for '[file]' is already in use

[image]

Sandcastle Help File Builder Documentation
SHE0004: The key '[key]' used for '[file]' is already in use
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Warning SHE0004: The key '[key]' used for '[file]' is already in use by '[otherFile]'. '[file]' will be ignored.

Cause

This warning occurs if a duplicate topic filename is encountered while parsing files for titles and keywords. This can occur if HTML files are added to a project as additional content. If an identically named file occurs in two separate folders, only the first file will be included in the table of contents.

Solution

To correct the problem, give the duplicate file a unique name in the project. If the file is referenced in a site map file, edit the site map file to use the new name as well.

See Also

Other Resources

Errors and Warnings


B1X0001: A help compiler path must be specified

[image]

Sandcastle Help File Builder Documentation
B1X0001: A help compiler path must be specified
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error B1X0001: A help compiler path must be specified

Cause

This error occurs if the HelpCompilerFolder property on the Build1xHelpFile build task has not been set or is set to an empty string.

Solution

Specify a valid path for the HelpCompilerFolder property on the Build1xHelpFile build task in the project file.

See Also

Other Resources

Errors and Warnings


B1X0002: A help project file must be specified and it must exist

[image]

Sandcastle Help File Builder Documentation
B1X0002: A help project file must be specified and it must exist
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error B1X0002: A help project file must be specified and it must exist

Cause

This error occurs if the HelpProjectName property on the Build1xHelpFile build task has not been set, is set to an empty string, or refers to a file that does not exist.

Solution

Specify a valid file that exists for the HelpProjectName property on the Build1xHelpFile build task in the project file.

See Also

Other Resources

Errors and Warnings


B2X0001: A help compiler path must be specified

[image]

Sandcastle Help File Builder Documentation
B2X0001: A help compiler path must be specified
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error B2X0001: A help compiler path must be specified

Cause

This error occurs if the HelpCompilerFolder property on the Build2xHelpFile build task has not been set or is set to an empty string.

Solution

Specify a valid path for the HelpCompilerFolder property on the Build2xHelpFile build task in the project file.

See Also

Other Resources

Errors and Warnings


B2X0002: An HTML help base name must be specified

[image]

Sandcastle Help File Builder Documentation
B2X0002: An HTML help base name must be specified
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error B2X0002: An HTML help base name must be specified

Cause

This error occurs if the HtmlHelpName property on the Build2xHelpFile build task has not been set or is set to an empty string.

Solution

Specify a valid name for the HtmlHelpName property on the Build2xHelpFile build task in the project file.

Note:

The project file that is to be compiled must also be named using the HtmlHelpName value with a .HxS extension. The project file must exist in the folder specified in the WorkingFolder property.

See Also

Other Resources

Errors and Warnings


BAT0001: A configuration file must be specified and it must exist

[image]

Sandcastle Help File Builder Documentation
BAT0001: A configuration file must be specified and it must exist
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error BAT0001: A configuration file must be specified and it must exist

Cause

This error occurs if the ConfigurationFile property on the BuildAssembler build task has not been set, is set to an empty string, or refers to a file that does not exist.

Solution

Specify a valid file that exists for the ConfigurationFile property on the BuildAssembler build task in the project file.

See Also

Other Resources

Errors and Warnings


BAT0002: A manifest file must be specified and it must exist

[image]

Sandcastle Help File Builder Documentation
BAT0002: A manifest file must be specified and it must exist
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error BAT0002: A manifest file must be specified and it must exist

Cause

This error occurs if the ManifestFile property on the BuildAssembler build task has not been set, is set to an empty string, or refers to a file that does not exist.

Solution

Specify a valid file that exists for the ManifestFile property on the BuildAssembler build task in the project file.

See Also

Other Resources

Errors and Warnings


BHT0001: Unable to get executing project

[image]

Sandcastle Help File Builder Documentation
BHT0001: Unable to get executing project
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Warning BHT0001: Unable to get executing project: [reason]. The specified project will be loaded but command line property overrides will be ignored.

Cause

The BuildHelp build task was unable to obtain a reference to the executing project for the reason indicated.

Solution

This most likely indicates an internal error in the build process. Open a work item in the Sandcastle Help File Builder project at CodePlex containing the details from the error message and attach a small example project with any related files that can be used to duplicate the problem.

See Also

Other Resources

Errors and Warnings


BHT0002: Unable to build project '[projectFile]': [error]

[image]

Sandcastle Help File Builder Documentation
BHT0002: Unable to build project '[projectFile]': [error]
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error BHT0002: Unable to build project '[projectFile]': [error]

Cause

This is a generic catch-all error that occurs when a build fails unexpectedly.

Solution

Review the build log output and look for other error or warning messages that may have contributed to the problem. If you cannot resolve the problem, please post a message in the Sandcastle Help File Builder discussion forum asking for help along with the details from the build log.

See Also

Other Resources

Errors and Warnings


BHT0003: The specified project file does not exist: [projectFile]

[image]

Sandcastle Help File Builder Documentation
BHT0003: The specified project file does not exist: [projectFile]
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error BHT0003: The specified project file does not exist: [projectFile]

Cause

This error occurs if the project file referenced by the ProjectFile property on the BuildHelp build task could not be found.

Solution

Check the value of the property to ensure that the filename is correct and that the project file does exist.

See Also

Other Resources

Errors and Warnings


BHT0004: An older MSBuild version is being used

[image]

Sandcastle Help File Builder Documentation
BHT0004: An older MSBuild version is being used
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error BHT0004: An older MSBuild version is being used. Unable to build help project.

Cause

The BuildHelp build task was unable to build the project because it is running under an older version of MSBuild.

Solution

Your build process must be changed to use MSBuild 3.5 or later to build the help project. For example, modify your build script to use the MSBuild 3.5 executable or, if using an MSBuild project, use the Exec task to execute it.

See Also

Other Resources

Errors and Warnings


CT0001: Unable to clean output folder. Reason: [reason]

[image]

Sandcastle Help File Builder Documentation
CT0001: Unable to clean output folder. Reason: [reason]
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error CT0001: Unable to clean output folder. Reason: [reason]

Cause

This error occurs if the CleanHelp build task is unable to purge the folders specified in the WorkingPath and OutputPath properties.

Solution

This is a generic, catch-all error that occurs if the specified folders could not be purged. Refer to the additional error information for information about why the error occurred and how it can be fixed (i.e. the folder is in use, no permission, etc.).

See Also

Other Resources

Errors and Warnings


MBT0001: At least one assembly (.dll or .exe) is required for MRefBuilder to parse

[image]

Sandcastle Help File Builder Documentation
MBT0001: At least one assembly (.dll or .exe) is required for MRefBuilder to parse
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error MBT0001: At least one assembly (.dll or .exe) is required for MRefBuilder to parse

Cause

This error occurs if no assemblies are specified in the MRefBuilder build task's Assemblies property.

Solution

Specify at least on assembly (.exe or .dll) in the Assemblies property so that the MRefBuilder tool has something for which to generate reflection information.

See Also

Other Resources

Errors and Warnings


MBT0002: Unable to generate response file. Reason: [reason]

[image]

Sandcastle Help File Builder Documentation
MBT0002: Unable to generate response file. Reason: [reason]
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error MBT0002: Unable to generate response file. Reason: [reason]

Cause

This error occurs if the MRefBuilder build task is unable to create the response file it needs.

Solution

This is a generic, catch-all error that occurs if the response file could not be created. Refer to the additional error information for information about why the error occurred and how it can be fixed (i.e. no permission, out of disk space, etc.).

See Also

Other Resources

Errors and Warnings


XTT0001: At least one XSL transformation is required

[image]

Sandcastle Help File Builder Documentation
XTT0001: At least one XSL transformation is required
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error XTT0001: At least one XSL transformation is required

Cause

This error occurs if no XSL transformation files are specified in the XslTransform build task's Transformations property.

Solution

Specify at least on XSL transformation in the Transformations property so that the XslTransform tool has something to use when transforming the input file.

See Also

Other Resources

Errors and Warnings


XTT0002: An input file must be specified and it must exist

[image]

Sandcastle Help File Builder Documentation
XTT0002: An input file must be specified and it must exist
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error XTT0002: An input file must be specified and it must exist

Cause

This error occurs if the InputFile property on the XslTransform build task has not been set, is set to an empty string, or refers to a file that does not exist.

Solution

Specify a valid file that exists for the InputFile property on the XslTransform build task in the project file.

See Also

Other Resources

Errors and Warnings


XTT0003: An output filename must be specified

[image]

Sandcastle Help File Builder Documentation
XTT0003: An output filename must be specified
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error XTT0003: An output filename must be specified

Cause

This error occurs if the OutputFile property on the XslTransform build task has not been set or is set to an empty string.

Solution

Specify a valid filename for the OutputFile property on the XslTransform build task in the project file.

See Also

Other Resources

Errors and Warnings


ACP0001: The Additional Content Only plug-in requires...

[image]

Sandcastle Help File Builder Documentation
ACP0001: The Additional Content Only plug-in requires...
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error ACP0001: The Additional Content Only plug-in requires a conceptual content layout file, a site map file, or content items in the project

Cause

This error occurs if the Additional Content Only plug-in cannot find at least one content layout file, site map file, or a file item with a build action of Content.

Solution

In order to produce a help file containing no API content, there must be at least one content layout file, a site map file, or some HTML content file items that can be used to produce non-API help topics that will appear in the help file. Add at least one required item and any additional files and perform the build again.

See Also

Other Resources

Errors and Warnings


ARL0001: The Additional Reference Links plug-in has not been configured yet

[image]

Sandcastle Help File Builder Documentation
ARL0001: The Additional Reference Links plug-in has not been configured yet
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error ARL0001: The Additional Reference Links plug-in has not been configured yet

Cause

The plug-in was added to the project but was not configured. The default configuration is not sufficient to use it in a build.

Solution

Open the editor for the PlugInConfigurations project property, select the plug-in, and click the Configure button to specify a valid configuration for it.

See Also

Other Resources

Errors and Warnings


ARL0002: At least one target is required for the Additional Reference Links plug-in

[image]

Sandcastle Help File Builder Documentation
ARL0002: At least one target is required for the Additional Reference Links plug-in
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error ARL0002: At least one target is required for the Additional Reference Links plug-in

Cause

The plug-in was added to the project but was not configured correctly.

Solution

Open the editor for the PlugInConfigurations project property, select the plug-in, and click the Configure button to specify a valid configuration for it. Add at least one project file to use as a source of additional reference links.

See Also

Other Resources

Errors and Warnings


ARL0003: Unable to build additional target project: [projectFile]

[image]

Sandcastle Help File Builder Documentation
ARL0003: Unable to build additional target project: [projectFile]
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error ARL0003: Unable to build additional target project: [projectFile]

Cause

This error occurs if there was a problem building the specified project file in order to obtain reference link information.

Solution

This is a generic, catch-all error. Load the indicated project and build it by itself to see if you can locate the cause of the problem. If it works by itself, look in the .\Working folder under the build folder of the project that uses it in the plug-in. You will find a build subfolder for it containing a log file. Review it to see if it can help you locate the cause of the error. If you are unable to resolve the issue, open a work item in the Sandcastle Help File Builder project at CodePlex containing the details from the error message and attach a small example project with any related files that can be used to duplicate the problem.

See Also

Other Resources

Errors and Warnings


ARL0004: Unable to locate Reflection Index Data component in [configFile]

[image]

Sandcastle Help File Builder Documentation
ARL0004: Unable to locate Reflection Index Data component in [configFile]
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error ARL0004: Unable to locate Reflection Index Data component in [configFile]

Cause

The Reflection Index Data component could not be located in the indicated configuration file.

Solution

This most likely indicates an internal error in the plug-in. Open a work item in the Sandcastle Help File Builder project at CodePlex containing the details from the error message and attach a small example project with any related files that can be used to duplicate the problem.

See Also

Other Resources

Errors and Warnings


ARL0005: Unable to locate Resolve Reference Links component in [configFile]

[image]

Sandcastle Help File Builder Documentation
ARL0005: Unable to locate Resolve Reference Links component in [configFile]
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error ARL0005: Unable to locate Resolve Reference Links component in [configFile]

Cause

The Resolve Reference Links component could not be located in the indicated configuration file.

Solution

This most likely indicates an internal error in the plug-in. Open a work item in the Sandcastle Help File Builder project at CodePlex containing the details from the error message and attach a small example project with any related files that can be used to duplicate the problem.

See Also

Other Resources

Errors and Warnings


ARL0006: Fatal error, unable to compile project '[projectFile]': [error]

[image]

Sandcastle Help File Builder Documentation
ARL0006: Fatal error, unable to compile project '[projectFile]': [error]
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error ARL0006: Fatal error, unable to compile project '[projectFile]': [error]

Cause

This error occurs if there was a problem building the specified project file in order to obtain reference link information.

Solution

This is a generic, catch-all error. Load the indicated project and build it by itself to see if you can locate the cause of the problem. If it works by itself, look in the .\Working folder under the build folder of the project that uses it in the plug-in. You will find a build subfolder for it containing a log file. Review it to see if it can help you locate the cause of the error. If you are unable to resolve the issue, open a work item in the Sandcastle Help File Builder project at CodePlex containing the details from the error message and attach a small example project with any related files that can be used to duplicate the problem.

See Also

Other Resources

Errors and Warnings


ARL0007: The help file project cannot be blank

[image]

Sandcastle Help File Builder Documentation
ARL0007: The help file project cannot be blank
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error ARL0007: The help file project cannot be blank

Cause

This error occurs if the Additional Reference Links plug-in has an invalid configuration.

Solution

Open the editor for the PlugInConfigurations project property, select the plug-in, and click the Configure button to specify a valid configuration for it. Be sure that the project filenames in each entry are not blank.

See Also

Other Resources

Errors and Warnings


ADP0001: Placeholder

[image]

Sandcastle Help File Builder Documentation
ADP0001: Placeholder
Send Feedback

[This is preliminary documentation and is subject to change.]

TODO: Error message goes here

Cause

TODO: Describe the cause

Solution

TODO: Describe possible solution


PRJ0001: Invalid or missing SchemaVersion

[image]

Sandcastle Help File Builder Documentation
PRJ0001: Invalid or missing SchemaVersion
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error PRJ0001: Invalid or missing SchemaVersion

Cause

This error is caused by a missing schema version property in the project.

Solution

The most likely cause of this error is that you have attempted to load a project file that is not valid for use with the current release of the help file builder. Only projects using the newer MSBuild format can be loaded with version 1.8.0.0 and later. Use the project converter to convert older projects to the new format.

Another cause is loading an MSBuild project file that was not created by the help file builder. Depending on what the project file is for, you may be able to convert it to the help file builder format too.

See Also

Other Resources

Errors and Warnings


PRJ0002: The selected file is for a more recent version

[image]

Sandcastle Help File Builder Documentation
PRJ0002: The selected file is for a more recent version
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error PRJ0002: The selected file is for a more recent version of the help file builder. Please upgrade your copy to load the file.

Cause

As indicated, the selected project file is for a more recent version of the help file builder. It contains project options that cannot be handled by your current release.

Solution

Upgrade to the latest release of Sandcastle and the Sandcastle Help File Builder.

See Also

Other Resources

Errors and Warnings


PRJ0003: Error reading project from '[file]': [reason]

[image]

Sandcastle Help File Builder Documentation
PRJ0003: Error reading project from '[file]': [reason]
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error PRJ0003: Error reading project from '[file]': [reason]

Cause

This is a generic catch-all error that occurs when there is a problem attempting to load a help file builder project. If you have been modifying the project file by hand, it could indicate that you have introduced an error into the help file properties.

Solution

Since this is a catch-all error, refer to the reason description for information about the cause of the error and how you might be able to correct it (i.e. file not found, permission issues, a corrupt file, etc.).

If you have been modifying the help file project by hand rather than by using the help file builder standalone GUI, back out your changes and try to reload the project. If you have not made any such modifications, open a work item in the Sandcastle Help File Builder project at CodePlex containing the details from the error message. Attach the affected project as an example.

See Also

Other Resources

Errors and Warnings


PRJ0004: An attempt was made to set a read-only or ignored property

[image]

Sandcastle Help File Builder Documentation
PRJ0004: An attempt was made to set a read-only or ignored property
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error PRJ0004: An attempt was made to set a read-only or ignored property: [property] Value: [value]

Cause

This is an internal error that indicates a problem with the project system or the project file. If you have been modifying the project file by hand, it could indicate that you have introduced an error into the help file properties.

Solution

If you have been modifying the help file project by hand rather than by using the help file builder standalone GUI, back out your changes and try to reload the project. If you have not made any such modifications, open a work item in the Sandcastle Help File Builder project at CodePlex containing the details from the error message. Attach the affected project as an example.

See Also

Other Resources

Errors and Warnings


PRJ0005: Unable to parse value '[value]' for property '[property]'

[image]

Sandcastle Help File Builder Documentation
PRJ0005: Unable to parse value '[value]' for property '[property]'
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error PRJ0005: Unable to parse value '[value]' for property '[property]'

Cause

This is an internal error that indicates a problem with the project system or the project file. If you have been modifying the project file by hand, it could indicate that you have introduced an error into the help file properties.

Solution

If you have been modifying the help file project by hand rather than by using the help file builder standalone GUI, back out your changes and try to reload the project. If you have not made any such modifications, open a work item in the Sandcastle Help File Builder project at CodePlex containing the details from the error message. Attach the affected project as an example.

See Also

Other Resources

Errors and Warnings


PRJ0006: Error saving project to '[file]': [reason]

[image]

Sandcastle Help File Builder Documentation
PRJ0006: Error saving project to '[file]': [reason]
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error PRJ0006: Error saving project to '[file]': [reason]

Cause

This is a generic catch-all error that occurs when a problem occurs while attempting to save a help file builder project. If you have been modifying the project file by hand, it could indicate that you have introduced an error into the help file properties.

Solution

Since this is a catch-all error, refer to the reason description for information about the cause of the error and how you might be able to correct it (i.e. permission issues, out of disk space, etc.).

If you have been modifying the help file project by hand rather than by using the help file builder standalone GUI, back out your changes and try to reload the project, make any necessary changes, and save the project. If you have not made any such modifications, open a work item in the Sandcastle Help File Builder project at CodePlex containing the details from the error message. Attach the affected project as an example.

See Also

Other Resources

Errors and Warnings


CVT0001: Unable to parse value '[value]' for property '[name]'

[image]

Sandcastle Help File Builder Documentation
CVT0001: Unable to parse value '[value]' for property '[name]'
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error CVT0001: Unable to parse value '[value]' for property '[name]': [error]

Cause

This is a generic catch-all error that occurs if there is a problem paring a property value in order to store it in the new project.

Solution

Since this is a catch-all error, refer to the error description for information about the cause of the error and how you might be able to correct it (i.e. bad value format, etc.). If you are unable to solve the problem based on the reported error, open a work item in the Sandcastle Help File Builder project at CodePlex containing the details from the error message. Attach the affected source project as an example.

See Also

Other Resources

Errors and Warnings


CVT0002: An attempt was made to set an unknown or read-only property

[image]

Sandcastle Help File Builder Documentation
CVT0002: An attempt was made to set an unknown or read-only property
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error CVT0002: An attempt was made to set an unknown or read-only property: [property] Value: [value]

Cause

This is an internal error that indicates a problem with the project system or the project file.

Solution

Open a work item in the Sandcastle Help File Builder project at CodePlex containing the details from the error message. Attach the affected source project as an example.

See Also

Other Resources

Errors and Warnings


CVT0003: Invalid or missing schema version

[image]

Sandcastle Help File Builder Documentation
CVT0003: Invalid or missing schema version
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error CVT0003: Invalid or missing schema version

Cause

This error is caused by a missing schema version property in the source project.

Solution

The most likely cause of this error is that you have attempted to load a help file builder version 1.7.0.0 or earlier project file that is not valid. Check the file to be sure that it is a help file builder project file. If you are unable to solve the problem based on the reported error, open a work item in the Sandcastle Help File Builder project at CodePlex containing the details from the error message. Attach the affected source project as an example.

See Also

Other Resources

Errors and Warnings


CVT0004: Unrecognized schema version

[image]

Sandcastle Help File Builder Documentation
CVT0004: Unrecognized schema version
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error CVT0004: Unrecognized schema version

Cause

This error is caused by an unrecognized schema version.

Solution

The most likely cause of this error is that you have attempted to load a help file builder version 1.7.0.0 or earlier project file that is not valid. Check the file to be sure that it is a help file builder project file. If you are unable to solve the problem based on the reported error, open a work item in the Sandcastle Help File Builder project at CodePlex containing the details from the error message. Attach the affected source project as an example.

See Also

Other Resources

Errors and Warnings


CVT0005: Error reading project from '[file]'

[image]

Sandcastle Help File Builder Documentation
CVT0005: Error reading project from '[file]'
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error CVT0005: Error reading project from '[file]' (last property = [property]): [error]

Cause

This is a generic catch-all error that occurs if there is a problem converting a project file.

Solution

Since this is a catch-all error, refer to the property name and error description for information about the cause of the error and how you might be able to correct it (i.e. bad value format, unrecognized value, etc.). If you are unable to solve the problem based on the reported error, open a work item in the Sandcastle Help File Builder project at CodePlex containing the details from the error message. Attach the affected source project as an example.

See Also

Other Resources

Errors and Warnings


CVT0006: Error converting content layout file

[image]

Sandcastle Help File Builder Documentation
CVT0006: Error converting content layout file
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Error CVT0006: Error converting content layout file ([file]): [error]

Cause

This is a generic catch-all error that occurs if there is a problem converting the conceptual content layout file.

Solution

Since this is a catch-all error, refer to the error description for information about the cause of the error and how you might be able to correct it (i.e. file not found, permissions error, etc.). If you are unable to solve the problem based on the reported error, open a work item in the Sandcastle Help File Builder project at CodePlex containing the details from the error message. Attach the affected source project and the indicated content layout file as an example.

See Also

Other Resources

Errors and Warnings


Localizing Language Resource Files

[image]

Sandcastle Help File Builder Documentation
Localizing Language Resource Files
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Sandcastle uses a set of resource files to contain text such as table of contents item titles, common topic element titles, messages, etc. Copies of the four main resource files are located in a .\Content subfolder beneath each presentation style folder under the .\Presentation folder in the main Sandcastle installation folder. An additional content file used by all presentation styles is located in the .\Shared\Content folder under the main .\Presentation folder.

The Resource Files

The following files contain the resources:

  • conceptual_content.xml contains titles for items in conceptual content files.
  • feedBack_content.xml contains items related to the feedback control in the VS2005 presentation style. Currently, the feedback control is not used by any of the presentation styles.
  • reference_content.xml contains titles for the various class library parts, filter text, and alternate image text.
  • shared_content.xml contains paths to the shared content (art, scripts, and style sheets), code section labels, and customizable text for the header and footer in each page. The help file builder overrides many of these using its own content file.
  • syntax_content.xml contains some programming language limitation messages. This is in the shared folder and is used by all presentation styles.
  • token_content.xml contains some supplemental reference messages.

The supplied files are all in English but can be translated into other languages for use in your help files. The help file builder includes its own shared content files which are used to override elements in the above files for such things as the help title, header and footer text, preliminary documentation message, etc. There are several copies of the shared content files, each representing a different language. You can find the files in the .\SharedContent folder under the Sandcastle Help File Builder installation folder. The files all start with SharedBuilderContent_ or XXXBuilderContent_ where "XXX" is a presentation style name and all are suffixed with a language ID based on the value returned by the CultureInfo.Name property (i.e. en-US, fr-FR, de-DE). Each file has a ".xml" extension.

A set of stop word list files also exists in the help file builder's shared content folder that are used when creating the full text index for the website build and for the HTML Help 2 file. The files contain a list of common words that are excluded from the full-text index. This prevents the index files from getting too large and containing useless information. You can add additional words to these files as needed. The files all start with StopWordList_ and are suffixed with a language ID based on the value returned by the CultureInfo.Name property (i.e. en-US, fr-FR, de-DE). Each file has a .txt extension.

Localizing Language Resources

To create a help file builder resource file for a new language, copy one of the existing files and change the name to use the culture name's ID as described above. If you are not sure what ID to use in the filename, go to the Locale Identifier Constants and Strings MSDN topic and locate the locale that you need. The locale name column contains the value to use for the filename. Edit the new file and translate the text to the selected language. If people are kind enough to supply additional translated files, I'll add them to later releases.

Due to the number of presentation styles and the number of files that would be created, it is not possible to maintain a matching set of Sandcastle's content files for each language. You will need to create localized copies of them for each language that you want. The standard files in the noted .\Content folders will always be used when English (en-US) is used as the selected language or if files for the selected language cannot be found. Note that these files tend to change with each new release of Sandcastle so you will have to compare and merge changes with your localized versions after each new release is issued.

To create your own localized versions of the content files, create a folder below each of the noted .\Content folders. The new folder should be named after the selected language ID (i.e. fr-FR, de-DE, etc.). Copy the Sandcastle content files to the new language folder and translate their content. When translating shared_content.xml, be sure to set the value of the item with the locale ID to the correct language ID. When you do a build with a language other than English, the help file builder will automatically look for a folder named after the selected language and will use the translated files if it finds them. If the translated files cannot be found, a warning is issued in the log file and the English versions will be used.

How the files are encoded is very important if they contain extended characters. To ensure that the help file builder and the Sandcastle tools properly interpret the encoding within the files, it is best to save the files such that they contain byte order marks at the start of the file for Unicode encoded formats as well as an XML header tag that specifies the correct encoding. In the absence of byte order marks, the encoding in the XML header tag ensures that the file is still interpreted correctly. The supplied default language resource files contain examples of this.

When using entities to represent special characters in the XML language resource files or in the header text, copyright text, etc, use the numeric form rather than the name form as the XML parser will not recognize them and will throw an exception. For example, if you specify &Auml; (Latin capital letter A with diaeresis) an exception will be generated. To fix it, use the numeric form instead (&#196;). This also applies to symbols such as &copy; in the copyright text. Instead, you should use &#169; to get the copyright symbol.

See Also

Other Resources

Customizing the Header and Footer Text
Customizing the Build Process


Customizing the Header and Footer Text

[image]

Sandcastle Help File Builder Documentation
Customizing the Header and Footer Text
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The text that appears in the header, footer, and copyright notice can be specified using the standard project properties. If you need to modify the format or style of these items, the preliminary documentation warning, or the feedback e-mail note, you can modify the related entries in the help file builder shared content files. These are found in the .\SharedContent folder under the help file builder installation folder.

Note:

The resource files are language and presentation style specific. You will need to modify the entries for each language and presentation style that you support.

The following entries are available:

  • The header entry controls the header text. By default, only the HeaderText and Preliminary substitution tags are listed in here.
  • The preliminary entry controls the text of the preliminary documentation warning. When enabled, this text is substituted for the tag in the header entry.
  • The footer entry controls the layout of the page footer. By default, only the Comments and Copyright substitution tags appear in here.
  • The comments entry controls the layout of the "send e-mail" note that appears if a FeedbackEMailAddress is specified.
  • The copyright entry controls the layout of the copyright information that appears in the footer if CopyrightHref and/or CopyrightText are specified.

There are several additional entries in the files but almost all of them are set using project property replacement tags alone.

See Also

Other Resources

Localizing Language Resource Files
Customizing the Build Process


Customizing the Build Process

[image]

Sandcastle Help File Builder Documentation
Customizing the Build Process
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

In order to provide the ability to customize the main build steps in earlier versions of the help file builder, the scripts used to run the tools and the related configuration files were placed in the .\Templates folder beneath the main help file builder installation folder rather than embedding them in the executables. In each file are a set of substitution tags that will be resolved to one of the project properties and, in some cases, a list of files at build time.

Note:

All current and future versions of the help file builder support plug-ins which provide a much more flexible way of altering and extending the build process without the need to modify the supplied templates. You can use the same set of substitution tags in your own scripts, configuration files, and plug-ins and resolve them at build-time as well.

Replacement Tags

The help file builder template files as well as various files in your own projects such as token files may contain one or more of the following substitution tags. At build-time, these tags will be replaced with the appropriate project value in order to produce the help file. Some of these tags also appear in the language resource files and are used to place items in the page header and footer. These tags can also be entered into text project properties such as HeaderText or FooterText to have them appear in the help topics.

Tip:

Any MSBuild property can also be referenced using the substitution tag syntax ({@PropertyName}). This allows you to define custom properties via the UserDefinedProperties project property and use them in other project properties such as HelpFileVersion, HeaderText, etc.

Replacement Tag | Description
{@AppDataFolder} and {@LocalDataFolder} | {@AppDataFolder} is replaced with the common application data folder for the help file builder. This is used to store third-party build components and plug-ins. {@LocalDataFolder} is replaced with the local application data folder for the help file builder. This is used to store cache files and other user settings. See the Special Folder Locations topic for more information.
{@AutoDocumentConstructors}, {@ShowMissingNamespaces}, {@ShowMissingParams}, {@ShowMissingRemarks}, {@ShowMissingReturns}, {@ShowMissingSummaries}, {@ShowMissingTypeParams}, {@ShowMissingValues} | These tags equates to the ShowMissing* project properties and are used to set the ShowMissingComponent build component configuration settings in the sandcastle.config file templates.
{@BinaryTOC} | This tag equates to a Yes or No value based on the BinaryTOC project setting. This is placed in the help file project template.
{@BuildDate} or {@BuildDate:[date-format]} | This tag allows you to insert a build date/time into a project file or a text project property such as HeaderText or FooterText. If {@BuildDate} is used, the full date time is inserted using the default format. You can also specify a custom date format. For example: {@BuildDate:MMMM d, yyyy a\t hh:mm tt}
{@CodeSnippetsFiles} | This tag expands to a list of the conceptual content code snippets files that will be used by the Example Component in conceptual content builds. To be included, the project file must have its BuildAction set to CodeSnippets.
{@CommentFileList} | This tag expands to a list of the XML comment files that will be used to produce the help file. This tag is placed in the Sandcastle configuration file.
{@Comments} | If a FeedbackEMailAddress is specified in the project, this tag expands to the include directive that adds the "send e-mail" note to the page footers.
{@ComponentsFolder} | This tag expands to the path where the custom build components can be found. This will be the Build Components\ folder under common application data folder ({@AppDataFolder}).
{@CopyrightHref} | This tag expands to the CopyrightHref project option.
{@CopyrightInfo} and {@HtmlEncCopyrightInfo} | These tags expand to an empty string if neither the CopyrightHref nor the CopyrightText project options are specified. If only one or the other is specified, then it results in the value of the project option that is present. If both are specified, it results in a link to the specified URL with the specified copyright text. The first version is plain text, the second version is HTML encoded.
{@CopyrightText} and {@HtmlEncCopyrightText} | These tags expand to the CopyrightText project option (plain text and HTML encoded).
{@Copyright} | If either or both of the copyright project options are specified, this tag will expand to the include directive necessary to place the text in the page footers.
{@DefaultTopic} and {@WebDefaultTopic} | These tags appear in the help file project template and the website index page respectively and expand to the filename of the default topic.
{@DocInternals} | This tag expands to "true" if either the DocumentInternals or DocumentPrivates project property is set to true. If both are set to false, this expands to "false".
{@ExtractFlags} | This tag expands to the flags that tell the HTML extract tool what files to create. It will generate files for the Help 1.x and website builds as needed.
{@FeedbackEMailAddress}, {@HtmlEncFeedbackEMailAddress}, {UrlEncFeedbackEMailAddress}, {@FeedbackEMailLinkText} | These tags expand to the FeedbackEMailAddress project option if it is specified (plain text, HTML encoded, and URL encoded) and the FeedbackEMailLinkText project option if specified (plain text). Note that if FeedbackEMailLinkText is specified, it will be used in place of the e-mail address for the {@HtmlEncFeedbackEMailAddress} tag's value.
{@FeedbackVisibility} and {@ShowFeedbackControl} | These tags are used to control the visibility of the feedback control in presentation styles that support it.
{@FrameworkVersion}, {@FrameworkVersionShort}, {@MRefFrameworkVersion}, {@MRefFrameworkVersionShort} | These tags expand to the selected FrameworkVersion project option (full and "major.minor" respectively) and are placed in the sandcastle.config and MRefBuilder.config configuration files.
{@H2RegPlugInEntries} and {@H2RegMergeNamespaces} | These two tags expand to the plug-in and merge namespace entries in the H2Reg.ini file.
{@HHCPath} | This tag expands to the path to the HTML help 1.x compiler. This will be the path that the help builder found or the HtmlHelp1xCompilerPath project option if it is specified instead.
{@HTMLHelpName} and {@HTMLEncHelpName} | These expand to the value of the HtmlHelpName project option (plain text and HTML encoded).
{@HXCompPath} | This tag expands to the path to the HTML help 2.x compiler. This will be the path that the help builder found or the HtmlHelp2xCompilerPath project option if it is specified instead.
{@HeaderText} | This tag expands to the value of the HeaderText project option.
{@Help1xProjectFiles} and {@Help2xProjectFiles} | These tags appear in the help file project templates and are used to return a list of all files that should be compiled into the help file.
{@HelpTitle}, {@HtmlEncHelpTitle}, {@UrlEncHelpTitle}, and {@ScriptHelpTitle} | These tags expand to the HelpTitle project option (plain text, HTML encoded, URL encoded, and quote-escaped for JavaScript).
{@IncludeProjectNode} | This tag expands to the parameter used to indicate that the "Project" root namespace node should be included in the table of contents for the Hana and VS2005 presentation styles based on the setting of the RootNamespaceContainer project property.
{@IndentHtml} | This tag expands to the parameter used to indicate whether or not the HTML rendered by BuildAssembler is indented. This is mainly a debugging aid. When true, the HTML is indented to make it more readable. Leave it set to false to produce more compact HTML.
{@InheritedCommentFileList} | This tag expands to a list of the XML comment files that will be used to produce the inherited documentation. This tag is placed in the Generate Inherited Documentation tool's configuration file.
{@LanguageFolder} | This tag expands to the language folder to use for the Sandcastle shared content files. If a folder is not found for the selected language, the default US-English Sandcastle shared content files are used.
{@LangId} and {@LanguageName} | These tags expands to the locale ID (LCID) and the locale ID plus language name for the Language project option.
{@Locale} | This tag expands to the locale name for the Language project option.
{@OutputFolder} | This tag expands to the full path to the output folder and is used in the templates to help the tools locate the output folder.
{@Preliminary} | This tag will expand to the include directive to place the "preliminary documentation" warning in all page headers if the Preliminary project option is set to true.
{@PresentationPath} and {@PresentationStyle} | The first tag expands to the path of the presentation folder that contains the art, scripts, style sheets, and transformations for the style selected with the project's PresentationStyle property. The second expands to the name of the style itself.
{@ProjectFolder} and {@HtmlEncProjectFolder} | These tags expand to the path that contains the project file (plain text and HTML encoded). This is useful for build components that need paths relative to the project.
{@ProjectLinks} | This tag expands to the value of the ProjectLinkType project option.
{@RootNamespaceTitle} | This tag expands to the value of the RootNamespaceTitle project option.
{@SandcastlePath} | This tag expands to the path to the Sandcastle installation folder. This will be the path that the help builder found or the SandcastlePath project option if it is specified instead.
{@SDKLinks} | This tag expands to the value of the SdkLinkType project option.
{@SHFBFolder} | This tag expands to the path to the Sandcastle Help File Builder installation folder.
{@StopWordFile} | This tag expands to the StopWordFile option in the Help 2 project file when the IncludeStopWordFile project property is set to true.
{@SyntaxFilters} and {@SyntaxFiltersDropDown} | These tags expand to the language filter components that determine which languages appear in the Syntax section of each help topic and the dropdown in the upper right corner of the topic in the Prototype style.
{@TokenFiles} | This tag expands to a list of the conceptual content token files that will be used by the token Shared Content Component in conceptual content builds. To appear in the list, the project file must have its BuildAction set to Tokens.
{@WindowOptions} | This tag expands to a value in the help file project that determines the window options available. Currently, a default set of options is used to display most of the common features such as the basic toolbar buttons and the search tab. If the IncludeFavorites project property is set to true, the value includes the option to show the Favorites tab too.
{@WorkingFolder} and {@HtmlEncWorkingFolder} | These tags expand to the full path to the working folder (plain text and HTML encoded) and are used in the templates to help the tools locate the files in the temporary working folder.

Template Files

The following files are found in the .\Templates folder under the main help file builder installation folder.

Template File | Description
Build1xHelpFile.proj and Build2xHelpFile.proj | These MSBuild projects are used to build the HTML Help 1.x and HTML Help 2.x help file projects respectively and copy the resulting help file and supporting files to the project's output folder.
BuildConceptualTopics.proj and BuildReferenceTopics.proj | These MSBuild projects are used to build the conceptual and reference help topics respectively using BuildAssembler.
conceptual.config | This is the Sandcastle configuration file template used to build conceptual help topics using BuildAssembler. The conceptual help build component stack is currently not dependent on the presentation style so the same one is used for all of them.
ExtractHtmlInfo.proj | This MSBuild project runs a tool used to generate the index file and table of contents file for HTML Help 1.x files and the table of contents file for websites. It can also localize the content files by performing several character replacements and saving the files using a different encoding to work around encoding issues encountered while using the Help 1.x compiler with certain languages that require double-byte characters.
FixScriptSharp.xsl | This XSL transformation is used to fix up the reflection information file produced by runing MRefBuilder on assemblies created by the Script# compiler. It adds fixes up some of the entries for use with Sandcastle and adds a scriptSharp element to the members so that the JavaScript syntax generator produces code that matches the actual output of the Script# tools.
GenerateInheritedDocs.proj and GenerateInheritedDocs.config | This MSBuild project and configuration file are used to generate the inherited documentation file.
GenerateIntermediateTOC.proj and Generate2xTOC.proj | These MSBuild projects are used to generate the intermediate table of contents file and the Help 2.x specific table of contents file by performing an XSL transformation on the reflection.xml file.
GenerateRefInfo.proj | This MSBuild project is used to generate the reflection information from the documentation assemblies using MRefBuilder. The result is the reflection.org file that contains information about the types in each assembly.
Hana.config, Prototype.config, and VS2005.config | These are the Sandcastle configuration file templates. One of these will be updated with the necessary paths and project options based on the presentation style selected. The transformed file is used as the sandcastle.config for BuildAssembler to produce the API help topic files.
Hana.xsl, Prototype.xsl, and VS2005.xsl These are the default XSL transformation files used to convert additional content .topic files into HTML files if a user-defined transformation file is not supplied.
Caution:

This feature has been deprecated in favor of using conceptual content. While it will continue to be supported, it will receive no future enhancements.
Help1x.hhp | This is the help file project template for HTML Help 1.x help files. This defines the basic help file options and the help window properties.
Help2x*.* | This set of files defines the help file project templates for HTML Help 2.x help files.
HelpFileBuilderTokens.tokens | This contains a default set of tokens used by all help projects. Currently, it only contains a single entry for the standard autoOutline token.
MRefBuilder.config | This configuration file is used to supply some configuration information to MRefBuilder that it uses when generating the reflection information file.
TransformBuildLog.xsl | This XSL transformation file is used to transform the build log into something that is more readable by formatting the build steps into collapsible sections and highlight errors, warnings, and build step project names.
TransformManifest.proj | This MSBuild project applies some XSL transformations to the reflection output file generated by MRefBuilder and results in the production of the reflection.xml and manifest.xml files.

See Also

Other Resources

Localizing Language Resource Files
Customizing the Header and Footer Text
Build Process Plug-Ins


Frequently Asked Questions (FAQ)

[image]

Sandcastle Help File Builder Documentation
Frequently Asked Questions (FAQ)
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The following are some common problems and solutions along with some known issues with Sandcastle and help files that you may encounter.

  • All Questions
  • Documenting Assemblies
  • Build Failures
  • Help File Issues
  • The API Filter
  • Additional Content
  • Custom Build Components
  • Build Process Plug-Ins
  • General Help Topic Questions
  • Other
  • See Also

All Questions

  • Documenting Assemblies
    • How do I use Sandcastle and the help file builder?
    • I have been using version 1.7.0.0 or earlier. Version 1.8.0.0 is a significant change. Where did option/feature X go?
    • How do I document a web application or a website project?
    • My project relies on third-party assemblies and/or interop assemblies that do not have XML comments files. How can I document my assemblies without them?
    • My project uses third party assemblies but I don't want to include them in my documentation. How do I exclude them?
    • How do I specify a generic such as IEnumerable<T> in a cref target and/or XML comments?
    • Can I use HTML markup in my XML comments?
    • How can I embed an image in a namespace, type, or member help topic?
    • How can I create an IntelliSense XML comments file that contains information on only the members documented in the help file and excludes all of the private member details?
    • How can I share project summary and namespace settings between multiple help file builder projects?
    • I have an assembly without code and without an XML comments file for which I'd like to create documentation and/or an Intellisense file. How can I do that?
    • I want to create a help file without an assembly. I didn't add any files to document or just added some "Comments Only" XML files to the list but the build stops and it tells me it cannot do that. Why?
  • Build Failures
    • Why does the build fail telling me that it cannot find the Sandcastle or HTML help compiler tools?
    • Why does the build fail telling me that it cannot find the most current version of Sandcastle?
    • Why does my build fail with an error saying that it cannot find an assembly?
    • Why does my build fail with an Unresolved assembly reference error?
    • Why does my build fail with an Unresolved assembly reference error when I try to document a Compact Framework application?
    • Why can't Sandcastle resolve all dependent assembly references automatically?
    • Why does my build fail with an error saying "No APIs found to document"?
    • Why does my build fail in MRefBuilder with a NullReferenceException related to OrcasNamer.WriteType?
    • My build fails because I am behind a proxy server and it cannot connect to the MSDN web service. How do I fix it?
    • My builds seem to hang during the BuildAssembler step. Why?
    • I'm getting an Out of Memory exception during a very large build. How do I prevent it?
    • Why is the help compiler failing with HHC3002 and HHC3004 errors referencing non-html files such as images?
    • Why is the help compiler failing with HHC6000 and HHC5007 errors referencing "disk full" and "fatal navigational compilation" errors?
    • Why is the help compiler failing with an HHC6003 error stating that itircl.dll has not been registered?
  • Help File Issues
    • Why doesn't my compiled help file load?
    • Why do all of the help file topics display a "Page not found" error?
    • Why doesn't my help file contain any/all of the classes from the assembly?
    • The help file is built okay but I don't see my comments on the members. Why not?
    • My help file contains lots of red "missing documentation" messages. How do I get rid of them?
    • Why are all of my code samples colorized as C# code?
    • Why don't my code samples show up unless I select the C# code filter?
    • The language name is showing up as the default title on a colorized code block but I don't want it to do that. How do I get rid of it?
    • Why does my help file title not appear when I use a language selection other than English?
    • Why does the help file title contain garbage characters?
    • How can I view an HTML Help 2 file?
    • How can I deploy an HTML Help 2 file to an end-user's system?
    • How can I add support for NamedUrlIndex options such as DefaultPage, HomePage, AboutPageIcon, etc.?
  • The API Filter
    • I used the Namespace Comments feature to exclude a namespace but it is still showing up in the help file. Why?
    • I used the <exclude /> tag feature to exclude a namespace/type/member but it is still showing up in the help file. Why?
    • I used the Namespace Comments feature to exclude a namespace. I now want it included but it is not showing up. Why?
    • I used the <exclude /> tag to exclude a namespace/type/member. I removed the tag as I now want it included but it is not showing up. Why?
  • Additional Content
    • I want my additional content pages to look like the selected presentation style used in the API topics. How can I do that?
    • How do I arrange the additional content pages and specify which is the default topic?
    • How can I create a link to a namespace element's help topic from an additional content page?
    • How can I create a link to an additional content page from a namespace, type, or member help topic?
    • How can I colorize code in my additional content files?
  • Custom Build Components
    • How do I configure the custom build components with project-specific settings?
    • Where can I find more information on the custom build components supplied with the help file builder?
    • How can I create my own custom build components?
  • Build Process Plug-Ins
    • How do I configure the plug-ins with project-specific settings?
    • Where can I find more information on the plug-ins supplied with the help file builder?
    • How can I create my own custom plug-ins?
  • General Help Topic Questions
    • How can I create a link to a namespace element's help topic from an external source such as application code or a page in an external web site?
  • Other
    • I use SharpDevelop 3.x or later. How do I update the copy of the help file builder that is distributed with it?
    • How can I make a donation to help support the Sandcastle Help File Builder project?

Documenting Assemblies

How do I use Sandcastle and the help file builder?
Read through the topics in the Getting Started section in the table of contents. These will give you an overview of how to use Sandcastle, the help file builder, and how to set up your projects to generate XML comments.
I have been using version 1.7.0.0 or earlier. Version 1.8.0.0 is a significant change. Where did option/feature X go?
Be sure to read through the version history starting at Version 1.8.0.0 (Alpha) since it contains all of the information about the change in project format and the user interface. The Where Did That Feature Go? section in that topic contains information about how to find features or equivalent functionality in the new release.
How do I document a web application or a website project?
See the Documenting Web Projects topic for details.
My project relies on third-party assemblies and/or interop assemblies that do not have XML comments files. How can I document my assemblies without them? / My project uses third party assemblies but I don't want to include them in my documentation. How do I exclude them?
Third-party assemblies with or without XML comments files and Visual Studio generated interop assemblies do not need to be documented. They are considered to be dependent or reference assemblies. As such, add them to the References node in the Project Explorer window rather than as documentation sources. See the References topic for more information.
How do I specify a generic such as IEnumerable<T> in a cref target and/or XML comments?
Use curly braces in cref targets and HTML entities (&lt; and &gt;) in the general XML comments. For example:
Copy
/// <summary>
/// See <see cref="IEnumerable{T}"/> for more information.
/// <p/>Another reference to IEnumerable&lt;T&gt;.
/// </summary>
Can I use HTML markup in my XML comments?
Yes, you can use HTML markup in your XML comments to add additional formatting. You can also use the img tag to embed an image in a namespace element's XML comments. Since the comments are XML, all HTML tags must be specified with a closing tag or as self-closing (i.e <p>This is a paragraph</p> or <p/>New paragraph).
How can I embed an image in a namespace, type, or member's help topic?
Embedding an image in an element's help topic is a two step process. First, you must add the image to the help file builder project's AdditionalContent property. The second step is to edit the member's XML comments (summary, remarks, etc) to add the img tag. To embed an image in the Project Summary or Namespace comments, add the image tag to the help file builder's Project Summary notes or namespace comments. Below are two examples of embedding an image in the XML comments. Note that all namespace help topics reside in an .\html folder so you must use a relative path to go up one level to find the image file. The first example assumes that the image is copied to the root of the help project. As such, no additional path beyond the relative indicator is required. The second example assumes that the image is copied to an .\Images folder. In that case, you must also specify the folder name. As noted above, the image tag must be self-closing to conform to the XML specification.

CopyExample <img> Tag Usage
/// <summary>
/// A class member.
/// </summary>
/// <remarks>An image: <img src="../Process.gif"/>
/// </remarks>
public void TestMethod()
{
    // ... Method implementation ...
}

/// <summary>
/// A useful class.
/// <p/>UML Diagram: <img src="../Images/TestClassUML.gif"
///     alt="UML Diagram" />
/// </summary>
public TestClass
{
    // ... Class implementation ...
}
How can I create an IntelliSense XML comments file that contains information on only the members documented in the help file and excludes all of the private member details?
Add the IntelliSense Component to the project using the ComponentConfigurations project property.
How can I share project summary and namespace settings between multiple help file builder projects?
Create a standalone XML comments file, add it to the project, and set its CommentsOnly property to true. See the Sharing Project Summary and Namespace Comments help topic for details.
I have an assembly without code and without an XML comments file for which I'd like to create documentation and/or an Intellisense file. How can I do that?
Create a blank XML comments file like the following and name it after the assembly with a .xml extension:

CopyBlank XML Comments File
<?xml version="1.0"?>
<doc>
  <assembly>
    <name>YourAssemblyNameHere</name>
  </assembly>
  <members>
  </members>
</doc>
Create a new help file builder project and add just that assembly and comments file to it. Select the ComponentConfigurations property and click the "..." button to the right of it. In the Component Configurations dialog, add the IntelliSense Component to the project. Next, set the project's Show Missing Tags properties to your liking. This will force the build to add "missing" notes for all items that you might want to document. Build the project and you will find a new XML comments file named after the assembly in the project's output folder. Edit the <member> elements in the XML comments file to add the comments that you want for each member. For example:
CopyMember Comments Example
<member name="M:SandcastleBuilder.Utils.XmlCommentsFileCollection.FindMember(System.String)">
    <summary>
    Search all comments files for the specified member.  If not found,
    add the blank member to the first file.
    </summary>
    <param name="memberName">The member name for which to search.</param>
    <returns>The XML node of the found or added member</returns>
</member>
 When you are done, replace your original placeholder file with the one generated from the build with your edited comments.
I want to create a help file without an assembly. I didn't add any files to document or added some "Comments Only" XML files to the list but the build stops and it tells me it cannot do that. Why?
Sandcastle was designed to document code based on a set of XML comments and API information found in a reflection information file. As such, it requires at least one assembly in order to produce a help file containing API documentation. If you do not include at least one assembly with a namespace containing at least one public class, the help file cannot be produced. To produce help files unrelated to assemblies, you can use some other tool such as the HTML Help Workshop or one of the commercial equivalents.

You can use the Additional Content Only plug-in to produce a help file based on additional content items alone. To do so, add the plug-in to the project via the PlugInConfigurations project option, add additional content to the project using the AdditionalContent project property, and build the help file. See the Additional Content Only Plug-In help topic for more information about it. See the Additional Content topic for more information about how to utilize additional content files.

Build Failures

Why does the build fail telling me that it cannot find the Sandcastle or HTML help compiler tools?
First and foremost, be sure that you have installed the latest version of Microsoft's Sandcastle documentation compiler tools and the HTML help compiler(s). The Sandcastle tools and the help compilers are not part of the help file builder and must be downloaded and installed separately.. The help file builder is written by Eric Woodruff and consists of a GUI and a project build system that act as front ends to the Sandcastle tools and help compilers produced by Microsoft. See the Links to Resources topic for information on where to download the required tools. If you have the tools installed, but in a non-standard location, you may need to specify the paths to the tools. See the Paths Category Properties topic for more information.
Why does the build fail telling me that it cannot find the most current version of Sandcastle?

First, be sure that you have the most recent version of Sandcastle installed. This can be confirmed by running MRefBuilder.exe from the command line and making sure that the version number that it reports is the same as the one expected by the help file builder.

Also check the top of the log file to see where it found the copy of Sandcastle that it tried to use. A common cause of finding an outdated version of Sandcastle is if you install the Visual Studio 2005 SDK. It contains an outdated version of Sandcastle and it resets the DXROOT environment variable to point at its copy. You can edit the environment variable to point at the latest version of Sandcastle or reinstall the latest version so that it sets the variable back to the right location.

Note:

There may be two copies of the DXROOT environment variable: one user copy and one system copy. If this is the case, delete the user copy and make sure that the system copy is pointing at the latest release of Sandcastle (the one from Microsoft, not the help file builder). You may need to reboot in order for the changes to take effect.

Why does my build fail with an error saying that it cannot find an assembly?
When you added items to the Assemblies to Document list, you may have specified the wrong name or perhaps chose the assembly from the wrong folder (i.e. Debug instead of Release). Check the assembly path and filename and verify that it does exist. If the path is correct, make sure the assembly actually exists. Rebuild your project if necessary to recreate it.
Why does my build fail with an Unresolved assembly reference error?
If the build fails in the Generating reflection information step with an error that starts "Error: Unresolved assembly reference", you need to add the named assembly as a reference. This is done by adding a reference to it to the References node in the Project Explorer window. See the References topic for more information on adding reference items. See the next question as well if you are documenting a Compact Framework application.
Why does my build fail with an Unresolved assembly reference error when I try to document a Compact Framework application?
In order to document Compact Framework applications you also need to add a reference item for the Compact Framework assemblies. These are usually located under the Visual Studio 2005 installation folder. The easiest way to reference them is to add a reference item with a path similar to the following:

Copy
%VS80COMNTOOLS%\..\..\SmartDevices\SDK\CompactFramework\2.0\v2.0\WindowsCE\*.dll
This will expand the VS80COMNTOOLS environment variable in order to find the Visual Studio 2005 installation location and append the necessary path to find the Compact Framework assemblies. See the References topic for more information on adding reference items.
Why can't Sandcastle resolve all dependent assembly references automatically?
Sandcastle, specifically MRefBuilder, uses CCI (Common Compiler Infrastructure) for assembly reflection. CCI searches the current directory for dependent assemblies as well as any directories specified by the /dep (Dependencies) option. CCI does not attempt to open a dependent assembly until some information from that assembly is needed. CCI is used because technically, CCI never "loads" any assembly; it just parses the data in the assembly file. That is why CCI can reflect over a foreign mscorlib while System.Reflection cannot. This allows Sandcastle to be used for documenting assemblies built with any version of the .NET Framework. CCI is also used by FxCop.
Why does my build fail with an error saying "No APIs found to document"?
Classes need to be declared public in your code, you need to enable the DocumentPrivates and/or DocumentInternals project property so that Sandcastle documents the internal/private members, or you need to include at least one assembly and at least one namespace to document. There should be at least one assembly listed in the Assemblies to Document list at the top of the main form. Click the Namespaces button to be sure that you have at least one valid namespace that is checked and thus included. If you are using the ApiFilter property, check it to make sure you have not accidentally excluded everything.
Why does my build fail in MRefBuilder with a NullReferenceException related to OrcasNamer.WriteType?
The most likely cause of this problem is that you have the project's FrameworkVersion property set to .NET 1.0 or .NET 1.1 but you are trying to document a .NET 2.0 or later assembly. Check the property to make sure that it is set appropriately for your assembly.
My build fails because I am behind a proxy server and it cannot connect to the MSDN web service. How do I fix it?
If the SdkLinkType property is set to MSDN, BuildAssembler will attempt to contact the MSDN web service to resolve links to SDK topics. If you are behind a proxy server, this will most likely fail and will abort the build process with an error similar to "HTTP status 407: Proxy Authentication Required". The simplest fix is to set the SdkLinkType property to None. The downside is that you will not get links to online SDK content. If you are building an HTML Help 2 (HxS) file, you can set the option to Index so that it generates links to the local help content when merged with the collection.

It has been reported that creating a BuildAssembler.exe.config file in the same folder as BuildAssembler.exe (the .\ProductionTools folder under the Sandcastle installation folder) and putting one of the following in it may allow it to work with the proxy server:

CopyMethod 1 (this works most often so try it first):
<configuration>
    <system.net>
        <defaultProxy useDefaultCredentials="true">
            <proxy usesystemdefault="true"/>
        </defaultProxy>
    </system.net>
</configuration>
CopyMethod 2:
<configuration>
    <system.net>
      <defaultProxy enabled="true" useDefaultCredentials="true">
        <proxy bypassonlocal="True"
            proxyaddress="http://yourproxy:8080" />
      </defaultProxy>
    </system.net>
</configuration>
CopyMethod 3 (use this if your company uses a proxy configuration script):
<configuration>
    <system.net>
      <defaultProxy useDefaultCredentials="true">
        <proxy scriptLocation="http://your.server.com/proxy.pac"
            usesystemdefault="True" />
      </defaultProxy>
    </system.net>
</configuration>
My builds seem to hang during the BuildAssembler step. Why?
If your builds seem to hang during the BuildAssembler step, setting the SdkLinkType property to None will get it to run faster with the side-effect that you will not have links to online SDK content. The only other alternative is to be patient and wait for it to finish. On a slow connection, it can take a very long time. If you are building an HTML Help 2 (HxS) file, you can set the option to Index so that it generates links to the local help content when merged with the collection.
I'm getting an Out of Memory exception during a very large build. How do I prevent it?
When performing a build that generates an extremely large amount of output, you may encounter an Out of Memory exception if verbose logging is enabled in the GUI help file builder. If this occurs, turn off the Verbose Logging option on the Documentation menu. Full details are still written to the log file and can be viewed after the build.
Why is the help compiler failing with HHC3002 and HHC3004 errors referencing non-html files such as images?
See BE0060: The [itemType] '[item]' contains a comma or '.h' which may cause the Help 1 compiler to fail.
Why is the help compiler failing with HHC6000 and HHC5007 errors referencing "disk full" and "fatal navigational compilation" errors?
Check the log file for the MRefBuilder output. It will most likely report that it found and documented zero types. This is caused by not having any public types in the documented assemblies or not specifying any assemblies at all to document (i.e. using Comments Only files). Sandcastle requires at least one assembly and will not document internal and private code by default. Be sure to declare at least one class public. If all classes really are supposed to be private and/or internal, set the DocumentPrivates and/or DocumentInternals project properties to true.
Why is the help compiler failing with HHC6003 error stating that itircl.dll has not been registered?
This error affects a small number of people and is caused by one of the help components (ITCC.DLL) either not getting installed or not getting registered correctly. Search your system for the DLL. If not found, you can either locate it on another system that has the Help 2 components or you can search Google for it. Once you obtain it, you will need to copy it to the failing system and register it. This can be done by running the following command from a command prompt. Adjust the path to the DLL as necessary based on its location on your system.
Copy
regsvr32 C:\Windows\System\itcc.dll

Help File Issues

Why doesn't my compiled help file load? / Why do all of the help file topics display a "Page not found" error?
For an HTML Help 2 file (.HxS), you need a separate viewer to load the help file or you need to integrate it into an existing collection. See the Links to Resources topic for a link to a freeware Help 2 viewer and a tool that can help you register your help file with a collection.

For HTML Help 1 files (.CHM), if the path to the help file contains "#", the help file may fail to load. The apparent reason for this is that the help viewer considers the "#" to be an unsafe character and it must be encoded for it to use it. Rename the folder to remove the "#" to get the file to load.

Another cause for the pages not displaying is a security patch that prevents the help viewer from running from the intranet zone (i.e. a network share). You can fix this problem by saving the following to a file and importing it into the registry.

CopyHelpFix.reg
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\HTMLHelp\1.x\ItssRestrictions]
"MaxAllowedZone"=dword:00000001

It may also be possible to unblock the file so that it can be viewed by right-clicking on it, selecting Properties and clicking the Unblock button on the General tab if it is there.

Why doesn't my help file contain any/all of the classes from the assembly?
The most likely cause of an empty help file or one that does not contain all of your assembly's classes is that the missing classes are not declared public. By default, when you add a class to a Visual Studio project, it does not add the public keyword to it. As such, you must remember to edit the class to make it public if necessary. Sandcastle does not document private and internal methods by default either. If you really want to see them in the help file, set the DocumentPrivates and/or DocumentInternals project properties to true.

You should also check the project to be sure that it does not have an ApiFilter defined that is excluding the items in question. An <exclude /> tag in the item's XML comments will also cause it to be removed from the documentation.

Another possible cause of missing classes is compiling a help file project using the wrong framework version selection. For example, if you compile a .NET 2.0 help project with the FrameworkVersion project property set to a .NET 1.x version number, you may end up with lots of missing classes. As such, check the property to be sure that it is set appropriately.

The help file is built okay but I don't see my comments on the members. Why not?
You either have not enabled the Visual Studio project option to produce an XML comments file for your assembly, it has a name different from that of the assembly and the help file builder did not see it when you added the assembly to the project, or the XML comments filename is not unique. Check the Assemblies to Document list. You should see the assembly name and the XML comments file name listed. If any entry contains "(No XML comments file)", edit the entry to specify the XML comments filename. See the Walkthrough: Enabling and Using XML Comments topic for information on enabling the XML comments file option in Visual Studio.

Be sure to give each project's XML comments file a unique name as they are copied to a common location for the build. Identically named files will overwrite each other and the documentation in the overwritten files will not appear in the help file. If the comments file options are set correctly, check to be sure that the XML comments in your source files are preceded by a triple slash for C# code (///) or a triple quote for VB.NET (''').

My help file contains lots of red "missing documentation" messages. How do I get rid of them?
The project properties in the Show Missing Tags category control which types of "missing documentation" messages appear in the help file. These can help you locate help topics that need attention to provide better documentation. Adding the missing tags to your code is one way to get rid of the message. You can search the help file for the text "missing documentation" or review the build log file to locate the members in question. If you do not care to see these messages, simply alter the project properties to turn off the ones that you do not want to see.
Why are all of my code samples colorized as C# code? / Why don't my code samples show up unless I select the C# code filter?
The help file builder automatically includes a copy of the Code Block Component that adds several attributes to the <code> tag. One of these is the lang attribute that lets you specify the language rules to use when colorizing the code. It is also used to indicate the code filter to which the sample should be connected. If omitted, the component will assume that the code is C#. You can change this behavior by adding a lang attribute that specifies a different language. You can also specify "none" as a value to disable colorization and the code filter for it.

If the majority of your code samples are in a language other than C#, you can override the default by using the ComponentConfigurations project property to add the Code Block Component to the project and configure it to use a different default setting.

The language name is showing up as the default title on a colorized code block but I don't want it to do that. How do I get rid of it?
Specify the title attribute and set it to a title of your choice or to a single space to suppress it (title=" "). To turn it off globally, use the ComponentConfigurations project option to add the Code Block Component to the project and edit its configuration to turn off the "Use language name as title" option.
Why does my help file title not appear when I use a language selection other than English?
For non-English HTML Help 1.x help files, the help title will not appear on the title of the help window unless the system's language matches the help file's language exactly. This is a known issue with the way the help viewer compares the language values.

To resolve encoding issues, add the DBCS Fix for CHM Builds Plug-In to the project. See the plug-in documentation for information about its configuration.

Why does the help file title contain garbage characters?
The HTML Help 1.x compiler does not appear to support unicode encoding of its project and table of contents files. This may cause the help title to display incorrectly if it contains extended characters that need encoding.

To resolve encoding issues, add the DBCS Fix for CHM Builds Plug-In to the project. See the plug-in documentation for information about its configuration.

How can I view an HTML Help 2 file?
For proofreading, you can use a standalone help view such as H2Viewer.exe. See the Links to Resources topic for information on where to get it. See the next question for information on deploying a Help 2 file.
How can I deploy an HTML Help 2 file to an end-user's system?
The simplest way to deploy a Help 2 file is to use H2Reg.exe. The help file builder produces a configuration file for it as part of the Help 2 build process. See the Deploying an HTML Help 2 File topic for more information.
How can I add support for NamedUrlIndex options such as DefaultPage, HomePage, AboutPageIcon, etc.?
See the Named URL Index Support topic for details.

The API Filter

I used the Namespace Comments feature to exclude a namespace but it is still showing up in the help file. Why? / I used the <exclude /> tag feature to exclude a namespace/type/member but it is still showing up in the help file. Why?
Check the build log in the section where it generated the API filter. You will probably see a warning there about the exclusion conflicting with the API filter. The API filter always wins. To fix the issue, edit the ApiFilter project property and exclude the item there.
I used the Namespace Comments feature to exclude a namespace. I now want it included but it is not showing up. Why? / I used the <exclude /> tag to exclude a namespace/type/member. I removed the tag as I now want it included but it is not showing up. Why?
Check the ApiFilter project property as it is probably being excluded in there. This situation does not generate a warning in the log so you have to check for it manually. Simply place a checkmark next to the item you want to have included.

Additional Content

I want my additional content pages to look like the selected presentation style used in the API topics. How can I do that?
Instead of using HTML files, you will need to store the additional content pages as XML content in files with a .topic extension. These will be processed using an XSL transformation at build time to make them look like the API topics. You can supply your own transformation file by putting its name in the project's TopicFileTransform property. If a transformation is not supplied, a default transform based on the selected presentation style is used. See the Topic File Transformation topic for more information.
How do I arrange the additional content pages and specify which is the default topic?
Add a site map file to the project and edit it to define the layout. See the Site Map File Editor topic for details.
How can I create a link to a namespace element's help topic from an additional content page?
Use a <see> tag to reference the namespace element. When the additional content page is parsed, the <see> tag will be replaced with a hyperlink to the namespace element's help topic page. See the Linking to Namespace Content help topic for details.
How can I create a link to an additional content page from a a namespace, type, or member help topic?
Edit the member's XML comments (summary, remarks, etc) to add an anchor (<a>) tag that points to the additional content page. To add a link in the Project Summary or Namespace comments, add the anchor tag to the help file builder's Project Summary notes or namespace comments. Below are two examples of adding a link in the XML comments. Note that all namespace help topics reside in an .\html folder so you must use a relative path to go up one level to find the additional content file. The first example assumes that the file is copied to the root of the help project. As such, no additional path beyond the relative indicator is required. The second example assumes that the file is copied to a .\Tutorials folder. In that case, you must also specify the folder name.

CopyLinking to Additional Content
/// <summary>
/// A class member.
/// </summary>
/// <remarks>Class usage tutorial:
/// <a href="../SomeClassTutorial.html">SomeClass Tutorial</a>
/// </remarks>
public void TestMethod()
{
    // ... Method implementation ...
}

/// <summary>
/// A useful class.  For more information see the
/// <a href="../Tutorials/SomeClass.html">tutorial</a>.
/// </summary>
public TestClass
{
    // ... Class implementation ...
}
How can I colorize code in my additional content files?
Use a <pre> tag and specify the necessary attributes to colorize it. When the additional content page is parsed, the content will be colorized based on the settings. See the Syntax Highlighting <pre> Tag Content help topic for details.

Custom Build Components

How do I configure the custom build components with project-specific settings?
Use the ComponentConfigurations project property. Click the "..." button to the right of the property, select the component from the list in the dialog that appears, and click the Configure button.
Where can I find more information on the custom build components supplied with the help file builder?
See the Custom Build Components help topic for more information and links to details about each component.
How can I create my own custom build components?
For information on writing your own custom build components, see the Code Project article Creating Custom Build Components for Sandcastle[^].

Build Process Plug-Ins

How do I configure the plug-ins with project-specific settings?
Use the PlugInConfigurations project property. Click the "..." button to the right of the property, select the plug-ins from the list in the dialog that appears, and click the Configure button.
Where can I find more information on the plug-ins supplied with the help file builder?
See the Build Process Plug-Ins help topic for more information and links to details about each plug-in.
How can I create my own custom plug-ins?
For information on writing your own custom plug-ins, see the Creating Build Process Plug-Ins help topic.

General Help Topic Questions

How can I create a link to a namespace element's help topic from an external source such as application code or a page in an external web site?

Set the project's NamingMethod property based on your preference and see the NamingMethod help topic for examples that show how to open specific topics based on the selected naming method from application code and how to determine the URL for a website link.

Other

I use SharpDevelop 3.x or later. How do I update the copy of the help file builder that is distributed with it?
To upgrade the copy of the help file builder included with SharpDevelop, do the following:
  • Download and install the latest version of Sandcastle from Microsoft. See the Links to Resources topic for the location.
  • Go to the Sandcastle Help File Builder project site on CodePlex.
  • Select the Releases page and download the SharpDevelop SHFB Distribution zip file for the current release of the help file builder.
  • Delete the existing content of the .\bin\Tools\SHFB folder under the main SharpDevelop installation folder and then extract the contents of the zip file into it. Usually, the folder will be something like C:\Program Files\SharpDevelop\x.x\bin\Tools\SHFB where "x.x" is the current SharpDevelop version number.

See Also

Other Resources

Installation Instructions
Links to Resources


Links to Resources

[image]

Sandcastle Help File Builder Documentation
Links to Resources
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This topics contains links to various resources that you may find useful.

  • Guides and Articles
  • Third-party Build Components, Plug-Ins, and Tools
  • Discussion Groups, Blogs, Etc.
  • See Also
Note:

For a list of required tools and suggested additional tools, see the Installation Instructions topic.

Guides and Articles

The following are various guides and articles that will help you become familiar with XML comments, conceptual content, and Sandcastle.

  • For a comprehensive list of XML documentation tags and a description of their attributes and usage you can download the XML Documentation Comments Guide.
  • For a comprehensive list of MAML documentation tags used in conceptual content and a description of their attributes and usage you can download the Sandcastle MAML Guide.
  • Special thanks to Alessandro Del Sole for featuring the Sandcastle Help File Builder in his Italian language book Programming with Visual Basic 2005 Beyond the Code.

Third-party Build Components, Plug-Ins, and Tools

The following components can add new features to the help topics generated by Sandcastle.

  • For a list of components supplied with the help file builder, see the Custom Build Components topic.
  • For a list of supplied plug-ins used to alter and extend the help file builder's build process, see the Build Process Plug-Ins topic.
  • Code Project Article: Creating Custom Build Components for Sandcastle
  • XML Schema Documenter - This plug-in allows you to integrate reference documentation for XML schemas into your help files.
  • Sandcastle LaTeX - This custom build component converts LaTeX embedded in XML comments to images in the final help file. The component utilizes mimeTeX 1.7.

  • Drawbridge - With this build component, Visual Studio class diagrams can be incorporated into the documentation generated by Sandcastle.

    Note:

    The Drawbridge component may not be compatible with the latest Sandcastle release. See this MSDN Documentation Forum thread for potential ways to get it to work if it has not yet been updated.

The following third-party tools are also available for use with Sandcastle and the help file builder.

  • Code Project Article: Producing Documentation for SQL Server Objects Using Sandcastle
  • ShoBiz - This is a BizTalk tool that generates Sandcastle documentation from BizTalk artifacts deployed into the databases. It promotes documentation as part of the solution lifecycle. The documentation structure mimics the Admin Console and extracts documentation comments from all sources.

Discussion Groups, Blogs, Etc.

The following resources provide places to discuss Sandcastle and the related tools, report bugs, and ask for help.

  • To discuss the help file builder, suggest new features, report bugs in it, and request help using it, visit the Sandcastle Help File Builder CodePlex project.
  • To discuss Microsoft's Sandcastle, suggest new features, report bugs in it, and request help using it, visit the Sandcastle CodePlex project.
  • For discussion and questions about help systems in general, visit the Microsoft Developer Documentation and Help System forum
  • The Sandcastle Blog provides news about Sandcastle and blog entries describing how its various features work.

See Also

Other Resources

Installation Instructions


Making a Donation

[image]

Sandcastle Help File Builder Documentation
Making a Donation
Send Feedback

[This is preliminary documentation and is subject to change.]

Several people have asked how to make a donation to support the Sandcastle Help File Builder project. If you would like to do so, you can make a donation of any amount you like by clicking on the PayPal donation button below. If you would prefer to donate via check or money order (USD), please send me an e-mail at Eric@EWoodruff.us and I will reply with my mailing address.

Make donations with PayPal - It's fast, free and secure!

The above method of donating is secure. PayPal guarantees your privacy and security. I never receive details of your payment other than the amount, your name, e-mail address, and any optionally entered information.

Thanks to those of you that have made a donation. It is much appreciated!


Version History
Send Feedback

[This is preliminary documentation and is subject to change.]

The topics in this section describe the various changes made to the Sandcastle Help File Builder over the life of the project.

Version History

Select a version below to see a description of its changes.

Note:

If you are coming to the latest version from version 1.7.0.0 or earlier be sure to read the Version 1.8.0.0 (Alpha) release notes and those for the subsequent beta releases as a significant number of changes occurred to the project file format and the standalone GUI in that release. Any existing projects will need to be converted to the new project file format before they can be used with the new version.

  • Version 1.8.0.2 (Beta 2)
  • Version 1.8.0.1 (Beta 1)
  • Version 1.8.0.0 (Alpha)
  • Version 1.7.0.0
  • Version 1.6.0.4
  • Version 1.6.0.2
  • Version 1.6.0.1
  • Version 1.6.0.0
  • Version 1.5.0.1
  • Version 1.5.0.0
  • Version 1.4.0.1
  • Version 1.4.0.0
  • Version 1.3.3.1
  • Version 1.3.2.0
  • Version 1.3.1.1
  • Version 1.3.1.0
  • Version 1.3.0.0
  • Version 1.2.0.0
  • Version 1.1.0.0
  • Version 1.0.0.1
  • Version 1.0.0.0


Version 1.8.0.2 (Beta 2)

[image]

Sandcastle Help File Builder Documentation
Version 1.8.0.2 (Beta 2)
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Version 1.8.0.2 was released on May 31st, 2009.

Changes in This Release

  • Fixed the BuildHelp task so that it can find the executing project when ran via an MSBuild build task inside another project file.
  • Fixed up XML encoding issues on property values in the MSBuild project template files.
  • Fixed project documenation sources so that the assembly name can be determined regardless of the case of the OutputType property value.
  • Fixed handling of the Platform configuration option so that if "Any CPU" (with a space) is passed to the build and it does not exist in the project documentation sources, it will be converted to "AnyCPU" (no space). This works around the issue in Team Build caused by it always passing in the value with a space.
  • Fixed a bug that caused the GenerateInheritedDocs tool to crash when the inheritdoc tag was nested within other XML comment tags.
  • Fixed a bug in the API Filter that caused a crash if you tried to go to, include, or exclude an inherited namespace from the search results.
  • Fixed a bug in the table of contents handling caused by using the Split TOC option on a container node without a topic association.
  • Fixed a couple of bugs in the UserDefinedProperties editor that caused it to lock up if a property was added after modifying a standard project property or if no value was set on a newly added property.
  • Fixed a bug that caused topics in sub-folders in content layout files selected as the default topic to not be set as the default topic when the project was built.
  • Fixed the content file editor collection so that it is serializable and can be saved with the user settings.

  • On Visual Studio solution documentation sources, each project loaded from the solution will have the following Visual Studio macros defined in it so that project properties that use them will be resolved correctly:

    • SolutionPath - Full solution path and filename.
    • SolutionDir - Path to solution with trailing backslash.
    • SolutionFileName - Solution filename plus extension.
    • SolutionName - Solution filename without extension.
    • SolutionExt - The solution file extension (.sln).
  • Added a DumpLogOnFailure property to the BuildHelp task that allows you to dump the log file to the MSBuild log when the build fails.
  • The API filter is now applied during partial builds. This fixes a problem in the Version Builder Plug-in where members where not being excluded from prior versions. If you need to suppress the API filter in a plug-in that performs a partial build, use the new SuppressApiFilter build engine property.
  • Added the XamlAttachedMembersAddIn add-in to the MRefBuilder configuration file template to add attached property and attached event information to the reflection information for WPF classes.
  • Added a new replacement tag (ScriptHelpTitle) to use as the parameter to JavaScript calls that take the help title as a parameter. This allows escaping single quotes to prevent script errors.
  • Added a user preference to show or hide line numbers in the text editor.
  • When editing a file, preference is now given to user-defined content file editors. If one is found, it will be launched. If not, the default built in editor will be used if there is one.
  • The behavior of the "various elements" dropdown on the text editor window toolbar has been changed. It now inserts the last element selected from the dropdown. By default, it inserts an alert element. Once another element is selected, that element becomes the default element inserted by clicking the toolbar button.

See Also

Other Resources

Version 1.8.0.1 (Beta 1)
Version 1.8.0.0 (Alpha)
Version History


Version 1.8.0.1 (Beta 1)

[image]

Sandcastle Help File Builder Documentation
Version 1.8.0.1 (Beta 1)
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Version 1.8.0.1 was released on February 4th, 2009.

  • Breaking Changes
  • Other Changes in This Release

Breaking Changes

  • All projects and components are now built using the .NET Framework 3.5 SP1. As such, you must have the .NET Framework 3.5 SP1 installed to use the help file builder and components. It can still build help files for any framework version from .NET 1.1 to .NET 3.5.
  • When a custom build component was added to the project in prior releases, attributes from the component node other than the ID, type, and assembly were not included in the project's copy of the configuration. This problem has been corrected. The only component affected by this fix is the Cached MSDN URL References component. If you use it in your projects, you should delete it and re-add it in the ComponentConfigurations project property so that it picks up the locale and link target attributes in order to use the appropriate settings for them during a build.
  • The IDs on the HierarchicalTocPlugIn and the TocExcludePlugIn changed. You will need to delete them from the PlugInConfigurations project property and add them back in to pick up the new IDs.
  • The location of user-defined template files and build component cache files has changed. They are now stored in the Local Application Data folder rather than the Common Application Data folder. However, the custom build components and plug-ins will themselves still reside in the Common Application Data folder. You should remove and add the three cached build components to the project file so that they use the new location. Any existing cache files can be moved to the new local data folder. This change was made to avoid problems with security and clashes with modified template and cache files when multiple people use the same PC. See the Special Folder Locations topic for more information.

Other Changes in This Release

  • Relative hint paths on reference items are now converted to full paths at build time so that they are located correctly.
  • Added ExtensionAttribute to the MRefBuilder attribute filter and excluded it from the DocumentAttributes property processing so that extension methods are documented correctly.
  • Fixed a bug in the Help 1 build project template that caused it to use the table of contents definition file for the index.
  • Fixed a bug that caused the Output Deployment plug-in to fail if a folder did not already exist when deploying to a file path.
  • Added " " (space), "*", and "?" to the characters replaced with an underscore by the MemberName naming method code to prevent save failures when the help topics are saved.
  • Paths to the comments files in sandcastle.config are now expanded fully before being written to it to prevent issues with environment variables expanding differently when the build engine runs as a 32-bit MSBuild process but the build step project runs as a 64-bit MSBuild process.
  • Added code to turn off the read-only attribute on MAML topics when they are copied to the working folder.
  • Added code to the Post-Transform Component so that see tags within code blocks are converted to links when the Code Block Component's keepSeeTags option is used. A prior release broke it due to changes needed to get the components to colorize code in conceptual builds. Note that the referenced target names must be fully qualified in order to get resolved.
  • Fixed a bug in the Show Missing Documentation component that caused it to fail if an auto-documented constructor's signature contained unencoded special XML characters.
  • If the DocumentSealedProtected property is set to False, it now removes inherited protected members too.
  • Added the ShowMissingIncludeTargets project property. This is used to add a "missing" message if an <include> tag is found in the comments for a topic indicating a missing file or invalid XPath query. However, it's really only useful for C# generated XML comments files (don't ask).
  • Added the UserDefinedProperties project property to the Build category. This allows you to add or edit user-defined MSBuild project properties that can be used to hold additional information or for use in substitution tags within other help file builder project properties.
  • Added support for CustomBeforeSHFBTargets and CustomAfterSHFBTargets properties that can define custom projects containing property or target overrides imported and evaluated before and after the help file builder targets respectively. These can be defined on the command line to import the custom targets and property overrides.
  • Substitution tag replacement (i.e. {@PropName}) now includes support for using any property name defined in the project. This includes user-defined MSBuild properties not recognized as help file builder properties and all global properties defined in the MSBuild build engine (reserved properties, environment variables, etc.).
  • The HelpFileVersion project property is now a string value. This allows you to specify user-defined MSBuild project properties to define the value (i.e. {@Version} or {@Major}.{@Minor}.{@Build}.{@Revision}). The end result must still evaluate to a valid four-part version number. If not, a build error will occur (BE0066).
  • Added an optional execution priority value to the ExecutionPoint object so that plug-ins can set an execution priority for each build step. It is used to determine the order in which the plug-ins will be executed. Those with a higher priority value will be executed before those with a lower value. Those with an identical priority may be executed in any order within their group. If not explicitly defined, the default priority value is 1000.
  • Added the SandcastleBuilder.MRefBuilder assembly which contains the BindingRedirectResolver component used by the Assembly Binding Redirection plug-in. The resolver component can be used in other third-party tools and standalone build scripts.
  • Added the Before Building user preference that lets you specify how to handle project and document changes prior to building the help file or previewing a topic.

  • Added the following new plug-ins:

    • Assembly Binding Redirection Plug-In
    • Bibliography Support Plug-In
    • XPath Reflection File Filter Plug-In - Thanks to Eyal Post for donating the code upon which this plug-in is based.
  • Thanks to Jeroen Vos for providing up to date information on using the Sandcastle Help File Builder v1.8.0.0 or later with Visual Studio Team Foundation Server 2008 SP1.

See Also

Other Resources

Version 1.8.0.0 (Alpha)
Version History


Version 1.8.0.0 (Alpha)

[image]

Sandcastle Help File Builder Documentation
Version 1.8.0.0 (Alpha)
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Version 1.8.0.0 was released on October 20th, 2008.

  • A New Project File Format and a New Look
  • Where Did That Feature Go?
  • Bug Fixes
  • Other Changes and New Features

A New Project File Format and a New Look

The main goal of this release was to rework the help file builder project file format and build engine to ready them for use in a Visual Studio package that will provide full Visual Studio integration in a future release. This resulted in a number of major changes.

Note:

Although Visual Studio integration is planned for a future release, the standalone GUI will still be produced and supported for those who do not use Visual Studio.

  • The help file builder now uses an MSBuild project file to store its settings. Along with the associated MSBuild tasks and target definition file, this allows you to build help file builder projects using MSBuild. It also makes it possible to create a Visual Studio package that will let you work with help file builder projects from within Visual Studio just like any other project in a solution file (planned for a future release).
  • A SHFBROOT environment variable is now used to locate the root help file builder folder for various tools. The value should point to the root installation folder. The installer will create the environment variable automatically but you may need to reboot in order for it to take effect. You will also need to manually define it on any system to which you manually copy the help file builder tools.
  • With the use of an MSBuild project file format, SandcastleBuilderConsole.exe was rendered obsolete and has been removed. Use MSBuild, Team Build, or another such tool to build a help file project from the command line or in automtated scripts.
  • Due to the change in format, help file builder projects from prior versions will need to be converted before use with the latest release. Once converted, they cannot be changed back or used with prior versions of the help file builder. See the Project File Converters topic for details.
  • Several project properties have been removed or altered and their functionality has moved elsewhere in the standalone GUI. See the "Where Did That Feature Go?" section below for details.
  • The NDoc-style GUI has been replaced by one that looks more like Visual Studio. This was required as by moving to an MSBuild project format, the conceptual content and supporting files are now part of the project and appear in the project file as build items. The new GUI provides a Project Explorer window that lets you manage these items. The Properties window retains the NDoc-like property grid and is used to edit the various non-file project properties.
    Note:

    See the Sandcastle Help File Builder Overview topic for more information on the new GUI and how to use it effectively.

  • The underlying namespace in the code for the GUI changed so any prior user preferences will not be carried forward when you first open the new version. You can set them up again via the File | User Preferences menu option.
    Note:

    It is no longer necessary to define external editors in the User Preferences dialog to edit files such as XML files, stylesheets, HTML files, etc. Common text-based file types recognized by filename extension will be edited within the GUI by default. As such, you do not need to add any custom editor associations for them in your user preferences.

  • Assemblies to Document are now referred to using the more generic term Documentation Sources. A documentation source can be an individual assembly (executable or DLL), an individual XML comments file, a Visual Studio project file (C#, VB.NET, or J#), a Visual Studio solution file containing one or more of the noted project types, or a wildcard item that results in a list of one or more of the previously mentioned file types. Documentation sources are now managed using the Documentation Sources project node in the Project Explorer window.
    Tip:

    Given that solutions and projects are supported as documentation sources, you may find it easier to add them as documentation sources instead of the assemblies, comments, and references that they contain. When a solution or project is used, these items are imported from them automatically at build time.

  • A Configuration and a Platform option can be defined to determine which assemblies are used in solution and project documentation sources.

  • Dependencies are now referred to using the term References. The old Dependencies property has been removed from the Properties window. They are now managed via the References project node in the Project Explorer window. References can be GAC entries, assembly files, COM objects, or Visual Studio project files.

    Note:

    While COM references are supported in the project file and will be handled correctly at build time, they cannot be added to the project via the standalone GUI. An alternative is to add the COM-callable wrapper assemblies as references instead.

  • All build step script files (.bat) have been replaced with MSBuild project files (.proj) with corresponding build tasks. This allows for better extensibility either directly or through plug-ins. In addition, it allows for support of Unicode values in such properties as the help filename.
  • The code has been heavily refactored and some project option collection classes and property names have been changed to reflect their purpose in relation to the MSBuild project file format. Others have been removed as they are no longer relevant. As such, expect build errors in any custom plug-ins that you have created. Most of the affected objects and properties are listed below.
    Old Item | New Item
    DependencyItem | Replaced by ReferenceItem (GAC or file), COMReferenceItem (COM object), and ProjectReferenceItem (Visual Studio project).
    DependencyItemCollection | Replaced by ReferenceItemCollection.
    DocumentAssembly | Replaced by DocumentationSource.
    DocumentAssemblyCollection | Replaced by DocumentationSourceCollection.
    SandcastleProject.Assemblies | Renamed SandcastleProject.DocumentationSources.
    SandcastleProject.Dependencies | Renamed SandcastleProject.References.
    BuildStep.CopyDependencies | Deleted as it was no longer relevant.
    BuildStep.ValidatingAssemblies | Renamed BuildStep.ValidatingDocumentationSources.

Where Did That Feature Go?

Several features and project options were removed and their functionality is now handled in a different manner. The following items will help you locate the old feature and determine how to do the same thing in the new version of the help file builder.

The Console Mode Builder (SandcastleBuilderConsole.exe)
With the use of an MSBuild project file format, SandcastleBuilderConsole.exe was rendered obsolete and has been removed. Use MSBuild, Team Build, or another such tool to build a help file project from the command line or in automtated scripts.
Assemblies to Document
This has been replaced by a more generic term: Documentation Sources. These are added to the Documentation Sources project node in the Project Explorer window.
Project and Namespace Summaries
Edit these via the Project Properties window. The NamespaceSummaries and ProjectSummary properties can be found in the Comments category. Click the "..." button to the right of each property to open the expanded property editor.
The AdditionalContent Property
Additional content files are now handled as project file items. They should have a BuildAction value of Content. The folder structure of the items determines their location in the compiled help file and, for HTML and .topic files in the absence of a site map file, their order and layout in the table of contents. Items at the root level end up in the root level of the help file and projects in subfolders end up in like-named subfolders in the compiled help file. For control over how the files appear in the table of contents, add a site map file to the project and use it to arrange the additional content files.
The AdditionalContent.ContentSiteMap Property
Site map files are handled as project file items. They should have a BuildAction value of SiteMap. Multiple site map and content layout files (used for conceptual content) can be specified in a project. The SortOrder property on them determines in what order their content is merged into the table of contents.
The AdditionalContent.TopicFileTransform Property
Topic file transformations used for .topic files are handled as project file items. They should have a BuildAction value of TopicTransform. Note that only the first TopicTransform item found during a build will be used. All others will be ignored.
The ConceptualContent Property
All conceptual content file types are handled as project file items. See the following items for details.
The ConceptualContent.CodeSnippets Property
Code snippets files are handled as project file items. They should have a BuildAction value of CodeSnippets. Multiple code snippets files can exist in a project and all will be included in the build.
The ConceptualContent.Images Property
Conceptual content image files are handled as project file items. They should have a BuildAction value of Image. Image properties such as their ID and alternate text are managed via the project file item properties.
The ConceptualContent.Tokens Property
Tokens are now handled via token files which are project file items. They should have a BuildAction value of Tokens. Multiple token files can exist in a project and all will be included in the build.
The ConceptualContent.Topics Property
Conceptual topic files are handled as project file items. They now have an extension of .aml and should have a BuildAction value of None. Content layout files determine which topics are compiled into the help file and their order in the table of contents. They have a .content file extension and a BuildAction value of ContentLayout. As noted above, multiple site map and content layout files can be specified in a project. The SortOrder property on them determines in what order their content is merged into the table of contents.
Note:

Topics added via the content layout editor are automatically added to the project file. In addition, topics are now tracked by their ID number so you are free to rearrange the files in the project folders without having to update their location in the content layout file.

The Dependencies Property
Dependencies are now referred to as References. References can be GAC entries, assemblies, COM objects, or Visual Studio project files. They are added to the References project node in the Project Explorer window.
Editing Conceptual Content Layout and Related Topic Properties
Add a Content Layout file to the project. This lets you edit the layout of the conceptual topics and manage their properties much like the conceptual content editor in prior versions of the help file builder. See also: The ConceptualContent.Topics Property
Inserting Image, Token, and Code Snippet References Into Topics
Image, token, code snippet, and code entity references are now all handled by the Entity References window. Select the type of entity to insert in the window's dropdown. Then drag and drop or double click the item to insert it into the topic. A Refresh button is available to update the available items if you make changes to their related project files.
New Project From NDoc Project/Visual Studio Project
The option to create a new project from an NDoc project (or various other project types) can be found in the File | New Project from Other Format menu option. The option to create a project from a Visual Studio solution or project has been removed. Visual Studio 2005/2008 solution and project files are supported natively as documentation sources.
Locating Third-Party Custom Build Components, Plug-Ins, and User-Defined Templates

To be Vista-compliant by not making changes to the installation folder, all files such as third-party custom build components, custom plug-ins, build component data cache files, and user-defined template files should now be located in subfolders under the EWSoftware\Sandcastle Help File Builder folder in the Common Application Data or Local Application Data folder. See the Special Folder Locations topic for more information.

Note:

Performing a build using one of the cached data components will create the root local application data folder automatically. However, if you need to place files there before then, you will need to create the folder manually.

Bug Fixes

  • Fixed a couple of bugs in the Hierarchical TOC plug-in that caused the namespaces to be nested incorrectly.
  • Fixed the Code Block Component so that nested code blocks in conceptual content are imported correctly.
  • Fixed a bug in the Split TOC option that caused the TOC items to be excluded if it was set on the first content item.
  • Exceptions in the namespace generation step in partial builds are now ignored so that you can get into the Namespace Comments dialog to fix the issue.
  • Fixed a bug in the HTML extract tool that caused it to fail on nodes without an associated file.

Other Changes and New Features

  • Documented assemblies and reference (dependency) assemblies are no longer copied to the working folder for the build. Instead, they are resolved and parsed in place at their given location. This prevents issues with similarly named assemblies overwriting each other in the working folder.
  • XML comments files are still copied to the working folder as they may be modified. Duplicates are given a unique name if a file by the same name already exists in the working folder. This prevents the loss of comments due to XML comments files in different projects that use the same name.
  • The project used by the build process is a clone of the active project. As such, it can be modified without affecting the active project.
  • All tool/build engine warnings and errors are now reported with a code and in a format compatible with the Visual Studio Error List tool window. The warning and error codes are documented and provide information about what the error means along with possible solutions.
  • Just prior to building a Help 1 (CHM) file, warnings are issued if the working path, the HTMLHelpName property, or any filename contains ".h" or a comma. Paths or files containing ".h" or a comma can cause odd compiler crashes. If you see this warning and the help compiler fails, change the names of the paths or files listed in the warning(s).
  • Added an allowMissingSource option to the Code Block Component to allow missing source code files/regions to generate warnings rather than errors. It also gives a more descriptive error when it fails to find a required attribute.
  • Added All and None buttons to the Namespace Comments dialog to check or uncheck all namespaces at once.
  • The default presentation style in new projects has changed from Prototype to VS2005.
  • Implemented basic find and replace support in the topic editor window (Ctrl+F and Ctrl+H). Also added Goto Line (Ctrl+G) and expanded the number of elements that can be inserted from the toolbar.
  • All help windows are now opened non-modally.
  • Thanks to Golo Roden for the Python keywords and code colorizer rule definitions. Use the language ID python or py to colorize a code block as Python code.
  • In the code download, all help file builder solutions and projects are now in Visual Studio 2008 SP1 format.
  • The help file content has been converted to MAML and uses the VS2005 style.

See Also

Other Resources

Version History
Known Issues and Limitations
FAQ


Version 1.7.0.0

[image]

Sandcastle Help File Builder Documentation
Version 1.7.0.0
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Version 1.7.0.0 was released on June 2nd, 2008.

  • Potential Breaking Changes
  • Non-breaking Changes in Behavior
  • Conceptual Content Support
  • Additional Content Models Deprecated
  • Other Changes in This Release
  • Documenting Website Projects
Note:

Request for Translations

This release contains several new entries in the shared content files found in the help file builder's .\SharedContent folder and a new stop word list file for each language. All new items are in English. If you can help translate the files for the various languages it would be much appreciated. Contact me before starting to let me know which language you want to translate. That way, I can let you know if it has already been done to save you the effort. See the Localizing Language Resource Files topic for information about the files and how to translate them. Thanks!

Potential Breaking Changes

  • The default configuration for all cached build components has changed. They no longer store their cache files in the help file builder folder. Instead, they store them in the %APPDATA%\EWSoftware\Sandcastle Help File Builder\Cache folder. This removes the need to run the help file builder as an administrator under Vista x64 when using the cached build components. If you are using them, you must remove them from the project and re-add them so that they pick up the new default configuration. You can also delete the cache files from the old location. You can find them in the .\BuildComponents\Cache folder under the main help file builder installation folder.
  • The default configuration for the Cached Framework Comments Index Data custom build component has changed. If you are using it, you must remove it from the project and re-add it so that it picks up the new default configuration. You can also delete the Comments.cache file as the naming method has changed and the old version is obsolete. You can find it in the .\BuildComponents\Cache folder under the main help file builder installation folder or in the new folder noted above if you moved the cache files.
  • A new insertConceptual configuration option was added to the build component definition configuration file. It is used to define a build component's placement within the conceptual.config file. The existing insert option will continue to be used for the reference build configuration file (sandcastle.config). If either element is omitted from a component's definition, it will not be merged into the given configuration file. This is a change from prior behavior which inserted the component at the start of the configuration file if a placement option was not specified
  • Components defined in the project's ComponentConfigurations property will be merged into the appropriate configuration files based on the presence of the insert and insertConceptual configuration elements. As such, the settings will be shared and the conceptual content will match the reference content in appearance.
  • A distinction is now made between JScript and JavaScript in the code colorizer to match the usage in Sandcastle. JScript now has its own rule set and is considered to be JScript.NET. JavaScript is regular JavaScript. Code examples using "JScript" or one of its variants as the language will be connected to the JScript language filter. Code examples using "JavaScript" or one of its variants as the language will be connected to the JavaScript language filter.
  • "XAML" has been added as a separate language in the code colorizer rules so that it can be correctly connected to the XAML language filter.
  • To support conceptual content, the following changes have been made to the build steps:
    • The CreateConfig build step has been renamed CreateBuildAssemblerConfigs. This step will now create the conceptual.config file as well.
    • The BuildHelpTopics build step has been renamed BuildReferenceTopics. This builds the reference (API) help topics.
    • Added the build steps CopyConceptualContent, CreateConceptualTopicConfigs, MergeTablesOfContents, and BuildConceptualTopics.
    • The BuildHelpTopics.bat script file has been renamed BuildReferenceTopics.bat. A new script file, BuildConceptualTopics.bat, was added to build the conceptual help topics.
    • If both conceptual content and additional content are included in a project, conceptual content will take precedence. Any additional content will appear after the conceptual content in the table of contents. Likewise, if specified, the default topic and split TOC topic in the conceptual content will take precedence. The equivalent settings in the additional content will only be used if not specified in the conceptual content.
  • A bug in the standard ResolveConceptualLinksComponent causes any specified inner text on <link> tags to be ignored and instead it always uses the title. I have reimplemented the component to fix that bug and added a couple of new features (see below). As such, any links you may have in your conceptual content files will start showing the inner text when built with the help file builder. You may need to review your documentation and either remove or update the inner text to something more appropriate on your links.

Non-breaking Changes in Behavior

  • The requirement that an XML comments file be associated with an assembly has been removed and the build behavior has changed for cases where the XML comments file for an assembly is blank. In such cases, the XML comments file is ignored and no comments will be associated with the assembly. This allows you to build a help file for an assembly without a comments file and is useful in a couple of the new plug-ins.
  • Wildcards are now supported in the AssemblyPath and XmlCommentsPath properties on each of the documented assemblies. This allows you to add one entry that will include multiple assemblies and/or comments files for documenting. This is also useful for documenting website projects in which the last part of the assembly names and comments files can change each time the website is published.
  • The behavior of the console mode builder's -assembly and -comments command line options has been adjusted accordingly to account for the new wildcard support.
  • The log file will list all assemblies and XML comments files copied during the ValidatingAssemblies build step so that you can verify it found the correct files. Warnings are also issued if duplicate files are copied that overwrite previously copied files in the working folder.
  • The PurgeDuplicateTopics project property has been removed as duplicates are now handled via the MergeDuplicates.xsl Sandcastle transformation immediately after MRefBuilder has been executed.
  • The Additional Content property category is now called Additional and Conceptual Content.
  • The ContentSiteMap and TopicFileTransform properties are now sub-properties of the AdditionalContent property. You must expand it to see them. This change was made to make their association with the additional content clear and to avoid incorrectly associating them with the new ConceptualContent property which does not make use of them.
  • The AdditonalContent and ContentSiteMap properites now share a common property editor to make it easier to edit their settings together and to make their association more apparent.
  • The help file builder will now include the necessary .NET Framework comments files based on the setting of the FrameworkVersion property. This ensures that all of the necessary comments files are included when using the .NET 3.0 and .NET 3.5 Frameworks.
  • The CachedCopyFromIndexComponent used for the comments index now names its cache files after the language and framework version.
  • Renamed the SyntaxFilters.ScriptSharp value to JavaScript as that is what it renders and this makes it more apparent that it can be used for other projects such as those that use the AjaxDoc plug-in. The old value will be translated to the new value automatically when an older project that contains it is loaded.
  • Added a customized version of the JavaScript declaration syntax generator component that will correctly document normal JavaScript. It will only convert the first letter of each member name to lowercase when documenting a Script# project.
  • The ShowMissingComponent messages are now localized. The messages appear in each of the SharedBuilderContent_[lang].xml files in the help file builder's .\SharedContent folder. The component also inserts the "missing namespace" message as well rather than the build process. A contentFile configuration option was added to the component that is used to specify the file containing the localized messages. If omitted, it defaults to using the English message text.
  • Due to a significant change in the way the language filters work in the Hana and Prototype presentation styles, the PostTransformComponent no longer connects examlpe code blocks to the language filter in those presentation styles. Given the way they are implemented, this feature would be better handled in the transformations and script files themselves.
  • The default topic transformation files now contain a default set of MSHelp:Attr elements for (name/value) DocSet/NetFramework, DocSet/{@HtmlHelpName}, Locale/{@Locale}, and TargetOS/Windows where the replacement tags will be replaced with the appropriate project option at build time. Any additional XML data island elements from the transformed topics will be merged with the default set.
  • Generate1xIndex.bat, Generate1xTOC.bat, GenerateWebsiteTOC.bat, and TocToWebContents.xsl have been removed. In their place is a new script template, ExtractHtmlInfo.bat, that runs a new tool that extracts TOC and keyword information from the HTML files to produce a better index and TOC with proper encoding support for foreign languages for the Help 1.x file and a TOC for websites.
  • If a new project is created from a Visual Studio 2008 solution or project, the FrameworkVersion property will be set based on the highest target framework specified within the Visual Studio project. This also applies to Visual Studio projects imported by the console mode builder.

Conceptual Content Support

  • Support for building conceptual content in addition to reference (API) content has been fully integrated into the build process. The new ConceptualContent property in the Additional and Conceptual Content property category allows you to manage the conceptual content.
  • The current conceptual content editor allows you to add, edit, and delete tokens, images, and conceptual topics in the project. The layout of the conceptual topics in the editor will determine their layout in the table of contents when built similar to how the site map works for additional content. Enhanced design support will be added in a later release.
  • Full support for colorized code blocks is included. Simply specify the code elements as you would in XML comments using all of the same options. This include support for imported code blocks.
  • The post-transform component is also supported and thus logos can be added to the conceptual topic headers. The conceptual build shares the same component configurations as the reference build so they will maintain the same look.
  • Documentation for conceptual content and its use with the help file builder is rather sparse at the moment. This will also be addressed in a future release.
  • An improved version of the ResolveConceptualLinksComponent has been added with the following features and fixes:
    • Broken links use the None style rather than the Index style so that it is apparant that they do not work.
    • The inner text from the conceptual link is used if specified. See the Potential Breaking Changes section above as this may affect any existing conceptual content that you have.
    • On broken links, when the showBrokenLinkText option is true and there is no inner text, the target value is displayed.
    • Conceptual link targets can include an optional anchor name from within the target such as "#Name" (i.e. <link xlink:href="3bdb6eb5-5e23-51c2-0051-3e224f82c201#Section2" />).
    • Unnecessary whitespace is removed from the link text.
    • If the companion file contains a <linkText> element and no inner text is specified, its value will be used for the link text rather than the title. This allows for a shorter title or description to use as the default link text.

Additional Content Models Deprecated

See the Conceptual and Additional Content topic for details.

Other Changes in This Release

  • Added support for the <inheritdoc /> XML comments tag. See the Using the <inheritdoc /> Tag topic in the help file for details.
  • Added the GenerateInheritedDocumentation build step to handle generation of inherited documentation.
  • Added the FeedbackEMailLinkText project property. If specified with a feedback e-mail address, the text in this property will be used as the link text. If left blank, the e-mail address will be used.
  • The BinaryTOC and IncludeFavorites properties are now found in their own category in the property grid (HTML Help 1).
  • Added the HTML Help 2 property category containing the following new project properties:
    • CollectionTocStyle - This defines the collection table of contents style used when plugged into an HTML Help 2 collection.
    • HelpAttributes - A collection of additional help attributes to add to the XML data island in each generated API topic.
    • HelpFileVersion - Specify the version number that should be applied to the help file.
    • IncludeStopWordList - Indicate whether or not to include the stop word list used to identify words to omit from Help 2 full text search index.
    • PlugInNamespaces - Specify a comma-separated list of namespaces that the collection will be plugged into when deployed using H2Reg.exe.
  • When performing a build that includes producing an HTML Help 2 file, a valid set of collection files and a configuration file for H2Reg.exe are now produced as well. They are located in the output folder with the help file.
  • Added the project property BuildLogFile that allows you to specify an alternate location and name for the build log file. If not set, it defaults to the filename LastBuild.log and stores it in the output folder identified by the OutputPath project property.
  • The log file is now in XML format to allow for running it through an XSL transform to make it more readable. A default XSL transform is supplied with the GUI (Templates\TransformBuildLog.xsl) and it is used in the GUI's log viewer dialog.
  • Added the IndentHtml project property as a debugging aid. When set to true, the HTML rendered by BuildAssembler is indented to make it more readable. Leave it set to false to produce more compact HTML.
  • Added a "-vsimport=solution|project,configName" option to the console mode builder that lets you specify a Visual Studio solution or project file from which to import the assemblies and XML comments files to document for the named configuration.
  • Added a "-helpattr=name,value" option to the console mode builder that lets you specify additional HTML Help 2 help attribute name/value pairs to add to the XML data island in each API topic.
  • The Namespace Summaries dialog box has been completely reworked. It now uses a partial build to gather the namespace information which will prevent the "assembly not found" errors that could occur due to nested dependencies that could not always be properly detected. In addition, namespaces can now be filtered by assembly and/or by some search text or a regular expression. A list of assemblies in which the selected namespace appears is also shown.
  • If comments for a class called NamespaceDoc within a namespace appear in the XML comments files, those comments will be used as the namespace comments. To keep the class from being included in the help file, leave off the public keyword and mark it with a CompilerGenerated attribute. See the Using NamespaceDoc Classes help topic for details.
  • Added a new keepSeeTags option to the Code Block Component that allows <see> tags that appear within the code to be passed through as-is so that they are rendered as clickable links to the referenced help topic (project topics or online MSDN topics). This option is also supported in additional content files on colorized <pre> tags but will only resolve links to project help topics.
  • Added a new filter option to the Code Block Component that allows you to specify whether or not a code block is connected to the appropriate language filter. If omitted or set to true, it will be connected. If set to false, it will not be connected.
  • The attribute name language is now recognized by the colorizer and the code block component as an acceptable alternative for the lang attribute name.
  • The CodeBlockComponent and PostTransformComponent where reworked to allow their use in conceptual content builds. This allows code blocks in conceptual content files to be colorized using the same options as in reference content builds.
  • Added the Help Attributes Component which is used to insert additional help attributes into the XML data island in each generated API topic. Support for this component is built into the help file builder via the HelpAttributes project property.
  • Abstract classes that implement the IPlugIn interface are now ignored when looking for plug-ins to load.
  • Added the following new plug-ins:
    • Additional Reference Links Plug-In - This is used to add additional reference link targets to the Reflection Index Data and Resolve Reference Links build components so that links can be created to other third party help in a Help 2 collection or to other online MSDN content.
    • DBCS Fix for CHM Builds Plug-In - This is designed to modify the HTML files and alter the build so as to overcome the encoding issues encountered when building Help 1.x (CHM) files for various foreign languages.
    • Hierarchical Table of Contents Plug-In - This is used to rearrange the table of contents such that namespaces are nested within their parent namespaces rather than appearing as a flat list of all namespaces at the root level.
    • Script# Reflection File Fixer Plug-In - This is used to fix up the reflection file produced from assemblies created by the Script# compiler so that they are documented correctly.
    • Table of Contents Exclusion Plug-In - This is used to exclude API members from the table of contents via the <tocexclude /> XML comment tag.
  • The AjaxDoc Plug-In now supports the ApiFilter property. Other plug-ins like it that generate their own reflection information can also apply the API filter manually by using the new ApplyManualApiFilter method on the BuildProcess object.
  • The Completion Notification plug-in now supports an optional XSL transform filename option. If specified and the log file is to be attached to the e-mail, the log file is ran through the transform and the resulting HTML file is attached in its place. If not specified, the raw log file is attached. The default transform can be used by specifying {@SHFBFolder}Templates\TransformBuildLog.xsl.
  • The Output Deployment plug-in now correctly supports relative file paths for the deployment locations. Relative file paths will be relative to the project file folder.
  • The table of contents entries for additional content items can now be split such that some appear before and some after the API topics. The ContentPlacement property's setting will be ignored if the table of contents is split via a custom tag in one of the additional content files or a site map is defined that specifies a split table of contents. In such cases, items prior to the entry with the "split" option will appear before the API content. The item with the "split" option and all items after it will appear below the API content.
  • Fixed a bug in the component configuration merging code that could cause the wrong component configuration to be replaced when more than one instance of the same component appeared in the project configuration.
  • Fixed a bug in ShowMissingComponent that caused the link in auto-documented constructors to point to the constructor topic rather than the class topic.
  • Updated the ShowMissingComponent so that it auto-documents constructors on the class's member and overloads list pages as well.
  • Added the ShowMissingTypeParams project property. When set to true (the default), it will show a "missing" message if generic type or method type parameter documentation is missing. This maps to the equivalent parameter added to the ShowMissingComponent.
  • The IntelliSenseComponent, PostTransformComponent, and VersionInfoComponent were updated to handle multiple assembly references in an API topic.
  • Fixed a bug in the PostTransformComponent that caused the VS2005 member list pages to be layed out incorrectly when using a logo and the version builder's framework menu was present.
  • Fixed a bug in the code colorizer rules for "//" style line comments that contained a "/*" which was incorrectly interpretted as the start of a block comment.
  • Fixed the XML colorizer rules so that they recognize string literals that span lines.
  • The code block component and additional content files can now extract commented regions from within XML, XAML, and SQL scripts. Just surround the snippet with comment lines containing #region and #endregion markers.
  • All logo placement options are now supported by the default topic transformation files.
  • If <MSHelp:Keyword Index="K" Term="[term]" /> tags exist in the XML data island in additional content files, the terms will now appear in the CHM file's index. The SHFB help file's additional content is now indexed using this method.
  • Fixed a JavaScript error in the website output that occurred if the full text search did not find any results.
  • The Index.aspx page now supports a topic query string parameter. If set to the path of a page in the website, it will display that page instead of the normal default topic page.
  • Thanks to Ferdinand Prantl for supplying the code necessary to add a keyword index pane to the ASP.NET index page.
  • Thanks to TimerLandChapel for providing additional translations for the Japanese content files.
  • Added some more common problems and solutions to the FAQ.
  • The entire project is now licensed using the Microsoft Public License (Ms-PL) to match the license used by Sandcastle itself.

Documenting Website Projects

A set of custom code providers is now available that simplifies obtaining XML comments files for C# and VB.NET website projects. In combination with the new wildcard support in the help file builder's Assemblies to Document list, producing a help file for websites is now a much simpler task. Download the custom code providers from the Sandcastle Styles Releases page. Click on the Documenting Web Projects link in the Releases box on the right side of the Release page to access it.

See Also

Other Resources

Version History


Version 1.6.0.4

[image]

Sandcastle Help File Builder Documentation
Version 1.6.0.4
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Version 1.6.0.4 was released on January 22nd, 2008.

Changes in This Release

  • Added support for the January 2008 release of Sandcastle.
  • Added CachedCopyFromIndexComponent and CachedResolveReferenceLinksComponent to the custom build components assembly. These cache key information for use across builds that should speed up the builds in many cases.
  • Added the DeploymentPlugIn which allows you to deploy the resulting help file output to a location other than the output folder (i.e. a file share, a web server, an FTP site, etc.).
  • Added the VersionBuilderPlugIn that allows you to generate version information for assemblies in the current project and other projects related to the same product that can be merged into the current project's help file topics.
  • Fixed a bug that caused the {@WorkingFolder} replacement tag to fail if used in a template file.
  • Fixed a bug in the Code Block and Post-transform Components that caused "none" language code blocks in API topics to always be hidden.
  • Fixed a bug in the default topic file transforms that caused it to not find the code colorizer script and stylesheet if the topic was not in the root folder.
  • Fixed issues caused by characters such as ampersand in the table of contents topic titles and filenames for Help 2 and website output.
  • If a topic file transform's output contains replacement tags, include items, blocks of code that need colorizing, or include code tags, they are now processed after the transform has occurred as well.
  • Added the map and area tags to the HTML passthrough section of the default transform files so that image maps can be used in additional content topics.
  • Added support for the Script# syntax generator to the SyntaxFilters project property.
  • The Assemblies to Document list now accepts files dragged and dropped from Windows Explorer.
  • When clearing the output folder, hidden folders and files are now ignored in addition to read-only folders and files.
  • When copying stock and additional content, hidden folders are ignored.
  • Added a Help2x_NamedURLIndex.HxK file to support the NamedURLIndex keyword options such as HomePage and DefaultPage within API and/or additional content topics.
  • Modified the Help 2 compiler check to also look for the Common Files\Microsoft Shared\Help 2.0 Compiler folder to handle versions installed by the VS 2008 SDK.
  • Fixed up handling of empty string literals in the code colorizer rules and added support for character literals (all C-style languages) and regular expression literals (JavaScript).
  • Added "Open help file after successful build" option to the View Help File submenu and toolbar button dropdown menu. If checked, the help file will be opened after the build completes successfully. This is a user setting and is saved across sessions.
  • Thanks to Joey Bradshaw for the PowerShell script keywords and code colorizer rule definitions. Use the language ID pshell, powershell, or ps1 to colorize a code block as PowerShell script.
  • Thanks to Milly for supplying the Japanese translations of the help file builder's shared content files.

See Also

Other Resources

Version History


Version 1.6.0.2

[image]

Sandcastle Help File Builder Documentation
Version 1.6.0.2
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Version 1.6.0.2 was released on November 14th, 2007.

Changes in This Release

  • Fixed a bug in the Post Transform Component that caused it to fail due to a change in the 1.6.0.1 release that altered the output path.
  • Fixed a bug in the topic file transformation caused by the XML writer sometimes being held open after use.
  • Dragging and dropping or editing a topics's properties in the Site Map Editor dialog now marks the file as changed so that it asks to save it when exiting the dialog.
  • Moved the CreateConfig build step down so that it runs just before the BuildHelpTopics step to give plug-ins a chance to merge any necessary information with the stuff that ends up in the configuration file such as the comments file names.
  • Removed the MinimumHelpFileBuilderVersion property from the IPlugIn interface as it isn't useful. The plug-ins are compiled against a specific signed version of the utilities assembly and won't load with a different version.
  • Custom build component support has been reworked and enhanced. Custom build component information is now loaded from the .\BuildComponents folder. A configuration file is used to define the build components and specify how they should be merged with the sandcastle.config file. This allows new components to be added and configured easily from within the help file builder without having to modify its template files. See the Creating a Component Configuration File topic for more details.
  • Added the IntelliSense Component. This build component is used to extract the XML comments into files that can be used for IntelliSense. Only the basic set of tags needed for IntelliSense are exported and only for documented API members.
  • When clearing the output folder, read-only files and folders are ignored as they are assumed to be under source control.

See Also

Other Resources

Version History


Version 1.6.0.1

[image]

Sandcastle Help File Builder Documentation
Version 1.6.0.1
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Version 1.6.0.1 was released on October 31st, 2007.

Changes in This Release

  • Added support for the October 2007 CTP of Sandcastle.
  • Fixed a couple of bugs related to topic file transformation.
  • Fixed a couple of bugs that caused the ApiFilter editor dialog to crash.
  • Fixed a couple of bugs in the AjaxDoc plug-in. It has also been updated to work correctly with AjaxDoc 1.1.
  • Adjusted the logo placement code in PostTransformComponent for the VS2005 style so that the logo appears correctly.
  • Added support for the VS2005 style's feedback control. It can be shown by setting the new ShowFeedbackControl property to true. Setting it to false hides it.
  • Added the SdkLinkTarget property to allow defining where MSDN links will open in the browser.
  • Support was added for the root namespaces page in the Hana and VS2005 styles when a root namespace container is used.
  • In additional content files, any HTML tag with a cref attribute will have the attribute converted to an href attribute that points to the found API topic (i.e. <area> tags in an image map).
  • Modified the VB.NET and VBScript comment colorization rules to fix problems with end of line detection. Added support for handling "<! >" entries such as those for DOCTYPE in the XML colorizer rules.
  • For consistency, the code colorizer scripts and stylesheets are now copied to the Scripts and Styles folders rather than the HTML folder. The outputPath property of the PostTransformComponent should now point to "Output" rather than "Output\html". The component will correct the path if it ends with "\html". The logo file is also copied to the Images folder rather than the root of the help content.
  • Some of the shared content items have been moved into presentation style specific shared content files due to differences in how those items are now handled by the style (specifically the header and footer items).
  • Added ".topic" and ".xslt" to the related File Open dialogs.
  • If building multiple output formats, website output is now built last to prevent unnecessary files ending up in the CHM and HxS files.
  • The HTML Help 2.x project files are now copied to the output folder to aid in creating a deployment file. Note that they will need modification to remove the DTD, compiler options, etc.
  • Improved the performance of various reflection file XPath queries which can speed up some of the build steps.
  • Merged changes from Martin Darilek into the version information build component to show the file version attribute value if present.

See Also

Other Resources

Version History


Version 1.6.0.0

[image]

Sandcastle Help File Builder Documentation
Version 1.6.0.0
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Version 1.6.0.0 was released on October 4th, 2007.

Changes in This Release

  • Added support for the September 2007 CTP of Sandcastle.
  • Versions of SharpDevelop 3.0.0.2658 and later now contain a copy of the Sandcastle Help File Builder. See the FAQ for information on how to install an update of Sandcastle and the help file builder for SharpDevelop.
  • Custom build process plug-ins are now supported that can be used to extend or alter the build process in various ways. Plug-ins supplied with the help file builder include:
    • Additional Content Only - Build help files based on nothing but the additional content items (documentation assemblies are excluded).
    • AjaxDoc Builder - Build help files for Atlas script libraries.
    • Completion Notification - E-mail the build results to someone optionally attaching the log file.
  • Added support for runing *.topic additional content files through an XSL transform so that they can match the appearance of the API topic pages. Basic transforms for the Hana, Prototype, and VS2005 styles are supplied. The TopicFileTransform property can be used to specify your own XSL transformation file.
  • Fixed a bug that caused private types to remain in the documentation if DocumentInternals was true but DocumentPrivates was false (and vice versa for internal types).
  • After MRefBuilder is executed, a check is performed to see if there is anything to document. If there are no public APIs, no private or internal APIs, or all namespaces are removed from the reflection information, the build is stopped with an error stating the problem.
  • Added a Content File Editors tab to the User Preferences dialog box. This allows you to associate non-default editors with content file extensions such as those for HTML files, stylesheets, images, etc.
  • Added an Edit button to the Additional Content Editor dialog box. When clicked on an entry representing a single file, the appropriate editor is launched to allow you to edit the file. If one has been defined using the User Preferences dialog box, that editor will be used. If one is not defined, the shell is used to launch the item with the Edit verb to invoke the default editor for the file. If an entry representing a wildcard is selected, a dialog opens first to let you choose a file to edit.
  • Added a ContentSiteMap project option which is used to specify the optional site map file that defines the table of contents layout for the additional content files. If used, the site map structure overrides the default table of contents layout derived from the folder structure of the additional content items.
  • Added an Edit Site Map button to the Content Item Editor dialog. This allows you to create or modify the layout of the site map entries.
  • Excluded namespaces and members with an <exclude /> tag are now removed using MRefBuilder's namespace ripping feature which is more efficient than removing them afterwards from the reflection information file. Excluded namespace and member information is merged with the new ApiFilter property. The ApiFilter property will take precedence if there is a conflict in exposure.
  • Added the ApiFilter project property to the Visibility category so that you can exclude documented API members and/or inherited API members using MRefBuilder's namespace ripping feature. This can provide more flexibility than using <exclude /> tags and is more efficient as the members are removed at the time the reflection information is generated.
  • The ApiFilter property designer lets you view the documented and inherited namespace members in a tree view and to check and uncheck items to include or exclude them. The namespace hierarchies are searchable using regular expressions and category options.
  • The console mode builder supports -include and -exclude command line options to add entries to the ApiFilter collection property.
  • Added DocumentInheritedPrivateFrameworkMembers and DocumentInheritedInternalFrameworkMembers properties to allow the removal of private and/or internal inherited framework members. Inherited protected framework members are now removed as well if DocumentProtected is set to false.
  • A KeepLogFile property was added to the project's Build category properties. The default is true to keep the log file after a successful build. If set to false, the log file is deleted after a successful build.
  • Added a FlagsEnumEditor type editor to the HelpFileFormat and SyntaxFilters project properties to make it easier to select multiple help file formats and language syntax filters in the dropdown editor.
  • The SyntaxFilters property now supports the JScript, VisualBasicUsage, and XamlUsage syntax filters. There is a lack of information on the XAML Usage filter right now so it is not clear how it can be fully used.
  • Project option replacement tags can now appear in text project properties such as HeaderText and FooterText.
  • Added a {@BuildDate} tag to insert the build date. It supports an optional format specifier. See the Customizing the Build Process topic for details on the available tags.
  • The language filter is now connected for all three presentation styles.
  • Added support for finding C++ #pragma region/#pragma endregion sections when extracting regions for code blocks.
  • The context menu for the property grid now contains a Copy property name to clipboard option that copies the current property's name to the clipboard.
  • The main form's size and location are saved to user settings on exit and the main form is restored to its prior size and location when opened the next time.
  • Thanks to JKendrick for the SQL script keywords and code colorizer rule definitions. Use the language ID sql, sql server, or sqlserver to colorize a code block as SQL script.
  • PLEASE NOTE: - Localized versions of the Sandcastle shared content files have been removed. The selected language will still be passed to the help compiler to localize the help window items but the table of contents and the actual help topic content will NOT be localized. This was necessary as with a third presentation style and a growing number of languages, it was becoming a project unto itself to merge and manage them all and to coordinate with all the other people to maintain them with each new CTP. A simplified localization model has been implemented. A small subset of shared content items are maintained that override items in user-managed translations of the different presentation style files. I will no longer manage a full, merged set of shared content resources. See the Localizing Language Resource Files help file topic for details. As of this release, not all items in the shared builder content files have been translated yet.

See Also

Other Resources

Version History


Version 1.5.0.1

[image]

Sandcastle Help File Builder Documentation
Version 1.5.0.1
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Version 1.5.0.1 was released on June 26th, 2007.

Changes in This Release

  • Fixed a bug that caused "Missing namespace summary" messages and failure to exclude namespaces when using the VS2005 or HANA presentation style.
  • Fixed a bug in the code colorizer that caused it to fail to match C# and J# language IDs to the correct rule set.
  • Replaced the hard-coded path in the table of contents generation script files with the correct replacement tag to match the other commands.

See Also

Other Resources

Version History


Version 1.5.0.0

[image]

Sandcastle Help File Builder Documentation
Version 1.5.0.0
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Version 1.5.0.0 was released on June 25th, 2007.

Changes in This Release

  • Added support for the June 2007 CTP of Sandcastle.
  • Fixed a bug that caused a crash when removing private framework field members.
  • Fixed a bug in the handling of <exclude/> that caused it to also remove base class members when removing a type.
  • Fixed a bug when generating the website table of contents caused by the angle brackets on nested generic types.
  • Fixed a bug in ShowMissingComponent caused by incorrect handling of generic template parameter names.
  • Fixed a bug in the code colorizer that caused it to match some pre tags incorrectly. Also fixed the "include file" regular expression so that it didn't match similar looking managed C++ generic declarations.
  • Fixed inconsistent handling of the tab size property in both the code colorizer and the code block component.
  • Added managed C++ keywords to the C++ colorizer template.
  • The list of assemblies to document is now maintained in sorted order.
  • Added code to verify that OutputPath and WorkingPath do not point to a root or well-known folder (i.e. C:\ or My Documents) to prevent users from accidentally deleting everything in it.
  • Support was added for finding <code> tags with closing </code> tags in addition to the self-closing tags for importing code blocks in additional content files.
  • Support was added for merging two or more code snippets into a single code example by nesting code tags within a parent code tag. Nested code tags are supported in XML comments and additional content files. See the Code Block Component topic and Importing and Colorizing Code from Source Files topic for details.
  • The code colorizer was updated to be more flexible in matching language IDs to rule sets. It will now match the ID case-insensitively to the ID or friendly name. It will also match several common variations to the correct rule sets (i.e. VB to VB.NET, CSharp to C#, etc.).
  • Added a ShowMissingNamespaces project option so that "missing namespace comments" messages in the help file can be suppressed if not wanted.
  • The website output option has been modified. It no longer uses a frame set. Instead, it uses a combination of DIV tags, CSS, Javascript, and an IFRAME to display the table of contents and the selected page.
  • In addition, a couple of ASP.NET pages are supplied that should work more efficiently than the basic Index.html page. The main Index.aspx page only loads the root nodes for the table of contents when first displayed. Ajax calls are used to load child nodes dynamically when they are first expanded (done using FillNode.aspx). A Web.config file is included that contains some necessary namespace declarations for the pages. The pages use inline code so there shouldn't be any need to compile them before deployment.
  • When viewing the ASP.NET index page, full-text search is also available. The search results are returned using an Ajax call to the SearchHelp.aspx page. Search results are sorted by rank (most likely match first) by default or they can be sorted by title.
  • Expanded the output viewing options to let you choose which format to view when multiple formats have been built. This includes the ASP.NET website option using the .NET 2.0 development web server (IIS not required).
  • The Verbose Logging option on the Documentation menu has been removed. There is now a User Preferences option on the Project menu that lets you edit non-project related user preferences such as the verbose logging option, an HTML Help 2.x viewer application, and the port to use for the ASP.NET development web server used to view website output.
  • The output and log viewing options were modified so that you can view the results from a prior session without having to do a build after restarting the help file builder.
  • Added some more common problems and solutions to the FAQ.
  • Localized versions of the shared content files were removed. See the 1.6.0.0 release notes for the reasons and information on the new implementation.

See Also

Other Resources

Version History


Version 1.4.0.1

[image]

Sandcastle Help File Builder Documentation
Version 1.4.0.1
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Version 1.4.0.1 was released on March 19th, 2007.

Changes in This Release

  • Added support for the March 2007 CTP Refresh of Sandcastle.
  • Fixed ShowMissingComponent so that it does not show "missing summary" warnings on root TOC entries for members, properties, etc. when using the VS2005 style.
  • Fixed CodeBlockComponent so that it HTML encodes the title attribute value.

See Also

Other Resources

Version History


Version 1.4.0.0

[image]

Sandcastle Help File Builder Documentation
Version 1.4.0.0
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Version 1.4.0.0 was released on March 11, 2007.

Changes in This Release

  • Added support for the March 2007 CTP of Sandcastle.
  • NOTE: The default configurations for the CodeBlockComponent and PostTransformComponent have changed and must be reset and reconfigured if you customized them via the ComponentConfigurations project option. Line numbering and outlining are now off by default. A new option "Connect code blocks to language filter" has been added to allow connecting the code blocks to the language filter. If enabled (the default), code blocks are shown or hidden based on the language filter setting. If disabled, code blocks are always shown regardless of the language filter setting. Options are also present to set the location of the "Copy" image and the file path for it.
  • Made some significant performance improvements. Build times in some cases involving extremely large numbers of topics can be reduced by up to 50% or more. The larger the number of topics to document, the more significant the decrease in build time.
    • Optimized loading and saving of the reflection information file and the XML comments files within the build engine.
    • Optimized the purge item code and duplicate checking in the name generation code to eliminate unnecessary XPath lookups.
    • The processing for the ShowMissing* options has been moved into a new build component (ShowMissingComponent). On extremely large documentation builds (tens of thousands of topics), the XPath queries that were used to look up the member comments and the information in the reflection file took an extremely long time. By moving the processing to a build component, the amount of information to search is greatly reduced and the time to add missing item comments is now negligible.
    • The version information lookup part of the PostTransformComponent was split out into a new VersionInfoComponent that runs before transformation of the topic occurs. This allows for an optimized lookup of the version information and the whole reflection file does not need to be loaded thus reducing memory usage for large builds and speeding up the searches for version information.
    • Added build step timing information so that it is easier to see which steps are taking the longest during a build.
  • The console mode builder can now accept project properties as command line options to override or add settings to a project. A response file can also be used to avoid problems with long command lines. See the Building Projects Outside the GUI topic for details.
  • Added the WorkingPath property so that you can specify an alternate location with a shorter path in which to perform the build if it fails due to long file path names.
  • The following file and folder project properties have been converted from strings to objects. This allows them to be persisted as paths relative to the current project location rather than as absolute paths at your choosing. In addition, environment variables such as %DXROOT%, %WINDIR%, etc. can be specified in the paths and they will be expanded at build time to the value of the specified environment variable. Properties affected:

    • SandcastleProject.HtmlHelp1xCompilerPath
    • SandcastleProject.HtmlHelp2xCompilerPath
    • SandcastleProject.SandcastlePath
    • SandcastleProject.WorkingPath
    • DocumentAssembly.AssemblyPath
    • DocumentAssembly.XmlCommentsPath
    • ContentItem.SourcePath
    • DependencyItem.DependencyPath

    The OutputPath property is still a string. If relative, it is always relative to the project folder and thus should not point at the prior location if the project is saved in a new folder. For similar reasons, the DestinationPath property of additional content items has also been left as a string.

    • All fully qualified paths in the affected properties in projects created by prior versions of the help file builder will become relative paths automatically when opened in the latest version. If you need a fixed path, expand the property and set the IsFixedPath property to true so that it is saved as an absolute rather than a relative path.

  • It is now possible to resolve project option values and shared content items in additional content files. See the Project Properties and Shared Content help topic in the Additional Content section for details.
  • Fixed a bug in the code to resolve links to namespace content from additional content that caused it to add too many relative path parts to the URLs. Fixed a bug that caused it to miss the default page setting if the page was associated with a folder. Also fixed a bug that caused it to ignore the page if it was associated with a folder and it was the only file in the folder.
  • Fixed a bug in the code colorizer caused by the description for the collapsed region not being HTML encoded. Also fixed up the definitions so that it doesn't colorize preprocessor text within quotes and comments and handles XML attribute names containing colons.
  • Fixed the CodeBlockComponent and the code colorizer so that they recognize VB.NET style #Else If, #End If, and #End Region statements.
  • The code colorizer now renders a "Copy" icon and text to the right of each title line on the code blocks and allows you to copy the code to the clipboard. The code is copied as plain text without the highlighting and line numbers if used. Default titles are also used on code block that do not have a title. The default title is based on the language specified.
  • Modified the the C++ comments fixup code so that it only strips out the unnecessary characters if they appear in a declaration involving the System.Collections.Generic namespace.
  • The PresentationStyle property now uses a type converter that allows you to select any folder under the .\Presentation folder in the main Sandcastle installation folder. This allows you to create custom versions of the Prototype and VS2005 styles using different names and select them for use from within a help file builder project.
  • The build process now tries to delete the help file first if it exists so that it stops immediately if the help file is open and cannot be overwritten.
  • Made the file extension checks case-insensitive when adding assemblies and comments files to the project and when examining additional content files during the build.
  • When documenting internals, private fields backing events are now removed as they can never be documented with comments.
  • Removed extraneous paragraph tags from the formatted footer replacement tag values.
  • Modified the comments shared content item so that the e-mail link in the page footers now appends the current topic's title to the help file's title for the e-mail's subject.
  • Added a FooterText property to the project that lets you add additional text to the footer of each page without having to modify the shared content file. The text is inserted at the start of the footer shared content item.
  • The post-transform component now turns off all file attributes when copying the highlighter and logo files so that they can be deleted at the end of the build when CleanIntermediates is set to true.
  • Added placement and alignment attributes to the logoFile element of the post-transform component. This allows the logo to be placed to the left, right, or above the topic title. When placed above the topic title, it can be aligned to the left or right or centered.
  • Moved the version information text to the end of the location information shared content items. The PostTransformComponent now moves the location/version text to the end of the footer in the Prototype style.
  • Added a Delete button to the Namespaces dialog that lets you remove old namespaces from the list that no longer appear in the assemblies.
  • Added Help1xAndHelp2x and Help1xAnd2xAndWebsite options to the HelpFileFormat project option.
  • Added an ExcludeItems property to the additional content items. If set to true, the file or files matching the source path are excluded. If used with a wildcard source path, all matching files in subfolders are excluded as well.

See Also

Other Resources

Version History


Version 1.3.3.1

[image]

Sandcastle Help File Builder Documentation
Version 1.3.3.1
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Version 1.3.3.1 was released on December 11th, 2006.

Changes in This Release

  • NOTE TO VERSION 1.3.3.0 RC USERS: You must reset the Post-transform Component configuration and reconfigure it before performing a build with this release due to changes in the configuration.
  • Updated for use with the December 2006 CTP. A patch file for the Sandcastle style and transformation files is supplied separately to fix missing support for br and hr tags in the Prototype style, to fixed numbered lists, and to add support for displaying the "Obsolete" messages on obsolete items. Extract the patch to your Sandcastle installation folder. See the ReadMe.txt file included with it for details on the fixes that I made.
  • Implemented a code block custom build component with the following features:
    • Syntax highlighting of code blocks in <code> tags. Languages supported: C#, VB.NET, C++, C, JavaScript, VBScript, J#, and XML.
    • Excess leading whitespace is stripped from the <code> blocks to left align them correctly.
    • Support for optional line numbering.
    • Support for optional collapsible regions for code in #region and #if/#else/#endif blocks with support for nested collapsible regions.
    • Support for reading in an external source file or a defined region of an external source file so that you can keep code samples in a buildable project to test for correctness and do away with managing the code samples in the XML comments and include files.
  • Implemented a post-transform custom build component with the following features:
    • Companion to the Code Block Component to add the supporing links for the colorizer script and stylesheet.
    • It can insert a logo image at the top of each help topic.
    • For the Prototype style, it hides the language combo box if only one language appears in the Syntax section.
    • Version information will be added to the help topics if used with the help file builder. If used outside the help file builder, a modification is required to the Sandcastle reference content files.
  • Added support for the XML comments <exclude/> tag.
  • Added the locale attribute to the ResolveReferenceLinksComponent in sandcastle.config to use the project language for the MSDN URLs. Note that there is a small bug in the component that causes the first reference to still point to the English site. This bug has been reported and will hopefully be fixed in the next Sandcastle CTP.
  • The build components are configured individually via the new project option ComponentConfigurations. Additional third party build components can be plugged into the help file builder by adding the default configuration to the sandcastle.config template with a unique ID attribute and implementing a public static ConfigureComponent method in the component. See the help file for more details.
  • Added a SyntaxFilters property that lets you specify which languages appear in the Syntax section of the help topics and, for the Prototype presentation style, the dropdown in the upper right of the topics. It can be set to CSharp, VisualBasic, CPlusPlus, JSharp, a combination of those values, All to include them all, Standard (the default) for C#, VB.NET, and C++ only, or to None to remove the Syntax section entirely.
  • Added the CppCommentsFixup project property to work around an issue with methods that take generics as parameters in XML comments files created by the C++ compiler (it doesn't match the other .NET compilers' naming conventions).
  • The FrameworkVersion property is now always saved in the project to prevent building against the wrong version when a project is edited on two different systems, one with a more recent version of .NET than another. It also defaults to .NET 2.0 for new projects rather than the most recent framework version on the system which may be .NET 3.0 to prevent unexpected problems. If you need .NET 3.0, you must select it manually.
  • The HelpTitle property is now displayed in the help topics at the top of the page where "Reference Library" used to be.
  • The ObsoleteAttribute, FlagsAttribute, and SerializableAttribute are now always included even if DocumentAttributes is set to false. These provide useful information and should not be filtered out.
  • The Preview and Arrange dialog for additional content no longer prompts for the project folder as it is maintained internally now.
  • Code in <pre> tags in additional content HTML files can be colorized by adding the colorizer attributes to them. See the Syntax Highlighting <pre> Tag Content topic for details.
  • Modified the tool search to also try to find Sandcastle via the DXROOT environment variable.

See Also

Other Resources

Version History


Version 1.3.2.0

[image]

Sandcastle Help File Builder Documentation
Version 1.3.2.0
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Version 1.3.2.0 was released on November 12th, 2006.

Changes in This Release

  • Updated for use with the November 2006 CTP. A patch file for the Sandcastle style and transformation files is supplied separately to fix a few issues that still remain with the stock versions supplied with Sandcastle. Extract the patch to your Sandcastle installation folder. See the ReadMe.txt file included with it for details on the fixes that I made.
  • Converted the Common Problems and Solutions help file topic into a FAQ topic and added several more items to it. A toolbar button and a Help menu option where added to give easy access to it from the help file builder.
  • Added the ability to add XML comments files without an associated assembly. This is useful for adding shared project summary or namespace summary comments to multiple projects without having to store the comments in the Sandcastle Help File Builder project. See the help file for details.
  • Paths to non-GAC dependency items can now be edited in the Dependency Item Editor dialog box so that you can make them have relative paths.
  • Added an MRefBuilder.config template that is used to tell MRefBuilder which framework comments to use based on the project's FrameworkVersion property. It is now possible to correctly document .NET 1.0 and 1.1 assemblies.
  • Added a new NamingMethod property that lets you specify how the help topic filenames are created (GUID, member name, or hashed member name). The last two make it easy to link to help topics from external applications or web pages. See the help file for more information.
  • Changed the build process to release the assembly loader immediately after copying dependencies to prevent the lease running out and causing an exception when trying to release it when done after a very long build.
  • The assembly loader was modified to add dependencies using a full path so that it can find them correctly.
  • Changed the Index.html template so that forward slashes are used in the default topic page's path rather than backslashes.
  • To prevent Out of Memory exceptions on extremely large builds, the BuildProcess class now writes messages to the log file for itself. A Verbose Logging option was also added to the Documentation menu in the GUI help file builder to prevent the problem as well. If disabled, only build step messages are logged to the output window during the build. This is an application user setting, not a project property.
  • Fixed the ShowMissingSummaries option so that if it is set to false and AutoDocumentConstructors is set to true, it does not add the unwanted "Missing Summary" text on methods, properties, etc.
  • Modified the tool searches so that if the "(x86)" version of the Program Files folder exists (64-bit Windows), it searches in there instead for Sandcastle and the help compilers. If multiple copies are found in the SDK folders, it now tries to return the latest SDK version.
  • Fixed the search for Sandcastle in the PATH environment variable so that if the help file builder path is ahead of the Sandcastle path, it ignores it. It will also search the VS2005 SDK folders if not found anywhere else.

See Also

Other Resources

Version History


Version 1.3.1.1

[image]

Sandcastle Help File Builder Documentation
Version 1.3.1.1
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Version 1.3.1.1 was released on October 9th, 2006.

Changes in This Release

  • Support for the October 7th Sandcastle CTP Refresh was confirmed. A patch file for some of the Sandcastle style and transformation files is supplied separately to fix a few issues that still remain with the stock versions supplied with Sandcastle. Extract the patch to your Sandcastle installation folder. See the ReadMe.txt file included with it for details on the fixes that I made.
  • The UTF-8 encoding is now preserved on XML comments files when adding the missing documentation tags. They lack an encoding attribute and byte order marks but are UTF-8 encoded and are now always treated as such to preserve the encodings on extended characters in the authored comments.
  • If DocumentAttributes is set to false, the [Serializable] attributes are removed from the syntax section now as well.
  • Implemented several new Document* properties that behave like the matching NDoc properties. See the Visibility Category Properties topic in the help file for more information.

See Also

Other Resources

Version History


Version 1.3.1.0

[image]

Sandcastle Help File Builder Documentation
Version 1.3.1.0
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Version 1.3.1.0 was released on October 3rd, 2006.

Changes in This Release

  • Updated for use with the September 2006 CTP.
  • The new PresentationStyle Help File category property can be used to select either the Prototype or VS2005 style for the generated help topics.
  • Fixed a bug that caused the website build to fail if generic classes were in the documented assemblies due to the angle brackets in their names.
  • Added the Show Missing Tags category properties to insert "missing documentation" messages to flag items that need attention.
  • Added an AutoDocumentConstructors property to automatically insert a default summary for constructors that are missing the <summary> tag and for compiler-generated constructors.
  • Added a Clean Output Folder option to the Documentation menu to delete all files from the project's OutputPath folder.

See Also

Other Resources

Version History


Version 1.3.0.0

[image]

Sandcastle Help File Builder Documentation
Version 1.3.0.0
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Version 1.3.0.0 was released on September 25th, 2006.

Changes in This Release

  • Improved the help file. The article was getting rather long so I have moved a lot of the information to the help file and expanded on it as needed to make it more useful. See it for more information on how to use the help file builder.
  • Added Website, Help1xAndWebsite, and Help2xAndWebsite options to the HelpFileFormat property to allow generating the help as a website, a website plus an HTML Help 1.x file, or a website plus an HTML Help 2.x file. The website output includes an index page complete with tree view for navigating the table of contents.
  • The ContentItem class's IsDefaultPage and ContentDescription properties have been removed as they are now obtained along with a sort order while copying the additional content items and building table of contents entries for them. See The Additional Content Property topic for more information on the new features.
  • Added a preview option to the Additional Content editor dialog box to preview the table of contents entries for the additional content. You can also arrange items and set the default topic from it.
  • Added the ability to create links to namespace help content from the additional content files. See the Linking to Namespace Content topic for more information.
  • Modified the file I/O code to detect the encoding of the files when reading them and to use the same encoding when writing them back out to preserve the character encodings within the files.
  • The table of contents file for HTML Help 1.x files is now saved using the default encoding based on the system's code page rather than UTF-8 encoding to ensure that the character encodings are correctly interpretted by the help compiler and viewer.
  • Some additional notes regarding encoding have been added to the information on how to create language resource files for other languages.
  • Added a command to the Documentation menu to clear the output window on the main form. The View Log form now loads the log text from the last build's log file.
  • Added a version check on MRefBuilder.exe to ensure that a valid version is being used. An exception is thrown if the version found is less than the expected version (you need to update Sandcastle). A warning is issued if the version found is greater than the expected version (you need to update the help file builder).
  • The New Project from Visual Studio Project option now recognizes VB.NET and J# solution files.
  • Fixed a bug that caused assembly loading to fail under certain circumstances when determining namespaces for the Namespace Summaries dialog box.
  • Fixed a bug that caused the build process to try and scan a drive that didn't exist when looking for the HTML Help 2.x compiler.
  • The Language property now only shows the list of languages for which resource files exist.

See Also

Other Resources

Version History


Version 1.2.0.0

[image]

Sandcastle Help File Builder Documentation
Version 1.2.0.0
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Version 1.2.0.0 was released on September 6th, 2006.

Changes in This Release

  • A new Prj Summary button appears on the main form in the Assemblies to Document section. It opens a form in which you can enter summary comments that should appear in the root namespaces page of the compiled help file.
  • A new Namespaces button appears on the main form that allows you to specify which assemblies should appear in the help file and the namespace summaries to display in the root namespaces page and on the help page for each namespace. By default, all namespaces in all assemblies are documented with the exception of the global (unnamed) namespace that sometimes appears and contains private module details.
  • The Add button used to add an assembly to document now opens a file selection dialog in which you can select one or more assemblies, executables, or comments files to document. It will assume that the matching file (assembly or comments file) has the same name as the selected file. If a match is not found, the missing file's name is set to Unknown and the Edit option can be used to fix it.
  • The dependencies editor now allows the selection of a GAC item. This allows you to specify a dependency that only resides in the GAC and has no copy that resides elsewhere. At build-time, the GAC is queried and the necessary assembly is copied to the working folder for use by MRefBuilder.
  • Added the ContentPlacement property that allows you to specify whether the additional content goes in ahead of the namespaces or after the namespaces in the table of contents.
  • Added the IsDefaultPage property to the ContentItem class that allows you to indicate whether or not the content item is the default page. If no item is marked as the default page, the root namespaces page is used as the default page.
  • Fixed a bug that caused the RootNamespaceContainer property to be ignored if there was no additional content defined.
  • Fixed up issues in various properties related to ampersands causing exceptions because they cannot be interpreted by the .NET XML parser. The values are now HTML or URL encoded as needed.
  • The value of the CopyrightText property is now treated as plain text. It will be HTML encoded where necessary to resolve issues related to the ampersand and the .NET XML parser. In addition, you can encode special characters such as the copyright symbol using an escaped hex value (i.e. © = \xA9).
  • Reworked the "run process" code so that it now reports progress as the tools are running rather than at the end after the tool completes. This gives more immediate feedback especially during long running builds so that you can see that it is still alive. It also captures the standard error stream output so that if a tool throws an exception, that information is now captured in the log file as well. Where appropriate, the name of the script being executed is also logged.
  • Increased the font size in the log viewer dialog box to 10pt so that it is easier to read.
  • Path-related properties are now grouped in a new Paths category in the property grid on the main form.
  • Visual Studio 2003 projects are now loaded using the default encoding rather than UTF-8 encoding to handle foreign language characters in the project properties.

See Also

Other Resources

Version History


Version 1.1.0.0

[image]

Sandcastle Help File Builder Documentation
Version 1.1.0.0
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Version 1.1.0.0 was released on August 28th, 2006.

Changes in This Release

  • Updated for use with the August 2006 CTP.
  • Added the option to create a new Sandcastle Help File Builder project by importing the assembly information from a Visual Studio 2003/2005 solution or project file.
  • Added the HelpFileFormat property to let you define the help file output format (HTML Help 1.x or HTML Help 2.x).
  • Renamed the HtmlHelpCompilerPath property to HtmlHelp1xCompilerPath for the HTML Help 1.x help compiler (HHC.EXE) and added the HtmlHelp2xCompilerPath property for the HTML Help 2.x help compiler (HXCOMP.EXE).
  • Added the project files necessary to build HTML Help 2.x help files and renamed a few of the template files to reflect their use in building HTML 1.x help files.
  • Fixed a problem in the final build step caused by a help filename with spaces in it.
  • The Dependencies property has been changed to a collection to allow easier specification of dependency items for MRefBuilder.
  • The {@IndexFile} tag has been removed and a new step added to generate the HTML Help 1.x index file via the new Sandcastle XSL transformation.
  • Renamed ShowAttributes to DocumentAttributes to match NDoc and put it in the Visibility category.
  • Added the DocumentInternals property to allow the documentation of private and internal members to be enabled.
  • Added ProjectLinkType and SdkLinkType options to control how links to other help topics are rendered in the help file.
  • Added a RootNamespaceContainer option. If true, a root Namespaces table of contents entry will be made the container of the namespaces. If false, the default, the namespaces are listed in the table of contents as root entries.

See Also

Other Resources

Version History


Version 1.0.0.1

[image]

Sandcastle Help File Builder Documentation
Version 1.0.0.1
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Version 1.0.0.1 was released on August 15th, 2006.

Changes in This Release

  • Fixed the build process so that it handles braces in the tool output when reporting progress.

See Also

Other Resources

Version History


Version 1.0.0.0

[image]

Sandcastle Help File Builder Documentation
Version 1.0.0.0
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Version 1.0.0.0 was released on August 14th, 2006.

Changes in This Release

  • Initial release.

See Also

Other Resources

Version History


Glossary

[image]

Sandcastle Help File Builder Documentation
Glossary
Send Feedback

[This is preliminary documentation and is subject to change.]
A | B | C | D | E | F | G | H | I | J | K | L | M | N | O | P | Q | R | S | T | U | V | W | X | Y | Z

A

additional content

An extra file included in the help file used to define extra content or used as a supporting file. This can be an HTML topic, an image, script, stylesheet, etc. In earlier releases of the help file builder, this was the way non-API content was included in the help file. The preferred method of including such content now is to use conceptual content. Although still supported, the additional content features of the help file builder are now considered deprecated.

See Also: conceptual content

B

BuildAssembler.exe

This is a tool supplied with Sandcastle that is used to build the help topics for conceptual and reference builds. It is passed a configuration file containing a list of build components to use in transforming the topics into HTML and a manifest file that lists the topics to build.

See Also: Sandcastle

C

Code Block Component

A custom build component that can be used to colorize code, add line numbering and/or collapsible section, and import code from working source code files. It can be used in both conceptual and reference builds. The component is integrated with the Sandcastle Help File Builder and is also available as a standalone component from the same project site for use in other tools or your own build scripts.

See Also: Sandcastle, Sandcastle Help File Builder, Post-Transform Component
code snippets file

A file used to store commonly used code snippets. The snippets can be inserted into a conceptual topic using the CodeEntityReference element.

conceptual build

A build that uses Sandcastle to produce help file topics using information extracted from conceptual content topics and their related files.

See Also: reference build, Sandcastle
conceptual content

A topic file that contains conceptual content. These can be used to add usage notes, walkthroughs, tutorials, etc. to a help file. Conceptual topics use MAML rather than HTML to define their content.

See Also: additional content, MAML

D

dependency

See reference.

documentation source

An individual assembly (executable or DLL), an individual XML comments file, a Visual Studio project file (C#, VB.NET, or J#), a Visual Studio solution file containing one or more of the noted project types, or a wildcard item that results in a list of one or more of the previously mentioned file types. These are used to produce API documentation in a help project. At least one assembly must be specified as a documentation source in order to produce API help content. Documentation sources are managed using the Documentation Sources project node in the Project Explorer window.

Tip:

Given that solutions and projects are supported as documentation sources, you may find it easier to add them as documentation sources instead of the assemblies, comments, and references that they contain. When a solution or project is used, these items are imported from them automatically at build time.

G

Globally Unique Identifier, GUID

A unique value that is associated with each conceptual topic and image in a project. When inserting links to topics or images, the ID is used to refer to them. This allows you to alter the names or locations of the topic files without having to change the name or location in each topic that references them.

M

MAML

An acronym that stands for Microsoft Assistance Markup Language. Conceptual content topics are composed of MAML elements.

See Also: conceptual content

P

Post-Transform Component

A custom build component that can be used insert a logo into the header of conceptual and reference build topics. It is a companion to the Code Block Component and inserts the necessary script into each topic if colorized code blocks are present and connects them to the language filter. In reference builds, it can also insert assembly version information into each topic.

See Also: Code Block Component, Sandcastle, Sandcastle Help File Builder

R

reference

Also referred to as a dependency. This is an assembly that is referenced by one of the documented assemblies for base class information but is itself not documented as part of the help project. They are managed via the References project node in the Project Explorer window. References can be GAC entries, assembly files, COM objects, or Visual Studio project files.

reference build

A build that uses Sandcastle to produce help file topics using information extracted from managed assemblies and their associated XML comments files.

See Also: conceptual build, Sandcastle

S

Sandcastle

Sandcastle is a set of tools produced by Microsoft that can be used to build help files for .NET managed libraries, conceptual content, or a mix of both.

See Also: Sandcastle Help File Builder
Sandcastle Help File Builder, SHFB

The Sandcastle Help File Builder is a standalone tool used to automate Sandcastle. It consists of a GUI front end that helps you manage and build help file projects. It uses a standard MSBuild format project file which can also by built from the command line using MSBuild or integrated into Visual Studio builds or other build scripts to produce a help file when your application projects are built. In addition, it provides a set of additional features beyond those supplied with Sandcastle that can improve your help file and make it easier to deploy.

See Also: Sandcastle

T

token, token file

A token is used as a replaceable tag within a topic and is represented using a token element. The inner text of the element is a token name. The tokens are defined in a separate token file. They are an easy way to represent common items that you use regularly such as a common phrase or external link.


SandcastleBuilder.Components Namespace

[image]

Sandcastle Help File Builder Documentation
SandcastleBuilder.Components Namespace
Send Feedback

[This is preliminary documentation and is subject to change.]

This namespace contains custom build components used by the Sandcastle tools MRefBuilder and BuildAssembler. The MRefBuilder components are used to add features such as assembly binding redirection when generating reflection information. The BuildAssembler components are used to add additional features to the help topics such as a logo, code colorization, warnings that indicate missing documentation elements, etc.

Classes

Class | Description
BindingRedirectResolver | This is a custom assembly resolver for Sandcastle's MRefBuilder tool that supports assembly binding redirect elements in its configuration that let you redirect an unknown assembly's strong name to another by version number when resolving an unknown reference.
BindingRedirectSettings | This represents binding redirection settings for the BindingRedirectResolver.
CachedCopyFromIndexComponent | This is a derived CopyFromIndexComponent class that loads the index document cache from a serialized binary file rather than loading it from the XML reflection data files. This can significantly decrease the amount of time needed to instantiate the component.
CachedResolveReferenceLinksComponent | This is a derived ResolveReferenceLinksComponent2 class that loads cached MSDN URLs from a serialized binary file rather than letting the base component invoke the web service to look them up. This can significantly decrease the amount of time needed to perform a build.
CodeBlockComponent | This build component is used to search for <code> XML comment tags and colorize the code within them. It can also include code from an external file or a region within the file.
ConceptualLinkInfo | This is a reimplementation of the ConceptualLinkInfo class used by ResolveConceptualLinksComponent.
IntelliSenseComponent | This build component is used to generate IntelliSense files based on the documented APIs.
JavaScriptDeclarationSyntaxGenerator | This is a JavaScript declaration syntax generator that is used to add a JavaScript Syntax section to each generated API topic.
MSHelpAttrComponent | This build component is used to add additional HTML Help 2.x attributes to the XML data island in each generated API topic.
PostTransformComponent | This build component is is a companion to the CodeBlockComponent. It is used to add the stylesheet and JavaScript links to the rendered HTML if the topic contains colorized code. In addition, it can insert a logo image at the top of each help topic and, for the Prototype presentation style, hide the language combo box if only one language appears in the Syntax section. With a modification to the Sandcastle reference content files, it will also add version information to each topic.
ResolveConceptualLinksComponent | This contains a reimplementation of ResolveConceptualLinksComponent that allows the use of inner text from the <link> tag, allows the use of anchor references (#anchorName) in the link target, and allows the use of an optional linkText element in the companion file to specify the link text.
ShowMissingComponent | This build component is used to add "missing" notes for missing summary, parameter, returns, value, and remarks tags. It can also add default summary documentation for constructors.
TargetDirectory | This is a reimplementation of the TargetDirectory class used by ResolveConceptualLinksComponent.
TargetInfo | This is a reimplementation of the TargetInfo class used by ResolveConceptualLinksComponent.
VersionInfoComponent | This build component is used to obtain version information for each topic so that it can be placed in the footer by the PostTransformComponent.

Enumerations

Enumeration | Description
LinkType | This public enumerated type defines the link types
PostTransformComponent..::.LogoAlignment | This enumeration defines the logo alignment options when placement is set to Above.
PostTransformComponent..::.LogoPlacement | This enumeration defines the logo placement options


BindingRedirectResolver Class

[image]

Sandcastle Help File Builder Documentation
BindingRedirectResolver Class
Members Example See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is a custom assembly resolver for Sandcastle's MRefBuilder tool that supports assembly binding redirect elements in its configuration that let you redirect an unknown assembly's strong name to another by version number when resolving an unknown reference.

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.MRefBuilder (in SandcastleBuilder.MRefBuilder.dll) Version: 1.8.0.2

Syntax

C#
public class BindingRedirectResolver : AssemblyResolver
Visual Basic (Declaration)
Public Class BindingRedirectResolver _
    Inherits AssemblyResolver

Remarks

This solves the problem reported in Sandcastle work item #1014. To use the resolver, it must be added to the MRefBuilder.config file by defining the resolver element as shown in the example below. Within the resolver element, add an assemblyBinding element that contains one or more dependentAssembly elements that define the redirections. If you have a set of redirections in an application or web configuration file, you can define a dependentAssembly element with an importFrom attribute that specifies the location of the configuration file from which to import the redirects. The other option is to specify individual redirects using the assemblyIdentity and bindingRedirect child elements of each dependentAssembly element. See the MSDN help for those elements for more information on their usage.
Important Note:
The assembly version(s) to which the entries are redirected must be one of the documented assemblies or must be referenced as a dependency using the /dep command line switch.

Examples

CopySample MRefBuilder.config
<configuration>
  <dduetools>
    <platform version="2.0"
      path="%SystemRoot%\Microsoft.NET\Framework\v2.0.50727\" />

    <!-- Replace the resolver element with this.  Update the path
         to point to the location of the assembly on your system. -->
    <resolver type="SandcastleBuilder.Components.BindingRedirectResolver"
        assembly="C:\SandcastleBuilder\SandcastleBuilder.MRefBuilder.dll"
        use-gac="false">

      <!-- Add an assemblyBinding element to contain the redirects -->
      <assemblyBinding>
        <!-- Import bindings from an application or web config file -->
        <dependentAssembly importFrom=".\Web.config" />

        <!-- Define a redirect for a range of versions -->
        <dependentAssembly>
          <assemblyIdentity name="NationalInstruments.Common"
              publicKeyToken="4544464cdeaab541" />
          <bindingRedirect oldVersion="1.0.0.0-8.1.20.168"
              newVersion="8.1.20.237" />
        </dependentAssembly>

        <!-- Define a redirect for a single version -->
        <dependentAssembly>
          <assemblyIdentity name="MyCompany.Util.ComponentFactory"
              publicKeyToken="E1458197622051B1" culture="neutral"/>
          <bindingRedirect oldVersion="1.2.3.4"
              newVersion="2.1.4.3"/>
        </dependentAssembly>

      </assemblyBinding>
    </resolver>

    <!-- ... rest of MRefBuilder.config ... -->

  </dduetools>
</configuration>

Inheritance Hierarchy

System..::.Object
Microsoft.Ddue.Tools.Reflection..::.AssemblyResolver
SandcastleBuilder.Components..::.BindingRedirectResolver

See Also

BindingRedirectResolver Members
SandcastleBuilder.Components Namespace


BindingRedirectResolver Members

[image] [image]

Sandcastle Help File Builder Documentation
BindingRedirectResolver Members
BindingRedirectResolver Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BindingRedirectResolver type exposes the following members.

Constructors

Name | Description
BindingRedirectResolver | Constructor

Methods

Name | Description
Add | (Inherited from AssemblyResolver.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnUnresolvedAssemblyReference | (Inherited from AssemblyResolver.)
ResolveReference | This is overridden to resolve unknown assembly references (Overrides AssemblyResolver..::.ResolveReference(AssemblyReference, Module).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
UseGac | (Inherited from AssemblyResolver.)

Events

Name | Description
UnresolvedAssemblyReference | (Inherited from AssemblyResolver.)

See Also

BindingRedirectResolver Class
SandcastleBuilder.Components Namespace


BindingRedirectResolver Constructor

[image]

Sandcastle Help File Builder Documentation
BindingRedirectResolver Constructor
BindingRedirectResolver Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.MRefBuilder (in SandcastleBuilder.MRefBuilder.dll) Version: 1.8.0.2

Syntax

C#
public BindingRedirectResolver(
    XPathNavigator configuration
)
Visual Basic (Declaration)
Public Sub New ( _
    configuration As XPathNavigator _
)

Parameters

configuration
Type: System.Xml.XPath..::.XPathNavigator
The configuration navigator

See Also

BindingRedirectResolver Class
SandcastleBuilder.Components Namespace


BindingRedirectResolver Methods

[image] [image]

Sandcastle Help File Builder Documentation
BindingRedirectResolver Methods
BindingRedirectResolver Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BindingRedirectResolver type exposes the following members.

Methods

Name | Description
Add | (Inherited from AssemblyResolver.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnUnresolvedAssemblyReference | (Inherited from AssemblyResolver.)
ResolveReference | This is overridden to resolve unknown assembly references (Overrides AssemblyResolver..::.ResolveReference(AssemblyReference, Module).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BindingRedirectResolver Class
SandcastleBuilder.Components Namespace


ResolveReference Method

[image]

Sandcastle Help File Builder Documentation
BindingRedirectResolver..::.ResolveReference Method
BindingRedirectResolver Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is overridden to resolve unknown assembly references

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.MRefBuilder (in SandcastleBuilder.MRefBuilder.dll) Version: 1.8.0.2

Syntax

C#
public override AssemblyNode ResolveReference(
    AssemblyReference reference,
    Module module
)
Visual Basic (Declaration)
Public Overrides Function ResolveReference ( _
    reference As AssemblyReference, _
    module As Module _
) As AssemblyNode

Parameters

reference
Type: System.Compiler..::.AssemblyReference
The reference to resolve
module
Type: System.Compiler..::.Module
The module

Return Value

The assembly node if resolved or null if not resolved

See Also

BindingRedirectResolver Class
SandcastleBuilder.Components Namespace


BindingRedirectResolver Properties

[image] [image]

Sandcastle Help File Builder Documentation
BindingRedirectResolver Properties
BindingRedirectResolver Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BindingRedirectResolver type exposes the following members.

Properties

Name | Description
UseGac | (Inherited from AssemblyResolver.)

See Also

BindingRedirectResolver Class
SandcastleBuilder.Components Namespace


BindingRedirectResolver Events

[image] [image]

Sandcastle Help File Builder Documentation
BindingRedirectResolver Events
BindingRedirectResolver Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BindingRedirectResolver type exposes the following members.

Events

Name | Description
UnresolvedAssemblyReference | (Inherited from AssemblyResolver.)

See Also

BindingRedirectResolver Class
SandcastleBuilder.Components Namespace


BindingRedirectSettings Class

[image]

Sandcastle Help File Builder Documentation
BindingRedirectSettings Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This represents binding redirection settings for the BindingRedirectResolver.

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.MRefBuilder (in SandcastleBuilder.MRefBuilder.dll) Version: 1.8.0.2

Syntax

C#
public class BindingRedirectSettings
Visual Basic (Declaration)
Public Class BindingRedirectSettings

Inheritance Hierarchy

System..::.Object
SandcastleBuilder.Components..::.BindingRedirectSettings

See Also

BindingRedirectSettings Members
SandcastleBuilder.Components Namespace


BindingRedirectSettings Members

[image] [image]

Sandcastle Help File Builder Documentation
BindingRedirectSettings Members
BindingRedirectSettings Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BindingRedirectSettings type exposes the following members.

Constructors

Name | Description
BindingRedirectSettings | Constructor

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromConfigFile | Load assembly binding redirects from a configuration file.
FromXPathNavigator | Create a binding redirect settings instance from an XPath navigator containing the settings.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsRedirectFor | This is used to determine whether or not this entry is a redirect for the given strong name
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | This returns a string representation of the item (Overrides Object..::.ToString()()().)

Properties

Name | Description
AssemblyName | This is used to get or set the assembly name (no extension)
ConfigurationFile | This is used to get or set the path to the configuration file from which the settings should be imported.
Culture | This is used to get or set the culture for the assembly
NewVersion | This is used to get or set the new version number to which the old versions are redirected.
OldVersion | This is used to get or set the old version number to redirect to the new version number.
OldVersionTo | This is used to get or set the ending old version number range to redirect to the new version number.
PublicKeyToken | This is used to get or set the public key token for the assembly
StrongName | This returns the strong name for the redirect assembly

See Also

BindingRedirectSettings Class
SandcastleBuilder.Components Namespace


BindingRedirectSettings Constructor

[image]

Sandcastle Help File Builder Documentation
BindingRedirectSettings Constructor
BindingRedirectSettings Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.MRefBuilder (in SandcastleBuilder.MRefBuilder.dll) Version: 1.8.0.2

Syntax

C#
public BindingRedirectSettings()
Visual Basic (Declaration)
Public Sub New

See Also

BindingRedirectSettings Class
SandcastleBuilder.Components Namespace


BindingRedirectSettings Methods

[image] [image]

Sandcastle Help File Builder Documentation
BindingRedirectSettings Methods
BindingRedirectSettings Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BindingRedirectSettings type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromConfigFile | Load assembly binding redirects from a configuration file.
FromXPathNavigator | Create a binding redirect settings instance from an XPath navigator containing the settings.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsRedirectFor | This is used to determine whether or not this entry is a redirect for the given strong name
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | This returns a string representation of the item (Overrides Object..::.ToString()()().)

See Also

BindingRedirectSettings Class
SandcastleBuilder.Components Namespace


FromConfigFile Method

[image]

Sandcastle Help File Builder Documentation
BindingRedirectSettings..::.FromConfigFile Method
BindingRedirectSettings Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Load assembly binding redirects from a configuration file.

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.MRefBuilder (in SandcastleBuilder.MRefBuilder.dll) Version: 1.8.0.2

Syntax

C#
public static Collection<BindingRedirectSettings> FromConfigFile(
    string configFile
)
Visual Basic (Declaration)
Public Shared Function FromConfigFile ( _
    configFile As String _
) As Collection(Of BindingRedirectSettings)

Parameters

configFile
Type: System..::.String
The configuration filename

Return Value

A collection containing the assembly binding redirects

See Also

BindingRedirectSettings Class
SandcastleBuilder.Components Namespace


FromXPathNavigator Method

[image]

Sandcastle Help File Builder Documentation
BindingRedirectSettings..::.FromXPathNavigator Method
BindingRedirectSettings Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Create a binding redirect settings instance from an XPath navigator containing the settings.

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.MRefBuilder (in SandcastleBuilder.MRefBuilder.dll) Version: 1.8.0.2

Syntax

C#
public static BindingRedirectSettings FromXPathNavigator(
    XPathNavigator navigator,
    IXmlNamespaceResolver resolver,
    string namespacePrefix
)
Visual Basic (Declaration)
Public Shared Function FromXPathNavigator ( _
    navigator As XPathNavigator, _
    resolver As IXmlNamespaceResolver, _
    namespacePrefix As String _
) As BindingRedirectSettings

Parameters

navigator
Type: System.Xml.XPath..::.XPathNavigator
The XPath navigator from which to obtain the settings.
resolver
Type: System.Xml..::.IXmlNamespaceResolver
An optional namespace resolver. Pass null if one is not needed.
namespacePrefix
Type: System..::.String
The namespace to prefix the elements with if needed. This is ignored if resolver is null.

Return Value

A BindingRedirectSettings object containing the settings from the XPath navigator.

Remarks

It should contain an element called dependentAssembly with a configFile attribute or a nested assemblyIdentity and bindingRedirect element that define the settings.

See Also

BindingRedirectSettings Class
SandcastleBuilder.Components Namespace


IsRedirectFor Method

[image]

Sandcastle Help File Builder Documentation
BindingRedirectSettings..::.IsRedirectFor Method
BindingRedirectSettings Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to determine whether or not this entry is a redirect for the given strong name

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.MRefBuilder (in SandcastleBuilder.MRefBuilder.dll) Version: 1.8.0.2

Syntax

C#
public bool IsRedirectFor(
    string strongName
)
Visual Basic (Declaration)
Public Function IsRedirectFor ( _
    strongName As String _
) As Boolean

Parameters

strongName
Type: System..::.String
The strong name to compare

Return Value

True if it is a redirect for the strong name, false if not

See Also

BindingRedirectSettings Class
SandcastleBuilder.Components Namespace


ToString Method

[image]

Sandcastle Help File Builder Documentation
BindingRedirectSettings..::.ToString Method
BindingRedirectSettings Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This returns a string representation of the item

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.MRefBuilder (in SandcastleBuilder.MRefBuilder.dll) Version: 1.8.0.2

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

Return Value

The item value as a string

See Also

BindingRedirectSettings Class
SandcastleBuilder.Components Namespace


BindingRedirectSettings Properties

[image] [image]

Sandcastle Help File Builder Documentation
BindingRedirectSettings Properties
BindingRedirectSettings Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BindingRedirectSettings type exposes the following members.

Properties

Name | Description
AssemblyName | This is used to get or set the assembly name (no extension)
ConfigurationFile | This is used to get or set the path to the configuration file from which the settings should be imported.
Culture | This is used to get or set the culture for the assembly
NewVersion | This is used to get or set the new version number to which the old versions are redirected.
OldVersion | This is used to get or set the old version number to redirect to the new version number.
OldVersionTo | This is used to get or set the ending old version number range to redirect to the new version number.
PublicKeyToken | This is used to get or set the public key token for the assembly
StrongName | This returns the strong name for the redirect assembly

See Also

BindingRedirectSettings Class
SandcastleBuilder.Components Namespace


AssemblyName Property

[image]

Sandcastle Help File Builder Documentation
BindingRedirectSettings..::.AssemblyName Property
BindingRedirectSettings Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set the assembly name (no extension)

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.MRefBuilder (in SandcastleBuilder.MRefBuilder.dll) Version: 1.8.0.2

Syntax

C#
public string AssemblyName { get; set; }
Visual Basic (Declaration)
Public Property AssemblyName As String

See Also

BindingRedirectSettings Class
SandcastleBuilder.Components Namespace


ConfigurationFile Property

[image]

Sandcastle Help File Builder Documentation
BindingRedirectSettings..::.ConfigurationFile Property
BindingRedirectSettings Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set the path to the configuration file from which the settings should be imported.

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.MRefBuilder (in SandcastleBuilder.MRefBuilder.dll) Version: 1.8.0.2

Syntax

C#
public string ConfigurationFile { get; set; }
Visual Basic (Declaration)
Public Property ConfigurationFile As String

Field Value

If specified, the properties in the Binding Redirect category are ignored.

See Also

BindingRedirectSettings Class
SandcastleBuilder.Components Namespace


Culture Property

[image]

Sandcastle Help File Builder Documentation
BindingRedirectSettings..::.Culture Property
BindingRedirectSettings Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set the culture for the assembly

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.MRefBuilder (in SandcastleBuilder.MRefBuilder.dll) Version: 1.8.0.2

Syntax

C#
public string Culture { get; set; }
Visual Basic (Declaration)
Public Property Culture As String

Field Value

If omitted, "neutral" is assumed

See Also

BindingRedirectSettings Class
SandcastleBuilder.Components Namespace


NewVersion Property

[image]

Sandcastle Help File Builder Documentation
BindingRedirectSettings..::.NewVersion Property
BindingRedirectSettings Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set the new version number to which the old versions are redirected.

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.MRefBuilder (in SandcastleBuilder.MRefBuilder.dll) Version: 1.8.0.2

Syntax

C#
public Version NewVersion { get; set; }
Visual Basic (Declaration)
Public Property NewVersion As Version

See Also

BindingRedirectSettings Class
SandcastleBuilder.Components Namespace


OldVersion Property

[image]

Sandcastle Help File Builder Documentation
BindingRedirectSettings..::.OldVersion Property
BindingRedirectSettings Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set the old version number to redirect to the new version number.

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.MRefBuilder (in SandcastleBuilder.MRefBuilder.dll) Version: 1.8.0.2

Syntax

C#
public Version OldVersion { get; set; }
Visual Basic (Declaration)
Public Property OldVersion As Version

See Also

BindingRedirectSettings Class
SandcastleBuilder.Components Namespace


OldVersionTo Property

[image]

Sandcastle Help File Builder Documentation
BindingRedirectSettings..::.OldVersionTo Property
BindingRedirectSettings Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set the ending old version number range to redirect to the new version number.

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.MRefBuilder (in SandcastleBuilder.MRefBuilder.dll) Version: 1.8.0.2

Syntax

C#
public Version OldVersionTo { get; set; }
Visual Basic (Declaration)
Public Property OldVersionTo As Version

Field Value

If not set, only OldVersion will be used to redirect a single version.

See Also

BindingRedirectSettings Class
SandcastleBuilder.Components Namespace


PublicKeyToken Property

[image]

Sandcastle Help File Builder Documentation
BindingRedirectSettings..::.PublicKeyToken Property
BindingRedirectSettings Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set the public key token for the assembly

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.MRefBuilder (in SandcastleBuilder.MRefBuilder.dll) Version: 1.8.0.2

Syntax

C#
public string PublicKeyToken { get; set; }
Visual Basic (Declaration)
Public Property PublicKeyToken As String

Field Value

If omitted, "null" is assumed

See Also

BindingRedirectSettings Class
SandcastleBuilder.Components Namespace


StrongName Property

[image]

Sandcastle Help File Builder Documentation
BindingRedirectSettings..::.StrongName Property
BindingRedirectSettings Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This returns the strong name for the redirect assembly

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.MRefBuilder (in SandcastleBuilder.MRefBuilder.dll) Version: 1.8.0.2

Syntax

C#
public string StrongName { get; }
Visual Basic (Declaration)
Public ReadOnly Property StrongName As String

See Also

BindingRedirectSettings Class
SandcastleBuilder.Components Namespace


CachedCopyFromIndexComponent Class

[image]

Sandcastle Help File Builder Documentation
CachedCopyFromIndexComponent Class
Members Example See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is a derived CopyFromIndexComponent class that loads the index document cache from a serialized binary file rather than loading it from the XML reflection data files. This can significantly decrease the amount of time needed to instantiate the component.

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.Components (in SandcastleBuilder.Components.dll) Version: 1.8.0.2

Syntax

C#
public class CachedCopyFromIndexComponent : CopyFromIndexComponent
Visual Basic (Declaration)
Public Class CachedCopyFromIndexComponent _
    Inherits CopyFromIndexComponent

Examples

CopyCached Reflection Index Data Example
<!-- Cached Reflection Index Data component.  This should replace
     the first instance of the CopyFromIndexComponent. -->
<component id="Cached Reflection Index Data"
  type="SandcastleBuilder.Components.CachedCopyFromIndexComponent"
  assembly="C:\SandcastleBuilder\SandcastleBuilder.Components.dll">
    <index name="reflection" value="/reflection/apis/api"
       key="@id" cache="10">
        <cache base="C:\Program Files\Sandcastle\Data\Reflection"
            recurse="true" files="*.xml"
            cacheFile="C:\SandcastleBuilder\Cache\Reflection.cache"/>
        <data files="reflection.xml" />
    </index>
    <copy name="reflection" source="*" target="/document/reference" />
</component>
CopyCached Framework Comments Index Data Example
<!-- Cached Framework Comments Index Data component.  This should
     replace the third instance of the CopyFromIndexComponent. -->
<component id="Cached Framework Comments Index Data"
  type="SandcastleBuilder.Components.CachedCopyFromIndexComponent"
  assembly="C:\SandcastleBuilder\SandcastleBuilder.Components.dll">
    <index name="comments" value="/doc/members/member"
      key="@name" cache="100">
      <cache files="%SystemRoot%\Microsoft.NET\Framework\v2.0.50727\en\*.xml"
        cacheFile="C:\SandcastleBuilder\Cache\en_2.0.50727.cache" />
      <data files="ExtraComments.xml" />
      <data files="TestDoc.xml" />
      <data files="_InheritedDocs_.xml" />
    </index>
    <copy name="comments" source="*" target="/document/comments" />
</component>

Inheritance Hierarchy

System..::.Object
Microsoft.Ddue.Tools..::.BuildComponent
Microsoft.Ddue.Tools..::.CopyFromIndexComponent
SandcastleBuilder.Components..::.CachedCopyFromIndexComponent

See Also

CachedCopyFromIndexComponent Members
SandcastleBuilder.Components Namespace


CachedCopyFromIndexComponent Members

[image] [image]

Sandcastle Help File Builder Documentation
CachedCopyFromIndexComponent Members
CachedCopyFromIndexComponent Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The CachedCopyFromIndexComponent type exposes the following members.

Constructors

Name | Description
CachedCopyFromIndexComponent | Constructor

Methods

Name | Description
Apply | Overloaded.
Dispose | This is used in the debug build to get an idea of how many files were kept loaded in the cache. (Overrides BuildComponent..::.Dispose()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnComponentEvent | (Inherited from BuildComponent.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteMessage | (Inherited from BuildComponent.)

Properties

Name | Description
BuildAssembler | (Inherited from BuildComponent.)

See Also

CachedCopyFromIndexComponent Class
SandcastleBuilder.Components Namespace


CachedCopyFromIndexComponent Constructor

[image]

Sandcastle Help File Builder Documentation
CachedCopyFromIndexComponent Constructor
CachedCopyFromIndexComponent Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.Components (in SandcastleBuilder.Components.dll) Version: 1.8.0.2

Syntax

C#
public CachedCopyFromIndexComponent(
    BuildAssembler assembler,
    XPathNavigator configuration
)
Visual Basic (Declaration)
Public Sub New ( _
    assembler As BuildAssembler, _
    configuration As XPathNavigator _
)

Parameters

assembler
Type: Microsoft.Ddue.Tools..::.BuildAssembler
A reference to the build assembler.
configuration
Type: System.Xml.XPath..::.XPathNavigator
The configuration information

Exceptions

Exception | Condition
System.Configuration..::.ConfigurationErrorsException | This is thrown if an error is detected in the configuration.

See Also

CachedCopyFromIndexComponent Class
SandcastleBuilder.Components Namespace


CachedCopyFromIndexComponent Methods

[image] [image]

Sandcastle Help File Builder Documentation
CachedCopyFromIndexComponent Methods
CachedCopyFromIndexComponent Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The CachedCopyFromIndexComponent type exposes the following members.

Methods

Name | Description
Apply | Overloaded.
Dispose | This is used in the debug build to get an idea of how many files were kept loaded in the cache. (Overrides BuildComponent..::.Dispose()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnComponentEvent | (Inherited from BuildComponent.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteMessage | (Inherited from BuildComponent.)

See Also

CachedCopyFromIndexComponent Class
SandcastleBuilder.Components Namespace


Apply Method

[image] [image]

Sandcastle Help File Builder Documentation
CachedCopyFromIndexComponent..::.Apply Method
CachedCopyFromIndexComponent Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Apply(XmlDocument) | (Inherited from BuildComponent.)
Apply(XmlDocument, String) | (Inherited from CopyFromIndexComponent.)

See Also

CachedCopyFromIndexComponent Class
CachedCopyFromIndexComponent Members
SandcastleBuilder.Components Namespace


Dispose Method

[image]

Sandcastle Help File Builder Documentation
CachedCopyFromIndexComponent..::.Dispose Method
CachedCopyFromIndexComponent Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used in the debug build to get an idea of how many files were kept loaded in the cache.

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.Components (in SandcastleBuilder.Components.dll) Version: 1.8.0.2

Syntax

C#
public override void Dispose()
Visual Basic (Declaration)
Public Overrides Sub Dispose

Implements

IDisposable..::.Dispose()()()

See Also

CachedCopyFromIndexComponent Class
SandcastleBuilder.Components Namespace


CachedCopyFromIndexComponent Properties

[image] [image]

Sandcastle Help File Builder Documentation
CachedCopyFromIndexComponent Properties
CachedCopyFromIndexComponent Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The CachedCopyFromIndexComponent type exposes the following members.

Properties

Name | Description
BuildAssembler | (Inherited from BuildComponent.)

See Also

CachedCopyFromIndexComponent Class
SandcastleBuilder.Components Namespace


CachedResolveReferenceLinksComponent Class

[image]

Sandcastle Help File Builder Documentation
CachedResolveReferenceLinksComponent Class
Members Example See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is a derived ResolveReferenceLinksComponent2 class that loads cached MSDN URLs from a serialized binary file rather than letting the base component invoke the web service to look them up. This can significantly decrease the amount of time needed to perform a build.

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.Components (in SandcastleBuilder.Components.dll) Version: 1.8.0.2

Syntax

C#
public class CachedResolveReferenceLinksComponent : ResolveReferenceLinksComponent2
Visual Basic (Declaration)
Public Class CachedResolveReferenceLinksComponent _
    Inherits ResolveReferenceLinksComponent2

Remarks

The cache is built cumulatively over time rather than having all 170,000+ resolved entries loaded, most of which would never be used. If new URLs are added to the cache during a build, the cache is saved during disposal so that the new entries are used on subsequent builds.

Examples

CopyExample configuration
<!-- Cached MSDN URL references component.  This should replace
     the standard ResolveReferenceLinksComponent2 build component. -->
<component type="SandcastleBuilder.Components.CachedResolveReferenceLinksComponent"
  assembly="C:\SandcastleBuilder\SandcastleBuilder.Components.dll"
  locale="en-us" linkTarget="_blank">
    <cache filename="C:\SandcastleBuilder\Cache\MsdnUrl.cache" />
    <targets base="C:\Program Files\Sandcastle\Data\Reflection"
        recurse="true" files="*.xml" type="MSDN" />
    <targets files="reflection.xml" type="Local" />
</component>

Inheritance Hierarchy

System..::.Object
Microsoft.Ddue.Tools..::.BuildComponent
Microsoft.Ddue.Tools..::.ResolveReferenceLinksComponent2
SandcastleBuilder.Components..::.CachedResolveReferenceLinksComponent

See Also

CachedResolveReferenceLinksComponent Members
SandcastleBuilder.Components Namespace


CachedResolveReferenceLinksComponent Members

[image] [image]

Sandcastle Help File Builder Documentation
CachedResolveReferenceLinksComponent Members
CachedResolveReferenceLinksComponent Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The CachedResolveReferenceLinksComponent type exposes the following members.

Constructors

Name | Description
CachedResolveReferenceLinksComponent | Constructor

Methods

Name | Description
Apply | Overloaded.
Dispose | This is overriden to save the updated cache when disposed (Overrides BuildComponent..::.Dispose()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnComponentEvent | (Inherited from BuildComponent.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteMessage | (Inherited from BuildComponent.)

Properties

Name | Description
BuildAssembler | (Inherited from BuildComponent.)

See Also

CachedResolveReferenceLinksComponent Class
SandcastleBuilder.Components Namespace


CachedResolveReferenceLinksComponent Constructor

[image]

Sandcastle Help File Builder Documentation
CachedResolveReferenceLinksComponent Constructor
CachedResolveReferenceLinksComponent Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.Components (in SandcastleBuilder.Components.dll) Version: 1.8.0.2

Syntax

C#
public CachedResolveReferenceLinksComponent(
    BuildAssembler assembler,
    XPathNavigator configuration
)
Visual Basic (Declaration)
Public Sub New ( _
    assembler As BuildAssembler, _
    configuration As XPathNavigator _
)

Parameters

assembler
Type: Microsoft.Ddue.Tools..::.BuildAssembler
A reference to the build assembler.
configuration
Type: System.Xml.XPath..::.XPathNavigator
The configuration information

Exceptions

Exception | Condition
System.Configuration..::.ConfigurationErrorsException | This is thrown if an error is detected in the configuration.

See Also

CachedResolveReferenceLinksComponent Class
SandcastleBuilder.Components Namespace


CachedResolveReferenceLinksComponent Methods

[image] [image]

Sandcastle Help File Builder Documentation
CachedResolveReferenceLinksComponent Methods
CachedResolveReferenceLinksComponent Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The CachedResolveReferenceLinksComponent type exposes the following members.

Methods

Name | Description
Apply | Overloaded.
Dispose | This is overriden to save the updated cache when disposed (Overrides BuildComponent..::.Dispose()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnComponentEvent | (Inherited from BuildComponent.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteMessage | (Inherited from BuildComponent.)

See Also

CachedResolveReferenceLinksComponent Class
SandcastleBuilder.Components Namespace


Apply Method

[image] [image]

Sandcastle Help File Builder Documentation
CachedResolveReferenceLinksComponent..::.Apply Method
CachedResolveReferenceLinksComponent Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Apply(XmlDocument) | (Inherited from BuildComponent.)
Apply(XmlDocument, String) | (Inherited from ResolveReferenceLinksComponent2.)

See Also

CachedResolveReferenceLinksComponent Class
CachedResolveReferenceLinksComponent Members
SandcastleBuilder.Components Namespace


Dispose Method

[image]

Sandcastle Help File Builder Documentation
CachedResolveReferenceLinksComponent..::.Dispose Method
CachedResolveReferenceLinksComponent Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is overriden to save the updated cache when disposed

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.Components (in SandcastleBuilder.Components.dll) Version: 1.8.0.2

Syntax

C#
public override void Dispose()
Visual Basic (Declaration)
Public Overrides Sub Dispose

Implements

IDisposable..::.Dispose()()()

See Also

CachedResolveReferenceLinksComponent Class
SandcastleBuilder.Components Namespace


CachedResolveReferenceLinksComponent Properties

[image] [image]

Sandcastle Help File Builder Documentation
CachedResolveReferenceLinksComponent Properties
CachedResolveReferenceLinksComponent Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The CachedResolveReferenceLinksComponent type exposes the following members.

Properties

Name | Description
BuildAssembler | (Inherited from BuildComponent.)

See Also

CachedResolveReferenceLinksComponent Class
SandcastleBuilder.Components Namespace


CodeBlockComponent Class

[image]

Sandcastle Help File Builder Documentation
CodeBlockComponent Class
Members Example See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This build component is used to search for <code> XML comment tags and colorize the code within them. It can also include code from an external file or a region within the file.

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.Components (in SandcastleBuilder.Components.dll) Version: 1.8.0.2

Syntax

C#
public class CodeBlockComponent : BuildComponent
Visual Basic (Declaration)
Public Class CodeBlockComponent _
    Inherits BuildComponent

Remarks

Note that this component must be paired with the PostTransformComponent.

Examples

CopyExample configuration
<!-- Code block component configuration.  This must appear before
     the TransformComponent.  See also: PostTransformComponent. -->
<component type="SandcastleBuilder.Components.CodeBlockComponent"
  assembly="C:\SandcastleBuilder\SandcastleBuilder.Components.dll">
    <!-- Base path for relative filenames in source
         attributes (optional). -->
    <basePath value="..\SandcastleComponents" />

    <!-- Connect to language filter (optional).  If omitted,
         language filtering is enabled by default. -->
    <languageFilter value="true" />

    <!-- Allow missing source files (Optional).  If omitted,
         it will generate errors if referenced source files
         are missing. -->
    <allowMissingSource value="false" />

    <!-- Remove region markers from imported code blocks.  If omitted,
         region markers in imported code blocks are left alone. -->
    <removeRegionMarkers value="false" />

    <!-- Code colorizer options (required).
      Attributes:
        Language syntax configuration file (required)
        XSLT style file (required)
        "Copy" image file URL (required)
        Default language (optional)
        Enable line numbering (optional)
        Enable outlining (optional)
        Keep XML comment "see" tags within the code (optional)
        Tab size for unknown languages (optional, 0 = use default)
        Use language name as default title (optional) -->
    <colorizer syntaxFile="highlight.xml" styleFile="highlight.xsl"
      copyImageUrl="CopyCode.gif" language="cs" numberLines="false"
      outlining="false" keepSeeTags="false" tabSize="0"
      defaultTitle="true" />
</component>
CopyExamples as used in XML comments.
<example>
A basic code block that uses the configuration defaults:
<code>
/// Code to colorize
</code>

Override options with block-specific options:
<code lang="xml" numberLines="true" outlining="false" tabSize="8" >
    &lt;XmlTags/&gt;
</code>

An entire external file or a delimited region from it can be
included.  This allows you to compile your example code externally
to ensure that it is still valid and saves you from maintaining it
in two places.

Retrieve all code from an external file.  Use VB.NET syntax.
<code source="..\Examples\WholeDemo.vb" lang="vbnet"/>

Retrieve a specific #region from an external file.
<code source="..\Examples\SeveralExamples.vb"
    region="Example 1" lang="vbnet"/>

Keep <see> tags within comments so that they are converted to
links to the help topics.
<code keepSeeTags="true">
int x = this.<see cref="CountStuff">CountStuff</see>(true);

string value = this.<see cref="System.Object.ToString">
<code>

<example>

Inheritance Hierarchy

System..::.Object
Microsoft.Ddue.Tools..::.BuildComponent
SandcastleBuilder.Components..::.CodeBlockComponent

See Also

CodeBlockComponent Members
SandcastleBuilder.Components Namespace


CodeBlockComponent Members

[image] [image]

Sandcastle Help File Builder Documentation
CodeBlockComponent Members
CodeBlockComponent Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The CodeBlockComponent type exposes the following members.

Constructors

Name | Description
CodeBlockComponent | Constructor

Methods

Name | Description
Apply | Overloaded.
ConfigureComponent | This static method is used by the Sandcastle Help File Builder to let the component perform its own configuration.
Dispose | (Inherited from BuildComponent.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnComponentEvent | (Inherited from BuildComponent.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteMessage | (Inherited from BuildComponent.)

Properties

Name | Description
BuildAssembler | (Inherited from BuildComponent.)
ColorizedCodeBlocks | This is used by the PostTransformComponent to insert the colorized code blocks.
CopyImageLocation | This is used by the PostTransformComponent to get the destination location and filename of the "Copy" image.
CopyText | This is used by the PostTransformComponent to get the "Copy" text so that it can be replaced with an include item.

See Also

CodeBlockComponent Class
SandcastleBuilder.Components Namespace


CodeBlockComponent Constructor

[image]

Sandcastle Help File Builder Documentation
CodeBlockComponent Constructor
CodeBlockComponent Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.Components (in SandcastleBuilder.Components.dll) Version: 1.8.0.2

Syntax

C#
public CodeBlockComponent(
    BuildAssembler assembler,
    XPathNavigator configuration
)
Visual Basic (Declaration)
Public Sub New ( _
    assembler As BuildAssembler, _
    configuration As XPathNavigator _
)

Parameters

assembler
Type: Microsoft.Ddue.Tools..::.BuildAssembler
A reference to the build assembler.
configuration
Type: System.Xml.XPath..::.XPathNavigator
The configuration information

Remarks

NOTE: This component must be paired with the PostTransformComponent. See the CodeBlockComponent class topic for an example of the configuration and usage.

Exceptions

Exception | Condition
System.Configuration..::.ConfigurationErrorsException | This is thrown if an error is detected in the configuration.

See Also

CodeBlockComponent Class
SandcastleBuilder.Components Namespace


CodeBlockComponent Methods

[image] [image]

Sandcastle Help File Builder Documentation
CodeBlockComponent Methods
CodeBlockComponent Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The CodeBlockComponent type exposes the following members.

Methods

Name | Description
Apply | Overloaded.
ConfigureComponent | This static method is used by the Sandcastle Help File Builder to let the component perform its own configuration.
Dispose | (Inherited from BuildComponent.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnComponentEvent | (Inherited from BuildComponent.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteMessage | (Inherited from BuildComponent.)

See Also

CodeBlockComponent Class
SandcastleBuilder.Components Namespace


Apply Method

[image] [image]

Sandcastle Help File Builder Documentation
CodeBlockComponent..::.Apply Method
CodeBlockComponent Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Apply(XmlDocument) | (Inherited from BuildComponent.)
Apply(XmlDocument, String) | This is implemented to perform the code colorization. (Overrides BuildComponent..::.Apply(XmlDocument, String).)

See Also

CodeBlockComponent Class
CodeBlockComponent Members
SandcastleBuilder.Components Namespace


Apply Method (XmlDocument, String)

[image]

Sandcastle Help File Builder Documentation
CodeBlockComponent..::.Apply Method (XmlDocument, String)
CodeBlockComponent Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is implemented to perform the code colorization.

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.Components (in SandcastleBuilder.Components.dll) Version: 1.8.0.2

Syntax

C#
public override void Apply(
    XmlDocument document,
    string key
)
Visual Basic (Declaration)
Public Overrides Sub Apply ( _
    document As XmlDocument, _
    key As String _
)

Parameters

document
Type: System.Xml..::.XmlDocument
The XML document with which to work.
key
Type: System..::.String
The key (member name) of the item being documented.

See Also

CodeBlockComponent Class
Apply Overload
SandcastleBuilder.Components Namespace


ConfigureComponent Method

[image]

Sandcastle Help File Builder Documentation
CodeBlockComponent..::.ConfigureComponent Method
CodeBlockComponent Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This static method is used by the Sandcastle Help File Builder to let the component perform its own configuration.

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.Components (in SandcastleBuilder.Components.dll) Version: 1.8.0.2

Syntax

C#
public static string ConfigureComponent(
    string currentConfig
)
Visual Basic (Declaration)
Public Shared Function ConfigureComponent ( _
    currentConfig As String _
) As String

Parameters

currentConfig
Type: System..::.String
The current configuration XML fragment

Return Value

A string containing the new configuration XML fragment

See Also

CodeBlockComponent Class
SandcastleBuilder.Components Namespace


CodeBlockComponent Properties

[image] [image]

Sandcastle Help File Builder Documentation
CodeBlockComponent Properties
CodeBlockComponent Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The CodeBlockComponent type exposes the following members.

Properties

Name | Description
BuildAssembler | (Inherited from BuildComponent.)
ColorizedCodeBlocks | This is used by the PostTransformComponent to insert the colorized code blocks.
CopyImageLocation | This is used by the PostTransformComponent to get the destination location and filename of the "Copy" image.
CopyText | This is used by the PostTransformComponent to get the "Copy" text so that it can be replaced with an include item.

See Also

CodeBlockComponent Class
SandcastleBuilder.Components Namespace


ColorizedCodeBlocks Property

[image]

Sandcastle Help File Builder Documentation
CodeBlockComponent..::.ColorizedCodeBlocks Property
CodeBlockComponent Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used by the PostTransformComponent to insert the colorized code blocks.

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.Components (in SandcastleBuilder.Components.dll) Version: 1.8.0.2

Syntax

C#
public static Dictionary<string, XmlNode> ColorizedCodeBlocks { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ColorizedCodeBlocks As Dictionary(Of String, XmlNode)

Remarks

The colorized code blocks contain HTML which isn't supported by conceptual topics pre-transformation. As such, we hold onto them here and use a placeholder ID. The post-transform component will replace the placeholder ID with the actual colorized code block.

See Also

CodeBlockComponent Class
SandcastleBuilder.Components Namespace


CopyImageLocation Property

[image]

Sandcastle Help File Builder Documentation
CodeBlockComponent..::.CopyImageLocation Property
CodeBlockComponent Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used by the PostTransformComponent to get the destination location and filename of the "Copy" image.

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.Components (in SandcastleBuilder.Components.dll) Version: 1.8.0.2

Syntax

C#
public static string CopyImageLocation { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CopyImageLocation As String

See Also

CodeBlockComponent Class
SandcastleBuilder.Components Namespace


CopyText Property

[image]

Sandcastle Help File Builder Documentation
CodeBlockComponent..::.CopyText Property
CodeBlockComponent Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used by the PostTransformComponent to get the "Copy" text so that it can be replaced with an include item.

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.Components (in SandcastleBuilder.Components.dll) Version: 1.8.0.2

Syntax

C#
public static string CopyText { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CopyText As String

Remarks

We can't do it here as the TransformComponent strips the <include> tag as it isn't one it recognizes.

See Also

CodeBlockComponent Class
SandcastleBuilder.Components Namespace


ConceptualLinkInfo Class

[image]

Sandcastle Help File Builder Documentation
ConceptualLinkInfo Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is a reimplementation of the ConceptualLinkInfo class used by ResolveConceptualLinksComponent.

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.Components (in SandcastleBuilder.Components.dll) Version: 1.8.0.2

Syntax

C#
public class ConceptualLinkInfo
Visual Basic (Declaration)
Public Class ConceptualLinkInfo

Inheritance Hierarchy

System..::.Object
SandcastleBuilder.Components..::.ConceptualLinkInfo

See Also

ConceptualLinkInfo Members
SandcastleBuilder.Components Namespace


ConceptualLinkInfo Members

[image] [image]

Sandcastle Help File Builder Documentation
ConceptualLinkInfo Members
ConceptualLinkInfo Class Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ConceptualLinkInfo type exposes the following members.

Methods

Name | Description
Create | This is used to create a conceptual link based on the information in the supplied XPath navigator.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Anchor | The optional anchor name within the target
Target | The target of the link
Text | The text to show for the link

See Also

ConceptualLinkInfo Class
SandcastleBuilder.Components Namespace


ConceptualLinkInfo Methods

[image] [image]

Sandcastle Help File Builder Documentation
ConceptualLinkInfo Methods
ConceptualLinkInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ConceptualLinkInfo type exposes the following members.

Methods

Name | Description
Create | This is used to create a conceptual link based on the information in the supplied XPath navigator.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConceptualLinkInfo Class
SandcastleBuilder.Components Namespace


Create Method

[image]

Sandcastle Help File Builder Documentation
ConceptualLinkInfo..::.Create Method
ConceptualLinkInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to create a conceptual link based on the information in the supplied XPath navigator.

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.Components (in SandcastleBuilder.Components.dll) Version: 1.8.0.2

Syntax

C#
public static ConceptualLinkInfo Create(
    XPathNavigator node
)
Visual Basic (Declaration)
Public Shared Function Create ( _
    node As XPathNavigator _
) As ConceptualLinkInfo

Parameters

node
Type: System.Xml.XPath..::.XPathNavigator
The XPath navigator node from which to load the link settings.

Return Value

A conceptual link info object

Exceptions

Exception | Condition
System..::.ArgumentNullException | This is thrown if the node parameters is null.

See Also

ConceptualLinkInfo Class
SandcastleBuilder.Components Namespace


ConceptualLinkInfo Properties

[image] [image]

Sandcastle Help File Builder Documentation
ConceptualLinkInfo Properties
ConceptualLinkInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ConceptualLinkInfo type exposes the following members.

Properties

Name | Description
Anchor | The optional anchor name within the target
Target | The target of the link
Text | The text to show for the link

See Also

ConceptualLinkInfo Class
SandcastleBuilder.Components Namespace


Anchor Property

[image]

Sandcastle Help File Builder Documentation
ConceptualLinkInfo..::.Anchor Property
ConceptualLinkInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The optional anchor name within the target

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.Components (in SandcastleBuilder.Components.dll) Version: 1.8.0.2

Syntax

C#
public string Anchor { get; }
Visual Basic (Declaration)
Public ReadOnly Property Anchor As String

See Also

ConceptualLinkInfo Class
SandcastleBuilder.Components Namespace


Target Property

[image]

Sandcastle Help File Builder Documentation
ConceptualLinkInfo..::.Target Property
ConceptualLinkInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The target of the link

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.Components (in SandcastleBuilder.Components.dll) Version: 1.8.0.2

Syntax

C#
public string Target { get; }
Visual Basic (Declaration)
Public ReadOnly Property Target As String

See Also

ConceptualLinkInfo Class
SandcastleBuilder.Components Namespace


Text Property

[image]

Sandcastle Help File Builder Documentation
ConceptualLinkInfo..::.Text Property
ConceptualLinkInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The text to show for the link

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.Components (in SandcastleBuilder.Components.dll) Version: 1.8.0.2

Syntax

C#
public string Text { get; }
Visual Basic (Declaration)
Public ReadOnly Property Text As String

See Also

ConceptualLinkInfo Class
SandcastleBuilder.Components Namespace


IntelliSenseComponent Class

[image]

Sandcastle Help File Builder Documentation
IntelliSenseComponent Class
Members Example See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This build component is used to generate IntelliSense files based on the documented APIs.

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.Components (in SandcastleBuilder.Components.dll) Version: 1.8.0.2

Syntax

C#
public class IntelliSenseComponent : BuildComponent
Visual Basic (Declaration)
Public Class IntelliSenseComponent _
    Inherits BuildComponent

Remarks

Only the basic set of tags needed for IntelliSense are exported and only for documented API members. This is based on the Microsoft IntelliSense build component. That version only works with Microsoft-specific XML comments files and does not work with general XML comments files created by the compilers.

Examples

CopyExample configuration
<!-- IntelliSense component configuration.  This must appear
     before the TransformComponent. -->
<component type="SandcastleBuilder.Components.IntelliSenseComponent"
  assembly="C:\SandcastleBuilder\SandcastleBuilder.Components.dll">
 <!-- Output options (optional)
      Attributes:
         Include Namespaces (false by default)
         Namespaces filename ("Namespaces" if not specified or empty)
         Directory (current folder if not specified or empty) -->
 <output includeNamespaces="false" namespacesFile="Namespaces"
     folder="C:\ProjectDocs\" />
</component>

Inheritance Hierarchy

System..::.Object
Microsoft.Ddue.Tools..::.BuildComponent
SandcastleBuilder.Components..::.IntelliSenseComponent

See Also

IntelliSenseComponent Members
SandcastleBuilder.Components Namespace


IntelliSenseComponent Members

[image] [image]

Sandcastle Help File Builder Documentation
IntelliSenseComponent Members
IntelliSenseComponent Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IntelliSenseComponent type exposes the following members.

Constructors

Name | Description
IntelliSenseComponent | Constructor.

Methods

Name | Description
Apply | Overloaded.
ConfigureComponent | This static method is used by the Sandcastle Help File Builder to let the component perform its own configuration.
Dispose | Write out closing tags and close all open XML writers when disposed. (Overrides BuildComponent..::.Dispose()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnComponentEvent | (Inherited from BuildComponent.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteMessage | (Inherited from BuildComponent.)

Properties

Name | Description
BuildAssembler | (Inherited from BuildComponent.)

See Also

IntelliSenseComponent Class
SandcastleBuilder.Components Namespace


IntelliSenseComponent Constructor

[image]

Sandcastle Help File Builder Documentation
IntelliSenseComponent Constructor
IntelliSenseComponent Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor.

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.Components (in SandcastleBuilder.Components.dll) Version: 1.8.0.2

Syntax

C#
public IntelliSenseComponent(
    BuildAssembler assembler,
    XPathNavigator configuration
)
Visual Basic (Declaration)
Public Sub New ( _
    assembler As BuildAssembler, _
    configuration As XPathNavigator _
)

Parameters

assembler
Type: Microsoft.Ddue.Tools..::.BuildAssembler
A reference to the build assembler.
configuration
Type: System.Xml.XPath..::.XPathNavigator
The configuration information

See Also

IntelliSenseComponent Class
SandcastleBuilder.Components Namespace


IntelliSenseComponent Methods

[image] [image]

Sandcastle Help File Builder Documentation
IntelliSenseComponent Methods
IntelliSenseComponent Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IntelliSenseComponent type exposes the following members.

Methods

Name | Description
Apply | Overloaded.
ConfigureComponent | This static method is used by the Sandcastle Help File Builder to let the component perform its own configuration.
Dispose | Write out closing tags and close all open XML writers when disposed. (Overrides BuildComponent..::.Dispose()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnComponentEvent | (Inherited from BuildComponent.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteMessage | (Inherited from BuildComponent.)

See Also

IntelliSenseComponent Class
SandcastleBuilder.Components Namespace


Apply Method

[image] [image]

Sandcastle Help File Builder Documentation
IntelliSenseComponent..::.Apply Method
IntelliSenseComponent Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Apply(XmlDocument) | (Inherited from BuildComponent.)
Apply(XmlDocument, String) | This is implemented to extract the IntelliSense comments. (Overrides BuildComponent..::.Apply(XmlDocument, String).)

See Also

IntelliSenseComponent Class
IntelliSenseComponent Members
SandcastleBuilder.Components Namespace


Apply Method (XmlDocument, String)

[image]

Sandcastle Help File Builder Documentation
IntelliSenseComponent..::.Apply Method (XmlDocument, String)
IntelliSenseComponent Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is implemented to extract the IntelliSense comments.

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.Components (in SandcastleBuilder.Components.dll) Version: 1.8.0.2

Syntax

C#
public override void Apply(
    XmlDocument document,
    string key
)
Visual Basic (Declaration)
Public Overrides Sub Apply ( _
    document As XmlDocument, _
    key As String _
)

Parameters

document
Type: System.Xml..::.XmlDocument
The XML document with which to work.
key
Type: System..::.String
The key (member name) of the item being documented.

See Also

IntelliSenseComponent Class
Apply Overload
SandcastleBuilder.Components Namespace


ConfigureComponent Method

[image]

Sandcastle Help File Builder Documentation
IntelliSenseComponent..::.ConfigureComponent Method
IntelliSenseComponent Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This static method is used by the Sandcastle Help File Builder to let the component perform its own configuration.

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.Components (in SandcastleBuilder.Components.dll) Version: 1.8.0.2

Syntax

C#
public static string ConfigureComponent(
    string currentConfig
)
Visual Basic (Declaration)
Public Shared Function ConfigureComponent ( _
    currentConfig As String _
) As String

Parameters

currentConfig
Type: System..::.String
The current configuration XML fragment

Return Value

A string containing the new configuration XML fragment

See Also

IntelliSenseComponent Class
SandcastleBuilder.Components Namespace


Dispose Method

[image]

Sandcastle Help File Builder Documentation
IntelliSenseComponent..::.Dispose Method
IntelliSenseComponent Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Write out closing tags and close all open XML writers when disposed.

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.Components (in SandcastleBuilder.Components.dll) Version: 1.8.0.2

Syntax

C#
public override void Dispose()
Visual Basic (Declaration)
Public Overrides Sub Dispose

Implements

IDisposable..::.Dispose()()()

See Also

IntelliSenseComponent Class
SandcastleBuilder.Components Namespace


IntelliSenseComponent Properties

[image] [image]

Sandcastle Help File Builder Documentation
IntelliSenseComponent Properties
IntelliSenseComponent Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IntelliSenseComponent type exposes the following members.

Properties

Name | Description
BuildAssembler | (Inherited from BuildComponent.)

See Also

IntelliSenseComponent Class
SandcastleBuilder.Components Namespace


JavaScriptDeclarationSyntaxGenerator Class

[image]

Sandcastle Help File Builder Documentation
JavaScriptDeclarationSyntaxGenerator Class
Members Example See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is a JavaScript declaration syntax generator that is used to add a JavaScript Syntax section to each generated API topic.

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.Components (in SandcastleBuilder.Components.dll) Version: 1.8.0.2

Syntax

C#
public class JavaScriptDeclarationSyntaxGenerator : SyntaxGeneratorTemplate
Visual Basic (Declaration)
Public Class JavaScriptDeclarationSyntaxGenerator _
    Inherits SyntaxGeneratorTemplate

Remarks

This version differs from the ScriptSharpDeclarationSyntaxGenerator in that it looks for a <scriptSharp /> element in the <api> node and, if found, only then will it apply the casing rules to the member name. If not present, no casing rules are applied to the member names thus it is suitable for use with regular JavaScript such as that used in AjaxDoc projects.

Examples

In order to use this script generator, you should modify the Sandcastle transformation file FixScriptSharp.xsl by adding the following template as the second one in the file. The help file builder uses a modified version of the transformation so that you do not need to apply the change when using it.
CopyFixScriptSharp.xsl Patch
<!-- Add a "scriptSharp" element to each API node so that the
     JavaScript syntax generator will apply the casing rules to the
     member name. -->
<xsl:template match="api">
  <xsl:copy>
    <xsl:apply-templates select="node() | @*" />
    <scriptSharp />
  </xsl:copy>
</xsl:template>

Inheritance Hierarchy

System..::.Object
Microsoft.Ddue.Tools..::.SyntaxGenerator
Microsoft.Ddue.Tools..::.SyntaxGeneratorTemplate
SandcastleBuilder.Components..::.JavaScriptDeclarationSyntaxGenerator

See Also

JavaScriptDeclarationSyntaxGenerator Members
SandcastleBuilder.Components Namespace


JavaScriptDeclarationSyntaxGenerator Members

[image] [image]

Sandcastle Help File Builder Documentation
JavaScriptDeclarationSyntaxGenerator Members
JavaScriptDeclarationSyntaxGenerator Class Constructors Methods Fields Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The JavaScriptDeclarationSyntaxGenerator type exposes the following members.

Constructors

Name | Description
JavaScriptDeclarationSyntaxGenerator | Constructor

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsUnsupportedExplicit | (Inherited from SyntaxGeneratorTemplate.)
IsUnsupportedGeneric | (Inherited from SyntaxGeneratorTemplate.)
IsUnsupportedUnsafe | (Inherited from SyntaxGeneratorTemplate.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteAttachedEventSyntax | Not used by this syntax generator (Overrides SyntaxGeneratorTemplate..::.WriteAttachedEventSyntax(XPathNavigator, SyntaxWriter).)
WriteAttachedPropertySyntax | Write out attached property syntax (Overrides SyntaxGeneratorTemplate..::.WriteAttachedPropertySyntax(XPathNavigator, SyntaxWriter).)
WriteCastSyntax | (Inherited from SyntaxGeneratorTemplate.)
WriteClassSyntax | Write out class syntax (Overrides SyntaxGeneratorTemplate..::.WriteClassSyntax(XPathNavigator, SyntaxWriter).)
WriteConstructorSyntax | Write out constructor syntax (Overrides SyntaxGeneratorTemplate..::.WriteConstructorSyntax(XPathNavigator, SyntaxWriter).)
WriteDelegateSyntax | Write out delegate syntax (Overrides SyntaxGeneratorTemplate..::.WriteDelegateSyntax(XPathNavigator, SyntaxWriter).)
WriteEnumerationSyntax | Write out enumeration syntax (Overrides SyntaxGeneratorTemplate..::.WriteEnumerationSyntax(XPathNavigator, SyntaxWriter).)
WriteEventSyntax | Write out event syntax (Overrides SyntaxGeneratorTemplate..::.WriteEventSyntax(XPathNavigator, SyntaxWriter).)
WriteFieldSyntax | Write out field syntax (Overrides SyntaxGeneratorTemplate..::.WriteFieldSyntax(XPathNavigator, SyntaxWriter).)
WriteInterfaceSyntax | Write out interface syntax (Overrides SyntaxGeneratorTemplate..::.WriteInterfaceSyntax(XPathNavigator, SyntaxWriter).)
WriteMemberSyntax | (Inherited from SyntaxGeneratorTemplate.)
WriteMethodSyntax | (Inherited from SyntaxGeneratorTemplate.)
WriteNamespaceSyntax | Write out namespace syntax (Overrides SyntaxGeneratorTemplate..::.WriteNamespaceSyntax(XPathNavigator, SyntaxWriter).)
WriteNormalMethodSyntax | Write out normal method syntax (Overrides SyntaxGeneratorTemplate..::.WriteNormalMethodSyntax(XPathNavigator, SyntaxWriter).)
WriteOperatorSyntax | Operator syntax is unsupported (Overrides SyntaxGeneratorTemplate..::.WriteOperatorSyntax(XPathNavigator, SyntaxWriter).)
WritePropertySyntax | Write out property syntax if supported (Overrides SyntaxGeneratorTemplate..::.WritePropertySyntax(XPathNavigator, SyntaxWriter).)
WriteStructureSyntax | Structure syntax is unsupported (Overrides SyntaxGeneratorTemplate..::.WriteStructureSyntax(XPathNavigator, SyntaxWriter).)
WriteSyntax | (Inherited from SyntaxGeneratorTemplate.)
WriteTypeSyntax | (Inherited from SyntaxGeneratorTemplate.)

Fields

Name | Description
language | (Inherited from SyntaxGeneratorTemplate.)

Properties

Name | Description
Language | (Inherited from SyntaxGeneratorTemplate.)

See Also

JavaScriptDeclarationSyntaxGenerator Class
SandcastleBuilder.Components Namespace


JavaScriptDeclarationSyntaxGenerator Constructor

[image]

Sandcastle Help File Builder Documentation
JavaScriptDeclarationSyntaxGenerator Constructor
JavaScriptDeclarationSyntaxGenerator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.Components (in SandcastleBuilder.Components.dll) Version: 1.8.0.2

Syntax

C#
public JavaScriptDeclarationSyntaxGenerator(
    XPathNavigator configuration
)
Visual Basic (Declaration)
Public Sub New ( _
    configuration As XPathNavigator _
)

Parameters

configuration
Type: System.Xml.XPath..::.XPathNavigator
The syntax generator configuration

See Also

JavaScriptDeclarationSyntaxGenerator Class
SandcastleBuilder.Components Namespace


JavaScriptDeclarationSyntaxGenerator Fields

[image] [image]

Sandcastle Help File Builder Documentation
JavaScriptDeclarationSyntaxGenerator Fields
JavaScriptDeclarationSyntaxGenerator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The JavaScriptDeclarationSyntaxGenerator type exposes the following members.

Fields

Name | Description
language | (Inherited from SyntaxGeneratorTemplate.)

See Also

JavaScriptDeclarationSyntaxGenerator Class
SandcastleBuilder.Components Namespace


JavaScriptDeclarationSyntaxGenerator Methods

[image] [image]

Sandcastle Help File Builder Documentation
JavaScriptDeclarationSyntaxGenerator Methods
JavaScriptDeclarationSyntaxGenerator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The JavaScriptDeclarationSyntaxGenerator type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsUnsupportedExplicit | (Inherited from SyntaxGeneratorTemplate.)
IsUnsupportedGeneric | (Inherited from SyntaxGeneratorTemplate.)
IsUnsupportedUnsafe | (Inherited from SyntaxGeneratorTemplate.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteAttachedEventSyntax | Not used by this syntax generator (Overrides SyntaxGeneratorTemplate..::.WriteAttachedEventSyntax(XPathNavigator, SyntaxWriter).)
WriteAttachedPropertySyntax | Write out attached property syntax (Overrides SyntaxGeneratorTemplate..::.WriteAttachedPropertySyntax(XPathNavigator, SyntaxWriter).)
WriteCastSyntax | (Inherited from SyntaxGeneratorTemplate.)
WriteClassSyntax | Write out class syntax (Overrides SyntaxGeneratorTemplate..::.WriteClassSyntax(XPathNavigator, SyntaxWriter).)
WriteConstructorSyntax | Write out constructor syntax (Overrides SyntaxGeneratorTemplate..::.WriteConstructorSyntax(XPathNavigator, SyntaxWriter).)
WriteDelegateSyntax | Write out delegate syntax (Overrides SyntaxGeneratorTemplate..::.WriteDelegateSyntax(XPathNavigator, SyntaxWriter).)
WriteEnumerationSyntax | Write out enumeration syntax (Overrides SyntaxGeneratorTemplate..::.WriteEnumerationSyntax(XPathNavigator, SyntaxWriter).)
WriteEventSyntax | Write out event syntax (Overrides SyntaxGeneratorTemplate..::.WriteEventSyntax(XPathNavigator, SyntaxWriter).)
WriteFieldSyntax | Write out field syntax (Overrides SyntaxGeneratorTemplate..::.WriteFieldSyntax(XPathNavigator, SyntaxWriter).)
WriteInterfaceSyntax | Write out interface syntax (Overrides SyntaxGeneratorTemplate..::.WriteInterfaceSyntax(XPathNavigator, SyntaxWriter).)
WriteMemberSyntax | (Inherited from SyntaxGeneratorTemplate.)
WriteMethodSyntax | (Inherited from SyntaxGeneratorTemplate.)
WriteNamespaceSyntax | Write out namespace syntax (Overrides SyntaxGeneratorTemplate..::.WriteNamespaceSyntax(XPathNavigator, SyntaxWriter).)
WriteNormalMethodSyntax | Write out normal method syntax (Overrides SyntaxGeneratorTemplate..::.WriteNormalMethodSyntax(XPathNavigator, SyntaxWriter).)
WriteOperatorSyntax | Operator syntax is unsupported (Overrides SyntaxGeneratorTemplate..::.WriteOperatorSyntax(XPathNavigator, SyntaxWriter).)
WritePropertySyntax | Write out property syntax if supported (Overrides SyntaxGeneratorTemplate..::.WritePropertySyntax(XPathNavigator, SyntaxWriter).)
WriteStructureSyntax | Structure syntax is unsupported (Overrides SyntaxGeneratorTemplate..::.WriteStructureSyntax(XPathNavigator, SyntaxWriter).)
WriteSyntax | (Inherited from SyntaxGeneratorTemplate.)
WriteTypeSyntax | (Inherited from SyntaxGeneratorTemplate.)

See Also

JavaScriptDeclarationSyntaxGenerator Class
SandcastleBuilder.Components Namespace


WriteAttachedEventSyntax Method

[image]

Sandcastle Help File Builder Documentation
JavaScriptDeclarationSyntaxGenerator..::.WriteAttachedEventSyntax Method
JavaScriptDeclarationSyntaxGenerator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Not used by this syntax generator

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.Components (in SandcastleBuilder.Components.dll) Version: 1.8.0.2

Syntax

C#
public override void WriteAttachedEventSyntax(
    XPathNavigator reflection,
    SyntaxWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub WriteAttachedEventSyntax ( _
    reflection As XPathNavigator, _
    writer As SyntaxWriter _
)

Parameters

reflection
Type: System.Xml.XPath..::.XPathNavigator
The reflection information
writer
Type: Microsoft.Ddue.Tools..::.SyntaxWriter
The syntax writer to which it is written

See Also

JavaScriptDeclarationSyntaxGenerator Class
SandcastleBuilder.Components Namespace


WriteAttachedPropertySyntax Method

[image]

Sandcastle Help File Builder Documentation
JavaScriptDeclarationSyntaxGenerator..::.WriteAttachedPropertySyntax Method
JavaScriptDeclarationSyntaxGenerator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Write out attached property syntax

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.Components (in SandcastleBuilder.Components.dll) Version: 1.8.0.2

Syntax

C#
public override void WriteAttachedPropertySyntax(
    XPathNavigator reflection,
    SyntaxWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub WriteAttachedPropertySyntax ( _
    reflection As XPathNavigator, _
    writer As SyntaxWriter _
)

Parameters

reflection
Type: System.Xml.XPath..::.XPathNavigator
The reflection information
writer
Type: Microsoft.Ddue.Tools..::.SyntaxWriter
The syntax writer to which it is written

See Also

JavaScriptDeclarationSyntaxGenerator Class
SandcastleBuilder.Components Namespace


WriteClassSyntax Method

[image]

Sandcastle Help File Builder Documentation
JavaScriptDeclarationSyntaxGenerator..::.WriteClassSyntax Method
JavaScriptDeclarationSyntaxGenerator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Write out class syntax

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.Components (in SandcastleBuilder.Components.dll) Version: 1.8.0.2

Syntax

C#
public override void WriteClassSyntax(
    XPathNavigator reflection,
    SyntaxWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub WriteClassSyntax ( _
    reflection As XPathNavigator, _
    writer As SyntaxWriter _
)

Parameters

reflection
Type: System.Xml.XPath..::.XPathNavigator
The reflection information
writer
Type: Microsoft.Ddue.Tools..::.SyntaxWriter
The syntax writer to which it is written

See Also

JavaScriptDeclarationSyntaxGenerator Class
SandcastleBuilder.Components Namespace


WriteConstructorSyntax Method

[image]

Sandcastle Help File Builder Documentation
JavaScriptDeclarationSyntaxGenerator..::.WriteConstructorSyntax Method
JavaScriptDeclarationSyntaxGenerator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Write out constructor syntax

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.Components (in SandcastleBuilder.Components.dll) Version: 1.8.0.2

Syntax

C#
public override void WriteConstructorSyntax(
    XPathNavigator reflection,
    SyntaxWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub WriteConstructorSyntax ( _
    reflection As XPathNavigator, _
    writer As SyntaxWriter _
)

Parameters

reflection
Type: System.Xml.XPath..::.XPathNavigator
The reflection information
writer
Type: Microsoft.Ddue.Tools..::.SyntaxWriter
The syntax writer to which it is written

See Also

JavaScriptDeclarationSyntaxGenerator Class
SandcastleBuilder.Components Namespace


WriteDelegateSyntax Method

[image]

Sandcastle Help File Builder Documentation
JavaScriptDeclarationSyntaxGenerator..::.WriteDelegateSyntax Method
JavaScriptDeclarationSyntaxGenerator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Write out delegate syntax

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.Components (in SandcastleBuilder.Components.dll) Version: 1.8.0.2

Syntax

C#
public override void WriteDelegateSyntax(
    XPathNavigator reflection,
    SyntaxWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub WriteDelegateSyntax ( _
    reflection As XPathNavigator, _
    writer As SyntaxWriter _
)

Parameters

reflection
Type: System.Xml.XPath..::.XPathNavigator
The reflection information
writer
Type: Microsoft.Ddue.Tools..::.SyntaxWriter
The syntax writer to which it is written

See Also

JavaScriptDeclarationSyntaxGenerator Class
SandcastleBuilder.Components Namespace


WriteEnumerationSyntax Method

[image]

Sandcastle Help File Builder Documentation
JavaScriptDeclarationSyntaxGenerator..::.WriteEnumerationSyntax Method
JavaScriptDeclarationSyntaxGenerator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Write out enumeration syntax

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.Components (in SandcastleBuilder.Components.dll) Version: 1.8.0.2

Syntax

C#
public override void WriteEnumerationSyntax(
    XPathNavigator reflection,
    SyntaxWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub WriteEnumerationSyntax ( _
    reflection As XPathNavigator, _
    writer As SyntaxWriter _
)

Parameters

reflection
Type: System.Xml.XPath..::.XPathNavigator
The reflection information
writer
Type: Microsoft.Ddue.Tools..::.SyntaxWriter
The syntax writer to which it is written

See Also

JavaScriptDeclarationSyntaxGenerator Class
SandcastleBuilder.Components Namespace


WriteEventSyntax Method

[image]

Sandcastle Help File Builder Documentation
JavaScriptDeclarationSyntaxGenerator..::.WriteEventSyntax Method
JavaScriptDeclarationSyntaxGenerator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Write out event syntax

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.Components (in SandcastleBuilder.Components.dll) Version: 1.8.0.2

Syntax

C#
public override void WriteEventSyntax(
    XPathNavigator reflection,
    SyntaxWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub WriteEventSyntax ( _
    reflection As XPathNavigator, _
    writer As SyntaxWriter _
)

Parameters

reflection
Type: System.Xml.XPath..::.XPathNavigator
The reflection information
writer
Type: Microsoft.Ddue.Tools..::.SyntaxWriter
The syntax writer to which it is written

See Also

JavaScriptDeclarationSyntaxGenerator Class
SandcastleBuilder.Components Namespace


WriteFieldSyntax Method

[image]

Sandcastle Help File Builder Documentation
JavaScriptDeclarationSyntaxGenerator..::.WriteFieldSyntax Method
JavaScriptDeclarationSyntaxGenerator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Write out field syntax

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.Components (in SandcastleBuilder.Components.dll) Version: 1.8.0.2

Syntax

C#
public override void WriteFieldSyntax(
    XPathNavigator reflection,
    SyntaxWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub WriteFieldSyntax ( _
    reflection As XPathNavigator, _
    writer As SyntaxWriter _
)

Parameters

reflection
Type: System.Xml.XPath..::.XPathNavigator
The reflection information
writer
Type: Microsoft.Ddue.Tools..::.SyntaxWriter
The syntax writer to which it is written

See Also

JavaScriptDeclarationSyntaxGenerator Class
SandcastleBuilder.Components Namespace


WriteInterfaceSyntax Method

[image]

Sandcastle Help File Builder Documentation
JavaScriptDeclarationSyntaxGenerator..::.WriteInterfaceSyntax Method
JavaScriptDeclarationSyntaxGenerator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Write out interface syntax

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.Components (in SandcastleBuilder.Components.dll) Version: 1.8.0.2

Syntax

C#
public override void WriteInterfaceSyntax(
    XPathNavigator reflection,
    SyntaxWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub WriteInterfaceSyntax ( _
    reflection As XPathNavigator, _
    writer As SyntaxWriter _
)

Parameters

reflection
Type: System.Xml.XPath..::.XPathNavigator
The reflection information
writer
Type: Microsoft.Ddue.Tools..::.SyntaxWriter
The syntax writer to which it is written

See Also

JavaScriptDeclarationSyntaxGenerator Class
SandcastleBuilder.Components Namespace


WriteNamespaceSyntax Method

[image]

Sandcastle Help File Builder Documentation
JavaScriptDeclarationSyntaxGenerator..::.WriteNamespaceSyntax Method
JavaScriptDeclarationSyntaxGenerator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Write out namespace syntax

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.Components (in SandcastleBuilder.Components.dll) Version: 1.8.0.2

Syntax

C#
public override void WriteNamespaceSyntax(
    XPathNavigator reflection,
    SyntaxWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub WriteNamespaceSyntax ( _
    reflection As XPathNavigator, _
    writer As SyntaxWriter _
)

Parameters

reflection
Type: System.Xml.XPath..::.XPathNavigator
The reflection information
writer
Type: Microsoft.Ddue.Tools..::.SyntaxWriter
The syntax writer to which it is written

See Also

JavaScriptDeclarationSyntaxGenerator Class
SandcastleBuilder.Components Namespace


WriteNormalMethodSyntax Method

[image]

Sandcastle Help File Builder Documentation
JavaScriptDeclarationSyntaxGenerator..::.WriteNormalMethodSyntax Method
JavaScriptDeclarationSyntaxGenerator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Write out normal method syntax

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.Components (in SandcastleBuilder.Components.dll) Version: 1.8.0.2

Syntax

C#
public override void WriteNormalMethodSyntax(
    XPathNavigator reflection,
    SyntaxWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub WriteNormalMethodSyntax ( _
    reflection As XPathNavigator, _
    writer As SyntaxWriter _
)

Parameters

reflection
Type: System.Xml.XPath..::.XPathNavigator
The reflection information
writer
Type: Microsoft.Ddue.Tools..::.SyntaxWriter
The syntax writer to which it is written

See Also

JavaScriptDeclarationSyntaxGenerator Class
SandcastleBuilder.Components Namespace


WriteOperatorSyntax Method

[image]

Sandcastle Help File Builder Documentation
JavaScriptDeclarationSyntaxGenerator..::.WriteOperatorSyntax Method
JavaScriptDeclarationSyntaxGenerator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Operator syntax is unsupported

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.Components (in SandcastleBuilder.Components.dll) Version: 1.8.0.2

Syntax

C#
public override void WriteOperatorSyntax(
    XPathNavigator reflection,
    SyntaxWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub WriteOperatorSyntax ( _
    reflection As XPathNavigator, _
    writer As SyntaxWriter _
)

Parameters

reflection
Type: System.Xml.XPath..::.XPathNavigator
The reflection information
writer
Type: Microsoft.Ddue.Tools..::.SyntaxWriter
The syntax writer to which it is written

See Also

JavaScriptDeclarationSyntaxGenerator Class
SandcastleBuilder.Components Namespace


WritePropertySyntax Method

[image]

Sandcastle Help File Builder Documentation
JavaScriptDeclarationSyntaxGenerator..::.WritePropertySyntax Method
JavaScriptDeclarationSyntaxGenerator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Write out property syntax if supported

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.Components (in SandcastleBuilder.Components.dll) Version: 1.8.0.2

Syntax

C#
public override void WritePropertySyntax(
    XPathNavigator reflection,
    SyntaxWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub WritePropertySyntax ( _
    reflection As XPathNavigator, _
    writer As SyntaxWriter _
)

Parameters

reflection
Type: System.Xml.XPath..::.XPathNavigator
The reflection information
writer
Type: Microsoft.Ddue.Tools..::.SyntaxWriter
The syntax writer to which it is written

See Also

JavaScriptDeclarationSyntaxGenerator Class
SandcastleBuilder.Components Namespace


WriteStructureSyntax Method

[image]

Sandcastle Help File Builder Documentation
JavaScriptDeclarationSyntaxGenerator..::.WriteStructureSyntax Method
JavaScriptDeclarationSyntaxGenerator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Structure syntax is unsupported

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.Components (in SandcastleBuilder.Components.dll) Version: 1.8.0.2

Syntax

C#
public override void WriteStructureSyntax(
    XPathNavigator reflection,
    SyntaxWriter writer
)
Visual Basic (Declaration)
Public Overrides Sub WriteStructureSyntax ( _
    reflection As XPathNavigator, _
    writer As SyntaxWriter _
)

Parameters

reflection
Type: System.Xml.XPath..::.XPathNavigator
The reflection information
writer
Type: Microsoft.Ddue.Tools..::.SyntaxWriter
The syntax writer to which it is written

See Also

JavaScriptDeclarationSyntaxGenerator Class
SandcastleBuilder.Components Namespace


JavaScriptDeclarationSyntaxGenerator Properties

[image] [image]

Sandcastle Help File Builder Documentation
JavaScriptDeclarationSyntaxGenerator Properties
JavaScriptDeclarationSyntaxGenerator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The JavaScriptDeclarationSyntaxGenerator type exposes the following members.

Properties

Name | Description
Language | (Inherited from SyntaxGeneratorTemplate.)

See Also

JavaScriptDeclarationSyntaxGenerator Class
SandcastleBuilder.Components Namespace


LinkType Enumeration

[image]

Sandcastle Help File Builder Documentation
LinkType Enumeration
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This public enumerated type defines the link types

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.Components (in SandcastleBuilder.Components.dll) Version: 1.8.0.2

Syntax

C#
public enum LinkType
Visual Basic (Declaration)
Public Enumeration LinkType

Members

Member name | Description
None | No links
Local | Local links
Index | Index links

See Also

SandcastleBuilder.Components Namespace


MSHelpAttrComponent Class

[image]

Sandcastle Help File Builder Documentation
MSHelpAttrComponent Class
Members Example See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This build component is used to add additional HTML Help 2.x attributes to the XML data island in each generated API topic.

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.Components (in SandcastleBuilder.Components.dll) Version: 1.8.0.2

Syntax

C#
public class MSHelpAttrComponent : BuildComponent
Visual Basic (Declaration)
Public Class MSHelpAttrComponent _
    Inherits BuildComponent

Examples

CopyExample configuration
<!-- HTML Help 2 attribute configuration.  This must appear after
     the TransformComponent. -->
<component type="SandcastleBuilder.Components.MSHelpAttrComponent"
  assembly="C:\SandcastleBuilder\SandcastleBuilder.Components.dll">
    <!-- Additional attributes (required) -->
    <attributes>
        <!-- At least one attribute element must be defined.  The
             "name" attribute is required.  The "value" attribute is
             optional. -->
        <attribute name="DocSet" value="NETFramework" / >
        <attribute name="DocSet" value="ProjectNamespace" / >
        <attribute name="TargetOS" value="Windows" / >
    </attributes>
</component>

Inheritance Hierarchy

System..::.Object
Microsoft.Ddue.Tools..::.BuildComponent
SandcastleBuilder.Components..::.MSHelpAttrComponent

See Also

MSHelpAttrComponent Members
SandcastleBuilder.Components Namespace


MSHelpAttrComponent Members

[image] [image]

Sandcastle Help File Builder Documentation
MSHelpAttrComponent Members
MSHelpAttrComponent Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The MSHelpAttrComponent type exposes the following members.

Constructors

Name | Description
MSHelpAttrComponent | Constructor

Methods

Name | Description
Apply | Overloaded.
Dispose | (Inherited from BuildComponent.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnComponentEvent | (Inherited from BuildComponent.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteMessage | (Inherited from BuildComponent.)

Properties

Name | Description
BuildAssembler | (Inherited from BuildComponent.)

See Also

MSHelpAttrComponent Class
SandcastleBuilder.Components Namespace


MSHelpAttrComponent Constructor

[image]

Sandcastle Help File Builder Documentation
MSHelpAttrComponent Constructor
MSHelpAttrComponent Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.Components (in SandcastleBuilder.Components.dll) Version: 1.8.0.2

Syntax

C#
public MSHelpAttrComponent(
    BuildAssembler assembler,
    XPathNavigator configuration
)
Visual Basic (Declaration)
Public Sub New ( _
    assembler As BuildAssembler, _
    configuration As XPathNavigator _
)

Parameters

assembler
Type: Microsoft.Ddue.Tools..::.BuildAssembler
A reference to the build assembler.
configuration
Type: System.Xml.XPath..::.XPathNavigator
The configuration information

Remarks

See the MSHelpAttrComponent class topic for an example of the configuration

Exceptions

Exception | Condition
System.Configuration..::.ConfigurationErrorsException | This is thrown if an error is detected in the configuration.

See Also

MSHelpAttrComponent Class
SandcastleBuilder.Components Namespace


MSHelpAttrComponent Methods

[image] [image]

Sandcastle Help File Builder Documentation
MSHelpAttrComponent Methods
MSHelpAttrComponent Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The MSHelpAttrComponent type exposes the following members.

Methods

Name | Description
Apply | Overloaded.
Dispose | (Inherited from BuildComponent.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnComponentEvent | (Inherited from BuildComponent.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteMessage | (Inherited from BuildComponent.)

See Also

MSHelpAttrComponent Class
SandcastleBuilder.Components Namespace


Apply Method

[image] [image]

Sandcastle Help File Builder Documentation
MSHelpAttrComponent..::.Apply Method
MSHelpAttrComponent Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Apply(XmlDocument) | (Inherited from BuildComponent.)
Apply(XmlDocument, String) | This is implemented to add the attributes to the XML data island. (Overrides BuildComponent..::.Apply(XmlDocument, String).)

See Also

MSHelpAttrComponent Class
MSHelpAttrComponent Members
SandcastleBuilder.Components Namespace


Apply Method (XmlDocument, String)

[image]

Sandcastle Help File Builder Documentation
MSHelpAttrComponent..::.Apply Method (XmlDocument, String)
MSHelpAttrComponent Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is implemented to add the attributes to the XML data island.

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.Components (in SandcastleBuilder.Components.dll) Version: 1.8.0.2

Syntax

C#
public override void Apply(
    XmlDocument document,
    string key
)
Visual Basic (Declaration)
Public Overrides Sub Apply ( _
    document As XmlDocument, _
    key As String _
)

Parameters

document
Type: System.Xml..::.XmlDocument
The XML document with which to work.
key
Type: System..::.String
The key (member name) of the item being documented.

See Also

MSHelpAttrComponent Class
Apply Overload
SandcastleBuilder.Components Namespace


MSHelpAttrComponent Properties

[image] [image]

Sandcastle Help File Builder Documentation
MSHelpAttrComponent Properties
MSHelpAttrComponent Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The MSHelpAttrComponent type exposes the following members.

Properties

Name | Description
BuildAssembler | (Inherited from BuildComponent.)

See Also

MSHelpAttrComponent Class
SandcastleBuilder.Components Namespace


PostTransformComponent Class

[image]

Sandcastle Help File Builder Documentation
PostTransformComponent Class
Members Example See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This build component is is a companion to the CodeBlockComponent. It is used to add the stylesheet and JavaScript links to the rendered HTML if the topic contains colorized code. In addition, it can insert a logo image at the top of each help topic and, for the Prototype presentation style, hide the language combo box if only one language appears in the Syntax section. With a modification to the Sandcastle reference content files, it will also add version information to each topic.

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.Components (in SandcastleBuilder.Components.dll) Version: 1.8.0.2

Syntax

C#
public class PostTransformComponent : BuildComponent
Visual Basic (Declaration)
Public Class PostTransformComponent _
    Inherits BuildComponent

Remarks

The colorizer files are only copied once and only if code is actually colorized. If the files already exist (i.e. additional content has replaced them), they are not copied either. That way, you can customize the color stylesheet as you see fit without modifying the default stylesheet.

By adding "Version: {2}" to the locationInformation entry and the assemblyNameAndModule entry in the reference_content.xml file in the Prototype, VS2005, and Hana style content files, you can add version information to each topic. The help file builder uses a composite file with this fix already in place.

Examples

CopyExample configuration
<!-- Post-transform component configuration.  This must
     appear after the TransformComponent.  See also:
     CodeBlockComponent. -->
<component type="SandcastleBuilder.Components.PostTransformComponent"
  assembly="C:\SandcastleComponents\SandcastleBuilder.Components.dll" >
    <!-- Code colorizer files (required).
         Attributes:
            Stylesheet file (required)
            Script file (required)
            "Copy" image file (required) -->
    <colorizer stylesheet="highlight.css" scriptFile="highlight.js"
       copyImage="CopyCode.gif" />

    <!-- Base output path for the files (required).  This should
         match the parent folder of the output path of the HTML files
         (see SaveComponent). -->
    <outputPath value="Output" />

    <!-- Logo image file (optional).  Filename is required.  The
         height, width, altText, placement, and alignment attributes
         are optional. -->
    <logoFile filename="Logo.jpg" height="64" width="64"
       altText="Test Logo" placement="left" alignment="left" />
</component>

Inheritance Hierarchy

System..::.Object
Microsoft.Ddue.Tools..::.BuildComponent
SandcastleBuilder.Components..::.PostTransformComponent

See Also

PostTransformComponent Members
SandcastleBuilder.Components Namespace


PostTransformComponent Members

[image] [image]

Sandcastle Help File Builder Documentation
PostTransformComponent Members
PostTransformComponent Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PostTransformComponent type exposes the following members.

Constructors

Name | Description
PostTransformComponent | Constructor

Methods

Name | Description
Apply | Overloaded.
ConfigureComponent | This static method is used by the Sandcastle Help File Builder to let the component perform its own configuration.
Dispose | (Inherited from BuildComponent.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnComponentEvent | (Inherited from BuildComponent.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteMessage | (Inherited from BuildComponent.)

Properties

Name | Description
BuildAssembler | (Inherited from BuildComponent.)

See Also

PostTransformComponent Class
SandcastleBuilder.Components Namespace


PostTransformComponent Constructor

[image]

Sandcastle Help File Builder Documentation
PostTransformComponent Constructor
PostTransformComponent Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.Components (in SandcastleBuilder.Components.dll) Version: 1.8.0.2

Syntax

C#
public PostTransformComponent(
    BuildAssembler assembler,
    XPathNavigator configuration
)
Visual Basic (Declaration)
Public Sub New ( _
    assembler As BuildAssembler, _
    configuration As XPathNavigator _
)

Parameters

assembler
Type: Microsoft.Ddue.Tools..::.BuildAssembler
A reference to the build assembler.
configuration
Type: System.Xml.XPath..::.XPathNavigator
The configuration information

Exceptions

Exception | Condition
System.Configuration..::.ConfigurationErrorsException | This is thrown if an error is detected in the configuration.

See Also

PostTransformComponent Class
SandcastleBuilder.Components Namespace


PostTransformComponent Methods

[image] [image]

Sandcastle Help File Builder Documentation
PostTransformComponent Methods
PostTransformComponent Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PostTransformComponent type exposes the following members.

Methods

Name | Description
Apply | Overloaded.
ConfigureComponent | This static method is used by the Sandcastle Help File Builder to let the component perform its own configuration.
Dispose | (Inherited from BuildComponent.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnComponentEvent | (Inherited from BuildComponent.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteMessage | (Inherited from BuildComponent.)

See Also

PostTransformComponent Class
SandcastleBuilder.Components Namespace


Apply Method

[image] [image]

Sandcastle Help File Builder Documentation
PostTransformComponent..::.Apply Method
PostTransformComponent Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Apply(XmlDocument) | (Inherited from BuildComponent.)
Apply(XmlDocument, String) | This is implemented to perform the post-transformation tasks. (Overrides BuildComponent..::.Apply(XmlDocument, String).)

See Also

PostTransformComponent Class
PostTransformComponent Members
SandcastleBuilder.Components Namespace


Apply Method (XmlDocument, String)

[image]

Sandcastle Help File Builder Documentation
PostTransformComponent..::.Apply Method (XmlDocument, String)
PostTransformComponent Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is implemented to perform the post-transformation tasks.

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.Components (in SandcastleBuilder.Components.dll) Version: 1.8.0.2

Syntax

C#
public override void Apply(
    XmlDocument document,
    string key
)
Visual Basic (Declaration)
Public Overrides Sub Apply ( _
    document As XmlDocument, _
    key As String _
)

Parameters

document
Type: System.Xml..::.XmlDocument
The XML document with which to work.
key
Type: System..::.String
The key (member name) of the item being documented.

See Also

PostTransformComponent Class
Apply Overload
SandcastleBuilder.Components Namespace


ConfigureComponent Method

[image]

Sandcastle Help File Builder Documentation
PostTransformComponent..::.ConfigureComponent Method
PostTransformComponent Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This static method is used by the Sandcastle Help File Builder to let the component perform its own configuration.

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.Components (in SandcastleBuilder.Components.dll) Version: 1.8.0.2

Syntax

C#
public static string ConfigureComponent(
    string currentConfig
)
Visual Basic (Declaration)
Public Shared Function ConfigureComponent ( _
    currentConfig As String _
) As String

Parameters

currentConfig
Type: System..::.String
The current configuration XML fragment

Return Value

A string containing the new configuration XML fragment

See Also

PostTransformComponent Class
SandcastleBuilder.Components Namespace


PostTransformComponent Properties

[image] [image]

Sandcastle Help File Builder Documentation
PostTransformComponent Properties
PostTransformComponent Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PostTransformComponent type exposes the following members.

Properties

Name | Description
BuildAssembler | (Inherited from BuildComponent.)

See Also

PostTransformComponent Class
SandcastleBuilder.Components Namespace


PostTransformComponent.LogoAlignment Enumeration

[image]

Sandcastle Help File Builder Documentation
PostTransformComponent..::.LogoAlignment Enumeration
PostTransformComponent Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This enumeration defines the logo alignment options when placement is set to Above.

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.Components (in SandcastleBuilder.Components.dll) Version: 1.8.0.2

Syntax

C#
public enum LogoAlignment
Visual Basic (Declaration)
Public Enumeration LogoAlignment

Members

Member name | Description
Left | Left-align the logo (the default).
Right | Right-align the logo.
Center | Center the logo.

See Also

SandcastleBuilder.Components Namespace


PostTransformComponent.LogoPlacement Enumeration

[image]

Sandcastle Help File Builder Documentation
PostTransformComponent..::.LogoPlacement Enumeration
PostTransformComponent Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This enumeration defines the logo placement options

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.Components (in SandcastleBuilder.Components.dll) Version: 1.8.0.2

Syntax

C#
public enum LogoPlacement
Visual Basic (Declaration)
Public Enumeration LogoPlacement

Members

Member name | Description
Left | Place the logo to the left of the header text (the default).
Right | Place the logo to the right of the header text.
Above | Place the logo above the header text.

See Also

SandcastleBuilder.Components Namespace


ResolveConceptualLinksComponent Class

[image]

Sandcastle Help File Builder Documentation
ResolveConceptualLinksComponent Class
Members Example See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This contains a reimplementation of ResolveConceptualLinksComponent that allows the use of inner text from the <link> tag, allows the use of anchor references (#anchorName) in the link target, and allows the use of an optional linkText element in the companion file to specify the link text.

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.Components (in SandcastleBuilder.Components.dll) Version: 1.8.0.2

Syntax

C#
public class ResolveConceptualLinksComponent : BuildComponent
Visual Basic (Declaration)
Public Class ResolveConceptualLinksComponent _
    Inherits BuildComponent

Remarks

This version contains the following improvements and fixes:
  • Broken links use the None style rather than the Index style so that it is apparant that they do not work.
  • The inner text from the conceptual link is used if specified.
  • On broken links, when the showBrokenLinkText option is true and there is no inner text, the target value is displayed.
  • Conceptual link targets can include an optional anchor name from within the target such as "#Name" (see examples below).
  • Unnecessary whitespace is removed from the link text.
  • If the companion file contains a <linkText> element and no inner text is specified, its value will be used for the link text rather than the title. This allows for a shorter title or description to use as the default link text.

Examples

On links without inner text, if the companion file contains a linkText element, that text will be used. If not, the title is used.
CopyExample Links
<!-- Link with inner text -->
<link xlink:href="3ab3113f-984b-19ac-7812-990192aca5b0">Click Here</link>
<!-- Link with anchor reference -->
<link xlink:href="3ab3113f-984b-19ac-7812-990192aca5b1#SubTopic" />
<!-- Link with inner text and an anchor reference -->
<link xlink:href="3ab3113f-984b-19ac-7812-990192aca5b1#PropA">PropertyA</link>
CopyExample configuration
<!-- Resolve conceptual links -->
<component type="SandcastleBuilder.Components.ResolveConceptualLinksComponent"
  assembly="C:\SandcastleBuilder\SandcastleBuilder.Components.dll"
  showBrokenLinkText="true">
    <targets base="xmlComp" type="local" />
</component>

Inheritance Hierarchy

System..::.Object
Microsoft.Ddue.Tools..::.BuildComponent
SandcastleBuilder.Components..::.ResolveConceptualLinksComponent

See Also

ResolveConceptualLinksComponent Members
SandcastleBuilder.Components Namespace


ResolveConceptualLinksComponent Members

[image] [image]

Sandcastle Help File Builder Documentation
ResolveConceptualLinksComponent Members
ResolveConceptualLinksComponent Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ResolveConceptualLinksComponent type exposes the following members.

Constructors

Name | Description
ResolveConceptualLinksComponent | Constructor

Methods

Name | Description
Apply | Overloaded.
Dispose | (Inherited from BuildComponent.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnComponentEvent | (Inherited from BuildComponent.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteMessage | (Inherited from BuildComponent.)

Properties

Name | Description
BuildAssembler | (Inherited from BuildComponent.)

See Also

ResolveConceptualLinksComponent Class
SandcastleBuilder.Components Namespace


ResolveConceptualLinksComponent Constructor

[image]

Sandcastle Help File Builder Documentation
ResolveConceptualLinksComponent Constructor
ResolveConceptualLinksComponent Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.Components (in SandcastleBuilder.Components.dll) Version: 1.8.0.2

Syntax

C#
public ResolveConceptualLinksComponent(
    BuildAssembler assembler,
    XPathNavigator configuration
)
Visual Basic (Declaration)
Public Sub New ( _
    assembler As BuildAssembler, _
    configuration As XPathNavigator _
)

Parameters

assembler
Type: Microsoft.Ddue.Tools..::.BuildAssembler
A reference to the build assembler.
configuration
Type: System.Xml.XPath..::.XPathNavigator
The configuration information

See Also

ResolveConceptualLinksComponent Class
SandcastleBuilder.Components Namespace


ResolveConceptualLinksComponent Methods

[image] [image]

Sandcastle Help File Builder Documentation
ResolveConceptualLinksComponent Methods
ResolveConceptualLinksComponent Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ResolveConceptualLinksComponent type exposes the following members.

Methods

Name | Description
Apply | Overloaded.
Dispose | (Inherited from BuildComponent.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnComponentEvent | (Inherited from BuildComponent.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteMessage | (Inherited from BuildComponent.)

See Also

ResolveConceptualLinksComponent Class
SandcastleBuilder.Components Namespace


Apply Method

[image] [image]

Sandcastle Help File Builder Documentation
ResolveConceptualLinksComponent..::.Apply Method
ResolveConceptualLinksComponent Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Apply(XmlDocument) | (Inherited from BuildComponent.)
Apply(XmlDocument, String) | This is implemented to resolve the conceptual links (Overrides BuildComponent..::.Apply(XmlDocument, String).)

See Also

ResolveConceptualLinksComponent Class
ResolveConceptualLinksComponent Members
SandcastleBuilder.Components Namespace


Apply Method (XmlDocument, String)

[image]

Sandcastle Help File Builder Documentation
ResolveConceptualLinksComponent..::.Apply Method (XmlDocument, String)
ResolveConceptualLinksComponent Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is implemented to resolve the conceptual links

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.Components (in SandcastleBuilder.Components.dll) Version: 1.8.0.2

Syntax

C#
public override void Apply(
    XmlDocument document,
    string key
)
Visual Basic (Declaration)
Public Overrides Sub Apply ( _
    document As XmlDocument, _
    key As String _
)

Parameters

document
Type: System.Xml..::.XmlDocument
The XML document with which to work.
key
Type: System..::.String
The key (member name) of the item being documented.

See Also

ResolveConceptualLinksComponent Class
Apply Overload
SandcastleBuilder.Components Namespace


ResolveConceptualLinksComponent Properties

[image] [image]

Sandcastle Help File Builder Documentation
ResolveConceptualLinksComponent Properties
ResolveConceptualLinksComponent Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ResolveConceptualLinksComponent type exposes the following members.

Properties

Name | Description
BuildAssembler | (Inherited from BuildComponent.)

See Also

ResolveConceptualLinksComponent Class
SandcastleBuilder.Components Namespace


ShowMissingComponent Class

[image]

Sandcastle Help File Builder Documentation
ShowMissingComponent Class
Members Example See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This build component is used to add "missing" notes for missing summary, parameter, returns, value, and remarks tags. It can also add default summary documentation for constructors.

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.Components (in SandcastleBuilder.Components.dll) Version: 1.8.0.2

Syntax

C#
public class ShowMissingComponent : BuildComponent
Visual Basic (Declaration)
Public Class ShowMissingComponent _
    Inherits BuildComponent

Examples

CopyExample configuration
<!-- Show missing documentation component configuration.  This must
     appear before the TransformComponent. -->
<component type="SandcastleBuilder.Components.ShowMissingComponent"
  assembly="C:\SandcastleBuilder\SandcastleBuilder.Components.dll">
    <!-- All elements are optional. -->

    <!-- Auto-document constructors (true by default) -->
    <AutoDocumentConstructors value="true" />

    <!-- Show missing param tags (true by default) -->
    <ShowMissingParams value="true" />

    <!-- Show missing typeparam tags (true by default) -->
    <ShowMissingTypeParams value="true" />

    <!-- Show missing remarks tags (false by default) -->
    <ShowMissingRemarks value="false" />

    <!-- Show missing returns tags (true by default) -->
    <ShowMissingReturns value="true" />

    <!-- Show missing summary tags (true by default) -->
    <ShowMissingSummaries value="true" />

    <!-- Show missing value tags (false by default) -->
    <ShowMissingValues value="false" />

    <!-- Show missing namespace comments (true by default) -->
    <ShowMissingNamespaces value="true" />

    <!-- Show missing include target docs (false by default) -->
    <ShowMissingIncludeTargets value="false" />

    <!-- Shared content file containing the localized
         messages (optional) -->
    <contentFile filename="C:\Working\SharedContent.xml" />
</component>

Inheritance Hierarchy

System..::.Object
Microsoft.Ddue.Tools..::.BuildComponent
SandcastleBuilder.Components..::.ShowMissingComponent

See Also

ShowMissingComponent Members
SandcastleBuilder.Components Namespace


ShowMissingComponent Members

[image] [image]

Sandcastle Help File Builder Documentation
ShowMissingComponent Members
ShowMissingComponent Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ShowMissingComponent type exposes the following members.

Constructors

Name | Description
ShowMissingComponent | Constructor

Methods

Name | Description
Apply | Overloaded.
Dispose | (Inherited from BuildComponent.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnComponentEvent | (Inherited from BuildComponent.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteMessage | (Inherited from BuildComponent.)

Properties

Name | Description
BuildAssembler | (Inherited from BuildComponent.)

See Also

ShowMissingComponent Class
SandcastleBuilder.Components Namespace


ShowMissingComponent Constructor

[image]

Sandcastle Help File Builder Documentation
ShowMissingComponent Constructor
ShowMissingComponent Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.Components (in SandcastleBuilder.Components.dll) Version: 1.8.0.2

Syntax

C#
public ShowMissingComponent(
    BuildAssembler assembler,
    XPathNavigator configuration
)
Visual Basic (Declaration)
Public Sub New ( _
    assembler As BuildAssembler, _
    configuration As XPathNavigator _
)

Parameters

assembler
Type: Microsoft.Ddue.Tools..::.BuildAssembler
A reference to the build assembler.
configuration
Type: System.Xml.XPath..::.XPathNavigator
The configuration information

Remarks

See the ShowMissingComponent class topic for an example of the configuration

Exceptions

Exception | Condition
System.Configuration..::.ConfigurationErrorsException | This is thrown if an error is detected in the configuration.

See Also

ShowMissingComponent Class
SandcastleBuilder.Components Namespace


ShowMissingComponent Methods

[image] [image]

Sandcastle Help File Builder Documentation
ShowMissingComponent Methods
ShowMissingComponent Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ShowMissingComponent type exposes the following members.

Methods

Name | Description
Apply | Overloaded.
Dispose | (Inherited from BuildComponent.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnComponentEvent | (Inherited from BuildComponent.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteMessage | (Inherited from BuildComponent.)

See Also

ShowMissingComponent Class
SandcastleBuilder.Components Namespace


Apply Method

[image] [image]

Sandcastle Help File Builder Documentation
ShowMissingComponent..::.Apply Method
ShowMissingComponent Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Apply(XmlDocument) | (Inherited from BuildComponent.)
Apply(XmlDocument, String) | This is implemented to add the missing documentation tags (Overrides BuildComponent..::.Apply(XmlDocument, String).)

See Also

ShowMissingComponent Class
ShowMissingComponent Members
SandcastleBuilder.Components Namespace


Apply Method (XmlDocument, String)

[image]

Sandcastle Help File Builder Documentation
ShowMissingComponent..::.Apply Method (XmlDocument, String)
ShowMissingComponent Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is implemented to add the missing documentation tags

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.Components (in SandcastleBuilder.Components.dll) Version: 1.8.0.2

Syntax

C#
public override void Apply(
    XmlDocument document,
    string key
)
Visual Basic (Declaration)
Public Overrides Sub Apply ( _
    document As XmlDocument, _
    key As String _
)

Parameters

document
Type: System.Xml..::.XmlDocument
The XML document with which to work.
key
Type: System..::.String
The key (member name) of the item being documented.

See Also

ShowMissingComponent Class
Apply Overload
SandcastleBuilder.Components Namespace


ShowMissingComponent Properties

[image] [image]

Sandcastle Help File Builder Documentation
ShowMissingComponent Properties
ShowMissingComponent Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ShowMissingComponent type exposes the following members.

Properties

Name | Description
BuildAssembler | (Inherited from BuildComponent.)

See Also

ShowMissingComponent Class
SandcastleBuilder.Components Namespace


TargetDirectory Class

[image]

Sandcastle Help File Builder Documentation
TargetDirectory Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is a reimplementation of the TargetDirectory class used by ResolveConceptualLinksComponent.

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.Components (in SandcastleBuilder.Components.dll) Version: 1.8.0.2

Syntax

C#
public class TargetDirectory
Visual Basic (Declaration)
Public Class TargetDirectory

Inheritance Hierarchy

System..::.Object
SandcastleBuilder.Components..::.TargetDirectory

See Also

TargetDirectory Members
SandcastleBuilder.Components Namespace


TargetDirectory Members

[image] [image]

Sandcastle Help File Builder Documentation
TargetDirectory Members
TargetDirectory Class Constructors Methods See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TargetDirectory type exposes the following members.

Constructors

Name | Description
TargetDirectory | Constructor

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTargetInfo | Get target info for the specified file
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TargetDirectory Class
SandcastleBuilder.Components Namespace


TargetDirectory Constructor

[image]

Sandcastle Help File Builder Documentation
TargetDirectory Constructor
TargetDirectory Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.Components (in SandcastleBuilder.Components.dll) Version: 1.8.0.2

Syntax

C#
public TargetDirectory(
    string targetDir,
    XPathExpression urlExp,
    XPathExpression textExp,
    XPathExpression linkTextExp,
    LinkType typeOfLink
)
Visual Basic (Declaration)
Public Sub New ( _
    targetDir As String, _
    urlExp As XPathExpression, _
    textExp As XPathExpression, _
    linkTextExp As XPathExpression, _
    typeOfLink As LinkType _
)

Parameters

targetDir
Type: System..::.String
The target directory
urlExp
Type: System.Xml.XPath..::.XPathExpression
The URL expression
textExp
Type: System.Xml.XPath..::.XPathExpression
The text (title) expression
linkTextExp
Type: System.Xml.XPath..::.XPathExpression
The alternate link text expression
typeOfLink
Type: SandcastleBuilder.Components..::.LinkType
The link type

Exceptions

Exception | Condition
System..::.ArgumentNullException | This is thrown if the directory, URL expression, or either text expression is null.

See Also

TargetDirectory Class
SandcastleBuilder.Components Namespace


TargetDirectory Methods

[image] [image]

Sandcastle Help File Builder Documentation
TargetDirectory Methods
TargetDirectory Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TargetDirectory type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTargetInfo | Get target info for the specified file
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TargetDirectory Class
SandcastleBuilder.Components Namespace


GetTargetInfo Method

[image]

Sandcastle Help File Builder Documentation
TargetDirectory..::.GetTargetInfo Method
TargetDirectory Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Get target info for the specified file

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.Components (in SandcastleBuilder.Components.dll) Version: 1.8.0.2

Syntax

C#
public TargetInfo GetTargetInfo(
    string file
)
Visual Basic (Declaration)
Public Function GetTargetInfo ( _
    file As String _
) As TargetInfo

Parameters

file
Type: System..::.String
The file for which to get target info

Return Value

A TargetInfo object if found or null if not found.

See Also

TargetDirectory Class
SandcastleBuilder.Components Namespace


TargetInfo Class

[image]

Sandcastle Help File Builder Documentation
TargetInfo Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is a reimplementation of the TargetInfo class used by ResolveConceptualLinksComponent.

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.Components (in SandcastleBuilder.Components.dll) Version: 1.8.0.2

Syntax

C#
public class TargetInfo
Visual Basic (Declaration)
Public Class TargetInfo

Inheritance Hierarchy

System..::.Object
SandcastleBuilder.Components..::.TargetInfo

See Also

TargetInfo Members
SandcastleBuilder.Components Namespace


TargetInfo Members

[image] [image]

Sandcastle Help File Builder Documentation
TargetInfo Members
TargetInfo Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TargetInfo type exposes the following members.

Constructors

Name | Description
TargetInfo | Constructor

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
LinkType | This read-only property is used to get the link type
Text | This read-only property is used to get the text
Url | This read-only property is used to get the URL

See Also

TargetInfo Class
SandcastleBuilder.Components Namespace


TargetInfo Constructor

[image]

Sandcastle Help File Builder Documentation
TargetInfo Constructor
TargetInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.Components (in SandcastleBuilder.Components.dll) Version: 1.8.0.2

Syntax

C#
public TargetInfo(
    string targetUrl,
    string targetText,
    LinkType typeOfLink
)
Visual Basic (Declaration)
Public Sub New ( _
    targetUrl As String, _
    targetText As String, _
    typeOfLink As LinkType _
)

Parameters

targetUrl
Type: System..::.String
The target URL
targetText
Type: System..::.String
The target's link text
typeOfLink
Type: SandcastleBuilder.Components..::.LinkType
The type of link

Exceptions

Exception | Condition
System..::.ArgumentNullException | This is thrown if the target URL or text is null.

See Also

TargetInfo Class
SandcastleBuilder.Components Namespace


TargetInfo Methods

[image] [image]

Sandcastle Help File Builder Documentation
TargetInfo Methods
TargetInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TargetInfo type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TargetInfo Class
SandcastleBuilder.Components Namespace


TargetInfo Properties

[image] [image]

Sandcastle Help File Builder Documentation
TargetInfo Properties
TargetInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TargetInfo type exposes the following members.

Properties

Name | Description
LinkType | This read-only property is used to get the link type
Text | This read-only property is used to get the text
Url | This read-only property is used to get the URL

See Also

TargetInfo Class
SandcastleBuilder.Components Namespace


LinkType Property

[image]

Sandcastle Help File Builder Documentation
TargetInfo..::.LinkType Property
TargetInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property is used to get the link type

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.Components (in SandcastleBuilder.Components.dll) Version: 1.8.0.2

Syntax

C#
public LinkType LinkType { get; }
Visual Basic (Declaration)
Public ReadOnly Property LinkType As LinkType

See Also

TargetInfo Class
SandcastleBuilder.Components Namespace


Text Property

[image]

Sandcastle Help File Builder Documentation
TargetInfo..::.Text Property
TargetInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property is used to get the text

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.Components (in SandcastleBuilder.Components.dll) Version: 1.8.0.2

Syntax

C#
public string Text { get; }
Visual Basic (Declaration)
Public ReadOnly Property Text As String

See Also

TargetInfo Class
SandcastleBuilder.Components Namespace


Url Property

[image]

Sandcastle Help File Builder Documentation
TargetInfo..::.Url Property
TargetInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property is used to get the URL

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.Components (in SandcastleBuilder.Components.dll) Version: 1.8.0.2

Syntax

C#
public string Url { get; }
Visual Basic (Declaration)
Public ReadOnly Property Url As String

See Also

TargetInfo Class
SandcastleBuilder.Components Namespace


VersionInfoComponent Class

[image]

Sandcastle Help File Builder Documentation
VersionInfoComponent Class
Members Example See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This build component is used to obtain version information for each topic so that it can be placed in the footer by the PostTransformComponent.

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.Components (in SandcastleBuilder.Components.dll) Version: 1.8.0.2

Syntax

C#
public class VersionInfoComponent : BuildComponent
Visual Basic (Declaration)
Public Class VersionInfoComponent _
    Inherits BuildComponent

Remarks

The PostTransformComponent adds the version information to the topic after it has been transformed into HTML. We need to get the version information here though as the reference information is lost once it has been transformed.

Examples

CopyExample configuration
<!-- Version information component configuration.  This must
     appear before the TransformComponent.  See also:
     PostTransformComponent -->
<component type="SandcastleBuilder.Components.VersionInfoComponent"
  assembly="C:\SandcastleBuilder\SandcastleBuilder.Components.dll">
    <!-- Reflection information file for version info (required) -->
    <reflectionFile filename="reflection.xml" />
</component>

Inheritance Hierarchy

System..::.Object
Microsoft.Ddue.Tools..::.BuildComponent
SandcastleBuilder.Components..::.VersionInfoComponent

See Also

VersionInfoComponent Members
SandcastleBuilder.Components Namespace


VersionInfoComponent Members

[image] [image]

Sandcastle Help File Builder Documentation
VersionInfoComponent Members
VersionInfoComponent Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The VersionInfoComponent type exposes the following members.

Constructors

Name | Description
VersionInfoComponent | Constructor

Methods

Name | Description
Apply | Overloaded.
Dispose | (Inherited from BuildComponent.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnComponentEvent | (Inherited from BuildComponent.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteMessage | (Inherited from BuildComponent.)

Properties

Name | Description
BuildAssembler | (Inherited from BuildComponent.)
ItemVersions | This is used by the PostTransformComponent to get the assembly versions for the current topic.

See Also

VersionInfoComponent Class
SandcastleBuilder.Components Namespace


VersionInfoComponent Constructor

[image]

Sandcastle Help File Builder Documentation
VersionInfoComponent Constructor
VersionInfoComponent Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.Components (in SandcastleBuilder.Components.dll) Version: 1.8.0.2

Syntax

C#
public VersionInfoComponent(
    BuildAssembler assembler,
    XPathNavigator configuration
)
Visual Basic (Declaration)
Public Sub New ( _
    assembler As BuildAssembler, _
    configuration As XPathNavigator _
)

Parameters

assembler
Type: Microsoft.Ddue.Tools..::.BuildAssembler
A reference to the build assembler.
configuration
Type: System.Xml.XPath..::.XPathNavigator
The configuration information

Remarks

See the VersionInfoComponent class topic for an example of the configuration

Exceptions

Exception | Condition
System.Configuration..::.ConfigurationErrorsException | This is thrown if an error is detected in the configuration.

See Also

VersionInfoComponent Class
SandcastleBuilder.Components Namespace


VersionInfoComponent Methods

[image] [image]

Sandcastle Help File Builder Documentation
VersionInfoComponent Methods
VersionInfoComponent Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The VersionInfoComponent type exposes the following members.

Methods

Name | Description
Apply | Overloaded.
Dispose | (Inherited from BuildComponent.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnComponentEvent | (Inherited from BuildComponent.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteMessage | (Inherited from BuildComponent.)

See Also

VersionInfoComponent Class
SandcastleBuilder.Components Namespace


Apply Method

[image] [image]

Sandcastle Help File Builder Documentation
VersionInfoComponent..::.Apply Method
VersionInfoComponent Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Apply(XmlDocument) | (Inherited from BuildComponent.)
Apply(XmlDocument, String) | This is implemented to set the version information ready for use by the PostTransformComponent. (Overrides BuildComponent..::.Apply(XmlDocument, String).)

See Also

VersionInfoComponent Class
VersionInfoComponent Members
SandcastleBuilder.Components Namespace


Apply Method (XmlDocument, String)

[image]

Sandcastle Help File Builder Documentation
VersionInfoComponent..::.Apply Method (XmlDocument, String)
VersionInfoComponent Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is implemented to set the version information ready for use by the PostTransformComponent.

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.Components (in SandcastleBuilder.Components.dll) Version: 1.8.0.2

Syntax

C#
public override void Apply(
    XmlDocument document,
    string key
)
Visual Basic (Declaration)
Public Overrides Sub Apply ( _
    document As XmlDocument, _
    key As String _
)

Parameters

document
Type: System.Xml..::.XmlDocument
The XML document with which to work.
key
Type: System..::.String
The key (member name) of the item being documented.

See Also

VersionInfoComponent Class
Apply Overload
SandcastleBuilder.Components Namespace


VersionInfoComponent Properties

[image] [image]

Sandcastle Help File Builder Documentation
VersionInfoComponent Properties
VersionInfoComponent Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The VersionInfoComponent type exposes the following members.

Properties

Name | Description
BuildAssembler | (Inherited from BuildComponent.)
ItemVersions | This is used by the PostTransformComponent to get the assembly versions for the current topic.

See Also

VersionInfoComponent Class
SandcastleBuilder.Components Namespace


ItemVersions Property

[image]

Sandcastle Help File Builder Documentation
VersionInfoComponent..::.ItemVersions Property
VersionInfoComponent Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used by the PostTransformComponent to get the assembly versions for the current topic.

Namespace: SandcastleBuilder.Components
Assembly: SandcastleBuilder.Components (in SandcastleBuilder.Components.dll) Version: 1.8.0.2

Syntax

C#
public static Collection<string> ItemVersions { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ItemVersions As Collection(Of String)

See Also

VersionInfoComponent Class
SandcastleBuilder.Components Namespace


SandcastleBuilder.Gui Namespace

[image]

Sandcastle Help File Builder Documentation
SandcastleBuilder.Gui Namespace
Send Feedback

[This is preliminary documentation and is subject to change.]

This namespace contains the classes for the GUI help file builder and project manager.

Classes

Class | Description
AboutDlg | This form is used to display application version information.
MainForm | This is the main form for the application
NewFromOtherFormatDlg | This form is used to convert a project in a different format to the new MSBuild format used by SHFB 1.8.0.0 and later.
PromptToSaveDlg | This form is used to prompt to save files before a build
StartUp | This class contains the main entry point and other start up code.
UserPreferencesDlg | This form is used to allow the user to modify help file builder preferences unrelated to projects.

Structures

Structure | Description
WINDOWPLACEMENT | This structure is used to get and set the main form's position

Enumerations

Enumeration | Description
BeforeBuildAction | This is used to determine what to do with unsaved files before building a project.


AboutDlg Class

[image]

Sandcastle Help File Builder Documentation
AboutDlg Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This form is used to display application version information.

Namespace: SandcastleBuilder.Gui
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public class AboutDlg : Form
Visual Basic (Declaration)
Public Class AboutDlg _
    Inherits Form

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
SandcastleBuilder.Gui..::.AboutDlg

See Also

AboutDlg Members
SandcastleBuilder.Gui Namespace


AboutDlg Members

[image] [image]

Sandcastle Help File Builder Documentation
AboutDlg Members
AboutDlg Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The AboutDlg type exposes the following members.

Constructors

Name | Description
AboutDlg | Constructor

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

AboutDlg Class
SandcastleBuilder.Gui Namespace


AboutDlg Constructor

[image]

Sandcastle Help File Builder Documentation
AboutDlg Constructor
AboutDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Gui
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public AboutDlg()
Visual Basic (Declaration)
Public Sub New

See Also

AboutDlg Class
SandcastleBuilder.Gui Namespace


AboutDlg Methods

[image] [image]

Sandcastle Help File Builder Documentation
AboutDlg Methods
AboutDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The AboutDlg type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

See Also

AboutDlg Class
SandcastleBuilder.Gui Namespace


AccessibilityNotifyClients Method

[image] [image]

Sandcastle Help File Builder Documentation
AboutDlg..::.AccessibilityNotifyClients Method
AboutDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

AboutDlg Class
AboutDlg Members
SandcastleBuilder.Gui Namespace


BeginInvoke Method

[image] [image]

Sandcastle Help File Builder Documentation
AboutDlg..::.BeginInvoke Method
AboutDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

AboutDlg Class
AboutDlg Members
SandcastleBuilder.Gui Namespace


Dispose Method

[image] [image]

Sandcastle Help File Builder Documentation
AboutDlg..::.Dispose Method
AboutDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides Form..::.Dispose(Boolean).)

See Also

AboutDlg Class
AboutDlg Members
SandcastleBuilder.Gui Namespace


Dispose Method (Boolean)

[image]

Sandcastle Help File Builder Documentation
AboutDlg..::.Dispose Method (Boolean)
AboutDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: SandcastleBuilder.Gui
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

AboutDlg Class
Dispose Overload
SandcastleBuilder.Gui Namespace


GetChildAtPoint Method

[image] [image]

Sandcastle Help File Builder Documentation
AboutDlg..::.GetChildAtPoint Method
AboutDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

AboutDlg Class
AboutDlg Members
SandcastleBuilder.Gui Namespace


Invalidate Method

[image] [image]

Sandcastle Help File Builder Documentation
AboutDlg..::.Invalidate Method
AboutDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

AboutDlg Class
AboutDlg Members
SandcastleBuilder.Gui Namespace


Invoke Method

[image] [image]

Sandcastle Help File Builder Documentation
AboutDlg..::.Invoke Method
AboutDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

AboutDlg Class
AboutDlg Members
SandcastleBuilder.Gui Namespace


MemberwiseClone Method

[image] [image]

Sandcastle Help File Builder Documentation
AboutDlg..::.MemberwiseClone Method
AboutDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

AboutDlg Class
AboutDlg Members
SandcastleBuilder.Gui Namespace


PerformLayout Method

[image] [image]

Sandcastle Help File Builder Documentation
AboutDlg..::.PerformLayout Method
AboutDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

AboutDlg Class
AboutDlg Members
SandcastleBuilder.Gui Namespace


ResumeLayout Method

[image] [image]

Sandcastle Help File Builder Documentation
AboutDlg..::.ResumeLayout Method
AboutDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

AboutDlg Class
AboutDlg Members
SandcastleBuilder.Gui Namespace


RtlTranslateAlignment Method

[image] [image]

Sandcastle Help File Builder Documentation
AboutDlg..::.RtlTranslateAlignment Method
AboutDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

AboutDlg Class
AboutDlg Members
SandcastleBuilder.Gui Namespace


Scale Method

[image] [image]

Sandcastle Help File Builder Documentation
AboutDlg..::.Scale Method
AboutDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

AboutDlg Class
AboutDlg Members
SandcastleBuilder.Gui Namespace


Select Method

[image] [image]

Sandcastle Help File Builder Documentation
AboutDlg..::.Select Method
AboutDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)

See Also

AboutDlg Class
AboutDlg Members
SandcastleBuilder.Gui Namespace


SetBounds Method

[image] [image]

Sandcastle Help File Builder Documentation
AboutDlg..::.SetBounds Method
AboutDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

AboutDlg Class
AboutDlg Members
SandcastleBuilder.Gui Namespace


Show Method

[image] [image]

Sandcastle Help File Builder Documentation
AboutDlg..::.Show Method
AboutDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Show()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

AboutDlg Class
AboutDlg Members
SandcastleBuilder.Gui Namespace


ShowDialog Method

[image] [image]

Sandcastle Help File Builder Documentation
AboutDlg..::.ShowDialog Method
AboutDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)

See Also

AboutDlg Class
AboutDlg Members
SandcastleBuilder.Gui Namespace


UpdateBounds Method

[image] [image]

Sandcastle Help File Builder Documentation
AboutDlg..::.UpdateBounds Method
AboutDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

AboutDlg Class
AboutDlg Members
SandcastleBuilder.Gui Namespace


Validate Method

[image] [image]

Sandcastle Help File Builder Documentation
AboutDlg..::.Validate Method
AboutDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

AboutDlg Class
AboutDlg Members
SandcastleBuilder.Gui Namespace


ValidateChildren Method

[image] [image]

Sandcastle Help File Builder Documentation
AboutDlg..::.ValidateChildren Method
AboutDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

AboutDlg Class
AboutDlg Members
SandcastleBuilder.Gui Namespace


AboutDlg Properties

[image] [image]

Sandcastle Help File Builder Documentation
AboutDlg Properties
AboutDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The AboutDlg type exposes the following members.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

AboutDlg Class
SandcastleBuilder.Gui Namespace


AboutDlg Events

[image] [image]

Sandcastle Help File Builder Documentation
AboutDlg Events
AboutDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The AboutDlg type exposes the following members.

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

AboutDlg Class
SandcastleBuilder.Gui Namespace


BeforeBuildAction Enumeration

[image]

Sandcastle Help File Builder Documentation
BeforeBuildAction Enumeration
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to determine what to do with unsaved files before building a project.

Namespace: SandcastleBuilder.Gui
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public enum BeforeBuildAction
Visual Basic (Declaration)
Public Enumeration BeforeBuildAction

Members

Member name | Description
SaveAllChanges | Save all changes to documents and the project.
SaveOpenDocuments | Only save changes to open documents.
PromptToSaveAll | Prompt to save changes to all open documents and the project.
DoNotSave | Do not save any changes.

See Also

SandcastleBuilder.Gui Namespace


MainForm Class

[image]

Sandcastle Help File Builder Documentation
MainForm Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is the main form for the application

Namespace: SandcastleBuilder.Gui
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public class MainForm : Form
Visual Basic (Declaration)
Public Class MainForm _
    Inherits Form

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
SandcastleBuilder.Gui..::.MainForm

See Also

MainForm Members
SandcastleBuilder.Gui Namespace


MainForm Members

[image] [image]

Sandcastle Help File Builder Documentation
MainForm Members
MainForm Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The MainForm type exposes the following members.

Constructors

Name | Description
MainForm | Constructor

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Host | Return a reference to the main form
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
ProjectExplorer | Get a reference to the Project Explorer pane
ProjectExplorerMenu | Get a reference to the Project Explorer menu item
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
StatusBarTextLabel | Get a reference to the status strip label used for status bar text
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

MainForm Class
SandcastleBuilder.Gui Namespace


MainForm Constructor

[image]

Sandcastle Help File Builder Documentation
MainForm Constructor
MainForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Gui
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public MainForm(
    string projectToLoad
)
Visual Basic (Declaration)
Public Sub New ( _
    projectToLoad As String _
)

Parameters

projectToLoad
Type: System..::.String
A default project file to load. If not specified, the most recently used project is loaded if there is one.

See Also

MainForm Class
SandcastleBuilder.Gui Namespace


MainForm Methods

[image] [image]

Sandcastle Help File Builder Documentation
MainForm Methods
MainForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The MainForm type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

See Also

MainForm Class
SandcastleBuilder.Gui Namespace


AccessibilityNotifyClients Method

[image] [image]

Sandcastle Help File Builder Documentation
MainForm..::.AccessibilityNotifyClients Method
MainForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

MainForm Class
MainForm Members
SandcastleBuilder.Gui Namespace


BeginInvoke Method

[image] [image]

Sandcastle Help File Builder Documentation
MainForm..::.BeginInvoke Method
MainForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

MainForm Class
MainForm Members
SandcastleBuilder.Gui Namespace


Dispose Method

[image] [image]

Sandcastle Help File Builder Documentation
MainForm..::.Dispose Method
MainForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides Form..::.Dispose(Boolean).)

See Also

MainForm Class
MainForm Members
SandcastleBuilder.Gui Namespace


Dispose Method (Boolean)

[image]

Sandcastle Help File Builder Documentation
MainForm..::.Dispose Method (Boolean)
MainForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: SandcastleBuilder.Gui
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

MainForm Class
Dispose Overload
SandcastleBuilder.Gui Namespace


GetChildAtPoint Method

[image] [image]

Sandcastle Help File Builder Documentation
MainForm..::.GetChildAtPoint Method
MainForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

MainForm Class
MainForm Members
SandcastleBuilder.Gui Namespace


Invalidate Method

[image] [image]

Sandcastle Help File Builder Documentation
MainForm..::.Invalidate Method
MainForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

MainForm Class
MainForm Members
SandcastleBuilder.Gui Namespace


Invoke Method

[image] [image]

Sandcastle Help File Builder Documentation
MainForm..::.Invoke Method
MainForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

MainForm Class
MainForm Members
SandcastleBuilder.Gui Namespace


MemberwiseClone Method

[image] [image]

Sandcastle Help File Builder Documentation
MainForm..::.MemberwiseClone Method
MainForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

MainForm Class
MainForm Members
SandcastleBuilder.Gui Namespace


PerformLayout Method

[image] [image]

Sandcastle Help File Builder Documentation
MainForm..::.PerformLayout Method
MainForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

MainForm Class
MainForm Members
SandcastleBuilder.Gui Namespace


ResumeLayout Method

[image] [image]

Sandcastle Help File Builder Documentation
MainForm..::.ResumeLayout Method
MainForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

MainForm Class
MainForm Members
SandcastleBuilder.Gui Namespace


RtlTranslateAlignment Method

[image] [image]

Sandcastle Help File Builder Documentation
MainForm..::.RtlTranslateAlignment Method
MainForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

MainForm Class
MainForm Members
SandcastleBuilder.Gui Namespace


Scale Method

[image] [image]

Sandcastle Help File Builder Documentation
MainForm..::.Scale Method
MainForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

MainForm Class
MainForm Members
SandcastleBuilder.Gui Namespace


Select Method

[image] [image]

Sandcastle Help File Builder Documentation
MainForm..::.Select Method
MainForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)

See Also

MainForm Class
MainForm Members
SandcastleBuilder.Gui Namespace


SetBounds Method

[image] [image]

Sandcastle Help File Builder Documentation
MainForm..::.SetBounds Method
MainForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

MainForm Class
MainForm Members
SandcastleBuilder.Gui Namespace


Show Method

[image] [image]

Sandcastle Help File Builder Documentation
MainForm..::.Show Method
MainForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Show()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

MainForm Class
MainForm Members
SandcastleBuilder.Gui Namespace


ShowDialog Method

[image] [image]

Sandcastle Help File Builder Documentation
MainForm..::.ShowDialog Method
MainForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)

See Also

MainForm Class
MainForm Members
SandcastleBuilder.Gui Namespace


UpdateBounds Method

[image] [image]

Sandcastle Help File Builder Documentation
MainForm..::.UpdateBounds Method
MainForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

MainForm Class
MainForm Members
SandcastleBuilder.Gui Namespace


Validate Method

[image] [image]

Sandcastle Help File Builder Documentation
MainForm..::.Validate Method
MainForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

MainForm Class
MainForm Members
SandcastleBuilder.Gui Namespace


ValidateChildren Method

[image] [image]

Sandcastle Help File Builder Documentation
MainForm..::.ValidateChildren Method
MainForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

MainForm Class
MainForm Members
SandcastleBuilder.Gui Namespace


MainForm Properties

[image] [image]

Sandcastle Help File Builder Documentation
MainForm Properties
MainForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The MainForm type exposes the following members.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Host | Return a reference to the main form
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
ProjectExplorer | Get a reference to the Project Explorer pane
ProjectExplorerMenu | Get a reference to the Project Explorer menu item
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
StatusBarTextLabel | Get a reference to the status strip label used for status bar text
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

MainForm Class
SandcastleBuilder.Gui Namespace


Host Property

[image]

Sandcastle Help File Builder Documentation
MainForm..::.Host Property
MainForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Return a reference to the main form

Namespace: SandcastleBuilder.Gui
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public static MainForm Host { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Host As MainForm

Remarks

This is used to let the various panes communicate between each other. There are probably several different ways to do this that are better but this is quick and dirty and it works.

See Also

MainForm Class
SandcastleBuilder.Gui Namespace


ProjectExplorer Property

[image]

Sandcastle Help File Builder Documentation
MainForm..::.ProjectExplorer Property
MainForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Get a reference to the Project Explorer pane

Namespace: SandcastleBuilder.Gui
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public ProjectExplorerWindow ProjectExplorer { get; }
Visual Basic (Declaration)
Public ReadOnly Property ProjectExplorer As ProjectExplorerWindow

See Also

MainForm Class
SandcastleBuilder.Gui Namespace


ProjectExplorerMenu Property

[image]

Sandcastle Help File Builder Documentation
MainForm..::.ProjectExplorerMenu Property
MainForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Get a reference to the Project Explorer menu item

Namespace: SandcastleBuilder.Gui
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public ToolStripMenuItem ProjectExplorerMenu { get; }
Visual Basic (Declaration)
Public ReadOnly Property ProjectExplorerMenu As ToolStripMenuItem

See Also

MainForm Class
SandcastleBuilder.Gui Namespace


StatusBarTextLabel Property

[image]

Sandcastle Help File Builder Documentation
MainForm..::.StatusBarTextLabel Property
MainForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Get a reference to the status strip label used for status bar text

Namespace: SandcastleBuilder.Gui
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public ToolStripStatusLabel StatusBarTextLabel { get; }
Visual Basic (Declaration)
Public ReadOnly Property StatusBarTextLabel As ToolStripStatusLabel

See Also

MainForm Class
SandcastleBuilder.Gui Namespace


MainForm Events

[image] [image]

Sandcastle Help File Builder Documentation
MainForm Events
MainForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The MainForm type exposes the following members.

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

MainForm Class
SandcastleBuilder.Gui Namespace


NewFromOtherFormatDlg Class

[image]

Sandcastle Help File Builder Documentation
NewFromOtherFormatDlg Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This form is used to convert a project in a different format to the new MSBuild format used by SHFB 1.8.0.0 and later.

Namespace: SandcastleBuilder.Gui
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public class NewFromOtherFormatDlg : Form
Visual Basic (Declaration)
Public Class NewFromOtherFormatDlg _
    Inherits Form

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
SandcastleBuilder.Gui..::.NewFromOtherFormatDlg

See Also

NewFromOtherFormatDlg Members
SandcastleBuilder.Gui Namespace


NewFromOtherFormatDlg Members

[image] [image]

Sandcastle Help File Builder Documentation
NewFromOtherFormatDlg Members
NewFromOtherFormatDlg Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The NewFromOtherFormatDlg type exposes the following members.

Constructors

Name | Description
NewFromOtherFormatDlg | Constructor

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
NewProjectFilename | Upon successful conversion, this will return the name of the new project file.
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

NewFromOtherFormatDlg Class
SandcastleBuilder.Gui Namespace


NewFromOtherFormatDlg Constructor

[image]

Sandcastle Help File Builder Documentation
NewFromOtherFormatDlg Constructor
NewFromOtherFormatDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Gui
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public NewFromOtherFormatDlg()
Visual Basic (Declaration)
Public Sub New

See Also

NewFromOtherFormatDlg Class
SandcastleBuilder.Gui Namespace


NewFromOtherFormatDlg Methods

[image] [image]

Sandcastle Help File Builder Documentation
NewFromOtherFormatDlg Methods
NewFromOtherFormatDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The NewFromOtherFormatDlg type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

See Also

NewFromOtherFormatDlg Class
SandcastleBuilder.Gui Namespace


AccessibilityNotifyClients Method

[image] [image]

Sandcastle Help File Builder Documentation
NewFromOtherFormatDlg..::.AccessibilityNotifyClients Method
NewFromOtherFormatDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

NewFromOtherFormatDlg Class
NewFromOtherFormatDlg Members
SandcastleBuilder.Gui Namespace


BeginInvoke Method

[image] [image]

Sandcastle Help File Builder Documentation
NewFromOtherFormatDlg..::.BeginInvoke Method
NewFromOtherFormatDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

NewFromOtherFormatDlg Class
NewFromOtherFormatDlg Members
SandcastleBuilder.Gui Namespace


Dispose Method

[image] [image]

Sandcastle Help File Builder Documentation
NewFromOtherFormatDlg..::.Dispose Method
NewFromOtherFormatDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides Form..::.Dispose(Boolean).)

See Also

NewFromOtherFormatDlg Class
NewFromOtherFormatDlg Members
SandcastleBuilder.Gui Namespace


Dispose Method (Boolean)

[image]

Sandcastle Help File Builder Documentation
NewFromOtherFormatDlg..::.Dispose Method (Boolean)
NewFromOtherFormatDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: SandcastleBuilder.Gui
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

NewFromOtherFormatDlg Class
Dispose Overload
SandcastleBuilder.Gui Namespace


GetChildAtPoint Method

[image] [image]

Sandcastle Help File Builder Documentation
NewFromOtherFormatDlg..::.GetChildAtPoint Method
NewFromOtherFormatDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

NewFromOtherFormatDlg Class
NewFromOtherFormatDlg Members
SandcastleBuilder.Gui Namespace


Invalidate Method

[image] [image]

Sandcastle Help File Builder Documentation
NewFromOtherFormatDlg..::.Invalidate Method
NewFromOtherFormatDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

NewFromOtherFormatDlg Class
NewFromOtherFormatDlg Members
SandcastleBuilder.Gui Namespace


Invoke Method

[image] [image]

Sandcastle Help File Builder Documentation
NewFromOtherFormatDlg..::.Invoke Method
NewFromOtherFormatDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

NewFromOtherFormatDlg Class
NewFromOtherFormatDlg Members
SandcastleBuilder.Gui Namespace


MemberwiseClone Method

[image] [image]

Sandcastle Help File Builder Documentation
NewFromOtherFormatDlg..::.MemberwiseClone Method
NewFromOtherFormatDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

NewFromOtherFormatDlg Class
NewFromOtherFormatDlg Members
SandcastleBuilder.Gui Namespace


PerformLayout Method

[image] [image]

Sandcastle Help File Builder Documentation
NewFromOtherFormatDlg..::.PerformLayout Method
NewFromOtherFormatDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

NewFromOtherFormatDlg Class
NewFromOtherFormatDlg Members
SandcastleBuilder.Gui Namespace


ResumeLayout Method

[image] [image]

Sandcastle Help File Builder Documentation
NewFromOtherFormatDlg..::.ResumeLayout Method
NewFromOtherFormatDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

NewFromOtherFormatDlg Class
NewFromOtherFormatDlg Members
SandcastleBuilder.Gui Namespace


RtlTranslateAlignment Method

[image] [image]

Sandcastle Help File Builder Documentation
NewFromOtherFormatDlg..::.RtlTranslateAlignment Method
NewFromOtherFormatDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

NewFromOtherFormatDlg Class
NewFromOtherFormatDlg Members
SandcastleBuilder.Gui Namespace


Scale Method

[image] [image]

Sandcastle Help File Builder Documentation
NewFromOtherFormatDlg..::.Scale Method
NewFromOtherFormatDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

NewFromOtherFormatDlg Class
NewFromOtherFormatDlg Members
SandcastleBuilder.Gui Namespace


Select Method

[image] [image]

Sandcastle Help File Builder Documentation
NewFromOtherFormatDlg..::.Select Method
NewFromOtherFormatDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)

See Also

NewFromOtherFormatDlg Class
NewFromOtherFormatDlg Members
SandcastleBuilder.Gui Namespace


SetBounds Method

[image] [image]

Sandcastle Help File Builder Documentation
NewFromOtherFormatDlg..::.SetBounds Method
NewFromOtherFormatDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

NewFromOtherFormatDlg Class
NewFromOtherFormatDlg Members
SandcastleBuilder.Gui Namespace


Show Method

[image] [image]

Sandcastle Help File Builder Documentation
NewFromOtherFormatDlg..::.Show Method
NewFromOtherFormatDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Show()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

NewFromOtherFormatDlg Class
NewFromOtherFormatDlg Members
SandcastleBuilder.Gui Namespace


ShowDialog Method

[image] [image]

Sandcastle Help File Builder Documentation
NewFromOtherFormatDlg..::.ShowDialog Method
NewFromOtherFormatDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)

See Also

NewFromOtherFormatDlg Class
NewFromOtherFormatDlg Members
SandcastleBuilder.Gui Namespace


UpdateBounds Method

[image] [image]

Sandcastle Help File Builder Documentation
NewFromOtherFormatDlg..::.UpdateBounds Method
NewFromOtherFormatDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

NewFromOtherFormatDlg Class
NewFromOtherFormatDlg Members
SandcastleBuilder.Gui Namespace


Validate Method

[image] [image]

Sandcastle Help File Builder Documentation
NewFromOtherFormatDlg..::.Validate Method
NewFromOtherFormatDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

NewFromOtherFormatDlg Class
NewFromOtherFormatDlg Members
SandcastleBuilder.Gui Namespace


ValidateChildren Method

[image] [image]

Sandcastle Help File Builder Documentation
NewFromOtherFormatDlg..::.ValidateChildren Method
NewFromOtherFormatDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

NewFromOtherFormatDlg Class
NewFromOtherFormatDlg Members
SandcastleBuilder.Gui Namespace


NewFromOtherFormatDlg Properties

[image] [image]

Sandcastle Help File Builder Documentation
NewFromOtherFormatDlg Properties
NewFromOtherFormatDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The NewFromOtherFormatDlg type exposes the following members.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
NewProjectFilename | Upon successful conversion, this will return the name of the new project file.
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

NewFromOtherFormatDlg Class
SandcastleBuilder.Gui Namespace


NewProjectFilename Property

[image]

Sandcastle Help File Builder Documentation
NewFromOtherFormatDlg..::.NewProjectFilename Property
NewFromOtherFormatDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Upon successful conversion, this will return the name of the new project file.

Namespace: SandcastleBuilder.Gui
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public string NewProjectFilename { get; }
Visual Basic (Declaration)
Public ReadOnly Property NewProjectFilename As String

See Also

NewFromOtherFormatDlg Class
SandcastleBuilder.Gui Namespace


NewFromOtherFormatDlg Events

[image] [image]

Sandcastle Help File Builder Documentation
NewFromOtherFormatDlg Events
NewFromOtherFormatDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The NewFromOtherFormatDlg type exposes the following members.

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

NewFromOtherFormatDlg Class
SandcastleBuilder.Gui Namespace


PromptToSaveDlg Class

[image]

Sandcastle Help File Builder Documentation
PromptToSaveDlg Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This form is used to prompt to save files before a build

Namespace: SandcastleBuilder.Gui
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public class PromptToSaveDlg : Form
Visual Basic (Declaration)
Public Class PromptToSaveDlg _
    Inherits Form

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
SandcastleBuilder.Gui..::.PromptToSaveDlg

See Also

PromptToSaveDlg Members
SandcastleBuilder.Gui Namespace


PromptToSaveDlg Members

[image] [image]

Sandcastle Help File Builder Documentation
PromptToSaveDlg Members
PromptToSaveDlg Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PromptToSaveDlg type exposes the following members.

Constructors

Name | Description
PromptToSaveDlg | Constructor

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

PromptToSaveDlg Class
SandcastleBuilder.Gui Namespace


PromptToSaveDlg Constructor

[image]

Sandcastle Help File Builder Documentation
PromptToSaveDlg Constructor
PromptToSaveDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Gui
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public PromptToSaveDlg(
    Collection<BaseContentEditor> filesToSave
)
Visual Basic (Declaration)
Public Sub New ( _
    filesToSave As Collection(Of BaseContentEditor) _
)

Parameters

filesToSave
Type: System.Collections.ObjectModel..::.Collection <(Of <( BaseContentEditor >)>)
A collection containing the editors with files to save.

See Also

PromptToSaveDlg Class
SandcastleBuilder.Gui Namespace


PromptToSaveDlg Methods

[image] [image]

Sandcastle Help File Builder Documentation
PromptToSaveDlg Methods
PromptToSaveDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PromptToSaveDlg type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

See Also

PromptToSaveDlg Class
SandcastleBuilder.Gui Namespace


AccessibilityNotifyClients Method

[image] [image]

Sandcastle Help File Builder Documentation
PromptToSaveDlg..::.AccessibilityNotifyClients Method
PromptToSaveDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

PromptToSaveDlg Class
PromptToSaveDlg Members
SandcastleBuilder.Gui Namespace


BeginInvoke Method

[image] [image]

Sandcastle Help File Builder Documentation
PromptToSaveDlg..::.BeginInvoke Method
PromptToSaveDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

PromptToSaveDlg Class
PromptToSaveDlg Members
SandcastleBuilder.Gui Namespace


Dispose Method

[image] [image]

Sandcastle Help File Builder Documentation
PromptToSaveDlg..::.Dispose Method
PromptToSaveDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides Form..::.Dispose(Boolean).)

See Also

PromptToSaveDlg Class
PromptToSaveDlg Members
SandcastleBuilder.Gui Namespace


Dispose Method (Boolean)

[image]

Sandcastle Help File Builder Documentation
PromptToSaveDlg..::.Dispose Method (Boolean)
PromptToSaveDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: SandcastleBuilder.Gui
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

PromptToSaveDlg Class
Dispose Overload
SandcastleBuilder.Gui Namespace


GetChildAtPoint Method

[image] [image]

Sandcastle Help File Builder Documentation
PromptToSaveDlg..::.GetChildAtPoint Method
PromptToSaveDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

PromptToSaveDlg Class
PromptToSaveDlg Members
SandcastleBuilder.Gui Namespace


Invalidate Method

[image] [image]

Sandcastle Help File Builder Documentation
PromptToSaveDlg..::.Invalidate Method
PromptToSaveDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

PromptToSaveDlg Class
PromptToSaveDlg Members
SandcastleBuilder.Gui Namespace


Invoke Method

[image] [image]

Sandcastle Help File Builder Documentation
PromptToSaveDlg..::.Invoke Method
PromptToSaveDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

PromptToSaveDlg Class
PromptToSaveDlg Members
SandcastleBuilder.Gui Namespace


MemberwiseClone Method

[image] [image]

Sandcastle Help File Builder Documentation
PromptToSaveDlg..::.MemberwiseClone Method
PromptToSaveDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

PromptToSaveDlg Class
PromptToSaveDlg Members
SandcastleBuilder.Gui Namespace


PerformLayout Method

[image] [image]

Sandcastle Help File Builder Documentation
PromptToSaveDlg..::.PerformLayout Method
PromptToSaveDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

PromptToSaveDlg Class
PromptToSaveDlg Members
SandcastleBuilder.Gui Namespace


ResumeLayout Method

[image] [image]

Sandcastle Help File Builder Documentation
PromptToSaveDlg..::.ResumeLayout Method
PromptToSaveDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

PromptToSaveDlg Class
PromptToSaveDlg Members
SandcastleBuilder.Gui Namespace


RtlTranslateAlignment Method

[image] [image]

Sandcastle Help File Builder Documentation
PromptToSaveDlg..::.RtlTranslateAlignment Method
PromptToSaveDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

PromptToSaveDlg Class
PromptToSaveDlg Members
SandcastleBuilder.Gui Namespace


Scale Method

[image] [image]

Sandcastle Help File Builder Documentation
PromptToSaveDlg..::.Scale Method
PromptToSaveDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

PromptToSaveDlg Class
PromptToSaveDlg Members
SandcastleBuilder.Gui Namespace


Select Method

[image] [image]

Sandcastle Help File Builder Documentation
PromptToSaveDlg..::.Select Method
PromptToSaveDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)

See Also

PromptToSaveDlg Class
PromptToSaveDlg Members
SandcastleBuilder.Gui Namespace


SetBounds Method

[image] [image]

Sandcastle Help File Builder Documentation
PromptToSaveDlg..::.SetBounds Method
PromptToSaveDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

PromptToSaveDlg Class
PromptToSaveDlg Members
SandcastleBuilder.Gui Namespace


Show Method

[image] [image]

Sandcastle Help File Builder Documentation
PromptToSaveDlg..::.Show Method
PromptToSaveDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Show()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

PromptToSaveDlg Class
PromptToSaveDlg Members
SandcastleBuilder.Gui Namespace


ShowDialog Method

[image] [image]

Sandcastle Help File Builder Documentation
PromptToSaveDlg..::.ShowDialog Method
PromptToSaveDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)

See Also

PromptToSaveDlg Class
PromptToSaveDlg Members
SandcastleBuilder.Gui Namespace


UpdateBounds Method

[image] [image]

Sandcastle Help File Builder Documentation
PromptToSaveDlg..::.UpdateBounds Method
PromptToSaveDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

PromptToSaveDlg Class
PromptToSaveDlg Members
SandcastleBuilder.Gui Namespace


Validate Method

[image] [image]

Sandcastle Help File Builder Documentation
PromptToSaveDlg..::.Validate Method
PromptToSaveDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

PromptToSaveDlg Class
PromptToSaveDlg Members
SandcastleBuilder.Gui Namespace


ValidateChildren Method

[image] [image]

Sandcastle Help File Builder Documentation
PromptToSaveDlg..::.ValidateChildren Method
PromptToSaveDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

PromptToSaveDlg Class
PromptToSaveDlg Members
SandcastleBuilder.Gui Namespace


PromptToSaveDlg Properties

[image] [image]

Sandcastle Help File Builder Documentation
PromptToSaveDlg Properties
PromptToSaveDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PromptToSaveDlg type exposes the following members.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

PromptToSaveDlg Class
SandcastleBuilder.Gui Namespace


PromptToSaveDlg Events

[image] [image]

Sandcastle Help File Builder Documentation
PromptToSaveDlg Events
PromptToSaveDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PromptToSaveDlg type exposes the following members.

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

PromptToSaveDlg Class
SandcastleBuilder.Gui Namespace


StartUp Class

[image]

Sandcastle Help File Builder Documentation
StartUp Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This class contains the main entry point and other start up code.

Namespace: SandcastleBuilder.Gui
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public sealed class StartUp
Visual Basic (Declaration)
Public NotInheritable Class StartUp

Inheritance Hierarchy

System..::.Object
SandcastleBuilder.Gui..::.StartUp

See Also

StartUp Members
SandcastleBuilder.Gui Namespace


StartUp Members

[image] [image]

Sandcastle Help File Builder Documentation
StartUp Members
StartUp Class Methods See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The StartUp type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StartUp Class
SandcastleBuilder.Gui Namespace


StartUp Methods

[image] [image]

Sandcastle Help File Builder Documentation
StartUp Methods
StartUp Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The StartUp type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StartUp Class
SandcastleBuilder.Gui Namespace


UserPreferencesDlg Class

[image]

Sandcastle Help File Builder Documentation
UserPreferencesDlg Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This form is used to allow the user to modify help file builder preferences unrelated to projects.

Namespace: SandcastleBuilder.Gui
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public class UserPreferencesDlg : Form
Visual Basic (Declaration)
Public Class UserPreferencesDlg _
    Inherits Form

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
SandcastleBuilder.Gui..::.UserPreferencesDlg

See Also

UserPreferencesDlg Members
SandcastleBuilder.Gui Namespace


UserPreferencesDlg Members

[image] [image]

Sandcastle Help File Builder Documentation
UserPreferencesDlg Members
UserPreferencesDlg Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The UserPreferencesDlg type exposes the following members.

Constructors

Name | Description
UserPreferencesDlg | Constructor

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

UserPreferencesDlg Class
SandcastleBuilder.Gui Namespace


UserPreferencesDlg Constructor

[image]

Sandcastle Help File Builder Documentation
UserPreferencesDlg Constructor
UserPreferencesDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Gui
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public UserPreferencesDlg()
Visual Basic (Declaration)
Public Sub New

See Also

UserPreferencesDlg Class
SandcastleBuilder.Gui Namespace


UserPreferencesDlg Methods

[image] [image]

Sandcastle Help File Builder Documentation
UserPreferencesDlg Methods
UserPreferencesDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The UserPreferencesDlg type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

See Also

UserPreferencesDlg Class
SandcastleBuilder.Gui Namespace


AccessibilityNotifyClients Method

[image] [image]

Sandcastle Help File Builder Documentation
UserPreferencesDlg..::.AccessibilityNotifyClients Method
UserPreferencesDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

UserPreferencesDlg Class
UserPreferencesDlg Members
SandcastleBuilder.Gui Namespace


BeginInvoke Method

[image] [image]

Sandcastle Help File Builder Documentation
UserPreferencesDlg..::.BeginInvoke Method
UserPreferencesDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

UserPreferencesDlg Class
UserPreferencesDlg Members
SandcastleBuilder.Gui Namespace


Dispose Method

[image] [image]

Sandcastle Help File Builder Documentation
UserPreferencesDlg..::.Dispose Method
UserPreferencesDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides Form..::.Dispose(Boolean).)

See Also

UserPreferencesDlg Class
UserPreferencesDlg Members
SandcastleBuilder.Gui Namespace


Dispose Method (Boolean)

[image]

Sandcastle Help File Builder Documentation
UserPreferencesDlg..::.Dispose Method (Boolean)
UserPreferencesDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: SandcastleBuilder.Gui
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

UserPreferencesDlg Class
Dispose Overload
SandcastleBuilder.Gui Namespace


GetChildAtPoint Method

[image] [image]

Sandcastle Help File Builder Documentation
UserPreferencesDlg..::.GetChildAtPoint Method
UserPreferencesDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

UserPreferencesDlg Class
UserPreferencesDlg Members
SandcastleBuilder.Gui Namespace


Invalidate Method

[image] [image]

Sandcastle Help File Builder Documentation
UserPreferencesDlg..::.Invalidate Method
UserPreferencesDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

UserPreferencesDlg Class
UserPreferencesDlg Members
SandcastleBuilder.Gui Namespace


Invoke Method

[image] [image]

Sandcastle Help File Builder Documentation
UserPreferencesDlg..::.Invoke Method
UserPreferencesDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

UserPreferencesDlg Class
UserPreferencesDlg Members
SandcastleBuilder.Gui Namespace


MemberwiseClone Method

[image] [image]

Sandcastle Help File Builder Documentation
UserPreferencesDlg..::.MemberwiseClone Method
UserPreferencesDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

UserPreferencesDlg Class
UserPreferencesDlg Members
SandcastleBuilder.Gui Namespace


PerformLayout Method

[image] [image]

Sandcastle Help File Builder Documentation
UserPreferencesDlg..::.PerformLayout Method
UserPreferencesDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

UserPreferencesDlg Class
UserPreferencesDlg Members
SandcastleBuilder.Gui Namespace


ResumeLayout Method

[image] [image]

Sandcastle Help File Builder Documentation
UserPreferencesDlg..::.ResumeLayout Method
UserPreferencesDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

UserPreferencesDlg Class
UserPreferencesDlg Members
SandcastleBuilder.Gui Namespace


RtlTranslateAlignment Method

[image] [image]

Sandcastle Help File Builder Documentation
UserPreferencesDlg..::.RtlTranslateAlignment Method
UserPreferencesDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

UserPreferencesDlg Class
UserPreferencesDlg Members
SandcastleBuilder.Gui Namespace


Scale Method

[image] [image]

Sandcastle Help File Builder Documentation
UserPreferencesDlg..::.Scale Method
UserPreferencesDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

UserPreferencesDlg Class
UserPreferencesDlg Members
SandcastleBuilder.Gui Namespace


Select Method

[image] [image]

Sandcastle Help File Builder Documentation
UserPreferencesDlg..::.Select Method
UserPreferencesDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)

See Also

UserPreferencesDlg Class
UserPreferencesDlg Members
SandcastleBuilder.Gui Namespace


SetBounds Method

[image] [image]

Sandcastle Help File Builder Documentation
UserPreferencesDlg..::.SetBounds Method
UserPreferencesDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

UserPreferencesDlg Class
UserPreferencesDlg Members
SandcastleBuilder.Gui Namespace


Show Method

[image] [image]

Sandcastle Help File Builder Documentation
UserPreferencesDlg..::.Show Method
UserPreferencesDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Show()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

UserPreferencesDlg Class
UserPreferencesDlg Members
SandcastleBuilder.Gui Namespace


ShowDialog Method

[image] [image]

Sandcastle Help File Builder Documentation
UserPreferencesDlg..::.ShowDialog Method
UserPreferencesDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)

See Also

UserPreferencesDlg Class
UserPreferencesDlg Members
SandcastleBuilder.Gui Namespace


UpdateBounds Method

[image] [image]

Sandcastle Help File Builder Documentation
UserPreferencesDlg..::.UpdateBounds Method
UserPreferencesDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

UserPreferencesDlg Class
UserPreferencesDlg Members
SandcastleBuilder.Gui Namespace


Validate Method

[image] [image]

Sandcastle Help File Builder Documentation
UserPreferencesDlg..::.Validate Method
UserPreferencesDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

UserPreferencesDlg Class
UserPreferencesDlg Members
SandcastleBuilder.Gui Namespace


ValidateChildren Method

[image] [image]

Sandcastle Help File Builder Documentation
UserPreferencesDlg..::.ValidateChildren Method
UserPreferencesDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

UserPreferencesDlg Class
UserPreferencesDlg Members
SandcastleBuilder.Gui Namespace


UserPreferencesDlg Properties

[image] [image]

Sandcastle Help File Builder Documentation
UserPreferencesDlg Properties
UserPreferencesDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The UserPreferencesDlg type exposes the following members.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

UserPreferencesDlg Class
SandcastleBuilder.Gui Namespace


UserPreferencesDlg Events

[image] [image]

Sandcastle Help File Builder Documentation
UserPreferencesDlg Events
UserPreferencesDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The UserPreferencesDlg type exposes the following members.

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

UserPreferencesDlg Class
SandcastleBuilder.Gui Namespace


WINDOWPLACEMENT Structure

[image]

Sandcastle Help File Builder Documentation
WINDOWPLACEMENT Structure
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This structure is used to get and set the main form's position

Namespace: SandcastleBuilder.Gui
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
[SerializableAttribute]
public struct WINDOWPLACEMENT
Visual Basic (Declaration)
<SerializableAttribute> _
Public Structure WINDOWPLACEMENT

See Also

WINDOWPLACEMENT Members
SandcastleBuilder.Gui Namespace


WINDOWPLACEMENT Members

[image] [image]

Sandcastle Help File Builder Documentation
WINDOWPLACEMENT Members
WINDOWPLACEMENT Structure Methods Fields See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The WINDOWPLACEMENT type exposes the following members.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Fields

Name | Description
flags | Window position control flags
length | The length of the structure
ptMaxPosition_x | Window upper left when maximized
ptMaxPosition_y | Window upper left when maximized
ptMinPosition_x | Window upper left when minimized
ptMinPosition_y | Window upper left when minimized
rcNormalPosition_bottom | Window coordinates when in the restored position
rcNormalPosition_left | Window coordinates when in the restored position
rcNormalPosition_right | Window coordinates when in the restored position
rcNormalPosition_top | Window coordinates when in the restored position
showCmd | The current show state of the window

See Also

WINDOWPLACEMENT Structure
SandcastleBuilder.Gui Namespace


WINDOWPLACEMENT Fields

[image] [image]

Sandcastle Help File Builder Documentation
WINDOWPLACEMENT Fields
WINDOWPLACEMENT Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The WINDOWPLACEMENT type exposes the following members.

Fields

Name | Description
flags | Window position control flags
length | The length of the structure
ptMaxPosition_x | Window upper left when maximized
ptMaxPosition_y | Window upper left when maximized
ptMinPosition_x | Window upper left when minimized
ptMinPosition_y | Window upper left when minimized
rcNormalPosition_bottom | Window coordinates when in the restored position
rcNormalPosition_left | Window coordinates when in the restored position
rcNormalPosition_right | Window coordinates when in the restored position
rcNormalPosition_top | Window coordinates when in the restored position
showCmd | The current show state of the window

See Also

WINDOWPLACEMENT Structure
SandcastleBuilder.Gui Namespace


flags Field

[image]

Sandcastle Help File Builder Documentation
WINDOWPLACEMENT..::.flags Field
WINDOWPLACEMENT Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Window position control flags

Namespace: SandcastleBuilder.Gui
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public int flags
Visual Basic (Declaration)
Public flags As Integer

See Also

WINDOWPLACEMENT Structure
SandcastleBuilder.Gui Namespace


length Field

[image]

Sandcastle Help File Builder Documentation
WINDOWPLACEMENT..::.length Field
WINDOWPLACEMENT Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The length of the structure

Namespace: SandcastleBuilder.Gui
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public int length
Visual Basic (Declaration)
Public length As Integer

See Also

WINDOWPLACEMENT Structure
SandcastleBuilder.Gui Namespace


ptMaxPosition_x Field

[image]

Sandcastle Help File Builder Documentation
WINDOWPLACEMENT..::.ptMaxPosition_x Field
WINDOWPLACEMENT Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Window upper left when maximized

Namespace: SandcastleBuilder.Gui
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public int ptMaxPosition_x
Visual Basic (Declaration)
Public ptMaxPosition_x As Integer

See Also

WINDOWPLACEMENT Structure
SandcastleBuilder.Gui Namespace


ptMaxPosition_y Field

[image]

Sandcastle Help File Builder Documentation
WINDOWPLACEMENT..::.ptMaxPosition_y Field
WINDOWPLACEMENT Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Window upper left when maximized

Namespace: SandcastleBuilder.Gui
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public int ptMaxPosition_y
Visual Basic (Declaration)
Public ptMaxPosition_y As Integer

See Also

WINDOWPLACEMENT Structure
SandcastleBuilder.Gui Namespace


ptMinPosition_x Field

[image]

Sandcastle Help File Builder Documentation
WINDOWPLACEMENT..::.ptMinPosition_x Field
WINDOWPLACEMENT Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Window upper left when minimized

Namespace: SandcastleBuilder.Gui
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public int ptMinPosition_x
Visual Basic (Declaration)
Public ptMinPosition_x As Integer

See Also

WINDOWPLACEMENT Structure
SandcastleBuilder.Gui Namespace


ptMinPosition_y Field

[image]

Sandcastle Help File Builder Documentation
WINDOWPLACEMENT..::.ptMinPosition_y Field
WINDOWPLACEMENT Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Window upper left when minimized

Namespace: SandcastleBuilder.Gui
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public int ptMinPosition_y
Visual Basic (Declaration)
Public ptMinPosition_y As Integer

See Also

WINDOWPLACEMENT Structure
SandcastleBuilder.Gui Namespace


rcNormalPosition_bottom Field

[image]

Sandcastle Help File Builder Documentation
WINDOWPLACEMENT..::.rcNormalPosition_bottom Field
WINDOWPLACEMENT Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Window coordinates when in the restored position

Namespace: SandcastleBuilder.Gui
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public int rcNormalPosition_bottom
Visual Basic (Declaration)
Public rcNormalPosition_bottom As Integer

See Also

WINDOWPLACEMENT Structure
SandcastleBuilder.Gui Namespace


rcNormalPosition_left Field

[image]

Sandcastle Help File Builder Documentation
WINDOWPLACEMENT..::.rcNormalPosition_left Field
WINDOWPLACEMENT Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Window coordinates when in the restored position

Namespace: SandcastleBuilder.Gui
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public int rcNormalPosition_left
Visual Basic (Declaration)
Public rcNormalPosition_left As Integer

See Also

WINDOWPLACEMENT Structure
SandcastleBuilder.Gui Namespace


rcNormalPosition_right Field

[image]

Sandcastle Help File Builder Documentation
WINDOWPLACEMENT..::.rcNormalPosition_right Field
WINDOWPLACEMENT Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Window coordinates when in the restored position

Namespace: SandcastleBuilder.Gui
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public int rcNormalPosition_right
Visual Basic (Declaration)
Public rcNormalPosition_right As Integer

See Also

WINDOWPLACEMENT Structure
SandcastleBuilder.Gui Namespace


rcNormalPosition_top Field

[image]

Sandcastle Help File Builder Documentation
WINDOWPLACEMENT..::.rcNormalPosition_top Field
WINDOWPLACEMENT Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Window coordinates when in the restored position

Namespace: SandcastleBuilder.Gui
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public int rcNormalPosition_top
Visual Basic (Declaration)
Public rcNormalPosition_top As Integer

See Also

WINDOWPLACEMENT Structure
SandcastleBuilder.Gui Namespace


showCmd Field

[image]

Sandcastle Help File Builder Documentation
WINDOWPLACEMENT..::.showCmd Field
WINDOWPLACEMENT Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The current show state of the window

Namespace: SandcastleBuilder.Gui
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public int showCmd
Visual Basic (Declaration)
Public showCmd As Integer

See Also

WINDOWPLACEMENT Structure
SandcastleBuilder.Gui Namespace


WINDOWPLACEMENT Methods

[image] [image]

Sandcastle Help File Builder Documentation
WINDOWPLACEMENT Methods
WINDOWPLACEMENT Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The WINDOWPLACEMENT type exposes the following members.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

WINDOWPLACEMENT Structure
SandcastleBuilder.Gui Namespace


SandcastleBuilder.Gui.ContentEditors Namespace

[image]

Sandcastle Help File Builder Documentation
SandcastleBuilder.Gui.ContentEditors Namespace
Send Feedback

[This is preliminary documentation and is subject to change.]

This namespace contains content editors used to edit the conceptual content items in the GUI.

Classes

Class | Description
BaseContentEditor | This is used as the base class for the Sandcastle Builder content editors.
ContentEditorControl | This is a derived ICSharpCode text editor control that is used to edit the conceptual content.
ContentLayoutWindow | This form is used to edit the conceptual content items
EntityReferenceWindow | This form is used to look up code entity references, code snippets, tokens, and images, and allows them to be dragged and dropped into a topic editor window.
FileTree | This is used to load the ProjectExplorerWindow tree view with the project file tree.
FindAndReplaceWindow | This form is used to handle search and replace in the text editor windows.
GotoLineDlg | This is used to enter the line number for the Goto Line editor action.
NodeData | This is used to hold basic information about the item represented by the tree view node in the ProjectExplorerWindow.
OutputWindow | This form is used to contain and view the build output
PreviewTopicWindow | This form is used to preview a topic
ProjectExplorerWindow | This form is used to manage the project items and files
ProjectPropertiesWindow | This form is used to edit the project properties
SelectGacEntriesDlg | This form is used to let the user select the GAC entries to add as project references.
SiteMapEditorWindow | This form is used to edit site map files that defines the table of contents layout for additional content items.
TokenEditorWindow | This form is used to edit a token file.
TopicEditorWindow | This form is used to edit a conceptual topic file.

Enumerations

Enumeration | Description
NodeIcon | This defines the ProjectExplorerWindow tree view node icon index values.


BaseContentEditor Class

[image]

Sandcastle Help File Builder Documentation
BaseContentEditor Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used as the base class for the Sandcastle Builder content editors.

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public class BaseContentEditor : DockContent
Visual Basic (Declaration)
Public Class BaseContentEditor _
    Inherits DockContent

Remarks

There are probably several different ways to do this that are better but this is quick and dirty and it works.

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
WeifenLuo.WinFormsUI.Docking..::.DockContent
SandcastleBuilder.Gui.ContentEditors..::.BaseContentEditor
SandcastleBuilder.Gui.ContentEditors..::.ContentLayoutWindow
SandcastleBuilder.Gui.ContentEditors..::.EntityReferenceWindow
SandcastleBuilder.Gui.ContentEditors..::.FindAndReplaceWindow
SandcastleBuilder.Gui.ContentEditors..::.OutputWindow
SandcastleBuilder.Gui.ContentEditors..::.PreviewTopicWindow
SandcastleBuilder.Gui.ContentEditors..::.ProjectExplorerWindow
SandcastleBuilder.Gui.ContentEditors..::.ProjectPropertiesWindow
SandcastleBuilder.Gui.ContentEditors..::.SiteMapEditorWindow
SandcastleBuilder.Gui.ContentEditors..::.TokenEditorWindow
SandcastleBuilder.Gui.ContentEditors..::.TopicEditorWindow

See Also

BaseContentEditor Members
SandcastleBuilder.Gui.ContentEditors Namespace


BaseContentEditor Members

[image] [image]

Sandcastle Help File Builder Documentation
BaseContentEditor Members
BaseContentEditor Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BaseContentEditor type exposes the following members.

Constructors

Name | Description
BaseContentEditor | Initializes a new instance of the BaseContentEditor class

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | (Inherited from DockContent.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DockTo | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
FloatAt | (Inherited from DockContent.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPersistString | (Inherited from DockContent.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | (Inherited from DockContent.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsDockStateValid | (Inherited from DockContent.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDockStateChanged | (Inherited from DockContent.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Save | Save the content of the window using its current filename
SaveAs | Save the content of the window using a different filename
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowEndUserDocking | (Inherited from DockContent.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoHidePortion | (Inherited from DockContent.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanClose | Returns true if the window can be closed or false if something prevents it from allowing the close to occur.
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSaveContent | This is used to see if the active document allows its content to be saved.
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CloseButton | (Inherited from DockContent.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockAreas | (Inherited from DockContent.)
DockHandler | (Inherited from DockContent.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DockPanel | (Inherited from DockContent.)
DockState | (Inherited from DockContent.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FloatPane | (Inherited from DockContent.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HideOnClose | (Inherited from DockContent.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsActivated | (Inherited from DockContent.)
IsContentDocument | This is used to see if the editor is a document type that should be saved prior to doing a build.
IsDirty | This returns the dirty state of the document if it supports saving
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsFloat | (Inherited from DockContent.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsHidden | (Inherited from DockContent.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Pane | (Inherited from DockContent.)
PanelPane | (Inherited from DockContent.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowHint | (Inherited from DockContent.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabPageContextMenu | (Inherited from DockContent.)
TabPageContextMenuStrip | (Inherited from DockContent.)
TabStop | (Inherited from Form.)
TabText | (Inherited from DockContent.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
ToolTipText | (Inherited from DockContent.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VisibleState | (Inherited from DockContent.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DockStateChanged | (Inherited from DockContent.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

BaseContentEditor Class
SandcastleBuilder.Gui.ContentEditors Namespace


BaseContentEditor Constructor

[image]

Sandcastle Help File Builder Documentation
BaseContentEditor Constructor
BaseContentEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the BaseContentEditor class

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public BaseContentEditor()
Visual Basic (Declaration)
Public Sub New

See Also

BaseContentEditor Class
SandcastleBuilder.Gui.ContentEditors Namespace


BaseContentEditor Methods

[image] [image]

Sandcastle Help File Builder Documentation
BaseContentEditor Methods
BaseContentEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BaseContentEditor type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | (Inherited from DockContent.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DockTo | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
FloatAt | (Inherited from DockContent.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPersistString | (Inherited from DockContent.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | (Inherited from DockContent.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsDockStateValid | (Inherited from DockContent.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDockStateChanged | (Inherited from DockContent.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Save | Save the content of the window using its current filename
SaveAs | Save the content of the window using a different filename
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

See Also

BaseContentEditor Class
SandcastleBuilder.Gui.ContentEditors Namespace


AccessibilityNotifyClients Method

[image] [image]

Sandcastle Help File Builder Documentation
BaseContentEditor..::.AccessibilityNotifyClients Method
BaseContentEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

BaseContentEditor Class
BaseContentEditor Members
SandcastleBuilder.Gui.ContentEditors Namespace


BeginInvoke Method

[image] [image]

Sandcastle Help File Builder Documentation
BaseContentEditor..::.BeginInvoke Method
BaseContentEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

BaseContentEditor Class
BaseContentEditor Members
SandcastleBuilder.Gui.ContentEditors Namespace


Dispose Method

[image] [image]

Sandcastle Help File Builder Documentation
BaseContentEditor..::.Dispose Method
BaseContentEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Disposes of the resources (other than memory) used by the Form. (Inherited from Form.)

See Also

BaseContentEditor Class
BaseContentEditor Members
SandcastleBuilder.Gui.ContentEditors Namespace


DockTo Method

[image] [image]

Sandcastle Help File Builder Documentation
BaseContentEditor..::.DockTo Method
BaseContentEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
DockTo(DockPanel, DockStyle) | (Inherited from DockContent.)
DockTo(DockPane, DockStyle, Int32) | (Inherited from DockContent.)

See Also

BaseContentEditor Class
BaseContentEditor Members
SandcastleBuilder.Gui.ContentEditors Namespace


GetChildAtPoint Method

[image] [image]

Sandcastle Help File Builder Documentation
BaseContentEditor..::.GetChildAtPoint Method
BaseContentEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

BaseContentEditor Class
BaseContentEditor Members
SandcastleBuilder.Gui.ContentEditors Namespace


Invalidate Method

[image] [image]

Sandcastle Help File Builder Documentation
BaseContentEditor..::.Invalidate Method
BaseContentEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

BaseContentEditor Class
BaseContentEditor Members
SandcastleBuilder.Gui.ContentEditors Namespace


Invoke Method

[image] [image]

Sandcastle Help File Builder Documentation
BaseContentEditor..::.Invoke Method
BaseContentEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

BaseContentEditor Class
BaseContentEditor Members
SandcastleBuilder.Gui.ContentEditors Namespace


MemberwiseClone Method

[image] [image]

Sandcastle Help File Builder Documentation
BaseContentEditor..::.MemberwiseClone Method
BaseContentEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

BaseContentEditor Class
BaseContentEditor Members
SandcastleBuilder.Gui.ContentEditors Namespace


PerformLayout Method

[image] [image]

Sandcastle Help File Builder Documentation
BaseContentEditor..::.PerformLayout Method
BaseContentEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

BaseContentEditor Class
BaseContentEditor Members
SandcastleBuilder.Gui.ContentEditors Namespace


ResumeLayout Method

[image] [image]

Sandcastle Help File Builder Documentation
BaseContentEditor..::.ResumeLayout Method
BaseContentEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

BaseContentEditor Class
BaseContentEditor Members
SandcastleBuilder.Gui.ContentEditors Namespace


RtlTranslateAlignment Method

[image] [image]

Sandcastle Help File Builder Documentation
BaseContentEditor..::.RtlTranslateAlignment Method
BaseContentEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

BaseContentEditor Class
BaseContentEditor Members
SandcastleBuilder.Gui.ContentEditors Namespace


Save Method

[image]

Sandcastle Help File Builder Documentation
BaseContentEditor..::.Save Method
BaseContentEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Save the content of the window using its current filename

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public virtual bool Save()
Visual Basic (Declaration)
Public Overridable Function Save As Boolean

Return Value

True if successful, false if not successful

See Also

BaseContentEditor Class
SandcastleBuilder.Gui.ContentEditors Namespace


SaveAs Method

[image]

Sandcastle Help File Builder Documentation
BaseContentEditor..::.SaveAs Method
BaseContentEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Save the content of the window using a different filename

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public virtual bool SaveAs()
Visual Basic (Declaration)
Public Overridable Function SaveAs As Boolean

Return Value

True if successful, false if not successful

See Also

BaseContentEditor Class
SandcastleBuilder.Gui.ContentEditors Namespace


Scale Method

[image] [image]

Sandcastle Help File Builder Documentation
BaseContentEditor..::.Scale Method
BaseContentEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

BaseContentEditor Class
BaseContentEditor Members
SandcastleBuilder.Gui.ContentEditors Namespace


Select Method

[image] [image]

Sandcastle Help File Builder Documentation
BaseContentEditor..::.Select Method
BaseContentEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)

See Also

BaseContentEditor Class
BaseContentEditor Members
SandcastleBuilder.Gui.ContentEditors Namespace


SetBounds Method

[image] [image]

Sandcastle Help File Builder Documentation
BaseContentEditor..::.SetBounds Method
BaseContentEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

BaseContentEditor Class
BaseContentEditor Members
SandcastleBuilder.Gui.ContentEditors Namespace


Show Method

[image] [image]

Sandcastle Help File Builder Documentation
BaseContentEditor..::.Show Method
BaseContentEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Show()()() | (Inherited from DockContent.)
Show(DockPanel) | (Inherited from DockContent.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Show(DockPanel, DockState) | (Inherited from DockContent.)
Show(DockPanel, Rectangle) | (Inherited from DockContent.)
Show(DockPane, IDockContent) | (Inherited from DockContent.)
Show(DockPane, DockAlignment, Double) | (Inherited from DockContent.)

See Also

BaseContentEditor Class
BaseContentEditor Members
SandcastleBuilder.Gui.ContentEditors Namespace


ShowDialog Method

[image] [image]

Sandcastle Help File Builder Documentation
BaseContentEditor..::.ShowDialog Method
BaseContentEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)

See Also

BaseContentEditor Class
BaseContentEditor Members
SandcastleBuilder.Gui.ContentEditors Namespace


UpdateBounds Method

[image] [image]

Sandcastle Help File Builder Documentation
BaseContentEditor..::.UpdateBounds Method
BaseContentEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

BaseContentEditor Class
BaseContentEditor Members
SandcastleBuilder.Gui.ContentEditors Namespace


Validate Method

[image] [image]

Sandcastle Help File Builder Documentation
BaseContentEditor..::.Validate Method
BaseContentEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

BaseContentEditor Class
BaseContentEditor Members
SandcastleBuilder.Gui.ContentEditors Namespace


ValidateChildren Method

[image] [image]

Sandcastle Help File Builder Documentation
BaseContentEditor..::.ValidateChildren Method
BaseContentEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

BaseContentEditor Class
BaseContentEditor Members
SandcastleBuilder.Gui.ContentEditors Namespace


BaseContentEditor Properties

[image] [image]

Sandcastle Help File Builder Documentation
BaseContentEditor Properties
BaseContentEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BaseContentEditor type exposes the following members.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowEndUserDocking | (Inherited from DockContent.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoHidePortion | (Inherited from DockContent.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanClose | Returns true if the window can be closed or false if something prevents it from allowing the close to occur.
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSaveContent | This is used to see if the active document allows its content to be saved.
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CloseButton | (Inherited from DockContent.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockAreas | (Inherited from DockContent.)
DockHandler | (Inherited from DockContent.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DockPanel | (Inherited from DockContent.)
DockState | (Inherited from DockContent.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FloatPane | (Inherited from DockContent.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HideOnClose | (Inherited from DockContent.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsActivated | (Inherited from DockContent.)
IsContentDocument | This is used to see if the editor is a document type that should be saved prior to doing a build.
IsDirty | This returns the dirty state of the document if it supports saving
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsFloat | (Inherited from DockContent.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsHidden | (Inherited from DockContent.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Pane | (Inherited from DockContent.)
PanelPane | (Inherited from DockContent.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowHint | (Inherited from DockContent.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabPageContextMenu | (Inherited from DockContent.)
TabPageContextMenuStrip | (Inherited from DockContent.)
TabStop | (Inherited from Form.)
TabText | (Inherited from DockContent.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
ToolTipText | (Inherited from DockContent.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VisibleState | (Inherited from DockContent.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

BaseContentEditor Class
SandcastleBuilder.Gui.ContentEditors Namespace


CanClose Property

[image]

Sandcastle Help File Builder Documentation
BaseContentEditor..::.CanClose Property
BaseContentEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Returns true if the window can be closed or false if something prevents it from allowing the close to occur.

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public virtual bool CanClose { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property CanClose As Boolean

See Also

BaseContentEditor Class
SandcastleBuilder.Gui.ContentEditors Namespace


CanSaveContent Property

[image]

Sandcastle Help File Builder Documentation
BaseContentEditor..::.CanSaveContent Property
BaseContentEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to see if the active document allows its content to be saved.

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public virtual bool CanSaveContent { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property CanSaveContent As Boolean

Return Value

Returns true if it supports saving its content or false if it does not.

See Also

BaseContentEditor Class
SandcastleBuilder.Gui.ContentEditors Namespace


IsContentDocument Property

[image]

Sandcastle Help File Builder Documentation
BaseContentEditor..::.IsContentDocument Property
BaseContentEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to see if the editor is a document type that should be saved prior to doing a build.

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public virtual bool IsContentDocument { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsContentDocument As Boolean

See Also

BaseContentEditor Class
SandcastleBuilder.Gui.ContentEditors Namespace


IsDirty Property

[image]

Sandcastle Help File Builder Documentation
BaseContentEditor..::.IsDirty Property
BaseContentEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This returns the dirty state of the document if it supports saving

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public virtual bool IsDirty { get; set; }
Visual Basic (Declaration)
Public Overridable Property IsDirty As Boolean

See Also

BaseContentEditor Class
SandcastleBuilder.Gui.ContentEditors Namespace


BaseContentEditor Events

[image] [image]

Sandcastle Help File Builder Documentation
BaseContentEditor Events
BaseContentEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BaseContentEditor type exposes the following members.

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DockStateChanged | (Inherited from DockContent.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

BaseContentEditor Class
SandcastleBuilder.Gui.ContentEditors Namespace


ContentEditorControl Class

[image]

Sandcastle Help File Builder Documentation
ContentEditorControl Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is a derived ICSharpCode text editor control that is used to edit the conceptual content.

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public class ContentEditorControl : TextEditorControl
Visual Basic (Declaration)
Public Class ContentEditorControl _
    Inherits TextEditorControl

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
ICSharpCode.TextEditor..::.TextEditorControlBase
ICSharpCode.TextEditor..::.TextEditorControl
SandcastleBuilder.Gui.ContentEditors..::.ContentEditorControl

See Also

ContentEditorControl Members
SandcastleBuilder.Gui.ContentEditors Namespace


ContentEditorControl Members

[image] [image]

Sandcastle Help File Builder Documentation
ContentEditorControl Members
ContentEditorControl Class Constructors Methods Fields Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ContentEditorControl type exposes the following members.

Constructors

Name | Description
ContentEditorControl | Constructor

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BeginUpdate | (Inherited from TextEditorControlBase.)
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CanSaveWithCurrentEncoding | (Inherited from TextEditorControlBase.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
EndUpdate | (Inherited from TextEditorControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | Execute a specified action in the editor
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetRangeDescription | (Inherited from TextEditorControlBase.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitializeTextAreaControl | (Inherited from TextEditorControl.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
InsertString | Insert a string of text into the specified text area at the current cursor location.
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsEditAction | (Inherited from TextEditorControlBase.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LoadFile | Overloaded.
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFileNameChanged | (Inherited from TextEditorControlBase.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnReloadHighlighting | (Inherited from TextEditorControlBase.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
OptionsChanged | (Inherited from TextEditorControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Redo | (Inherited from TextEditorControl.)
Refresh | (Inherited from TextEditorControlBase.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
SaveFile | Overloaded.
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetActiveTextAreaControl | (Inherited from TextEditorControl.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetHighlighting | (Inherited from TextEditorControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Split | (Inherited from TextEditorControl.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Undo | (Inherited from TextEditorControl.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Fields

Name | Description
editactions | (Inherited from TextEditorControlBase.)
textAreaPanel | (Inherited from TextEditorControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveTextAreaControl | (Inherited from TextEditorControl.)
AllowCaretBeyondEOL | (Inherited from TextEditorControlBase.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
BracketMatchingStyle | (Inherited from TextEditorControlBase.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
ConvertTabsToSpaces | (Inherited from TextEditorControlBase.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from TextEditorControlBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Document | (Inherited from TextEditorControlBase.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
EnableFolding | (Inherited from TextEditorControlBase.)
EnableRedo | (Inherited from TextEditorControl.)
EnableUndo | (Inherited from TextEditorControl.)
Encoding | (Inherited from TextEditorControlBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FileName | (Inherited from TextEditorControlBase.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | (Inherited from TextEditorControlBase.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HideMouseCursor | (Inherited from TextEditorControlBase.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
IndentStyle | (Inherited from TextEditorControlBase.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsIconBarVisible | (Inherited from TextEditorControlBase.)
IsInUpdate | (Inherited from TextEditorControlBase.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsReadOnly | (Inherited from TextEditorControlBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
LineViewerStyle | (Inherited from TextEditorControlBase.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
PrintDocument | (Inherited from TextEditorControl.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowEOLMarkers | (Inherited from TextEditorControlBase.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowHRuler | (Inherited from TextEditorControlBase.)
ShowInvalidLines | (Inherited from TextEditorControlBase.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowLineNumbers | (Inherited from TextEditorControlBase.)
ShowMatchingBracket | (Inherited from TextEditorControlBase.)
ShowSpaces | (Inherited from TextEditorControlBase.)
ShowTabs | (Inherited from TextEditorControlBase.)
ShowVRuler | (Inherited from TextEditorControlBase.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndent | (Inherited from TextEditorControlBase.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from TextEditorControlBase.)
TextEditorProperties | (Inherited from TextEditorControlBase.)
TextRenderingHint | (Inherited from TextEditorControlBase.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VRulerRow | (Inherited from TextEditorControlBase.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
ActiveTextAreaControlChanged | (Inherited from TextEditorControl.)
AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FileNameChanged | (Inherited from TextEditorControlBase.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from TextEditorControlBase.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

ContentEditorControl Class
SandcastleBuilder.Gui.ContentEditors Namespace


ContentEditorControl Constructor

[image]

Sandcastle Help File Builder Documentation
ContentEditorControl Constructor
ContentEditorControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public ContentEditorControl()
Visual Basic (Declaration)
Public Sub New

See Also

ContentEditorControl Class
SandcastleBuilder.Gui.ContentEditors Namespace


ContentEditorControl Fields

[image] [image]

Sandcastle Help File Builder Documentation
ContentEditorControl Fields
ContentEditorControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ContentEditorControl type exposes the following members.

Fields

Name | Description
editactions | (Inherited from TextEditorControlBase.)
textAreaPanel | (Inherited from TextEditorControl.)

See Also

ContentEditorControl Class
SandcastleBuilder.Gui.ContentEditors Namespace


ContentEditorControl Methods

[image] [image]

Sandcastle Help File Builder Documentation
ContentEditorControl Methods
ContentEditorControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ContentEditorControl type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BeginUpdate | (Inherited from TextEditorControlBase.)
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CanSaveWithCurrentEncoding | (Inherited from TextEditorControlBase.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
EndUpdate | (Inherited from TextEditorControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | Execute a specified action in the editor
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetRangeDescription | (Inherited from TextEditorControlBase.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitializeTextAreaControl | (Inherited from TextEditorControl.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
InsertString | Insert a string of text into the specified text area at the current cursor location.
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsEditAction | (Inherited from TextEditorControlBase.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LoadFile | Overloaded.
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFileNameChanged | (Inherited from TextEditorControlBase.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnReloadHighlighting | (Inherited from TextEditorControlBase.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
OptionsChanged | (Inherited from TextEditorControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Redo | (Inherited from TextEditorControl.)
Refresh | (Inherited from TextEditorControlBase.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
SaveFile | Overloaded.
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetActiveTextAreaControl | (Inherited from TextEditorControl.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetHighlighting | (Inherited from TextEditorControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Split | (Inherited from TextEditorControl.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Undo | (Inherited from TextEditorControl.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

ContentEditorControl Class
SandcastleBuilder.Gui.ContentEditors Namespace


AccessibilityNotifyClients Method

[image] [image]

Sandcastle Help File Builder Documentation
ContentEditorControl..::.AccessibilityNotifyClients Method
ContentEditorControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

ContentEditorControl Class
ContentEditorControl Members
SandcastleBuilder.Gui.ContentEditors Namespace


BeginInvoke Method

[image] [image]

Sandcastle Help File Builder Documentation
ContentEditorControl..::.BeginInvoke Method
ContentEditorControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

ContentEditorControl Class
ContentEditorControl Members
SandcastleBuilder.Gui.ContentEditors Namespace


Dispose Method

[image] [image]

Sandcastle Help File Builder Documentation
ContentEditorControl..::.Dispose Method
ContentEditorControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | (Inherited from TextEditorControl.)

See Also

ContentEditorControl Class
ContentEditorControl Members
SandcastleBuilder.Gui.ContentEditors Namespace


Execute Method

[image]

Sandcastle Help File Builder Documentation
ContentEditorControl..::.Execute Method
ContentEditorControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Execute a specified action in the editor

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public void Execute(
    IEditAction action
)
Visual Basic (Declaration)
Public Sub Execute ( _
    action As IEditAction _
)

Parameters

action
Type: ICSharpCode.TextEditor.Actions..::.IEditAction
The action to execute

See Also

ContentEditorControl Class
SandcastleBuilder.Gui.ContentEditors Namespace


GetChildAtPoint Method

[image] [image]

Sandcastle Help File Builder Documentation
ContentEditorControl..::.GetChildAtPoint Method
ContentEditorControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

ContentEditorControl Class
ContentEditorControl Members
SandcastleBuilder.Gui.ContentEditors Namespace


InsertString Method

[image]

Sandcastle Help File Builder Documentation
ContentEditorControl..::.InsertString Method
ContentEditorControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Insert a string of text into the specified text area at the current cursor location.

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public static void InsertString(
    TextArea textArea,
    string text
)
Visual Basic (Declaration)
Public Shared Sub InsertString ( _
    textArea As TextArea, _
    text As String _
)

Parameters

textArea
Type: ICSharpCode.TextEditor..::.TextArea
The text area to use
text
Type: System..::.String
The text to insert

See Also

ContentEditorControl Class
SandcastleBuilder.Gui.ContentEditors Namespace


Invalidate Method

[image] [image]

Sandcastle Help File Builder Documentation
ContentEditorControl..::.Invalidate Method
ContentEditorControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

ContentEditorControl Class
ContentEditorControl Members
SandcastleBuilder.Gui.ContentEditors Namespace


Invoke Method

[image] [image]

Sandcastle Help File Builder Documentation
ContentEditorControl..::.Invoke Method
ContentEditorControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

ContentEditorControl Class
ContentEditorControl Members
SandcastleBuilder.Gui.ContentEditors Namespace


LoadFile Method

[image] [image]

Sandcastle Help File Builder Documentation
ContentEditorControl..::.LoadFile Method
ContentEditorControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
LoadFile(String) | (Inherited from TextEditorControlBase.)
LoadFile(String, Boolean, Boolean) | (Inherited from TextEditorControlBase.)
LoadFile(String, Stream, Boolean, Boolean) | (Inherited from TextEditorControlBase.)

See Also

ContentEditorControl Class
ContentEditorControl Members
SandcastleBuilder.Gui.ContentEditors Namespace


MemberwiseClone Method

[image] [image]

Sandcastle Help File Builder Documentation
ContentEditorControl..::.MemberwiseClone Method
ContentEditorControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ContentEditorControl Class
ContentEditorControl Members
SandcastleBuilder.Gui.ContentEditors Namespace


PerformLayout Method

[image] [image]

Sandcastle Help File Builder Documentation
ContentEditorControl..::.PerformLayout Method
ContentEditorControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

ContentEditorControl Class
ContentEditorControl Members
SandcastleBuilder.Gui.ContentEditors Namespace


ResumeLayout Method

[image] [image]

Sandcastle Help File Builder Documentation
ContentEditorControl..::.ResumeLayout Method
ContentEditorControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

ContentEditorControl Class
ContentEditorControl Members
SandcastleBuilder.Gui.ContentEditors Namespace


RtlTranslateAlignment Method

[image] [image]

Sandcastle Help File Builder Documentation
ContentEditorControl..::.RtlTranslateAlignment Method
ContentEditorControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

ContentEditorControl Class
ContentEditorControl Members
SandcastleBuilder.Gui.ContentEditors Namespace


SaveFile Method

[image] [image]

Sandcastle Help File Builder Documentation
ContentEditorControl..::.SaveFile Method
ContentEditorControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SaveFile(String) | (Inherited from TextEditorControlBase.)
SaveFile(Stream) | (Inherited from TextEditorControlBase.)

See Also

ContentEditorControl Class
ContentEditorControl Members
SandcastleBuilder.Gui.ContentEditors Namespace


Scale Method

[image] [image]

Sandcastle Help File Builder Documentation
ContentEditorControl..::.Scale Method
ContentEditorControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

ContentEditorControl Class
ContentEditorControl Members
SandcastleBuilder.Gui.ContentEditors Namespace


Select Method

[image] [image]

Sandcastle Help File Builder Documentation
ContentEditorControl..::.Select Method
ContentEditorControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

ContentEditorControl Class
ContentEditorControl Members
SandcastleBuilder.Gui.ContentEditors Namespace


SetBounds Method

[image] [image]

Sandcastle Help File Builder Documentation
ContentEditorControl..::.SetBounds Method
ContentEditorControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

ContentEditorControl Class
ContentEditorControl Members
SandcastleBuilder.Gui.ContentEditors Namespace


UpdateBounds Method

[image] [image]

Sandcastle Help File Builder Documentation
ContentEditorControl..::.UpdateBounds Method
ContentEditorControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

ContentEditorControl Class
ContentEditorControl Members
SandcastleBuilder.Gui.ContentEditors Namespace


Validate Method

[image] [image]

Sandcastle Help File Builder Documentation
ContentEditorControl..::.Validate Method
ContentEditorControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

ContentEditorControl Class
ContentEditorControl Members
SandcastleBuilder.Gui.ContentEditors Namespace


ValidateChildren Method

[image] [image]

Sandcastle Help File Builder Documentation
ContentEditorControl..::.ValidateChildren Method
ContentEditorControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

ContentEditorControl Class
ContentEditorControl Members
SandcastleBuilder.Gui.ContentEditors Namespace


ContentEditorControl Properties

[image] [image]

Sandcastle Help File Builder Documentation
ContentEditorControl Properties
ContentEditorControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ContentEditorControl type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveTextAreaControl | (Inherited from TextEditorControl.)
AllowCaretBeyondEOL | (Inherited from TextEditorControlBase.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
BracketMatchingStyle | (Inherited from TextEditorControlBase.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
ConvertTabsToSpaces | (Inherited from TextEditorControlBase.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from TextEditorControlBase.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Document | (Inherited from TextEditorControlBase.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
EnableFolding | (Inherited from TextEditorControlBase.)
EnableRedo | (Inherited from TextEditorControl.)
EnableUndo | (Inherited from TextEditorControl.)
Encoding | (Inherited from TextEditorControlBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FileName | (Inherited from TextEditorControlBase.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | (Inherited from TextEditorControlBase.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HideMouseCursor | (Inherited from TextEditorControlBase.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
IndentStyle | (Inherited from TextEditorControlBase.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsIconBarVisible | (Inherited from TextEditorControlBase.)
IsInUpdate | (Inherited from TextEditorControlBase.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsReadOnly | (Inherited from TextEditorControlBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
LineViewerStyle | (Inherited from TextEditorControlBase.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
PrintDocument | (Inherited from TextEditorControl.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowEOLMarkers | (Inherited from TextEditorControlBase.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowHRuler | (Inherited from TextEditorControlBase.)
ShowInvalidLines | (Inherited from TextEditorControlBase.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowLineNumbers | (Inherited from TextEditorControlBase.)
ShowMatchingBracket | (Inherited from TextEditorControlBase.)
ShowSpaces | (Inherited from TextEditorControlBase.)
ShowTabs | (Inherited from TextEditorControlBase.)
ShowVRuler | (Inherited from TextEditorControlBase.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndent | (Inherited from TextEditorControlBase.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from TextEditorControlBase.)
TextEditorProperties | (Inherited from TextEditorControlBase.)
TextRenderingHint | (Inherited from TextEditorControlBase.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VRulerRow | (Inherited from TextEditorControlBase.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

ContentEditorControl Class
SandcastleBuilder.Gui.ContentEditors Namespace


ContentEditorControl Events

[image] [image]

Sandcastle Help File Builder Documentation
ContentEditorControl Events
ContentEditorControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ContentEditorControl type exposes the following members.

Events

Name | Description
ActiveTextAreaControlChanged | (Inherited from TextEditorControl.)
AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FileNameChanged | (Inherited from TextEditorControlBase.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from TextEditorControlBase.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

ContentEditorControl Class
SandcastleBuilder.Gui.ContentEditors Namespace


ContentLayoutWindow Class

[image]

Sandcastle Help File Builder Documentation
ContentLayoutWindow Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This form is used to edit the conceptual content items

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public class ContentLayoutWindow : BaseContentEditor
Visual Basic (Declaration)
Public Class ContentLayoutWindow _
    Inherits BaseContentEditor

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
WeifenLuo.WinFormsUI.Docking..::.DockContent
SandcastleBuilder.Gui.ContentEditors..::.BaseContentEditor
SandcastleBuilder.Gui.ContentEditors..::.ContentLayoutWindow

See Also

ContentLayoutWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


ContentLayoutWindow Members

[image] [image]

Sandcastle Help File Builder Documentation
ContentLayoutWindow Members
ContentLayoutWindow Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ContentLayoutWindow type exposes the following members.

Constructors

Name | Description
ContentLayoutWindow | Constructor

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | (Inherited from DockContent.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DockTo | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
FloatAt | (Inherited from DockContent.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPersistString | (Inherited from DockContent.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | (Inherited from DockContent.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsDockStateValid | (Inherited from DockContent.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDockStateChanged | (Inherited from DockContent.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Save | Overloaded. There are two overloads for this method
SaveAs | Save the content of the window using a different filename (Overrides BaseContentEditor..::.SaveAs()()().)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowEndUserDocking | (Inherited from DockContent.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoHidePortion | (Inherited from DockContent.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanClose | Returns true if the window can be closed or false if something prevents it from allowing the close to occur. (Overrides BaseContentEditor..::.CanClose.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSaveContent | This is used to see if the active document allows its content to be saved. (Overrides BaseContentEditor..::.CanSaveContent.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CloseButton | (Inherited from DockContent.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockAreas | (Inherited from DockContent.)
DockHandler | (Inherited from DockContent.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DockPanel | (Inherited from DockContent.)
DockState | (Inherited from DockContent.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FloatPane | (Inherited from DockContent.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HideOnClose | (Inherited from DockContent.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsActivated | (Inherited from DockContent.)
IsContentDocument | This is used to see if the editor is a document type that should be saved prior to doing a build. (Overrides BaseContentEditor..::.IsContentDocument.)
IsDirty | This returns the dirty state of the document if it supports saving (Inherited from BaseContentEditor.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsFloat | (Inherited from DockContent.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsHidden | (Inherited from DockContent.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Pane | (Inherited from DockContent.)
PanelPane | (Inherited from DockContent.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowHint | (Inherited from DockContent.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabPageContextMenu | (Inherited from DockContent.)
TabPageContextMenuStrip | (Inherited from DockContent.)
TabStop | (Inherited from Form.)
TabText | (Inherited from DockContent.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
ToolTipText | (Inherited from DockContent.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VisibleState | (Inherited from DockContent.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DockStateChanged | (Inherited from DockContent.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

ContentLayoutWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


ContentLayoutWindow Constructor

[image]

Sandcastle Help File Builder Documentation
ContentLayoutWindow Constructor
ContentLayoutWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public ContentLayoutWindow(
    FileItem fileItem
)
Visual Basic (Declaration)
Public Sub New ( _
    fileItem As FileItem _
)

Parameters

fileItem
Type: SandcastleBuilder.Utils..::.FileItem
The project file item to edit

See Also

ContentLayoutWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


ContentLayoutWindow Methods

[image] [image]

Sandcastle Help File Builder Documentation
ContentLayoutWindow Methods
ContentLayoutWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ContentLayoutWindow type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | (Inherited from DockContent.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DockTo | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
FloatAt | (Inherited from DockContent.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPersistString | (Inherited from DockContent.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | (Inherited from DockContent.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsDockStateValid | (Inherited from DockContent.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDockStateChanged | (Inherited from DockContent.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Save | Overloaded. There are two overloads for this method
SaveAs | Save the content of the window using a different filename (Overrides BaseContentEditor..::.SaveAs()()().)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

See Also

ContentLayoutWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


AccessibilityNotifyClients Method

[image] [image]

Sandcastle Help File Builder Documentation
ContentLayoutWindow..::.AccessibilityNotifyClients Method
ContentLayoutWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

ContentLayoutWindow Class
ContentLayoutWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


BeginInvoke Method

[image] [image]

Sandcastle Help File Builder Documentation
ContentLayoutWindow..::.BeginInvoke Method
ContentLayoutWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

ContentLayoutWindow Class
ContentLayoutWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Dispose Method

[image] [image]

Sandcastle Help File Builder Documentation
ContentLayoutWindow..::.Dispose Method
ContentLayoutWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides Form..::.Dispose(Boolean).)

See Also

ContentLayoutWindow Class
ContentLayoutWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Dispose Method (Boolean)

[image]

Sandcastle Help File Builder Documentation
ContentLayoutWindow..::.Dispose Method (Boolean)
ContentLayoutWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

ContentLayoutWindow Class
Dispose Overload
SandcastleBuilder.Gui.ContentEditors Namespace


DockTo Method

[image] [image]

Sandcastle Help File Builder Documentation
ContentLayoutWindow..::.DockTo Method
ContentLayoutWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
DockTo(DockPanel, DockStyle) | (Inherited from DockContent.)
DockTo(DockPane, DockStyle, Int32) | (Inherited from DockContent.)

See Also

ContentLayoutWindow Class
ContentLayoutWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


GetChildAtPoint Method

[image] [image]

Sandcastle Help File Builder Documentation
ContentLayoutWindow..::.GetChildAtPoint Method
ContentLayoutWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

ContentLayoutWindow Class
ContentLayoutWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Invalidate Method

[image] [image]

Sandcastle Help File Builder Documentation
ContentLayoutWindow..::.Invalidate Method
ContentLayoutWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

ContentLayoutWindow Class
ContentLayoutWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Invoke Method

[image] [image]

Sandcastle Help File Builder Documentation
ContentLayoutWindow..::.Invoke Method
ContentLayoutWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

ContentLayoutWindow Class
ContentLayoutWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


MemberwiseClone Method

[image] [image]

Sandcastle Help File Builder Documentation
ContentLayoutWindow..::.MemberwiseClone Method
ContentLayoutWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ContentLayoutWindow Class
ContentLayoutWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


PerformLayout Method

[image] [image]

Sandcastle Help File Builder Documentation
ContentLayoutWindow..::.PerformLayout Method
ContentLayoutWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

ContentLayoutWindow Class
ContentLayoutWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


ResumeLayout Method

[image] [image]

Sandcastle Help File Builder Documentation
ContentLayoutWindow..::.ResumeLayout Method
ContentLayoutWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

ContentLayoutWindow Class
ContentLayoutWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


RtlTranslateAlignment Method

[image] [image]

Sandcastle Help File Builder Documentation
ContentLayoutWindow..::.RtlTranslateAlignment Method
ContentLayoutWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

ContentLayoutWindow Class
ContentLayoutWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Save Method

[image] [image]

Sandcastle Help File Builder Documentation
ContentLayoutWindow..::.Save Method
ContentLayoutWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

There are two overloads for this method

Overload List

Name | Description
Save()()() | Save the content of the window using its current filename (Overrides BaseContentEditor..::.Save()()().)
Save(String) | Save the topic to a new filename

See Also

ContentLayoutWindow Class
ContentLayoutWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Save Method

[image]

Sandcastle Help File Builder Documentation
ContentLayoutWindow..::.Save Method
ContentLayoutWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Save the content of the window using its current filename

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public override bool Save()
Visual Basic (Declaration)
Public Overrides Function Save As Boolean

Return Value

True if successful, false if not successful

See Also

ContentLayoutWindow Class
Save Overload
SandcastleBuilder.Gui.ContentEditors Namespace


Save Method (String)

[image]

Sandcastle Help File Builder Documentation
ContentLayoutWindow..::.Save Method (String)
ContentLayoutWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Save the topic to a new filename

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public bool Save(
    string filename
)
Visual Basic (Declaration)
Public Function Save ( _
    filename As String _
) As Boolean

Parameters

filename
Type: System..::.String
The new filename

Return Value

True if saved successfully, false if not

See Also

ContentLayoutWindow Class
Save Overload
SandcastleBuilder.Gui.ContentEditors Namespace


SaveAs Method

[image]

Sandcastle Help File Builder Documentation
ContentLayoutWindow..::.SaveAs Method
ContentLayoutWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Save the content of the window using a different filename

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public override bool SaveAs()
Visual Basic (Declaration)
Public Overrides Function SaveAs As Boolean

Return Value

True if successful, false if not successful

See Also

ContentLayoutWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


Scale Method

[image] [image]

Sandcastle Help File Builder Documentation
ContentLayoutWindow..::.Scale Method
ContentLayoutWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

ContentLayoutWindow Class
ContentLayoutWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Select Method

[image] [image]

Sandcastle Help File Builder Documentation
ContentLayoutWindow..::.Select Method
ContentLayoutWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)

See Also

ContentLayoutWindow Class
ContentLayoutWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


SetBounds Method

[image] [image]

Sandcastle Help File Builder Documentation
ContentLayoutWindow..::.SetBounds Method
ContentLayoutWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

ContentLayoutWindow Class
ContentLayoutWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Show Method

[image] [image]

Sandcastle Help File Builder Documentation
ContentLayoutWindow..::.Show Method
ContentLayoutWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Show()()() | (Inherited from DockContent.)
Show(DockPanel) | (Inherited from DockContent.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Show(DockPanel, DockState) | (Inherited from DockContent.)
Show(DockPanel, Rectangle) | (Inherited from DockContent.)
Show(DockPane, IDockContent) | (Inherited from DockContent.)
Show(DockPane, DockAlignment, Double) | (Inherited from DockContent.)

See Also

ContentLayoutWindow Class
ContentLayoutWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


ShowDialog Method

[image] [image]

Sandcastle Help File Builder Documentation
ContentLayoutWindow..::.ShowDialog Method
ContentLayoutWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)

See Also

ContentLayoutWindow Class
ContentLayoutWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


UpdateBounds Method

[image] [image]

Sandcastle Help File Builder Documentation
ContentLayoutWindow..::.UpdateBounds Method
ContentLayoutWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

ContentLayoutWindow Class
ContentLayoutWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Validate Method

[image] [image]

Sandcastle Help File Builder Documentation
ContentLayoutWindow..::.Validate Method
ContentLayoutWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

ContentLayoutWindow Class
ContentLayoutWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


ValidateChildren Method

[image] [image]

Sandcastle Help File Builder Documentation
ContentLayoutWindow..::.ValidateChildren Method
ContentLayoutWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

ContentLayoutWindow Class
ContentLayoutWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


ContentLayoutWindow Properties

[image] [image]

Sandcastle Help File Builder Documentation
ContentLayoutWindow Properties
ContentLayoutWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ContentLayoutWindow type exposes the following members.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowEndUserDocking | (Inherited from DockContent.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoHidePortion | (Inherited from DockContent.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanClose | Returns true if the window can be closed or false if something prevents it from allowing the close to occur. (Overrides BaseContentEditor..::.CanClose.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSaveContent | This is used to see if the active document allows its content to be saved. (Overrides BaseContentEditor..::.CanSaveContent.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CloseButton | (Inherited from DockContent.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockAreas | (Inherited from DockContent.)
DockHandler | (Inherited from DockContent.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DockPanel | (Inherited from DockContent.)
DockState | (Inherited from DockContent.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FloatPane | (Inherited from DockContent.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HideOnClose | (Inherited from DockContent.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsActivated | (Inherited from DockContent.)
IsContentDocument | This is used to see if the editor is a document type that should be saved prior to doing a build. (Overrides BaseContentEditor..::.IsContentDocument.)
IsDirty | This returns the dirty state of the document if it supports saving (Inherited from BaseContentEditor.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsFloat | (Inherited from DockContent.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsHidden | (Inherited from DockContent.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Pane | (Inherited from DockContent.)
PanelPane | (Inherited from DockContent.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowHint | (Inherited from DockContent.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabPageContextMenu | (Inherited from DockContent.)
TabPageContextMenuStrip | (Inherited from DockContent.)
TabStop | (Inherited from Form.)
TabText | (Inherited from DockContent.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
ToolTipText | (Inherited from DockContent.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VisibleState | (Inherited from DockContent.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

ContentLayoutWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


CanClose Property

[image]

Sandcastle Help File Builder Documentation
ContentLayoutWindow..::.CanClose Property
ContentLayoutWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Returns true if the window can be closed or false if something prevents it from allowing the close to occur.

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public override bool CanClose { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property CanClose As Boolean

See Also

ContentLayoutWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


CanSaveContent Property

[image]

Sandcastle Help File Builder Documentation
ContentLayoutWindow..::.CanSaveContent Property
ContentLayoutWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to see if the active document allows its content to be saved.

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public override bool CanSaveContent { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property CanSaveContent As Boolean

Return Value

Returns true if it supports saving its content or false if it does not.

See Also

ContentLayoutWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


IsContentDocument Property

[image]

Sandcastle Help File Builder Documentation
ContentLayoutWindow..::.IsContentDocument Property
ContentLayoutWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to see if the editor is a document type that should be saved prior to doing a build.

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public override bool IsContentDocument { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property IsContentDocument As Boolean

See Also

ContentLayoutWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


ContentLayoutWindow Events

[image] [image]

Sandcastle Help File Builder Documentation
ContentLayoutWindow Events
ContentLayoutWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ContentLayoutWindow type exposes the following members.

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DockStateChanged | (Inherited from DockContent.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

ContentLayoutWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


EntityReferenceWindow Class

[image]

Sandcastle Help File Builder Documentation
EntityReferenceWindow Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This form is used to look up code entity references, code snippets, tokens, and images, and allows them to be dragged and dropped into a topic editor window.

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public class EntityReferenceWindow : BaseContentEditor
Visual Basic (Declaration)
Public Class EntityReferenceWindow _
    Inherits BaseContentEditor

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
WeifenLuo.WinFormsUI.Docking..::.DockContent
SandcastleBuilder.Gui.ContentEditors..::.BaseContentEditor
SandcastleBuilder.Gui.ContentEditors..::.EntityReferenceWindow

See Also

EntityReferenceWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


EntityReferenceWindow Members

[image] [image]

Sandcastle Help File Builder Documentation
EntityReferenceWindow Members
EntityReferenceWindow Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The EntityReferenceWindow type exposes the following members.

Constructors

Name | Description
EntityReferenceWindow | Constructor

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | (Inherited from DockContent.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DockTo | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
FloatAt | (Inherited from DockContent.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPersistString | (Inherited from DockContent.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | (Inherited from DockContent.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsDockStateValid | (Inherited from DockContent.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDockStateChanged | (Inherited from DockContent.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Save | Save the content of the window using its current filename (Inherited from BaseContentEditor.)
SaveAs | Save the content of the window using a different filename (Inherited from BaseContentEditor.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowEndUserDocking | (Inherited from DockContent.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoHidePortion | (Inherited from DockContent.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanClose | Returns true if the window can be closed or false if something prevents it from allowing the close to occur. (Inherited from BaseContentEditor.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSaveContent | This is used to see if the active document allows its content to be saved. (Inherited from BaseContentEditor.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CloseButton | (Inherited from DockContent.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
CurrentProject | This is used to set or get the current project
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockAreas | (Inherited from DockContent.)
DockHandler | (Inherited from DockContent.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DockPanel | (Inherited from DockContent.)
DockState | (Inherited from DockContent.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FloatPane | (Inherited from DockContent.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HideOnClose | (Inherited from DockContent.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsActivated | (Inherited from DockContent.)
IsContentDocument | This is used to see if the editor is a document type that should be saved prior to doing a build. (Inherited from BaseContentEditor.)
IsDirty | This returns the dirty state of the document if it supports saving (Inherited from BaseContentEditor.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsFloat | (Inherited from DockContent.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsHidden | (Inherited from DockContent.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Pane | (Inherited from DockContent.)
PanelPane | (Inherited from DockContent.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowHint | (Inherited from DockContent.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabPageContextMenu | (Inherited from DockContent.)
TabPageContextMenuStrip | (Inherited from DockContent.)
TabStop | (Inherited from Form.)
TabText | (Inherited from DockContent.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
ToolTipText | (Inherited from DockContent.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VisibleState | (Inherited from DockContent.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DockStateChanged | (Inherited from DockContent.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

EntityReferenceWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


EntityReferenceWindow Constructor

[image]

Sandcastle Help File Builder Documentation
EntityReferenceWindow Constructor
EntityReferenceWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public EntityReferenceWindow(
    ToolStripStatusLabel statusLabel
)
Visual Basic (Declaration)
Public Sub New ( _
    statusLabel As ToolStripStatusLabel _
)

Parameters

statusLabel
Type: System.Windows.Forms..::.ToolStripStatusLabel
The status text label control

See Also

EntityReferenceWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


EntityReferenceWindow Methods

[image] [image]

Sandcastle Help File Builder Documentation
EntityReferenceWindow Methods
EntityReferenceWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The EntityReferenceWindow type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | (Inherited from DockContent.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DockTo | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
FloatAt | (Inherited from DockContent.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPersistString | (Inherited from DockContent.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | (Inherited from DockContent.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsDockStateValid | (Inherited from DockContent.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDockStateChanged | (Inherited from DockContent.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Save | Save the content of the window using its current filename (Inherited from BaseContentEditor.)
SaveAs | Save the content of the window using a different filename (Inherited from BaseContentEditor.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

See Also

EntityReferenceWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


AccessibilityNotifyClients Method

[image] [image]

Sandcastle Help File Builder Documentation
EntityReferenceWindow..::.AccessibilityNotifyClients Method
EntityReferenceWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

EntityReferenceWindow Class
EntityReferenceWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


BeginInvoke Method

[image] [image]

Sandcastle Help File Builder Documentation
EntityReferenceWindow..::.BeginInvoke Method
EntityReferenceWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

EntityReferenceWindow Class
EntityReferenceWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Dispose Method

[image] [image]

Sandcastle Help File Builder Documentation
EntityReferenceWindow..::.Dispose Method
EntityReferenceWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides Form..::.Dispose(Boolean).)

See Also

EntityReferenceWindow Class
EntityReferenceWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Dispose Method (Boolean)

[image]

Sandcastle Help File Builder Documentation
EntityReferenceWindow..::.Dispose Method (Boolean)
EntityReferenceWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

EntityReferenceWindow Class
Dispose Overload
SandcastleBuilder.Gui.ContentEditors Namespace


DockTo Method

[image] [image]

Sandcastle Help File Builder Documentation
EntityReferenceWindow..::.DockTo Method
EntityReferenceWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
DockTo(DockPanel, DockStyle) | (Inherited from DockContent.)
DockTo(DockPane, DockStyle, Int32) | (Inherited from DockContent.)

See Also

EntityReferenceWindow Class
EntityReferenceWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


GetChildAtPoint Method

[image] [image]

Sandcastle Help File Builder Documentation
EntityReferenceWindow..::.GetChildAtPoint Method
EntityReferenceWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

EntityReferenceWindow Class
EntityReferenceWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Invalidate Method

[image] [image]

Sandcastle Help File Builder Documentation
EntityReferenceWindow..::.Invalidate Method
EntityReferenceWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

EntityReferenceWindow Class
EntityReferenceWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Invoke Method

[image] [image]

Sandcastle Help File Builder Documentation
EntityReferenceWindow..::.Invoke Method
EntityReferenceWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

EntityReferenceWindow Class
EntityReferenceWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


MemberwiseClone Method

[image] [image]

Sandcastle Help File Builder Documentation
EntityReferenceWindow..::.MemberwiseClone Method
EntityReferenceWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

EntityReferenceWindow Class
EntityReferenceWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


PerformLayout Method

[image] [image]

Sandcastle Help File Builder Documentation
EntityReferenceWindow..::.PerformLayout Method
EntityReferenceWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

EntityReferenceWindow Class
EntityReferenceWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


ResumeLayout Method

[image] [image]

Sandcastle Help File Builder Documentation
EntityReferenceWindow..::.ResumeLayout Method
EntityReferenceWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

EntityReferenceWindow Class
EntityReferenceWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


RtlTranslateAlignment Method

[image] [image]

Sandcastle Help File Builder Documentation
EntityReferenceWindow..::.RtlTranslateAlignment Method
EntityReferenceWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

EntityReferenceWindow Class
EntityReferenceWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Scale Method

[image] [image]

Sandcastle Help File Builder Documentation
EntityReferenceWindow..::.Scale Method
EntityReferenceWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

EntityReferenceWindow Class
EntityReferenceWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Select Method

[image] [image]

Sandcastle Help File Builder Documentation
EntityReferenceWindow..::.Select Method
EntityReferenceWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)

See Also

EntityReferenceWindow Class
EntityReferenceWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


SetBounds Method

[image] [image]

Sandcastle Help File Builder Documentation
EntityReferenceWindow..::.SetBounds Method
EntityReferenceWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

EntityReferenceWindow Class
EntityReferenceWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Show Method

[image] [image]

Sandcastle Help File Builder Documentation
EntityReferenceWindow..::.Show Method
EntityReferenceWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Show()()() | (Inherited from DockContent.)
Show(DockPanel) | (Inherited from DockContent.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Show(DockPanel, DockState) | (Inherited from DockContent.)
Show(DockPanel, Rectangle) | (Inherited from DockContent.)
Show(DockPane, IDockContent) | (Inherited from DockContent.)
Show(DockPane, DockAlignment, Double) | (Inherited from DockContent.)

See Also

EntityReferenceWindow Class
EntityReferenceWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


ShowDialog Method

[image] [image]

Sandcastle Help File Builder Documentation
EntityReferenceWindow..::.ShowDialog Method
EntityReferenceWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)

See Also

EntityReferenceWindow Class
EntityReferenceWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


UpdateBounds Method

[image] [image]

Sandcastle Help File Builder Documentation
EntityReferenceWindow..::.UpdateBounds Method
EntityReferenceWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

EntityReferenceWindow Class
EntityReferenceWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Validate Method

[image] [image]

Sandcastle Help File Builder Documentation
EntityReferenceWindow..::.Validate Method
EntityReferenceWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

EntityReferenceWindow Class
EntityReferenceWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


ValidateChildren Method

[image] [image]

Sandcastle Help File Builder Documentation
EntityReferenceWindow..::.ValidateChildren Method
EntityReferenceWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

EntityReferenceWindow Class
EntityReferenceWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


EntityReferenceWindow Properties

[image] [image]

Sandcastle Help File Builder Documentation
EntityReferenceWindow Properties
EntityReferenceWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The EntityReferenceWindow type exposes the following members.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowEndUserDocking | (Inherited from DockContent.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoHidePortion | (Inherited from DockContent.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanClose | Returns true if the window can be closed or false if something prevents it from allowing the close to occur. (Inherited from BaseContentEditor.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSaveContent | This is used to see if the active document allows its content to be saved. (Inherited from BaseContentEditor.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CloseButton | (Inherited from DockContent.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
CurrentProject | This is used to set or get the current project
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockAreas | (Inherited from DockContent.)
DockHandler | (Inherited from DockContent.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DockPanel | (Inherited from DockContent.)
DockState | (Inherited from DockContent.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FloatPane | (Inherited from DockContent.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HideOnClose | (Inherited from DockContent.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsActivated | (Inherited from DockContent.)
IsContentDocument | This is used to see if the editor is a document type that should be saved prior to doing a build. (Inherited from BaseContentEditor.)
IsDirty | This returns the dirty state of the document if it supports saving (Inherited from BaseContentEditor.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsFloat | (Inherited from DockContent.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsHidden | (Inherited from DockContent.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Pane | (Inherited from DockContent.)
PanelPane | (Inherited from DockContent.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowHint | (Inherited from DockContent.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabPageContextMenu | (Inherited from DockContent.)
TabPageContextMenuStrip | (Inherited from DockContent.)
TabStop | (Inherited from Form.)
TabText | (Inherited from DockContent.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
ToolTipText | (Inherited from DockContent.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VisibleState | (Inherited from DockContent.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

EntityReferenceWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


CurrentProject Property

[image]

Sandcastle Help File Builder Documentation
EntityReferenceWindow..::.CurrentProject Property
EntityReferenceWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to set or get the current project

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public SandcastleProject CurrentProject { get; set; }
Visual Basic (Declaration)
Public Property CurrentProject As SandcastleProject

See Also

EntityReferenceWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


EntityReferenceWindow Events

[image] [image]

Sandcastle Help File Builder Documentation
EntityReferenceWindow Events
EntityReferenceWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The EntityReferenceWindow type exposes the following members.

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DockStateChanged | (Inherited from DockContent.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

EntityReferenceWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


FileTree Class

[image]

Sandcastle Help File Builder Documentation
FileTree Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to load the ProjectExplorerWindow tree view with the project file tree.

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public class FileTree
Visual Basic (Declaration)
Public Class FileTree

Remarks

It is also used to handle such tasks as renaming, removing, and adding nodes.

Inheritance Hierarchy

System..::.Object
SandcastleBuilder.Gui.ContentEditors..::.FileTree

See Also

FileTree Members
SandcastleBuilder.Gui.ContentEditors Namespace


FileTree Members

[image] [image]

Sandcastle Help File Builder Documentation
FileTree Members
FileTree Class Constructors Methods See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FileTree type exposes the following members.

Constructors

Name | Description
FileTree | Constructor

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
LoadTree | Load the tree with the folder and file items
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RefreshPathsInChildren | Refresh the path info in each child node due to a renamed parent folder node.
RemoveNode | Remove the children of a folder node from the project.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FileTree Class
SandcastleBuilder.Gui.ContentEditors Namespace


FileTree Constructor

[image]

Sandcastle Help File Builder Documentation
FileTree Constructor
FileTree Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public FileTree(
    TreeView treeControl
)
Visual Basic (Declaration)
Public Sub New ( _
    treeControl As TreeView _
)

Parameters

treeControl
Type: System.Windows.Forms..::.TreeView
The TreeView control with which this instance is associated.

See Also

FileTree Class
SandcastleBuilder.Gui.ContentEditors Namespace


FileTree Methods

[image] [image]

Sandcastle Help File Builder Documentation
FileTree Methods
FileTree Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FileTree type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
LoadTree | Load the tree with the folder and file items
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RefreshPathsInChildren | Refresh the path info in each child node due to a renamed parent folder node.
RemoveNode | Remove the children of a folder node from the project.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FileTree Class
SandcastleBuilder.Gui.ContentEditors Namespace


LoadTree Method

[image]

Sandcastle Help File Builder Documentation
FileTree..::.LoadTree Method
FileTree Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Load the tree with the folder and file items

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public void LoadTree(
    Collection<FileItem> files
)
Visual Basic (Declaration)
Public Sub LoadTree ( _
    files As Collection(Of FileItem) _
)

Parameters

files
Type: System.Collections.ObjectModel..::.Collection <(Of <( FileItem >)>)
The folder and file build items from the project

See Also

FileTree Class
SandcastleBuilder.Gui.ContentEditors Namespace


RefreshPathsInChildren Method

[image]

Sandcastle Help File Builder Documentation
FileTree..::.RefreshPathsInChildren Method
FileTree Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Refresh the path info in each child node due to a renamed parent folder node.

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public void RefreshPathsInChildren(
    TreeNode node
)
Visual Basic (Declaration)
Public Sub RefreshPathsInChildren ( _
    node As TreeNode _
)

Parameters

node
Type: System.Windows.Forms..::.TreeNode
The node in which to refresh the children

See Also

FileTree Class
SandcastleBuilder.Gui.ContentEditors Namespace


RemoveNode Method

[image]

Sandcastle Help File Builder Documentation
FileTree..::.RemoveNode Method
FileTree Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Remove the children of a folder node from the project.

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public void RemoveNode(
    TreeNode node,
    bool permanently
)
Visual Basic (Declaration)
Public Sub RemoveNode ( _
    node As TreeNode, _
    permanently As Boolean _
)

Parameters

node
Type: System.Windows.Forms..::.TreeNode
The parent folder node
permanently
Type: System..::.Boolean
True to delete the items or false to just remove them from the project.

See Also

FileTree Class
SandcastleBuilder.Gui.ContentEditors Namespace


FindAndReplaceWindow Class

[image]

Sandcastle Help File Builder Documentation
FindAndReplaceWindow Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This form is used to handle search and replace in the text editor windows.

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public class FindAndReplaceWindow : BaseContentEditor
Visual Basic (Declaration)
Public Class FindAndReplaceWindow _
    Inherits BaseContentEditor

Remarks

This is rather crude but it works. It's the best I could do after poking around in the editor code. It will do for the time being even if it isn't the most efficient way of doing it.

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
WeifenLuo.WinFormsUI.Docking..::.DockContent
SandcastleBuilder.Gui.ContentEditors..::.BaseContentEditor
SandcastleBuilder.Gui.ContentEditors..::.FindAndReplaceWindow

See Also

FindAndReplaceWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


FindAndReplaceWindow Members

[image] [image]

Sandcastle Help File Builder Documentation
FindAndReplaceWindow Members
FindAndReplaceWindow Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FindAndReplaceWindow type exposes the following members.

Constructors

Name | Description
FindAndReplaceWindow | Constructor

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | (Inherited from DockContent.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DockTo | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
FloatAt | (Inherited from DockContent.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPersistString | (Inherited from DockContent.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | (Inherited from DockContent.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsDockStateValid | (Inherited from DockContent.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDockStateChanged | (Inherited from DockContent.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Save | Save the content of the window using its current filename (Inherited from BaseContentEditor.)
SaveAs | Save the content of the window using a different filename (Inherited from BaseContentEditor.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
ShowReplaceControls | This is used to show or hide the Replace controls
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowEndUserDocking | (Inherited from DockContent.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoHidePortion | (Inherited from DockContent.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanClose | Returns true if the window can be closed or false if something prevents it from allowing the close to occur. (Inherited from BaseContentEditor.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSaveContent | This is used to see if the active document allows its content to be saved. (Inherited from BaseContentEditor.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CaseSensitive | This is used to get or set whether the search is case-sensitive
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CloseButton | (Inherited from DockContent.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockAreas | (Inherited from DockContent.)
DockHandler | (Inherited from DockContent.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DockPanel | (Inherited from DockContent.)
DockState | (Inherited from DockContent.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FindText | This is used to get or set the find text
FloatPane | (Inherited from DockContent.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HideOnClose | (Inherited from DockContent.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsActivated | (Inherited from DockContent.)
IsContentDocument | This is used to see if the editor is a document type that should be saved prior to doing a build. (Inherited from BaseContentEditor.)
IsDirty | This returns the dirty state of the document if it supports saving (Inherited from BaseContentEditor.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsFloat | (Inherited from DockContent.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsHidden | (Inherited from DockContent.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Pane | (Inherited from DockContent.)
PanelPane | (Inherited from DockContent.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ReplaceWith | This is used to get or set the replacement text
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowHint | (Inherited from DockContent.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabPageContextMenu | (Inherited from DockContent.)
TabPageContextMenuStrip | (Inherited from DockContent.)
TabStop | (Inherited from Form.)
TabText | (Inherited from DockContent.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
ToolTipText | (Inherited from DockContent.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VisibleState | (Inherited from DockContent.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DockStateChanged | (Inherited from DockContent.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

FindAndReplaceWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


FindAndReplaceWindow Constructor

[image]

Sandcastle Help File Builder Documentation
FindAndReplaceWindow Constructor
FindAndReplaceWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public FindAndReplaceWindow()
Visual Basic (Declaration)
Public Sub New

See Also

FindAndReplaceWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


FindAndReplaceWindow Methods

[image] [image]

Sandcastle Help File Builder Documentation
FindAndReplaceWindow Methods
FindAndReplaceWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FindAndReplaceWindow type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | (Inherited from DockContent.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DockTo | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
FloatAt | (Inherited from DockContent.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPersistString | (Inherited from DockContent.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | (Inherited from DockContent.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsDockStateValid | (Inherited from DockContent.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDockStateChanged | (Inherited from DockContent.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Save | Save the content of the window using its current filename (Inherited from BaseContentEditor.)
SaveAs | Save the content of the window using a different filename (Inherited from BaseContentEditor.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
ShowReplaceControls | This is used to show or hide the Replace controls
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

See Also

FindAndReplaceWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


AccessibilityNotifyClients Method

[image] [image]

Sandcastle Help File Builder Documentation
FindAndReplaceWindow..::.AccessibilityNotifyClients Method
FindAndReplaceWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

FindAndReplaceWindow Class
FindAndReplaceWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


BeginInvoke Method

[image] [image]

Sandcastle Help File Builder Documentation
FindAndReplaceWindow..::.BeginInvoke Method
FindAndReplaceWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

FindAndReplaceWindow Class
FindAndReplaceWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Dispose Method

[image] [image]

Sandcastle Help File Builder Documentation
FindAndReplaceWindow..::.Dispose Method
FindAndReplaceWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides Form..::.Dispose(Boolean).)

See Also

FindAndReplaceWindow Class
FindAndReplaceWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Dispose Method (Boolean)

[image]

Sandcastle Help File Builder Documentation
FindAndReplaceWindow..::.Dispose Method (Boolean)
FindAndReplaceWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

FindAndReplaceWindow Class
Dispose Overload
SandcastleBuilder.Gui.ContentEditors Namespace


DockTo Method

[image] [image]

Sandcastle Help File Builder Documentation
FindAndReplaceWindow..::.DockTo Method
FindAndReplaceWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
DockTo(DockPanel, DockStyle) | (Inherited from DockContent.)
DockTo(DockPane, DockStyle, Int32) | (Inherited from DockContent.)

See Also

FindAndReplaceWindow Class
FindAndReplaceWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


GetChildAtPoint Method

[image] [image]

Sandcastle Help File Builder Documentation
FindAndReplaceWindow..::.GetChildAtPoint Method
FindAndReplaceWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

FindAndReplaceWindow Class
FindAndReplaceWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Invalidate Method

[image] [image]

Sandcastle Help File Builder Documentation
FindAndReplaceWindow..::.Invalidate Method
FindAndReplaceWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

FindAndReplaceWindow Class
FindAndReplaceWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Invoke Method

[image] [image]

Sandcastle Help File Builder Documentation
FindAndReplaceWindow..::.Invoke Method
FindAndReplaceWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

FindAndReplaceWindow Class
FindAndReplaceWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


MemberwiseClone Method

[image] [image]

Sandcastle Help File Builder Documentation
FindAndReplaceWindow..::.MemberwiseClone Method
FindAndReplaceWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

FindAndReplaceWindow Class
FindAndReplaceWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


PerformLayout Method

[image] [image]

Sandcastle Help File Builder Documentation
FindAndReplaceWindow..::.PerformLayout Method
FindAndReplaceWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

FindAndReplaceWindow Class
FindAndReplaceWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


ResumeLayout Method

[image] [image]

Sandcastle Help File Builder Documentation
FindAndReplaceWindow..::.ResumeLayout Method
FindAndReplaceWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

FindAndReplaceWindow Class
FindAndReplaceWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


RtlTranslateAlignment Method

[image] [image]

Sandcastle Help File Builder Documentation
FindAndReplaceWindow..::.RtlTranslateAlignment Method
FindAndReplaceWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

FindAndReplaceWindow Class
FindAndReplaceWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Scale Method

[image] [image]

Sandcastle Help File Builder Documentation
FindAndReplaceWindow..::.Scale Method
FindAndReplaceWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

FindAndReplaceWindow Class
FindAndReplaceWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Select Method

[image] [image]

Sandcastle Help File Builder Documentation
FindAndReplaceWindow..::.Select Method
FindAndReplaceWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)

See Also

FindAndReplaceWindow Class
FindAndReplaceWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


SetBounds Method

[image] [image]

Sandcastle Help File Builder Documentation
FindAndReplaceWindow..::.SetBounds Method
FindAndReplaceWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

FindAndReplaceWindow Class
FindAndReplaceWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Show Method

[image] [image]

Sandcastle Help File Builder Documentation
FindAndReplaceWindow..::.Show Method
FindAndReplaceWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Show()()() | (Inherited from DockContent.)
Show(DockPanel) | (Inherited from DockContent.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Show(DockPanel, DockState) | (Inherited from DockContent.)
Show(DockPanel, Rectangle) | (Inherited from DockContent.)
Show(DockPane, IDockContent) | (Inherited from DockContent.)
Show(DockPane, DockAlignment, Double) | (Inherited from DockContent.)

See Also

FindAndReplaceWindow Class
FindAndReplaceWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


ShowDialog Method

[image] [image]

Sandcastle Help File Builder Documentation
FindAndReplaceWindow..::.ShowDialog Method
FindAndReplaceWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)

See Also

FindAndReplaceWindow Class
FindAndReplaceWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


ShowReplaceControls Method

[image]

Sandcastle Help File Builder Documentation
FindAndReplaceWindow..::.ShowReplaceControls Method
FindAndReplaceWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to show or hide the Replace controls

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public bool ShowReplaceControls(
    bool show
)
Visual Basic (Declaration)
Public Function ShowReplaceControls ( _
    show As Boolean _
) As Boolean

Parameters

show
Type: System..::.Boolean
True to show them, false to hide them

Return Value

The prior state of the controls (false for hidden, true for visible).

See Also

FindAndReplaceWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


UpdateBounds Method

[image] [image]

Sandcastle Help File Builder Documentation
FindAndReplaceWindow..::.UpdateBounds Method
FindAndReplaceWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

FindAndReplaceWindow Class
FindAndReplaceWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Validate Method

[image] [image]

Sandcastle Help File Builder Documentation
FindAndReplaceWindow..::.Validate Method
FindAndReplaceWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

FindAndReplaceWindow Class
FindAndReplaceWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


ValidateChildren Method

[image] [image]

Sandcastle Help File Builder Documentation
FindAndReplaceWindow..::.ValidateChildren Method
FindAndReplaceWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

FindAndReplaceWindow Class
FindAndReplaceWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


FindAndReplaceWindow Properties

[image] [image]

Sandcastle Help File Builder Documentation
FindAndReplaceWindow Properties
FindAndReplaceWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FindAndReplaceWindow type exposes the following members.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowEndUserDocking | (Inherited from DockContent.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoHidePortion | (Inherited from DockContent.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanClose | Returns true if the window can be closed or false if something prevents it from allowing the close to occur. (Inherited from BaseContentEditor.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSaveContent | This is used to see if the active document allows its content to be saved. (Inherited from BaseContentEditor.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CaseSensitive | This is used to get or set whether the search is case-sensitive
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CloseButton | (Inherited from DockContent.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockAreas | (Inherited from DockContent.)
DockHandler | (Inherited from DockContent.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DockPanel | (Inherited from DockContent.)
DockState | (Inherited from DockContent.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FindText | This is used to get or set the find text
FloatPane | (Inherited from DockContent.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HideOnClose | (Inherited from DockContent.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsActivated | (Inherited from DockContent.)
IsContentDocument | This is used to see if the editor is a document type that should be saved prior to doing a build. (Inherited from BaseContentEditor.)
IsDirty | This returns the dirty state of the document if it supports saving (Inherited from BaseContentEditor.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsFloat | (Inherited from DockContent.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsHidden | (Inherited from DockContent.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Pane | (Inherited from DockContent.)
PanelPane | (Inherited from DockContent.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ReplaceWith | This is used to get or set the replacement text
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowHint | (Inherited from DockContent.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabPageContextMenu | (Inherited from DockContent.)
TabPageContextMenuStrip | (Inherited from DockContent.)
TabStop | (Inherited from Form.)
TabText | (Inherited from DockContent.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
ToolTipText | (Inherited from DockContent.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VisibleState | (Inherited from DockContent.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

FindAndReplaceWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


CaseSensitive Property

[image]

Sandcastle Help File Builder Documentation
FindAndReplaceWindow..::.CaseSensitive Property
FindAndReplaceWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set whether the search is case-sensitive

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public bool CaseSensitive { get; set; }
Visual Basic (Declaration)
Public Property CaseSensitive As Boolean

See Also

FindAndReplaceWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


FindText Property

[image]

Sandcastle Help File Builder Documentation
FindAndReplaceWindow..::.FindText Property
FindAndReplaceWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set the find text

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public string FindText { get; set; }
Visual Basic (Declaration)
Public Property FindText As String

See Also

FindAndReplaceWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


ReplaceWith Property

[image]

Sandcastle Help File Builder Documentation
FindAndReplaceWindow..::.ReplaceWith Property
FindAndReplaceWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set the replacement text

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public string ReplaceWith { get; set; }
Visual Basic (Declaration)
Public Property ReplaceWith As String

See Also

FindAndReplaceWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


FindAndReplaceWindow Events

[image] [image]

Sandcastle Help File Builder Documentation
FindAndReplaceWindow Events
FindAndReplaceWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FindAndReplaceWindow type exposes the following members.

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DockStateChanged | (Inherited from DockContent.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

FindAndReplaceWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


GotoLineDlg Class

[image]

Sandcastle Help File Builder Documentation
GotoLineDlg Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to enter the line number for the Goto Line editor action.

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public class GotoLineDlg : Form
Visual Basic (Declaration)
Public Class GotoLineDlg _
    Inherits Form

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
SandcastleBuilder.Gui.ContentEditors..::.GotoLineDlg

See Also

GotoLineDlg Members
SandcastleBuilder.Gui.ContentEditors Namespace


GotoLineDlg Members

[image] [image]

Sandcastle Help File Builder Documentation
GotoLineDlg Members
GotoLineDlg Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The GotoLineDlg type exposes the following members.

Constructors

Name | Description
GotoLineDlg | Constructor

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
LineNumber | This read-only property returns the entered line number
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

GotoLineDlg Class
SandcastleBuilder.Gui.ContentEditors Namespace


GotoLineDlg Constructor

[image]

Sandcastle Help File Builder Documentation
GotoLineDlg Constructor
GotoLineDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public GotoLineDlg()
Visual Basic (Declaration)
Public Sub New

See Also

GotoLineDlg Class
SandcastleBuilder.Gui.ContentEditors Namespace


GotoLineDlg Methods

[image] [image]

Sandcastle Help File Builder Documentation
GotoLineDlg Methods
GotoLineDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The GotoLineDlg type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

See Also

GotoLineDlg Class
SandcastleBuilder.Gui.ContentEditors Namespace


AccessibilityNotifyClients Method

[image] [image]

Sandcastle Help File Builder Documentation
GotoLineDlg..::.AccessibilityNotifyClients Method
GotoLineDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

GotoLineDlg Class
GotoLineDlg Members
SandcastleBuilder.Gui.ContentEditors Namespace


BeginInvoke Method

[image] [image]

Sandcastle Help File Builder Documentation
GotoLineDlg..::.BeginInvoke Method
GotoLineDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

GotoLineDlg Class
GotoLineDlg Members
SandcastleBuilder.Gui.ContentEditors Namespace


Dispose Method

[image] [image]

Sandcastle Help File Builder Documentation
GotoLineDlg..::.Dispose Method
GotoLineDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides Form..::.Dispose(Boolean).)

See Also

GotoLineDlg Class
GotoLineDlg Members
SandcastleBuilder.Gui.ContentEditors Namespace


Dispose Method (Boolean)

[image]

Sandcastle Help File Builder Documentation
GotoLineDlg..::.Dispose Method (Boolean)
GotoLineDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

GotoLineDlg Class
Dispose Overload
SandcastleBuilder.Gui.ContentEditors Namespace


GetChildAtPoint Method

[image] [image]

Sandcastle Help File Builder Documentation
GotoLineDlg..::.GetChildAtPoint Method
GotoLineDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

GotoLineDlg Class
GotoLineDlg Members
SandcastleBuilder.Gui.ContentEditors Namespace


Invalidate Method

[image] [image]

Sandcastle Help File Builder Documentation
GotoLineDlg..::.Invalidate Method
GotoLineDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

GotoLineDlg Class
GotoLineDlg Members
SandcastleBuilder.Gui.ContentEditors Namespace


Invoke Method

[image] [image]

Sandcastle Help File Builder Documentation
GotoLineDlg..::.Invoke Method
GotoLineDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

GotoLineDlg Class
GotoLineDlg Members
SandcastleBuilder.Gui.ContentEditors Namespace


MemberwiseClone Method

[image] [image]

Sandcastle Help File Builder Documentation
GotoLineDlg..::.MemberwiseClone Method
GotoLineDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

GotoLineDlg Class
GotoLineDlg Members
SandcastleBuilder.Gui.ContentEditors Namespace


PerformLayout Method

[image] [image]

Sandcastle Help File Builder Documentation
GotoLineDlg..::.PerformLayout Method
GotoLineDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

GotoLineDlg Class
GotoLineDlg Members
SandcastleBuilder.Gui.ContentEditors Namespace


ResumeLayout Method

[image] [image]

Sandcastle Help File Builder Documentation
GotoLineDlg..::.ResumeLayout Method
GotoLineDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

GotoLineDlg Class
GotoLineDlg Members
SandcastleBuilder.Gui.ContentEditors Namespace


RtlTranslateAlignment Method

[image] [image]

Sandcastle Help File Builder Documentation
GotoLineDlg..::.RtlTranslateAlignment Method
GotoLineDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

GotoLineDlg Class
GotoLineDlg Members
SandcastleBuilder.Gui.ContentEditors Namespace


Scale Method

[image] [image]

Sandcastle Help File Builder Documentation
GotoLineDlg..::.Scale Method
GotoLineDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

GotoLineDlg Class
GotoLineDlg Members
SandcastleBuilder.Gui.ContentEditors Namespace


Select Method

[image] [image]

Sandcastle Help File Builder Documentation
GotoLineDlg..::.Select Method
GotoLineDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)

See Also

GotoLineDlg Class
GotoLineDlg Members
SandcastleBuilder.Gui.ContentEditors Namespace


SetBounds Method

[image] [image]

Sandcastle Help File Builder Documentation
GotoLineDlg..::.SetBounds Method
GotoLineDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

GotoLineDlg Class
GotoLineDlg Members
SandcastleBuilder.Gui.ContentEditors Namespace


Show Method

[image] [image]

Sandcastle Help File Builder Documentation
GotoLineDlg..::.Show Method
GotoLineDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Show()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

GotoLineDlg Class
GotoLineDlg Members
SandcastleBuilder.Gui.ContentEditors Namespace


ShowDialog Method

[image] [image]

Sandcastle Help File Builder Documentation
GotoLineDlg..::.ShowDialog Method
GotoLineDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)

See Also

GotoLineDlg Class
GotoLineDlg Members
SandcastleBuilder.Gui.ContentEditors Namespace


UpdateBounds Method

[image] [image]

Sandcastle Help File Builder Documentation
GotoLineDlg..::.UpdateBounds Method
GotoLineDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

GotoLineDlg Class
GotoLineDlg Members
SandcastleBuilder.Gui.ContentEditors Namespace


Validate Method

[image] [image]

Sandcastle Help File Builder Documentation
GotoLineDlg..::.Validate Method
GotoLineDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

GotoLineDlg Class
GotoLineDlg Members
SandcastleBuilder.Gui.ContentEditors Namespace


ValidateChildren Method

[image] [image]

Sandcastle Help File Builder Documentation
GotoLineDlg..::.ValidateChildren Method
GotoLineDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

GotoLineDlg Class
GotoLineDlg Members
SandcastleBuilder.Gui.ContentEditors Namespace


GotoLineDlg Properties

[image] [image]

Sandcastle Help File Builder Documentation
GotoLineDlg Properties
GotoLineDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The GotoLineDlg type exposes the following members.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
LineNumber | This read-only property returns the entered line number
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

GotoLineDlg Class
SandcastleBuilder.Gui.ContentEditors Namespace


LineNumber Property

[image]

Sandcastle Help File Builder Documentation
GotoLineDlg..::.LineNumber Property
GotoLineDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns the entered line number

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public int LineNumber { get; }
Visual Basic (Declaration)
Public ReadOnly Property LineNumber As Integer

See Also

GotoLineDlg Class
SandcastleBuilder.Gui.ContentEditors Namespace


GotoLineDlg Events

[image] [image]

Sandcastle Help File Builder Documentation
GotoLineDlg Events
GotoLineDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The GotoLineDlg type exposes the following members.

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

GotoLineDlg Class
SandcastleBuilder.Gui.ContentEditors Namespace


NodeData Class

[image]

Sandcastle Help File Builder Documentation
NodeData Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to hold basic information about the item represented by the tree view node in the ProjectExplorerWindow.

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public class NodeData
Visual Basic (Declaration)
Public Class NodeData

Inheritance Hierarchy

System..::.Object
SandcastleBuilder.Gui.ContentEditors..::.NodeData

See Also

NodeData Members
SandcastleBuilder.Gui.ContentEditors Namespace


NodeData Members

[image] [image]

Sandcastle Help File Builder Documentation
NodeData Members
NodeData Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The NodeData type exposes the following members.

Constructors

Name | Description
NodeData | Constructor

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BuildAction | The build action
Item | The build item for the node
Properties | The properties for the object

See Also

NodeData Class
SandcastleBuilder.Gui.ContentEditors Namespace


NodeData Constructor

[image]

Sandcastle Help File Builder Documentation
NodeData Constructor
NodeData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public NodeData(
    BuildAction action,
    Object item,
    Object properties
)
Visual Basic (Declaration)
Public Sub New ( _
    action As BuildAction, _
    item As Object, _
    properties As Object _
)

Parameters

action
Type: SandcastleBuilder.Utils..::.BuildAction
The build action
item
Type: System..::.Object
The node item
properties
Type: System..::.Object
The node properties

See Also

NodeData Class
SandcastleBuilder.Gui.ContentEditors Namespace


NodeData Methods

[image] [image]

Sandcastle Help File Builder Documentation
NodeData Methods
NodeData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The NodeData type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NodeData Class
SandcastleBuilder.Gui.ContentEditors Namespace


NodeData Properties

[image] [image]

Sandcastle Help File Builder Documentation
NodeData Properties
NodeData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The NodeData type exposes the following members.

Properties

Name | Description
BuildAction | The build action
Item | The build item for the node
Properties | The properties for the object

See Also

NodeData Class
SandcastleBuilder.Gui.ContentEditors Namespace


BuildAction Property

[image]

Sandcastle Help File Builder Documentation
NodeData..::.BuildAction Property
NodeData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The build action

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public BuildAction BuildAction { get; }
Visual Basic (Declaration)
Public ReadOnly Property BuildAction As BuildAction

See Also

NodeData Class
SandcastleBuilder.Gui.ContentEditors Namespace


Item Property

[image]

Sandcastle Help File Builder Documentation
NodeData..::.Item Property
NodeData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The build item for the node

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public Object Item { get; }
Visual Basic (Declaration)
Public ReadOnly Property Item As Object

See Also

NodeData Class
SandcastleBuilder.Gui.ContentEditors Namespace


Properties Property

[image]

Sandcastle Help File Builder Documentation
NodeData..::.Properties Property
NodeData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The properties for the object

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public Object Properties { get; }
Visual Basic (Declaration)
Public ReadOnly Property Properties As Object

Field Value

If a separate properties object is not specified, this will return the item itself.

See Also

NodeData Class
SandcastleBuilder.Gui.ContentEditors Namespace


NodeIcon Enumeration

[image]

Sandcastle Help File Builder Documentation
NodeIcon Enumeration
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This defines the ProjectExplorerWindow tree view node icon index values.

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
[SerializableAttribute]
public enum NodeIcon
Visual Basic (Declaration)
<SerializableAttribute> _
Public Enumeration NodeIcon

Members

Member name | Description
None | Unknown item
ProjectNode | The root project node
DocSourceFolder | Documentation source folder
ReferenceFolder | References folder
GeneralFolder | General folder
DocSource | Documentation source
ReferenceItem | Reference
ImageFile | Image file
CodeSnippets | Code snippets file
ContentLayout | Conceptual content layout/sitemap file
TokenFile | Conceptual content token file
TopicTransform | Additional content topic transformation file
XmlFile | XML file
Content | General content file (MAML, HTML, stylesheet, etc.)

See Also

SandcastleBuilder.Gui.ContentEditors Namespace


OutputWindow Class

[image]

Sandcastle Help File Builder Documentation
OutputWindow Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This form is used to contain and view the build output

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public class OutputWindow : BaseContentEditor
Visual Basic (Declaration)
Public Class OutputWindow _
    Inherits BaseContentEditor

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
WeifenLuo.WinFormsUI.Docking..::.DockContent
SandcastleBuilder.Gui.ContentEditors..::.BaseContentEditor
SandcastleBuilder.Gui.ContentEditors..::.OutputWindow

See Also

OutputWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


OutputWindow Members

[image] [image]

Sandcastle Help File Builder Documentation
OutputWindow Members
OutputWindow Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OutputWindow type exposes the following members.

Constructors

Name | Description
OutputWindow | Constructor

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | (Inherited from DockContent.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
AppendText | Append text to the build output
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DockTo | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
FloatAt | (Inherited from DockContent.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPersistString | (Inherited from DockContent.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | (Inherited from DockContent.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsDockStateValid | (Inherited from DockContent.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDockStateChanged | (Inherited from DockContent.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | This is overridden to ignore Ctrl+F4 which closes the window rather than hide it when docked as a document. (Overrides Form..::.OnFormClosing(FormClosingEventArgs).)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetLogViewer | Reset the log viewer ready for a new build
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Save | Save the content of the window using its current filename (Inherited from BaseContentEditor.)
SaveAs | Save the content of the window using a different filename (Inherited from BaseContentEditor.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetBuildState | Enable or disable based on the build state
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
TransformLogFile | This is used to transform the log file from XML to HTML for viewing
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateSettings | Update the window settings based on the user preferences
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
ViewBuildOutput | View the build output
ViewLogFile | View the specified log file
WndProc | (Inherited from Form.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowEndUserDocking | (Inherited from DockContent.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoHidePortion | (Inherited from DockContent.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanClose | Returns true if the window can be closed or false if something prevents it from allowing the close to occur. (Inherited from BaseContentEditor.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSaveContent | This is used to see if the active document allows its content to be saved. (Inherited from BaseContentEditor.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CloseButton | (Inherited from DockContent.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockAreas | (Inherited from DockContent.)
DockHandler | (Inherited from DockContent.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DockPanel | (Inherited from DockContent.)
DockState | (Inherited from DockContent.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FloatPane | (Inherited from DockContent.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HideOnClose | (Inherited from DockContent.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsActivated | (Inherited from DockContent.)
IsContentDocument | This is used to see if the editor is a document type that should be saved prior to doing a build. (Inherited from BaseContentEditor.)
IsDirty | This returns the dirty state of the document if it supports saving (Inherited from BaseContentEditor.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsFloat | (Inherited from DockContent.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsHidden | (Inherited from DockContent.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
LogFile | This is used to get or set the log filename from the last build
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Pane | (Inherited from DockContent.)
PanelPane | (Inherited from DockContent.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowHint | (Inherited from DockContent.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabPageContextMenu | (Inherited from DockContent.)
TabPageContextMenuStrip | (Inherited from DockContent.)
TabStop | (Inherited from Form.)
TabText | (Inherited from DockContent.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
ToolTipText | (Inherited from DockContent.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VisibleState | (Inherited from DockContent.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DockStateChanged | (Inherited from DockContent.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

OutputWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


OutputWindow Constructor

[image]

Sandcastle Help File Builder Documentation
OutputWindow Constructor
OutputWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public OutputWindow()
Visual Basic (Declaration)
Public Sub New

See Also

OutputWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


OutputWindow Methods

[image] [image]

Sandcastle Help File Builder Documentation
OutputWindow Methods
OutputWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OutputWindow type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | (Inherited from DockContent.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
AppendText | Append text to the build output
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DockTo | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
FloatAt | (Inherited from DockContent.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPersistString | (Inherited from DockContent.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | (Inherited from DockContent.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsDockStateValid | (Inherited from DockContent.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDockStateChanged | (Inherited from DockContent.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | This is overridden to ignore Ctrl+F4 which closes the window rather than hide it when docked as a document. (Overrides Form..::.OnFormClosing(FormClosingEventArgs).)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetLogViewer | Reset the log viewer ready for a new build
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Save | Save the content of the window using its current filename (Inherited from BaseContentEditor.)
SaveAs | Save the content of the window using a different filename (Inherited from BaseContentEditor.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetBuildState | Enable or disable based on the build state
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
TransformLogFile | This is used to transform the log file from XML to HTML for viewing
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateSettings | Update the window settings based on the user preferences
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
ViewBuildOutput | View the build output
ViewLogFile | View the specified log file
WndProc | (Inherited from Form.)

See Also

OutputWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


AccessibilityNotifyClients Method

[image] [image]

Sandcastle Help File Builder Documentation
OutputWindow..::.AccessibilityNotifyClients Method
OutputWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

OutputWindow Class
OutputWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


AppendText Method

[image]

Sandcastle Help File Builder Documentation
OutputWindow..::.AppendText Method
OutputWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Append text to the build output

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public void AppendText(
    string text
)
Visual Basic (Declaration)
Public Sub AppendText ( _
    text As String _
)

Parameters

text
Type: System..::.String
The text to append

Remarks

A carriage return and line feed are added automatically.

See Also

OutputWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


BeginInvoke Method

[image] [image]

Sandcastle Help File Builder Documentation
OutputWindow..::.BeginInvoke Method
OutputWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

OutputWindow Class
OutputWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Dispose Method

[image] [image]

Sandcastle Help File Builder Documentation
OutputWindow..::.Dispose Method
OutputWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides Form..::.Dispose(Boolean).)

See Also

OutputWindow Class
OutputWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Dispose Method (Boolean)

[image]

Sandcastle Help File Builder Documentation
OutputWindow..::.Dispose Method (Boolean)
OutputWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

OutputWindow Class
Dispose Overload
SandcastleBuilder.Gui.ContentEditors Namespace


DockTo Method

[image] [image]

Sandcastle Help File Builder Documentation
OutputWindow..::.DockTo Method
OutputWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
DockTo(DockPanel, DockStyle) | (Inherited from DockContent.)
DockTo(DockPane, DockStyle, Int32) | (Inherited from DockContent.)

See Also

OutputWindow Class
OutputWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


GetChildAtPoint Method

[image] [image]

Sandcastle Help File Builder Documentation
OutputWindow..::.GetChildAtPoint Method
OutputWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

OutputWindow Class
OutputWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Invalidate Method

[image] [image]

Sandcastle Help File Builder Documentation
OutputWindow..::.Invalidate Method
OutputWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

OutputWindow Class
OutputWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Invoke Method

[image] [image]

Sandcastle Help File Builder Documentation
OutputWindow..::.Invoke Method
OutputWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

OutputWindow Class
OutputWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


MemberwiseClone Method

[image] [image]

Sandcastle Help File Builder Documentation
OutputWindow..::.MemberwiseClone Method
OutputWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

OutputWindow Class
OutputWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


OnFormClosing Method

[image]

Sandcastle Help File Builder Documentation
OutputWindow..::.OnFormClosing Method
OutputWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is overridden to ignore Ctrl+F4 which closes the window rather than hide it when docked as a document.

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
protected override void OnFormClosing(
    FormClosingEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnFormClosing ( _
    e As FormClosingEventArgs _
)

Parameters

e
Type: System.Windows.Forms..::.FormClosingEventArgs
The event arguments

See Also

OutputWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


PerformLayout Method

[image] [image]

Sandcastle Help File Builder Documentation
OutputWindow..::.PerformLayout Method
OutputWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

OutputWindow Class
OutputWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


ResetLogViewer Method

[image]

Sandcastle Help File Builder Documentation
OutputWindow..::.ResetLogViewer Method
OutputWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Reset the log viewer ready for a new build

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public void ResetLogViewer()
Visual Basic (Declaration)
Public Sub ResetLogViewer

See Also

OutputWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


ResumeLayout Method

[image] [image]

Sandcastle Help File Builder Documentation
OutputWindow..::.ResumeLayout Method
OutputWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

OutputWindow Class
OutputWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


RtlTranslateAlignment Method

[image] [image]

Sandcastle Help File Builder Documentation
OutputWindow..::.RtlTranslateAlignment Method
OutputWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

OutputWindow Class
OutputWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Scale Method

[image] [image]

Sandcastle Help File Builder Documentation
OutputWindow..::.Scale Method
OutputWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

OutputWindow Class
OutputWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Select Method

[image] [image]

Sandcastle Help File Builder Documentation
OutputWindow..::.Select Method
OutputWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)

See Also

OutputWindow Class
OutputWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


SetBounds Method

[image] [image]

Sandcastle Help File Builder Documentation
OutputWindow..::.SetBounds Method
OutputWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

OutputWindow Class
OutputWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


SetBuildState Method

[image]

Sandcastle Help File Builder Documentation
OutputWindow..::.SetBuildState Method
OutputWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Enable or disable based on the build state

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public void SetBuildState(
    bool isBuilding
)
Visual Basic (Declaration)
Public Sub SetBuildState ( _
    isBuilding As Boolean _
)

Parameters

isBuilding
Type: System..::.Boolean
True if building, false if not

See Also

OutputWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


Show Method

[image] [image]

Sandcastle Help File Builder Documentation
OutputWindow..::.Show Method
OutputWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Show()()() | (Inherited from DockContent.)
Show(DockPanel) | (Inherited from DockContent.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Show(DockPanel, DockState) | (Inherited from DockContent.)
Show(DockPanel, Rectangle) | (Inherited from DockContent.)
Show(DockPane, IDockContent) | (Inherited from DockContent.)
Show(DockPane, DockAlignment, Double) | (Inherited from DockContent.)

See Also

OutputWindow Class
OutputWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


ShowDialog Method

[image] [image]

Sandcastle Help File Builder Documentation
OutputWindow..::.ShowDialog Method
OutputWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)

See Also

OutputWindow Class
OutputWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


TransformLogFile Method

[image]

Sandcastle Help File Builder Documentation
OutputWindow..::.TransformLogFile Method
OutputWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to transform the log file from XML to HTML for viewing

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public static string TransformLogFile(
    string logFile
)
Visual Basic (Declaration)
Public Shared Function TransformLogFile ( _
    logFile As String _
) As String

Parameters

logFile
Type: System..::.String
The log file to transform

Return Value

The HTML representing the transformed log file

See Also

OutputWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


UpdateBounds Method

[image] [image]

Sandcastle Help File Builder Documentation
OutputWindow..::.UpdateBounds Method
OutputWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

OutputWindow Class
OutputWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


UpdateSettings Method

[image]

Sandcastle Help File Builder Documentation
OutputWindow..::.UpdateSettings Method
OutputWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Update the window settings based on the user preferences

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public void UpdateSettings()
Visual Basic (Declaration)
Public Sub UpdateSettings

See Also

OutputWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


Validate Method

[image] [image]

Sandcastle Help File Builder Documentation
OutputWindow..::.Validate Method
OutputWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

OutputWindow Class
OutputWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


ValidateChildren Method

[image] [image]

Sandcastle Help File Builder Documentation
OutputWindow..::.ValidateChildren Method
OutputWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

OutputWindow Class
OutputWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


ViewBuildOutput Method

[image]

Sandcastle Help File Builder Documentation
OutputWindow..::.ViewBuildOutput Method
OutputWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

View the build output

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public void ViewBuildOutput()
Visual Basic (Declaration)
Public Sub ViewBuildOutput

See Also

OutputWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


ViewLogFile Method

[image]

Sandcastle Help File Builder Documentation
OutputWindow..::.ViewLogFile Method
OutputWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

View the specified log file

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public void ViewLogFile(
    string logFilename
)
Visual Basic (Declaration)
Public Sub ViewLogFile ( _
    logFilename As String _
)

Parameters

logFilename
Type: System..::.String
The log file to view

See Also

OutputWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


OutputWindow Properties

[image] [image]

Sandcastle Help File Builder Documentation
OutputWindow Properties
OutputWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OutputWindow type exposes the following members.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowEndUserDocking | (Inherited from DockContent.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoHidePortion | (Inherited from DockContent.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanClose | Returns true if the window can be closed or false if something prevents it from allowing the close to occur. (Inherited from BaseContentEditor.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSaveContent | This is used to see if the active document allows its content to be saved. (Inherited from BaseContentEditor.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CloseButton | (Inherited from DockContent.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockAreas | (Inherited from DockContent.)
DockHandler | (Inherited from DockContent.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DockPanel | (Inherited from DockContent.)
DockState | (Inherited from DockContent.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FloatPane | (Inherited from DockContent.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HideOnClose | (Inherited from DockContent.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsActivated | (Inherited from DockContent.)
IsContentDocument | This is used to see if the editor is a document type that should be saved prior to doing a build. (Inherited from BaseContentEditor.)
IsDirty | This returns the dirty state of the document if it supports saving (Inherited from BaseContentEditor.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsFloat | (Inherited from DockContent.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsHidden | (Inherited from DockContent.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
LogFile | This is used to get or set the log filename from the last build
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Pane | (Inherited from DockContent.)
PanelPane | (Inherited from DockContent.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowHint | (Inherited from DockContent.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabPageContextMenu | (Inherited from DockContent.)
TabPageContextMenuStrip | (Inherited from DockContent.)
TabStop | (Inherited from Form.)
TabText | (Inherited from DockContent.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
ToolTipText | (Inherited from DockContent.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VisibleState | (Inherited from DockContent.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

OutputWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


LogFile Property

[image]

Sandcastle Help File Builder Documentation
OutputWindow..::.LogFile Property
OutputWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set the log filename from the last build

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public string LogFile { get; set; }
Visual Basic (Declaration)
Public Property LogFile As String

See Also

OutputWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


OutputWindow Events

[image] [image]

Sandcastle Help File Builder Documentation
OutputWindow Events
OutputWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OutputWindow type exposes the following members.

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DockStateChanged | (Inherited from DockContent.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

OutputWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


PreviewTopicWindow Class

[image]

Sandcastle Help File Builder Documentation
PreviewTopicWindow Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This form is used to preview a topic

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public class PreviewTopicWindow : BaseContentEditor
Visual Basic (Declaration)
Public Class PreviewTopicWindow _
    Inherits BaseContentEditor

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
WeifenLuo.WinFormsUI.Docking..::.DockContent
SandcastleBuilder.Gui.ContentEditors..::.BaseContentEditor
SandcastleBuilder.Gui.ContentEditors..::.PreviewTopicWindow

See Also

PreviewTopicWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


PreviewTopicWindow Members

[image] [image]

Sandcastle Help File Builder Documentation
PreviewTopicWindow Members
PreviewTopicWindow Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PreviewTopicWindow type exposes the following members.

Constructors

Name | Description
PreviewTopicWindow | Constructor

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | (Inherited from DockContent.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DockTo | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
FloatAt | (Inherited from DockContent.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPersistString | (Inherited from DockContent.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | (Inherited from DockContent.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsDockStateValid | (Inherited from DockContent.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDockStateChanged | (Inherited from DockContent.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | This is overridden to ignore Ctrl+F4 which closes the window rather than hide it when docked as a document. (Overrides Form..::.OnFormClosing(FormClosingEventArgs).)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreviewTopic | Build the conceptual content and preview the specified file
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Save | Save the content of the window using its current filename (Inherited from BaseContentEditor.)
SaveAs | Save the content of the window using a different filename (Inherited from BaseContentEditor.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowEndUserDocking | (Inherited from DockContent.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoHidePortion | (Inherited from DockContent.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanClose | This read-only property is used to determine whether or not the preview window can be closed. (Overrides BaseContentEditor..::.CanClose.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSaveContent | This is used to see if the active document allows its content to be saved. (Inherited from BaseContentEditor.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CloseButton | (Inherited from DockContent.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockAreas | (Inherited from DockContent.)
DockHandler | (Inherited from DockContent.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DockPanel | (Inherited from DockContent.)
DockState | (Inherited from DockContent.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FloatPane | (Inherited from DockContent.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HideOnClose | (Inherited from DockContent.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsActivated | (Inherited from DockContent.)
IsContentDocument | This is used to see if the editor is a document type that should be saved prior to doing a build. (Inherited from BaseContentEditor.)
IsDirty | This returns the dirty state of the document if it supports saving (Inherited from BaseContentEditor.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsFloat | (Inherited from DockContent.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsHidden | (Inherited from DockContent.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Pane | (Inherited from DockContent.)
PanelPane | (Inherited from DockContent.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowHint | (Inherited from DockContent.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabPageContextMenu | (Inherited from DockContent.)
TabPageContextMenuStrip | (Inherited from DockContent.)
TabStop | (Inherited from Form.)
TabText | (Inherited from DockContent.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
ToolTipText | (Inherited from DockContent.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VisibleState | (Inherited from DockContent.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DockStateChanged | (Inherited from DockContent.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

PreviewTopicWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


PreviewTopicWindow Constructor

[image]

Sandcastle Help File Builder Documentation
PreviewTopicWindow Constructor
PreviewTopicWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public PreviewTopicWindow()
Visual Basic (Declaration)
Public Sub New

See Also

PreviewTopicWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


PreviewTopicWindow Methods

[image] [image]

Sandcastle Help File Builder Documentation
PreviewTopicWindow Methods
PreviewTopicWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PreviewTopicWindow type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | (Inherited from DockContent.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DockTo | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
FloatAt | (Inherited from DockContent.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPersistString | (Inherited from DockContent.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | (Inherited from DockContent.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsDockStateValid | (Inherited from DockContent.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDockStateChanged | (Inherited from DockContent.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | This is overridden to ignore Ctrl+F4 which closes the window rather than hide it when docked as a document. (Overrides Form..::.OnFormClosing(FormClosingEventArgs).)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreviewTopic | Build the conceptual content and preview the specified file
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Save | Save the content of the window using its current filename (Inherited from BaseContentEditor.)
SaveAs | Save the content of the window using a different filename (Inherited from BaseContentEditor.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

See Also

PreviewTopicWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


AccessibilityNotifyClients Method

[image] [image]

Sandcastle Help File Builder Documentation
PreviewTopicWindow..::.AccessibilityNotifyClients Method
PreviewTopicWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

PreviewTopicWindow Class
PreviewTopicWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


BeginInvoke Method

[image] [image]

Sandcastle Help File Builder Documentation
PreviewTopicWindow..::.BeginInvoke Method
PreviewTopicWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

PreviewTopicWindow Class
PreviewTopicWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Dispose Method

[image] [image]

Sandcastle Help File Builder Documentation
PreviewTopicWindow..::.Dispose Method
PreviewTopicWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides Form..::.Dispose(Boolean).)

See Also

PreviewTopicWindow Class
PreviewTopicWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Dispose Method (Boolean)

[image]

Sandcastle Help File Builder Documentation
PreviewTopicWindow..::.Dispose Method (Boolean)
PreviewTopicWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

PreviewTopicWindow Class
Dispose Overload
SandcastleBuilder.Gui.ContentEditors Namespace


DockTo Method

[image] [image]

Sandcastle Help File Builder Documentation
PreviewTopicWindow..::.DockTo Method
PreviewTopicWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
DockTo(DockPanel, DockStyle) | (Inherited from DockContent.)
DockTo(DockPane, DockStyle, Int32) | (Inherited from DockContent.)

See Also

PreviewTopicWindow Class
PreviewTopicWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


GetChildAtPoint Method

[image] [image]

Sandcastle Help File Builder Documentation
PreviewTopicWindow..::.GetChildAtPoint Method
PreviewTopicWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

PreviewTopicWindow Class
PreviewTopicWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Invalidate Method

[image] [image]

Sandcastle Help File Builder Documentation
PreviewTopicWindow..::.Invalidate Method
PreviewTopicWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

PreviewTopicWindow Class
PreviewTopicWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Invoke Method

[image] [image]

Sandcastle Help File Builder Documentation
PreviewTopicWindow..::.Invoke Method
PreviewTopicWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

PreviewTopicWindow Class
PreviewTopicWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


MemberwiseClone Method

[image] [image]

Sandcastle Help File Builder Documentation
PreviewTopicWindow..::.MemberwiseClone Method
PreviewTopicWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

PreviewTopicWindow Class
PreviewTopicWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


OnFormClosing Method

[image]

Sandcastle Help File Builder Documentation
PreviewTopicWindow..::.OnFormClosing Method
PreviewTopicWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is overridden to ignore Ctrl+F4 which closes the window rather than hide it when docked as a document.

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
protected override void OnFormClosing(
    FormClosingEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnFormClosing ( _
    e As FormClosingEventArgs _
)

Parameters

e
Type: System.Windows.Forms..::.FormClosingEventArgs
The event arguments

See Also

PreviewTopicWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


PerformLayout Method

[image] [image]

Sandcastle Help File Builder Documentation
PreviewTopicWindow..::.PerformLayout Method
PreviewTopicWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

PreviewTopicWindow Class
PreviewTopicWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


PreviewTopic Method

[image]

Sandcastle Help File Builder Documentation
PreviewTopicWindow..::.PreviewTopic Method
PreviewTopicWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Build the conceptual content and preview the specified file

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public void PreviewTopic(
    SandcastleProject project,
    FileItem preview
)
Visual Basic (Declaration)
Public Sub PreviewTopic ( _
    project As SandcastleProject, _
    preview As FileItem _
)

Parameters

project
Type: SandcastleBuilder.Utils..::.SandcastleProject
The current project
preview
Type: SandcastleBuilder.Utils..::.FileItem
The file to preview

See Also

PreviewTopicWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


ResumeLayout Method

[image] [image]

Sandcastle Help File Builder Documentation
PreviewTopicWindow..::.ResumeLayout Method
PreviewTopicWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

PreviewTopicWindow Class
PreviewTopicWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


RtlTranslateAlignment Method

[image] [image]

Sandcastle Help File Builder Documentation
PreviewTopicWindow..::.RtlTranslateAlignment Method
PreviewTopicWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

PreviewTopicWindow Class
PreviewTopicWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Scale Method

[image] [image]

Sandcastle Help File Builder Documentation
PreviewTopicWindow..::.Scale Method
PreviewTopicWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

PreviewTopicWindow Class
PreviewTopicWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Select Method

[image] [image]

Sandcastle Help File Builder Documentation
PreviewTopicWindow..::.Select Method
PreviewTopicWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)

See Also

PreviewTopicWindow Class
PreviewTopicWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


SetBounds Method

[image] [image]

Sandcastle Help File Builder Documentation
PreviewTopicWindow..::.SetBounds Method
PreviewTopicWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

PreviewTopicWindow Class
PreviewTopicWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Show Method

[image] [image]

Sandcastle Help File Builder Documentation
PreviewTopicWindow..::.Show Method
PreviewTopicWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Show()()() | (Inherited from DockContent.)
Show(DockPanel) | (Inherited from DockContent.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Show(DockPanel, DockState) | (Inherited from DockContent.)
Show(DockPanel, Rectangle) | (Inherited from DockContent.)
Show(DockPane, IDockContent) | (Inherited from DockContent.)
Show(DockPane, DockAlignment, Double) | (Inherited from DockContent.)

See Also

PreviewTopicWindow Class
PreviewTopicWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


ShowDialog Method

[image] [image]

Sandcastle Help File Builder Documentation
PreviewTopicWindow..::.ShowDialog Method
PreviewTopicWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)

See Also

PreviewTopicWindow Class
PreviewTopicWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


UpdateBounds Method

[image] [image]

Sandcastle Help File Builder Documentation
PreviewTopicWindow..::.UpdateBounds Method
PreviewTopicWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

PreviewTopicWindow Class
PreviewTopicWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Validate Method

[image] [image]

Sandcastle Help File Builder Documentation
PreviewTopicWindow..::.Validate Method
PreviewTopicWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

PreviewTopicWindow Class
PreviewTopicWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


ValidateChildren Method

[image] [image]

Sandcastle Help File Builder Documentation
PreviewTopicWindow..::.ValidateChildren Method
PreviewTopicWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

PreviewTopicWindow Class
PreviewTopicWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


PreviewTopicWindow Properties

[image] [image]

Sandcastle Help File Builder Documentation
PreviewTopicWindow Properties
PreviewTopicWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PreviewTopicWindow type exposes the following members.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowEndUserDocking | (Inherited from DockContent.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoHidePortion | (Inherited from DockContent.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanClose | This read-only property is used to determine whether or not the preview window can be closed. (Overrides BaseContentEditor..::.CanClose.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSaveContent | This is used to see if the active document allows its content to be saved. (Inherited from BaseContentEditor.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CloseButton | (Inherited from DockContent.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockAreas | (Inherited from DockContent.)
DockHandler | (Inherited from DockContent.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DockPanel | (Inherited from DockContent.)
DockState | (Inherited from DockContent.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FloatPane | (Inherited from DockContent.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HideOnClose | (Inherited from DockContent.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsActivated | (Inherited from DockContent.)
IsContentDocument | This is used to see if the editor is a document type that should be saved prior to doing a build. (Inherited from BaseContentEditor.)
IsDirty | This returns the dirty state of the document if it supports saving (Inherited from BaseContentEditor.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsFloat | (Inherited from DockContent.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsHidden | (Inherited from DockContent.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Pane | (Inherited from DockContent.)
PanelPane | (Inherited from DockContent.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowHint | (Inherited from DockContent.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabPageContextMenu | (Inherited from DockContent.)
TabPageContextMenuStrip | (Inherited from DockContent.)
TabStop | (Inherited from Form.)
TabText | (Inherited from DockContent.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
ToolTipText | (Inherited from DockContent.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VisibleState | (Inherited from DockContent.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

PreviewTopicWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


CanClose Property

[image]

Sandcastle Help File Builder Documentation
PreviewTopicWindow..::.CanClose Property
PreviewTopicWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property is used to determine whether or not the preview window can be closed.

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public override bool CanClose { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property CanClose As Boolean

See Also

PreviewTopicWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


PreviewTopicWindow Events

[image] [image]

Sandcastle Help File Builder Documentation
PreviewTopicWindow Events
PreviewTopicWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PreviewTopicWindow type exposes the following members.

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DockStateChanged | (Inherited from DockContent.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

PreviewTopicWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


ProjectExplorerWindow Class

[image]

Sandcastle Help File Builder Documentation
ProjectExplorerWindow Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This form is used to manage the project items and files

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public class ProjectExplorerWindow : BaseContentEditor
Visual Basic (Declaration)
Public Class ProjectExplorerWindow _
    Inherits BaseContentEditor

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
WeifenLuo.WinFormsUI.Docking..::.DockContent
SandcastleBuilder.Gui.ContentEditors..::.BaseContentEditor
SandcastleBuilder.Gui.ContentEditors..::.ProjectExplorerWindow

See Also

ProjectExplorerWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


ProjectExplorerWindow Members

[image] [image]

Sandcastle Help File Builder Documentation
ProjectExplorerWindow Members
ProjectExplorerWindow Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ProjectExplorerWindow type exposes the following members.

Constructors

Name | Description
ProjectExplorerWindow | Constructor

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | (Inherited from DockContent.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
AskToSaveProject | This is called to ask the user if they want to save their project
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DockTo | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
FloatAt | (Inherited from DockContent.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPersistString | (Inherited from DockContent.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | (Inherited from DockContent.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsDockStateValid | (Inherited from DockContent.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDockStateChanged | (Inherited from DockContent.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RefreshProject | This is called to refresh the project explorer view after another pane has added files to the project.
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Save | Overloaded.
SaveAs | Save the content of the window using a different filename (Overrides BaseContentEditor..::.SaveAs()()().)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowEndUserDocking | (Inherited from DockContent.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoHidePortion | (Inherited from DockContent.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanClose | Returns true if the window can be closed or false if something prevents it from allowing the close to occur. (Inherited from BaseContentEditor.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSaveContent | This is used to see if the active document allows its content to be saved. (Overrides BaseContentEditor..::.CanSaveContent.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CloseButton | (Inherited from DockContent.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
CurrentProject | This is used to get a reference to the current project
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockAreas | (Inherited from DockContent.)
DockHandler | (Inherited from DockContent.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DockPanel | (Inherited from DockContent.)
DockState | (Inherited from DockContent.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FloatPane | (Inherited from DockContent.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HideOnClose | (Inherited from DockContent.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsActivated | (Inherited from DockContent.)
IsContentDocument | This is used to see if the editor is a document type that should be saved prior to doing a build. (Inherited from BaseContentEditor.)
IsDirty | This returns the dirty state of the document if it supports saving (Overrides BaseContentEditor..::.IsDirty.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsFloat | (Inherited from DockContent.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsHidden | (Inherited from DockContent.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Pane | (Inherited from DockContent.)
PanelPane | (Inherited from DockContent.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowHint | (Inherited from DockContent.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabPageContextMenu | (Inherited from DockContent.)
TabPageContextMenuStrip | (Inherited from DockContent.)
TabStop | (Inherited from Form.)
TabText | (Inherited from DockContent.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
ToolTipText | (Inherited from DockContent.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VisibleState | (Inherited from DockContent.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DockStateChanged | (Inherited from DockContent.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

ProjectExplorerWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


ProjectExplorerWindow Constructor

[image]

Sandcastle Help File Builder Documentation
ProjectExplorerWindow Constructor
ProjectExplorerWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public ProjectExplorerWindow()
Visual Basic (Declaration)
Public Sub New

See Also

ProjectExplorerWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


ProjectExplorerWindow Methods

[image] [image]

Sandcastle Help File Builder Documentation
ProjectExplorerWindow Methods
ProjectExplorerWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ProjectExplorerWindow type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | (Inherited from DockContent.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
AskToSaveProject | This is called to ask the user if they want to save their project
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DockTo | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
FloatAt | (Inherited from DockContent.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPersistString | (Inherited from DockContent.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | (Inherited from DockContent.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsDockStateValid | (Inherited from DockContent.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDockStateChanged | (Inherited from DockContent.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RefreshProject | This is called to refresh the project explorer view after another pane has added files to the project.
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Save | Overloaded.
SaveAs | Save the content of the window using a different filename (Overrides BaseContentEditor..::.SaveAs()()().)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

See Also

ProjectExplorerWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


AccessibilityNotifyClients Method

[image] [image]

Sandcastle Help File Builder Documentation
ProjectExplorerWindow..::.AccessibilityNotifyClients Method
ProjectExplorerWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

ProjectExplorerWindow Class
ProjectExplorerWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


AskToSaveProject Method

[image]

Sandcastle Help File Builder Documentation
ProjectExplorerWindow..::.AskToSaveProject Method
ProjectExplorerWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is called to ask the user if they want to save their project

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public bool AskToSaveProject()
Visual Basic (Declaration)
Public Function AskToSaveProject As Boolean

Return Value

Returns true if saved successfully or no save is wanted. Returns false on error or if cancelled.

See Also

ProjectExplorerWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


BeginInvoke Method

[image] [image]

Sandcastle Help File Builder Documentation
ProjectExplorerWindow..::.BeginInvoke Method
ProjectExplorerWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

ProjectExplorerWindow Class
ProjectExplorerWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Dispose Method

[image] [image]

Sandcastle Help File Builder Documentation
ProjectExplorerWindow..::.Dispose Method
ProjectExplorerWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides Form..::.Dispose(Boolean).)

See Also

ProjectExplorerWindow Class
ProjectExplorerWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Dispose Method (Boolean)

[image]

Sandcastle Help File Builder Documentation
ProjectExplorerWindow..::.Dispose Method (Boolean)
ProjectExplorerWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

ProjectExplorerWindow Class
Dispose Overload
SandcastleBuilder.Gui.ContentEditors Namespace


DockTo Method

[image] [image]

Sandcastle Help File Builder Documentation
ProjectExplorerWindow..::.DockTo Method
ProjectExplorerWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
DockTo(DockPanel, DockStyle) | (Inherited from DockContent.)
DockTo(DockPane, DockStyle, Int32) | (Inherited from DockContent.)

See Also

ProjectExplorerWindow Class
ProjectExplorerWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


GetChildAtPoint Method

[image] [image]

Sandcastle Help File Builder Documentation
ProjectExplorerWindow..::.GetChildAtPoint Method
ProjectExplorerWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

ProjectExplorerWindow Class
ProjectExplorerWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Invalidate Method

[image] [image]

Sandcastle Help File Builder Documentation
ProjectExplorerWindow..::.Invalidate Method
ProjectExplorerWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

ProjectExplorerWindow Class
ProjectExplorerWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Invoke Method

[image] [image]

Sandcastle Help File Builder Documentation
ProjectExplorerWindow..::.Invoke Method
ProjectExplorerWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

ProjectExplorerWindow Class
ProjectExplorerWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


MemberwiseClone Method

[image] [image]

Sandcastle Help File Builder Documentation
ProjectExplorerWindow..::.MemberwiseClone Method
ProjectExplorerWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ProjectExplorerWindow Class
ProjectExplorerWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


PerformLayout Method

[image] [image]

Sandcastle Help File Builder Documentation
ProjectExplorerWindow..::.PerformLayout Method
ProjectExplorerWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

ProjectExplorerWindow Class
ProjectExplorerWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


RefreshProject Method

[image]

Sandcastle Help File Builder Documentation
ProjectExplorerWindow..::.RefreshProject Method
ProjectExplorerWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is called to refresh the project explorer view after another pane has added files to the project.

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public void RefreshProject()
Visual Basic (Declaration)
Public Sub RefreshProject

See Also

ProjectExplorerWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


ResumeLayout Method

[image] [image]

Sandcastle Help File Builder Documentation
ProjectExplorerWindow..::.ResumeLayout Method
ProjectExplorerWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

ProjectExplorerWindow Class
ProjectExplorerWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


RtlTranslateAlignment Method

[image] [image]

Sandcastle Help File Builder Documentation
ProjectExplorerWindow..::.RtlTranslateAlignment Method
ProjectExplorerWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

ProjectExplorerWindow Class
ProjectExplorerWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Save Method

[image] [image]

Sandcastle Help File Builder Documentation
ProjectExplorerWindow..::.Save Method
ProjectExplorerWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Save()()() | Save the content of the window using its current filename (Overrides BaseContentEditor..::.Save()()().)
Save(String) | Save the project file

See Also

ProjectExplorerWindow Class
ProjectExplorerWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Save Method

[image]

Sandcastle Help File Builder Documentation
ProjectExplorerWindow..::.Save Method
ProjectExplorerWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Save the content of the window using its current filename

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public override bool Save()
Visual Basic (Declaration)
Public Overrides Function Save As Boolean

Return Value

True if successful, false if not successful

See Also

ProjectExplorerWindow Class
Save Overload
SandcastleBuilder.Gui.ContentEditors Namespace


Save Method (String)

[image]

Sandcastle Help File Builder Documentation
ProjectExplorerWindow..::.Save Method (String)
ProjectExplorerWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Save the project file

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public bool Save(
    string filename
)
Visual Basic (Declaration)
Public Function Save ( _
    filename As String _
) As Boolean

Parameters

filename
Type: System..::.String
The filename to which the project is saved

Return Value

True if successful, false if not

See Also

ProjectExplorerWindow Class
Save Overload
SandcastleBuilder.Gui.ContentEditors Namespace


SaveAs Method

[image]

Sandcastle Help File Builder Documentation
ProjectExplorerWindow..::.SaveAs Method
ProjectExplorerWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Save the content of the window using a different filename

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public override bool SaveAs()
Visual Basic (Declaration)
Public Overrides Function SaveAs As Boolean

Return Value

True if successful, false if not successful

See Also

ProjectExplorerWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


Scale Method

[image] [image]

Sandcastle Help File Builder Documentation
ProjectExplorerWindow..::.Scale Method
ProjectExplorerWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

ProjectExplorerWindow Class
ProjectExplorerWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Select Method

[image] [image]

Sandcastle Help File Builder Documentation
ProjectExplorerWindow..::.Select Method
ProjectExplorerWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)

See Also

ProjectExplorerWindow Class
ProjectExplorerWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


SetBounds Method

[image] [image]

Sandcastle Help File Builder Documentation
ProjectExplorerWindow..::.SetBounds Method
ProjectExplorerWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

ProjectExplorerWindow Class
ProjectExplorerWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Show Method

[image] [image]

Sandcastle Help File Builder Documentation
ProjectExplorerWindow..::.Show Method
ProjectExplorerWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Show()()() | (Inherited from DockContent.)
Show(DockPanel) | (Inherited from DockContent.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Show(DockPanel, DockState) | (Inherited from DockContent.)
Show(DockPanel, Rectangle) | (Inherited from DockContent.)
Show(DockPane, IDockContent) | (Inherited from DockContent.)
Show(DockPane, DockAlignment, Double) | (Inherited from DockContent.)

See Also

ProjectExplorerWindow Class
ProjectExplorerWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


ShowDialog Method

[image] [image]

Sandcastle Help File Builder Documentation
ProjectExplorerWindow..::.ShowDialog Method
ProjectExplorerWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)

See Also

ProjectExplorerWindow Class
ProjectExplorerWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


UpdateBounds Method

[image] [image]

Sandcastle Help File Builder Documentation
ProjectExplorerWindow..::.UpdateBounds Method
ProjectExplorerWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

ProjectExplorerWindow Class
ProjectExplorerWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Validate Method

[image] [image]

Sandcastle Help File Builder Documentation
ProjectExplorerWindow..::.Validate Method
ProjectExplorerWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

ProjectExplorerWindow Class
ProjectExplorerWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


ValidateChildren Method

[image] [image]

Sandcastle Help File Builder Documentation
ProjectExplorerWindow..::.ValidateChildren Method
ProjectExplorerWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

ProjectExplorerWindow Class
ProjectExplorerWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


ProjectExplorerWindow Properties

[image] [image]

Sandcastle Help File Builder Documentation
ProjectExplorerWindow Properties
ProjectExplorerWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ProjectExplorerWindow type exposes the following members.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowEndUserDocking | (Inherited from DockContent.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoHidePortion | (Inherited from DockContent.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanClose | Returns true if the window can be closed or false if something prevents it from allowing the close to occur. (Inherited from BaseContentEditor.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSaveContent | This is used to see if the active document allows its content to be saved. (Overrides BaseContentEditor..::.CanSaveContent.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CloseButton | (Inherited from DockContent.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
CurrentProject | This is used to get a reference to the current project
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockAreas | (Inherited from DockContent.)
DockHandler | (Inherited from DockContent.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DockPanel | (Inherited from DockContent.)
DockState | (Inherited from DockContent.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FloatPane | (Inherited from DockContent.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HideOnClose | (Inherited from DockContent.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsActivated | (Inherited from DockContent.)
IsContentDocument | This is used to see if the editor is a document type that should be saved prior to doing a build. (Inherited from BaseContentEditor.)
IsDirty | This returns the dirty state of the document if it supports saving (Overrides BaseContentEditor..::.IsDirty.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsFloat | (Inherited from DockContent.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsHidden | (Inherited from DockContent.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Pane | (Inherited from DockContent.)
PanelPane | (Inherited from DockContent.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowHint | (Inherited from DockContent.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabPageContextMenu | (Inherited from DockContent.)
TabPageContextMenuStrip | (Inherited from DockContent.)
TabStop | (Inherited from Form.)
TabText | (Inherited from DockContent.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
ToolTipText | (Inherited from DockContent.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VisibleState | (Inherited from DockContent.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

ProjectExplorerWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


CanSaveContent Property

[image]

Sandcastle Help File Builder Documentation
ProjectExplorerWindow..::.CanSaveContent Property
ProjectExplorerWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to see if the active document allows its content to be saved.

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public override bool CanSaveContent { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property CanSaveContent As Boolean

Return Value

Returns true if it supports saving its content or false if it does not.

See Also

ProjectExplorerWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


CurrentProject Property

[image]

Sandcastle Help File Builder Documentation
ProjectExplorerWindow..::.CurrentProject Property
ProjectExplorerWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get a reference to the current project

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public SandcastleProject CurrentProject { get; set; }
Visual Basic (Declaration)
Public Property CurrentProject As SandcastleProject

See Also

ProjectExplorerWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


IsDirty Property

[image]

Sandcastle Help File Builder Documentation
ProjectExplorerWindow..::.IsDirty Property
ProjectExplorerWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This returns the dirty state of the document if it supports saving

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public override bool IsDirty { get; set; }
Visual Basic (Declaration)
Public Overrides Property IsDirty As Boolean

See Also

ProjectExplorerWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


ProjectExplorerWindow Events

[image] [image]

Sandcastle Help File Builder Documentation
ProjectExplorerWindow Events
ProjectExplorerWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ProjectExplorerWindow type exposes the following members.

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DockStateChanged | (Inherited from DockContent.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

ProjectExplorerWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


ProjectPropertiesWindow Class

[image]

Sandcastle Help File Builder Documentation
ProjectPropertiesWindow Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This form is used to edit the project properties

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public class ProjectPropertiesWindow : BaseContentEditor
Visual Basic (Declaration)
Public Class ProjectPropertiesWindow _
    Inherits BaseContentEditor

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
WeifenLuo.WinFormsUI.Docking..::.DockContent
SandcastleBuilder.Gui.ContentEditors..::.BaseContentEditor
SandcastleBuilder.Gui.ContentEditors..::.ProjectPropertiesWindow

See Also

ProjectPropertiesWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


ProjectPropertiesWindow Members

[image] [image]

Sandcastle Help File Builder Documentation
ProjectPropertiesWindow Members
ProjectPropertiesWindow Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ProjectPropertiesWindow type exposes the following members.

Constructors

Name | Description
ProjectPropertiesWindow | Constructor

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | (Inherited from DockContent.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DockTo | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
FloatAt | (Inherited from DockContent.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPersistString | (Inherited from DockContent.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | (Inherited from DockContent.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsDockStateValid | (Inherited from DockContent.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDockStateChanged | (Inherited from DockContent.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | This is overridden to ignore Ctrl+F4 which closes the window rather than hide it when docked as a document. (Overrides Form..::.OnFormClosing(FormClosingEventArgs).)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Reset the property grid splitter position after being made visible (Overrides Form..::.OnVisibleChanged(EventArgs).)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RefreshProperties | This is called to refresh the property grid after a change that may have affected it.
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Save | Save the content of the window using its current filename (Overrides BaseContentEditor..::.Save()()().)
SaveAs | Save the content of the window using a different filename (Overrides BaseContentEditor..::.SaveAs()()().)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowEndUserDocking | (Inherited from DockContent.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoHidePortion | (Inherited from DockContent.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanClose | Returns true if the window can be closed or false if something prevents it from allowing the close to occur. (Overrides BaseContentEditor..::.CanClose.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSaveContent | This is used to see if the active document allows its content to be saved. (Overrides BaseContentEditor..::.CanSaveContent.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CloseButton | (Inherited from DockContent.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
CurrentProject | This is used to set or get the current project
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockAreas | (Inherited from DockContent.)
DockHandler | (Inherited from DockContent.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DockPanel | (Inherited from DockContent.)
DockState | (Inherited from DockContent.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FloatPane | (Inherited from DockContent.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HideOnClose | (Inherited from DockContent.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsActivated | (Inherited from DockContent.)
IsContentDocument | This is used to see if the editor is a document type that should be saved prior to doing a build. (Inherited from BaseContentEditor.)
IsDirty | This returns the dirty state of the document if it supports saving (Overrides BaseContentEditor..::.IsDirty.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsFloat | (Inherited from DockContent.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsHidden | (Inherited from DockContent.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Pane | (Inherited from DockContent.)
PanelPane | (Inherited from DockContent.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowHint | (Inherited from DockContent.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabPageContextMenu | (Inherited from DockContent.)
TabPageContextMenuStrip | (Inherited from DockContent.)
TabStop | (Inherited from Form.)
TabText | (Inherited from DockContent.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
ToolTipText | (Inherited from DockContent.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VisibleState | (Inherited from DockContent.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DockStateChanged | (Inherited from DockContent.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

ProjectPropertiesWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


ProjectPropertiesWindow Constructor

[image]

Sandcastle Help File Builder Documentation
ProjectPropertiesWindow Constructor
ProjectPropertiesWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public ProjectPropertiesWindow()
Visual Basic (Declaration)
Public Sub New

See Also

ProjectPropertiesWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


ProjectPropertiesWindow Methods

[image] [image]

Sandcastle Help File Builder Documentation
ProjectPropertiesWindow Methods
ProjectPropertiesWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ProjectPropertiesWindow type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | (Inherited from DockContent.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DockTo | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
FloatAt | (Inherited from DockContent.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPersistString | (Inherited from DockContent.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | (Inherited from DockContent.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsDockStateValid | (Inherited from DockContent.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDockStateChanged | (Inherited from DockContent.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | This is overridden to ignore Ctrl+F4 which closes the window rather than hide it when docked as a document. (Overrides Form..::.OnFormClosing(FormClosingEventArgs).)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Reset the property grid splitter position after being made visible (Overrides Form..::.OnVisibleChanged(EventArgs).)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RefreshProperties | This is called to refresh the property grid after a change that may have affected it.
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Save | Save the content of the window using its current filename (Overrides BaseContentEditor..::.Save()()().)
SaveAs | Save the content of the window using a different filename (Overrides BaseContentEditor..::.SaveAs()()().)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

See Also

ProjectPropertiesWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


AccessibilityNotifyClients Method

[image] [image]

Sandcastle Help File Builder Documentation
ProjectPropertiesWindow..::.AccessibilityNotifyClients Method
ProjectPropertiesWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

ProjectPropertiesWindow Class
ProjectPropertiesWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


BeginInvoke Method

[image] [image]

Sandcastle Help File Builder Documentation
ProjectPropertiesWindow..::.BeginInvoke Method
ProjectPropertiesWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

ProjectPropertiesWindow Class
ProjectPropertiesWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Dispose Method

[image] [image]

Sandcastle Help File Builder Documentation
ProjectPropertiesWindow..::.Dispose Method
ProjectPropertiesWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides Form..::.Dispose(Boolean).)

See Also

ProjectPropertiesWindow Class
ProjectPropertiesWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Dispose Method (Boolean)

[image]

Sandcastle Help File Builder Documentation
ProjectPropertiesWindow..::.Dispose Method (Boolean)
ProjectPropertiesWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

ProjectPropertiesWindow Class
Dispose Overload
SandcastleBuilder.Gui.ContentEditors Namespace


DockTo Method

[image] [image]

Sandcastle Help File Builder Documentation
ProjectPropertiesWindow..::.DockTo Method
ProjectPropertiesWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
DockTo(DockPanel, DockStyle) | (Inherited from DockContent.)
DockTo(DockPane, DockStyle, Int32) | (Inherited from DockContent.)

See Also

ProjectPropertiesWindow Class
ProjectPropertiesWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


GetChildAtPoint Method

[image] [image]

Sandcastle Help File Builder Documentation
ProjectPropertiesWindow..::.GetChildAtPoint Method
ProjectPropertiesWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

ProjectPropertiesWindow Class
ProjectPropertiesWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Invalidate Method

[image] [image]

Sandcastle Help File Builder Documentation
ProjectPropertiesWindow..::.Invalidate Method
ProjectPropertiesWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

ProjectPropertiesWindow Class
ProjectPropertiesWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Invoke Method

[image] [image]

Sandcastle Help File Builder Documentation
ProjectPropertiesWindow..::.Invoke Method
ProjectPropertiesWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

ProjectPropertiesWindow Class
ProjectPropertiesWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


MemberwiseClone Method

[image] [image]

Sandcastle Help File Builder Documentation
ProjectPropertiesWindow..::.MemberwiseClone Method
ProjectPropertiesWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ProjectPropertiesWindow Class
ProjectPropertiesWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


OnFormClosing Method

[image]

Sandcastle Help File Builder Documentation
ProjectPropertiesWindow..::.OnFormClosing Method
ProjectPropertiesWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is overridden to ignore Ctrl+F4 which closes the window rather than hide it when docked as a document.

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
protected override void OnFormClosing(
    FormClosingEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnFormClosing ( _
    e As FormClosingEventArgs _
)

Parameters

e
Type: System.Windows.Forms..::.FormClosingEventArgs
The event arguments

See Also

ProjectPropertiesWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


OnVisibleChanged Method

[image]

Sandcastle Help File Builder Documentation
ProjectPropertiesWindow..::.OnVisibleChanged Method
ProjectPropertiesWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Reset the property grid splitter position after being made visible

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
protected override void OnVisibleChanged(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnVisibleChanged ( _
    e As EventArgs _
)

Parameters

e
Type: System..::.EventArgs
The event arguments

Remarks

If not, it tends to be way to large

See Also

ProjectPropertiesWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


PerformLayout Method

[image] [image]

Sandcastle Help File Builder Documentation
ProjectPropertiesWindow..::.PerformLayout Method
ProjectPropertiesWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

ProjectPropertiesWindow Class
ProjectPropertiesWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


RefreshProperties Method

[image]

Sandcastle Help File Builder Documentation
ProjectPropertiesWindow..::.RefreshProperties Method
ProjectPropertiesWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is called to refresh the property grid after a change that may have affected it.

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public void RefreshProperties()
Visual Basic (Declaration)
Public Sub RefreshProperties

See Also

ProjectPropertiesWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


ResumeLayout Method

[image] [image]

Sandcastle Help File Builder Documentation
ProjectPropertiesWindow..::.ResumeLayout Method
ProjectPropertiesWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

ProjectPropertiesWindow Class
ProjectPropertiesWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


RtlTranslateAlignment Method

[image] [image]

Sandcastle Help File Builder Documentation
ProjectPropertiesWindow..::.RtlTranslateAlignment Method
ProjectPropertiesWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

ProjectPropertiesWindow Class
ProjectPropertiesWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Save Method

[image]

Sandcastle Help File Builder Documentation
ProjectPropertiesWindow..::.Save Method
ProjectPropertiesWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Save the content of the window using its current filename

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public override bool Save()
Visual Basic (Declaration)
Public Overrides Function Save As Boolean

Return Value

True if successful, false if not successful

See Also

ProjectPropertiesWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


SaveAs Method

[image]

Sandcastle Help File Builder Documentation
ProjectPropertiesWindow..::.SaveAs Method
ProjectPropertiesWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Save the content of the window using a different filename

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public override bool SaveAs()
Visual Basic (Declaration)
Public Overrides Function SaveAs As Boolean

Return Value

True if successful, false if not successful

See Also

ProjectPropertiesWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


Scale Method

[image] [image]

Sandcastle Help File Builder Documentation
ProjectPropertiesWindow..::.Scale Method
ProjectPropertiesWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

ProjectPropertiesWindow Class
ProjectPropertiesWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Select Method

[image] [image]

Sandcastle Help File Builder Documentation
ProjectPropertiesWindow..::.Select Method
ProjectPropertiesWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)

See Also

ProjectPropertiesWindow Class
ProjectPropertiesWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


SetBounds Method

[image] [image]

Sandcastle Help File Builder Documentation
ProjectPropertiesWindow..::.SetBounds Method
ProjectPropertiesWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

ProjectPropertiesWindow Class
ProjectPropertiesWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Show Method

[image] [image]

Sandcastle Help File Builder Documentation
ProjectPropertiesWindow..::.Show Method
ProjectPropertiesWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Show()()() | (Inherited from DockContent.)
Show(DockPanel) | (Inherited from DockContent.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Show(DockPanel, DockState) | (Inherited from DockContent.)
Show(DockPanel, Rectangle) | (Inherited from DockContent.)
Show(DockPane, IDockContent) | (Inherited from DockContent.)
Show(DockPane, DockAlignment, Double) | (Inherited from DockContent.)

See Also

ProjectPropertiesWindow Class
ProjectPropertiesWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


ShowDialog Method

[image] [image]

Sandcastle Help File Builder Documentation
ProjectPropertiesWindow..::.ShowDialog Method
ProjectPropertiesWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)

See Also

ProjectPropertiesWindow Class
ProjectPropertiesWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


UpdateBounds Method

[image] [image]

Sandcastle Help File Builder Documentation
ProjectPropertiesWindow..::.UpdateBounds Method
ProjectPropertiesWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

ProjectPropertiesWindow Class
ProjectPropertiesWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Validate Method

[image] [image]

Sandcastle Help File Builder Documentation
ProjectPropertiesWindow..::.Validate Method
ProjectPropertiesWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

ProjectPropertiesWindow Class
ProjectPropertiesWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


ValidateChildren Method

[image] [image]

Sandcastle Help File Builder Documentation
ProjectPropertiesWindow..::.ValidateChildren Method
ProjectPropertiesWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

ProjectPropertiesWindow Class
ProjectPropertiesWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


ProjectPropertiesWindow Properties

[image] [image]

Sandcastle Help File Builder Documentation
ProjectPropertiesWindow Properties
ProjectPropertiesWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ProjectPropertiesWindow type exposes the following members.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowEndUserDocking | (Inherited from DockContent.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoHidePortion | (Inherited from DockContent.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanClose | Returns true if the window can be closed or false if something prevents it from allowing the close to occur. (Overrides BaseContentEditor..::.CanClose.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSaveContent | This is used to see if the active document allows its content to be saved. (Overrides BaseContentEditor..::.CanSaveContent.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CloseButton | (Inherited from DockContent.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
CurrentProject | This is used to set or get the current project
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockAreas | (Inherited from DockContent.)
DockHandler | (Inherited from DockContent.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DockPanel | (Inherited from DockContent.)
DockState | (Inherited from DockContent.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FloatPane | (Inherited from DockContent.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HideOnClose | (Inherited from DockContent.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsActivated | (Inherited from DockContent.)
IsContentDocument | This is used to see if the editor is a document type that should be saved prior to doing a build. (Inherited from BaseContentEditor.)
IsDirty | This returns the dirty state of the document if it supports saving (Overrides BaseContentEditor..::.IsDirty.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsFloat | (Inherited from DockContent.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsHidden | (Inherited from DockContent.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Pane | (Inherited from DockContent.)
PanelPane | (Inherited from DockContent.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowHint | (Inherited from DockContent.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabPageContextMenu | (Inherited from DockContent.)
TabPageContextMenuStrip | (Inherited from DockContent.)
TabStop | (Inherited from Form.)
TabText | (Inherited from DockContent.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
ToolTipText | (Inherited from DockContent.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VisibleState | (Inherited from DockContent.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

ProjectPropertiesWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


CanClose Property

[image]

Sandcastle Help File Builder Documentation
ProjectPropertiesWindow..::.CanClose Property
ProjectPropertiesWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Returns true if the window can be closed or false if something prevents it from allowing the close to occur.

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public override bool CanClose { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property CanClose As Boolean

See Also

ProjectPropertiesWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


CanSaveContent Property

[image]

Sandcastle Help File Builder Documentation
ProjectPropertiesWindow..::.CanSaveContent Property
ProjectPropertiesWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to see if the active document allows its content to be saved.

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public override bool CanSaveContent { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property CanSaveContent As Boolean

Return Value

Returns true if it supports saving its content or false if it does not.

See Also

ProjectPropertiesWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


CurrentProject Property

[image]

Sandcastle Help File Builder Documentation
ProjectPropertiesWindow..::.CurrentProject Property
ProjectPropertiesWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to set or get the current project

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public SandcastleProject CurrentProject { get; set; }
Visual Basic (Declaration)
Public Property CurrentProject As SandcastleProject

See Also

ProjectPropertiesWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


IsDirty Property

[image]

Sandcastle Help File Builder Documentation
ProjectPropertiesWindow..::.IsDirty Property
ProjectPropertiesWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This returns the dirty state of the document if it supports saving

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public override bool IsDirty { get; set; }
Visual Basic (Declaration)
Public Overrides Property IsDirty As Boolean

See Also

ProjectPropertiesWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


ProjectPropertiesWindow Events

[image] [image]

Sandcastle Help File Builder Documentation
ProjectPropertiesWindow Events
ProjectPropertiesWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ProjectPropertiesWindow type exposes the following members.

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DockStateChanged | (Inherited from DockContent.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

ProjectPropertiesWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


SelectGacEntriesDlg Class

[image]

Sandcastle Help File Builder Documentation
SelectGacEntriesDlg Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This form is used to let the user select the GAC entries to add as project references.

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public class SelectGacEntriesDlg : Form
Visual Basic (Declaration)
Public Class SelectGacEntriesDlg _
    Inherits Form

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
SandcastleBuilder.Gui.ContentEditors..::.SelectGacEntriesDlg

See Also

SelectGacEntriesDlg Members
SandcastleBuilder.Gui.ContentEditors Namespace


SelectGacEntriesDlg Members

[image] [image]

Sandcastle Help File Builder Documentation
SelectGacEntriesDlg Members
SelectGacEntriesDlg Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SelectGacEntriesDlg type exposes the following members.

Constructors

Name | Description
SelectGacEntriesDlg | Constructor

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
SelectedEntries | This is used to return the list of selected references
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

SelectGacEntriesDlg Class
SandcastleBuilder.Gui.ContentEditors Namespace


SelectGacEntriesDlg Constructor

[image]

Sandcastle Help File Builder Documentation
SelectGacEntriesDlg Constructor
SelectGacEntriesDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public SelectGacEntriesDlg()
Visual Basic (Declaration)
Public Sub New

See Also

SelectGacEntriesDlg Class
SandcastleBuilder.Gui.ContentEditors Namespace


SelectGacEntriesDlg Methods

[image] [image]

Sandcastle Help File Builder Documentation
SelectGacEntriesDlg Methods
SelectGacEntriesDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SelectGacEntriesDlg type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

See Also

SelectGacEntriesDlg Class
SandcastleBuilder.Gui.ContentEditors Namespace


AccessibilityNotifyClients Method

[image] [image]

Sandcastle Help File Builder Documentation
SelectGacEntriesDlg..::.AccessibilityNotifyClients Method
SelectGacEntriesDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

SelectGacEntriesDlg Class
SelectGacEntriesDlg Members
SandcastleBuilder.Gui.ContentEditors Namespace


BeginInvoke Method

[image] [image]

Sandcastle Help File Builder Documentation
SelectGacEntriesDlg..::.BeginInvoke Method
SelectGacEntriesDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

SelectGacEntriesDlg Class
SelectGacEntriesDlg Members
SandcastleBuilder.Gui.ContentEditors Namespace


Dispose Method

[image] [image]

Sandcastle Help File Builder Documentation
SelectGacEntriesDlg..::.Dispose Method
SelectGacEntriesDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides Form..::.Dispose(Boolean).)

See Also

SelectGacEntriesDlg Class
SelectGacEntriesDlg Members
SandcastleBuilder.Gui.ContentEditors Namespace


Dispose Method (Boolean)

[image]

Sandcastle Help File Builder Documentation
SelectGacEntriesDlg..::.Dispose Method (Boolean)
SelectGacEntriesDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

SelectGacEntriesDlg Class
Dispose Overload
SandcastleBuilder.Gui.ContentEditors Namespace


GetChildAtPoint Method

[image] [image]

Sandcastle Help File Builder Documentation
SelectGacEntriesDlg..::.GetChildAtPoint Method
SelectGacEntriesDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

SelectGacEntriesDlg Class
SelectGacEntriesDlg Members
SandcastleBuilder.Gui.ContentEditors Namespace


Invalidate Method

[image] [image]

Sandcastle Help File Builder Documentation
SelectGacEntriesDlg..::.Invalidate Method
SelectGacEntriesDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

SelectGacEntriesDlg Class
SelectGacEntriesDlg Members
SandcastleBuilder.Gui.ContentEditors Namespace


Invoke Method

[image] [image]

Sandcastle Help File Builder Documentation
SelectGacEntriesDlg..::.Invoke Method
SelectGacEntriesDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

SelectGacEntriesDlg Class
SelectGacEntriesDlg Members
SandcastleBuilder.Gui.ContentEditors Namespace


MemberwiseClone Method

[image] [image]

Sandcastle Help File Builder Documentation
SelectGacEntriesDlg..::.MemberwiseClone Method
SelectGacEntriesDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

SelectGacEntriesDlg Class
SelectGacEntriesDlg Members
SandcastleBuilder.Gui.ContentEditors Namespace


PerformLayout Method

[image] [image]

Sandcastle Help File Builder Documentation
SelectGacEntriesDlg..::.PerformLayout Method
SelectGacEntriesDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

SelectGacEntriesDlg Class
SelectGacEntriesDlg Members
SandcastleBuilder.Gui.ContentEditors Namespace


ResumeLayout Method

[image] [image]

Sandcastle Help File Builder Documentation
SelectGacEntriesDlg..::.ResumeLayout Method
SelectGacEntriesDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

SelectGacEntriesDlg Class
SelectGacEntriesDlg Members
SandcastleBuilder.Gui.ContentEditors Namespace


RtlTranslateAlignment Method

[image] [image]

Sandcastle Help File Builder Documentation
SelectGacEntriesDlg..::.RtlTranslateAlignment Method
SelectGacEntriesDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

SelectGacEntriesDlg Class
SelectGacEntriesDlg Members
SandcastleBuilder.Gui.ContentEditors Namespace


Scale Method

[image] [image]

Sandcastle Help File Builder Documentation
SelectGacEntriesDlg..::.Scale Method
SelectGacEntriesDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

SelectGacEntriesDlg Class
SelectGacEntriesDlg Members
SandcastleBuilder.Gui.ContentEditors Namespace


Select Method

[image] [image]

Sandcastle Help File Builder Documentation
SelectGacEntriesDlg..::.Select Method
SelectGacEntriesDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)

See Also

SelectGacEntriesDlg Class
SelectGacEntriesDlg Members
SandcastleBuilder.Gui.ContentEditors Namespace


SetBounds Method

[image] [image]

Sandcastle Help File Builder Documentation
SelectGacEntriesDlg..::.SetBounds Method
SelectGacEntriesDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

SelectGacEntriesDlg Class
SelectGacEntriesDlg Members
SandcastleBuilder.Gui.ContentEditors Namespace


Show Method

[image] [image]

Sandcastle Help File Builder Documentation
SelectGacEntriesDlg..::.Show Method
SelectGacEntriesDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Show()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

SelectGacEntriesDlg Class
SelectGacEntriesDlg Members
SandcastleBuilder.Gui.ContentEditors Namespace


ShowDialog Method

[image] [image]

Sandcastle Help File Builder Documentation
SelectGacEntriesDlg..::.ShowDialog Method
SelectGacEntriesDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)

See Also

SelectGacEntriesDlg Class
SelectGacEntriesDlg Members
SandcastleBuilder.Gui.ContentEditors Namespace


UpdateBounds Method

[image] [image]

Sandcastle Help File Builder Documentation
SelectGacEntriesDlg..::.UpdateBounds Method
SelectGacEntriesDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

SelectGacEntriesDlg Class
SelectGacEntriesDlg Members
SandcastleBuilder.Gui.ContentEditors Namespace


Validate Method

[image] [image]

Sandcastle Help File Builder Documentation
SelectGacEntriesDlg..::.Validate Method
SelectGacEntriesDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

SelectGacEntriesDlg Class
SelectGacEntriesDlg Members
SandcastleBuilder.Gui.ContentEditors Namespace


ValidateChildren Method

[image] [image]

Sandcastle Help File Builder Documentation
SelectGacEntriesDlg..::.ValidateChildren Method
SelectGacEntriesDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

SelectGacEntriesDlg Class
SelectGacEntriesDlg Members
SandcastleBuilder.Gui.ContentEditors Namespace


SelectGacEntriesDlg Properties

[image] [image]

Sandcastle Help File Builder Documentation
SelectGacEntriesDlg Properties
SelectGacEntriesDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SelectGacEntriesDlg type exposes the following members.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
SelectedEntries | This is used to return the list of selected references
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

SelectGacEntriesDlg Class
SandcastleBuilder.Gui.ContentEditors Namespace


SelectedEntries Property

[image]

Sandcastle Help File Builder Documentation
SelectGacEntriesDlg..::.SelectedEntries Property
SelectGacEntriesDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to return the list of selected references

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public Collection<string> SelectedEntries { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectedEntries As Collection(Of String)

See Also

SelectGacEntriesDlg Class
SandcastleBuilder.Gui.ContentEditors Namespace


SelectGacEntriesDlg Events

[image] [image]

Sandcastle Help File Builder Documentation
SelectGacEntriesDlg Events
SelectGacEntriesDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SelectGacEntriesDlg type exposes the following members.

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

SelectGacEntriesDlg Class
SandcastleBuilder.Gui.ContentEditors Namespace


SiteMapEditorWindow Class

[image]

Sandcastle Help File Builder Documentation
SiteMapEditorWindow Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This form is used to edit site map files that defines the table of contents layout for additional content items.

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public class SiteMapEditorWindow : BaseContentEditor
Visual Basic (Declaration)
Public Class SiteMapEditorWindow _
    Inherits BaseContentEditor

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
WeifenLuo.WinFormsUI.Docking..::.DockContent
SandcastleBuilder.Gui.ContentEditors..::.BaseContentEditor
SandcastleBuilder.Gui.ContentEditors..::.SiteMapEditorWindow

See Also

SiteMapEditorWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


SiteMapEditorWindow Members

[image] [image]

Sandcastle Help File Builder Documentation
SiteMapEditorWindow Members
SiteMapEditorWindow Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SiteMapEditorWindow type exposes the following members.

Constructors

Name | Description
SiteMapEditorWindow | Constructor

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | (Inherited from DockContent.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DockTo | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
FloatAt | (Inherited from DockContent.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPersistString | (Inherited from DockContent.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | (Inherited from DockContent.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsDockStateValid | (Inherited from DockContent.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDockStateChanged | (Inherited from DockContent.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Save | Overloaded. There are two overloads for this method
SaveAs | Save the content of the window using a different filename (Overrides BaseContentEditor..::.SaveAs()()().)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowEndUserDocking | (Inherited from DockContent.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoHidePortion | (Inherited from DockContent.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanClose | Returns true if the window can be closed or false if something prevents it from allowing the close to occur. (Overrides BaseContentEditor..::.CanClose.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSaveContent | This is used to see if the active document allows its content to be saved. (Overrides BaseContentEditor..::.CanSaveContent.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CloseButton | (Inherited from DockContent.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockAreas | (Inherited from DockContent.)
DockHandler | (Inherited from DockContent.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DockPanel | (Inherited from DockContent.)
DockState | (Inherited from DockContent.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FloatPane | (Inherited from DockContent.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HideOnClose | (Inherited from DockContent.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsActivated | (Inherited from DockContent.)
IsContentDocument | This is used to see if the editor is a document type that should be saved prior to doing a build. (Overrides BaseContentEditor..::.IsContentDocument.)
IsDirty | This returns the dirty state of the document if it supports saving (Inherited from BaseContentEditor.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsFloat | (Inherited from DockContent.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsHidden | (Inherited from DockContent.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Pane | (Inherited from DockContent.)
PanelPane | (Inherited from DockContent.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowHint | (Inherited from DockContent.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabPageContextMenu | (Inherited from DockContent.)
TabPageContextMenuStrip | (Inherited from DockContent.)
TabStop | (Inherited from Form.)
TabText | (Inherited from DockContent.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
ToolTipText | (Inherited from DockContent.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VisibleState | (Inherited from DockContent.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DockStateChanged | (Inherited from DockContent.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

SiteMapEditorWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


SiteMapEditorWindow Constructor

[image]

Sandcastle Help File Builder Documentation
SiteMapEditorWindow Constructor
SiteMapEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public SiteMapEditorWindow(
    FileItem fileItem
)
Visual Basic (Declaration)
Public Sub New ( _
    fileItem As FileItem _
)

Parameters

fileItem
Type: SandcastleBuilder.Utils..::.FileItem
The project file item to edit

See Also

SiteMapEditorWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


SiteMapEditorWindow Methods

[image] [image]

Sandcastle Help File Builder Documentation
SiteMapEditorWindow Methods
SiteMapEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SiteMapEditorWindow type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | (Inherited from DockContent.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DockTo | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
FloatAt | (Inherited from DockContent.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPersistString | (Inherited from DockContent.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | (Inherited from DockContent.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsDockStateValid | (Inherited from DockContent.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDockStateChanged | (Inherited from DockContent.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Save | Overloaded. There are two overloads for this method
SaveAs | Save the content of the window using a different filename (Overrides BaseContentEditor..::.SaveAs()()().)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

See Also

SiteMapEditorWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


AccessibilityNotifyClients Method

[image] [image]

Sandcastle Help File Builder Documentation
SiteMapEditorWindow..::.AccessibilityNotifyClients Method
SiteMapEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

SiteMapEditorWindow Class
SiteMapEditorWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


BeginInvoke Method

[image] [image]

Sandcastle Help File Builder Documentation
SiteMapEditorWindow..::.BeginInvoke Method
SiteMapEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

SiteMapEditorWindow Class
SiteMapEditorWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Dispose Method

[image] [image]

Sandcastle Help File Builder Documentation
SiteMapEditorWindow..::.Dispose Method
SiteMapEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides Form..::.Dispose(Boolean).)

See Also

SiteMapEditorWindow Class
SiteMapEditorWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Dispose Method (Boolean)

[image]

Sandcastle Help File Builder Documentation
SiteMapEditorWindow..::.Dispose Method (Boolean)
SiteMapEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

SiteMapEditorWindow Class
Dispose Overload
SandcastleBuilder.Gui.ContentEditors Namespace


DockTo Method

[image] [image]

Sandcastle Help File Builder Documentation
SiteMapEditorWindow..::.DockTo Method
SiteMapEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
DockTo(DockPanel, DockStyle) | (Inherited from DockContent.)
DockTo(DockPane, DockStyle, Int32) | (Inherited from DockContent.)

See Also

SiteMapEditorWindow Class
SiteMapEditorWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


GetChildAtPoint Method

[image] [image]

Sandcastle Help File Builder Documentation
SiteMapEditorWindow..::.GetChildAtPoint Method
SiteMapEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

SiteMapEditorWindow Class
SiteMapEditorWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Invalidate Method

[image] [image]

Sandcastle Help File Builder Documentation
SiteMapEditorWindow..::.Invalidate Method
SiteMapEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

SiteMapEditorWindow Class
SiteMapEditorWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Invoke Method

[image] [image]

Sandcastle Help File Builder Documentation
SiteMapEditorWindow..::.Invoke Method
SiteMapEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

SiteMapEditorWindow Class
SiteMapEditorWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


MemberwiseClone Method

[image] [image]

Sandcastle Help File Builder Documentation
SiteMapEditorWindow..::.MemberwiseClone Method
SiteMapEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

SiteMapEditorWindow Class
SiteMapEditorWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


PerformLayout Method

[image] [image]

Sandcastle Help File Builder Documentation
SiteMapEditorWindow..::.PerformLayout Method
SiteMapEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

SiteMapEditorWindow Class
SiteMapEditorWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


ResumeLayout Method

[image] [image]

Sandcastle Help File Builder Documentation
SiteMapEditorWindow..::.ResumeLayout Method
SiteMapEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

SiteMapEditorWindow Class
SiteMapEditorWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


RtlTranslateAlignment Method

[image] [image]

Sandcastle Help File Builder Documentation
SiteMapEditorWindow..::.RtlTranslateAlignment Method
SiteMapEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

SiteMapEditorWindow Class
SiteMapEditorWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Save Method

[image] [image]

Sandcastle Help File Builder Documentation
SiteMapEditorWindow..::.Save Method
SiteMapEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

There are two overloads for this method

Overload List

Name | Description
Save()()() | Save the content of the window using its current filename (Overrides BaseContentEditor..::.Save()()().)
Save(String) | Save the topic to a new filename

See Also

SiteMapEditorWindow Class
SiteMapEditorWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Save Method

[image]

Sandcastle Help File Builder Documentation
SiteMapEditorWindow..::.Save Method
SiteMapEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Save the content of the window using its current filename

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public override bool Save()
Visual Basic (Declaration)
Public Overrides Function Save As Boolean

Return Value

True if successful, false if not successful

See Also

SiteMapEditorWindow Class
Save Overload
SandcastleBuilder.Gui.ContentEditors Namespace


Save Method (String)

[image]

Sandcastle Help File Builder Documentation
SiteMapEditorWindow..::.Save Method (String)
SiteMapEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Save the topic to a new filename

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public bool Save(
    string filename
)
Visual Basic (Declaration)
Public Function Save ( _
    filename As String _
) As Boolean

Parameters

filename
Type: System..::.String
The new filename

Return Value

True if saved successfully, false if not

See Also

SiteMapEditorWindow Class
Save Overload
SandcastleBuilder.Gui.ContentEditors Namespace


SaveAs Method

[image]

Sandcastle Help File Builder Documentation
SiteMapEditorWindow..::.SaveAs Method
SiteMapEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Save the content of the window using a different filename

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public override bool SaveAs()
Visual Basic (Declaration)
Public Overrides Function SaveAs As Boolean

Return Value

True if successful, false if not successful

See Also

SiteMapEditorWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


Scale Method

[image] [image]

Sandcastle Help File Builder Documentation
SiteMapEditorWindow..::.Scale Method
SiteMapEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

SiteMapEditorWindow Class
SiteMapEditorWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Select Method

[image] [image]

Sandcastle Help File Builder Documentation
SiteMapEditorWindow..::.Select Method
SiteMapEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)

See Also

SiteMapEditorWindow Class
SiteMapEditorWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


SetBounds Method

[image] [image]

Sandcastle Help File Builder Documentation
SiteMapEditorWindow..::.SetBounds Method
SiteMapEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

SiteMapEditorWindow Class
SiteMapEditorWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Show Method

[image] [image]

Sandcastle Help File Builder Documentation
SiteMapEditorWindow..::.Show Method
SiteMapEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Show()()() | (Inherited from DockContent.)
Show(DockPanel) | (Inherited from DockContent.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Show(DockPanel, DockState) | (Inherited from DockContent.)
Show(DockPanel, Rectangle) | (Inherited from DockContent.)
Show(DockPane, IDockContent) | (Inherited from DockContent.)
Show(DockPane, DockAlignment, Double) | (Inherited from DockContent.)

See Also

SiteMapEditorWindow Class
SiteMapEditorWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


ShowDialog Method

[image] [image]

Sandcastle Help File Builder Documentation
SiteMapEditorWindow..::.ShowDialog Method
SiteMapEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)

See Also

SiteMapEditorWindow Class
SiteMapEditorWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


UpdateBounds Method

[image] [image]

Sandcastle Help File Builder Documentation
SiteMapEditorWindow..::.UpdateBounds Method
SiteMapEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

SiteMapEditorWindow Class
SiteMapEditorWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Validate Method

[image] [image]

Sandcastle Help File Builder Documentation
SiteMapEditorWindow..::.Validate Method
SiteMapEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

SiteMapEditorWindow Class
SiteMapEditorWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


ValidateChildren Method

[image] [image]

Sandcastle Help File Builder Documentation
SiteMapEditorWindow..::.ValidateChildren Method
SiteMapEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

SiteMapEditorWindow Class
SiteMapEditorWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


SiteMapEditorWindow Properties

[image] [image]

Sandcastle Help File Builder Documentation
SiteMapEditorWindow Properties
SiteMapEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SiteMapEditorWindow type exposes the following members.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowEndUserDocking | (Inherited from DockContent.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoHidePortion | (Inherited from DockContent.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanClose | Returns true if the window can be closed or false if something prevents it from allowing the close to occur. (Overrides BaseContentEditor..::.CanClose.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSaveContent | This is used to see if the active document allows its content to be saved. (Overrides BaseContentEditor..::.CanSaveContent.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CloseButton | (Inherited from DockContent.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockAreas | (Inherited from DockContent.)
DockHandler | (Inherited from DockContent.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DockPanel | (Inherited from DockContent.)
DockState | (Inherited from DockContent.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FloatPane | (Inherited from DockContent.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HideOnClose | (Inherited from DockContent.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsActivated | (Inherited from DockContent.)
IsContentDocument | This is used to see if the editor is a document type that should be saved prior to doing a build. (Overrides BaseContentEditor..::.IsContentDocument.)
IsDirty | This returns the dirty state of the document if it supports saving (Inherited from BaseContentEditor.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsFloat | (Inherited from DockContent.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsHidden | (Inherited from DockContent.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Pane | (Inherited from DockContent.)
PanelPane | (Inherited from DockContent.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowHint | (Inherited from DockContent.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabPageContextMenu | (Inherited from DockContent.)
TabPageContextMenuStrip | (Inherited from DockContent.)
TabStop | (Inherited from Form.)
TabText | (Inherited from DockContent.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
ToolTipText | (Inherited from DockContent.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VisibleState | (Inherited from DockContent.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

SiteMapEditorWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


CanClose Property

[image]

Sandcastle Help File Builder Documentation
SiteMapEditorWindow..::.CanClose Property
SiteMapEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Returns true if the window can be closed or false if something prevents it from allowing the close to occur.

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public override bool CanClose { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property CanClose As Boolean

See Also

SiteMapEditorWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


CanSaveContent Property

[image]

Sandcastle Help File Builder Documentation
SiteMapEditorWindow..::.CanSaveContent Property
SiteMapEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to see if the active document allows its content to be saved.

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public override bool CanSaveContent { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property CanSaveContent As Boolean

Return Value

Returns true if it supports saving its content or false if it does not.

See Also

SiteMapEditorWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


IsContentDocument Property

[image]

Sandcastle Help File Builder Documentation
SiteMapEditorWindow..::.IsContentDocument Property
SiteMapEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to see if the editor is a document type that should be saved prior to doing a build.

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public override bool IsContentDocument { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property IsContentDocument As Boolean

See Also

SiteMapEditorWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


SiteMapEditorWindow Events

[image] [image]

Sandcastle Help File Builder Documentation
SiteMapEditorWindow Events
SiteMapEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SiteMapEditorWindow type exposes the following members.

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DockStateChanged | (Inherited from DockContent.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

SiteMapEditorWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


TokenEditorWindow Class

[image]

Sandcastle Help File Builder Documentation
TokenEditorWindow Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This form is used to edit a token file.

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public class TokenEditorWindow : BaseContentEditor
Visual Basic (Declaration)
Public Class TokenEditorWindow _
    Inherits BaseContentEditor

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
WeifenLuo.WinFormsUI.Docking..::.DockContent
SandcastleBuilder.Gui.ContentEditors..::.BaseContentEditor
SandcastleBuilder.Gui.ContentEditors..::.TokenEditorWindow

See Also

TokenEditorWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


TokenEditorWindow Members

[image] [image]

Sandcastle Help File Builder Documentation
TokenEditorWindow Members
TokenEditorWindow Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TokenEditorWindow type exposes the following members.

Constructors

Name | Description
TokenEditorWindow | Constructor

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | (Inherited from DockContent.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DockTo | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
FloatAt | (Inherited from DockContent.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPersistString | (Inherited from DockContent.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | (Inherited from DockContent.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsDockStateValid | (Inherited from DockContent.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | This is overriden to prompt to save changes if necessary (Overrides Form..::.OnClosing(CancelEventArgs).)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDockStateChanged | (Inherited from DockContent.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Save | Overloaded. There are two overloads for this method
SaveAs | Save the content of the window using a different filename (Overrides BaseContentEditor..::.SaveAs()()().)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateFont | Update the font used based on the selected user settings
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowEndUserDocking | (Inherited from DockContent.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoHidePortion | (Inherited from DockContent.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanClose | Returns true if the window can be closed or false if something prevents it from allowing the close to occur. (Overrides BaseContentEditor..::.CanClose.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSaveContent | This is used to see if the active document allows its content to be saved. (Overrides BaseContentEditor..::.CanSaveContent.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CloseButton | (Inherited from DockContent.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockAreas | (Inherited from DockContent.)
DockHandler | (Inherited from DockContent.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DockPanel | (Inherited from DockContent.)
DockState | (Inherited from DockContent.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FloatPane | (Inherited from DockContent.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HideOnClose | (Inherited from DockContent.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsActivated | (Inherited from DockContent.)
IsContentDocument | This is used to see if the editor is a document type that should be saved prior to doing a build. (Overrides BaseContentEditor..::.IsContentDocument.)
IsDirty | This returns the dirty state of the document if it supports saving (Inherited from BaseContentEditor.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsFloat | (Inherited from DockContent.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsHidden | (Inherited from DockContent.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Pane | (Inherited from DockContent.)
PanelPane | (Inherited from DockContent.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowHint | (Inherited from DockContent.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabPageContextMenu | (Inherited from DockContent.)
TabPageContextMenuStrip | (Inherited from DockContent.)
TabStop | (Inherited from Form.)
TabText | (Inherited from DockContent.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
ToolTipText | (Inherited from DockContent.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VisibleState | (Inherited from DockContent.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DockStateChanged | (Inherited from DockContent.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

TokenEditorWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


TokenEditorWindow Constructor

[image]

Sandcastle Help File Builder Documentation
TokenEditorWindow Constructor
TokenEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public TokenEditorWindow(
    FileItem fileItem
)
Visual Basic (Declaration)
Public Sub New ( _
    fileItem As FileItem _
)

Parameters

fileItem
Type: SandcastleBuilder.Utils..::.FileItem
The project file item to edit

See Also

TokenEditorWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


TokenEditorWindow Methods

[image] [image]

Sandcastle Help File Builder Documentation
TokenEditorWindow Methods
TokenEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TokenEditorWindow type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | (Inherited from DockContent.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DockTo | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
FloatAt | (Inherited from DockContent.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPersistString | (Inherited from DockContent.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | (Inherited from DockContent.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsDockStateValid | (Inherited from DockContent.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | This is overriden to prompt to save changes if necessary (Overrides Form..::.OnClosing(CancelEventArgs).)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDockStateChanged | (Inherited from DockContent.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Save | Overloaded. There are two overloads for this method
SaveAs | Save the content of the window using a different filename (Overrides BaseContentEditor..::.SaveAs()()().)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateFont | Update the font used based on the selected user settings
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

See Also

TokenEditorWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


AccessibilityNotifyClients Method

[image] [image]

Sandcastle Help File Builder Documentation
TokenEditorWindow..::.AccessibilityNotifyClients Method
TokenEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

TokenEditorWindow Class
TokenEditorWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


BeginInvoke Method

[image] [image]

Sandcastle Help File Builder Documentation
TokenEditorWindow..::.BeginInvoke Method
TokenEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

TokenEditorWindow Class
TokenEditorWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Dispose Method

[image] [image]

Sandcastle Help File Builder Documentation
TokenEditorWindow..::.Dispose Method
TokenEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides Form..::.Dispose(Boolean).)

See Also

TokenEditorWindow Class
TokenEditorWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Dispose Method (Boolean)

[image]

Sandcastle Help File Builder Documentation
TokenEditorWindow..::.Dispose Method (Boolean)
TokenEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

TokenEditorWindow Class
Dispose Overload
SandcastleBuilder.Gui.ContentEditors Namespace


DockTo Method

[image] [image]

Sandcastle Help File Builder Documentation
TokenEditorWindow..::.DockTo Method
TokenEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
DockTo(DockPanel, DockStyle) | (Inherited from DockContent.)
DockTo(DockPane, DockStyle, Int32) | (Inherited from DockContent.)

See Also

TokenEditorWindow Class
TokenEditorWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


GetChildAtPoint Method

[image] [image]

Sandcastle Help File Builder Documentation
TokenEditorWindow..::.GetChildAtPoint Method
TokenEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

TokenEditorWindow Class
TokenEditorWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Invalidate Method

[image] [image]

Sandcastle Help File Builder Documentation
TokenEditorWindow..::.Invalidate Method
TokenEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

TokenEditorWindow Class
TokenEditorWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Invoke Method

[image] [image]

Sandcastle Help File Builder Documentation
TokenEditorWindow..::.Invoke Method
TokenEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

TokenEditorWindow Class
TokenEditorWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


MemberwiseClone Method

[image] [image]

Sandcastle Help File Builder Documentation
TokenEditorWindow..::.MemberwiseClone Method
TokenEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

TokenEditorWindow Class
TokenEditorWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


OnClosing Method

[image]

Sandcastle Help File Builder Documentation
TokenEditorWindow..::.OnClosing Method
TokenEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is overriden to prompt to save changes if necessary

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
protected override void OnClosing(
    CancelEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnClosing ( _
    e As CancelEventArgs _
)

Parameters

e
Type: System.ComponentModel..::.CancelEventArgs
The event arguments

See Also

TokenEditorWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


PerformLayout Method

[image] [image]

Sandcastle Help File Builder Documentation
TokenEditorWindow..::.PerformLayout Method
TokenEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

TokenEditorWindow Class
TokenEditorWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


ResumeLayout Method

[image] [image]

Sandcastle Help File Builder Documentation
TokenEditorWindow..::.ResumeLayout Method
TokenEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

TokenEditorWindow Class
TokenEditorWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


RtlTranslateAlignment Method

[image] [image]

Sandcastle Help File Builder Documentation
TokenEditorWindow..::.RtlTranslateAlignment Method
TokenEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

TokenEditorWindow Class
TokenEditorWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Save Method

[image] [image]

Sandcastle Help File Builder Documentation
TokenEditorWindow..::.Save Method
TokenEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

There are two overloads for this method

Overload List

Name | Description
Save()()() | Save the content of the window using its current filename (Overrides BaseContentEditor..::.Save()()().)
Save(String) | Save the topic to a new filename

See Also

TokenEditorWindow Class
TokenEditorWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Save Method

[image]

Sandcastle Help File Builder Documentation
TokenEditorWindow..::.Save Method
TokenEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Save the content of the window using its current filename

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public override bool Save()
Visual Basic (Declaration)
Public Overrides Function Save As Boolean

Return Value

True if successful, false if not successful

See Also

TokenEditorWindow Class
Save Overload
SandcastleBuilder.Gui.ContentEditors Namespace


Save Method (String)

[image]

Sandcastle Help File Builder Documentation
TokenEditorWindow..::.Save Method (String)
TokenEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Save the topic to a new filename

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public bool Save(
    string filename
)
Visual Basic (Declaration)
Public Function Save ( _
    filename As String _
) As Boolean

Parameters

filename
Type: System..::.String
The new filename

Return Value

True if saved successfully, false if not

See Also

TokenEditorWindow Class
Save Overload
SandcastleBuilder.Gui.ContentEditors Namespace


SaveAs Method

[image]

Sandcastle Help File Builder Documentation
TokenEditorWindow..::.SaveAs Method
TokenEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Save the content of the window using a different filename

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public override bool SaveAs()
Visual Basic (Declaration)
Public Overrides Function SaveAs As Boolean

Return Value

True if successful, false if not successful

See Also

TokenEditorWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


Scale Method

[image] [image]

Sandcastle Help File Builder Documentation
TokenEditorWindow..::.Scale Method
TokenEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

TokenEditorWindow Class
TokenEditorWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Select Method

[image] [image]

Sandcastle Help File Builder Documentation
TokenEditorWindow..::.Select Method
TokenEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)

See Also

TokenEditorWindow Class
TokenEditorWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


SetBounds Method

[image] [image]

Sandcastle Help File Builder Documentation
TokenEditorWindow..::.SetBounds Method
TokenEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

TokenEditorWindow Class
TokenEditorWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Show Method

[image] [image]

Sandcastle Help File Builder Documentation
TokenEditorWindow..::.Show Method
TokenEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Show()()() | (Inherited from DockContent.)
Show(DockPanel) | (Inherited from DockContent.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Show(DockPanel, DockState) | (Inherited from DockContent.)
Show(DockPanel, Rectangle) | (Inherited from DockContent.)
Show(DockPane, IDockContent) | (Inherited from DockContent.)
Show(DockPane, DockAlignment, Double) | (Inherited from DockContent.)

See Also

TokenEditorWindow Class
TokenEditorWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


ShowDialog Method

[image] [image]

Sandcastle Help File Builder Documentation
TokenEditorWindow..::.ShowDialog Method
TokenEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)

See Also

TokenEditorWindow Class
TokenEditorWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


UpdateBounds Method

[image] [image]

Sandcastle Help File Builder Documentation
TokenEditorWindow..::.UpdateBounds Method
TokenEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

TokenEditorWindow Class
TokenEditorWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


UpdateFont Method

[image]

Sandcastle Help File Builder Documentation
TokenEditorWindow..::.UpdateFont Method
TokenEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Update the font used based on the selected user settings

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public void UpdateFont()
Visual Basic (Declaration)
Public Sub UpdateFont

See Also

TokenEditorWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


Validate Method

[image] [image]

Sandcastle Help File Builder Documentation
TokenEditorWindow..::.Validate Method
TokenEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

TokenEditorWindow Class
TokenEditorWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


ValidateChildren Method

[image] [image]

Sandcastle Help File Builder Documentation
TokenEditorWindow..::.ValidateChildren Method
TokenEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

TokenEditorWindow Class
TokenEditorWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


TokenEditorWindow Properties

[image] [image]

Sandcastle Help File Builder Documentation
TokenEditorWindow Properties
TokenEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TokenEditorWindow type exposes the following members.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowEndUserDocking | (Inherited from DockContent.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoHidePortion | (Inherited from DockContent.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanClose | Returns true if the window can be closed or false if something prevents it from allowing the close to occur. (Overrides BaseContentEditor..::.CanClose.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSaveContent | This is used to see if the active document allows its content to be saved. (Overrides BaseContentEditor..::.CanSaveContent.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CloseButton | (Inherited from DockContent.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockAreas | (Inherited from DockContent.)
DockHandler | (Inherited from DockContent.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DockPanel | (Inherited from DockContent.)
DockState | (Inherited from DockContent.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FloatPane | (Inherited from DockContent.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HideOnClose | (Inherited from DockContent.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsActivated | (Inherited from DockContent.)
IsContentDocument | This is used to see if the editor is a document type that should be saved prior to doing a build. (Overrides BaseContentEditor..::.IsContentDocument.)
IsDirty | This returns the dirty state of the document if it supports saving (Inherited from BaseContentEditor.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsFloat | (Inherited from DockContent.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsHidden | (Inherited from DockContent.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Pane | (Inherited from DockContent.)
PanelPane | (Inherited from DockContent.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowHint | (Inherited from DockContent.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabPageContextMenu | (Inherited from DockContent.)
TabPageContextMenuStrip | (Inherited from DockContent.)
TabStop | (Inherited from Form.)
TabText | (Inherited from DockContent.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
ToolTipText | (Inherited from DockContent.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VisibleState | (Inherited from DockContent.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

TokenEditorWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


CanClose Property

[image]

Sandcastle Help File Builder Documentation
TokenEditorWindow..::.CanClose Property
TokenEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Returns true if the window can be closed or false if something prevents it from allowing the close to occur.

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public override bool CanClose { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property CanClose As Boolean

See Also

TokenEditorWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


CanSaveContent Property

[image]

Sandcastle Help File Builder Documentation
TokenEditorWindow..::.CanSaveContent Property
TokenEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to see if the active document allows its content to be saved.

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public override bool CanSaveContent { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property CanSaveContent As Boolean

Return Value

Returns true if it supports saving its content or false if it does not.

See Also

TokenEditorWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


IsContentDocument Property

[image]

Sandcastle Help File Builder Documentation
TokenEditorWindow..::.IsContentDocument Property
TokenEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to see if the editor is a document type that should be saved prior to doing a build.

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public override bool IsContentDocument { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property IsContentDocument As Boolean

See Also

TokenEditorWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


TokenEditorWindow Events

[image] [image]

Sandcastle Help File Builder Documentation
TokenEditorWindow Events
TokenEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TokenEditorWindow type exposes the following members.

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DockStateChanged | (Inherited from DockContent.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

TokenEditorWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


TopicEditorWindow Class

[image]

Sandcastle Help File Builder Documentation
TopicEditorWindow Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This form is used to edit a conceptual topic file.

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public class TopicEditorWindow : BaseContentEditor
Visual Basic (Declaration)
Public Class TopicEditorWindow _
    Inherits BaseContentEditor

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
WeifenLuo.WinFormsUI.Docking..::.DockContent
SandcastleBuilder.Gui.ContentEditors..::.BaseContentEditor
SandcastleBuilder.Gui.ContentEditors..::.TopicEditorWindow

See Also

TopicEditorWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


TopicEditorWindow Members

[image] [image]

Sandcastle Help File Builder Documentation
TopicEditorWindow Members
TopicEditorWindow Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TopicEditorWindow type exposes the following members.

Constructors

Name | Description
TopicEditorWindow | Constructor

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | (Inherited from DockContent.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DockTo | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
FindText | Find the specified text in the editor
FloatAt | (Inherited from DockContent.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPersistString | (Inherited from DockContent.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | (Inherited from DockContent.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsDockStateValid | (Inherited from DockContent.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | This is overriden to prompt to save changes if necessary (Overrides Form..::.OnClosing(CancelEventArgs).)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDockStateChanged | (Inherited from DockContent.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PasteFromClipboard | Paste text from the clipboard into the editor
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ReplaceAll | Find and replace all occurrences of the specified text in the editor.
ReplaceText | Find and replace the next occurrence of the specified text in the editor.
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Save | Overloaded. There are two overloads for this method
SaveAs | Save the content of the window using a different filename (Overrides BaseContentEditor..::.SaveAs()()().)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateFont | Update the font used based on the selected user settings
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowEndUserDocking | (Inherited from DockContent.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoHidePortion | (Inherited from DockContent.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanClose | Returns true if the window can be closed or false if something prevents it from allowing the close to occur. (Overrides BaseContentEditor..::.CanClose.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSaveContent | This is used to see if the active document allows its content to be saved. (Overrides BaseContentEditor..::.CanSaveContent.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CloseButton | (Inherited from DockContent.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockAreas | (Inherited from DockContent.)
DockHandler | (Inherited from DockContent.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DockPanel | (Inherited from DockContent.)
DockState | (Inherited from DockContent.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Filename | This returns the filename
FloatPane | (Inherited from DockContent.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HideOnClose | (Inherited from DockContent.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsActivated | (Inherited from DockContent.)
IsContentDocument | This is used to see if the editor is a document type that should be saved prior to doing a build. (Overrides BaseContentEditor..::.IsContentDocument.)
IsDirty | This returns the dirty state of the document if it supports saving (Inherited from BaseContentEditor.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsFloat | (Inherited from DockContent.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsHidden | (Inherited from DockContent.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Pane | (Inherited from DockContent.)
PanelPane | (Inherited from DockContent.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowHint | (Inherited from DockContent.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabPageContextMenu | (Inherited from DockContent.)
TabPageContextMenuStrip | (Inherited from DockContent.)
TabStop | (Inherited from Form.)
TabText | (Inherited from DockContent.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
ToolTipText | (Inherited from DockContent.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VisibleState | (Inherited from DockContent.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DockStateChanged | (Inherited from DockContent.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

TopicEditorWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


TopicEditorWindow Constructor

[image]

Sandcastle Help File Builder Documentation
TopicEditorWindow Constructor
TopicEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public TopicEditorWindow(
    string filename
)
Visual Basic (Declaration)
Public Sub New ( _
    filename As String _
)

Parameters

filename
Type: System..::.String
The filename to load

See Also

TopicEditorWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


TopicEditorWindow Methods

[image] [image]

Sandcastle Help File Builder Documentation
TopicEditorWindow Methods
TopicEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TopicEditorWindow type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | (Inherited from DockContent.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DockTo | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
FindText | Find the specified text in the editor
FloatAt | (Inherited from DockContent.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPersistString | (Inherited from DockContent.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | (Inherited from DockContent.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsDockStateValid | (Inherited from DockContent.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | This is overriden to prompt to save changes if necessary (Overrides Form..::.OnClosing(CancelEventArgs).)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDockStateChanged | (Inherited from DockContent.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PasteFromClipboard | Paste text from the clipboard into the editor
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ReplaceAll | Find and replace all occurrences of the specified text in the editor.
ReplaceText | Find and replace the next occurrence of the specified text in the editor.
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Save | Overloaded. There are two overloads for this method
SaveAs | Save the content of the window using a different filename (Overrides BaseContentEditor..::.SaveAs()()().)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateFont | Update the font used based on the selected user settings
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

See Also

TopicEditorWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


AccessibilityNotifyClients Method

[image] [image]

Sandcastle Help File Builder Documentation
TopicEditorWindow..::.AccessibilityNotifyClients Method
TopicEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

TopicEditorWindow Class
TopicEditorWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


BeginInvoke Method

[image] [image]

Sandcastle Help File Builder Documentation
TopicEditorWindow..::.BeginInvoke Method
TopicEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

TopicEditorWindow Class
TopicEditorWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Dispose Method

[image] [image]

Sandcastle Help File Builder Documentation
TopicEditorWindow..::.Dispose Method
TopicEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides Form..::.Dispose(Boolean).)

See Also

TopicEditorWindow Class
TopicEditorWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Dispose Method (Boolean)

[image]

Sandcastle Help File Builder Documentation
TopicEditorWindow..::.Dispose Method (Boolean)
TopicEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

TopicEditorWindow Class
Dispose Overload
SandcastleBuilder.Gui.ContentEditors Namespace


DockTo Method

[image] [image]

Sandcastle Help File Builder Documentation
TopicEditorWindow..::.DockTo Method
TopicEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
DockTo(DockPanel, DockStyle) | (Inherited from DockContent.)
DockTo(DockPane, DockStyle, Int32) | (Inherited from DockContent.)

See Also

TopicEditorWindow Class
TopicEditorWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


FindText Method

[image]

Sandcastle Help File Builder Documentation
TopicEditorWindow..::.FindText Method
TopicEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Find the specified text in the editor

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public bool FindText(
    string textToFind,
    bool caseSensitive
)
Visual Basic (Declaration)
Public Function FindText ( _
    textToFind As String, _
    caseSensitive As Boolean _
) As Boolean

Parameters

textToFind
Type: System..::.String
The text to find
caseSensitive
Type: System..::.Boolean
True to do a case-sensitive search or false to do a case-insensitive search

Return Value

True if the text is found, false if not

See Also

TopicEditorWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


GetChildAtPoint Method

[image] [image]

Sandcastle Help File Builder Documentation
TopicEditorWindow..::.GetChildAtPoint Method
TopicEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

TopicEditorWindow Class
TopicEditorWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Invalidate Method

[image] [image]

Sandcastle Help File Builder Documentation
TopicEditorWindow..::.Invalidate Method
TopicEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

TopicEditorWindow Class
TopicEditorWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Invoke Method

[image] [image]

Sandcastle Help File Builder Documentation
TopicEditorWindow..::.Invoke Method
TopicEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

TopicEditorWindow Class
TopicEditorWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


MemberwiseClone Method

[image] [image]

Sandcastle Help File Builder Documentation
TopicEditorWindow..::.MemberwiseClone Method
TopicEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

TopicEditorWindow Class
TopicEditorWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


OnClosing Method

[image]

Sandcastle Help File Builder Documentation
TopicEditorWindow..::.OnClosing Method
TopicEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is overriden to prompt to save changes if necessary

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
protected override void OnClosing(
    CancelEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnClosing ( _
    e As CancelEventArgs _
)

Parameters

e
Type: System.ComponentModel..::.CancelEventArgs
The event arguments

See Also

TopicEditorWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


PasteFromClipboard Method

[image]

Sandcastle Help File Builder Documentation
TopicEditorWindow..::.PasteFromClipboard Method
TopicEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Paste text from the clipboard into the editor

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public void PasteFromClipboard()
Visual Basic (Declaration)
Public Sub PasteFromClipboard

See Also

TopicEditorWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


PerformLayout Method

[image] [image]

Sandcastle Help File Builder Documentation
TopicEditorWindow..::.PerformLayout Method
TopicEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

TopicEditorWindow Class
TopicEditorWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


ReplaceAll Method

[image]

Sandcastle Help File Builder Documentation
TopicEditorWindow..::.ReplaceAll Method
TopicEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Find and replace all occurrences of the specified text in the editor.

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public bool ReplaceAll(
    string textToFind,
    string replaceWith,
    bool caseSensitive
)
Visual Basic (Declaration)
Public Function ReplaceAll ( _
    textToFind As String, _
    replaceWith As String, _
    caseSensitive As Boolean _
) As Boolean

Parameters

textToFind
Type: System..::.String
The text to find
replaceWith
Type: System..::.String
The replacement text
caseSensitive
Type: System..::.Boolean
True to do a case-sensitive search or false to do a case-insensitive search

Return Value

True if replacements were made, false if not

See Also

TopicEditorWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


ReplaceText Method

[image]

Sandcastle Help File Builder Documentation
TopicEditorWindow..::.ReplaceText Method
TopicEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Find and replace the next occurrence of the specified text in the editor.

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public bool ReplaceText(
    string textToFind,
    string replaceWith,
    bool caseSensitive
)
Visual Basic (Declaration)
Public Function ReplaceText ( _
    textToFind As String, _
    replaceWith As String, _
    caseSensitive As Boolean _
) As Boolean

Parameters

textToFind
Type: System..::.String
The text to find
replaceWith
Type: System..::.String
The replacement text
caseSensitive
Type: System..::.Boolean
True to do a case-sensitive search or false to do a case-insensitive search

Return Value

True if the text is found and replaced, false if not

See Also

TopicEditorWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


ResumeLayout Method

[image] [image]

Sandcastle Help File Builder Documentation
TopicEditorWindow..::.ResumeLayout Method
TopicEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

TopicEditorWindow Class
TopicEditorWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


RtlTranslateAlignment Method

[image] [image]

Sandcastle Help File Builder Documentation
TopicEditorWindow..::.RtlTranslateAlignment Method
TopicEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

TopicEditorWindow Class
TopicEditorWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Save Method

[image] [image]

Sandcastle Help File Builder Documentation
TopicEditorWindow..::.Save Method
TopicEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

There are two overloads for this method

Overload List

Name | Description
Save()()() | Save the content of the window using its current filename (Overrides BaseContentEditor..::.Save()()().)
Save(String) | Save the topic to a new filename

See Also

TopicEditorWindow Class
TopicEditorWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Save Method

[image]

Sandcastle Help File Builder Documentation
TopicEditorWindow..::.Save Method
TopicEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Save the content of the window using its current filename

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public override bool Save()
Visual Basic (Declaration)
Public Overrides Function Save As Boolean

Return Value

True if successful, false if not successful

See Also

TopicEditorWindow Class
Save Overload
SandcastleBuilder.Gui.ContentEditors Namespace


Save Method (String)

[image]

Sandcastle Help File Builder Documentation
TopicEditorWindow..::.Save Method (String)
TopicEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Save the topic to a new filename

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public bool Save(
    string filename
)
Visual Basic (Declaration)
Public Function Save ( _
    filename As String _
) As Boolean

Parameters

filename
Type: System..::.String
The new filename

Return Value

True if saved successfully, false if not

See Also

TopicEditorWindow Class
Save Overload
SandcastleBuilder.Gui.ContentEditors Namespace


SaveAs Method

[image]

Sandcastle Help File Builder Documentation
TopicEditorWindow..::.SaveAs Method
TopicEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Save the content of the window using a different filename

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public override bool SaveAs()
Visual Basic (Declaration)
Public Overrides Function SaveAs As Boolean

Return Value

True if successful, false if not successful

See Also

TopicEditorWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


Scale Method

[image] [image]

Sandcastle Help File Builder Documentation
TopicEditorWindow..::.Scale Method
TopicEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

TopicEditorWindow Class
TopicEditorWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Select Method

[image] [image]

Sandcastle Help File Builder Documentation
TopicEditorWindow..::.Select Method
TopicEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)

See Also

TopicEditorWindow Class
TopicEditorWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


SetBounds Method

[image] [image]

Sandcastle Help File Builder Documentation
TopicEditorWindow..::.SetBounds Method
TopicEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

TopicEditorWindow Class
TopicEditorWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


Show Method

[image] [image]

Sandcastle Help File Builder Documentation
TopicEditorWindow..::.Show Method
TopicEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Show()()() | (Inherited from DockContent.)
Show(DockPanel) | (Inherited from DockContent.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Show(DockPanel, DockState) | (Inherited from DockContent.)
Show(DockPanel, Rectangle) | (Inherited from DockContent.)
Show(DockPane, IDockContent) | (Inherited from DockContent.)
Show(DockPane, DockAlignment, Double) | (Inherited from DockContent.)

See Also

TopicEditorWindow Class
TopicEditorWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


ShowDialog Method

[image] [image]

Sandcastle Help File Builder Documentation
TopicEditorWindow..::.ShowDialog Method
TopicEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)

See Also

TopicEditorWindow Class
TopicEditorWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


UpdateBounds Method

[image] [image]

Sandcastle Help File Builder Documentation
TopicEditorWindow..::.UpdateBounds Method
TopicEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

TopicEditorWindow Class
TopicEditorWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


UpdateFont Method

[image]

Sandcastle Help File Builder Documentation
TopicEditorWindow..::.UpdateFont Method
TopicEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Update the font used based on the selected user settings

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public void UpdateFont()
Visual Basic (Declaration)
Public Sub UpdateFont

See Also

TopicEditorWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


Validate Method

[image] [image]

Sandcastle Help File Builder Documentation
TopicEditorWindow..::.Validate Method
TopicEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

TopicEditorWindow Class
TopicEditorWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


ValidateChildren Method

[image] [image]

Sandcastle Help File Builder Documentation
TopicEditorWindow..::.ValidateChildren Method
TopicEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

TopicEditorWindow Class
TopicEditorWindow Members
SandcastleBuilder.Gui.ContentEditors Namespace


TopicEditorWindow Properties

[image] [image]

Sandcastle Help File Builder Documentation
TopicEditorWindow Properties
TopicEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TopicEditorWindow type exposes the following members.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowEndUserDocking | (Inherited from DockContent.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoHidePortion | (Inherited from DockContent.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanClose | Returns true if the window can be closed or false if something prevents it from allowing the close to occur. (Overrides BaseContentEditor..::.CanClose.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSaveContent | This is used to see if the active document allows its content to be saved. (Overrides BaseContentEditor..::.CanSaveContent.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CloseButton | (Inherited from DockContent.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockAreas | (Inherited from DockContent.)
DockHandler | (Inherited from DockContent.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DockPanel | (Inherited from DockContent.)
DockState | (Inherited from DockContent.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Filename | This returns the filename
FloatPane | (Inherited from DockContent.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HideOnClose | (Inherited from DockContent.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsActivated | (Inherited from DockContent.)
IsContentDocument | This is used to see if the editor is a document type that should be saved prior to doing a build. (Overrides BaseContentEditor..::.IsContentDocument.)
IsDirty | This returns the dirty state of the document if it supports saving (Inherited from BaseContentEditor.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsFloat | (Inherited from DockContent.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsHidden | (Inherited from DockContent.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Pane | (Inherited from DockContent.)
PanelPane | (Inherited from DockContent.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowHint | (Inherited from DockContent.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabPageContextMenu | (Inherited from DockContent.)
TabPageContextMenuStrip | (Inherited from DockContent.)
TabStop | (Inherited from Form.)
TabText | (Inherited from DockContent.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
ToolTipText | (Inherited from DockContent.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VisibleState | (Inherited from DockContent.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

TopicEditorWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


CanClose Property

[image]

Sandcastle Help File Builder Documentation
TopicEditorWindow..::.CanClose Property
TopicEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Returns true if the window can be closed or false if something prevents it from allowing the close to occur.

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public override bool CanClose { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property CanClose As Boolean

See Also

TopicEditorWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


CanSaveContent Property

[image]

Sandcastle Help File Builder Documentation
TopicEditorWindow..::.CanSaveContent Property
TopicEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to see if the active document allows its content to be saved.

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public override bool CanSaveContent { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property CanSaveContent As Boolean

Return Value

Returns true if it supports saving its content or false if it does not.

See Also

TopicEditorWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


Filename Property

[image]

Sandcastle Help File Builder Documentation
TopicEditorWindow..::.Filename Property
TopicEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This returns the filename

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public string Filename { get; }
Visual Basic (Declaration)
Public ReadOnly Property Filename As String

See Also

TopicEditorWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


IsContentDocument Property

[image]

Sandcastle Help File Builder Documentation
TopicEditorWindow..::.IsContentDocument Property
TopicEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to see if the editor is a document type that should be saved prior to doing a build.

Namespace: SandcastleBuilder.Gui.ContentEditors
Assembly: SandcastleBuilderGUI (in SandcastleBuilderGUI.exe) Version: 1.8.0.2

Syntax

C#
public override bool IsContentDocument { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property IsContentDocument As Boolean

See Also

TopicEditorWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


TopicEditorWindow Events

[image] [image]

Sandcastle Help File Builder Documentation
TopicEditorWindow Events
TopicEditorWindow Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TopicEditorWindow type exposes the following members.

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DockStateChanged | (Inherited from DockContent.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

TopicEditorWindow Class
SandcastleBuilder.Gui.ContentEditors Namespace


SandcastleBuilder.HtmlExtract Namespace

[image]

Sandcastle Help File Builder Documentation
SandcastleBuilder.HtmlExtract Namespace
Send Feedback

[This is preliminary documentation and is subject to change.]

This is the console mode application used to extract title and keyword information from HTML files for use in creating the CHM table of contents and keyword index files.

Classes

Class | Description
OptionInfo | This class holds command line option information.
SandcastleHtmlExtract | This is the console mode application used to extract title and keyword information from HTML files for use in creating the CHM table of contents and keyword index files.


OptionInfo Class

[image]

Sandcastle Help File Builder Documentation
OptionInfo Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This class holds command line option information.

Namespace: SandcastleBuilder.HtmlExtract
Assembly: SandcastleHtmlExtract (in SandcastleHtmlExtract.exe) Version: 1.8.0.2

Syntax

C#
public class OptionInfo
Visual Basic (Declaration)
Public Class OptionInfo

Inheritance Hierarchy

System..::.Object
SandcastleBuilder.HtmlExtract..::.OptionInfo

See Also

OptionInfo Members
SandcastleBuilder.HtmlExtract Namespace


OptionInfo Members

[image] [image]

Sandcastle Help File Builder Documentation
OptionInfo Members
OptionInfo Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OptionInfo type exposes the following members.

Constructors

Name | Description
OptionInfo | Constructor

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Name | Get the option name
OptionText | Get the option text as specified
SecondValue | Get the second option value if there was one
ThirdValue | Get the third option value if there was one
Value | Get the option value

See Also

OptionInfo Class
SandcastleBuilder.HtmlExtract Namespace


OptionInfo Constructor

[image]

Sandcastle Help File Builder Documentation
OptionInfo Constructor
OptionInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.HtmlExtract
Assembly: SandcastleHtmlExtract (in SandcastleHtmlExtract.exe) Version: 1.8.0.2

Syntax

C#
public OptionInfo(
    string option
)
Visual Basic (Declaration)
Public Sub New ( _
    option As String _
)

Parameters

option
Type: System..::.String
The option text to parse

See Also

OptionInfo Class
SandcastleBuilder.HtmlExtract Namespace


OptionInfo Methods

[image] [image]

Sandcastle Help File Builder Documentation
OptionInfo Methods
OptionInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OptionInfo type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OptionInfo Class
SandcastleBuilder.HtmlExtract Namespace


OptionInfo Properties

[image] [image]

Sandcastle Help File Builder Documentation
OptionInfo Properties
OptionInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OptionInfo type exposes the following members.

Properties

Name | Description
Name | Get the option name
OptionText | Get the option text as specified
SecondValue | Get the second option value if there was one
ThirdValue | Get the third option value if there was one
Value | Get the option value

See Also

OptionInfo Class
SandcastleBuilder.HtmlExtract Namespace


Name Property

[image]

Sandcastle Help File Builder Documentation
OptionInfo..::.Name Property
OptionInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Get the option name

Namespace: SandcastleBuilder.HtmlExtract
Assembly: SandcastleHtmlExtract (in SandcastleHtmlExtract.exe) Version: 1.8.0.2

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String

See Also

OptionInfo Class
SandcastleBuilder.HtmlExtract Namespace


OptionText Property

[image]

Sandcastle Help File Builder Documentation
OptionInfo..::.OptionText Property
OptionInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Get the option text as specified

Namespace: SandcastleBuilder.HtmlExtract
Assembly: SandcastleHtmlExtract (in SandcastleHtmlExtract.exe) Version: 1.8.0.2

Syntax

C#
public string OptionText { get; }
Visual Basic (Declaration)
Public ReadOnly Property OptionText As String

See Also

OptionInfo Class
SandcastleBuilder.HtmlExtract Namespace


SecondValue Property

[image]

Sandcastle Help File Builder Documentation
OptionInfo..::.SecondValue Property
OptionInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Get the second option value if there was one

Namespace: SandcastleBuilder.HtmlExtract
Assembly: SandcastleHtmlExtract (in SandcastleHtmlExtract.exe) Version: 1.8.0.2

Syntax

C#
public string SecondValue { get; }
Visual Basic (Declaration)
Public ReadOnly Property SecondValue As String

See Also

OptionInfo Class
SandcastleBuilder.HtmlExtract Namespace


ThirdValue Property

[image]

Sandcastle Help File Builder Documentation
OptionInfo..::.ThirdValue Property
OptionInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Get the third option value if there was one

Namespace: SandcastleBuilder.HtmlExtract
Assembly: SandcastleHtmlExtract (in SandcastleHtmlExtract.exe) Version: 1.8.0.2

Syntax

C#
public string ThirdValue { get; }
Visual Basic (Declaration)
Public ReadOnly Property ThirdValue As String

See Also

OptionInfo Class
SandcastleBuilder.HtmlExtract Namespace


Value Property

[image]

Sandcastle Help File Builder Documentation
OptionInfo..::.Value Property
OptionInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Get the option value

Namespace: SandcastleBuilder.HtmlExtract
Assembly: SandcastleHtmlExtract (in SandcastleHtmlExtract.exe) Version: 1.8.0.2

Syntax

C#
public string Value { get; }
Visual Basic (Declaration)
Public ReadOnly Property Value As String

See Also

OptionInfo Class
SandcastleBuilder.HtmlExtract Namespace


SandcastleHtmlExtract Class

[image]

Sandcastle Help File Builder Documentation
SandcastleHtmlExtract Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is the console mode application used to extract title and keyword information from HTML files for use in creating the CHM table of contents and keyword index files.

Namespace: SandcastleBuilder.HtmlExtract
Assembly: SandcastleHtmlExtract (in SandcastleHtmlExtract.exe) Version: 1.8.0.2

Syntax

C#
public class SandcastleHtmlExtract : Task
Visual Basic (Declaration)
Public Class SandcastleHtmlExtract _
    Inherits Task

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
SandcastleBuilder.HtmlExtract..::.SandcastleHtmlExtract

See Also

SandcastleHtmlExtract Members
SandcastleBuilder.HtmlExtract Namespace


SandcastleHtmlExtract Members

[image] [image]

Sandcastle Help File Builder Documentation
SandcastleHtmlExtract Members
SandcastleHtmlExtract Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SandcastleHtmlExtract type exposes the following members.

Constructors

Name | Description
SandcastleHtmlExtract | Initializes a new instance of the SandcastleHtmlExtract class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | This is used to execute the task and generate the inherited documentation. (Overrides Task..::.Execute()()().)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Main | Main program entry point
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (Inherited from Task.)
BuildEngine2 | (Inherited from Task.)
GenerateHelp1Files | This is used to specify whether the extract should generate files for a Help 1 build.
GenerateWebFiles | This is used to specify whether the extract should generate files for a website build.
HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (Inherited from Task.)
HostObject | Gets or sets the host object associated with the task. (Inherited from Task.)
HtmlFolder | This is used to set the HTML output folder name
LanguageId | This is used to set the language ID (LCID)
LocalizedFolder | This is used to set the localized output folder name
Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (Inherited from Task.)
OutputFolder | This is used to set the general output folder name
ProjectName | This is used to set the project name
TaskResources | Gets or sets the culture-specific resources associated with the task. (Inherited from Task.)
TocFile | This is used to set the table of contents XML filename

See Also

SandcastleHtmlExtract Class
SandcastleBuilder.HtmlExtract Namespace


SandcastleHtmlExtract Constructor

[image]

Sandcastle Help File Builder Documentation
SandcastleHtmlExtract Constructor
SandcastleHtmlExtract Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the SandcastleHtmlExtract class

Namespace: SandcastleBuilder.HtmlExtract
Assembly: SandcastleHtmlExtract (in SandcastleHtmlExtract.exe) Version: 1.8.0.2

Syntax

C#
public SandcastleHtmlExtract()
Visual Basic (Declaration)
Public Sub New

See Also

SandcastleHtmlExtract Class
SandcastleBuilder.HtmlExtract Namespace


SandcastleHtmlExtract Methods

[image] [image]

Sandcastle Help File Builder Documentation
SandcastleHtmlExtract Methods
SandcastleHtmlExtract Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SandcastleHtmlExtract type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | This is used to execute the task and generate the inherited documentation. (Overrides Task..::.Execute()()().)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Main | Main program entry point
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SandcastleHtmlExtract Class
SandcastleBuilder.HtmlExtract Namespace


Execute Method

[image]

Sandcastle Help File Builder Documentation
SandcastleHtmlExtract..::.Execute Method
SandcastleHtmlExtract Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to execute the task and generate the inherited documentation.

Namespace: SandcastleBuilder.HtmlExtract
Assembly: SandcastleHtmlExtract (in SandcastleHtmlExtract.exe) Version: 1.8.0.2

Syntax

C#
public override bool Execute()
Visual Basic (Declaration)
Public Overrides Function Execute As Boolean

Return Value

True on success or false on failure.

Implements

ITask..::.Execute()()()

See Also

SandcastleHtmlExtract Class
SandcastleBuilder.HtmlExtract Namespace


Main Method

[image]

Sandcastle Help File Builder Documentation
SandcastleHtmlExtract..::.Main Method
SandcastleHtmlExtract Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Main program entry point

Namespace: SandcastleBuilder.HtmlExtract
Assembly: SandcastleHtmlExtract (in SandcastleHtmlExtract.exe) Version: 1.8.0.2

Syntax

C#
public static int Main(
    string[] args
)
Visual Basic (Declaration)
Public Shared Function Main ( _
    args As String() _
) As Integer

Parameters

args
Type: array< System..::.String >[]()[]
The command line arguments

Return Value

Zero on success or a non-zero value on failure

See Also

SandcastleHtmlExtract Class
SandcastleBuilder.HtmlExtract Namespace


SandcastleHtmlExtract Properties

[image] [image]

Sandcastle Help File Builder Documentation
SandcastleHtmlExtract Properties
SandcastleHtmlExtract Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SandcastleHtmlExtract type exposes the following members.

Properties

Name | Description
BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (Inherited from Task.)
BuildEngine2 | (Inherited from Task.)
GenerateHelp1Files | This is used to specify whether the extract should generate files for a Help 1 build.
GenerateWebFiles | This is used to specify whether the extract should generate files for a website build.
HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (Inherited from Task.)
HostObject | Gets or sets the host object associated with the task. (Inherited from Task.)
HtmlFolder | This is used to set the HTML output folder name
LanguageId | This is used to set the language ID (LCID)
LocalizedFolder | This is used to set the localized output folder name
Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (Inherited from Task.)
OutputFolder | This is used to set the general output folder name
ProjectName | This is used to set the project name
TaskResources | Gets or sets the culture-specific resources associated with the task. (Inherited from Task.)
TocFile | This is used to set the table of contents XML filename

See Also

SandcastleHtmlExtract Class
SandcastleBuilder.HtmlExtract Namespace


GenerateHelp1Files Property

[image]

Sandcastle Help File Builder Documentation
SandcastleHtmlExtract..::.GenerateHelp1Files Property
SandcastleHtmlExtract Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to specify whether the extract should generate files for a Help 1 build.

Namespace: SandcastleBuilder.HtmlExtract
Assembly: SandcastleHtmlExtract (in SandcastleHtmlExtract.exe) Version: 1.8.0.2

Syntax

C#
public bool GenerateHelp1Files { get; set; }
Visual Basic (Declaration)
Public Property GenerateHelp1Files As Boolean

Field Value

This property and/or GenerateWebFiles should be set to true.

See Also

SandcastleHtmlExtract Class
SandcastleBuilder.HtmlExtract Namespace


GenerateWebFiles Property

[image]

Sandcastle Help File Builder Documentation
SandcastleHtmlExtract..::.GenerateWebFiles Property
SandcastleHtmlExtract Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to specify whether the extract should generate files for a website build.

Namespace: SandcastleBuilder.HtmlExtract
Assembly: SandcastleHtmlExtract (in SandcastleHtmlExtract.exe) Version: 1.8.0.2

Syntax

C#
public bool GenerateWebFiles { get; set; }
Visual Basic (Declaration)
Public Property GenerateWebFiles As Boolean

Field Value

This property and/or GenerateHelp1Files should be set to true.

See Also

SandcastleHtmlExtract Class
SandcastleBuilder.HtmlExtract Namespace


HtmlFolder Property

[image]

Sandcastle Help File Builder Documentation
SandcastleHtmlExtract..::.HtmlFolder Property
SandcastleHtmlExtract Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to set the HTML output folder name

Namespace: SandcastleBuilder.HtmlExtract
Assembly: SandcastleHtmlExtract (in SandcastleHtmlExtract.exe) Version: 1.8.0.2

Syntax

C#
public string HtmlFolder { get; set; }
Visual Basic (Declaration)
Public Property HtmlFolder As String

Field Value

This is optional. If not set, it defaults to Output.

See Also

SandcastleHtmlExtract Class
SandcastleBuilder.HtmlExtract Namespace


LanguageId Property

[image]

Sandcastle Help File Builder Documentation
SandcastleHtmlExtract..::.LanguageId Property
SandcastleHtmlExtract Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to set the language ID (LCID)

Namespace: SandcastleBuilder.HtmlExtract
Assembly: SandcastleHtmlExtract (in SandcastleHtmlExtract.exe) Version: 1.8.0.2

Syntax

C#
public int LanguageId { get; set; }
Visual Basic (Declaration)
Public Property LanguageId As Integer

Field Value

This is optional. If not set, it defaults to 1033.

See Also

SandcastleHtmlExtract Class
SandcastleBuilder.HtmlExtract Namespace


LocalizedFolder Property

[image]

Sandcastle Help File Builder Documentation
SandcastleHtmlExtract..::.LocalizedFolder Property
SandcastleHtmlExtract Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to set the localized output folder name

Namespace: SandcastleBuilder.HtmlExtract
Assembly: SandcastleHtmlExtract (in SandcastleHtmlExtract.exe) Version: 1.8.0.2

Syntax

C#
public string LocalizedFolder { get; set; }
Visual Basic (Declaration)
Public Property LocalizedFolder As String

Field Value

This is optional. If not set, the HTML files will not be localized.

See Also

SandcastleHtmlExtract Class
SandcastleBuilder.HtmlExtract Namespace


OutputFolder Property

[image]

Sandcastle Help File Builder Documentation
SandcastleHtmlExtract..::.OutputFolder Property
SandcastleHtmlExtract Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to set the general output folder name

Namespace: SandcastleBuilder.HtmlExtract
Assembly: SandcastleHtmlExtract (in SandcastleHtmlExtract.exe) Version: 1.8.0.2

Syntax

C#
public string OutputFolder { get; set; }
Visual Basic (Declaration)
Public Property OutputFolder As String

Field Value

This is optional. If not set, it defaults to the current working folder.

See Also

SandcastleHtmlExtract Class
SandcastleBuilder.HtmlExtract Namespace


ProjectName Property

[image]

Sandcastle Help File Builder Documentation
SandcastleHtmlExtract..::.ProjectName Property
SandcastleHtmlExtract Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to set the project name

Namespace: SandcastleBuilder.HtmlExtract
Assembly: SandcastleHtmlExtract (in SandcastleHtmlExtract.exe) Version: 1.8.0.2

Syntax

C#
public string ProjectName { get; set; }
Visual Basic (Declaration)
Public Property ProjectName As String

See Also

SandcastleHtmlExtract Class
SandcastleBuilder.HtmlExtract Namespace


TocFile Property

[image]

Sandcastle Help File Builder Documentation
SandcastleHtmlExtract..::.TocFile Property
SandcastleHtmlExtract Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to set the table of contents XML filename

Namespace: SandcastleBuilder.HtmlExtract
Assembly: SandcastleHtmlExtract (in SandcastleHtmlExtract.exe) Version: 1.8.0.2

Syntax

C#
public string TocFile { get; set; }
Visual Basic (Declaration)
Public Property TocFile As String

Field Value

This is optional. If not set, it defaults to toc.xml.

See Also

SandcastleHtmlExtract Class
SandcastleBuilder.HtmlExtract Namespace


SandcastleBuilder.PlugIns Namespace

[image]

Sandcastle Help File Builder Documentation
SandcastleBuilder.PlugIns Namespace
Send Feedback

[This is preliminary documentation and is subject to change.]

This namespace contains the plug-ins supplied with the Sandcastle Help File Builder. These can be used in a project to extend or alter the build process in various ways such as supporting build completion notification, deployment, and generating documentation with AjaxDoc.

Classes

Class | Description
AdditionalContentOnlyPlugIn | This plug-in class can be used to build a help file consisting of nothing but additional content items. It is also useful for proofreading your additional content without having to build all the API topics.
AdditionalReferenceLinksPlugIn | This plug-in class is designed to add additional reference link targets to the Reflection Index Data and Resolve Reference Links build components so that links can be created to other third party help in a Help 2 collection.
AjaxDocPlugIn | This plug-in class is designed to generate XML comments and reflection file information for Atlas client script libraries using AjaxDoc.
BibliographySupportPlugIn | This plug-in class is used to add bibliography support to the topics
BindingRedirectResolverPlugIn | This plug-in class is used to add assembly binding redirection support to the MRefBuilder configuration file.
BindingRedirectSettings | This represents binding redirection settings for the BindingRedirectResolverPlugIn.
BindingRedirectSettingsCollection | This collection class is used to hold the binding redirect settings information for the BindingRedirectResolverPlugIn.
CompletionNotificationPlugIn | This plug-in class is designed to run after the build completes to send notification of the completion status via e-mail. The log file can be sent as an attachment.
DbcsFixPlugIn | This plug-in class is designed to modify the HTML files and alter the build so as to overcome the encoding issues encountered when building Help 1.x (CHM) files for various foreign languages.
DeploymentLocation | This represents a deployment location
DeploymentPlugIn | This plug-in class is used to copy the resulting help file output to a location other than the output folder (i.e. a file share, an FTP site, a web server, etc.).
HierarchicalTocPlugIn | This plug-in class can be used to rearrange the table of contents such that namespaces are nested within their parent namespaces rather than appearing as a flat list of all namespaces at the root level.
ProxyCredentials | This class is used to specify credentials for a proxy server.
ReferenceLinkSettings | This represents reference link settings for the AdditionalReferenceLinksPlugIn.
ReferenceLinkSettingsCollection | This collection class is used to hold the reference link settings information for the AdditionalReferenceLinksPlugIn.
ScriptSharpPlugIn | This plug-in class is designed to modify the reflection information file produced after running MRefBuilder on assemblies produced by the Script# compiler so that it is suitable for use in producing a help file.
TocExcludePlugIn | This plug-in class can be used to exclude API members from the table of contents via the <tocexclude /> XML comment tag. The excluded items are still accessible in the help file via other topic links.
UserCredentials | This class is used to specify user credentials.
VersionBuilderPlugIn | This plug-in class is designed to generate version information for assemblies in the current project and others related to the same product that can be merged into the current project's help file topics.
VersionSettings | This represents version settings for the VersionBuilderPlugIn.
VersionSettingsCollection | This collection class is used to hold the version settings information for the VersionBuilderPlugIn.
XPathReflectionFileFilterPlugIn | This plug-in class is used to filter out unwanted information from the reflection information file using XPath queries.


AdditionalContentOnlyPlugIn Class

[image]

Sandcastle Help File Builder Documentation
AdditionalContentOnlyPlugIn Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This plug-in class can be used to build a help file consisting of nothing but additional content items. It is also useful for proofreading your additional content without having to build all the API topics.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public class AdditionalContentOnlyPlugIn : IPlugIn,
    IDisposable
Visual Basic (Declaration)
Public Class AdditionalContentOnlyPlugIn _
    Implements IPlugIn, IDisposable

Inheritance Hierarchy

System..::.Object
SandcastleBuilder.PlugIns..::.AdditionalContentOnlyPlugIn

See Also

AdditionalContentOnlyPlugIn Members
SandcastleBuilder.PlugIns Namespace


AdditionalContentOnlyPlugIn Members

[image] [image]

Sandcastle Help File Builder Documentation
AdditionalContentOnlyPlugIn Members
AdditionalContentOnlyPlugIn Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The AdditionalContentOnlyPlugIn type exposes the following members.

Constructors

Name | Description
AdditionalContentOnlyPlugIn | Initializes a new instance of the AdditionalContentOnlyPlugIn class

Methods

Name | Description
ConfigurePlugIn | This method is used by the Sandcastle Help File Builder to let the plug-in perform its own configuration.
Dispose | Overloaded. There are two overloads for this method.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | This method is used to execute the plug-in during the build process
Finalize | This handles garbage collection to ensure proper disposal of the plug-in if not done explicity with Dispose()()(). (Overrides Object..::.Finalize()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Initialize | This method is used to initialize the plug-in at the start of the build process.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Copyright | This read-only property returns the copyright information for the plug-in.
Description | This read-only property returns a brief description of the plug-in
ExecutionPoints | This read-only property returns a collection of execution points that define when the plug-in should be invoked during the build process.
Name | This read-only property returns a friendly name for the plug-in
RunsInPartialBuild | This plug-in does not run in partial builds
Version | This read-only property returns the version of the plug-in

See Also

AdditionalContentOnlyPlugIn Class
SandcastleBuilder.PlugIns Namespace


AdditionalContentOnlyPlugIn Constructor

[image]

Sandcastle Help File Builder Documentation
AdditionalContentOnlyPlugIn Constructor
AdditionalContentOnlyPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the AdditionalContentOnlyPlugIn class

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public AdditionalContentOnlyPlugIn()
Visual Basic (Declaration)
Public Sub New

See Also

AdditionalContentOnlyPlugIn Class
SandcastleBuilder.PlugIns Namespace


AdditionalContentOnlyPlugIn Methods

[image] [image]

Sandcastle Help File Builder Documentation
AdditionalContentOnlyPlugIn Methods
AdditionalContentOnlyPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The AdditionalContentOnlyPlugIn type exposes the following members.

Methods

Name | Description
ConfigurePlugIn | This method is used by the Sandcastle Help File Builder to let the plug-in perform its own configuration.
Dispose | Overloaded. There are two overloads for this method.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | This method is used to execute the plug-in during the build process
Finalize | This handles garbage collection to ensure proper disposal of the plug-in if not done explicity with Dispose()()(). (Overrides Object..::.Finalize()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Initialize | This method is used to initialize the plug-in at the start of the build process.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AdditionalContentOnlyPlugIn Class
SandcastleBuilder.PlugIns Namespace


ConfigurePlugIn Method

[image]

Sandcastle Help File Builder Documentation
AdditionalContentOnlyPlugIn..::.ConfigurePlugIn Method
AdditionalContentOnlyPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This method is used by the Sandcastle Help File Builder to let the plug-in perform its own configuration.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public string ConfigurePlugIn(
    SandcastleProject project,
    string currentConfig
)
Visual Basic (Declaration)
Public Function ConfigurePlugIn ( _
    project As SandcastleProject, _
    currentConfig As String _
) As String

Parameters

project
Type: SandcastleBuilder.Utils..::.SandcastleProject
A reference to the active project
currentConfig
Type: System..::.String
The current configuration XML fragment

Return Value

A string containing the new configuration XML fragment

Implements

IPlugIn..::.ConfigurePlugIn(SandcastleProject, String)

Remarks

The configuration data will be stored in the help file builder project.

See Also

AdditionalContentOnlyPlugIn Class
SandcastleBuilder.PlugIns Namespace


Dispose Method

[image] [image]

Sandcastle Help File Builder Documentation
AdditionalContentOnlyPlugIn..::.Dispose Method
AdditionalContentOnlyPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

There are two overloads for this method.

Overload List

Name | Description
Dispose()()() | This implements the Dispose() interface to properly dispose of the plug-in object.
Dispose(Boolean) | This can be overridden by derived classes to add their own disposal code if necessary.

See Also

AdditionalContentOnlyPlugIn Class
AdditionalContentOnlyPlugIn Members
SandcastleBuilder.PlugIns Namespace


Dispose Method

[image]

Sandcastle Help File Builder Documentation
AdditionalContentOnlyPlugIn..::.Dispose Method
AdditionalContentOnlyPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This implements the Dispose() interface to properly dispose of the plug-in object.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose

Implements

IDisposable..::.Dispose()()()

See Also

AdditionalContentOnlyPlugIn Class
Dispose Overload
SandcastleBuilder.PlugIns Namespace


Dispose Method (Boolean)

[image]

Sandcastle Help File Builder Documentation
AdditionalContentOnlyPlugIn..::.Dispose Method (Boolean)
AdditionalContentOnlyPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This can be overridden by derived classes to add their own disposal code if necessary.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
protected virtual void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overridable Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
Pass true to dispose of the managed and unmanaged resources or false to just dispose of the unmanaged resources.

See Also

AdditionalContentOnlyPlugIn Class
Dispose Overload
SandcastleBuilder.PlugIns Namespace


Execute Method

[image]

Sandcastle Help File Builder Documentation
AdditionalContentOnlyPlugIn..::.Execute Method
AdditionalContentOnlyPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This method is used to execute the plug-in during the build process

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public void Execute(
    ExecutionContext context
)
Visual Basic (Declaration)
Public Sub Execute ( _
    context As ExecutionContext _
)

Parameters

context
Type: SandcastleBuilder.Utils.PlugIn..::.ExecutionContext
The current execution context

Implements

IPlugIn..::.Execute(ExecutionContext)

See Also

AdditionalContentOnlyPlugIn Class
SandcastleBuilder.PlugIns Namespace


Finalize Method

[image]

Sandcastle Help File Builder Documentation
AdditionalContentOnlyPlugIn..::.Finalize Method
AdditionalContentOnlyPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This handles garbage collection to ensure proper disposal of the plug-in if not done explicity with Dispose()()().

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
protected override void Finalize()
Visual Basic (Declaration)
Protected Overrides Sub Finalize

See Also

AdditionalContentOnlyPlugIn Class
SandcastleBuilder.PlugIns Namespace


Initialize Method

[image]

Sandcastle Help File Builder Documentation
AdditionalContentOnlyPlugIn..::.Initialize Method
AdditionalContentOnlyPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This method is used to initialize the plug-in at the start of the build process.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public void Initialize(
    BuildProcess buildProcess,
    XPathNavigator configuration
)
Visual Basic (Declaration)
Public Sub Initialize ( _
    buildProcess As BuildProcess, _
    configuration As XPathNavigator _
)

Parameters

buildProcess
Type: SandcastleBuilder.Utils.BuildEngine..::.BuildProcess
A reference to the current build process.
configuration
Type: System.Xml.XPath..::.XPathNavigator
The configuration data that the plug-in should use to initialize itself.

Implements

IPlugIn..::.Initialize(BuildProcess, XPathNavigator)

See Also

AdditionalContentOnlyPlugIn Class
SandcastleBuilder.PlugIns Namespace


AdditionalContentOnlyPlugIn Properties

[image] [image]

Sandcastle Help File Builder Documentation
AdditionalContentOnlyPlugIn Properties
AdditionalContentOnlyPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The AdditionalContentOnlyPlugIn type exposes the following members.

Properties

Name | Description
Copyright | This read-only property returns the copyright information for the plug-in.
Description | This read-only property returns a brief description of the plug-in
ExecutionPoints | This read-only property returns a collection of execution points that define when the plug-in should be invoked during the build process.
Name | This read-only property returns a friendly name for the plug-in
RunsInPartialBuild | This plug-in does not run in partial builds
Version | This read-only property returns the version of the plug-in

See Also

AdditionalContentOnlyPlugIn Class
SandcastleBuilder.PlugIns Namespace


Copyright Property

[image]

Sandcastle Help File Builder Documentation
AdditionalContentOnlyPlugIn..::.Copyright Property
AdditionalContentOnlyPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns the copyright information for the plug-in.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public string Copyright { get; }
Visual Basic (Declaration)
Public ReadOnly Property Copyright As String

Implements

IPlugIn..::.Copyright

See Also

AdditionalContentOnlyPlugIn Class
SandcastleBuilder.PlugIns Namespace


Description Property

[image]

Sandcastle Help File Builder Documentation
AdditionalContentOnlyPlugIn..::.Description Property
AdditionalContentOnlyPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns a brief description of the plug-in

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public string Description { get; }
Visual Basic (Declaration)
Public ReadOnly Property Description As String

Implements

IPlugIn..::.Description

See Also

AdditionalContentOnlyPlugIn Class
SandcastleBuilder.PlugIns Namespace


ExecutionPoints Property

[image]

Sandcastle Help File Builder Documentation
AdditionalContentOnlyPlugIn..::.ExecutionPoints Property
AdditionalContentOnlyPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns a collection of execution points that define when the plug-in should be invoked during the build process.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public ExecutionPointCollection ExecutionPoints { get; }
Visual Basic (Declaration)
Public ReadOnly Property ExecutionPoints As ExecutionPointCollection

Implements

IPlugIn..::.ExecutionPoints

See Also

AdditionalContentOnlyPlugIn Class
SandcastleBuilder.PlugIns Namespace


Name Property

[image]

Sandcastle Help File Builder Documentation
AdditionalContentOnlyPlugIn..::.Name Property
AdditionalContentOnlyPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns a friendly name for the plug-in

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String

Implements

IPlugIn..::.Name

See Also

AdditionalContentOnlyPlugIn Class
SandcastleBuilder.PlugIns Namespace


RunsInPartialBuild Property

[image]

Sandcastle Help File Builder Documentation
AdditionalContentOnlyPlugIn..::.RunsInPartialBuild Property
AdditionalContentOnlyPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This plug-in does not run in partial builds

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public bool RunsInPartialBuild { get; }
Visual Basic (Declaration)
Public ReadOnly Property RunsInPartialBuild As Boolean

Implements

IPlugIn..::.RunsInPartialBuild

See Also

AdditionalContentOnlyPlugIn Class
SandcastleBuilder.PlugIns Namespace


Version Property

[image]

Sandcastle Help File Builder Documentation
AdditionalContentOnlyPlugIn..::.Version Property
AdditionalContentOnlyPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns the version of the plug-in

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public Version Version { get; }
Visual Basic (Declaration)
Public ReadOnly Property Version As Version

Implements

IPlugIn..::.Version

See Also

AdditionalContentOnlyPlugIn Class
SandcastleBuilder.PlugIns Namespace


AdditionalReferenceLinksPlugIn Class

[image]

Sandcastle Help File Builder Documentation
AdditionalReferenceLinksPlugIn Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This plug-in class is designed to add additional reference link targets to the Reflection Index Data and Resolve Reference Links build components so that links can be created to other third party help in a Help 2 collection.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public class AdditionalReferenceLinksPlugIn : IPlugIn,
    IDisposable
Visual Basic (Declaration)
Public Class AdditionalReferenceLinksPlugIn _
    Implements IPlugIn, IDisposable

Inheritance Hierarchy

System..::.Object
SandcastleBuilder.PlugIns..::.AdditionalReferenceLinksPlugIn

See Also

AdditionalReferenceLinksPlugIn Members
SandcastleBuilder.PlugIns Namespace


AdditionalReferenceLinksPlugIn Members

[image] [image]

Sandcastle Help File Builder Documentation
AdditionalReferenceLinksPlugIn Members
AdditionalReferenceLinksPlugIn Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The AdditionalReferenceLinksPlugIn type exposes the following members.

Constructors

Name | Description
AdditionalReferenceLinksPlugIn | Initializes a new instance of the AdditionalReferenceLinksPlugIn class

Methods

Name | Description
ConfigurePlugIn | This method is used by the Sandcastle Help File Builder to let the plug-in perform its own configuration.
Dispose | Overloaded. There are two overloads for this method.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | This method is used to execute the plug-in during the build process
Finalize | This handles garbage collection to ensure proper disposal of the plug-in if not done explicity with Dispose()()(). (Overrides Object..::.Finalize()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Initialize | This method is used to initialize the plug-in at the start of the build process.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Copyright | This read-only property returns the copyright information for the plug-in.
Description | This read-only property returns a brief description of the plug-in
ExecutionPoints | This read-only property returns a collection of execution points that define when the plug-in should be invoked during the build process.
Name | This read-only property returns a friendly name for the plug-in
RunsInPartialBuild | This plug-in does not run in partial builds
Version | This read-only property returns the version of the plug-in

See Also

AdditionalReferenceLinksPlugIn Class
SandcastleBuilder.PlugIns Namespace


AdditionalReferenceLinksPlugIn Constructor

[image]

Sandcastle Help File Builder Documentation
AdditionalReferenceLinksPlugIn Constructor
AdditionalReferenceLinksPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the AdditionalReferenceLinksPlugIn class

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public AdditionalReferenceLinksPlugIn()
Visual Basic (Declaration)
Public Sub New

See Also

AdditionalReferenceLinksPlugIn Class
SandcastleBuilder.PlugIns Namespace


AdditionalReferenceLinksPlugIn Methods

[image] [image]

Sandcastle Help File Builder Documentation
AdditionalReferenceLinksPlugIn Methods
AdditionalReferenceLinksPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The AdditionalReferenceLinksPlugIn type exposes the following members.

Methods

Name | Description
ConfigurePlugIn | This method is used by the Sandcastle Help File Builder to let the plug-in perform its own configuration.
Dispose | Overloaded. There are two overloads for this method.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | This method is used to execute the plug-in during the build process
Finalize | This handles garbage collection to ensure proper disposal of the plug-in if not done explicity with Dispose()()(). (Overrides Object..::.Finalize()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Initialize | This method is used to initialize the plug-in at the start of the build process.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AdditionalReferenceLinksPlugIn Class
SandcastleBuilder.PlugIns Namespace


ConfigurePlugIn Method

[image]

Sandcastle Help File Builder Documentation
AdditionalReferenceLinksPlugIn..::.ConfigurePlugIn Method
AdditionalReferenceLinksPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This method is used by the Sandcastle Help File Builder to let the plug-in perform its own configuration.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public string ConfigurePlugIn(
    SandcastleProject project,
    string currentConfig
)
Visual Basic (Declaration)
Public Function ConfigurePlugIn ( _
    project As SandcastleProject, _
    currentConfig As String _
) As String

Parameters

project
Type: SandcastleBuilder.Utils..::.SandcastleProject
A reference to the active project
currentConfig
Type: System..::.String
The current configuration XML fragment

Return Value

A string containing the new configuration XML fragment

Implements

IPlugIn..::.ConfigurePlugIn(SandcastleProject, String)

Remarks

The configuration data will be stored in the help file builder project.

See Also

AdditionalReferenceLinksPlugIn Class
SandcastleBuilder.PlugIns Namespace


Dispose Method

[image] [image]

Sandcastle Help File Builder Documentation
AdditionalReferenceLinksPlugIn..::.Dispose Method
AdditionalReferenceLinksPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

There are two overloads for this method.

Overload List

Name | Description
Dispose()()() | This implements the Dispose() interface to properly dispose of the plug-in object.
Dispose(Boolean) | This can be overridden by derived classes to add their own disposal code if necessary.

See Also

AdditionalReferenceLinksPlugIn Class
AdditionalReferenceLinksPlugIn Members
SandcastleBuilder.PlugIns Namespace


Dispose Method

[image]

Sandcastle Help File Builder Documentation
AdditionalReferenceLinksPlugIn..::.Dispose Method
AdditionalReferenceLinksPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This implements the Dispose() interface to properly dispose of the plug-in object.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose

Implements

IDisposable..::.Dispose()()()

See Also

AdditionalReferenceLinksPlugIn Class
Dispose Overload
SandcastleBuilder.PlugIns Namespace


Dispose Method (Boolean)

[image]

Sandcastle Help File Builder Documentation
AdditionalReferenceLinksPlugIn..::.Dispose Method (Boolean)
AdditionalReferenceLinksPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This can be overridden by derived classes to add their own disposal code if necessary.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
protected virtual void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overridable Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
Pass true to dispose of the managed and unmanaged resources or false to just dispose of the unmanaged resources.

See Also

AdditionalReferenceLinksPlugIn Class
Dispose Overload
SandcastleBuilder.PlugIns Namespace


Execute Method

[image]

Sandcastle Help File Builder Documentation
AdditionalReferenceLinksPlugIn..::.Execute Method
AdditionalReferenceLinksPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This method is used to execute the plug-in during the build process

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public void Execute(
    ExecutionContext context
)
Visual Basic (Declaration)
Public Sub Execute ( _
    context As ExecutionContext _
)

Parameters

context
Type: SandcastleBuilder.Utils.PlugIn..::.ExecutionContext
The current execution context

Implements

IPlugIn..::.Execute(ExecutionContext)

See Also

AdditionalReferenceLinksPlugIn Class
SandcastleBuilder.PlugIns Namespace


Finalize Method

[image]

Sandcastle Help File Builder Documentation
AdditionalReferenceLinksPlugIn..::.Finalize Method
AdditionalReferenceLinksPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This handles garbage collection to ensure proper disposal of the plug-in if not done explicity with Dispose()()().

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
protected override void Finalize()
Visual Basic (Declaration)
Protected Overrides Sub Finalize

See Also

AdditionalReferenceLinksPlugIn Class
SandcastleBuilder.PlugIns Namespace


Initialize Method

[image]

Sandcastle Help File Builder Documentation
AdditionalReferenceLinksPlugIn..::.Initialize Method
AdditionalReferenceLinksPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This method is used to initialize the plug-in at the start of the build process.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public void Initialize(
    BuildProcess buildProcess,
    XPathNavigator configuration
)
Visual Basic (Declaration)
Public Sub Initialize ( _
    buildProcess As BuildProcess, _
    configuration As XPathNavigator _
)

Parameters

buildProcess
Type: SandcastleBuilder.Utils.BuildEngine..::.BuildProcess
A reference to the current build process.
configuration
Type: System.Xml.XPath..::.XPathNavigator
The configuration data that the plug-in should use to initialize itself.

Implements

IPlugIn..::.Initialize(BuildProcess, XPathNavigator)

Exceptions

Exception | Condition
SandcastleBuilder.Utils..::.BuilderException | This is thrown if the plug-in configuration is not valid.

See Also

AdditionalReferenceLinksPlugIn Class
SandcastleBuilder.PlugIns Namespace


AdditionalReferenceLinksPlugIn Properties

[image] [image]

Sandcastle Help File Builder Documentation
AdditionalReferenceLinksPlugIn Properties
AdditionalReferenceLinksPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The AdditionalReferenceLinksPlugIn type exposes the following members.

Properties

Name | Description
Copyright | This read-only property returns the copyright information for the plug-in.
Description | This read-only property returns a brief description of the plug-in
ExecutionPoints | This read-only property returns a collection of execution points that define when the plug-in should be invoked during the build process.
Name | This read-only property returns a friendly name for the plug-in
RunsInPartialBuild | This plug-in does not run in partial builds
Version | This read-only property returns the version of the plug-in

See Also

AdditionalReferenceLinksPlugIn Class
SandcastleBuilder.PlugIns Namespace


Copyright Property

[image]

Sandcastle Help File Builder Documentation
AdditionalReferenceLinksPlugIn..::.Copyright Property
AdditionalReferenceLinksPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns the copyright information for the plug-in.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public string Copyright { get; }
Visual Basic (Declaration)
Public ReadOnly Property Copyright As String

Implements

IPlugIn..::.Copyright

See Also

AdditionalReferenceLinksPlugIn Class
SandcastleBuilder.PlugIns Namespace


Description Property

[image]

Sandcastle Help File Builder Documentation
AdditionalReferenceLinksPlugIn..::.Description Property
AdditionalReferenceLinksPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns a brief description of the plug-in

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public string Description { get; }
Visual Basic (Declaration)
Public ReadOnly Property Description As String

Implements

IPlugIn..::.Description

See Also

AdditionalReferenceLinksPlugIn Class
SandcastleBuilder.PlugIns Namespace


ExecutionPoints Property

[image]

Sandcastle Help File Builder Documentation
AdditionalReferenceLinksPlugIn..::.ExecutionPoints Property
AdditionalReferenceLinksPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns a collection of execution points that define when the plug-in should be invoked during the build process.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public ExecutionPointCollection ExecutionPoints { get; }
Visual Basic (Declaration)
Public ReadOnly Property ExecutionPoints As ExecutionPointCollection

Implements

IPlugIn..::.ExecutionPoints

See Also

AdditionalReferenceLinksPlugIn Class
SandcastleBuilder.PlugIns Namespace


Name Property

[image]

Sandcastle Help File Builder Documentation
AdditionalReferenceLinksPlugIn..::.Name Property
AdditionalReferenceLinksPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns a friendly name for the plug-in

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String

Implements

IPlugIn..::.Name

See Also

AdditionalReferenceLinksPlugIn Class
SandcastleBuilder.PlugIns Namespace


RunsInPartialBuild Property

[image]

Sandcastle Help File Builder Documentation
AdditionalReferenceLinksPlugIn..::.RunsInPartialBuild Property
AdditionalReferenceLinksPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This plug-in does not run in partial builds

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public bool RunsInPartialBuild { get; }
Visual Basic (Declaration)
Public ReadOnly Property RunsInPartialBuild As Boolean

Implements

IPlugIn..::.RunsInPartialBuild

See Also

AdditionalReferenceLinksPlugIn Class
SandcastleBuilder.PlugIns Namespace


Version Property

[image]

Sandcastle Help File Builder Documentation
AdditionalReferenceLinksPlugIn..::.Version Property
AdditionalReferenceLinksPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns the version of the plug-in

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public Version Version { get; }
Visual Basic (Declaration)
Public ReadOnly Property Version As Version

Implements

IPlugIn..::.Version

See Also

AdditionalReferenceLinksPlugIn Class
SandcastleBuilder.PlugIns Namespace


AjaxDocPlugIn Class

[image]

Sandcastle Help File Builder Documentation
AjaxDocPlugIn Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This plug-in class is designed to generate XML comments and reflection file information for Atlas client script libraries using AjaxDoc.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public class AjaxDocPlugIn : IPlugIn,
    IDisposable
Visual Basic (Declaration)
Public Class AjaxDocPlugIn _
    Implements IPlugIn, IDisposable

Inheritance Hierarchy

System..::.Object
SandcastleBuilder.PlugIns..::.AjaxDocPlugIn

See Also

AjaxDocPlugIn Members
SandcastleBuilder.PlugIns Namespace


AjaxDocPlugIn Members

[image] [image]

Sandcastle Help File Builder Documentation
AjaxDocPlugIn Members
AjaxDocPlugIn Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The AjaxDocPlugIn type exposes the following members.

Constructors

Name | Description
AjaxDocPlugIn | Initializes a new instance of the AjaxDocPlugIn class

Methods

Name | Description
ConfigurePlugIn | This method is used by the Sandcastle Help File Builder to let the plug-in perform its own configuration.
Dispose | Overloaded. There are two overloads for this method.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | This method is used to execute the plug-in during the build process
Finalize | This handles garbage collection to ensure proper disposal of the plug-in if not done explicity with Dispose()()(). (Overrides Object..::.Finalize()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Initialize | This method is used to initialize the plug-in at the start of the build process.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Copyright | This read-only property returns the copyright information for the plug-in.
Description | This read-only property returns a brief description of the plug-in
ExecutionPoints | This read-only property returns a collection of execution points that define when the plug-in should be invoked during the build process.
Name | This read-only property returns a friendly name for the plug-in
RunsInPartialBuild | This plug-in runs in partial builds
Version | This read-only property returns the version of the plug-in

See Also

AjaxDocPlugIn Class
SandcastleBuilder.PlugIns Namespace


AjaxDocPlugIn Constructor

[image]

Sandcastle Help File Builder Documentation
AjaxDocPlugIn Constructor
AjaxDocPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the AjaxDocPlugIn class

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public AjaxDocPlugIn()
Visual Basic (Declaration)
Public Sub New

See Also

AjaxDocPlugIn Class
SandcastleBuilder.PlugIns Namespace


AjaxDocPlugIn Methods

[image] [image]

Sandcastle Help File Builder Documentation
AjaxDocPlugIn Methods
AjaxDocPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The AjaxDocPlugIn type exposes the following members.

Methods

Name | Description
ConfigurePlugIn | This method is used by the Sandcastle Help File Builder to let the plug-in perform its own configuration.
Dispose | Overloaded. There are two overloads for this method.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | This method is used to execute the plug-in during the build process
Finalize | This handles garbage collection to ensure proper disposal of the plug-in if not done explicity with Dispose()()(). (Overrides Object..::.Finalize()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Initialize | This method is used to initialize the plug-in at the start of the build process.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AjaxDocPlugIn Class
SandcastleBuilder.PlugIns Namespace


ConfigurePlugIn Method

[image]

Sandcastle Help File Builder Documentation
AjaxDocPlugIn..::.ConfigurePlugIn Method
AjaxDocPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This method is used by the Sandcastle Help File Builder to let the plug-in perform its own configuration.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public string ConfigurePlugIn(
    SandcastleProject project,
    string currentConfig
)
Visual Basic (Declaration)
Public Function ConfigurePlugIn ( _
    project As SandcastleProject, _
    currentConfig As String _
) As String

Parameters

project
Type: SandcastleBuilder.Utils..::.SandcastleProject
A reference to the active project
currentConfig
Type: System..::.String
The current configuration XML fragment

Return Value

A string containing the new configuration XML fragment

Implements

IPlugIn..::.ConfigurePlugIn(SandcastleProject, String)

Remarks

The configuration data will be stored in the help file builder project.

See Also

AjaxDocPlugIn Class
SandcastleBuilder.PlugIns Namespace


Dispose Method

[image] [image]

Sandcastle Help File Builder Documentation
AjaxDocPlugIn..::.Dispose Method
AjaxDocPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

There are two overloads for this method.

Overload List

Name | Description
Dispose()()() | This implements the Dispose() interface to properly dispose of the plug-in object.
Dispose(Boolean) | This can be overridden by derived classes to add their own disposal code if necessary.

See Also

AjaxDocPlugIn Class
AjaxDocPlugIn Members
SandcastleBuilder.PlugIns Namespace


Dispose Method

[image]

Sandcastle Help File Builder Documentation
AjaxDocPlugIn..::.Dispose Method
AjaxDocPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This implements the Dispose() interface to properly dispose of the plug-in object.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose

Implements

IDisposable..::.Dispose()()()

See Also

AjaxDocPlugIn Class
Dispose Overload
SandcastleBuilder.PlugIns Namespace


Dispose Method (Boolean)

[image]

Sandcastle Help File Builder Documentation
AjaxDocPlugIn..::.Dispose Method (Boolean)
AjaxDocPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This can be overridden by derived classes to add their own disposal code if necessary.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
protected virtual void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overridable Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
Pass true to dispose of the managed and unmanaged resources or false to just dispose of the unmanaged resources.

See Also

AjaxDocPlugIn Class
Dispose Overload
SandcastleBuilder.PlugIns Namespace


Execute Method

[image]

Sandcastle Help File Builder Documentation
AjaxDocPlugIn..::.Execute Method
AjaxDocPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This method is used to execute the plug-in during the build process

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public void Execute(
    ExecutionContext context
)
Visual Basic (Declaration)
Public Sub Execute ( _
    context As ExecutionContext _
)

Parameters

context
Type: SandcastleBuilder.Utils.PlugIn..::.ExecutionContext
The current execution context

Implements

IPlugIn..::.Execute(ExecutionContext)

See Also

AjaxDocPlugIn Class
SandcastleBuilder.PlugIns Namespace


Finalize Method

[image]

Sandcastle Help File Builder Documentation
AjaxDocPlugIn..::.Finalize Method
AjaxDocPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This handles garbage collection to ensure proper disposal of the plug-in if not done explicity with Dispose()()().

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
protected override void Finalize()
Visual Basic (Declaration)
Protected Overrides Sub Finalize

See Also

AjaxDocPlugIn Class
SandcastleBuilder.PlugIns Namespace


Initialize Method

[image]

Sandcastle Help File Builder Documentation
AjaxDocPlugIn..::.Initialize Method
AjaxDocPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This method is used to initialize the plug-in at the start of the build process.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public void Initialize(
    BuildProcess buildProcess,
    XPathNavigator configuration
)
Visual Basic (Declaration)
Public Sub Initialize ( _
    buildProcess As BuildProcess, _
    configuration As XPathNavigator _
)

Parameters

buildProcess
Type: SandcastleBuilder.Utils.BuildEngine..::.BuildProcess
A reference to the current build process.
configuration
Type: System.Xml.XPath..::.XPathNavigator
The configuration data that the plug-in should use to initialize itself.

Implements

IPlugIn..::.Initialize(BuildProcess, XPathNavigator)

Exceptions

Exception | Condition
SandcastleBuilder.Utils..::.BuilderException | This is thrown if the plug-in configuration is not valid.

See Also

AjaxDocPlugIn Class
SandcastleBuilder.PlugIns Namespace


AjaxDocPlugIn Properties

[image] [image]

Sandcastle Help File Builder Documentation
AjaxDocPlugIn Properties
AjaxDocPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The AjaxDocPlugIn type exposes the following members.

Properties

Name | Description
Copyright | This read-only property returns the copyright information for the plug-in.
Description | This read-only property returns a brief description of the plug-in
ExecutionPoints | This read-only property returns a collection of execution points that define when the plug-in should be invoked during the build process.
Name | This read-only property returns a friendly name for the plug-in
RunsInPartialBuild | This plug-in runs in partial builds
Version | This read-only property returns the version of the plug-in

See Also

AjaxDocPlugIn Class
SandcastleBuilder.PlugIns Namespace


Copyright Property

[image]

Sandcastle Help File Builder Documentation
AjaxDocPlugIn..::.Copyright Property
AjaxDocPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns the copyright information for the plug-in.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public string Copyright { get; }
Visual Basic (Declaration)
Public ReadOnly Property Copyright As String

Implements

IPlugIn..::.Copyright

See Also

AjaxDocPlugIn Class
SandcastleBuilder.PlugIns Namespace


Description Property

[image]

Sandcastle Help File Builder Documentation
AjaxDocPlugIn..::.Description Property
AjaxDocPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns a brief description of the plug-in

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public string Description { get; }
Visual Basic (Declaration)
Public ReadOnly Property Description As String

Implements

IPlugIn..::.Description

See Also

AjaxDocPlugIn Class
SandcastleBuilder.PlugIns Namespace


ExecutionPoints Property

[image]

Sandcastle Help File Builder Documentation
AjaxDocPlugIn..::.ExecutionPoints Property
AjaxDocPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns a collection of execution points that define when the plug-in should be invoked during the build process.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public ExecutionPointCollection ExecutionPoints { get; }
Visual Basic (Declaration)
Public ReadOnly Property ExecutionPoints As ExecutionPointCollection

Implements

IPlugIn..::.ExecutionPoints

See Also

AjaxDocPlugIn Class
SandcastleBuilder.PlugIns Namespace


Name Property

[image]

Sandcastle Help File Builder Documentation
AjaxDocPlugIn..::.Name Property
AjaxDocPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns a friendly name for the plug-in

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String

Implements

IPlugIn..::.Name

See Also

AjaxDocPlugIn Class
SandcastleBuilder.PlugIns Namespace


RunsInPartialBuild Property

[image]

Sandcastle Help File Builder Documentation
AjaxDocPlugIn..::.RunsInPartialBuild Property
AjaxDocPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This plug-in runs in partial builds

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public bool RunsInPartialBuild { get; }
Visual Basic (Declaration)
Public ReadOnly Property RunsInPartialBuild As Boolean

Implements

IPlugIn..::.RunsInPartialBuild

See Also

AjaxDocPlugIn Class
SandcastleBuilder.PlugIns Namespace


Version Property

[image]

Sandcastle Help File Builder Documentation
AjaxDocPlugIn..::.Version Property
AjaxDocPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns the version of the plug-in

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public Version Version { get; }
Visual Basic (Declaration)
Public ReadOnly Property Version As Version

Implements

IPlugIn..::.Version

See Also

AjaxDocPlugIn Class
SandcastleBuilder.PlugIns Namespace


BibliographySupportPlugIn Class

[image]

Sandcastle Help File Builder Documentation
BibliographySupportPlugIn Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This plug-in class is used to add bibliography support to the topics

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public class BibliographySupportPlugIn : IPlugIn,
    IDisposable
Visual Basic (Declaration)
Public Class BibliographySupportPlugIn _
    Implements IPlugIn, IDisposable

Inheritance Hierarchy

System..::.Object
SandcastleBuilder.PlugIns..::.BibliographySupportPlugIn

See Also

BibliographySupportPlugIn Members
SandcastleBuilder.PlugIns Namespace


BibliographySupportPlugIn Members

[image] [image]

Sandcastle Help File Builder Documentation
BibliographySupportPlugIn Members
BibliographySupportPlugIn Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BibliographySupportPlugIn type exposes the following members.

Constructors

Name | Description
BibliographySupportPlugIn | Initializes a new instance of the BibliographySupportPlugIn class

Methods

Name | Description
ConfigurePlugIn | This method is used by the Sandcastle Help File Builder to let the plug-in perform its own configuration.
Dispose | Overloaded. There are two overloads for this method.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | This method is used to execute the plug-in during the build process
Finalize | This handles garbage collection to ensure proper disposal of the plug-in if not done explicity with Dispose()()(). (Overrides Object..::.Finalize()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Initialize | This method is used to initialize the plug-in at the start of the build process.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Copyright | This read-only property returns the copyright information for the plug-in.
Description | This read-only property returns a brief description of the plug-in
ExecutionPoints | This read-only property returns a collection of execution points that define when the plug-in should be invoked during the build process.
Name | This read-only property returns a friendly name for the plug-in
RunsInPartialBuild | This plug-in runs in partial builds
Version | This read-only property returns the version of the plug-in

See Also

BibliographySupportPlugIn Class
SandcastleBuilder.PlugIns Namespace


BibliographySupportPlugIn Constructor

[image]

Sandcastle Help File Builder Documentation
BibliographySupportPlugIn Constructor
BibliographySupportPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the BibliographySupportPlugIn class

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public BibliographySupportPlugIn()
Visual Basic (Declaration)
Public Sub New

See Also

BibliographySupportPlugIn Class
SandcastleBuilder.PlugIns Namespace


BibliographySupportPlugIn Methods

[image] [image]

Sandcastle Help File Builder Documentation
BibliographySupportPlugIn Methods
BibliographySupportPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BibliographySupportPlugIn type exposes the following members.

Methods

Name | Description
ConfigurePlugIn | This method is used by the Sandcastle Help File Builder to let the plug-in perform its own configuration.
Dispose | Overloaded. There are two overloads for this method.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | This method is used to execute the plug-in during the build process
Finalize | This handles garbage collection to ensure proper disposal of the plug-in if not done explicity with Dispose()()(). (Overrides Object..::.Finalize()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Initialize | This method is used to initialize the plug-in at the start of the build process.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BibliographySupportPlugIn Class
SandcastleBuilder.PlugIns Namespace


ConfigurePlugIn Method

[image]

Sandcastle Help File Builder Documentation
BibliographySupportPlugIn..::.ConfigurePlugIn Method
BibliographySupportPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This method is used by the Sandcastle Help File Builder to let the plug-in perform its own configuration.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public string ConfigurePlugIn(
    SandcastleProject project,
    string currentConfig
)
Visual Basic (Declaration)
Public Function ConfigurePlugIn ( _
    project As SandcastleProject, _
    currentConfig As String _
) As String

Parameters

project
Type: SandcastleBuilder.Utils..::.SandcastleProject
A reference to the active project
currentConfig
Type: System..::.String
The current configuration XML fragment

Return Value

A string containing the new configuration XML fragment

Implements

IPlugIn..::.ConfigurePlugIn(SandcastleProject, String)

Remarks

The configuration data will be stored in the help file builder project.

See Also

BibliographySupportPlugIn Class
SandcastleBuilder.PlugIns Namespace


Dispose Method

[image] [image]

Sandcastle Help File Builder Documentation
BibliographySupportPlugIn..::.Dispose Method
BibliographySupportPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

There are two overloads for this method.

Overload List

Name | Description
Dispose()()() | This implements the Dispose() interface to properly dispose of the plug-in object.
Dispose(Boolean) | This can be overridden by derived classes to add their own disposal code if necessary.

See Also

BibliographySupportPlugIn Class
BibliographySupportPlugIn Members
SandcastleBuilder.PlugIns Namespace


Dispose Method

[image]

Sandcastle Help File Builder Documentation
BibliographySupportPlugIn..::.Dispose Method
BibliographySupportPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This implements the Dispose() interface to properly dispose of the plug-in object.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose

Implements

IDisposable..::.Dispose()()()

See Also

BibliographySupportPlugIn Class
Dispose Overload
SandcastleBuilder.PlugIns Namespace


Dispose Method (Boolean)

[image]

Sandcastle Help File Builder Documentation
BibliographySupportPlugIn..::.Dispose Method (Boolean)
BibliographySupportPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This can be overridden by derived classes to add their own disposal code if necessary.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
protected virtual void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overridable Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
Pass true to dispose of the managed and unmanaged resources or false to just dispose of the unmanaged resources.

See Also

BibliographySupportPlugIn Class
Dispose Overload
SandcastleBuilder.PlugIns Namespace


Execute Method

[image]

Sandcastle Help File Builder Documentation
BibliographySupportPlugIn..::.Execute Method
BibliographySupportPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This method is used to execute the plug-in during the build process

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public void Execute(
    ExecutionContext context
)
Visual Basic (Declaration)
Public Sub Execute ( _
    context As ExecutionContext _
)

Parameters

context
Type: SandcastleBuilder.Utils.PlugIn..::.ExecutionContext
The current execution context

Implements

IPlugIn..::.Execute(ExecutionContext)

See Also

BibliographySupportPlugIn Class
SandcastleBuilder.PlugIns Namespace


Finalize Method

[image]

Sandcastle Help File Builder Documentation
BibliographySupportPlugIn..::.Finalize Method
BibliographySupportPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This handles garbage collection to ensure proper disposal of the plug-in if not done explicity with Dispose()()().

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
protected override void Finalize()
Visual Basic (Declaration)
Protected Overrides Sub Finalize

See Also

BibliographySupportPlugIn Class
SandcastleBuilder.PlugIns Namespace


Initialize Method

[image]

Sandcastle Help File Builder Documentation
BibliographySupportPlugIn..::.Initialize Method
BibliographySupportPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This method is used to initialize the plug-in at the start of the build process.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public void Initialize(
    BuildProcess buildProcess,
    XPathNavigator configuration
)
Visual Basic (Declaration)
Public Sub Initialize ( _
    buildProcess As BuildProcess, _
    configuration As XPathNavigator _
)

Parameters

buildProcess
Type: SandcastleBuilder.Utils.BuildEngine..::.BuildProcess
A reference to the current build process.
configuration
Type: System.Xml.XPath..::.XPathNavigator
The configuration data that the plug-in should use to initialize itself.

Implements

IPlugIn..::.Initialize(BuildProcess, XPathNavigator)

See Also

BibliographySupportPlugIn Class
SandcastleBuilder.PlugIns Namespace


BibliographySupportPlugIn Properties

[image] [image]

Sandcastle Help File Builder Documentation
BibliographySupportPlugIn Properties
BibliographySupportPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BibliographySupportPlugIn type exposes the following members.

Properties

Name | Description
Copyright | This read-only property returns the copyright information for the plug-in.
Description | This read-only property returns a brief description of the plug-in
ExecutionPoints | This read-only property returns a collection of execution points that define when the plug-in should be invoked during the build process.
Name | This read-only property returns a friendly name for the plug-in
RunsInPartialBuild | This plug-in runs in partial builds
Version | This read-only property returns the version of the plug-in

See Also

BibliographySupportPlugIn Class
SandcastleBuilder.PlugIns Namespace


Copyright Property

[image]

Sandcastle Help File Builder Documentation
BibliographySupportPlugIn..::.Copyright Property
BibliographySupportPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns the copyright information for the plug-in.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public string Copyright { get; }
Visual Basic (Declaration)
Public ReadOnly Property Copyright As String

Implements

IPlugIn..::.Copyright

See Also

BibliographySupportPlugIn Class
SandcastleBuilder.PlugIns Namespace


Description Property

[image]

Sandcastle Help File Builder Documentation
BibliographySupportPlugIn..::.Description Property
BibliographySupportPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns a brief description of the plug-in

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public string Description { get; }
Visual Basic (Declaration)
Public ReadOnly Property Description As String

Implements

IPlugIn..::.Description

See Also

BibliographySupportPlugIn Class
SandcastleBuilder.PlugIns Namespace


ExecutionPoints Property

[image]

Sandcastle Help File Builder Documentation
BibliographySupportPlugIn..::.ExecutionPoints Property
BibliographySupportPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns a collection of execution points that define when the plug-in should be invoked during the build process.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public ExecutionPointCollection ExecutionPoints { get; }
Visual Basic (Declaration)
Public ReadOnly Property ExecutionPoints As ExecutionPointCollection

Implements

IPlugIn..::.ExecutionPoints

See Also

BibliographySupportPlugIn Class
SandcastleBuilder.PlugIns Namespace


Name Property

[image]

Sandcastle Help File Builder Documentation
BibliographySupportPlugIn..::.Name Property
BibliographySupportPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns a friendly name for the plug-in

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String

Implements

IPlugIn..::.Name

See Also

BibliographySupportPlugIn Class
SandcastleBuilder.PlugIns Namespace


RunsInPartialBuild Property

[image]

Sandcastle Help File Builder Documentation
BibliographySupportPlugIn..::.RunsInPartialBuild Property
BibliographySupportPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This plug-in runs in partial builds

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public bool RunsInPartialBuild { get; }
Visual Basic (Declaration)
Public ReadOnly Property RunsInPartialBuild As Boolean

Implements

IPlugIn..::.RunsInPartialBuild

See Also

BibliographySupportPlugIn Class
SandcastleBuilder.PlugIns Namespace


Version Property

[image]

Sandcastle Help File Builder Documentation
BibliographySupportPlugIn..::.Version Property
BibliographySupportPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns the version of the plug-in

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public Version Version { get; }
Visual Basic (Declaration)
Public ReadOnly Property Version As Version

Implements

IPlugIn..::.Version

See Also

BibliographySupportPlugIn Class
SandcastleBuilder.PlugIns Namespace


BindingRedirectResolverPlugIn Class

[image]

Sandcastle Help File Builder Documentation
BindingRedirectResolverPlugIn Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This plug-in class is used to add assembly binding redirection support to the MRefBuilder configuration file.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public class BindingRedirectResolverPlugIn : IPlugIn,
    IDisposable
Visual Basic (Declaration)
Public Class BindingRedirectResolverPlugIn _
    Implements IPlugIn, IDisposable

Inheritance Hierarchy

System..::.Object
SandcastleBuilder.PlugIns..::.BindingRedirectResolverPlugIn

See Also

BindingRedirectResolverPlugIn Members
SandcastleBuilder.PlugIns Namespace


BindingRedirectResolverPlugIn Members

[image] [image]

Sandcastle Help File Builder Documentation
BindingRedirectResolverPlugIn Members
BindingRedirectResolverPlugIn Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BindingRedirectResolverPlugIn type exposes the following members.

Constructors

Name | Description
BindingRedirectResolverPlugIn | Initializes a new instance of the BindingRedirectResolverPlugIn class

Methods

Name | Description
ConfigurePlugIn | This method is used by the Sandcastle Help File Builder to let the plug-in perform its own configuration.
Dispose | Overloaded. There are two overloads for this method.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | This method is used to execute the plug-in during the build process
Finalize | This handles garbage collection to ensure proper disposal of the plug-in if not done explicity with Dispose()()(). (Overrides Object..::.Finalize()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Initialize | This method is used to initialize the plug-in at the start of the build process.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Copyright | This read-only property returns the copyright information for the plug-in.
Description | This read-only property returns a brief description of the plug-in
ExecutionPoints | This read-only property returns a collection of execution points that define when the plug-in should be invoked during the build process.
Name | This read-only property returns a friendly name for the plug-in
RunsInPartialBuild | This plug-in runs in partial builds
Version | This read-only property returns the version of the plug-in

See Also

BindingRedirectResolverPlugIn Class
SandcastleBuilder.PlugIns Namespace


BindingRedirectResolverPlugIn Constructor

[image]

Sandcastle Help File Builder Documentation
BindingRedirectResolverPlugIn Constructor
BindingRedirectResolverPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the BindingRedirectResolverPlugIn class

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public BindingRedirectResolverPlugIn()
Visual Basic (Declaration)
Public Sub New

See Also

BindingRedirectResolverPlugIn Class
SandcastleBuilder.PlugIns Namespace


BindingRedirectResolverPlugIn Methods

[image] [image]

Sandcastle Help File Builder Documentation
BindingRedirectResolverPlugIn Methods
BindingRedirectResolverPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BindingRedirectResolverPlugIn type exposes the following members.

Methods

Name | Description
ConfigurePlugIn | This method is used by the Sandcastle Help File Builder to let the plug-in perform its own configuration.
Dispose | Overloaded. There are two overloads for this method.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | This method is used to execute the plug-in during the build process
Finalize | This handles garbage collection to ensure proper disposal of the plug-in if not done explicity with Dispose()()(). (Overrides Object..::.Finalize()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Initialize | This method is used to initialize the plug-in at the start of the build process.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BindingRedirectResolverPlugIn Class
SandcastleBuilder.PlugIns Namespace


ConfigurePlugIn Method

[image]

Sandcastle Help File Builder Documentation
BindingRedirectResolverPlugIn..::.ConfigurePlugIn Method
BindingRedirectResolverPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This method is used by the Sandcastle Help File Builder to let the plug-in perform its own configuration.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public string ConfigurePlugIn(
    SandcastleProject project,
    string currentConfig
)
Visual Basic (Declaration)
Public Function ConfigurePlugIn ( _
    project As SandcastleProject, _
    currentConfig As String _
) As String

Parameters

project
Type: SandcastleBuilder.Utils..::.SandcastleProject
A reference to the active project
currentConfig
Type: System..::.String
The current configuration XML fragment

Return Value

A string containing the new configuration XML fragment

Implements

IPlugIn..::.ConfigurePlugIn(SandcastleProject, String)

Remarks

The configuration data will be stored in the help file builder project.

See Also

BindingRedirectResolverPlugIn Class
SandcastleBuilder.PlugIns Namespace


Dispose Method

[image] [image]

Sandcastle Help File Builder Documentation
BindingRedirectResolverPlugIn..::.Dispose Method
BindingRedirectResolverPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

There are two overloads for this method.

Overload List

Name | Description
Dispose()()() | This implements the Dispose() interface to properly dispose of the plug-in object.
Dispose(Boolean) | This can be overridden by derived classes to add their own disposal code if necessary.

See Also

BindingRedirectResolverPlugIn Class
BindingRedirectResolverPlugIn Members
SandcastleBuilder.PlugIns Namespace


Dispose Method

[image]

Sandcastle Help File Builder Documentation
BindingRedirectResolverPlugIn..::.Dispose Method
BindingRedirectResolverPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This implements the Dispose() interface to properly dispose of the plug-in object.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose

Implements

IDisposable..::.Dispose()()()

See Also

BindingRedirectResolverPlugIn Class
Dispose Overload
SandcastleBuilder.PlugIns Namespace


Dispose Method (Boolean)

[image]

Sandcastle Help File Builder Documentation
BindingRedirectResolverPlugIn..::.Dispose Method (Boolean)
BindingRedirectResolverPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This can be overridden by derived classes to add their own disposal code if necessary.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
protected virtual void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overridable Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
Pass true to dispose of the managed and unmanaged resources or false to just dispose of the unmanaged resources.

See Also

BindingRedirectResolverPlugIn Class
Dispose Overload
SandcastleBuilder.PlugIns Namespace


Execute Method

[image]

Sandcastle Help File Builder Documentation
BindingRedirectResolverPlugIn..::.Execute Method
BindingRedirectResolverPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This method is used to execute the plug-in during the build process

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public void Execute(
    ExecutionContext context
)
Visual Basic (Declaration)
Public Sub Execute ( _
    context As ExecutionContext _
)

Parameters

context
Type: SandcastleBuilder.Utils.PlugIn..::.ExecutionContext
The current execution context

Implements

IPlugIn..::.Execute(ExecutionContext)

See Also

BindingRedirectResolverPlugIn Class
SandcastleBuilder.PlugIns Namespace


Finalize Method

[image]

Sandcastle Help File Builder Documentation
BindingRedirectResolverPlugIn..::.Finalize Method
BindingRedirectResolverPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This handles garbage collection to ensure proper disposal of the plug-in if not done explicity with Dispose()()().

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
protected override void Finalize()
Visual Basic (Declaration)
Protected Overrides Sub Finalize

See Also

BindingRedirectResolverPlugIn Class
SandcastleBuilder.PlugIns Namespace


Initialize Method

[image]

Sandcastle Help File Builder Documentation
BindingRedirectResolverPlugIn..::.Initialize Method
BindingRedirectResolverPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This method is used to initialize the plug-in at the start of the build process.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public void Initialize(
    BuildProcess buildProcess,
    XPathNavigator configuration
)
Visual Basic (Declaration)
Public Sub Initialize ( _
    buildProcess As BuildProcess, _
    configuration As XPathNavigator _
)

Parameters

buildProcess
Type: SandcastleBuilder.Utils.BuildEngine..::.BuildProcess
A reference to the current build process.
configuration
Type: System.Xml.XPath..::.XPathNavigator
The configuration data that the plug-in should use to initialize itself.

Implements

IPlugIn..::.Initialize(BuildProcess, XPathNavigator)

See Also

BindingRedirectResolverPlugIn Class
SandcastleBuilder.PlugIns Namespace


BindingRedirectResolverPlugIn Properties

[image] [image]

Sandcastle Help File Builder Documentation
BindingRedirectResolverPlugIn Properties
BindingRedirectResolverPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BindingRedirectResolverPlugIn type exposes the following members.

Properties

Name | Description
Copyright | This read-only property returns the copyright information for the plug-in.
Description | This read-only property returns a brief description of the plug-in
ExecutionPoints | This read-only property returns a collection of execution points that define when the plug-in should be invoked during the build process.
Name | This read-only property returns a friendly name for the plug-in
RunsInPartialBuild | This plug-in runs in partial builds
Version | This read-only property returns the version of the plug-in

See Also

BindingRedirectResolverPlugIn Class
SandcastleBuilder.PlugIns Namespace


Copyright Property

[image]

Sandcastle Help File Builder Documentation
BindingRedirectResolverPlugIn..::.Copyright Property
BindingRedirectResolverPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns the copyright information for the plug-in.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public string Copyright { get; }
Visual Basic (Declaration)
Public ReadOnly Property Copyright As String

Implements

IPlugIn..::.Copyright

See Also

BindingRedirectResolverPlugIn Class
SandcastleBuilder.PlugIns Namespace


Description Property

[image]

Sandcastle Help File Builder Documentation
BindingRedirectResolverPlugIn..::.Description Property
BindingRedirectResolverPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns a brief description of the plug-in

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public string Description { get; }
Visual Basic (Declaration)
Public ReadOnly Property Description As String

Implements

IPlugIn..::.Description

See Also

BindingRedirectResolverPlugIn Class
SandcastleBuilder.PlugIns Namespace


ExecutionPoints Property

[image]

Sandcastle Help File Builder Documentation
BindingRedirectResolverPlugIn..::.ExecutionPoints Property
BindingRedirectResolverPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns a collection of execution points that define when the plug-in should be invoked during the build process.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public ExecutionPointCollection ExecutionPoints { get; }
Visual Basic (Declaration)
Public ReadOnly Property ExecutionPoints As ExecutionPointCollection

Implements

IPlugIn..::.ExecutionPoints

See Also

BindingRedirectResolverPlugIn Class
SandcastleBuilder.PlugIns Namespace


Name Property

[image]

Sandcastle Help File Builder Documentation
BindingRedirectResolverPlugIn..::.Name Property
BindingRedirectResolverPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns a friendly name for the plug-in

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String

Implements

IPlugIn..::.Name

See Also

BindingRedirectResolverPlugIn Class
SandcastleBuilder.PlugIns Namespace


RunsInPartialBuild Property

[image]

Sandcastle Help File Builder Documentation
BindingRedirectResolverPlugIn..::.RunsInPartialBuild Property
BindingRedirectResolverPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This plug-in runs in partial builds

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public bool RunsInPartialBuild { get; }
Visual Basic (Declaration)
Public ReadOnly Property RunsInPartialBuild As Boolean

Implements

IPlugIn..::.RunsInPartialBuild

See Also

BindingRedirectResolverPlugIn Class
SandcastleBuilder.PlugIns Namespace


Version Property

[image]

Sandcastle Help File Builder Documentation
BindingRedirectResolverPlugIn..::.Version Property
BindingRedirectResolverPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns the version of the plug-in

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public Version Version { get; }
Visual Basic (Declaration)
Public ReadOnly Property Version As Version

Implements

IPlugIn..::.Version

See Also

BindingRedirectResolverPlugIn Class
SandcastleBuilder.PlugIns Namespace


BindingRedirectSettings Class

[image]

Sandcastle Help File Builder Documentation
BindingRedirectSettings Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This represents binding redirection settings for the BindingRedirectResolverPlugIn.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public class BindingRedirectSettings
Visual Basic (Declaration)
Public Class BindingRedirectSettings

Inheritance Hierarchy

System..::.Object
SandcastleBuilder.PlugIns..::.BindingRedirectSettings

See Also

BindingRedirectSettings Members
SandcastleBuilder.PlugIns Namespace


BindingRedirectSettings Members

[image] [image]

Sandcastle Help File Builder Documentation
BindingRedirectSettings Members
BindingRedirectSettings Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BindingRedirectSettings type exposes the following members.

Constructors

Name | Description
BindingRedirectSettings | Constructor

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromXPathNavigator | Create a binding redirect settings instance from an XPath navigator containing the settings.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | This returns a string representation of the item (Overrides Object..::.ToString()()().)
ToXml | Store the binding redirect settings as a node in the given XML document.

Properties

Name | Description
AssemblyName | This is used to get or set the assembly name (no extension)
ConfigurationFile | This is used to get or set the path to the configuration file from which the settings should be imported.
Culture | This is used to get or set the culture for the assembly
NewVersion | This is used to get or set the new version number to which the old versions are redirected.
OldVersion | This is used to get or set the old version number to redirect to the new version number.
OldVersionTo | This is used to get or set the ending old version number range to redirect to the new version number.
PublicKeyToken | This is used to get or set the public key token for the assembly

See Also

BindingRedirectSettings Class
SandcastleBuilder.PlugIns Namespace


BindingRedirectSettings Constructor

[image]

Sandcastle Help File Builder Documentation
BindingRedirectSettings Constructor
BindingRedirectSettings Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public BindingRedirectSettings(
    IBasePathProvider provider
)
Visual Basic (Declaration)
Public Sub New ( _
    provider As IBasePathProvider _
)

Parameters

provider
Type: SandcastleBuilder.Utils..::.IBasePathProvider
The base path provider

See Also

BindingRedirectSettings Class
SandcastleBuilder.PlugIns Namespace


BindingRedirectSettings Methods

[image] [image]

Sandcastle Help File Builder Documentation
BindingRedirectSettings Methods
BindingRedirectSettings Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BindingRedirectSettings type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromXPathNavigator | Create a binding redirect settings instance from an XPath navigator containing the settings.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | This returns a string representation of the item (Overrides Object..::.ToString()()().)
ToXml | Store the binding redirect settings as a node in the given XML document.

See Also

BindingRedirectSettings Class
SandcastleBuilder.PlugIns Namespace


FromXPathNavigator Method

[image]

Sandcastle Help File Builder Documentation
BindingRedirectSettings..::.FromXPathNavigator Method
BindingRedirectSettings Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Create a binding redirect settings instance from an XPath navigator containing the settings.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public static BindingRedirectSettings FromXPathNavigator(
    IBasePathProvider pathProvider,
    XPathNavigator navigator
)
Visual Basic (Declaration)
Public Shared Function FromXPathNavigator ( _
    pathProvider As IBasePathProvider, _
    navigator As XPathNavigator _
) As BindingRedirectSettings

Parameters

pathProvider
Type: SandcastleBuilder.Utils..::.IBasePathProvider
The base path provider object
navigator
Type: System.Xml.XPath..::.XPathNavigator
The XPath navigator from which to obtain the settings.

Return Value

A BindingRedirectSettings object containing the settings from the XPath navigator.

Remarks

It should contain an element called dependentAssembly with a configFile attribute or a nested assemblyIdentity and bindingRedirect element that define the settings.

See Also

BindingRedirectSettings Class
SandcastleBuilder.PlugIns Namespace


ToString Method

[image]

Sandcastle Help File Builder Documentation
BindingRedirectSettings..::.ToString Method
BindingRedirectSettings Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This returns a string representation of the item

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

Return Value

The item value as a string

See Also

BindingRedirectSettings Class
SandcastleBuilder.PlugIns Namespace


ToXml Method

[image]

Sandcastle Help File Builder Documentation
BindingRedirectSettings..::.ToXml Method
BindingRedirectSettings Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Store the binding redirect settings as a node in the given XML document.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public XmlNode ToXml(
    XmlDocument config,
    XmlNode root
)
Visual Basic (Declaration)
Public Function ToXml ( _
    config As XmlDocument, _
    root As XmlNode _
) As XmlNode

Parameters

config
Type: System.Xml..::.XmlDocument
The XML document
root
Type: System.Xml..::.XmlNode
The node in which to store the element

Return Value

Returns the node that was added.

Remarks

The settings are stored in an element called dependentAssembly.

See Also

BindingRedirectSettings Class
SandcastleBuilder.PlugIns Namespace


BindingRedirectSettings Properties

[image] [image]

Sandcastle Help File Builder Documentation
BindingRedirectSettings Properties
BindingRedirectSettings Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BindingRedirectSettings type exposes the following members.

Properties

Name | Description
AssemblyName | This is used to get or set the assembly name (no extension)
ConfigurationFile | This is used to get or set the path to the configuration file from which the settings should be imported.
Culture | This is used to get or set the culture for the assembly
NewVersion | This is used to get or set the new version number to which the old versions are redirected.
OldVersion | This is used to get or set the old version number to redirect to the new version number.
OldVersionTo | This is used to get or set the ending old version number range to redirect to the new version number.
PublicKeyToken | This is used to get or set the public key token for the assembly

See Also

BindingRedirectSettings Class
SandcastleBuilder.PlugIns Namespace


AssemblyName Property

[image]

Sandcastle Help File Builder Documentation
BindingRedirectSettings..::.AssemblyName Property
BindingRedirectSettings Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set the assembly name (no extension)

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public string AssemblyName { get; set; }
Visual Basic (Declaration)
Public Property AssemblyName As String

See Also

BindingRedirectSettings Class
SandcastleBuilder.PlugIns Namespace


ConfigurationFile Property

[image]

Sandcastle Help File Builder Documentation
BindingRedirectSettings..::.ConfigurationFile Property
BindingRedirectSettings Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set the path to the configuration file from which the settings should be imported.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public FilePath ConfigurationFile { get; set; }
Visual Basic (Declaration)
Public Property ConfigurationFile As FilePath

Field Value

If specified, the properties in the Binding Redirect category are ignored.

See Also

BindingRedirectSettings Class
SandcastleBuilder.PlugIns Namespace


Culture Property

[image]

Sandcastle Help File Builder Documentation
BindingRedirectSettings..::.Culture Property
BindingRedirectSettings Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set the culture for the assembly

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public string Culture { get; set; }
Visual Basic (Declaration)
Public Property Culture As String

Field Value

If omitted, "neutral" is assumed

See Also

BindingRedirectSettings Class
SandcastleBuilder.PlugIns Namespace


NewVersion Property

[image]

Sandcastle Help File Builder Documentation
BindingRedirectSettings..::.NewVersion Property
BindingRedirectSettings Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set the new version number to which the old versions are redirected.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public Version NewVersion { get; set; }
Visual Basic (Declaration)
Public Property NewVersion As Version

See Also

BindingRedirectSettings Class
SandcastleBuilder.PlugIns Namespace


OldVersion Property

[image]

Sandcastle Help File Builder Documentation
BindingRedirectSettings..::.OldVersion Property
BindingRedirectSettings Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set the old version number to redirect to the new version number.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public Version OldVersion { get; set; }
Visual Basic (Declaration)
Public Property OldVersion As Version

See Also

BindingRedirectSettings Class
SandcastleBuilder.PlugIns Namespace


OldVersionTo Property

[image]

Sandcastle Help File Builder Documentation
BindingRedirectSettings..::.OldVersionTo Property
BindingRedirectSettings Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set the ending old version number range to redirect to the new version number.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public Version OldVersionTo { get; set; }
Visual Basic (Declaration)
Public Property OldVersionTo As Version

Field Value

If not set, only OldVersion will be used to redirect a single version.

See Also

BindingRedirectSettings Class
SandcastleBuilder.PlugIns Namespace


PublicKeyToken Property

[image]

Sandcastle Help File Builder Documentation
BindingRedirectSettings..::.PublicKeyToken Property
BindingRedirectSettings Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set the public key token for the assembly

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public string PublicKeyToken { get; set; }
Visual Basic (Declaration)
Public Property PublicKeyToken As String

Field Value

If omitted, "null" is assumed

See Also

BindingRedirectSettings Class
SandcastleBuilder.PlugIns Namespace


BindingRedirectSettingsCollection Class

[image]

Sandcastle Help File Builder Documentation
BindingRedirectSettingsCollection Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This collection class is used to hold the binding redirect settings information for the BindingRedirectResolverPlugIn.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public class BindingRedirectSettingsCollection : BindingList<BindingRedirectSettings>
Visual Basic (Declaration)
Public Class BindingRedirectSettingsCollection _
    Inherits BindingList(Of BindingRedirectSettings)

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection <(Of <( BindingRedirectSettings >)>)
System.ComponentModel..::.BindingList <(Of <( BindingRedirectSettings >)>)
SandcastleBuilder.PlugIns..::.BindingRedirectSettingsCollection

See Also

BindingRedirectSettingsCollection Members
SandcastleBuilder.PlugIns Namespace


BindingRedirectSettingsCollection Members

[image] [image]

Sandcastle Help File Builder Documentation
BindingRedirectSettingsCollection Members
BindingRedirectSettingsCollection Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BindingRedirectSettingsCollection type exposes the following members.

Constructors

Name | Description
BindingRedirectSettingsCollection | Initializes a new instance of the BindingRedirectSettingsCollection class

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( BindingRedirectSettings >)>).)
AddNew | Adds a new item to the collection. (Inherited from BindingList <(Of <( BindingRedirectSettings >)>).)
AddNewCore | Adds a new item to the end of the collection. (Inherited from BindingList <(Of <( BindingRedirectSettings >)>).)
ApplySortCore | Sorts the items if overridden in a derived class; otherwise, throws a NotSupportedException. (Inherited from BindingList <(Of <( BindingRedirectSettings >)>).)
CancelNew | Discards a pending new item. (Inherited from BindingList <(Of <( BindingRedirectSettings >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( BindingRedirectSettings >)>).)
ClearItems | Removes all elements from the collection. (Inherited from BindingList <(Of <( BindingRedirectSettings >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( BindingRedirectSettings >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <( BindingRedirectSettings >)>).)
EndNew | Commits a pending new item to the collection. (Inherited from BindingList <(Of <( BindingRedirectSettings >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindCore | Searches for the index of the item that has the specified property descriptor with the specified value, if searching is implemented in a derived class; otherwise, a NotSupportedException. (Inherited from BindingList <(Of <( BindingRedirectSettings >)>).)
FromXml | This is used to load the binding redirect settings list from the configuration settings.
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( BindingRedirectSettings >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection <(Of <( BindingRedirectSettings >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( BindingRedirectSettings >)>).)
InsertItem | Inserts the specified item in the list at the specified index. (Inherited from BindingList <(Of <( BindingRedirectSettings >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnAddingNew | Raises the AddingNew event. (Inherited from BindingList <(Of <( BindingRedirectSettings >)>).)
OnListChanged | Raises the ListChanged event. (Inherited from BindingList <(Of <( BindingRedirectSettings >)>).)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( BindingRedirectSettings >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( BindingRedirectSettings >)>).)
RemoveItem | Removes the item at the specified index. (Inherited from BindingList <(Of <( BindingRedirectSettings >)>).)
RemoveSortCore | Removes any sort applied with ApplySortCore(PropertyDescriptor, ListSortDirection) if sorting is implemented in a derived class; otherwise, raises NotSupportedException. (Inherited from BindingList <(Of <( BindingRedirectSettings >)>).)
ResetBindings | Raises a ListChanged event of type Reset. (Inherited from BindingList <(Of <( BindingRedirectSettings >)>).)
ResetItem | Raises a ListChanged event of type ItemChanged for the item at the specified position. (Inherited from BindingList <(Of <( BindingRedirectSettings >)>).)
SetItem | Replaces the item at the specified index with the specified item. (Inherited from BindingList <(Of <( BindingRedirectSettings >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | This is used to save the binding redirect settings list to the configuration settings.

Properties

Name | Description
AllowEdit | Gets or sets a value indicating whether items in the list can be edited. (Inherited from BindingList <(Of <( BindingRedirectSettings >)>).)
AllowNew | Gets or sets a value indicating whether you can add items to the list using the AddNew()()() method. (Inherited from BindingList <(Of <( BindingRedirectSettings >)>).)
AllowRemove | Gets or sets a value indicating whether you can remove items from the collection. (Inherited from BindingList <(Of <( BindingRedirectSettings >)>).)
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( BindingRedirectSettings >)>).)
IsSortedCore | Gets a value indicating whether the list is sorted. (Inherited from BindingList <(Of <( BindingRedirectSettings >)>).)
Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <( BindingRedirectSettings >)>).)
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( BindingRedirectSettings >)>).)
RaiseListChangedEvents | Gets or sets a value indicating whether adding or removing items within the list raises ListChanged events. (Inherited from BindingList <(Of <( BindingRedirectSettings >)>).)
SortDirectionCore | Gets the direction the list is sorted. (Inherited from BindingList <(Of <( BindingRedirectSettings >)>).)
SortPropertyCore | Gets the property descriptor that is used for sorting the list if sorting is implemented in a derived class; otherwise, returns null. (Inherited from BindingList <(Of <( BindingRedirectSettings >)>).)
SupportsChangeNotificationCore | Gets a value indicating whether ListChanged events are enabled. (Inherited from BindingList <(Of <( BindingRedirectSettings >)>).)
SupportsSearchingCore | Gets a value indicating whether the list supports searching. (Inherited from BindingList <(Of <( BindingRedirectSettings >)>).)
SupportsSortingCore | Gets a value indicating whether the list supports sorting. (Inherited from BindingList <(Of <( BindingRedirectSettings >)>).)

Events

Name | Description
AddingNew | Occurs before an item is added to the list. (Inherited from BindingList <(Of <( BindingRedirectSettings >)>).)
ListChanged | Occurs when the list or an item in the list changes. (Inherited from BindingList <(Of <( BindingRedirectSettings >)>).)

See Also

BindingRedirectSettingsCollection Class
SandcastleBuilder.PlugIns Namespace


BindingRedirectSettingsCollection Constructor

[image]

Sandcastle Help File Builder Documentation
BindingRedirectSettingsCollection Constructor
BindingRedirectSettingsCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the BindingRedirectSettingsCollection class

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public BindingRedirectSettingsCollection()
Visual Basic (Declaration)
Public Sub New

See Also

BindingRedirectSettingsCollection Class
SandcastleBuilder.PlugIns Namespace


BindingRedirectSettingsCollection Methods

[image] [image]

Sandcastle Help File Builder Documentation
BindingRedirectSettingsCollection Methods
BindingRedirectSettingsCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BindingRedirectSettingsCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( BindingRedirectSettings >)>).)
AddNew | Adds a new item to the collection. (Inherited from BindingList <(Of <( BindingRedirectSettings >)>).)
AddNewCore | Adds a new item to the end of the collection. (Inherited from BindingList <(Of <( BindingRedirectSettings >)>).)
ApplySortCore | Sorts the items if overridden in a derived class; otherwise, throws a NotSupportedException. (Inherited from BindingList <(Of <( BindingRedirectSettings >)>).)
CancelNew | Discards a pending new item. (Inherited from BindingList <(Of <( BindingRedirectSettings >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( BindingRedirectSettings >)>).)
ClearItems | Removes all elements from the collection. (Inherited from BindingList <(Of <( BindingRedirectSettings >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( BindingRedirectSettings >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <( BindingRedirectSettings >)>).)
EndNew | Commits a pending new item to the collection. (Inherited from BindingList <(Of <( BindingRedirectSettings >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindCore | Searches for the index of the item that has the specified property descriptor with the specified value, if searching is implemented in a derived class; otherwise, a NotSupportedException. (Inherited from BindingList <(Of <( BindingRedirectSettings >)>).)
FromXml | This is used to load the binding redirect settings list from the configuration settings.
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( BindingRedirectSettings >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection <(Of <( BindingRedirectSettings >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( BindingRedirectSettings >)>).)
InsertItem | Inserts the specified item in the list at the specified index. (Inherited from BindingList <(Of <( BindingRedirectSettings >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnAddingNew | Raises the AddingNew event. (Inherited from BindingList <(Of <( BindingRedirectSettings >)>).)
OnListChanged | Raises the ListChanged event. (Inherited from BindingList <(Of <( BindingRedirectSettings >)>).)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( BindingRedirectSettings >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( BindingRedirectSettings >)>).)
RemoveItem | Removes the item at the specified index. (Inherited from BindingList <(Of <( BindingRedirectSettings >)>).)
RemoveSortCore | Removes any sort applied with ApplySortCore(PropertyDescriptor, ListSortDirection) if sorting is implemented in a derived class; otherwise, raises NotSupportedException. (Inherited from BindingList <(Of <( BindingRedirectSettings >)>).)
ResetBindings | Raises a ListChanged event of type Reset. (Inherited from BindingList <(Of <( BindingRedirectSettings >)>).)
ResetItem | Raises a ListChanged event of type ItemChanged for the item at the specified position. (Inherited from BindingList <(Of <( BindingRedirectSettings >)>).)
SetItem | Replaces the item at the specified index with the specified item. (Inherited from BindingList <(Of <( BindingRedirectSettings >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | This is used to save the binding redirect settings list to the configuration settings.

See Also

BindingRedirectSettingsCollection Class
SandcastleBuilder.PlugIns Namespace


FromXml Method

[image]

Sandcastle Help File Builder Documentation
BindingRedirectSettingsCollection..::.FromXml Method
BindingRedirectSettingsCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to load the binding redirect settings list from the configuration settings.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public void FromXml(
    IBasePathProvider pathProvider,
    XPathNavigator navigator
)
Visual Basic (Declaration)
Public Sub FromXml ( _
    pathProvider As IBasePathProvider, _
    navigator As XPathNavigator _
)

Parameters

pathProvider
Type: SandcastleBuilder.Utils..::.IBasePathProvider
The base path provider object
navigator
Type: System.Xml.XPath..::.XPathNavigator
The XPath navigator from which the information is loaded.

See Also

BindingRedirectSettingsCollection Class
SandcastleBuilder.PlugIns Namespace


ToXml Method

[image]

Sandcastle Help File Builder Documentation
BindingRedirectSettingsCollection..::.ToXml Method
BindingRedirectSettingsCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to save the binding redirect settings list to the configuration settings.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public void ToXml(
    XmlDocument config,
    XmlNode root
)
Visual Basic (Declaration)
Public Sub ToXml ( _
    config As XmlDocument, _
    root As XmlNode _
)

Parameters

config
Type: System.Xml..::.XmlDocument
The XML configuration document.
root
Type: System.Xml..::.XmlNode
The root configuration node

See Also

BindingRedirectSettingsCollection Class
SandcastleBuilder.PlugIns Namespace


BindingRedirectSettingsCollection Properties

[image] [image]

Sandcastle Help File Builder Documentation
BindingRedirectSettingsCollection Properties
BindingRedirectSettingsCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BindingRedirectSettingsCollection type exposes the following members.

Properties

Name | Description
AllowEdit | Gets or sets a value indicating whether items in the list can be edited. (Inherited from BindingList <(Of <( BindingRedirectSettings >)>).)
AllowNew | Gets or sets a value indicating whether you can add items to the list using the AddNew()()() method. (Inherited from BindingList <(Of <( BindingRedirectSettings >)>).)
AllowRemove | Gets or sets a value indicating whether you can remove items from the collection. (Inherited from BindingList <(Of <( BindingRedirectSettings >)>).)
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( BindingRedirectSettings >)>).)
IsSortedCore | Gets a value indicating whether the list is sorted. (Inherited from BindingList <(Of <( BindingRedirectSettings >)>).)
Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <( BindingRedirectSettings >)>).)
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( BindingRedirectSettings >)>).)
RaiseListChangedEvents | Gets or sets a value indicating whether adding or removing items within the list raises ListChanged events. (Inherited from BindingList <(Of <( BindingRedirectSettings >)>).)
SortDirectionCore | Gets the direction the list is sorted. (Inherited from BindingList <(Of <( BindingRedirectSettings >)>).)
SortPropertyCore | Gets the property descriptor that is used for sorting the list if sorting is implemented in a derived class; otherwise, returns null. (Inherited from BindingList <(Of <( BindingRedirectSettings >)>).)
SupportsChangeNotificationCore | Gets a value indicating whether ListChanged events are enabled. (Inherited from BindingList <(Of <( BindingRedirectSettings >)>).)
SupportsSearchingCore | Gets a value indicating whether the list supports searching. (Inherited from BindingList <(Of <( BindingRedirectSettings >)>).)
SupportsSortingCore | Gets a value indicating whether the list supports sorting. (Inherited from BindingList <(Of <( BindingRedirectSettings >)>).)

See Also

BindingRedirectSettingsCollection Class
SandcastleBuilder.PlugIns Namespace


BindingRedirectSettingsCollection Events

[image] [image]

Sandcastle Help File Builder Documentation
BindingRedirectSettingsCollection Events
BindingRedirectSettingsCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BindingRedirectSettingsCollection type exposes the following members.

Events

Name | Description
AddingNew | Occurs before an item is added to the list. (Inherited from BindingList <(Of <( BindingRedirectSettings >)>).)
ListChanged | Occurs when the list or an item in the list changes. (Inherited from BindingList <(Of <( BindingRedirectSettings >)>).)

See Also

BindingRedirectSettingsCollection Class
SandcastleBuilder.PlugIns Namespace


CompletionNotificationPlugIn Class

[image]

Sandcastle Help File Builder Documentation
CompletionNotificationPlugIn Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This plug-in class is designed to run after the build completes to send notification of the completion status via e-mail. The log file can be sent as an attachment.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public class CompletionNotificationPlugIn : IPlugIn,
    IDisposable
Visual Basic (Declaration)
Public Class CompletionNotificationPlugIn _
    Implements IPlugIn, IDisposable

Inheritance Hierarchy

System..::.Object
SandcastleBuilder.PlugIns..::.CompletionNotificationPlugIn

See Also

CompletionNotificationPlugIn Members
SandcastleBuilder.PlugIns Namespace


CompletionNotificationPlugIn Members

[image] [image]

Sandcastle Help File Builder Documentation
CompletionNotificationPlugIn Members
CompletionNotificationPlugIn Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The CompletionNotificationPlugIn type exposes the following members.

Constructors

Name | Description
CompletionNotificationPlugIn | Initializes a new instance of the CompletionNotificationPlugIn class

Methods

Name | Description
ConfigurePlugIn | This method is used by the Sandcastle Help File Builder to let the plug-in perform its own configuration.
Dispose | Overloaded. There are two overloads for this method.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | This method is used to execute the plug-in during the build process
Finalize | This handles garbage collection to ensure proper disposal of the plug-in if not done explicity with Dispose()()(). (Overrides Object..::.Finalize()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Initialize | This method is used to initialize the plug-in at the start of the build process.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Copyright | This read-only property returns the copyright information for the plug-in.
Description | This read-only property returns a brief description of the plug-in
ExecutionPoints | This read-only property returns a collection of execution points that define when the plug-in should be invoked during the build process.
Name | This read-only property returns a friendly name for the plug-in
RunsInPartialBuild | This plug-in does not run in partial builds
Version | This read-only property returns the version of the plug-in

See Also

CompletionNotificationPlugIn Class
SandcastleBuilder.PlugIns Namespace


CompletionNotificationPlugIn Constructor

[image]

Sandcastle Help File Builder Documentation
CompletionNotificationPlugIn Constructor
CompletionNotificationPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the CompletionNotificationPlugIn class

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public CompletionNotificationPlugIn()
Visual Basic (Declaration)
Public Sub New

See Also

CompletionNotificationPlugIn Class
SandcastleBuilder.PlugIns Namespace


CompletionNotificationPlugIn Methods

[image] [image]

Sandcastle Help File Builder Documentation
CompletionNotificationPlugIn Methods
CompletionNotificationPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The CompletionNotificationPlugIn type exposes the following members.

Methods

Name | Description
ConfigurePlugIn | This method is used by the Sandcastle Help File Builder to let the plug-in perform its own configuration.
Dispose | Overloaded. There are two overloads for this method.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | This method is used to execute the plug-in during the build process
Finalize | This handles garbage collection to ensure proper disposal of the plug-in if not done explicity with Dispose()()(). (Overrides Object..::.Finalize()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Initialize | This method is used to initialize the plug-in at the start of the build process.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CompletionNotificationPlugIn Class
SandcastleBuilder.PlugIns Namespace


ConfigurePlugIn Method

[image]

Sandcastle Help File Builder Documentation
CompletionNotificationPlugIn..::.ConfigurePlugIn Method
CompletionNotificationPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This method is used by the Sandcastle Help File Builder to let the plug-in perform its own configuration.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public string ConfigurePlugIn(
    SandcastleProject project,
    string currentConfig
)
Visual Basic (Declaration)
Public Function ConfigurePlugIn ( _
    project As SandcastleProject, _
    currentConfig As String _
) As String

Parameters

project
Type: SandcastleBuilder.Utils..::.SandcastleProject
A reference to the active project
currentConfig
Type: System..::.String
The current configuration XML fragment

Return Value

A string containing the new configuration XML fragment

Implements

IPlugIn..::.ConfigurePlugIn(SandcastleProject, String)

Remarks

The configuration data will be stored in the help file builder project.

See Also

CompletionNotificationPlugIn Class
SandcastleBuilder.PlugIns Namespace


Dispose Method

[image] [image]

Sandcastle Help File Builder Documentation
CompletionNotificationPlugIn..::.Dispose Method
CompletionNotificationPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

There are two overloads for this method.

Overload List

Name | Description
Dispose()()() | This implements the Dispose() interface to properly dispose of the plug-in object.
Dispose(Boolean) | This can be overridden by derived classes to add their own disposal code if necessary.

See Also

CompletionNotificationPlugIn Class
CompletionNotificationPlugIn Members
SandcastleBuilder.PlugIns Namespace


Dispose Method

[image]

Sandcastle Help File Builder Documentation
CompletionNotificationPlugIn..::.Dispose Method
CompletionNotificationPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This implements the Dispose() interface to properly dispose of the plug-in object.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose

Implements

IDisposable..::.Dispose()()()

See Also

CompletionNotificationPlugIn Class
Dispose Overload
SandcastleBuilder.PlugIns Namespace


Dispose Method (Boolean)

[image]

Sandcastle Help File Builder Documentation
CompletionNotificationPlugIn..::.Dispose Method (Boolean)
CompletionNotificationPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This can be overridden by derived classes to add their own disposal code if necessary.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
protected virtual void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overridable Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
Pass true to dispose of the managed and unmanaged resources or false to just dispose of the unmanaged resources.

See Also

CompletionNotificationPlugIn Class
Dispose Overload
SandcastleBuilder.PlugIns Namespace


Execute Method

[image]

Sandcastle Help File Builder Documentation
CompletionNotificationPlugIn..::.Execute Method
CompletionNotificationPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This method is used to execute the plug-in during the build process

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public void Execute(
    ExecutionContext context
)
Visual Basic (Declaration)
Public Sub Execute ( _
    context As ExecutionContext _
)

Parameters

context
Type: SandcastleBuilder.Utils.PlugIn..::.ExecutionContext
The current execution context

Implements

IPlugIn..::.Execute(ExecutionContext)

Remarks

Since this runs after completion of the build and the log file is closed, any progress messages reported here will not appear in it, just in the output window on the main form.

See Also

CompletionNotificationPlugIn Class
SandcastleBuilder.PlugIns Namespace


Finalize Method

[image]

Sandcastle Help File Builder Documentation
CompletionNotificationPlugIn..::.Finalize Method
CompletionNotificationPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This handles garbage collection to ensure proper disposal of the plug-in if not done explicity with Dispose()()().

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
protected override void Finalize()
Visual Basic (Declaration)
Protected Overrides Sub Finalize

See Also

CompletionNotificationPlugIn Class
SandcastleBuilder.PlugIns Namespace


Initialize Method

[image]

Sandcastle Help File Builder Documentation
CompletionNotificationPlugIn..::.Initialize Method
CompletionNotificationPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This method is used to initialize the plug-in at the start of the build process.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public void Initialize(
    BuildProcess buildProcess,
    XPathNavigator configuration
)
Visual Basic (Declaration)
Public Sub Initialize ( _
    buildProcess As BuildProcess, _
    configuration As XPathNavigator _
)

Parameters

buildProcess
Type: SandcastleBuilder.Utils.BuildEngine..::.BuildProcess
A reference to the current build process.
configuration
Type: System.Xml.XPath..::.XPathNavigator
The configuration data that the plug-in should use to initialize itself.

Implements

IPlugIn..::.Initialize(BuildProcess, XPathNavigator)

Exceptions

Exception | Condition
SandcastleBuilder.Utils..::.BuilderException | This is thrown if the plug-in configuration is not valid.

See Also

CompletionNotificationPlugIn Class
SandcastleBuilder.PlugIns Namespace


CompletionNotificationPlugIn Properties

[image] [image]

Sandcastle Help File Builder Documentation
CompletionNotificationPlugIn Properties
CompletionNotificationPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The CompletionNotificationPlugIn type exposes the following members.

Properties

Name | Description
Copyright | This read-only property returns the copyright information for the plug-in.
Description | This read-only property returns a brief description of the plug-in
ExecutionPoints | This read-only property returns a collection of execution points that define when the plug-in should be invoked during the build process.
Name | This read-only property returns a friendly name for the plug-in
RunsInPartialBuild | This plug-in does not run in partial builds
Version | This read-only property returns the version of the plug-in

See Also

CompletionNotificationPlugIn Class
SandcastleBuilder.PlugIns Namespace


Copyright Property

[image]

Sandcastle Help File Builder Documentation
CompletionNotificationPlugIn..::.Copyright Property
CompletionNotificationPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns the copyright information for the plug-in.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public string Copyright { get; }
Visual Basic (Declaration)
Public ReadOnly Property Copyright As String

Implements

IPlugIn..::.Copyright

See Also

CompletionNotificationPlugIn Class
SandcastleBuilder.PlugIns Namespace


Description Property

[image]

Sandcastle Help File Builder Documentation
CompletionNotificationPlugIn..::.Description Property
CompletionNotificationPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns a brief description of the plug-in

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public string Description { get; }
Visual Basic (Declaration)
Public ReadOnly Property Description As String

Implements

IPlugIn..::.Description

See Also

CompletionNotificationPlugIn Class
SandcastleBuilder.PlugIns Namespace


ExecutionPoints Property

[image]

Sandcastle Help File Builder Documentation
CompletionNotificationPlugIn..::.ExecutionPoints Property
CompletionNotificationPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns a collection of execution points that define when the plug-in should be invoked during the build process.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public ExecutionPointCollection ExecutionPoints { get; }
Visual Basic (Declaration)
Public ReadOnly Property ExecutionPoints As ExecutionPointCollection

Implements

IPlugIn..::.ExecutionPoints

See Also

CompletionNotificationPlugIn Class
SandcastleBuilder.PlugIns Namespace


Name Property

[image]

Sandcastle Help File Builder Documentation
CompletionNotificationPlugIn..::.Name Property
CompletionNotificationPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns a friendly name for the plug-in

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String

Implements

IPlugIn..::.Name

See Also

CompletionNotificationPlugIn Class
SandcastleBuilder.PlugIns Namespace


RunsInPartialBuild Property

[image]

Sandcastle Help File Builder Documentation
CompletionNotificationPlugIn..::.RunsInPartialBuild Property
CompletionNotificationPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This plug-in does not run in partial builds

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public bool RunsInPartialBuild { get; }
Visual Basic (Declaration)
Public ReadOnly Property RunsInPartialBuild As Boolean

Implements

IPlugIn..::.RunsInPartialBuild

See Also

CompletionNotificationPlugIn Class
SandcastleBuilder.PlugIns Namespace


Version Property

[image]

Sandcastle Help File Builder Documentation
CompletionNotificationPlugIn..::.Version Property
CompletionNotificationPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns the version of the plug-in

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public Version Version { get; }
Visual Basic (Declaration)
Public ReadOnly Property Version As Version

Implements

IPlugIn..::.Version

See Also

CompletionNotificationPlugIn Class
SandcastleBuilder.PlugIns Namespace


DbcsFixPlugIn Class

[image]

Sandcastle Help File Builder Documentation
DbcsFixPlugIn Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This plug-in class is designed to modify the HTML files and alter the build so as to overcome the encoding issues encountered when building Help 1.x (CHM) files for various foreign languages.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public class DbcsFixPlugIn : IPlugIn,
    IDisposable
Visual Basic (Declaration)
Public Class DbcsFixPlugIn _
    Implements IPlugIn, IDisposable

Remarks

This uses the Steel Bytes SBAppLocale tool to run the Help 1.x compiler using the correct locale.

Inheritance Hierarchy

System..::.Object
SandcastleBuilder.PlugIns..::.DbcsFixPlugIn

See Also

DbcsFixPlugIn Members
SandcastleBuilder.PlugIns Namespace


DbcsFixPlugIn Members

[image] [image]

Sandcastle Help File Builder Documentation
DbcsFixPlugIn Members
DbcsFixPlugIn Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DbcsFixPlugIn type exposes the following members.

Constructors

Name | Description
DbcsFixPlugIn | Initializes a new instance of the DbcsFixPlugIn class

Methods

Name | Description
ConfigurePlugIn | This method is used by the Sandcastle Help File Builder to let the plug-in perform its own configuration.
Dispose | Overloaded. There are two overloads for this method.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | This method is used to execute the plug-in during the build process
Finalize | This handles garbage collection to ensure proper disposal of the plug-in if not done explicity with Dispose()()(). (Overrides Object..::.Finalize()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Initialize | This method is used to initialize the plug-in at the start of the build process.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Copyright | This read-only property returns the copyright information for the plug-in.
Description | This read-only property returns a brief description of the plug-in
ExecutionPoints | This read-only property returns a collection of execution points that define when the plug-in should be invoked during the build process.
Name | This read-only property returns a friendly name for the plug-in
RunsInPartialBuild | This plug-in does not run in partial builds
Version | This read-only property returns the version of the plug-in

See Also

DbcsFixPlugIn Class
SandcastleBuilder.PlugIns Namespace


DbcsFixPlugIn Constructor

[image]

Sandcastle Help File Builder Documentation
DbcsFixPlugIn Constructor
DbcsFixPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the DbcsFixPlugIn class

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public DbcsFixPlugIn()
Visual Basic (Declaration)
Public Sub New

See Also

DbcsFixPlugIn Class
SandcastleBuilder.PlugIns Namespace


DbcsFixPlugIn Methods

[image] [image]

Sandcastle Help File Builder Documentation
DbcsFixPlugIn Methods
DbcsFixPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DbcsFixPlugIn type exposes the following members.

Methods

Name | Description
ConfigurePlugIn | This method is used by the Sandcastle Help File Builder to let the plug-in perform its own configuration.
Dispose | Overloaded. There are two overloads for this method.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | This method is used to execute the plug-in during the build process
Finalize | This handles garbage collection to ensure proper disposal of the plug-in if not done explicity with Dispose()()(). (Overrides Object..::.Finalize()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Initialize | This method is used to initialize the plug-in at the start of the build process.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DbcsFixPlugIn Class
SandcastleBuilder.PlugIns Namespace


ConfigurePlugIn Method

[image]

Sandcastle Help File Builder Documentation
DbcsFixPlugIn..::.ConfigurePlugIn Method
DbcsFixPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This method is used by the Sandcastle Help File Builder to let the plug-in perform its own configuration.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public string ConfigurePlugIn(
    SandcastleProject project,
    string currentConfig
)
Visual Basic (Declaration)
Public Function ConfigurePlugIn ( _
    project As SandcastleProject, _
    currentConfig As String _
) As String

Parameters

project
Type: SandcastleBuilder.Utils..::.SandcastleProject
A reference to the active project
currentConfig
Type: System..::.String
The current configuration XML fragment

Return Value

A string containing the new configuration XML fragment

Implements

IPlugIn..::.ConfigurePlugIn(SandcastleProject, String)

Remarks

The configuration data will be stored in the help file builder project.

See Also

DbcsFixPlugIn Class
SandcastleBuilder.PlugIns Namespace


Dispose Method

[image] [image]

Sandcastle Help File Builder Documentation
DbcsFixPlugIn..::.Dispose Method
DbcsFixPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

There are two overloads for this method.

Overload List

Name | Description
Dispose()()() | This implements the Dispose() interface to properly dispose of the plug-in object.
Dispose(Boolean) | This can be overridden by derived classes to add their own disposal code if necessary.

See Also

DbcsFixPlugIn Class
DbcsFixPlugIn Members
SandcastleBuilder.PlugIns Namespace


Dispose Method

[image]

Sandcastle Help File Builder Documentation
DbcsFixPlugIn..::.Dispose Method
DbcsFixPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This implements the Dispose() interface to properly dispose of the plug-in object.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose

Implements

IDisposable..::.Dispose()()()

See Also

DbcsFixPlugIn Class
Dispose Overload
SandcastleBuilder.PlugIns Namespace


Dispose Method (Boolean)

[image]

Sandcastle Help File Builder Documentation
DbcsFixPlugIn..::.Dispose Method (Boolean)
DbcsFixPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This can be overridden by derived classes to add their own disposal code if necessary.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
protected virtual void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overridable Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
Pass true to dispose of the managed and unmanaged resources or false to just dispose of the unmanaged resources.

See Also

DbcsFixPlugIn Class
Dispose Overload
SandcastleBuilder.PlugIns Namespace


Execute Method

[image]

Sandcastle Help File Builder Documentation
DbcsFixPlugIn..::.Execute Method
DbcsFixPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This method is used to execute the plug-in during the build process

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public void Execute(
    ExecutionContext context
)
Visual Basic (Declaration)
Public Sub Execute ( _
    context As ExecutionContext _
)

Parameters

context
Type: SandcastleBuilder.Utils.PlugIn..::.ExecutionContext
The current execution context

Implements

IPlugIn..::.Execute(ExecutionContext)

See Also

DbcsFixPlugIn Class
SandcastleBuilder.PlugIns Namespace


Finalize Method

[image]

Sandcastle Help File Builder Documentation
DbcsFixPlugIn..::.Finalize Method
DbcsFixPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This handles garbage collection to ensure proper disposal of the plug-in if not done explicity with Dispose()()().

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
protected override void Finalize()
Visual Basic (Declaration)
Protected Overrides Sub Finalize

See Also

DbcsFixPlugIn Class
SandcastleBuilder.PlugIns Namespace


Initialize Method

[image]

Sandcastle Help File Builder Documentation
DbcsFixPlugIn..::.Initialize Method
DbcsFixPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This method is used to initialize the plug-in at the start of the build process.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public void Initialize(
    BuildProcess buildProcess,
    XPathNavigator configuration
)
Visual Basic (Declaration)
Public Sub Initialize ( _
    buildProcess As BuildProcess, _
    configuration As XPathNavigator _
)

Parameters

buildProcess
Type: SandcastleBuilder.Utils.BuildEngine..::.BuildProcess
A reference to the current build process.
configuration
Type: System.Xml.XPath..::.XPathNavigator
The configuration data that the plug-in should use to initialize itself.

Implements

IPlugIn..::.Initialize(BuildProcess, XPathNavigator)

See Also

DbcsFixPlugIn Class
SandcastleBuilder.PlugIns Namespace


DbcsFixPlugIn Properties

[image] [image]

Sandcastle Help File Builder Documentation
DbcsFixPlugIn Properties
DbcsFixPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DbcsFixPlugIn type exposes the following members.

Properties

Name | Description
Copyright | This read-only property returns the copyright information for the plug-in.
Description | This read-only property returns a brief description of the plug-in
ExecutionPoints | This read-only property returns a collection of execution points that define when the plug-in should be invoked during the build process.
Name | This read-only property returns a friendly name for the plug-in
RunsInPartialBuild | This plug-in does not run in partial builds
Version | This read-only property returns the version of the plug-in

See Also

DbcsFixPlugIn Class
SandcastleBuilder.PlugIns Namespace


Copyright Property

[image]

Sandcastle Help File Builder Documentation
DbcsFixPlugIn..::.Copyright Property
DbcsFixPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns the copyright information for the plug-in.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public string Copyright { get; }
Visual Basic (Declaration)
Public ReadOnly Property Copyright As String

Implements

IPlugIn..::.Copyright

See Also

DbcsFixPlugIn Class
SandcastleBuilder.PlugIns Namespace


Description Property

[image]

Sandcastle Help File Builder Documentation
DbcsFixPlugIn..::.Description Property
DbcsFixPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns a brief description of the plug-in

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public string Description { get; }
Visual Basic (Declaration)
Public ReadOnly Property Description As String

Implements

IPlugIn..::.Description

See Also

DbcsFixPlugIn Class
SandcastleBuilder.PlugIns Namespace


ExecutionPoints Property

[image]

Sandcastle Help File Builder Documentation
DbcsFixPlugIn..::.ExecutionPoints Property
DbcsFixPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns a collection of execution points that define when the plug-in should be invoked during the build process.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public ExecutionPointCollection ExecutionPoints { get; }
Visual Basic (Declaration)
Public ReadOnly Property ExecutionPoints As ExecutionPointCollection

Implements

IPlugIn..::.ExecutionPoints

See Also

DbcsFixPlugIn Class
SandcastleBuilder.PlugIns Namespace


Name Property

[image]

Sandcastle Help File Builder Documentation
DbcsFixPlugIn..::.Name Property
DbcsFixPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns a friendly name for the plug-in

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String

Implements

IPlugIn..::.Name

See Also

DbcsFixPlugIn Class
SandcastleBuilder.PlugIns Namespace


RunsInPartialBuild Property

[image]

Sandcastle Help File Builder Documentation
DbcsFixPlugIn..::.RunsInPartialBuild Property
DbcsFixPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This plug-in does not run in partial builds

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public bool RunsInPartialBuild { get; }
Visual Basic (Declaration)
Public ReadOnly Property RunsInPartialBuild As Boolean

Implements

IPlugIn..::.RunsInPartialBuild

See Also

DbcsFixPlugIn Class
SandcastleBuilder.PlugIns Namespace


Version Property

[image]

Sandcastle Help File Builder Documentation
DbcsFixPlugIn..::.Version Property
DbcsFixPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns the version of the plug-in

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public Version Version { get; }
Visual Basic (Declaration)
Public ReadOnly Property Version As Version

Implements

IPlugIn..::.Version

See Also

DbcsFixPlugIn Class
SandcastleBuilder.PlugIns Namespace


DeploymentLocation Class

[image]

Sandcastle Help File Builder Documentation
DeploymentLocation Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This represents a deployment location

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public class DeploymentLocation
Visual Basic (Declaration)
Public Class DeploymentLocation

Inheritance Hierarchy

System..::.Object
SandcastleBuilder.PlugIns..::.DeploymentLocation

See Also

DeploymentLocation Members
SandcastleBuilder.PlugIns Namespace


DeploymentLocation Members

[image] [image]

Sandcastle Help File Builder Documentation
DeploymentLocation Members
DeploymentLocation Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DeploymentLocation type exposes the following members.

Constructors

Name | Description
DeploymentLocation | Overloaded. There are two overloads for the constructor

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromXPathNavigator | Create a deployment location instance from an XPath navigator containing the settings.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | Store the deployment location as a node in the given XML document

Properties

Name | Description
Location | The location to which the help file is deployed
ProxyCredentials | The proxy credentials for the location
UserCredentials | The user credentials for the location

See Also

DeploymentLocation Class
SandcastleBuilder.PlugIns Namespace


DeploymentLocation Constructor

[image] [image]

Sandcastle Help File Builder Documentation
DeploymentLocation Constructor
DeploymentLocation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

There are two overloads for the constructor

Overload List

Name | Description
DeploymentLocation()()() | Constructor
DeploymentLocation(Uri, UserCredentials, ProxyCredentials) | Constructor

See Also

DeploymentLocation Class
DeploymentLocation Members
SandcastleBuilder.PlugIns Namespace


DeploymentLocation Constructor

[image]

Sandcastle Help File Builder Documentation
DeploymentLocation Constructor
DeploymentLocation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public DeploymentLocation()
Visual Basic (Declaration)
Public Sub New

See Also

DeploymentLocation Class
DeploymentLocation Overload
SandcastleBuilder.PlugIns Namespace


DeploymentLocation Constructor (Uri, UserCredentials, ProxyCredentials)

[image]

Sandcastle Help File Builder Documentation
DeploymentLocation Constructor (Uri, UserCredentials, ProxyCredentials)
DeploymentLocation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public DeploymentLocation(
    Uri deployTo,
    UserCredentials user,
    ProxyCredentials proxy
)
Visual Basic (Declaration)
Public Sub New ( _
    deployTo As Uri, _
    user As UserCredentials, _
    proxy As ProxyCredentials _
)

Parameters

deployTo
Type: System..::.Uri
The deployment location
user
Type: SandcastleBuilder.PlugIns..::.UserCredentials
The user credentials, if any
proxy
Type: SandcastleBuilder.PlugIns..::.ProxyCredentials
The proxy credentials, if any

See Also

DeploymentLocation Class
DeploymentLocation Overload
SandcastleBuilder.PlugIns Namespace


DeploymentLocation Methods

[image] [image]

Sandcastle Help File Builder Documentation
DeploymentLocation Methods
DeploymentLocation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DeploymentLocation type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromXPathNavigator | Create a deployment location instance from an XPath navigator containing the settings.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | Store the deployment location as a node in the given XML document

See Also

DeploymentLocation Class
SandcastleBuilder.PlugIns Namespace


FromXPathNavigator Method

[image]

Sandcastle Help File Builder Documentation
DeploymentLocation..::.FromXPathNavigator Method
DeploymentLocation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Create a deployment location instance from an XPath navigator containing the settings.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public static DeploymentLocation FromXPathNavigator(
    XPathNavigator navigator,
    string id
)
Visual Basic (Declaration)
Public Shared Function FromXPathNavigator ( _
    navigator As XPathNavigator, _
    id As String _
) As DeploymentLocation

Parameters

navigator
Type: System.Xml.XPath..::.XPathNavigator
The XPath navigator from which to obtain the settings.
id
Type: System..::.String
The id of the element to load

Return Value

A DeploymentLocation object containing the settings from the XPath navigator.

Remarks

It should contain an element called deploymentLocation with two attributes (id with the specified ID value and location) and nested userCredentials and proxyCredentials elements.

See Also

DeploymentLocation Class
SandcastleBuilder.PlugIns Namespace


ToXml Method

[image]

Sandcastle Help File Builder Documentation
DeploymentLocation..::.ToXml Method
DeploymentLocation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Store the deployment location as a node in the given XML document

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public XmlNode ToXml(
    XmlDocument config,
    XmlNode root,
    string id
)
Visual Basic (Declaration)
Public Function ToXml ( _
    config As XmlDocument, _
    root As XmlNode, _
    id As String _
) As XmlNode

Parameters

config
Type: System.Xml..::.XmlDocument
The XML document
root
Type: System.Xml..::.XmlNode
The node in which to store the element
id
Type: System..::.String
The id of the element to create

Return Value

Returns the node that was added or the one that already existed in the document.

Remarks

The deployment location is stored in an element called deploymentLocation with two attributes (id matching the specified id and location) and nested userCredentials and proxyCredentials elements. It is created if it does not already exist.

See Also

DeploymentLocation Class
SandcastleBuilder.PlugIns Namespace


DeploymentLocation Properties

[image] [image]

Sandcastle Help File Builder Documentation
DeploymentLocation Properties
DeploymentLocation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DeploymentLocation type exposes the following members.

Properties

Name | Description
Location | The location to which the help file is deployed
ProxyCredentials | The proxy credentials for the location
UserCredentials | The user credentials for the location

See Also

DeploymentLocation Class
SandcastleBuilder.PlugIns Namespace


Location Property

[image]

Sandcastle Help File Builder Documentation
DeploymentLocation..::.Location Property
DeploymentLocation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The location to which the help file is deployed

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public Uri Location { get; set; }
Visual Basic (Declaration)
Public Property Location As Uri

See Also

DeploymentLocation Class
SandcastleBuilder.PlugIns Namespace


ProxyCredentials Property

[image]

Sandcastle Help File Builder Documentation
DeploymentLocation..::.ProxyCredentials Property
DeploymentLocation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The proxy credentials for the location

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public ProxyCredentials ProxyCredentials { get; }
Visual Basic (Declaration)
Public ReadOnly Property ProxyCredentials As ProxyCredentials

See Also

DeploymentLocation Class
SandcastleBuilder.PlugIns Namespace


UserCredentials Property

[image]

Sandcastle Help File Builder Documentation
DeploymentLocation..::.UserCredentials Property
DeploymentLocation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The user credentials for the location

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public UserCredentials UserCredentials { get; }
Visual Basic (Declaration)
Public ReadOnly Property UserCredentials As UserCredentials

See Also

DeploymentLocation Class
SandcastleBuilder.PlugIns Namespace


DeploymentPlugIn Class

[image]

Sandcastle Help File Builder Documentation
DeploymentPlugIn Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This plug-in class is used to copy the resulting help file output to a location other than the output folder (i.e. a file share, an FTP site, a web server, etc.).

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public class DeploymentPlugIn : IPlugIn,
    IDisposable
Visual Basic (Declaration)
Public Class DeploymentPlugIn _
    Implements IPlugIn, IDisposable

Inheritance Hierarchy

System..::.Object
SandcastleBuilder.PlugIns..::.DeploymentPlugIn

See Also

DeploymentPlugIn Members
SandcastleBuilder.PlugIns Namespace


DeploymentPlugIn Members

[image] [image]

Sandcastle Help File Builder Documentation
DeploymentPlugIn Members
DeploymentPlugIn Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DeploymentPlugIn type exposes the following members.

Constructors

Name | Description
DeploymentPlugIn | Initializes a new instance of the DeploymentPlugIn class

Methods

Name | Description
ConfigurePlugIn | This method is used by the Sandcastle Help File Builder to let the plug-in perform its own configuration.
Dispose | Overloaded. There are two overloads for this method.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | This method is used to execute the plug-in during the build process
Finalize | This handles garbage collection to ensure proper disposal of the plug-in if not done explicity with Dispose()()(). (Overrides Object..::.Finalize()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Initialize | This method is used to initialize the plug-in at the start of the build process.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Copyright | This read-only property returns the copyright information for the plug-in.
Description | This read-only property returns a brief description of the plug-in
ExecutionPoints | This read-only property returns a collection of execution points that define when the plug-in should be invoked during the build process.
Name | This read-only property returns a friendly name for the plug-in
RunsInPartialBuild | This plug-in does not run in partial builds
Version | This read-only property returns the version of the plug-in

See Also

DeploymentPlugIn Class
SandcastleBuilder.PlugIns Namespace


DeploymentPlugIn Constructor

[image]

Sandcastle Help File Builder Documentation
DeploymentPlugIn Constructor
DeploymentPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the DeploymentPlugIn class

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public DeploymentPlugIn()
Visual Basic (Declaration)
Public Sub New

See Also

DeploymentPlugIn Class
SandcastleBuilder.PlugIns Namespace


DeploymentPlugIn Methods

[image] [image]

Sandcastle Help File Builder Documentation
DeploymentPlugIn Methods
DeploymentPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DeploymentPlugIn type exposes the following members.

Methods

Name | Description
ConfigurePlugIn | This method is used by the Sandcastle Help File Builder to let the plug-in perform its own configuration.
Dispose | Overloaded. There are two overloads for this method.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | This method is used to execute the plug-in during the build process
Finalize | This handles garbage collection to ensure proper disposal of the plug-in if not done explicity with Dispose()()(). (Overrides Object..::.Finalize()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Initialize | This method is used to initialize the plug-in at the start of the build process.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DeploymentPlugIn Class
SandcastleBuilder.PlugIns Namespace


ConfigurePlugIn Method

[image]

Sandcastle Help File Builder Documentation
DeploymentPlugIn..::.ConfigurePlugIn Method
DeploymentPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This method is used by the Sandcastle Help File Builder to let the plug-in perform its own configuration.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public string ConfigurePlugIn(
    SandcastleProject project,
    string currentConfig
)
Visual Basic (Declaration)
Public Function ConfigurePlugIn ( _
    project As SandcastleProject, _
    currentConfig As String _
) As String

Parameters

project
Type: SandcastleBuilder.Utils..::.SandcastleProject
A reference to the active project
currentConfig
Type: System..::.String
The current configuration XML fragment

Return Value

A string containing the new configuration XML fragment

Implements

IPlugIn..::.ConfigurePlugIn(SandcastleProject, String)

Remarks

The configuration data will be stored in the help file builder project.

See Also

DeploymentPlugIn Class
SandcastleBuilder.PlugIns Namespace


Dispose Method

[image] [image]

Sandcastle Help File Builder Documentation
DeploymentPlugIn..::.Dispose Method
DeploymentPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

There are two overloads for this method.

Overload List

Name | Description
Dispose()()() | This implements the Dispose() interface to properly dispose of the plug-in object.
Dispose(Boolean) | This can be overridden by derived classes to add their own disposal code if necessary.

See Also

DeploymentPlugIn Class
DeploymentPlugIn Members
SandcastleBuilder.PlugIns Namespace


Dispose Method

[image]

Sandcastle Help File Builder Documentation
DeploymentPlugIn..::.Dispose Method
DeploymentPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This implements the Dispose() interface to properly dispose of the plug-in object.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose

Implements

IDisposable..::.Dispose()()()

See Also

DeploymentPlugIn Class
Dispose Overload
SandcastleBuilder.PlugIns Namespace


Dispose Method (Boolean)

[image]

Sandcastle Help File Builder Documentation
DeploymentPlugIn..::.Dispose Method (Boolean)
DeploymentPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This can be overridden by derived classes to add their own disposal code if necessary.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
protected virtual void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overridable Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
Pass true to dispose of the managed and unmanaged resources or false to just dispose of the unmanaged resources.

See Also

DeploymentPlugIn Class
Dispose Overload
SandcastleBuilder.PlugIns Namespace


Execute Method

[image]

Sandcastle Help File Builder Documentation
DeploymentPlugIn..::.Execute Method
DeploymentPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This method is used to execute the plug-in during the build process

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public void Execute(
    ExecutionContext context
)
Visual Basic (Declaration)
Public Sub Execute ( _
    context As ExecutionContext _
)

Parameters

context
Type: SandcastleBuilder.Utils.PlugIn..::.ExecutionContext
The current execution context

Implements

IPlugIn..::.Execute(ExecutionContext)

See Also

DeploymentPlugIn Class
SandcastleBuilder.PlugIns Namespace


Finalize Method

[image]

Sandcastle Help File Builder Documentation
DeploymentPlugIn..::.Finalize Method
DeploymentPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This handles garbage collection to ensure proper disposal of the plug-in if not done explicity with Dispose()()().

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
protected override void Finalize()
Visual Basic (Declaration)
Protected Overrides Sub Finalize

See Also

DeploymentPlugIn Class
SandcastleBuilder.PlugIns Namespace


Initialize Method

[image]

Sandcastle Help File Builder Documentation
DeploymentPlugIn..::.Initialize Method
DeploymentPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This method is used to initialize the plug-in at the start of the build process.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public void Initialize(
    BuildProcess buildProcess,
    XPathNavigator configuration
)
Visual Basic (Declaration)
Public Sub Initialize ( _
    buildProcess As BuildProcess, _
    configuration As XPathNavigator _
)

Parameters

buildProcess
Type: SandcastleBuilder.Utils.BuildEngine..::.BuildProcess
A reference to the current build process.
configuration
Type: System.Xml.XPath..::.XPathNavigator
The configuration data that the plug-in should use to initialize itself.

Implements

IPlugIn..::.Initialize(BuildProcess, XPathNavigator)

Exceptions

Exception | Condition
SandcastleBuilder.Utils..::.BuilderException | This is thrown if the plug-in configuration is not valid.

See Also

DeploymentPlugIn Class
SandcastleBuilder.PlugIns Namespace


DeploymentPlugIn Properties

[image] [image]

Sandcastle Help File Builder Documentation
DeploymentPlugIn Properties
DeploymentPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DeploymentPlugIn type exposes the following members.

Properties

Name | Description
Copyright | This read-only property returns the copyright information for the plug-in.
Description | This read-only property returns a brief description of the plug-in
ExecutionPoints | This read-only property returns a collection of execution points that define when the plug-in should be invoked during the build process.
Name | This read-only property returns a friendly name for the plug-in
RunsInPartialBuild | This plug-in does not run in partial builds
Version | This read-only property returns the version of the plug-in

See Also

DeploymentPlugIn Class
SandcastleBuilder.PlugIns Namespace


Copyright Property

[image]

Sandcastle Help File Builder Documentation
DeploymentPlugIn..::.Copyright Property
DeploymentPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns the copyright information for the plug-in.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public string Copyright { get; }
Visual Basic (Declaration)
Public ReadOnly Property Copyright As String

Implements

IPlugIn..::.Copyright

See Also

DeploymentPlugIn Class
SandcastleBuilder.PlugIns Namespace


Description Property

[image]

Sandcastle Help File Builder Documentation
DeploymentPlugIn..::.Description Property
DeploymentPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns a brief description of the plug-in

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public string Description { get; }
Visual Basic (Declaration)
Public ReadOnly Property Description As String

Implements

IPlugIn..::.Description

See Also

DeploymentPlugIn Class
SandcastleBuilder.PlugIns Namespace


ExecutionPoints Property

[image]

Sandcastle Help File Builder Documentation
DeploymentPlugIn..::.ExecutionPoints Property
DeploymentPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns a collection of execution points that define when the plug-in should be invoked during the build process.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public ExecutionPointCollection ExecutionPoints { get; }
Visual Basic (Declaration)
Public ReadOnly Property ExecutionPoints As ExecutionPointCollection

Implements

IPlugIn..::.ExecutionPoints

See Also

DeploymentPlugIn Class
SandcastleBuilder.PlugIns Namespace


Name Property

[image]

Sandcastle Help File Builder Documentation
DeploymentPlugIn..::.Name Property
DeploymentPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns a friendly name for the plug-in

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String

Implements

IPlugIn..::.Name

See Also

DeploymentPlugIn Class
SandcastleBuilder.PlugIns Namespace


RunsInPartialBuild Property

[image]

Sandcastle Help File Builder Documentation
DeploymentPlugIn..::.RunsInPartialBuild Property
DeploymentPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This plug-in does not run in partial builds

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public bool RunsInPartialBuild { get; }
Visual Basic (Declaration)
Public ReadOnly Property RunsInPartialBuild As Boolean

Implements

IPlugIn..::.RunsInPartialBuild

See Also

DeploymentPlugIn Class
SandcastleBuilder.PlugIns Namespace


Version Property

[image]

Sandcastle Help File Builder Documentation
DeploymentPlugIn..::.Version Property
DeploymentPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns the version of the plug-in

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public Version Version { get; }
Visual Basic (Declaration)
Public ReadOnly Property Version As Version

Implements

IPlugIn..::.Version

See Also

DeploymentPlugIn Class
SandcastleBuilder.PlugIns Namespace


HierarchicalTocPlugIn Class

[image]

Sandcastle Help File Builder Documentation
HierarchicalTocPlugIn Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This plug-in class can be used to rearrange the table of contents such that namespaces are nested within their parent namespaces rather than appearing as a flat list of all namespaces at the root level.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public class HierarchicalTocPlugIn : IPlugIn,
    IDisposable
Visual Basic (Declaration)
Public Class HierarchicalTocPlugIn _
    Implements IPlugIn, IDisposable

Inheritance Hierarchy

System..::.Object
SandcastleBuilder.PlugIns..::.HierarchicalTocPlugIn

See Also

HierarchicalTocPlugIn Members
SandcastleBuilder.PlugIns Namespace


HierarchicalTocPlugIn Members

[image] [image]

Sandcastle Help File Builder Documentation
HierarchicalTocPlugIn Members
HierarchicalTocPlugIn Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The HierarchicalTocPlugIn type exposes the following members.

Constructors

Name | Description
HierarchicalTocPlugIn | Initializes a new instance of the HierarchicalTocPlugIn class

Methods

Name | Description
ConfigurePlugIn | This method is used by the Sandcastle Help File Builder to let the plug-in perform its own configuration.
Dispose | Overloaded. There are two overloads for this method.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | This method is used to execute the plug-in during the build process
Finalize | This handles garbage collection to ensure proper disposal of the plug-in if not done explicity with Dispose()()(). (Overrides Object..::.Finalize()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Initialize | This method is used to initialize the plug-in at the start of the build process.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Copyright | This read-only property returns the copyright information for the plug-in.
Description | This read-only property returns a brief description of the plug-in
ExecutionPoints | This read-only property returns a collection of execution points that define when the plug-in should be invoked during the build process.
Name | This read-only property returns a friendly name for the plug-in
RunsInPartialBuild | This plug-in does not run in partial builds
Version | This read-only property returns the version of the plug-in

See Also

HierarchicalTocPlugIn Class
SandcastleBuilder.PlugIns Namespace


HierarchicalTocPlugIn Constructor

[image]

Sandcastle Help File Builder Documentation
HierarchicalTocPlugIn Constructor
HierarchicalTocPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the HierarchicalTocPlugIn class

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public HierarchicalTocPlugIn()
Visual Basic (Declaration)
Public Sub New

See Also

HierarchicalTocPlugIn Class
SandcastleBuilder.PlugIns Namespace


HierarchicalTocPlugIn Methods

[image] [image]

Sandcastle Help File Builder Documentation
HierarchicalTocPlugIn Methods
HierarchicalTocPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The HierarchicalTocPlugIn type exposes the following members.

Methods

Name | Description
ConfigurePlugIn | This method is used by the Sandcastle Help File Builder to let the plug-in perform its own configuration.
Dispose | Overloaded. There are two overloads for this method.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | This method is used to execute the plug-in during the build process
Finalize | This handles garbage collection to ensure proper disposal of the plug-in if not done explicity with Dispose()()(). (Overrides Object..::.Finalize()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Initialize | This method is used to initialize the plug-in at the start of the build process.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HierarchicalTocPlugIn Class
SandcastleBuilder.PlugIns Namespace


ConfigurePlugIn Method

[image]

Sandcastle Help File Builder Documentation
HierarchicalTocPlugIn..::.ConfigurePlugIn Method
HierarchicalTocPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This method is used by the Sandcastle Help File Builder to let the plug-in perform its own configuration.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public string ConfigurePlugIn(
    SandcastleProject project,
    string currentConfig
)
Visual Basic (Declaration)
Public Function ConfigurePlugIn ( _
    project As SandcastleProject, _
    currentConfig As String _
) As String

Parameters

project
Type: SandcastleBuilder.Utils..::.SandcastleProject
A reference to the active project
currentConfig
Type: System..::.String
The current configuration XML fragment

Return Value

A string containing the new configuration XML fragment

Implements

IPlugIn..::.ConfigurePlugIn(SandcastleProject, String)

Remarks

The configuration data will be stored in the help file builder project.

See Also

HierarchicalTocPlugIn Class
SandcastleBuilder.PlugIns Namespace


Dispose Method

[image] [image]

Sandcastle Help File Builder Documentation
HierarchicalTocPlugIn..::.Dispose Method
HierarchicalTocPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

There are two overloads for this method.

Overload List

Name | Description
Dispose()()() | This implements the Dispose() interface to properly dispose of the plug-in object.
Dispose(Boolean) | This can be overridden by derived classes to add their own disposal code if necessary.

See Also

HierarchicalTocPlugIn Class
HierarchicalTocPlugIn Members
SandcastleBuilder.PlugIns Namespace


Dispose Method

[image]

Sandcastle Help File Builder Documentation
HierarchicalTocPlugIn..::.Dispose Method
HierarchicalTocPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This implements the Dispose() interface to properly dispose of the plug-in object.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose

Implements

IDisposable..::.Dispose()()()

See Also

HierarchicalTocPlugIn Class
Dispose Overload
SandcastleBuilder.PlugIns Namespace


Dispose Method (Boolean)

[image]

Sandcastle Help File Builder Documentation
HierarchicalTocPlugIn..::.Dispose Method (Boolean)
HierarchicalTocPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This can be overridden by derived classes to add their own disposal code if necessary.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
protected virtual void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overridable Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
Pass true to dispose of the managed and unmanaged resources or false to just dispose of the unmanaged resources.

See Also

HierarchicalTocPlugIn Class
Dispose Overload
SandcastleBuilder.PlugIns Namespace


Execute Method

[image]

Sandcastle Help File Builder Documentation
HierarchicalTocPlugIn..::.Execute Method
HierarchicalTocPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This method is used to execute the plug-in during the build process

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public void Execute(
    ExecutionContext context
)
Visual Basic (Declaration)
Public Sub Execute ( _
    context As ExecutionContext _
)

Parameters

context
Type: SandcastleBuilder.Utils.PlugIn..::.ExecutionContext
The current execution context

Implements

IPlugIn..::.Execute(ExecutionContext)

See Also

HierarchicalTocPlugIn Class
SandcastleBuilder.PlugIns Namespace


Finalize Method

[image]

Sandcastle Help File Builder Documentation
HierarchicalTocPlugIn..::.Finalize Method
HierarchicalTocPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This handles garbage collection to ensure proper disposal of the plug-in if not done explicity with Dispose()()().

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
protected override void Finalize()
Visual Basic (Declaration)
Protected Overrides Sub Finalize

See Also

HierarchicalTocPlugIn Class
SandcastleBuilder.PlugIns Namespace


Initialize Method

[image]

Sandcastle Help File Builder Documentation
HierarchicalTocPlugIn..::.Initialize Method
HierarchicalTocPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This method is used to initialize the plug-in at the start of the build process.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public void Initialize(
    BuildProcess buildProcess,
    XPathNavigator configuration
)
Visual Basic (Declaration)
Public Sub Initialize ( _
    buildProcess As BuildProcess, _
    configuration As XPathNavigator _
)

Parameters

buildProcess
Type: SandcastleBuilder.Utils.BuildEngine..::.BuildProcess
A reference to the current build process.
configuration
Type: System.Xml.XPath..::.XPathNavigator
The configuration data that the plug-in should use to initialize itself.

Implements

IPlugIn..::.Initialize(BuildProcess, XPathNavigator)

See Also

HierarchicalTocPlugIn Class
SandcastleBuilder.PlugIns Namespace


HierarchicalTocPlugIn Properties

[image] [image]

Sandcastle Help File Builder Documentation
HierarchicalTocPlugIn Properties
HierarchicalTocPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The HierarchicalTocPlugIn type exposes the following members.

Properties

Name | Description
Copyright | This read-only property returns the copyright information for the plug-in.
Description | This read-only property returns a brief description of the plug-in
ExecutionPoints | This read-only property returns a collection of execution points that define when the plug-in should be invoked during the build process.
Name | This read-only property returns a friendly name for the plug-in
RunsInPartialBuild | This plug-in does not run in partial builds
Version | This read-only property returns the version of the plug-in

See Also

HierarchicalTocPlugIn Class
SandcastleBuilder.PlugIns Namespace


Copyright Property

[image]

Sandcastle Help File Builder Documentation
HierarchicalTocPlugIn..::.Copyright Property
HierarchicalTocPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns the copyright information for the plug-in.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public string Copyright { get; }
Visual Basic (Declaration)
Public ReadOnly Property Copyright As String

Implements

IPlugIn..::.Copyright

See Also

HierarchicalTocPlugIn Class
SandcastleBuilder.PlugIns Namespace


Description Property

[image]

Sandcastle Help File Builder Documentation
HierarchicalTocPlugIn..::.Description Property
HierarchicalTocPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns a brief description of the plug-in

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public string Description { get; }
Visual Basic (Declaration)
Public ReadOnly Property Description As String

Implements

IPlugIn..::.Description

See Also

HierarchicalTocPlugIn Class
SandcastleBuilder.PlugIns Namespace


ExecutionPoints Property

[image]

Sandcastle Help File Builder Documentation
HierarchicalTocPlugIn..::.ExecutionPoints Property
HierarchicalTocPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns a collection of execution points that define when the plug-in should be invoked during the build process.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public ExecutionPointCollection ExecutionPoints { get; }
Visual Basic (Declaration)
Public ReadOnly Property ExecutionPoints As ExecutionPointCollection

Implements

IPlugIn..::.ExecutionPoints

See Also

HierarchicalTocPlugIn Class
SandcastleBuilder.PlugIns Namespace


Name Property

[image]

Sandcastle Help File Builder Documentation
HierarchicalTocPlugIn..::.Name Property
HierarchicalTocPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns a friendly name for the plug-in

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String

Implements

IPlugIn..::.Name

See Also

HierarchicalTocPlugIn Class
SandcastleBuilder.PlugIns Namespace


RunsInPartialBuild Property

[image]

Sandcastle Help File Builder Documentation
HierarchicalTocPlugIn..::.RunsInPartialBuild Property
HierarchicalTocPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This plug-in does not run in partial builds

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public bool RunsInPartialBuild { get; }
Visual Basic (Declaration)
Public ReadOnly Property RunsInPartialBuild As Boolean

Implements

IPlugIn..::.RunsInPartialBuild

See Also

HierarchicalTocPlugIn Class
SandcastleBuilder.PlugIns Namespace


Version Property

[image]

Sandcastle Help File Builder Documentation
HierarchicalTocPlugIn..::.Version Property
HierarchicalTocPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns the version of the plug-in

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public Version Version { get; }
Visual Basic (Declaration)
Public ReadOnly Property Version As Version

Implements

IPlugIn..::.Version

See Also

HierarchicalTocPlugIn Class
SandcastleBuilder.PlugIns Namespace


ProxyCredentials Class

[image]

Sandcastle Help File Builder Documentation
ProxyCredentials Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This class is used to specify credentials for a proxy server.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public class ProxyCredentials
Visual Basic (Declaration)
Public Class ProxyCredentials

Inheritance Hierarchy

System..::.Object
SandcastleBuilder.PlugIns..::.ProxyCredentials

See Also

ProxyCredentials Members
SandcastleBuilder.PlugIns Namespace


ProxyCredentials Members

[image] [image]

Sandcastle Help File Builder Documentation
ProxyCredentials Members
ProxyCredentials Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ProxyCredentials type exposes the following members.

Constructors

Name | Description
ProxyCredentials | Overloaded. There are two overloads for the constructor.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromXPathNavigator | Create a proxy credentials instance from an XPath navigator containing the settings.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | Store the credentials as a node in the given XML document

Properties

Name | Description
Credentials | Get the user credentials
ProxyServer | Get or set the proxy server name
UseProxyServer | This is used to set or get the flag indicating whether or not to use the proxy server.

See Also

ProxyCredentials Class
SandcastleBuilder.PlugIns Namespace


ProxyCredentials Constructor

[image] [image]

Sandcastle Help File Builder Documentation
ProxyCredentials Constructor
ProxyCredentials Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

There are two overloads for the constructor.

Overload List

Name | Description
ProxyCredentials()()() | Constructor
ProxyCredentials(Boolean, Uri, UserCredentials) | Constructor

See Also

ProxyCredentials Class
ProxyCredentials Members
SandcastleBuilder.PlugIns Namespace


ProxyCredentials Constructor

[image]

Sandcastle Help File Builder Documentation
ProxyCredentials Constructor
ProxyCredentials Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public ProxyCredentials()
Visual Basic (Declaration)
Public Sub New

See Also

ProxyCredentials Class
ProxyCredentials Overload
SandcastleBuilder.PlugIns Namespace


ProxyCredentials Constructor (Boolean, Uri, UserCredentials)

[image]

Sandcastle Help File Builder Documentation
ProxyCredentials Constructor (Boolean, Uri, UserCredentials)
ProxyCredentials Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public ProxyCredentials(
    bool useProxy,
    Uri server,
    UserCredentials proxyUser
)
Visual Basic (Declaration)
Public Sub New ( _
    useProxy As Boolean, _
    server As Uri, _
    proxyUser As UserCredentials _
)

Parameters

useProxy
Type: System..::.Boolean
True to use default the proxy server, false to not use it.
server
Type: System..::.Uri
The server name to use.
proxyUser
Type: SandcastleBuilder.PlugIns..::.UserCredentials
The user credentials to use for the proxy server.

See Also

ProxyCredentials Class
ProxyCredentials Overload
SandcastleBuilder.PlugIns Namespace


ProxyCredentials Methods

[image] [image]

Sandcastle Help File Builder Documentation
ProxyCredentials Methods
ProxyCredentials Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ProxyCredentials type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromXPathNavigator | Create a proxy credentials instance from an XPath navigator containing the settings.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | Store the credentials as a node in the given XML document

See Also

ProxyCredentials Class
SandcastleBuilder.PlugIns Namespace


FromXPathNavigator Method

[image]

Sandcastle Help File Builder Documentation
ProxyCredentials..::.FromXPathNavigator Method
ProxyCredentials Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Create a proxy credentials instance from an XPath navigator containing the settings.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public static ProxyCredentials FromXPathNavigator(
    XPathNavigator navigator
)
Visual Basic (Declaration)
Public Shared Function FromXPathNavigator ( _
    navigator As XPathNavigator _
) As ProxyCredentials

Parameters

navigator
Type: System.Xml.XPath..::.XPathNavigator
The XPath navigator from which to obtain the settings.

Return Value

A ProxyCredentials object containing the settings from the XPath navigator.

Remarks

It should contain an element called proxyCredentials with two attributes (useProxy and proxyServer) and a nested userCredentials element.

See Also

ProxyCredentials Class
SandcastleBuilder.PlugIns Namespace


ToXml Method

[image]

Sandcastle Help File Builder Documentation
ProxyCredentials..::.ToXml Method
ProxyCredentials Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Store the credentials as a node in the given XML document

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public XmlNode ToXml(
    XmlDocument config,
    XmlNode root
)
Visual Basic (Declaration)
Public Function ToXml ( _
    config As XmlDocument, _
    root As XmlNode _
) As XmlNode

Parameters

config
Type: System.Xml..::.XmlDocument
The XML document
root
Type: System.Xml..::.XmlNode
The node in which to store the element

Return Value

Returns the node that was added or the one that already existed in the document.

Remarks

The credentials are stored in an element called proxyCredentials with two attributes (useProxy and proxyServer) and a nested userCredentials element. It is created if it does not already exist.

See Also

ProxyCredentials Class
SandcastleBuilder.PlugIns Namespace


ProxyCredentials Properties

[image] [image]

Sandcastle Help File Builder Documentation
ProxyCredentials Properties
ProxyCredentials Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ProxyCredentials type exposes the following members.

Properties

Name | Description
Credentials | Get the user credentials
ProxyServer | Get or set the proxy server name
UseProxyServer | This is used to set or get the flag indicating whether or not to use the proxy server.

See Also

ProxyCredentials Class
SandcastleBuilder.PlugIns Namespace


Credentials Property

[image]

Sandcastle Help File Builder Documentation
ProxyCredentials..::.Credentials Property
ProxyCredentials Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Get the user credentials

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public UserCredentials Credentials { get; }
Visual Basic (Declaration)
Public ReadOnly Property Credentials As UserCredentials

Field Value

If UseProxyServer is false, this will be ignored.

See Also

ProxyCredentials Class
SandcastleBuilder.PlugIns Namespace


ProxyServer Property

[image]

Sandcastle Help File Builder Documentation
ProxyCredentials..::.ProxyServer Property
ProxyCredentials Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Get or set the proxy server name

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public Uri ProxyServer { get; set; }
Visual Basic (Declaration)
Public Property ProxyServer As Uri

Field Value

If UseProxyServer is false, this will be ignored.

See Also

ProxyCredentials Class
SandcastleBuilder.PlugIns Namespace


UseProxyServer Property

[image]

Sandcastle Help File Builder Documentation
ProxyCredentials..::.UseProxyServer Property
ProxyCredentials Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to set or get the flag indicating whether or not to use the proxy server.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public bool UseProxyServer { get; set; }
Visual Basic (Declaration)
Public Property UseProxyServer As Boolean

Field Value

By default, this is false and ProxyServer and Credentials will be ignored.

See Also

ProxyCredentials Class
SandcastleBuilder.PlugIns Namespace


ReferenceLinkSettings Class

[image]

Sandcastle Help File Builder Documentation
ReferenceLinkSettings Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This represents reference link settings for the AdditionalReferenceLinksPlugIn.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public class ReferenceLinkSettings
Visual Basic (Declaration)
Public Class ReferenceLinkSettings

Inheritance Hierarchy

System..::.Object
SandcastleBuilder.PlugIns..::.ReferenceLinkSettings

See Also

ReferenceLinkSettings Members
SandcastleBuilder.PlugIns Namespace


ReferenceLinkSettings Members

[image] [image]

Sandcastle Help File Builder Documentation
ReferenceLinkSettings Members
ReferenceLinkSettings Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ReferenceLinkSettings type exposes the following members.

Constructors

Name | Description
ReferenceLinkSettings | Constructor

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromXPathNavigator | Create a reference link settings instance from an XPath navigator containing the settings.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | Store the reference link settings as a node in the given XML document.

Properties

Name | Description
HelpFileProject | This is used to get or set the path to the help file builder project used to generate reference link information.
LinkType | This is used to get or set the link type for the target
ListDescription | This returns a description of the entry suitable for display in a bound list control.

See Also

ReferenceLinkSettings Class
SandcastleBuilder.PlugIns Namespace


ReferenceLinkSettings Constructor

[image]

Sandcastle Help File Builder Documentation
ReferenceLinkSettings Constructor
ReferenceLinkSettings Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public ReferenceLinkSettings()
Visual Basic (Declaration)
Public Sub New

See Also

ReferenceLinkSettings Class
SandcastleBuilder.PlugIns Namespace


ReferenceLinkSettings Methods

[image] [image]

Sandcastle Help File Builder Documentation
ReferenceLinkSettings Methods
ReferenceLinkSettings Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ReferenceLinkSettings type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromXPathNavigator | Create a reference link settings instance from an XPath navigator containing the settings.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | Store the reference link settings as a node in the given XML document.

See Also

ReferenceLinkSettings Class
SandcastleBuilder.PlugIns Namespace


FromXPathNavigator Method

[image]

Sandcastle Help File Builder Documentation
ReferenceLinkSettings..::.FromXPathNavigator Method
ReferenceLinkSettings Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Create a reference link settings instance from an XPath navigator containing the settings.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public static ReferenceLinkSettings FromXPathNavigator(
    IBasePathProvider pathProvider,
    XPathNavigator navigator
)
Visual Basic (Declaration)
Public Shared Function FromXPathNavigator ( _
    pathProvider As IBasePathProvider, _
    navigator As XPathNavigator _
) As ReferenceLinkSettings

Parameters

pathProvider
Type: SandcastleBuilder.Utils..::.IBasePathProvider
The base path provider object
navigator
Type: System.Xml.XPath..::.XPathNavigator
The XPath navigator from which to obtain the settings.

Return Value

A ReferenceLinkSettings object containing the settings from the XPath navigator.

Remarks

It should contain an element called target with two attributes (linkType and helpFileProject).

See Also

ReferenceLinkSettings Class
SandcastleBuilder.PlugIns Namespace


ToXml Method

[image]

Sandcastle Help File Builder Documentation
ReferenceLinkSettings..::.ToXml Method
ReferenceLinkSettings Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Store the reference link settings as a node in the given XML document.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public XmlNode ToXml(
    XmlDocument config,
    XmlNode root
)
Visual Basic (Declaration)
Public Function ToXml ( _
    config As XmlDocument, _
    root As XmlNode _
) As XmlNode

Parameters

config
Type: System.Xml..::.XmlDocument
The XML document
root
Type: System.Xml..::.XmlNode
The node in which to store the element

Return Value

Returns the node that was added.

Remarks

The reference link settings are stored in an element called target with two attributes (linkType and helpFileProject).

See Also

ReferenceLinkSettings Class
SandcastleBuilder.PlugIns Namespace


ReferenceLinkSettings Properties

[image] [image]

Sandcastle Help File Builder Documentation
ReferenceLinkSettings Properties
ReferenceLinkSettings Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ReferenceLinkSettings type exposes the following members.

Properties

Name | Description
HelpFileProject | This is used to get or set the path to the help file builder project used to generate reference link information.
LinkType | This is used to get or set the link type for the target
ListDescription | This returns a description of the entry suitable for display in a bound list control.

See Also

ReferenceLinkSettings Class
SandcastleBuilder.PlugIns Namespace


HelpFileProject Property

[image]

Sandcastle Help File Builder Documentation
ReferenceLinkSettings..::.HelpFileProject Property
ReferenceLinkSettings Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set the path to the help file builder project used to generate reference link information.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public FilePath HelpFileProject { get; set; }
Visual Basic (Declaration)
Public Property HelpFileProject As FilePath

Field Value

The help file builder project makes it simple to manage settings for the other target's assemblies such as references, API filter settings, etc.

See Also

ReferenceLinkSettings Class
SandcastleBuilder.PlugIns Namespace


LinkType Property

[image]

Sandcastle Help File Builder Documentation
ReferenceLinkSettings..::.LinkType Property
ReferenceLinkSettings Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set the link type for the target

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public SdkLinkType LinkType { get; set; }
Visual Basic (Declaration)
Public Property LinkType As SdkLinkType

See Also

ReferenceLinkSettings Class
SandcastleBuilder.PlugIns Namespace


ListDescription Property

[image]

Sandcastle Help File Builder Documentation
ReferenceLinkSettings..::.ListDescription Property
ReferenceLinkSettings Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This returns a description of the entry suitable for display in a bound list control.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public string ListDescription { get; }
Visual Basic (Declaration)
Public ReadOnly Property ListDescription As String

See Also

ReferenceLinkSettings Class
SandcastleBuilder.PlugIns Namespace


ReferenceLinkSettingsCollection Class

[image]

Sandcastle Help File Builder Documentation
ReferenceLinkSettingsCollection Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This collection class is used to hold the reference link settings information for the AdditionalReferenceLinksPlugIn.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public class ReferenceLinkSettingsCollection : BindingList<ReferenceLinkSettings>
Visual Basic (Declaration)
Public Class ReferenceLinkSettingsCollection _
    Inherits BindingList(Of ReferenceLinkSettings)

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection <(Of <( ReferenceLinkSettings >)>)
System.ComponentModel..::.BindingList <(Of <( ReferenceLinkSettings >)>)
SandcastleBuilder.PlugIns..::.ReferenceLinkSettingsCollection

See Also

ReferenceLinkSettingsCollection Members
SandcastleBuilder.PlugIns Namespace


ReferenceLinkSettingsCollection Members

[image] [image]

Sandcastle Help File Builder Documentation
ReferenceLinkSettingsCollection Members
ReferenceLinkSettingsCollection Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ReferenceLinkSettingsCollection type exposes the following members.

Constructors

Name | Description
ReferenceLinkSettingsCollection | Initializes a new instance of the ReferenceLinkSettingsCollection class

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ReferenceLinkSettings >)>).)
AddNew | Adds a new item to the collection. (Inherited from BindingList <(Of <( ReferenceLinkSettings >)>).)
AddNewCore | Adds a new item to the end of the collection. (Inherited from BindingList <(Of <( ReferenceLinkSettings >)>).)
ApplySortCore | Sorts the items if overridden in a derived class; otherwise, throws a NotSupportedException. (Inherited from BindingList <(Of <( ReferenceLinkSettings >)>).)
CancelNew | Discards a pending new item. (Inherited from BindingList <(Of <( ReferenceLinkSettings >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ReferenceLinkSettings >)>).)
ClearItems | Removes all elements from the collection. (Inherited from BindingList <(Of <( ReferenceLinkSettings >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ReferenceLinkSettings >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <( ReferenceLinkSettings >)>).)
EndNew | Commits a pending new item to the collection. (Inherited from BindingList <(Of <( ReferenceLinkSettings >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindCore | Searches for the index of the item that has the specified property descriptor with the specified value, if searching is implemented in a derived class; otherwise, a NotSupportedException. (Inherited from BindingList <(Of <( ReferenceLinkSettings >)>).)
FromXml | This is used to load the reference link settings list from the configuration settings.
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ReferenceLinkSettings >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ReferenceLinkSettings >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( ReferenceLinkSettings >)>).)
InsertItem | Inserts the specified item in the list at the specified index. (Inherited from BindingList <(Of <( ReferenceLinkSettings >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnAddingNew | Raises the AddingNew event. (Inherited from BindingList <(Of <( ReferenceLinkSettings >)>).)
OnListChanged | Raises the ListChanged event. (Inherited from BindingList <(Of <( ReferenceLinkSettings >)>).)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ReferenceLinkSettings >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ReferenceLinkSettings >)>).)
RemoveItem | Removes the item at the specified index. (Inherited from BindingList <(Of <( ReferenceLinkSettings >)>).)
RemoveSortCore | Removes any sort applied with ApplySortCore(PropertyDescriptor, ListSortDirection) if sorting is implemented in a derived class; otherwise, raises NotSupportedException. (Inherited from BindingList <(Of <( ReferenceLinkSettings >)>).)
ResetBindings | Raises a ListChanged event of type Reset. (Inherited from BindingList <(Of <( ReferenceLinkSettings >)>).)
ResetItem | Raises a ListChanged event of type ItemChanged for the item at the specified position. (Inherited from BindingList <(Of <( ReferenceLinkSettings >)>).)
SetItem | Replaces the item at the specified index with the specified item. (Inherited from BindingList <(Of <( ReferenceLinkSettings >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | This is used to save the reference link settings list to the configuration settings.

Properties

Name | Description
AllowEdit | Gets or sets a value indicating whether items in the list can be edited. (Inherited from BindingList <(Of <( ReferenceLinkSettings >)>).)
AllowNew | Gets or sets a value indicating whether you can add items to the list using the AddNew()()() method. (Inherited from BindingList <(Of <( ReferenceLinkSettings >)>).)
AllowRemove | Gets or sets a value indicating whether you can remove items from the collection. (Inherited from BindingList <(Of <( ReferenceLinkSettings >)>).)
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ReferenceLinkSettings >)>).)
IsSortedCore | Gets a value indicating whether the list is sorted. (Inherited from BindingList <(Of <( ReferenceLinkSettings >)>).)
Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <( ReferenceLinkSettings >)>).)
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ReferenceLinkSettings >)>).)
RaiseListChangedEvents | Gets or sets a value indicating whether adding or removing items within the list raises ListChanged events. (Inherited from BindingList <(Of <( ReferenceLinkSettings >)>).)
SortDirectionCore | Gets the direction the list is sorted. (Inherited from BindingList <(Of <( ReferenceLinkSettings >)>).)
SortPropertyCore | Gets the property descriptor that is used for sorting the list if sorting is implemented in a derived class; otherwise, returns null. (Inherited from BindingList <(Of <( ReferenceLinkSettings >)>).)
SupportsChangeNotificationCore | Gets a value indicating whether ListChanged events are enabled. (Inherited from BindingList <(Of <( ReferenceLinkSettings >)>).)
SupportsSearchingCore | Gets a value indicating whether the list supports searching. (Inherited from BindingList <(Of <( ReferenceLinkSettings >)>).)
SupportsSortingCore | Gets a value indicating whether the list supports sorting. (Inherited from BindingList <(Of <( ReferenceLinkSettings >)>).)

Events

Name | Description
AddingNew | Occurs before an item is added to the list. (Inherited from BindingList <(Of <( ReferenceLinkSettings >)>).)
ListChanged | Occurs when the list or an item in the list changes. (Inherited from BindingList <(Of <( ReferenceLinkSettings >)>).)

See Also

ReferenceLinkSettingsCollection Class
SandcastleBuilder.PlugIns Namespace


ReferenceLinkSettingsCollection Constructor

[image]

Sandcastle Help File Builder Documentation
ReferenceLinkSettingsCollection Constructor
ReferenceLinkSettingsCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ReferenceLinkSettingsCollection class

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public ReferenceLinkSettingsCollection()
Visual Basic (Declaration)
Public Sub New

See Also

ReferenceLinkSettingsCollection Class
SandcastleBuilder.PlugIns Namespace


ReferenceLinkSettingsCollection Methods

[image] [image]

Sandcastle Help File Builder Documentation
ReferenceLinkSettingsCollection Methods
ReferenceLinkSettingsCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ReferenceLinkSettingsCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ReferenceLinkSettings >)>).)
AddNew | Adds a new item to the collection. (Inherited from BindingList <(Of <( ReferenceLinkSettings >)>).)
AddNewCore | Adds a new item to the end of the collection. (Inherited from BindingList <(Of <( ReferenceLinkSettings >)>).)
ApplySortCore | Sorts the items if overridden in a derived class; otherwise, throws a NotSupportedException. (Inherited from BindingList <(Of <( ReferenceLinkSettings >)>).)
CancelNew | Discards a pending new item. (Inherited from BindingList <(Of <( ReferenceLinkSettings >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ReferenceLinkSettings >)>).)
ClearItems | Removes all elements from the collection. (Inherited from BindingList <(Of <( ReferenceLinkSettings >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ReferenceLinkSettings >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <( ReferenceLinkSettings >)>).)
EndNew | Commits a pending new item to the collection. (Inherited from BindingList <(Of <( ReferenceLinkSettings >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindCore | Searches for the index of the item that has the specified property descriptor with the specified value, if searching is implemented in a derived class; otherwise, a NotSupportedException. (Inherited from BindingList <(Of <( ReferenceLinkSettings >)>).)
FromXml | This is used to load the reference link settings list from the configuration settings.
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ReferenceLinkSettings >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ReferenceLinkSettings >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( ReferenceLinkSettings >)>).)
InsertItem | Inserts the specified item in the list at the specified index. (Inherited from BindingList <(Of <( ReferenceLinkSettings >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnAddingNew | Raises the AddingNew event. (Inherited from BindingList <(Of <( ReferenceLinkSettings >)>).)
OnListChanged | Raises the ListChanged event. (Inherited from BindingList <(Of <( ReferenceLinkSettings >)>).)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ReferenceLinkSettings >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ReferenceLinkSettings >)>).)
RemoveItem | Removes the item at the specified index. (Inherited from BindingList <(Of <( ReferenceLinkSettings >)>).)
RemoveSortCore | Removes any sort applied with ApplySortCore(PropertyDescriptor, ListSortDirection) if sorting is implemented in a derived class; otherwise, raises NotSupportedException. (Inherited from BindingList <(Of <( ReferenceLinkSettings >)>).)
ResetBindings | Raises a ListChanged event of type Reset. (Inherited from BindingList <(Of <( ReferenceLinkSettings >)>).)
ResetItem | Raises a ListChanged event of type ItemChanged for the item at the specified position. (Inherited from BindingList <(Of <( ReferenceLinkSettings >)>).)
SetItem | Replaces the item at the specified index with the specified item. (Inherited from BindingList <(Of <( ReferenceLinkSettings >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | This is used to save the reference link settings list to the configuration settings.

See Also

ReferenceLinkSettingsCollection Class
SandcastleBuilder.PlugIns Namespace


FromXml Method

[image]

Sandcastle Help File Builder Documentation
ReferenceLinkSettingsCollection..::.FromXml Method
ReferenceLinkSettingsCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to load the reference link settings list from the configuration settings.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public void FromXml(
    IBasePathProvider pathProvider,
    XPathNavigator navigator
)
Visual Basic (Declaration)
Public Sub FromXml ( _
    pathProvider As IBasePathProvider, _
    navigator As XPathNavigator _
)

Parameters

pathProvider
Type: SandcastleBuilder.Utils..::.IBasePathProvider
The base path provider object
navigator
Type: System.Xml.XPath..::.XPathNavigator
The XPath navigator from which the information is loaded.

See Also

ReferenceLinkSettingsCollection Class
SandcastleBuilder.PlugIns Namespace


ToXml Method

[image]

Sandcastle Help File Builder Documentation
ReferenceLinkSettingsCollection..::.ToXml Method
ReferenceLinkSettingsCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to save the reference link settings list to the configuration settings.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public void ToXml(
    XmlDocument config,
    XmlNode root
)
Visual Basic (Declaration)
Public Sub ToXml ( _
    config As XmlDocument, _
    root As XmlNode _
)

Parameters

config
Type: System.Xml..::.XmlDocument
The XML configuration document.
root
Type: System.Xml..::.XmlNode
The root configuration node

See Also

ReferenceLinkSettingsCollection Class
SandcastleBuilder.PlugIns Namespace


ReferenceLinkSettingsCollection Properties

[image] [image]

Sandcastle Help File Builder Documentation
ReferenceLinkSettingsCollection Properties
ReferenceLinkSettingsCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ReferenceLinkSettingsCollection type exposes the following members.

Properties

Name | Description
AllowEdit | Gets or sets a value indicating whether items in the list can be edited. (Inherited from BindingList <(Of <( ReferenceLinkSettings >)>).)
AllowNew | Gets or sets a value indicating whether you can add items to the list using the AddNew()()() method. (Inherited from BindingList <(Of <( ReferenceLinkSettings >)>).)
AllowRemove | Gets or sets a value indicating whether you can remove items from the collection. (Inherited from BindingList <(Of <( ReferenceLinkSettings >)>).)
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ReferenceLinkSettings >)>).)
IsSortedCore | Gets a value indicating whether the list is sorted. (Inherited from BindingList <(Of <( ReferenceLinkSettings >)>).)
Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <( ReferenceLinkSettings >)>).)
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ReferenceLinkSettings >)>).)
RaiseListChangedEvents | Gets or sets a value indicating whether adding or removing items within the list raises ListChanged events. (Inherited from BindingList <(Of <( ReferenceLinkSettings >)>).)
SortDirectionCore | Gets the direction the list is sorted. (Inherited from BindingList <(Of <( ReferenceLinkSettings >)>).)
SortPropertyCore | Gets the property descriptor that is used for sorting the list if sorting is implemented in a derived class; otherwise, returns null. (Inherited from BindingList <(Of <( ReferenceLinkSettings >)>).)
SupportsChangeNotificationCore | Gets a value indicating whether ListChanged events are enabled. (Inherited from BindingList <(Of <( ReferenceLinkSettings >)>).)
SupportsSearchingCore | Gets a value indicating whether the list supports searching. (Inherited from BindingList <(Of <( ReferenceLinkSettings >)>).)
SupportsSortingCore | Gets a value indicating whether the list supports sorting. (Inherited from BindingList <(Of <( ReferenceLinkSettings >)>).)

See Also

ReferenceLinkSettingsCollection Class
SandcastleBuilder.PlugIns Namespace


ReferenceLinkSettingsCollection Events

[image] [image]

Sandcastle Help File Builder Documentation
ReferenceLinkSettingsCollection Events
ReferenceLinkSettingsCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ReferenceLinkSettingsCollection type exposes the following members.

Events

Name | Description
AddingNew | Occurs before an item is added to the list. (Inherited from BindingList <(Of <( ReferenceLinkSettings >)>).)
ListChanged | Occurs when the list or an item in the list changes. (Inherited from BindingList <(Of <( ReferenceLinkSettings >)>).)

See Also

ReferenceLinkSettingsCollection Class
SandcastleBuilder.PlugIns Namespace


ScriptSharpPlugIn Class

[image]

Sandcastle Help File Builder Documentation
ScriptSharpPlugIn Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This plug-in class is designed to modify the reflection information file produced after running MRefBuilder on assemblies produced by the Script# compiler so that it is suitable for use in producing a help file.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public class ScriptSharpPlugIn : IPlugIn,
    IDisposable
Visual Basic (Declaration)
Public Class ScriptSharpPlugIn _
    Implements IPlugIn, IDisposable

Inheritance Hierarchy

System..::.Object
SandcastleBuilder.PlugIns..::.ScriptSharpPlugIn

See Also

ScriptSharpPlugIn Members
SandcastleBuilder.PlugIns Namespace


ScriptSharpPlugIn Members

[image] [image]

Sandcastle Help File Builder Documentation
ScriptSharpPlugIn Members
ScriptSharpPlugIn Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ScriptSharpPlugIn type exposes the following members.

Constructors

Name | Description
ScriptSharpPlugIn | Initializes a new instance of the ScriptSharpPlugIn class

Methods

Name | Description
ConfigurePlugIn | This method is used by the Sandcastle Help File Builder to let the plug-in perform its own configuration.
Dispose | Overloaded. There are two overloads for this method.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | This method is used to execute the plug-in during the build process
Finalize | This handles garbage collection to ensure proper disposal of the plug-in if not done explicity with Dispose()()(). (Overrides Object..::.Finalize()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Initialize | This method is used to initialize the plug-in at the start of the build process.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Copyright | This read-only property returns the copyright information for the plug-in.
Description | This read-only property returns a brief description of the plug-in
ExecutionPoints | This read-only property returns a collection of execution points that define when the plug-in should be invoked during the build process.
Name | This read-only property returns a friendly name for the plug-in
RunsInPartialBuild | This plug-in runs in partial builds
Version | This read-only property returns the version of the plug-in

See Also

ScriptSharpPlugIn Class
SandcastleBuilder.PlugIns Namespace


ScriptSharpPlugIn Constructor

[image]

Sandcastle Help File Builder Documentation
ScriptSharpPlugIn Constructor
ScriptSharpPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ScriptSharpPlugIn class

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public ScriptSharpPlugIn()
Visual Basic (Declaration)
Public Sub New

See Also

ScriptSharpPlugIn Class
SandcastleBuilder.PlugIns Namespace


ScriptSharpPlugIn Methods

[image] [image]

Sandcastle Help File Builder Documentation
ScriptSharpPlugIn Methods
ScriptSharpPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ScriptSharpPlugIn type exposes the following members.

Methods

Name | Description
ConfigurePlugIn | This method is used by the Sandcastle Help File Builder to let the plug-in perform its own configuration.
Dispose | Overloaded. There are two overloads for this method.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | This method is used to execute the plug-in during the build process
Finalize | This handles garbage collection to ensure proper disposal of the plug-in if not done explicity with Dispose()()(). (Overrides Object..::.Finalize()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Initialize | This method is used to initialize the plug-in at the start of the build process.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ScriptSharpPlugIn Class
SandcastleBuilder.PlugIns Namespace


ConfigurePlugIn Method

[image]

Sandcastle Help File Builder Documentation
ScriptSharpPlugIn..::.ConfigurePlugIn Method
ScriptSharpPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This method is used by the Sandcastle Help File Builder to let the plug-in perform its own configuration.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public string ConfigurePlugIn(
    SandcastleProject project,
    string currentConfig
)
Visual Basic (Declaration)
Public Function ConfigurePlugIn ( _
    project As SandcastleProject, _
    currentConfig As String _
) As String

Parameters

project
Type: SandcastleBuilder.Utils..::.SandcastleProject
A reference to the active project
currentConfig
Type: System..::.String
The current configuration XML fragment

Return Value

A string containing the new configuration XML fragment

Implements

IPlugIn..::.ConfigurePlugIn(SandcastleProject, String)

Remarks

The configuration data will be stored in the help file builder project.

See Also

ScriptSharpPlugIn Class
SandcastleBuilder.PlugIns Namespace


Dispose Method

[image] [image]

Sandcastle Help File Builder Documentation
ScriptSharpPlugIn..::.Dispose Method
ScriptSharpPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

There are two overloads for this method.

Overload List

Name | Description
Dispose()()() | This implements the Dispose() interface to properly dispose of the plug-in object.
Dispose(Boolean) | This can be overridden by derived classes to add their own disposal code if necessary.

See Also

ScriptSharpPlugIn Class
ScriptSharpPlugIn Members
SandcastleBuilder.PlugIns Namespace


Dispose Method

[image]

Sandcastle Help File Builder Documentation
ScriptSharpPlugIn..::.Dispose Method
ScriptSharpPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This implements the Dispose() interface to properly dispose of the plug-in object.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose

Implements

IDisposable..::.Dispose()()()

See Also

ScriptSharpPlugIn Class
Dispose Overload
SandcastleBuilder.PlugIns Namespace


Dispose Method (Boolean)

[image]

Sandcastle Help File Builder Documentation
ScriptSharpPlugIn..::.Dispose Method (Boolean)
ScriptSharpPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This can be overridden by derived classes to add their own disposal code if necessary.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
protected virtual void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overridable Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
Pass true to dispose of the managed and unmanaged resources or false to just dispose of the unmanaged resources.

See Also

ScriptSharpPlugIn Class
Dispose Overload
SandcastleBuilder.PlugIns Namespace


Execute Method

[image]

Sandcastle Help File Builder Documentation
ScriptSharpPlugIn..::.Execute Method
ScriptSharpPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This method is used to execute the plug-in during the build process

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public void Execute(
    ExecutionContext context
)
Visual Basic (Declaration)
Public Sub Execute ( _
    context As ExecutionContext _
)

Parameters

context
Type: SandcastleBuilder.Utils.PlugIn..::.ExecutionContext
The current execution context

Implements

IPlugIn..::.Execute(ExecutionContext)

See Also

ScriptSharpPlugIn Class
SandcastleBuilder.PlugIns Namespace


Finalize Method

[image]

Sandcastle Help File Builder Documentation
ScriptSharpPlugIn..::.Finalize Method
ScriptSharpPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This handles garbage collection to ensure proper disposal of the plug-in if not done explicity with Dispose()()().

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
protected override void Finalize()
Visual Basic (Declaration)
Protected Overrides Sub Finalize

See Also

ScriptSharpPlugIn Class
SandcastleBuilder.PlugIns Namespace


Initialize Method

[image]

Sandcastle Help File Builder Documentation
ScriptSharpPlugIn..::.Initialize Method
ScriptSharpPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This method is used to initialize the plug-in at the start of the build process.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public void Initialize(
    BuildProcess buildProcess,
    XPathNavigator configuration
)
Visual Basic (Declaration)
Public Sub Initialize ( _
    buildProcess As BuildProcess, _
    configuration As XPathNavigator _
)

Parameters

buildProcess
Type: SandcastleBuilder.Utils.BuildEngine..::.BuildProcess
A reference to the current build process.
configuration
Type: System.Xml.XPath..::.XPathNavigator
The configuration data that the plug-in should use to initialize itself.

Implements

IPlugIn..::.Initialize(BuildProcess, XPathNavigator)

See Also

ScriptSharpPlugIn Class
SandcastleBuilder.PlugIns Namespace


ScriptSharpPlugIn Properties

[image] [image]

Sandcastle Help File Builder Documentation
ScriptSharpPlugIn Properties
ScriptSharpPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ScriptSharpPlugIn type exposes the following members.

Properties

Name | Description
Copyright | This read-only property returns the copyright information for the plug-in.
Description | This read-only property returns a brief description of the plug-in
ExecutionPoints | This read-only property returns a collection of execution points that define when the plug-in should be invoked during the build process.
Name | This read-only property returns a friendly name for the plug-in
RunsInPartialBuild | This plug-in runs in partial builds
Version | This read-only property returns the version of the plug-in

See Also

ScriptSharpPlugIn Class
SandcastleBuilder.PlugIns Namespace


Copyright Property

[image]

Sandcastle Help File Builder Documentation
ScriptSharpPlugIn..::.Copyright Property
ScriptSharpPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns the copyright information for the plug-in.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public string Copyright { get; }
Visual Basic (Declaration)
Public ReadOnly Property Copyright As String

Implements

IPlugIn..::.Copyright

See Also

ScriptSharpPlugIn Class
SandcastleBuilder.PlugIns Namespace


Description Property

[image]

Sandcastle Help File Builder Documentation
ScriptSharpPlugIn..::.Description Property
ScriptSharpPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns a brief description of the plug-in

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public string Description { get; }
Visual Basic (Declaration)
Public ReadOnly Property Description As String

Implements

IPlugIn..::.Description

See Also

ScriptSharpPlugIn Class
SandcastleBuilder.PlugIns Namespace


ExecutionPoints Property

[image]

Sandcastle Help File Builder Documentation
ScriptSharpPlugIn..::.ExecutionPoints Property
ScriptSharpPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns a collection of execution points that define when the plug-in should be invoked during the build process.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public ExecutionPointCollection ExecutionPoints { get; }
Visual Basic (Declaration)
Public ReadOnly Property ExecutionPoints As ExecutionPointCollection

Implements

IPlugIn..::.ExecutionPoints

See Also

ScriptSharpPlugIn Class
SandcastleBuilder.PlugIns Namespace


Name Property

[image]

Sandcastle Help File Builder Documentation
ScriptSharpPlugIn..::.Name Property
ScriptSharpPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns a friendly name for the plug-in

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String

Implements

IPlugIn..::.Name

See Also

ScriptSharpPlugIn Class
SandcastleBuilder.PlugIns Namespace


RunsInPartialBuild Property

[image]

Sandcastle Help File Builder Documentation
ScriptSharpPlugIn..::.RunsInPartialBuild Property
ScriptSharpPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This plug-in runs in partial builds

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public bool RunsInPartialBuild { get; }
Visual Basic (Declaration)
Public ReadOnly Property RunsInPartialBuild As Boolean

Implements

IPlugIn..::.RunsInPartialBuild

See Also

ScriptSharpPlugIn Class
SandcastleBuilder.PlugIns Namespace


Version Property

[image]

Sandcastle Help File Builder Documentation
ScriptSharpPlugIn..::.Version Property
ScriptSharpPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns the version of the plug-in

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public Version Version { get; }
Visual Basic (Declaration)
Public ReadOnly Property Version As Version

Implements

IPlugIn..::.Version

See Also

ScriptSharpPlugIn Class
SandcastleBuilder.PlugIns Namespace


TocExcludePlugIn Class

[image]

Sandcastle Help File Builder Documentation
TocExcludePlugIn Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This plug-in class can be used to exclude API members from the table of contents via the <tocexclude /> XML comment tag. The excluded items are still accessible in the help file via other topic links.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public class TocExcludePlugIn : IPlugIn,
    IDisposable
Visual Basic (Declaration)
Public Class TocExcludePlugIn _
    Implements IPlugIn, IDisposable

Inheritance Hierarchy

System..::.Object
SandcastleBuilder.PlugIns..::.TocExcludePlugIn

See Also

TocExcludePlugIn Members
SandcastleBuilder.PlugIns Namespace


TocExcludePlugIn Members

[image] [image]

Sandcastle Help File Builder Documentation
TocExcludePlugIn Members
TocExcludePlugIn Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TocExcludePlugIn type exposes the following members.

Constructors

Name | Description
TocExcludePlugIn | Initializes a new instance of the TocExcludePlugIn class

Methods

Name | Description
ConfigurePlugIn | This method is used by the Sandcastle Help File Builder to let the plug-in perform its own configuration.
Dispose | Overloaded. There are two overloads for this method.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | This method is used to execute the plug-in during the build process
Finalize | This handles garbage collection to ensure proper disposal of the plug-in if not done explicity with Dispose()()(). (Overrides Object..::.Finalize()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Initialize | This method is used to initialize the plug-in at the start of the build process.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Copyright | This read-only property returns the copyright information for the plug-in.
Description | This read-only property returns a brief description of the plug-in
ExecutionPoints | This read-only property returns a collection of execution points that define when the plug-in should be invoked during the build process.
Name | This read-only property returns a friendly name for the plug-in
RunsInPartialBuild | This plug-in does not run in partial builds
Version | This read-only property returns the version of the plug-in

See Also

TocExcludePlugIn Class
SandcastleBuilder.PlugIns Namespace


TocExcludePlugIn Constructor

[image]

Sandcastle Help File Builder Documentation
TocExcludePlugIn Constructor
TocExcludePlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TocExcludePlugIn class

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public TocExcludePlugIn()
Visual Basic (Declaration)
Public Sub New

See Also

TocExcludePlugIn Class
SandcastleBuilder.PlugIns Namespace


TocExcludePlugIn Methods

[image] [image]

Sandcastle Help File Builder Documentation
TocExcludePlugIn Methods
TocExcludePlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TocExcludePlugIn type exposes the following members.

Methods

Name | Description
ConfigurePlugIn | This method is used by the Sandcastle Help File Builder to let the plug-in perform its own configuration.
Dispose | Overloaded. There are two overloads for this method.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | This method is used to execute the plug-in during the build process
Finalize | This handles garbage collection to ensure proper disposal of the plug-in if not done explicity with Dispose()()(). (Overrides Object..::.Finalize()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Initialize | This method is used to initialize the plug-in at the start of the build process.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TocExcludePlugIn Class
SandcastleBuilder.PlugIns Namespace


ConfigurePlugIn Method

[image]

Sandcastle Help File Builder Documentation
TocExcludePlugIn..::.ConfigurePlugIn Method
TocExcludePlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This method is used by the Sandcastle Help File Builder to let the plug-in perform its own configuration.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public string ConfigurePlugIn(
    SandcastleProject project,
    string currentConfig
)
Visual Basic (Declaration)
Public Function ConfigurePlugIn ( _
    project As SandcastleProject, _
    currentConfig As String _
) As String

Parameters

project
Type: SandcastleBuilder.Utils..::.SandcastleProject
A reference to the active project
currentConfig
Type: System..::.String
The current configuration XML fragment

Return Value

A string containing the new configuration XML fragment

Implements

IPlugIn..::.ConfigurePlugIn(SandcastleProject, String)

Remarks

The configuration data will be stored in the help file builder project.

See Also

TocExcludePlugIn Class
SandcastleBuilder.PlugIns Namespace


Dispose Method

[image] [image]

Sandcastle Help File Builder Documentation
TocExcludePlugIn..::.Dispose Method
TocExcludePlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

There are two overloads for this method.

Overload List

Name | Description
Dispose()()() | This implements the Dispose() interface to properly dispose of the plug-in object.
Dispose(Boolean) | This can be overridden by derived classes to add their own disposal code if necessary.

See Also

TocExcludePlugIn Class
TocExcludePlugIn Members
SandcastleBuilder.PlugIns Namespace


Dispose Method

[image]

Sandcastle Help File Builder Documentation
TocExcludePlugIn..::.Dispose Method
TocExcludePlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This implements the Dispose() interface to properly dispose of the plug-in object.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose

Implements

IDisposable..::.Dispose()()()

See Also

TocExcludePlugIn Class
Dispose Overload
SandcastleBuilder.PlugIns Namespace


Dispose Method (Boolean)

[image]

Sandcastle Help File Builder Documentation
TocExcludePlugIn..::.Dispose Method (Boolean)
TocExcludePlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This can be overridden by derived classes to add their own disposal code if necessary.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
protected virtual void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overridable Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
Pass true to dispose of the managed and unmanaged resources or false to just dispose of the unmanaged resources.

See Also

TocExcludePlugIn Class
Dispose Overload
SandcastleBuilder.PlugIns Namespace


Execute Method

[image]

Sandcastle Help File Builder Documentation
TocExcludePlugIn..::.Execute Method
TocExcludePlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This method is used to execute the plug-in during the build process

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public void Execute(
    ExecutionContext context
)
Visual Basic (Declaration)
Public Sub Execute ( _
    context As ExecutionContext _
)

Parameters

context
Type: SandcastleBuilder.Utils.PlugIn..::.ExecutionContext
The current execution context

Implements

IPlugIn..::.Execute(ExecutionContext)

See Also

TocExcludePlugIn Class
SandcastleBuilder.PlugIns Namespace


Finalize Method

[image]

Sandcastle Help File Builder Documentation
TocExcludePlugIn..::.Finalize Method
TocExcludePlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This handles garbage collection to ensure proper disposal of the plug-in if not done explicity with Dispose()()().

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
protected override void Finalize()
Visual Basic (Declaration)
Protected Overrides Sub Finalize

See Also

TocExcludePlugIn Class
SandcastleBuilder.PlugIns Namespace


Initialize Method

[image]

Sandcastle Help File Builder Documentation
TocExcludePlugIn..::.Initialize Method
TocExcludePlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This method is used to initialize the plug-in at the start of the build process.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public void Initialize(
    BuildProcess buildProcess,
    XPathNavigator configuration
)
Visual Basic (Declaration)
Public Sub Initialize ( _
    buildProcess As BuildProcess, _
    configuration As XPathNavigator _
)

Parameters

buildProcess
Type: SandcastleBuilder.Utils.BuildEngine..::.BuildProcess
A reference to the current build process.
configuration
Type: System.Xml.XPath..::.XPathNavigator
The configuration data that the plug-in should use to initialize itself.

Implements

IPlugIn..::.Initialize(BuildProcess, XPathNavigator)

See Also

TocExcludePlugIn Class
SandcastleBuilder.PlugIns Namespace


TocExcludePlugIn Properties

[image] [image]

Sandcastle Help File Builder Documentation
TocExcludePlugIn Properties
TocExcludePlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TocExcludePlugIn type exposes the following members.

Properties

Name | Description
Copyright | This read-only property returns the copyright information for the plug-in.
Description | This read-only property returns a brief description of the plug-in
ExecutionPoints | This read-only property returns a collection of execution points that define when the plug-in should be invoked during the build process.
Name | This read-only property returns a friendly name for the plug-in
RunsInPartialBuild | This plug-in does not run in partial builds
Version | This read-only property returns the version of the plug-in

See Also

TocExcludePlugIn Class
SandcastleBuilder.PlugIns Namespace


Copyright Property

[image]

Sandcastle Help File Builder Documentation
TocExcludePlugIn..::.Copyright Property
TocExcludePlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns the copyright information for the plug-in.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public string Copyright { get; }
Visual Basic (Declaration)
Public ReadOnly Property Copyright As String

Implements

IPlugIn..::.Copyright

See Also

TocExcludePlugIn Class
SandcastleBuilder.PlugIns Namespace


Description Property

[image]

Sandcastle Help File Builder Documentation
TocExcludePlugIn..::.Description Property
TocExcludePlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns a brief description of the plug-in

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public string Description { get; }
Visual Basic (Declaration)
Public ReadOnly Property Description As String

Implements

IPlugIn..::.Description

See Also

TocExcludePlugIn Class
SandcastleBuilder.PlugIns Namespace


ExecutionPoints Property

[image]

Sandcastle Help File Builder Documentation
TocExcludePlugIn..::.ExecutionPoints Property
TocExcludePlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns a collection of execution points that define when the plug-in should be invoked during the build process.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public ExecutionPointCollection ExecutionPoints { get; }
Visual Basic (Declaration)
Public ReadOnly Property ExecutionPoints As ExecutionPointCollection

Implements

IPlugIn..::.ExecutionPoints

See Also

TocExcludePlugIn Class
SandcastleBuilder.PlugIns Namespace


Name Property

[image]

Sandcastle Help File Builder Documentation
TocExcludePlugIn..::.Name Property
TocExcludePlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns a friendly name for the plug-in

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String

Implements

IPlugIn..::.Name

See Also

TocExcludePlugIn Class
SandcastleBuilder.PlugIns Namespace


RunsInPartialBuild Property

[image]

Sandcastle Help File Builder Documentation
TocExcludePlugIn..::.RunsInPartialBuild Property
TocExcludePlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This plug-in does not run in partial builds

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public bool RunsInPartialBuild { get; }
Visual Basic (Declaration)
Public ReadOnly Property RunsInPartialBuild As Boolean

Implements

IPlugIn..::.RunsInPartialBuild

See Also

TocExcludePlugIn Class
SandcastleBuilder.PlugIns Namespace


Version Property

[image]

Sandcastle Help File Builder Documentation
TocExcludePlugIn..::.Version Property
TocExcludePlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns the version of the plug-in

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public Version Version { get; }
Visual Basic (Declaration)
Public ReadOnly Property Version As Version

Implements

IPlugIn..::.Version

See Also

TocExcludePlugIn Class
SandcastleBuilder.PlugIns Namespace


UserCredentials Class

[image]

Sandcastle Help File Builder Documentation
UserCredentials Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This class is used to specify user credentials.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public class UserCredentials
Visual Basic (Declaration)
Public Class UserCredentials

Inheritance Hierarchy

System..::.Object
SandcastleBuilder.PlugIns..::.UserCredentials

See Also

UserCredentials Members
SandcastleBuilder.PlugIns Namespace


UserCredentials Members

[image] [image]

Sandcastle Help File Builder Documentation
UserCredentials Members
UserCredentials Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The UserCredentials type exposes the following members.

Constructors

Name | Description
UserCredentials | Overloaded. There are two overloads for the constructor.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromXPathNavigator | Create a user credentials instance from an XPath navigator containing the settings.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | Store the credentials as a node in the given XML document

Properties

Name | Description
Password | Get or set the password
UseDefaultCredentials | This is used to set or get the flag indicating whether or not to use default credentials.
UserName | Get or set the user name

See Also

UserCredentials Class
SandcastleBuilder.PlugIns Namespace


UserCredentials Constructor

[image] [image]

Sandcastle Help File Builder Documentation
UserCredentials Constructor
UserCredentials Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

There are two overloads for the constructor.

Overload List

Name | Description
UserCredentials()()() | Constructor
UserCredentials(Boolean, String, String) | Constructor

See Also

UserCredentials Class
UserCredentials Members
SandcastleBuilder.PlugIns Namespace


UserCredentials Constructor

[image]

Sandcastle Help File Builder Documentation
UserCredentials Constructor
UserCredentials Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public UserCredentials()
Visual Basic (Declaration)
Public Sub New

See Also

UserCredentials Class
UserCredentials Overload
SandcastleBuilder.PlugIns Namespace


UserCredentials Constructor (Boolean, String, String)

[image]

Sandcastle Help File Builder Documentation
UserCredentials Constructor (Boolean, String, String)
UserCredentials Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public UserCredentials(
    bool useDefault,
    string user,
    string pwd
)
Visual Basic (Declaration)
Public Sub New ( _
    useDefault As Boolean, _
    user As String, _
    pwd As String _
)

Parameters

useDefault
Type: System..::.Boolean
True to use default credentials, false to use the supplied user name and password.
user
Type: System..::.String
The user name to use.
pwd
Type: System..::.String
The password to use.

See Also

UserCredentials Class
UserCredentials Overload
SandcastleBuilder.PlugIns Namespace


UserCredentials Methods

[image] [image]

Sandcastle Help File Builder Documentation
UserCredentials Methods
UserCredentials Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The UserCredentials type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromXPathNavigator | Create a user credentials instance from an XPath navigator containing the settings.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | Store the credentials as a node in the given XML document

See Also

UserCredentials Class
SandcastleBuilder.PlugIns Namespace


FromXPathNavigator Method

[image]

Sandcastle Help File Builder Documentation
UserCredentials..::.FromXPathNavigator Method
UserCredentials Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Create a user credentials instance from an XPath navigator containing the settings.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public static UserCredentials FromXPathNavigator(
    XPathNavigator navigator
)
Visual Basic (Declaration)
Public Shared Function FromXPathNavigator ( _
    navigator As XPathNavigator _
) As UserCredentials

Parameters

navigator
Type: System.Xml.XPath..::.XPathNavigator
The XPath navigator from which to obtain the settings.

Return Value

A UserCredentials object containing the settings from the XPath navigator.

Remarks

It should contain an element called userCredentials with three attributes: useDefault, userName, and password.

See Also

UserCredentials Class
SandcastleBuilder.PlugIns Namespace


ToXml Method

[image]

Sandcastle Help File Builder Documentation
UserCredentials..::.ToXml Method
UserCredentials Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Store the credentials as a node in the given XML document

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public XmlNode ToXml(
    XmlDocument config,
    XmlNode root
)
Visual Basic (Declaration)
Public Function ToXml ( _
    config As XmlDocument, _
    root As XmlNode _
) As XmlNode

Parameters

config
Type: System.Xml..::.XmlDocument
The XML document
root
Type: System.Xml..::.XmlNode
The node in which to store the element

Return Value

Returns the node that was added or the one that already existed in the document.

Remarks

The credentials are stored in an element called userCredentials with three attributes: useDefault, userName, and password. It is created if it does not already exist.

See Also

UserCredentials Class
SandcastleBuilder.PlugIns Namespace


UserCredentials Properties

[image] [image]

Sandcastle Help File Builder Documentation
UserCredentials Properties
UserCredentials Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The UserCredentials type exposes the following members.

Properties

Name | Description
Password | Get or set the password
UseDefaultCredentials | This is used to set or get the flag indicating whether or not to use default credentials.
UserName | Get or set the user name

See Also

UserCredentials Class
SandcastleBuilder.PlugIns Namespace


Password Property

[image]

Sandcastle Help File Builder Documentation
UserCredentials..::.Password Property
UserCredentials Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Get or set the password

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public string Password { get; set; }
Visual Basic (Declaration)
Public Property Password As String

Field Value

If UseDefaultCredentials is true, this will be ignored.

See Also

UserCredentials Class
SandcastleBuilder.PlugIns Namespace


UseDefaultCredentials Property

[image]

Sandcastle Help File Builder Documentation
UserCredentials..::.UseDefaultCredentials Property
UserCredentials Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to set or get the flag indicating whether or not to use default credentials.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public bool UseDefaultCredentials { get; set; }
Visual Basic (Declaration)
Public Property UseDefaultCredentials As Boolean

Field Value

By default, this is true and UserName and Password will be ignored.

See Also

UserCredentials Class
SandcastleBuilder.PlugIns Namespace


UserName Property

[image]

Sandcastle Help File Builder Documentation
UserCredentials..::.UserName Property
UserCredentials Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Get or set the user name

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public string UserName { get; set; }
Visual Basic (Declaration)
Public Property UserName As String

Field Value

If UseDefaultCredentials is true, this will be ignored.

See Also

UserCredentials Class
SandcastleBuilder.PlugIns Namespace


VersionBuilderPlugIn Class

[image]

Sandcastle Help File Builder Documentation
VersionBuilderPlugIn Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This plug-in class is designed to generate version information for assemblies in the current project and others related to the same product that can be merged into the current project's help file topics.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public class VersionBuilderPlugIn : IPlugIn,
    IDisposable
Visual Basic (Declaration)
Public Class VersionBuilderPlugIn _
    Implements IPlugIn, IDisposable

Inheritance Hierarchy

System..::.Object
SandcastleBuilder.PlugIns..::.VersionBuilderPlugIn

See Also

VersionBuilderPlugIn Members
SandcastleBuilder.PlugIns Namespace


VersionBuilderPlugIn Members

[image] [image]

Sandcastle Help File Builder Documentation
VersionBuilderPlugIn Members
VersionBuilderPlugIn Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The VersionBuilderPlugIn type exposes the following members.

Constructors

Name | Description
VersionBuilderPlugIn | Initializes a new instance of the VersionBuilderPlugIn class

Methods

Name | Description
ConfigurePlugIn | This method is used by the Sandcastle Help File Builder to let the plug-in perform its own configuration.
Dispose | Overloaded. There are two overloads for this method.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | This method is used to execute the plug-in during the build process
Finalize | This handles garbage collection to ensure proper disposal of the plug-in if not done explicity with Dispose()()(). (Overrides Object..::.Finalize()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Initialize | This method is used to initialize the plug-in at the start of the build process.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Copyright | This read-only property returns the copyright information for the plug-in.
Description | This read-only property returns a brief description of the plug-in
ExecutionPoints | This read-only property returns a collection of execution points that define when the plug-in should be invoked during the build process.
Name | This read-only property returns a friendly name for the plug-in
RunsInPartialBuild | This plug-in runs in partial builds
Version | This read-only property returns the version of the plug-in

See Also

VersionBuilderPlugIn Class
SandcastleBuilder.PlugIns Namespace


VersionBuilderPlugIn Constructor

[image]

Sandcastle Help File Builder Documentation
VersionBuilderPlugIn Constructor
VersionBuilderPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the VersionBuilderPlugIn class

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public VersionBuilderPlugIn()
Visual Basic (Declaration)
Public Sub New

See Also

VersionBuilderPlugIn Class
SandcastleBuilder.PlugIns Namespace


VersionBuilderPlugIn Methods

[image] [image]

Sandcastle Help File Builder Documentation
VersionBuilderPlugIn Methods
VersionBuilderPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The VersionBuilderPlugIn type exposes the following members.

Methods

Name | Description
ConfigurePlugIn | This method is used by the Sandcastle Help File Builder to let the plug-in perform its own configuration.
Dispose | Overloaded. There are two overloads for this method.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | This method is used to execute the plug-in during the build process
Finalize | This handles garbage collection to ensure proper disposal of the plug-in if not done explicity with Dispose()()(). (Overrides Object..::.Finalize()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Initialize | This method is used to initialize the plug-in at the start of the build process.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VersionBuilderPlugIn Class
SandcastleBuilder.PlugIns Namespace


ConfigurePlugIn Method

[image]

Sandcastle Help File Builder Documentation
VersionBuilderPlugIn..::.ConfigurePlugIn Method
VersionBuilderPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This method is used by the Sandcastle Help File Builder to let the plug-in perform its own configuration.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public string ConfigurePlugIn(
    SandcastleProject project,
    string currentConfig
)
Visual Basic (Declaration)
Public Function ConfigurePlugIn ( _
    project As SandcastleProject, _
    currentConfig As String _
) As String

Parameters

project
Type: SandcastleBuilder.Utils..::.SandcastleProject
A reference to the active project
currentConfig
Type: System..::.String
The current configuration XML fragment

Return Value

A string containing the new configuration XML fragment

Implements

IPlugIn..::.ConfigurePlugIn(SandcastleProject, String)

Remarks

The configuration data will be stored in the help file builder project.

See Also

VersionBuilderPlugIn Class
SandcastleBuilder.PlugIns Namespace


Dispose Method

[image] [image]

Sandcastle Help File Builder Documentation
VersionBuilderPlugIn..::.Dispose Method
VersionBuilderPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

There are two overloads for this method.

Overload List

Name | Description
Dispose()()() | This implements the Dispose() interface to properly dispose of the plug-in object.
Dispose(Boolean) | This can be overridden by derived classes to add their own disposal code if necessary.

See Also

VersionBuilderPlugIn Class
VersionBuilderPlugIn Members
SandcastleBuilder.PlugIns Namespace


Dispose Method

[image]

Sandcastle Help File Builder Documentation
VersionBuilderPlugIn..::.Dispose Method
VersionBuilderPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This implements the Dispose() interface to properly dispose of the plug-in object.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose

Implements

IDisposable..::.Dispose()()()

See Also

VersionBuilderPlugIn Class
Dispose Overload
SandcastleBuilder.PlugIns Namespace


Dispose Method (Boolean)

[image]

Sandcastle Help File Builder Documentation
VersionBuilderPlugIn..::.Dispose Method (Boolean)
VersionBuilderPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This can be overridden by derived classes to add their own disposal code if necessary.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
protected virtual void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overridable Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
Pass true to dispose of the managed and unmanaged resources or false to just dispose of the unmanaged resources.

See Also

VersionBuilderPlugIn Class
Dispose Overload
SandcastleBuilder.PlugIns Namespace


Execute Method

[image]

Sandcastle Help File Builder Documentation
VersionBuilderPlugIn..::.Execute Method
VersionBuilderPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This method is used to execute the plug-in during the build process

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public void Execute(
    ExecutionContext context
)
Visual Basic (Declaration)
Public Sub Execute ( _
    context As ExecutionContext _
)

Parameters

context
Type: SandcastleBuilder.Utils.PlugIn..::.ExecutionContext
The current execution context

Implements

IPlugIn..::.Execute(ExecutionContext)

See Also

VersionBuilderPlugIn Class
SandcastleBuilder.PlugIns Namespace


Finalize Method

[image]

Sandcastle Help File Builder Documentation
VersionBuilderPlugIn..::.Finalize Method
VersionBuilderPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This handles garbage collection to ensure proper disposal of the plug-in if not done explicity with Dispose()()().

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
protected override void Finalize()
Visual Basic (Declaration)
Protected Overrides Sub Finalize

See Also

VersionBuilderPlugIn Class
SandcastleBuilder.PlugIns Namespace


Initialize Method

[image]

Sandcastle Help File Builder Documentation
VersionBuilderPlugIn..::.Initialize Method
VersionBuilderPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This method is used to initialize the plug-in at the start of the build process.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public void Initialize(
    BuildProcess buildProcess,
    XPathNavigator configuration
)
Visual Basic (Declaration)
Public Sub Initialize ( _
    buildProcess As BuildProcess, _
    configuration As XPathNavigator _
)

Parameters

buildProcess
Type: SandcastleBuilder.Utils.BuildEngine..::.BuildProcess
A reference to the current build process.
configuration
Type: System.Xml.XPath..::.XPathNavigator
The configuration data that the plug-in should use to initialize itself.

Implements

IPlugIn..::.Initialize(BuildProcess, XPathNavigator)

Exceptions

Exception | Condition
SandcastleBuilder.Utils..::.BuilderException | This is thrown if the plug-in configuration is not valid.

See Also

VersionBuilderPlugIn Class
SandcastleBuilder.PlugIns Namespace


VersionBuilderPlugIn Properties

[image] [image]

Sandcastle Help File Builder Documentation
VersionBuilderPlugIn Properties
VersionBuilderPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The VersionBuilderPlugIn type exposes the following members.

Properties

Name | Description
Copyright | This read-only property returns the copyright information for the plug-in.
Description | This read-only property returns a brief description of the plug-in
ExecutionPoints | This read-only property returns a collection of execution points that define when the plug-in should be invoked during the build process.
Name | This read-only property returns a friendly name for the plug-in
RunsInPartialBuild | This plug-in runs in partial builds
Version | This read-only property returns the version of the plug-in

See Also

VersionBuilderPlugIn Class
SandcastleBuilder.PlugIns Namespace


Copyright Property

[image]

Sandcastle Help File Builder Documentation
VersionBuilderPlugIn..::.Copyright Property
VersionBuilderPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns the copyright information for the plug-in.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public string Copyright { get; }
Visual Basic (Declaration)
Public ReadOnly Property Copyright As String

Implements

IPlugIn..::.Copyright

See Also

VersionBuilderPlugIn Class
SandcastleBuilder.PlugIns Namespace


Description Property

[image]

Sandcastle Help File Builder Documentation
VersionBuilderPlugIn..::.Description Property
VersionBuilderPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns a brief description of the plug-in

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public string Description { get; }
Visual Basic (Declaration)
Public ReadOnly Property Description As String

Implements

IPlugIn..::.Description

See Also

VersionBuilderPlugIn Class
SandcastleBuilder.PlugIns Namespace


ExecutionPoints Property

[image]

Sandcastle Help File Builder Documentation
VersionBuilderPlugIn..::.ExecutionPoints Property
VersionBuilderPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns a collection of execution points that define when the plug-in should be invoked during the build process.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public ExecutionPointCollection ExecutionPoints { get; }
Visual Basic (Declaration)
Public ReadOnly Property ExecutionPoints As ExecutionPointCollection

Implements

IPlugIn..::.ExecutionPoints

See Also

VersionBuilderPlugIn Class
SandcastleBuilder.PlugIns Namespace


Name Property

[image]

Sandcastle Help File Builder Documentation
VersionBuilderPlugIn..::.Name Property
VersionBuilderPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns a friendly name for the plug-in

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String

Implements

IPlugIn..::.Name

See Also

VersionBuilderPlugIn Class
SandcastleBuilder.PlugIns Namespace


RunsInPartialBuild Property

[image]

Sandcastle Help File Builder Documentation
VersionBuilderPlugIn..::.RunsInPartialBuild Property
VersionBuilderPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This plug-in runs in partial builds

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public bool RunsInPartialBuild { get; }
Visual Basic (Declaration)
Public ReadOnly Property RunsInPartialBuild As Boolean

Implements

IPlugIn..::.RunsInPartialBuild

See Also

VersionBuilderPlugIn Class
SandcastleBuilder.PlugIns Namespace


Version Property

[image]

Sandcastle Help File Builder Documentation
VersionBuilderPlugIn..::.Version Property
VersionBuilderPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns the version of the plug-in

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public Version Version { get; }
Visual Basic (Declaration)
Public ReadOnly Property Version As Version

Implements

IPlugIn..::.Version

See Also

VersionBuilderPlugIn Class
SandcastleBuilder.PlugIns Namespace


VersionSettings Class

[image]

Sandcastle Help File Builder Documentation
VersionSettings Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This represents version settings for the VersionBuilderPlugIn.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public class VersionSettings
Visual Basic (Declaration)
Public Class VersionSettings

Inheritance Hierarchy

System..::.Object
SandcastleBuilder.PlugIns..::.VersionSettings

See Also

VersionSettings Members
SandcastleBuilder.PlugIns Namespace


VersionSettings Members

[image] [image]

Sandcastle Help File Builder Documentation
VersionSettings Members
VersionSettings Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The VersionSettings type exposes the following members.

Constructors

Name | Description
VersionSettings | Constructor

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromXPathNavigator | Create a version settings instance from an XPath navigator containing the settings.
GetHashCode | This is overridden to return the hash code of the combined framework and version number. (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | Store the version settings as a node in the given XML document

Properties

Name | Description
FrameworkLabel | This is used to get or set the framework label for the related project.
HelpFileProject | This is used to get or set the path to the help file builder project used to generate version information.
ListDescription | This returns a description of the entry suitable for display in a bound list control.
Version | This is used to get or set the version number description for the related project.

See Also

VersionSettings Class
SandcastleBuilder.PlugIns Namespace


VersionSettings Constructor

[image]

Sandcastle Help File Builder Documentation
VersionSettings Constructor
VersionSettings Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public VersionSettings()
Visual Basic (Declaration)
Public Sub New

See Also

VersionSettings Class
SandcastleBuilder.PlugIns Namespace


VersionSettings Methods

[image] [image]

Sandcastle Help File Builder Documentation
VersionSettings Methods
VersionSettings Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The VersionSettings type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromXPathNavigator | Create a version settings instance from an XPath navigator containing the settings.
GetHashCode | This is overridden to return the hash code of the combined framework and version number. (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | Store the version settings as a node in the given XML document

See Also

VersionSettings Class
SandcastleBuilder.PlugIns Namespace


FromXPathNavigator Method

[image]

Sandcastle Help File Builder Documentation
VersionSettings..::.FromXPathNavigator Method
VersionSettings Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Create a version settings instance from an XPath navigator containing the settings.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public static VersionSettings FromXPathNavigator(
    IBasePathProvider pathProvider,
    XPathNavigator navigator
)
Visual Basic (Declaration)
Public Shared Function FromXPathNavigator ( _
    pathProvider As IBasePathProvider, _
    navigator As XPathNavigator _
) As VersionSettings

Parameters

pathProvider
Type: SandcastleBuilder.Utils..::.IBasePathProvider
The base path provider object
navigator
Type: System.Xml.XPath..::.XPathNavigator
The XPath navigator from which to obtain the settings.

Return Value

A VersionSettings object containing the settings from the XPath navigator.

Remarks

It should contain an element called version with three attributes (label, version and helpFileProject).

See Also

VersionSettings Class
SandcastleBuilder.PlugIns Namespace


GetHashCode Method

[image]

Sandcastle Help File Builder Documentation
VersionSettings..::.GetHashCode Method
VersionSettings Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is overridden to return the hash code of the combined framework and version number.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer

Return Value

The hash code for the version settings.

See Also

VersionSettings Class
SandcastleBuilder.PlugIns Namespace


ToXml Method

[image]

Sandcastle Help File Builder Documentation
VersionSettings..::.ToXml Method
VersionSettings Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Store the version settings as a node in the given XML document

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public XmlNode ToXml(
    XmlDocument config,
    XmlNode root
)
Visual Basic (Declaration)
Public Function ToXml ( _
    config As XmlDocument, _
    root As XmlNode _
) As XmlNode

Parameters

config
Type: System.Xml..::.XmlDocument
The XML document
root
Type: System.Xml..::.XmlNode
The node in which to store the element

Return Value

Returns the node that was added.

Remarks

The version settings are stored in an element called version with three attributes (label, version and helpFileProject).

See Also

VersionSettings Class
SandcastleBuilder.PlugIns Namespace


VersionSettings Properties

[image] [image]

Sandcastle Help File Builder Documentation
VersionSettings Properties
VersionSettings Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The VersionSettings type exposes the following members.

Properties

Name | Description
FrameworkLabel | This is used to get or set the framework label for the related project.
HelpFileProject | This is used to get or set the path to the help file builder project used to generate version information.
ListDescription | This returns a description of the entry suitable for display in a bound list control.
Version | This is used to get or set the version number description for the related project.

See Also

VersionSettings Class
SandcastleBuilder.PlugIns Namespace


FrameworkLabel Property

[image]

Sandcastle Help File Builder Documentation
VersionSettings..::.FrameworkLabel Property
VersionSettings Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set the framework label for the related project.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public string FrameworkLabel { get; set; }
Visual Basic (Declaration)
Public Property FrameworkLabel As String

Remarks

This is used to group like versions of projects.

See Also

VersionSettings Class
SandcastleBuilder.PlugIns Namespace


HelpFileProject Property

[image]

Sandcastle Help File Builder Documentation
VersionSettings..::.HelpFileProject Property
VersionSettings Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set the path to the help file builder project used to generate version information.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public FilePath HelpFileProject { get; set; }
Visual Basic (Declaration)
Public Property HelpFileProject As FilePath

Field Value

The help file builder project makes it simple to manage settings for the prior version's assemblies such as references, API filter settings, etc.

See Also

VersionSettings Class
SandcastleBuilder.PlugIns Namespace


ListDescription Property

[image]

Sandcastle Help File Builder Documentation
VersionSettings..::.ListDescription Property
VersionSettings Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This returns a description of the entry suitable for display in a bound list control.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public string ListDescription { get; }
Visual Basic (Declaration)
Public ReadOnly Property ListDescription As String

See Also

VersionSettings Class
SandcastleBuilder.PlugIns Namespace


Version Property

[image]

Sandcastle Help File Builder Documentation
VersionSettings..::.Version Property
VersionSettings Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set the version number description for the related project.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public string Version { get; set; }
Visual Basic (Declaration)
Public Property Version As String

See Also

VersionSettings Class
SandcastleBuilder.PlugIns Namespace


VersionSettingsCollection Class

[image]

Sandcastle Help File Builder Documentation
VersionSettingsCollection Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This collection class is used to hold the version settings information for the VersionBuilderPlugIn.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public class VersionSettingsCollection : BindingList<VersionSettings>
Visual Basic (Declaration)
Public Class VersionSettingsCollection _
    Inherits BindingList(Of VersionSettings)

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection <(Of <( VersionSettings >)>)
System.ComponentModel..::.BindingList <(Of <( VersionSettings >)>)
SandcastleBuilder.PlugIns..::.VersionSettingsCollection

See Also

VersionSettingsCollection Members
SandcastleBuilder.PlugIns Namespace


VersionSettingsCollection Members

[image] [image]

Sandcastle Help File Builder Documentation
VersionSettingsCollection Members
VersionSettingsCollection Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The VersionSettingsCollection type exposes the following members.

Constructors

Name | Description
VersionSettingsCollection | Initializes a new instance of the VersionSettingsCollection class

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( VersionSettings >)>).)
AddNew | Adds a new item to the collection. (Inherited from BindingList <(Of <( VersionSettings >)>).)
AddNewCore | Adds a new item to the end of the collection. (Inherited from BindingList <(Of <( VersionSettings >)>).)
ApplySortCore | Sorts the items if overridden in a derived class; otherwise, throws a NotSupportedException. (Inherited from BindingList <(Of <( VersionSettings >)>).)
CancelNew | Discards a pending new item. (Inherited from BindingList <(Of <( VersionSettings >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( VersionSettings >)>).)
ClearItems | Removes all elements from the collection. (Inherited from BindingList <(Of <( VersionSettings >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( VersionSettings >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <( VersionSettings >)>).)
EndNew | Commits a pending new item to the collection. (Inherited from BindingList <(Of <( VersionSettings >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindCore | Searches for the index of the item that has the specified property descriptor with the specified value, if searching is implemented in a derived class; otherwise, a NotSupportedException. (Inherited from BindingList <(Of <( VersionSettings >)>).)
FromXml | This is used to load the version settings list from the configuration settings.
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( VersionSettings >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection <(Of <( VersionSettings >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( VersionSettings >)>).)
InsertItem | Inserts the specified item in the list at the specified index. (Inherited from BindingList <(Of <( VersionSettings >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnAddingNew | Raises the AddingNew event. (Inherited from BindingList <(Of <( VersionSettings >)>).)
OnListChanged | Raises the ListChanged event. (Inherited from BindingList <(Of <( VersionSettings >)>).)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( VersionSettings >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( VersionSettings >)>).)
RemoveItem | Removes the item at the specified index. (Inherited from BindingList <(Of <( VersionSettings >)>).)
RemoveSortCore | Removes any sort applied with ApplySortCore(PropertyDescriptor, ListSortDirection) if sorting is implemented in a derived class; otherwise, raises NotSupportedException. (Inherited from BindingList <(Of <( VersionSettings >)>).)
ResetBindings | Raises a ListChanged event of type Reset. (Inherited from BindingList <(Of <( VersionSettings >)>).)
ResetItem | Raises a ListChanged event of type ItemChanged for the item at the specified position. (Inherited from BindingList <(Of <( VersionSettings >)>).)
SetItem | Replaces the item at the specified index with the specified item. (Inherited from BindingList <(Of <( VersionSettings >)>).)
Sort | This is used to sort the collection in ascending order by framework label and version.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | This is used to save the version settings list to the configuration settings.

Properties

Name | Description
AllowEdit | Gets or sets a value indicating whether items in the list can be edited. (Inherited from BindingList <(Of <( VersionSettings >)>).)
AllowNew | Gets or sets a value indicating whether you can add items to the list using the AddNew()()() method. (Inherited from BindingList <(Of <( VersionSettings >)>).)
AllowRemove | Gets or sets a value indicating whether you can remove items from the collection. (Inherited from BindingList <(Of <( VersionSettings >)>).)
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( VersionSettings >)>).)
IsSortedCore | Gets a value indicating whether the list is sorted. (Inherited from BindingList <(Of <( VersionSettings >)>).)
Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <( VersionSettings >)>).)
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( VersionSettings >)>).)
RaiseListChangedEvents | Gets or sets a value indicating whether adding or removing items within the list raises ListChanged events. (Inherited from BindingList <(Of <( VersionSettings >)>).)
SortDirectionCore | Gets the direction the list is sorted. (Inherited from BindingList <(Of <( VersionSettings >)>).)
SortPropertyCore | Gets the property descriptor that is used for sorting the list if sorting is implemented in a derived class; otherwise, returns null. (Inherited from BindingList <(Of <( VersionSettings >)>).)
SupportsChangeNotificationCore | Gets a value indicating whether ListChanged events are enabled. (Inherited from BindingList <(Of <( VersionSettings >)>).)
SupportsSearchingCore | Gets a value indicating whether the list supports searching. (Inherited from BindingList <(Of <( VersionSettings >)>).)
SupportsSortingCore | Gets a value indicating whether the list supports sorting. (Inherited from BindingList <(Of <( VersionSettings >)>).)

Events

Name | Description
AddingNew | Occurs before an item is added to the list. (Inherited from BindingList <(Of <( VersionSettings >)>).)
ListChanged | Occurs when the list or an item in the list changes. (Inherited from BindingList <(Of <( VersionSettings >)>).)

See Also

VersionSettingsCollection Class
SandcastleBuilder.PlugIns Namespace


VersionSettingsCollection Constructor

[image]

Sandcastle Help File Builder Documentation
VersionSettingsCollection Constructor
VersionSettingsCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the VersionSettingsCollection class

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public VersionSettingsCollection()
Visual Basic (Declaration)
Public Sub New

See Also

VersionSettingsCollection Class
SandcastleBuilder.PlugIns Namespace


VersionSettingsCollection Methods

[image] [image]

Sandcastle Help File Builder Documentation
VersionSettingsCollection Methods
VersionSettingsCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The VersionSettingsCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( VersionSettings >)>).)
AddNew | Adds a new item to the collection. (Inherited from BindingList <(Of <( VersionSettings >)>).)
AddNewCore | Adds a new item to the end of the collection. (Inherited from BindingList <(Of <( VersionSettings >)>).)
ApplySortCore | Sorts the items if overridden in a derived class; otherwise, throws a NotSupportedException. (Inherited from BindingList <(Of <( VersionSettings >)>).)
CancelNew | Discards a pending new item. (Inherited from BindingList <(Of <( VersionSettings >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( VersionSettings >)>).)
ClearItems | Removes all elements from the collection. (Inherited from BindingList <(Of <( VersionSettings >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( VersionSettings >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <( VersionSettings >)>).)
EndNew | Commits a pending new item to the collection. (Inherited from BindingList <(Of <( VersionSettings >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindCore | Searches for the index of the item that has the specified property descriptor with the specified value, if searching is implemented in a derived class; otherwise, a NotSupportedException. (Inherited from BindingList <(Of <( VersionSettings >)>).)
FromXml | This is used to load the version settings list from the configuration settings.
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( VersionSettings >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection <(Of <( VersionSettings >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( VersionSettings >)>).)
InsertItem | Inserts the specified item in the list at the specified index. (Inherited from BindingList <(Of <( VersionSettings >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnAddingNew | Raises the AddingNew event. (Inherited from BindingList <(Of <( VersionSettings >)>).)
OnListChanged | Raises the ListChanged event. (Inherited from BindingList <(Of <( VersionSettings >)>).)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( VersionSettings >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( VersionSettings >)>).)
RemoveItem | Removes the item at the specified index. (Inherited from BindingList <(Of <( VersionSettings >)>).)
RemoveSortCore | Removes any sort applied with ApplySortCore(PropertyDescriptor, ListSortDirection) if sorting is implemented in a derived class; otherwise, raises NotSupportedException. (Inherited from BindingList <(Of <( VersionSettings >)>).)
ResetBindings | Raises a ListChanged event of type Reset. (Inherited from BindingList <(Of <( VersionSettings >)>).)
ResetItem | Raises a ListChanged event of type ItemChanged for the item at the specified position. (Inherited from BindingList <(Of <( VersionSettings >)>).)
SetItem | Replaces the item at the specified index with the specified item. (Inherited from BindingList <(Of <( VersionSettings >)>).)
Sort | This is used to sort the collection in ascending order by framework label and version.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | This is used to save the version settings list to the configuration settings.

See Also

VersionSettingsCollection Class
SandcastleBuilder.PlugIns Namespace


FromXml Method

[image]

Sandcastle Help File Builder Documentation
VersionSettingsCollection..::.FromXml Method
VersionSettingsCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to load the version settings list from the configuration settings.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public void FromXml(
    IBasePathProvider pathProvider,
    XPathNavigator navigator
)
Visual Basic (Declaration)
Public Sub FromXml ( _
    pathProvider As IBasePathProvider, _
    navigator As XPathNavigator _
)

Parameters

pathProvider
Type: SandcastleBuilder.Utils..::.IBasePathProvider
The base path provider object
navigator
Type: System.Xml.XPath..::.XPathNavigator
The XPath navigator from which the information is loaded.

See Also

VersionSettingsCollection Class
SandcastleBuilder.PlugIns Namespace


Sort Method

[image]

Sandcastle Help File Builder Documentation
VersionSettingsCollection..::.Sort Method
VersionSettingsCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to sort the collection in ascending order by framework label and version.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public void Sort()
Visual Basic (Declaration)
Public Sub Sort

See Also

VersionSettingsCollection Class
SandcastleBuilder.PlugIns Namespace


ToXml Method

[image]

Sandcastle Help File Builder Documentation
VersionSettingsCollection..::.ToXml Method
VersionSettingsCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to save the version settings list to the configuration settings.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public void ToXml(
    XmlDocument config,
    XmlNode root
)
Visual Basic (Declaration)
Public Sub ToXml ( _
    config As XmlDocument, _
    root As XmlNode _
)

Parameters

config
Type: System.Xml..::.XmlDocument
The XML configuration document.
root
Type: System.Xml..::.XmlNode
The root configuration node

See Also

VersionSettingsCollection Class
SandcastleBuilder.PlugIns Namespace


VersionSettingsCollection Properties

[image] [image]

Sandcastle Help File Builder Documentation
VersionSettingsCollection Properties
VersionSettingsCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The VersionSettingsCollection type exposes the following members.

Properties

Name | Description
AllowEdit | Gets or sets a value indicating whether items in the list can be edited. (Inherited from BindingList <(Of <( VersionSettings >)>).)
AllowNew | Gets or sets a value indicating whether you can add items to the list using the AddNew()()() method. (Inherited from BindingList <(Of <( VersionSettings >)>).)
AllowRemove | Gets or sets a value indicating whether you can remove items from the collection. (Inherited from BindingList <(Of <( VersionSettings >)>).)
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( VersionSettings >)>).)
IsSortedCore | Gets a value indicating whether the list is sorted. (Inherited from BindingList <(Of <( VersionSettings >)>).)
Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <( VersionSettings >)>).)
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( VersionSettings >)>).)
RaiseListChangedEvents | Gets or sets a value indicating whether adding or removing items within the list raises ListChanged events. (Inherited from BindingList <(Of <( VersionSettings >)>).)
SortDirectionCore | Gets the direction the list is sorted. (Inherited from BindingList <(Of <( VersionSettings >)>).)
SortPropertyCore | Gets the property descriptor that is used for sorting the list if sorting is implemented in a derived class; otherwise, returns null. (Inherited from BindingList <(Of <( VersionSettings >)>).)
SupportsChangeNotificationCore | Gets a value indicating whether ListChanged events are enabled. (Inherited from BindingList <(Of <( VersionSettings >)>).)
SupportsSearchingCore | Gets a value indicating whether the list supports searching. (Inherited from BindingList <(Of <( VersionSettings >)>).)
SupportsSortingCore | Gets a value indicating whether the list supports sorting. (Inherited from BindingList <(Of <( VersionSettings >)>).)

See Also

VersionSettingsCollection Class
SandcastleBuilder.PlugIns Namespace


VersionSettingsCollection Events

[image] [image]

Sandcastle Help File Builder Documentation
VersionSettingsCollection Events
VersionSettingsCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The VersionSettingsCollection type exposes the following members.

Events

Name | Description
AddingNew | Occurs before an item is added to the list. (Inherited from BindingList <(Of <( VersionSettings >)>).)
ListChanged | Occurs when the list or an item in the list changes. (Inherited from BindingList <(Of <( VersionSettings >)>).)

See Also

VersionSettingsCollection Class
SandcastleBuilder.PlugIns Namespace


XPathReflectionFileFilterPlugIn Class

[image]

Sandcastle Help File Builder Documentation
XPathReflectionFileFilterPlugIn Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This plug-in class is used to filter out unwanted information from the reflection information file using XPath queries.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public class XPathReflectionFileFilterPlugIn : IPlugIn,
    IDisposable
Visual Basic (Declaration)
Public Class XPathReflectionFileFilterPlugIn _
    Implements IPlugIn, IDisposable

Inheritance Hierarchy

System..::.Object
SandcastleBuilder.PlugIns..::.XPathReflectionFileFilterPlugIn

See Also

XPathReflectionFileFilterPlugIn Members
SandcastleBuilder.PlugIns Namespace


XPathReflectionFileFilterPlugIn Members

[image] [image]

Sandcastle Help File Builder Documentation
XPathReflectionFileFilterPlugIn Members
XPathReflectionFileFilterPlugIn Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The XPathReflectionFileFilterPlugIn type exposes the following members.

Constructors

Name | Description
XPathReflectionFileFilterPlugIn | Initializes a new instance of the XPathReflectionFileFilterPlugIn class

Methods

Name | Description
ConfigurePlugIn | This method is used by the Sandcastle Help File Builder to let the plug-in perform its own configuration.
Dispose | Overloaded. There are two overloads for this method.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | This method is used to execute the plug-in during the build process
Finalize | This handles garbage collection to ensure proper disposal of the plug-in if not done explicity with Dispose()()(). (Overrides Object..::.Finalize()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Initialize | This method is used to initialize the plug-in at the start of the build process.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Copyright | This read-only property returns the copyright information for the plug-in.
Description | This read-only property returns a brief description of the plug-in
ExecutionPoints | This read-only property returns a collection of execution points that define when the plug-in should be invoked during the build process.
Name | This read-only property returns a friendly name for the plug-in
RunsInPartialBuild | This plug-in runs in partial builds
Version | This read-only property returns the version of the plug-in

See Also

XPathReflectionFileFilterPlugIn Class
SandcastleBuilder.PlugIns Namespace


XPathReflectionFileFilterPlugIn Constructor

[image]

Sandcastle Help File Builder Documentation
XPathReflectionFileFilterPlugIn Constructor
XPathReflectionFileFilterPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the XPathReflectionFileFilterPlugIn class

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public XPathReflectionFileFilterPlugIn()
Visual Basic (Declaration)
Public Sub New

See Also

XPathReflectionFileFilterPlugIn Class
SandcastleBuilder.PlugIns Namespace


XPathReflectionFileFilterPlugIn Methods

[image] [image]

Sandcastle Help File Builder Documentation
XPathReflectionFileFilterPlugIn Methods
XPathReflectionFileFilterPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The XPathReflectionFileFilterPlugIn type exposes the following members.

Methods

Name | Description
ConfigurePlugIn | This method is used by the Sandcastle Help File Builder to let the plug-in perform its own configuration.
Dispose | Overloaded. There are two overloads for this method.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | This method is used to execute the plug-in during the build process
Finalize | This handles garbage collection to ensure proper disposal of the plug-in if not done explicity with Dispose()()(). (Overrides Object..::.Finalize()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Initialize | This method is used to initialize the plug-in at the start of the build process.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

XPathReflectionFileFilterPlugIn Class
SandcastleBuilder.PlugIns Namespace


ConfigurePlugIn Method

[image]

Sandcastle Help File Builder Documentation
XPathReflectionFileFilterPlugIn..::.ConfigurePlugIn Method
XPathReflectionFileFilterPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This method is used by the Sandcastle Help File Builder to let the plug-in perform its own configuration.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public string ConfigurePlugIn(
    SandcastleProject project,
    string currentConfig
)
Visual Basic (Declaration)
Public Function ConfigurePlugIn ( _
    project As SandcastleProject, _
    currentConfig As String _
) As String

Parameters

project
Type: SandcastleBuilder.Utils..::.SandcastleProject
A reference to the active project
currentConfig
Type: System..::.String
The current configuration XML fragment

Return Value

A string containing the new configuration XML fragment

Implements

IPlugIn..::.ConfigurePlugIn(SandcastleProject, String)

Remarks

The configuration data will be stored in the help file builder project.

See Also

XPathReflectionFileFilterPlugIn Class
SandcastleBuilder.PlugIns Namespace


Dispose Method

[image] [image]

Sandcastle Help File Builder Documentation
XPathReflectionFileFilterPlugIn..::.Dispose Method
XPathReflectionFileFilterPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

There are two overloads for this method.

Overload List

Name | Description
Dispose()()() | This implements the Dispose() interface to properly dispose of the plug-in object.
Dispose(Boolean) | This can be overridden by derived classes to add their own disposal code if necessary.

See Also

XPathReflectionFileFilterPlugIn Class
XPathReflectionFileFilterPlugIn Members
SandcastleBuilder.PlugIns Namespace


Dispose Method

[image]

Sandcastle Help File Builder Documentation
XPathReflectionFileFilterPlugIn..::.Dispose Method
XPathReflectionFileFilterPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This implements the Dispose() interface to properly dispose of the plug-in object.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose

Implements

IDisposable..::.Dispose()()()

See Also

XPathReflectionFileFilterPlugIn Class
Dispose Overload
SandcastleBuilder.PlugIns Namespace


Dispose Method (Boolean)

[image]

Sandcastle Help File Builder Documentation
XPathReflectionFileFilterPlugIn..::.Dispose Method (Boolean)
XPathReflectionFileFilterPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This can be overridden by derived classes to add their own disposal code if necessary.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
protected virtual void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overridable Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
Pass true to dispose of the managed and unmanaged resources or false to just dispose of the unmanaged resources.

See Also

XPathReflectionFileFilterPlugIn Class
Dispose Overload
SandcastleBuilder.PlugIns Namespace


Execute Method

[image]

Sandcastle Help File Builder Documentation
XPathReflectionFileFilterPlugIn..::.Execute Method
XPathReflectionFileFilterPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This method is used to execute the plug-in during the build process

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public void Execute(
    ExecutionContext context
)
Visual Basic (Declaration)
Public Sub Execute ( _
    context As ExecutionContext _
)

Parameters

context
Type: SandcastleBuilder.Utils.PlugIn..::.ExecutionContext
The current execution context

Implements

IPlugIn..::.Execute(ExecutionContext)

See Also

XPathReflectionFileFilterPlugIn Class
SandcastleBuilder.PlugIns Namespace


Finalize Method

[image]

Sandcastle Help File Builder Documentation
XPathReflectionFileFilterPlugIn..::.Finalize Method
XPathReflectionFileFilterPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This handles garbage collection to ensure proper disposal of the plug-in if not done explicity with Dispose()()().

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
protected override void Finalize()
Visual Basic (Declaration)
Protected Overrides Sub Finalize

See Also

XPathReflectionFileFilterPlugIn Class
SandcastleBuilder.PlugIns Namespace


Initialize Method

[image]

Sandcastle Help File Builder Documentation
XPathReflectionFileFilterPlugIn..::.Initialize Method
XPathReflectionFileFilterPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This method is used to initialize the plug-in at the start of the build process.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public void Initialize(
    BuildProcess buildProcess,
    XPathNavigator configuration
)
Visual Basic (Declaration)
Public Sub Initialize ( _
    buildProcess As BuildProcess, _
    configuration As XPathNavigator _
)

Parameters

buildProcess
Type: SandcastleBuilder.Utils.BuildEngine..::.BuildProcess
A reference to the current build process.
configuration
Type: System.Xml.XPath..::.XPathNavigator
The configuration data that the plug-in should use to initialize itself.

Implements

IPlugIn..::.Initialize(BuildProcess, XPathNavigator)

See Also

XPathReflectionFileFilterPlugIn Class
SandcastleBuilder.PlugIns Namespace


XPathReflectionFileFilterPlugIn Properties

[image] [image]

Sandcastle Help File Builder Documentation
XPathReflectionFileFilterPlugIn Properties
XPathReflectionFileFilterPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The XPathReflectionFileFilterPlugIn type exposes the following members.

Properties

Name | Description
Copyright | This read-only property returns the copyright information for the plug-in.
Description | This read-only property returns a brief description of the plug-in
ExecutionPoints | This read-only property returns a collection of execution points that define when the plug-in should be invoked during the build process.
Name | This read-only property returns a friendly name for the plug-in
RunsInPartialBuild | This plug-in runs in partial builds
Version | This read-only property returns the version of the plug-in

See Also

XPathReflectionFileFilterPlugIn Class
SandcastleBuilder.PlugIns Namespace


Copyright Property

[image]

Sandcastle Help File Builder Documentation
XPathReflectionFileFilterPlugIn..::.Copyright Property
XPathReflectionFileFilterPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns the copyright information for the plug-in.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public string Copyright { get; }
Visual Basic (Declaration)
Public ReadOnly Property Copyright As String

Implements

IPlugIn..::.Copyright

See Also

XPathReflectionFileFilterPlugIn Class
SandcastleBuilder.PlugIns Namespace


Description Property

[image]

Sandcastle Help File Builder Documentation
XPathReflectionFileFilterPlugIn..::.Description Property
XPathReflectionFileFilterPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns a brief description of the plug-in

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public string Description { get; }
Visual Basic (Declaration)
Public ReadOnly Property Description As String

Implements

IPlugIn..::.Description

See Also

XPathReflectionFileFilterPlugIn Class
SandcastleBuilder.PlugIns Namespace


ExecutionPoints Property

[image]

Sandcastle Help File Builder Documentation
XPathReflectionFileFilterPlugIn..::.ExecutionPoints Property
XPathReflectionFileFilterPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns a collection of execution points that define when the plug-in should be invoked during the build process.

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public ExecutionPointCollection ExecutionPoints { get; }
Visual Basic (Declaration)
Public ReadOnly Property ExecutionPoints As ExecutionPointCollection

Implements

IPlugIn..::.ExecutionPoints

See Also

XPathReflectionFileFilterPlugIn Class
SandcastleBuilder.PlugIns Namespace


Name Property

[image]

Sandcastle Help File Builder Documentation
XPathReflectionFileFilterPlugIn..::.Name Property
XPathReflectionFileFilterPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns a friendly name for the plug-in

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String

Implements

IPlugIn..::.Name

See Also

XPathReflectionFileFilterPlugIn Class
SandcastleBuilder.PlugIns Namespace


RunsInPartialBuild Property

[image]

Sandcastle Help File Builder Documentation
XPathReflectionFileFilterPlugIn..::.RunsInPartialBuild Property
XPathReflectionFileFilterPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This plug-in runs in partial builds

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public bool RunsInPartialBuild { get; }
Visual Basic (Declaration)
Public ReadOnly Property RunsInPartialBuild As Boolean

Implements

IPlugIn..::.RunsInPartialBuild

See Also

XPathReflectionFileFilterPlugIn Class
SandcastleBuilder.PlugIns Namespace


Version Property

[image]

Sandcastle Help File Builder Documentation
XPathReflectionFileFilterPlugIn..::.Version Property
XPathReflectionFileFilterPlugIn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns the version of the plug-in

Namespace: SandcastleBuilder.PlugIns
Assembly: SandcastleBuilder.PlugIns (in SandcastleBuilder.PlugIns.dll) Version: 1.8.0.2

Syntax

C#
public Version Version { get; }
Visual Basic (Declaration)
Public ReadOnly Property Version As Version

Implements

IPlugIn..::.Version

See Also

XPathReflectionFileFilterPlugIn Class
SandcastleBuilder.PlugIns Namespace


SandcastleBuilder.Utils Namespace

[image]

Sandcastle Help File Builder Documentation
SandcastleBuilder.Utils Namespace
Send Feedback

[This is preliminary documentation and is subject to change.]

This namespace contains various utility classes and the help file builder project classes.

Classes

Class | Description
ApiFilter | This represents an API entry that is to be removed from the reflection information using MRefBuilder's namespace ripping feature.
ApiFilterCollection | This collection class is used to hold the API filter entries for MRefBuilder to remove.
BaseBuildItem | This is a base wrapper class for a build item in the project
BuilderException | This exception class is thrown by the application if it encounters an unrecoverable error.
COMReferenceItem | This represents a COM reference item that can be used by MRefBuilder to locate assembly dependencies for the assemblies being documented.
Constants | This class holds a set of constants that define various application values such as the application name, common data folder, etc.
DocumentationSource | This represents an assembly, an XML comments file, a Visual Studio Solution (C#, VB.NET, or J#), or a Visual Studio solution containing one or more C#, VB.NET or J# projects to use for building a help file.
DocumentationSourceCollection | This collection class is used to hold the documentation sources
FileItem | This class represents a file that is part of the project (MAML/additional content, site map, stylesheet, etc.).
FileItemCollection | This collection class is used to hold build items from a project.
FilePath | This class is used to represent a file path. Support is included for treating the path as fixed or relative and for expanding environment variables in the path name.
FolderPath | This class is used to represent a folder path. Support is included for treating the path as fixed or relative and for expanding environment variables in the path name.
MSHelpAttr | This represents an HTML Help 2.x attribute that can be added to the XML data island in each help topic generated by BuildAssembler.
MSHelpAttrCollection | This collection class is used to hold the help attribute items for a project.
MSHelpKeyword | This represents an HTML Help 2.x index keyword that can be added to the XML data island in each help topic generated by BuildAssembler.
MSHelpKeywordCollection | This collection class is used to hold the help index keyword items for a project.
NamespaceSummaryItem | This represents a a namespace summary item that can be used to add comments to a namespace in the help file or exclude it completely from the help file.
NamespaceSummaryItemCollection | This collection class is used to hold the namespace summary items for a project.
ProjectElement | This class is a wrapper for build items in the project.
ProjectPropertyChangedEventArgs | This event arguments class is used to specify which project property changed along with the old and new values.
ProjectReferenceItem | This represents a project reference item that can be used by MRefBuilder to locate assembly dependencies for the assemblies being documented.
PropertyBasedCollectionItem | This is the base class for collection items that are stored in an MSBuild property element.
ReferenceItem | This represents a reference item that can be used by MRefBuilder to locate assembly dependencies for the assemblies being documented.
ReferenceItemCollection | This collection class is used to hold the reference items for a project
SandcastleProject | This class represents all of the properties that make up a Sandcastle Help File Builder project.

Interfaces

Interface | Description
IBasePathProvider | This interface defines the properties used to obtain a base path for a FilePath object.

Enumerations

Enumeration | Description
ApiEntryType | This public enumerated type defines the API entry types that can be removed from the reflection information file.
BuildAction | This defines the build action (item name) for build items in a project
CollectionTocStyle | This public enumerated type defines the collection table of contents style for HTML Help 2 collections.
ContentPlacement | This public enumerated type defines the placement of the additional content items in the table of contents if any are defined.
DocumentType | This public enumerated type defines the conceptual document types
HelpFileFormat | This public enumerated type defines the type(s) of help file generated
MissingTags | This public enumerated type defines the missing documentation tags for which to search.
NamingMethod | This public enumerated type defines the naming method to use for the help topic filenames.
ProjectLinkType | This public enumerated type defines the type of links used to reference other help topics referring to items in the documented assemblies.
SdkLinkTarget | This public enumerated type defines the locations in which a browser window can be opened for the MSDN SDK links.
SdkLinkType | This public enumerated type defines the type of links used to reference other help topics referring to framework (SDK) help topics.
SyntaxFilters | This public enumerated type defines the languages to include in the help topic Syntax section.
VisibleItems | This public enumerated type defines the optional visible items in the help file.


ApiEntryType Enumeration

[image]

Sandcastle Help File Builder Documentation
ApiEntryType Enumeration
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This public enumerated type defines the API entry types that can be removed from the reflection information file.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
[SerializableAttribute]
public enum ApiEntryType
Visual Basic (Declaration)
<SerializableAttribute> _
Public Enumeration ApiEntryType

Members

Member name | Description
None | An unknown entry
Namespace | A namespace
Class | A class
Structure | An interface
Interface | An interface
Enumeration | An enumeration
Delegate | A delegate
Constructor | A constructor
Method | A method
Operator | An operator
Property | A property
Event | An event
Field | A field

See Also

SandcastleBuilder.Utils Namespace


ApiFilter Class

[image]

Sandcastle Help File Builder Documentation
ApiFilter Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This represents an API entry that is to be removed from the reflection information using MRefBuilder's namespace ripping feature.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public class ApiFilter : IComparable<ApiFilter>,
    ICloneable
Visual Basic (Declaration)
Public Class ApiFilter _
    Implements IComparable(Of ApiFilter), ICloneable

Inheritance Hierarchy

System..::.Object
SandcastleBuilder.Utils..::.ApiFilter

See Also

ApiFilter Members
SandcastleBuilder.Utils Namespace


ApiFilter Members

[image] [image]

Sandcastle Help File Builder Documentation
ApiFilter Members
ApiFilter Class Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ApiFilter type exposes the following members.

Methods

Name | Description
ApiEntryTypeFromLetter | This is used to convert an API type letter to an ApiEntryType enumerated value.
Clone | Clone the API filter
CompareTo | Compares this instance to another instance and returns an indication of their relative values.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name Description
Children
This returns the child API filter collection for this entry
EntryType
This is used to get or set the API entry type
FilterName
This is used to get the API filter name
FullName
This is used to get the fully qualified name of the API entry
IsExposed
This is used to get or set whether or not the entry is exposed
IsProjectExclude
This is used to get or set whether or not the entry is excluded via the project (i.e. via the SHFB Namespaces option or an
CopyC#
<exclude />
 tag.

See Also

ApiFilter Class
SandcastleBuilder.Utils Namespace


ApiFilter Methods

[image] [image]

Sandcastle Help File Builder Documentation
ApiFilter Methods
ApiFilter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ApiFilter type exposes the following members.

Methods

Name | Description
ApiEntryTypeFromLetter | This is used to convert an API type letter to an ApiEntryType enumerated value.
Clone | Clone the API filter
CompareTo | Compares this instance to another instance and returns an indication of their relative values.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ApiFilter Class
SandcastleBuilder.Utils Namespace


ApiEntryTypeFromLetter Method

[image]

Sandcastle Help File Builder Documentation
ApiFilter..::.ApiEntryTypeFromLetter Method
ApiFilter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to convert an API type letter to an ApiEntryType enumerated value.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public static ApiEntryType ApiEntryTypeFromLetter(
    char apiType
)
Visual Basic (Declaration)
Public Shared Function ApiEntryTypeFromLetter ( _
    apiType As Char _
) As ApiEntryType

Parameters

apiType
Type: System..::.Char
The letter to convert

Return Value

The ApiEntryType represented by the letter

See Also

ApiFilter Class
SandcastleBuilder.Utils Namespace


Clone Method

[image]

Sandcastle Help File Builder Documentation
ApiFilter..::.Clone Method
ApiFilter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clone the API filter

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public Object Clone()
Visual Basic (Declaration)
Public Function Clone As Object

Return Value

A clone of the filter

Implements

ICloneable..::.Clone()()()

See Also

ApiFilter Class
SandcastleBuilder.Utils Namespace


CompareTo Method

[image]

Sandcastle Help File Builder Documentation
ApiFilter..::.CompareTo Method
ApiFilter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Compares this instance to another instance and returns an indication of their relative values.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public int CompareTo(
    ApiFilter other
)
Visual Basic (Declaration)
Public Function CompareTo ( _
    other As ApiFilter _
) As Integer

Parameters

other
Type: SandcastleBuilder.Utils..::.ApiFilter
An ApiFilter object to compare

Return Value

Returns -1 if this instance is less than the value, 0 if they are equal, or 1 if this instance is greater than the value or the value is null.

Implements

IComparable<(Of <(T>)>)..::.CompareTo(T)

Remarks

Entries are sorted by API entry type and full name

See Also

ApiFilter Class
SandcastleBuilder.Utils Namespace


ApiFilter Properties

[image] [image]

Sandcastle Help File Builder Documentation
ApiFilter Properties
ApiFilter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ApiFilter type exposes the following members.

Properties

Name Description
Children
This returns the child API filter collection for this entry
EntryType
This is used to get or set the API entry type
FilterName
This is used to get the API filter name
FullName
This is used to get the fully qualified name of the API entry
IsExposed
This is used to get or set whether or not the entry is exposed
IsProjectExclude
This is used to get or set whether or not the entry is excluded via the project (i.e. via the SHFB Namespaces option or an
CopyC#
<exclude />
 tag.

See Also

ApiFilter Class
SandcastleBuilder.Utils Namespace


Children Property

[image]

Sandcastle Help File Builder Documentation
ApiFilter..::.Children Property
ApiFilter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This returns the child API filter collection for this entry

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public ApiFilterCollection Children { get; }
Visual Basic (Declaration)
Public ReadOnly Property Children As ApiFilterCollection

Field Value

For namespaces and types, if there are children, they represent the specific entries within the namespace or type to hide or expose.

See Also

ApiFilter Class
SandcastleBuilder.Utils Namespace


EntryType Property

[image]

Sandcastle Help File Builder Documentation
ApiFilter..::.EntryType Property
ApiFilter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set the API entry type

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public ApiEntryType EntryType { get; set; }
Visual Basic (Declaration)
Public Property EntryType As ApiEntryType

See Also

ApiFilter Class
SandcastleBuilder.Utils Namespace


FilterName Property

[image]

Sandcastle Help File Builder Documentation
ApiFilter..::.FilterName Property
ApiFilter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get the API filter name

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string FilterName { get; set; }
Visual Basic (Declaration)
Public Property FilterName As String

Field Value

For API entry types other than namespaces, this is the name without the namespace and, for methods properties, etc. the type.

See Also

ApiFilter Class
SandcastleBuilder.Utils Namespace


FullName Property

[image]

Sandcastle Help File Builder Documentation
ApiFilter..::.FullName Property
ApiFilter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get the fully qualified name of the API entry

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string FullName { get; set; }
Visual Basic (Declaration)
Public Property FullName As String

See Also

ApiFilter Class
SandcastleBuilder.Utils Namespace


IsExposed Property

[image]

Sandcastle Help File Builder Documentation
ApiFilter..::.IsExposed Property
ApiFilter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set whether or not the entry is exposed

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool IsExposed { get; set; }
Visual Basic (Declaration)
Public Property IsExposed As Boolean

See Also

ApiFilter Class
SandcastleBuilder.Utils Namespace


IsProjectExclude Property

[image]

Sandcastle Help File Builder Documentation
ApiFilter..::.IsProjectExclude Property
ApiFilter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set whether or not the entry is excluded via the project (i.e. via the SHFB Namespaces option or an
CopyC#
<exclude />
 tag.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool IsProjectExclude { get; set; }
Visual Basic (Declaration)
Public Property IsProjectExclude As Boolean

See Also

ApiFilter Class
SandcastleBuilder.Utils Namespace


ApiFilterCollection Class

[image]

Sandcastle Help File Builder Documentation
ApiFilterCollection Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This collection class is used to hold the API filter entries for MRefBuilder to remove.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public class ApiFilterCollection : BindingList<ApiFilter>,
    ICloneable
Visual Basic (Declaration)
Public Class ApiFilterCollection _
    Inherits BindingList(Of ApiFilter) _
    Implements ICloneable

Remarks

Note:
Unlike other collections in the project, this one is cleared and rebuilt if it changes. As such, the contained items do not notify the project when they change as they are created anew each time the collection is rebuilt.

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection <(Of <( ApiFilter >)>)
System.ComponentModel..::.BindingList <(Of <( ApiFilter >)>)
SandcastleBuilder.Utils..::.ApiFilterCollection

See Also

ApiFilterCollection Members
SandcastleBuilder.Utils Namespace


ApiFilterCollection Members

[image] [image]

Sandcastle Help File Builder Documentation
ApiFilterCollection Members
ApiFilterCollection Class Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ApiFilterCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ApiFilter >)>).)
AddNamespaceChild | Add a new type entry to this namespace collection
AddNew | Adds a new item to the collection. (Inherited from BindingList <(Of <( ApiFilter >)>).)
AddNewCore | Adds a new item to the end of the collection. (Inherited from BindingList <(Of <( ApiFilter >)>).)
AddTypeChild | Add a new member entry to this type collection
ApplySortCore | Sorts the items if overridden in a derived class; otherwise, throws a NotSupportedException. (Inherited from BindingList <(Of <( ApiFilter >)>).)
CancelNew | Discards a pending new item. (Inherited from BindingList <(Of <( ApiFilter >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ApiFilter >)>).)
ClearItems | Removes all elements from the collection. (Inherited from BindingList <(Of <( ApiFilter >)>).)
Clone | Clone the API filter collection
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ApiFilter >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <( ApiFilter >)>).)
EndNew | Commits a pending new item to the collection. (Inherited from BindingList <(Of <( ApiFilter >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindCore | Searches for the index of the item that has the specified property descriptor with the specified value, if searching is implemented in a derived class; otherwise, a NotSupportedException. (Inherited from BindingList <(Of <( ApiFilter >)>).)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ApiFilter >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ApiFilter >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( ApiFilter >)>).)
InsertItem | Inserts the specified item in the list at the specified index. (Inherited from BindingList <(Of <( ApiFilter >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MergeEntry | This is used to merge an entry with the filter collection
OnAddingNew | Raises the AddingNew event. (Inherited from BindingList <(Of <( ApiFilter >)>).)
OnListChanged | This is overridden to mark the collection as dirty when it changes (Overrides BindingList<(Of <(T>)>)..::.OnListChanged(ListChangedEventArgs).)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ApiFilter >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ApiFilter >)>).)
RemoveItem | Removes the item at the specified index. (Inherited from BindingList <(Of <( ApiFilter >)>).)
RemoveSortCore | Removes any sort applied with ApplySortCore(PropertyDescriptor, ListSortDirection) if sorting is implemented in a derived class; otherwise, raises NotSupportedException. (Inherited from BindingList <(Of <( ApiFilter >)>).)
ResetBindings | Raises a ListChanged event of type Reset. (Inherited from BindingList <(Of <( ApiFilter >)>).)
ResetItem | Raises a ListChanged event of type ItemChanged for the item at the specified position. (Inherited from BindingList <(Of <( ApiFilter >)>).)
SetItem | Replaces the item at the specified index with the specified item. (Inherited from BindingList <(Of <( ApiFilter >)>).)
Sort | This is used to sort the collection
ToString | Convert the API filter entry and its children to a string (Overrides Object..::.ToString()()().)

Properties

Name | Description
AllowEdit | Gets or sets a value indicating whether items in the list can be edited. (Inherited from BindingList <(Of <( ApiFilter >)>).)
AllowNew | Gets or sets a value indicating whether you can add items to the list using the AddNew()()() method. (Inherited from BindingList <(Of <( ApiFilter >)>).)
AllowRemove | Gets or sets a value indicating whether you can remove items from the collection. (Inherited from BindingList <(Of <( ApiFilter >)>).)
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ApiFilter >)>).)
IsDirty | This is used to get or set the dirty state of the collection
IsSortedCore | Gets a value indicating whether the list is sorted. (Inherited from BindingList <(Of <( ApiFilter >)>).)
Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <( ApiFilter >)>).)
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ApiFilter >)>).)
Project | This is used to get a reference to the project that owns the collection.
RaiseListChangedEvents | Gets or sets a value indicating whether adding or removing items within the list raises ListChanged events. (Inherited from BindingList <(Of <( ApiFilter >)>).)
SortDirectionCore | Gets the direction the list is sorted. (Inherited from BindingList <(Of <( ApiFilter >)>).)
SortPropertyCore | Gets the property descriptor that is used for sorting the list if sorting is implemented in a derived class; otherwise, returns null. (Inherited from BindingList <(Of <( ApiFilter >)>).)
SupportsChangeNotificationCore | Gets a value indicating whether ListChanged events are enabled. (Inherited from BindingList <(Of <( ApiFilter >)>).)
SupportsSearchingCore | Gets a value indicating whether the list supports searching. (Inherited from BindingList <(Of <( ApiFilter >)>).)
SupportsSortingCore | Gets a value indicating whether the list supports sorting. (Inherited from BindingList <(Of <( ApiFilter >)>).)

Events

Name | Description
AddingNew | Occurs before an item is added to the list. (Inherited from BindingList <(Of <( ApiFilter >)>).)
ListChanged | Occurs when the list or an item in the list changes. (Inherited from BindingList <(Of <( ApiFilter >)>).)

See Also

ApiFilterCollection Class
SandcastleBuilder.Utils Namespace


ApiFilterCollection Methods

[image] [image]

Sandcastle Help File Builder Documentation
ApiFilterCollection Methods
ApiFilterCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ApiFilterCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ApiFilter >)>).)
AddNamespaceChild | Add a new type entry to this namespace collection
AddNew | Adds a new item to the collection. (Inherited from BindingList <(Of <( ApiFilter >)>).)
AddNewCore | Adds a new item to the end of the collection. (Inherited from BindingList <(Of <( ApiFilter >)>).)
AddTypeChild | Add a new member entry to this type collection
ApplySortCore | Sorts the items if overridden in a derived class; otherwise, throws a NotSupportedException. (Inherited from BindingList <(Of <( ApiFilter >)>).)
CancelNew | Discards a pending new item. (Inherited from BindingList <(Of <( ApiFilter >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ApiFilter >)>).)
ClearItems | Removes all elements from the collection. (Inherited from BindingList <(Of <( ApiFilter >)>).)
Clone | Clone the API filter collection
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ApiFilter >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <( ApiFilter >)>).)
EndNew | Commits a pending new item to the collection. (Inherited from BindingList <(Of <( ApiFilter >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindCore | Searches for the index of the item that has the specified property descriptor with the specified value, if searching is implemented in a derived class; otherwise, a NotSupportedException. (Inherited from BindingList <(Of <( ApiFilter >)>).)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ApiFilter >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ApiFilter >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( ApiFilter >)>).)
InsertItem | Inserts the specified item in the list at the specified index. (Inherited from BindingList <(Of <( ApiFilter >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MergeEntry | This is used to merge an entry with the filter collection
OnAddingNew | Raises the AddingNew event. (Inherited from BindingList <(Of <( ApiFilter >)>).)
OnListChanged | This is overridden to mark the collection as dirty when it changes (Overrides BindingList<(Of <(T>)>)..::.OnListChanged(ListChangedEventArgs).)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ApiFilter >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ApiFilter >)>).)
RemoveItem | Removes the item at the specified index. (Inherited from BindingList <(Of <( ApiFilter >)>).)
RemoveSortCore | Removes any sort applied with ApplySortCore(PropertyDescriptor, ListSortDirection) if sorting is implemented in a derived class; otherwise, raises NotSupportedException. (Inherited from BindingList <(Of <( ApiFilter >)>).)
ResetBindings | Raises a ListChanged event of type Reset. (Inherited from BindingList <(Of <( ApiFilter >)>).)
ResetItem | Raises a ListChanged event of type ItemChanged for the item at the specified position. (Inherited from BindingList <(Of <( ApiFilter >)>).)
SetItem | Replaces the item at the specified index with the specified item. (Inherited from BindingList <(Of <( ApiFilter >)>).)
Sort | This is used to sort the collection
ToString | Convert the API filter entry and its children to a string (Overrides Object..::.ToString()()().)

See Also

ApiFilterCollection Class
SandcastleBuilder.Utils Namespace


AddNamespaceChild Method

[image]

Sandcastle Help File Builder Documentation
ApiFilterCollection..::.AddNamespaceChild Method
ApiFilterCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Add a new type entry to this namespace collection

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool AddNamespaceChild(
    string fullName,
    string nameSpace,
    string typeName,
    string memberName
)
Visual Basic (Declaration)
Public Function AddNamespaceChild ( _
    fullName As String, _
    nameSpace As String, _
    typeName As String, _
    memberName As String _
) As Boolean

Parameters

fullName
Type: System..::.String
The full name of the entry
nameSpace
Type: System..::.String
The namespace
typeName
Type: System..::.String
The type name
memberName
Type: System..::.String
The member

Return Value

True if merged without conflict or false if the merged member conflicted with an existing entry. The existing entry will take precedence.

Remarks

Entries added by this method are exclusions based on namespace comment or <exclude/> tag exclusions.

See Also

ApiFilterCollection Class
SandcastleBuilder.Utils Namespace


AddTypeChild Method

[image]

Sandcastle Help File Builder Documentation
ApiFilterCollection..::.AddTypeChild Method
ApiFilterCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Add a new member entry to this type collection

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool AddTypeChild(
    string fullName,
    string typeName,
    string memberName
)
Visual Basic (Declaration)
Public Function AddTypeChild ( _
    fullName As String, _
    typeName As String, _
    memberName As String _
) As Boolean

Parameters

fullName
Type: System..::.String
The full name of the entry
typeName
Type: System..::.String
The type name
memberName
Type: System..::.String
The member

Return Value

True if merged without conflict or false if the merged member conflicted with an existing entry. The existing entry will take precedence.

Remarks

Entries added by this method are exclusions based on namespace comment or <exclude/> tag exclusions.

See Also

ApiFilterCollection Class
SandcastleBuilder.Utils Namespace


Clone Method

[image]

Sandcastle Help File Builder Documentation
ApiFilterCollection..::.Clone Method
ApiFilterCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clone the API filter collection

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public Object Clone()
Visual Basic (Declaration)
Public Function Clone As Object

Return Value

A clone of the collection

Implements

ICloneable..::.Clone()()()

See Also

ApiFilterCollection Class
SandcastleBuilder.Utils Namespace


MergeEntry Method

[image]

Sandcastle Help File Builder Documentation
ApiFilterCollection..::.MergeEntry Method
ApiFilterCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to merge an entry with the filter collection

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool MergeEntry(
    ApiEntryType entryType,
    string fullName,
    bool isExposed,
    bool isProjectExclude
)
Visual Basic (Declaration)
Public Function MergeEntry ( _
    entryType As ApiEntryType, _
    fullName As String, _
    isExposed As Boolean, _
    isProjectExclude As Boolean _
) As Boolean

Parameters

entryType
Type: SandcastleBuilder.Utils..::.ApiEntryType
The entry type
fullName
Type: System..::.String
The member's full name
isExposed
Type: System..::.Boolean
True to expose it, false to remove it
isProjectExclude
Type: System..::.Boolean
True if this is a project exclude (currently this will always be true).

Return Value

True if merged without conflict or false if the merged member conflicted with an existing entry. The existing entry will take precedence.

See Also

ApiFilterCollection Class
SandcastleBuilder.Utils Namespace


OnListChanged Method

[image]

Sandcastle Help File Builder Documentation
ApiFilterCollection..::.OnListChanged Method
ApiFilterCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is overridden to mark the collection as dirty when it changes

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected override void OnListChanged(
    ListChangedEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnListChanged ( _
    e As ListChangedEventArgs _
)

Parameters

e
Type: System.ComponentModel..::.ListChangedEventArgs
The event arguments

See Also

ApiFilterCollection Class
SandcastleBuilder.Utils Namespace


Sort Method

[image]

Sandcastle Help File Builder Documentation
ApiFilterCollection..::.Sort Method
ApiFilterCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to sort the collection

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public void Sort()
Visual Basic (Declaration)
Public Sub Sort

Remarks

All top level items and their children are sorted by API entry type and then by name

See Also

ApiFilterCollection Class
SandcastleBuilder.Utils Namespace


ToString Method

[image]

Sandcastle Help File Builder Documentation
ApiFilterCollection..::.ToString Method
ApiFilterCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Convert the API filter entry and its children to a string

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

Return Value

The entries in the MRefBuilder API filter XML format

See Also

ApiFilterCollection Class
SandcastleBuilder.Utils Namespace


ApiFilterCollection Properties

[image] [image]

Sandcastle Help File Builder Documentation
ApiFilterCollection Properties
ApiFilterCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ApiFilterCollection type exposes the following members.

Properties

Name | Description
AllowEdit | Gets or sets a value indicating whether items in the list can be edited. (Inherited from BindingList <(Of <( ApiFilter >)>).)
AllowNew | Gets or sets a value indicating whether you can add items to the list using the AddNew()()() method. (Inherited from BindingList <(Of <( ApiFilter >)>).)
AllowRemove | Gets or sets a value indicating whether you can remove items from the collection. (Inherited from BindingList <(Of <( ApiFilter >)>).)
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ApiFilter >)>).)
IsDirty | This is used to get or set the dirty state of the collection
IsSortedCore | Gets a value indicating whether the list is sorted. (Inherited from BindingList <(Of <( ApiFilter >)>).)
Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <( ApiFilter >)>).)
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ApiFilter >)>).)
Project | This is used to get a reference to the project that owns the collection.
RaiseListChangedEvents | Gets or sets a value indicating whether adding or removing items within the list raises ListChanged events. (Inherited from BindingList <(Of <( ApiFilter >)>).)
SortDirectionCore | Gets the direction the list is sorted. (Inherited from BindingList <(Of <( ApiFilter >)>).)
SortPropertyCore | Gets the property descriptor that is used for sorting the list if sorting is implemented in a derived class; otherwise, returns null. (Inherited from BindingList <(Of <( ApiFilter >)>).)
SupportsChangeNotificationCore | Gets a value indicating whether ListChanged events are enabled. (Inherited from BindingList <(Of <( ApiFilter >)>).)
SupportsSearchingCore | Gets a value indicating whether the list supports searching. (Inherited from BindingList <(Of <( ApiFilter >)>).)
SupportsSortingCore | Gets a value indicating whether the list supports sorting. (Inherited from BindingList <(Of <( ApiFilter >)>).)

See Also

ApiFilterCollection Class
SandcastleBuilder.Utils Namespace


IsDirty Property

[image]

Sandcastle Help File Builder Documentation
ApiFilterCollection..::.IsDirty Property
ApiFilterCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set the dirty state of the collection

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool IsDirty { get; set; }
Visual Basic (Declaration)
Public Property IsDirty As Boolean

See Also

ApiFilterCollection Class
SandcastleBuilder.Utils Namespace


Project Property

[image]

Sandcastle Help File Builder Documentation
ApiFilterCollection..::.Project Property
ApiFilterCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get a reference to the project that owns the collection.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public SandcastleProject Project { get; }
Visual Basic (Declaration)
Public ReadOnly Property Project As SandcastleProject

Remarks

Child collections do not contain a reference to the project file.

See Also

ApiFilterCollection Class
SandcastleBuilder.Utils Namespace


ApiFilterCollection Events

[image] [image]

Sandcastle Help File Builder Documentation
ApiFilterCollection Events
ApiFilterCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ApiFilterCollection type exposes the following members.

Events

Name | Description
AddingNew | Occurs before an item is added to the list. (Inherited from BindingList <(Of <( ApiFilter >)>).)
ListChanged | Occurs when the list or an item in the list changes. (Inherited from BindingList <(Of <( ApiFilter >)>).)

See Also

ApiFilterCollection Class
SandcastleBuilder.Utils Namespace


BaseBuildItem Class

[image]

Sandcastle Help File Builder Documentation
BaseBuildItem Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is a base wrapper class for a build item in the project

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public abstract class BaseBuildItem
Visual Basic (Declaration)
Public MustInherit Class BaseBuildItem

Inheritance Hierarchy

System..::.Object
SandcastleBuilder.Utils..::.BaseBuildItem
SandcastleBuilder.Utils..::.FileItem
SandcastleBuilder.Utils..::.ReferenceItem

See Also

BaseBuildItem Members
SandcastleBuilder.Utils Namespace


BaseBuildItem Members

[image] [image]

Sandcastle Help File Builder Documentation
BaseBuildItem Members
BaseBuildItem Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BaseBuildItem type exposes the following members.

Constructors

Name | Description
BaseBuildItem | Constructor

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ProjectElement | This returns the project element associated with the instance

See Also

BaseBuildItem Class
SandcastleBuilder.Utils Namespace


BaseBuildItem Constructor

[image]

Sandcastle Help File Builder Documentation
BaseBuildItem Constructor
BaseBuildItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected BaseBuildItem(
    ProjectElement element
)
Visual Basic (Declaration)
Protected Sub New ( _
    element As ProjectElement _
)

Parameters

element
Type: SandcastleBuilder.Utils..::.ProjectElement
The project element associated with the instance

See Also

BaseBuildItem Class
SandcastleBuilder.Utils Namespace


BaseBuildItem Methods

[image] [image]

Sandcastle Help File Builder Documentation
BaseBuildItem Methods
BaseBuildItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BaseBuildItem type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BaseBuildItem Class
SandcastleBuilder.Utils Namespace


BaseBuildItem Properties

[image] [image]

Sandcastle Help File Builder Documentation
BaseBuildItem Properties
BaseBuildItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BaseBuildItem type exposes the following members.

Properties

Name | Description
ProjectElement | This returns the project element associated with the instance

See Also

BaseBuildItem Class
SandcastleBuilder.Utils Namespace


ProjectElement Property

[image]

Sandcastle Help File Builder Documentation
BaseBuildItem..::.ProjectElement Property
BaseBuildItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This returns the project element associated with the instance

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public ProjectElement ProjectElement { get; }
Visual Basic (Declaration)
Public ReadOnly Property ProjectElement As ProjectElement

See Also

BaseBuildItem Class
SandcastleBuilder.Utils Namespace


BuildAction Enumeration

[image]

Sandcastle Help File Builder Documentation
BuildAction Enumeration
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This defines the build action (item name) for build items in a project

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
[SerializableAttribute]
public enum BuildAction
Visual Basic (Declaration)
<SerializableAttribute> _
Public Enumeration BuildAction

Members

Member name | Description
None | No action, the item is ignored
Image | Conceptual content image file
CodeSnippets | Conceptual content code snippets file
Tokens | Conceptual content token file
ContentLayout | Conceptual content layout file
SiteMap | Additional content site map file
TopicTransform | Additional content topic transformation file
Content | General content file (HTML, stylesheet, images not related to conceptual content, etc.)
Folder | A folder (project explorer designation only, not a build action)
Project | The project (project explorer designation only, not a build action)
DocumentationSource | A documentation source (project explorer designation only, not a build action)
ReferenceItem | A reference item (project explorer designation only, not a build action)

See Also

SandcastleBuilder.Utils Namespace


BuilderException Class

[image]

Sandcastle Help File Builder Documentation
BuilderException Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This exception class is thrown by the application if it encounters an unrecoverable error.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
[SerializableAttribute]
public class BuilderException : Exception
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class BuilderException _
    Inherits Exception

Inheritance Hierarchy

System..::.Object
System..::.Exception
SandcastleBuilder.Utils..::.BuilderException

See Also

BuilderException Members
SandcastleBuilder.Utils Namespace


BuilderException Members

[image] [image]

Sandcastle Help File Builder Documentation
BuilderException Members
BuilderException Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BuilderException type exposes the following members.

Constructors

Name | Description
BuilderException | Overloaded. There are six overloads for the constructor

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | This implements the ISerializable interface and adds the error code to the serialization information. (Overrides Exception..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
ErrorCode | Get the error code associated with the exception
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

BuilderException Class
SandcastleBuilder.Utils Namespace


BuilderException Constructor

[image] [image]

Sandcastle Help File Builder Documentation
BuilderException Constructor
BuilderException Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

There are six overloads for the constructor

Overload List

Name | Description
BuilderException()()() | Default constructor.
BuilderException(String) | Initializes a new instance of the Exception class with a specified error message.
BuilderException(SerializationInfo, StreamingContext) | Deserialization constructor for use with ISerializable.
BuilderException(String, Exception) | Initializes a new instance of the Exception class with a specified error message and a reference to the inner exception that is the cause of this exception.
BuilderException(String, String) | This constructor takes an error code and a message string
BuilderException(String, String, Exception) | This constructor takes an error code, a message string, and an inner exception.

See Also

BuilderException Class
BuilderException Members
SandcastleBuilder.Utils Namespace


BuilderException Constructor

[image]

Sandcastle Help File Builder Documentation
BuilderException Constructor
BuilderException Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Default constructor.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public BuilderException()
Visual Basic (Declaration)
Public Sub New

See Also

BuilderException Class
BuilderException Overload
SandcastleBuilder.Utils Namespace


BuilderException Constructor (String)

[image]

Sandcastle Help File Builder Documentation
BuilderException Constructor (String)
BuilderException Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Exception class with a specified error message.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public BuilderException(
    string message
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)

Parameters

message
Type: System..::.String
The message that describes the error.

See Also

BuilderException Class
BuilderException Overload
SandcastleBuilder.Utils Namespace


BuilderException Constructor (SerializationInfo, StreamingContext)

[image]

Sandcastle Help File Builder Documentation
BuilderException Constructor (SerializationInfo, StreamingContext)
BuilderException Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Deserialization constructor for use with ISerializable.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected BuilderException(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The serialization info object
context
Type: System.Runtime.Serialization..::.StreamingContext
The streaming context object

See Also

BuilderException Class
BuilderException Overload
SandcastleBuilder.Utils Namespace


BuilderException Constructor (String, Exception)

[image]

Sandcastle Help File Builder Documentation
BuilderException Constructor (String, Exception)
BuilderException Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Exception class with a specified error message and a reference to the inner exception that is the cause of this exception.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public BuilderException(
    string message,
    Exception innerException
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    innerException As Exception _
)

Parameters

message
Type: System..::.String
The error message that explains the reason for the exception.
innerException
Type: System..::.Exception
The exception that is the cause of the current exception, or a null reference (Nothing in Visual Basic) if no inner exception is specified.

See Also

BuilderException Class
BuilderException Overload
SandcastleBuilder.Utils Namespace


BuilderException Constructor (String, String)

[image]

Sandcastle Help File Builder Documentation
BuilderException Constructor (String, String)
BuilderException Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This constructor takes an error code and a message string

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public BuilderException(
    string code,
    string message
)
Visual Basic (Declaration)
Public Sub New ( _
    code As String, _
    message As String _
)

Parameters

code
Type: System..::.String
The error code. The suggested format is one to four letters to identify the component or process followed by four digits, zero padded to the left, with no spaces.
message
Type: System..::.String
The exception message

See Also

BuilderException Class
BuilderException Overload
SandcastleBuilder.Utils Namespace


BuilderException Constructor (String, String, Exception)

[image]

Sandcastle Help File Builder Documentation
BuilderException Constructor (String, String, Exception)
BuilderException Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This constructor takes an error code, a message string, and an inner exception.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public BuilderException(
    string code,
    string message,
    Exception innerException
)
Visual Basic (Declaration)
Public Sub New ( _
    code As String, _
    message As String, _
    innerException As Exception _
)

Parameters

code
Type: System..::.String
The error code. The suggested format is one to four letters to identify the component or process followed by four digits, zero padded to the left, with no spaces.
message
Type: System..::.String
The exception message
innerException
Type: System..::.Exception
The inner exception

See Also

BuilderException Class
BuilderException Overload
SandcastleBuilder.Utils Namespace


BuilderException Methods

[image] [image]

Sandcastle Help File Builder Documentation
BuilderException Methods
BuilderException Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BuilderException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | This implements the ISerializable interface and adds the error code to the serialization information. (Overrides Exception..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

BuilderException Class
SandcastleBuilder.Utils Namespace


GetObjectData Method

[image]

Sandcastle Help File Builder Documentation
BuilderException..::.GetObjectData Method
BuilderException Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This implements the ISerializable interface and adds the error code to the serialization information.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The serialization info object
context
Type: System.Runtime.Serialization..::.StreamingContext
The streaming context

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)
_Exception..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

BuilderException Class
SandcastleBuilder.Utils Namespace


BuilderException Properties

[image] [image]

Sandcastle Help File Builder Documentation
BuilderException Properties
BuilderException Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BuilderException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
ErrorCode | Get the error code associated with the exception
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

BuilderException Class
SandcastleBuilder.Utils Namespace


ErrorCode Property

[image]

Sandcastle Help File Builder Documentation
BuilderException..::.ErrorCode Property
BuilderException Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Get the error code associated with the exception

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string ErrorCode { get; }
Visual Basic (Declaration)
Public ReadOnly Property ErrorCode As String

See Also

BuilderException Class
SandcastleBuilder.Utils Namespace


CollectionTocStyle Enumeration

[image]

Sandcastle Help File Builder Documentation
CollectionTocStyle Enumeration
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This public enumerated type defines the collection table of contents style for HTML Help 2 collections.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
[SerializableAttribute]
public enum CollectionTocStyle
Visual Basic (Declaration)
<SerializableAttribute> _
Public Enumeration CollectionTocStyle

Members

Member name | Description
Hierarchical | The collection content will be grouped under a root node.
Flat | The collection content will be listed at the root level.

See Also

SandcastleBuilder.Utils Namespace


COMReferenceItem Class

[image]

Sandcastle Help File Builder Documentation
COMReferenceItem Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This represents a COM reference item that can be used by MRefBuilder to locate assembly dependencies for the assemblies being documented.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public class COMReferenceItem : ReferenceItem
Visual Basic (Declaration)
Public Class COMReferenceItem _
    Inherits ReferenceItem

Inheritance Hierarchy

System..::.Object
SandcastleBuilder.Utils..::.BaseBuildItem
SandcastleBuilder.Utils..::.ReferenceItem
SandcastleBuilder.Utils..::.COMReferenceItem

See Also

COMReferenceItem Members
SandcastleBuilder.Utils Namespace


COMReferenceItem Members

[image] [image]

Sandcastle Help File Builder Documentation
COMReferenceItem Members
COMReferenceItem Class Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The COMReferenceItem type exposes the following members.

Methods

Name | Description
Equals | See if specified item equals this one by name alone (Inherited from ReferenceItem.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAttributes | Returns a collection of custom attributes for this instance of a component. (Inherited from ReferenceItem.)
GetClassName | Returns the class name of this instance of a component. (Inherited from ReferenceItem.)
GetComponentName | Returns the name of this instance of a component. (Inherited from ReferenceItem.)
GetConverter | Returns a type converter for this instance of a component. (Inherited from ReferenceItem.)
GetDefaultEvent | Returns the default event for this instance of a component. (Inherited from ReferenceItem.)
GetDefaultProperty | Returns the default property for this instance of a component. (Inherited from ReferenceItem.)
GetEditor | Returns an editor of the specified type for this instance of a component. (Inherited from ReferenceItem.)
GetEvents | Overloaded.
GetHashCode | Get a hash code for this item (Inherited from ReferenceItem.)
GetProperties | Overloaded.
GetPropertyOwner | Returns an object that contains the property described by the specified property descriptor. (Inherited from ReferenceItem.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Return a string representation of the item (Inherited from ReferenceItem.)

Properties

Name | Description
Guid | This is used to get the project reference's GUID
HintPath | Hint path isn't applicable to COM references (Overrides ReferenceItem..::.HintPath.)
ProjectElement | This returns the project element associated with the instance (Inherited from BaseBuildItem.)
Reference | This is used to get the reference description (Inherited from ReferenceItem.)
VersionMajor | This is used to get the major version number
VersionMinor | This is used to get the minor version number
WrapperTool | This is used to get the wrapper tool

See Also

COMReferenceItem Class
SandcastleBuilder.Utils Namespace


COMReferenceItem Methods

[image] [image]

Sandcastle Help File Builder Documentation
COMReferenceItem Methods
COMReferenceItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The COMReferenceItem type exposes the following members.

Methods

Name | Description
Equals | See if specified item equals this one by name alone (Inherited from ReferenceItem.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAttributes | Returns a collection of custom attributes for this instance of a component. (Inherited from ReferenceItem.)
GetClassName | Returns the class name of this instance of a component. (Inherited from ReferenceItem.)
GetComponentName | Returns the name of this instance of a component. (Inherited from ReferenceItem.)
GetConverter | Returns a type converter for this instance of a component. (Inherited from ReferenceItem.)
GetDefaultEvent | Returns the default event for this instance of a component. (Inherited from ReferenceItem.)
GetDefaultProperty | Returns the default property for this instance of a component. (Inherited from ReferenceItem.)
GetEditor | Returns an editor of the specified type for this instance of a component. (Inherited from ReferenceItem.)
GetEvents | Overloaded.
GetHashCode | Get a hash code for this item (Inherited from ReferenceItem.)
GetProperties | Overloaded.
GetPropertyOwner | Returns an object that contains the property described by the specified property descriptor. (Inherited from ReferenceItem.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Return a string representation of the item (Inherited from ReferenceItem.)

See Also

COMReferenceItem Class
SandcastleBuilder.Utils Namespace


GetEvents Method

[image] [image]

Sandcastle Help File Builder Documentation
COMReferenceItem..::.GetEvents Method
COMReferenceItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetEvents()()() | Returns the events for this instance of a component. (Inherited from ReferenceItem.)
GetEvents(array<Attribute>[]()[]) | Returns the events for this instance of a component using the specified attribute array as a filter. (Inherited from ReferenceItem.)

See Also

COMReferenceItem Class
COMReferenceItem Members
SandcastleBuilder.Utils Namespace


GetProperties Method

[image] [image]

Sandcastle Help File Builder Documentation
COMReferenceItem..::.GetProperties Method
COMReferenceItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetProperties()()() | Returns the properties for this instance of a component. (Inherited from ReferenceItem.)
GetProperties(array<Attribute>[]()[]) | Returns the properties for this instance of a component using the attribute array as a filter. (Inherited from ReferenceItem.)

See Also

COMReferenceItem Class
COMReferenceItem Members
SandcastleBuilder.Utils Namespace


COMReferenceItem Properties

[image] [image]

Sandcastle Help File Builder Documentation
COMReferenceItem Properties
COMReferenceItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The COMReferenceItem type exposes the following members.

Properties

Name | Description
Guid | This is used to get the project reference's GUID
HintPath | Hint path isn't applicable to COM references (Overrides ReferenceItem..::.HintPath.)
ProjectElement | This returns the project element associated with the instance (Inherited from BaseBuildItem.)
Reference | This is used to get the reference description (Inherited from ReferenceItem.)
VersionMajor | This is used to get the major version number
VersionMinor | This is used to get the minor version number
WrapperTool | This is used to get the wrapper tool

See Also

COMReferenceItem Class
SandcastleBuilder.Utils Namespace


Guid Property

[image]

Sandcastle Help File Builder Documentation
COMReferenceItem..::.Guid Property
COMReferenceItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get the project reference's GUID

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string Guid { get; }
Visual Basic (Declaration)
Public ReadOnly Property Guid As String

See Also

COMReferenceItem Class
SandcastleBuilder.Utils Namespace


HintPath Property

[image]

Sandcastle Help File Builder Documentation
COMReferenceItem..::.HintPath Property
COMReferenceItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Hint path isn't applicable to COM references

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public override FilePath HintPath { get; set; }
Visual Basic (Declaration)
Public Overrides Property HintPath As FilePath

See Also

COMReferenceItem Class
SandcastleBuilder.Utils Namespace


VersionMajor Property

[image]

Sandcastle Help File Builder Documentation
COMReferenceItem..::.VersionMajor Property
COMReferenceItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get the major version number

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string VersionMajor { get; }
Visual Basic (Declaration)
Public ReadOnly Property VersionMajor As String

See Also

COMReferenceItem Class
SandcastleBuilder.Utils Namespace


VersionMinor Property

[image]

Sandcastle Help File Builder Documentation
COMReferenceItem..::.VersionMinor Property
COMReferenceItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get the minor version number

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string VersionMinor { get; }
Visual Basic (Declaration)
Public ReadOnly Property VersionMinor As String

See Also

COMReferenceItem Class
SandcastleBuilder.Utils Namespace


WrapperTool Property

[image]

Sandcastle Help File Builder Documentation
COMReferenceItem..::.WrapperTool Property
COMReferenceItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get the wrapper tool

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string WrapperTool { get; }
Visual Basic (Declaration)
Public ReadOnly Property WrapperTool As String

See Also

COMReferenceItem Class
SandcastleBuilder.Utils Namespace


Constants Class

[image]

Sandcastle Help File Builder Documentation
Constants Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This class holds a set of constants that define various application values such as the application name, common data folder, etc.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public static class Constants
Visual Basic (Declaration)
Public NotInheritable Class Constants

Inheritance Hierarchy

System..::.Object
SandcastleBuilder.Utils..::.Constants

See Also

Constants Members
SandcastleBuilder.Utils Namespace


Constants Members

[image] [image]

Sandcastle Help File Builder Documentation
Constants Members
Constants Class Fields See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Constants type exposes the following members.

Fields

Name | Description
AppName | The application name
CompanyName | The company name
ComponentsFolder | This folder is located under the CommonApplicationData folder and contains custom build components that can be added to a project.
ConceptualTemplates | This folder is located under the LocalApplicationData folder and contains user-defined conceptual content topic templates that can be added to a project.
ItemTemplates | This folder is located under the LocalApplicationData folder and contains user-defined item templates that can be added to a project.
PlugInsFolder | This folder is located under the CommonApplicationData folder and contains custom plug-ins that can be added to a project.
ProgramDataFolder | The application folder in which the component and user data files are stored.

See Also

Constants Class
SandcastleBuilder.Utils Namespace


Constants Fields

[image] [image]

Sandcastle Help File Builder Documentation
Constants Fields
Constants Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Constants type exposes the following members.

Fields

Name | Description
AppName | The application name
CompanyName | The company name
ComponentsFolder | This folder is located under the CommonApplicationData folder and contains custom build components that can be added to a project.
ConceptualTemplates | This folder is located under the LocalApplicationData folder and contains user-defined conceptual content topic templates that can be added to a project.
ItemTemplates | This folder is located under the LocalApplicationData folder and contains user-defined item templates that can be added to a project.
PlugInsFolder | This folder is located under the CommonApplicationData folder and contains custom plug-ins that can be added to a project.
ProgramDataFolder | The application folder in which the component and user data files are stored.

See Also

Constants Class
SandcastleBuilder.Utils Namespace


AppName Field

[image]

Sandcastle Help File Builder Documentation
Constants..::.AppName Field
Constants Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The application name

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public const string AppName
Visual Basic (Declaration)
Public Const AppName As String

See Also

Constants Class
SandcastleBuilder.Utils Namespace


CompanyName Field

[image]

Sandcastle Help File Builder Documentation
Constants..::.CompanyName Field
Constants Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The company name

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public const string CompanyName
Visual Basic (Declaration)
Public Const CompanyName As String

See Also

Constants Class
SandcastleBuilder.Utils Namespace


ComponentsFolder Field

[image]

Sandcastle Help File Builder Documentation
Constants..::.ComponentsFolder Field
Constants Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This folder is located under the CommonApplicationData folder and contains custom build components that can be added to a project.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public const string ComponentsFolder
Visual Basic (Declaration)
Public Const ComponentsFolder As String

See Also

Constants Class
SandcastleBuilder.Utils Namespace


ConceptualTemplates Field

[image]

Sandcastle Help File Builder Documentation
Constants..::.ConceptualTemplates Field
Constants Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This folder is located under the LocalApplicationData folder and contains user-defined conceptual content topic templates that can be added to a project.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public const string ConceptualTemplates
Visual Basic (Declaration)
Public Const ConceptualTemplates As String

See Also

Constants Class
SandcastleBuilder.Utils Namespace


ItemTemplates Field

[image]

Sandcastle Help File Builder Documentation
Constants..::.ItemTemplates Field
Constants Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This folder is located under the LocalApplicationData folder and contains user-defined item templates that can be added to a project.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public const string ItemTemplates
Visual Basic (Declaration)
Public Const ItemTemplates As String

See Also

Constants Class
SandcastleBuilder.Utils Namespace


PlugInsFolder Field

[image]

Sandcastle Help File Builder Documentation
Constants..::.PlugInsFolder Field
Constants Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This folder is located under the CommonApplicationData folder and contains custom plug-ins that can be added to a project.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public const string PlugInsFolder
Visual Basic (Declaration)
Public Const PlugInsFolder As String

See Also

Constants Class
SandcastleBuilder.Utils Namespace


ProgramDataFolder Field

[image]

Sandcastle Help File Builder Documentation
Constants..::.ProgramDataFolder Field
Constants Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The application folder in which the component and user data files are stored.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public const string ProgramDataFolder
Visual Basic (Declaration)
Public Const ProgramDataFolder As String

Remarks

This folder will be located under the CommonApplicationData or LocalApplicationData folder.

See Also

Constants Class
SandcastleBuilder.Utils Namespace


ContentPlacement Enumeration

[image]

Sandcastle Help File Builder Documentation
ContentPlacement Enumeration
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This public enumerated type defines the placement of the additional content items in the table of contents if any are defined.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
[SerializableAttribute]
public enum ContentPlacement
Visual Basic (Declaration)
<SerializableAttribute> _
Public Enumeration ContentPlacement

Members

Member name | Description
AboveNamespaces | Additional content appears above the namespaces
BelowNamespaces | Additional content appears below the namespaces

See Also

SandcastleBuilder.Utils Namespace


DocumentationSource Class

[image]

Sandcastle Help File Builder Documentation
DocumentationSource Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This represents an assembly, an XML comments file, a Visual Studio Solution (C#, VB.NET, or J#), or a Visual Studio solution containing one or more C#, VB.NET or J# projects to use for building a help file.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public class DocumentationSource : PropertyBasedCollectionItem
Visual Basic (Declaration)
Public Class DocumentationSource _
    Inherits PropertyBasedCollectionItem

Remarks

Wildcards are supported in the SourceFile property.

Inheritance Hierarchy

System..::.Object
SandcastleBuilder.Utils..::.PropertyBasedCollectionItem
SandcastleBuilder.Utils..::.DocumentationSource

See Also

DocumentationSource Members
SandcastleBuilder.Utils Namespace


DocumentationSource Members

[image] [image]

Sandcastle Help File Builder Documentation
DocumentationSource Members
DocumentationSource Class Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DocumentationSource type exposes the following members.

Methods

Name | Description
Assemblies | This returns a collection of assemblies based on the specified wildcard.
CheckProjectIsEditable | This is used to see if the project can be edited. If not, abort the change by throwing an exception. (Inherited from PropertyBasedCollectionItem.)
CommentsFiles | This returns a collection of XML comments files based on the specified wildcard.
Equals | See if specified item equals this one (Overrides Object..::.Equals(Object).)
ExtractProjectsFromSolution | Extract all project filenames from the given Visual Studio solution file.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Get a hash code for this item (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Projects | This returns a collection of MSBuild project filenames based on the specified wildcard.
ToString | Return a string representation of the item (Overrides Object..::.ToString()()().)

Properties

Name | Description
Configuration | This is used to get or set the project configuration to use when the source path refers to a Visual Studio solution or project.
IncludeSubFolders | This is used to get or set whether subfolders are included when searching for files if the SourceFile value contains wildcards.
IsDirty | This is used to get or set the dirty state of the item (Inherited from PropertyBasedCollectionItem.)
Platform | This is used to get or set the project platform to use when the source path refers to a Visual Studio solution or project.
ProjectFile | This is used to get the owning project file (Inherited from PropertyBasedCollectionItem.)
SourceDescription | This returns a description of the entry suitable for display in a bound list control.
SourceFile | This is used to set or get the documentation source file path

See Also

DocumentationSource Class
SandcastleBuilder.Utils Namespace


DocumentationSource Methods

[image] [image]

Sandcastle Help File Builder Documentation
DocumentationSource Methods
DocumentationSource Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DocumentationSource type exposes the following members.

Methods

Name | Description
Assemblies | This returns a collection of assemblies based on the specified wildcard.
CheckProjectIsEditable | This is used to see if the project can be edited. If not, abort the change by throwing an exception. (Inherited from PropertyBasedCollectionItem.)
CommentsFiles | This returns a collection of XML comments files based on the specified wildcard.
Equals | See if specified item equals this one (Overrides Object..::.Equals(Object).)
ExtractProjectsFromSolution | Extract all project filenames from the given Visual Studio solution file.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Get a hash code for this item (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Projects | This returns a collection of MSBuild project filenames based on the specified wildcard.
ToString | Return a string representation of the item (Overrides Object..::.ToString()()().)

See Also

DocumentationSource Class
SandcastleBuilder.Utils Namespace


Assemblies Method

[image]

Sandcastle Help File Builder Documentation
DocumentationSource..::.Assemblies Method
DocumentationSource Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This returns a collection of assemblies based on the specified wildcard.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public static Collection<string> Assemblies(
    string wildcard,
    bool includeSubfolders
)
Visual Basic (Declaration)
Public Shared Function Assemblies ( _
    wildcard As String, _
    includeSubfolders As Boolean _
) As Collection(Of String)

Parameters

wildcard
Type: System..::.String
The wildcard to use to find assemblies.
includeSubfolders
Type: System..::.Boolean
If true and the wildcard parameter includes wildcard characters, subfolders will be searched as well. If not, only the top-level folder is searched.

Return Value

A list of assemblies matching the wildcard

See Also

DocumentationSource Class
SandcastleBuilder.Utils Namespace


CommentsFiles Method

[image]

Sandcastle Help File Builder Documentation
DocumentationSource..::.CommentsFiles Method
DocumentationSource Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This returns a collection of XML comments files based on the specified wildcard.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public static Collection<string> CommentsFiles(
    string wildcard,
    bool includeSubfolders
)
Visual Basic (Declaration)
Public Shared Function CommentsFiles ( _
    wildcard As String, _
    includeSubfolders As Boolean _
) As Collection(Of String)

Parameters

wildcard
Type: System..::.String
The wildcard to use to find comments files.
includeSubfolders
Type: System..::.Boolean
If true and the wildcard parameter includes wildcard characters, subfolders will be searched as well. If not, only the top-level folder is searched.

Return Value

A list of XML comments files matching the wildcard

See Also

DocumentationSource Class
SandcastleBuilder.Utils Namespace


Equals Method

[image]

Sandcastle Help File Builder Documentation
DocumentationSource..::.Equals Method
DocumentationSource Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

See if specified item equals this one

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::.Object
The object to compare to this one

Return Value

True if equal, false if not

Remarks

For documentation sources, equality is based solely on the SourceFile value. The configuration and platform settings are not considered.

See Also

DocumentationSource Class
SandcastleBuilder.Utils Namespace


ExtractProjectsFromSolution Method

[image]

Sandcastle Help File Builder Documentation
DocumentationSource..::.ExtractProjectsFromSolution Method
DocumentationSource Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Extract all project filenames from the given Visual Studio solution file.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public static void ExtractProjectsFromSolution(
    string solutionFile,
    Collection<string> projectFiles
)
Visual Basic (Declaration)
Public Shared Sub ExtractProjectsFromSolution ( _
    solutionFile As String, _
    projectFiles As Collection(Of String) _
)

Parameters

solutionFile
Type: System..::.String
The Visual Studio solution from which to extract the projects.
projectFiles
Type: System.Collections.ObjectModel..::.Collection <(Of <( String >)>)
The collection used to return the extracted projects.

See Also

DocumentationSource Class
SandcastleBuilder.Utils Namespace


GetHashCode Method

[image]

Sandcastle Help File Builder Documentation
DocumentationSource..::.GetHashCode Method
DocumentationSource Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Get a hash code for this item

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer

Return Value

Returns the hash code for the assembly path and XML comments path.

See Also

DocumentationSource Class
SandcastleBuilder.Utils Namespace


Projects Method

[image]

Sandcastle Help File Builder Documentation
DocumentationSource..::.Projects Method
DocumentationSource Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This returns a collection of MSBuild project filenames based on the specified wildcard.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public static Collection<string> Projects(
    string wildcard,
    bool includeSubfolders
)
Visual Basic (Declaration)
Public Shared Function Projects ( _
    wildcard As String, _
    includeSubfolders As Boolean _
) As Collection(Of String)

Parameters

wildcard
Type: System..::.String
The wildcard to use to find solutions and projects.
includeSubfolders
Type: System..::.Boolean
If true and the wildcard parameter includes wildcard characters, subfolders will be searched as well. If not, only the top-level folder is searched.

Return Value

A list of projects matching the wildcard. Any solution files (.sln) found are returned last, each followed by the project filenames extracted from it.

See Also

DocumentationSource Class
SandcastleBuilder.Utils Namespace


ToString Method

[image]

Sandcastle Help File Builder Documentation
DocumentationSource..::.ToString Method
DocumentationSource Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Return a string representation of the item

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

Return Value

Returns the assembly path and XML comments path separated by a comma.

See Also

DocumentationSource Class
SandcastleBuilder.Utils Namespace


DocumentationSource Properties

[image] [image]

Sandcastle Help File Builder Documentation
DocumentationSource Properties
DocumentationSource Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DocumentationSource type exposes the following members.

Properties

Name | Description
Configuration | This is used to get or set the project configuration to use when the source path refers to a Visual Studio solution or project.
IncludeSubFolders | This is used to get or set whether subfolders are included when searching for files if the SourceFile value contains wildcards.
IsDirty | This is used to get or set the dirty state of the item (Inherited from PropertyBasedCollectionItem.)
Platform | This is used to get or set the project platform to use when the source path refers to a Visual Studio solution or project.
ProjectFile | This is used to get the owning project file (Inherited from PropertyBasedCollectionItem.)
SourceDescription | This returns a description of the entry suitable for display in a bound list control.
SourceFile | This is used to set or get the documentation source file path

See Also

DocumentationSource Class
SandcastleBuilder.Utils Namespace


Configuration Property

[image]

Sandcastle Help File Builder Documentation
DocumentationSource..::.Configuration Property
DocumentationSource Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set the project configuration to use when the source path refers to a Visual Studio solution or project.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string Configuration { get; set; }
Visual Basic (Declaration)
Public Property Configuration As String

Field Value

If not set, the configuration value from the owning help file project will be used. This will be ignored for assembly and XML comments file entries.

See Also

DocumentationSource Class
SandcastleBuilder.Utils Namespace


IncludeSubFolders Property

[image]

Sandcastle Help File Builder Documentation
DocumentationSource..::.IncludeSubFolders Property
DocumentationSource Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set whether subfolders are included when searching for files if the SourceFile value contains wildcards.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool IncludeSubFolders { get; set; }
Visual Basic (Declaration)
Public Property IncludeSubFolders As Boolean

Field Value

If set to true and the source file value contains wildcards, subfolders will be included. If set to false, the default, or the source file value does not contain wildcards, only the top-level folder is included in the search.

See Also

DocumentationSource Class
SandcastleBuilder.Utils Namespace


Platform Property

[image]

Sandcastle Help File Builder Documentation
DocumentationSource..::.Platform Property
DocumentationSource Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set the project platform to use when the source path refers to a Visual Studio solution or project.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string Platform { get; set; }
Visual Basic (Declaration)
Public Property Platform As String

Field Value

If not set, the platform value from the owning help file project will be used. This will be ignored for assembly and XML comments file entries.

See Also

DocumentationSource Class
SandcastleBuilder.Utils Namespace


SourceDescription Property

[image]

Sandcastle Help File Builder Documentation
DocumentationSource..::.SourceDescription Property
DocumentationSource Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This returns a description of the entry suitable for display in a bound list control.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string SourceDescription { get; }
Visual Basic (Declaration)
Public ReadOnly Property SourceDescription As String

See Also

DocumentationSource Class
SandcastleBuilder.Utils Namespace


SourceFile Property

[image]

Sandcastle Help File Builder Documentation
DocumentationSource..::.SourceFile Property
DocumentationSource Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to set or get the documentation source file path

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public FilePath SourceFile { get; set; }
Visual Basic (Declaration)
Public Property SourceFile As FilePath

Field Value

Wildcards are supported. If used, all files matching the wildcard will be included as long as their extension is one of the following: .exe, .dll, .*proj, .sln.

See Also

DocumentationSource Class
SandcastleBuilder.Utils Namespace


DocumentationSourceCollection Class

[image]

Sandcastle Help File Builder Documentation
DocumentationSourceCollection Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This collection class is used to hold the documentation sources

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public class DocumentationSourceCollection : BindingList<DocumentationSource>
Visual Basic (Declaration)
Public Class DocumentationSourceCollection _
    Inherits BindingList(Of DocumentationSource)

Remarks

A documentation source is an assembly, an XML comments file, a Visual Studio project (C#, VB.NET, or J#), or a Visual Studio solution containing one or more C#, VB.NET or J# projects.

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection <(Of <( DocumentationSource >)>)
System.ComponentModel..::.BindingList <(Of <( DocumentationSource >)>)
SandcastleBuilder.Utils..::.DocumentationSourceCollection

See Also

DocumentationSourceCollection Members
SandcastleBuilder.Utils Namespace


DocumentationSourceCollection Members

[image] [image]

Sandcastle Help File Builder Documentation
DocumentationSourceCollection Members
DocumentationSourceCollection Class Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DocumentationSourceCollection type exposes the following members.

Methods

Name | Description
Add | Overloaded.
AddNew | Adds a new item to the collection. (Inherited from BindingList <(Of <( DocumentationSource >)>).)
AddNewCore | Adds a new item to the end of the collection. (Inherited from BindingList <(Of <( DocumentationSource >)>).)
ApplySortCore | Sorts the items if overridden in a derived class; otherwise, throws a NotSupportedException. (Inherited from BindingList <(Of <( DocumentationSource >)>).)
CancelNew | Discards a pending new item. (Inherited from BindingList <(Of <( DocumentationSource >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DocumentationSource >)>).)
ClearItems | Removes all elements from the collection. (Inherited from BindingList <(Of <( DocumentationSource >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DocumentationSource >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <( DocumentationSource >)>).)
EndNew | Commits a pending new item to the collection. (Inherited from BindingList <(Of <( DocumentationSource >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindCore | Searches for the index of the item that has the specified property descriptor with the specified value, if searching is implemented in a derived class; otherwise, a NotSupportedException. (Inherited from BindingList <(Of <( DocumentationSource >)>).)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DocumentationSource >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DocumentationSource >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( DocumentationSource >)>).)
InsertItem | Inserts the specified item in the list at the specified index. (Inherited from BindingList <(Of <( DocumentationSource >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnAddingNew | Raises the AddingNew event. (Inherited from BindingList <(Of <( DocumentationSource >)>).)
OnListChanged | This is overridden to mark the collection as dirty when it changes (Overrides BindingList<(Of <(T>)>)..::.OnListChanged(ListChangedEventArgs).)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DocumentationSource >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DocumentationSource >)>).)
RemoveItem | Removes the item at the specified index. (Inherited from BindingList <(Of <( DocumentationSource >)>).)
RemoveSortCore | Removes any sort applied with ApplySortCore(PropertyDescriptor, ListSortDirection) if sorting is implemented in a derived class; otherwise, raises NotSupportedException. (Inherited from BindingList <(Of <( DocumentationSource >)>).)
ResetBindings | Raises a ListChanged event of type Reset. (Inherited from BindingList <(Of <( DocumentationSource >)>).)
ResetItem | Raises a ListChanged event of type ItemChanged for the item at the specified position. (Inherited from BindingList <(Of <( DocumentationSource >)>).)
SetItem | Replaces the item at the specified index with the specified item. (Inherited from BindingList <(Of <( DocumentationSource >)>).)
Sort | This is used to sort the collection in ascending order.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AllowEdit | Gets or sets a value indicating whether items in the list can be edited. (Inherited from BindingList <(Of <( DocumentationSource >)>).)
AllowNew | Gets or sets a value indicating whether you can add items to the list using the AddNew()()() method. (Inherited from BindingList <(Of <( DocumentationSource >)>).)
AllowRemove | Gets or sets a value indicating whether you can remove items from the collection. (Inherited from BindingList <(Of <( DocumentationSource >)>).)
Assemblies | This read-only property returns a list of assemblies in the collection.
CommentsFiles | This read-only property returns a list of XML comments files in the collection.
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DocumentationSource >)>).)
IsDirty | This is used to get or set the dirty state of the collection
IsSortedCore | Gets a value indicating whether the list is sorted. (Inherited from BindingList <(Of <( DocumentationSource >)>).)
Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <( DocumentationSource >)>).)
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DocumentationSource >)>).)
RaiseListChangedEvents | Gets or sets a value indicating whether adding or removing items within the list raises ListChanged events. (Inherited from BindingList <(Of <( DocumentationSource >)>).)
SortDirectionCore | Gets the direction the list is sorted. (Inherited from BindingList <(Of <( DocumentationSource >)>).)
SortPropertyCore | Gets the property descriptor that is used for sorting the list if sorting is implemented in a derived class; otherwise, returns null. (Inherited from BindingList <(Of <( DocumentationSource >)>).)
SupportsChangeNotificationCore | Gets a value indicating whether ListChanged events are enabled. (Inherited from BindingList <(Of <( DocumentationSource >)>).)
SupportsSearchingCore | Gets a value indicating whether the list supports searching. (Inherited from BindingList <(Of <( DocumentationSource >)>).)
SupportsSortingCore | Gets a value indicating whether the list supports sorting. (Inherited from BindingList <(Of <( DocumentationSource >)>).)

Events

Name | Description
AddingNew | Occurs before an item is added to the list. (Inherited from BindingList <(Of <( DocumentationSource >)>).)
ListChanged | Occurs when the list or an item in the list changes. (Inherited from BindingList <(Of <( DocumentationSource >)>).)

See Also

DocumentationSourceCollection Class
SandcastleBuilder.Utils Namespace


DocumentationSourceCollection Methods

[image] [image]

Sandcastle Help File Builder Documentation
DocumentationSourceCollection Methods
DocumentationSourceCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DocumentationSourceCollection type exposes the following members.

Methods

Name | Description
Add | Overloaded.
AddNew | Adds a new item to the collection. (Inherited from BindingList <(Of <( DocumentationSource >)>).)
AddNewCore | Adds a new item to the end of the collection. (Inherited from BindingList <(Of <( DocumentationSource >)>).)
ApplySortCore | Sorts the items if overridden in a derived class; otherwise, throws a NotSupportedException. (Inherited from BindingList <(Of <( DocumentationSource >)>).)
CancelNew | Discards a pending new item. (Inherited from BindingList <(Of <( DocumentationSource >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DocumentationSource >)>).)
ClearItems | Removes all elements from the collection. (Inherited from BindingList <(Of <( DocumentationSource >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DocumentationSource >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <( DocumentationSource >)>).)
EndNew | Commits a pending new item to the collection. (Inherited from BindingList <(Of <( DocumentationSource >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindCore | Searches for the index of the item that has the specified property descriptor with the specified value, if searching is implemented in a derived class; otherwise, a NotSupportedException. (Inherited from BindingList <(Of <( DocumentationSource >)>).)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DocumentationSource >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DocumentationSource >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( DocumentationSource >)>).)
InsertItem | Inserts the specified item in the list at the specified index. (Inherited from BindingList <(Of <( DocumentationSource >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnAddingNew | Raises the AddingNew event. (Inherited from BindingList <(Of <( DocumentationSource >)>).)
OnListChanged | This is overridden to mark the collection as dirty when it changes (Overrides BindingList<(Of <(T>)>)..::.OnListChanged(ListChangedEventArgs).)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DocumentationSource >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DocumentationSource >)>).)
RemoveItem | Removes the item at the specified index. (Inherited from BindingList <(Of <( DocumentationSource >)>).)
RemoveSortCore | Removes any sort applied with ApplySortCore(PropertyDescriptor, ListSortDirection) if sorting is implemented in a derived class; otherwise, raises NotSupportedException. (Inherited from BindingList <(Of <( DocumentationSource >)>).)
ResetBindings | Raises a ListChanged event of type Reset. (Inherited from BindingList <(Of <( DocumentationSource >)>).)
ResetItem | Raises a ListChanged event of type ItemChanged for the item at the specified position. (Inherited from BindingList <(Of <( DocumentationSource >)>).)
SetItem | Replaces the item at the specified index with the specified item. (Inherited from BindingList <(Of <( DocumentationSource >)>).)
Sort | This is used to sort the collection in ascending order.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentationSourceCollection Class
SandcastleBuilder.Utils Namespace


Add Method

[image] [image]

Sandcastle Help File Builder Documentation
DocumentationSourceCollection..::.Add Method
DocumentationSourceCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Add(T) | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DocumentationSource >)>).)
Add(String, String, String, Boolean) | Add a new item to the collection

See Also

DocumentationSourceCollection Class
DocumentationSourceCollection Members
SandcastleBuilder.Utils Namespace


Add Method (String, String, String, Boolean)

[image]

Sandcastle Help File Builder Documentation
DocumentationSourceCollection..::.Add Method (String, String, String, Boolean)
DocumentationSourceCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Add a new item to the collection

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public DocumentationSource Add(
    string filename,
    string config,
    string platform,
    bool subFolders
)
Visual Basic (Declaration)
Public Function Add ( _
    filename As String, _
    config As String, _
    platform As String, _
    subFolders As Boolean _
) As DocumentationSource

Parameters

filename
Type: System..::.String
The filename to add
config
Type: System..::.String
The configuration to use for projects
platform
Type: System..::.String
The platform to use for projects
subFolders
Type: System..::.Boolean
True to include subfolders, false to only search the top-level folder.

Return Value

The DocumentationSource added to the project or the existing item if the filename already exists in the collection.

Remarks

The DocumentationSource constructor is internal so that we control creation of the items and can associate them with the project.

See Also

DocumentationSourceCollection Class
Add Overload
SandcastleBuilder.Utils Namespace


OnListChanged Method

[image]

Sandcastle Help File Builder Documentation
DocumentationSourceCollection..::.OnListChanged Method
DocumentationSourceCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is overridden to mark the collection as dirty when it changes

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected override void OnListChanged(
    ListChangedEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnListChanged ( _
    e As ListChangedEventArgs _
)

Parameters

e
Type: System.ComponentModel..::.ListChangedEventArgs
The event arguments

See Also

DocumentationSourceCollection Class
SandcastleBuilder.Utils Namespace


Sort Method

[image]

Sandcastle Help File Builder Documentation
DocumentationSourceCollection..::.Sort Method
DocumentationSourceCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to sort the collection in ascending order.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public void Sort()
Visual Basic (Declaration)
Public Sub Sort

See Also

DocumentationSourceCollection Class
SandcastleBuilder.Utils Namespace


DocumentationSourceCollection Properties

[image] [image]

Sandcastle Help File Builder Documentation
DocumentationSourceCollection Properties
DocumentationSourceCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DocumentationSourceCollection type exposes the following members.

Properties

Name | Description
AllowEdit | Gets or sets a value indicating whether items in the list can be edited. (Inherited from BindingList <(Of <( DocumentationSource >)>).)
AllowNew | Gets or sets a value indicating whether you can add items to the list using the AddNew()()() method. (Inherited from BindingList <(Of <( DocumentationSource >)>).)
AllowRemove | Gets or sets a value indicating whether you can remove items from the collection. (Inherited from BindingList <(Of <( DocumentationSource >)>).)
Assemblies | This read-only property returns a list of assemblies in the collection.
CommentsFiles | This read-only property returns a list of XML comments files in the collection.
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DocumentationSource >)>).)
IsDirty | This is used to get or set the dirty state of the collection
IsSortedCore | Gets a value indicating whether the list is sorted. (Inherited from BindingList <(Of <( DocumentationSource >)>).)
Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <( DocumentationSource >)>).)
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DocumentationSource >)>).)
RaiseListChangedEvents | Gets or sets a value indicating whether adding or removing items within the list raises ListChanged events. (Inherited from BindingList <(Of <( DocumentationSource >)>).)
SortDirectionCore | Gets the direction the list is sorted. (Inherited from BindingList <(Of <( DocumentationSource >)>).)
SortPropertyCore | Gets the property descriptor that is used for sorting the list if sorting is implemented in a derived class; otherwise, returns null. (Inherited from BindingList <(Of <( DocumentationSource >)>).)
SupportsChangeNotificationCore | Gets a value indicating whether ListChanged events are enabled. (Inherited from BindingList <(Of <( DocumentationSource >)>).)
SupportsSearchingCore | Gets a value indicating whether the list supports searching. (Inherited from BindingList <(Of <( DocumentationSource >)>).)
SupportsSortingCore | Gets a value indicating whether the list supports sorting. (Inherited from BindingList <(Of <( DocumentationSource >)>).)

See Also

DocumentationSourceCollection Class
SandcastleBuilder.Utils Namespace


Assemblies Property

[image]

Sandcastle Help File Builder Documentation
DocumentationSourceCollection..::.Assemblies Property
DocumentationSourceCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns a list of assemblies in the collection.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public Collection<string> Assemblies { get; }
Visual Basic (Declaration)
Public ReadOnly Property Assemblies As Collection(Of String)

See Also

DocumentationSourceCollection Class
SandcastleBuilder.Utils Namespace


CommentsFiles Property

[image]

Sandcastle Help File Builder Documentation
DocumentationSourceCollection..::.CommentsFiles Property
DocumentationSourceCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns a list of XML comments files in the collection.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public Collection<string> CommentsFiles { get; }
Visual Basic (Declaration)
Public ReadOnly Property CommentsFiles As Collection(Of String)

See Also

DocumentationSourceCollection Class
SandcastleBuilder.Utils Namespace


IsDirty Property

[image]

Sandcastle Help File Builder Documentation
DocumentationSourceCollection..::.IsDirty Property
DocumentationSourceCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set the dirty state of the collection

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool IsDirty { get; set; }
Visual Basic (Declaration)
Public Property IsDirty As Boolean

See Also

DocumentationSourceCollection Class
SandcastleBuilder.Utils Namespace


DocumentationSourceCollection Events

[image] [image]

Sandcastle Help File Builder Documentation
DocumentationSourceCollection Events
DocumentationSourceCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DocumentationSourceCollection type exposes the following members.

Events

Name | Description
AddingNew | Occurs before an item is added to the list. (Inherited from BindingList <(Of <( DocumentationSource >)>).)
ListChanged | Occurs when the list or an item in the list changes. (Inherited from BindingList <(Of <( DocumentationSource >)>).)

See Also

DocumentationSourceCollection Class
SandcastleBuilder.Utils Namespace


DocumentType Enumeration

[image]

Sandcastle Help File Builder Documentation
DocumentType Enumeration
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This public enumerated type defines the conceptual document types

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
[SerializableAttribute]
public enum DocumentType
Visual Basic (Declaration)
<SerializableAttribute> _
Public Enumeration DocumentType

Members

Member name | Description
None | Unknown document type or empty container node
NotFound | File not found
Invalid | Invalid document (i.e. bad format, parsing errors)
DeveloperConceptualDocument | Conceptual document
DeveloperErrorMessageDocument | Error Message document
DeveloperGlossaryDocument | Glossary document
DeveloperHowToDocument | How To document
DeveloperOrientationDocument | Orientation document
CodeEntityDocument | Reference List document
DeveloperReferenceWithSyntaxDocument | Reference With Syntax document
DeveloperReferenceWithoutSyntaxDocument | Reference Without Syntax document
DeveloperSampleDocument | Sample Document
DeveloperSDKTechnologyOverviewArchitectureDocument | SDK Technology Overview Architechture document
DeveloperSDKTechnologyOverviewCodeDirectoryDocument | SDK Technology Overview Code Directory document
DeveloperSDKTechnologyOverviewOrientationDocument | SDK Technology Overview Orientation document
DeveloperSDKTechnologyOverviewScenariosDocument | SDK Technology Overview Scenarios document
DeveloperSDKTechnologyOverviewTechnologySummaryDocument | SDK Technology Overview Technology Summary document
DeveloperTroubleshootingDocument | Troubleshooting document
DeveloperUIReferenceDocument | User Interface Reference document
DeveloperWalkthroughDocument | Walkthrough document
DeveloperWhitePaperDocument | Whitepaper document
DeveloperXmlReference | XML Reference document
Html | Raw HTML

See Also

SandcastleBuilder.Utils Namespace


FileItem Class

[image]

Sandcastle Help File Builder Documentation
FileItem Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This class represents a file that is part of the project (MAML/additional content, site map, stylesheet, etc.).

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public class FileItem : BaseBuildItem, ICustomTypeDescriptor
Visual Basic (Declaration)
Public Class FileItem _
    Inherits BaseBuildItem _
    Implements ICustomTypeDescriptor

Inheritance Hierarchy

System..::.Object
SandcastleBuilder.Utils..::.BaseBuildItem
SandcastleBuilder.Utils..::.FileItem

See Also

FileItem Members
SandcastleBuilder.Utils Namespace


FileItem Members

[image] [image]

Sandcastle Help File Builder Documentation
FileItem Members
FileItem Class Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FileItem type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAttributes | Returns a collection of custom attributes for this instance of a component.
GetClassName | Returns the class name of this instance of a component.
GetComponentName | Returns the name of this instance of a component.
GetConverter | Returns a type converter for this instance of a component.
GetDefaultEvent | Returns the default event for this instance of a component.
GetDefaultProperty | Returns the default property for this instance of a component.
GetEditor | Returns an editor of the specified type for this instance of a component.
GetEvents | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetProperties | Overloaded.
GetPropertyOwner | Returns an object that contains the property described by the specified property descriptor.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RefreshPaths | Refresh the paths due to a parent path being renamed
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AlternateText | This is used to get or set alternate text for an image
BuildAction | This is used to set or get the build action of the item
CopyToMedia | This is used to get or set whether an item is copied to the output folder during a build.
ExcludeFromToc | For content items such as HTML pages, this is used to get or set whether or not the item is excluded from the table of contents.
FullPath | This is used to get the full path to the item
ImageId | This is used to get or set an ID for a conceptual content image
Include | This is used to set or get the filename (include path)
Link | This is used to set or get the link path
Name | This is used to set or get the name of the item
ProjectElement | This returns the project element associated with the instance (Inherited from BaseBuildItem.)
SortOrder | This is used to get or set the sort order for content layout and site map files.

See Also

FileItem Class
SandcastleBuilder.Utils Namespace


FileItem Methods

[image] [image]

Sandcastle Help File Builder Documentation
FileItem Methods
FileItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FileItem type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAttributes | Returns a collection of custom attributes for this instance of a component.
GetClassName | Returns the class name of this instance of a component.
GetComponentName | Returns the name of this instance of a component.
GetConverter | Returns a type converter for this instance of a component.
GetDefaultEvent | Returns the default event for this instance of a component.
GetDefaultProperty | Returns the default property for this instance of a component.
GetEditor | Returns an editor of the specified type for this instance of a component.
GetEvents | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetProperties | Overloaded.
GetPropertyOwner | Returns an object that contains the property described by the specified property descriptor.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RefreshPaths | Refresh the paths due to a parent path being renamed
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FileItem Class
SandcastleBuilder.Utils Namespace


GetAttributes Method

[image]

Sandcastle Help File Builder Documentation
FileItem..::.GetAttributes Method
FileItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Returns a collection of custom attributes for this instance of a component.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public AttributeCollection GetAttributes()
Visual Basic (Declaration)
Public Function GetAttributes As AttributeCollection

Return Value

An AttributeCollection containing the attributes for this object.

Implements

ICustomTypeDescriptor..::.GetAttributes()()()

See Also

FileItem Class
SandcastleBuilder.Utils Namespace


GetClassName Method

[image]

Sandcastle Help File Builder Documentation
FileItem..::.GetClassName Method
FileItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Returns the class name of this instance of a component.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string GetClassName()
Visual Basic (Declaration)
Public Function GetClassName As String

Return Value

The class name of the object, or null if the class does not have a name.

Implements

ICustomTypeDescriptor..::.GetClassName()()()

See Also

FileItem Class
SandcastleBuilder.Utils Namespace


GetComponentName Method

[image]

Sandcastle Help File Builder Documentation
FileItem..::.GetComponentName Method
FileItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Returns the name of this instance of a component.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string GetComponentName()
Visual Basic (Declaration)
Public Function GetComponentName As String

Return Value

The name of the object, or null if the object does not have a name.

Implements

ICustomTypeDescriptor..::.GetComponentName()()()

See Also

FileItem Class
SandcastleBuilder.Utils Namespace


GetConverter Method

[image]

Sandcastle Help File Builder Documentation
FileItem..::.GetConverter Method
FileItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Returns a type converter for this instance of a component.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public TypeConverter GetConverter()
Visual Basic (Declaration)
Public Function GetConverter As TypeConverter

Return Value

A TypeConverter that is the converter for this object, or null if there is no TypeConverter for this object.

Implements

ICustomTypeDescriptor..::.GetConverter()()()

See Also

FileItem Class
SandcastleBuilder.Utils Namespace


GetDefaultEvent Method

[image]

Sandcastle Help File Builder Documentation
FileItem..::.GetDefaultEvent Method
FileItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Returns the default event for this instance of a component.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public EventDescriptor GetDefaultEvent()
Visual Basic (Declaration)
Public Function GetDefaultEvent As EventDescriptor

Return Value

An EventDescriptor that represents the default event for this object, or null if this object does not have events.

Implements

ICustomTypeDescriptor..::.GetDefaultEvent()()()

See Also

FileItem Class
SandcastleBuilder.Utils Namespace


GetDefaultProperty Method

[image]

Sandcastle Help File Builder Documentation
FileItem..::.GetDefaultProperty Method
FileItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Returns the default property for this instance of a component.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public PropertyDescriptor GetDefaultProperty()
Visual Basic (Declaration)
Public Function GetDefaultProperty As PropertyDescriptor

Return Value

A PropertyDescriptor that represents the default property for this object, or null if this object does not have properties.

Implements

ICustomTypeDescriptor..::.GetDefaultProperty()()()

See Also

FileItem Class
SandcastleBuilder.Utils Namespace


GetEditor Method

[image]

Sandcastle Help File Builder Documentation
FileItem..::.GetEditor Method
FileItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Returns an editor of the specified type for this instance of a component.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public Object GetEditor(
    Type editorBaseType
)
Visual Basic (Declaration)
Public Function GetEditor ( _
    editorBaseType As Type _
) As Object

Parameters

editorBaseType
Type: System..::.Type
A Type that represents the editor for this object.

Return Value

An Object of the specified type that is the editor for this object, or null if the editor cannot be found.

Implements

ICustomTypeDescriptor..::.GetEditor(Type)

See Also

FileItem Class
SandcastleBuilder.Utils Namespace


GetEvents Method

[image] [image]

Sandcastle Help File Builder Documentation
FileItem..::.GetEvents Method
FileItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetEvents()()() | Returns the events for this instance of a component.
GetEvents(array<Attribute>[]()[]) | Returns the events for this instance of a component using the specified attribute array as a filter.

See Also

FileItem Class
FileItem Members
SandcastleBuilder.Utils Namespace


GetEvents Method

[image]

Sandcastle Help File Builder Documentation
FileItem..::.GetEvents Method
FileItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Returns the events for this instance of a component.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public EventDescriptorCollection GetEvents()
Visual Basic (Declaration)
Public Function GetEvents As EventDescriptorCollection

Return Value

An EventDescriptorCollection that represents the events for this component instance.

Implements

ICustomTypeDescriptor..::.GetEvents()()()

See Also

FileItem Class
GetEvents Overload
SandcastleBuilder.Utils Namespace


GetEvents Method (Attribute[])

[image]

Sandcastle Help File Builder Documentation
FileItem..::.GetEvents Method (array<Attribute>[]()[])
FileItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Returns the events for this instance of a component using the specified attribute array as a filter.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public EventDescriptorCollection GetEvents(
    Attribute[] attributes
)
Visual Basic (Declaration)
Public Function GetEvents ( _
    attributes As Attribute() _
) As EventDescriptorCollection

Parameters

attributes
Type: array< System..::.Attribute >[]()[]
An array of type Attribute that is used as a filter.

Return Value

An EventDescriptorCollection that represents the filtered events for this component instance.

Implements

ICustomTypeDescriptor..::.GetEvents(array<Attribute>[]()[])

See Also

FileItem Class
GetEvents Overload
SandcastleBuilder.Utils Namespace


GetProperties Method

[image] [image]

Sandcastle Help File Builder Documentation
FileItem..::.GetProperties Method
FileItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetProperties()()() | Returns the properties for this instance of a component.
GetProperties(array<Attribute>[]()[]) | Returns the properties for this instance of a component using the attribute array as a filter.

See Also

FileItem Class
FileItem Members
SandcastleBuilder.Utils Namespace


GetProperties Method

[image]

Sandcastle Help File Builder Documentation
FileItem..::.GetProperties Method
FileItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Returns the properties for this instance of a component.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public PropertyDescriptorCollection GetProperties()
Visual Basic (Declaration)
Public Function GetProperties As PropertyDescriptorCollection

Return Value

A PropertyDescriptorCollection that represents the properties for this component instance.

Implements

ICustomTypeDescriptor..::.GetProperties()()()

See Also

FileItem Class
GetProperties Overload
SandcastleBuilder.Utils Namespace


GetProperties Method (Attribute[])

[image]

Sandcastle Help File Builder Documentation
FileItem..::.GetProperties Method (array<Attribute>[]()[])
FileItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Returns the properties for this instance of a component using the attribute array as a filter.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public PropertyDescriptorCollection GetProperties(
    Attribute[] attributes
)
Visual Basic (Declaration)
Public Function GetProperties ( _
    attributes As Attribute() _
) As PropertyDescriptorCollection

Parameters

attributes
Type: array< System..::.Attribute >[]()[]
An array of type Attribute that is used as a filter.

Return Value

A PropertyDescriptorCollection that represents the filtered properties for this component instance.

Implements

ICustomTypeDescriptor..::.GetProperties(array<Attribute>[]()[])

See Also

FileItem Class
GetProperties Overload
SandcastleBuilder.Utils Namespace


GetPropertyOwner Method

[image]

Sandcastle Help File Builder Documentation
FileItem..::.GetPropertyOwner Method
FileItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Returns an object that contains the property described by the specified property descriptor.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public Object GetPropertyOwner(
    PropertyDescriptor pd
)
Visual Basic (Declaration)
Public Function GetPropertyOwner ( _
    pd As PropertyDescriptor _
) As Object

Parameters

pd
Type: System.ComponentModel..::.PropertyDescriptor
A PropertyDescriptor that represents the property whose owner is to be found.

Return Value

An Object that represents the owner of the specified property.

Implements

ICustomTypeDescriptor..::.GetPropertyOwner(PropertyDescriptor)

See Also

FileItem Class
SandcastleBuilder.Utils Namespace


RefreshPaths Method

[image]

Sandcastle Help File Builder Documentation
FileItem..::.RefreshPaths Method
FileItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Refresh the paths due to a parent path being renamed

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public void RefreshPaths()
Visual Basic (Declaration)
Public Sub RefreshPaths

See Also

FileItem Class
SandcastleBuilder.Utils Namespace


FileItem Properties

[image] [image]

Sandcastle Help File Builder Documentation
FileItem Properties
FileItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FileItem type exposes the following members.

Properties

Name | Description
AlternateText | This is used to get or set alternate text for an image
BuildAction | This is used to set or get the build action of the item
CopyToMedia | This is used to get or set whether an item is copied to the output folder during a build.
ExcludeFromToc | For content items such as HTML pages, this is used to get or set whether or not the item is excluded from the table of contents.
FullPath | This is used to get the full path to the item
ImageId | This is used to get or set an ID for a conceptual content image
Include | This is used to set or get the filename (include path)
Link | This is used to set or get the link path
Name | This is used to set or get the name of the item
ProjectElement | This returns the project element associated with the instance (Inherited from BaseBuildItem.)
SortOrder | This is used to get or set the sort order for content layout and site map files.

See Also

FileItem Class
SandcastleBuilder.Utils Namespace


AlternateText Property

[image]

Sandcastle Help File Builder Documentation
FileItem..::.AlternateText Property
FileItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set alternate text for an image

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string AlternateText { get; set; }
Visual Basic (Declaration)
Public Property AlternateText As String

See Also

FileItem Class
SandcastleBuilder.Utils Namespace


BuildAction Property

[image]

Sandcastle Help File Builder Documentation
FileItem..::.BuildAction Property
FileItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to set or get the build action of the item

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public BuildAction BuildAction { get; set; }
Visual Basic (Declaration)
Public Property BuildAction As BuildAction

See Also

FileItem Class
SandcastleBuilder.Utils Namespace


CopyToMedia Property

[image]

Sandcastle Help File Builder Documentation
FileItem..::.CopyToMedia Property
FileItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set whether an item is copied to the output folder during a build.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool CopyToMedia { get; set; }
Visual Basic (Declaration)
Public Property CopyToMedia As Boolean

Remarks

If this is set to true, the image will always be copied to the build's media folder. If false, it is only copied if referenced in a topic.

See Also

FileItem Class
SandcastleBuilder.Utils Namespace


ExcludeFromToc Property

[image]

Sandcastle Help File Builder Documentation
FileItem..::.ExcludeFromToc Property
FileItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

For content items such as HTML pages, this is used to get or set whether or not the item is excluded from the table of contents.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool ExcludeFromToc { get; set; }
Visual Basic (Declaration)
Public Property ExcludeFromToc As Boolean

Remarks

If true, the item is not included in the table of contents. If false, it will be included.

See Also

FileItem Class
SandcastleBuilder.Utils Namespace


FullPath Property

[image]

Sandcastle Help File Builder Documentation
FileItem..::.FullPath Property
FileItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get the full path to the item

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string FullPath { get; }
Visual Basic (Declaration)
Public ReadOnly Property FullPath As String

See Also

FileItem Class
SandcastleBuilder.Utils Namespace


ImageId Property

[image]

Sandcastle Help File Builder Documentation
FileItem..::.ImageId Property
FileItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set an ID for a conceptual content image

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string ImageId { get; set; }
Visual Basic (Declaration)
Public Property ImageId As String

Remarks

This is used to indicate that an image file is part of the conceptual content. Image items without an ID are not valid and will be ignored.

See Also

FileItem Class
SandcastleBuilder.Utils Namespace


Include Property

[image]

Sandcastle Help File Builder Documentation
FileItem..::.Include Property
FileItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to set or get the filename (include path)

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public FilePath Include { get; set; }
Visual Basic (Declaration)
Public Property Include As FilePath

See Also

FileItem Class
SandcastleBuilder.Utils Namespace


Link Property

[image]

Sandcastle Help File Builder Documentation
FileItem..::.Link Property
FileItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to set or get the link path

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public FilePath Link { get; set; }
Visual Basic (Declaration)
Public Property Link As FilePath

Field Value

If the item has no link path, this returns the Include path.

See Also

FileItem Class
SandcastleBuilder.Utils Namespace


Name Property

[image]

Sandcastle Help File Builder Documentation
FileItem..::.Name Property
FileItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to set or get the name of the item

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String

See Also

FileItem Class
SandcastleBuilder.Utils Namespace


SortOrder Property

[image]

Sandcastle Help File Builder Documentation
FileItem..::.SortOrder Property
FileItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set the sort order for content layout and site map files.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public int SortOrder { get; set; }
Visual Basic (Declaration)
Public Property SortOrder As Integer

See Also

FileItem Class
SandcastleBuilder.Utils Namespace


FileItemCollection Class

[image]

Sandcastle Help File Builder Documentation
FileItemCollection Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This collection class is used to hold build items from a project.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public class FileItemCollection : BindingList<FileItem>
Visual Basic (Declaration)
Public Class FileItemCollection _
    Inherits BindingList(Of FileItem)

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection <(Of <( FileItem >)>)
System.ComponentModel..::.BindingList <(Of <( FileItem >)>)
SandcastleBuilder.Utils..::.FileItemCollection

See Also

FileItemCollection Members
SandcastleBuilder.Utils Namespace


FileItemCollection Members

[image] [image]

Sandcastle Help File Builder Documentation
FileItemCollection Members
FileItemCollection Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FileItemCollection type exposes the following members.

Constructors

Name | Description
FileItemCollection | Constructor

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( FileItem >)>).)
AddNew | Adds a new item to the collection. (Inherited from BindingList <(Of <( FileItem >)>).)
AddNewCore | Adds a new item to the end of the collection. (Inherited from BindingList <(Of <( FileItem >)>).)
ApplySortCore | Sorts the items if overridden in a derived class; otherwise, throws a NotSupportedException. (Inherited from BindingList <(Of <( FileItem >)>).)
CancelNew | Discards a pending new item. (Inherited from BindingList <(Of <( FileItem >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( FileItem >)>).)
ClearItems | Removes all elements from the collection. (Inherited from BindingList <(Of <( FileItem >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( FileItem >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <( FileItem >)>).)
EndNew | Commits a pending new item to the collection. (Inherited from BindingList <(Of <( FileItem >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindCore | Searches for the index of the item that has the specified property descriptor with the specified value, if searching is implemented in a derived class; otherwise, a NotSupportedException. (Inherited from BindingList <(Of <( FileItem >)>).)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( FileItem >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection <(Of <( FileItem >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( FileItem >)>).)
InsertItem | Inserts the specified item in the list at the specified index. (Inherited from BindingList <(Of <( FileItem >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnAddingNew | Raises the AddingNew event. (Inherited from BindingList <(Of <( FileItem >)>).)
OnListChanged | Raises the ListChanged event. (Inherited from BindingList <(Of <( FileItem >)>).)
Refresh | This is used to refresh the collection by loading the image build items from the project.
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( FileItem >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( FileItem >)>).)
RemoveItem | Removes the item at the specified index. (Inherited from BindingList <(Of <( FileItem >)>).)
RemoveSortCore | Removes any sort applied with ApplySortCore(PropertyDescriptor, ListSortDirection) if sorting is implemented in a derived class; otherwise, raises NotSupportedException. (Inherited from BindingList <(Of <( FileItem >)>).)
ResetBindings | Raises a ListChanged event of type Reset. (Inherited from BindingList <(Of <( FileItem >)>).)
ResetItem | Raises a ListChanged event of type ItemChanged for the item at the specified position. (Inherited from BindingList <(Of <( FileItem >)>).)
SetItem | Replaces the item at the specified index with the specified item. (Inherited from BindingList <(Of <( FileItem >)>).)
Sort | This is used to sort the collection
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AllowEdit | Gets or sets a value indicating whether items in the list can be edited. (Inherited from BindingList <(Of <( FileItem >)>).)
AllowNew | Gets or sets a value indicating whether you can add items to the list using the AddNew()()() method. (Inherited from BindingList <(Of <( FileItem >)>).)
AllowRemove | Gets or sets a value indicating whether you can remove items from the collection. (Inherited from BindingList <(Of <( FileItem >)>).)
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( FileItem >)>).)
IsSortedCore | Gets a value indicating whether the list is sorted. (Inherited from BindingList <(Of <( FileItem >)>).)
Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <( FileItem >)>).)
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( FileItem >)>).)
RaiseListChangedEvents | Gets or sets a value indicating whether adding or removing items within the list raises ListChanged events. (Inherited from BindingList <(Of <( FileItem >)>).)
SortDirectionCore | Gets the direction the list is sorted. (Inherited from BindingList <(Of <( FileItem >)>).)
SortPropertyCore | Gets the property descriptor that is used for sorting the list if sorting is implemented in a derived class; otherwise, returns null. (Inherited from BindingList <(Of <( FileItem >)>).)
SupportsChangeNotificationCore | Gets a value indicating whether ListChanged events are enabled. (Inherited from BindingList <(Of <( FileItem >)>).)
SupportsSearchingCore | Gets a value indicating whether the list supports searching. (Inherited from BindingList <(Of <( FileItem >)>).)
SupportsSortingCore | Gets a value indicating whether the list supports sorting. (Inherited from BindingList <(Of <( FileItem >)>).)

Events

Name | Description
AddingNew | Occurs before an item is added to the list. (Inherited from BindingList <(Of <( FileItem >)>).)
ListChanged | Occurs when the list or an item in the list changes. (Inherited from BindingList <(Of <( FileItem >)>).)

See Also

FileItemCollection Class
SandcastleBuilder.Utils Namespace


FileItemCollection Constructor

[image]

Sandcastle Help File Builder Documentation
FileItemCollection Constructor
FileItemCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public FileItemCollection(
    SandcastleProject project,
    BuildAction action
)
Visual Basic (Declaration)
Public Sub New ( _
    project As SandcastleProject, _
    action As BuildAction _
)

Parameters

project
Type: SandcastleBuilder.Utils..::.SandcastleProject
The project file containing the build items
action
Type: SandcastleBuilder.Utils..::.BuildAction
The build action for the items to hold in the collection.

See Also

FileItemCollection Class
SandcastleBuilder.Utils Namespace


FileItemCollection Methods

[image] [image]

Sandcastle Help File Builder Documentation
FileItemCollection Methods
FileItemCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FileItemCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( FileItem >)>).)
AddNew | Adds a new item to the collection. (Inherited from BindingList <(Of <( FileItem >)>).)
AddNewCore | Adds a new item to the end of the collection. (Inherited from BindingList <(Of <( FileItem >)>).)
ApplySortCore | Sorts the items if overridden in a derived class; otherwise, throws a NotSupportedException. (Inherited from BindingList <(Of <( FileItem >)>).)
CancelNew | Discards a pending new item. (Inherited from BindingList <(Of <( FileItem >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( FileItem >)>).)
ClearItems | Removes all elements from the collection. (Inherited from BindingList <(Of <( FileItem >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( FileItem >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <( FileItem >)>).)
EndNew | Commits a pending new item to the collection. (Inherited from BindingList <(Of <( FileItem >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindCore | Searches for the index of the item that has the specified property descriptor with the specified value, if searching is implemented in a derived class; otherwise, a NotSupportedException. (Inherited from BindingList <(Of <( FileItem >)>).)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( FileItem >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection <(Of <( FileItem >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( FileItem >)>).)
InsertItem | Inserts the specified item in the list at the specified index. (Inherited from BindingList <(Of <( FileItem >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnAddingNew | Raises the AddingNew event. (Inherited from BindingList <(Of <( FileItem >)>).)
OnListChanged | Raises the ListChanged event. (Inherited from BindingList <(Of <( FileItem >)>).)
Refresh | This is used to refresh the collection by loading the image build items from the project.
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( FileItem >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( FileItem >)>).)
RemoveItem | Removes the item at the specified index. (Inherited from BindingList <(Of <( FileItem >)>).)
RemoveSortCore | Removes any sort applied with ApplySortCore(PropertyDescriptor, ListSortDirection) if sorting is implemented in a derived class; otherwise, raises NotSupportedException. (Inherited from BindingList <(Of <( FileItem >)>).)
ResetBindings | Raises a ListChanged event of type Reset. (Inherited from BindingList <(Of <( FileItem >)>).)
ResetItem | Raises a ListChanged event of type ItemChanged for the item at the specified position. (Inherited from BindingList <(Of <( FileItem >)>).)
SetItem | Replaces the item at the specified index with the specified item. (Inherited from BindingList <(Of <( FileItem >)>).)
Sort | This is used to sort the collection
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FileItemCollection Class
SandcastleBuilder.Utils Namespace


Refresh Method

[image]

Sandcastle Help File Builder Documentation
FileItemCollection..::.Refresh Method
FileItemCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to refresh the collection by loading the image build items from the project.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public void Refresh()
Visual Basic (Declaration)
Public Sub Refresh

See Also

FileItemCollection Class
SandcastleBuilder.Utils Namespace


Sort Method

[image]

Sandcastle Help File Builder Documentation
FileItemCollection..::.Sort Method
FileItemCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to sort the collection

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public void Sort()
Visual Basic (Declaration)
Public Sub Sort

Remarks

Values are sorted by display title and ID. Comparisons are case-insensitive.

See Also

FileItemCollection Class
SandcastleBuilder.Utils Namespace


FileItemCollection Properties

[image] [image]

Sandcastle Help File Builder Documentation
FileItemCollection Properties
FileItemCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FileItemCollection type exposes the following members.

Properties

Name | Description
AllowEdit | Gets or sets a value indicating whether items in the list can be edited. (Inherited from BindingList <(Of <( FileItem >)>).)
AllowNew | Gets or sets a value indicating whether you can add items to the list using the AddNew()()() method. (Inherited from BindingList <(Of <( FileItem >)>).)
AllowRemove | Gets or sets a value indicating whether you can remove items from the collection. (Inherited from BindingList <(Of <( FileItem >)>).)
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( FileItem >)>).)
IsSortedCore | Gets a value indicating whether the list is sorted. (Inherited from BindingList <(Of <( FileItem >)>).)
Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <( FileItem >)>).)
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( FileItem >)>).)
RaiseListChangedEvents | Gets or sets a value indicating whether adding or removing items within the list raises ListChanged events. (Inherited from BindingList <(Of <( FileItem >)>).)
SortDirectionCore | Gets the direction the list is sorted. (Inherited from BindingList <(Of <( FileItem >)>).)
SortPropertyCore | Gets the property descriptor that is used for sorting the list if sorting is implemented in a derived class; otherwise, returns null. (Inherited from BindingList <(Of <( FileItem >)>).)
SupportsChangeNotificationCore | Gets a value indicating whether ListChanged events are enabled. (Inherited from BindingList <(Of <( FileItem >)>).)
SupportsSearchingCore | Gets a value indicating whether the list supports searching. (Inherited from BindingList <(Of <( FileItem >)>).)
SupportsSortingCore | Gets a value indicating whether the list supports sorting. (Inherited from BindingList <(Of <( FileItem >)>).)

See Also

FileItemCollection Class
SandcastleBuilder.Utils Namespace


FileItemCollection Events

[image] [image]

Sandcastle Help File Builder Documentation
FileItemCollection Events
FileItemCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FileItemCollection type exposes the following members.

Events

Name | Description
AddingNew | Occurs before an item is added to the list. (Inherited from BindingList <(Of <( FileItem >)>).)
ListChanged | Occurs when the list or an item in the list changes. (Inherited from BindingList <(Of <( FileItem >)>).)

See Also

FileItemCollection Class
SandcastleBuilder.Utils Namespace


FilePath Class

[image]

Sandcastle Help File Builder Documentation
FilePath Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This class is used to represent a file path. Support is included for treating the path as fixed or relative and for expanding environment variables in the path name.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
[SerializableAttribute]
public class FilePath : ICloneable
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class FilePath _
    Implements ICloneable

Inheritance Hierarchy

System..::.Object
SandcastleBuilder.Utils..::.FilePath
SandcastleBuilder.Utils..::.FolderPath

See Also

FilePath Members
SandcastleBuilder.Utils Namespace


FilePath Members

[image] [image]

Sandcastle Help File Builder Documentation
FilePath Members
FilePath Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FilePath type exposes the following members.

Constructors

Name | Description
FilePath | Overloaded. There are three overloads for the constructor.

Methods

Name | Description
AbsoluteToRelativePath | This helper method can be used to convert an absolute path to one that is relative to the given base path.
Clone | This returns a clone of the object
Equals | This is overridden to allow proper comparison of file path objects. (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetFullPath | This returns the fully qualified path for the specified path. This version allows wildcards in the filename part if present.
GetHashCode | Get a hash code for the file path object (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnPersistablePathChanged | This raises the PersistablePathChanged event
OnPersistablePathChanging | This raises the PersistablePathChanging event
RelativeToAbsolutePath | This helper method can be used to convert a relative path to an absolute path based on the given base path.
ToString | Convert the file path to a string (Overrides Object..::.ToString()()().)

Operators

Name | Description
Equality | Overload for equal operator.
Implicit | This is used to handle an implicit conversion from a FilePath object to a string.
Inequality | Overload for not equal operator.

Properties

Name | Description
BasePath | This returns the base path for the object
BasePathProvider | This is used to get the base path provider for the object.
Exists | This read-only property can be used to determine whether or not the file path exists.
ExpandedPath | This read-only property is used to display the fully qualified path with environment variable expansions in the designer.
IsFixedPath | This is used to indicate whether or not the path will be treated as a relative or fixed path when converted retrieved via the PersistablePath property.
Path | This is used to get or set the path to use.
PersistablePath | This is used to retrieve the file path in a format suitable for persisting to storage based on the current settings.

Events

Name | Description
PersistablePathChanged | This event is raised when the persistable path changes
PersistablePathChanging | This event is raised when the persistable path is about to be changed.

See Also

FilePath Class
SandcastleBuilder.Utils Namespace


FilePath Constructor

[image] [image]

Sandcastle Help File Builder Documentation
FilePath Constructor
FilePath Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

There are three overloads for the constructor.

Overload List

Name | Description
FilePath(IBasePathProvider) | Default constructor. The file path is undefined.
FilePath(String, IBasePathProvider) | Constructor. Assign the specified path.
FilePath(String, Boolean, IBasePathProvider) | Constructor. Assign the specified path and fixed setting.

See Also

FilePath Class
FilePath Members
SandcastleBuilder.Utils Namespace


FilePath Constructor (IBasePathProvider)

[image]

Sandcastle Help File Builder Documentation
FilePath Constructor (IBasePathProvider)
FilePath Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Default constructor. The file path is undefined.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public FilePath(
    IBasePathProvider provider
)
Visual Basic (Declaration)
Public Sub New ( _
    provider As IBasePathProvider _
)

Parameters

provider
Type: SandcastleBuilder.Utils..::.IBasePathProvider
The base base provider

See Also

FilePath Class
FilePath Overload
SandcastleBuilder.Utils Namespace


FilePath Constructor (String, IBasePathProvider)

[image]

Sandcastle Help File Builder Documentation
FilePath Constructor (String, IBasePathProvider)
FilePath Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor. Assign the specified path.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public FilePath(
    string path,
    IBasePathProvider provider
)
Visual Basic (Declaration)
Public Sub New ( _
    path As String, _
    provider As IBasePathProvider _
)

Parameters

path
Type: System..::.String
A relative or absolute path.
provider
Type: SandcastleBuilder.Utils..::.IBasePathProvider
The base base provider

Remarks

Unless IsFixedPath is set to true, the path is always treated as a relative path.

See Also

FilePath Class
FilePath Overload
SandcastleBuilder.Utils Namespace


FilePath Constructor (String, Boolean, IBasePathProvider)

[image]

Sandcastle Help File Builder Documentation
FilePath Constructor (String, Boolean, IBasePathProvider)
FilePath Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor. Assign the specified path and fixed setting.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public FilePath(
    string path,
    bool isFixed,
    IBasePathProvider provider
)
Visual Basic (Declaration)
Public Sub New ( _
    path As String, _
    isFixed As Boolean, _
    provider As IBasePathProvider _
)

Parameters

path
Type: System..::.String
A relative or absolute path.
isFixed
Type: System..::.Boolean
True to treat the path as fixed, false to treat it as a relative path.
provider
Type: SandcastleBuilder.Utils..::.IBasePathProvider
The base base provider

See Also

FilePath Class
FilePath Overload
SandcastleBuilder.Utils Namespace


FilePath Methods

[image] [image]

Sandcastle Help File Builder Documentation
FilePath Methods
FilePath Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FilePath type exposes the following members.

Methods

Name | Description
AbsoluteToRelativePath | This helper method can be used to convert an absolute path to one that is relative to the given base path.
Clone | This returns a clone of the object
Equals | This is overridden to allow proper comparison of file path objects. (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetFullPath | This returns the fully qualified path for the specified path. This version allows wildcards in the filename part if present.
GetHashCode | Get a hash code for the file path object (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnPersistablePathChanged | This raises the PersistablePathChanged event
OnPersistablePathChanging | This raises the PersistablePathChanging event
RelativeToAbsolutePath | This helper method can be used to convert a relative path to an absolute path based on the given base path.
ToString | Convert the file path to a string (Overrides Object..::.ToString()()().)

Operators

Name | Description
Equality | Overload for equal operator.
Implicit | This is used to handle an implicit conversion from a FilePath object to a string.
Inequality | Overload for not equal operator.

See Also

FilePath Class
SandcastleBuilder.Utils Namespace


AbsoluteToRelativePath Method

[image]

Sandcastle Help File Builder Documentation
FilePath..::.AbsoluteToRelativePath Method
FilePath Class Example See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This helper method can be used to convert an absolute path to one that is relative to the given base path.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public static string AbsoluteToRelativePath(
    string basePath,
    string absolutePath
)
Visual Basic (Declaration)
Public Shared Function AbsoluteToRelativePath ( _
    basePath As String, _
    absolutePath As String _
) As String

Parameters

basePath
Type: System..::.String
The base path
absolutePath
Type: System..::.String
An absolute path

Return Value

A path to the given absolute path that is relative to the given base path.

Remarks

If the base path is null or empty, the current working folder is used.

Examples

CopyC#
string basePath = @"E:\DotNet\CS\TestProject\Source";
string absolutePath = @"E:\DotNet\CS\TestProject\Doc\Help.html";

string relativePath = FilePath.AbsoluteToRelativePath(basePath,
    absolutePath);

Console.WriteLine(relativePath);

// Results in: ..\Doc\Help.html
CopyVB.NET
Dim basePath As String = "E:\DotNet\CS\TestProject\Source"
Dim absolutePath As String = "E:\DotNet\CS\TestProject\Doc\Help.html"

Dim relativePath As String = _
    FilePath.AbsoluteToRelativePath(basePath, absolutePath);

Console.WriteLine(relativePath)

' Results in: ..\Doc\Help.html

See Also

FilePath Class
SandcastleBuilder.Utils Namespace


Clone Method

[image]

Sandcastle Help File Builder Documentation
FilePath..::.Clone Method
FilePath Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This returns a clone of the object

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public Object Clone()
Visual Basic (Declaration)
Public Function Clone As Object

Return Value

A clone of the object

Implements

ICloneable..::.Clone()()()

See Also

FilePath Class
SandcastleBuilder.Utils Namespace


Equality Operator

[image]

Sandcastle Help File Builder Documentation
FilePath..::.Equality Operator
FilePath Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload for equal operator.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public static bool operator ==(
    FilePath firstPath,
    FilePath secondPath
)
Visual Basic (Declaration)
Public Shared Operator = ( _
    firstPath As FilePath, _
    secondPath As FilePath _
) As Boolean

Parameters

firstPath
Type: SandcastleBuilder.Utils..::.FilePath
The first object to compare
secondPath
Type: SandcastleBuilder.Utils..::.FilePath
The second object to compare

Return Value

True if equal, false if not.

See Also

FilePath Class
SandcastleBuilder.Utils Namespace


Equals Method

[image]

Sandcastle Help File Builder Documentation
FilePath..::.Equals Method
FilePath Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is overridden to allow proper comparison of file path objects.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::.Object
The object to which this instance is compared.

Return Value

Returns true if the object equals this instance, false if it does not.

See Also

FilePath Class
SandcastleBuilder.Utils Namespace


GetFullPath Method

[image]

Sandcastle Help File Builder Documentation
FilePath..::.GetFullPath Method
FilePath Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This returns the fully qualified path for the specified path. This version allows wildcards in the filename part if present.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public static string GetFullPath(
    string path
)
Visual Basic (Declaration)
Public Shared Function GetFullPath ( _
    path As String _
) As String

Parameters

path
Type: System..::.String
The path to expand

Return Value

The fully qualified path name

Remarks

The System.IO.Path version of GetFullPath(String) will throw an exception if the path contains wildcard characters. This version does not.

See Also

FilePath Class
SandcastleBuilder.Utils Namespace


GetHashCode Method

[image]

Sandcastle Help File Builder Documentation
FilePath..::.GetHashCode Method
FilePath Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Get a hash code for the file path object

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer

Return Value

Returns the hash code of the ToString()()() value converted to lowercase.

See Also

FilePath Class
SandcastleBuilder.Utils Namespace


Implicit Operator

[image]

Sandcastle Help File Builder Documentation
FilePath..::.Implicit Operator
FilePath Class Example See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to handle an implicit conversion from a FilePath object to a string.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public static implicit operator string (
    FilePath filePath
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    filePath As FilePath _
) As String

Parameters

filePath
Type: SandcastleBuilder.Utils..::.FilePath
The FilePath to convert.

Return Value

The file path as a relative or absolute path string based on its current settings.

Examples

CopyC#
FilePath filePath = new FilePath(@"%APPDATA%\TestApp\App.config");

// The FilePath object is automatically converted to a string
// representing the expanded, fully qualified path.
string pathString = filePath;
CopyVB.NET
Dim filePath As New FilePath("%APPDATA%\TestApp\App.config")

' The FilePath object is automatically converted to a string
' representing the expanded, fully qualified path.
Dim pathString As String = filePath

See Also

FilePath Class
SandcastleBuilder.Utils Namespace


Inequality Operator

[image]

Sandcastle Help File Builder Documentation
FilePath..::.Inequality Operator
FilePath Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload for not equal operator.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public static bool operator !=(
    FilePath firstPath,
    FilePath secondPath
)
Visual Basic (Declaration)
Public Shared Operator <> ( _
    firstPath As FilePath, _
    secondPath As FilePath _
) As Boolean

Parameters

firstPath
Type: SandcastleBuilder.Utils..::.FilePath
The first object to compare
secondPath
Type: SandcastleBuilder.Utils..::.FilePath
The second object to compare

Return Value

True if not equal, false if they are.

See Also

FilePath Class
SandcastleBuilder.Utils Namespace


OnPersistablePathChanged Method

[image]

Sandcastle Help File Builder Documentation
FilePath..::.OnPersistablePathChanged Method
FilePath Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This raises the PersistablePathChanged event

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected void OnPersistablePathChanged(
    EventArgs e
)
Visual Basic (Declaration)
Protected Sub OnPersistablePathChanged ( _
    e As EventArgs _
)

Parameters

e
Type: System..::.EventArgs
The event arguments

See Also

FilePath Class
SandcastleBuilder.Utils Namespace


OnPersistablePathChanging Method

[image]

Sandcastle Help File Builder Documentation
FilePath..::.OnPersistablePathChanging Method
FilePath Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This raises the PersistablePathChanging event

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected void OnPersistablePathChanging(
    EventArgs e
)
Visual Basic (Declaration)
Protected Sub OnPersistablePathChanging ( _
    e As EventArgs _
)

Parameters

e
Type: System..::.EventArgs
The event arguments

See Also

FilePath Class
SandcastleBuilder.Utils Namespace


RelativeToAbsolutePath Method

[image]

Sandcastle Help File Builder Documentation
FilePath..::.RelativeToAbsolutePath Method
FilePath Class Example See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This helper method can be used to convert a relative path to an absolute path based on the given base path.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public static string RelativeToAbsolutePath(
    string basePath,
    string relativePath
)
Visual Basic (Declaration)
Public Shared Function RelativeToAbsolutePath ( _
    basePath As String, _
    relativePath As String _
) As String

Parameters

basePath
Type: System..::.String
The base path
relativePath
Type: System..::.String
A relative path

Return Value

An absolute path

Remarks

If the base path is null or empty, the current working folder is used.

Examples

CopyC#
string basePath = @"E:\DotNet\CS\TestProject\Source";
string relativePath = @"..\Doc\Help.html";

string absolutePath = FilePath.RelativeToAbsolutePath(basePath,
    relativePath);

Console.WriteLine(absolutePath);

// Results in: E:\DotNet\CS\TestProject\Doc\Help.html
CopyVB.NET
Dim basePath As String = "E:\DotNet\CS\TestProject\Source"
Dim relativePath As String = "..\Doc\Help.html"

Dim absolutePath As String = _
    FilePath.RelativeToAbsolutePath(basePath, relativePath);

Console.WriteLine(absolutePath)

' Results in: E:\DotNet\CS\TestProject\Doc\Help.html

See Also

FilePath Class
SandcastleBuilder.Utils Namespace


ToString Method

[image]

Sandcastle Help File Builder Documentation
FilePath..::.ToString Method
FilePath Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Convert the file path to a string

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

Return Value

A fixed or relative path based on the current settings.

See Also

FilePath Class
SandcastleBuilder.Utils Namespace


FilePath Properties

[image] [image]

Sandcastle Help File Builder Documentation
FilePath Properties
FilePath Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FilePath type exposes the following members.

Properties

Name | Description
BasePath | This returns the base path for the object
BasePathProvider | This is used to get the base path provider for the object.
Exists | This read-only property can be used to determine whether or not the file path exists.
ExpandedPath | This read-only property is used to display the fully qualified path with environment variable expansions in the designer.
IsFixedPath | This is used to indicate whether or not the path will be treated as a relative or fixed path when converted retrieved via the PersistablePath property.
Path | This is used to get or set the path to use.
PersistablePath | This is used to retrieve the file path in a format suitable for persisting to storage based on the current settings.

See Also

FilePath Class
SandcastleBuilder.Utils Namespace


BasePath Property

[image]

Sandcastle Help File Builder Documentation
FilePath..::.BasePath Property
FilePath Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This returns the base path for the object

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string BasePath { get; }
Visual Basic (Declaration)
Public ReadOnly Property BasePath As String

Field Value

If no IBasePathProvider has been specified, this returns the current directory.

See Also

FilePath Class
SandcastleBuilder.Utils Namespace


BasePathProvider Property

[image]

Sandcastle Help File Builder Documentation
FilePath..::.BasePathProvider Property
FilePath Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get the base path provider for the object.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public IBasePathProvider BasePathProvider { get; }
Visual Basic (Declaration)
Public ReadOnly Property BasePathProvider As IBasePathProvider

See Also

FilePath Class
SandcastleBuilder.Utils Namespace


Exists Property

[image]

Sandcastle Help File Builder Documentation
FilePath..::.Exists Property
FilePath Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property can be used to determine whether or not the file path exists.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public virtual bool Exists { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Exists As Boolean

See Also

FilePath Class
SandcastleBuilder.Utils Namespace


ExpandedPath Property

[image]

Sandcastle Help File Builder Documentation
FilePath..::.ExpandedPath Property
FilePath Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property is used to display the fully qualified path with environment variable expansions in the designer.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string ExpandedPath { get; }
Visual Basic (Declaration)
Public ReadOnly Property ExpandedPath As String

See Also

FilePath Class
SandcastleBuilder.Utils Namespace


IsFixedPath Property

[image]

Sandcastle Help File Builder Documentation
FilePath..::.IsFixedPath Property
FilePath Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to indicate whether or not the path will be treated as a relative or fixed path when converted retrieved via the PersistablePath property.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool IsFixedPath { get; set; }
Visual Basic (Declaration)
Public Property IsFixedPath As Boolean

Field Value

If true, the path is returned as a fixed path when retrieved. If false, it is returned as a path relative to the current value of the BasePath property.

See Also

FilePath Class
SandcastleBuilder.Utils Namespace


Path Property

[image]

Sandcastle Help File Builder Documentation
FilePath..::.Path Property
FilePath Class Example See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set the path to use.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public virtual string Path { get; set; }
Visual Basic (Declaration)
Public Overridable Property Path As String

Field Value

When set, if the path is not rooted (a relative path), IsFixedPath is set to false. If rooted (an absolute path), it is not changed. This property always returns a fully qualified path but without any environment variable expansions.

If set to a null or empty string, the file path is cleared and is considered to be undefined.

Examples

CopyC#
FilePath path = new FilePath();

// Set it to a relative path
path.Path = @"..\..\Test.txt";

// Set it to an absolute path
path.Path = @"C:\My Documents\Info.doc";

// Set it to a path based on an environment variable
path.Path = @"%HOMEDRIVE%%HOMEPATH%\Favorites\*.*";
CopyVB.NET
Dim path As New FilePath()

' Set it to a relative path
path.Path = "..\..\Test.txt"

' Set it to an absolute path
path.Path = "C:\My Documents\Info.doc"

' Set it to a path based on an environment variable
path.Path = "%HOMEDRIVE%%HOMEPATH%\Favorites\*.*"

See Also

FilePath Class
SandcastleBuilder.Utils Namespace


PersistablePath Property

[image]

Sandcastle Help File Builder Documentation
FilePath..::.PersistablePath Property
FilePath Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to retrieve the file path in a format suitable for persisting to storage based on the current settings.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public virtual string PersistablePath { get; set; }
Visual Basic (Declaration)
Public Overridable Property PersistablePath As String

Remarks

If IsFixedPath is true, an absolute path is always returned. If false, the path is returned in a form that is relative to the path stored in the BasePath property.

See Also

FilePath Class
SandcastleBuilder.Utils Namespace


FilePath Events

[image] [image]

Sandcastle Help File Builder Documentation
FilePath Events
FilePath Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FilePath type exposes the following members.

Events

Name | Description
PersistablePathChanged | This event is raised when the persistable path changes
PersistablePathChanging | This event is raised when the persistable path is about to be changed.

See Also

FilePath Class
SandcastleBuilder.Utils Namespace


PersistablePathChanged Event

[image]

Sandcastle Help File Builder Documentation
FilePath..::.PersistablePathChanged Event
FilePath Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This event is raised when the persistable path changes

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public event EventHandler PersistablePathChanged
Visual Basic (Declaration)
Public Event PersistablePathChanged As EventHandler

See Also

FilePath Class
SandcastleBuilder.Utils Namespace


PersistablePathChanging Event

[image]

Sandcastle Help File Builder Documentation
FilePath..::.PersistablePathChanging Event
FilePath Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This event is raised when the persistable path is about to be changed.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public event EventHandler PersistablePathChanging
Visual Basic (Declaration)
Public Event PersistablePathChanging As EventHandler

See Also

FilePath Class
SandcastleBuilder.Utils Namespace


FolderPath Class

[image]

Sandcastle Help File Builder Documentation
FolderPath Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This class is used to represent a folder path. Support is included for treating the path as fixed or relative and for expanding environment variables in the path name.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
[SerializableAttribute]
public class FolderPath : FilePath
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class FolderPath _
    Inherits FilePath

Inheritance Hierarchy

System..::.Object
SandcastleBuilder.Utils..::.FilePath
SandcastleBuilder.Utils..::.FolderPath

See Also

FolderPath Members
SandcastleBuilder.Utils Namespace


FolderPath Members

[image] [image]

Sandcastle Help File Builder Documentation
FolderPath Members
FolderPath Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FolderPath type exposes the following members.

Constructors

Name | Description
FolderPath | Overloaded. There are three overloads for the constructor.

Methods

Name | Description
Clone | This returns a clone of the object (Inherited from FilePath.)
Equals | This is overridden to allow proper comparison of file path objects. (Inherited from FilePath.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Get a hash code for the file path object (Inherited from FilePath.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsPathTerminated | This can be used to find out if a path is terminated with a trailing backslash.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnPersistablePathChanged | This raises the PersistablePathChanged event (Inherited from FilePath.)
OnPersistablePathChanging | This raises the PersistablePathChanging event (Inherited from FilePath.)
TerminatePath | This can be used to ensure that a path is terminated with a trailing backslash.
ToString | Convert the file path to a string (Inherited from FilePath.)

Properties

Name | Description
BasePath | This returns the base path for the object (Inherited from FilePath.)
BasePathProvider | This is used to get the base path provider for the object. (Inherited from FilePath.)
Exists | This read-only property can be used to determine whether or not the folder path exists. (Overrides FilePath..::.Exists.)
ExpandedPath | This read-only property is used to display the fully qualified path with environment variable expansions in the designer. (Inherited from FilePath.)
IsFixedPath | This is used to indicate whether or not the path will be treated as a relative or fixed path when converted retrieved via the PersistablePath property. (Inherited from FilePath.)
Path | This is used to get or set the path. (Overrides FilePath..::.Path.)
PersistablePath | This is used to retrieve the file path in a format suitable for persisting to storage based on the current settings. (Inherited from FilePath.)

Events

Name | Description
PersistablePathChanged | This event is raised when the persistable path changes (Inherited from FilePath.)
PersistablePathChanging | This event is raised when the persistable path is about to be changed. (Inherited from FilePath.)

See Also

FolderPath Class
SandcastleBuilder.Utils Namespace


FolderPath Constructor

[image] [image]

Sandcastle Help File Builder Documentation
FolderPath Constructor
FolderPath Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

There are three overloads for the constructor.

Overload List

Name | Description
FolderPath(IBasePathProvider) | Default constructor. The folder path is undefined.
FolderPath(String, IBasePathProvider) | Constructor. Assign the specified path.
FolderPath(String, Boolean, IBasePathProvider) | Constructor. Assign the specified path and fixed setting.

See Also

FolderPath Class
FolderPath Members
SandcastleBuilder.Utils Namespace


FolderPath Constructor (IBasePathProvider)

[image]

Sandcastle Help File Builder Documentation
FolderPath Constructor (IBasePathProvider)
FolderPath Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Default constructor. The folder path is undefined.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public FolderPath(
    IBasePathProvider provider
)
Visual Basic (Declaration)
Public Sub New ( _
    provider As IBasePathProvider _
)

Parameters

provider
Type: SandcastleBuilder.Utils..::.IBasePathProvider
The base path provider

See Also

FolderPath Class
FolderPath Overload
SandcastleBuilder.Utils Namespace


FolderPath Constructor (String, IBasePathProvider)

[image]

Sandcastle Help File Builder Documentation
FolderPath Constructor (String, IBasePathProvider)
FolderPath Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor. Assign the specified path.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public FolderPath(
    string path,
    IBasePathProvider provider
)
Visual Basic (Declaration)
Public Sub New ( _
    path As String, _
    provider As IBasePathProvider _
)

Parameters

path
Type: System..::.String
A relative or absolute path.
provider
Type: SandcastleBuilder.Utils..::.IBasePathProvider
The base path provider

Remarks

Unless IsFixedPath is set to true, the path is always treated as a relative path.

See Also

FolderPath Class
FolderPath Overload
SandcastleBuilder.Utils Namespace


FolderPath Constructor (String, Boolean, IBasePathProvider)

[image]

Sandcastle Help File Builder Documentation
FolderPath Constructor (String, Boolean, IBasePathProvider)
FolderPath Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor. Assign the specified path and fixed setting.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public FolderPath(
    string path,
    bool isFixed,
    IBasePathProvider provider
)
Visual Basic (Declaration)
Public Sub New ( _
    path As String, _
    isFixed As Boolean, _
    provider As IBasePathProvider _
)

Parameters

path
Type: System..::.String
A relative or absolute path.
isFixed
Type: System..::.Boolean
True to treat the path as fixed, false to treat it as a relative path.
provider
Type: SandcastleBuilder.Utils..::.IBasePathProvider
The base path provider

See Also

FolderPath Class
FolderPath Overload
SandcastleBuilder.Utils Namespace


FolderPath Methods

[image] [image]

Sandcastle Help File Builder Documentation
FolderPath Methods
FolderPath Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FolderPath type exposes the following members.

Methods

Name | Description
Clone | This returns a clone of the object (Inherited from FilePath.)
Equals | This is overridden to allow proper comparison of file path objects. (Inherited from FilePath.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Get a hash code for the file path object (Inherited from FilePath.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsPathTerminated | This can be used to find out if a path is terminated with a trailing backslash.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnPersistablePathChanged | This raises the PersistablePathChanged event (Inherited from FilePath.)
OnPersistablePathChanging | This raises the PersistablePathChanging event (Inherited from FilePath.)
TerminatePath | This can be used to ensure that a path is terminated with a trailing backslash.
ToString | Convert the file path to a string (Inherited from FilePath.)

See Also

FolderPath Class
SandcastleBuilder.Utils Namespace


IsPathTerminated Method

[image]

Sandcastle Help File Builder Documentation
FolderPath..::.IsPathTerminated Method
FolderPath Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This can be used to find out if a path is terminated with a trailing backslash.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public static bool IsPathTerminated(
    string path
)
Visual Basic (Declaration)
Public Shared Function IsPathTerminated ( _
    path As String _
) As Boolean

Parameters

path
Type: System..::.String
The path to check

Return Value

Returns true if it is, false if it is not.

See Also

FolderPath Class
SandcastleBuilder.Utils Namespace


TerminatePath Method

[image]

Sandcastle Help File Builder Documentation
FolderPath..::.TerminatePath Method
FolderPath Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This can be used to ensure that a path is terminated with a trailing backslash.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public static string TerminatePath(
    string path
)
Visual Basic (Declaration)
Public Shared Function TerminatePath ( _
    path As String _
) As String

Parameters

path
Type: System..::.String
The path to check

Return Value

The path with a trailing backslash added if necessary.

See Also

FolderPath Class
SandcastleBuilder.Utils Namespace


FolderPath Properties

[image] [image]

Sandcastle Help File Builder Documentation
FolderPath Properties
FolderPath Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FolderPath type exposes the following members.

Properties

Name | Description
BasePath | This returns the base path for the object (Inherited from FilePath.)
BasePathProvider | This is used to get the base path provider for the object. (Inherited from FilePath.)
Exists | This read-only property can be used to determine whether or not the folder path exists. (Overrides FilePath..::.Exists.)
ExpandedPath | This read-only property is used to display the fully qualified path with environment variable expansions in the designer. (Inherited from FilePath.)
IsFixedPath | This is used to indicate whether or not the path will be treated as a relative or fixed path when converted retrieved via the PersistablePath property. (Inherited from FilePath.)
Path | This is used to get or set the path. (Overrides FilePath..::.Path.)
PersistablePath | This is used to retrieve the file path in a format suitable for persisting to storage based on the current settings. (Inherited from FilePath.)

See Also

FolderPath Class
SandcastleBuilder.Utils Namespace


Exists Property

[image]

Sandcastle Help File Builder Documentation
FolderPath..::.Exists Property
FolderPath Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property can be used to determine whether or not the folder path exists.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public override bool Exists { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Exists As Boolean

See Also

FolderPath Class
SandcastleBuilder.Utils Namespace


Path Property

[image]

Sandcastle Help File Builder Documentation
FolderPath..::.Path Property
FolderPath Class Example See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set the path.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public override string Path { get; set; }
Visual Basic (Declaration)
Public Overrides Property Path As String

Field Value

When set, if the path is not rooted (a relative path), IsFixedPath is set to false. If rooted (an absolute path), it is not changed. This property always returns a fully qualified path but without any environment variable expansions and terminated with a trailing backslash if needed.

If set to a null or empty string, the folder path is cleared and is considered to be undefined.

Examples

CopyC#
FolderPath path = new FolderPath();

// Set it to a relative path
path.Path = @"..\..\ProjectFolder";

// Set it to an absolute path
path.Path = @"C:\My Documents\ProjectDocs\";

// Set it to a path based on an environment variable
path.Path = @"%HOMEDRIVE%%HOMEPATH%\Favorites\";
CopyVB.NET
Dim path As New FilePath()

' Set it to a relative path
path.Path = "..\..\ProjectFolder"

' Set it to an absolute path
path.Path = "C:\My Documents\ProjectDocs\"

' Set it to a path based on an environment variable
path.Path = "%HOMEDRIVE%%HOMEPATH%\Favorites\"

See Also

FolderPath Class
SandcastleBuilder.Utils Namespace


FolderPath Events

[image] [image]

Sandcastle Help File Builder Documentation
FolderPath Events
FolderPath Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FolderPath type exposes the following members.

Events

Name | Description
PersistablePathChanged | This event is raised when the persistable path changes (Inherited from FilePath.)
PersistablePathChanging | This event is raised when the persistable path is about to be changed. (Inherited from FilePath.)

See Also

FolderPath Class
SandcastleBuilder.Utils Namespace


HelpFileFormat Enumeration

[image]

Sandcastle Help File Builder Documentation
HelpFileFormat Enumeration
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This public enumerated type defines the type(s) of help file generated

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
[SerializableAttribute]
[FlagsAttribute]
public enum HelpFileFormat
Visual Basic (Declaration)
<SerializableAttribute> _
<FlagsAttribute> _
Public Enumeration HelpFileFormat

Members

Member name | Description
HtmlHelp1x | HTML Help 1.x format built with HHC.EXE
HtmlHelp2x | HTML Help 2.x format built with HXCOMP.EXE
Website | A website with basic frame set viewer page
Help1xAndHelp2x | An HTML Help 1.x and an HTML Help 2.x file
Help1xAndWebsite | An HTML Help 1.x file and website
Help2xAndWebsite | An HTML Help 2.x file and website
Help1xAnd2xAndWebsite | An HTML Help 1.x file, HTML Help 2.x file, and a website

See Also

SandcastleBuilder.Utils Namespace


IBasePathProvider Interface

[image]

Sandcastle Help File Builder Documentation
IBasePathProvider Interface
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This interface defines the properties used to obtain a base path for a FilePath object.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public interface IBasePathProvider
Visual Basic (Declaration)
Public Interface IBasePathProvider

See Also

IBasePathProvider Members
SandcastleBuilder.Utils Namespace


IBasePathProvider Members

[image] [image]

Sandcastle Help File Builder Documentation
IBasePathProvider Members
IBasePathProvider Interface Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IBasePathProvider type exposes the following members.

Properties

Name | Description
BasePath | This read-only property returns the base path

See Also

IBasePathProvider Interface
SandcastleBuilder.Utils Namespace


IBasePathProvider Properties

[image] [image]

Sandcastle Help File Builder Documentation
IBasePathProvider Properties
IBasePathProvider Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IBasePathProvider type exposes the following members.

Properties

Name | Description
BasePath | This read-only property returns the base path

See Also

IBasePathProvider Interface
SandcastleBuilder.Utils Namespace


BasePath Property

[image]

Sandcastle Help File Builder Documentation
IBasePathProvider..::.BasePath Property
IBasePathProvider Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns the base path

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
string BasePath { get; }
Visual Basic (Declaration)
ReadOnly Property BasePath As String

See Also

IBasePathProvider Interface
SandcastleBuilder.Utils Namespace


MissingTags Enumeration

[image]

Sandcastle Help File Builder Documentation
MissingTags Enumeration
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This public enumerated type defines the missing documentation tags for which to search.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
[SerializableAttribute]
[FlagsAttribute]
public enum MissingTags
Visual Basic (Declaration)
<SerializableAttribute> _
<FlagsAttribute> _
Public Enumeration MissingTags

Members

Member name | Description
None | Do not search for any missing tags.
Summary | Search for missing <summary> tags.
Parameter | Search for missing <param> tags.
Returns | Search for missing <returns> tags.
Value | Search for missing <value> tags.
Remarks | Search for missing <remarks> tags.
AutoDocumentCtors | Automatically document constructors if they are missing a <summary> tag.
Namespace | Search for missing namespace comments.
TypeParameter | Search for missing <typeparam> tags.
IncludeTargets | Search for missing <include> target documentation.

See Also

SandcastleBuilder.Utils Namespace


MSHelpAttr Class

[image]

Sandcastle Help File Builder Documentation
MSHelpAttr Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This represents an HTML Help 2.x attribute that can be added to the XML data island in each help topic generated by BuildAssembler.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
[SerializableAttribute]
public class MSHelpAttr : PropertyBasedCollectionItem, IComparable<MSHelpAttr>
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class MSHelpAttr _
    Inherits PropertyBasedCollectionItem _
    Implements IComparable(Of MSHelpAttr)

Inheritance Hierarchy

System..::.Object
SandcastleBuilder.Utils..::.PropertyBasedCollectionItem
SandcastleBuilder.Utils..::.MSHelpAttr

See Also

MSHelpAttr Members
SandcastleBuilder.Utils Namespace


MSHelpAttr Members

[image] [image]

Sandcastle Help File Builder Documentation
MSHelpAttr Members
MSHelpAttr Class Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The MSHelpAttr type exposes the following members.

Methods

Name | Description
CheckProjectIsEditable | This is used to see if the project can be edited. If not, abort the change by throwing an exception. (Inherited from PropertyBasedCollectionItem.)
CompareTo | Compares this instance to another instance and returns an indication of their relative values.
Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Get a hash code for this item (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Return a string representation of the item (Overrides Object..::.ToString()()().)

Properties

Name | Description
AttributeName | This is used to get or set the attribute name
AttributeValue | This is used to get or set the attribute value
IsDirty | This is used to get or set the dirty state of the item (Inherited from PropertyBasedCollectionItem.)
ProjectFile | This is used to get the owning project file (Inherited from PropertyBasedCollectionItem.)

See Also

MSHelpAttr Class
SandcastleBuilder.Utils Namespace


MSHelpAttr Methods

[image] [image]

Sandcastle Help File Builder Documentation
MSHelpAttr Methods
MSHelpAttr Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The MSHelpAttr type exposes the following members.

Methods

Name | Description
CheckProjectIsEditable | This is used to see if the project can be edited. If not, abort the change by throwing an exception. (Inherited from PropertyBasedCollectionItem.)
CompareTo | Compares this instance to another instance and returns an indication of their relative values.
Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Get a hash code for this item (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Return a string representation of the item (Overrides Object..::.ToString()()().)

See Also

MSHelpAttr Class
SandcastleBuilder.Utils Namespace


CompareTo Method

[image]

Sandcastle Help File Builder Documentation
MSHelpAttr..::.CompareTo Method
MSHelpAttr Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Compares this instance to another instance and returns an indication of their relative values.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public int CompareTo(
    MSHelpAttr other
)
Visual Basic (Declaration)
Public Function CompareTo ( _
    other As MSHelpAttr _
) As Integer

Parameters

other
Type: SandcastleBuilder.Utils..::.MSHelpAttr
A MSHelpAttr object to compare

Return Value

Returns -1 if this instance is less than the value, 0 if they are equal, or 1 if this instance is greater than the value or the value is null.

Implements

IComparable<(Of <(T>)>)..::.CompareTo(T)

Remarks

Entries are sorted by name and then value

See Also

MSHelpAttr Class
SandcastleBuilder.Utils Namespace


Equals Method

[image]

Sandcastle Help File Builder Documentation
MSHelpAttr..::.Equals Method
MSHelpAttr Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Determines whether the specified Object is equal to the current Object.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::.Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Exceptions

Exception | Condition
System..::.NullReferenceException | The obj parameter is null.

See Also

MSHelpAttr Class
SandcastleBuilder.Utils Namespace


GetHashCode Method

[image]

Sandcastle Help File Builder Documentation
MSHelpAttr..::.GetHashCode Method
MSHelpAttr Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Get a hash code for this item

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer

Return Value

Returns the hash code for the attribute name and value.

See Also

MSHelpAttr Class
SandcastleBuilder.Utils Namespace


ToString Method

[image]

Sandcastle Help File Builder Documentation
MSHelpAttr..::.ToString Method
MSHelpAttr Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Return a string representation of the item

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

Return Value

Returns the item in its XML format

See Also

MSHelpAttr Class
SandcastleBuilder.Utils Namespace


MSHelpAttr Properties

[image] [image]

Sandcastle Help File Builder Documentation
MSHelpAttr Properties
MSHelpAttr Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The MSHelpAttr type exposes the following members.

Properties

Name | Description
AttributeName | This is used to get or set the attribute name
AttributeValue | This is used to get or set the attribute value
IsDirty | This is used to get or set the dirty state of the item (Inherited from PropertyBasedCollectionItem.)
ProjectFile | This is used to get the owning project file (Inherited from PropertyBasedCollectionItem.)

See Also

MSHelpAttr Class
SandcastleBuilder.Utils Namespace


AttributeName Property

[image]

Sandcastle Help File Builder Documentation
MSHelpAttr..::.AttributeName Property
MSHelpAttr Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set the attribute name

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string AttributeName { get; set; }
Visual Basic (Declaration)
Public Property AttributeName As String

See Also

MSHelpAttr Class
SandcastleBuilder.Utils Namespace


AttributeValue Property

[image]

Sandcastle Help File Builder Documentation
MSHelpAttr..::.AttributeValue Property
MSHelpAttr Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set the attribute value

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string AttributeValue { get; set; }
Visual Basic (Declaration)
Public Property AttributeValue As String

See Also

MSHelpAttr Class
SandcastleBuilder.Utils Namespace


MSHelpAttrCollection Class

[image]

Sandcastle Help File Builder Documentation
MSHelpAttrCollection Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This collection class is used to hold the help attribute items for a project.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public class MSHelpAttrCollection : BindingList<MSHelpAttr>
Visual Basic (Declaration)
Public Class MSHelpAttrCollection _
    Inherits BindingList(Of MSHelpAttr)

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection <(Of <( MSHelpAttr >)>)
System.ComponentModel..::.BindingList <(Of <( MSHelpAttr >)>)
SandcastleBuilder.Utils..::.MSHelpAttrCollection

See Also

MSHelpAttrCollection Members
SandcastleBuilder.Utils Namespace


MSHelpAttrCollection Members

[image] [image]

Sandcastle Help File Builder Documentation
MSHelpAttrCollection Members
MSHelpAttrCollection Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The MSHelpAttrCollection type exposes the following members.

Constructors

Name | Description
MSHelpAttrCollection | Constructor

Methods

Name | Description
Add | Overloaded.
AddNew | Adds a new item to the collection. (Inherited from BindingList <(Of <( MSHelpAttr >)>).)
AddNewCore | Adds a new item to the end of the collection. (Inherited from BindingList <(Of <( MSHelpAttr >)>).)
ApplySortCore | Sorts the items if overridden in a derived class; otherwise, throws a NotSupportedException. (Inherited from BindingList <(Of <( MSHelpAttr >)>).)
CancelNew | Discards a pending new item. (Inherited from BindingList <(Of <( MSHelpAttr >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( MSHelpAttr >)>).)
ClearItems | Removes all elements from the collection. (Inherited from BindingList <(Of <( MSHelpAttr >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( MSHelpAttr >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <( MSHelpAttr >)>).)
EndNew | Commits a pending new item to the collection. (Inherited from BindingList <(Of <( MSHelpAttr >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindCore | Searches for the index of the item that has the specified property descriptor with the specified value, if searching is implemented in a derived class; otherwise, a NotSupportedException. (Inherited from BindingList <(Of <( MSHelpAttr >)>).)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( MSHelpAttr >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection <(Of <( MSHelpAttr >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( MSHelpAttr >)>).)
InsertItem | Inserts the specified item in the list at the specified index. (Inherited from BindingList <(Of <( MSHelpAttr >)>).)
MarkAsDirty | This is used to mark the collection as changed when there is no associated project.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnAddingNew | Raises the AddingNew event. (Inherited from BindingList <(Of <( MSHelpAttr >)>).)
OnListChanged | This is overridden to mark the collection as dirty when it changes (Overrides BindingList<(Of <(T>)>)..::.OnListChanged(ListChangedEventArgs).)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( MSHelpAttr >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( MSHelpAttr >)>).)
RemoveItem | Removes the item at the specified index. (Inherited from BindingList <(Of <( MSHelpAttr >)>).)
RemoveSortCore | Removes any sort applied with ApplySortCore(PropertyDescriptor, ListSortDirection) if sorting is implemented in a derived class; otherwise, raises NotSupportedException. (Inherited from BindingList <(Of <( MSHelpAttr >)>).)
ResetBindings | Raises a ListChanged event of type Reset. (Inherited from BindingList <(Of <( MSHelpAttr >)>).)
ResetItem | Raises a ListChanged event of type ItemChanged for the item at the specified position. (Inherited from BindingList <(Of <( MSHelpAttr >)>).)
SetItem | Replaces the item at the specified index with the specified item. (Inherited from BindingList <(Of <( MSHelpAttr >)>).)
Sort | This is used to sort the collection
ToConfigurationString | Convert the collection to its string form for use in the sandcastle.config file.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteXml | Write the collection to the given XML text writer

Properties

Name | Description
AllowEdit | Gets or sets a value indicating whether items in the list can be edited. (Inherited from BindingList <(Of <( MSHelpAttr >)>).)
AllowNew | Gets or sets a value indicating whether you can add items to the list using the AddNew()()() method. (Inherited from BindingList <(Of <( MSHelpAttr >)>).)
AllowRemove | Gets or sets a value indicating whether you can remove items from the collection. (Inherited from BindingList <(Of <( MSHelpAttr >)>).)
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( MSHelpAttr >)>).)
IsDirty | This is used to get or set the dirty state of the collection
IsSortedCore | Gets a value indicating whether the list is sorted. (Inherited from BindingList <(Of <( MSHelpAttr >)>).)
Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <( MSHelpAttr >)>).)
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( MSHelpAttr >)>).)
RaiseListChangedEvents | Gets or sets a value indicating whether adding or removing items within the list raises ListChanged events. (Inherited from BindingList <(Of <( MSHelpAttr >)>).)
SortDirectionCore | Gets the direction the list is sorted. (Inherited from BindingList <(Of <( MSHelpAttr >)>).)
SortPropertyCore | Gets the property descriptor that is used for sorting the list if sorting is implemented in a derived class; otherwise, returns null. (Inherited from BindingList <(Of <( MSHelpAttr >)>).)
SupportsChangeNotificationCore | Gets a value indicating whether ListChanged events are enabled. (Inherited from BindingList <(Of <( MSHelpAttr >)>).)
SupportsSearchingCore | Gets a value indicating whether the list supports searching. (Inherited from BindingList <(Of <( MSHelpAttr >)>).)
SupportsSortingCore | Gets a value indicating whether the list supports sorting. (Inherited from BindingList <(Of <( MSHelpAttr >)>).)

Events

Name | Description
AddingNew | Occurs before an item is added to the list. (Inherited from BindingList <(Of <( MSHelpAttr >)>).)
ListChanged | Occurs when the list or an item in the list changes. (Inherited from BindingList <(Of <( MSHelpAttr >)>).)

See Also

MSHelpAttrCollection Class
SandcastleBuilder.Utils Namespace


MSHelpAttrCollection Constructor

[image]

Sandcastle Help File Builder Documentation
MSHelpAttrCollection Constructor
MSHelpAttrCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public MSHelpAttrCollection(
    SandcastleProject project
)
Visual Basic (Declaration)
Public Sub New ( _
    project As SandcastleProject _
)

Parameters

project
Type: SandcastleBuilder.Utils..::.SandcastleProject
The project that owns the collection or null for a standalone collection

See Also

MSHelpAttrCollection Class
SandcastleBuilder.Utils Namespace


MSHelpAttrCollection Methods

[image] [image]

Sandcastle Help File Builder Documentation
MSHelpAttrCollection Methods
MSHelpAttrCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The MSHelpAttrCollection type exposes the following members.

Methods

Name | Description
Add | Overloaded.
AddNew | Adds a new item to the collection. (Inherited from BindingList <(Of <( MSHelpAttr >)>).)
AddNewCore | Adds a new item to the end of the collection. (Inherited from BindingList <(Of <( MSHelpAttr >)>).)
ApplySortCore | Sorts the items if overridden in a derived class; otherwise, throws a NotSupportedException. (Inherited from BindingList <(Of <( MSHelpAttr >)>).)
CancelNew | Discards a pending new item. (Inherited from BindingList <(Of <( MSHelpAttr >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( MSHelpAttr >)>).)
ClearItems | Removes all elements from the collection. (Inherited from BindingList <(Of <( MSHelpAttr >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( MSHelpAttr >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <( MSHelpAttr >)>).)
EndNew | Commits a pending new item to the collection. (Inherited from BindingList <(Of <( MSHelpAttr >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindCore | Searches for the index of the item that has the specified property descriptor with the specified value, if searching is implemented in a derived class; otherwise, a NotSupportedException. (Inherited from BindingList <(Of <( MSHelpAttr >)>).)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( MSHelpAttr >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection <(Of <( MSHelpAttr >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( MSHelpAttr >)>).)
InsertItem | Inserts the specified item in the list at the specified index. (Inherited from BindingList <(Of <( MSHelpAttr >)>).)
MarkAsDirty | This is used to mark the collection as changed when there is no associated project.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnAddingNew | Raises the AddingNew event. (Inherited from BindingList <(Of <( MSHelpAttr >)>).)
OnListChanged | This is overridden to mark the collection as dirty when it changes (Overrides BindingList<(Of <(T>)>)..::.OnListChanged(ListChangedEventArgs).)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( MSHelpAttr >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( MSHelpAttr >)>).)
RemoveItem | Removes the item at the specified index. (Inherited from BindingList <(Of <( MSHelpAttr >)>).)
RemoveSortCore | Removes any sort applied with ApplySortCore(PropertyDescriptor, ListSortDirection) if sorting is implemented in a derived class; otherwise, raises NotSupportedException. (Inherited from BindingList <(Of <( MSHelpAttr >)>).)
ResetBindings | Raises a ListChanged event of type Reset. (Inherited from BindingList <(Of <( MSHelpAttr >)>).)
ResetItem | Raises a ListChanged event of type ItemChanged for the item at the specified position. (Inherited from BindingList <(Of <( MSHelpAttr >)>).)
SetItem | Replaces the item at the specified index with the specified item. (Inherited from BindingList <(Of <( MSHelpAttr >)>).)
Sort | This is used to sort the collection
ToConfigurationString | Convert the collection to its string form for use in the sandcastle.config file.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteXml | Write the collection to the given XML text writer

See Also

MSHelpAttrCollection Class
SandcastleBuilder.Utils Namespace


Add Method

[image] [image]

Sandcastle Help File Builder Documentation
MSHelpAttrCollection..::.Add Method
MSHelpAttrCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Add(T) | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( MSHelpAttr >)>).)
Add(String, String) | Add a new item to the collection

See Also

MSHelpAttrCollection Class
MSHelpAttrCollection Members
SandcastleBuilder.Utils Namespace


Add Method (String, String)

[image]

Sandcastle Help File Builder Documentation
MSHelpAttrCollection..::.Add Method (String, String)
MSHelpAttrCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Add a new item to the collection

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public MSHelpAttr Add(
    string name,
    string value
)
Visual Basic (Declaration)
Public Function Add ( _
    name As String, _
    value As String _
) As MSHelpAttr

Parameters

name
Type: System..::.String
The attribute name
value
Type: System..::.String
The attribute value

Return Value

The MSHelpAttr added to the project. If If the item already exists in the collection, the existing item is returned.

Remarks

The MSHelpAttr constructor is internal so that we control creation of the items and can associate them with the project.

See Also

MSHelpAttrCollection Class
Add Overload
SandcastleBuilder.Utils Namespace


MarkAsDirty Method

[image]

Sandcastle Help File Builder Documentation
MSHelpAttrCollection..::.MarkAsDirty Method
MSHelpAttrCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to mark the collection as changed when there is no associated project.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public void MarkAsDirty()
Visual Basic (Declaration)
Public Sub MarkAsDirty

See Also

MSHelpAttrCollection Class
SandcastleBuilder.Utils Namespace


OnListChanged Method

[image]

Sandcastle Help File Builder Documentation
MSHelpAttrCollection..::.OnListChanged Method
MSHelpAttrCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is overridden to mark the collection as dirty when it changes

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected override void OnListChanged(
    ListChangedEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnListChanged ( _
    e As ListChangedEventArgs _
)

Parameters

e
Type: System.ComponentModel..::.ListChangedEventArgs
The event arguments

See Also

MSHelpAttrCollection Class
SandcastleBuilder.Utils Namespace


Sort Method

[image]

Sandcastle Help File Builder Documentation
MSHelpAttrCollection..::.Sort Method
MSHelpAttrCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to sort the collection

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public void Sort()
Visual Basic (Declaration)
Public Sub Sort

Remarks

Values are sorted by attribute name and value

See Also

MSHelpAttrCollection Class
SandcastleBuilder.Utils Namespace


ToConfigurationString Method

[image]

Sandcastle Help File Builder Documentation
MSHelpAttrCollection..::.ToConfigurationString Method
MSHelpAttrCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Convert the collection to its string form for use in the sandcastle.config file.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string ToConfigurationString()
Visual Basic (Declaration)
Public Function ToConfigurationString As String

Return Value

The help attribute collection in string form ready for use in the Sandcastle BuildAssembler configuration file.

See Also

MSHelpAttrCollection Class
SandcastleBuilder.Utils Namespace


WriteXml Method

[image]

Sandcastle Help File Builder Documentation
MSHelpAttrCollection..::.WriteXml Method
MSHelpAttrCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Write the collection to the given XML text writer

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public void WriteXml(
    XmlWriter xw,
    bool includeContainer
)
Visual Basic (Declaration)
Public Sub WriteXml ( _
    xw As XmlWriter, _
    includeContainer As Boolean _
)

Parameters

xw
Type: System.Xml..::.XmlWriter
The XML text writer to which the information is written.
includeContainer
Type: System..::.Boolean
True to write out the containing HelpAttributes element, false to exclude it.

See Also

MSHelpAttrCollection Class
SandcastleBuilder.Utils Namespace


MSHelpAttrCollection Properties

[image] [image]

Sandcastle Help File Builder Documentation
MSHelpAttrCollection Properties
MSHelpAttrCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The MSHelpAttrCollection type exposes the following members.

Properties

Name | Description
AllowEdit | Gets or sets a value indicating whether items in the list can be edited. (Inherited from BindingList <(Of <( MSHelpAttr >)>).)
AllowNew | Gets or sets a value indicating whether you can add items to the list using the AddNew()()() method. (Inherited from BindingList <(Of <( MSHelpAttr >)>).)
AllowRemove | Gets or sets a value indicating whether you can remove items from the collection. (Inherited from BindingList <(Of <( MSHelpAttr >)>).)
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( MSHelpAttr >)>).)
IsDirty | This is used to get or set the dirty state of the collection
IsSortedCore | Gets a value indicating whether the list is sorted. (Inherited from BindingList <(Of <( MSHelpAttr >)>).)
Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <( MSHelpAttr >)>).)
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( MSHelpAttr >)>).)
RaiseListChangedEvents | Gets or sets a value indicating whether adding or removing items within the list raises ListChanged events. (Inherited from BindingList <(Of <( MSHelpAttr >)>).)
SortDirectionCore | Gets the direction the list is sorted. (Inherited from BindingList <(Of <( MSHelpAttr >)>).)
SortPropertyCore | Gets the property descriptor that is used for sorting the list if sorting is implemented in a derived class; otherwise, returns null. (Inherited from BindingList <(Of <( MSHelpAttr >)>).)
SupportsChangeNotificationCore | Gets a value indicating whether ListChanged events are enabled. (Inherited from BindingList <(Of <( MSHelpAttr >)>).)
SupportsSearchingCore | Gets a value indicating whether the list supports searching. (Inherited from BindingList <(Of <( MSHelpAttr >)>).)
SupportsSortingCore | Gets a value indicating whether the list supports sorting. (Inherited from BindingList <(Of <( MSHelpAttr >)>).)

See Also

MSHelpAttrCollection Class
SandcastleBuilder.Utils Namespace


IsDirty Property

[image]

Sandcastle Help File Builder Documentation
MSHelpAttrCollection..::.IsDirty Property
MSHelpAttrCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set the dirty state of the collection

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool IsDirty { get; set; }
Visual Basic (Declaration)
Public Property IsDirty As Boolean

See Also

MSHelpAttrCollection Class
SandcastleBuilder.Utils Namespace


MSHelpAttrCollection Events

[image] [image]

Sandcastle Help File Builder Documentation
MSHelpAttrCollection Events
MSHelpAttrCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The MSHelpAttrCollection type exposes the following members.

Events

Name | Description
AddingNew | Occurs before an item is added to the list. (Inherited from BindingList <(Of <( MSHelpAttr >)>).)
ListChanged | Occurs when the list or an item in the list changes. (Inherited from BindingList <(Of <( MSHelpAttr >)>).)

See Also

MSHelpAttrCollection Class
SandcastleBuilder.Utils Namespace


MSHelpKeyword Class

[image]

Sandcastle Help File Builder Documentation
MSHelpKeyword Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This represents an HTML Help 2.x index keyword that can be added to the XML data island in each help topic generated by BuildAssembler.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
[SerializableAttribute]
public class MSHelpKeyword : IComparable<MSHelpKeyword>
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class MSHelpKeyword _
    Implements IComparable(Of MSHelpKeyword)

Inheritance Hierarchy

System..::.Object
SandcastleBuilder.Utils..::.MSHelpKeyword

See Also

MSHelpKeyword Members
SandcastleBuilder.Utils Namespace


MSHelpKeyword Members

[image] [image]

Sandcastle Help File Builder Documentation
MSHelpKeyword Members
MSHelpKeyword Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The MSHelpKeyword type exposes the following members.

Constructors

Name | Description
MSHelpKeyword | Overloaded.

Methods

Name | Description
CompareTo | Compares this instance to another instance and returns an indication of their relative values.
Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Get a hash code for this item (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Return a string representation of the item (Overrides Object..::.ToString()()().)

Properties

Name | Description
Index | This is used to get or set the index name
Term | This is used to get or set the index term

See Also

MSHelpKeyword Class
SandcastleBuilder.Utils Namespace


MSHelpKeyword Constructor

[image] [image]

Sandcastle Help File Builder Documentation
MSHelpKeyword Constructor
MSHelpKeyword Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MSHelpKeyword()()() | Constructor
MSHelpKeyword(String, String) | Constructor

See Also

MSHelpKeyword Class
MSHelpKeyword Members
SandcastleBuilder.Utils Namespace


MSHelpKeyword Constructor

[image]

Sandcastle Help File Builder Documentation
MSHelpKeyword Constructor
MSHelpKeyword Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public MSHelpKeyword()
Visual Basic (Declaration)
Public Sub New

Remarks

The index name defaults to "K"

See Also

MSHelpKeyword Class
MSHelpKeyword Overload
SandcastleBuilder.Utils Namespace


MSHelpKeyword Constructor (String, String)

[image]

Sandcastle Help File Builder Documentation
MSHelpKeyword Constructor (String, String)
MSHelpKeyword Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public MSHelpKeyword(
    string indexName,
    string keywordTerm
)
Visual Basic (Declaration)
Public Sub New ( _
    indexName As String, _
    keywordTerm As String _
)

Parameters

indexName
Type: System..::.String
The index name
keywordTerm
Type: System..::.String
The index term

See Also

MSHelpKeyword Class
MSHelpKeyword Overload
SandcastleBuilder.Utils Namespace


MSHelpKeyword Methods

[image] [image]

Sandcastle Help File Builder Documentation
MSHelpKeyword Methods
MSHelpKeyword Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The MSHelpKeyword type exposes the following members.

Methods

Name | Description
CompareTo | Compares this instance to another instance and returns an indication of their relative values.
Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Get a hash code for this item (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Return a string representation of the item (Overrides Object..::.ToString()()().)

See Also

MSHelpKeyword Class
SandcastleBuilder.Utils Namespace


CompareTo Method

[image]

Sandcastle Help File Builder Documentation
MSHelpKeyword..::.CompareTo Method
MSHelpKeyword Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Compares this instance to another instance and returns an indication of their relative values.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public int CompareTo(
    MSHelpKeyword other
)
Visual Basic (Declaration)
Public Function CompareTo ( _
    other As MSHelpKeyword _
) As Integer

Parameters

other
Type: SandcastleBuilder.Utils..::.MSHelpKeyword
A MSHelpKeyword object to compare

Return Value

Returns -1 if this instance is less than the value, 0 if they are equal, or 1 if this instance is greater than the value or the value is null.

Implements

IComparable<(Of <(T>)>)..::.CompareTo(T)

Remarks

Entries are sorted by name and then value

See Also

MSHelpKeyword Class
SandcastleBuilder.Utils Namespace


Equals Method

[image]

Sandcastle Help File Builder Documentation
MSHelpKeyword..::.Equals Method
MSHelpKeyword Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Determines whether the specified Object is equal to the current Object.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::.Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Exceptions

Exception | Condition
System..::.NullReferenceException | The obj parameter is null.

See Also

MSHelpKeyword Class
SandcastleBuilder.Utils Namespace


GetHashCode Method

[image]

Sandcastle Help File Builder Documentation
MSHelpKeyword..::.GetHashCode Method
MSHelpKeyword Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Get a hash code for this item

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer

Return Value

Returns the hash code for the index name and term.

See Also

MSHelpKeyword Class
SandcastleBuilder.Utils Namespace


ToString Method

[image]

Sandcastle Help File Builder Documentation
MSHelpKeyword..::.ToString Method
MSHelpKeyword Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Return a string representation of the item

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

Return Value

Returns the item in its XML format

See Also

MSHelpKeyword Class
SandcastleBuilder.Utils Namespace


MSHelpKeyword Properties

[image] [image]

Sandcastle Help File Builder Documentation
MSHelpKeyword Properties
MSHelpKeyword Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The MSHelpKeyword type exposes the following members.

Properties

Name | Description
Index | This is used to get or set the index name
Term | This is used to get or set the index term

See Also

MSHelpKeyword Class
SandcastleBuilder.Utils Namespace


Index Property

[image]

Sandcastle Help File Builder Documentation
MSHelpKeyword..::.Index Property
MSHelpKeyword Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set the index name

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string Index { get; set; }
Visual Basic (Declaration)
Public Property Index As String

See Also

MSHelpKeyword Class
SandcastleBuilder.Utils Namespace


Term Property

[image]

Sandcastle Help File Builder Documentation
MSHelpKeyword..::.Term Property
MSHelpKeyword Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set the index term

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string Term { get; set; }
Visual Basic (Declaration)
Public Property Term As String

See Also

MSHelpKeyword Class
SandcastleBuilder.Utils Namespace


MSHelpKeywordCollection Class

[image]

Sandcastle Help File Builder Documentation
MSHelpKeywordCollection Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This collection class is used to hold the help index keyword items for a project.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
[SerializableAttribute]
public class MSHelpKeywordCollection : BindingList<MSHelpKeyword>
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class MSHelpKeywordCollection _
    Inherits BindingList(Of MSHelpKeyword)

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection <(Of <( MSHelpKeyword >)>)
System.ComponentModel..::.BindingList <(Of <( MSHelpKeyword >)>)
SandcastleBuilder.Utils..::.MSHelpKeywordCollection

See Also

MSHelpKeywordCollection Members
SandcastleBuilder.Utils Namespace


MSHelpKeywordCollection Members

[image] [image]

Sandcastle Help File Builder Documentation
MSHelpKeywordCollection Members
MSHelpKeywordCollection Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The MSHelpKeywordCollection type exposes the following members.

Constructors

Name | Description
MSHelpKeywordCollection | Initializes a new instance of the MSHelpKeywordCollection class

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( MSHelpKeyword >)>).)
AddNew | Adds a new item to the collection. (Inherited from BindingList <(Of <( MSHelpKeyword >)>).)
AddNewCore | Adds a new item to the end of the collection. (Inherited from BindingList <(Of <( MSHelpKeyword >)>).)
ApplySortCore | Sorts the items if overridden in a derived class; otherwise, throws a NotSupportedException. (Inherited from BindingList <(Of <( MSHelpKeyword >)>).)
CancelNew | Discards a pending new item. (Inherited from BindingList <(Of <( MSHelpKeyword >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( MSHelpKeyword >)>).)
ClearItems | Removes all elements from the collection. (Inherited from BindingList <(Of <( MSHelpKeyword >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( MSHelpKeyword >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <( MSHelpKeyword >)>).)
EndNew | Commits a pending new item to the collection. (Inherited from BindingList <(Of <( MSHelpKeyword >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindCore | Searches for the index of the item that has the specified property descriptor with the specified value, if searching is implemented in a derived class; otherwise, a NotSupportedException. (Inherited from BindingList <(Of <( MSHelpKeyword >)>).)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( MSHelpKeyword >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection <(Of <( MSHelpKeyword >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( MSHelpKeyword >)>).)
InsertItem | Inserts the specified item in the list at the specified index. (Inherited from BindingList <(Of <( MSHelpKeyword >)>).)
MarkAsDirty | This is used to mark the collection as changed when there is no associated project.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnAddingNew | Raises the AddingNew event. (Inherited from BindingList <(Of <( MSHelpKeyword >)>).)
OnListChanged | Raises the ListChanged event. (Inherited from BindingList <(Of <( MSHelpKeyword >)>).)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( MSHelpKeyword >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( MSHelpKeyword >)>).)
RemoveItem | Removes the item at the specified index. (Inherited from BindingList <(Of <( MSHelpKeyword >)>).)
RemoveSortCore | Removes any sort applied with ApplySortCore(PropertyDescriptor, ListSortDirection) if sorting is implemented in a derived class; otherwise, raises NotSupportedException. (Inherited from BindingList <(Of <( MSHelpKeyword >)>).)
ResetBindings | Raises a ListChanged event of type Reset. (Inherited from BindingList <(Of <( MSHelpKeyword >)>).)
ResetItem | Raises a ListChanged event of type ItemChanged for the item at the specified position. (Inherited from BindingList <(Of <( MSHelpKeyword >)>).)
SetItem | Replaces the item at the specified index with the specified item. (Inherited from BindingList <(Of <( MSHelpKeyword >)>).)
Sort | This is used to sort the collection
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteXml | This is used to save the keyword collection to the project file.

Properties

Name | Description
AllowEdit | Gets or sets a value indicating whether items in the list can be edited. (Inherited from BindingList <(Of <( MSHelpKeyword >)>).)
AllowNew | Gets or sets a value indicating whether you can add items to the list using the AddNew()()() method. (Inherited from BindingList <(Of <( MSHelpKeyword >)>).)
AllowRemove | Gets or sets a value indicating whether you can remove items from the collection. (Inherited from BindingList <(Of <( MSHelpKeyword >)>).)
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( MSHelpKeyword >)>).)
IsSortedCore | Gets a value indicating whether the list is sorted. (Inherited from BindingList <(Of <( MSHelpKeyword >)>).)
Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <( MSHelpKeyword >)>).)
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( MSHelpKeyword >)>).)
RaiseListChangedEvents | Gets or sets a value indicating whether adding or removing items within the list raises ListChanged events. (Inherited from BindingList <(Of <( MSHelpKeyword >)>).)
SortDirectionCore | Gets the direction the list is sorted. (Inherited from BindingList <(Of <( MSHelpKeyword >)>).)
SortPropertyCore | Gets the property descriptor that is used for sorting the list if sorting is implemented in a derived class; otherwise, returns null. (Inherited from BindingList <(Of <( MSHelpKeyword >)>).)
SupportsChangeNotificationCore | Gets a value indicating whether ListChanged events are enabled. (Inherited from BindingList <(Of <( MSHelpKeyword >)>).)
SupportsSearchingCore | Gets a value indicating whether the list supports searching. (Inherited from BindingList <(Of <( MSHelpKeyword >)>).)
SupportsSortingCore | Gets a value indicating whether the list supports sorting. (Inherited from BindingList <(Of <( MSHelpKeyword >)>).)

Events

Name | Description
AddingNew | Occurs before an item is added to the list. (Inherited from BindingList <(Of <( MSHelpKeyword >)>).)
ListChanged | Occurs when the list or an item in the list changes. (Inherited from BindingList <(Of <( MSHelpKeyword >)>).)

See Also

MSHelpKeywordCollection Class
SandcastleBuilder.Utils Namespace


MSHelpKeywordCollection Constructor

[image]

Sandcastle Help File Builder Documentation
MSHelpKeywordCollection Constructor
MSHelpKeywordCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the MSHelpKeywordCollection class

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public MSHelpKeywordCollection()
Visual Basic (Declaration)
Public Sub New

See Also

MSHelpKeywordCollection Class
SandcastleBuilder.Utils Namespace


MSHelpKeywordCollection Methods

[image] [image]

Sandcastle Help File Builder Documentation
MSHelpKeywordCollection Methods
MSHelpKeywordCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The MSHelpKeywordCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( MSHelpKeyword >)>).)
AddNew | Adds a new item to the collection. (Inherited from BindingList <(Of <( MSHelpKeyword >)>).)
AddNewCore | Adds a new item to the end of the collection. (Inherited from BindingList <(Of <( MSHelpKeyword >)>).)
ApplySortCore | Sorts the items if overridden in a derived class; otherwise, throws a NotSupportedException. (Inherited from BindingList <(Of <( MSHelpKeyword >)>).)
CancelNew | Discards a pending new item. (Inherited from BindingList <(Of <( MSHelpKeyword >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( MSHelpKeyword >)>).)
ClearItems | Removes all elements from the collection. (Inherited from BindingList <(Of <( MSHelpKeyword >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( MSHelpKeyword >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <( MSHelpKeyword >)>).)
EndNew | Commits a pending new item to the collection. (Inherited from BindingList <(Of <( MSHelpKeyword >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindCore | Searches for the index of the item that has the specified property descriptor with the specified value, if searching is implemented in a derived class; otherwise, a NotSupportedException. (Inherited from BindingList <(Of <( MSHelpKeyword >)>).)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( MSHelpKeyword >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection <(Of <( MSHelpKeyword >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( MSHelpKeyword >)>).)
InsertItem | Inserts the specified item in the list at the specified index. (Inherited from BindingList <(Of <( MSHelpKeyword >)>).)
MarkAsDirty | This is used to mark the collection as changed when there is no associated project.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnAddingNew | Raises the AddingNew event. (Inherited from BindingList <(Of <( MSHelpKeyword >)>).)
OnListChanged | Raises the ListChanged event. (Inherited from BindingList <(Of <( MSHelpKeyword >)>).)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( MSHelpKeyword >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( MSHelpKeyword >)>).)
RemoveItem | Removes the item at the specified index. (Inherited from BindingList <(Of <( MSHelpKeyword >)>).)
RemoveSortCore | Removes any sort applied with ApplySortCore(PropertyDescriptor, ListSortDirection) if sorting is implemented in a derived class; otherwise, raises NotSupportedException. (Inherited from BindingList <(Of <( MSHelpKeyword >)>).)
ResetBindings | Raises a ListChanged event of type Reset. (Inherited from BindingList <(Of <( MSHelpKeyword >)>).)
ResetItem | Raises a ListChanged event of type ItemChanged for the item at the specified position. (Inherited from BindingList <(Of <( MSHelpKeyword >)>).)
SetItem | Replaces the item at the specified index with the specified item. (Inherited from BindingList <(Of <( MSHelpKeyword >)>).)
Sort | This is used to sort the collection
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteXml | This is used to save the keyword collection to the project file.

See Also

MSHelpKeywordCollection Class
SandcastleBuilder.Utils Namespace


MarkAsDirty Method

[image]

Sandcastle Help File Builder Documentation
MSHelpKeywordCollection..::.MarkAsDirty Method
MSHelpKeywordCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to mark the collection as changed when there is no associated project.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public void MarkAsDirty()
Visual Basic (Declaration)
Public Sub MarkAsDirty

See Also

MSHelpKeywordCollection Class
SandcastleBuilder.Utils Namespace


Sort Method

[image]

Sandcastle Help File Builder Documentation
MSHelpKeywordCollection..::.Sort Method
MSHelpKeywordCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to sort the collection

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public void Sort()
Visual Basic (Declaration)
Public Sub Sort

Remarks

Values are sorted by index name and term

See Also

MSHelpKeywordCollection Class
SandcastleBuilder.Utils Namespace


WriteXml Method

[image]

Sandcastle Help File Builder Documentation
MSHelpKeywordCollection..::.WriteXml Method
MSHelpKeywordCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to save the keyword collection to the project file.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public void WriteXml(
    XmlWriter xw
)
Visual Basic (Declaration)
Public Sub WriteXml ( _
    xw As XmlWriter _
)

Parameters

xw
Type: System.Xml..::.XmlWriter
The XML text writer to which the information is written.

See Also

MSHelpKeywordCollection Class
SandcastleBuilder.Utils Namespace


MSHelpKeywordCollection Properties

[image] [image]

Sandcastle Help File Builder Documentation
MSHelpKeywordCollection Properties
MSHelpKeywordCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The MSHelpKeywordCollection type exposes the following members.

Properties

Name | Description
AllowEdit | Gets or sets a value indicating whether items in the list can be edited. (Inherited from BindingList <(Of <( MSHelpKeyword >)>).)
AllowNew | Gets or sets a value indicating whether you can add items to the list using the AddNew()()() method. (Inherited from BindingList <(Of <( MSHelpKeyword >)>).)
AllowRemove | Gets or sets a value indicating whether you can remove items from the collection. (Inherited from BindingList <(Of <( MSHelpKeyword >)>).)
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( MSHelpKeyword >)>).)
IsSortedCore | Gets a value indicating whether the list is sorted. (Inherited from BindingList <(Of <( MSHelpKeyword >)>).)
Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <( MSHelpKeyword >)>).)
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( MSHelpKeyword >)>).)
RaiseListChangedEvents | Gets or sets a value indicating whether adding or removing items within the list raises ListChanged events. (Inherited from BindingList <(Of <( MSHelpKeyword >)>).)
SortDirectionCore | Gets the direction the list is sorted. (Inherited from BindingList <(Of <( MSHelpKeyword >)>).)
SortPropertyCore | Gets the property descriptor that is used for sorting the list if sorting is implemented in a derived class; otherwise, returns null. (Inherited from BindingList <(Of <( MSHelpKeyword >)>).)
SupportsChangeNotificationCore | Gets a value indicating whether ListChanged events are enabled. (Inherited from BindingList <(Of <( MSHelpKeyword >)>).)
SupportsSearchingCore | Gets a value indicating whether the list supports searching. (Inherited from BindingList <(Of <( MSHelpKeyword >)>).)
SupportsSortingCore | Gets a value indicating whether the list supports sorting. (Inherited from BindingList <(Of <( MSHelpKeyword >)>).)

See Also

MSHelpKeywordCollection Class
SandcastleBuilder.Utils Namespace


MSHelpKeywordCollection Events

[image] [image]

Sandcastle Help File Builder Documentation
MSHelpKeywordCollection Events
MSHelpKeywordCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The MSHelpKeywordCollection type exposes the following members.

Events

Name | Description
AddingNew | Occurs before an item is added to the list. (Inherited from BindingList <(Of <( MSHelpKeyword >)>).)
ListChanged | Occurs when the list or an item in the list changes. (Inherited from BindingList <(Of <( MSHelpKeyword >)>).)

See Also

MSHelpKeywordCollection Class
SandcastleBuilder.Utils Namespace


NamespaceSummaryItem Class

[image]

Sandcastle Help File Builder Documentation
NamespaceSummaryItem Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This represents a a namespace summary item that can be used to add comments to a namespace in the help file or exclude it completely from the help file.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public class NamespaceSummaryItem : PropertyBasedCollectionItem
Visual Basic (Declaration)
Public Class NamespaceSummaryItem _
    Inherits PropertyBasedCollectionItem

Inheritance Hierarchy

System..::.Object
SandcastleBuilder.Utils..::.PropertyBasedCollectionItem
SandcastleBuilder.Utils..::.NamespaceSummaryItem

See Also

NamespaceSummaryItem Members
SandcastleBuilder.Utils Namespace


NamespaceSummaryItem Members

[image] [image]

Sandcastle Help File Builder Documentation
NamespaceSummaryItem Members
NamespaceSummaryItem Class Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The NamespaceSummaryItem type exposes the following members.

Methods

Name | Description
CheckProjectIsEditable | This is used to see if the project can be edited. If not, abort the change by throwing an exception. (Inherited from PropertyBasedCollectionItem.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Return the namespace name as the string representation of the object. (Overrides Object..::.ToString()()().)

Properties

Name | Description
IsDirty | This is used to get or set the dirty state of the item (Inherited from PropertyBasedCollectionItem.)
IsDocumented | This is used to get or set whether or not the namespace is included in the help file.
Name | This read-only property is used to get the namespace name
ProjectFile | This is used to get the owning project file (Inherited from PropertyBasedCollectionItem.)
Summary | This is used to get or set the namespace summary comments

See Also

NamespaceSummaryItem Class
SandcastleBuilder.Utils Namespace


NamespaceSummaryItem Methods

[image] [image]

Sandcastle Help File Builder Documentation
NamespaceSummaryItem Methods
NamespaceSummaryItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The NamespaceSummaryItem type exposes the following members.

Methods

Name | Description
CheckProjectIsEditable | This is used to see if the project can be edited. If not, abort the change by throwing an exception. (Inherited from PropertyBasedCollectionItem.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Return the namespace name as the string representation of the object. (Overrides Object..::.ToString()()().)

See Also

NamespaceSummaryItem Class
SandcastleBuilder.Utils Namespace


ToString Method

[image]

Sandcastle Help File Builder Documentation
NamespaceSummaryItem..::.ToString Method
NamespaceSummaryItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Return the namespace name as the string representation of the object.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

Return Value

The namespace name

See Also

NamespaceSummaryItem Class
SandcastleBuilder.Utils Namespace


NamespaceSummaryItem Properties

[image] [image]

Sandcastle Help File Builder Documentation
NamespaceSummaryItem Properties
NamespaceSummaryItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The NamespaceSummaryItem type exposes the following members.

Properties

Name | Description
IsDirty | This is used to get or set the dirty state of the item (Inherited from PropertyBasedCollectionItem.)
IsDocumented | This is used to get or set whether or not the namespace is included in the help file.
Name | This read-only property is used to get the namespace name
ProjectFile | This is used to get the owning project file (Inherited from PropertyBasedCollectionItem.)
Summary | This is used to get or set the namespace summary comments

See Also

NamespaceSummaryItem Class
SandcastleBuilder.Utils Namespace


IsDocumented Property

[image]

Sandcastle Help File Builder Documentation
NamespaceSummaryItem..::.IsDocumented Property
NamespaceSummaryItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set whether or not the namespace is included in the help file.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool IsDocumented { get; set; }
Visual Basic (Declaration)
Public Property IsDocumented As Boolean

See Also

NamespaceSummaryItem Class
SandcastleBuilder.Utils Namespace


Name Property

[image]

Sandcastle Help File Builder Documentation
NamespaceSummaryItem..::.Name Property
NamespaceSummaryItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property is used to get the namespace name

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String

See Also

NamespaceSummaryItem Class
SandcastleBuilder.Utils Namespace


Summary Property

[image]

Sandcastle Help File Builder Documentation
NamespaceSummaryItem..::.Summary Property
NamespaceSummaryItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set the namespace summary comments

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string Summary { get; set; }
Visual Basic (Declaration)
Public Property Summary As String

See Also

NamespaceSummaryItem Class
SandcastleBuilder.Utils Namespace


NamespaceSummaryItemCollection Class

[image]

Sandcastle Help File Builder Documentation
NamespaceSummaryItemCollection Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This collection class is used to hold the namespace summary items for a project.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public class NamespaceSummaryItemCollection : BindingList<NamespaceSummaryItem>
Visual Basic (Declaration)
Public Class NamespaceSummaryItemCollection _
    Inherits BindingList(Of NamespaceSummaryItem)

Remarks

Namespaces that appear in the assemblies but not in this list are documented by default and will appear without a namespace summary.

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection <(Of <( NamespaceSummaryItem >)>)
System.ComponentModel..::.BindingList <(Of <( NamespaceSummaryItem >)>)
SandcastleBuilder.Utils..::.NamespaceSummaryItemCollection

See Also

NamespaceSummaryItemCollection Members
SandcastleBuilder.Utils Namespace


NamespaceSummaryItemCollection Members

[image] [image]

Sandcastle Help File Builder Documentation
NamespaceSummaryItemCollection Members
NamespaceSummaryItemCollection Class Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The NamespaceSummaryItemCollection type exposes the following members.

Methods

Name | Description
Add | Overloaded.
AddNew | Adds a new item to the collection. (Inherited from BindingList <(Of <( NamespaceSummaryItem >)>).)
AddNewCore | Adds a new item to the end of the collection. (Inherited from BindingList <(Of <( NamespaceSummaryItem >)>).)
ApplySortCore | Sorts the items if overridden in a derived class; otherwise, throws a NotSupportedException. (Inherited from BindingList <(Of <( NamespaceSummaryItem >)>).)
CancelNew | Discards a pending new item. (Inherited from BindingList <(Of <( NamespaceSummaryItem >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( NamespaceSummaryItem >)>).)
ClearItems | Removes all elements from the collection. (Inherited from BindingList <(Of <( NamespaceSummaryItem >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( NamespaceSummaryItem >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <( NamespaceSummaryItem >)>).)
CreateTemporaryItem | Create a temporary item that isn't part of the project
EndNew | Commits a pending new item to the collection. (Inherited from BindingList <(Of <( NamespaceSummaryItem >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindCore | Searches for the index of the item that has the specified property descriptor with the specified value, if searching is implemented in a derived class; otherwise, a NotSupportedException. (Inherited from BindingList <(Of <( NamespaceSummaryItem >)>).)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( NamespaceSummaryItem >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection <(Of <( NamespaceSummaryItem >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( NamespaceSummaryItem >)>).)
InsertItem | Inserts the specified item in the list at the specified index. (Inherited from BindingList <(Of <( NamespaceSummaryItem >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnAddingNew | Raises the AddingNew event. (Inherited from BindingList <(Of <( NamespaceSummaryItem >)>).)
OnListChanged | This is overridden to mark the collection as dirty when it changes (Overrides BindingList<(Of <(T>)>)..::.OnListChanged(ListChangedEventArgs).)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( NamespaceSummaryItem >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( NamespaceSummaryItem >)>).)
RemoveItem | Removes the item at the specified index. (Inherited from BindingList <(Of <( NamespaceSummaryItem >)>).)
RemoveSortCore | Removes any sort applied with ApplySortCore(PropertyDescriptor, ListSortDirection) if sorting is implemented in a derived class; otherwise, raises NotSupportedException. (Inherited from BindingList <(Of <( NamespaceSummaryItem >)>).)
ResetBindings | Raises a ListChanged event of type Reset. (Inherited from BindingList <(Of <( NamespaceSummaryItem >)>).)
ResetItem | Raises a ListChanged event of type ItemChanged for the item at the specified position. (Inherited from BindingList <(Of <( NamespaceSummaryItem >)>).)
SetItem | Replaces the item at the specified index with the specified item. (Inherited from BindingList <(Of <( NamespaceSummaryItem >)>).)
Sort | This is used to sort the namespace items by name
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AllowEdit | Gets or sets a value indicating whether items in the list can be edited. (Inherited from BindingList <(Of <( NamespaceSummaryItem >)>).)
AllowNew | Gets or sets a value indicating whether you can add items to the list using the AddNew()()() method. (Inherited from BindingList <(Of <( NamespaceSummaryItem >)>).)
AllowRemove | Gets or sets a value indicating whether you can remove items from the collection. (Inherited from BindingList <(Of <( NamespaceSummaryItem >)>).)
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( NamespaceSummaryItem >)>).)
IsDirty | This is used to get or set the dirty state of the collection
IsSortedCore | Gets a value indicating whether the list is sorted. (Inherited from BindingList <(Of <( NamespaceSummaryItem >)>).)
Item | Overloaded.
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( NamespaceSummaryItem >)>).)
Project | This is used to get a reference to the project that owns the collection.
RaiseListChangedEvents | Gets or sets a value indicating whether adding or removing items within the list raises ListChanged events. (Inherited from BindingList <(Of <( NamespaceSummaryItem >)>).)
SortDirectionCore | Gets the direction the list is sorted. (Inherited from BindingList <(Of <( NamespaceSummaryItem >)>).)
SortPropertyCore | Gets the property descriptor that is used for sorting the list if sorting is implemented in a derived class; otherwise, returns null. (Inherited from BindingList <(Of <( NamespaceSummaryItem >)>).)
SupportsChangeNotificationCore | Gets a value indicating whether ListChanged events are enabled. (Inherited from BindingList <(Of <( NamespaceSummaryItem >)>).)
SupportsSearchingCore | Gets a value indicating whether the list supports searching. (Inherited from BindingList <(Of <( NamespaceSummaryItem >)>).)
SupportsSortingCore | Gets a value indicating whether the list supports sorting. (Inherited from BindingList <(Of <( NamespaceSummaryItem >)>).)

Events

Name | Description
AddingNew | Occurs before an item is added to the list. (Inherited from BindingList <(Of <( NamespaceSummaryItem >)>).)
ListChanged | Occurs when the list or an item in the list changes. (Inherited from BindingList <(Of <( NamespaceSummaryItem >)>).)

See Also

NamespaceSummaryItemCollection Class
SandcastleBuilder.Utils Namespace


NamespaceSummaryItemCollection Methods

[image] [image]

Sandcastle Help File Builder Documentation
NamespaceSummaryItemCollection Methods
NamespaceSummaryItemCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The NamespaceSummaryItemCollection type exposes the following members.

Methods

Name | Description
Add | Overloaded.
AddNew | Adds a new item to the collection. (Inherited from BindingList <(Of <( NamespaceSummaryItem >)>).)
AddNewCore | Adds a new item to the end of the collection. (Inherited from BindingList <(Of <( NamespaceSummaryItem >)>).)
ApplySortCore | Sorts the items if overridden in a derived class; otherwise, throws a NotSupportedException. (Inherited from BindingList <(Of <( NamespaceSummaryItem >)>).)
CancelNew | Discards a pending new item. (Inherited from BindingList <(Of <( NamespaceSummaryItem >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( NamespaceSummaryItem >)>).)
ClearItems | Removes all elements from the collection. (Inherited from BindingList <(Of <( NamespaceSummaryItem >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( NamespaceSummaryItem >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <( NamespaceSummaryItem >)>).)
CreateTemporaryItem | Create a temporary item that isn't part of the project
EndNew | Commits a pending new item to the collection. (Inherited from BindingList <(Of <( NamespaceSummaryItem >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindCore | Searches for the index of the item that has the specified property descriptor with the specified value, if searching is implemented in a derived class; otherwise, a NotSupportedException. (Inherited from BindingList <(Of <( NamespaceSummaryItem >)>).)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( NamespaceSummaryItem >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection <(Of <( NamespaceSummaryItem >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( NamespaceSummaryItem >)>).)
InsertItem | Inserts the specified item in the list at the specified index. (Inherited from BindingList <(Of <( NamespaceSummaryItem >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnAddingNew | Raises the AddingNew event. (Inherited from BindingList <(Of <( NamespaceSummaryItem >)>).)
OnListChanged | This is overridden to mark the collection as dirty when it changes (Overrides BindingList<(Of <(T>)>)..::.OnListChanged(ListChangedEventArgs).)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( NamespaceSummaryItem >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( NamespaceSummaryItem >)>).)
RemoveItem | Removes the item at the specified index. (Inherited from BindingList <(Of <( NamespaceSummaryItem >)>).)
RemoveSortCore | Removes any sort applied with ApplySortCore(PropertyDescriptor, ListSortDirection) if sorting is implemented in a derived class; otherwise, raises NotSupportedException. (Inherited from BindingList <(Of <( NamespaceSummaryItem >)>).)
ResetBindings | Raises a ListChanged event of type Reset. (Inherited from BindingList <(Of <( NamespaceSummaryItem >)>).)
ResetItem | Raises a ListChanged event of type ItemChanged for the item at the specified position. (Inherited from BindingList <(Of <( NamespaceSummaryItem >)>).)
SetItem | Replaces the item at the specified index with the specified item. (Inherited from BindingList <(Of <( NamespaceSummaryItem >)>).)
Sort | This is used to sort the namespace items by name
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NamespaceSummaryItemCollection Class
SandcastleBuilder.Utils Namespace


Add Method

[image] [image]

Sandcastle Help File Builder Documentation
NamespaceSummaryItemCollection..::.Add Method
NamespaceSummaryItemCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Add(T) | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( NamespaceSummaryItem >)>).)
Add(String, Boolean, String) | Add a new item to the collection

See Also

NamespaceSummaryItemCollection Class
NamespaceSummaryItemCollection Members
SandcastleBuilder.Utils Namespace


Add Method (String, Boolean, String)

[image]

Sandcastle Help File Builder Documentation
NamespaceSummaryItemCollection..::.Add Method (String, Boolean, String)
NamespaceSummaryItemCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Add a new item to the collection

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public NamespaceSummaryItem Add(
    string name,
    bool isDocumented,
    string summary
)
Visual Basic (Declaration)
Public Function Add ( _
    name As String, _
    isDocumented As Boolean, _
    summary As String _
) As NamespaceSummaryItem

Parameters

name
Type: System..::.String
The namespace name
isDocumented
Type: System..::.Boolean
True for documented, false for not documented
summary
Type: System..::.String
The summary text

Return Value

The NamespaceSummaryItem added to the project. If the namespace already exists in the collection, the existing item is returned.

Remarks

The NamespaceSummaryItem constructor is internal so that we control creation of the items and can associate them with the project.

See Also

NamespaceSummaryItemCollection Class
Add Overload
SandcastleBuilder.Utils Namespace


CreateTemporaryItem Method

[image]

Sandcastle Help File Builder Documentation
NamespaceSummaryItemCollection..::.CreateTemporaryItem Method
NamespaceSummaryItemCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Create a temporary item that isn't part of the project

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public NamespaceSummaryItem CreateTemporaryItem(
    string name
)
Visual Basic (Declaration)
Public Function CreateTemporaryItem ( _
    name As String _
) As NamespaceSummaryItem

Parameters

name
Type: System..::.String
The namespace name

Return Value

The NamespaceSummaryItem that can later be added to the project if necessary.

Exceptions

Exception | Condition
System..::.ArgumentException | This is thrown if the given namespace already exists in the collection.

See Also

NamespaceSummaryItemCollection Class
SandcastleBuilder.Utils Namespace


OnListChanged Method

[image]

Sandcastle Help File Builder Documentation
NamespaceSummaryItemCollection..::.OnListChanged Method
NamespaceSummaryItemCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is overridden to mark the collection as dirty when it changes

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected override void OnListChanged(
    ListChangedEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnListChanged ( _
    e As ListChangedEventArgs _
)

Parameters

e
Type: System.ComponentModel..::.ListChangedEventArgs
The event arguments

See Also

NamespaceSummaryItemCollection Class
SandcastleBuilder.Utils Namespace


Sort Method

[image]

Sandcastle Help File Builder Documentation
NamespaceSummaryItemCollection..::.Sort Method
NamespaceSummaryItemCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to sort the namespace items by name

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public void Sort()
Visual Basic (Declaration)
Public Sub Sort

See Also

NamespaceSummaryItemCollection Class
SandcastleBuilder.Utils Namespace


NamespaceSummaryItemCollection Properties

[image] [image]

Sandcastle Help File Builder Documentation
NamespaceSummaryItemCollection Properties
NamespaceSummaryItemCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The NamespaceSummaryItemCollection type exposes the following members.

Properties

Name | Description
AllowEdit | Gets or sets a value indicating whether items in the list can be edited. (Inherited from BindingList <(Of <( NamespaceSummaryItem >)>).)
AllowNew | Gets or sets a value indicating whether you can add items to the list using the AddNew()()() method. (Inherited from BindingList <(Of <( NamespaceSummaryItem >)>).)
AllowRemove | Gets or sets a value indicating whether you can remove items from the collection. (Inherited from BindingList <(Of <( NamespaceSummaryItem >)>).)
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( NamespaceSummaryItem >)>).)
IsDirty | This is used to get or set the dirty state of the collection
IsSortedCore | Gets a value indicating whether the list is sorted. (Inherited from BindingList <(Of <( NamespaceSummaryItem >)>).)
Item | Overloaded.
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( NamespaceSummaryItem >)>).)
Project | This is used to get a reference to the project that owns the collection.
RaiseListChangedEvents | Gets or sets a value indicating whether adding or removing items within the list raises ListChanged events. (Inherited from BindingList <(Of <( NamespaceSummaryItem >)>).)
SortDirectionCore | Gets the direction the list is sorted. (Inherited from BindingList <(Of <( NamespaceSummaryItem >)>).)
SortPropertyCore | Gets the property descriptor that is used for sorting the list if sorting is implemented in a derived class; otherwise, returns null. (Inherited from BindingList <(Of <( NamespaceSummaryItem >)>).)
SupportsChangeNotificationCore | Gets a value indicating whether ListChanged events are enabled. (Inherited from BindingList <(Of <( NamespaceSummaryItem >)>).)
SupportsSearchingCore | Gets a value indicating whether the list supports searching. (Inherited from BindingList <(Of <( NamespaceSummaryItem >)>).)
SupportsSortingCore | Gets a value indicating whether the list supports sorting. (Inherited from BindingList <(Of <( NamespaceSummaryItem >)>).)

See Also

NamespaceSummaryItemCollection Class
SandcastleBuilder.Utils Namespace


IsDirty Property

[image]

Sandcastle Help File Builder Documentation
NamespaceSummaryItemCollection..::.IsDirty Property
NamespaceSummaryItemCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set the dirty state of the collection

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool IsDirty { get; set; }
Visual Basic (Declaration)
Public Property IsDirty As Boolean

See Also

NamespaceSummaryItemCollection Class
SandcastleBuilder.Utils Namespace


Item Property

[image] [image]

Sandcastle Help File Builder Documentation
NamespaceSummaryItemCollection..::.Item Property
NamespaceSummaryItemCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Item[([(Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection <(Of <( NamespaceSummaryItem >)>).)
Item[([(String])]) | Indexer. This can be used to retrieve the summary information for the specified namespace.

See Also

NamespaceSummaryItemCollection Class
NamespaceSummaryItemCollection Members
SandcastleBuilder.Utils Namespace


Item Property (String)

[image]

Sandcastle Help File Builder Documentation
NamespaceSummaryItemCollection..::.Item Property (String)
NamespaceSummaryItemCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Indexer. This can be used to retrieve the summary information for the specified namespace.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public NamespaceSummaryItem this[
    string name
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    name As String _
) As NamespaceSummaryItem

Parameters

name
Type: System..::.String
The namespace for which to search

Return Value

The namespace summary information if found or null if not found.

See Also

NamespaceSummaryItemCollection Class
Item Overload
SandcastleBuilder.Utils Namespace


Project Property

[image]

Sandcastle Help File Builder Documentation
NamespaceSummaryItemCollection..::.Project Property
NamespaceSummaryItemCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get a reference to the project that owns the collection.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public SandcastleProject Project { get; }
Visual Basic (Declaration)
Public ReadOnly Property Project As SandcastleProject

See Also

NamespaceSummaryItemCollection Class
SandcastleBuilder.Utils Namespace


NamespaceSummaryItemCollection Events

[image] [image]

Sandcastle Help File Builder Documentation
NamespaceSummaryItemCollection Events
NamespaceSummaryItemCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The NamespaceSummaryItemCollection type exposes the following members.

Events

Name | Description
AddingNew | Occurs before an item is added to the list. (Inherited from BindingList <(Of <( NamespaceSummaryItem >)>).)
ListChanged | Occurs when the list or an item in the list changes. (Inherited from BindingList <(Of <( NamespaceSummaryItem >)>).)

See Also

NamespaceSummaryItemCollection Class
SandcastleBuilder.Utils Namespace


NamingMethod Enumeration

[image]

Sandcastle Help File Builder Documentation
NamingMethod Enumeration
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This public enumerated type defines the naming method to use for the help topic filenames.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
[SerializableAttribute]
public enum NamingMethod
Visual Basic (Declaration)
<SerializableAttribute> _
Public Enumeration NamingMethod

Members

Member name | Description
Guid | Use the default GUID file naming method.
MemberName | Use the member name without parameters as the filename. The characters ":", ".", "#", and "`" in the name are replaced with an underscore (i.e. T:CustomType becomes T_CustomType, M:CustomType.#ctor becomes M_CustomType__ctor, P:CustomType.Property becomes P:CustomType_Property, etc). Duplicate names will have an incrementing value appended to the end of the name (i.e. M_CustomType_Method, M_CustomType.Method_1, M_CustomType_Method_2, etc).
HashedMemberName | Use the hashed member name without parameters as the filename. No character replacements are made for this option and the GetHashCode method is used to generate the hash value and it is formatted as a hex value. This is useful for extremely long type names that cause the filename to exceed the maximum length when the full path is included. Duplicate names will have an incrementing value appended to the name prior to creating the hash value as needed.

See Also

SandcastleBuilder.Utils Namespace


ProjectElement Class

[image]

Sandcastle Help File Builder Documentation
ProjectElement Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This class is a wrapper for build items in the project.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public sealed class ProjectElement
Visual Basic (Declaration)
Public NotInheritable Class ProjectElement

Inheritance Hierarchy

System..::.Object
SandcastleBuilder.Utils..::.ProjectElement

See Also

ProjectElement Members
SandcastleBuilder.Utils Namespace


ProjectElement Members

[image] [image]

Sandcastle Help File Builder Documentation
ProjectElement Members
ProjectElement Class Methods Fields Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ProjectElement type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::.GetHashCode()()().)
GetMetadata | Get a metadata value from a project element
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasMetadata | See if the named metadata item exists
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RemoveFromProjectFile | Remove the item from the project
SetMetadata | Set a metadata value in the project item
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Operators

Name | Description
Equality | Overload for equal operator
Inequality | Overload for not equal operator

Fields

Name | Description
AlternateText | Alternate text
BuildAction | Build action
Configuration | Configuration setting
CopyToMedia | Copy to media folder
ExcludeFromToc | Exclude from table of contents
Guid | Project COM object's GUID
HintPath | File reference hint path
ImageId | Image ID
IncludePath | Include item
LinkPath | Linked item path
Name | Project name item
OutDir | Output directory setting
Platform | Platform setting
ProjectGuid | Project GUID item
SolutionDir | Solution directory
SolutionExt | Solution extension
SolutionFileName | Solution filename (no path)
SolutionName | Solution name (no path or extension)
SolutionPath | Solution path (directory and filename)
SortOrder | Sort order
VersionMajor | Project COM object's major version
VersionMinor | Project COM object's minor version
WrapperTool | Project COM object's wrapper tool

Properties

Name | Description
Include | This is used to set or get the filename (Include attribute)
ItemName | This is used to set or get the item name (a.k.a BuildAction)
Project | This read-only property is used to get the containing project

See Also

ProjectElement Class
SandcastleBuilder.Utils Namespace


ProjectElement Fields

[image] [image]

Sandcastle Help File Builder Documentation
ProjectElement Fields
ProjectElement Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ProjectElement type exposes the following members.

Fields

Name | Description
AlternateText | Alternate text
BuildAction | Build action
Configuration | Configuration setting
CopyToMedia | Copy to media folder
ExcludeFromToc | Exclude from table of contents
Guid | Project COM object's GUID
HintPath | File reference hint path
ImageId | Image ID
IncludePath | Include item
LinkPath | Linked item path
Name | Project name item
OutDir | Output directory setting
Platform | Platform setting
ProjectGuid | Project GUID item
SolutionDir | Solution directory
SolutionExt | Solution extension
SolutionFileName | Solution filename (no path)
SolutionName | Solution name (no path or extension)
SolutionPath | Solution path (directory and filename)
SortOrder | Sort order
VersionMajor | Project COM object's major version
VersionMinor | Project COM object's minor version
WrapperTool | Project COM object's wrapper tool

See Also

ProjectElement Class
SandcastleBuilder.Utils Namespace


AlternateText Field

[image]

Sandcastle Help File Builder Documentation
ProjectElement..::.AlternateText Field
ProjectElement Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Alternate text

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public const string AlternateText
Visual Basic (Declaration)
Public Const AlternateText As String

See Also

ProjectElement Class
SandcastleBuilder.Utils Namespace


BuildAction Field

[image]

Sandcastle Help File Builder Documentation
ProjectElement..::.BuildAction Field
ProjectElement Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Build action

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public const string BuildAction
Visual Basic (Declaration)
Public Const BuildAction As String

See Also

ProjectElement Class
SandcastleBuilder.Utils Namespace


Configuration Field

[image]

Sandcastle Help File Builder Documentation
ProjectElement..::.Configuration Field
ProjectElement Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Configuration setting

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public const string Configuration
Visual Basic (Declaration)
Public Const Configuration As String

See Also

ProjectElement Class
SandcastleBuilder.Utils Namespace


CopyToMedia Field

[image]

Sandcastle Help File Builder Documentation
ProjectElement..::.CopyToMedia Field
ProjectElement Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Copy to media folder

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public const string CopyToMedia
Visual Basic (Declaration)
Public Const CopyToMedia As String

See Also

ProjectElement Class
SandcastleBuilder.Utils Namespace


ExcludeFromToc Field

[image]

Sandcastle Help File Builder Documentation
ProjectElement..::.ExcludeFromToc Field
ProjectElement Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Exclude from table of contents

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public const string ExcludeFromToc
Visual Basic (Declaration)
Public Const ExcludeFromToc As String

See Also

ProjectElement Class
SandcastleBuilder.Utils Namespace


Guid Field

[image]

Sandcastle Help File Builder Documentation
ProjectElement..::.Guid Field
ProjectElement Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Project COM object's GUID

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public const string Guid
Visual Basic (Declaration)
Public Const Guid As String

See Also

ProjectElement Class
SandcastleBuilder.Utils Namespace


HintPath Field

[image]

Sandcastle Help File Builder Documentation
ProjectElement..::.HintPath Field
ProjectElement Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

File reference hint path

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public const string HintPath
Visual Basic (Declaration)
Public Const HintPath As String

See Also

ProjectElement Class
SandcastleBuilder.Utils Namespace


ImageId Field

[image]

Sandcastle Help File Builder Documentation
ProjectElement..::.ImageId Field
ProjectElement Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Image ID

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public const string ImageId
Visual Basic (Declaration)
Public Const ImageId As String

See Also

ProjectElement Class
SandcastleBuilder.Utils Namespace


IncludePath Field

[image]

Sandcastle Help File Builder Documentation
ProjectElement..::.IncludePath Field
ProjectElement Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Include item

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public const string IncludePath
Visual Basic (Declaration)
Public Const IncludePath As String

See Also

ProjectElement Class
SandcastleBuilder.Utils Namespace


LinkPath Field

[image]

Sandcastle Help File Builder Documentation
ProjectElement..::.LinkPath Field
ProjectElement Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Linked item path

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public const string LinkPath
Visual Basic (Declaration)
Public Const LinkPath As String

See Also

ProjectElement Class
SandcastleBuilder.Utils Namespace


Name Field

[image]

Sandcastle Help File Builder Documentation
ProjectElement..::.Name Field
ProjectElement Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Project name item

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public const string Name
Visual Basic (Declaration)
Public Const Name As String

See Also

ProjectElement Class
SandcastleBuilder.Utils Namespace


OutDir Field

[image]

Sandcastle Help File Builder Documentation
ProjectElement..::.OutDir Field
ProjectElement Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Output directory setting

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public const string OutDir
Visual Basic (Declaration)
Public Const OutDir As String

See Also

ProjectElement Class
SandcastleBuilder.Utils Namespace


Platform Field

[image]

Sandcastle Help File Builder Documentation
ProjectElement..::.Platform Field
ProjectElement Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Platform setting

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public const string Platform
Visual Basic (Declaration)
Public Const Platform As String

See Also

ProjectElement Class
SandcastleBuilder.Utils Namespace


ProjectGuid Field

[image]

Sandcastle Help File Builder Documentation
ProjectElement..::.ProjectGuid Field
ProjectElement Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Project GUID item

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public const string ProjectGuid
Visual Basic (Declaration)
Public Const ProjectGuid As String

See Also

ProjectElement Class
SandcastleBuilder.Utils Namespace


SolutionDir Field

[image]

Sandcastle Help File Builder Documentation
ProjectElement..::.SolutionDir Field
ProjectElement Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Solution directory

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public const string SolutionDir
Visual Basic (Declaration)
Public Const SolutionDir As String

See Also

ProjectElement Class
SandcastleBuilder.Utils Namespace


SolutionExt Field

[image]

Sandcastle Help File Builder Documentation
ProjectElement..::.SolutionExt Field
ProjectElement Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Solution extension

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public const string SolutionExt
Visual Basic (Declaration)
Public Const SolutionExt As String

See Also

ProjectElement Class
SandcastleBuilder.Utils Namespace


SolutionFileName Field

[image]

Sandcastle Help File Builder Documentation
ProjectElement..::.SolutionFileName Field
ProjectElement Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Solution filename (no path)

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public const string SolutionFileName
Visual Basic (Declaration)
Public Const SolutionFileName As String

See Also

ProjectElement Class
SandcastleBuilder.Utils Namespace


SolutionName Field

[image]

Sandcastle Help File Builder Documentation
ProjectElement..::.SolutionName Field
ProjectElement Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Solution name (no path or extension)

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public const string SolutionName
Visual Basic (Declaration)
Public Const SolutionName As String

See Also

ProjectElement Class
SandcastleBuilder.Utils Namespace


SolutionPath Field

[image]

Sandcastle Help File Builder Documentation
ProjectElement..::.SolutionPath Field
ProjectElement Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Solution path (directory and filename)

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public const string SolutionPath
Visual Basic (Declaration)
Public Const SolutionPath As String

See Also

ProjectElement Class
SandcastleBuilder.Utils Namespace


SortOrder Field

[image]

Sandcastle Help File Builder Documentation
ProjectElement..::.SortOrder Field
ProjectElement Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Sort order

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public const string SortOrder
Visual Basic (Declaration)
Public Const SortOrder As String

See Also

ProjectElement Class
SandcastleBuilder.Utils Namespace


VersionMajor Field

[image]

Sandcastle Help File Builder Documentation
ProjectElement..::.VersionMajor Field
ProjectElement Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Project COM object's major version

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public const string VersionMajor
Visual Basic (Declaration)
Public Const VersionMajor As String

See Also

ProjectElement Class
SandcastleBuilder.Utils Namespace


VersionMinor Field

[image]

Sandcastle Help File Builder Documentation
ProjectElement..::.VersionMinor Field
ProjectElement Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Project COM object's minor version

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public const string VersionMinor
Visual Basic (Declaration)
Public Const VersionMinor As String

See Also

ProjectElement Class
SandcastleBuilder.Utils Namespace


WrapperTool Field

[image]

Sandcastle Help File Builder Documentation
ProjectElement..::.WrapperTool Field
ProjectElement Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Project COM object's wrapper tool

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public const string WrapperTool
Visual Basic (Declaration)
Public Const WrapperTool As String

See Also

ProjectElement Class
SandcastleBuilder.Utils Namespace


ProjectElement Methods

[image] [image]

Sandcastle Help File Builder Documentation
ProjectElement Methods
ProjectElement Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ProjectElement type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::.GetHashCode()()().)
GetMetadata | Get a metadata value from a project element
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasMetadata | See if the named metadata item exists
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RemoveFromProjectFile | Remove the item from the project
SetMetadata | Set a metadata value in the project item
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Operators

Name | Description
Equality | Overload for equal operator
Inequality | Overload for not equal operator

See Also

ProjectElement Class
SandcastleBuilder.Utils Namespace


Equality Operator

[image]

Sandcastle Help File Builder Documentation
ProjectElement..::.Equality Operator
ProjectElement Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload for equal operator

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public static bool operator ==(
    ProjectElement element1,
    ProjectElement element2
)
Visual Basic (Declaration)
Public Shared Operator = ( _
    element1 As ProjectElement, _
    element2 As ProjectElement _
) As Boolean

Parameters

element1
Type: SandcastleBuilder.Utils..::.ProjectElement
The first element object
element2
Type: SandcastleBuilder.Utils..::.ProjectElement
The second element object

Return Value

True if equal, false if not.

See Also

ProjectElement Class
SandcastleBuilder.Utils Namespace


Equals Method

[image]

Sandcastle Help File Builder Documentation
ProjectElement..::.Equals Method
ProjectElement Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Determines whether the specified Object is equal to the current Object.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::.Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Exceptions

Exception | Condition
System..::.NullReferenceException | The obj parameter is null.

See Also

ProjectElement Class
SandcastleBuilder.Utils Namespace


GetHashCode Method

[image]

Sandcastle Help File Builder Documentation
ProjectElement..::.GetHashCode Method
ProjectElement Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Serves as a hash function for a particular type.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer

Return Value

A hash code for the current Object.

See Also

ProjectElement Class
SandcastleBuilder.Utils Namespace


GetMetadata Method

[image]

Sandcastle Help File Builder Documentation
ProjectElement..::.GetMetadata Method
ProjectElement Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Get a metadata value from a project element

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string GetMetadata(
    string name
)
Visual Basic (Declaration)
Public Function GetMetadata ( _
    name As String _
) As String

Parameters

name
Type: System..::.String
The name of the metadata element to get

Return Value

The value of the metadata element

See Also

ProjectElement Class
SandcastleBuilder.Utils Namespace


HasMetadata Method

[image]

Sandcastle Help File Builder Documentation
ProjectElement..::.HasMetadata Method
ProjectElement Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

See if the named metadata item exists

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool HasMetadata(
    string name
)
Visual Basic (Declaration)
Public Function HasMetadata ( _
    name As String _
) As Boolean

Parameters

name
Type: System..::.String
The metadata name for which to check

Return Value

True if present, false if not

See Also

ProjectElement Class
SandcastleBuilder.Utils Namespace


Inequality Operator

[image]

Sandcastle Help File Builder Documentation
ProjectElement..::.Inequality Operator
ProjectElement Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload for not equal operator

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public static bool operator !=(
    ProjectElement element1,
    ProjectElement element2
)
Visual Basic (Declaration)
Public Shared Operator <> ( _
    element1 As ProjectElement, _
    element2 As ProjectElement _
) As Boolean

Parameters

element1
Type: SandcastleBuilder.Utils..::.ProjectElement
The first element object
element2
Type: SandcastleBuilder.Utils..::.ProjectElement
The second element object

Return Value

True if not equal, false if they are equal.

See Also

ProjectElement Class
SandcastleBuilder.Utils Namespace


RemoveFromProjectFile Method

[image]

Sandcastle Help File Builder Documentation
ProjectElement..::.RemoveFromProjectFile Method
ProjectElement Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Remove the item from the project

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public void RemoveFromProjectFile()
Visual Basic (Declaration)
Public Sub RemoveFromProjectFile

See Also

ProjectElement Class
SandcastleBuilder.Utils Namespace


SetMetadata Method

[image]

Sandcastle Help File Builder Documentation
ProjectElement..::.SetMetadata Method
ProjectElement Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Set a metadata value in the project item

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public void SetMetadata(
    string name,
    string value
)
Visual Basic (Declaration)
Public Sub SetMetadata ( _
    name As String, _
    value As String _
)

Parameters

name
Type: System..::.String
The name of the metadata element
value
Type: System..::.String
The value to store in the element

See Also

ProjectElement Class
SandcastleBuilder.Utils Namespace


ProjectElement Properties

[image] [image]

Sandcastle Help File Builder Documentation
ProjectElement Properties
ProjectElement Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ProjectElement type exposes the following members.

Properties

Name | Description
Include | This is used to set or get the filename (Include attribute)
ItemName | This is used to set or get the item name (a.k.a BuildAction)
Project | This read-only property is used to get the containing project

See Also

ProjectElement Class
SandcastleBuilder.Utils Namespace


Include Property

[image]

Sandcastle Help File Builder Documentation
ProjectElement..::.Include Property
ProjectElement Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to set or get the filename (Include attribute)

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string Include { get; set; }
Visual Basic (Declaration)
Public Property Include As String

See Also

ProjectElement Class
SandcastleBuilder.Utils Namespace


ItemName Property

[image]

Sandcastle Help File Builder Documentation
ProjectElement..::.ItemName Property
ProjectElement Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to set or get the item name (a.k.a BuildAction)

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string ItemName { get; set; }
Visual Basic (Declaration)
Public Property ItemName As String

See Also

ProjectElement Class
SandcastleBuilder.Utils Namespace


Project Property

[image]

Sandcastle Help File Builder Documentation
ProjectElement..::.Project Property
ProjectElement Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property is used to get the containing project

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public SandcastleProject Project { get; }
Visual Basic (Declaration)
Public ReadOnly Property Project As SandcastleProject

See Also

ProjectElement Class
SandcastleBuilder.Utils Namespace


ProjectLinkType Enumeration

[image]

Sandcastle Help File Builder Documentation
ProjectLinkType Enumeration
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This public enumerated type defines the type of links used to reference other help topics referring to items in the documented assemblies.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
[SerializableAttribute]
public enum ProjectLinkType
Visual Basic (Declaration)
<SerializableAttribute> _
Public Enumeration ProjectLinkType

Members

Member name | Description
None | No active links.
Local | Local links within the project using anchor tags. This is the default. This type is compatible with HTML 1.x and HTML 2.x help files.
Index | MS-Help style links for use within an HTML 2.x help file.

See Also

SandcastleBuilder.Utils Namespace


ProjectPropertyChangedEventArgs Class

[image]

Sandcastle Help File Builder Documentation
ProjectPropertyChangedEventArgs Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This event arguments class is used to specify which project property changed along with the old and new values.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public class ProjectPropertyChangedEventArgs : EventArgs
Visual Basic (Declaration)
Public Class ProjectPropertyChangedEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
SandcastleBuilder.Utils..::.ProjectPropertyChangedEventArgs

See Also

ProjectPropertyChangedEventArgs Members
SandcastleBuilder.Utils Namespace


ProjectPropertyChangedEventArgs Members

[image] [image]

Sandcastle Help File Builder Documentation
ProjectPropertyChangedEventArgs Members
ProjectPropertyChangedEventArgs Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ProjectPropertyChangedEventArgs type exposes the following members.

Constructors

Name | Description
ProjectPropertyChangedEventArgs | Constructor

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
NewValue | This read-only property returns the new value
OldValue | This read-only property returns the old value
PropertyName | This read-only property returns the property name

See Also

ProjectPropertyChangedEventArgs Class
SandcastleBuilder.Utils Namespace


ProjectPropertyChangedEventArgs Constructor

[image]

Sandcastle Help File Builder Documentation
ProjectPropertyChangedEventArgs Constructor
ProjectPropertyChangedEventArgs Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public ProjectPropertyChangedEventArgs(
    string name,
    string oldVal,
    string newVal
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    oldVal As String, _
    newVal As String _
)

Parameters

name
Type: System..::.String
The property name
oldVal
Type: System..::.String
The old value
newVal
Type: System..::.String
The new value

See Also

ProjectPropertyChangedEventArgs Class
SandcastleBuilder.Utils Namespace


ProjectPropertyChangedEventArgs Methods

[image] [image]

Sandcastle Help File Builder Documentation
ProjectPropertyChangedEventArgs Methods
ProjectPropertyChangedEventArgs Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ProjectPropertyChangedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProjectPropertyChangedEventArgs Class
SandcastleBuilder.Utils Namespace


ProjectPropertyChangedEventArgs Properties

[image] [image]

Sandcastle Help File Builder Documentation
ProjectPropertyChangedEventArgs Properties
ProjectPropertyChangedEventArgs Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ProjectPropertyChangedEventArgs type exposes the following members.

Properties

Name | Description
NewValue | This read-only property returns the new value
OldValue | This read-only property returns the old value
PropertyName | This read-only property returns the property name

See Also

ProjectPropertyChangedEventArgs Class
SandcastleBuilder.Utils Namespace


NewValue Property

[image]

Sandcastle Help File Builder Documentation
ProjectPropertyChangedEventArgs..::.NewValue Property
ProjectPropertyChangedEventArgs Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns the new value

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string NewValue { get; }
Visual Basic (Declaration)
Public ReadOnly Property NewValue As String

See Also

ProjectPropertyChangedEventArgs Class
SandcastleBuilder.Utils Namespace


OldValue Property

[image]

Sandcastle Help File Builder Documentation
ProjectPropertyChangedEventArgs..::.OldValue Property
ProjectPropertyChangedEventArgs Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns the old value

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string OldValue { get; }
Visual Basic (Declaration)
Public ReadOnly Property OldValue As String

See Also

ProjectPropertyChangedEventArgs Class
SandcastleBuilder.Utils Namespace


PropertyName Property

[image]

Sandcastle Help File Builder Documentation
ProjectPropertyChangedEventArgs..::.PropertyName Property
ProjectPropertyChangedEventArgs Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns the property name

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string PropertyName { get; }
Visual Basic (Declaration)
Public ReadOnly Property PropertyName As String

See Also

ProjectPropertyChangedEventArgs Class
SandcastleBuilder.Utils Namespace


ProjectReferenceItem Class

[image]

Sandcastle Help File Builder Documentation
ProjectReferenceItem Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This represents a project reference item that can be used by MRefBuilder to locate assembly dependencies for the assemblies being documented.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public class ProjectReferenceItem : ReferenceItem
Visual Basic (Declaration)
Public Class ProjectReferenceItem _
    Inherits ReferenceItem

Inheritance Hierarchy

System..::.Object
SandcastleBuilder.Utils..::.BaseBuildItem
SandcastleBuilder.Utils..::.ReferenceItem
SandcastleBuilder.Utils..::.ProjectReferenceItem

See Also

ProjectReferenceItem Members
SandcastleBuilder.Utils Namespace


ProjectReferenceItem Members

[image] [image]

Sandcastle Help File Builder Documentation
ProjectReferenceItem Members
ProjectReferenceItem Class Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ProjectReferenceItem type exposes the following members.

Methods

Name | Description
Equals | See if specified item equals this one by name alone (Inherited from ReferenceItem.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAttributes | Returns a collection of custom attributes for this instance of a component. (Inherited from ReferenceItem.)
GetClassName | Returns the class name of this instance of a component. (Inherited from ReferenceItem.)
GetComponentName | Returns the name of this instance of a component. (Inherited from ReferenceItem.)
GetConverter | Returns a type converter for this instance of a component. (Inherited from ReferenceItem.)
GetDefaultEvent | Returns the default event for this instance of a component. (Inherited from ReferenceItem.)
GetDefaultProperty | Returns the default property for this instance of a component. (Inherited from ReferenceItem.)
GetEditor | Returns an editor of the specified type for this instance of a component. (Inherited from ReferenceItem.)
GetEvents | Overloaded.
GetHashCode | Get a hash code for this item (Inherited from ReferenceItem.)
GetProperties | Overloaded.
GetPropertyOwner | Returns an object that contains the property described by the specified property descriptor. (Inherited from ReferenceItem.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Return a string representation of the item (Inherited from ReferenceItem.)

Properties

Name | Description
HintPath | Hint path isn't applicable to project references (Overrides ReferenceItem..::.HintPath.)
Name | This is used to get the project name
Project | This is used to get the project reference's GUID
ProjectElement | This returns the project element associated with the instance (Inherited from BaseBuildItem.)
ProjectPath | This is used to set or path to the project
Reference | This is overridden to return the project name rather than the file path. (Overrides ReferenceItem..::.Reference.)

See Also

ProjectReferenceItem Class
SandcastleBuilder.Utils Namespace


ProjectReferenceItem Methods

[image] [image]

Sandcastle Help File Builder Documentation
ProjectReferenceItem Methods
ProjectReferenceItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ProjectReferenceItem type exposes the following members.

Methods

Name | Description
Equals | See if specified item equals this one by name alone (Inherited from ReferenceItem.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAttributes | Returns a collection of custom attributes for this instance of a component. (Inherited from ReferenceItem.)
GetClassName | Returns the class name of this instance of a component. (Inherited from ReferenceItem.)
GetComponentName | Returns the name of this instance of a component. (Inherited from ReferenceItem.)
GetConverter | Returns a type converter for this instance of a component. (Inherited from ReferenceItem.)
GetDefaultEvent | Returns the default event for this instance of a component. (Inherited from ReferenceItem.)
GetDefaultProperty | Returns the default property for this instance of a component. (Inherited from ReferenceItem.)
GetEditor | Returns an editor of the specified type for this instance of a component. (Inherited from ReferenceItem.)
GetEvents | Overloaded.
GetHashCode | Get a hash code for this item (Inherited from ReferenceItem.)
GetProperties | Overloaded.
GetPropertyOwner | Returns an object that contains the property described by the specified property descriptor. (Inherited from ReferenceItem.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Return a string representation of the item (Inherited from ReferenceItem.)

See Also

ProjectReferenceItem Class
SandcastleBuilder.Utils Namespace


GetEvents Method

[image] [image]

Sandcastle Help File Builder Documentation
ProjectReferenceItem..::.GetEvents Method
ProjectReferenceItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetEvents()()() | Returns the events for this instance of a component. (Inherited from ReferenceItem.)
GetEvents(array<Attribute>[]()[]) | Returns the events for this instance of a component using the specified attribute array as a filter. (Inherited from ReferenceItem.)

See Also

ProjectReferenceItem Class
ProjectReferenceItem Members
SandcastleBuilder.Utils Namespace


GetProperties Method

[image] [image]

Sandcastle Help File Builder Documentation
ProjectReferenceItem..::.GetProperties Method
ProjectReferenceItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetProperties()()() | Returns the properties for this instance of a component. (Inherited from ReferenceItem.)
GetProperties(array<Attribute>[]()[]) | Returns the properties for this instance of a component using the attribute array as a filter. (Inherited from ReferenceItem.)

See Also

ProjectReferenceItem Class
ProjectReferenceItem Members
SandcastleBuilder.Utils Namespace


ProjectReferenceItem Properties

[image] [image]

Sandcastle Help File Builder Documentation
ProjectReferenceItem Properties
ProjectReferenceItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ProjectReferenceItem type exposes the following members.

Properties

Name | Description
HintPath | Hint path isn't applicable to project references (Overrides ReferenceItem..::.HintPath.)
Name | This is used to get the project name
Project | This is used to get the project reference's GUID
ProjectElement | This returns the project element associated with the instance (Inherited from BaseBuildItem.)
ProjectPath | This is used to set or path to the project
Reference | This is overridden to return the project name rather than the file path. (Overrides ReferenceItem..::.Reference.)

See Also

ProjectReferenceItem Class
SandcastleBuilder.Utils Namespace


HintPath Property

[image]

Sandcastle Help File Builder Documentation
ProjectReferenceItem..::.HintPath Property
ProjectReferenceItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Hint path isn't applicable to project references

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public override FilePath HintPath { get; set; }
Visual Basic (Declaration)
Public Overrides Property HintPath As FilePath

See Also

ProjectReferenceItem Class
SandcastleBuilder.Utils Namespace


Name Property

[image]

Sandcastle Help File Builder Documentation
ProjectReferenceItem..::.Name Property
ProjectReferenceItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get the project name

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String

See Also

ProjectReferenceItem Class
SandcastleBuilder.Utils Namespace


Project Property

[image]

Sandcastle Help File Builder Documentation
ProjectReferenceItem..::.Project Property
ProjectReferenceItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get the project reference's GUID

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string Project { get; }
Visual Basic (Declaration)
Public ReadOnly Property Project As String

See Also

ProjectReferenceItem Class
SandcastleBuilder.Utils Namespace


ProjectPath Property

[image]

Sandcastle Help File Builder Documentation
ProjectReferenceItem..::.ProjectPath Property
ProjectReferenceItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to set or path to the project

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public FilePath ProjectPath { get; set; }
Visual Basic (Declaration)
Public Property ProjectPath As FilePath

See Also

ProjectReferenceItem Class
SandcastleBuilder.Utils Namespace


Reference Property

[image]

Sandcastle Help File Builder Documentation
ProjectReferenceItem..::.Reference Property
ProjectReferenceItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is overridden to return the project name rather than the file path.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public override string Reference { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Reference As String

See Also

ProjectReferenceItem Class
SandcastleBuilder.Utils Namespace


PropertyBasedCollectionItem Class

[image]

Sandcastle Help File Builder Documentation
PropertyBasedCollectionItem Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is the base class for collection items that are stored in an MSBuild property element.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public abstract class PropertyBasedCollectionItem
Visual Basic (Declaration)
Public MustInherit Class PropertyBasedCollectionItem

Inheritance Hierarchy

System..::.Object
SandcastleBuilder.Utils..::.PropertyBasedCollectionItem
SandcastleBuilder.Utils.BuildComponent..::.BuildComponentConfiguration
SandcastleBuilder.Utils..::.DocumentationSource
SandcastleBuilder.Utils..::.MSHelpAttr
SandcastleBuilder.Utils..::.NamespaceSummaryItem
SandcastleBuilder.Utils.PlugIn..::.PlugInConfiguration

See Also

PropertyBasedCollectionItem Members
SandcastleBuilder.Utils Namespace


PropertyBasedCollectionItem Members

[image] [image]

Sandcastle Help File Builder Documentation
PropertyBasedCollectionItem Members
PropertyBasedCollectionItem Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PropertyBasedCollectionItem type exposes the following members.

Constructors

Name | Description
PropertyBasedCollectionItem | Constructor

Methods

Name | Description
CheckProjectIsEditable | This is used to see if the project can be edited. If not, abort the change by throwing an exception.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsDirty | This is used to get or set the dirty state of the item
ProjectFile | This is used to get the owning project file

See Also

PropertyBasedCollectionItem Class
SandcastleBuilder.Utils Namespace


PropertyBasedCollectionItem Constructor

[image]

Sandcastle Help File Builder Documentation
PropertyBasedCollectionItem Constructor
PropertyBasedCollectionItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected PropertyBasedCollectionItem(
    SandcastleProject project
)
Visual Basic (Declaration)
Protected Sub New ( _
    project As SandcastleProject _
)

Parameters

project
Type: SandcastleBuilder.Utils..::.SandcastleProject
The owning project

See Also

PropertyBasedCollectionItem Class
SandcastleBuilder.Utils Namespace


PropertyBasedCollectionItem Methods

[image] [image]

Sandcastle Help File Builder Documentation
PropertyBasedCollectionItem Methods
PropertyBasedCollectionItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PropertyBasedCollectionItem type exposes the following members.

Methods

Name | Description
CheckProjectIsEditable | This is used to see if the project can be edited. If not, abort the change by throwing an exception.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PropertyBasedCollectionItem Class
SandcastleBuilder.Utils Namespace


CheckProjectIsEditable Method

[image]

Sandcastle Help File Builder Documentation
PropertyBasedCollectionItem..::.CheckProjectIsEditable Method
PropertyBasedCollectionItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to see if the project can be edited. If not, abort the change by throwing an exception.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected void CheckProjectIsEditable()
Visual Basic (Declaration)
Protected Sub CheckProjectIsEditable

See Also

PropertyBasedCollectionItem Class
SandcastleBuilder.Utils Namespace


PropertyBasedCollectionItem Properties

[image] [image]

Sandcastle Help File Builder Documentation
PropertyBasedCollectionItem Properties
PropertyBasedCollectionItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PropertyBasedCollectionItem type exposes the following members.

Properties

Name | Description
IsDirty | This is used to get or set the dirty state of the item
ProjectFile | This is used to get the owning project file

See Also

PropertyBasedCollectionItem Class
SandcastleBuilder.Utils Namespace


IsDirty Property

[image]

Sandcastle Help File Builder Documentation
PropertyBasedCollectionItem..::.IsDirty Property
PropertyBasedCollectionItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set the dirty state of the item

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool IsDirty { get; set; }
Visual Basic (Declaration)
Public Property IsDirty As Boolean

See Also

PropertyBasedCollectionItem Class
SandcastleBuilder.Utils Namespace


ProjectFile Property

[image]

Sandcastle Help File Builder Documentation
PropertyBasedCollectionItem..::.ProjectFile Property
PropertyBasedCollectionItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get the owning project file

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public SandcastleProject ProjectFile { get; }
Visual Basic (Declaration)
Public ReadOnly Property ProjectFile As SandcastleProject

See Also

PropertyBasedCollectionItem Class
SandcastleBuilder.Utils Namespace


ReferenceItem Class

[image]

Sandcastle Help File Builder Documentation
ReferenceItem Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This represents a reference item that can be used by MRefBuilder to locate assembly dependencies for the assemblies being documented.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public class ReferenceItem : BaseBuildItem,
    ICustomTypeDescriptor
Visual Basic (Declaration)
Public Class ReferenceItem _
    Inherits BaseBuildItem _
    Implements ICustomTypeDescriptor

Inheritance Hierarchy

System..::.Object
SandcastleBuilder.Utils..::.BaseBuildItem
SandcastleBuilder.Utils..::.ReferenceItem
SandcastleBuilder.Utils..::.COMReferenceItem
SandcastleBuilder.Utils..::.ProjectReferenceItem

See Also

ReferenceItem Members
SandcastleBuilder.Utils Namespace


ReferenceItem Members

[image] [image]

Sandcastle Help File Builder Documentation
ReferenceItem Members
ReferenceItem Class Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ReferenceItem type exposes the following members.

Methods

Name | Description
Equals | See if specified item equals this one by name alone (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAttributes | Returns a collection of custom attributes for this instance of a component.
GetClassName | Returns the class name of this instance of a component.
GetComponentName | Returns the name of this instance of a component.
GetConverter | Returns a type converter for this instance of a component.
GetDefaultEvent | Returns the default event for this instance of a component.
GetDefaultProperty | Returns the default property for this instance of a component.
GetEditor | Returns an editor of the specified type for this instance of a component.
GetEvents | Overloaded.
GetHashCode | Get a hash code for this item (Overrides Object..::.GetHashCode()()().)
GetProperties | Overloaded.
GetPropertyOwner | Returns an object that contains the property described by the specified property descriptor.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Return a string representation of the item (Overrides Object..::.ToString()()().)

Properties

Name | Description
HintPath | This is used to set or path to the dependency
ProjectElement | This returns the project element associated with the instance (Inherited from BaseBuildItem.)
Reference | This is used to get the reference description

See Also

ReferenceItem Class
SandcastleBuilder.Utils Namespace


ReferenceItem Methods

[image] [image]

Sandcastle Help File Builder Documentation
ReferenceItem Methods
ReferenceItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ReferenceItem type exposes the following members.

Methods

Name | Description
Equals | See if specified item equals this one by name alone (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAttributes | Returns a collection of custom attributes for this instance of a component.
GetClassName | Returns the class name of this instance of a component.
GetComponentName | Returns the name of this instance of a component.
GetConverter | Returns a type converter for this instance of a component.
GetDefaultEvent | Returns the default event for this instance of a component.
GetDefaultProperty | Returns the default property for this instance of a component.
GetEditor | Returns an editor of the specified type for this instance of a component.
GetEvents | Overloaded.
GetHashCode | Get a hash code for this item (Overrides Object..::.GetHashCode()()().)
GetProperties | Overloaded.
GetPropertyOwner | Returns an object that contains the property described by the specified property descriptor.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Return a string representation of the item (Overrides Object..::.ToString()()().)

See Also

ReferenceItem Class
SandcastleBuilder.Utils Namespace


Equals Method

[image]

Sandcastle Help File Builder Documentation
ReferenceItem..::.Equals Method
ReferenceItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

See if specified item equals this one by name alone

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::.Object
The object to compare to this one

Return Value

True if equal, false if not

See Also

ReferenceItem Class
SandcastleBuilder.Utils Namespace


GetAttributes Method

[image]

Sandcastle Help File Builder Documentation
ReferenceItem..::.GetAttributes Method
ReferenceItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Returns a collection of custom attributes for this instance of a component.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public AttributeCollection GetAttributes()
Visual Basic (Declaration)
Public Function GetAttributes As AttributeCollection

Return Value

An AttributeCollection containing the attributes for this object.

Implements

ICustomTypeDescriptor..::.GetAttributes()()()

See Also

ReferenceItem Class
SandcastleBuilder.Utils Namespace


GetClassName Method

[image]

Sandcastle Help File Builder Documentation
ReferenceItem..::.GetClassName Method
ReferenceItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Returns the class name of this instance of a component.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string GetClassName()
Visual Basic (Declaration)
Public Function GetClassName As String

Return Value

The class name of the object, or null if the class does not have a name.

Implements

ICustomTypeDescriptor..::.GetClassName()()()

See Also

ReferenceItem Class
SandcastleBuilder.Utils Namespace


GetComponentName Method

[image]

Sandcastle Help File Builder Documentation
ReferenceItem..::.GetComponentName Method
ReferenceItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Returns the name of this instance of a component.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string GetComponentName()
Visual Basic (Declaration)
Public Function GetComponentName As String

Return Value

The name of the object, or null if the object does not have a name.

Implements

ICustomTypeDescriptor..::.GetComponentName()()()

See Also

ReferenceItem Class
SandcastleBuilder.Utils Namespace


GetConverter Method

[image]

Sandcastle Help File Builder Documentation
ReferenceItem..::.GetConverter Method
ReferenceItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Returns a type converter for this instance of a component.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public TypeConverter GetConverter()
Visual Basic (Declaration)
Public Function GetConverter As TypeConverter

Return Value

A TypeConverter that is the converter for this object, or null if there is no TypeConverter for this object.

Implements

ICustomTypeDescriptor..::.GetConverter()()()

See Also

ReferenceItem Class
SandcastleBuilder.Utils Namespace


GetDefaultEvent Method

[image]

Sandcastle Help File Builder Documentation
ReferenceItem..::.GetDefaultEvent Method
ReferenceItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Returns the default event for this instance of a component.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public EventDescriptor GetDefaultEvent()
Visual Basic (Declaration)
Public Function GetDefaultEvent As EventDescriptor

Return Value

An EventDescriptor that represents the default event for this object, or null if this object does not have events.

Implements

ICustomTypeDescriptor..::.GetDefaultEvent()()()

See Also

ReferenceItem Class
SandcastleBuilder.Utils Namespace


GetDefaultProperty Method

[image]

Sandcastle Help File Builder Documentation
ReferenceItem..::.GetDefaultProperty Method
ReferenceItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Returns the default property for this instance of a component.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public PropertyDescriptor GetDefaultProperty()
Visual Basic (Declaration)
Public Function GetDefaultProperty As PropertyDescriptor

Return Value

A PropertyDescriptor that represents the default property for this object, or null if this object does not have properties.

Implements

ICustomTypeDescriptor..::.GetDefaultProperty()()()

See Also

ReferenceItem Class
SandcastleBuilder.Utils Namespace


GetEditor Method

[image]

Sandcastle Help File Builder Documentation
ReferenceItem..::.GetEditor Method
ReferenceItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Returns an editor of the specified type for this instance of a component.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public Object GetEditor(
    Type editorBaseType
)
Visual Basic (Declaration)
Public Function GetEditor ( _
    editorBaseType As Type _
) As Object

Parameters

editorBaseType
Type: System..::.Type
A Type that represents the editor for this object.

Return Value

An Object of the specified type that is the editor for this object, or null if the editor cannot be found.

Implements

ICustomTypeDescriptor..::.GetEditor(Type)

See Also

ReferenceItem Class
SandcastleBuilder.Utils Namespace


GetEvents Method

[image] [image]

Sandcastle Help File Builder Documentation
ReferenceItem..::.GetEvents Method
ReferenceItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetEvents()()() | Returns the events for this instance of a component.
GetEvents(array<Attribute>[]()[]) | Returns the events for this instance of a component using the specified attribute array as a filter.

See Also

ReferenceItem Class
ReferenceItem Members
SandcastleBuilder.Utils Namespace


GetEvents Method

[image]

Sandcastle Help File Builder Documentation
ReferenceItem..::.GetEvents Method
ReferenceItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Returns the events for this instance of a component.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public EventDescriptorCollection GetEvents()
Visual Basic (Declaration)
Public Function GetEvents As EventDescriptorCollection

Return Value

An EventDescriptorCollection that represents the events for this component instance.

Implements

ICustomTypeDescriptor..::.GetEvents()()()

See Also

ReferenceItem Class
GetEvents Overload
SandcastleBuilder.Utils Namespace


GetEvents Method (Attribute[])

[image]

Sandcastle Help File Builder Documentation
ReferenceItem..::.GetEvents Method (array<Attribute>[]()[])
ReferenceItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Returns the events for this instance of a component using the specified attribute array as a filter.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public EventDescriptorCollection GetEvents(
    Attribute[] attributes
)
Visual Basic (Declaration)
Public Function GetEvents ( _
    attributes As Attribute() _
) As EventDescriptorCollection

Parameters

attributes
Type: array< System..::.Attribute >[]()[]
An array of type Attribute that is used as a filter.

Return Value

An EventDescriptorCollection that represents the filtered events for this component instance.

Implements

ICustomTypeDescriptor..::.GetEvents(array<Attribute>[]()[])

See Also

ReferenceItem Class
GetEvents Overload
SandcastleBuilder.Utils Namespace


GetHashCode Method

[image]

Sandcastle Help File Builder Documentation
ReferenceItem..::.GetHashCode Method
ReferenceItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Get a hash code for this item

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer

Return Value

Returns the hash code for the assembly path and XML comments path.

See Also

ReferenceItem Class
SandcastleBuilder.Utils Namespace


GetProperties Method

[image] [image]

Sandcastle Help File Builder Documentation
ReferenceItem..::.GetProperties Method
ReferenceItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetProperties()()() | Returns the properties for this instance of a component.
GetProperties(array<Attribute>[]()[]) | Returns the properties for this instance of a component using the attribute array as a filter.

See Also

ReferenceItem Class
ReferenceItem Members
SandcastleBuilder.Utils Namespace


GetProperties Method

[image]

Sandcastle Help File Builder Documentation
ReferenceItem..::.GetProperties Method
ReferenceItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Returns the properties for this instance of a component.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public PropertyDescriptorCollection GetProperties()
Visual Basic (Declaration)
Public Function GetProperties As PropertyDescriptorCollection

Return Value

A PropertyDescriptorCollection that represents the properties for this component instance.

Implements

ICustomTypeDescriptor..::.GetProperties()()()

See Also

ReferenceItem Class
GetProperties Overload
SandcastleBuilder.Utils Namespace


GetProperties Method (Attribute[])

[image]

Sandcastle Help File Builder Documentation
ReferenceItem..::.GetProperties Method (array<Attribute>[]()[])
ReferenceItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Returns the properties for this instance of a component using the attribute array as a filter.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public PropertyDescriptorCollection GetProperties(
    Attribute[] attributes
)
Visual Basic (Declaration)
Public Function GetProperties ( _
    attributes As Attribute() _
) As PropertyDescriptorCollection

Parameters

attributes
Type: array< System..::.Attribute >[]()[]
An array of type Attribute that is used as a filter.

Return Value

A PropertyDescriptorCollection that represents the filtered properties for this component instance.

Implements

ICustomTypeDescriptor..::.GetProperties(array<Attribute>[]()[])

See Also

ReferenceItem Class
GetProperties Overload
SandcastleBuilder.Utils Namespace


GetPropertyOwner Method

[image]

Sandcastle Help File Builder Documentation
ReferenceItem..::.GetPropertyOwner Method
ReferenceItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Returns an object that contains the property described by the specified property descriptor.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public Object GetPropertyOwner(
    PropertyDescriptor pd
)
Visual Basic (Declaration)
Public Function GetPropertyOwner ( _
    pd As PropertyDescriptor _
) As Object

Parameters

pd
Type: System.ComponentModel..::.PropertyDescriptor
A PropertyDescriptor that represents the property whose owner is to be found.

Return Value

An Object that represents the owner of the specified property.

Implements

ICustomTypeDescriptor..::.GetPropertyOwner(PropertyDescriptor)

See Also

ReferenceItem Class
SandcastleBuilder.Utils Namespace


ToString Method

[image]

Sandcastle Help File Builder Documentation
ReferenceItem..::.ToString Method
ReferenceItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Return a string representation of the item

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

Return Value

Returns the assembly path and XML comments path separated by a comma.

See Also

ReferenceItem Class
SandcastleBuilder.Utils Namespace


ReferenceItem Properties

[image] [image]

Sandcastle Help File Builder Documentation
ReferenceItem Properties
ReferenceItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ReferenceItem type exposes the following members.

Properties

Name | Description
HintPath | This is used to set or path to the dependency
ProjectElement | This returns the project element associated with the instance (Inherited from BaseBuildItem.)
Reference | This is used to get the reference description

See Also

ReferenceItem Class
SandcastleBuilder.Utils Namespace


HintPath Property

[image]

Sandcastle Help File Builder Documentation
ReferenceItem..::.HintPath Property
ReferenceItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to set or path to the dependency

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public virtual FilePath HintPath { get; set; }
Visual Basic (Declaration)
Public Overridable Property HintPath As FilePath

Field Value

For GAC dependencies, this should be null.

See Also

ReferenceItem Class
SandcastleBuilder.Utils Namespace


Reference Property

[image]

Sandcastle Help File Builder Documentation
ReferenceItem..::.Reference Property
ReferenceItem Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get the reference description

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public virtual string Reference { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Reference As String

See Also

ReferenceItem Class
SandcastleBuilder.Utils Namespace


ReferenceItemCollection Class

[image]

Sandcastle Help File Builder Documentation
ReferenceItemCollection Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This collection class is used to hold the reference items for a project

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public class ReferenceItemCollection : BindingList<ReferenceItem>
Visual Basic (Declaration)
Public Class ReferenceItemCollection _
    Inherits BindingList(Of ReferenceItem)

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection <(Of <( ReferenceItem >)>)
System.ComponentModel..::.BindingList <(Of <( ReferenceItem >)>)
SandcastleBuilder.Utils..::.ReferenceItemCollection

See Also

ReferenceItemCollection Members
SandcastleBuilder.Utils Namespace


ReferenceItemCollection Members

[image] [image]

Sandcastle Help File Builder Documentation
ReferenceItemCollection Members
ReferenceItemCollection Class Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ReferenceItemCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ReferenceItem >)>).)
AddNew | Adds a new item to the collection. (Inherited from BindingList <(Of <( ReferenceItem >)>).)
AddNewCore | Adds a new item to the end of the collection. (Inherited from BindingList <(Of <( ReferenceItem >)>).)
AddProjectReference | Add a new project reference item to the collection
AddReference | Add a new GAC or file reference item to the collection
ApplySortCore | Sorts the items if overridden in a derived class; otherwise, throws a NotSupportedException. (Inherited from BindingList <(Of <( ReferenceItem >)>).)
CancelNew | Discards a pending new item. (Inherited from BindingList <(Of <( ReferenceItem >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ReferenceItem >)>).)
ClearItems | Removes all elements from the collection. (Inherited from BindingList <(Of <( ReferenceItem >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ReferenceItem >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <( ReferenceItem >)>).)
EndNew | Commits a pending new item to the collection. (Inherited from BindingList <(Of <( ReferenceItem >)>).)
EnsureCurrent | This is used to ensure that the collection has up to date information about the reference build items in the project.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindCore | Searches for the index of the item that has the specified property descriptor with the specified value, if searching is implemented in a derived class; otherwise, a NotSupportedException. (Inherited from BindingList <(Of <( ReferenceItem >)>).)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ReferenceItem >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ReferenceItem >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( ReferenceItem >)>).)
InsertItem | Inserts the specified item in the list at the specified index. (Inherited from BindingList <(Of <( ReferenceItem >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnAddingNew | Raises the AddingNew event. (Inherited from BindingList <(Of <( ReferenceItem >)>).)
OnListChanged | This is overridden to suppress the event when loading references (Overrides BindingList<(Of <(T>)>)..::.OnListChanged(ListChangedEventArgs).)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ReferenceItem >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ReferenceItem >)>).)
RemoveItem | Remove an item from the collection and from the project file (Overrides BindingList<(Of <(T>)>)..::.RemoveItem(Int32).)
RemoveSortCore | Removes any sort applied with ApplySortCore(PropertyDescriptor, ListSortDirection) if sorting is implemented in a derived class; otherwise, raises NotSupportedException. (Inherited from BindingList <(Of <( ReferenceItem >)>).)
ResetBindings | Raises a ListChanged event of type Reset. (Inherited from BindingList <(Of <( ReferenceItem >)>).)
ResetItem | Raises a ListChanged event of type ItemChanged for the item at the specified position. (Inherited from BindingList <(Of <( ReferenceItem >)>).)
SetItem | Replaces the item at the specified index with the specified item. (Inherited from BindingList <(Of <( ReferenceItem >)>).)
Sort | This is used to sort the collection in ascending order.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AllowEdit | Gets or sets a value indicating whether items in the list can be edited. (Inherited from BindingList <(Of <( ReferenceItem >)>).)
AllowNew | Gets or sets a value indicating whether you can add items to the list using the AddNew()()() method. (Inherited from BindingList <(Of <( ReferenceItem >)>).)
AllowRemove | Gets or sets a value indicating whether you can remove items from the collection. (Inherited from BindingList <(Of <( ReferenceItem >)>).)
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ReferenceItem >)>).)
IsSortedCore | Gets a value indicating whether the list is sorted. (Inherited from BindingList <(Of <( ReferenceItem >)>).)
Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <( ReferenceItem >)>).)
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ReferenceItem >)>).)
RaiseListChangedEvents | Gets or sets a value indicating whether adding or removing items within the list raises ListChanged events. (Inherited from BindingList <(Of <( ReferenceItem >)>).)
SortDirectionCore | Gets the direction the list is sorted. (Inherited from BindingList <(Of <( ReferenceItem >)>).)
SortPropertyCore | Gets the property descriptor that is used for sorting the list if sorting is implemented in a derived class; otherwise, returns null. (Inherited from BindingList <(Of <( ReferenceItem >)>).)
SupportsChangeNotificationCore | Gets a value indicating whether ListChanged events are enabled. (Inherited from BindingList <(Of <( ReferenceItem >)>).)
SupportsSearchingCore | Gets a value indicating whether the list supports searching. (Inherited from BindingList <(Of <( ReferenceItem >)>).)
SupportsSortingCore | Gets a value indicating whether the list supports sorting. (Inherited from BindingList <(Of <( ReferenceItem >)>).)

Events

Name | Description
AddingNew | Occurs before an item is added to the list. (Inherited from BindingList <(Of <( ReferenceItem >)>).)
ListChanged | Occurs when the list or an item in the list changes. (Inherited from BindingList <(Of <( ReferenceItem >)>).)

See Also

ReferenceItemCollection Class
SandcastleBuilder.Utils Namespace


ReferenceItemCollection Methods

[image] [image]

Sandcastle Help File Builder Documentation
ReferenceItemCollection Methods
ReferenceItemCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ReferenceItemCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ReferenceItem >)>).)
AddNew | Adds a new item to the collection. (Inherited from BindingList <(Of <( ReferenceItem >)>).)
AddNewCore | Adds a new item to the end of the collection. (Inherited from BindingList <(Of <( ReferenceItem >)>).)
AddProjectReference | Add a new project reference item to the collection
AddReference | Add a new GAC or file reference item to the collection
ApplySortCore | Sorts the items if overridden in a derived class; otherwise, throws a NotSupportedException. (Inherited from BindingList <(Of <( ReferenceItem >)>).)
CancelNew | Discards a pending new item. (Inherited from BindingList <(Of <( ReferenceItem >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ReferenceItem >)>).)
ClearItems | Removes all elements from the collection. (Inherited from BindingList <(Of <( ReferenceItem >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ReferenceItem >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <( ReferenceItem >)>).)
EndNew | Commits a pending new item to the collection. (Inherited from BindingList <(Of <( ReferenceItem >)>).)
EnsureCurrent | This is used to ensure that the collection has up to date information about the reference build items in the project.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindCore | Searches for the index of the item that has the specified property descriptor with the specified value, if searching is implemented in a derived class; otherwise, a NotSupportedException. (Inherited from BindingList <(Of <( ReferenceItem >)>).)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ReferenceItem >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ReferenceItem >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( ReferenceItem >)>).)
InsertItem | Inserts the specified item in the list at the specified index. (Inherited from BindingList <(Of <( ReferenceItem >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnAddingNew | Raises the AddingNew event. (Inherited from BindingList <(Of <( ReferenceItem >)>).)
OnListChanged | This is overridden to suppress the event when loading references (Overrides BindingList<(Of <(T>)>)..::.OnListChanged(ListChangedEventArgs).)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ReferenceItem >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ReferenceItem >)>).)
RemoveItem | Remove an item from the collection and from the project file (Overrides BindingList<(Of <(T>)>)..::.RemoveItem(Int32).)
RemoveSortCore | Removes any sort applied with ApplySortCore(PropertyDescriptor, ListSortDirection) if sorting is implemented in a derived class; otherwise, raises NotSupportedException. (Inherited from BindingList <(Of <( ReferenceItem >)>).)
ResetBindings | Raises a ListChanged event of type Reset. (Inherited from BindingList <(Of <( ReferenceItem >)>).)
ResetItem | Raises a ListChanged event of type ItemChanged for the item at the specified position. (Inherited from BindingList <(Of <( ReferenceItem >)>).)
SetItem | Replaces the item at the specified index with the specified item. (Inherited from BindingList <(Of <( ReferenceItem >)>).)
Sort | This is used to sort the collection in ascending order.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReferenceItemCollection Class
SandcastleBuilder.Utils Namespace


AddProjectReference Method

[image]

Sandcastle Help File Builder Documentation
ReferenceItemCollection..::.AddProjectReference Method
ReferenceItemCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Add a new project reference item to the collection

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public ProjectReferenceItem AddProjectReference(
    string projectPath
)
Visual Basic (Declaration)
Public Function AddProjectReference ( _
    projectPath As String _
) As ProjectReferenceItem

Parameters

projectPath
Type: System..::.String
The path to the project

Return Value

The ProjectReferenceItem added to the project. If the named item already exists in the collection a reference to the existing item is returned.

See Also

ReferenceItemCollection Class
SandcastleBuilder.Utils Namespace


AddReference Method

[image]

Sandcastle Help File Builder Documentation
ReferenceItemCollection..::.AddReference Method
ReferenceItemCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Add a new GAC or file reference item to the collection

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public ReferenceItem AddReference(
    string referenceName,
    string hintPath
)
Visual Basic (Declaration)
Public Function AddReference ( _
    referenceName As String, _
    hintPath As String _
) As ReferenceItem

Parameters

referenceName
Type: System..::.String
The reference name. This will be the GAC name or the base filename for file reference.
hintPath
Type: System..::.String
The hint path for file references. For GAC references, this should be null.

Return Value

The ReferenceItem added to the project. If the named item already exists in the collection a reference to the existing item is returned.

Remarks

The ReferenceItem constructor is internal so that we control creation of the items and can associate them with a project element.

See Also

ReferenceItemCollection Class
SandcastleBuilder.Utils Namespace


EnsureCurrent Method

[image]

Sandcastle Help File Builder Documentation
ReferenceItemCollection..::.EnsureCurrent Method
ReferenceItemCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to ensure that the collection has up to date information about the reference build items in the project.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public void EnsureCurrent(
    bool refresh
)
Visual Basic (Declaration)
Public Sub EnsureCurrent ( _
    refresh As Boolean _
)

Parameters

refresh
Type: System..::.Boolean
True to refresh if out of date or false to only load the references if not already done.

Remarks

The collection is only loaded when necessary

See Also

ReferenceItemCollection Class
SandcastleBuilder.Utils Namespace


OnListChanged Method

[image]

Sandcastle Help File Builder Documentation
ReferenceItemCollection..::.OnListChanged Method
ReferenceItemCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is overridden to suppress the event when loading references

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected override void OnListChanged(
    ListChangedEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnListChanged ( _
    e As ListChangedEventArgs _
)

Parameters

e
Type: System.ComponentModel..::.ListChangedEventArgs
The event arguments

See Also

ReferenceItemCollection Class
SandcastleBuilder.Utils Namespace


RemoveItem Method

[image]

Sandcastle Help File Builder Documentation
ReferenceItemCollection..::.RemoveItem Method
ReferenceItemCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Remove an item from the collection and from the project file

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected override void RemoveItem(
    int index
)
Visual Basic (Declaration)
Protected Overrides Sub RemoveItem ( _
    index As Integer _
)

Parameters

index
Type: System..::.Int32
The index of the item to remove

See Also

ReferenceItemCollection Class
SandcastleBuilder.Utils Namespace


Sort Method

[image]

Sandcastle Help File Builder Documentation
ReferenceItemCollection..::.Sort Method
ReferenceItemCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to sort the collection in ascending order.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public void Sort()
Visual Basic (Declaration)
Public Sub Sort

See Also

ReferenceItemCollection Class
SandcastleBuilder.Utils Namespace


ReferenceItemCollection Properties

[image] [image]

Sandcastle Help File Builder Documentation
ReferenceItemCollection Properties
ReferenceItemCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ReferenceItemCollection type exposes the following members.

Properties

Name | Description
AllowEdit | Gets or sets a value indicating whether items in the list can be edited. (Inherited from BindingList <(Of <( ReferenceItem >)>).)
AllowNew | Gets or sets a value indicating whether you can add items to the list using the AddNew()()() method. (Inherited from BindingList <(Of <( ReferenceItem >)>).)
AllowRemove | Gets or sets a value indicating whether you can remove items from the collection. (Inherited from BindingList <(Of <( ReferenceItem >)>).)
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ReferenceItem >)>).)
IsSortedCore | Gets a value indicating whether the list is sorted. (Inherited from BindingList <(Of <( ReferenceItem >)>).)
Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <( ReferenceItem >)>).)
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ReferenceItem >)>).)
RaiseListChangedEvents | Gets or sets a value indicating whether adding or removing items within the list raises ListChanged events. (Inherited from BindingList <(Of <( ReferenceItem >)>).)
SortDirectionCore | Gets the direction the list is sorted. (Inherited from BindingList <(Of <( ReferenceItem >)>).)
SortPropertyCore | Gets the property descriptor that is used for sorting the list if sorting is implemented in a derived class; otherwise, returns null. (Inherited from BindingList <(Of <( ReferenceItem >)>).)
SupportsChangeNotificationCore | Gets a value indicating whether ListChanged events are enabled. (Inherited from BindingList <(Of <( ReferenceItem >)>).)
SupportsSearchingCore | Gets a value indicating whether the list supports searching. (Inherited from BindingList <(Of <( ReferenceItem >)>).)
SupportsSortingCore | Gets a value indicating whether the list supports sorting. (Inherited from BindingList <(Of <( ReferenceItem >)>).)

See Also

ReferenceItemCollection Class
SandcastleBuilder.Utils Namespace


ReferenceItemCollection Events

[image] [image]

Sandcastle Help File Builder Documentation
ReferenceItemCollection Events
ReferenceItemCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ReferenceItemCollection type exposes the following members.

Events

Name | Description
AddingNew | Occurs before an item is added to the list. (Inherited from BindingList <(Of <( ReferenceItem >)>).)
ListChanged | Occurs when the list or an item in the list changes. (Inherited from BindingList <(Of <( ReferenceItem >)>).)

See Also

ReferenceItemCollection Class
SandcastleBuilder.Utils Namespace


SandcastleProject Class

[image]

Sandcastle Help File Builder Documentation
SandcastleProject Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This class represents all of the properties that make up a Sandcastle Help File Builder project.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public class SandcastleProject : IBasePathProvider
Visual Basic (Declaration)
Public Class SandcastleProject _
    Implements IBasePathProvider

Inheritance Hierarchy

System..::.Object
SandcastleBuilder.Utils..::.SandcastleProject

See Also

SandcastleProject Members
SandcastleBuilder.Utils Namespace


SandcastleProject Members

[image] [image]

Sandcastle Help File Builder Documentation
SandcastleProject Members
SandcastleProject Class Constructors Methods Fields Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SandcastleProject type exposes the following members.

Constructors

Name | Description
SandcastleProject | Overloaded. There are five overloads for the constructor

Methods

Name | Description
AddFileToProject | Add a new file build item to the project
AddFolderToProject | Add a new folder build item to the project
DefaultBuildAction | This is used to determine the default build action for a file based on its extension.
EnsureProjectIsCurrent | This is used to ensure that all local collection project properties have been stored in the MSBuild project file and that path-type properties are current based on the current project location.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindFile | This is used to locate a file by name in the project
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasItems | This returns true if the project contains items using the given build action.
MarkAsDirty | This is used to mark the project as dirty and in need of being saved.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnDirtyChanged | This raises the DirtyChanged event.
OnDocumentationSourcesChanged | This raises the DocumentationSourcesChanged event.
OnProjectPropertyChanged | This raises the ProjectPropertyChanged event.
OnQueryEditProjectFile | This raises the QueryEditProjectFile event.
SaveProject | This is used to save the project file
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
DefaultConfiguration | The default configuration
DefaultPlatform | The default platform

Properties

Name | Description
ApiFilter | This is used to get the API filter collection.
AutoDocumentConstructors | This is used to get or set whether or not constructors are automatically documented if they are missing the <summary> tag and for classes with compiler generated constructors.
BasePath | This read-only property returns the base path
BinaryTOC | This is used to set or get the path to the Sandcastle components
BuildLogFile | This is used to set or get the path and filename of the build log file.
CleanIntermediates | This is used to set or get whether intermediate files are deleted after a successful build.
CollectionTocStyle | This is used to set or get the collection table of contents style used when plugged into an HTML Help 2 collection.
ComponentConfigurations | This is used to get a dictionary of build component configurations.
Configuration | This is used to get or set the configuration to use when building the project.
ContentPlacement | This is used to set or get the placement of any additional and conceptual content items in the table of contents.
CopyrightHref | This is used to set or get the URL to use as the link for the copyright notice.
CopyrightText | This is used to set or get the copyright notice that appears in the footer of each page.
CppCommentsFixup | This is used to set or get whether to fix-up the XML comments files to work around an issue with those generated by the C++ compiler.
DecodedCopyrightText | This is used to get the copyright notice that appears in the footer of each page with any hex value place holders replaced with their actual character.
DocumentationSources | Returns the list of documentation sources to use in building the help file.
DocumentAttributes | This is used to get or set whether or not attributes on types and members are documented in the syntax portion of the help file.
DocumentExplicitInterfaceImplementations | This is used to get or set whether or not explicit interface implementations are documented.
DocumentInheritedFrameworkInternalMembers | This is used to get or set whether or not inherited internal framework members are documented.
DocumentInheritedFrameworkMembers | This is used to get or set whether or not inherited framework members are documented.
DocumentInheritedFrameworkPrivateMembers | This is used to get or set whether or not inherited private framework members are documented.
DocumentInheritedMembers | This is used to get or set whether or not inherited members are documented.
DocumentInternals | This is used to get or set whether or not internal members are documented in the help file.
DocumentPrivateFields | This is used to get or set whether or not private fields are documented in the help file.
DocumentPrivates | This is used to get or set whether or not private members are documented in the help file.
DocumentProtected | This is used to get or set whether or not protected members are documented in the help file.
DocumentProtectedInternalAsProtected | This is used to get or set whether or not "protected internal" members are documented as "protected" only in the help file.
DocumentSealedProtected | This is used to get or set whether or not protected members of sealed classes are documented in the help file.
FeedbackEMailAddress | This is used to set or get the feedback e-mail address that appears in the footer of each page.
FeedbackEMailLinkText | This is used to set or get the feedback e-mail link text that appears in the feedback e-mail link in the footer of each page.
FileItems | This returns a collection of all build items in the project that represent folders and files.
Filename | This read-only property is used to get the filename for the project
FooterText | This is used to set or get additional text that should appear in the footer of every page.
FrameworkVersion | This is used to set or get the .NET Framework version to which the documentation links for system types should point.
HeaderText | This is used to set or get additional text that should appear in the header of every page.
HelpAttributes | This is used to get a collection of additional Help 2 attributes that will be added to each generated help topic.
HelpFileFormat | This is used to set or get the help file format generated by the build process.
HelpFileVersion | This is used to set or get the version number applied to the help file.
HelpTitle | This is used to set or get the help file's title
HtmlHelp1xCompilerPath | This is used to set or get the path to the HTML 1.x help compiler (HHC.EXE).
HtmlHelp2xCompilerPath | This is used to set or get the path to the HTML 2.x help compiler (HXCOMP.EXE).
HtmlHelpName | This is used to set or get the name of the compiled help file. Do not include a path or the extension. For HTML Help 2 builds, this is also used as the collection namespace name (avoid spaces).
IncludeFavorites | This is used to set or get whether or not a Favorites tab will appear in the help file.
IncludeStopWordList | This is used to set or get whether or not to include the stop word list used to identify words to omit from the Help 2 full text search index.
IndentHtml | This is used to set or get whether or not the HTML rendered by BuildAssembler is indented.
IsDirty | This is used to get the dirty state of the project
KeepLogFile | This is used to set or get whether or not the log file is retained after a successful build.
Language | This is used to set or get the language option for the help file and to determine which set of presentation resource files to use.
LogFileLocation | This read-only property is used to get the build log file location.
MissingTags | This read-only helper property returns the flags to use when looking for missing tags.
MSBuildOutDir | This is used to get or set the MSBuild OutDir property value that is defined when using Team Build.
MSBuildProject | This read-only property is used to get the underlying MSBuild project.
NamespaceSummaries | Returns the list of namespace summaries
NamingMethod | This is used to set or get the naming method used to generate the help topic filenames.
OutputPath | This is used to set or get the path to which the help files will be generated.
Platform | This is used to get or set the platform to use when building the project.
PlugInConfigurations | This is used to get a dictionary of build process plug-in configurations.
PlugInNamespaces | This is used to set or get a comma-separated list of namespaces that the collection will be plugged into when deployed using H2Reg.exe.
Preliminary | This is used to set or get whether or not all pages should be marked with a "preliminary documentation" warning in the page header.
PresentationStyle | This is used to set or get the presentation style for the help topic pages.
ProjectLinkType | This is used to set or get the type of links used to reference other help topics referring to items within the documented assemblies.
ProjectSummary | This is used to set or get the project summary comments
References | This is used to get a collection of reference dependencies (files, GAC, COM, or project) for MRefBuilder if needed.
RootNamespaceContainer | This is used to set or get whether or not a root namespace entry is added to the table of contents to act as a container for the namespaces from the documented assemblies.
RootNamespaceTitle | This is used to set or get an alternate title for the root namespaces page and the root table of contents container that appears when RootNamespaceContainer is set to true.
SandcastlePath | This is used to set or get the path to the Sandcastle components
SdkLinkTarget | This is used to set or get the target window for MSDN SDK links.
SdkLinkType | This is used to set or get the type of links used to reference other help topics referring to framework (SDK) help topics.
ShowFeedbackControl | This is used to set or get whether or not the feedback control is visible in presentation styles that support it.
ShowMissingIncludeTargets | This is used to get or set whether or not missing <include> tag target documentation is indicated in the help file.
ShowMissingNamespaces | This is used to get or set whether or not missing namespace comments are indicated in the help file.
ShowMissingParams | This is used to get or set whether or not missing <param> tags are indicated in the help file.
ShowMissingRemarks | This is used to get or set whether or not missing <remarks> tags are indicated in the help file.
ShowMissingReturns | This is used to get or set whether or not missing <returns> tags are indicated in the help file.
ShowMissingSummaries | This is used to get or set whether or not missing <summary> tags are indicated in the help file.
ShowMissingTypeParams | This is used to get or set whether or not missing <typeparam> tags on generic types and methods are indicated in the help file.
ShowMissingValues | This is used to get or set whether or not missing <value> tags are indicated in the help file.
SyntaxFilters | This is used to set or get the language filters which determines which languages appear in the Syntax section of the help topics.
UserDefinedProperties | This is used to present a design-time property that is used for editing user-defined project file properties.
UsingFinalValues | This read-only property is used to get whether or not the project is using final values for the project properties.
VisibleItems | This read-only helper property returns the flags used to indicate which optional items to document.
WorkingPath | This is used to set or get the path to the working folder used during the build process to store the intermediate files.

Events

Name | Description
DirtyChanged | This event is raised when the dirty property changes
DocumentationSourcesChanged | This event is raised when the assembly list is modified
ProjectPropertyChanged | This event is raised when a property is changed
QueryEditProjectFile | This event is raised when a property is about to be changed to see if the project file can be edited.

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


SandcastleProject Constructor

[image] [image]

Sandcastle Help File Builder Documentation
SandcastleProject Constructor
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

There are five overloads for the constructor

Overload List

Name | Description
SandcastleProject()()() | Constructor
SandcastleProject(Project, Boolean) | This is used to create a Sandcastle Builder project from an existing MSBuild project instance.
SandcastleProject(SandcastleProject, Boolean) | This is used to clone an existing project in order to build it without affecting the existing project's properties.
SandcastleProject(String, Boolean) | Load a Sandcastle Builder project from the given filename.

See Also

SandcastleProject Class
SandcastleProject Members
SandcastleBuilder.Utils Namespace


SandcastleProject Constructor

[image]

Sandcastle Help File Builder Documentation
SandcastleProject Constructor
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected SandcastleProject()
Visual Basic (Declaration)
Protected Sub New

See Also

SandcastleProject Class
SandcastleProject Overload
SandcastleBuilder.Utils Namespace


SandcastleProject Constructor (Project, Boolean)

[image]

Sandcastle Help File Builder Documentation
SandcastleProject Constructor (Project, Boolean)
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to create a Sandcastle Builder project from an existing MSBuild project instance.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public SandcastleProject(
    Project existingProject,
    bool useFinalValues
)
Visual Basic (Declaration)
Public Sub New ( _
    existingProject As Project, _
    useFinalValues As Boolean _
)

Parameters

existingProject
Type: Microsoft.Build.BuildEngine..::.Project
The existing project instance
useFinalValues
Type: System..::.Boolean
True to load final values (i.e. for build) or false to load design-time values.

Remarks

It is assumed that the project has been loaded, the property values are current, and, if using final values, that the configuration and platform have been set in the MSBuild project global properties.

See Also

SandcastleProject Class
SandcastleProject Overload
SandcastleBuilder.Utils Namespace


SandcastleProject Constructor (SandcastleProject, Boolean)

[image]

Sandcastle Help File Builder Documentation
SandcastleProject Constructor (SandcastleProject, Boolean)
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to clone an existing project in order to build it without affecting the existing project's properties.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public SandcastleProject(
    SandcastleProject cloneProject,
    bool useFinalValues
)
Visual Basic (Declaration)
Public Sub New ( _
    cloneProject As SandcastleProject, _
    useFinalValues As Boolean _
)

Parameters

cloneProject
Type: SandcastleBuilder.Utils..::.SandcastleProject
The project to clone
useFinalValues
Type: System..::.Boolean
True to load final values (i.e. for build) or false to load design-time values.

Remarks

This is used to perform partial builds where we may want to use alternate property values.

See Also

SandcastleProject Class
SandcastleProject Overload
SandcastleBuilder.Utils Namespace


SandcastleProject Constructor (String, Boolean)

[image]

Sandcastle Help File Builder Documentation
SandcastleProject Constructor (String, Boolean)
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Load a Sandcastle Builder project from the given filename.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public SandcastleProject(
    string filename,
    bool mustExist
)
Visual Basic (Declaration)
Public Sub New ( _
    filename As String, _
    mustExist As Boolean _
)

Parameters

filename
Type: System..::.String
The filename to load
mustExist
Type: System..::.Boolean
Specify true if the file must exist or false if a new project should be created if the file does not exist.

Exceptions

Exception | Condition
System..::.ArgumentException | This is thrown if a filename is not specified or if it does not exist and mustExist is true.

See Also

SandcastleProject Class
SandcastleProject Overload
SandcastleBuilder.Utils Namespace


SandcastleProject Fields

[image] [image]

Sandcastle Help File Builder Documentation
SandcastleProject Fields
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SandcastleProject type exposes the following members.

Fields

Name | Description
DefaultConfiguration | The default configuration
DefaultPlatform | The default platform

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


DefaultConfiguration Field

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.DefaultConfiguration Field
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The default configuration

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public const string DefaultConfiguration
Visual Basic (Declaration)
Public Const DefaultConfiguration As String

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


DefaultPlatform Field

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.DefaultPlatform Field
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The default platform

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public const string DefaultPlatform
Visual Basic (Declaration)
Public Const DefaultPlatform As String

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


SandcastleProject Methods

[image] [image]

Sandcastle Help File Builder Documentation
SandcastleProject Methods
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SandcastleProject type exposes the following members.

Methods

Name | Description
AddFileToProject | Add a new file build item to the project
AddFolderToProject | Add a new folder build item to the project
DefaultBuildAction | This is used to determine the default build action for a file based on its extension.
EnsureProjectIsCurrent | This is used to ensure that all local collection project properties have been stored in the MSBuild project file and that path-type properties are current based on the current project location.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindFile | This is used to locate a file by name in the project
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasItems | This returns true if the project contains items using the given build action.
MarkAsDirty | This is used to mark the project as dirty and in need of being saved.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnDirtyChanged | This raises the DirtyChanged event.
OnDocumentationSourcesChanged | This raises the DocumentationSourcesChanged event.
OnProjectPropertyChanged | This raises the ProjectPropertyChanged event.
OnQueryEditProjectFile | This raises the QueryEditProjectFile event.
SaveProject | This is used to save the project file
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


AddFileToProject Method

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.AddFileToProject Method
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Add a new file build item to the project

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public FileItem AddFileToProject(
    string sourceFile,
    string destFile
)
Visual Basic (Declaration)
Public Function AddFileToProject ( _
    sourceFile As String, _
    destFile As String _
) As FileItem

Parameters

sourceFile
Type: System..::.String
The source filename
destFile
Type: System..::.String
The optional destination path. If empty, null, or it does not start with the project folder, the file is copied to the root folder of the project.

Return Value

The new FileItem.

Remarks

If the file does not exist in the project, it is copied to the destination path or project folder if not already there. The default build action is determined based on the filename's extension. If the file is already part of the project, the existing item is returned.

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


AddFolderToProject Method

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.AddFolderToProject Method
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Add a new folder build item to the project

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public FileItem AddFolderToProject(
    string folder
)
Visual Basic (Declaration)
Public Function AddFolderToProject ( _
    folder As String _
) As FileItem

Parameters

folder
Type: System..::.String
The folder name

Return Value

The new FileItem.

Remarks

If the folder does not exist in the project, it is added and created if not already there. If the folder is already part of the project, the existing item is returned.

Exceptions

Exception | Condition
System..::.ArgumentException | This is thrown if the path matches the project root path or is not below it.

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


DefaultBuildAction Method

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.DefaultBuildAction Method
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to determine the default build action for a file based on its extension.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public static BuildAction DefaultBuildAction(
    string filename
)
Visual Basic (Declaration)
Public Shared Function DefaultBuildAction ( _
    filename As String _
) As BuildAction

Parameters

filename
Type: System..::.String
The filename to use

Return Value

The build action based on the extension

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


EnsureProjectIsCurrent Method

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.EnsureProjectIsCurrent Method
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to ensure that all local collection project properties have been stored in the MSBuild project file and that path-type properties are current based on the current project location.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public void EnsureProjectIsCurrent(
    bool forceUpdate
)
Visual Basic (Declaration)
Public Sub EnsureProjectIsCurrent ( _
    forceUpdate As Boolean _
)

Parameters

forceUpdate
Type: System..::.Boolean
True to force an update of all affected properties or false to only update those that need it.

Remarks

This only affects the property-based collection properties and path-type properties. Simple types and item group element properties are stored when modified.

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


FindFile Method

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.FindFile Method
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to locate a file by name in the project

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public FileItem FindFile(
    string fileToFind
)
Visual Basic (Declaration)
Public Function FindFile ( _
    fileToFind As String _
) As FileItem

Parameters

fileToFind
Type: System..::.String
The fully qualified file path to find

Return Value

The file item if found or null if not found

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


HasItems Method

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.HasItems Method
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This returns true if the project contains items using the given build action.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool HasItems(
    BuildAction buildAction
)
Visual Basic (Declaration)
Public Function HasItems ( _
    buildAction As BuildAction _
) As Boolean

Parameters

buildAction
Type: SandcastleBuilder.Utils..::.BuildAction
The build action for which to check

Return Value

True if at least one item has the given build action or false if there are no items with the given build action.

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


MarkAsDirty Method

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.MarkAsDirty Method
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to mark the project as dirty and in need of being saved.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public void MarkAsDirty()
Visual Basic (Declaration)
Public Sub MarkAsDirty

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


OnDirtyChanged Method

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.OnDirtyChanged Method
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This raises the DirtyChanged event.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected void OnDirtyChanged(
    EventArgs e
)
Visual Basic (Declaration)
Protected Sub OnDirtyChanged ( _
    e As EventArgs _
)

Parameters

e
Type: System..::.EventArgs
The event arguments

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


OnDocumentationSourcesChanged Method

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.OnDocumentationSourcesChanged Method
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This raises the DocumentationSourcesChanged event.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected void OnDocumentationSourcesChanged(
    EventArgs e
)
Visual Basic (Declaration)
Protected Sub OnDocumentationSourcesChanged ( _
    e As EventArgs _
)

Parameters

e
Type: System..::.EventArgs
The event arguments

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


OnProjectPropertyChanged Method

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.OnProjectPropertyChanged Method
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This raises the ProjectPropertyChanged event.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected void OnProjectPropertyChanged(
    ProjectPropertyChangedEventArgs e
)
Visual Basic (Declaration)
Protected Sub OnProjectPropertyChanged ( _
    e As ProjectPropertyChangedEventArgs _
)

Parameters

e
Type: SandcastleBuilder.Utils..::.ProjectPropertyChangedEventArgs
The event arguments

Remarks

This will also mark the project as dirty

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


OnQueryEditProjectFile Method

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.OnQueryEditProjectFile Method
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This raises the QueryEditProjectFile event.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected internal void OnQueryEditProjectFile(
    CancelEventArgs e
)
Visual Basic (Declaration)
Protected Friend Sub OnQueryEditProjectFile ( _
    e As CancelEventArgs _
)

Parameters

e
Type: System.ComponentModel..::.CancelEventArgs
The event arguments

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


SaveProject Method

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.SaveProject Method
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to save the project file

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public void SaveProject(
    string filename
)
Visual Basic (Declaration)
Public Sub SaveProject ( _
    filename As String _
)

Parameters

filename
Type: System..::.String
The filename for the project

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


SandcastleProject Properties

[image] [image]

Sandcastle Help File Builder Documentation
SandcastleProject Properties
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SandcastleProject type exposes the following members.

Properties

Name | Description
ApiFilter | This is used to get the API filter collection.
AutoDocumentConstructors | This is used to get or set whether or not constructors are automatically documented if they are missing the <summary> tag and for classes with compiler generated constructors.
BasePath | This read-only property returns the base path
BinaryTOC | This is used to set or get the path to the Sandcastle components
BuildLogFile | This is used to set or get the path and filename of the build log file.
CleanIntermediates | This is used to set or get whether intermediate files are deleted after a successful build.
CollectionTocStyle | This is used to set or get the collection table of contents style used when plugged into an HTML Help 2 collection.
ComponentConfigurations | This is used to get a dictionary of build component configurations.
Configuration | This is used to get or set the configuration to use when building the project.
ContentPlacement | This is used to set or get the placement of any additional and conceptual content items in the table of contents.
CopyrightHref | This is used to set or get the URL to use as the link for the copyright notice.
CopyrightText | This is used to set or get the copyright notice that appears in the footer of each page.
CppCommentsFixup | This is used to set or get whether to fix-up the XML comments files to work around an issue with those generated by the C++ compiler.
DecodedCopyrightText | This is used to get the copyright notice that appears in the footer of each page with any hex value place holders replaced with their actual character.
DocumentationSources | Returns the list of documentation sources to use in building the help file.
DocumentAttributes | This is used to get or set whether or not attributes on types and members are documented in the syntax portion of the help file.
DocumentExplicitInterfaceImplementations | This is used to get or set whether or not explicit interface implementations are documented.
DocumentInheritedFrameworkInternalMembers | This is used to get or set whether or not inherited internal framework members are documented.
DocumentInheritedFrameworkMembers | This is used to get or set whether or not inherited framework members are documented.
DocumentInheritedFrameworkPrivateMembers | This is used to get or set whether or not inherited private framework members are documented.
DocumentInheritedMembers | This is used to get or set whether or not inherited members are documented.
DocumentInternals | This is used to get or set whether or not internal members are documented in the help file.
DocumentPrivateFields | This is used to get or set whether or not private fields are documented in the help file.
DocumentPrivates | This is used to get or set whether or not private members are documented in the help file.
DocumentProtected | This is used to get or set whether or not protected members are documented in the help file.
DocumentProtectedInternalAsProtected | This is used to get or set whether or not "protected internal" members are documented as "protected" only in the help file.
DocumentSealedProtected | This is used to get or set whether or not protected members of sealed classes are documented in the help file.
FeedbackEMailAddress | This is used to set or get the feedback e-mail address that appears in the footer of each page.
FeedbackEMailLinkText | This is used to set or get the feedback e-mail link text that appears in the feedback e-mail link in the footer of each page.
FileItems | This returns a collection of all build items in the project that represent folders and files.
Filename | This read-only property is used to get the filename for the project
FooterText | This is used to set or get additional text that should appear in the footer of every page.
FrameworkVersion | This is used to set or get the .NET Framework version to which the documentation links for system types should point.
HeaderText | This is used to set or get additional text that should appear in the header of every page.
HelpAttributes | This is used to get a collection of additional Help 2 attributes that will be added to each generated help topic.
HelpFileFormat | This is used to set or get the help file format generated by the build process.
HelpFileVersion | This is used to set or get the version number applied to the help file.
HelpTitle | This is used to set or get the help file's title
HtmlHelp1xCompilerPath | This is used to set or get the path to the HTML 1.x help compiler (HHC.EXE).
HtmlHelp2xCompilerPath | This is used to set or get the path to the HTML 2.x help compiler (HXCOMP.EXE).
HtmlHelpName | This is used to set or get the name of the compiled help file. Do not include a path or the extension. For HTML Help 2 builds, this is also used as the collection namespace name (avoid spaces).
IncludeFavorites | This is used to set or get whether or not a Favorites tab will appear in the help file.
IncludeStopWordList | This is used to set or get whether or not to include the stop word list used to identify words to omit from the Help 2 full text search index.
IndentHtml | This is used to set or get whether or not the HTML rendered by BuildAssembler is indented.
IsDirty | This is used to get the dirty state of the project
KeepLogFile | This is used to set or get whether or not the log file is retained after a successful build.
Language | This is used to set or get the language option for the help file and to determine which set of presentation resource files to use.
LogFileLocation | This read-only property is used to get the build log file location.
MissingTags | This read-only helper property returns the flags to use when looking for missing tags.
MSBuildOutDir | This is used to get or set the MSBuild OutDir property value that is defined when using Team Build.
MSBuildProject | This read-only property is used to get the underlying MSBuild project.
NamespaceSummaries | Returns the list of namespace summaries
NamingMethod | This is used to set or get the naming method used to generate the help topic filenames.
OutputPath | This is used to set or get the path to which the help files will be generated.
Platform | This is used to get or set the platform to use when building the project.
PlugInConfigurations | This is used to get a dictionary of build process plug-in configurations.
PlugInNamespaces | This is used to set or get a comma-separated list of namespaces that the collection will be plugged into when deployed using H2Reg.exe.
Preliminary | This is used to set or get whether or not all pages should be marked with a "preliminary documentation" warning in the page header.
PresentationStyle | This is used to set or get the presentation style for the help topic pages.
ProjectLinkType | This is used to set or get the type of links used to reference other help topics referring to items within the documented assemblies.
ProjectSummary | This is used to set or get the project summary comments
References | This is used to get a collection of reference dependencies (files, GAC, COM, or project) for MRefBuilder if needed.
RootNamespaceContainer | This is used to set or get whether or not a root namespace entry is added to the table of contents to act as a container for the namespaces from the documented assemblies.
RootNamespaceTitle | This is used to set or get an alternate title for the root namespaces page and the root table of contents container that appears when RootNamespaceContainer is set to true.
SandcastlePath | This is used to set or get the path to the Sandcastle components
SdkLinkTarget | This is used to set or get the target window for MSDN SDK links.
SdkLinkType | This is used to set or get the type of links used to reference other help topics referring to framework (SDK) help topics.
ShowFeedbackControl | This is used to set or get whether or not the feedback control is visible in presentation styles that support it.
ShowMissingIncludeTargets | This is used to get or set whether or not missing <include> tag target documentation is indicated in the help file.
ShowMissingNamespaces | This is used to get or set whether or not missing namespace comments are indicated in the help file.
ShowMissingParams | This is used to get or set whether or not missing <param> tags are indicated in the help file.
ShowMissingRemarks | This is used to get or set whether or not missing <remarks> tags are indicated in the help file.
ShowMissingReturns | This is used to get or set whether or not missing <returns> tags are indicated in the help file.
ShowMissingSummaries | This is used to get or set whether or not missing <summary> tags are indicated in the help file.
ShowMissingTypeParams | This is used to get or set whether or not missing <typeparam> tags on generic types and methods are indicated in the help file.
ShowMissingValues | This is used to get or set whether or not missing <value> tags are indicated in the help file.
SyntaxFilters | This is used to set or get the language filters which determines which languages appear in the Syntax section of the help topics.
UserDefinedProperties | This is used to present a design-time property that is used for editing user-defined project file properties.
UsingFinalValues | This read-only property is used to get whether or not the project is using final values for the project properties.
VisibleItems | This read-only helper property returns the flags used to indicate which optional items to document.
WorkingPath | This is used to set or get the path to the working folder used during the build process to store the intermediate files.

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


ApiFilter Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.ApiFilter Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get the API filter collection.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public ApiFilterCollection ApiFilter { get; }
Visual Basic (Declaration)
Public ReadOnly Property ApiFilter As ApiFilterCollection

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


AutoDocumentConstructors Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.AutoDocumentConstructors Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set whether or not constructors are automatically documented if they are missing the <summary> tag and for classes with compiler generated constructors.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool AutoDocumentConstructors { get; set; }
Visual Basic (Declaration)
Public Property AutoDocumentConstructors As Boolean

Field Value

Set this to true to automatically add default text for the <summary> tag on constructors that are missing it and for classes with a compiler generated constructor. If set to false and ShowMissingSummaries is true, a "missing summary" warning will appear instead. A message is also written to the log file.

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


BasePath Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.BasePath Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns the base path

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string BasePath { get; }
Visual Basic (Declaration)
Public ReadOnly Property BasePath As String

Implements

IBasePathProvider..::.BasePath

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


BinaryTOC Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.BinaryTOC Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to set or get the path to the Sandcastle components

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool BinaryTOC { get; set; }
Visual Basic (Declaration)
Public Property BinaryTOC As Boolean

Remarks

This can significantly reduce the amount of time required to load a very large help document.

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


BuildLogFile Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.BuildLogFile Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to set or get the path and filename of the build log file.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public FilePath BuildLogFile { get; set; }
Visual Basic (Declaration)
Public Property BuildLogFile As FilePath

Field Value

If not specified, a default name of LastBuild.log is used and the file is saved in the path identified in the OutputPath property.

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


CleanIntermediates Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.CleanIntermediates Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to set or get whether intermediate files are deleted after a successful build.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool CleanIntermediates { get; set; }
Visual Basic (Declaration)
Public Property CleanIntermediates As Boolean

Field Value

The default value is true.

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


CollectionTocStyle Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.CollectionTocStyle Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to set or get the collection table of contents style used when plugged into an HTML Help 2 collection.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public CollectionTocStyle CollectionTocStyle { get; set; }
Visual Basic (Declaration)
Public Property CollectionTocStyle As CollectionTocStyle

Remarks

The default is Hierarchical.

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


ComponentConfigurations Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.ComponentConfigurations Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get a dictionary of build component configurations.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public ComponentConfigurationDictionary ComponentConfigurations { get; }
Visual Basic (Declaration)
Public ReadOnly Property ComponentConfigurations As ComponentConfigurationDictionary

Remarks

This allows you to configure the settings for third party build components if they support it.

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


Configuration Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.Configuration Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set the configuration to use when building the project.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string Configuration { get; set; }
Visual Basic (Declaration)
Public Property Configuration As String

Field Value

This value is used for project documentation sources and project references so that the correct items are used from them.

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


ContentPlacement Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.ContentPlacement Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to set or get the placement of any additional and conceptual content items in the table of contents.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public ContentPlacement ContentPlacement { get; set; }
Visual Basic (Declaration)
Public Property ContentPlacement As ContentPlacement

Field Value

The default is to place additional and conceptual content items above the namespaces.

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


CopyrightHref Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.CopyrightHref Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to set or get the URL to use as the link for the copyright notice.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string CopyrightHref { get; set; }
Visual Basic (Declaration)
Public Property CopyrightHref As String

Field Value

If not set, the see cref="CopyrighText"/> (if any) is not turned into a clickable link.

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


CopyrightText Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.CopyrightText Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to set or get the copyright notice that appears in the footer of each page.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string CopyrightText { get; set; }
Visual Basic (Declaration)
Public Property CopyrightText As String

Remarks

If not set, no copyright note will appear. If a CopyrightHref is specified without copyright text, the URL appears instead.

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


CppCommentsFixup Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.CppCommentsFixup Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to set or get whether to fix-up the XML comments files to work around an issue with those generated by the C++ compiler.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool CppCommentsFixup { get; set; }
Visual Basic (Declaration)
Public Property CppCommentsFixup As Boolean

Field Value

The default value is false.

Remarks

The C++ compiler generates method signatures that differ from the other .NET compilers for methods that take generics as parameters. These methods fail to get documented as they do not match the output of MRefBuilder. The C# and VB.NET compilers generate names that do match it and this option is not needed for comments files generated by them. Set this to true if the project contains C++ compiler generated XML comments files and your project contains methods that take generic types for parameters.

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


DecodedCopyrightText Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.DecodedCopyrightText Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get the copyright notice that appears in the footer of each page with any hex value place holders replaced with their actual character.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string DecodedCopyrightText { get; }
Visual Basic (Declaration)
Public ReadOnly Property DecodedCopyrightText As String

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


DocumentationSources Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.DocumentationSources Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Returns the list of documentation sources to use in building the help file.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public DocumentationSourceCollection DocumentationSources { get; }
Visual Basic (Declaration)
Public ReadOnly Property DocumentationSources As DocumentationSourceCollection

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


DocumentAttributes Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.DocumentAttributes Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set whether or not attributes on types and members are documented in the syntax portion of the help file.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool DocumentAttributes { get; set; }
Visual Basic (Declaration)
Public Property DocumentAttributes As Boolean

Field Value

Set to true to document attributes or false to hide them

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


DocumentExplicitInterfaceImplementations Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.DocumentExplicitInterfaceImplementations Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set whether or not explicit interface implementations are documented.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool DocumentExplicitInterfaceImplementations { get; set; }
Visual Basic (Declaration)
Public Property DocumentExplicitInterfaceImplementations As Boolean

Field Value

Set to true to document explicit interface implementations or false to hide them.

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


DocumentInheritedFrameworkInternalMembers Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.DocumentInheritedFrameworkInternalMembers Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set whether or not inherited internal framework members are documented.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool DocumentInheritedFrameworkInternalMembers { get; set; }
Visual Basic (Declaration)
Public Property DocumentInheritedFrameworkInternalMembers As Boolean

Field Value

Set to true to document inherited internal framework members or false to hide them. For this to work, DocumentInheritedFrameworkMembers and DocumentInternals must also be enabled.

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


DocumentInheritedFrameworkMembers Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.DocumentInheritedFrameworkMembers Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set whether or not inherited framework members are documented.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool DocumentInheritedFrameworkMembers { get; set; }
Visual Basic (Declaration)
Public Property DocumentInheritedFrameworkMembers As Boolean

Field Value

Set to true to document inherited framework members or false to hide them. For this to work, DocumentInheritedMembers must also be enabled.

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


DocumentInheritedFrameworkPrivateMembers Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.DocumentInheritedFrameworkPrivateMembers Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set whether or not inherited private framework members are documented.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool DocumentInheritedFrameworkPrivateMembers { get; set; }
Visual Basic (Declaration)
Public Property DocumentInheritedFrameworkPrivateMembers As Boolean

Field Value

Set to true to document inherited private framework members or false to hide them. For this to work, DocumentInheritedFrameworkMembers and DocumentPrivates must also be enabled.

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


DocumentInheritedMembers Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.DocumentInheritedMembers Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set whether or not inherited members are documented.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool DocumentInheritedMembers { get; set; }
Visual Basic (Declaration)
Public Property DocumentInheritedMembers As Boolean

Field Value

Set to true to document inherited members or false to hide them.

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


DocumentInternals Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.DocumentInternals Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set whether or not internal members are documented in the help file.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool DocumentInternals { get; set; }
Visual Basic (Declaration)
Public Property DocumentInternals As Boolean

Field Value

Set to true to document internal members or false to hide them

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


DocumentPrivateFields Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.DocumentPrivateFields Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set whether or not private fields are documented in the help file.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool DocumentPrivateFields { get; set; }
Visual Basic (Declaration)
Public Property DocumentPrivateFields As Boolean

Field Value

Set to true to document private fields or false to hide them. For this to work, DocumentPrivates must also be enabled.

Remarks

Private fields are most often used to back properties and do not have documentation. With this set to false, they are omitted from the help file to reduce unnecessary clutter.

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


DocumentPrivates Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.DocumentPrivates Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set whether or not private members are documented in the help file.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool DocumentPrivates { get; set; }
Visual Basic (Declaration)
Public Property DocumentPrivates As Boolean

Field Value

Set to true to document private members or false to hide them

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


DocumentProtected Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.DocumentProtected Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set whether or not protected members are documented in the help file.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool DocumentProtected { get; set; }
Visual Basic (Declaration)
Public Property DocumentProtected As Boolean

Field Value

Set to true to document protected members or false to hide them

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


DocumentProtectedInternalAsProtected Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.DocumentProtectedInternalAsProtected Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set whether or not "protected internal" members are documented as "protected" only in the help file.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool DocumentProtectedInternalAsProtected { get; set; }
Visual Basic (Declaration)
Public Property DocumentProtectedInternalAsProtected As Boolean

Field Value

Set to true to document "protected internal" members as "protected" only or false to document them normally. This option is ignored if DocumentProtected is false.

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


DocumentSealedProtected Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.DocumentSealedProtected Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set whether or not protected members of sealed classes are documented in the help file.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool DocumentSealedProtected { get; set; }
Visual Basic (Declaration)
Public Property DocumentSealedProtected As Boolean

Field Value

Set to true to document protected members of sealed classes or false to hide them. For this to work, DocumentProtected must also be enabled.

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


FeedbackEMailAddress Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.FeedbackEMailAddress Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to set or get the feedback e-mail address that appears in the footer of each page.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string FeedbackEMailAddress { get; set; }
Visual Basic (Declaration)
Public Property FeedbackEMailAddress As String

Remarks

If not set, no feedback link will appear. If FeedbackEMailLinkText is set, that text will appear as the text for the link. If not set, the e-mail address is used as the link text.

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


FeedbackEMailLinkText Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.FeedbackEMailLinkText Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to set or get the feedback e-mail link text that appears in the feedback e-mail link in the footer of each page.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string FeedbackEMailLinkText { get; set; }
Visual Basic (Declaration)
Public Property FeedbackEMailLinkText As String

Remarks

If set, this text will appear as the link text for the FeedbackEMailAddress link. If not set, the e-mail address is used for the link text.

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


FileItems Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.FileItems Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This returns a collection of all build items in the project that represent folders and files.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public Collection<FileItem> FileItems { get; }
Visual Basic (Declaration)
Public ReadOnly Property FileItems As Collection(Of FileItem)

Remarks

This collection is generated each time the property is used. As such, cache a copy if you need to use it repeatedly.

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


Filename Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.Filename Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property is used to get the filename for the project

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string Filename { get; }
Visual Basic (Declaration)
Public ReadOnly Property Filename As String

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


FooterText Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.FooterText Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to set or get additional text that should appear in the footer of every page.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string FooterText { get; set; }
Visual Basic (Declaration)
Public Property FooterText As String

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


FrameworkVersion Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.FrameworkVersion Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to set or get the .NET Framework version to which the documentation links for system types should point.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string FrameworkVersion { get; set; }
Visual Basic (Declaration)
Public Property FrameworkVersion As String

Remarks

If not found, it will default to the most recent version of the framework installed.

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


HeaderText Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.HeaderText Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to set or get additional text that should appear in the header of every page.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string HeaderText { get; set; }
Visual Basic (Declaration)
Public Property HeaderText As String

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


HelpAttributes Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.HelpAttributes Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get a collection of additional Help 2 attributes that will be added to each generated help topic.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public MSHelpAttrCollection HelpAttributes { get; }
Visual Basic (Declaration)
Public ReadOnly Property HelpAttributes As MSHelpAttrCollection

Remarks

The attributes are added by a custom build component in the BuildAssembler step.

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


HelpFileFormat Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.HelpFileFormat Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to set or get the help file format generated by the build process.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public HelpFileFormat HelpFileFormat { get; set; }
Visual Basic (Declaration)
Public Property HelpFileFormat As HelpFileFormat

Field Value

The default is to produce an HTML Help 1.x format file built using HHC.exe.

Remarks

If building a web site, the output folder will be cleared before the new content is copied to it.

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


HelpFileVersion Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.HelpFileVersion Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to set or get the version number applied to the help file.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string HelpFileVersion { get; set; }
Visual Basic (Declaration)
Public Property HelpFileVersion As String

Remarks

The default is 1.0.0.0

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


HelpTitle Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.HelpTitle Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to set or get the help file's title

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string HelpTitle { get; set; }
Visual Basic (Declaration)
Public Property HelpTitle As String

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


HtmlHelp1xCompilerPath Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.HtmlHelp1xCompilerPath Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to set or get the path to the HTML 1.x help compiler (HHC.EXE).

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public FolderPath HtmlHelp1xCompilerPath { get; set; }
Visual Basic (Declaration)
Public Property HtmlHelp1xCompilerPath As FolderPath

Field Value

You only need to set this if the builder cannot determine the path for itself.

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


HtmlHelp2xCompilerPath Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.HtmlHelp2xCompilerPath Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to set or get the path to the HTML 2.x help compiler (HXCOMP.EXE).

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public FolderPath HtmlHelp2xCompilerPath { get; set; }
Visual Basic (Declaration)
Public Property HtmlHelp2xCompilerPath As FolderPath

Field Value

You only need to set this if the builder cannot determine the path for itself.

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


HtmlHelpName Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.HtmlHelpName Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to set or get the name of the compiled help file. Do not include a path or the extension. For HTML Help 2 builds, this is also used as the collection namespace name (avoid spaces).

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string HtmlHelpName { get; set; }
Visual Basic (Declaration)
Public Property HtmlHelpName As String

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


IncludeFavorites Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.IncludeFavorites Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to set or get whether or not a Favorites tab will appear in the help file.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool IncludeFavorites { get; set; }
Visual Basic (Declaration)
Public Property IncludeFavorites As Boolean

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


IncludeStopWordList Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.IncludeStopWordList Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to set or get whether or not to include the stop word list used to identify words to omit from the Help 2 full text search index.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool IncludeStopWordList { get; set; }
Visual Basic (Declaration)
Public Property IncludeStopWordList As Boolean

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


IndentHtml Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.IndentHtml Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to set or get whether or not the HTML rendered by BuildAssembler is indented.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool IndentHtml { get; set; }
Visual Basic (Declaration)
Public Property IndentHtml As Boolean

Field Value

This is mainly a debugging aid. Leave it set to false, the default to produce more compact HTML.

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


IsDirty Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.IsDirty Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get the dirty state of the project

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool IsDirty { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsDirty As Boolean

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


KeepLogFile Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.KeepLogFile Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to set or get whether or not the log file is retained after a successful build.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool KeepLogFile { get; set; }
Visual Basic (Declaration)
Public Property KeepLogFile As Boolean

Field Value

The default value is true.

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


Language Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.Language Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to set or get the language option for the help file and to determine which set of presentation resource files to use.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public CultureInfo Language { get; set; }
Visual Basic (Declaration)
Public Property Language As CultureInfo

Field Value

If a matching set of presentation resources cannot be found for the specified language, the US English set will be used.

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


LogFileLocation Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.LogFileLocation Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property is used to get the build log file location.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string LogFileLocation { get; }
Visual Basic (Declaration)
Public ReadOnly Property LogFileLocation As String

Field Value

If BuildLogFile is set, it returns its value. If not set, it returns the full path created by using the OutputPath property value and a filename of LastBuild.log.

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


MissingTags Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.MissingTags Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only helper property returns the flags to use when looking for missing tags.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public MissingTags MissingTags { get; private set; }
Visual Basic (Declaration)
Public Property MissingTags As MissingTags

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


MSBuildOutDir Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.MSBuildOutDir Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set the MSBuild OutDir property value that is defined when using Team Build.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string MSBuildOutDir { get; set; }
Visual Basic (Declaration)
Public Property MSBuildOutDir As String

Field Value

This value is used for project documentation sources and project references so that the correct items are used from them.

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


MSBuildProject Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.MSBuildProject Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property is used to get the underlying MSBuild project.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public Project MSBuildProject { get; }
Visual Basic (Declaration)
Public ReadOnly Property MSBuildProject As Project

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


NamespaceSummaries Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.NamespaceSummaries Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Returns the list of namespace summaries

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public NamespaceSummaryItemCollection NamespaceSummaries { get; }
Visual Basic (Declaration)
Public ReadOnly Property NamespaceSummaries As NamespaceSummaryItemCollection

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


NamingMethod Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.NamingMethod Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to set or get the naming method used to generate the help topic filenames.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public NamingMethod NamingMethod { get; set; }
Visual Basic (Declaration)
Public Property NamingMethod As NamingMethod

Field Value

The default is to use GUID values as the filenames.

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


OutputPath Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.OutputPath Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to set or get the path to which the help files will be generated.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string OutputPath { get; set; }
Visual Basic (Declaration)
Public Property OutputPath As String

Remarks

The default is to create it in a folder called Help in the same folder as the project file.

Warning: If building a web site, the output folder's prior content will be erased without warning prior to copying the new web site content to it!

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


Platform Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.Platform Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set the platform to use when building the project.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string Platform { get; set; }
Visual Basic (Declaration)
Public Property Platform As String

Field Value

This value is used for project documentation sources and project references so that the correct items are used from them.

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


PlugInConfigurations Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.PlugInConfigurations Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get a dictionary of build process plug-in configurations.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public PlugInConfigurationDictionary PlugInConfigurations { get; }
Visual Basic (Declaration)
Public ReadOnly Property PlugInConfigurations As PlugInConfigurationDictionary

Remarks

This allows you to select and configure the settings for third party build process plug-ins.

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


PlugInNamespaces Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.PlugInNamespaces Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to set or get a comma-separated list of namespaces that the collection will be plugged into when deployed using H2Reg.exe.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string PlugInNamespaces { get; set; }
Visual Basic (Declaration)
Public Property PlugInNamespaces As String

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


Preliminary Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.Preliminary Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to set or get whether or not all pages should be marked with a "preliminary documentation" warning in the page header.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool Preliminary { get; set; }
Visual Basic (Declaration)
Public Property Preliminary As Boolean

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


PresentationStyle Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.PresentationStyle Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to set or get the presentation style for the help topic pages.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string PresentationStyle { get; set; }
Visual Basic (Declaration)
Public Property PresentationStyle As String

Field Value

The default is to use the VS2005 style.

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


ProjectLinkType Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.ProjectLinkType Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to set or get the type of links used to reference other help topics referring to items within the documented assemblies.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public ProjectLinkType ProjectLinkType { get; set; }
Visual Basic (Declaration)
Public Property ProjectLinkType As ProjectLinkType

Field Value

The default is to produce local links.

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


ProjectSummary Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.ProjectSummary Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to set or get the project summary comments

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string ProjectSummary { get; set; }
Visual Basic (Declaration)
Public Property ProjectSummary As String

Remarks

These notes will appear in the root namespaces page if entered.

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


References Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.References Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get a collection of reference dependencies (files, GAC, COM, or project) for MRefBuilder if needed.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public ReferenceItemCollection References { get; }
Visual Basic (Declaration)
Public ReadOnly Property References As ReferenceItemCollection

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


RootNamespaceContainer Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.RootNamespaceContainer Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to set or get whether or not a root namespace entry is added to the table of contents to act as a container for the namespaces from the documented assemblies.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool RootNamespaceContainer { get; set; }
Visual Basic (Declaration)
Public Property RootNamespaceContainer As Boolean

Field Value

If true, a root Namespaces table of contents entry will be created as the container of the namespaces in the documented assemblies. If false, the default, the namespaces are listed in the table of contents as root entries.

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


RootNamespaceTitle Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.RootNamespaceTitle Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to set or get an alternate title for the root namespaces page and the root table of contents container that appears when RootNamespaceContainer is set to true.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string RootNamespaceTitle { get; set; }
Visual Basic (Declaration)
Public Property RootNamespaceTitle As String

Field Value

If left blank (the default), the localized version of the text "Namespaces" will be used.

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


SandcastlePath Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.SandcastlePath Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to set or get the path to the Sandcastle components

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public FolderPath SandcastlePath { get; set; }
Visual Basic (Declaration)
Public Property SandcastlePath As FolderPath

Field Value

You only need to set this if the builder cannot determine the path for itself.

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


SdkLinkTarget Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.SdkLinkTarget Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to set or get the target window for MSDN SDK links.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public SdkLinkTarget SdkLinkTarget { get; set; }
Visual Basic (Declaration)
Public Property SdkLinkTarget As SdkLinkTarget

Field Value

The default is Blank to open the MSDN topics in a new window. This option only has an effect if the SdkLinkType property is set to MSDN.

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


SdkLinkType Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.SdkLinkType Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to set or get the type of links used to reference other help topics referring to framework (SDK) help topics.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public SdkLinkType SdkLinkType { get; set; }
Visual Basic (Declaration)
Public Property SdkLinkType As SdkLinkType

Field Value

The default is to produce MSDN links.

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


ShowFeedbackControl Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.ShowFeedbackControl Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to set or get whether or not the feedback control is visible in presentation styles that support it.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool ShowFeedbackControl { get; set; }
Visual Basic (Declaration)
Public Property ShowFeedbackControl As Boolean

Field Value

If true and the presentation style supports it, the feedback control is shown in the topic page footer.

Remarks

This property may be obsolete. It was added for the Sandcastle October 2007 CTP. However, as of the January 2008 release, the feedback control is no longer present. As such, this property may be removed at a later date.

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


ShowMissingIncludeTargets Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.ShowMissingIncludeTargets Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set whether or not missing <include> tag target documentation is indicated in the help file.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool ShowMissingIncludeTargets { get; set; }
Visual Basic (Declaration)
Public Property ShowMissingIncludeTargets As Boolean

Field Value

Set this to true to add a message to the help topic to indicate that the <include> tag's target documentation is missing. A message is also written to the log file.

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


ShowMissingNamespaces Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.ShowMissingNamespaces Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set whether or not missing namespace comments are indicated in the help file.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool ShowMissingNamespaces { get; set; }
Visual Basic (Declaration)
Public Property ShowMissingNamespaces As Boolean

Field Value

Set this to true to add a message to the help topic to indicate that the <summary> tag is missing. A message is also written to the log file.

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


ShowMissingParams Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.ShowMissingParams Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set whether or not missing <param> tags are indicated in the help file.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool ShowMissingParams { get; set; }
Visual Basic (Declaration)
Public Property ShowMissingParams As Boolean

Field Value

Set this to true to add a message to the help topic to indicate that a <param> tag is missing. A message is also written to the log file.

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


ShowMissingRemarks Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.ShowMissingRemarks Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set whether or not missing <remarks> tags are indicated in the help file.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool ShowMissingRemarks { get; set; }
Visual Basic (Declaration)
Public Property ShowMissingRemarks As Boolean

Field Value

Set this to true to add a message to the help topic to indicate that the <remarks> tag is missing. A message is also written to the log file.

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


ShowMissingReturns Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.ShowMissingReturns Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set whether or not missing <returns> tags are indicated in the help file.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool ShowMissingReturns { get; set; }
Visual Basic (Declaration)
Public Property ShowMissingReturns As Boolean

Field Value

Set this to true to add a message to the help topic to indicate that the <returns> tag is missing. A message is also written to the log file.

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


ShowMissingSummaries Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.ShowMissingSummaries Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set whether or not missing <summary> tags are indicated in the help file.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool ShowMissingSummaries { get; set; }
Visual Basic (Declaration)
Public Property ShowMissingSummaries As Boolean

Field Value

Set this to true to add a message to the help topic to indicate that the <summary> tag is missing. A message is also written to the log file.

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


ShowMissingTypeParams Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.ShowMissingTypeParams Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set whether or not missing <typeparam> tags on generic types and methods are indicated in the help file.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool ShowMissingTypeParams { get; set; }
Visual Basic (Declaration)
Public Property ShowMissingTypeParams As Boolean

Field Value

Set this to true to add a message to the help topic to indicate that a <typeparam> tag is missing from a generic type or method. A message is also written to the log file.

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


ShowMissingValues Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.ShowMissingValues Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set whether or not missing <value> tags are indicated in the help file.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool ShowMissingValues { get; set; }
Visual Basic (Declaration)
Public Property ShowMissingValues As Boolean

Field Value

Set this to true to add a message to the help topic to indicate that the <value> tag is missing. A message is also written to the log file.

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


SyntaxFilters Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.SyntaxFilters Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to set or get the language filters which determines which languages appear in the Syntax section of the help topics.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public SyntaxFilters SyntaxFilters { get; set; }
Visual Basic (Declaration)
Public Property SyntaxFilters As SyntaxFilters

Field Value

The default is Standard (C#, VB.NET, and C++).

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


UserDefinedProperties Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.UserDefinedProperties Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to present a design-time property that is used for editing user-defined project file properties.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public SandcastleProject UserDefinedProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property UserDefinedProperties As SandcastleProject

Remarks

The designer attached to the property handles updating the user-defined project properties.

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


UsingFinalValues Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.UsingFinalValues Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property is used to get whether or not the project is using final values for the project properties.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool UsingFinalValues { get; }
Visual Basic (Declaration)
Public ReadOnly Property UsingFinalValues As Boolean

Field Value

If true, final values (i.e. evaluated values used at build time) are being returned by the properties in this instance.

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


VisibleItems Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.VisibleItems Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only helper property returns the flags used to indicate which optional items to document.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public VisibleItems VisibleItems { get; private set; }
Visual Basic (Declaration)
Public Property VisibleItems As VisibleItems

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


WorkingPath Property

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.WorkingPath Property
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to set or get the path to the working folder used during the build process to store the intermediate files.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public FolderPath WorkingPath { get; set; }
Visual Basic (Declaration)
Public Property WorkingPath As FolderPath

Field Value

This can be used to perform the build in a different location with a shorter path if you encounter errors due to long file path names. If not specified, it defaults to a folder called .\Working under the folder specified by the OutputPath property.

Warning: All files and folders in the path specified in this property will be erased without warning when the build starts.

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


SandcastleProject Events

[image] [image]

Sandcastle Help File Builder Documentation
SandcastleProject Events
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SandcastleProject type exposes the following members.

Events

Name | Description
DirtyChanged | This event is raised when the dirty property changes
DocumentationSourcesChanged | This event is raised when the assembly list is modified
ProjectPropertyChanged | This event is raised when a property is changed
QueryEditProjectFile | This event is raised when a property is about to be changed to see if the project file can be edited.

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


DirtyChanged Event

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.DirtyChanged Event
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This event is raised when the dirty property changes

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public event EventHandler DirtyChanged
Visual Basic (Declaration)
Public Event DirtyChanged As EventHandler

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


DocumentationSourcesChanged Event

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.DocumentationSourcesChanged Event
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This event is raised when the assembly list is modified

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public event EventHandler DocumentationSourcesChanged
Visual Basic (Declaration)
Public Event DocumentationSourcesChanged As EventHandler

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


ProjectPropertyChanged Event

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.ProjectPropertyChanged Event
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This event is raised when a property is changed

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public event EventHandler<ProjectPropertyChangedEventArgs> ProjectPropertyChanged
Visual Basic (Declaration)
Public Event ProjectPropertyChanged As EventHandler(Of ProjectPropertyChangedEventArgs)

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


QueryEditProjectFile Event

[image]

Sandcastle Help File Builder Documentation
SandcastleProject..::.QueryEditProjectFile Event
SandcastleProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This event is raised when a property is about to be changed to see if the project file can be edited.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public event EventHandler<CancelEventArgs> QueryEditProjectFile
Visual Basic (Declaration)
Public Event QueryEditProjectFile As EventHandler(Of CancelEventArgs)

Remarks

If the project file cannot be edited, the handler should cancel the event so that the property is not changed.

See Also

SandcastleProject Class
SandcastleBuilder.Utils Namespace


SdkLinkTarget Enumeration

[image]

Sandcastle Help File Builder Documentation
SdkLinkTarget Enumeration
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This public enumerated type defines the locations in which a browser window can be opened for the MSDN SDK links.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
[SerializableAttribute]
public enum SdkLinkTarget
Visual Basic (Declaration)
<SerializableAttribute> _
Public Enumeration SdkLinkTarget

Members

Member name | Description
Blank | The URL is loaded into a new unnamed window.
Self | The current document is replaced with the specified URL.
Parent | The URL is loaded into the current frame's parent. If the frame has no parent, this value acts like the value Self.
Top | The URL replaces any framesets that may be loaded. If there are no framesets defined, this value acts like the value Self.

See Also

SandcastleBuilder.Utils Namespace


SdkLinkType Enumeration

[image]

Sandcastle Help File Builder Documentation
SdkLinkType Enumeration
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This public enumerated type defines the type of links used to reference other help topics referring to framework (SDK) help topics.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
[SerializableAttribute]
public enum SdkLinkType
Visual Basic (Declaration)
<SerializableAttribute> _
Public Enumeration SdkLinkType

Members

Member name | Description
None | No active links.
Index | MS-Help style links for use within an HTML 2.x help file.
Msdn | Links to framework topics on MSDN. This is the default. This type is compatible with HTML 1.x and HTML 2.x help files.

See Also

SandcastleBuilder.Utils Namespace


SyntaxFilters Enumeration

[image]

Sandcastle Help File Builder Documentation
SyntaxFilters Enumeration
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This public enumerated type defines the languages to include in the help topic Syntax section.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
[SerializableAttribute]
[FlagsAttribute]
public enum SyntaxFilters
Visual Basic (Declaration)
<SerializableAttribute> _
<FlagsAttribute> _
Public Enumeration SyntaxFilters

Members

Member name | Description
None | Do not include the syntax section.
CSharp | Include C# syntax.
VisualBasic | Include VB.NET syntax.
CPlusPlus | Include C++ syntax.
JSharp | Include the J# syntax.
JScript | Include the JScript syntax.
VisualBasicUsage | Include the Visual Basic usage syntax.
XamlUsage | Include the XAML usage syntax.
JavaScript | Include the JavaScript syntax.
Standard | The standard set (C#, VB.NET, and C++).
AllButUsage | Include all languages except the usage filters
All | Include all languages and usage.

See Also

SandcastleBuilder.Utils Namespace


VisibleItems Enumeration

[image]

Sandcastle Help File Builder Documentation
VisibleItems Enumeration
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This public enumerated type defines the optional visible items in the help file.

Namespace: SandcastleBuilder.Utils
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
[SerializableAttribute]
[FlagsAttribute]
public enum VisibleItems
Visual Basic (Declaration)
<SerializableAttribute> _
<FlagsAttribute> _
Public Enumeration VisibleItems

Members

Member name | Description
None | None of the optional items are visible.
Attributes | Document attributes.
ExplicitInterfaceImplementations | Document explicit interface implementations.
InheritedMembers | Document inherited members.
InheritedFrameworkMembers | Document inherited framework members. For this to work, InheritedMembers must also be enabled.
Internals | Document internal members.
Privates | Document private members.
Protected | Document protected members.
ProtectedInternalAsProtected | Document "protected internal" members as "protected" only.
SealedProtected | Document protected members of sealed classes. For this to work, Protected must also be enabled.
PrivateFields | Document private fields. For this to work, Privates must also be enabled.
InheritedFrameworkPrivateMembers | Document inherited private framework members. For this to work InheritedFrameworkMembers must also be enabled.
InheritedFrameworkInternalMembers | Document inherited internal framework members. For this to work InheritedFrameworkMembers must also be enabled.

See Also

SandcastleBuilder.Utils Namespace


SandcastleBuilder.Utils.BuildComponent Namespace

[image]

Sandcastle Help File Builder Documentation
SandcastleBuilder.Utils.BuildComponent Namespace
Send Feedback

[This is preliminary documentation and is subject to change.]

This namespace contains the classes used to manage the configurations for third-party build components that can be merged into the sandcastle.config configuration file.

Classes

Class | Description
BuildComponentConfiguration | This collection class is used to hold the additional content items for a project.
BuildComponentInfo | This class contains information about the loaded build components.
BuildComponentManager | This class is used to manage the set of third party build components.
ComponentConfigurationDictionary | This collection class is used to hold the additional content items for a project.
ComponentPosition | This is used to define the position of a custom build component within the Sandcastle configuration file.

Enumerations

Enumeration | Description
ComponentPosition..::.Placement | This enumeration defines the placement values


BuildComponentConfiguration Class

[image]

Sandcastle Help File Builder Documentation
BuildComponentConfiguration Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This collection class is used to hold the additional content items for a project.

Namespace: SandcastleBuilder.Utils.BuildComponent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public class BuildComponentConfiguration : PropertyBasedCollectionItem
Visual Basic (Declaration)
Public Class BuildComponentConfiguration _
    Inherits PropertyBasedCollectionItem

Inheritance Hierarchy

System..::.Object
SandcastleBuilder.Utils..::.PropertyBasedCollectionItem
SandcastleBuilder.Utils.BuildComponent..::.BuildComponentConfiguration

See Also

BuildComponentConfiguration Members
SandcastleBuilder.Utils.BuildComponent Namespace


BuildComponentConfiguration Members

[image] [image]

Sandcastle Help File Builder Documentation
BuildComponentConfiguration Members
BuildComponentConfiguration Class Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BuildComponentConfiguration type exposes the following members.

Methods

Name | Description
CheckProjectIsEditable | This is used to see if the project can be edited. If not, abort the change by throwing an exception. (Inherited from PropertyBasedCollectionItem.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Configuration | This is used to get or set the component's configuration information.
Enabled | This is used to get or set the build component's enabled state
IsDirty | This is used to get or set the dirty state of the item (Inherited from PropertyBasedCollectionItem.)
ProjectFile | This is used to get the owning project file (Inherited from PropertyBasedCollectionItem.)

See Also

BuildComponentConfiguration Class
SandcastleBuilder.Utils.BuildComponent Namespace


BuildComponentConfiguration Methods

[image] [image]

Sandcastle Help File Builder Documentation
BuildComponentConfiguration Methods
BuildComponentConfiguration Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BuildComponentConfiguration type exposes the following members.

Methods

Name | Description
CheckProjectIsEditable | This is used to see if the project can be edited. If not, abort the change by throwing an exception. (Inherited from PropertyBasedCollectionItem.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BuildComponentConfiguration Class
SandcastleBuilder.Utils.BuildComponent Namespace


BuildComponentConfiguration Properties

[image] [image]

Sandcastle Help File Builder Documentation
BuildComponentConfiguration Properties
BuildComponentConfiguration Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BuildComponentConfiguration type exposes the following members.

Properties

Name | Description
Configuration | This is used to get or set the component's configuration information.
Enabled | This is used to get or set the build component's enabled state
IsDirty | This is used to get or set the dirty state of the item (Inherited from PropertyBasedCollectionItem.)
ProjectFile | This is used to get the owning project file (Inherited from PropertyBasedCollectionItem.)

See Also

BuildComponentConfiguration Class
SandcastleBuilder.Utils.BuildComponent Namespace


Configuration Property

[image]

Sandcastle Help File Builder Documentation
BuildComponentConfiguration..::.Configuration Property
BuildComponentConfiguration Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set the component's configuration information.

Namespace: SandcastleBuilder.Utils.BuildComponent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string Configuration { get; set; }
Visual Basic (Declaration)
Public Property Configuration As String

Field Value

This should be an XML fragment. The root node should be named configuration.

See Also

BuildComponentConfiguration Class
SandcastleBuilder.Utils.BuildComponent Namespace


Enabled Property

[image]

Sandcastle Help File Builder Documentation
BuildComponentConfiguration..::.Enabled Property
BuildComponentConfiguration Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set the build component's enabled state

Namespace: SandcastleBuilder.Utils.BuildComponent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool Enabled { get; set; }
Visual Basic (Declaration)
Public Property Enabled As Boolean

Field Value

If set to false, the component will not be used in the build.

See Also

BuildComponentConfiguration Class
SandcastleBuilder.Utils.BuildComponent Namespace


BuildComponentInfo Class

[image]

Sandcastle Help File Builder Documentation
BuildComponentInfo Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This class contains information about the loaded build components.

Namespace: SandcastleBuilder.Utils.BuildComponent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public class BuildComponentInfo
Visual Basic (Declaration)
Public Class BuildComponentInfo

Inheritance Hierarchy

System..::.Object
SandcastleBuilder.Utils.BuildComponent..::.BuildComponentInfo

See Also

BuildComponentInfo Members
SandcastleBuilder.Utils.BuildComponent Namespace


BuildComponentInfo Members

[image] [image]

Sandcastle Help File Builder Documentation
BuildComponentInfo Members
BuildComponentInfo Class Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BuildComponentInfo type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AssemblyPath | This read-only property returns the path to the assembly containing the component
ConceptualBuildPosition | This read-only property returns the position of the component in the conceptual build configuration file (conceptual.config).
ConfigureMethod | This read-only property returns the method name used to configure the component interactively from within the help file builder.
Copyright | This read-only property returns copyright information for the component.
DefaultConfiguration | This read-only property returns the default configuration for the component.
Dependencies | This read-only property returns the collection of component IDs on which this component depends.
Description | This read-only property returns a description of the component
Id | This read-only property returns the ID of the build component
InvalidReason | If not valid, this read-only property returns the reason
IsHidden | This read-only property returns the hidden flag
IsValid | This read-only property returns true if the component configuration is valid or false if it is not.
ReferenceBuildPosition | This read-only property returns the position of the component in the reference build configuration file (sandcastle.config).
TypeName | This read-only property returns the type name of the component
Version | This read-only property returns version information for the component.

See Also

BuildComponentInfo Class
SandcastleBuilder.Utils.BuildComponent Namespace


BuildComponentInfo Methods

[image] [image]

Sandcastle Help File Builder Documentation
BuildComponentInfo Methods
BuildComponentInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BuildComponentInfo type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BuildComponentInfo Class
SandcastleBuilder.Utils.BuildComponent Namespace


BuildComponentInfo Properties

[image] [image]

Sandcastle Help File Builder Documentation
BuildComponentInfo Properties
BuildComponentInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BuildComponentInfo type exposes the following members.

Properties

Name | Description
AssemblyPath | This read-only property returns the path to the assembly containing the component
ConceptualBuildPosition | This read-only property returns the position of the component in the conceptual build configuration file (conceptual.config).
ConfigureMethod | This read-only property returns the method name used to configure the component interactively from within the help file builder.
Copyright | This read-only property returns copyright information for the component.
DefaultConfiguration | This read-only property returns the default configuration for the component.
Dependencies | This read-only property returns the collection of component IDs on which this component depends.
Description | This read-only property returns a description of the component
Id | This read-only property returns the ID of the build component
InvalidReason | If not valid, this read-only property returns the reason
IsHidden | This read-only property returns the hidden flag
IsValid | This read-only property returns true if the component configuration is valid or false if it is not.
ReferenceBuildPosition | This read-only property returns the position of the component in the reference build configuration file (sandcastle.config).
TypeName | This read-only property returns the type name of the component
Version | This read-only property returns version information for the component.

See Also

BuildComponentInfo Class
SandcastleBuilder.Utils.BuildComponent Namespace


AssemblyPath Property

[image]

Sandcastle Help File Builder Documentation
BuildComponentInfo..::.AssemblyPath Property
BuildComponentInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns the path to the assembly containing the component

Namespace: SandcastleBuilder.Utils.BuildComponent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string AssemblyPath { get; }
Visual Basic (Declaration)
Public ReadOnly Property AssemblyPath As String

See Also

BuildComponentInfo Class
SandcastleBuilder.Utils.BuildComponent Namespace


ConceptualBuildPosition Property

[image]

Sandcastle Help File Builder Documentation
BuildComponentInfo..::.ConceptualBuildPosition Property
BuildComponentInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns the position of the component in the conceptual build configuration file (conceptual.config).

Namespace: SandcastleBuilder.Utils.BuildComponent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public ComponentPosition ConceptualBuildPosition { get; }
Visual Basic (Declaration)
Public ReadOnly Property ConceptualBuildPosition As ComponentPosition

Remarks

If not defined, it will not be used.

See Also

BuildComponentInfo Class
SandcastleBuilder.Utils.BuildComponent Namespace


ConfigureMethod Property

[image]

Sandcastle Help File Builder Documentation
BuildComponentInfo..::.ConfigureMethod Property
BuildComponentInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns the method name used to configure the component interactively from within the help file builder.

Namespace: SandcastleBuilder.Utils.BuildComponent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string ConfigureMethod { get; }
Visual Basic (Declaration)
Public ReadOnly Property ConfigureMethod As String

Remarks

If not specifed, a default editor will be used to allow modifying the raw XML configuration text.

See Also

BuildComponentInfo Class
SandcastleBuilder.Utils.BuildComponent Namespace


Copyright Property

[image]

Sandcastle Help File Builder Documentation
BuildComponentInfo..::.Copyright Property
BuildComponentInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns copyright information for the component.

Namespace: SandcastleBuilder.Utils.BuildComponent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string Copyright { get; }
Visual Basic (Declaration)
Public ReadOnly Property Copyright As String

See Also

BuildComponentInfo Class
SandcastleBuilder.Utils.BuildComponent Namespace


DefaultConfiguration Property

[image]

Sandcastle Help File Builder Documentation
BuildComponentInfo..::.DefaultConfiguration Property
BuildComponentInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns the default configuration for the component.

Namespace: SandcastleBuilder.Utils.BuildComponent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string DefaultConfiguration { get; }
Visual Basic (Declaration)
Public ReadOnly Property DefaultConfiguration As String

Remarks

This will include the enclosing <component> tag.

See Also

BuildComponentInfo Class
SandcastleBuilder.Utils.BuildComponent Namespace


Dependencies Property

[image]

Sandcastle Help File Builder Documentation
BuildComponentInfo..::.Dependencies Property
BuildComponentInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns the collection of component IDs on which this component depends.

Namespace: SandcastleBuilder.Utils.BuildComponent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public ReadOnlyCollection<string> Dependencies { get; }
Visual Basic (Declaration)
Public ReadOnly Property Dependencies As ReadOnlyCollection(Of String)

See Also

BuildComponentInfo Class
SandcastleBuilder.Utils.BuildComponent Namespace


Description Property

[image]

Sandcastle Help File Builder Documentation
BuildComponentInfo..::.Description Property
BuildComponentInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns a description of the component

Namespace: SandcastleBuilder.Utils.BuildComponent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string Description { get; }
Visual Basic (Declaration)
Public ReadOnly Property Description As String

See Also

BuildComponentInfo Class
SandcastleBuilder.Utils.BuildComponent Namespace


Id Property

[image]

Sandcastle Help File Builder Documentation
BuildComponentInfo..::.Id Property
BuildComponentInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns the ID of the build component

Namespace: SandcastleBuilder.Utils.BuildComponent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string Id { get; }
Visual Basic (Declaration)
Public ReadOnly Property Id As String

See Also

BuildComponentInfo Class
SandcastleBuilder.Utils.BuildComponent Namespace


InvalidReason Property

[image]

Sandcastle Help File Builder Documentation
BuildComponentInfo..::.InvalidReason Property
BuildComponentInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

If not valid, this read-only property returns the reason

Namespace: SandcastleBuilder.Utils.BuildComponent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string InvalidReason { get; }
Visual Basic (Declaration)
Public ReadOnly Property InvalidReason As String

See Also

BuildComponentInfo Class
SandcastleBuilder.Utils.BuildComponent Namespace


IsHidden Property

[image]

Sandcastle Help File Builder Documentation
BuildComponentInfo..::.IsHidden Property
BuildComponentInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns the hidden flag

Namespace: SandcastleBuilder.Utils.BuildComponent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool IsHidden { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsHidden As Boolean

Remarks

If hidden, the component will not be selectable from within the help file builder.

See Also

BuildComponentInfo Class
SandcastleBuilder.Utils.BuildComponent Namespace


IsValid Property

[image]

Sandcastle Help File Builder Documentation
BuildComponentInfo..::.IsValid Property
BuildComponentInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns true if the component configuration is valid or false if it is not.

Namespace: SandcastleBuilder.Utils.BuildComponent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool IsValid { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsValid As Boolean

Remarks

If not valid, the component cannot be used.

See Also

BuildComponentInfo Class
SandcastleBuilder.Utils.BuildComponent Namespace


ReferenceBuildPosition Property

[image]

Sandcastle Help File Builder Documentation
BuildComponentInfo..::.ReferenceBuildPosition Property
BuildComponentInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns the position of the component in the reference build configuration file (sandcastle.config).

Namespace: SandcastleBuilder.Utils.BuildComponent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public ComponentPosition ReferenceBuildPosition { get; }
Visual Basic (Declaration)
Public ReadOnly Property ReferenceBuildPosition As ComponentPosition

Remarks

If not defined, it will not be used.

See Also

BuildComponentInfo Class
SandcastleBuilder.Utils.BuildComponent Namespace


TypeName Property

[image]

Sandcastle Help File Builder Documentation
BuildComponentInfo..::.TypeName Property
BuildComponentInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns the type name of the component

Namespace: SandcastleBuilder.Utils.BuildComponent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string TypeName { get; }
Visual Basic (Declaration)
Public ReadOnly Property TypeName As String

See Also

BuildComponentInfo Class
SandcastleBuilder.Utils.BuildComponent Namespace


Version Property

[image]

Sandcastle Help File Builder Documentation
BuildComponentInfo..::.Version Property
BuildComponentInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns version information for the component.

Namespace: SandcastleBuilder.Utils.BuildComponent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public Version Version { get; }
Visual Basic (Declaration)
Public ReadOnly Property Version As Version

See Also

BuildComponentInfo Class
SandcastleBuilder.Utils.BuildComponent Namespace


BuildComponentManager Class

[image]

Sandcastle Help File Builder Documentation
BuildComponentManager Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This class is used to manage the set of third party build components.

Namespace: SandcastleBuilder.Utils.BuildComponent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public static class BuildComponentManager
Visual Basic (Declaration)
Public NotInheritable Class BuildComponentManager

Inheritance Hierarchy

System..::.Object
SandcastleBuilder.Utils.BuildComponent..::.BuildComponentManager

See Also

BuildComponentManager Members
SandcastleBuilder.Utils.BuildComponent Namespace


BuildComponentManager Members

[image] [image]

Sandcastle Help File Builder Documentation
BuildComponentManager Members
BuildComponentManager Class Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BuildComponentManager type exposes the following members.

Methods

Name | Description
ResolveComponentPath | This is used to resolve replacement tags and environment variables in a build component's assembly path and return the actual path to it.

Properties

Name | Description
BuildComponents | This returns a dictionary containing the loaded build component information.
BuildComponentsFolder | This read-only property returns the build components folder
SandcastlePath | This is used to set or get the Sandcastle installation folder

See Also

BuildComponentManager Class
SandcastleBuilder.Utils.BuildComponent Namespace


BuildComponentManager Methods

[image] [image]

Sandcastle Help File Builder Documentation
BuildComponentManager Methods
BuildComponentManager Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BuildComponentManager type exposes the following members.

Methods

Name | Description
ResolveComponentPath | This is used to resolve replacement tags and environment variables in a build component's assembly path and return the actual path to it.

See Also

BuildComponentManager Class
SandcastleBuilder.Utils.BuildComponent Namespace


ResolveComponentPath Method

[image]

Sandcastle Help File Builder Documentation
BuildComponentManager..::.ResolveComponentPath Method
BuildComponentManager Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to resolve replacement tags and environment variables in a build component's assembly path and return the actual path to it.

Namespace: SandcastleBuilder.Utils.BuildComponent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public static string ResolveComponentPath(
    string path
)
Visual Basic (Declaration)
Public Shared Function ResolveComponentPath ( _
    path As String _
) As String

Parameters

path
Type: System..::.String
The path to resolve

Return Value

The actual absolute path to the assembly

See Also

BuildComponentManager Class
SandcastleBuilder.Utils.BuildComponent Namespace


BuildComponentManager Properties

[image] [image]

Sandcastle Help File Builder Documentation
BuildComponentManager Properties
BuildComponentManager Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BuildComponentManager type exposes the following members.

Properties

Name | Description
BuildComponents | This returns a dictionary containing the loaded build component information.
BuildComponentsFolder | This read-only property returns the build components folder
SandcastlePath | This is used to set or get the Sandcastle installation folder

See Also

BuildComponentManager Class
SandcastleBuilder.Utils.BuildComponent Namespace


BuildComponents Property

[image]

Sandcastle Help File Builder Documentation
BuildComponentManager..::.BuildComponents Property
BuildComponentManager Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This returns a dictionary containing the loaded build component information.

Namespace: SandcastleBuilder.Utils.BuildComponent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public static Dictionary<string, BuildComponentInfo> BuildComponents { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property BuildComponents As Dictionary(Of String, BuildComponentInfo)

Field Value

The dictionary keys are the component IDs.

See Also

BuildComponentManager Class
SandcastleBuilder.Utils.BuildComponent Namespace


BuildComponentsFolder Property

[image]

Sandcastle Help File Builder Documentation
BuildComponentManager..::.BuildComponentsFolder Property
BuildComponentManager Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns the build components folder

Namespace: SandcastleBuilder.Utils.BuildComponent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public static string BuildComponentsFolder { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property BuildComponentsFolder As String

See Also

BuildComponentManager Class
SandcastleBuilder.Utils.BuildComponent Namespace


SandcastlePath Property

[image]

Sandcastle Help File Builder Documentation
BuildComponentManager..::.SandcastlePath Property
BuildComponentManager Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to set or get the Sandcastle installation folder

Namespace: SandcastleBuilder.Utils.BuildComponent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public static string SandcastlePath { get; set; }
Visual Basic (Declaration)
Public Shared Property SandcastlePath As String

See Also

BuildComponentManager Class
SandcastleBuilder.Utils.BuildComponent Namespace


ComponentConfigurationDictionary Class

[image]

Sandcastle Help File Builder Documentation
ComponentConfigurationDictionary Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This collection class is used to hold the additional content items for a project.

Namespace: SandcastleBuilder.Utils.BuildComponent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
[SerializableAttribute]
public class ComponentConfigurationDictionary : Dictionary<string, BuildComponentConfiguration>
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class ComponentConfigurationDictionary _
    Inherits Dictionary(Of String, BuildComponentConfiguration)

Inheritance Hierarchy

System..::.Object
System.Collections.Generic..::.Dictionary <(Of <( String, BuildComponentConfiguration >)>)
SandcastleBuilder.Utils.BuildComponent..::.ComponentConfigurationDictionary

See Also

ComponentConfigurationDictionary Members
SandcastleBuilder.Utils.BuildComponent Namespace


ComponentConfigurationDictionary Members

[image] [image]

Sandcastle Help File Builder Documentation
ComponentConfigurationDictionary Members
ComponentConfigurationDictionary Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ComponentConfigurationDictionary type exposes the following members.

Constructors

Name | Description
ComponentConfigurationDictionary | Default constructor

Methods

Name | Description
Add | Overloaded.
Clear | Removes all keys and values from the Dictionary<(Of <(TKey, TValue>)>). (Inherited from Dictionary <(Of <( String, BuildComponentConfiguration >)>).)
ContainsKey | Determines whether the Dictionary<(Of <(TKey, TValue>)>) contains the specified key. (Inherited from Dictionary <(Of <( String, BuildComponentConfiguration >)>).)
ContainsValue | Determines whether the Dictionary<(Of <(TKey, TValue>)>) contains a specific value. (Inherited from Dictionary <(Of <( String, BuildComponentConfiguration >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(TKey, TValue>)>). (Inherited from Dictionary <(Of <( String, BuildComponentConfiguration >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(TKey, TValue>)>) instance. (Inherited from Dictionary <(Of <( String, BuildComponentConfiguration >)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <( String, BuildComponentConfiguration >)>).)
Remove | Removes the value with the specified key from the Dictionary<(Of <(TKey, TValue>)>). (Inherited from Dictionary <(Of <( String, BuildComponentConfiguration >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <( String, BuildComponentConfiguration >)>).)

Properties

Name | Description
Comparer | Gets the IEqualityComparer<(Of <(T>)>) that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <( String, BuildComponentConfiguration >)>).)
Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(TKey, TValue>)>). (Inherited from Dictionary <(Of <( String, BuildComponentConfiguration >)>).)
IsDirty | This is used to get or set the dirty state of the collection
Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <( String, BuildComponentConfiguration >)>).)
Keys | Gets a collection containing the keys in the Dictionary<(Of <(TKey, TValue>)>). (Inherited from Dictionary <(Of <( String, BuildComponentConfiguration >)>).)
Values | Gets a collection containing the values in the Dictionary<(Of <(TKey, TValue>)>). (Inherited from Dictionary <(Of <( String, BuildComponentConfiguration >)>).)

Events

Name | Description
DictionaryChanged | This event is raised when the dictionary is modified

See Also

ComponentConfigurationDictionary Class
SandcastleBuilder.Utils.BuildComponent Namespace


ComponentConfigurationDictionary Constructor

[image]

Sandcastle Help File Builder Documentation
ComponentConfigurationDictionary Constructor
ComponentConfigurationDictionary Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Default constructor

Namespace: SandcastleBuilder.Utils.BuildComponent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public ComponentConfigurationDictionary(
    SandcastleProject project
)
Visual Basic (Declaration)
Public Sub New ( _
    project As SandcastleProject _
)

Parameters

project
Type: SandcastleBuilder.Utils..::.SandcastleProject
The project that owns the collection

See Also

ComponentConfigurationDictionary Class
SandcastleBuilder.Utils.BuildComponent Namespace


ComponentConfigurationDictionary Methods

[image] [image]

Sandcastle Help File Builder Documentation
ComponentConfigurationDictionary Methods
ComponentConfigurationDictionary Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ComponentConfigurationDictionary type exposes the following members.

Methods

Name | Description
Add | Overloaded.
Clear | Removes all keys and values from the Dictionary<(Of <(TKey, TValue>)>). (Inherited from Dictionary <(Of <( String, BuildComponentConfiguration >)>).)
ContainsKey | Determines whether the Dictionary<(Of <(TKey, TValue>)>) contains the specified key. (Inherited from Dictionary <(Of <( String, BuildComponentConfiguration >)>).)
ContainsValue | Determines whether the Dictionary<(Of <(TKey, TValue>)>) contains a specific value. (Inherited from Dictionary <(Of <( String, BuildComponentConfiguration >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(TKey, TValue>)>). (Inherited from Dictionary <(Of <( String, BuildComponentConfiguration >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(TKey, TValue>)>) instance. (Inherited from Dictionary <(Of <( String, BuildComponentConfiguration >)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <( String, BuildComponentConfiguration >)>).)
Remove | Removes the value with the specified key from the Dictionary<(Of <(TKey, TValue>)>). (Inherited from Dictionary <(Of <( String, BuildComponentConfiguration >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <( String, BuildComponentConfiguration >)>).)

See Also

ComponentConfigurationDictionary Class
SandcastleBuilder.Utils.BuildComponent Namespace


Add Method

[image] [image]

Sandcastle Help File Builder Documentation
ComponentConfigurationDictionary..::.Add Method
ComponentConfigurationDictionary Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Add(TKey, TValue) | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <( String, BuildComponentConfiguration >)>).)
Add(String, Boolean, String) | Add a new item to the dictionary

See Also

ComponentConfigurationDictionary Class
ComponentConfigurationDictionary Members
SandcastleBuilder.Utils.BuildComponent Namespace


Add Method (String, Boolean, String)

[image]

Sandcastle Help File Builder Documentation
ComponentConfigurationDictionary..::.Add Method (String, Boolean, String)
ComponentConfigurationDictionary Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Add a new item to the dictionary

Namespace: SandcastleBuilder.Utils.BuildComponent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public BuildComponentConfiguration Add(
    string id,
    bool enabled,
    string config
)
Visual Basic (Declaration)
Public Function Add ( _
    id As String, _
    enabled As Boolean, _
    config As String _
) As BuildComponentConfiguration

Parameters

id
Type: System..::.String
The component ID
enabled
Type: System..::.Boolean
True for enabled, false disabled
config
Type: System..::.String
The component configuration

Return Value

The BuildComponentConfiguration added to the project. If the ID already exists in the collection, the existing item is returned.

Remarks

The BuildComponentConfiguration constructor is internal so that we control creation of the items and can associate them with the project.

See Also

ComponentConfigurationDictionary Class
Add Overload
SandcastleBuilder.Utils.BuildComponent Namespace


ComponentConfigurationDictionary Properties

[image] [image]

Sandcastle Help File Builder Documentation
ComponentConfigurationDictionary Properties
ComponentConfigurationDictionary Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ComponentConfigurationDictionary type exposes the following members.

Properties

Name | Description
Comparer | Gets the IEqualityComparer<(Of <(T>)>) that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <( String, BuildComponentConfiguration >)>).)
Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(TKey, TValue>)>). (Inherited from Dictionary <(Of <( String, BuildComponentConfiguration >)>).)
IsDirty | This is used to get or set the dirty state of the collection
Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <( String, BuildComponentConfiguration >)>).)
Keys | Gets a collection containing the keys in the Dictionary<(Of <(TKey, TValue>)>). (Inherited from Dictionary <(Of <( String, BuildComponentConfiguration >)>).)
Values | Gets a collection containing the values in the Dictionary<(Of <(TKey, TValue>)>). (Inherited from Dictionary <(Of <( String, BuildComponentConfiguration >)>).)

See Also

ComponentConfigurationDictionary Class
SandcastleBuilder.Utils.BuildComponent Namespace


IsDirty Property

[image]

Sandcastle Help File Builder Documentation
ComponentConfigurationDictionary..::.IsDirty Property
ComponentConfigurationDictionary Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set the dirty state of the collection

Namespace: SandcastleBuilder.Utils.BuildComponent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool IsDirty { get; set; }
Visual Basic (Declaration)
Public Property IsDirty As Boolean

See Also

ComponentConfigurationDictionary Class
SandcastleBuilder.Utils.BuildComponent Namespace


ComponentConfigurationDictionary Events

[image] [image]

Sandcastle Help File Builder Documentation
ComponentConfigurationDictionary Events
ComponentConfigurationDictionary Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ComponentConfigurationDictionary type exposes the following members.

Events

Name | Description
DictionaryChanged | This event is raised when the dictionary is modified

See Also

ComponentConfigurationDictionary Class
SandcastleBuilder.Utils.BuildComponent Namespace


DictionaryChanged Event

[image]

Sandcastle Help File Builder Documentation
ComponentConfigurationDictionary..::.DictionaryChanged Event
ComponentConfigurationDictionary Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This event is raised when the dictionary is modified

Namespace: SandcastleBuilder.Utils.BuildComponent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public event ListChangedEventHandler DictionaryChanged
Visual Basic (Declaration)
Public Event DictionaryChanged As ListChangedEventHandler

See Also

ComponentConfigurationDictionary Class
SandcastleBuilder.Utils.BuildComponent Namespace


ComponentPosition Class

[image]

Sandcastle Help File Builder Documentation
ComponentPosition Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to define the position of a custom build component within the Sandcastle configuration file.

Namespace: SandcastleBuilder.Utils.BuildComponent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public class ComponentPosition
Visual Basic (Declaration)
Public Class ComponentPosition

Inheritance Hierarchy

System..::.Object
SandcastleBuilder.Utils.BuildComponent..::.ComponentPosition

See Also

ComponentPosition Members
SandcastleBuilder.Utils.BuildComponent Namespace


ComponentPosition Members

[image] [image]

Sandcastle Help File Builder Documentation
ComponentPosition Members
ComponentPosition Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ComponentPosition type exposes the following members.

Constructors

Name | Description
ComponentPosition | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Id | This read-only property returns the ID of the component
Instance | This read-only property returns the instance of the component to replace, insert before, or insert after.
Place | This read-only property returns the placement value
TypeName | This read-only property returns the type name of the component

See Also

ComponentPosition Class
SandcastleBuilder.Utils.BuildComponent Namespace


ComponentPosition Constructor

[image] [image]

Sandcastle Help File Builder Documentation
ComponentPosition Constructor
ComponentPosition Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ComponentPosition()()() | Constructor
ComponentPosition(XPathNavigator) | Constructor

See Also

ComponentPosition Class
ComponentPosition Members
SandcastleBuilder.Utils.BuildComponent Namespace


ComponentPosition Constructor

[image]

Sandcastle Help File Builder Documentation
ComponentPosition Constructor
ComponentPosition Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Utils.BuildComponent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public ComponentPosition()
Visual Basic (Declaration)
Public Sub New

See Also

ComponentPosition Class
ComponentPosition Overload
SandcastleBuilder.Utils.BuildComponent Namespace


ComponentPosition Constructor (XPathNavigator)

[image]

Sandcastle Help File Builder Documentation
ComponentPosition Constructor (XPathNavigator)
ComponentPosition Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Utils.BuildComponent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public ComponentPosition(
    XPathNavigator config
)
Visual Basic (Declaration)
Public Sub New ( _
    config As XPathNavigator _
)

Parameters

config
Type: System.Xml.XPath..::.XPathNavigator
The XPath navigator containing the configuration

See Also

ComponentPosition Class
ComponentPosition Overload
SandcastleBuilder.Utils.BuildComponent Namespace


ComponentPosition Methods

[image] [image]

Sandcastle Help File Builder Documentation
ComponentPosition Methods
ComponentPosition Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ComponentPosition type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ComponentPosition Class
SandcastleBuilder.Utils.BuildComponent Namespace


ComponentPosition Properties

[image] [image]

Sandcastle Help File Builder Documentation
ComponentPosition Properties
ComponentPosition Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ComponentPosition type exposes the following members.

Properties

Name | Description
Id | This read-only property returns the ID of the component
Instance | This read-only property returns the instance of the component to replace, insert before, or insert after.
Place | This read-only property returns the placement value
TypeName | This read-only property returns the type name of the component

See Also

ComponentPosition Class
SandcastleBuilder.Utils.BuildComponent Namespace


Id Property

[image]

Sandcastle Help File Builder Documentation
ComponentPosition..::.Id Property
ComponentPosition Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns the ID of the component

Namespace: SandcastleBuilder.Utils.BuildComponent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string Id { get; }
Visual Basic (Declaration)
Public ReadOnly Property Id As String

Remarks

If not specified, use TypeName.

See Also

ComponentPosition Class
SandcastleBuilder.Utils.BuildComponent Namespace


Instance Property

[image]

Sandcastle Help File Builder Documentation
ComponentPosition..::.Instance Property
ComponentPosition Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns the instance of the component to replace, insert before, or insert after.

Namespace: SandcastleBuilder.Utils.BuildComponent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public int Instance { get; }
Visual Basic (Declaration)
Public ReadOnly Property Instance As Integer

Remarks

If not specified 1 is assumed.

See Also

ComponentPosition Class
SandcastleBuilder.Utils.BuildComponent Namespace


Place Property

[image]

Sandcastle Help File Builder Documentation
ComponentPosition..::.Place Property
ComponentPosition Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns the placement value

Namespace: SandcastleBuilder.Utils.BuildComponent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public ComponentPosition..::.Placement Place { get; }
Visual Basic (Declaration)
Public ReadOnly Property Place As ComponentPosition..::.Placement

See Also

ComponentPosition Class
SandcastleBuilder.Utils.BuildComponent Namespace


TypeName Property

[image]

Sandcastle Help File Builder Documentation
ComponentPosition..::.TypeName Property
ComponentPosition Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns the type name of the component

Namespace: SandcastleBuilder.Utils.BuildComponent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string TypeName { get; }
Visual Basic (Declaration)
Public ReadOnly Property TypeName As String

Remarks

If not specified, use Id.

See Also

ComponentPosition Class
SandcastleBuilder.Utils.BuildComponent Namespace


ComponentPosition.Placement Enumeration

[image]

Sandcastle Help File Builder Documentation
ComponentPosition..::.Placement Enumeration
ComponentPosition Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This enumeration defines the placement values

Namespace: SandcastleBuilder.Utils.BuildComponent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
[SerializableAttribute]
public enum Placement
Visual Basic (Declaration)
<SerializableAttribute> _
Public Enumeration Placement

Members

Member name | Description
Before | Place the component before the one indicated.
After | Place the component after the one indicated.
Start | Insert the component at the start of the configuration file.
End | Insert the component at the end of the configuration file.
Replace | Replace the indicated component configuration with this one.
NotUsed | The component is not used in this configuration

See Also

SandcastleBuilder.Utils.BuildComponent Namespace


SandcastleBuilder.Utils.BuildEngine Namespace

[image]

Sandcastle Help File Builder Documentation
SandcastleBuilder.Utils.BuildEngine Namespace
Send Feedback

[This is preliminary documentation and is subject to change.]

This namespace contains the classes related to the build engine.

Classes

Class | Description
BuildProcess | This class is used to handle all aspects of the build process in a separate thread.
BuildProgressEventArgs | This is a custom event arguments class for the BuildProgress event.
FullTextIndex | This is a really basic implementation of an algorithm used to create a full-text index of the website pages so that they can be searched using the ASP.NET web pages.
XmlCommentsFile | This represents an XML comment file and is used when searching for and adding missing documentation tag information.
XmlCommentsFileCollection | This collection class is used to hold the XML comments files during the build process.

Enumerations

Enumeration | Description
BuildStep | This public enumerated type defines the build steps used when reporting progress during a build.


BuildProcess Class

[image]

Sandcastle Help File Builder Documentation
BuildProcess Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This class is used to handle all aspects of the build process in a separate thread.
This class is used to handle all aspects of the build process in a separate thread.

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public class BuildProcess
Visual Basic (Declaration)
Public Class BuildProcess

Inheritance Hierarchy

System..::.Object
SandcastleBuilder.Utils.BuildEngine..::.BuildProcess

See Also

BuildProcess Members
SandcastleBuilder.Utils.BuildEngine Namespace


BuildProcess Members

[image] [image]

Sandcastle Help File Builder Documentation
BuildProcess Members
BuildProcess Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BuildProcess type exposes the following members.

Constructors

Name | Description
BuildProcess | Overloaded. There are two overloads for the constructor.

Methods

Name | Description
ApplyManualApiFilter | This is used to manually apply the specified API filter to the specified reflection information file.
ApplyVisibilityProperties | Apply the project's Visibility category properties to the reflection information file.
Build | Call this method to perform the build on the project.
CopyAdditionalContent | This is called to copy the additional content files and build a list of them for the help file project.
CopyStandardHelpContent | This is called to create the help project output folder and copy the standard content files (art, media, scripts, and styles) to the help project folder.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExecuteAfterStepPlugIns | This can be used by plug-ins using the InsteadOf execution behavior to execute plug-ins that want to run after the plug-in has executed its main processing.
ExecuteBeforeStepPlugIns | This can be used by plug-ins using the InsteadOf execution behavior to execute plug-ins that want to run before the plug-in executes its main processing.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindOnFixedDrives | Find a folder by searching the Program Files folders on all fixed drives.
FindSdkExecutable | This is used to find the named executable in one of the Visual Studio SDK installation folders.
FindTools | Find the Sandcastle tools and the HTML help compiler
GenerateHtmlToc | This is called to generate the HTML table of contents when creating the website output.
GenerateNamespaceSummaries | This is called to generate the namespace summary file
GenerateWebsite | This is used to generate the website helper files and copy the output to the project output folder ready for use as a website.
GetFrameworkCommentsFiles | This is used to get a list of .NET Framework comments file locations.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HelpProjectFileList | This returns a complete list of files for inclusion in the compiled help file.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ModifyHelpTopicFilenames | This is used to change the filenames assigned to each member in the reflection information file.
OnBuildProgress | This raises the BuildProgress event.
OnBuildStepChanged | This raises the BuildStepChanged event.
ReadWithEncoding | This is used to read in a file using an appropriate encoding method
RecursiveCopy | This copies files from the specified source folder to the specified destination folder. If any subfolders are found below the source folder and the wildcard is "*.*", the subfolders are also copied recursively.
ReportProgress | Overloaded. This method has two overloads.
ReportWarning | This is used to report a warning that may need attention
RunProcess | This is used to run a step in the build process
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformTemplate | Transform the specified template by inserting the necessary values into the place holders and saving it to the working folder.
TransformText | Transform the specified template text by inserting the necessary values into the place holders tags.
UpdateTableOfContents | This is called to determine the default topic for the help file and insert any additional table of contents entries for the additional content files.
ValidateDocumentationSources | Validate the documentation source information and copy the files to the working folder.
VerifySafePath | Make sure the path isn't one the user would regret having nuked without warning.

Properties

Name | Description
BuildApiFilter | This read-only property returns the API filter that is used at build-time to filter the API elements.
CommentsFiles | This read-only property returns the XML comments files collection
ConceptualContent | This is used to get the conceptual content settings in effect for the build.
CurrentFormat | This returns the current help file format being generated
CurrentProject | This returns the current project being used for the build
Help1CompilerFolder | This returns the name of the HTML Help 1.x compiler folder determined by the build process.
Help1Files | This returns a list of the Help 1 (CHM) files that were built
Help2CompilerFolder | This returns the name of the HTML Help 2.x compiler folder determined by the build process.
Help2Files | This returns a list of the Help 2 (HxS) files that were built
HelpFileBuilderFolder | This returns the location of the help file builder executables
IsPartialBuild | This read-only property is used to get the partial build flag
LoadedPlugIns | This returns a Dictionary<(Of <(TKey, TValue>)>) containing the currently loaded plug-ins.
LogFilename | This returns the name of the log file used for saving the build progress messages.
MSBuildExePath | This returns the path to MSBuild.exe
OutputFolder | This returns the output folder where the log file and help file can be found after the build process has finished.
PresentationStyleFolder | This returns the name of the main Sandcastle presentation style folder determined by the build process.
ProjectFilename | This returns the project filename without the folder
ProjectFolder | This returns the project folder name
ReflectionInfoFilename | This returns the name of the reflection information file
SandcastleFolder | This returns the name of the main Sandcastle folder determined by the build process.
SuppressApiFilter | This controls whether or not the API filter is suppressed.
TemplateFolder | This returns the location of the help file builder template folder.
WebsiteFiles | This returns a list of the website files that were built
WorkingFolder | This returns the name of the working files folder

Events

Name | Description
BuildProgress | This event is raised to report progress information throughout each build step.
BuildStepChanged | This event is raised to report a change in the build step

See Also

BuildProcess Class
SandcastleBuilder.Utils.BuildEngine Namespace


BuildProcess Constructor

[image] [image]

Sandcastle Help File Builder Documentation
BuildProcess Constructor
BuildProcess Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

There are two overloads for the constructor.

Overload List

Name | Description
BuildProcess(SandcastleProject) | Constructor
BuildProcess(SandcastleProject, Boolean) | Constructor

See Also

BuildProcess Class
BuildProcess Members
SandcastleBuilder.Utils.BuildEngine Namespace


BuildProcess Constructor (SandcastleProject)

[image]

Sandcastle Help File Builder Documentation
BuildProcess Constructor (SandcastleProject)
BuildProcess Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public BuildProcess(
    SandcastleProject buildProject
)
Visual Basic (Declaration)
Public Sub New ( _
    buildProject As SandcastleProject _
)

Parameters

buildProject
Type: SandcastleBuilder.Utils..::.SandcastleProject
The project to build

See Also

BuildProcess Class
BuildProcess Overload
SandcastleBuilder.Utils.BuildEngine Namespace


BuildProcess Constructor (SandcastleProject, Boolean)

[image]

Sandcastle Help File Builder Documentation
BuildProcess Constructor (SandcastleProject, Boolean)
BuildProcess Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public BuildProcess(
    SandcastleProject buildProject,
    bool partialBuild
)
Visual Basic (Declaration)
Public Sub New ( _
    buildProject As SandcastleProject, _
    partialBuild As Boolean _
)

Parameters

buildProject
Type: SandcastleBuilder.Utils..::.SandcastleProject
The project to build
partialBuild
Type: System..::.Boolean
Pass true to perform a partial build

See Also

BuildProcess Class
BuildProcess Overload
SandcastleBuilder.Utils.BuildEngine Namespace


BuildProcess Methods

[image] [image]

Sandcastle Help File Builder Documentation
BuildProcess Methods
BuildProcess Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BuildProcess type exposes the following members.

Methods

Name | Description
ApplyManualApiFilter | This is used to manually apply the specified API filter to the specified reflection information file.
ApplyVisibilityProperties | Apply the project's Visibility category properties to the reflection information file.
Build | Call this method to perform the build on the project.
CopyAdditionalContent | This is called to copy the additional content files and build a list of them for the help file project.
CopyStandardHelpContent | This is called to create the help project output folder and copy the standard content files (art, media, scripts, and styles) to the help project folder.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExecuteAfterStepPlugIns | This can be used by plug-ins using the InsteadOf execution behavior to execute plug-ins that want to run after the plug-in has executed its main processing.
ExecuteBeforeStepPlugIns | This can be used by plug-ins using the InsteadOf execution behavior to execute plug-ins that want to run before the plug-in executes its main processing.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindOnFixedDrives | Find a folder by searching the Program Files folders on all fixed drives.
FindSdkExecutable | This is used to find the named executable in one of the Visual Studio SDK installation folders.
FindTools | Find the Sandcastle tools and the HTML help compiler
GenerateHtmlToc | This is called to generate the HTML table of contents when creating the website output.
GenerateNamespaceSummaries | This is called to generate the namespace summary file
GenerateWebsite | This is used to generate the website helper files and copy the output to the project output folder ready for use as a website.
GetFrameworkCommentsFiles | This is used to get a list of .NET Framework comments file locations.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HelpProjectFileList | This returns a complete list of files for inclusion in the compiled help file.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ModifyHelpTopicFilenames | This is used to change the filenames assigned to each member in the reflection information file.
OnBuildProgress | This raises the BuildProgress event.
OnBuildStepChanged | This raises the BuildStepChanged event.
ReadWithEncoding | This is used to read in a file using an appropriate encoding method
RecursiveCopy | This copies files from the specified source folder to the specified destination folder. If any subfolders are found below the source folder and the wildcard is "*.*", the subfolders are also copied recursively.
ReportProgress | Overloaded. This method has two overloads.
ReportWarning | This is used to report a warning that may need attention
RunProcess | This is used to run a step in the build process
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformTemplate | Transform the specified template by inserting the necessary values into the place holders and saving it to the working folder.
TransformText | Transform the specified template text by inserting the necessary values into the place holders tags.
UpdateTableOfContents | This is called to determine the default topic for the help file and insert any additional table of contents entries for the additional content files.
ValidateDocumentationSources | Validate the documentation source information and copy the files to the working folder.
VerifySafePath | Make sure the path isn't one the user would regret having nuked without warning.

See Also

BuildProcess Class
SandcastleBuilder.Utils.BuildEngine Namespace


ApplyManualApiFilter Method

[image]

Sandcastle Help File Builder Documentation
BuildProcess..::.ApplyManualApiFilter Method
BuildProcess Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to manually apply the specified API filter to the specified reflection information file.

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public void ApplyManualApiFilter(
    ApiFilterCollection apiFilter,
    string reflectionFilename
)
Visual Basic (Declaration)
Public Sub ApplyManualApiFilter ( _
    apiFilter As ApiFilterCollection, _
    reflectionFilename As String _
)

Parameters

apiFilter
Type: SandcastleBuilder.Utils..::.ApiFilterCollection
The API filter to apply
reflectionFilename
Type: System..::.String
The reflection information file

Remarks

This can be used by any plug-in that does not produce a reflection information file using MRefBuilder.exe. In such cases, the API filter is not applied unless the plug-in uses this method. If the reflection information file is produced by MRefBuilder.exe, there is no need to use this method as it will apply the API filter automatically to the file that it produces.

See Also

BuildProcess Class
SandcastleBuilder.Utils.BuildEngine Namespace


ApplyVisibilityProperties Method

[image]

Sandcastle Help File Builder Documentation
BuildProcess..::.ApplyVisibilityProperties Method
BuildProcess Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Apply the project's Visibility category properties to the reflection information file.

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected void ApplyVisibilityProperties()
Visual Basic (Declaration)
Protected Sub ApplyVisibilityProperties

Remarks

This is used to remove entries from the reflection information file so that it does not appear in the help file. See the Document* properties in the SandcastleProject class for information on the items removed.

See Also

BuildProcess Class
SandcastleBuilder.Utils.BuildEngine Namespace


Build Method

[image]

Sandcastle Help File Builder Documentation
BuildProcess..::.Build Method
BuildProcess Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Call this method to perform the build on the project.

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public void Build()
Visual Basic (Declaration)
Public Sub Build

See Also

BuildProcess Class
SandcastleBuilder.Utils.BuildEngine Namespace


CopyAdditionalContent Method

[image]

Sandcastle Help File Builder Documentation
BuildProcess..::.CopyAdditionalContent Method
BuildProcess Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is called to copy the additional content files and build a list of them for the help file project.

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected void CopyAdditionalContent()
Visual Basic (Declaration)
Protected Sub CopyAdditionalContent

Remarks

Note that for wilcard content items, the folders are copied recursively.

See Also

BuildProcess Class
SandcastleBuilder.Utils.BuildEngine Namespace


CopyStandardHelpContent Method

[image]

Sandcastle Help File Builder Documentation
BuildProcess..::.CopyStandardHelpContent Method
BuildProcess Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is called to create the help project output folder and copy the standard content files (art, media, scripts, and styles) to the help project folder.

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected void CopyStandardHelpContent()
Visual Basic (Declaration)
Protected Sub CopyStandardHelpContent

Remarks

This creates the folders Output\ and Output\html under the working folder and copies the stock art, icon, media, script, and style sheet files from the {@PresentationPath}\art, {@PresentationPath}\icons, {@PresentationPath}\media, {@PresentationPath}\scripts, and {@PresentationPath}\styles folders which are located in the Sandcastle installation folder. The art, icons, and media folders may or may not exist based on the style.

See Also

BuildProcess Class
SandcastleBuilder.Utils.BuildEngine Namespace


ExecuteAfterStepPlugIns Method

[image]

Sandcastle Help File Builder Documentation
BuildProcess..::.ExecuteAfterStepPlugIns Method
BuildProcess Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This can be used by plug-ins using the InsteadOf execution behavior to execute plug-ins that want to run after the plug-in has executed its main processing.

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public void ExecuteAfterStepPlugIns()
Visual Basic (Declaration)
Public Sub ExecuteAfterStepPlugIns

Remarks

This will only run once per step. Any subsequent calls by other plug-ins will be ignored.

See Also

BuildProcess Class
SandcastleBuilder.Utils.BuildEngine Namespace


ExecuteBeforeStepPlugIns Method

[image]

Sandcastle Help File Builder Documentation
BuildProcess..::.ExecuteBeforeStepPlugIns Method
BuildProcess Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This can be used by plug-ins using the InsteadOf execution behavior to execute plug-ins that want to run before the plug-in executes its main processing.

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public void ExecuteBeforeStepPlugIns()
Visual Basic (Declaration)
Public Sub ExecuteBeforeStepPlugIns

Remarks

This will only run once per step. Any subsequent calls by other plug-ins will be ignored.

See Also

BuildProcess Class
SandcastleBuilder.Utils.BuildEngine Namespace


FindOnFixedDrives Method

[image]

Sandcastle Help File Builder Documentation
BuildProcess..::.FindOnFixedDrives Method
BuildProcess Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Find a folder by searching the Program Files folders on all fixed drives.

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected internal static string FindOnFixedDrives(
    string path
)
Visual Basic (Declaration)
Protected Friend Shared Function FindOnFixedDrives ( _
    path As String _
) As String

Parameters

path
Type: System..::.String
The path for which to search

Return Value

The path if found or an empty string if not found

See Also

BuildProcess Class
SandcastleBuilder.Utils.BuildEngine Namespace


FindSdkExecutable Method

[image]

Sandcastle Help File Builder Documentation
BuildProcess..::.FindSdkExecutable Method
BuildProcess Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to find the named executable in one of the Visual Studio SDK installation folders.

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected internal static string FindSdkExecutable(
    string exeName
)
Visual Basic (Declaration)
Protected Friend Shared Function FindSdkExecutable ( _
    exeName As String _
) As String

Parameters

exeName
Type: System..::.String
The name of the executable to find

Return Value

The path if found or an empty string if not found

Remarks

The search looks in all "Visual*" folders under the Program Files special folder on all fixed drives.

See Also

BuildProcess Class
SandcastleBuilder.Utils.BuildEngine Namespace


FindTools Method

[image]

Sandcastle Help File Builder Documentation
BuildProcess..::.FindTools Method
BuildProcess Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Find the Sandcastle tools and the HTML help compiler

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected void FindTools()
Visual Basic (Declaration)
Protected Sub FindTools

Exceptions

Exception | Condition
SandcastleBuilder.Utils..::.BuilderException | This is thrown if any of the tools cannot be found.

See Also

BuildProcess Class
SandcastleBuilder.Utils.BuildEngine Namespace


GenerateHtmlToc Method

[image]

Sandcastle Help File Builder Documentation
BuildProcess..::.GenerateHtmlToc Method
BuildProcess Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is called to generate the HTML table of contents when creating the website output.

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected string GenerateHtmlToc()
Visual Basic (Declaration)
Protected Function GenerateHtmlToc As String

Return Value

The HTML to insert for the table of contents.

See Also

BuildProcess Class
SandcastleBuilder.Utils.BuildEngine Namespace


GenerateNamespaceSummaries Method

[image]

Sandcastle Help File Builder Documentation
BuildProcess..::.GenerateNamespaceSummaries Method
BuildProcess Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is called to generate the namespace summary file

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected void GenerateNamespaceSummaries()
Visual Basic (Declaration)
Protected Sub GenerateNamespaceSummaries

See Also

BuildProcess Class
SandcastleBuilder.Utils.BuildEngine Namespace


GenerateWebsite Method

[image]

Sandcastle Help File Builder Documentation
BuildProcess..::.GenerateWebsite Method
BuildProcess Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to generate the website helper files and copy the output to the project output folder ready for use as a website.

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected void GenerateWebsite()
Visual Basic (Declaration)
Protected Sub GenerateWebsite

See Also

BuildProcess Class
SandcastleBuilder.Utils.BuildEngine Namespace


GetFrameworkCommentsFiles Method

[image]

Sandcastle Help File Builder Documentation
BuildProcess..::.GetFrameworkCommentsFiles Method
BuildProcess Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get a list of .NET Framework comments file locations.

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public static void GetFrameworkCommentsFiles(
    Collection<string> frameworkLocations,
    Dictionary<string, string> cacheName,
    CultureInfo language,
    string version
)
Visual Basic (Declaration)
Public Shared Sub GetFrameworkCommentsFiles ( _
    frameworkLocations As Collection(Of String), _
    cacheName As Dictionary(Of String, String), _
    language As CultureInfo, _
    version As String _
)

Parameters

frameworkLocations
Type: System.Collections.ObjectModel..::.Collection <(Of <( String >)>)
The locations of the comments files.
cacheName
Type: System.Collections.Generic..::.Dictionary <(Of <( String, String >)>)
A dictionary to contain the cache file names for the comments file sets.
language
Type: System.Globalization..::.CultureInfo
If the given language version of the comments are present, they will be used. If not, the default English version comments files are used.
version
Type: System..::.String
The framework version for which to get comments files.

See Also

BuildProcess Class
SandcastleBuilder.Utils.BuildEngine Namespace


HelpProjectFileList Method

[image]

Sandcastle Help File Builder Documentation
BuildProcess..::.HelpProjectFileList Method
BuildProcess Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This returns a complete list of files for inclusion in the compiled help file.

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected string HelpProjectFileList(
    string folder,
    HelpFileFormat format
)
Visual Basic (Declaration)
Protected Function HelpProjectFileList ( _
    folder As String, _
    format As HelpFileFormat _
) As String

Parameters

folder
Type: System..::.String
The folder to expand
format
Type: SandcastleBuilder.Utils..::.HelpFileFormat
The HTML help file format

Return Value

The full list of all files for the help project

Remarks

The help file list is expanded to ensure that we get all additional content including all nested subfolders. The format parameter determines the format of the returned file list. For HTML 1.x, it returns a list of the filenames. For HTML 2.x, it returns the list formatted with the necessary XML markup.

See Also

BuildProcess Class
SandcastleBuilder.Utils.BuildEngine Namespace


ModifyHelpTopicFilenames Method

[image]

Sandcastle Help File Builder Documentation
BuildProcess..::.ModifyHelpTopicFilenames Method
BuildProcess Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to change the filenames assigned to each member in the reflection information file.

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected void ModifyHelpTopicFilenames()
Visual Basic (Declaration)
Protected Sub ModifyHelpTopicFilenames

See Also

BuildProcess Class
SandcastleBuilder.Utils.BuildEngine Namespace


OnBuildProgress Method

[image]

Sandcastle Help File Builder Documentation
BuildProcess..::.OnBuildProgress Method
BuildProcess Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This raises the BuildProgress event.

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected virtual void OnBuildProgress(
    BuildProgressEventArgs e
)
Visual Basic (Declaration)
Protected Overridable Sub OnBuildProgress ( _
    e As BuildProgressEventArgs _
)

Parameters

e
Type: SandcastleBuilder.Utils.BuildEngine..::.BuildProgressEventArgs
The event arguments

See Also

BuildProcess Class
SandcastleBuilder.Utils.BuildEngine Namespace


OnBuildStepChanged Method

[image]

Sandcastle Help File Builder Documentation
BuildProcess..::.OnBuildStepChanged Method
BuildProcess Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This raises the BuildStepChanged event.

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected virtual void OnBuildStepChanged(
    BuildProgressEventArgs e
)
Visual Basic (Declaration)
Protected Overridable Sub OnBuildStepChanged ( _
    e As BuildProgressEventArgs _
)

Parameters

e
Type: SandcastleBuilder.Utils.BuildEngine..::.BuildProgressEventArgs
The event arguments

See Also

BuildProcess Class
SandcastleBuilder.Utils.BuildEngine Namespace


ReadWithEncoding Method

[image]

Sandcastle Help File Builder Documentation
BuildProcess..::.ReadWithEncoding Method
BuildProcess Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to read in a file using an appropriate encoding method

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public static string ReadWithEncoding(
    string filename,
    ref Encoding encoding
)
Visual Basic (Declaration)
Public Shared Function ReadWithEncoding ( _
    filename As String, _
    ByRef encoding As Encoding _
) As String

Parameters

filename
Type: System..::.String
The file to load
encoding
Type: System.Text..::.Encoding %
Pass the default encoding to use. On return, it contains the actual encoding for the file.

Return Value

The contents of the file.

Remarks

When reading the file, use the default encoding specified but detect the encoding if byte order marks are present. In addition, if the template is an XML file and it contains an encoding identifier in the XML tag, the file is read using that encoding.

See Also

BuildProcess Class
SandcastleBuilder.Utils.BuildEngine Namespace


RecursiveCopy Method

[image]

Sandcastle Help File Builder Documentation
BuildProcess..::.RecursiveCopy Method
BuildProcess Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This copies files from the specified source folder to the specified destination folder. If any subfolders are found below the source folder and the wildcard is "*.*", the subfolders are also copied recursively.

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected void RecursiveCopy(
    string sourcePath,
    string destPath
)
Visual Basic (Declaration)
Protected Sub RecursiveCopy ( _
    sourcePath As String, _
    destPath As String _
)

Parameters

sourcePath
Type: System..::.String
The source path from which to copy
destPath
Type: System..::.String
The destination path to which to copy

See Also

BuildProcess Class
SandcastleBuilder.Utils.BuildEngine Namespace


ReportProgress Method

[image] [image]

Sandcastle Help File Builder Documentation
BuildProcess..::.ReportProgress Method
BuildProcess Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This method has two overloads.

Overload List

Name | Description
ReportProgress(String, array<Object>[]()[]) | This is used to report progress during the build process within the current step.
ReportProgress(BuildStep, String, array<Object>[]()[]) | This is used to report progress during the build process and possibly update the current step.

See Also

BuildProcess Class
BuildProcess Members
SandcastleBuilder.Utils.BuildEngine Namespace


ReportProgress Method (String, Object[])

[image]

Sandcastle Help File Builder Documentation
BuildProcess..::.ReportProgress Method (String, array<Object>[]()[])
BuildProcess Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to report progress during the build process within the current step.

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public void ReportProgress(
    string message,
    params Object[] args
)
Visual Basic (Declaration)
Public Sub ReportProgress ( _
    message As String, _
    ParamArray args As Object() _
)

Parameters

message
Type: System..::.String
The message to report
args
Type: array< System..::.Object >[]()[]
A list of arguments to format into the message text

See Also

BuildProcess Class
ReportProgress Overload
SandcastleBuilder.Utils.BuildEngine Namespace


ReportProgress Method (BuildStep, String, Object[])

[image]

Sandcastle Help File Builder Documentation
BuildProcess..::.ReportProgress Method (BuildStep, String, array<Object>[]()[])
BuildProcess Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to report progress during the build process and possibly update the current step.

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected void ReportProgress(
    BuildStep step,
    string message,
    params Object[] args
)
Visual Basic (Declaration)
Protected Sub ReportProgress ( _
    step As BuildStep, _
    message As String, _
    ParamArray args As Object() _
)

Parameters

step
Type: SandcastleBuilder.Utils.BuildEngine..::.BuildStep
The current build step
message
Type: System..::.String
The message to report
args
Type: array< System..::.Object >[]()[]
A list of arguments to format into the message text

See Also

BuildProcess Class
ReportProgress Overload
SandcastleBuilder.Utils.BuildEngine Namespace


ReportWarning Method

[image]

Sandcastle Help File Builder Documentation
BuildProcess..::.ReportWarning Method
BuildProcess Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to report a warning that may need attention

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public void ReportWarning(
    string warningCode,
    string message,
    params Object[] args
)
Visual Basic (Declaration)
Public Sub ReportWarning ( _
    warningCode As String, _
    message As String, _
    ParamArray args As Object() _
)

Parameters

warningCode
Type: System..::.String
The warning code
message
Type: System..::.String
The message to report
args
Type: array< System..::.Object >[]()[]
A list of arguments to format into the message text

See Also

BuildProcess Class
SandcastleBuilder.Utils.BuildEngine Namespace


RunProcess Method

[image]

Sandcastle Help File Builder Documentation
BuildProcess..::.RunProcess Method
BuildProcess Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to run a step in the build process

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public void RunProcess(
    string fileToRun,
    string args
)
Visual Basic (Declaration)
Public Sub RunProcess ( _
    fileToRun As String, _
    args As String _
)

Parameters

fileToRun
Type: System..::.String
The file to execute. This will be one of the template batch files with all the necessary values for the paths and options plugged into it.
args
Type: System..::.String
The arguments to pass to the file if any.

See Also

BuildProcess Class
SandcastleBuilder.Utils.BuildEngine Namespace


TransformTemplate Method

[image]

Sandcastle Help File Builder Documentation
BuildProcess..::.TransformTemplate Method
BuildProcess Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Transform the specified template by inserting the necessary values into the place holders and saving it to the working folder.

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string TransformTemplate(
    string template,
    string sourceFolder,
    string destFolder
)
Visual Basic (Declaration)
Public Function TransformTemplate ( _
    template As String, _
    sourceFolder As String, _
    destFolder As String _
) As String

Parameters

template
Type: System..::.String
The template to transform
sourceFolder
Type: System..::.String
The folder where the template is located
destFolder
Type: System..::.String
The folder in which to save the transformed file

Return Value

The path to the transformed file

See Also

BuildProcess Class
SandcastleBuilder.Utils.BuildEngine Namespace


TransformText Method

[image]

Sandcastle Help File Builder Documentation
BuildProcess..::.TransformText Method
BuildProcess Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Transform the specified template text by inserting the necessary values into the place holders tags.

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string TransformText(
    string templateText,
    params Object[] args
)
Visual Basic (Declaration)
Public Function TransformText ( _
    templateText As String, _
    ParamArray args As Object() _
) As String

Parameters

templateText
Type: System..::.String
The template text to transform
args
Type: array< System..::.Object >[]()[]
An optional list of arguments to format into the template before transforming it.

Return Value

The transformed text

See Also

BuildProcess Class
SandcastleBuilder.Utils.BuildEngine Namespace


UpdateTableOfContents Method

[image]

Sandcastle Help File Builder Documentation
BuildProcess..::.UpdateTableOfContents Method
BuildProcess Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is called to determine the default topic for the help file and insert any additional table of contents entries for the additional content files.

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected void UpdateTableOfContents(
    HelpFileFormat format
)
Visual Basic (Declaration)
Protected Sub UpdateTableOfContents ( _
    format As HelpFileFormat _
)

Parameters

format
Type: SandcastleBuilder.Utils..::.HelpFileFormat
The format of the table of contents (HtmlHelp1x, HtmlHelp2x, or Website).

Remarks

In the absence of an additional content item with a default topic indicator, the default page is determined by extracting the first entry from the generated table of contents file. If an additional content item with a default topic indicator has been specified, it will be the used instead. The default topic is not used by HTML Help 2.x files.

Exceptions

Exception | Condition
System..::.ArgumentException | This is thrown if the format is not HtmlHelp1x, HtmlHelp2x, or Website.

See Also

BuildProcess Class
SandcastleBuilder.Utils.BuildEngine Namespace


ValidateDocumentationSources Method

[image]

Sandcastle Help File Builder Documentation
BuildProcess..::.ValidateDocumentationSources Method
BuildProcess Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Validate the documentation source information and copy the files to the working folder.

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected void ValidateDocumentationSources()
Visual Basic (Declaration)
Protected Sub ValidateDocumentationSources

Exceptions

Exception | Condition
SandcastleBuilder.Utils..::.BuilderException | This is thrown if any of the information is invalid.

See Also

BuildProcess Class
SandcastleBuilder.Utils.BuildEngine Namespace


VerifySafePath Method

[image]

Sandcastle Help File Builder Documentation
BuildProcess..::.VerifySafePath Method
BuildProcess Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Make sure the path isn't one the user would regret having nuked without warning.

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public static void VerifySafePath(
    string propertyName,
    string propertyValue,
    string projectPath
)
Visual Basic (Declaration)
Public Shared Sub VerifySafePath ( _
    propertyName As String, _
    propertyValue As String, _
    projectPath As String _
)

Parameters

propertyName
Type: System..::.String
The name of the path property
propertyValue
Type: System..::.String
It's current value
projectPath
Type: System..::.String
The path to the current project

Remarks

Since most people don't read the help file and also ignore the warning in the property grid description pane, we'll take some steps to idiot-proof the dangerous path properties. I'm starting to lose count of the number of people that point WorkingPath at the root of their C:\ drive and wonder why all their files disappear.

Paths checked for include root references to hard drives and network shares, most common well-known folders, and the project's root folder.

Exceptions

Exception | Condition
SandcastleBuilder.Utils..::.BuilderException | This is thrown if the path is one of the ones that probably should not be used.

See Also

BuildProcess Class
SandcastleBuilder.Utils.BuildEngine Namespace


BuildProcess Properties

[image] [image]

Sandcastle Help File Builder Documentation
BuildProcess Properties
BuildProcess Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BuildProcess type exposes the following members.

Properties

Name | Description
BuildApiFilter | This read-only property returns the API filter that is used at build-time to filter the API elements.
CommentsFiles | This read-only property returns the XML comments files collection
ConceptualContent | This is used to get the conceptual content settings in effect for the build.
CurrentFormat | This returns the current help file format being generated
CurrentProject | This returns the current project being used for the build
Help1CompilerFolder | This returns the name of the HTML Help 1.x compiler folder determined by the build process.
Help1Files | This returns a list of the Help 1 (CHM) files that were built
Help2CompilerFolder | This returns the name of the HTML Help 2.x compiler folder determined by the build process.
Help2Files | This returns a list of the Help 2 (HxS) files that were built
HelpFileBuilderFolder | This returns the location of the help file builder executables
IsPartialBuild | This read-only property is used to get the partial build flag
LoadedPlugIns | This returns a Dictionary<(Of <(TKey, TValue>)>) containing the currently loaded plug-ins.
LogFilename | This returns the name of the log file used for saving the build progress messages.
MSBuildExePath | This returns the path to MSBuild.exe
OutputFolder | This returns the output folder where the log file and help file can be found after the build process has finished.
PresentationStyleFolder | This returns the name of the main Sandcastle presentation style folder determined by the build process.
ProjectFilename | This returns the project filename without the folder
ProjectFolder | This returns the project folder name
ReflectionInfoFilename | This returns the name of the reflection information file
SandcastleFolder | This returns the name of the main Sandcastle folder determined by the build process.
SuppressApiFilter | This controls whether or not the API filter is suppressed.
TemplateFolder | This returns the location of the help file builder template folder.
WebsiteFiles | This returns a list of the website files that were built
WorkingFolder | This returns the name of the working files folder

See Also

BuildProcess Class
SandcastleBuilder.Utils.BuildEngine Namespace


BuildApiFilter Property

[image]

Sandcastle Help File Builder Documentation
BuildProcess..::.BuildApiFilter Property
BuildProcess Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns the API filter that is used at build-time to filter the API elements.

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public ApiFilterCollection BuildApiFilter { get; }
Visual Basic (Declaration)
Public ReadOnly Property BuildApiFilter As ApiFilterCollection

Remarks

This is a combination of the project's API filter, namespace exclusions, and
CopyC#
<exclude />
 tag exclusions.

See Also

BuildProcess Class
SandcastleBuilder.Utils.BuildEngine Namespace


CommentsFiles Property

[image]

Sandcastle Help File Builder Documentation
BuildProcess..::.CommentsFiles Property
BuildProcess Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns the XML comments files collection

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public XmlCommentsFileCollection CommentsFiles { get; }
Visual Basic (Declaration)
Public ReadOnly Property CommentsFiles As XmlCommentsFileCollection

See Also

BuildProcess Class
SandcastleBuilder.Utils.BuildEngine Namespace


ConceptualContent Property

[image]

Sandcastle Help File Builder Documentation
BuildProcess..::.ConceptualContent Property
BuildProcess Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get the conceptual content settings in effect for the build.

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public ConceptualContentSettings ConceptualContent { get; }
Visual Basic (Declaration)
Public ReadOnly Property ConceptualContent As ConceptualContentSettings

Remarks

This will not return a useable value until after the CopyStandardContent BuildStep.

See Also

BuildProcess Class
SandcastleBuilder.Utils.BuildEngine Namespace


CurrentFormat Property

[image]

Sandcastle Help File Builder Documentation
BuildProcess..::.CurrentFormat Property
BuildProcess Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This returns the current help file format being generated

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public HelpFileFormat CurrentFormat { get; }
Visual Basic (Declaration)
Public ReadOnly Property CurrentFormat As HelpFileFormat

Remarks

The GenerateHelpFormatTableOfContents, GenerateHelpFileIndex, GenerateHelpProject, UpdateTableOfContents, and CompilingHelpFile steps will run once for each help file format selected. This property allows a plug-in to determine which files it may need to work with during those steps or to skip processing if it is not relevant.

See Also

BuildProcess Class
SandcastleBuilder.Utils.BuildEngine Namespace


CurrentProject Property

[image]

Sandcastle Help File Builder Documentation
BuildProcess..::.CurrentProject Property
BuildProcess Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This returns the current project being used for the build

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public SandcastleProject CurrentProject { get; }
Visual Basic (Declaration)
Public ReadOnly Property CurrentProject As SandcastleProject

Remarks

Although there is nothing stopping it, project options should not be modified during a build.

See Also

BuildProcess Class
SandcastleBuilder.Utils.BuildEngine Namespace


Help1CompilerFolder Property

[image]

Sandcastle Help File Builder Documentation
BuildProcess..::.Help1CompilerFolder Property
BuildProcess Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This returns the name of the HTML Help 1.x compiler folder determined by the build process.

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string Help1CompilerFolder { get; }
Visual Basic (Declaration)
Public ReadOnly Property Help1CompilerFolder As String

See Also

BuildProcess Class
SandcastleBuilder.Utils.BuildEngine Namespace


Help1Files Property

[image]

Sandcastle Help File Builder Documentation
BuildProcess..::.Help1Files Property
BuildProcess Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This returns a list of the Help 1 (CHM) files that were built

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public Collection<string> Help1Files { get; }
Visual Basic (Declaration)
Public ReadOnly Property Help1Files As Collection(Of String)

Remarks

If the Help 1 format was not built, this returns an empty collection.

See Also

BuildProcess Class
SandcastleBuilder.Utils.BuildEngine Namespace


Help2CompilerFolder Property

[image]

Sandcastle Help File Builder Documentation
BuildProcess..::.Help2CompilerFolder Property
BuildProcess Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This returns the name of the HTML Help 2.x compiler folder determined by the build process.

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string Help2CompilerFolder { get; }
Visual Basic (Declaration)
Public ReadOnly Property Help2CompilerFolder As String

See Also

BuildProcess Class
SandcastleBuilder.Utils.BuildEngine Namespace


Help2Files Property

[image]

Sandcastle Help File Builder Documentation
BuildProcess..::.Help2Files Property
BuildProcess Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This returns a list of the Help 2 (HxS) files that were built

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public Collection<string> Help2Files { get; }
Visual Basic (Declaration)
Public ReadOnly Property Help2Files As Collection(Of String)

Remarks

If the Help 2 format was not built, this returns an empty collection.

See Also

BuildProcess Class
SandcastleBuilder.Utils.BuildEngine Namespace


HelpFileBuilderFolder Property

[image]

Sandcastle Help File Builder Documentation
BuildProcess..::.HelpFileBuilderFolder Property
BuildProcess Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This returns the location of the help file builder executables

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string HelpFileBuilderFolder { get; }
Visual Basic (Declaration)
Public ReadOnly Property HelpFileBuilderFolder As String

See Also

BuildProcess Class
SandcastleBuilder.Utils.BuildEngine Namespace


IsPartialBuild Property

[image]

Sandcastle Help File Builder Documentation
BuildProcess..::.IsPartialBuild Property
BuildProcess Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property is used to get the partial build flag

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool IsPartialBuild { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsPartialBuild As Boolean

Remarks

Partial builds occur when editing the namespace summaries, editing the API filter, and as part of some plug-ins and may not require all build options. In a partial build, build steps after ApplyVisibilityProperties are not executed.

See Also

BuildProcess Class
SandcastleBuilder.Utils.BuildEngine Namespace


LoadedPlugIns Property

[image]

Sandcastle Help File Builder Documentation
BuildProcess..::.LoadedPlugIns Property
BuildProcess Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This returns a Dictionary<(Of <(TKey, TValue>)>) containing the currently loaded plug-ins.

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public Dictionary<string, IPlugIn> LoadedPlugIns { get; }
Visual Basic (Declaration)
Public ReadOnly Property LoadedPlugIns As Dictionary(Of String, IPlugIn)

Field Value

The key is the plug in name. The value is a reference to an IPlugIn interface for the plug-in.

Remarks

This allows you to access other plug-ins to facilitate sharing of information between them.

See Also

BuildProcess Class
SandcastleBuilder.Utils.BuildEngine Namespace


LogFilename Property

[image]

Sandcastle Help File Builder Documentation
BuildProcess..::.LogFilename Property
BuildProcess Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This returns the name of the log file used for saving the build progress messages.

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string LogFilename { get; }
Visual Basic (Declaration)
Public ReadOnly Property LogFilename As String

See Also

BuildProcess Class
SandcastleBuilder.Utils.BuildEngine Namespace


MSBuildExePath Property

[image]

Sandcastle Help File Builder Documentation
BuildProcess..::.MSBuildExePath Property
BuildProcess Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This returns the path to MSBuild.exe

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string MSBuildExePath { get; }
Visual Basic (Declaration)
Public ReadOnly Property MSBuildExePath As String

See Also

BuildProcess Class
SandcastleBuilder.Utils.BuildEngine Namespace


OutputFolder Property

[image]

Sandcastle Help File Builder Documentation
BuildProcess..::.OutputFolder Property
BuildProcess Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This returns the output folder where the log file and help file can be found after the build process has finished.

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string OutputFolder { get; }
Visual Basic (Declaration)
Public ReadOnly Property OutputFolder As String

See Also

BuildProcess Class
SandcastleBuilder.Utils.BuildEngine Namespace


PresentationStyleFolder Property

[image]

Sandcastle Help File Builder Documentation
BuildProcess..::.PresentationStyleFolder Property
BuildProcess Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This returns the name of the main Sandcastle presentation style folder determined by the build process.

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string PresentationStyleFolder { get; }
Visual Basic (Declaration)
Public ReadOnly Property PresentationStyleFolder As String

See Also

BuildProcess Class
SandcastleBuilder.Utils.BuildEngine Namespace


ProjectFilename Property

[image]

Sandcastle Help File Builder Documentation
BuildProcess..::.ProjectFilename Property
BuildProcess Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This returns the project filename without the folder

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string ProjectFilename { get; }
Visual Basic (Declaration)
Public ReadOnly Property ProjectFilename As String

See Also

BuildProcess Class
SandcastleBuilder.Utils.BuildEngine Namespace


ProjectFolder Property

[image]

Sandcastle Help File Builder Documentation
BuildProcess..::.ProjectFolder Property
BuildProcess Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This returns the project folder name

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string ProjectFolder { get; }
Visual Basic (Declaration)
Public ReadOnly Property ProjectFolder As String

See Also

BuildProcess Class
SandcastleBuilder.Utils.BuildEngine Namespace


ReflectionInfoFilename Property

[image]

Sandcastle Help File Builder Documentation
BuildProcess..::.ReflectionInfoFilename Property
BuildProcess Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This returns the name of the reflection information file

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string ReflectionInfoFilename { get; }
Visual Basic (Declaration)
Public ReadOnly Property ReflectionInfoFilename As String

See Also

BuildProcess Class
SandcastleBuilder.Utils.BuildEngine Namespace


SandcastleFolder Property

[image]

Sandcastle Help File Builder Documentation
BuildProcess..::.SandcastleFolder Property
BuildProcess Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This returns the name of the main Sandcastle folder determined by the build process.

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string SandcastleFolder { get; }
Visual Basic (Declaration)
Public ReadOnly Property SandcastleFolder As String

See Also

BuildProcess Class
SandcastleBuilder.Utils.BuildEngine Namespace


SuppressApiFilter Property

[image]

Sandcastle Help File Builder Documentation
BuildProcess..::.SuppressApiFilter Property
BuildProcess Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This controls whether or not the API filter is suppressed.

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool SuppressApiFilter { get; set; }
Visual Basic (Declaration)
Public Property SuppressApiFilter As Boolean

Field Value

By default, it is not suppressed and the API filter will be applied. The API Filter designer uses this to suppress the filter so that all members are obtained.

See Also

BuildProcess Class
SandcastleBuilder.Utils.BuildEngine Namespace


TemplateFolder Property

[image]

Sandcastle Help File Builder Documentation
BuildProcess..::.TemplateFolder Property
BuildProcess Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This returns the location of the help file builder template folder.

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string TemplateFolder { get; }
Visual Basic (Declaration)
Public ReadOnly Property TemplateFolder As String

See Also

BuildProcess Class
SandcastleBuilder.Utils.BuildEngine Namespace


WebsiteFiles Property

[image]

Sandcastle Help File Builder Documentation
BuildProcess..::.WebsiteFiles Property
BuildProcess Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This returns a list of the website files that were built

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public Collection<string> WebsiteFiles { get; }
Visual Basic (Declaration)
Public ReadOnly Property WebsiteFiles As Collection(Of String)

Remarks

If the website format was not built, this returns an empty collection.

See Also

BuildProcess Class
SandcastleBuilder.Utils.BuildEngine Namespace


WorkingFolder Property

[image]

Sandcastle Help File Builder Documentation
BuildProcess..::.WorkingFolder Property
BuildProcess Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This returns the name of the working files folder

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string WorkingFolder { get; }
Visual Basic (Declaration)
Public ReadOnly Property WorkingFolder As String

See Also

BuildProcess Class
SandcastleBuilder.Utils.BuildEngine Namespace


BuildProcess Events

[image] [image]

Sandcastle Help File Builder Documentation
BuildProcess Events
BuildProcess Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BuildProcess type exposes the following members.

Events

Name | Description
BuildProgress | This event is raised to report progress information throughout each build step.
BuildStepChanged | This event is raised to report a change in the build step

See Also

BuildProcess Class
SandcastleBuilder.Utils.BuildEngine Namespace


BuildProgress Event

[image]

Sandcastle Help File Builder Documentation
BuildProcess..::.BuildProgress Event
BuildProcess Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This event is raised to report progress information throughout each build step.

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public event EventHandler<BuildProgressEventArgs> BuildProgress
Visual Basic (Declaration)
Public Event BuildProgress As EventHandler(Of BuildProgressEventArgs)

See Also

BuildProcess Class
SandcastleBuilder.Utils.BuildEngine Namespace


BuildStepChanged Event

[image]

Sandcastle Help File Builder Documentation
BuildProcess..::.BuildStepChanged Event
BuildProcess Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This event is raised to report a change in the build step

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public event EventHandler<BuildProgressEventArgs> BuildStepChanged
Visual Basic (Declaration)
Public Event BuildStepChanged As EventHandler(Of BuildProgressEventArgs)

See Also

BuildProcess Class
SandcastleBuilder.Utils.BuildEngine Namespace


BuildProgressEventArgs Class

[image]

Sandcastle Help File Builder Documentation
BuildProgressEventArgs Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is a custom event arguments class for the BuildProgress event.

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public class BuildProgressEventArgs : EventArgs
Visual Basic (Declaration)
Public Class BuildProgressEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
SandcastleBuilder.Utils.BuildEngine..::.BuildProgressEventArgs

See Also

BuildProgressEventArgs Members
SandcastleBuilder.Utils.BuildEngine Namespace


BuildProgressEventArgs Members

[image] [image]

Sandcastle Help File Builder Documentation
BuildProgressEventArgs Members
BuildProgressEventArgs Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BuildProgressEventArgs type exposes the following members.

Constructors

Name | Description
BuildProgressEventArgs | Constructor

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BuildStep | Get the current build step of the build process
HasCompleted | Get a flag indicating whether or not the build has completed
Message | Get the message associated with the progress report

See Also

BuildProgressEventArgs Class
SandcastleBuilder.Utils.BuildEngine Namespace


BuildProgressEventArgs Constructor

[image]

Sandcastle Help File Builder Documentation
BuildProgressEventArgs Constructor
BuildProgressEventArgs Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public BuildProgressEventArgs()
Visual Basic (Declaration)
Public Sub New

See Also

BuildProgressEventArgs Class
SandcastleBuilder.Utils.BuildEngine Namespace


BuildProgressEventArgs Methods

[image] [image]

Sandcastle Help File Builder Documentation
BuildProgressEventArgs Methods
BuildProgressEventArgs Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BuildProgressEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BuildProgressEventArgs Class
SandcastleBuilder.Utils.BuildEngine Namespace


BuildProgressEventArgs Properties

[image] [image]

Sandcastle Help File Builder Documentation
BuildProgressEventArgs Properties
BuildProgressEventArgs Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BuildProgressEventArgs type exposes the following members.

Properties

Name | Description
BuildStep | Get the current build step of the build process
HasCompleted | Get a flag indicating whether or not the build has completed
Message | Get the message associated with the progress report

See Also

BuildProgressEventArgs Class
SandcastleBuilder.Utils.BuildEngine Namespace


BuildStep Property

[image]

Sandcastle Help File Builder Documentation
BuildProgressEventArgs..::.BuildStep Property
BuildProgressEventArgs Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Get the current build step of the build process

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public BuildStep BuildStep { get; internal set; }
Visual Basic (Declaration)
Public Property BuildStep As BuildStep

See Also

BuildProgressEventArgs Class
SandcastleBuilder.Utils.BuildEngine Namespace


HasCompleted Property

[image]

Sandcastle Help File Builder Documentation
BuildProgressEventArgs..::.HasCompleted Property
BuildProgressEventArgs Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Get a flag indicating whether or not the build has completed

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool HasCompleted { get; internal set; }
Visual Basic (Declaration)
Public Property HasCompleted As Boolean

See Also

BuildProgressEventArgs Class
SandcastleBuilder.Utils.BuildEngine Namespace


Message Property

[image]

Sandcastle Help File Builder Documentation
BuildProgressEventArgs..::.Message Property
BuildProgressEventArgs Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Get the message associated with the progress report

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string Message { get; internal set; }
Visual Basic (Declaration)
Public Property Message As String

See Also

BuildProgressEventArgs Class
SandcastleBuilder.Utils.BuildEngine Namespace


BuildStep Enumeration

[image]

Sandcastle Help File Builder Documentation
BuildStep Enumeration
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This public enumerated type defines the build steps used when reporting progress during a build.

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
[SerializableAttribute]
public enum BuildStep
Visual Basic (Declaration)
<SerializableAttribute> _
Public Enumeration BuildStep

Members

Member name | Description
None | The build has not yet started.
Initializing | Initializing to prepare for build.
ClearWorkFolder | The working folder is about to be created or cleared.
FindingTools | The builder is searching for Sandcastle and the HTML help compiler.
ValidatingDocumentationSources | The documentation source information is being validated and copied to the build folder.
GenerateSharedContent | The shared content files are being generated.
GenerateApiFilter | Generate the API filter for MRefBuilder
GenerateReflectionInfo | The reflection information is being generated by MRefBuilder.
GenerateNamespaceSummaries | Namespace summary information is being generated.
ApplyVisibilityProperties | The Visibility category properties are being applied to the reflection information file to remove unwanted items.
GenerateInheritedDocumentation | All <inheritDoc /> tags are being expanded.
TransformReflectionInfo | The reflection information is being transformed by XslTransform.
ModifyHelpTopicFilenames | Help topic filenames are being altered.
CopyStandardContent | The standard help file content (art, scripts, and styles) is being copied to the help project folder.
CopyConceptualContent | The conceptual content files are being copied.
CreateConceptualTopicConfigs | The conceptual content topic configuration files are being generated.
CopyAdditionalContent | The additional content files are being copied to the help project folder.
CreateBuildAssemblerConfigs | The sandcastle.config Conceptual.config BuildAssembler files are being created.
MergeCustomConfigs | Custom build component configurations are being merged into the sandcastle.config file.
MergeTablesOfContents | The conceptual and additional content tables of contents are being merged.
BuildConceptualTopics | Conceptual help file topics are being generated by BuildAssembler.
BuildReferenceTopics | API reference help file topics are being generated by BuildAssembler.
GenerateIntermediateTableOfContents | The intermediate table of contents is being generated by XslTransform.
ExtractingHtmlInfo | Title and keyword index information is being extracted for the Help 1.x TOC and index and/or website TOC.
GenerateHelpFormatTableOfContents | The format-specific table of contents is being generated by XslTransform.
UpdateTableOfContents | The table of contents is being updated with additional and conceptual content items and the default page is being determined.
GenerateHelpFileIndex | The help file index is being generated.
GenerateHelpProject | The help project file is being generated.
CompilingHelpFile | The help file project is being compiled.
GenerateFullTextIndex | Generate full-text index for ASP.NET website search.
CopyingWebsiteFiles | The website files are being copied to the output path.
CleanIntermediates | The temporary help project files are being removed.
Completed | The build has completed successfully.
Canceled | The build was canceled by user request.
Failed | The build failed with an unexpected error.

See Also

SandcastleBuilder.Utils.BuildEngine Namespace


FullTextIndex Class

[image]

Sandcastle Help File Builder Documentation
FullTextIndex Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is a really basic implementation of an algorithm used to create a full-text index of the website pages so that they can be searched using the ASP.NET web pages.

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public class FullTextIndex
Visual Basic (Declaration)
Public Class FullTextIndex

Remarks

So that an assembly does not have to be deployed to deserialize the index information, the index information is represented using built-in data types (string and long).

Inheritance Hierarchy

System..::.Object
SandcastleBuilder.Utils.BuildEngine..::.FullTextIndex

See Also

FullTextIndex Members
SandcastleBuilder.Utils.BuildEngine Namespace


FullTextIndex Members

[image] [image]

Sandcastle Help File Builder Documentation
FullTextIndex Members
FullTextIndex Class Constructors Methods See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FullTextIndex type exposes the following members.

Constructors

Name | Description
FullTextIndex | Constructor

Methods

Name | Description
CreateFullTextIndex | Create a full-text index from web pages found in the specified file path.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SaveIndex | Save the index information to the specified location.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FullTextIndex Class
SandcastleBuilder.Utils.BuildEngine Namespace


FullTextIndex Constructor

[image]

Sandcastle Help File Builder Documentation
FullTextIndex Constructor
FullTextIndex Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public FullTextIndex(
    string exclusions,
    CultureInfo language
)
Visual Basic (Declaration)
Public Sub New ( _
    exclusions As String, _
    language As CultureInfo _
)

Parameters

exclusions
Type: System..::.String
The file containing common word exclusions. The file should contain one work per line in lowercase. These words will not appear in the index.
language
Type: System.Globalization..::.CultureInfo
The culture information

See Also

FullTextIndex Class
SandcastleBuilder.Utils.BuildEngine Namespace


FullTextIndex Methods

[image] [image]

Sandcastle Help File Builder Documentation
FullTextIndex Methods
FullTextIndex Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FullTextIndex type exposes the following members.

Methods

Name | Description
CreateFullTextIndex | Create a full-text index from web pages found in the specified file path.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SaveIndex | Save the index information to the specified location.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FullTextIndex Class
SandcastleBuilder.Utils.BuildEngine Namespace


CreateFullTextIndex Method

[image]

Sandcastle Help File Builder Documentation
FullTextIndex..::.CreateFullTextIndex Method
FullTextIndex Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Create a full-text index from web pages found in the specified file path.

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public void CreateFullTextIndex(
    string filePath
)
Visual Basic (Declaration)
Public Sub CreateFullTextIndex ( _
    filePath As String _
)

Parameters

filePath
Type: System..::.String
The path containing the files to index

Remarks

Words in the exclusion list, those that are less than three characters long, and anything starting with a digit will not appear in the index.

See Also

FullTextIndex Class
SandcastleBuilder.Utils.BuildEngine Namespace


SaveIndex Method

[image]

Sandcastle Help File Builder Documentation
FullTextIndex..::.SaveIndex Method
FullTextIndex Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Save the index information to the specified location.

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public void SaveIndex(
    string indexPath
)
Visual Basic (Declaration)
Public Sub SaveIndex ( _
    indexPath As String _
)

Parameters

indexPath
Type: System..::.String
The path to which the index files are saved.

Remarks

Binary serialization is used to save the index data.

See Also

FullTextIndex Class
SandcastleBuilder.Utils.BuildEngine Namespace


XmlCommentsFile Class

[image]

Sandcastle Help File Builder Documentation
XmlCommentsFile Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This represents an XML comment file and is used when searching for and adding missing documentation tag information.

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public class XmlCommentsFile
Visual Basic (Declaration)
Public Class XmlCommentsFile

Inheritance Hierarchy

System..::.Object
SandcastleBuilder.Utils.BuildEngine..::.XmlCommentsFile

See Also

XmlCommentsFile Members
SandcastleBuilder.Utils.BuildEngine Namespace


XmlCommentsFile Members

[image] [image]

Sandcastle Help File Builder Documentation
XmlCommentsFile Members
XmlCommentsFile Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The XmlCommentsFile type exposes the following members.

Constructors

Name | Description
XmlCommentsFile | Constructor

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FixupComments | This is called to fixup the comments for C++ compiler generated XML comments files.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Save | Save the comments file if it was modified
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Comments | This is used to load the comments file on first use
Members | This read-only property is used to get the root members node
SourcePath | This read-only property is used to get the source path of the file

See Also

XmlCommentsFile Class
SandcastleBuilder.Utils.BuildEngine Namespace


XmlCommentsFile Constructor

[image]

Sandcastle Help File Builder Documentation
XmlCommentsFile Constructor
XmlCommentsFile Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public XmlCommentsFile(
    string filename
)
Visual Basic (Declaration)
Public Sub New ( _
    filename As String _
)

Parameters

filename
Type: System..::.String
The XML comments filename

Exceptions

Exception | Condition
System..::.ArgumentNullException | This is thrown if the filename is null or an empty string.

See Also

XmlCommentsFile Class
SandcastleBuilder.Utils.BuildEngine Namespace


XmlCommentsFile Methods

[image] [image]

Sandcastle Help File Builder Documentation
XmlCommentsFile Methods
XmlCommentsFile Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The XmlCommentsFile type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FixupComments | This is called to fixup the comments for C++ compiler generated XML comments files.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Save | Save the comments file if it was modified
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

XmlCommentsFile Class
SandcastleBuilder.Utils.BuildEngine Namespace


FixupComments Method

[image]

Sandcastle Help File Builder Documentation
XmlCommentsFile..::.FixupComments Method
XmlCommentsFile Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is called to fixup the comments for C++ compiler generated XML comments files.

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public void FixupComments()
Visual Basic (Declaration)
Public Sub FixupComments

Remarks

The C++ compiler generates method signatures that differ from the other .NET compilers for methods that take generics as parameters. These methods fail to get documented as they do not match the output of MRefBuilder. The C# and VB.NET compilers generate names that do match it and this option is not needed for comments files generated by them. The C++ compiler also has problems resolving references to some members if it hasn't seen them yet. These are prefixed with "!:" which is removed by the fix-up code.

See Also

XmlCommentsFile Class
SandcastleBuilder.Utils.BuildEngine Namespace


Save Method

[image]

Sandcastle Help File Builder Documentation
XmlCommentsFile..::.Save Method
XmlCommentsFile Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Save the comments file if it was modified

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public void Save()
Visual Basic (Declaration)
Public Sub Save

See Also

XmlCommentsFile Class
SandcastleBuilder.Utils.BuildEngine Namespace


XmlCommentsFile Properties

[image] [image]

Sandcastle Help File Builder Documentation
XmlCommentsFile Properties
XmlCommentsFile Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The XmlCommentsFile type exposes the following members.

Properties

Name | Description
Comments | This is used to load the comments file on first use
Members | This read-only property is used to get the root members node
SourcePath | This read-only property is used to get the source path of the file

See Also

XmlCommentsFile Class
SandcastleBuilder.Utils.BuildEngine Namespace


Comments Property

[image]

Sandcastle Help File Builder Documentation
XmlCommentsFile..::.Comments Property
XmlCommentsFile Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to load the comments file on first use

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public XmlDocument Comments { get; }
Visual Basic (Declaration)
Public ReadOnly Property Comments As XmlDocument

See Also

XmlCommentsFile Class
SandcastleBuilder.Utils.BuildEngine Namespace


Members Property

[image]

Sandcastle Help File Builder Documentation
XmlCommentsFile..::.Members Property
XmlCommentsFile Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property is used to get the root members node

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public XmlNode Members { get; }
Visual Basic (Declaration)
Public ReadOnly Property Members As XmlNode

See Also

XmlCommentsFile Class
SandcastleBuilder.Utils.BuildEngine Namespace


SourcePath Property

[image]

Sandcastle Help File Builder Documentation
XmlCommentsFile..::.SourcePath Property
XmlCommentsFile Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property is used to get the source path of the file

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string SourcePath { get; }
Visual Basic (Declaration)
Public ReadOnly Property SourcePath As String

See Also

XmlCommentsFile Class
SandcastleBuilder.Utils.BuildEngine Namespace


XmlCommentsFileCollection Class

[image]

Sandcastle Help File Builder Documentation
XmlCommentsFileCollection Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This collection class is used to hold the XML comments files during the build process.

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public class XmlCommentsFileCollection : BindingList<XmlCommentsFile>
Visual Basic (Declaration)
Public Class XmlCommentsFileCollection _
    Inherits BindingList(Of XmlCommentsFile)

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection <(Of <( XmlCommentsFile >)>)
System.ComponentModel..::.BindingList <(Of <( XmlCommentsFile >)>)
SandcastleBuilder.Utils.BuildEngine..::.XmlCommentsFileCollection

See Also

XmlCommentsFileCollection Members
SandcastleBuilder.Utils.BuildEngine Namespace


XmlCommentsFileCollection Members

[image] [image]

Sandcastle Help File Builder Documentation
XmlCommentsFileCollection Members
XmlCommentsFileCollection Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The XmlCommentsFileCollection type exposes the following members.

Constructors

Name | Description
XmlCommentsFileCollection | Initializes a new instance of the XmlCommentsFileCollection class

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( XmlCommentsFile >)>).)
AddNew | Adds a new item to the collection. (Inherited from BindingList <(Of <( XmlCommentsFile >)>).)
AddNewCore | Adds a new item to the end of the collection. (Inherited from BindingList <(Of <( XmlCommentsFile >)>).)
ApplySortCore | Sorts the items if overridden in a derived class; otherwise, throws a NotSupportedException. (Inherited from BindingList <(Of <( XmlCommentsFile >)>).)
CancelNew | Discards a pending new item. (Inherited from BindingList <(Of <( XmlCommentsFile >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( XmlCommentsFile >)>).)
ClearItems | Removes all elements from the collection. (Inherited from BindingList <(Of <( XmlCommentsFile >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( XmlCommentsFile >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <( XmlCommentsFile >)>).)
EndNew | Commits a pending new item to the collection. (Inherited from BindingList <(Of <( XmlCommentsFile >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindCore | Searches for the index of the item that has the specified property descriptor with the specified value, if searching is implemented in a derived class; otherwise, a NotSupportedException. (Inherited from BindingList <(Of <( XmlCommentsFile >)>).)
FindMember | Search all comments files for the specified member. If not found, add the blank member to the first file.
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( XmlCommentsFile >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection <(Of <( XmlCommentsFile >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( XmlCommentsFile >)>).)
InsertItem | Inserts the specified item in the list at the specified index. (Inherited from BindingList <(Of <( XmlCommentsFile >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnAddingNew | Raises the AddingNew event. (Inherited from BindingList <(Of <( XmlCommentsFile >)>).)
OnListChanged | Raises the ListChanged event. (Inherited from BindingList <(Of <( XmlCommentsFile >)>).)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( XmlCommentsFile >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( XmlCommentsFile >)>).)
RemoveItem | Removes the item at the specified index. (Inherited from BindingList <(Of <( XmlCommentsFile >)>).)
RemoveSortCore | Removes any sort applied with ApplySortCore(PropertyDescriptor, ListSortDirection) if sorting is implemented in a derived class; otherwise, raises NotSupportedException. (Inherited from BindingList <(Of <( XmlCommentsFile >)>).)
ReplaceNamespaceDocEntries | This will search for all type member comments where the ID contains NamespaceDoc and convert them to namespace entries for the containing namespace.
ResetBindings | Raises a ListChanged event of type Reset. (Inherited from BindingList <(Of <( XmlCommentsFile >)>).)
ResetItem | Raises a ListChanged event of type ItemChanged for the item at the specified position. (Inherited from BindingList <(Of <( XmlCommentsFile >)>).)
Save | Save the comments files
SetItem | Replaces the item at the specified index with the specified item. (Inherited from BindingList <(Of <( XmlCommentsFile >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AllowEdit | Gets or sets a value indicating whether items in the list can be edited. (Inherited from BindingList <(Of <( XmlCommentsFile >)>).)
AllowNew | Gets or sets a value indicating whether you can add items to the list using the AddNew()()() method. (Inherited from BindingList <(Of <( XmlCommentsFile >)>).)
AllowRemove | Gets or sets a value indicating whether you can remove items from the collection. (Inherited from BindingList <(Of <( XmlCommentsFile >)>).)
ContainsInheritedDocumentation | This read-only property returns true if any of the comments files contain an <inheritdoc /> tag indicating that the Inherited Documentation tool will need to be ran.
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( XmlCommentsFile >)>).)
IsSortedCore | Gets a value indicating whether the list is sorted. (Inherited from BindingList <(Of <( XmlCommentsFile >)>).)
Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <( XmlCommentsFile >)>).)
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( XmlCommentsFile >)>).)
RaiseListChangedEvents | Gets or sets a value indicating whether adding or removing items within the list raises ListChanged events. (Inherited from BindingList <(Of <( XmlCommentsFile >)>).)
SortDirectionCore | Gets the direction the list is sorted. (Inherited from BindingList <(Of <( XmlCommentsFile >)>).)
SortPropertyCore | Gets the property descriptor that is used for sorting the list if sorting is implemented in a derived class; otherwise, returns null. (Inherited from BindingList <(Of <( XmlCommentsFile >)>).)
SupportsChangeNotificationCore | Gets a value indicating whether ListChanged events are enabled. (Inherited from BindingList <(Of <( XmlCommentsFile >)>).)
SupportsSearchingCore | Gets a value indicating whether the list supports searching. (Inherited from BindingList <(Of <( XmlCommentsFile >)>).)
SupportsSortingCore | Gets a value indicating whether the list supports sorting. (Inherited from BindingList <(Of <( XmlCommentsFile >)>).)

Events

Name | Description
AddingNew | Occurs before an item is added to the list. (Inherited from BindingList <(Of <( XmlCommentsFile >)>).)
ListChanged | Occurs when the list or an item in the list changes. (Inherited from BindingList <(Of <( XmlCommentsFile >)>).)

See Also

XmlCommentsFileCollection Class
SandcastleBuilder.Utils.BuildEngine Namespace


XmlCommentsFileCollection Constructor

[image]

Sandcastle Help File Builder Documentation
XmlCommentsFileCollection Constructor
XmlCommentsFileCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the XmlCommentsFileCollection class

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public XmlCommentsFileCollection()
Visual Basic (Declaration)
Public Sub New

See Also

XmlCommentsFileCollection Class
SandcastleBuilder.Utils.BuildEngine Namespace


XmlCommentsFileCollection Methods

[image] [image]

Sandcastle Help File Builder Documentation
XmlCommentsFileCollection Methods
XmlCommentsFileCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The XmlCommentsFileCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( XmlCommentsFile >)>).)
AddNew | Adds a new item to the collection. (Inherited from BindingList <(Of <( XmlCommentsFile >)>).)
AddNewCore | Adds a new item to the end of the collection. (Inherited from BindingList <(Of <( XmlCommentsFile >)>).)
ApplySortCore | Sorts the items if overridden in a derived class; otherwise, throws a NotSupportedException. (Inherited from BindingList <(Of <( XmlCommentsFile >)>).)
CancelNew | Discards a pending new item. (Inherited from BindingList <(Of <( XmlCommentsFile >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( XmlCommentsFile >)>).)
ClearItems | Removes all elements from the collection. (Inherited from BindingList <(Of <( XmlCommentsFile >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( XmlCommentsFile >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <( XmlCommentsFile >)>).)
EndNew | Commits a pending new item to the collection. (Inherited from BindingList <(Of <( XmlCommentsFile >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindCore | Searches for the index of the item that has the specified property descriptor with the specified value, if searching is implemented in a derived class; otherwise, a NotSupportedException. (Inherited from BindingList <(Of <( XmlCommentsFile >)>).)
FindMember | Search all comments files for the specified member. If not found, add the blank member to the first file.
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( XmlCommentsFile >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection <(Of <( XmlCommentsFile >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( XmlCommentsFile >)>).)
InsertItem | Inserts the specified item in the list at the specified index. (Inherited from BindingList <(Of <( XmlCommentsFile >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnAddingNew | Raises the AddingNew event. (Inherited from BindingList <(Of <( XmlCommentsFile >)>).)
OnListChanged | Raises the ListChanged event. (Inherited from BindingList <(Of <( XmlCommentsFile >)>).)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( XmlCommentsFile >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( XmlCommentsFile >)>).)
RemoveItem | Removes the item at the specified index. (Inherited from BindingList <(Of <( XmlCommentsFile >)>).)
RemoveSortCore | Removes any sort applied with ApplySortCore(PropertyDescriptor, ListSortDirection) if sorting is implemented in a derived class; otherwise, raises NotSupportedException. (Inherited from BindingList <(Of <( XmlCommentsFile >)>).)
ReplaceNamespaceDocEntries | This will search for all type member comments where the ID contains NamespaceDoc and convert them to namespace entries for the containing namespace.
ResetBindings | Raises a ListChanged event of type Reset. (Inherited from BindingList <(Of <( XmlCommentsFile >)>).)
ResetItem | Raises a ListChanged event of type ItemChanged for the item at the specified position. (Inherited from BindingList <(Of <( XmlCommentsFile >)>).)
Save | Save the comments files
SetItem | Replaces the item at the specified index with the specified item. (Inherited from BindingList <(Of <( XmlCommentsFile >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

XmlCommentsFileCollection Class
SandcastleBuilder.Utils.BuildEngine Namespace


FindMember Method

[image]

Sandcastle Help File Builder Documentation
XmlCommentsFileCollection..::.FindMember Method
XmlCommentsFileCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Search all comments files for the specified member. If not found, add the blank member to the first file.

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public XmlNode FindMember(
    string memberName
)
Visual Basic (Declaration)
Public Function FindMember ( _
    memberName As String _
) As XmlNode

Parameters

memberName
Type: System..::.String
The member name for which to search.

Return Value

The XML node of the found or added member

See Also

XmlCommentsFileCollection Class
SandcastleBuilder.Utils.BuildEngine Namespace


ReplaceNamespaceDocEntries Method

[image]

Sandcastle Help File Builder Documentation
XmlCommentsFileCollection..::.ReplaceNamespaceDocEntries Method
XmlCommentsFileCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This will search for all type member comments where the ID contains NamespaceDoc and convert them to namespace entries for the containing namespace.

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public void ReplaceNamespaceDocEntries()
Visual Basic (Declaration)
Public Sub ReplaceNamespaceDocEntries

Remarks

The converted ID effectively converts the comments into comments for the class's containing namespace.

See Also

XmlCommentsFileCollection Class
SandcastleBuilder.Utils.BuildEngine Namespace


Save Method

[image]

Sandcastle Help File Builder Documentation
XmlCommentsFileCollection..::.Save Method
XmlCommentsFileCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Save the comments files

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public void Save()
Visual Basic (Declaration)
Public Sub Save

See Also

XmlCommentsFileCollection Class
SandcastleBuilder.Utils.BuildEngine Namespace


XmlCommentsFileCollection Properties

[image] [image]

Sandcastle Help File Builder Documentation
XmlCommentsFileCollection Properties
XmlCommentsFileCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The XmlCommentsFileCollection type exposes the following members.

Properties

Name | Description
AllowEdit | Gets or sets a value indicating whether items in the list can be edited. (Inherited from BindingList <(Of <( XmlCommentsFile >)>).)
AllowNew | Gets or sets a value indicating whether you can add items to the list using the AddNew()()() method. (Inherited from BindingList <(Of <( XmlCommentsFile >)>).)
AllowRemove | Gets or sets a value indicating whether you can remove items from the collection. (Inherited from BindingList <(Of <( XmlCommentsFile >)>).)
ContainsInheritedDocumentation | This read-only property returns true if any of the comments files contain an <inheritdoc /> tag indicating that the Inherited Documentation tool will need to be ran.
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( XmlCommentsFile >)>).)
IsSortedCore | Gets a value indicating whether the list is sorted. (Inherited from BindingList <(Of <( XmlCommentsFile >)>).)
Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <( XmlCommentsFile >)>).)
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( XmlCommentsFile >)>).)
RaiseListChangedEvents | Gets or sets a value indicating whether adding or removing items within the list raises ListChanged events. (Inherited from BindingList <(Of <( XmlCommentsFile >)>).)
SortDirectionCore | Gets the direction the list is sorted. (Inherited from BindingList <(Of <( XmlCommentsFile >)>).)
SortPropertyCore | Gets the property descriptor that is used for sorting the list if sorting is implemented in a derived class; otherwise, returns null. (Inherited from BindingList <(Of <( XmlCommentsFile >)>).)
SupportsChangeNotificationCore | Gets a value indicating whether ListChanged events are enabled. (Inherited from BindingList <(Of <( XmlCommentsFile >)>).)
SupportsSearchingCore | Gets a value indicating whether the list supports searching. (Inherited from BindingList <(Of <( XmlCommentsFile >)>).)
SupportsSortingCore | Gets a value indicating whether the list supports sorting. (Inherited from BindingList <(Of <( XmlCommentsFile >)>).)

See Also

XmlCommentsFileCollection Class
SandcastleBuilder.Utils.BuildEngine Namespace


ContainsInheritedDocumentation Property

[image]

Sandcastle Help File Builder Documentation
XmlCommentsFileCollection..::.ContainsInheritedDocumentation Property
XmlCommentsFileCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns true if any of the comments files contain an <inheritdoc /> tag indicating that the Inherited Documentation tool will need to be ran.

Namespace: SandcastleBuilder.Utils.BuildEngine
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool ContainsInheritedDocumentation { get; }
Visual Basic (Declaration)
Public ReadOnly Property ContainsInheritedDocumentation As Boolean

See Also

XmlCommentsFileCollection Class
SandcastleBuilder.Utils.BuildEngine Namespace


XmlCommentsFileCollection Events

[image] [image]

Sandcastle Help File Builder Documentation
XmlCommentsFileCollection Events
XmlCommentsFileCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The XmlCommentsFileCollection type exposes the following members.

Events

Name | Description
AddingNew | Occurs before an item is added to the list. (Inherited from BindingList <(Of <( XmlCommentsFile >)>).)
ListChanged | Occurs when the list or an item in the list changes. (Inherited from BindingList <(Of <( XmlCommentsFile >)>).)

See Also

XmlCommentsFileCollection Class
SandcastleBuilder.Utils.BuildEngine Namespace


SandcastleBuilder.Utils.ConceptualContent Namespace

[image]

Sandcastle Help File Builder Documentation
SandcastleBuilder.Utils.ConceptualContent Namespace
Send Feedback

[This is preliminary documentation and is subject to change.]

This namespace contains classes related to conceptual content items.

Classes

Class | Description
CodeEntityReference | This represents a conceptual content CodeEntityReference that can be used to insert a common item, value, or construct into topics.
CodeReference | This represents a conceptual content CodeReference that can be used to insert a common item, value, or construct into topics.
CodeSnippetCollection | This collection class is used to hold the conceptual content code snippet information for an associated code snippets file.
ConceptualContentSettings | This class is used to hold the conceptual content settings for a project during a build and for editing.
ImageReference | This represents a conceptual content image that can be used to insert a reference to an image in a topic.
ImageReferenceCollection | This collection class is used to hold the conceptual content image references for a project.
TocEntry | This represents a table of contents entry. This is used to build the table of contents entries for additional content items.
TocEntryCollection | This collection class is used to hold the table of contents entries for additional content items.
Token | This represents a conceptual content token that can be used to insert a common item, value, or construct into topics.
TokenCollection | This collection class is used to hold the conceptual content tokens for an associated token file.
Topic | This represents a conceptual content topic.
TopicCollection | This collection class is used to hold the conceptual content topics for a project.
TopicFile | This class represents a conceptual content topic file

Interfaces

Interface | Description
ITableOfContents | This interface is used to interact with project files that can generate table of contents entries.

Enumerations

Enumeration | Description
ContentType | This defines the content types that can be edited


CodeEntityReference Class

[image]

Sandcastle Help File Builder Documentation
CodeEntityReference Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This represents a conceptual content CodeEntityReference that can be used to insert a common item, value, or construct into topics.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
[SerializableAttribute]
public class CodeEntityReference
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class CodeEntityReference

Remarks

This class is serializable so that it can be copied to the clipboard.

Inheritance Hierarchy

System..::.Object
SandcastleBuilder.Utils.ConceptualContent..::.CodeEntityReference

See Also

CodeEntityReference Members
SandcastleBuilder.Utils.ConceptualContent Namespace


CodeEntityReference Members

[image] [image]

Sandcastle Help File Builder Documentation
CodeEntityReference Members
CodeEntityReference Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The CodeEntityReference type exposes the following members.

Constructors

Name | Description
CodeEntityReference | Constructor

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToCodeEntityReference | Convert the entity to its <codeEntityReference> element form
ToSee | Convert the entity to its <see> element form
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Id | This is used to get or set the CodeEntityReference name

See Also

CodeEntityReference Class
SandcastleBuilder.Utils.ConceptualContent Namespace


CodeEntityReference Constructor

[image]

Sandcastle Help File Builder Documentation
CodeEntityReference Constructor
CodeEntityReference Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public CodeEntityReference(
    string refId
)
Visual Basic (Declaration)
Public Sub New ( _
    refId As String _
)

Parameters

refId
Type: System..::.String
The reference ID

See Also

CodeEntityReference Class
SandcastleBuilder.Utils.ConceptualContent Namespace


CodeEntityReference Methods

[image] [image]

Sandcastle Help File Builder Documentation
CodeEntityReference Methods
CodeEntityReference Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The CodeEntityReference type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToCodeEntityReference | Convert the entity to its <codeEntityReference> element form
ToSee | Convert the entity to its <see> element form
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CodeEntityReference Class
SandcastleBuilder.Utils.ConceptualContent Namespace


ToCodeEntityReference Method

[image]

Sandcastle Help File Builder Documentation
CodeEntityReference..::.ToCodeEntityReference Method
CodeEntityReference Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Convert the entity to its <codeEntityReference> element form

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string ToCodeEntityReference()
Visual Basic (Declaration)
Public Function ToCodeEntityReference As String

Return Value

The entity in its <codeEntityReference> element form

See Also

CodeEntityReference Class
SandcastleBuilder.Utils.ConceptualContent Namespace


ToSee Method

[image]

Sandcastle Help File Builder Documentation
CodeEntityReference..::.ToSee Method
CodeEntityReference Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Convert the entity to its <see> element form

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string ToSee()
Visual Basic (Declaration)
Public Function ToSee As String

Return Value

The token in its <see> element form

See Also

CodeEntityReference Class
SandcastleBuilder.Utils.ConceptualContent Namespace


CodeEntityReference Properties

[image] [image]

Sandcastle Help File Builder Documentation
CodeEntityReference Properties
CodeEntityReference Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The CodeEntityReference type exposes the following members.

Properties

Name | Description
Id | This is used to get or set the CodeEntityReference name

See Also

CodeEntityReference Class
SandcastleBuilder.Utils.ConceptualContent Namespace


Id Property

[image]

Sandcastle Help File Builder Documentation
CodeEntityReference..::.Id Property
CodeEntityReference Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set the CodeEntityReference name

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string Id { get; set; }
Visual Basic (Declaration)
Public Property Id As String

See Also

CodeEntityReference Class
SandcastleBuilder.Utils.ConceptualContent Namespace


CodeReference Class

[image]

Sandcastle Help File Builder Documentation
CodeReference Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This represents a conceptual content CodeReference that can be used to insert a common item, value, or construct into topics.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
[SerializableAttribute]
public class CodeReference
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class CodeReference

Remarks

This class is serializable so that it can be copied to the clipboard.

Inheritance Hierarchy

System..::.Object
SandcastleBuilder.Utils.ConceptualContent..::.CodeReference

See Also

CodeReference Members
SandcastleBuilder.Utils.ConceptualContent Namespace


CodeReference Members

[image] [image]

Sandcastle Help File Builder Documentation
CodeReference Members
CodeReference Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The CodeReference type exposes the following members.

Constructors

Name | Description
CodeReference | Constructor

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToCodeReference | Convert the token to its <codeReference> element form
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Id | This is used to get or set the CodeReference name

See Also

CodeReference Class
SandcastleBuilder.Utils.ConceptualContent Namespace


CodeReference Constructor

[image]

Sandcastle Help File Builder Documentation
CodeReference Constructor
CodeReference Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public CodeReference(
    string refId
)
Visual Basic (Declaration)
Public Sub New ( _
    refId As String _
)

Parameters

refId
Type: System..::.String
The reference ID

See Also

CodeReference Class
SandcastleBuilder.Utils.ConceptualContent Namespace


CodeReference Methods

[image] [image]

Sandcastle Help File Builder Documentation
CodeReference Methods
CodeReference Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The CodeReference type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToCodeReference | Convert the token to its <codeReference> element form
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CodeReference Class
SandcastleBuilder.Utils.ConceptualContent Namespace


ToCodeReference Method

[image]

Sandcastle Help File Builder Documentation
CodeReference..::.ToCodeReference Method
CodeReference Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Convert the token to its <codeReference> element form

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string ToCodeReference()
Visual Basic (Declaration)
Public Function ToCodeReference As String

Return Value

The token in its <codeReference> element form

See Also

CodeReference Class
SandcastleBuilder.Utils.ConceptualContent Namespace


CodeReference Properties

[image] [image]

Sandcastle Help File Builder Documentation
CodeReference Properties
CodeReference Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The CodeReference type exposes the following members.

Properties

Name | Description
Id | This is used to get or set the CodeReference name

See Also

CodeReference Class
SandcastleBuilder.Utils.ConceptualContent Namespace


Id Property

[image]

Sandcastle Help File Builder Documentation
CodeReference..::.Id Property
CodeReference Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set the CodeReference name

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string Id { get; set; }
Visual Basic (Declaration)
Public Property Id As String

See Also

CodeReference Class
SandcastleBuilder.Utils.ConceptualContent Namespace


CodeSnippetCollection Class

[image]

Sandcastle Help File Builder Documentation
CodeSnippetCollection Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This collection class is used to hold the conceptual content code snippet information for an associated code snippets file.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public class CodeSnippetCollection : BindingList<CodeReference>
Visual Basic (Declaration)
Public Class CodeSnippetCollection _
    Inherits BindingList(Of CodeReference)

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection <(Of <( CodeReference >)>)
System.ComponentModel..::.BindingList <(Of <( CodeReference >)>)
SandcastleBuilder.Utils.ConceptualContent..::.CodeSnippetCollection

See Also

CodeSnippetCollection Members
SandcastleBuilder.Utils.ConceptualContent Namespace


CodeSnippetCollection Members

[image] [image]

Sandcastle Help File Builder Documentation
CodeSnippetCollection Members
CodeSnippetCollection Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The CodeSnippetCollection type exposes the following members.

Constructors

Name | Description
CodeSnippetCollection | Constructor

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( CodeReference >)>).)
AddNew | Adds a new item to the collection. (Inherited from BindingList <(Of <( CodeReference >)>).)
AddNewCore | Adds a new item to the end of the collection. (Inherited from BindingList <(Of <( CodeReference >)>).)
ApplySortCore | Sorts the items if overridden in a derived class; otherwise, throws a NotSupportedException. (Inherited from BindingList <(Of <( CodeReference >)>).)
CancelNew | Discards a pending new item. (Inherited from BindingList <(Of <( CodeReference >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( CodeReference >)>).)
ClearItems | Removes all elements from the collection. (Inherited from BindingList <(Of <( CodeReference >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( CodeReference >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <( CodeReference >)>).)
EndNew | Commits a pending new item to the collection. (Inherited from BindingList <(Of <( CodeReference >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindCore | Searches for the index of the item that has the specified property descriptor with the specified value, if searching is implemented in a derived class; otherwise, a NotSupportedException. (Inherited from BindingList <(Of <( CodeReference >)>).)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( CodeReference >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection <(Of <( CodeReference >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( CodeReference >)>).)
InsertItem | Inserts the specified item in the list at the specified index. (Inherited from BindingList <(Of <( CodeReference >)>).)
Load | Load the collection from the related file
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnAddingNew | Raises the AddingNew event. (Inherited from BindingList <(Of <( CodeReference >)>).)
OnListChanged | Raises the ListChanged event. (Inherited from BindingList <(Of <( CodeReference >)>).)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( CodeReference >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( CodeReference >)>).)
RemoveItem | Removes the item at the specified index. (Inherited from BindingList <(Of <( CodeReference >)>).)
RemoveSortCore | Removes any sort applied with ApplySortCore(PropertyDescriptor, ListSortDirection) if sorting is implemented in a derived class; otherwise, raises NotSupportedException. (Inherited from BindingList <(Of <( CodeReference >)>).)
ResetBindings | Raises a ListChanged event of type Reset. (Inherited from BindingList <(Of <( CodeReference >)>).)
ResetItem | Raises a ListChanged event of type ItemChanged for the item at the specified position. (Inherited from BindingList <(Of <( CodeReference >)>).)
SetItem | Replaces the item at the specified index with the specified item. (Inherited from BindingList <(Of <( CodeReference >)>).)
Sort | This is used to sort the collection
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AllowEdit | Gets or sets a value indicating whether items in the list can be edited. (Inherited from BindingList <(Of <( CodeReference >)>).)
AllowNew | Gets or sets a value indicating whether you can add items to the list using the AddNew()()() method. (Inherited from BindingList <(Of <( CodeReference >)>).)
AllowRemove | Gets or sets a value indicating whether you can remove items from the collection. (Inherited from BindingList <(Of <( CodeReference >)>).)
CodeSnippetFile | This is used to get the build item related to the code snippet file containing the collection items.
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( CodeReference >)>).)
IsSortedCore | Gets a value indicating whether the list is sorted. (Inherited from BindingList <(Of <( CodeReference >)>).)
Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <( CodeReference >)>).)
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( CodeReference >)>).)
RaiseListChangedEvents | Gets or sets a value indicating whether adding or removing items within the list raises ListChanged events. (Inherited from BindingList <(Of <( CodeReference >)>).)
SortDirectionCore | Gets the direction the list is sorted. (Inherited from BindingList <(Of <( CodeReference >)>).)
SortPropertyCore | Gets the property descriptor that is used for sorting the list if sorting is implemented in a derived class; otherwise, returns null. (Inherited from BindingList <(Of <( CodeReference >)>).)
SupportsChangeNotificationCore | Gets a value indicating whether ListChanged events are enabled. (Inherited from BindingList <(Of <( CodeReference >)>).)
SupportsSearchingCore | Gets a value indicating whether the list supports searching. (Inherited from BindingList <(Of <( CodeReference >)>).)
SupportsSortingCore | Gets a value indicating whether the list supports sorting. (Inherited from BindingList <(Of <( CodeReference >)>).)

Events

Name | Description
AddingNew | Occurs before an item is added to the list. (Inherited from BindingList <(Of <( CodeReference >)>).)
ListChanged | Occurs when the list or an item in the list changes. (Inherited from BindingList <(Of <( CodeReference >)>).)

See Also

CodeSnippetCollection Class
SandcastleBuilder.Utils.ConceptualContent Namespace


CodeSnippetCollection Constructor

[image]

Sandcastle Help File Builder Documentation
CodeSnippetCollection Constructor
CodeSnippetCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public CodeSnippetCollection(
    FileItem file
)
Visual Basic (Declaration)
Public Sub New ( _
    file As FileItem _
)

Parameters

file
Type: SandcastleBuilder.Utils..::.FileItem
The code snippets file associated with the collection.

Remarks

Code snippets are not loaded until the Load()()() method is called.

See Also

CodeSnippetCollection Class
SandcastleBuilder.Utils.ConceptualContent Namespace


CodeSnippetCollection Methods

[image] [image]

Sandcastle Help File Builder Documentation
CodeSnippetCollection Methods
CodeSnippetCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The CodeSnippetCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( CodeReference >)>).)
AddNew | Adds a new item to the collection. (Inherited from BindingList <(Of <( CodeReference >)>).)
AddNewCore | Adds a new item to the end of the collection. (Inherited from BindingList <(Of <( CodeReference >)>).)
ApplySortCore | Sorts the items if overridden in a derived class; otherwise, throws a NotSupportedException. (Inherited from BindingList <(Of <( CodeReference >)>).)
CancelNew | Discards a pending new item. (Inherited from BindingList <(Of <( CodeReference >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( CodeReference >)>).)
ClearItems | Removes all elements from the collection. (Inherited from BindingList <(Of <( CodeReference >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( CodeReference >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <( CodeReference >)>).)
EndNew | Commits a pending new item to the collection. (Inherited from BindingList <(Of <( CodeReference >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindCore | Searches for the index of the item that has the specified property descriptor with the specified value, if searching is implemented in a derived class; otherwise, a NotSupportedException. (Inherited from BindingList <(Of <( CodeReference >)>).)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( CodeReference >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection <(Of <( CodeReference >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( CodeReference >)>).)
InsertItem | Inserts the specified item in the list at the specified index. (Inherited from BindingList <(Of <( CodeReference >)>).)
Load | Load the collection from the related file
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnAddingNew | Raises the AddingNew event. (Inherited from BindingList <(Of <( CodeReference >)>).)
OnListChanged | Raises the ListChanged event. (Inherited from BindingList <(Of <( CodeReference >)>).)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( CodeReference >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( CodeReference >)>).)
RemoveItem | Removes the item at the specified index. (Inherited from BindingList <(Of <( CodeReference >)>).)
RemoveSortCore | Removes any sort applied with ApplySortCore(PropertyDescriptor, ListSortDirection) if sorting is implemented in a derived class; otherwise, raises NotSupportedException. (Inherited from BindingList <(Of <( CodeReference >)>).)
ResetBindings | Raises a ListChanged event of type Reset. (Inherited from BindingList <(Of <( CodeReference >)>).)
ResetItem | Raises a ListChanged event of type ItemChanged for the item at the specified position. (Inherited from BindingList <(Of <( CodeReference >)>).)
SetItem | Replaces the item at the specified index with the specified item. (Inherited from BindingList <(Of <( CodeReference >)>).)
Sort | This is used to sort the collection
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CodeSnippetCollection Class
SandcastleBuilder.Utils.ConceptualContent Namespace


Load Method

[image]

Sandcastle Help File Builder Documentation
CodeSnippetCollection..::.Load Method
CodeSnippetCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Load the collection from the related file

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public void Load()
Visual Basic (Declaration)
Public Sub Load

Remarks

This will be done automatically at constructor. This can be called to reload the collection if needed.

See Also

CodeSnippetCollection Class
SandcastleBuilder.Utils.ConceptualContent Namespace


Sort Method

[image]

Sandcastle Help File Builder Documentation
CodeSnippetCollection..::.Sort Method
CodeSnippetCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to sort the collection

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public void Sort()
Visual Basic (Declaration)
Public Sub Sort

Remarks

Values are sorted by ID. Comparisons are case-sensitive.

See Also

CodeSnippetCollection Class
SandcastleBuilder.Utils.ConceptualContent Namespace


CodeSnippetCollection Properties

[image] [image]

Sandcastle Help File Builder Documentation
CodeSnippetCollection Properties
CodeSnippetCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The CodeSnippetCollection type exposes the following members.

Properties

Name | Description
AllowEdit | Gets or sets a value indicating whether items in the list can be edited. (Inherited from BindingList <(Of <( CodeReference >)>).)
AllowNew | Gets or sets a value indicating whether you can add items to the list using the AddNew()()() method. (Inherited from BindingList <(Of <( CodeReference >)>).)
AllowRemove | Gets or sets a value indicating whether you can remove items from the collection. (Inherited from BindingList <(Of <( CodeReference >)>).)
CodeSnippetFile | This is used to get the build item related to the code snippet file containing the collection items.
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( CodeReference >)>).)
IsSortedCore | Gets a value indicating whether the list is sorted. (Inherited from BindingList <(Of <( CodeReference >)>).)
Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <( CodeReference >)>).)
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( CodeReference >)>).)
RaiseListChangedEvents | Gets or sets a value indicating whether adding or removing items within the list raises ListChanged events. (Inherited from BindingList <(Of <( CodeReference >)>).)
SortDirectionCore | Gets the direction the list is sorted. (Inherited from BindingList <(Of <( CodeReference >)>).)
SortPropertyCore | Gets the property descriptor that is used for sorting the list if sorting is implemented in a derived class; otherwise, returns null. (Inherited from BindingList <(Of <( CodeReference >)>).)
SupportsChangeNotificationCore | Gets a value indicating whether ListChanged events are enabled. (Inherited from BindingList <(Of <( CodeReference >)>).)
SupportsSearchingCore | Gets a value indicating whether the list supports searching. (Inherited from BindingList <(Of <( CodeReference >)>).)
SupportsSortingCore | Gets a value indicating whether the list supports sorting. (Inherited from BindingList <(Of <( CodeReference >)>).)

See Also

CodeSnippetCollection Class
SandcastleBuilder.Utils.ConceptualContent Namespace


CodeSnippetFile Property

[image]

Sandcastle Help File Builder Documentation
CodeSnippetCollection..::.CodeSnippetFile Property
CodeSnippetCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get the build item related to the code snippet file containing the collection items.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public FileItem CodeSnippetFile { get; }
Visual Basic (Declaration)
Public ReadOnly Property CodeSnippetFile As FileItem

See Also

CodeSnippetCollection Class
SandcastleBuilder.Utils.ConceptualContent Namespace


CodeSnippetCollection Events

[image] [image]

Sandcastle Help File Builder Documentation
CodeSnippetCollection Events
CodeSnippetCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The CodeSnippetCollection type exposes the following members.

Events

Name | Description
AddingNew | Occurs before an item is added to the list. (Inherited from BindingList <(Of <( CodeReference >)>).)
ListChanged | Occurs when the list or an item in the list changes. (Inherited from BindingList <(Of <( CodeReference >)>).)

See Also

CodeSnippetCollection Class
SandcastleBuilder.Utils.ConceptualContent Namespace


ConceptualContentSettings Class

[image]

Sandcastle Help File Builder Documentation
ConceptualContentSettings Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This class is used to hold the conceptual content settings for a project during a build and for editing.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public class ConceptualContentSettings
Visual Basic (Declaration)
Public Class ConceptualContentSettings

Inheritance Hierarchy

System..::.Object
SandcastleBuilder.Utils.ConceptualContent..::.ConceptualContentSettings

See Also

ConceptualContentSettings Members
SandcastleBuilder.Utils.ConceptualContent Namespace


ConceptualContentSettings Members

[image] [image]

Sandcastle Help File Builder Documentation
ConceptualContentSettings Members
ConceptualContentSettings Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ConceptualContentSettings type exposes the following members.

Constructors

Name | Description
ConceptualContentSettings | Constructor

Methods

Name | Description
CopyContentFiles | This is used to copy the additional content token, image, and topic files to the build folder.
CreateConfigurationFiles | This is used to create the conceptual content build configuration files.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CodeSnippetFiles | This is used to get the conceptual content code snippet files
ContentLayoutFiles | This is used to get the conceptual content layout files
ImageFiles | This is used to get the conceptual content image files
TokenFiles | This is used to get the conceptual content token files
Topics | This is used to get a collection of the conceptual content topics

See Also

ConceptualContentSettings Class
SandcastleBuilder.Utils.ConceptualContent Namespace


ConceptualContentSettings Constructor

[image]

Sandcastle Help File Builder Documentation
ConceptualContentSettings Constructor
ConceptualContentSettings Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public ConceptualContentSettings(
    SandcastleProject project
)
Visual Basic (Declaration)
Public Sub New ( _
    project As SandcastleProject _
)

Parameters

project
Type: SandcastleBuilder.Utils..::.SandcastleProject
The project from which to load the settings

See Also

ConceptualContentSettings Class
SandcastleBuilder.Utils.ConceptualContent Namespace


ConceptualContentSettings Methods

[image] [image]

Sandcastle Help File Builder Documentation
ConceptualContentSettings Methods
ConceptualContentSettings Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ConceptualContentSettings type exposes the following members.

Methods

Name | Description
CopyContentFiles | This is used to copy the additional content token, image, and topic files to the build folder.
CreateConfigurationFiles | This is used to create the conceptual content build configuration files.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConceptualContentSettings Class
SandcastleBuilder.Utils.ConceptualContent Namespace


CopyContentFiles Method

[image]

Sandcastle Help File Builder Documentation
ConceptualContentSettings..::.CopyContentFiles Method
ConceptualContentSettings Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to copy the additional content token, image, and topic files to the build folder.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public void CopyContentFiles(
    BuildProcess builder
)
Visual Basic (Declaration)
Public Sub CopyContentFiles ( _
    builder As BuildProcess _
)

Parameters

builder
Type: SandcastleBuilder.Utils.BuildEngine..::.BuildProcess
The build process

Remarks

This will copy the code snippet file if specified, save token information to a shared content file called _Tokens_.xml in the build process's working folder, copy the image files to the .\media folder in the build process's working folder, save the media map to a file called _MediaContent_.xml in the build process's working folder, and save the topic files to the .\ddueXml folder in the build process's working folder. The topic files will have their content wrapped in a <topic> tag if needed and will be named using their Id value.

See Also

ConceptualContentSettings Class
SandcastleBuilder.Utils.ConceptualContent Namespace


CreateConfigurationFiles Method

[image]

Sandcastle Help File Builder Documentation
ConceptualContentSettings..::.CreateConfigurationFiles Method
ConceptualContentSettings Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to create the conceptual content build configuration files.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public void CreateConfigurationFiles(
    BuildProcess builder
)
Visual Basic (Declaration)
Public Sub CreateConfigurationFiles ( _
    builder As BuildProcess _
)

Parameters

builder
Type: SandcastleBuilder.Utils.BuildEngine..::.BuildProcess
The build process

Remarks

This will create the companion files used to resolve conceptual links and the _ContentMetadata_.xml and ConceptualManifest.xml configuration files.

See Also

ConceptualContentSettings Class
SandcastleBuilder.Utils.ConceptualContent Namespace


ConceptualContentSettings Properties

[image] [image]

Sandcastle Help File Builder Documentation
ConceptualContentSettings Properties
ConceptualContentSettings Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ConceptualContentSettings type exposes the following members.

Properties

Name | Description
CodeSnippetFiles | This is used to get the conceptual content code snippet files
ContentLayoutFiles | This is used to get the conceptual content layout files
ImageFiles | This is used to get the conceptual content image files
TokenFiles | This is used to get the conceptual content token files
Topics | This is used to get a collection of the conceptual content topics

See Also

ConceptualContentSettings Class
SandcastleBuilder.Utils.ConceptualContent Namespace


CodeSnippetFiles Property

[image]

Sandcastle Help File Builder Documentation
ConceptualContentSettings..::.CodeSnippetFiles Property
ConceptualContentSettings Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get the conceptual content code snippet files

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public FileItemCollection CodeSnippetFiles { get; }
Visual Basic (Declaration)
Public ReadOnly Property CodeSnippetFiles As FileItemCollection

See Also

ConceptualContentSettings Class
SandcastleBuilder.Utils.ConceptualContent Namespace


ContentLayoutFiles Property

[image]

Sandcastle Help File Builder Documentation
ConceptualContentSettings..::.ContentLayoutFiles Property
ConceptualContentSettings Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get the conceptual content layout files

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public FileItemCollection ContentLayoutFiles { get; }
Visual Basic (Declaration)
Public ReadOnly Property ContentLayoutFiles As FileItemCollection

See Also

ConceptualContentSettings Class
SandcastleBuilder.Utils.ConceptualContent Namespace


ImageFiles Property

[image]

Sandcastle Help File Builder Documentation
ConceptualContentSettings..::.ImageFiles Property
ConceptualContentSettings Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get the conceptual content image files

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public ImageReferenceCollection ImageFiles { get; }
Visual Basic (Declaration)
Public ReadOnly Property ImageFiles As ImageReferenceCollection

See Also

ConceptualContentSettings Class
SandcastleBuilder.Utils.ConceptualContent Namespace


TokenFiles Property

[image]

Sandcastle Help File Builder Documentation
ConceptualContentSettings..::.TokenFiles Property
ConceptualContentSettings Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get the conceptual content token files

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public FileItemCollection TokenFiles { get; }
Visual Basic (Declaration)
Public ReadOnly Property TokenFiles As FileItemCollection

See Also

ConceptualContentSettings Class
SandcastleBuilder.Utils.ConceptualContent Namespace


Topics Property

[image]

Sandcastle Help File Builder Documentation
ConceptualContentSettings..::.Topics Property
ConceptualContentSettings Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get a collection of the conceptual content topics

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public Collection<TopicCollection> Topics { get; }
Visual Basic (Declaration)
Public ReadOnly Property Topics As Collection(Of TopicCollection)

Remarks

Each item in the collection represents one content layout file from the project.

See Also

ConceptualContentSettings Class
SandcastleBuilder.Utils.ConceptualContent Namespace


ContentType Enumeration

[image]

Sandcastle Help File Builder Documentation
ContentType Enumeration
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This defines the content types that can be edited

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
[SerializableAttribute]
public enum ContentType
Visual Basic (Declaration)
<SerializableAttribute> _
Public Enumeration ContentType

Members

Member name | Description
CodeSnippets | Code snippets
Images | Edit image references
Tokens | Edit tokens
Topics | Edit topics

See Also

SandcastleBuilder.Utils.ConceptualContent Namespace


ImageReference Class

[image]

Sandcastle Help File Builder Documentation
ImageReference Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This represents a conceptual content image that can be used to insert a reference to an image in a topic.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public class ImageReference
Visual Basic (Declaration)
Public Class ImageReference

Remarks

This class is serializable so that it can be copied to the clipboard.

Inheritance Hierarchy

System..::.Object
SandcastleBuilder.Utils.ConceptualContent..::.ImageReference

See Also

ImageReference Members
SandcastleBuilder.Utils.ConceptualContent Namespace


ImageReference Members

[image] [image]

Sandcastle Help File Builder Documentation
ImageReference Members
ImageReference Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ImageReference type exposes the following members.

Constructors

Name | Description
ImageReference | Constructor

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToExternalLink | Convert the image reference to an <externalLink> element.
ToImageLink | Convert the image reference to an <img> element.
ToMediaLink | Convert the image reference to a <mediaLink> element.
ToMediaLinkInline | Convert the image reference to a <mediaLinkInline> element.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AlternateText | This is used to get or set the optional alternate text for the image
CopyToMedia | This is used to get or set whether or not to copy the image to the .\Output\media folder if it is not referenced in a media link.
DisplayTitle | This read-only property is used to get a title for display (i.e. in the designer).
FileItem | This is used to get the file item associated with the image reference.
Filename | This is used to get the image filename
FullPath | This is used to get the full path to the image file
Id | This is used to get the unique ID of the image

See Also

ImageReference Class
SandcastleBuilder.Utils.ConceptualContent Namespace


ImageReference Constructor

[image]

Sandcastle Help File Builder Documentation
ImageReference Constructor
ImageReference Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public ImageReference(
    FileItem buildItem
)
Visual Basic (Declaration)
Public Sub New ( _
    buildItem As FileItem _
)

Parameters

buildItem
Type: SandcastleBuilder.Utils..::.FileItem
The build item to associate with the image reference.

See Also

ImageReference Class
SandcastleBuilder.Utils.ConceptualContent Namespace


ImageReference Methods

[image] [image]

Sandcastle Help File Builder Documentation
ImageReference Methods
ImageReference Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ImageReference type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToExternalLink | Convert the image reference to an <externalLink> element.
ToImageLink | Convert the image reference to an <img> element.
ToMediaLink | Convert the image reference to a <mediaLink> element.
ToMediaLinkInline | Convert the image reference to a <mediaLinkInline> element.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ImageReference Class
SandcastleBuilder.Utils.ConceptualContent Namespace


ToExternalLink Method

[image]

Sandcastle Help File Builder Documentation
ImageReference..::.ToExternalLink Method
ImageReference Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Convert the image reference to an <externalLink> element.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string ToExternalLink()
Visual Basic (Declaration)
Public Function ToExternalLink As String

Return Value

The image in its <externalLink> element form

See Also

ImageReference Class
SandcastleBuilder.Utils.ConceptualContent Namespace


ToImageLink Method

[image]

Sandcastle Help File Builder Documentation
ImageReference..::.ToImageLink Method
ImageReference Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Convert the image reference to an <img> element.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string ToImageLink()
Visual Basic (Declaration)
Public Function ToImageLink As String

Return Value

The image in its <img> element form

See Also

ImageReference Class
SandcastleBuilder.Utils.ConceptualContent Namespace


ToMediaLink Method

[image]

Sandcastle Help File Builder Documentation
ImageReference..::.ToMediaLink Method
ImageReference Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Convert the image reference to a <mediaLink> element.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string ToMediaLink()
Visual Basic (Declaration)
Public Function ToMediaLink As String

Return Value

The image in its <mediaLink> element form

See Also

ImageReference Class
SandcastleBuilder.Utils.ConceptualContent Namespace


ToMediaLinkInline Method

[image]

Sandcastle Help File Builder Documentation
ImageReference..::.ToMediaLinkInline Method
ImageReference Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Convert the image reference to a <mediaLinkInline> element.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string ToMediaLinkInline()
Visual Basic (Declaration)
Public Function ToMediaLinkInline As String

Return Value

The image in its <mediaLinkInline> element form

See Also

ImageReference Class
SandcastleBuilder.Utils.ConceptualContent Namespace


ImageReference Properties

[image] [image]

Sandcastle Help File Builder Documentation
ImageReference Properties
ImageReference Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ImageReference type exposes the following members.

Properties

Name | Description
AlternateText | This is used to get or set the optional alternate text for the image
CopyToMedia | This is used to get or set whether or not to copy the image to the .\Output\media folder if it is not referenced in a media link.
DisplayTitle | This read-only property is used to get a title for display (i.e. in the designer).
FileItem | This is used to get the file item associated with the image reference.
Filename | This is used to get the image filename
FullPath | This is used to get the full path to the image file
Id | This is used to get the unique ID of the image

See Also

ImageReference Class
SandcastleBuilder.Utils.ConceptualContent Namespace


AlternateText Property

[image]

Sandcastle Help File Builder Documentation
ImageReference..::.AlternateText Property
ImageReference Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set the optional alternate text for the image

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string AlternateText { get; set; }
Visual Basic (Declaration)
Public Property AlternateText As String

See Also

ImageReference Class
SandcastleBuilder.Utils.ConceptualContent Namespace


CopyToMedia Property

[image]

Sandcastle Help File Builder Documentation
ImageReference..::.CopyToMedia Property
ImageReference Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set whether or not to copy the image to the .\Output\media folder if it is not referenced in a media link.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool CopyToMedia { get; set; }
Visual Basic (Declaration)
Public Property CopyToMedia As Boolean

Field Value

The default is false and the image will not be copied unless it is referenced in a media link. If set to true, the image will be copied even if it is not referenced. This is useful for forcing the copy of images referenced in external links which are not handled by the art reference build component.

See Also

ImageReference Class
SandcastleBuilder.Utils.ConceptualContent Namespace


DisplayTitle Property

[image]

Sandcastle Help File Builder Documentation
ImageReference..::.DisplayTitle Property
ImageReference Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property is used to get a title for display (i.e. in the designer).

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string DisplayTitle { get; }
Visual Basic (Declaration)
Public ReadOnly Property DisplayTitle As String

Field Value

If there is AlternateText specified, it is returned along with the filename and the image ID in parentheses. If not, the filename is returned along with the image ID in parentheses.

See Also

ImageReference Class
SandcastleBuilder.Utils.ConceptualContent Namespace


FileItem Property

[image]

Sandcastle Help File Builder Documentation
ImageReference..::.FileItem Property
ImageReference Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get the file item associated with the image reference.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public FileItem FileItem { get; }
Visual Basic (Declaration)
Public ReadOnly Property FileItem As FileItem

See Also

ImageReference Class
SandcastleBuilder.Utils.ConceptualContent Namespace


Filename Property

[image]

Sandcastle Help File Builder Documentation
ImageReference..::.Filename Property
ImageReference Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get the image filename

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string Filename { get; }
Visual Basic (Declaration)
Public ReadOnly Property Filename As String

See Also

ImageReference Class
SandcastleBuilder.Utils.ConceptualContent Namespace


FullPath Property

[image]

Sandcastle Help File Builder Documentation
ImageReference..::.FullPath Property
ImageReference Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get the full path to the image file

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string FullPath { get; }
Visual Basic (Declaration)
Public ReadOnly Property FullPath As String

See Also

ImageReference Class
SandcastleBuilder.Utils.ConceptualContent Namespace


Id Property

[image]

Sandcastle Help File Builder Documentation
ImageReference..::.Id Property
ImageReference Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get the unique ID of the image

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string Id { get; set; }
Visual Basic (Declaration)
Public Property Id As String

See Also

ImageReference Class
SandcastleBuilder.Utils.ConceptualContent Namespace


ImageReferenceCollection Class

[image]

Sandcastle Help File Builder Documentation
ImageReferenceCollection Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This collection class is used to hold the conceptual content image references for a project.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public class ImageReferenceCollection : BindingList<ImageReference>
Visual Basic (Declaration)
Public Class ImageReferenceCollection _
    Inherits BindingList(Of ImageReference)

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection <(Of <( ImageReference >)>)
System.ComponentModel..::.BindingList <(Of <( ImageReference >)>)
SandcastleBuilder.Utils.ConceptualContent..::.ImageReferenceCollection

See Also

ImageReferenceCollection Members
SandcastleBuilder.Utils.ConceptualContent Namespace


ImageReferenceCollection Members

[image] [image]

Sandcastle Help File Builder Documentation
ImageReferenceCollection Members
ImageReferenceCollection Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ImageReferenceCollection type exposes the following members.

Constructors

Name | Description
ImageReferenceCollection | Constructor

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ImageReference >)>).)
AddNew | Adds a new item to the collection. (Inherited from BindingList <(Of <( ImageReference >)>).)
AddNewCore | Adds a new item to the end of the collection. (Inherited from BindingList <(Of <( ImageReference >)>).)
ApplySortCore | Sorts the items if overridden in a derived class; otherwise, throws a NotSupportedException. (Inherited from BindingList <(Of <( ImageReference >)>).)
CancelNew | Discards a pending new item. (Inherited from BindingList <(Of <( ImageReference >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ImageReference >)>).)
ClearItems | Removes all elements from the collection. (Inherited from BindingList <(Of <( ImageReference >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ImageReference >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <( ImageReference >)>).)
EndNew | Commits a pending new item to the collection. (Inherited from BindingList <(Of <( ImageReference >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindCore | Searches for the index of the item that has the specified property descriptor with the specified value, if searching is implemented in a derived class; otherwise, a NotSupportedException. (Inherited from BindingList <(Of <( ImageReference >)>).)
FindId | Find the image with the specified ID (case-insensitive).
FindImageFile | Find the image with the specified filename.
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ImageReference >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ImageReference >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( ImageReference >)>).)
InsertItem | Inserts the specified item in the list at the specified index. (Inherited from BindingList <(Of <( ImageReference >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnAddingNew | Raises the AddingNew event. (Inherited from BindingList <(Of <( ImageReference >)>).)
OnListChanged | Raises the ListChanged event. (Inherited from BindingList <(Of <( ImageReference >)>).)
Refresh | This is used to refresh the collection by loading the image build items from the project.
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ImageReference >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ImageReference >)>).)
RemoveItem | Removes the item at the specified index. (Inherited from BindingList <(Of <( ImageReference >)>).)
RemoveSortCore | Removes any sort applied with ApplySortCore(PropertyDescriptor, ListSortDirection) if sorting is implemented in a derived class; otherwise, raises NotSupportedException. (Inherited from BindingList <(Of <( ImageReference >)>).)
ResetBindings | Raises a ListChanged event of type Reset. (Inherited from BindingList <(Of <( ImageReference >)>).)
ResetItem | Raises a ListChanged event of type ItemChanged for the item at the specified position. (Inherited from BindingList <(Of <( ImageReference >)>).)
SaveAsSharedContent | Write the image reference collection to a map file ready for use by BuildAssembler.
SetItem | Replaces the item at the specified index with the specified item. (Inherited from BindingList <(Of <( ImageReference >)>).)
Sort | This is used to sort the collection
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AllowEdit | Gets or sets a value indicating whether items in the list can be edited. (Inherited from BindingList <(Of <( ImageReference >)>).)
AllowNew | Gets or sets a value indicating whether you can add items to the list using the AddNew()()() method. (Inherited from BindingList <(Of <( ImageReference >)>).)
AllowRemove | Gets or sets a value indicating whether you can remove items from the collection. (Inherited from BindingList <(Of <( ImageReference >)>).)
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ImageReference >)>).)
IsSortedCore | Gets a value indicating whether the list is sorted. (Inherited from BindingList <(Of <( ImageReference >)>).)
Item | Overloaded.
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ImageReference >)>).)
RaiseListChangedEvents | Gets or sets a value indicating whether adding or removing items within the list raises ListChanged events. (Inherited from BindingList <(Of <( ImageReference >)>).)
SortDirectionCore | Gets the direction the list is sorted. (Inherited from BindingList <(Of <( ImageReference >)>).)
SortPropertyCore | Gets the property descriptor that is used for sorting the list if sorting is implemented in a derived class; otherwise, returns null. (Inherited from BindingList <(Of <( ImageReference >)>).)
SupportsChangeNotificationCore | Gets a value indicating whether ListChanged events are enabled. (Inherited from BindingList <(Of <( ImageReference >)>).)
SupportsSearchingCore | Gets a value indicating whether the list supports searching. (Inherited from BindingList <(Of <( ImageReference >)>).)
SupportsSortingCore | Gets a value indicating whether the list supports sorting. (Inherited from BindingList <(Of <( ImageReference >)>).)

Events

Name | Description
AddingNew | Occurs before an item is added to the list. (Inherited from BindingList <(Of <( ImageReference >)>).)
ListChanged | Occurs when the list or an item in the list changes. (Inherited from BindingList <(Of <( ImageReference >)>).)

See Also

ImageReferenceCollection Class
SandcastleBuilder.Utils.ConceptualContent Namespace


ImageReferenceCollection Constructor

[image]

Sandcastle Help File Builder Documentation
ImageReferenceCollection Constructor
ImageReferenceCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public ImageReferenceCollection(
    SandcastleProject project
)
Visual Basic (Declaration)
Public Sub New ( _
    project As SandcastleProject _
)

Parameters

project
Type: SandcastleBuilder.Utils..::.SandcastleProject
The project file containing the image build items.

See Also

ImageReferenceCollection Class
SandcastleBuilder.Utils.ConceptualContent Namespace


ImageReferenceCollection Methods

[image] [image]

Sandcastle Help File Builder Documentation
ImageReferenceCollection Methods
ImageReferenceCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ImageReferenceCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ImageReference >)>).)
AddNew | Adds a new item to the collection. (Inherited from BindingList <(Of <( ImageReference >)>).)
AddNewCore | Adds a new item to the end of the collection. (Inherited from BindingList <(Of <( ImageReference >)>).)
ApplySortCore | Sorts the items if overridden in a derived class; otherwise, throws a NotSupportedException. (Inherited from BindingList <(Of <( ImageReference >)>).)
CancelNew | Discards a pending new item. (Inherited from BindingList <(Of <( ImageReference >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ImageReference >)>).)
ClearItems | Removes all elements from the collection. (Inherited from BindingList <(Of <( ImageReference >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ImageReference >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <( ImageReference >)>).)
EndNew | Commits a pending new item to the collection. (Inherited from BindingList <(Of <( ImageReference >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindCore | Searches for the index of the item that has the specified property descriptor with the specified value, if searching is implemented in a derived class; otherwise, a NotSupportedException. (Inherited from BindingList <(Of <( ImageReference >)>).)
FindId | Find the image with the specified ID (case-insensitive).
FindImageFile | Find the image with the specified filename.
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ImageReference >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ImageReference >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( ImageReference >)>).)
InsertItem | Inserts the specified item in the list at the specified index. (Inherited from BindingList <(Of <( ImageReference >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnAddingNew | Raises the AddingNew event. (Inherited from BindingList <(Of <( ImageReference >)>).)
OnListChanged | Raises the ListChanged event. (Inherited from BindingList <(Of <( ImageReference >)>).)
Refresh | This is used to refresh the collection by loading the image build items from the project.
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ImageReference >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ImageReference >)>).)
RemoveItem | Removes the item at the specified index. (Inherited from BindingList <(Of <( ImageReference >)>).)
RemoveSortCore | Removes any sort applied with ApplySortCore(PropertyDescriptor, ListSortDirection) if sorting is implemented in a derived class; otherwise, raises NotSupportedException. (Inherited from BindingList <(Of <( ImageReference >)>).)
ResetBindings | Raises a ListChanged event of type Reset. (Inherited from BindingList <(Of <( ImageReference >)>).)
ResetItem | Raises a ListChanged event of type ItemChanged for the item at the specified position. (Inherited from BindingList <(Of <( ImageReference >)>).)
SaveAsSharedContent | Write the image reference collection to a map file ready for use by BuildAssembler.
SetItem | Replaces the item at the specified index with the specified item. (Inherited from BindingList <(Of <( ImageReference >)>).)
Sort | This is used to sort the collection
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ImageReferenceCollection Class
SandcastleBuilder.Utils.ConceptualContent Namespace


FindId Method

[image]

Sandcastle Help File Builder Documentation
ImageReferenceCollection..::.FindId Method
ImageReferenceCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Find the image with the specified ID (case-insensitive).

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public ImageReference FindId(
    string id
)
Visual Basic (Declaration)
Public Function FindId ( _
    id As String _
) As ImageReference

Parameters

id
Type: System..::.String
The ID to find

Return Value

The image if found or null if not found

See Also

ImageReferenceCollection Class
SandcastleBuilder.Utils.ConceptualContent Namespace


FindImageFile Method

[image]

Sandcastle Help File Builder Documentation
ImageReferenceCollection..::.FindImageFile Method
ImageReferenceCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Find the image with the specified filename.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public ImageReference FindImageFile(
    string filename
)
Visual Basic (Declaration)
Public Function FindImageFile ( _
    filename As String _
) As ImageReference

Parameters

filename
Type: System..::.String
The filename to find

Return Value

The image if found or null if not found

See Also

ImageReferenceCollection Class
SandcastleBuilder.Utils.ConceptualContent Namespace


Refresh Method

[image]

Sandcastle Help File Builder Documentation
ImageReferenceCollection..::.Refresh Method
ImageReferenceCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to refresh the collection by loading the image build items from the project.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public void Refresh()
Visual Basic (Declaration)
Public Sub Refresh

See Also

ImageReferenceCollection Class
SandcastleBuilder.Utils.ConceptualContent Namespace


SaveAsSharedContent Method

[image]

Sandcastle Help File Builder Documentation
ImageReferenceCollection..::.SaveAsSharedContent Method
ImageReferenceCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Write the image reference collection to a map file ready for use by BuildAssembler.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public void SaveAsSharedContent(
    string filename,
    string imagePath,
    BuildProcess builder
)
Visual Basic (Declaration)
Public Sub SaveAsSharedContent ( _
    filename As String, _
    imagePath As String, _
    builder As BuildProcess _
)

Parameters

filename
Type: System..::.String
The file to which the image reference collection is saved.
imagePath
Type: System..::.String
The path to which the image files should be copied.
builder
Type: SandcastleBuilder.Utils.BuildEngine..::.BuildProcess
The build process

Remarks

Images with their CopyToMedia property set to true are copied to the media folder immediately.

See Also

ImageReferenceCollection Class
SandcastleBuilder.Utils.ConceptualContent Namespace


Sort Method

[image]

Sandcastle Help File Builder Documentation
ImageReferenceCollection..::.Sort Method
ImageReferenceCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to sort the collection

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public void Sort()
Visual Basic (Declaration)
Public Sub Sort

Remarks

Values are sorted by display title and ID. Comparisons are case-insensitive.

See Also

ImageReferenceCollection Class
SandcastleBuilder.Utils.ConceptualContent Namespace


ImageReferenceCollection Properties

[image] [image]

Sandcastle Help File Builder Documentation
ImageReferenceCollection Properties
ImageReferenceCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ImageReferenceCollection type exposes the following members.

Properties

Name | Description
AllowEdit | Gets or sets a value indicating whether items in the list can be edited. (Inherited from BindingList <(Of <( ImageReference >)>).)
AllowNew | Gets or sets a value indicating whether you can add items to the list using the AddNew()()() method. (Inherited from BindingList <(Of <( ImageReference >)>).)
AllowRemove | Gets or sets a value indicating whether you can remove items from the collection. (Inherited from BindingList <(Of <( ImageReference >)>).)
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ImageReference >)>).)
IsSortedCore | Gets a value indicating whether the list is sorted. (Inherited from BindingList <(Of <( ImageReference >)>).)
Item | Overloaded.
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ImageReference >)>).)
RaiseListChangedEvents | Gets or sets a value indicating whether adding or removing items within the list raises ListChanged events. (Inherited from BindingList <(Of <( ImageReference >)>).)
SortDirectionCore | Gets the direction the list is sorted. (Inherited from BindingList <(Of <( ImageReference >)>).)
SortPropertyCore | Gets the property descriptor that is used for sorting the list if sorting is implemented in a derived class; otherwise, returns null. (Inherited from BindingList <(Of <( ImageReference >)>).)
SupportsChangeNotificationCore | Gets a value indicating whether ListChanged events are enabled. (Inherited from BindingList <(Of <( ImageReference >)>).)
SupportsSearchingCore | Gets a value indicating whether the list supports searching. (Inherited from BindingList <(Of <( ImageReference >)>).)
SupportsSortingCore | Gets a value indicating whether the list supports sorting. (Inherited from BindingList <(Of <( ImageReference >)>).)

See Also

ImageReferenceCollection Class
SandcastleBuilder.Utils.ConceptualContent Namespace


Item Property

[image] [image]

Sandcastle Help File Builder Documentation
ImageReferenceCollection..::.Item Property
ImageReferenceCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Item[([(Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection <(Of <( ImageReference >)>).)
Item[([(String])]) | This can be used to get an image by its unique ID (case-sensitive)

See Also

ImageReferenceCollection Class
ImageReferenceCollection Members
SandcastleBuilder.Utils.ConceptualContent Namespace


Item Property (String)

[image]

Sandcastle Help File Builder Documentation
ImageReferenceCollection..::.Item Property (String)
ImageReferenceCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This can be used to get an image by its unique ID (case-sensitive)

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public ImageReference this[
    string id
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    id As String _
) As ImageReference

Parameters

id
Type: System..::.String
The ID of the item to get.

Field Value

Returns the image with the specified Id or null if not found.

See Also

ImageReferenceCollection Class
Item Overload
SandcastleBuilder.Utils.ConceptualContent Namespace


ImageReferenceCollection Events

[image] [image]

Sandcastle Help File Builder Documentation
ImageReferenceCollection Events
ImageReferenceCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ImageReferenceCollection type exposes the following members.

Events

Name | Description
AddingNew | Occurs before an item is added to the list. (Inherited from BindingList <(Of <( ImageReference >)>).)
ListChanged | Occurs when the list or an item in the list changes. (Inherited from BindingList <(Of <( ImageReference >)>).)

See Also

ImageReferenceCollection Class
SandcastleBuilder.Utils.ConceptualContent Namespace


ITableOfContents Interface

[image]

Sandcastle Help File Builder Documentation
ITableOfContents Interface
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This interface is used to interact with project files that can generate table of contents entries.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public interface ITableOfContents
Visual Basic (Declaration)
Public Interface ITableOfContents

See Also

ITableOfContents Members
SandcastleBuilder.Utils.ConceptualContent Namespace


ITableOfContents Members

[image] [image]

Sandcastle Help File Builder Documentation
ITableOfContents Members
ITableOfContents Interface Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ITableOfContents type exposes the following members.

Methods

Name | Description
GenerateTableOfContents | Generate the table of contents for the conceptual topics

Properties

Name | Description
ContentLayoutFile | Get the content layout FileItem

See Also

ITableOfContents Interface
SandcastleBuilder.Utils.ConceptualContent Namespace


ITableOfContents Methods

[image] [image]

Sandcastle Help File Builder Documentation
ITableOfContents Methods
ITableOfContents Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ITableOfContents type exposes the following members.

Methods

Name | Description
GenerateTableOfContents | Generate the table of contents for the conceptual topics

See Also

ITableOfContents Interface
SandcastleBuilder.Utils.ConceptualContent Namespace


GenerateTableOfContents Method

[image]

Sandcastle Help File Builder Documentation
ITableOfContents..::.GenerateTableOfContents Method
ITableOfContents Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Generate the table of contents for the conceptual topics

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
void GenerateTableOfContents(
    TocEntryCollection toc,
    IBasePathProvider pathProvider
)
Visual Basic (Declaration)
Sub GenerateTableOfContents ( _
    toc As TocEntryCollection, _
    pathProvider As IBasePathProvider _
)

Parameters

toc
Type: SandcastleBuilder.Utils.ConceptualContent..::.TocEntryCollection
The table of contents collection
pathProvider
Type: SandcastleBuilder.Utils..::.IBasePathProvider
The base path provider

See Also

ITableOfContents Interface
SandcastleBuilder.Utils.ConceptualContent Namespace


ITableOfContents Properties

[image] [image]

Sandcastle Help File Builder Documentation
ITableOfContents Properties
ITableOfContents Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ITableOfContents type exposes the following members.

Properties

Name | Description
ContentLayoutFile | Get the content layout FileItem

See Also

ITableOfContents Interface
SandcastleBuilder.Utils.ConceptualContent Namespace


ContentLayoutFile Property

[image]

Sandcastle Help File Builder Documentation
ITableOfContents..::.ContentLayoutFile Property
ITableOfContents Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Get the content layout FileItem

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
FileItem ContentLayoutFile { get; }
Visual Basic (Declaration)
ReadOnly Property ContentLayoutFile As FileItem

See Also

ITableOfContents Interface
SandcastleBuilder.Utils.ConceptualContent Namespace


TocEntry Class

[image]

Sandcastle Help File Builder Documentation
TocEntry Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This represents a table of contents entry. This is used to build the table of contents entries for additional content items.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public class TocEntry : IComparable<TocEntry>,
    ICloneable
Visual Basic (Declaration)
Public Class TocEntry _
    Implements IComparable(Of TocEntry), ICloneable

Inheritance Hierarchy

System..::.Object
SandcastleBuilder.Utils.ConceptualContent..::.TocEntry

See Also

TocEntry Members
SandcastleBuilder.Utils.ConceptualContent Namespace


TocEntry Members

[image] [image]

Sandcastle Help File Builder Documentation
TocEntry Members
TocEntry Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TocEntry type exposes the following members.

Constructors

Name | Description
TocEntry | Constructor

Methods

Name | Description
Clone | Clone this table of contents entry
CompareTo | Compares this instance to another instance and returns an indication of their relative values.
ContainsMatch | See if this entry or one of its children is a match to the specified source filename.
Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Get a hash code for this item (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
LoadSiteMapNode | This will load information about the entry from the node and will also load all child nodes.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SaveAsSiteMapNode | Save this node and its children to the specified root node as site map nodes.
ToAnchor | Convert the entry to its <a> element form
ToString | Overloaded.

Operators

Name | Description
Equality | Overload for equal operator
GreaterThan | Overload for greater than operator
Inequality | Overload for not equal operator
LessThan | Overload for less than operator

Properties

Name | Description
BasePathProvider | This returns the IBasePathProvider for the entry.
Children | This returns the child table of contents collection for this entry
DestinationFile | This is used to get or set the entry's destination file path.
HasCodeBlocks | This is used to get or set whether or not the topic has <code /> blocks that need expanding.
HasLinks | This is used to get or set whether or not the topic has links that need to be resolved when the file is copied.
HasProjectTags | This is used to get or set whether or not the topic has tags that should be resolved to project options.
IncludePage | This is used to get or set whether or not the page will appear in the table of contents.
IsDefaultTopic | This is used to get or set whether or not the item is the default topic for the help file.
NeedsColorizing | This is used to get or set whether or not the topic has <pre> blocks that have a lang attribute to indicate that they should be colorized.
Parent | This is used to track the topic's parent collection
SortOrder | This is used to get or set the sort order for the entry within its group.
SourceFile | This is used to get or set the entry's source file path.
SplitToc | This is used to get or set whether or not the table of contents is split after this entry.
Title | This is used to get or set the entry's title in the table of contents.

See Also

TocEntry Class
SandcastleBuilder.Utils.ConceptualContent Namespace


TocEntry Constructor

[image]

Sandcastle Help File Builder Documentation
TocEntry Constructor
TocEntry Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public TocEntry(
    IBasePathProvider basePathProvider
)
Visual Basic (Declaration)
Public Sub New ( _
    basePathProvider As IBasePathProvider _
)

Parameters

basePathProvider
Type: SandcastleBuilder.Utils..::.IBasePathProvider
The base path provider

See Also

TocEntry Class
SandcastleBuilder.Utils.ConceptualContent Namespace


TocEntry Methods

[image] [image]

Sandcastle Help File Builder Documentation
TocEntry Methods
TocEntry Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TocEntry type exposes the following members.

Methods

Name | Description
Clone | Clone this table of contents entry
CompareTo | Compares this instance to another instance and returns an indication of their relative values.
ContainsMatch | See if this entry or one of its children is a match to the specified source filename.
Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Get a hash code for this item (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
LoadSiteMapNode | This will load information about the entry from the node and will also load all child nodes.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SaveAsSiteMapNode | Save this node and its children to the specified root node as site map nodes.
ToAnchor | Convert the entry to its <a> element form
ToString | Overloaded.

Operators

Name | Description
Equality | Overload for equal operator
GreaterThan | Overload for greater than operator
Inequality | Overload for not equal operator
LessThan | Overload for less than operator

See Also

TocEntry Class
SandcastleBuilder.Utils.ConceptualContent Namespace


Clone Method

[image]

Sandcastle Help File Builder Documentation
TocEntry..::.Clone Method
TocEntry Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clone this table of contents entry

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public Object Clone()
Visual Basic (Declaration)
Public Function Clone As Object

Return Value

A clone of this table of contents entry

Implements

ICloneable..::.Clone()()()

See Also

TocEntry Class
SandcastleBuilder.Utils.ConceptualContent Namespace


CompareTo Method

[image]

Sandcastle Help File Builder Documentation
TocEntry..::.CompareTo Method
TocEntry Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Compares this instance to another instance and returns an indication of their relative values.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public int CompareTo(
    TocEntry other
)
Visual Basic (Declaration)
Public Function CompareTo ( _
    other As TocEntry _
) As Integer

Parameters

other
Type: SandcastleBuilder.Utils.ConceptualContent..::.TocEntry
A TocEntry object to compare

Return Value

Returns -1 if this instance is less than the value, 0 if they are equal, or 1 if this instance is greater than the value or the value is null.

Implements

IComparable<(Of <(T>)>)..::.CompareTo(T)

Remarks

The SortOrder property is compared first. If equal, the Title property is used.

See Also

TocEntry Class
SandcastleBuilder.Utils.ConceptualContent Namespace


ContainsMatch Method

[image]

Sandcastle Help File Builder Documentation
TocEntry..::.ContainsMatch Method
TocEntry Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

See if this entry or one of its children is a match to the specified source filename.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public TocEntry ContainsMatch(
    string sourceFilename
)
Visual Basic (Declaration)
Public Function ContainsMatch ( _
    sourceFilename As String _
) As TocEntry

Parameters

sourceFilename
Type: System..::.String
The source filename to match

Return Value

The match TOC entry or null if not found

See Also

TocEntry Class
SandcastleBuilder.Utils.ConceptualContent Namespace


Equality Operator

[image]

Sandcastle Help File Builder Documentation
TocEntry..::.Equality Operator
TocEntry Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload for equal operator

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public static bool operator ==(
    TocEntry t1,
    TocEntry t2
)
Visual Basic (Declaration)
Public Shared Operator = ( _
    t1 As TocEntry, _
    t2 As TocEntry _
) As Boolean

Parameters

t1
Type: SandcastleBuilder.Utils.ConceptualContent..::.TocEntry
The first TOC entry object
t2
Type: SandcastleBuilder.Utils.ConceptualContent..::.TocEntry
The second TOC entry object

Return Value

True if equal, false if not.

See Also

TocEntry Class
SandcastleBuilder.Utils.ConceptualContent Namespace


Equals Method

[image]

Sandcastle Help File Builder Documentation
TocEntry..::.Equals Method
TocEntry Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Determines whether the specified Object is equal to the current Object.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::.Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Exceptions

Exception | Condition
System..::.NullReferenceException | The obj parameter is null.

See Also

TocEntry Class
SandcastleBuilder.Utils.ConceptualContent Namespace


GetHashCode Method

[image]

Sandcastle Help File Builder Documentation
TocEntry..::.GetHashCode Method
TocEntry Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Get a hash code for this item

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer

Return Value

Returns the hash code for the ToString()()() value.

See Also

TocEntry Class
SandcastleBuilder.Utils.ConceptualContent Namespace


GreaterThan Operator

[image]

Sandcastle Help File Builder Documentation
TocEntry..::.GreaterThan Operator
TocEntry Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload for greater than operator

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public static bool operator >(
    TocEntry t1,
    TocEntry t2
)
Visual Basic (Declaration)
Public Shared Operator > ( _
    t1 As TocEntry, _
    t2 As TocEntry _
) As Boolean

Parameters

t1
Type: SandcastleBuilder.Utils.ConceptualContent..::.TocEntry
The first TOC entry object
t2
Type: SandcastleBuilder.Utils.ConceptualContent..::.TocEntry
The second TOC entry object

Return Value

True if t1 is greater than t2, false if not.

See Also

TocEntry Class
SandcastleBuilder.Utils.ConceptualContent Namespace


Inequality Operator

[image]

Sandcastle Help File Builder Documentation
TocEntry..::.Inequality Operator
TocEntry Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload for not equal operator

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public static bool operator !=(
    TocEntry t1,
    TocEntry t2
)
Visual Basic (Declaration)
Public Shared Operator <> ( _
    t1 As TocEntry, _
    t2 As TocEntry _
) As Boolean

Parameters

t1
Type: SandcastleBuilder.Utils.ConceptualContent..::.TocEntry
The first TOC entry object
t2
Type: SandcastleBuilder.Utils.ConceptualContent..::.TocEntry
The second TOC entry object

Return Value

True if not equal, false if they are equal.

See Also

TocEntry Class
SandcastleBuilder.Utils.ConceptualContent Namespace


LessThan Operator

[image]

Sandcastle Help File Builder Documentation
TocEntry..::.LessThan Operator
TocEntry Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload for less than operator

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public static bool operator <(
    TocEntry t1,
    TocEntry t2
)
Visual Basic (Declaration)
Public Shared Operator < ( _
    t1 As TocEntry, _
    t2 As TocEntry _
) As Boolean

Parameters

t1
Type: SandcastleBuilder.Utils.ConceptualContent..::.TocEntry
The first TOC entry object
t2
Type: SandcastleBuilder.Utils.ConceptualContent..::.TocEntry
The second TOC entry object

Return Value

True if t1 is less than t2, false if not.

See Also

TocEntry Class
SandcastleBuilder.Utils.ConceptualContent Namespace


LoadSiteMapNode Method

[image]

Sandcastle Help File Builder Documentation
TocEntry..::.LoadSiteMapNode Method
TocEntry Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This will load information about the entry from the node and will also load all child nodes.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public void LoadSiteMapNode(
    XmlNode site
)
Visual Basic (Declaration)
Public Sub LoadSiteMapNode ( _
    site As XmlNode _
)

Parameters

site
Type: System.Xml..::.XmlNode
The site map node to use for this entry

See Also

TocEntry Class
SandcastleBuilder.Utils.ConceptualContent Namespace


SaveAsSiteMapNode Method

[image]

Sandcastle Help File Builder Documentation
TocEntry..::.SaveAsSiteMapNode Method
TocEntry Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Save this node and its children to the specified root node as site map nodes.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public void SaveAsSiteMapNode(
    XmlNode root
)
Visual Basic (Declaration)
Public Sub SaveAsSiteMapNode ( _
    root As XmlNode _
)

Parameters

root
Type: System.Xml..::.XmlNode
The root node to which the current entry is added.

See Also

TocEntry Class
SandcastleBuilder.Utils.ConceptualContent Namespace


ToAnchor Method

[image]

Sandcastle Help File Builder Documentation
TocEntry..::.ToAnchor Method
TocEntry Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Convert the entry to its <a> element form

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string ToAnchor(
    string innerText
)
Visual Basic (Declaration)
Public Function ToAnchor ( _
    innerText As String _
) As String

Parameters

innerText
Type: System..::.String
Optional inner text

Return Value

The topic in its <a> element form

See Also

TocEntry Class
SandcastleBuilder.Utils.ConceptualContent Namespace


ToString Method

[image] [image]

Sandcastle Help File Builder Documentation
TocEntry..::.ToString Method
TocEntry Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ToString()()() | Convert the table of contents entry and its children to a string (Overrides Object..::.ToString()()().)
ToString(HelpFileFormat) | Convert the table of contents entry and its children to a string in the specified help file format.

See Also

TocEntry Class
TocEntry Members
SandcastleBuilder.Utils.ConceptualContent Namespace


ToString Method

[image]

Sandcastle Help File Builder Documentation
TocEntry..::.ToString Method
TocEntry Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Convert the table of contents entry and its children to a string

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

Return Value

The entries in HTML 1.x help format

See Also

TocEntry Class
ToString Overload
SandcastleBuilder.Utils.ConceptualContent Namespace


ToString Method (HelpFileFormat)

[image]

Sandcastle Help File Builder Documentation
TocEntry..::.ToString Method (HelpFileFormat)
TocEntry Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Convert the table of contents entry and its children to a string in the specified help file format.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string ToString(
    HelpFileFormat format
)
Visual Basic (Declaration)
Public Function ToString ( _
    format As HelpFileFormat _
) As String

Parameters

format
Type: SandcastleBuilder.Utils..::.HelpFileFormat
The help file format to use

Return Value

The entries in specified help format

Exceptions

Exception | Condition
System..::.ArgumentException | This is thrown if the format is not HtmlHelp1x or HtmlHelp2x.

See Also

TocEntry Class
ToString Overload
SandcastleBuilder.Utils.ConceptualContent Namespace


TocEntry Properties

[image] [image]

Sandcastle Help File Builder Documentation
TocEntry Properties
TocEntry Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TocEntry type exposes the following members.

Properties

Name | Description
BasePathProvider | This returns the IBasePathProvider for the entry.
Children | This returns the child table of contents collection for this entry
DestinationFile | This is used to get or set the entry's destination file path.
HasCodeBlocks | This is used to get or set whether or not the topic has <code /> blocks that need expanding.
HasLinks | This is used to get or set whether or not the topic has links that need to be resolved when the file is copied.
HasProjectTags | This is used to get or set whether or not the topic has tags that should be resolved to project options.
IncludePage | This is used to get or set whether or not the page will appear in the table of contents.
IsDefaultTopic | This is used to get or set whether or not the item is the default topic for the help file.
NeedsColorizing | This is used to get or set whether or not the topic has <pre> blocks that have a lang attribute to indicate that they should be colorized.
Parent | This is used to track the topic's parent collection
SortOrder | This is used to get or set the sort order for the entry within its group.
SourceFile | This is used to get or set the entry's source file path.
SplitToc | This is used to get or set whether or not the table of contents is split after this entry.
Title | This is used to get or set the entry's title in the table of contents.

See Also

TocEntry Class
SandcastleBuilder.Utils.ConceptualContent Namespace


BasePathProvider Property

[image]

Sandcastle Help File Builder Documentation
TocEntry..::.BasePathProvider Property
TocEntry Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This returns the IBasePathProvider for the entry.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public IBasePathProvider BasePathProvider { get; }
Visual Basic (Declaration)
Public ReadOnly Property BasePathProvider As IBasePathProvider

See Also

TocEntry Class
SandcastleBuilder.Utils.ConceptualContent Namespace


Children Property

[image]

Sandcastle Help File Builder Documentation
TocEntry..::.Children Property
TocEntry Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This returns the child table of contents collection for this entry

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public TocEntryCollection Children { get; }
Visual Basic (Declaration)
Public ReadOnly Property Children As TocEntryCollection

Field Value

If empty, this is a single item in the table of contents. If it has children, they are listed below this one. A file may or may not be associated with this entry if it is a root node.

See Also

TocEntry Class
SandcastleBuilder.Utils.ConceptualContent Namespace


DestinationFile Property

[image]

Sandcastle Help File Builder Documentation
TocEntry..::.DestinationFile Property
TocEntry Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set the entry's destination file path.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string DestinationFile { get; set; }
Visual Basic (Declaration)
Public Property DestinationFile As String

See Also

TocEntry Class
SandcastleBuilder.Utils.ConceptualContent Namespace


HasCodeBlocks Property

[image]

Sandcastle Help File Builder Documentation
TocEntry..::.HasCodeBlocks Property
TocEntry Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set whether or not the topic has <code /> blocks that need expanding.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool HasCodeBlocks { get; set; }
Visual Basic (Declaration)
Public Property HasCodeBlocks As Boolean

See Also

TocEntry Class
SandcastleBuilder.Utils.ConceptualContent Namespace


HasLinks Property

[image]

Sandcastle Help File Builder Documentation
TocEntry..::.HasLinks Property
TocEntry Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set whether or not the topic has links that need to be resolved when the file is copied.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool HasLinks { get; set; }
Visual Basic (Declaration)
Public Property HasLinks As Boolean

See Also

TocEntry Class
SandcastleBuilder.Utils.ConceptualContent Namespace


HasProjectTags Property

[image]

Sandcastle Help File Builder Documentation
TocEntry..::.HasProjectTags Property
TocEntry Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set whether or not the topic has tags that should be resolved to project options.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool HasProjectTags { get; set; }
Visual Basic (Declaration)
Public Property HasProjectTags As Boolean

See Also

TocEntry Class
SandcastleBuilder.Utils.ConceptualContent Namespace


IncludePage Property

[image]

Sandcastle Help File Builder Documentation
TocEntry..::.IncludePage Property
TocEntry Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set whether or not the page will appear in the table of contents.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool IncludePage { get; set; }
Visual Basic (Declaration)
Public Property IncludePage As Boolean

Remarks

For root entries that have children, the node will appear in the table of contents but will have no page associated with it. The other options such as SortOrder will still have an effect.

See Also

TocEntry Class
SandcastleBuilder.Utils.ConceptualContent Namespace


IsDefaultTopic Property

[image]

Sandcastle Help File Builder Documentation
TocEntry..::.IsDefaultTopic Property
TocEntry Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set whether or not the item is the default topic for the help file.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool IsDefaultTopic { get; set; }
Visual Basic (Declaration)
Public Property IsDefaultTopic As Boolean

See Also

TocEntry Class
SandcastleBuilder.Utils.ConceptualContent Namespace


NeedsColorizing Property

[image]

Sandcastle Help File Builder Documentation
TocEntry..::.NeedsColorizing Property
TocEntry Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set whether or not the topic has <pre> blocks that have a lang attribute to indicate that they should be colorized.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool NeedsColorizing { get; set; }
Visual Basic (Declaration)
Public Property NeedsColorizing As Boolean

See Also

TocEntry Class
SandcastleBuilder.Utils.ConceptualContent Namespace


Parent Property

[image]

Sandcastle Help File Builder Documentation
TocEntry..::.Parent Property
TocEntry Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to track the topic's parent collection

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public TocEntryCollection Parent { get; internal set; }
Visual Basic (Declaration)
Public Property Parent As TocEntryCollection

Remarks

This is used by the designer to move items around within the collection.

See Also

TocEntry Class
SandcastleBuilder.Utils.ConceptualContent Namespace


SortOrder Property

[image]

Sandcastle Help File Builder Documentation
TocEntry..::.SortOrder Property
TocEntry Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set the sort order for the entry within its group.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public int SortOrder { get; set; }
Visual Basic (Declaration)
Public Property SortOrder As Integer

Field Value

Entries with identical sort order values will sort by title as well. Items with not specific sort order will sort below those with a defined sort order.

See Also

TocEntry Class
SandcastleBuilder.Utils.ConceptualContent Namespace


SourceFile Property

[image]

Sandcastle Help File Builder Documentation
TocEntry..::.SourceFile Property
TocEntry Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set the entry's source file path.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public FilePath SourceFile { get; set; }
Visual Basic (Declaration)
Public Property SourceFile As FilePath

See Also

TocEntry Class
SandcastleBuilder.Utils.ConceptualContent Namespace


SplitToc Property

[image]

Sandcastle Help File Builder Documentation
TocEntry..::.SplitToc Property
TocEntry Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set whether or not the table of contents is split after this entry.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool SplitToc { get; set; }
Visual Basic (Declaration)
Public Property SplitToc As Boolean

Remarks

This is only valid on root entries and the first one seen will cause all items from that tiem onward to appear below the API content. All items prior to the entry will appear before the API content. If used, the ContentPlacement project property will be ignored.

See Also

TocEntry Class
SandcastleBuilder.Utils.ConceptualContent Namespace


Title Property

[image]

Sandcastle Help File Builder Documentation
TocEntry..::.Title Property
TocEntry Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set the entry's title in the table of contents.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string Title { get; set; }
Visual Basic (Declaration)
Public Property Title As String

See Also

TocEntry Class
SandcastleBuilder.Utils.ConceptualContent Namespace


TocEntryCollection Class

[image]

Sandcastle Help File Builder Documentation
TocEntryCollection Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This collection class is used to hold the table of contents entries for additional content items.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public class TocEntryCollection : BindingList<TocEntry>,
    ITableOfContents
Visual Basic (Declaration)
Public Class TocEntryCollection _
    Inherits BindingList(Of TocEntry) _
    Implements ITableOfContents

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection <(Of <( TocEntry >)>)
System.ComponentModel..::.BindingList <(Of <( TocEntry >)>)
SandcastleBuilder.Utils.ConceptualContent..::.TocEntryCollection

See Also

TocEntryCollection Members
SandcastleBuilder.Utils.ConceptualContent Namespace


TocEntryCollection Members

[image] [image]

Sandcastle Help File Builder Documentation
TocEntryCollection Members
TocEntryCollection Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TocEntryCollection type exposes the following members.

Constructors

Name | Description
TocEntryCollection | Overloaded. There are two overloads for the constructor

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( TocEntry >)>).)
AddNew | Adds a new item to the collection. (Inherited from BindingList <(Of <( TocEntry >)>).)
AddNewCore | Adds a new item to the end of the collection. (Inherited from BindingList <(Of <( TocEntry >)>).)
AddTopicsFromFolder | Add all topics from the specified folder recursively to the collection and to the given project file.
ApplySortCore | Sorts the items if overridden in a derived class; otherwise, throws a NotSupportedException. (Inherited from BindingList <(Of <( TocEntry >)>).)
CancelNew | Discards a pending new item. (Inherited from BindingList <(Of <( TocEntry >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( TocEntry >)>).)
ClearItems | Removes all elements from the collection. (Inherited from BindingList <(Of <( TocEntry >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( TocEntry >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <( TocEntry >)>).)
EndNew | Commits a pending new item to the collection. (Inherited from BindingList <(Of <( TocEntry >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Find | Find a TOC entry with the same source filename
FindCore | Searches for the index of the item that has the specified property descriptor with the specified value, if searching is implemented in a derived class; otherwise, a NotSupportedException. (Inherited from BindingList <(Of <( TocEntry >)>).)
FindDefaultTopic | This is used to locate the default topic if one exists
GenerateTableOfContents | This is used to merge this TOC with another one
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( TocEntry >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection <(Of <( TocEntry >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( TocEntry >)>).)
InsertItem | This is overridden to set the inserted item's parent to this collection. (Overrides BindingList<(Of <(T>)>)..::.InsertItem(Int32, T).)
Load | This is used to load the table of contents entries from the site map file associated with the collection.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnAddingNew | Raises the AddingNew event. (Inherited from BindingList <(Of <( TocEntry >)>).)
OnListChanged | Raises the ListChanged event. (Inherited from BindingList <(Of <( TocEntry >)>).)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( TocEntry >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( TocEntry >)>).)
RemoveExcludedNodes | This will remove excluded nodes from a TOC created off of the additional content items in a project. In addition, it merges the information from folder entries into the folder nodes.
RemoveItem | This is overridden to clear the parent on the removed item (Overrides BindingList<(Of <(T>)>)..::.RemoveItem(Int32).)
RemoveSortCore | Removes any sort applied with ApplySortCore(PropertyDescriptor, ListSortDirection) if sorting is implemented in a derived class; otherwise, raises NotSupportedException. (Inherited from BindingList <(Of <( TocEntry >)>).)
ResetBindings | Raises a ListChanged event of type Reset. (Inherited from BindingList <(Of <( TocEntry >)>).)
ResetItem | Raises a ListChanged event of type ItemChanged for the item at the specified position. (Inherited from BindingList <(Of <( TocEntry >)>).)
Save | This is used to save the table of contents entries to the site map file associated with the collection.
SetItem | This is overridden to set the inserted item's parent to this collection. (Overrides BindingList<(Of <(T>)>)..::.SetItem(Int32, T).)
Sort | This is used to sort the collection
ToString | Overloaded.

Properties

Name | Description
AllowEdit | Gets or sets a value indicating whether items in the list can be edited. (Inherited from BindingList <(Of <( TocEntry >)>).)
AllowNew | Gets or sets a value indicating whether you can add items to the list using the AddNew()()() method. (Inherited from BindingList <(Of <( TocEntry >)>).)
AllowRemove | Gets or sets a value indicating whether you can remove items from the collection. (Inherited from BindingList <(Of <( TocEntry >)>).)
ContentLayoutFile | This is used to get the site map file associated with the collection.
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( TocEntry >)>).)
DefaultTopic | This is used to get the default topic
FileItem | This read-only property returns the project file item associated with the collection.
IsSortedCore | Gets a value indicating whether the list is sorted. (Inherited from BindingList <(Of <( TocEntry >)>).)
Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <( TocEntry >)>).)
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( TocEntry >)>).)
RaiseListChangedEvents | Gets or sets a value indicating whether adding or removing items within the list raises ListChanged events. (Inherited from BindingList <(Of <( TocEntry >)>).)
SortDirectionCore | Gets the direction the list is sorted. (Inherited from BindingList <(Of <( TocEntry >)>).)
SortPropertyCore | Gets the property descriptor that is used for sorting the list if sorting is implemented in a derived class; otherwise, returns null. (Inherited from BindingList <(Of <( TocEntry >)>).)
SplitTocAtTopic | This is used to get the topic at which the table of contents is split by the API content.
SupportsChangeNotificationCore | Gets a value indicating whether ListChanged events are enabled. (Inherited from BindingList <(Of <( TocEntry >)>).)
SupportsSearchingCore | Gets a value indicating whether the list supports searching. (Inherited from BindingList <(Of <( TocEntry >)>).)
SupportsSortingCore | Gets a value indicating whether the list supports sorting. (Inherited from BindingList <(Of <( TocEntry >)>).)

Events

Name | Description
AddingNew | Occurs before an item is added to the list. (Inherited from BindingList <(Of <( TocEntry >)>).)
ListChanged | Occurs when the list or an item in the list changes. (Inherited from BindingList <(Of <( TocEntry >)>).)

See Also

TocEntryCollection Class
SandcastleBuilder.Utils.ConceptualContent Namespace


TocEntryCollection Constructor

[image] [image]

Sandcastle Help File Builder Documentation
TocEntryCollection Constructor
TocEntryCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

There are two overloads for the constructor

Overload List

Name | Description
TocEntryCollection()()() | Default constructor
TocEntryCollection(FileItem) | Constructor

See Also

TocEntryCollection Class
TocEntryCollection Members
SandcastleBuilder.Utils.ConceptualContent Namespace


TocEntryCollection Constructor

[image]

Sandcastle Help File Builder Documentation
TocEntryCollection Constructor
TocEntryCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Default constructor

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public TocEntryCollection()
Visual Basic (Declaration)
Public Sub New

See Also

TocEntryCollection Class
TocEntryCollection Overload
SandcastleBuilder.Utils.ConceptualContent Namespace


TocEntryCollection Constructor (FileItem)

[image]

Sandcastle Help File Builder Documentation
TocEntryCollection Constructor (FileItem)
TocEntryCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public TocEntryCollection(
    FileItem siteMap
)
Visual Basic (Declaration)
Public Sub New ( _
    siteMap As FileItem _
)

Parameters

siteMap
Type: SandcastleBuilder.Utils..::.FileItem
The site map file associated with the collection.

See Also

TocEntryCollection Class
TocEntryCollection Overload
SandcastleBuilder.Utils.ConceptualContent Namespace


TocEntryCollection Methods

[image] [image]

Sandcastle Help File Builder Documentation
TocEntryCollection Methods
TocEntryCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TocEntryCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( TocEntry >)>).)
AddNew | Adds a new item to the collection. (Inherited from BindingList <(Of <( TocEntry >)>).)
AddNewCore | Adds a new item to the end of the collection. (Inherited from BindingList <(Of <( TocEntry >)>).)
AddTopicsFromFolder | Add all topics from the specified folder recursively to the collection and to the given project file.
ApplySortCore | Sorts the items if overridden in a derived class; otherwise, throws a NotSupportedException. (Inherited from BindingList <(Of <( TocEntry >)>).)
CancelNew | Discards a pending new item. (Inherited from BindingList <(Of <( TocEntry >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( TocEntry >)>).)
ClearItems | Removes all elements from the collection. (Inherited from BindingList <(Of <( TocEntry >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( TocEntry >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <( TocEntry >)>).)
EndNew | Commits a pending new item to the collection. (Inherited from BindingList <(Of <( TocEntry >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Find | Find a TOC entry with the same source filename
FindCore | Searches for the index of the item that has the specified property descriptor with the specified value, if searching is implemented in a derived class; otherwise, a NotSupportedException. (Inherited from BindingList <(Of <( TocEntry >)>).)
FindDefaultTopic | This is used to locate the default topic if one exists
GenerateTableOfContents | This is used to merge this TOC with another one
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( TocEntry >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection <(Of <( TocEntry >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( TocEntry >)>).)
InsertItem | This is overridden to set the inserted item's parent to this collection. (Overrides BindingList<(Of <(T>)>)..::.InsertItem(Int32, T).)
Load | This is used to load the table of contents entries from the site map file associated with the collection.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnAddingNew | Raises the AddingNew event. (Inherited from BindingList <(Of <( TocEntry >)>).)
OnListChanged | Raises the ListChanged event. (Inherited from BindingList <(Of <( TocEntry >)>).)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( TocEntry >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( TocEntry >)>).)
RemoveExcludedNodes | This will remove excluded nodes from a TOC created off of the additional content items in a project. In addition, it merges the information from folder entries into the folder nodes.
RemoveItem | This is overridden to clear the parent on the removed item (Overrides BindingList<(Of <(T>)>)..::.RemoveItem(Int32).)
RemoveSortCore | Removes any sort applied with ApplySortCore(PropertyDescriptor, ListSortDirection) if sorting is implemented in a derived class; otherwise, raises NotSupportedException. (Inherited from BindingList <(Of <( TocEntry >)>).)
ResetBindings | Raises a ListChanged event of type Reset. (Inherited from BindingList <(Of <( TocEntry >)>).)
ResetItem | Raises a ListChanged event of type ItemChanged for the item at the specified position. (Inherited from BindingList <(Of <( TocEntry >)>).)
Save | This is used to save the table of contents entries to the site map file associated with the collection.
SetItem | This is overridden to set the inserted item's parent to this collection. (Overrides BindingList<(Of <(T>)>)..::.SetItem(Int32, T).)
Sort | This is used to sort the collection
ToString | Overloaded.

See Also

TocEntryCollection Class
SandcastleBuilder.Utils.ConceptualContent Namespace


AddTopicsFromFolder Method

[image]

Sandcastle Help File Builder Documentation
TocEntryCollection..::.AddTopicsFromFolder Method
TocEntryCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Add all topics from the specified folder recursively to the collection and to the given project file.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public void AddTopicsFromFolder(
    string folder,
    string basePath,
    SandcastleProject project
)
Visual Basic (Declaration)
Public Sub AddTopicsFromFolder ( _
    folder As String, _
    basePath As String, _
    project As SandcastleProject _
)

Parameters

folder
Type: System..::.String
The folder from which to get the files
basePath
Type: System..::.String
The base path to remove from files copied from another folder into the project folder. On the first call, this should match the folder value.
project
Type: SandcastleBuilder.Utils..::.SandcastleProject
The project to which the files are added

Remarks

Only actual HTML content topic files are added. They must have a ".htm?" extension. Folders will be added as sub-topics recursively. If a file with the same name as the folder exists, it will be associated with the container node. If no such file exists, an empty container node is created.

See Also

TocEntryCollection Class
SandcastleBuilder.Utils.ConceptualContent Namespace


Find Method

[image]

Sandcastle Help File Builder Documentation
TocEntryCollection..::.Find Method
TocEntryCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Find a TOC entry with the same source filename

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public TocEntry Find(
    string sourceFilename
)
Visual Basic (Declaration)
Public Function Find ( _
    sourceFilename As String _
) As TocEntry

Parameters

sourceFilename
Type: System..::.String
The source filename to match

Return Value

The match TOC entry or null if not found

See Also

TocEntryCollection Class
SandcastleBuilder.Utils.ConceptualContent Namespace


FindDefaultTopic Method

[image]

Sandcastle Help File Builder Documentation
TocEntryCollection..::.FindDefaultTopic Method
TocEntryCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to locate the default topic if one exists

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public TocEntry FindDefaultTopic()
Visual Basic (Declaration)
Public Function FindDefaultTopic As TocEntry

Return Value

The default topic if found or null if not found

Remarks

The first entry found is returned. Nodes are searched recursively.

See Also

TocEntryCollection Class
SandcastleBuilder.Utils.ConceptualContent Namespace


GenerateTableOfContents Method

[image]

Sandcastle Help File Builder Documentation
TocEntryCollection..::.GenerateTableOfContents Method
TocEntryCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to merge this TOC with another one

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public void GenerateTableOfContents(
    TocEntryCollection toc,
    IBasePathProvider pathProvider
)
Visual Basic (Declaration)
Public Sub GenerateTableOfContents ( _
    toc As TocEntryCollection, _
    pathProvider As IBasePathProvider _
)

Parameters

toc
Type: SandcastleBuilder.Utils.ConceptualContent..::.TocEntryCollection
The table of contents collection
pathProvider
Type: SandcastleBuilder.Utils..::.IBasePathProvider
The base path provider

Implements

ITableOfContents..::.GenerateTableOfContents(TocEntryCollection, IBasePathProvider)

See Also

TocEntryCollection Class
SandcastleBuilder.Utils.ConceptualContent Namespace


InsertItem Method

[image]

Sandcastle Help File Builder Documentation
TocEntryCollection..::.InsertItem Method
TocEntryCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is overridden to set the inserted item's parent to this collection.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected override void InsertItem(
    int index,
    TocEntry item
)
Visual Basic (Declaration)
Protected Overrides Sub InsertItem ( _
    index As Integer, _
    item As TocEntry _
)

Parameters

index
Type: System..::.Int32
The zero-based index where the item is to be inserted.
item
Type: SandcastleBuilder.Utils.ConceptualContent..::.TocEntry
The item to insert in the list.

See Also

TocEntryCollection Class
SandcastleBuilder.Utils.ConceptualContent Namespace


Load Method

[image]

Sandcastle Help File Builder Documentation
TocEntryCollection..::.Load Method
TocEntryCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to load the table of contents entries from the site map file associated with the collection.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public void Load()
Visual Basic (Declaration)
Public Sub Load

Exceptions

Exception | Condition
System..::.InvalidOperationException | This is thrown if a site map has not been associated with the collection.

See Also

TocEntryCollection Class
SandcastleBuilder.Utils.ConceptualContent Namespace


RemoveExcludedNodes Method

[image]

Sandcastle Help File Builder Documentation
TocEntryCollection..::.RemoveExcludedNodes Method
TocEntryCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This will remove excluded nodes from a TOC created off of the additional content items in a project. In addition, it merges the information from folder entries into the folder nodes.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public void RemoveExcludedNodes(
    TocEntry parent
)
Visual Basic (Declaration)
Public Sub RemoveExcludedNodes ( _
    parent As TocEntry _
)

Parameters

parent
Type: SandcastleBuilder.Utils.ConceptualContent..::.TocEntry
The parent node

See Also

TocEntryCollection Class
SandcastleBuilder.Utils.ConceptualContent Namespace


RemoveItem Method

[image]

Sandcastle Help File Builder Documentation
TocEntryCollection..::.RemoveItem Method
TocEntryCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is overridden to clear the parent on the removed item

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected override void RemoveItem(
    int index
)
Visual Basic (Declaration)
Protected Overrides Sub RemoveItem ( _
    index As Integer _
)

Parameters

index
Type: System..::.Int32
The index of the item to remove

See Also

TocEntryCollection Class
SandcastleBuilder.Utils.ConceptualContent Namespace


Save Method

[image]

Sandcastle Help File Builder Documentation
TocEntryCollection..::.Save Method
TocEntryCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to save the table of contents entries to the site map file associated with the collection.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public void Save()
Visual Basic (Declaration)
Public Sub Save

Exceptions

Exception | Condition
System..::.InvalidOperationException | This is thrown if a site map has not been associated with the collection.

See Also

TocEntryCollection Class
SandcastleBuilder.Utils.ConceptualContent Namespace


SetItem Method

[image]

Sandcastle Help File Builder Documentation
TocEntryCollection..::.SetItem Method
TocEntryCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is overridden to set the inserted item's parent to this collection.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected override void SetItem(
    int index,
    TocEntry item
)
Visual Basic (Declaration)
Protected Overrides Sub SetItem ( _
    index As Integer, _
    item As TocEntry _
)

Parameters

index
Type: System..::.Int32
The zero-based index of the item to replace.
item
Type: SandcastleBuilder.Utils.ConceptualContent..::.TocEntry
The new value for the item at the specified index. The value can be null for reference types.

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | index is less than zero. -or- index is greater than Count.

See Also

TocEntryCollection Class
SandcastleBuilder.Utils.ConceptualContent Namespace


Sort Method

[image]

Sandcastle Help File Builder Documentation
TocEntryCollection..::.Sort Method
TocEntryCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to sort the collection

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public void Sort()
Visual Basic (Declaration)
Public Sub Sort

Remarks

All top level items and their children are sorted

See Also

TocEntryCollection Class
SandcastleBuilder.Utils.ConceptualContent Namespace


ToString Method

[image] [image]

Sandcastle Help File Builder Documentation
TocEntryCollection..::.ToString Method
TocEntryCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ToString()()() | Convert the table of contents entry and its children to a string (Overrides Object..::.ToString()()().)
ToString(HelpFileFormat) | Convert the table of contents entry and its children to a string in the specified help file format.

See Also

TocEntryCollection Class
TocEntryCollection Members
SandcastleBuilder.Utils.ConceptualContent Namespace


ToString Method

[image]

Sandcastle Help File Builder Documentation
TocEntryCollection..::.ToString Method
TocEntryCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Convert the table of contents entry and its children to a string

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

Return Value

The entries in HTML 1.x help format

See Also

TocEntryCollection Class
ToString Overload
SandcastleBuilder.Utils.ConceptualContent Namespace


ToString Method (HelpFileFormat)

[image]

Sandcastle Help File Builder Documentation
TocEntryCollection..::.ToString Method (HelpFileFormat)
TocEntryCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Convert the table of contents entry and its children to a string in the specified help file format.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string ToString(
    HelpFileFormat format
)
Visual Basic (Declaration)
Public Function ToString ( _
    format As HelpFileFormat _
) As String

Parameters

format
Type: SandcastleBuilder.Utils..::.HelpFileFormat
The help file format to use

Return Value

The entries in specified help format

Exceptions

Exception | Condition
System..::.ArgumentException | This is thrown if the format is not HtmlHelp1x, HtmlHelp2x, or Website.

See Also

TocEntryCollection Class
ToString Overload
SandcastleBuilder.Utils.ConceptualContent Namespace


TocEntryCollection Properties

[image] [image]

Sandcastle Help File Builder Documentation
TocEntryCollection Properties
TocEntryCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TocEntryCollection type exposes the following members.

Properties

Name | Description
AllowEdit | Gets or sets a value indicating whether items in the list can be edited. (Inherited from BindingList <(Of <( TocEntry >)>).)
AllowNew | Gets or sets a value indicating whether you can add items to the list using the AddNew()()() method. (Inherited from BindingList <(Of <( TocEntry >)>).)
AllowRemove | Gets or sets a value indicating whether you can remove items from the collection. (Inherited from BindingList <(Of <( TocEntry >)>).)
ContentLayoutFile | This is used to get the site map file associated with the collection.
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( TocEntry >)>).)
DefaultTopic | This is used to get the default topic
FileItem | This read-only property returns the project file item associated with the collection.
IsSortedCore | Gets a value indicating whether the list is sorted. (Inherited from BindingList <(Of <( TocEntry >)>).)
Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <( TocEntry >)>).)
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( TocEntry >)>).)
RaiseListChangedEvents | Gets or sets a value indicating whether adding or removing items within the list raises ListChanged events. (Inherited from BindingList <(Of <( TocEntry >)>).)
SortDirectionCore | Gets the direction the list is sorted. (Inherited from BindingList <(Of <( TocEntry >)>).)
SortPropertyCore | Gets the property descriptor that is used for sorting the list if sorting is implemented in a derived class; otherwise, returns null. (Inherited from BindingList <(Of <( TocEntry >)>).)
SplitTocAtTopic | This is used to get the topic at which the table of contents is split by the API content.
SupportsChangeNotificationCore | Gets a value indicating whether ListChanged events are enabled. (Inherited from BindingList <(Of <( TocEntry >)>).)
SupportsSearchingCore | Gets a value indicating whether the list supports searching. (Inherited from BindingList <(Of <( TocEntry >)>).)
SupportsSortingCore | Gets a value indicating whether the list supports sorting. (Inherited from BindingList <(Of <( TocEntry >)>).)

See Also

TocEntryCollection Class
SandcastleBuilder.Utils.ConceptualContent Namespace


ContentLayoutFile Property

[image]

Sandcastle Help File Builder Documentation
TocEntryCollection..::.ContentLayoutFile Property
TocEntryCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get the site map file associated with the collection.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public FileItem ContentLayoutFile { get; }
Visual Basic (Declaration)
Public ReadOnly Property ContentLayoutFile As FileItem

Implements

ITableOfContents..::.ContentLayoutFile

See Also

TocEntryCollection Class
SandcastleBuilder.Utils.ConceptualContent Namespace


DefaultTopic Property

[image]

Sandcastle Help File Builder Documentation
TocEntryCollection..::.DefaultTopic Property
TocEntryCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get the default topic

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public TocEntry DefaultTopic { get; }
Visual Basic (Declaration)
Public ReadOnly Property DefaultTopic As TocEntry

Field Value

It returns the default topic or null if one is not set

See Also

TocEntryCollection Class
SandcastleBuilder.Utils.ConceptualContent Namespace


FileItem Property

[image]

Sandcastle Help File Builder Documentation
TocEntryCollection..::.FileItem Property
TocEntryCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns the project file item associated with the collection.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public FileItem FileItem { get; }
Visual Basic (Declaration)
Public ReadOnly Property FileItem As FileItem

See Also

TocEntryCollection Class
SandcastleBuilder.Utils.ConceptualContent Namespace


SplitTocAtTopic Property

[image]

Sandcastle Help File Builder Documentation
TocEntryCollection..::.SplitTocAtTopic Property
TocEntryCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get the topic at which the table of contents is split by the API content.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public TocEntry SplitTocAtTopic { get; }
Visual Basic (Declaration)
Public ReadOnly Property SplitTocAtTopic As TocEntry

Field Value

This will only be valid if it refers to a root level topic. It will return null if a split location has not been set at the root level.

See Also

TocEntryCollection Class
SandcastleBuilder.Utils.ConceptualContent Namespace


TocEntryCollection Events

[image] [image]

Sandcastle Help File Builder Documentation
TocEntryCollection Events
TocEntryCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TocEntryCollection type exposes the following members.

Events

Name | Description
AddingNew | Occurs before an item is added to the list. (Inherited from BindingList <(Of <( TocEntry >)>).)
ListChanged | Occurs when the list or an item in the list changes. (Inherited from BindingList <(Of <( TocEntry >)>).)

See Also

TocEntryCollection Class
SandcastleBuilder.Utils.ConceptualContent Namespace


Token Class

[image]

Sandcastle Help File Builder Documentation
Token Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This represents a conceptual content token that can be used to insert a common item, value, or construct into topics.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
[SerializableAttribute]
public class Token
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class Token

Remarks

This class is serializable so that it can be copied to the clipboard.

Inheritance Hierarchy

System..::.Object
SandcastleBuilder.Utils.ConceptualContent..::.Token

See Also

Token Members
SandcastleBuilder.Utils.ConceptualContent Namespace


Token Members

[image] [image]

Sandcastle Help File Builder Documentation
Token Members
Token Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Token type exposes the following members.

Constructors

Name | Description
Token | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToToken | Convert the token to its <token> element form

Properties

Name | Description
TokenName | This is used to get or set the token name
TokenValue | This is used to get or set the token value

See Also

Token Class
SandcastleBuilder.Utils.ConceptualContent Namespace


Token Constructor

[image] [image]

Sandcastle Help File Builder Documentation
Token Constructor
Token Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Token()()() | Constructor
Token(String, String) | Constructor

See Also

Token Class
Token Members
SandcastleBuilder.Utils.ConceptualContent Namespace


Token Constructor

[image]

Sandcastle Help File Builder Documentation
Token Constructor
Token Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public Token()
Visual Basic (Declaration)
Public Sub New

Remarks

The token name defaults to "NoName"

See Also

Token Class
Token Overload
SandcastleBuilder.Utils.ConceptualContent Namespace


Token Constructor (String, String)

[image]

Sandcastle Help File Builder Documentation
Token Constructor (String, String)
Token Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public Token(
    string name,
    string value
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    value As String _
)

Parameters

name
Type: System..::.String
The token name
value
Type: System..::.String
The token value

See Also

Token Class
Token Overload
SandcastleBuilder.Utils.ConceptualContent Namespace


Token Methods

[image] [image]

Sandcastle Help File Builder Documentation
Token Methods
Token Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Token type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToToken | Convert the token to its <token> element form

See Also

Token Class
SandcastleBuilder.Utils.ConceptualContent Namespace


ToToken Method

[image]

Sandcastle Help File Builder Documentation
Token..::.ToToken Method
Token Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Convert the token to its <token> element form

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string ToToken()
Visual Basic (Declaration)
Public Function ToToken As String

Return Value

The token in its <token> element form

See Also

Token Class
SandcastleBuilder.Utils.ConceptualContent Namespace


Token Properties

[image] [image]

Sandcastle Help File Builder Documentation
Token Properties
Token Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Token type exposes the following members.

Properties

Name | Description
TokenName | This is used to get or set the token name
TokenValue | This is used to get or set the token value

See Also

Token Class
SandcastleBuilder.Utils.ConceptualContent Namespace


TokenName Property

[image]

Sandcastle Help File Builder Documentation
Token..::.TokenName Property
Token Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set the token name

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string TokenName { get; set; }
Visual Basic (Declaration)
Public Property TokenName As String

See Also

Token Class
SandcastleBuilder.Utils.ConceptualContent Namespace


TokenValue Property

[image]

Sandcastle Help File Builder Documentation
Token..::.TokenValue Property
Token Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set the token value

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string TokenValue { get; set; }
Visual Basic (Declaration)
Public Property TokenValue As String

Field Value

The value can contain help file builder replacement tags. These will be replaced at build time with the appropriate project value.

See Also

Token Class
SandcastleBuilder.Utils.ConceptualContent Namespace


TokenCollection Class

[image]

Sandcastle Help File Builder Documentation
TokenCollection Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This collection class is used to hold the conceptual content tokens for an associated token file.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public class TokenCollection : BindingList<Token>
Visual Basic (Declaration)
Public Class TokenCollection _
    Inherits BindingList(Of Token)

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection <(Of <( Token >)>)
System.ComponentModel..::.BindingList <(Of <( Token >)>)
SandcastleBuilder.Utils.ConceptualContent..::.TokenCollection

See Also

TokenCollection Members
SandcastleBuilder.Utils.ConceptualContent Namespace


TokenCollection Members

[image] [image]

Sandcastle Help File Builder Documentation
TokenCollection Members
TokenCollection Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TokenCollection type exposes the following members.

Constructors

Name | Description
TokenCollection | Constructor

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Token >)>).)
AddNew | Adds a new item to the collection. (Inherited from BindingList <(Of <( Token >)>).)
AddNewCore | Adds a new item to the end of the collection. (Inherited from BindingList <(Of <( Token >)>).)
ApplySortCore | Sorts the items if overridden in a derived class; otherwise, throws a NotSupportedException. (Inherited from BindingList <(Of <( Token >)>).)
CancelNew | Discards a pending new item. (Inherited from BindingList <(Of <( Token >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Token >)>).)
ClearItems | Removes all elements from the collection. (Inherited from BindingList <(Of <( Token >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Token >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <( Token >)>).)
EndNew | Commits a pending new item to the collection. (Inherited from BindingList <(Of <( Token >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindCore | Searches for the index of the item that has the specified property descriptor with the specified value, if searching is implemented in a derived class; otherwise, a NotSupportedException. (Inherited from BindingList <(Of <( Token >)>).)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Token >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Token >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( Token >)>).)
InsertItem | Inserts the specified item in the list at the specified index. (Inherited from BindingList <(Of <( Token >)>).)
Load | Load the collection from the related file
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnAddingNew | Raises the AddingNew event. (Inherited from BindingList <(Of <( Token >)>).)
OnListChanged | Raises the ListChanged event. (Inherited from BindingList <(Of <( Token >)>).)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Token >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Token >)>).)
RemoveItem | Removes the item at the specified index. (Inherited from BindingList <(Of <( Token >)>).)
RemoveSortCore | Removes any sort applied with ApplySortCore(PropertyDescriptor, ListSortDirection) if sorting is implemented in a derived class; otherwise, raises NotSupportedException. (Inherited from BindingList <(Of <( Token >)>).)
ResetBindings | Raises a ListChanged event of type Reset. (Inherited from BindingList <(Of <( Token >)>).)
ResetItem | Raises a ListChanged event of type ItemChanged for the item at the specified position. (Inherited from BindingList <(Of <( Token >)>).)
Save | Save the token collection to its related file ready for use by BuildAssembler.
SetItem | Replaces the item at the specified index with the specified item. (Inherited from BindingList <(Of <( Token >)>).)
Sort | This is used to sort the collection
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AllowEdit | Gets or sets a value indicating whether items in the list can be edited. (Inherited from BindingList <(Of <( Token >)>).)
AllowNew | Gets or sets a value indicating whether you can add items to the list using the AddNew()()() method. (Inherited from BindingList <(Of <( Token >)>).)
AllowRemove | Gets or sets a value indicating whether you can remove items from the collection. (Inherited from BindingList <(Of <( Token >)>).)
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Token >)>).)
FileItem | This read-only property returns the project file item associated with the collection.
IsSortedCore | Gets a value indicating whether the list is sorted. (Inherited from BindingList <(Of <( Token >)>).)
Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <( Token >)>).)
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Token >)>).)
RaiseListChangedEvents | Gets or sets a value indicating whether adding or removing items within the list raises ListChanged events. (Inherited from BindingList <(Of <( Token >)>).)
SortDirectionCore | Gets the direction the list is sorted. (Inherited from BindingList <(Of <( Token >)>).)
SortPropertyCore | Gets the property descriptor that is used for sorting the list if sorting is implemented in a derived class; otherwise, returns null. (Inherited from BindingList <(Of <( Token >)>).)
SupportsChangeNotificationCore | Gets a value indicating whether ListChanged events are enabled. (Inherited from BindingList <(Of <( Token >)>).)
SupportsSearchingCore | Gets a value indicating whether the list supports searching. (Inherited from BindingList <(Of <( Token >)>).)
SupportsSortingCore | Gets a value indicating whether the list supports sorting. (Inherited from BindingList <(Of <( Token >)>).)

Events

Name | Description
AddingNew | Occurs before an item is added to the list. (Inherited from BindingList <(Of <( Token >)>).)
ListChanged | Occurs when the list or an item in the list changes. (Inherited from BindingList <(Of <( Token >)>).)

See Also

TokenCollection Class
SandcastleBuilder.Utils.ConceptualContent Namespace


TokenCollection Constructor

[image]

Sandcastle Help File Builder Documentation
TokenCollection Constructor
TokenCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public TokenCollection(
    FileItem file
)
Visual Basic (Declaration)
Public Sub New ( _
    file As FileItem _
)

Parameters

file
Type: SandcastleBuilder.Utils..::.FileItem
The token file associated with the collection.

Remarks

Tokens are not loaded until the Load()()() method is called.

See Also

TokenCollection Class
SandcastleBuilder.Utils.ConceptualContent Namespace


TokenCollection Methods

[image] [image]

Sandcastle Help File Builder Documentation
TokenCollection Methods
TokenCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TokenCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Token >)>).)
AddNew | Adds a new item to the collection. (Inherited from BindingList <(Of <( Token >)>).)
AddNewCore | Adds a new item to the end of the collection. (Inherited from BindingList <(Of <( Token >)>).)
ApplySortCore | Sorts the items if overridden in a derived class; otherwise, throws a NotSupportedException. (Inherited from BindingList <(Of <( Token >)>).)
CancelNew | Discards a pending new item. (Inherited from BindingList <(Of <( Token >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Token >)>).)
ClearItems | Removes all elements from the collection. (Inherited from BindingList <(Of <( Token >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Token >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <( Token >)>).)
EndNew | Commits a pending new item to the collection. (Inherited from BindingList <(Of <( Token >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindCore | Searches for the index of the item that has the specified property descriptor with the specified value, if searching is implemented in a derived class; otherwise, a NotSupportedException. (Inherited from BindingList <(Of <( Token >)>).)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Token >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Token >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( Token >)>).)
InsertItem | Inserts the specified item in the list at the specified index. (Inherited from BindingList <(Of <( Token >)>).)
Load | Load the collection from the related file
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnAddingNew | Raises the AddingNew event. (Inherited from BindingList <(Of <( Token >)>).)
OnListChanged | Raises the ListChanged event. (Inherited from BindingList <(Of <( Token >)>).)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Token >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Token >)>).)
RemoveItem | Removes the item at the specified index. (Inherited from BindingList <(Of <( Token >)>).)
RemoveSortCore | Removes any sort applied with ApplySortCore(PropertyDescriptor, ListSortDirection) if sorting is implemented in a derived class; otherwise, raises NotSupportedException. (Inherited from BindingList <(Of <( Token >)>).)
ResetBindings | Raises a ListChanged event of type Reset. (Inherited from BindingList <(Of <( Token >)>).)
ResetItem | Raises a ListChanged event of type ItemChanged for the item at the specified position. (Inherited from BindingList <(Of <( Token >)>).)
Save | Save the token collection to its related file ready for use by BuildAssembler.
SetItem | Replaces the item at the specified index with the specified item. (Inherited from BindingList <(Of <( Token >)>).)
Sort | This is used to sort the collection
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TokenCollection Class
SandcastleBuilder.Utils.ConceptualContent Namespace


Load Method

[image]

Sandcastle Help File Builder Documentation
TokenCollection..::.Load Method
TokenCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Load the collection from the related file

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public void Load()
Visual Basic (Declaration)
Public Sub Load

Remarks

This will be done automatically at constructor. This can be called to reload the collection if needed.

See Also

TokenCollection Class
SandcastleBuilder.Utils.ConceptualContent Namespace


Save Method

[image]

Sandcastle Help File Builder Documentation
TokenCollection..::.Save Method
TokenCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Save the token collection to its related file ready for use by BuildAssembler.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public void Save()
Visual Basic (Declaration)
Public Sub Save

See Also

TokenCollection Class
SandcastleBuilder.Utils.ConceptualContent Namespace


Sort Method

[image]

Sandcastle Help File Builder Documentation
TokenCollection..::.Sort Method
TokenCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to sort the collection

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public void Sort()
Visual Basic (Declaration)
Public Sub Sort

Remarks

Values are sorted by token name and value. Comparisons are case-sensitive.

See Also

TokenCollection Class
SandcastleBuilder.Utils.ConceptualContent Namespace


TokenCollection Properties

[image] [image]

Sandcastle Help File Builder Documentation
TokenCollection Properties
TokenCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TokenCollection type exposes the following members.

Properties

Name | Description
AllowEdit | Gets or sets a value indicating whether items in the list can be edited. (Inherited from BindingList <(Of <( Token >)>).)
AllowNew | Gets or sets a value indicating whether you can add items to the list using the AddNew()()() method. (Inherited from BindingList <(Of <( Token >)>).)
AllowRemove | Gets or sets a value indicating whether you can remove items from the collection. (Inherited from BindingList <(Of <( Token >)>).)
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Token >)>).)
FileItem | This read-only property returns the project file item associated with the collection.
IsSortedCore | Gets a value indicating whether the list is sorted. (Inherited from BindingList <(Of <( Token >)>).)
Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <( Token >)>).)
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Token >)>).)
RaiseListChangedEvents | Gets or sets a value indicating whether adding or removing items within the list raises ListChanged events. (Inherited from BindingList <(Of <( Token >)>).)
SortDirectionCore | Gets the direction the list is sorted. (Inherited from BindingList <(Of <( Token >)>).)
SortPropertyCore | Gets the property descriptor that is used for sorting the list if sorting is implemented in a derived class; otherwise, returns null. (Inherited from BindingList <(Of <( Token >)>).)
SupportsChangeNotificationCore | Gets a value indicating whether ListChanged events are enabled. (Inherited from BindingList <(Of <( Token >)>).)
SupportsSearchingCore | Gets a value indicating whether the list supports searching. (Inherited from BindingList <(Of <( Token >)>).)
SupportsSortingCore | Gets a value indicating whether the list supports sorting. (Inherited from BindingList <(Of <( Token >)>).)

See Also

TokenCollection Class
SandcastleBuilder.Utils.ConceptualContent Namespace


FileItem Property

[image]

Sandcastle Help File Builder Documentation
TokenCollection..::.FileItem Property
TokenCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns the project file item associated with the collection.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public FileItem FileItem { get; }
Visual Basic (Declaration)
Public ReadOnly Property FileItem As FileItem

See Also

TokenCollection Class
SandcastleBuilder.Utils.ConceptualContent Namespace


TokenCollection Events

[image] [image]

Sandcastle Help File Builder Documentation
TokenCollection Events
TokenCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TokenCollection type exposes the following members.

Events

Name | Description
AddingNew | Occurs before an item is added to the list. (Inherited from BindingList <(Of <( Token >)>).)
ListChanged | Occurs when the list or an item in the list changes. (Inherited from BindingList <(Of <( Token >)>).)

See Also

TokenCollection Class
SandcastleBuilder.Utils.ConceptualContent Namespace


Topic Class

[image]

Sandcastle Help File Builder Documentation
Topic Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This represents a conceptual content topic.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public class Topic
Visual Basic (Declaration)
Public Class Topic

Remarks

This class is serializable so that it can be copied to the clipboard.

Inheritance Hierarchy

System..::.Object
SandcastleBuilder.Utils.ConceptualContent..::.Topic

See Also

Topic Members
SandcastleBuilder.Utils.ConceptualContent Namespace


Topic Members

[image] [image]

Sandcastle Help File Builder Documentation
Topic Members
Topic Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Topic type exposes the following members.

Constructors

Name | Description
Topic | Constructor

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToAnchor | Convert the topic to its <a> element form
ToLink | Convert the topic to its <link> element form
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ContentId | This is used to get the content ID from the content layout file.
DisplayTitle | This read-only property is used to get a title for display (i.e. in the designer).
DocumentType | This read-only property is used to get the document type
HelpAttributes | This is used to get the additional attributes that will be added to MAML topic.
Id | This is used to get the unique ID of the topic
IsDefaultTopic | This is used to when merging TOC files to determine the default topic.
Keywords | This is used to get the index keywords that will be added to the MAML topic.
LinkText | This is used to get or set the topic's optional link text.
NoTopicFile | This read-only property returns true if there is no associated topic file by choice rather than it not being found.
Parent | This is used to track the topic's parent collection
RevisionNumber | This is used to get the topic's revision number
Subtopics | This is used to get the sub-topics beneath this topic.
Title | This is used to get the required title that should be used for the topic.
TocTitle | This is used to get or set the topic's optional table of contents title.
TopicFile | This is used to get or set the topic file information related to the topic.
TopicFilename | This is used to get the filename of the related project file (if any)
Visible | This is used to get or set whether or not the topic is visible in the table of contents.

See Also

Topic Class
SandcastleBuilder.Utils.ConceptualContent Namespace


Topic Constructor

[image]

Sandcastle Help File Builder Documentation
Topic Constructor
Topic Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public Topic()
Visual Basic (Declaration)
Public Sub New

See Also

Topic Class
SandcastleBuilder.Utils.ConceptualContent Namespace


Topic Methods

[image] [image]

Sandcastle Help File Builder Documentation
Topic Methods
Topic Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Topic type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToAnchor | Convert the topic to its <a> element form
ToLink | Convert the topic to its <link> element form
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Topic Class
SandcastleBuilder.Utils.ConceptualContent Namespace


ToAnchor Method

[image]

Sandcastle Help File Builder Documentation
Topic..::.ToAnchor Method
Topic Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Convert the topic to its <a> element form

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string ToAnchor(
    string innerText
)
Visual Basic (Declaration)
Public Function ToAnchor ( _
    innerText As String _
) As String

Parameters

innerText
Type: System..::.String
Optional inner text

Return Value

The topic in its <a> element form

See Also

Topic Class
SandcastleBuilder.Utils.ConceptualContent Namespace


ToLink Method

[image]

Sandcastle Help File Builder Documentation
Topic..::.ToLink Method
Topic Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Convert the topic to its <link> element form

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string ToLink(
    string innerText
)
Visual Basic (Declaration)
Public Function ToLink ( _
    innerText As String _
) As String

Parameters

innerText
Type: System..::.String
Optional inner text

Return Value

The topic in its <link> element form

See Also

Topic Class
SandcastleBuilder.Utils.ConceptualContent Namespace


Topic Properties

[image] [image]

Sandcastle Help File Builder Documentation
Topic Properties
Topic Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Topic type exposes the following members.

Properties

Name | Description
ContentId | This is used to get the content ID from the content layout file.
DisplayTitle | This read-only property is used to get a title for display (i.e. in the designer).
DocumentType | This read-only property is used to get the document type
HelpAttributes | This is used to get the additional attributes that will be added to MAML topic.
Id | This is used to get the unique ID of the topic
IsDefaultTopic | This is used to when merging TOC files to determine the default topic.
Keywords | This is used to get the index keywords that will be added to the MAML topic.
LinkText | This is used to get or set the topic's optional link text.
NoTopicFile | This read-only property returns true if there is no associated topic file by choice rather than it not being found.
Parent | This is used to track the topic's parent collection
RevisionNumber | This is used to get the topic's revision number
Subtopics | This is used to get the sub-topics beneath this topic.
Title | This is used to get the required title that should be used for the topic.
TocTitle | This is used to get or set the topic's optional table of contents title.
TopicFile | This is used to get or set the topic file information related to the topic.
TopicFilename | This is used to get the filename of the related project file (if any)
Visible | This is used to get or set whether or not the topic is visible in the table of contents.

See Also

Topic Class
SandcastleBuilder.Utils.ConceptualContent Namespace


ContentId Property

[image]

Sandcastle Help File Builder Documentation
Topic..::.ContentId Property
Topic Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get the content ID from the content layout file.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string ContentId { get; }
Visual Basic (Declaration)
Public ReadOnly Property ContentId As String

Remarks

This should match an ID from a project file. If not, it will serve as an container node with no associated topic.

See Also

Topic Class
SandcastleBuilder.Utils.ConceptualContent Namespace


DisplayTitle Property

[image]

Sandcastle Help File Builder Documentation
Topic..::.DisplayTitle Property
Topic Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property is used to get a title for display (i.e. in the designer).

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string DisplayTitle { get; }
Visual Basic (Declaration)
Public ReadOnly Property DisplayTitle As String

Field Value

If there is a TocTitle specified, it is used. If not, the Title value is used. If it does not contain a value, the filename without the path and extension is used. If the file has not been specified, does not exist, the document type is not recognized, or it is invalid (i.e. badly formed), it returns an appropriate message describing the problem.

See Also

Topic Class
SandcastleBuilder.Utils.ConceptualContent Namespace


DocumentType Property

[image]

Sandcastle Help File Builder Documentation
Topic..::.DocumentType Property
Topic Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property is used to get the document type

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public DocumentType DocumentType { get; }
Visual Basic (Declaration)
Public ReadOnly Property DocumentType As DocumentType

See Also

Topic Class
SandcastleBuilder.Utils.ConceptualContent Namespace


HelpAttributes Property

[image]

Sandcastle Help File Builder Documentation
Topic..::.HelpAttributes Property
Topic Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get the additional attributes that will be added to MAML topic.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public MSHelpAttrCollection HelpAttributes { get; }
Visual Basic (Declaration)
Public ReadOnly Property HelpAttributes As MSHelpAttrCollection

See Also

Topic Class
SandcastleBuilder.Utils.ConceptualContent Namespace


Id Property

[image]

Sandcastle Help File Builder Documentation
Topic..::.Id Property
Topic Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get the unique ID of the topic

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string Id { get; }
Visual Basic (Declaration)
Public ReadOnly Property Id As String

See Also

Topic Class
SandcastleBuilder.Utils.ConceptualContent Namespace


IsDefaultTopic Property

[image]

Sandcastle Help File Builder Documentation
Topic..::.IsDefaultTopic Property
Topic Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to when merging TOC files to determine the default topic.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool IsDefaultTopic { get; set; }
Visual Basic (Declaration)
Public Property IsDefaultTopic As Boolean

See Also

Topic Class
SandcastleBuilder.Utils.ConceptualContent Namespace


Keywords Property

[image]

Sandcastle Help File Builder Documentation
Topic..::.Keywords Property
Topic Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get the index keywords that will be added to the MAML topic.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public MSHelpKeywordCollection Keywords { get; }
Visual Basic (Declaration)
Public ReadOnly Property Keywords As MSHelpKeywordCollection

See Also

Topic Class
SandcastleBuilder.Utils.ConceptualContent Namespace


LinkText Property

[image]

Sandcastle Help File Builder Documentation
Topic..::.LinkText Property
Topic Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set the topic's optional link text.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string LinkText { get; set; }
Visual Basic (Declaration)
Public Property LinkText As String

Field Value

This can be used to provide different text that is used in links that refer to the topic. If not set, it will be set to the Title value.

See Also

Topic Class
SandcastleBuilder.Utils.ConceptualContent Namespace


NoTopicFile Property

[image]

Sandcastle Help File Builder Documentation
Topic..::.NoTopicFile Property
Topic Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns true if there is no associated topic file by choice rather than it not being found.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool NoTopicFile { get; }
Visual Basic (Declaration)
Public ReadOnly Property NoTopicFile As Boolean

See Also

Topic Class
SandcastleBuilder.Utils.ConceptualContent Namespace


Parent Property

[image]

Sandcastle Help File Builder Documentation
Topic..::.Parent Property
Topic Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to track the topic's parent collection

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public TopicCollection Parent { get; internal set; }
Visual Basic (Declaration)
Public Property Parent As TopicCollection

Remarks

This is used by the designer to move items around within the collection.

See Also

Topic Class
SandcastleBuilder.Utils.ConceptualContent Namespace


RevisionNumber Property

[image]

Sandcastle Help File Builder Documentation
Topic..::.RevisionNumber Property
Topic Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get the topic's revision number

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public int RevisionNumber { get; }
Visual Basic (Declaration)
Public ReadOnly Property RevisionNumber As Integer

See Also

Topic Class
SandcastleBuilder.Utils.ConceptualContent Namespace


Subtopics Property

[image]

Sandcastle Help File Builder Documentation
Topic..::.Subtopics Property
Topic Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get the sub-topics beneath this topic.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public TopicCollection Subtopics { get; }
Visual Basic (Declaration)
Public ReadOnly Property Subtopics As TopicCollection

See Also

Topic Class
SandcastleBuilder.Utils.ConceptualContent Namespace


Title Property

[image]

Sandcastle Help File Builder Documentation
Topic..::.Title Property
Topic Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get the required title that should be used for the topic.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string Title { get; set; }
Visual Basic (Declaration)
Public Property Title As String

Field Value

If not set, the topic filename without a path or extension is used.

See Also

Topic Class
SandcastleBuilder.Utils.ConceptualContent Namespace


TocTitle Property

[image]

Sandcastle Help File Builder Documentation
Topic..::.TocTitle Property
Topic Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set the topic's optional table of contents title.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string TocTitle { get; set; }
Visual Basic (Declaration)
Public Property TocTitle As String

Field Value

This can be used to provide a different topic title in the table of contents. If not set, it will be set to the Title value.

See Also

Topic Class
SandcastleBuilder.Utils.ConceptualContent Namespace


TopicFile Property

[image]

Sandcastle Help File Builder Documentation
Topic..::.TopicFile Property
Topic Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set the topic file information related to the topic.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public TopicFile TopicFile { get; set; }
Visual Basic (Declaration)
Public Property TopicFile As TopicFile

Field Value

If there is no topic file, this topic serves as a container node for its sub-topics and no content will be displayed for it when selected in the help file's table of contents.

See Also

Topic Class
SandcastleBuilder.Utils.ConceptualContent Namespace


TopicFilename Property

[image]

Sandcastle Help File Builder Documentation
Topic..::.TopicFilename Property
Topic Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get the filename of the related project file (if any)

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string TopicFilename { get; }
Visual Basic (Declaration)
Public ReadOnly Property TopicFilename As String

See Also

Topic Class
SandcastleBuilder.Utils.ConceptualContent Namespace


Visible Property

[image]

Sandcastle Help File Builder Documentation
Topic..::.Visible Property
Topic Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set whether or not the topic is visible in the table of contents.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool Visible { get; set; }
Visual Basic (Declaration)
Public Property Visible As Boolean

Field Value

If set to false, the item will still be added to the help file but to be accessible, a link to it must appear in one of the other topics.

See Also

Topic Class
SandcastleBuilder.Utils.ConceptualContent Namespace


TopicCollection Class

[image]

Sandcastle Help File Builder Documentation
TopicCollection Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This collection class is used to hold the conceptual content topics for a project.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public class TopicCollection : BindingList<Topic>,
    ITableOfContents
Visual Basic (Declaration)
Public Class TopicCollection _
    Inherits BindingList(Of Topic) _
    Implements ITableOfContents

Remarks

This class is serializable so that it can be copied to the clipboard.

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection <(Of <( Topic >)>)
System.ComponentModel..::.BindingList <(Of <( Topic >)>)
SandcastleBuilder.Utils.ConceptualContent..::.TopicCollection

See Also

TopicCollection Members
SandcastleBuilder.Utils.ConceptualContent Namespace


TopicCollection Members

[image] [image]

Sandcastle Help File Builder Documentation
TopicCollection Members
TopicCollection Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TopicCollection type exposes the following members.

Constructors

Name | Description
TopicCollection | Constructor

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Topic >)>).)
AddNew | Adds a new item to the collection. (Inherited from BindingList <(Of <( Topic >)>).)
AddNewCore | Adds a new item to the end of the collection. (Inherited from BindingList <(Of <( Topic >)>).)
AddTopicsFromFolder | Add all topics from the specified folder recursively to the collection and to the given project file.
ApplySortCore | Sorts the items if overridden in a derived class; otherwise, throws a NotSupportedException. (Inherited from BindingList <(Of <( Topic >)>).)
CancelNew | Discards a pending new item. (Inherited from BindingList <(Of <( Topic >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Topic >)>).)
ClearItems | This is overridden to clear the default topic and split TOC topic when the collection is cleared. (Overrides BindingList<(Of <(T>)>)..::.ClearItems()()().)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Topic >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <( Topic >)>).)
EndNew | Commits a pending new item to the collection. (Inherited from BindingList <(Of <( Topic >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindCore | Searches for the index of the item that has the specified property descriptor with the specified value, if searching is implemented in a derived class; otherwise, a NotSupportedException. (Inherited from BindingList <(Of <( Topic >)>).)
GenerateConceptualTopics | This creates copies of the conceptual topic files in the build process's working folder.
GenerateTableOfContents | Generate the table of contents for the conceptual topics
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Topic >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Topic >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( Topic >)>).)
InsertItem | This is overridden to set the inserted item's parent to this collection. (Overrides BindingList<(Of <(T>)>)..::.InsertItem(Int32, T).)
Load | Load the collection from the related file
MatchProjectFilesToTopics | This gets all possible content files from the project and attempts to match them to the topics in the collection by ID.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnAddingNew | Raises the AddingNew event. (Inherited from BindingList <(Of <( Topic >)>).)
OnListChanged | Raises the ListChanged event. (Inherited from BindingList <(Of <( Topic >)>).)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Topic >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Topic >)>).)
RemoveItem | This is overridden to clear the parent on the removed item (Overrides BindingList<(Of <(T>)>)..::.RemoveItem(Int32).)
RemoveSortCore | Removes any sort applied with ApplySortCore(PropertyDescriptor, ListSortDirection) if sorting is implemented in a derived class; otherwise, raises NotSupportedException. (Inherited from BindingList <(Of <( Topic >)>).)
ResetBindings | Raises a ListChanged event of type Reset. (Inherited from BindingList <(Of <( Topic >)>).)
ResetItem | Raises a ListChanged event of type ItemChanged for the item at the specified position. (Inherited from BindingList <(Of <( Topic >)>).)
Save | Save the topic collection to the related content layout file
SetItem | This is overridden to set the inserted item's parent to this collection. (Overrides BindingList<(Of <(T>)>)..::.SetItem(Int32, T).)
Sort | This is used to sort the collection
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AllowEdit | Gets or sets a value indicating whether items in the list can be edited. (Inherited from BindingList <(Of <( Topic >)>).)
AllowNew | Gets or sets a value indicating whether you can add items to the list using the AddNew()()() method. (Inherited from BindingList <(Of <( Topic >)>).)
AllowRemove | Gets or sets a value indicating whether you can remove items from the collection. (Inherited from BindingList <(Of <( Topic >)>).)
ContentLayoutFile | This is used to get the build item related to the content layout file containing the collection items.
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Topic >)>).)
DefaultTopic | This is used to get or set the default topic
FileItem | This read-only property returns the project file item associated with the collection.
IsSortedCore | Gets a value indicating whether the list is sorted. (Inherited from BindingList <(Of <( Topic >)>).)
Item | Overloaded.
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Topic >)>).)
RaiseListChangedEvents | Gets or sets a value indicating whether adding or removing items within the list raises ListChanged events. (Inherited from BindingList <(Of <( Topic >)>).)
SortDirectionCore | Gets the direction the list is sorted. (Inherited from BindingList <(Of <( Topic >)>).)
SortPropertyCore | Gets the property descriptor that is used for sorting the list if sorting is implemented in a derived class; otherwise, returns null. (Inherited from BindingList <(Of <( Topic >)>).)
SplitTocAtTopic | This is used to get or set the topic at which the table of contents is split by the API content.
SupportsChangeNotificationCore | Gets a value indicating whether ListChanged events are enabled. (Inherited from BindingList <(Of <( Topic >)>).)
SupportsSearchingCore | Gets a value indicating whether the list supports searching. (Inherited from BindingList <(Of <( Topic >)>).)
SupportsSortingCore | Gets a value indicating whether the list supports sorting. (Inherited from BindingList <(Of <( Topic >)>).)

Events

Name | Description
AddingNew | Occurs before an item is added to the list. (Inherited from BindingList <(Of <( Topic >)>).)
ListChanged | Occurs when the list or an item in the list changes. (Inherited from BindingList <(Of <( Topic >)>).)

See Also

TopicCollection Class
SandcastleBuilder.Utils.ConceptualContent Namespace


TopicCollection Constructor

[image]

Sandcastle Help File Builder Documentation
TopicCollection Constructor
TopicCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public TopicCollection(
    FileItem file
)
Visual Basic (Declaration)
Public Sub New ( _
    file As FileItem _
)

Parameters

file
Type: SandcastleBuilder.Utils..::.FileItem
The content layout file associated with the collection.

Remarks

Topics are not loaded until the Load()()() method is called. If the file parameter is null, this is assumed to be a child topic collection.

See Also

TopicCollection Class
SandcastleBuilder.Utils.ConceptualContent Namespace


TopicCollection Methods

[image] [image]

Sandcastle Help File Builder Documentation
TopicCollection Methods
TopicCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TopicCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Topic >)>).)
AddNew | Adds a new item to the collection. (Inherited from BindingList <(Of <( Topic >)>).)
AddNewCore | Adds a new item to the end of the collection. (Inherited from BindingList <(Of <( Topic >)>).)
AddTopicsFromFolder | Add all topics from the specified folder recursively to the collection and to the given project file.
ApplySortCore | Sorts the items if overridden in a derived class; otherwise, throws a NotSupportedException. (Inherited from BindingList <(Of <( Topic >)>).)
CancelNew | Discards a pending new item. (Inherited from BindingList <(Of <( Topic >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Topic >)>).)
ClearItems | This is overridden to clear the default topic and split TOC topic when the collection is cleared. (Overrides BindingList<(Of <(T>)>)..::.ClearItems()()().)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Topic >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <( Topic >)>).)
EndNew | Commits a pending new item to the collection. (Inherited from BindingList <(Of <( Topic >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindCore | Searches for the index of the item that has the specified property descriptor with the specified value, if searching is implemented in a derived class; otherwise, a NotSupportedException. (Inherited from BindingList <(Of <( Topic >)>).)
GenerateConceptualTopics | This creates copies of the conceptual topic files in the build process's working folder.
GenerateTableOfContents | Generate the table of contents for the conceptual topics
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Topic >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Topic >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( Topic >)>).)
InsertItem | This is overridden to set the inserted item's parent to this collection. (Overrides BindingList<(Of <(T>)>)..::.InsertItem(Int32, T).)
Load | Load the collection from the related file
MatchProjectFilesToTopics | This gets all possible content files from the project and attempts to match them to the topics in the collection by ID.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnAddingNew | Raises the AddingNew event. (Inherited from BindingList <(Of <( Topic >)>).)
OnListChanged | Raises the ListChanged event. (Inherited from BindingList <(Of <( Topic >)>).)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Topic >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Topic >)>).)
RemoveItem | This is overridden to clear the parent on the removed item (Overrides BindingList<(Of <(T>)>)..::.RemoveItem(Int32).)
RemoveSortCore | Removes any sort applied with ApplySortCore(PropertyDescriptor, ListSortDirection) if sorting is implemented in a derived class; otherwise, raises NotSupportedException. (Inherited from BindingList <(Of <( Topic >)>).)
ResetBindings | Raises a ListChanged event of type Reset. (Inherited from BindingList <(Of <( Topic >)>).)
ResetItem | Raises a ListChanged event of type ItemChanged for the item at the specified position. (Inherited from BindingList <(Of <( Topic >)>).)
Save | Save the topic collection to the related content layout file
SetItem | This is overridden to set the inserted item's parent to this collection. (Overrides BindingList<(Of <(T>)>)..::.SetItem(Int32, T).)
Sort | This is used to sort the collection
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TopicCollection Class
SandcastleBuilder.Utils.ConceptualContent Namespace


AddTopicsFromFolder Method

[image]

Sandcastle Help File Builder Documentation
TopicCollection..::.AddTopicsFromFolder Method
TopicCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Add all topics from the specified folder recursively to the collection and to the given project file.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public void AddTopicsFromFolder(
    string folder,
    string basePath,
    SandcastleProject project
)
Visual Basic (Declaration)
Public Sub AddTopicsFromFolder ( _
    folder As String, _
    basePath As String, _
    project As SandcastleProject _
)

Parameters

folder
Type: System..::.String
The folder from which to get the files
basePath
Type: System..::.String
The base path to remove from files copied from another folder into the project folder. On the first call, this should match the folder value.
project
Type: SandcastleBuilder.Utils..::.SandcastleProject
The project to which the files are added

Remarks

Only actual conceptual content topic files are added. They must have a ".aml" extension and must be one of the valid document types. Folders will be added as sub-topics recursively. If a file with the same name as the folder exists, it will be associated with the container node. If no such file exists, an empty container node is created.

See Also

TopicCollection Class
SandcastleBuilder.Utils.ConceptualContent Namespace


ClearItems Method

[image]

Sandcastle Help File Builder Documentation
TopicCollection..::.ClearItems Method
TopicCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is overridden to clear the default topic and split TOC topic when the collection is cleared.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected override void ClearItems()
Visual Basic (Declaration)
Protected Overrides Sub ClearItems

See Also

TopicCollection Class
SandcastleBuilder.Utils.ConceptualContent Namespace


GenerateConceptualTopics Method

[image]

Sandcastle Help File Builder Documentation
TopicCollection..::.GenerateConceptualTopics Method
TopicCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This creates copies of the conceptual topic files in the build process's working folder.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public void GenerateConceptualTopics(
    string folder,
    BuildProcess builder
)
Visual Basic (Declaration)
Public Sub GenerateConceptualTopics ( _
    folder As String, _
    builder As BuildProcess _
)

Parameters

folder
Type: System..::.String
The folder in which to place the topic files
builder
Type: SandcastleBuilder.Utils.BuildEngine..::.BuildProcess
The build process

Remarks

Each topic file will be named using its Id. If necessary, its content will be wrapped in a <topic> element. Sub-topics are written out recursively.

See Also

TopicCollection Class
SandcastleBuilder.Utils.ConceptualContent Namespace


GenerateTableOfContents Method

[image]

Sandcastle Help File Builder Documentation
TopicCollection..::.GenerateTableOfContents Method
TopicCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Generate the table of contents for the conceptual topics

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public void GenerateTableOfContents(
    TocEntryCollection toc,
    IBasePathProvider pathProvider
)
Visual Basic (Declaration)
Public Sub GenerateTableOfContents ( _
    toc As TocEntryCollection, _
    pathProvider As IBasePathProvider _
)

Parameters

toc
Type: SandcastleBuilder.Utils.ConceptualContent..::.TocEntryCollection
The table of contents collection
pathProvider
Type: SandcastleBuilder.Utils..::.IBasePathProvider
The base path provider

Implements

ITableOfContents..::.GenerateTableOfContents(TocEntryCollection, IBasePathProvider)

See Also

TopicCollection Class
SandcastleBuilder.Utils.ConceptualContent Namespace


InsertItem Method

[image]

Sandcastle Help File Builder Documentation
TopicCollection..::.InsertItem Method
TopicCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is overridden to set the inserted item's parent to this collection.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected override void InsertItem(
    int index,
    Topic item
)
Visual Basic (Declaration)
Protected Overrides Sub InsertItem ( _
    index As Integer, _
    item As Topic _
)

Parameters

index
Type: System..::.Int32
The zero-based index where the item is to be inserted.
item
Type: SandcastleBuilder.Utils.ConceptualContent..::.Topic
The item to insert in the list.

See Also

TopicCollection Class
SandcastleBuilder.Utils.ConceptualContent Namespace


Load Method

[image]

Sandcastle Help File Builder Documentation
TopicCollection..::.Load Method
TopicCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Load the collection from the related file

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public void Load()
Visual Basic (Declaration)
Public Sub Load

Remarks

This will be done automatically at constructor. This can be called to reload the collection if needed.

See Also

TopicCollection Class
SandcastleBuilder.Utils.ConceptualContent Namespace


MatchProjectFilesToTopics Method

[image]

Sandcastle Help File Builder Documentation
TopicCollection..::.MatchProjectFilesToTopics Method
TopicCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This gets all possible content files from the project and attempts to match them to the topics in the collection by ID.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public void MatchProjectFilesToTopics()
Visual Basic (Declaration)
Public Sub MatchProjectFilesToTopics

See Also

TopicCollection Class
SandcastleBuilder.Utils.ConceptualContent Namespace


RemoveItem Method

[image]

Sandcastle Help File Builder Documentation
TopicCollection..::.RemoveItem Method
TopicCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is overridden to clear the parent on the removed item

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected override void RemoveItem(
    int index
)
Visual Basic (Declaration)
Protected Overrides Sub RemoveItem ( _
    index As Integer _
)

Parameters

index
Type: System..::.Int32
The index of the item to remove

See Also

TopicCollection Class
SandcastleBuilder.Utils.ConceptualContent Namespace


Save Method

[image]

Sandcastle Help File Builder Documentation
TopicCollection..::.Save Method
TopicCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Save the topic collection to the related content layout file

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public void Save()
Visual Basic (Declaration)
Public Sub Save

See Also

TopicCollection Class
SandcastleBuilder.Utils.ConceptualContent Namespace


SetItem Method

[image]

Sandcastle Help File Builder Documentation
TopicCollection..::.SetItem Method
TopicCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is overridden to set the inserted item's parent to this collection.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected override void SetItem(
    int index,
    Topic item
)
Visual Basic (Declaration)
Protected Overrides Sub SetItem ( _
    index As Integer, _
    item As Topic _
)

Parameters

index
Type: System..::.Int32
The zero-based index of the item to replace.
item
Type: SandcastleBuilder.Utils.ConceptualContent..::.Topic
The new value for the item at the specified index. The value can be null for reference types.

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | index is less than zero. -or- index is greater than Count.

See Also

TopicCollection Class
SandcastleBuilder.Utils.ConceptualContent Namespace


Sort Method

[image]

Sandcastle Help File Builder Documentation
TopicCollection..::.Sort Method
TopicCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to sort the collection

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public void Sort()
Visual Basic (Declaration)
Public Sub Sort

Remarks

Values are sorted by display title. Comparisons are case-sensitive.

See Also

TopicCollection Class
SandcastleBuilder.Utils.ConceptualContent Namespace


TopicCollection Properties

[image] [image]

Sandcastle Help File Builder Documentation
TopicCollection Properties
TopicCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TopicCollection type exposes the following members.

Properties

Name | Description
AllowEdit | Gets or sets a value indicating whether items in the list can be edited. (Inherited from BindingList <(Of <( Topic >)>).)
AllowNew | Gets or sets a value indicating whether you can add items to the list using the AddNew()()() method. (Inherited from BindingList <(Of <( Topic >)>).)
AllowRemove | Gets or sets a value indicating whether you can remove items from the collection. (Inherited from BindingList <(Of <( Topic >)>).)
ContentLayoutFile | This is used to get the build item related to the content layout file containing the collection items.
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Topic >)>).)
DefaultTopic | This is used to get or set the default topic
FileItem | This read-only property returns the project file item associated with the collection.
IsSortedCore | Gets a value indicating whether the list is sorted. (Inherited from BindingList <(Of <( Topic >)>).)
Item | Overloaded.
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Topic >)>).)
RaiseListChangedEvents | Gets or sets a value indicating whether adding or removing items within the list raises ListChanged events. (Inherited from BindingList <(Of <( Topic >)>).)
SortDirectionCore | Gets the direction the list is sorted. (Inherited from BindingList <(Of <( Topic >)>).)
SortPropertyCore | Gets the property descriptor that is used for sorting the list if sorting is implemented in a derived class; otherwise, returns null. (Inherited from BindingList <(Of <( Topic >)>).)
SplitTocAtTopic | This is used to get or set the topic at which the table of contents is split by the API content.
SupportsChangeNotificationCore | Gets a value indicating whether ListChanged events are enabled. (Inherited from BindingList <(Of <( Topic >)>).)
SupportsSearchingCore | Gets a value indicating whether the list supports searching. (Inherited from BindingList <(Of <( Topic >)>).)
SupportsSortingCore | Gets a value indicating whether the list supports sorting. (Inherited from BindingList <(Of <( Topic >)>).)

See Also

TopicCollection Class
SandcastleBuilder.Utils.ConceptualContent Namespace


ContentLayoutFile Property

[image]

Sandcastle Help File Builder Documentation
TopicCollection..::.ContentLayoutFile Property
TopicCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get the build item related to the content layout file containing the collection items.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public FileItem ContentLayoutFile { get; }
Visual Basic (Declaration)
Public ReadOnly Property ContentLayoutFile As FileItem

Implements

ITableOfContents..::.ContentLayoutFile

See Also

TopicCollection Class
SandcastleBuilder.Utils.ConceptualContent Namespace


DefaultTopic Property

[image]

Sandcastle Help File Builder Documentation
TopicCollection..::.DefaultTopic Property
TopicCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set the default topic

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public Topic DefaultTopic { get; set; }
Visual Basic (Declaration)
Public Property DefaultTopic As Topic

Field Value

It returns the default topic or null if one is not set

See Also

TopicCollection Class
SandcastleBuilder.Utils.ConceptualContent Namespace


FileItem Property

[image]

Sandcastle Help File Builder Documentation
TopicCollection..::.FileItem Property
TopicCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns the project file item associated with the collection.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public FileItem FileItem { get; }
Visual Basic (Declaration)
Public ReadOnly Property FileItem As FileItem

See Also

TopicCollection Class
SandcastleBuilder.Utils.ConceptualContent Namespace


Item Property

[image] [image]

Sandcastle Help File Builder Documentation
TopicCollection..::.Item Property
TopicCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Item[([(Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection <(Of <( Topic >)>).)
Item[([(String])]) | This can be used to get a topic by its unique ID (case-insensitive)

See Also

TopicCollection Class
TopicCollection Members
SandcastleBuilder.Utils.ConceptualContent Namespace


Item Property (String)

[image]

Sandcastle Help File Builder Documentation
TopicCollection..::.Item Property (String)
TopicCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This can be used to get a topic by its unique ID (case-insensitive)

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public Topic this[
    string id
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    id As String _
) As Topic

Parameters

id
Type: System..::.String
The ID of the item to get.

Field Value

Returns the topic with the specified Id or null if not found.

See Also

TopicCollection Class
Item Overload
SandcastleBuilder.Utils.ConceptualContent Namespace


SplitTocAtTopic Property

[image]

Sandcastle Help File Builder Documentation
TopicCollection..::.SplitTocAtTopic Property
TopicCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set the topic at which the table of contents is split by the API content.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public Topic SplitTocAtTopic { get; set; }
Visual Basic (Declaration)
Public Property SplitTocAtTopic As Topic

Field Value

This will only be valid if it refers to a root level topic. It will return null if a split location has not been set.

See Also

TopicCollection Class
SandcastleBuilder.Utils.ConceptualContent Namespace


TopicCollection Events

[image] [image]

Sandcastle Help File Builder Documentation
TopicCollection Events
TopicCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TopicCollection type exposes the following members.

Events

Name | Description
AddingNew | Occurs before an item is added to the list. (Inherited from BindingList <(Of <( Topic >)>).)
ListChanged | Occurs when the list or an item in the list changes. (Inherited from BindingList <(Of <( Topic >)>).)

See Also

TopicCollection Class
SandcastleBuilder.Utils.ConceptualContent Namespace


TopicFile Class

[image]

Sandcastle Help File Builder Documentation
TopicFile Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This class represents a conceptual content topic file

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public class TopicFile
Visual Basic (Declaration)
Public Class TopicFile

Inheritance Hierarchy

System..::.Object
SandcastleBuilder.Utils.ConceptualContent..::.TopicFile

See Also

TopicFile Members
SandcastleBuilder.Utils.ConceptualContent Namespace


TopicFile Members

[image] [image]

Sandcastle Help File Builder Documentation
TopicFile Members
TopicFile Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TopicFile type exposes the following members.

Constructors

Name | Description
TopicFile | Constructor

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ParseContent | This will parse the file content and extract the document type, unique ID, and revision number.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DocumentType | This read-only property is used to get the document type
ErrorMessage | This read-only property is used to return the error message if DocumentType returns Invalid.
FileItem | This is used to get or set the file build item
FullPath | Get the full path to the file
Id | This is used to get the unique ID of the topic
Name | Get the name of the file without the path
RevisionNumber | This is used to get the topic's revision number

See Also

TopicFile Class
SandcastleBuilder.Utils.ConceptualContent Namespace


TopicFile Constructor

[image]

Sandcastle Help File Builder Documentation
TopicFile Constructor
TopicFile Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public TopicFile(
    FileItem file
)
Visual Basic (Declaration)
Public Sub New ( _
    file As FileItem _
)

Parameters

file
Type: SandcastleBuilder.Utils..::.FileItem
The file build item from the project

Exceptions

Exception | Condition
System..::.ArgumentNullException | This is thrown if the file item is null.

See Also

TopicFile Class
SandcastleBuilder.Utils.ConceptualContent Namespace


TopicFile Methods

[image] [image]

Sandcastle Help File Builder Documentation
TopicFile Methods
TopicFile Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TopicFile type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ParseContent | This will parse the file content and extract the document type, unique ID, and revision number.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TopicFile Class
SandcastleBuilder.Utils.ConceptualContent Namespace


ParseContent Method

[image]

Sandcastle Help File Builder Documentation
TopicFile..::.ParseContent Method
TopicFile Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This will parse the file content and extract the document type, unique ID, and revision number.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public void ParseContent(
    bool reparse
)
Visual Basic (Declaration)
Public Sub ParseContent ( _
    reparse As Boolean _
)

Parameters

reparse
Type: System..::.Boolean
If false and the file has already been parsed, the method just returns. If true, the file is reparsed to refresh the information.

See Also

TopicFile Class
SandcastleBuilder.Utils.ConceptualContent Namespace


TopicFile Properties

[image] [image]

Sandcastle Help File Builder Documentation
TopicFile Properties
TopicFile Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TopicFile type exposes the following members.

Properties

Name | Description
DocumentType | This read-only property is used to get the document type
ErrorMessage | This read-only property is used to return the error message if DocumentType returns Invalid.
FileItem | This is used to get or set the file build item
FullPath | Get the full path to the file
Id | This is used to get the unique ID of the topic
Name | Get the name of the file without the path
RevisionNumber | This is used to get the topic's revision number

See Also

TopicFile Class
SandcastleBuilder.Utils.ConceptualContent Namespace


DocumentType Property

[image]

Sandcastle Help File Builder Documentation
TopicFile..::.DocumentType Property
TopicFile Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property is used to get the document type

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public DocumentType DocumentType { get; }
Visual Basic (Declaration)
Public ReadOnly Property DocumentType As DocumentType

See Also

TopicFile Class
SandcastleBuilder.Utils.ConceptualContent Namespace


ErrorMessage Property

[image]

Sandcastle Help File Builder Documentation
TopicFile..::.ErrorMessage Property
TopicFile Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property is used to return the error message if DocumentType returns Invalid.

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string ErrorMessage { get; }
Visual Basic (Declaration)
Public ReadOnly Property ErrorMessage As String

See Also

TopicFile Class
SandcastleBuilder.Utils.ConceptualContent Namespace


FileItem Property

[image]

Sandcastle Help File Builder Documentation
TopicFile..::.FileItem Property
TopicFile Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set the file build item

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public FileItem FileItem { get; set; }
Visual Basic (Declaration)
Public Property FileItem As FileItem

See Also

TopicFile Class
SandcastleBuilder.Utils.ConceptualContent Namespace


FullPath Property

[image]

Sandcastle Help File Builder Documentation
TopicFile..::.FullPath Property
TopicFile Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Get the full path to the file

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string FullPath { get; }
Visual Basic (Declaration)
Public ReadOnly Property FullPath As String

See Also

TopicFile Class
SandcastleBuilder.Utils.ConceptualContent Namespace


Id Property

[image]

Sandcastle Help File Builder Documentation
TopicFile..::.Id Property
TopicFile Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get the unique ID of the topic

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string Id { get; }
Visual Basic (Declaration)
Public ReadOnly Property Id As String

See Also

TopicFile Class
SandcastleBuilder.Utils.ConceptualContent Namespace


Name Property

[image]

Sandcastle Help File Builder Documentation
TopicFile..::.Name Property
TopicFile Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Get the name of the file without the path

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String

See Also

TopicFile Class
SandcastleBuilder.Utils.ConceptualContent Namespace


RevisionNumber Property

[image]

Sandcastle Help File Builder Documentation
TopicFile..::.RevisionNumber Property
TopicFile Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get the topic's revision number

Namespace: SandcastleBuilder.Utils.ConceptualContent
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public int RevisionNumber { get; }
Visual Basic (Declaration)
Public ReadOnly Property RevisionNumber As Integer

See Also

TopicFile Class
SandcastleBuilder.Utils.ConceptualContent Namespace


SandcastleBuilder.Utils.Controls Namespace

[image]

Sandcastle Help File Builder Documentation
SandcastleBuilder.Utils.Controls Namespace
Send Feedback

[This is preliminary documentation and is subject to change.]

This namespace contains various control classes.

Classes

Class | Description
CustomPropertyGrid | This is a custom property grid that allows you to set the initial width of the property name pane and has a context menu that allows you to hide the description pane and reset the selected property value.
DividerGroupBox | This is a simple derived group box control that draws the label text followed by a dividing line to the right of the text but no other surrounding border.
DividerLabel | This is a simple derived label control that draws the label text followed by a dividing line to the right of the text.
RefreshableItemListBox | This is a a simple derived list box in which you can refresh a specified item to show updates to the text displayed in the list box for the item.
StatusBarTextProvider | This is an IExtenderProvider component that allows you to add status bar text for menu items and form controls. When built for use with .NET 2.0, it also supports adding status bar text for menu strip, tool strip, and status strip components.


CustomPropertyGrid Class

[image]

Sandcastle Help File Builder Documentation
CustomPropertyGrid Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is a custom property grid that allows you to set the initial width of the property name pane and has a context menu that allows you to hide the description pane and reset the selected property value.

Namespace: SandcastleBuilder.Utils.Controls
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public class CustomPropertyGrid : PropertyGrid
Visual Basic (Declaration)
Public Class CustomPropertyGrid _
    Inherits PropertyGrid

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.PropertyGrid
SandcastleBuilder.Utils.Controls..::.CustomPropertyGrid

See Also

CustomPropertyGrid Members
SandcastleBuilder.Utils.Controls Namespace


CustomPropertyGrid Members

[image] [image]

Sandcastle Help File Builder Documentation
CustomPropertyGrid Members
CustomPropertyGrid Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The CustomPropertyGrid type exposes the following members.

Constructors

Name | Description
CustomPropertyGrid | Constructor

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CollapseAllGridItems | Collapses all the categories in the PropertyGrid. (Inherited from PropertyGrid.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreatePropertyTab | When overridden in a derived class, enables the creation of a PropertyTab. (Inherited from PropertyGrid.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExpandAllGridItems | Expands all the categories in the PropertyGrid. (Inherited from PropertyGrid.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnComComponentNameChanged | Raises the ComComponentNameChanged event. (Inherited from PropertyGrid.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | This is overridden to reset the pane width to the user-preferred width after creating the control. (Overrides ContainerControl..::.OnCreateControl()()().)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from PropertyGrid.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | (Inherited from PropertyGrid.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from PropertyGrid.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from PropertyGrid.)
OnHandleDestroyed | (Inherited from PropertyGrid.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from PropertyGrid.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from PropertyGrid.)
OnMouseUp | Raises the MouseUp event. (Inherited from PropertyGrid.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnNotifyPropertyValueUIItemsChanged | Raises the NotifyPropertyValueUIItemsChanged()()() event. (Inherited from PropertyGrid.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from PropertyGrid.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnPropertySortChanged | Raises the PropertySortChanged event. (Inherited from PropertyGrid.)
OnPropertyTabChanged | Raises the PropertyTabChanged event. (Inherited from PropertyGrid.)
OnPropertyValueChanged | Raises the PropertyValueChanged event. (Inherited from PropertyGrid.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | Raises the Resize event. (Inherited from PropertyGrid.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSelectedGridItemChanged | Raises the SelectedGridItemChanged event. (Inherited from PropertyGrid.)
OnSelectedObjectsChanged | Raises the SelectedObjectsChanged event. (Inherited from PropertyGrid.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from PropertyGrid.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from PropertyGrid.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from PropertyGrid.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from PropertyGrid.)
RefreshTabs | Refreshes the property tabs of the specified scope. (Inherited from PropertyGrid.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetSelectedProperty | Resets the selected property to its default value. (Inherited from PropertyGrid.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | This method is not relevant for this class. (Inherited from PropertyGrid.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
ShowEventsButton | (Inherited from PropertyGrid.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from PropertyGrid.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | This property is not relevant for this class. (Inherited from PropertyGrid.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | This property is not relevant for this class. (Inherited from Control.)
AutoValidate | Gets or sets a value that indicates whether controls in this container will be automatically validated when the focus changes. (Inherited from ContainerControl.)
BackColor | (Inherited from PropertyGrid.)
BackgroundImage | This property is not relevant for this class. (Inherited from PropertyGrid.)
BackgroundImageLayout | This property is not relevant for this class. (Inherited from PropertyGrid.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
BrowsableAttributes | Gets or sets the browsable attributes associated with the object that the property grid is attached to. (Inherited from PropertyGrid.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
CanShowCommands | Gets a value indicating whether the commands pane can be made visible for the currently selected objects. (Inherited from PropertyGrid.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CategoryForeColor | Gets or sets the text color used for category headings. (Inherited from PropertyGrid.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CommandsActiveLinkColor | Gets or sets the color of active links in the executable commands region. (Inherited from PropertyGrid.)
CommandsBackColor | Gets or sets the background color of the hot commands region. (Inherited from PropertyGrid.)
CommandsDisabledLinkColor | Gets or sets the unavailable link color for the executable commands region. (Inherited from PropertyGrid.)
CommandsForeColor | Gets or sets the foreground color for the hot commands region. (Inherited from PropertyGrid.)
CommandsLinkColor | Gets or sets the link color for the executable commands region. (Inherited from PropertyGrid.)
CommandsVisible | Gets a value indicating whether the commands pane is visible. (Inherited from PropertyGrid.)
CommandsVisibleIfAvailable | Gets or sets a value indicating whether the commands pane is visible for objects that expose verbs. (Inherited from PropertyGrid.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuDefaultLocation | Gets the default location for the shortcut menu. (Inherited from PropertyGrid.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | This property is not relevant for this class. (Inherited from PropertyGrid.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from ContainerControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from PropertyGrid.)
DefaultTabType | Gets the type of the default tab. (Inherited from PropertyGrid.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
DrawFlatToolbar | Gets or sets a value indicating whether the PropertyGrid control paints its toolbar with flat buttons. (Inherited from PropertyGrid.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | This property is not relevant for this class. (Inherited from PropertyGrid.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpBackColor | Gets or sets the background color for the Help region. (Inherited from PropertyGrid.)
HelpForeColor | Gets or sets the foreground color for the Help region. (Inherited from PropertyGrid.)
HelpVisible | Gets or sets a value indicating whether the Help text is visible. (Inherited from PropertyGrid.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LargeButtons | Gets or sets a value indicating whether buttons appear in standard size or in large size. (Inherited from PropertyGrid.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
LineColor | Gets or sets the color of the gridlines and borders. (Inherited from PropertyGrid.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | This property is not relevant for this class. (Inherited from PropertyGrid.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
PropertyNamePaneWidth | This is used to set or get the width of the property name pane
PropertySort | Gets or sets the type of sorting the PropertyGrid uses to display properties. (Inherited from PropertyGrid.)
PropertyTabs | Gets the collection of property tabs that are displayed in the grid. (Inherited from PropertyGrid.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
SelectedGridItem | Gets or sets the selected grid item. (Inherited from PropertyGrid.)
SelectedObject | Gets or sets the object for which the grid displays properties. (Inherited from PropertyGrid.)
SelectedObjects | Gets or sets the currently selected objects. (Inherited from PropertyGrid.)
SelectedTab | Gets the currently selected property tab. (Inherited from PropertyGrid.)
ShowFocusCues | (Inherited from PropertyGrid.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | (Inherited from PropertyGrid.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from PropertyGrid.)
ToolbarVisible | Gets or sets a value indicating whether the toolbar is visible. (Inherited from PropertyGrid.)
ToolStripRenderer | Gets or sets the painting functionality for ToolStrip objects. (Inherited from PropertyGrid.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseCompatibleTextRendering | Gets or sets a value that determines whether to use the compatible text rendering engine (GDI+) or not (GDI). (Inherited from PropertyGrid.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
ViewBackColor | Gets or sets a value indicating the background color in the grid. (Inherited from PropertyGrid.)
ViewForeColor | Gets or sets a value indicating the color of the text in the grid. (Inherited from PropertyGrid.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from ContainerControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from PropertyGrid.)
BackgroundImageLayoutChanged | Occurs when the value of the BackgroundImageLayout property changes. (Inherited from PropertyGrid.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the value of the ForeColor property changes. (Inherited from PropertyGrid.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is first pressed. (Inherited from PropertyGrid.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from PropertyGrid.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from PropertyGrid.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the user clicks the PropertyGrid control with the mouse. (Inherited from PropertyGrid.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from PropertyGrid.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from PropertyGrid.)
MouseMove | Occurs when the mouse pointer moves over the control. (Inherited from PropertyGrid.)
MouseUp | Occurs when the mouse pointer is over the control and the user releases a mouse button. (Inherited from PropertyGrid.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the value of the Padding property changes. (Inherited from PropertyGrid.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
PropertySortChanged | Occurs when the sort mode is changed. (Inherited from PropertyGrid.)
PropertyTabChanged | Occurs when a property tab changes. (Inherited from PropertyGrid.)
PropertyValueChanged | Occurs when a property value changes. (Inherited from PropertyGrid.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SelectedGridItemChanged | Occurs when the selected GridItem is changed. (Inherited from PropertyGrid.)
SelectedObjectsChanged | Occurs when the objects selected by the SelectedObjects property have changed. (Inherited from PropertyGrid.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | Occurs when the text of the PropertyGrid changes. (Inherited from PropertyGrid.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

CustomPropertyGrid Class
SandcastleBuilder.Utils.Controls Namespace


CustomPropertyGrid Constructor

[image]

Sandcastle Help File Builder Documentation
CustomPropertyGrid Constructor
CustomPropertyGrid Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Utils.Controls
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public CustomPropertyGrid()
Visual Basic (Declaration)
Public Sub New

See Also

CustomPropertyGrid Class
SandcastleBuilder.Utils.Controls Namespace


CustomPropertyGrid Methods

[image] [image]

Sandcastle Help File Builder Documentation
CustomPropertyGrid Methods
CustomPropertyGrid Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The CustomPropertyGrid type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CollapseAllGridItems | Collapses all the categories in the PropertyGrid. (Inherited from PropertyGrid.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreatePropertyTab | When overridden in a derived class, enables the creation of a PropertyTab. (Inherited from PropertyGrid.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExpandAllGridItems | Expands all the categories in the PropertyGrid. (Inherited from PropertyGrid.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnComComponentNameChanged | Raises the ComComponentNameChanged event. (Inherited from PropertyGrid.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | This is overridden to reset the pane width to the user-preferred width after creating the control. (Overrides ContainerControl..::.OnCreateControl()()().)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from PropertyGrid.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | (Inherited from PropertyGrid.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from PropertyGrid.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from PropertyGrid.)
OnHandleDestroyed | (Inherited from PropertyGrid.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from PropertyGrid.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from PropertyGrid.)
OnMouseUp | Raises the MouseUp event. (Inherited from PropertyGrid.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnNotifyPropertyValueUIItemsChanged | Raises the NotifyPropertyValueUIItemsChanged()()() event. (Inherited from PropertyGrid.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from PropertyGrid.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnPropertySortChanged | Raises the PropertySortChanged event. (Inherited from PropertyGrid.)
OnPropertyTabChanged | Raises the PropertyTabChanged event. (Inherited from PropertyGrid.)
OnPropertyValueChanged | Raises the PropertyValueChanged event. (Inherited from PropertyGrid.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | Raises the Resize event. (Inherited from PropertyGrid.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSelectedGridItemChanged | Raises the SelectedGridItemChanged event. (Inherited from PropertyGrid.)
OnSelectedObjectsChanged | Raises the SelectedObjectsChanged event. (Inherited from PropertyGrid.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from PropertyGrid.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from PropertyGrid.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from PropertyGrid.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from PropertyGrid.)
RefreshTabs | Refreshes the property tabs of the specified scope. (Inherited from PropertyGrid.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetSelectedProperty | Resets the selected property to its default value. (Inherited from PropertyGrid.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | This method is not relevant for this class. (Inherited from PropertyGrid.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
ShowEventsButton | (Inherited from PropertyGrid.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from PropertyGrid.)

See Also

CustomPropertyGrid Class
SandcastleBuilder.Utils.Controls Namespace


AccessibilityNotifyClients Method

[image] [image]

Sandcastle Help File Builder Documentation
CustomPropertyGrid..::.AccessibilityNotifyClients Method
CustomPropertyGrid Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

CustomPropertyGrid Class
CustomPropertyGrid Members
SandcastleBuilder.Utils.Controls Namespace


BeginInvoke Method

[image] [image]

Sandcastle Help File Builder Documentation
CustomPropertyGrid..::.BeginInvoke Method
CustomPropertyGrid Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

CustomPropertyGrid Class
CustomPropertyGrid Members
SandcastleBuilder.Utils.Controls Namespace


Dispose Method

[image] [image]

Sandcastle Help File Builder Documentation
CustomPropertyGrid..::.Dispose Method
CustomPropertyGrid Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides PropertyGrid..::.Dispose(Boolean).)

See Also

CustomPropertyGrid Class
CustomPropertyGrid Members
SandcastleBuilder.Utils.Controls Namespace


Dispose Method (Boolean)

[image]

Sandcastle Help File Builder Documentation
CustomPropertyGrid..::.Dispose Method (Boolean)
CustomPropertyGrid Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: SandcastleBuilder.Utils.Controls
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
True to release both managed and unmanaged resources, false to just release unmanaged resources.

See Also

CustomPropertyGrid Class
Dispose Overload
SandcastleBuilder.Utils.Controls Namespace


GetChildAtPoint Method

[image] [image]

Sandcastle Help File Builder Documentation
CustomPropertyGrid..::.GetChildAtPoint Method
CustomPropertyGrid Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

CustomPropertyGrid Class
CustomPropertyGrid Members
SandcastleBuilder.Utils.Controls Namespace


Invalidate Method

[image] [image]

Sandcastle Help File Builder Documentation
CustomPropertyGrid..::.Invalidate Method
CustomPropertyGrid Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

CustomPropertyGrid Class
CustomPropertyGrid Members
SandcastleBuilder.Utils.Controls Namespace


Invoke Method

[image] [image]

Sandcastle Help File Builder Documentation
CustomPropertyGrid..::.Invoke Method
CustomPropertyGrid Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

CustomPropertyGrid Class
CustomPropertyGrid Members
SandcastleBuilder.Utils.Controls Namespace


MemberwiseClone Method

[image] [image]

Sandcastle Help File Builder Documentation
CustomPropertyGrid..::.MemberwiseClone Method
CustomPropertyGrid Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

CustomPropertyGrid Class
CustomPropertyGrid Members
SandcastleBuilder.Utils.Controls Namespace


OnCreateControl Method

[image]

Sandcastle Help File Builder Documentation
CustomPropertyGrid..::.OnCreateControl Method
CustomPropertyGrid Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is overridden to reset the pane width to the user-preferred width after creating the control.

Namespace: SandcastleBuilder.Utils.Controls
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected override void OnCreateControl()
Visual Basic (Declaration)
Protected Overrides Sub OnCreateControl

See Also

CustomPropertyGrid Class
SandcastleBuilder.Utils.Controls Namespace


PerformLayout Method

[image] [image]

Sandcastle Help File Builder Documentation
CustomPropertyGrid..::.PerformLayout Method
CustomPropertyGrid Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

CustomPropertyGrid Class
CustomPropertyGrid Members
SandcastleBuilder.Utils.Controls Namespace


ResumeLayout Method

[image] [image]

Sandcastle Help File Builder Documentation
CustomPropertyGrid..::.ResumeLayout Method
CustomPropertyGrid Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

CustomPropertyGrid Class
CustomPropertyGrid Members
SandcastleBuilder.Utils.Controls Namespace


RtlTranslateAlignment Method

[image] [image]

Sandcastle Help File Builder Documentation
CustomPropertyGrid..::.RtlTranslateAlignment Method
CustomPropertyGrid Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

CustomPropertyGrid Class
CustomPropertyGrid Members
SandcastleBuilder.Utils.Controls Namespace


Scale Method

[image] [image]

Sandcastle Help File Builder Documentation
CustomPropertyGrid..::.Scale Method
CustomPropertyGrid Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

CustomPropertyGrid Class
CustomPropertyGrid Members
SandcastleBuilder.Utils.Controls Namespace


Select Method

[image] [image]

Sandcastle Help File Builder Documentation
CustomPropertyGrid..::.Select Method
CustomPropertyGrid Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

CustomPropertyGrid Class
CustomPropertyGrid Members
SandcastleBuilder.Utils.Controls Namespace


SetBounds Method

[image] [image]

Sandcastle Help File Builder Documentation
CustomPropertyGrid..::.SetBounds Method
CustomPropertyGrid Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

CustomPropertyGrid Class
CustomPropertyGrid Members
SandcastleBuilder.Utils.Controls Namespace


UpdateBounds Method

[image] [image]

Sandcastle Help File Builder Documentation
CustomPropertyGrid..::.UpdateBounds Method
CustomPropertyGrid Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

CustomPropertyGrid Class
CustomPropertyGrid Members
SandcastleBuilder.Utils.Controls Namespace


Validate Method

[image] [image]

Sandcastle Help File Builder Documentation
CustomPropertyGrid..::.Validate Method
CustomPropertyGrid Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

CustomPropertyGrid Class
CustomPropertyGrid Members
SandcastleBuilder.Utils.Controls Namespace


ValidateChildren Method

[image] [image]

Sandcastle Help File Builder Documentation
CustomPropertyGrid..::.ValidateChildren Method
CustomPropertyGrid Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | Causes all of the child controls within a control that support validation to validate their data. (Inherited from ContainerControl.)
ValidateChildren(ValidationConstraints) | Causes all of the child controls within a control that support validation to validate their data. (Inherited from ContainerControl.)

See Also

CustomPropertyGrid Class
CustomPropertyGrid Members
SandcastleBuilder.Utils.Controls Namespace


CustomPropertyGrid Properties

[image] [image]

Sandcastle Help File Builder Documentation
CustomPropertyGrid Properties
CustomPropertyGrid Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The CustomPropertyGrid type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | This property is not relevant for this class. (Inherited from PropertyGrid.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | This property is not relevant for this class. (Inherited from Control.)
AutoValidate | Gets or sets a value that indicates whether controls in this container will be automatically validated when the focus changes. (Inherited from ContainerControl.)
BackColor | (Inherited from PropertyGrid.)
BackgroundImage | This property is not relevant for this class. (Inherited from PropertyGrid.)
BackgroundImageLayout | This property is not relevant for this class. (Inherited from PropertyGrid.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
BrowsableAttributes | Gets or sets the browsable attributes associated with the object that the property grid is attached to. (Inherited from PropertyGrid.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
CanShowCommands | Gets a value indicating whether the commands pane can be made visible for the currently selected objects. (Inherited from PropertyGrid.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CategoryForeColor | Gets or sets the text color used for category headings. (Inherited from PropertyGrid.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CommandsActiveLinkColor | Gets or sets the color of active links in the executable commands region. (Inherited from PropertyGrid.)
CommandsBackColor | Gets or sets the background color of the hot commands region. (Inherited from PropertyGrid.)
CommandsDisabledLinkColor | Gets or sets the unavailable link color for the executable commands region. (Inherited from PropertyGrid.)
CommandsForeColor | Gets or sets the foreground color for the hot commands region. (Inherited from PropertyGrid.)
CommandsLinkColor | Gets or sets the link color for the executable commands region. (Inherited from PropertyGrid.)
CommandsVisible | Gets a value indicating whether the commands pane is visible. (Inherited from PropertyGrid.)
CommandsVisibleIfAvailable | Gets or sets a value indicating whether the commands pane is visible for objects that expose verbs. (Inherited from PropertyGrid.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuDefaultLocation | Gets the default location for the shortcut menu. (Inherited from PropertyGrid.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | This property is not relevant for this class. (Inherited from PropertyGrid.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from ContainerControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from PropertyGrid.)
DefaultTabType | Gets the type of the default tab. (Inherited from PropertyGrid.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
DrawFlatToolbar | Gets or sets a value indicating whether the PropertyGrid control paints its toolbar with flat buttons. (Inherited from PropertyGrid.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | This property is not relevant for this class. (Inherited from PropertyGrid.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpBackColor | Gets or sets the background color for the Help region. (Inherited from PropertyGrid.)
HelpForeColor | Gets or sets the foreground color for the Help region. (Inherited from PropertyGrid.)
HelpVisible | Gets or sets a value indicating whether the Help text is visible. (Inherited from PropertyGrid.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LargeButtons | Gets or sets a value indicating whether buttons appear in standard size or in large size. (Inherited from PropertyGrid.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
LineColor | Gets or sets the color of the gridlines and borders. (Inherited from PropertyGrid.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | This property is not relevant for this class. (Inherited from PropertyGrid.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
PropertyNamePaneWidth | This is used to set or get the width of the property name pane
PropertySort | Gets or sets the type of sorting the PropertyGrid uses to display properties. (Inherited from PropertyGrid.)
PropertyTabs | Gets the collection of property tabs that are displayed in the grid. (Inherited from PropertyGrid.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
SelectedGridItem | Gets or sets the selected grid item. (Inherited from PropertyGrid.)
SelectedObject | Gets or sets the object for which the grid displays properties. (Inherited from PropertyGrid.)
SelectedObjects | Gets or sets the currently selected objects. (Inherited from PropertyGrid.)
SelectedTab | Gets the currently selected property tab. (Inherited from PropertyGrid.)
ShowFocusCues | (Inherited from PropertyGrid.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | (Inherited from PropertyGrid.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from PropertyGrid.)
ToolbarVisible | Gets or sets a value indicating whether the toolbar is visible. (Inherited from PropertyGrid.)
ToolStripRenderer | Gets or sets the painting functionality for ToolStrip objects. (Inherited from PropertyGrid.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseCompatibleTextRendering | Gets or sets a value that determines whether to use the compatible text rendering engine (GDI+) or not (GDI). (Inherited from PropertyGrid.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
ViewBackColor | Gets or sets a value indicating the background color in the grid. (Inherited from PropertyGrid.)
ViewForeColor | Gets or sets a value indicating the color of the text in the grid. (Inherited from PropertyGrid.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

CustomPropertyGrid Class
SandcastleBuilder.Utils.Controls Namespace


PropertyNamePaneWidth Property

[image]

Sandcastle Help File Builder Documentation
CustomPropertyGrid..::.PropertyNamePaneWidth Property
CustomPropertyGrid Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to set or get the width of the property name pane

Namespace: SandcastleBuilder.Utils.Controls
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public int PropertyNamePaneWidth { get; set; }
Visual Basic (Declaration)
Public Property PropertyNamePaneWidth As Integer

Remarks

Reflection is used to modify the pane width

See Also

CustomPropertyGrid Class
SandcastleBuilder.Utils.Controls Namespace


CustomPropertyGrid Events

[image] [image]

Sandcastle Help File Builder Documentation
CustomPropertyGrid Events
CustomPropertyGrid Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The CustomPropertyGrid type exposes the following members.

Events

Name | Description
AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from ContainerControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from PropertyGrid.)
BackgroundImageLayoutChanged | Occurs when the value of the BackgroundImageLayout property changes. (Inherited from PropertyGrid.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the value of the ForeColor property changes. (Inherited from PropertyGrid.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is first pressed. (Inherited from PropertyGrid.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from PropertyGrid.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from PropertyGrid.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the user clicks the PropertyGrid control with the mouse. (Inherited from PropertyGrid.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from PropertyGrid.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from PropertyGrid.)
MouseMove | Occurs when the mouse pointer moves over the control. (Inherited from PropertyGrid.)
MouseUp | Occurs when the mouse pointer is over the control and the user releases a mouse button. (Inherited from PropertyGrid.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the value of the Padding property changes. (Inherited from PropertyGrid.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
PropertySortChanged | Occurs when the sort mode is changed. (Inherited from PropertyGrid.)
PropertyTabChanged | Occurs when a property tab changes. (Inherited from PropertyGrid.)
PropertyValueChanged | Occurs when a property value changes. (Inherited from PropertyGrid.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SelectedGridItemChanged | Occurs when the selected GridItem is changed. (Inherited from PropertyGrid.)
SelectedObjectsChanged | Occurs when the objects selected by the SelectedObjects property have changed. (Inherited from PropertyGrid.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | Occurs when the text of the PropertyGrid changes. (Inherited from PropertyGrid.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

CustomPropertyGrid Class
SandcastleBuilder.Utils.Controls Namespace


DividerGroupBox Class

[image]

Sandcastle Help File Builder Documentation
DividerGroupBox Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is a simple derived group box control that draws the label text followed by a dividing line to the right of the text but no other surrounding border.

Namespace: SandcastleBuilder.Utils.Controls
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public class DividerGroupBox : GroupBox
Visual Basic (Declaration)
Public Class DividerGroupBox _
    Inherits GroupBox

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.GroupBox
SandcastleBuilder.Utils.Controls..::.DividerGroupBox

See Also

DividerGroupBox Members
SandcastleBuilder.Utils.Controls Namespace


DividerGroupBox Members

[image] [image]

Sandcastle Help File Builder Documentation
DividerGroupBox Members
DividerGroupBox Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DividerGroupBox type exposes the following members.

Constructors

Name | Description
DividerGroupBox | Constructor

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the GroupBox. (Inherited from GroupBox.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl()()() method. (Inherited from Control.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | (Inherited from GroupBox.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | Raises the Layout event. (Inherited from Control.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
OnPaint | This is overridden to draw the text and the dividing line (Overrides GroupBox..::.OnPaint(PaintEventArgs).)
OnPaintBackground | Paints the background of the control. (Inherited from Control.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | Raises the Resize event. (Inherited from Control.)
OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Control.)
ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from GroupBox.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | Scales the GroupBox by the specified factor and scaling instruction. (Inherited from GroupBox.)
ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from GroupBox.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
WndProc | (Inherited from GroupBox.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
AllowDrop | Gets or sets a value that indicates whether the control will allow drag-and-drop operations and events to be used. (Inherited from GroupBox.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoSize | Gets or sets a value that indicates whether the GroupBox resizes based on its contents. (Inherited from GroupBox.)
AutoSizeMode | Gets or sets how the GroupBox behaves when its AutoSize property is enabled. (Inherited from GroupBox.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from GroupBox.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the Padding structure that contains the default padding settings for a GroupBox control. (Inherited from GroupBox.)
DefaultSize | (Inherited from GroupBox.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets a rectangle that represents the dimensions of the GroupBox. (Inherited from GroupBox.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FlatStyle | Gets or sets the flat style appearance of the group box control. (Inherited from GroupBox.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value that indicates whether the user can press the TAB key to give the focus to the GroupBox. (Inherited from GroupBox.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from GroupBox.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseCompatibleTextRendering | Gets or sets a value that indicates whether the text of the GroupBox is rendered using compatible text rendering (GDI+) or GDI. (Inherited from GroupBox.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | Occurs when the value of the AutoSize property changes. (Inherited from GroupBox.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the user clicks the GroupBox control. (Inherited from GroupBox.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the user double-clicks the GroupBox control. (Inherited from GroupBox.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when the user presses a key while the GroupBox control has focus. (Inherited from GroupBox.)
KeyPress | Occurs when the user presses a key while the GroupBox control has focus. (Inherited from GroupBox.)
KeyUp | Occurs when the user releases a key while the GroupBox control has focus. (Inherited from GroupBox.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the user clicks the GroupBox control with the mouse. (Inherited from GroupBox.)
MouseDoubleClick | Occurs when the user double-clicks the GroupBox control with the mouse. (Inherited from GroupBox.)
MouseDown | Occurs when the user presses a mouse button while the mouse pointer is over the control. (Inherited from GroupBox.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from GroupBox.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from GroupBox.)
MouseMove | Occurs when the user moves the mouse pointer over the control. (Inherited from GroupBox.)
MouseUp | Occurs when the user releases a mouse button while the mouse pointer is over the control. (Inherited from GroupBox.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the value of the TabStop property changes. (Inherited from GroupBox.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

DividerGroupBox Class
SandcastleBuilder.Utils.Controls Namespace


DividerGroupBox Constructor

[image]

Sandcastle Help File Builder Documentation
DividerGroupBox Constructor
DividerGroupBox Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Utils.Controls
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public DividerGroupBox()
Visual Basic (Declaration)
Public Sub New

See Also

DividerGroupBox Class
SandcastleBuilder.Utils.Controls Namespace


DividerGroupBox Methods

[image] [image]

Sandcastle Help File Builder Documentation
DividerGroupBox Methods
DividerGroupBox Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DividerGroupBox type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the GroupBox. (Inherited from GroupBox.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl()()() method. (Inherited from Control.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | (Inherited from GroupBox.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | Raises the Layout event. (Inherited from Control.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
OnPaint | This is overridden to draw the text and the dividing line (Overrides GroupBox..::.OnPaint(PaintEventArgs).)
OnPaintBackground | Paints the background of the control. (Inherited from Control.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | Raises the Resize event. (Inherited from Control.)
OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Control.)
ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from GroupBox.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | Scales the GroupBox by the specified factor and scaling instruction. (Inherited from GroupBox.)
ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from GroupBox.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
WndProc | (Inherited from GroupBox.)

See Also

DividerGroupBox Class
SandcastleBuilder.Utils.Controls Namespace


AccessibilityNotifyClients Method

[image] [image]

Sandcastle Help File Builder Documentation
DividerGroupBox..::.AccessibilityNotifyClients Method
DividerGroupBox Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

DividerGroupBox Class
DividerGroupBox Members
SandcastleBuilder.Utils.Controls Namespace


BeginInvoke Method

[image] [image]

Sandcastle Help File Builder Documentation
DividerGroupBox..::.BeginInvoke Method
DividerGroupBox Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

DividerGroupBox Class
DividerGroupBox Members
SandcastleBuilder.Utils.Controls Namespace


Dispose Method

[image] [image]

Sandcastle Help File Builder Documentation
DividerGroupBox..::.Dispose Method
DividerGroupBox Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)

See Also

DividerGroupBox Class
DividerGroupBox Members
SandcastleBuilder.Utils.Controls Namespace


GetChildAtPoint Method

[image] [image]

Sandcastle Help File Builder Documentation
DividerGroupBox..::.GetChildAtPoint Method
DividerGroupBox Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

DividerGroupBox Class
DividerGroupBox Members
SandcastleBuilder.Utils.Controls Namespace


Invalidate Method

[image] [image]

Sandcastle Help File Builder Documentation
DividerGroupBox..::.Invalidate Method
DividerGroupBox Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

DividerGroupBox Class
DividerGroupBox Members
SandcastleBuilder.Utils.Controls Namespace


Invoke Method

[image] [image]

Sandcastle Help File Builder Documentation
DividerGroupBox..::.Invoke Method
DividerGroupBox Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

DividerGroupBox Class
DividerGroupBox Members
SandcastleBuilder.Utils.Controls Namespace


MemberwiseClone Method

[image] [image]

Sandcastle Help File Builder Documentation
DividerGroupBox..::.MemberwiseClone Method
DividerGroupBox Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

DividerGroupBox Class
DividerGroupBox Members
SandcastleBuilder.Utils.Controls Namespace


OnPaint Method

[image]

Sandcastle Help File Builder Documentation
DividerGroupBox..::.OnPaint Method
DividerGroupBox Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is overridden to draw the text and the dividing line

Namespace: SandcastleBuilder.Utils.Controls
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected override void OnPaint(
    PaintEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)

Parameters

e
Type: System.Windows.Forms..::.PaintEventArgs
The event arguments

See Also

DividerGroupBox Class
SandcastleBuilder.Utils.Controls Namespace


PerformLayout Method

[image] [image]

Sandcastle Help File Builder Documentation
DividerGroupBox..::.PerformLayout Method
DividerGroupBox Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

DividerGroupBox Class
DividerGroupBox Members
SandcastleBuilder.Utils.Controls Namespace


ResumeLayout Method

[image] [image]

Sandcastle Help File Builder Documentation
DividerGroupBox..::.ResumeLayout Method
DividerGroupBox Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

DividerGroupBox Class
DividerGroupBox Members
SandcastleBuilder.Utils.Controls Namespace


RtlTranslateAlignment Method

[image] [image]

Sandcastle Help File Builder Documentation
DividerGroupBox..::.RtlTranslateAlignment Method
DividerGroupBox Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

DividerGroupBox Class
DividerGroupBox Members
SandcastleBuilder.Utils.Controls Namespace


Scale Method

[image] [image]

Sandcastle Help File Builder Documentation
DividerGroupBox..::.Scale Method
DividerGroupBox Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

DividerGroupBox Class
DividerGroupBox Members
SandcastleBuilder.Utils.Controls Namespace


Select Method

[image] [image]

Sandcastle Help File Builder Documentation
DividerGroupBox..::.Select Method
DividerGroupBox Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

DividerGroupBox Class
DividerGroupBox Members
SandcastleBuilder.Utils.Controls Namespace


SetBounds Method

[image] [image]

Sandcastle Help File Builder Documentation
DividerGroupBox..::.SetBounds Method
DividerGroupBox Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

DividerGroupBox Class
DividerGroupBox Members
SandcastleBuilder.Utils.Controls Namespace


UpdateBounds Method

[image] [image]

Sandcastle Help File Builder Documentation
DividerGroupBox..::.UpdateBounds Method
DividerGroupBox Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

DividerGroupBox Class
DividerGroupBox Members
SandcastleBuilder.Utils.Controls Namespace


DividerGroupBox Properties

[image] [image]

Sandcastle Help File Builder Documentation
DividerGroupBox Properties
DividerGroupBox Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DividerGroupBox type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
AllowDrop | Gets or sets a value that indicates whether the control will allow drag-and-drop operations and events to be used. (Inherited from GroupBox.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoSize | Gets or sets a value that indicates whether the GroupBox resizes based on its contents. (Inherited from GroupBox.)
AutoSizeMode | Gets or sets how the GroupBox behaves when its AutoSize property is enabled. (Inherited from GroupBox.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from GroupBox.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the Padding structure that contains the default padding settings for a GroupBox control. (Inherited from GroupBox.)
DefaultSize | (Inherited from GroupBox.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets a rectangle that represents the dimensions of the GroupBox. (Inherited from GroupBox.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FlatStyle | Gets or sets the flat style appearance of the group box control. (Inherited from GroupBox.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value that indicates whether the user can press the TAB key to give the focus to the GroupBox. (Inherited from GroupBox.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from GroupBox.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseCompatibleTextRendering | Gets or sets a value that indicates whether the text of the GroupBox is rendered using compatible text rendering (GDI+) or GDI. (Inherited from GroupBox.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

DividerGroupBox Class
SandcastleBuilder.Utils.Controls Namespace


DividerGroupBox Events

[image] [image]

Sandcastle Help File Builder Documentation
DividerGroupBox Events
DividerGroupBox Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DividerGroupBox type exposes the following members.

Events

Name | Description
AutoSizeChanged | Occurs when the value of the AutoSize property changes. (Inherited from GroupBox.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the user clicks the GroupBox control. (Inherited from GroupBox.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the user double-clicks the GroupBox control. (Inherited from GroupBox.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when the user presses a key while the GroupBox control has focus. (Inherited from GroupBox.)
KeyPress | Occurs when the user presses a key while the GroupBox control has focus. (Inherited from GroupBox.)
KeyUp | Occurs when the user releases a key while the GroupBox control has focus. (Inherited from GroupBox.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the user clicks the GroupBox control with the mouse. (Inherited from GroupBox.)
MouseDoubleClick | Occurs when the user double-clicks the GroupBox control with the mouse. (Inherited from GroupBox.)
MouseDown | Occurs when the user presses a mouse button while the mouse pointer is over the control. (Inherited from GroupBox.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from GroupBox.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from GroupBox.)
MouseMove | Occurs when the user moves the mouse pointer over the control. (Inherited from GroupBox.)
MouseUp | Occurs when the user releases a mouse button while the mouse pointer is over the control. (Inherited from GroupBox.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the value of the TabStop property changes. (Inherited from GroupBox.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

DividerGroupBox Class
SandcastleBuilder.Utils.Controls Namespace


DividerLabel Class

[image]

Sandcastle Help File Builder Documentation
DividerLabel Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is a simple derived label control that draws the label text followed by a dividing line to the right of the text.

Namespace: SandcastleBuilder.Utils.Controls
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public class DividerLabel : Label
Visual Basic (Declaration)
Public Class DividerLabel _
    Inherits Label

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.Label
SandcastleBuilder.Utils.Controls..::.DividerLabel

See Also

DividerLabel Members
SandcastleBuilder.Utils.Controls Namespace


DividerLabel Members

[image] [image]

Sandcastle Help File Builder Documentation
DividerLabel Members
DividerLabel Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DividerLabel type exposes the following members.

Constructors

Name | Description
DividerLabel | Constructor

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CalcImageRenderBounds | Determines the size and location of an image drawn within the Label control based on the alignment of the control. (Inherited from Label.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | (Inherited from Label.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawImage | Draws an Image within the specified bounds. (Inherited from Label.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | (Inherited from Label.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl()()() method. (Inherited from Control.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Label.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | (Inherited from Label.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Label.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | Raises the Layout event. (Inherited from Control.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | (Inherited from Label.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | (Inherited from Label.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from Label.)
OnPaint | This is overridden to draw the text and the dividing line (Overrides Label..::.OnPaint(PaintEventArgs).)
OnPaintBackground | Paints the background of the control. (Inherited from Control.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from Label.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | Raises the Resize event. (Inherited from Control.)
OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Label.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextAlignChanged | Raises the TextAlignChanged event. (Inherited from Label.)
OnTextChanged | (Inherited from Label.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from Label.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Control.)
ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from Label.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Sets the specified bounds of the label. (Inherited from Label.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Label.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
WndProc | (Inherited from Label.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoEllipsis | Gets or sets a value indicating whether the ellipsis character (...) appears at the right edge of the Label, denoting that the Label text extends beyond the specified length of the Label. (Inherited from Label.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoSize | Gets or sets a value indicating whether the control is automatically resized to display its entire contents. (Inherited from Label.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the image rendered on the background of the control. (Inherited from Label.)
BackgroundImageLayout | This property is not relevant for this class. (Inherited from Label.)
BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
BorderStyle | Gets or sets the border style for the control. (Inherited from Label.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Label.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by this control. (Inherited from Label.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Label.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Label.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FlatStyle | Gets or sets the flat style appearance of the label control. (Inherited from Label.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
Image | Gets or sets the image that is displayed on a Label. (Inherited from Label.)
ImageAlign | Gets or sets the alignment of an image that is displayed in the control. (Inherited from Label.)
ImageIndex | Gets or sets the index value of the image displayed on the Label. (Inherited from Label.)
ImageKey | Gets or sets the key accessor for the image in the ImageList. (Inherited from Label.)
ImageList | Gets or sets the ImageList that contains the images to display in the Label control. (Inherited from Label.)
ImeMode | Gets or sets the Input Method Editor (IME) mode supported by this control. (Inherited from Label.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
PreferredHeight | Gets the preferred height of the control. (Inherited from Label.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
PreferredWidth | Gets the preferred width of the control. (Inherited from Label.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
RenderTransparent | Obsolete. Indicates whether the container control background is rendered on the Label. (Inherited from Label.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can tab to the Label. This property is not used by this class. (Inherited from Label.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Label.)
TextAlign | Gets or sets the alignment of text in the label. (Inherited from Label.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseCompatibleTextRendering | Gets or sets a value that specifies whether text rendering should be compatible with previous releases of Windows Forms. (Inherited from Label.)
UseMnemonic | Gets or sets a value indicating whether the control interprets an ampersand character (&) in the control's Text property to be an access key prefix character. (Inherited from Label.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | Occurs when the value of the AutoSize property changes. (Inherited from Label.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the BackgroundImage property changes. (Inherited from Label.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Label.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property changes. (Inherited from Label.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when the user presses a key while the label has focus. (Inherited from Label.)
KeyPress | Occurs when the user presses a key while the label has focus. (Inherited from Label.)
KeyUp | Occurs when the user releases a key while the label has focus. (Inherited from Label.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property changes. (Inherited from Label.)
TextAlignChanged | Occurs when the value of the TextAlign property has changed. (Inherited from Label.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

DividerLabel Class
SandcastleBuilder.Utils.Controls Namespace


DividerLabel Constructor

[image]

Sandcastle Help File Builder Documentation
DividerLabel Constructor
DividerLabel Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Utils.Controls
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public DividerLabel()
Visual Basic (Declaration)
Public Sub New

See Also

DividerLabel Class
SandcastleBuilder.Utils.Controls Namespace


DividerLabel Methods

[image] [image]

Sandcastle Help File Builder Documentation
DividerLabel Methods
DividerLabel Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DividerLabel type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CalcImageRenderBounds | Determines the size and location of an image drawn within the Label control based on the alignment of the control. (Inherited from Label.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | (Inherited from Label.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawImage | Draws an Image within the specified bounds. (Inherited from Label.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | (Inherited from Label.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl()()() method. (Inherited from Control.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Label.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | (Inherited from Label.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Label.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | Raises the Layout event. (Inherited from Control.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | (Inherited from Label.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | (Inherited from Label.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from Label.)
OnPaint | This is overridden to draw the text and the dividing line (Overrides Label..::.OnPaint(PaintEventArgs).)
OnPaintBackground | Paints the background of the control. (Inherited from Control.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from Label.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | Raises the Resize event. (Inherited from Control.)
OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Label.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextAlignChanged | Raises the TextAlignChanged event. (Inherited from Label.)
OnTextChanged | (Inherited from Label.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from Label.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Control.)
ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from Label.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Sets the specified bounds of the label. (Inherited from Label.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Label.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
WndProc | (Inherited from Label.)

See Also

DividerLabel Class
SandcastleBuilder.Utils.Controls Namespace


AccessibilityNotifyClients Method

[image] [image]

Sandcastle Help File Builder Documentation
DividerLabel..::.AccessibilityNotifyClients Method
DividerLabel Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

DividerLabel Class
DividerLabel Members
SandcastleBuilder.Utils.Controls Namespace


BeginInvoke Method

[image] [image]

Sandcastle Help File Builder Documentation
DividerLabel..::.BeginInvoke Method
DividerLabel Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

DividerLabel Class
DividerLabel Members
SandcastleBuilder.Utils.Controls Namespace


Dispose Method

[image] [image]

Sandcastle Help File Builder Documentation
DividerLabel..::.Dispose Method
DividerLabel Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Label and optionally releases the managed resources. (Inherited from Label.)

See Also

DividerLabel Class
DividerLabel Members
SandcastleBuilder.Utils.Controls Namespace


GetChildAtPoint Method

[image] [image]

Sandcastle Help File Builder Documentation
DividerLabel..::.GetChildAtPoint Method
DividerLabel Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

DividerLabel Class
DividerLabel Members
SandcastleBuilder.Utils.Controls Namespace


Invalidate Method

[image] [image]

Sandcastle Help File Builder Documentation
DividerLabel..::.Invalidate Method
DividerLabel Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

DividerLabel Class
DividerLabel Members
SandcastleBuilder.Utils.Controls Namespace


Invoke Method

[image] [image]

Sandcastle Help File Builder Documentation
DividerLabel..::.Invoke Method
DividerLabel Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

DividerLabel Class
DividerLabel Members
SandcastleBuilder.Utils.Controls Namespace


MemberwiseClone Method

[image] [image]

Sandcastle Help File Builder Documentation
DividerLabel..::.MemberwiseClone Method
DividerLabel Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

DividerLabel Class
DividerLabel Members
SandcastleBuilder.Utils.Controls Namespace


OnPaint Method

[image]

Sandcastle Help File Builder Documentation
DividerLabel..::.OnPaint Method
DividerLabel Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is overridden to draw the text and the dividing line

Namespace: SandcastleBuilder.Utils.Controls
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected override void OnPaint(
    PaintEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)

Parameters

e
Type: System.Windows.Forms..::.PaintEventArgs
The event arguments

See Also

DividerLabel Class
SandcastleBuilder.Utils.Controls Namespace


PerformLayout Method

[image] [image]

Sandcastle Help File Builder Documentation
DividerLabel..::.PerformLayout Method
DividerLabel Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

DividerLabel Class
DividerLabel Members
SandcastleBuilder.Utils.Controls Namespace


ResumeLayout Method

[image] [image]

Sandcastle Help File Builder Documentation
DividerLabel..::.ResumeLayout Method
DividerLabel Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

DividerLabel Class
DividerLabel Members
SandcastleBuilder.Utils.Controls Namespace


RtlTranslateAlignment Method

[image] [image]

Sandcastle Help File Builder Documentation
DividerLabel..::.RtlTranslateAlignment Method
DividerLabel Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

DividerLabel Class
DividerLabel Members
SandcastleBuilder.Utils.Controls Namespace


Scale Method

[image] [image]

Sandcastle Help File Builder Documentation
DividerLabel..::.Scale Method
DividerLabel Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

DividerLabel Class
DividerLabel Members
SandcastleBuilder.Utils.Controls Namespace


Select Method

[image] [image]

Sandcastle Help File Builder Documentation
DividerLabel..::.Select Method
DividerLabel Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

DividerLabel Class
DividerLabel Members
SandcastleBuilder.Utils.Controls Namespace


SetBounds Method

[image] [image]

Sandcastle Help File Builder Documentation
DividerLabel..::.SetBounds Method
DividerLabel Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

DividerLabel Class
DividerLabel Members
SandcastleBuilder.Utils.Controls Namespace


UpdateBounds Method

[image] [image]

Sandcastle Help File Builder Documentation
DividerLabel..::.UpdateBounds Method
DividerLabel Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

DividerLabel Class
DividerLabel Members
SandcastleBuilder.Utils.Controls Namespace


DividerLabel Properties

[image] [image]

Sandcastle Help File Builder Documentation
DividerLabel Properties
DividerLabel Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DividerLabel type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoEllipsis | Gets or sets a value indicating whether the ellipsis character (...) appears at the right edge of the Label, denoting that the Label text extends beyond the specified length of the Label. (Inherited from Label.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoSize | Gets or sets a value indicating whether the control is automatically resized to display its entire contents. (Inherited from Label.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the image rendered on the background of the control. (Inherited from Label.)
BackgroundImageLayout | This property is not relevant for this class. (Inherited from Label.)
BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
BorderStyle | Gets or sets the border style for the control. (Inherited from Label.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Label.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by this control. (Inherited from Label.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Label.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Label.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FlatStyle | Gets or sets the flat style appearance of the label control. (Inherited from Label.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
Image | Gets or sets the image that is displayed on a Label. (Inherited from Label.)
ImageAlign | Gets or sets the alignment of an image that is displayed in the control. (Inherited from Label.)
ImageIndex | Gets or sets the index value of the image displayed on the Label. (Inherited from Label.)
ImageKey | Gets or sets the key accessor for the image in the ImageList. (Inherited from Label.)
ImageList | Gets or sets the ImageList that contains the images to display in the Label control. (Inherited from Label.)
ImeMode | Gets or sets the Input Method Editor (IME) mode supported by this control. (Inherited from Label.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
PreferredHeight | Gets the preferred height of the control. (Inherited from Label.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
PreferredWidth | Gets the preferred width of the control. (Inherited from Label.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
RenderTransparent | Obsolete. Indicates whether the container control background is rendered on the Label. (Inherited from Label.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can tab to the Label. This property is not used by this class. (Inherited from Label.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Label.)
TextAlign | Gets or sets the alignment of text in the label. (Inherited from Label.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseCompatibleTextRendering | Gets or sets a value that specifies whether text rendering should be compatible with previous releases of Windows Forms. (Inherited from Label.)
UseMnemonic | Gets or sets a value indicating whether the control interprets an ampersand character (&) in the control's Text property to be an access key prefix character. (Inherited from Label.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

DividerLabel Class
SandcastleBuilder.Utils.Controls Namespace


DividerLabel Events

[image] [image]

Sandcastle Help File Builder Documentation
DividerLabel Events
DividerLabel Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DividerLabel type exposes the following members.

Events

Name | Description
AutoSizeChanged | Occurs when the value of the AutoSize property changes. (Inherited from Label.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the BackgroundImage property changes. (Inherited from Label.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Label.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property changes. (Inherited from Label.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when the user presses a key while the label has focus. (Inherited from Label.)
KeyPress | Occurs when the user presses a key while the label has focus. (Inherited from Label.)
KeyUp | Occurs when the user releases a key while the label has focus. (Inherited from Label.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property changes. (Inherited from Label.)
TextAlignChanged | Occurs when the value of the TextAlign property has changed. (Inherited from Label.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

DividerLabel Class
SandcastleBuilder.Utils.Controls Namespace


RefreshableItemListBox Class

[image]

Sandcastle Help File Builder Documentation
RefreshableItemListBox Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is a a simple derived list box in which you can refresh a specified item to show updates to the text displayed in the list box for the item.

Namespace: SandcastleBuilder.Utils.Controls
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public class RefreshableItemListBox : ListBox
Visual Basic (Declaration)
Public Class RefreshableItemListBox _
    Inherits ListBox

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ListControl
System.Windows.Forms..::.ListBox
SandcastleBuilder.Utils.Controls..::.RefreshableItemListBox

See Also

RefreshableItemListBox Members
SandcastleBuilder.Utils.Controls Namespace


RefreshableItemListBox Members

[image] [image]

Sandcastle Help File Builder Documentation
RefreshableItemListBox Members
RefreshableItemListBox Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The RefreshableItemListBox type exposes the following members.

Constructors

Name | Description
RefreshableItemListBox | Initializes a new instance of the RefreshableItemListBox class

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemsCore | Obsolete. This member is obsolete, and there is no replacement. (Inherited from ListBox.)
BeginInvoke | Overloaded.
BeginUpdate | Maintains performance while items are added to the ListBox one at a time by preventing the control from drawing until the EndUpdate()()() method is called. (Inherited from ListBox.)
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
ClearSelected | Unselects all items in the ListBox. (Inherited from ListBox.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateItemCollection | Creates a new instance of the item collection. (Inherited from ListBox.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
EndUpdate | Resumes painting the ListBox control after painting is suspended by the BeginUpdate()()() method. (Inherited from ListBox.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
FilterItemOnProperty | Overloaded.
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
FindString | Overloaded.
FindStringExact | Overloaded.
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetItemHeight | Returns the height of an item in the ListBox. (Inherited from ListBox.)
GetItemRectangle | Returns the bounding rectangle for an item in the ListBox. (Inherited from ListBox.)
GetItemText | Returns the text representation of the specified item. (Inherited from ListControl.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the ListBox is scaled. (Inherited from ListBox.)
GetSelected | Returns a value indicating whether the specified item is selected. (Inherited from ListBox.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
IndexFromPoint | Overloaded.
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Handles special input keys, such as PAGE UP, PAGE DOWN, HOME, END, and so on. (Inherited from ListControl.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | (Inherited from ListControl.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | (Inherited from ListBox.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl()()() method. (Inherited from Control.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDataSourceChanged | (Inherited from ListBox.)
OnDisplayMemberChanged | (Inherited from ListBox.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnDrawItem | Raises the DrawItem event. (Inherited from ListBox.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | (Inherited from ListBox.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormat | Raises the Format event. (Inherited from ListControl.)
OnFormatInfoChanged | Raises the FormatInfoChanged event. (Inherited from ListControl.)
OnFormatStringChanged | Raises the FormatStringChanged event. (Inherited from ListControl.)
OnFormattingEnabledChanged | Raises the FormattingEnabledChanged event. (Inherited from ListControl.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Specifies when the window handle has been created so that column width and other characteristics can be set. Inheriting classes should call base.OnHandleCreated. (Inherited from ListBox.)
OnHandleDestroyed | Overridden to be sure that items are set up and cleared out correctly. Inheriting controls should call base.OnHandleDestroyed. (Inherited from ListBox.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | Raises the Layout event. (Inherited from Control.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMeasureItem | Raises the MeasureItem event. (Inherited from ListBox.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | Paints the background of the control. (Inherited from Control.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ListBox.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from ListBox.)
OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
OnSelectedIndexChanged | (Inherited from ListBox.)
OnSelectedValueChanged | (Inherited from ListBox.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnValueMemberChanged | Raises the ValueMemberChanged event. (Inherited from ListControl.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Control.)
ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Overloaded.
RefreshItem | Refreshes the item contained at the specified index. (Inherited from ListBox.)
RefreshItems | Refreshes all ListBox items and retrieves new strings for them. (Inherited from ListBox.)
ResetBackColor | (Inherited from ListBox.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | (Inherited from ListBox.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ListBox.)
ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Sets the specified bounds of the ListBox control. (Inherited from ListBox.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetItemCore | Sets the object with the specified index in the derived class. (Inherited from ListBox.)
SetItemsCore | Clears the contents of the ListBox and adds the specified items to the control. (Inherited from ListBox.)
SetSelected | Selects or clears the selection for the specified item in a ListBox. (Inherited from ListBox.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Sort | Sorts the items in the ListBox. (Inherited from ListBox.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a string representation of the ListBox. (Inherited from ListBox.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
WmReflectCommand | Processes the command message the ListView control receives from the top-level window. (Inherited from ListBox.)
WndProc | The list's window procedure. (Inherited from ListBox.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowSelection | Gets a value indicating whether the ListBox currently enables selection of list items. (Inherited from ListBox.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoSize | This property is not relevant for this class. (Inherited from Control.)
BackColor | (Inherited from ListBox.)
BackgroundImage | This property is not relevant to this class. (Inherited from ListBox.)
BackgroundImageLayout | Gets or sets the background image layout for a ListBox as defined in the ImageLayout enumeration. (Inherited from ListBox.)
BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
BorderStyle | Gets or sets the type of border that is drawn around the ListBox. (Inherited from ListBox.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
ColumnWidth | Gets or sets the width of columns in a multicolumn ListBox. (Inherited from ListBox.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from ListBox.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
CustomTabOffsets | Gets the width of the tabs between the items in the ListBox. (Inherited from ListBox.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DataManager | Gets the CurrencyManager associated with this control. (Inherited from ListControl.)
DataSource | Gets or sets the data source for this ListControl. (Inherited from ListControl.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from ListBox.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayMember | Gets or sets the property to display for this ListControl. (Inherited from ListControl.)
DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
DrawMode | Gets or sets the drawing mode for the control. (Inherited from ListBox.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | (Inherited from ListBox.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | (Inherited from ListBox.)
FormatInfo | Gets or sets the IFormatProvider that provides custom formatting behavior. (Inherited from ListControl.)
FormatString | Gets or sets the format-specifier characters that indicate how a value is to be displayed. (Inherited from ListControl.)
FormattingEnabled | Gets or sets a value indicating whether formatting is applied to the DisplayMember property of the ListControl. (Inherited from ListControl.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalExtent | Gets or sets the width by which the horizontal scroll bar of a ListBox can scroll. (Inherited from ListBox.)
HorizontalScrollbar | Gets or sets a value indicating whether a horizontal scroll bar is displayed in the control. (Inherited from ListBox.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
IntegralHeight | Gets or sets a value indicating whether the control should resize to avoid showing partial items. (Inherited from ListBox.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
ItemHeight | Gets or sets the height of an item in the ListBox. (Inherited from ListBox.)
Items | Gets the items of the ListBox. (Inherited from ListBox.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MultiColumn | Gets or sets a value indicating whether the ListBox supports multiple columns. (Inherited from ListBox.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | This property is not relevant to this class. (Inherited from ListBox.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
PreferredHeight | Gets the combined height of all items in the ListBox. (Inherited from ListBox.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether text displayed by the control is displayed from right to left. (Inherited from ListBox.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ScrollAlwaysVisible | Gets or sets a value indicating whether the vertical scroll bar is shown at all times. (Inherited from ListBox.)
SelectedIndex | Gets or sets the zero-based index of the currently selected item in a ListBox. (Inherited from ListBox.)
SelectedIndices | Gets a collection that contains the zero-based indexes of all currently selected items in the ListBox. (Inherited from ListBox.)
SelectedItem | Gets or sets the currently selected item in the ListBox. (Inherited from ListBox.)
SelectedItems | Gets a collection containing the currently selected items in the ListBox. (Inherited from ListBox.)
SelectedValue | Gets or sets the value of the member property specified by the ValueMember property. (Inherited from ListControl.)
SelectionMode | Gets or sets the method in which items are selected in the ListBox. (Inherited from ListBox.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
Sorted | Gets or sets a value indicating whether the items in the ListBox are sorted alphabetically. (Inherited from ListBox.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | Gets or searches for the text of the currently selected item in the ListBox. (Inherited from ListBox.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopIndex | Gets or sets the index of the first visible item in the ListBox. (Inherited from ListBox.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseCustomTabOffsets | Gets or sets a value indicating whether the ListBox recognizes and expands tab characters when it draws its strings by using the CustomTabOffsets integer array. (Inherited from ListBox.)
UseTabStops | Gets or sets a value indicating whether the ListBox can recognize and expand tab characters when drawing its strings. (Inherited from ListBox.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
ValueMember | Gets or sets the property to use as the actual value for the items in the ListControl. (Inherited from ListControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the BackgroundImage property of the label changes. (Inherited from ListBox.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from ListBox.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the ListBox control is clicked. (Inherited from ListBox.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
DataSourceChanged | Occurs when the DataSource changes. (Inherited from ListControl.)
DisplayMemberChanged | Occurs when the DisplayMember property changes. (Inherited from ListControl.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
DrawItem | Occurs when a visual aspect of an owner-drawn ListBox changes. (Inherited from ListBox.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Format | Occurs when the control is bound to a data value. (Inherited from ListControl.)
FormatInfoChanged | Occurs when the value of the FormatInfo property changes. (Inherited from ListControl.)
FormatStringChanged | Occurs when value of the FormatString property changes (Inherited from ListControl.)
FormattingEnabledChanged | Occurs when the value of the FormattingEnabled property changes. (Inherited from ListControl.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MeasureItem | Occurs when an owner-drawn ListBox is created and the sizes of the list items are determined. (Inherited from ListBox.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the user clicks the ListBox control with the mouse pointer. (Inherited from ListBox.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the value of the Padding property changes. (Inherited from ListBox.)
Paint | Occurs when the ListBox control is painted. (Inherited from ListBox.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
SelectedIndexChanged | Occurs when the SelectedIndex property has changed. (Inherited from ListBox.)
SelectedValueChanged | Occurs when the SelectedValue property changes. (Inherited from ListControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | Occurs when the Text property is changed. (Inherited from ListBox.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
ValueMemberChanged | Occurs when the ValueMember property changes. (Inherited from ListControl.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

RefreshableItemListBox Class
SandcastleBuilder.Utils.Controls Namespace


RefreshableItemListBox Constructor

[image]

Sandcastle Help File Builder Documentation
RefreshableItemListBox Constructor
RefreshableItemListBox Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the RefreshableItemListBox class

Namespace: SandcastleBuilder.Utils.Controls
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public RefreshableItemListBox()
Visual Basic (Declaration)
Public Sub New

See Also

RefreshableItemListBox Class
SandcastleBuilder.Utils.Controls Namespace


RefreshableItemListBox Methods

[image] [image]

Sandcastle Help File Builder Documentation
RefreshableItemListBox Methods
RefreshableItemListBox Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The RefreshableItemListBox type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemsCore | Obsolete. This member is obsolete, and there is no replacement. (Inherited from ListBox.)
BeginInvoke | Overloaded.
BeginUpdate | Maintains performance while items are added to the ListBox one at a time by preventing the control from drawing until the EndUpdate()()() method is called. (Inherited from ListBox.)
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
ClearSelected | Unselects all items in the ListBox. (Inherited from ListBox.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateItemCollection | Creates a new instance of the item collection. (Inherited from ListBox.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
EndUpdate | Resumes painting the ListBox control after painting is suspended by the BeginUpdate()()() method. (Inherited from ListBox.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
FilterItemOnProperty | Overloaded.
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
FindString | Overloaded.
FindStringExact | Overloaded.
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetItemHeight | Returns the height of an item in the ListBox. (Inherited from ListBox.)
GetItemRectangle | Returns the bounding rectangle for an item in the ListBox. (Inherited from ListBox.)
GetItemText | Returns the text representation of the specified item. (Inherited from ListControl.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the ListBox is scaled. (Inherited from ListBox.)
GetSelected | Returns a value indicating whether the specified item is selected. (Inherited from ListBox.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
IndexFromPoint | Overloaded.
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Handles special input keys, such as PAGE UP, PAGE DOWN, HOME, END, and so on. (Inherited from ListControl.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | (Inherited from ListControl.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | (Inherited from ListBox.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl()()() method. (Inherited from Control.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDataSourceChanged | (Inherited from ListBox.)
OnDisplayMemberChanged | (Inherited from ListBox.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnDrawItem | Raises the DrawItem event. (Inherited from ListBox.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | (Inherited from ListBox.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormat | Raises the Format event. (Inherited from ListControl.)
OnFormatInfoChanged | Raises the FormatInfoChanged event. (Inherited from ListControl.)
OnFormatStringChanged | Raises the FormatStringChanged event. (Inherited from ListControl.)
OnFormattingEnabledChanged | Raises the FormattingEnabledChanged event. (Inherited from ListControl.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Specifies when the window handle has been created so that column width and other characteristics can be set. Inheriting classes should call base.OnHandleCreated. (Inherited from ListBox.)
OnHandleDestroyed | Overridden to be sure that items are set up and cleared out correctly. Inheriting controls should call base.OnHandleDestroyed. (Inherited from ListBox.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | Raises the Layout event. (Inherited from Control.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMeasureItem | Raises the MeasureItem event. (Inherited from ListBox.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | Paints the background of the control. (Inherited from Control.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ListBox.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from ListBox.)
OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
OnSelectedIndexChanged | (Inherited from ListBox.)
OnSelectedValueChanged | (Inherited from ListBox.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnValueMemberChanged | Raises the ValueMemberChanged event. (Inherited from ListControl.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Control.)
ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Overloaded.
RefreshItem | Refreshes the item contained at the specified index. (Inherited from ListBox.)
RefreshItems | Refreshes all ListBox items and retrieves new strings for them. (Inherited from ListBox.)
ResetBackColor | (Inherited from ListBox.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | (Inherited from ListBox.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ListBox.)
ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Sets the specified bounds of the ListBox control. (Inherited from ListBox.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetItemCore | Sets the object with the specified index in the derived class. (Inherited from ListBox.)
SetItemsCore | Clears the contents of the ListBox and adds the specified items to the control. (Inherited from ListBox.)
SetSelected | Selects or clears the selection for the specified item in a ListBox. (Inherited from ListBox.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Sort | Sorts the items in the ListBox. (Inherited from ListBox.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a string representation of the ListBox. (Inherited from ListBox.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
WmReflectCommand | Processes the command message the ListView control receives from the top-level window. (Inherited from ListBox.)
WndProc | The list's window procedure. (Inherited from ListBox.)

See Also

RefreshableItemListBox Class
SandcastleBuilder.Utils.Controls Namespace


AccessibilityNotifyClients Method

[image] [image]

Sandcastle Help File Builder Documentation
RefreshableItemListBox..::.AccessibilityNotifyClients Method
RefreshableItemListBox Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

RefreshableItemListBox Class
RefreshableItemListBox Members
SandcastleBuilder.Utils.Controls Namespace


BeginInvoke Method

[image] [image]

Sandcastle Help File Builder Documentation
RefreshableItemListBox..::.BeginInvoke Method
RefreshableItemListBox Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

RefreshableItemListBox Class
RefreshableItemListBox Members
SandcastleBuilder.Utils.Controls Namespace


Dispose Method

[image] [image]

Sandcastle Help File Builder Documentation
RefreshableItemListBox..::.Dispose Method
RefreshableItemListBox Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control.)

See Also

RefreshableItemListBox Class
RefreshableItemListBox Members
SandcastleBuilder.Utils.Controls Namespace


FilterItemOnProperty Method

[image] [image]

Sandcastle Help File Builder Documentation
RefreshableItemListBox..::.FilterItemOnProperty Method
RefreshableItemListBox Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
FilterItemOnProperty(Object) | Retrieves the current value of the ListControl item, if it is a property of an object, given the item. (Inherited from ListControl.)
FilterItemOnProperty(Object, String) | Returns the current value of the ListControl item, if it is a property of an object given the item and the property name. (Inherited from ListControl.)

See Also

RefreshableItemListBox Class
RefreshableItemListBox Members
SandcastleBuilder.Utils.Controls Namespace


FindString Method

[image] [image]

Sandcastle Help File Builder Documentation
RefreshableItemListBox..::.FindString Method
RefreshableItemListBox Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
FindString(String) | Finds the first item in the ListBox that starts with the specified string. (Inherited from ListBox.)
FindString(String, Int32) | Finds the first item in the ListBox that starts with the specified string. The search starts at a specific starting index. (Inherited from ListBox.)

See Also

RefreshableItemListBox Class
RefreshableItemListBox Members
SandcastleBuilder.Utils.Controls Namespace


FindStringExact Method

[image] [image]

Sandcastle Help File Builder Documentation
RefreshableItemListBox..::.FindStringExact Method
RefreshableItemListBox Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
FindStringExact(String) | Finds the first item in the ListBox that exactly matches the specified string. (Inherited from ListBox.)
FindStringExact(String, Int32) | Finds the first item in the ListBox that exactly matches the specified string. The search starts at a specific starting index. (Inherited from ListBox.)

See Also

RefreshableItemListBox Class
RefreshableItemListBox Members
SandcastleBuilder.Utils.Controls Namespace


GetChildAtPoint Method

[image] [image]

Sandcastle Help File Builder Documentation
RefreshableItemListBox..::.GetChildAtPoint Method
RefreshableItemListBox Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

RefreshableItemListBox Class
RefreshableItemListBox Members
SandcastleBuilder.Utils.Controls Namespace


IndexFromPoint Method

[image] [image]

Sandcastle Help File Builder Documentation
RefreshableItemListBox..::.IndexFromPoint Method
RefreshableItemListBox Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IndexFromPoint(Point) | Returns the zero-based index of the item at the specified coordinates. (Inherited from ListBox.)
IndexFromPoint(Int32, Int32) | Returns the zero-based index of the item at the specified coordinates. (Inherited from ListBox.)

See Also

RefreshableItemListBox Class
RefreshableItemListBox Members
SandcastleBuilder.Utils.Controls Namespace


Invalidate Method

[image] [image]

Sandcastle Help File Builder Documentation
RefreshableItemListBox..::.Invalidate Method
RefreshableItemListBox Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

RefreshableItemListBox Class
RefreshableItemListBox Members
SandcastleBuilder.Utils.Controls Namespace


Invoke Method

[image] [image]

Sandcastle Help File Builder Documentation
RefreshableItemListBox..::.Invoke Method
RefreshableItemListBox Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

RefreshableItemListBox Class
RefreshableItemListBox Members
SandcastleBuilder.Utils.Controls Namespace


MemberwiseClone Method

[image] [image]

Sandcastle Help File Builder Documentation
RefreshableItemListBox..::.MemberwiseClone Method
RefreshableItemListBox Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

RefreshableItemListBox Class
RefreshableItemListBox Members
SandcastleBuilder.Utils.Controls Namespace


PerformLayout Method

[image] [image]

Sandcastle Help File Builder Documentation
RefreshableItemListBox..::.PerformLayout Method
RefreshableItemListBox Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

RefreshableItemListBox Class
RefreshableItemListBox Members
SandcastleBuilder.Utils.Controls Namespace


Refresh Method

[image] [image]

Sandcastle Help File Builder Documentation
RefreshableItemListBox..::.Refresh Method
RefreshableItemListBox Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Refresh()()() | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from ListBox.)
Refresh(Int32) | Refresh the specified item in the list box

See Also

RefreshableItemListBox Class
RefreshableItemListBox Members
SandcastleBuilder.Utils.Controls Namespace


Refresh Method (Int32)

[image]

Sandcastle Help File Builder Documentation
RefreshableItemListBox..::.Refresh Method (Int32)
RefreshableItemListBox Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Refresh the specified item in the list box

Namespace: SandcastleBuilder.Utils.Controls
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public void Refresh(
    int index
)
Visual Basic (Declaration)
Public Sub Refresh ( _
    index As Integer _
)

Parameters

index
Type: System..::.Int32
The index of the item to refresh

See Also

RefreshableItemListBox Class
Refresh Overload
SandcastleBuilder.Utils.Controls Namespace


ResumeLayout Method

[image] [image]

Sandcastle Help File Builder Documentation
RefreshableItemListBox..::.ResumeLayout Method
RefreshableItemListBox Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

RefreshableItemListBox Class
RefreshableItemListBox Members
SandcastleBuilder.Utils.Controls Namespace


RtlTranslateAlignment Method

[image] [image]

Sandcastle Help File Builder Documentation
RefreshableItemListBox..::.RtlTranslateAlignment Method
RefreshableItemListBox Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

RefreshableItemListBox Class
RefreshableItemListBox Members
SandcastleBuilder.Utils.Controls Namespace


Scale Method

[image] [image]

Sandcastle Help File Builder Documentation
RefreshableItemListBox..::.Scale Method
RefreshableItemListBox Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

RefreshableItemListBox Class
RefreshableItemListBox Members
SandcastleBuilder.Utils.Controls Namespace


Select Method

[image] [image]

Sandcastle Help File Builder Documentation
RefreshableItemListBox..::.Select Method
RefreshableItemListBox Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

RefreshableItemListBox Class
RefreshableItemListBox Members
SandcastleBuilder.Utils.Controls Namespace


SetBounds Method

[image] [image]

Sandcastle Help File Builder Documentation
RefreshableItemListBox..::.SetBounds Method
RefreshableItemListBox Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

RefreshableItemListBox Class
RefreshableItemListBox Members
SandcastleBuilder.Utils.Controls Namespace


UpdateBounds Method

[image] [image]

Sandcastle Help File Builder Documentation
RefreshableItemListBox..::.UpdateBounds Method
RefreshableItemListBox Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

RefreshableItemListBox Class
RefreshableItemListBox Members
SandcastleBuilder.Utils.Controls Namespace


RefreshableItemListBox Properties

[image] [image]

Sandcastle Help File Builder Documentation
RefreshableItemListBox Properties
RefreshableItemListBox Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The RefreshableItemListBox type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowSelection | Gets a value indicating whether the ListBox currently enables selection of list items. (Inherited from ListBox.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoSize | This property is not relevant for this class. (Inherited from Control.)
BackColor | (Inherited from ListBox.)
BackgroundImage | This property is not relevant to this class. (Inherited from ListBox.)
BackgroundImageLayout | Gets or sets the background image layout for a ListBox as defined in the ImageLayout enumeration. (Inherited from ListBox.)
BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
BorderStyle | Gets or sets the type of border that is drawn around the ListBox. (Inherited from ListBox.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
ColumnWidth | Gets or sets the width of columns in a multicolumn ListBox. (Inherited from ListBox.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from ListBox.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
CustomTabOffsets | Gets the width of the tabs between the items in the ListBox. (Inherited from ListBox.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DataManager | Gets the CurrencyManager associated with this control. (Inherited from ListControl.)
DataSource | Gets or sets the data source for this ListControl. (Inherited from ListControl.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from ListBox.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayMember | Gets or sets the property to display for this ListControl. (Inherited from ListControl.)
DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
DrawMode | Gets or sets the drawing mode for the control. (Inherited from ListBox.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | (Inherited from ListBox.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | (Inherited from ListBox.)
FormatInfo | Gets or sets the IFormatProvider that provides custom formatting behavior. (Inherited from ListControl.)
FormatString | Gets or sets the format-specifier characters that indicate how a value is to be displayed. (Inherited from ListControl.)
FormattingEnabled | Gets or sets a value indicating whether formatting is applied to the DisplayMember property of the ListControl. (Inherited from ListControl.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalExtent | Gets or sets the width by which the horizontal scroll bar of a ListBox can scroll. (Inherited from ListBox.)
HorizontalScrollbar | Gets or sets a value indicating whether a horizontal scroll bar is displayed in the control. (Inherited from ListBox.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
IntegralHeight | Gets or sets a value indicating whether the control should resize to avoid showing partial items. (Inherited from ListBox.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
ItemHeight | Gets or sets the height of an item in the ListBox. (Inherited from ListBox.)
Items | Gets the items of the ListBox. (Inherited from ListBox.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MultiColumn | Gets or sets a value indicating whether the ListBox supports multiple columns. (Inherited from ListBox.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | This property is not relevant to this class. (Inherited from ListBox.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
PreferredHeight | Gets the combined height of all items in the ListBox. (Inherited from ListBox.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether text displayed by the control is displayed from right to left. (Inherited from ListBox.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ScrollAlwaysVisible | Gets or sets a value indicating whether the vertical scroll bar is shown at all times. (Inherited from ListBox.)
SelectedIndex | Gets or sets the zero-based index of the currently selected item in a ListBox. (Inherited from ListBox.)
SelectedIndices | Gets a collection that contains the zero-based indexes of all currently selected items in the ListBox. (Inherited from ListBox.)
SelectedItem | Gets or sets the currently selected item in the ListBox. (Inherited from ListBox.)
SelectedItems | Gets a collection containing the currently selected items in the ListBox. (Inherited from ListBox.)
SelectedValue | Gets or sets the value of the member property specified by the ValueMember property. (Inherited from ListControl.)
SelectionMode | Gets or sets the method in which items are selected in the ListBox. (Inherited from ListBox.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
Sorted | Gets or sets a value indicating whether the items in the ListBox are sorted alphabetically. (Inherited from ListBox.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | Gets or searches for the text of the currently selected item in the ListBox. (Inherited from ListBox.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopIndex | Gets or sets the index of the first visible item in the ListBox. (Inherited from ListBox.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseCustomTabOffsets | Gets or sets a value indicating whether the ListBox recognizes and expands tab characters when it draws its strings by using the CustomTabOffsets integer array. (Inherited from ListBox.)
UseTabStops | Gets or sets a value indicating whether the ListBox can recognize and expand tab characters when drawing its strings. (Inherited from ListBox.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
ValueMember | Gets or sets the property to use as the actual value for the items in the ListControl. (Inherited from ListControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

RefreshableItemListBox Class
SandcastleBuilder.Utils.Controls Namespace


RefreshableItemListBox Events

[image] [image]

Sandcastle Help File Builder Documentation
RefreshableItemListBox Events
RefreshableItemListBox Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The RefreshableItemListBox type exposes the following members.

Events

Name | Description
AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the BackgroundImage property of the label changes. (Inherited from ListBox.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from ListBox.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the ListBox control is clicked. (Inherited from ListBox.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
DataSourceChanged | Occurs when the DataSource changes. (Inherited from ListControl.)
DisplayMemberChanged | Occurs when the DisplayMember property changes. (Inherited from ListControl.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
DrawItem | Occurs when a visual aspect of an owner-drawn ListBox changes. (Inherited from ListBox.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Format | Occurs when the control is bound to a data value. (Inherited from ListControl.)
FormatInfoChanged | Occurs when the value of the FormatInfo property changes. (Inherited from ListControl.)
FormatStringChanged | Occurs when value of the FormatString property changes (Inherited from ListControl.)
FormattingEnabledChanged | Occurs when the value of the FormattingEnabled property changes. (Inherited from ListControl.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MeasureItem | Occurs when an owner-drawn ListBox is created and the sizes of the list items are determined. (Inherited from ListBox.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the user clicks the ListBox control with the mouse pointer. (Inherited from ListBox.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the value of the Padding property changes. (Inherited from ListBox.)
Paint | Occurs when the ListBox control is painted. (Inherited from ListBox.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
SelectedIndexChanged | Occurs when the SelectedIndex property has changed. (Inherited from ListBox.)
SelectedValueChanged | Occurs when the SelectedValue property changes. (Inherited from ListControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | Occurs when the Text property is changed. (Inherited from ListBox.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
ValueMemberChanged | Occurs when the ValueMember property changes. (Inherited from ListControl.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

RefreshableItemListBox Class
SandcastleBuilder.Utils.Controls Namespace


StatusBarTextProvider Class

[image]

Sandcastle Help File Builder Documentation
StatusBarTextProvider Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is an IExtenderProvider component that allows you to add status bar text for menu items and form controls. When built for use with .NET 2.0, it also supports adding status bar text for menu strip, tool strip, and status strip components.

Namespace: SandcastleBuilder.Utils.Controls
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public class StatusBarTextProvider : Component,
    IExtenderProvider
Visual Basic (Declaration)
Public Class StatusBarTextProvider _
    Inherits Component _
    Implements IExtenderProvider

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
SandcastleBuilder.Utils.Controls..::.StatusBarTextProvider

See Also

StatusBarTextProvider Members
SandcastleBuilder.Utils.Controls Namespace


StatusBarTextProvider Members

[image] [image]

Sandcastle Help File Builder Documentation
StatusBarTextProvider Members
StatusBarTextProvider Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The StatusBarTextProvider type exposes the following members.

Constructors

Name | Description
StatusBarTextProvider | Overloaded. There are two overloads for the constructor

Methods

Name | Description
CanExtend | This is implemented to determine if the component can be extended with the extra properties.
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetShowAsBlank | This is used to retrieve the "show as blank" flag for a menu item or control.
GetStatusBarText | This is used to retrieve the status bar text for a component.
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitializeProgressBar | Overloaded. There are six overloads for this method.
MemberwiseClone | Overloaded.
ResetProgressBar | Overloaded. There are two overloads for this method.
SetShowAsBlank | This stores the "show as blank" flag for the specified component.
SetStatusBarText | This stores the status bar text for the specified component.
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateProgress | Overloaded. There are four overloads for this method

Properties

Name | Description
ApplicationDefaultText | This is used to set or get the default text to show when no item has the focus or no status text for the application status bar.
ApplicationDisplayPanel | This is used to set or get the status bar panel in which to display the messages in the common application status bar.
ApplicationStatusBar | This is used to set or get the default status bar component to use for displaying the status bar text messages.
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
InstanceDefaultText | This is used to set or get the default text to show when no item has the focus or no status text for the instance status bar.
InstanceDisplayPanel | This is used to set or get the status bar panel in which to display the messages when the InstanceStatusBar property is set to a status bar.
InstanceStatusBar | This is used to get or set the status bar component to use for this instance.
ProgressBar | This is used to get or set the tool strip progress bar component that can be used to display progress through a long running task.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
StatusLabel | This is used to get or set the tool strip status label component that can be used to display a status message in conjunction with the ProgressBar component.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

StatusBarTextProvider Class
SandcastleBuilder.Utils.Controls Namespace


StatusBarTextProvider Constructor

[image] [image]

Sandcastle Help File Builder Documentation
StatusBarTextProvider Constructor
StatusBarTextProvider Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

There are two overloads for the constructor

Overload List

Name | Description
StatusBarTextProvider()()() | Default constructor
StatusBarTextProvider(IContainer) | Constructor. This one takes a reference to a container.

See Also

StatusBarTextProvider Class
StatusBarTextProvider Members
SandcastleBuilder.Utils.Controls Namespace


StatusBarTextProvider Constructor

[image]

Sandcastle Help File Builder Documentation
StatusBarTextProvider Constructor
StatusBarTextProvider Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Default constructor

Namespace: SandcastleBuilder.Utils.Controls
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public StatusBarTextProvider()
Visual Basic (Declaration)
Public Sub New

See Also

StatusBarTextProvider Class
StatusBarTextProvider Overload
SandcastleBuilder.Utils.Controls Namespace


StatusBarTextProvider Constructor (IContainer)

[image]

Sandcastle Help File Builder Documentation
StatusBarTextProvider Constructor (IContainer)
StatusBarTextProvider Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor. This one takes a reference to a container.

Namespace: SandcastleBuilder.Utils.Controls
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public StatusBarTextProvider(
    IContainer container
)
Visual Basic (Declaration)
Public Sub New ( _
    container As IContainer _
)

Parameters

container
Type: System.ComponentModel..::.IContainer
The container for the component

See Also

StatusBarTextProvider Class
StatusBarTextProvider Overload
SandcastleBuilder.Utils.Controls Namespace


StatusBarTextProvider Methods

[image] [image]

Sandcastle Help File Builder Documentation
StatusBarTextProvider Methods
StatusBarTextProvider Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The StatusBarTextProvider type exposes the following members.

Methods

Name | Description
CanExtend | This is implemented to determine if the component can be extended with the extra properties.
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetShowAsBlank | This is used to retrieve the "show as blank" flag for a menu item or control.
GetStatusBarText | This is used to retrieve the status bar text for a component.
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitializeProgressBar | Overloaded. There are six overloads for this method.
MemberwiseClone | Overloaded.
ResetProgressBar | Overloaded. There are two overloads for this method.
SetShowAsBlank | This stores the "show as blank" flag for the specified component.
SetStatusBarText | This stores the status bar text for the specified component.
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateProgress | Overloaded. There are four overloads for this method

See Also

StatusBarTextProvider Class
SandcastleBuilder.Utils.Controls Namespace


CanExtend Method

[image]

Sandcastle Help File Builder Documentation
StatusBarTextProvider..::.CanExtend Method
StatusBarTextProvider Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is implemented to determine if the component can be extended with the extra properties.

Namespace: SandcastleBuilder.Utils.Controls
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool CanExtend(
    Object extendee
)
Visual Basic (Declaration)
Public Function CanExtend ( _
    extendee As Object _
) As Boolean

Parameters

extendee
Type: System..::.Object
The object to check

Return Value

True if it can be extended, false if not

Implements

IExtenderProvider..::.CanExtend(Object)

Remarks

MenuItem components and everything derived from ToolStripItem (.NET 2.0) and Control are extended with the StatusBarText and ShowAsBlank properties with the following exceptions: Form, Label, PictureBox, ProgressBar, ScrollBar, Splitter, StatusBar, ToolBar, ToolStrip (.NET 2.0) and controls derived from them. The Form contain controls and the other controls cannot receive the focus needed to display the text so there is no point in giving them status bar text. The exception to the above rule is LinkLabel which can receive the focus and thus can be extended. ToolStripItem components are only supported when built for use with .NET 2.0.

See Also

StatusBarTextProvider Class
SandcastleBuilder.Utils.Controls Namespace


Dispose Method

[image] [image]

Sandcastle Help File Builder Documentation
StatusBarTextProvider..::.Dispose Method
StatusBarTextProvider Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides Component..::.Dispose(Boolean).)

See Also

StatusBarTextProvider Class
StatusBarTextProvider Members
SandcastleBuilder.Utils.Controls Namespace


Dispose Method (Boolean)

[image]

Sandcastle Help File Builder Documentation
StatusBarTextProvider..::.Dispose Method (Boolean)
StatusBarTextProvider Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: SandcastleBuilder.Utils.Controls
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
True to release both managed and unmanaged resources, false to just release unmanaged resources.

See Also

StatusBarTextProvider Class
Dispose Overload
SandcastleBuilder.Utils.Controls Namespace


GetShowAsBlank Method

[image]

Sandcastle Help File Builder Documentation
StatusBarTextProvider..::.GetShowAsBlank Method
StatusBarTextProvider Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to retrieve the "show as blank" flag for a menu item or control.

Namespace: SandcastleBuilder.Utils.Controls
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool GetShowAsBlank(
    Component comp
)
Visual Basic (Declaration)
Public Function GetShowAsBlank ( _
    comp As Component _
) As Boolean

Parameters

comp
Type: System.ComponentModel..::.Component
The item for which to get the flag

Return Value

True if it will show a blank status bar message or false if not.

Exceptions

Exception | Condition
System..::.ArgumentException | This is thrown if the component is null or if it is not a menu item, control, or a tool strip item.

See Also

StatusBarTextProvider Class
SandcastleBuilder.Utils.Controls Namespace


GetStatusBarText Method

[image]

Sandcastle Help File Builder Documentation
StatusBarTextProvider..::.GetStatusBarText Method
StatusBarTextProvider Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to retrieve the status bar text for a component.

Namespace: SandcastleBuilder.Utils.Controls
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string GetStatusBarText(
    Component comp
)
Visual Basic (Declaration)
Public Function GetStatusBarText ( _
    comp As Component _
) As String

Parameters

comp
Type: System.ComponentModel..::.Component
The component for which to get the status bar text

Return Value

The message string if found or null if not found

Exceptions

Exception | Condition
System..::.ArgumentException | This is thrown if the component is null or if it is not a menu item, control, or a tool strip item.

See Also

StatusBarTextProvider Class
SandcastleBuilder.Utils.Controls Namespace


InitializeProgressBar Method

[image] [image]

Sandcastle Help File Builder Documentation
StatusBarTextProvider..::.InitializeProgressBar Method
StatusBarTextProvider Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

There are six overloads for this method.

Overload List

Name | Description
InitializeProgressBar(Int32) | This can be used to initialize the status strip progress bar controls.
InitializeProgressBar(Int32, Int32) | This can be used to initialize the status strip progress bar controls.
InitializeProgressBar(Int32, String) | This can be used to initialize the status strip progress bar controls.
InitializeProgressBar(Int32, Int32, Int32) | This can be used to initialize the status strip progress bar controls.
InitializeProgressBar(Int32, Int32, String) | This can be used to initialize the status strip progress bar controls.
InitializeProgressBar(Int32, Int32, Int32, Int32, String) | This can be used to initialize the status strip progress bar controls.

See Also

StatusBarTextProvider Class
StatusBarTextProvider Members
SandcastleBuilder.Utils.Controls Namespace


InitializeProgressBar Method (Int32)

[image]

Sandcastle Help File Builder Documentation
StatusBarTextProvider..::.InitializeProgressBar Method (Int32)
StatusBarTextProvider Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This can be used to initialize the status strip progress bar controls.

Namespace: SandcastleBuilder.Utils.Controls
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public static void InitializeProgressBar(
    int maximum
)
Visual Basic (Declaration)
Public Shared Sub InitializeProgressBar ( _
    maximum As Integer _
)

Parameters

maximum
Type: System..::.Int32
The maximum value

See Also

StatusBarTextProvider Class
InitializeProgressBar Overload
SandcastleBuilder.Utils.Controls Namespace


InitializeProgressBar Method (Int32, Int32)

[image]

Sandcastle Help File Builder Documentation
StatusBarTextProvider..::.InitializeProgressBar Method (Int32, Int32)
StatusBarTextProvider Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This can be used to initialize the status strip progress bar controls.

Namespace: SandcastleBuilder.Utils.Controls
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public static void InitializeProgressBar(
    int minimum,
    int maximum
)
Visual Basic (Declaration)
Public Shared Sub InitializeProgressBar ( _
    minimum As Integer, _
    maximum As Integer _
)

Parameters

minimum
Type: System..::.Int32
The minimum value
maximum
Type: System..::.Int32
The maximum value

See Also

StatusBarTextProvider Class
InitializeProgressBar Overload
SandcastleBuilder.Utils.Controls Namespace


InitializeProgressBar Method (Int32, String)

[image]

Sandcastle Help File Builder Documentation
StatusBarTextProvider..::.InitializeProgressBar Method (Int32, String)
StatusBarTextProvider Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This can be used to initialize the status strip progress bar controls.

Namespace: SandcastleBuilder.Utils.Controls
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public static void InitializeProgressBar(
    int maximum,
    string progressNote
)
Visual Basic (Declaration)
Public Shared Sub InitializeProgressBar ( _
    maximum As Integer, _
    progressNote As String _
)

Parameters

maximum
Type: System..::.Int32
The maximum value
progressNote
Type: System..::.String
A note for the progress note status label control. If null, the current text is left alone.

See Also

StatusBarTextProvider Class
InitializeProgressBar Overload
SandcastleBuilder.Utils.Controls Namespace


InitializeProgressBar Method (Int32, Int32, Int32)

[image]

Sandcastle Help File Builder Documentation
StatusBarTextProvider..::.InitializeProgressBar Method (Int32, Int32, Int32)
StatusBarTextProvider Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This can be used to initialize the status strip progress bar controls.

Namespace: SandcastleBuilder.Utils.Controls
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public static void InitializeProgressBar(
    int minimum,
    int maximum,
    int current
)
Visual Basic (Declaration)
Public Shared Sub InitializeProgressBar ( _
    minimum As Integer, _
    maximum As Integer, _
    current As Integer _
)

Parameters

minimum
Type: System..::.Int32
The minimum value
maximum
Type: System..::.Int32
The maximum value
current
Type: System..::.Int32
The current value

See Also

StatusBarTextProvider Class
InitializeProgressBar Overload
SandcastleBuilder.Utils.Controls Namespace


InitializeProgressBar Method (Int32, Int32, String)

[image]

Sandcastle Help File Builder Documentation
StatusBarTextProvider..::.InitializeProgressBar Method (Int32, Int32, String)
StatusBarTextProvider Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This can be used to initialize the status strip progress bar controls.

Namespace: SandcastleBuilder.Utils.Controls
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public static void InitializeProgressBar(
    int minimum,
    int maximum,
    string progressNote
)
Visual Basic (Declaration)
Public Shared Sub InitializeProgressBar ( _
    minimum As Integer, _
    maximum As Integer, _
    progressNote As String _
)

Parameters

minimum
Type: System..::.Int32
The minimum value
maximum
Type: System..::.Int32
The maximum value
progressNote
Type: System..::.String
A note for the progress note status label control. If null, the current text is left alone.

See Also

StatusBarTextProvider Class
InitializeProgressBar Overload
SandcastleBuilder.Utils.Controls Namespace


InitializeProgressBar Method (Int32, Int32, Int32, Int32, String)

[image]

Sandcastle Help File Builder Documentation
StatusBarTextProvider..::.InitializeProgressBar Method (Int32, Int32, Int32, Int32, String)
StatusBarTextProvider Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This can be used to initialize the status strip progress bar controls.

Namespace: SandcastleBuilder.Utils.Controls
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public static void InitializeProgressBar(
    int minimum,
    int maximum,
    int current,
    int step,
    string progressNote
)
Visual Basic (Declaration)
Public Shared Sub InitializeProgressBar ( _
    minimum As Integer, _
    maximum As Integer, _
    current As Integer, _
    step As Integer, _
    progressNote As String _
)

Parameters

minimum
Type: System..::.Int32
The minimum value
maximum
Type: System..::.Int32
The maximum value
current
Type: System..::.Int32
The current value
step
Type: System..::.Int32
The step value for the progress bar
progressNote
Type: System..::.String
A note for the progress note status label control. If null, the current text is left alone.

See Also

StatusBarTextProvider Class
InitializeProgressBar Overload
SandcastleBuilder.Utils.Controls Namespace


MemberwiseClone Method

[image] [image]

Sandcastle Help File Builder Documentation
StatusBarTextProvider..::.MemberwiseClone Method
StatusBarTextProvider Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

StatusBarTextProvider Class
StatusBarTextProvider Members
SandcastleBuilder.Utils.Controls Namespace


ResetProgressBar Method

[image] [image]

Sandcastle Help File Builder Documentation
StatusBarTextProvider..::.ResetProgressBar Method
StatusBarTextProvider Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

There are two overloads for this method.

Overload List

Name | Description
ResetProgressBar()()() | This can be used to reset the status strip progress bar to its minimum value.
ResetProgressBar(String) | This can be used to reset the status strip progress bar to its minimum value and display a new progress message.

See Also

StatusBarTextProvider Class
StatusBarTextProvider Members
SandcastleBuilder.Utils.Controls Namespace


ResetProgressBar Method

[image]

Sandcastle Help File Builder Documentation
StatusBarTextProvider..::.ResetProgressBar Method
StatusBarTextProvider Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This can be used to reset the status strip progress bar to its minimum value.

Namespace: SandcastleBuilder.Utils.Controls
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public static void ResetProgressBar()
Visual Basic (Declaration)
Public Shared Sub ResetProgressBar

Remarks

This version resets the progress bar to zero and clears the progress note.

See Also

StatusBarTextProvider Class
ResetProgressBar Overload
SandcastleBuilder.Utils.Controls Namespace


ResetProgressBar Method (String)

[image]

Sandcastle Help File Builder Documentation
StatusBarTextProvider..::.ResetProgressBar Method (String)
StatusBarTextProvider Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This can be used to reset the status strip progress bar to its minimum value and display a new progress message.

Namespace: SandcastleBuilder.Utils.Controls
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public static void ResetProgressBar(
    string progressNote
)
Visual Basic (Declaration)
Public Shared Sub ResetProgressBar ( _
    progressNote As String _
)

Parameters

progressNote
Type: System..::.String
The progress note to display in the progress note status label. If set to null, the message is cleared.

See Also

StatusBarTextProvider Class
ResetProgressBar Overload
SandcastleBuilder.Utils.Controls Namespace


SetShowAsBlank Method

[image]

Sandcastle Help File Builder Documentation
StatusBarTextProvider..::.SetShowAsBlank Method
StatusBarTextProvider Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This stores the "show as blank" flag for the specified component.

Namespace: SandcastleBuilder.Utils.Controls
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public void SetShowAsBlank(
    Component comp,
    bool showBlank
)
Visual Basic (Declaration)
Public Sub SetShowAsBlank ( _
    comp As Component, _
    showBlank As Boolean _
)

Parameters

comp
Type: System.ComponentModel..::.Component
The component associated with the property
showBlank
Type: System..::.Boolean
The flag value for the component

Remarks

The designer converts strings containing nothing but spaces to empty strings and this equates to the default and the value is not serialized to code. If you want a blank string to display, set this property to true instead. This property takes precedence over the StatusBarText property.

Exceptions

Exception | Condition
System..::.ArgumentException | This is thrown if the component is null or if it is not a menu item, control, or a tool strip item.

See Also

StatusBarTextProvider Class
SandcastleBuilder.Utils.Controls Namespace


SetStatusBarText Method

[image]

Sandcastle Help File Builder Documentation
StatusBarTextProvider..::.SetStatusBarText Method
StatusBarTextProvider Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This stores the status bar text for the specified component.

Namespace: SandcastleBuilder.Utils.Controls
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public void SetStatusBarText(
    Component comp,
    string message
)
Visual Basic (Declaration)
Public Sub SetStatusBarText ( _
    comp As Component, _
    message As String _
)

Parameters

comp
Type: System.ComponentModel..::.Component
The component associated with the message
message
Type: System..::.String
The status bar text for the component

Remarks

The designer converts strings containing nothing but spaces to empty strings and won't serialize them to code. If you want a blank string to display, use SetShowAsBlank(Component, Boolean) to set the "show as blank" flag to true instead.

Exceptions

Exception | Condition
System..::.ArgumentException | This is thrown if the component is null or if it is not a menu item, control, or a tool strip item.

See Also

StatusBarTextProvider Class
SandcastleBuilder.Utils.Controls Namespace


UpdateProgress Method

[image] [image]

Sandcastle Help File Builder Documentation
StatusBarTextProvider..::.UpdateProgress Method
StatusBarTextProvider Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

There are four overloads for this method

Overload List

Name | Description
UpdateProgress()()() | This can be used to update the progress bar with a new value
UpdateProgress(Int32) | This can be used to update the progress bar with a new value
UpdateProgress(String) | This can be used to update the progress bar with a new value
UpdateProgress(Int32, String) | This can be used to update the progress bar with a new value

See Also

StatusBarTextProvider Class
StatusBarTextProvider Members
SandcastleBuilder.Utils.Controls Namespace


UpdateProgress Method

[image]

Sandcastle Help File Builder Documentation
StatusBarTextProvider..::.UpdateProgress Method
StatusBarTextProvider Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This can be used to update the progress bar with a new value

Namespace: SandcastleBuilder.Utils.Controls
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public static void UpdateProgress()
Visual Basic (Declaration)
Public Shared Sub UpdateProgress

Remarks

This version updates the progress by the step value.

See Also

StatusBarTextProvider Class
UpdateProgress Overload
SandcastleBuilder.Utils.Controls Namespace


UpdateProgress Method (Int32)

[image]

Sandcastle Help File Builder Documentation
StatusBarTextProvider..::.UpdateProgress Method (Int32)
StatusBarTextProvider Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This can be used to update the progress bar with a new value

Namespace: SandcastleBuilder.Utils.Controls
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public static void UpdateProgress(
    int current
)
Visual Basic (Declaration)
Public Shared Sub UpdateProgress ( _
    current As Integer _
)

Parameters

current
Type: System..::.Int32
The current value

See Also

StatusBarTextProvider Class
UpdateProgress Overload
SandcastleBuilder.Utils.Controls Namespace


UpdateProgress Method (String)

[image]

Sandcastle Help File Builder Documentation
StatusBarTextProvider..::.UpdateProgress Method (String)
StatusBarTextProvider Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This can be used to update the progress bar with a new value

Namespace: SandcastleBuilder.Utils.Controls
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public static void UpdateProgress(
    string progressNote
)
Visual Basic (Declaration)
Public Shared Sub UpdateProgress ( _
    progressNote As String _
)

Parameters

progressNote
Type: System..::.String
A note for the progress note status label control.

Remarks

This version updates the progress by the step value and updates the progress note.

See Also

StatusBarTextProvider Class
UpdateProgress Overload
SandcastleBuilder.Utils.Controls Namespace


UpdateProgress Method (Int32, String)

[image]

Sandcastle Help File Builder Documentation
StatusBarTextProvider..::.UpdateProgress Method (Int32, String)
StatusBarTextProvider Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This can be used to update the progress bar with a new value

Namespace: SandcastleBuilder.Utils.Controls
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public static void UpdateProgress(
    int current,
    string progressNote
)
Visual Basic (Declaration)
Public Shared Sub UpdateProgress ( _
    current As Integer, _
    progressNote As String _
)

Parameters

current
Type: System..::.Int32
The current value
progressNote
Type: System..::.String
A note for the progress note status label control. If null, the current text is left alone.

See Also

StatusBarTextProvider Class
UpdateProgress Overload
SandcastleBuilder.Utils.Controls Namespace


StatusBarTextProvider Properties

[image] [image]

Sandcastle Help File Builder Documentation
StatusBarTextProvider Properties
StatusBarTextProvider Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The StatusBarTextProvider type exposes the following members.

Properties

Name | Description
ApplicationDefaultText | This is used to set or get the default text to show when no item has the focus or no status text for the application status bar.
ApplicationDisplayPanel | This is used to set or get the status bar panel in which to display the messages in the common application status bar.
ApplicationStatusBar | This is used to set or get the default status bar component to use for displaying the status bar text messages.
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
InstanceDefaultText | This is used to set or get the default text to show when no item has the focus or no status text for the instance status bar.
InstanceDisplayPanel | This is used to set or get the status bar panel in which to display the messages when the InstanceStatusBar property is set to a status bar.
InstanceStatusBar | This is used to get or set the status bar component to use for this instance.
ProgressBar | This is used to get or set the tool strip progress bar component that can be used to display progress through a long running task.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
StatusLabel | This is used to get or set the tool strip status label component that can be used to display a status message in conjunction with the ProgressBar component.

See Also

StatusBarTextProvider Class
SandcastleBuilder.Utils.Controls Namespace


ApplicationDefaultText Property

[image]

Sandcastle Help File Builder Documentation
StatusBarTextProvider..::.ApplicationDefaultText Property
StatusBarTextProvider Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to set or get the default text to show when no item has the focus or no status text for the application status bar.

Namespace: SandcastleBuilder.Utils.Controls
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public static string ApplicationDefaultText { get; set; }
Visual Basic (Declaration)
Public Shared Property ApplicationDefaultText As String

Field Value

By default, it will be set to the text in the selected status bar component. If you set it to a different value, set this property after specifying the status bar control to use.

See Also

StatusBarTextProvider Class
SandcastleBuilder.Utils.Controls Namespace


ApplicationDisplayPanel Property

[image]

Sandcastle Help File Builder Documentation
StatusBarTextProvider..::.ApplicationDisplayPanel Property
StatusBarTextProvider Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to set or get the status bar panel in which to display the messages in the common application status bar.

Namespace: SandcastleBuilder.Utils.Controls
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public static int ApplicationDisplayPanel { get; set; }
Visual Basic (Declaration)
Public Shared Property ApplicationDisplayPanel As Integer

Field Value

This property is static and must be set at some point during application initialization. This display panel will be used unless the InstanceStatusBar property is set to override the status bar used. In that case, the InstanceDisplayPanel is used instead.

The default is zero (the first panel). If the status bar does not have panels, the index exceeds the panel count, or the status bar's ShowPanels property is false, messages will be shown in the status bar's Text property instead. This property is ignored if using a tool strip item to display the text.

See Also

StatusBarTextProvider Class
SandcastleBuilder.Utils.Controls Namespace
StatusBarTextProvider..::.ApplicationStatusBar
StatusBarTextProvider..::.InstanceStatusBar
StatusBarTextProvider..::.InstanceDisplayPanel


ApplicationStatusBar Property

[image]

Sandcastle Help File Builder Documentation
StatusBarTextProvider..::.ApplicationStatusBar Property
StatusBarTextProvider Class Example See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to set or get the default status bar component to use for displaying the status bar text messages.

Namespace: SandcastleBuilder.Utils.Controls
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public static Object ApplicationStatusBar { get; set; }
Visual Basic (Declaration)
Public Shared Property ApplicationStatusBar As Object

Field Value

This property is static and must be set at some point during application initialization. This component will be used unless the InstanceStatusBar property is set to override it.

Examples

CopyC#
// Define the default status bar to use in the main form's
// constructor
public MainForm()
{
    InitializeComponent();

    //=========
    // .NET 1.1
    //=========
    // Tell the StatusBarTextProvider component the status bar
    // to use.
    StatusBarTextProvider.ApplicationStatusBar = sbStatusBar;

    // You can also use any panel you like.  The default is zero
    // (the left-most panel).  For the demo, we'll use the one
    // in the middle.
    StatusBarTextProvider.ApplicationDisplayPanel = 1;

    //=========
    // .NET 2.0
    //=========
    // Tell the StatusBarTextProvider component the component
    // to use to display the text.  When using a tool strip
    // component, the ApplicationDisplayPanel property is ignored.
    StatusBarTextProvider.ApplicationStatusBar = tslStatusText;

    // Define the status label and progress bar too.  This allows
    // easy access to those items from anywhere within the
    // application.
    StatusBarTextProvider.StatusLabel = tslProgressNote;
    StatusBarTextProvider.ProgressBar = tspbProgressBar;
}
CopyVB.NET
' Define the default status bar to use in the main form's
' constructor
Public Sub New()
    MyBase.New()

    InitializeComponent()

    '=========
    ' .NET 1.1
    '=========
    ' Tell the StatusBarTextProvider component the status bar
    ' to use.
    StatusBarTextProvider.ApplicationStatusBar = sbStatusBar;

    ' You can also use any panel you like.  The default is zero
    ' (the left-most panel).  For the demo, we'll use the one
    ' in the middle.
    StatusBarTextProvider.ApplicationDisplayPanel = 1;

    '=========
    ' .NET 2.0
    '=========
    ' Tell the StatusBarTextProvider component the component
    ' to use to display the text.  When using a tool strip
    ' component, the ApplicationDisplayPanel property is ignored.
    StatusBarTextProvider.ApplicationStatusBar = tslStatusText;

    ' Define the status label and progress bar too.  This allows
    ' easy access to those items from anywhere within the
    ' application.
    StatusBarTextProvider.StatusLabel = tslProgressNote;
    StatusBarTextProvider.ProgressBar = tspbProgressBar;
End Sub

Exceptions

Exception | Condition
System..::.ArgumentException | This is thrown if the object is not a status bar control or a tool strip item.

See Also

StatusBarTextProvider Class
SandcastleBuilder.Utils.Controls Namespace
StatusBarTextProvider..::.ApplicationDisplayPanel
StatusBarTextProvider..::.InstanceStatusBar
StatusBarTextProvider..::.InstanceDisplayPanel


InstanceDefaultText Property

[image]

Sandcastle Help File Builder Documentation
StatusBarTextProvider..::.InstanceDefaultText Property
StatusBarTextProvider Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to set or get the default text to show when no item has the focus or no status text for the instance status bar.

Namespace: SandcastleBuilder.Utils.Controls
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string InstanceDefaultText { get; set; }
Visual Basic (Declaration)
Public Property InstanceDefaultText As String

Field Value

By default, it will be set to the text in the selected status bar component. If set to a different value, set this property after specifying the status bar control to use.

See Also

StatusBarTextProvider Class
SandcastleBuilder.Utils.Controls Namespace


InstanceDisplayPanel Property

[image]

Sandcastle Help File Builder Documentation
StatusBarTextProvider..::.InstanceDisplayPanel Property
StatusBarTextProvider Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to set or get the status bar panel in which to display the messages when the InstanceStatusBar property is set to a status bar.

Namespace: SandcastleBuilder.Utils.Controls
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public int InstanceDisplayPanel { get; set; }
Visual Basic (Declaration)
Public Property InstanceDisplayPanel As Integer

Field Value

The default is zero (the first panel). If the status bar does not have panels, the index exceeds the panel count, or the status bar's ShowPanels property is false, messages will be shown in the status bar's Text property instead. If using the ApplicationStatusBar, this property is ignored. It is also ignored if using a tool strip item to display the text.

See Also

StatusBarTextProvider Class
SandcastleBuilder.Utils.Controls Namespace
StatusBarTextProvider..::.ApplicationStatusBar
StatusBarTextProvider..::.ApplicationDisplayPanel
StatusBarTextProvider..::.InstanceStatusBar


InstanceStatusBar Property

[image]

Sandcastle Help File Builder Documentation
StatusBarTextProvider..::.InstanceStatusBar Property
StatusBarTextProvider Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set the status bar component to use for this instance.

Namespace: SandcastleBuilder.Utils.Controls
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public Object InstanceStatusBar { get; set; }
Visual Basic (Declaration)
Public Property InstanceStatusBar As Object

Field Value

If not set or set to null, it will use the status bar control assigned to the ApplicationStatusBar property.

Exceptions

Exception | Condition
System..::.ArgumentException | This is thrown if the object is not a status bar control or a tool strip item.

See Also

StatusBarTextProvider Class
SandcastleBuilder.Utils.Controls Namespace
StatusBarTextProvider..::.ApplicationStatusBar
StatusBarTextProvider..::.ApplicationDisplayPanel
StatusBarTextProvider..::.InstanceDisplayPanel


ProgressBar Property

[image]

Sandcastle Help File Builder Documentation
StatusBarTextProvider..::.ProgressBar Property
StatusBarTextProvider Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set the tool strip progress bar component that can be used to display progress through a long running task.

Namespace: SandcastleBuilder.Utils.Controls
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public static ToolStripProgressBar ProgressBar { get; set; }
Visual Basic (Declaration)
Public Shared Property ProgressBar As ToolStripProgressBar

Remarks

This can be used in conjunction with StatusLabel. This property is only available when used with .NET 2.0.

See Also

StatusBarTextProvider Class
SandcastleBuilder.Utils.Controls Namespace


StatusLabel Property

[image]

Sandcastle Help File Builder Documentation
StatusBarTextProvider..::.StatusLabel Property
StatusBarTextProvider Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set the tool strip status label component that can be used to display a status message in conjunction with the ProgressBar component.

Namespace: SandcastleBuilder.Utils.Controls
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public static ToolStripStatusLabel StatusLabel { get; set; }
Visual Basic (Declaration)
Public Shared Property StatusLabel As ToolStripStatusLabel

Remarks

This property is only available when used with .NET 2.0.

See Also

StatusBarTextProvider Class
SandcastleBuilder.Utils.Controls Namespace


StatusBarTextProvider Events

[image] [image]

Sandcastle Help File Builder Documentation
StatusBarTextProvider Events
StatusBarTextProvider Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The StatusBarTextProvider type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

StatusBarTextProvider Class
SandcastleBuilder.Utils.Controls Namespace


SandcastleBuilder.Utils.Conversion Namespace

[image]

Sandcastle Help File Builder Documentation
SandcastleBuilder.Utils.Conversion Namespace
Send Feedback

[This is preliminary documentation and is subject to change.]

This namespaces contains classes used to convert projects in other formats to the latest MSBuild project format used by the help file builder.

Classes

Class | Description
ConvertConceptualContent | This class is used to convert conceptual content settings in version 1.7.0.0 and prior SHFB project files to the new MSBuild format.
ConvertFromDocProject | This class is used to convert DocProject project files to the MSBuild format project files used by the help file builder.
ConvertFromMSExampleGui | This class is used to convert the Microsoft example Sandcastle GUI project files to the MSBuild format project files used by the help file builder.
ConvertFromNDoc | This class is used to convert NDoc 1.x project files to the MSBuild format project files used by the help file builder.
ConvertFromSandcastleGui | This class is used to convert Stephan Smetsers Sandcastle GUI project files to the MSBuild format project files used by the help file builder.
ConvertFromShfbFile | This class is used to convert version 1.7.0.0 and prior SHFB project files to the new MSBuild format project files.
ConvertToMSBuildFormat | This class is an abstract base class used to convert a project in another format to the new MSBuild format project files used by SHFB 1.8.0.0 and later.


ConvertConceptualContent Class

[image]

Sandcastle Help File Builder Documentation
ConvertConceptualContent Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This class is used to convert conceptual content settings in version 1.7.0.0 and prior SHFB project files to the new MSBuild format.

Namespace: SandcastleBuilder.Utils.Conversion
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public class ConvertConceptualContent
Visual Basic (Declaration)
Public Class ConvertConceptualContent

Inheritance Hierarchy

System..::.Object
SandcastleBuilder.Utils.Conversion..::.ConvertConceptualContent

See Also

ConvertConceptualContent Members
SandcastleBuilder.Utils.Conversion Namespace


ConvertConceptualContent Members

[image] [image]

Sandcastle Help File Builder Documentation
ConvertConceptualContent Members
ConvertConceptualContent Class Constructors Methods See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ConvertConceptualContent type exposes the following members.

Constructors

Name | Description
ConvertConceptualContent | Constructor

Methods

Name | Description
ConvertContent | This is used to convert the conceptual content from the old project into the format required by the new project.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConvertConceptualContent Class
SandcastleBuilder.Utils.Conversion Namespace


ConvertConceptualContent Constructor

[image]

Sandcastle Help File Builder Documentation
ConvertConceptualContent Constructor
ConvertConceptualContent Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Utils.Conversion
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public ConvertConceptualContent(
    ConvertFromShfbFile projectConverter
)
Visual Basic (Declaration)
Public Sub New ( _
    projectConverter As ConvertFromShfbFile _
)

Parameters

projectConverter
Type: SandcastleBuilder.Utils.Conversion..::.ConvertFromShfbFile
The project converter object

See Also

ConvertConceptualContent Class
SandcastleBuilder.Utils.Conversion Namespace


ConvertConceptualContent Methods

[image] [image]

Sandcastle Help File Builder Documentation
ConvertConceptualContent Methods
ConvertConceptualContent Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ConvertConceptualContent type exposes the following members.

Methods

Name | Description
ConvertContent | This is used to convert the conceptual content from the old project into the format required by the new project.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConvertConceptualContent Class
SandcastleBuilder.Utils.Conversion Namespace


ConvertContent Method

[image]

Sandcastle Help File Builder Documentation
ConvertConceptualContent..::.ConvertContent Method
ConvertConceptualContent Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to convert the conceptual content from the old project into the format required by the new project.

Namespace: SandcastleBuilder.Utils.Conversion
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public void ConvertContent()
Visual Basic (Declaration)
Public Sub ConvertContent

See Also

ConvertConceptualContent Class
SandcastleBuilder.Utils.Conversion Namespace


ConvertFromDocProject Class

[image]

Sandcastle Help File Builder Documentation
ConvertFromDocProject Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This class is used to convert DocProject project files to the MSBuild format project files used by the help file builder.

Namespace: SandcastleBuilder.Utils.Conversion
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public class ConvertFromDocProject : ConvertToMSBuildFormat
Visual Basic (Declaration)
Public Class ConvertFromDocProject _
    Inherits ConvertToMSBuildFormat

Inheritance Hierarchy

System..::.Object
SandcastleBuilder.Utils.Conversion..::.ConvertToMSBuildFormat
SandcastleBuilder.Utils.Conversion..::.ConvertFromDocProject

See Also

ConvertFromDocProject Members
SandcastleBuilder.Utils.Conversion Namespace


ConvertFromDocProject Members

[image] [image]

Sandcastle Help File Builder Documentation
ConvertFromDocProject Members
ConvertFromDocProject Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ConvertFromDocProject type exposes the following members.

Constructors

Name | Description
ConvertFromDocProject | Constructor

Methods

Name | Description
ConvertProject | This is used to perform the actual conversion (Overrides ConvertToMSBuildFormat..::.ConvertProject()()().)
CreateFolderItems | This can be called after all additional content has been added to create the Folder build items in the project. (Inherited from ConvertToMSBuildFormat.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FullPath | This converts a relative path to a full path using the old project's folder. (Inherited from ConvertToMSBuildFormat.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetProperty | This is used to set the named property to the specified value using Reflection. (Inherited from ConvertToMSBuildFormat.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
OldFolder | Get the old project folder (Inherited from ConvertToMSBuildFormat.)
OldProjectFile | Get the old project filename (Inherited from ConvertToMSBuildFormat.)
Project | Get the new project (Inherited from ConvertToMSBuildFormat.)
ProjectFolder | Get the new project folder (Inherited from ConvertToMSBuildFormat.)
Reader | An XML reader isn't used by this converter (Overrides ConvertToMSBuildFormat..::.Reader.)

See Also

ConvertFromDocProject Class
SandcastleBuilder.Utils.Conversion Namespace


ConvertFromDocProject Constructor

[image]

Sandcastle Help File Builder Documentation
ConvertFromDocProject Constructor
ConvertFromDocProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Utils.Conversion
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public ConvertFromDocProject(
    string oldProjectFile,
    string folder
)
Visual Basic (Declaration)
Public Sub New ( _
    oldProjectFile As String, _
    folder As String _
)

Parameters

oldProjectFile
Type: System..::.String
The old project filename
folder
Type: System..::.String
The folder in which to place the new project and its related files. This cannot be the same folder as the old project file.

See Also

ConvertFromDocProject Class
SandcastleBuilder.Utils.Conversion Namespace


ConvertFromDocProject Methods

[image] [image]

Sandcastle Help File Builder Documentation
ConvertFromDocProject Methods
ConvertFromDocProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ConvertFromDocProject type exposes the following members.

Methods

Name | Description
ConvertProject | This is used to perform the actual conversion (Overrides ConvertToMSBuildFormat..::.ConvertProject()()().)
CreateFolderItems | This can be called after all additional content has been added to create the Folder build items in the project. (Inherited from ConvertToMSBuildFormat.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FullPath | This converts a relative path to a full path using the old project's folder. (Inherited from ConvertToMSBuildFormat.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetProperty | This is used to set the named property to the specified value using Reflection. (Inherited from ConvertToMSBuildFormat.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConvertFromDocProject Class
SandcastleBuilder.Utils.Conversion Namespace


ConvertProject Method

[image]

Sandcastle Help File Builder Documentation
ConvertFromDocProject..::.ConvertProject Method
ConvertFromDocProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to perform the actual conversion

Namespace: SandcastleBuilder.Utils.Conversion
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public override string ConvertProject()
Visual Basic (Declaration)
Public Overrides Function ConvertProject As String

Return Value

The new project filename on success. An exception is thrown if the conversion fails.

See Also

ConvertFromDocProject Class
SandcastleBuilder.Utils.Conversion Namespace


ConvertFromDocProject Properties

[image] [image]

Sandcastle Help File Builder Documentation
ConvertFromDocProject Properties
ConvertFromDocProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ConvertFromDocProject type exposes the following members.

Properties

Name | Description
OldFolder | Get the old project folder (Inherited from ConvertToMSBuildFormat.)
OldProjectFile | Get the old project filename (Inherited from ConvertToMSBuildFormat.)
Project | Get the new project (Inherited from ConvertToMSBuildFormat.)
ProjectFolder | Get the new project folder (Inherited from ConvertToMSBuildFormat.)
Reader | An XML reader isn't used by this converter (Overrides ConvertToMSBuildFormat..::.Reader.)

See Also

ConvertFromDocProject Class
SandcastleBuilder.Utils.Conversion Namespace


Reader Property

[image]

Sandcastle Help File Builder Documentation
ConvertFromDocProject..::.Reader Property
ConvertFromDocProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

An XML reader isn't used by this converter

Namespace: SandcastleBuilder.Utils.Conversion
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected internal override XmlTextReader Reader { get; }
Visual Basic (Declaration)
Protected Friend Overrides ReadOnly Property Reader As XmlTextReader

See Also

ConvertFromDocProject Class
SandcastleBuilder.Utils.Conversion Namespace


ConvertFromMSExampleGui Class

[image]

Sandcastle Help File Builder Documentation
ConvertFromMSExampleGui Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This class is used to convert the Microsoft example Sandcastle GUI project files to the MSBuild format project files used by the help file builder.

Namespace: SandcastleBuilder.Utils.Conversion
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public class ConvertFromMSExampleGui : ConvertToMSBuildFormat
Visual Basic (Declaration)
Public Class ConvertFromMSExampleGui _
    Inherits ConvertToMSBuildFormat

Inheritance Hierarchy

System..::.Object
SandcastleBuilder.Utils.Conversion..::.ConvertToMSBuildFormat
SandcastleBuilder.Utils.Conversion..::.ConvertFromMSExampleGui

See Also

ConvertFromMSExampleGui Members
SandcastleBuilder.Utils.Conversion Namespace


ConvertFromMSExampleGui Members

[image] [image]

Sandcastle Help File Builder Documentation
ConvertFromMSExampleGui Members
ConvertFromMSExampleGui Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ConvertFromMSExampleGui type exposes the following members.

Constructors

Name | Description
ConvertFromMSExampleGui | Constructor

Methods

Name | Description
ConvertProject | This is used to perform the actual conversion (Overrides ConvertToMSBuildFormat..::.ConvertProject()()().)
CreateFolderItems | This can be called after all additional content has been added to create the Folder build items in the project. (Inherited from ConvertToMSBuildFormat.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FullPath | This converts a relative path to a full path using the old project's folder. (Inherited from ConvertToMSBuildFormat.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetProperty | This is used to set the named property to the specified value using Reflection. (Inherited from ConvertToMSBuildFormat.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
OldFolder | Get the old project folder (Inherited from ConvertToMSBuildFormat.)
OldProjectFile | Get the old project filename (Inherited from ConvertToMSBuildFormat.)
Project | Get the new project (Inherited from ConvertToMSBuildFormat.)
ProjectFolder | Get the new project folder (Inherited from ConvertToMSBuildFormat.)
Reader | An XML reader isn't used by this converter (Overrides ConvertToMSBuildFormat..::.Reader.)

See Also

ConvertFromMSExampleGui Class
SandcastleBuilder.Utils.Conversion Namespace


ConvertFromMSExampleGui Constructor

[image]

Sandcastle Help File Builder Documentation
ConvertFromMSExampleGui Constructor
ConvertFromMSExampleGui Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Utils.Conversion
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public ConvertFromMSExampleGui(
    string oldProjectFile,
    string folder
)
Visual Basic (Declaration)
Public Sub New ( _
    oldProjectFile As String, _
    folder As String _
)

Parameters

oldProjectFile
Type: System..::.String
The old project filename
folder
Type: System..::.String
The folder in which to place the new project and its related files. This cannot be the same folder as the old project file.

See Also

ConvertFromMSExampleGui Class
SandcastleBuilder.Utils.Conversion Namespace


ConvertFromMSExampleGui Methods

[image] [image]

Sandcastle Help File Builder Documentation
ConvertFromMSExampleGui Methods
ConvertFromMSExampleGui Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ConvertFromMSExampleGui type exposes the following members.

Methods

Name | Description
ConvertProject | This is used to perform the actual conversion (Overrides ConvertToMSBuildFormat..::.ConvertProject()()().)
CreateFolderItems | This can be called after all additional content has been added to create the Folder build items in the project. (Inherited from ConvertToMSBuildFormat.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FullPath | This converts a relative path to a full path using the old project's folder. (Inherited from ConvertToMSBuildFormat.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetProperty | This is used to set the named property to the specified value using Reflection. (Inherited from ConvertToMSBuildFormat.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConvertFromMSExampleGui Class
SandcastleBuilder.Utils.Conversion Namespace


ConvertProject Method

[image]

Sandcastle Help File Builder Documentation
ConvertFromMSExampleGui..::.ConvertProject Method
ConvertFromMSExampleGui Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to perform the actual conversion

Namespace: SandcastleBuilder.Utils.Conversion
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public override string ConvertProject()
Visual Basic (Declaration)
Public Overrides Function ConvertProject As String

Return Value

The new project filename on success. An exception is thrown if the conversion fails.

See Also

ConvertFromMSExampleGui Class
SandcastleBuilder.Utils.Conversion Namespace


ConvertFromMSExampleGui Properties

[image] [image]

Sandcastle Help File Builder Documentation
ConvertFromMSExampleGui Properties
ConvertFromMSExampleGui Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ConvertFromMSExampleGui type exposes the following members.

Properties

Name | Description
OldFolder | Get the old project folder (Inherited from ConvertToMSBuildFormat.)
OldProjectFile | Get the old project filename (Inherited from ConvertToMSBuildFormat.)
Project | Get the new project (Inherited from ConvertToMSBuildFormat.)
ProjectFolder | Get the new project folder (Inherited from ConvertToMSBuildFormat.)
Reader | An XML reader isn't used by this converter (Overrides ConvertToMSBuildFormat..::.Reader.)

See Also

ConvertFromMSExampleGui Class
SandcastleBuilder.Utils.Conversion Namespace


Reader Property

[image]

Sandcastle Help File Builder Documentation
ConvertFromMSExampleGui..::.Reader Property
ConvertFromMSExampleGui Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

An XML reader isn't used by this converter

Namespace: SandcastleBuilder.Utils.Conversion
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected internal override XmlTextReader Reader { get; }
Visual Basic (Declaration)
Protected Friend Overrides ReadOnly Property Reader As XmlTextReader

See Also

ConvertFromMSExampleGui Class
SandcastleBuilder.Utils.Conversion Namespace


ConvertFromNDoc Class

[image]

Sandcastle Help File Builder Documentation
ConvertFromNDoc Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This class is used to convert NDoc 1.x project files to the MSBuild format project files used by the help file builder.

Namespace: SandcastleBuilder.Utils.Conversion
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public class ConvertFromNDoc : ConvertToMSBuildFormat
Visual Basic (Declaration)
Public Class ConvertFromNDoc _
    Inherits ConvertToMSBuildFormat

Inheritance Hierarchy

System..::.Object
SandcastleBuilder.Utils.Conversion..::.ConvertToMSBuildFormat
SandcastleBuilder.Utils.Conversion..::.ConvertFromNDoc

See Also

ConvertFromNDoc Members
SandcastleBuilder.Utils.Conversion Namespace


ConvertFromNDoc Members

[image] [image]

Sandcastle Help File Builder Documentation
ConvertFromNDoc Members
ConvertFromNDoc Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ConvertFromNDoc type exposes the following members.

Constructors

Name | Description
ConvertFromNDoc | Constructor

Methods

Name | Description
ConvertProject | This is used to perform the actual conversion (Overrides ConvertToMSBuildFormat..::.ConvertProject()()().)
CreateFolderItems | This can be called after all additional content has been added to create the Folder build items in the project. (Inherited from ConvertToMSBuildFormat.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FullPath | This converts a relative path to a full path using the old project's folder. (Inherited from ConvertToMSBuildFormat.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetProperty | This is used to set the named property to the specified value using Reflection. (Inherited from ConvertToMSBuildFormat.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
OldFolder | Get the old project folder (Inherited from ConvertToMSBuildFormat.)
OldProjectFile | Get the old project filename (Inherited from ConvertToMSBuildFormat.)
Project | Get the new project (Inherited from ConvertToMSBuildFormat.)
ProjectFolder | Get the new project folder (Inherited from ConvertToMSBuildFormat.)
Reader | An XML reader isn't used by this converter (Overrides ConvertToMSBuildFormat..::.Reader.)

See Also

ConvertFromNDoc Class
SandcastleBuilder.Utils.Conversion Namespace


ConvertFromNDoc Constructor

[image]

Sandcastle Help File Builder Documentation
ConvertFromNDoc Constructor
ConvertFromNDoc Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Utils.Conversion
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public ConvertFromNDoc(
    string oldProjectFile,
    string folder
)
Visual Basic (Declaration)
Public Sub New ( _
    oldProjectFile As String, _
    folder As String _
)

Parameters

oldProjectFile
Type: System..::.String
The old project filename
folder
Type: System..::.String
The folder in which to place the new project and its related files. This cannot be the same folder as the old project file.

See Also

ConvertFromNDoc Class
SandcastleBuilder.Utils.Conversion Namespace


ConvertFromNDoc Methods

[image] [image]

Sandcastle Help File Builder Documentation
ConvertFromNDoc Methods
ConvertFromNDoc Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ConvertFromNDoc type exposes the following members.

Methods

Name | Description
ConvertProject | This is used to perform the actual conversion (Overrides ConvertToMSBuildFormat..::.ConvertProject()()().)
CreateFolderItems | This can be called after all additional content has been added to create the Folder build items in the project. (Inherited from ConvertToMSBuildFormat.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FullPath | This converts a relative path to a full path using the old project's folder. (Inherited from ConvertToMSBuildFormat.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetProperty | This is used to set the named property to the specified value using Reflection. (Inherited from ConvertToMSBuildFormat.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConvertFromNDoc Class
SandcastleBuilder.Utils.Conversion Namespace


ConvertProject Method

[image]

Sandcastle Help File Builder Documentation
ConvertFromNDoc..::.ConvertProject Method
ConvertFromNDoc Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to perform the actual conversion

Namespace: SandcastleBuilder.Utils.Conversion
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public override string ConvertProject()
Visual Basic (Declaration)
Public Overrides Function ConvertProject As String

Return Value

The new project filename on success. An exception is thrown if the conversion fails.

See Also

ConvertFromNDoc Class
SandcastleBuilder.Utils.Conversion Namespace


ConvertFromNDoc Properties

[image] [image]

Sandcastle Help File Builder Documentation
ConvertFromNDoc Properties
ConvertFromNDoc Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ConvertFromNDoc type exposes the following members.

Properties

Name | Description
OldFolder | Get the old project folder (Inherited from ConvertToMSBuildFormat.)
OldProjectFile | Get the old project filename (Inherited from ConvertToMSBuildFormat.)
Project | Get the new project (Inherited from ConvertToMSBuildFormat.)
ProjectFolder | Get the new project folder (Inherited from ConvertToMSBuildFormat.)
Reader | An XML reader isn't used by this converter (Overrides ConvertToMSBuildFormat..::.Reader.)

See Also

ConvertFromNDoc Class
SandcastleBuilder.Utils.Conversion Namespace


Reader Property

[image]

Sandcastle Help File Builder Documentation
ConvertFromNDoc..::.Reader Property
ConvertFromNDoc Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

An XML reader isn't used by this converter

Namespace: SandcastleBuilder.Utils.Conversion
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected internal override XmlTextReader Reader { get; }
Visual Basic (Declaration)
Protected Friend Overrides ReadOnly Property Reader As XmlTextReader

See Also

ConvertFromNDoc Class
SandcastleBuilder.Utils.Conversion Namespace


ConvertFromSandcastleGui Class

[image]

Sandcastle Help File Builder Documentation
ConvertFromSandcastleGui Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This class is used to convert Stephan Smetsers Sandcastle GUI project files to the MSBuild format project files used by the help file builder.

Namespace: SandcastleBuilder.Utils.Conversion
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public class ConvertFromSandcastleGui : ConvertToMSBuildFormat
Visual Basic (Declaration)
Public Class ConvertFromSandcastleGui _
    Inherits ConvertToMSBuildFormat

Inheritance Hierarchy

System..::.Object
SandcastleBuilder.Utils.Conversion..::.ConvertToMSBuildFormat
SandcastleBuilder.Utils.Conversion..::.ConvertFromSandcastleGui

See Also

ConvertFromSandcastleGui Members
SandcastleBuilder.Utils.Conversion Namespace


ConvertFromSandcastleGui Members

[image] [image]

Sandcastle Help File Builder Documentation
ConvertFromSandcastleGui Members
ConvertFromSandcastleGui Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ConvertFromSandcastleGui type exposes the following members.

Constructors

Name | Description
ConvertFromSandcastleGui | Constructor

Methods

Name | Description
ConvertProject | This is used to perform the actual conversion (Overrides ConvertToMSBuildFormat..::.ConvertProject()()().)
CreateFolderItems | This can be called after all additional content has been added to create the Folder build items in the project. (Inherited from ConvertToMSBuildFormat.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FullPath | This converts a relative path to a full path using the old project's folder. (Inherited from ConvertToMSBuildFormat.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetProperty | This is used to set the named property to the specified value using Reflection. (Inherited from ConvertToMSBuildFormat.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
OldFolder | Get the old project folder (Inherited from ConvertToMSBuildFormat.)
OldProjectFile | Get the old project filename (Inherited from ConvertToMSBuildFormat.)
Project | Get the new project (Inherited from ConvertToMSBuildFormat.)
ProjectFolder | Get the new project folder (Inherited from ConvertToMSBuildFormat.)
Reader | An XML reader isn't used by this converter (Overrides ConvertToMSBuildFormat..::.Reader.)

See Also

ConvertFromSandcastleGui Class
SandcastleBuilder.Utils.Conversion Namespace


ConvertFromSandcastleGui Constructor

[image]

Sandcastle Help File Builder Documentation
ConvertFromSandcastleGui Constructor
ConvertFromSandcastleGui Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Utils.Conversion
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public ConvertFromSandcastleGui(
    string oldProjectFile,
    string folder
)
Visual Basic (Declaration)
Public Sub New ( _
    oldProjectFile As String, _
    folder As String _
)

Parameters

oldProjectFile
Type: System..::.String
The old project filename
folder
Type: System..::.String
The folder in which to place the new project and its related files. This cannot be the same folder as the old project file.

See Also

ConvertFromSandcastleGui Class
SandcastleBuilder.Utils.Conversion Namespace


ConvertFromSandcastleGui Methods

[image] [image]

Sandcastle Help File Builder Documentation
ConvertFromSandcastleGui Methods
ConvertFromSandcastleGui Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ConvertFromSandcastleGui type exposes the following members.

Methods

Name | Description
ConvertProject | This is used to perform the actual conversion (Overrides ConvertToMSBuildFormat..::.ConvertProject()()().)
CreateFolderItems | This can be called after all additional content has been added to create the Folder build items in the project. (Inherited from ConvertToMSBuildFormat.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FullPath | This converts a relative path to a full path using the old project's folder. (Inherited from ConvertToMSBuildFormat.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetProperty | This is used to set the named property to the specified value using Reflection. (Inherited from ConvertToMSBuildFormat.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConvertFromSandcastleGui Class
SandcastleBuilder.Utils.Conversion Namespace


ConvertProject Method

[image]

Sandcastle Help File Builder Documentation
ConvertFromSandcastleGui..::.ConvertProject Method
ConvertFromSandcastleGui Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to perform the actual conversion

Namespace: SandcastleBuilder.Utils.Conversion
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public override string ConvertProject()
Visual Basic (Declaration)
Public Overrides Function ConvertProject As String

Return Value

The new project filename on success. An exception is thrown if the conversion fails.

See Also

ConvertFromSandcastleGui Class
SandcastleBuilder.Utils.Conversion Namespace


ConvertFromSandcastleGui Properties

[image] [image]

Sandcastle Help File Builder Documentation
ConvertFromSandcastleGui Properties
ConvertFromSandcastleGui Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ConvertFromSandcastleGui type exposes the following members.

Properties

Name | Description
OldFolder | Get the old project folder (Inherited from ConvertToMSBuildFormat.)
OldProjectFile | Get the old project filename (Inherited from ConvertToMSBuildFormat.)
Project | Get the new project (Inherited from ConvertToMSBuildFormat.)
ProjectFolder | Get the new project folder (Inherited from ConvertToMSBuildFormat.)
Reader | An XML reader isn't used by this converter (Overrides ConvertToMSBuildFormat..::.Reader.)

See Also

ConvertFromSandcastleGui Class
SandcastleBuilder.Utils.Conversion Namespace


Reader Property

[image]

Sandcastle Help File Builder Documentation
ConvertFromSandcastleGui..::.Reader Property
ConvertFromSandcastleGui Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

An XML reader isn't used by this converter

Namespace: SandcastleBuilder.Utils.Conversion
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected internal override XmlTextReader Reader { get; }
Visual Basic (Declaration)
Protected Friend Overrides ReadOnly Property Reader As XmlTextReader

See Also

ConvertFromSandcastleGui Class
SandcastleBuilder.Utils.Conversion Namespace


ConvertFromShfbFile Class

[image]

Sandcastle Help File Builder Documentation
ConvertFromShfbFile Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This class is used to convert version 1.7.0.0 and prior SHFB project files to the new MSBuild format project files.

Namespace: SandcastleBuilder.Utils.Conversion
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public sealed class ConvertFromShfbFile : ConvertToMSBuildFormat
Visual Basic (Declaration)
Public NotInheritable Class ConvertFromShfbFile _
    Inherits ConvertToMSBuildFormat

Inheritance Hierarchy

System..::.Object
SandcastleBuilder.Utils.Conversion..::.ConvertToMSBuildFormat
SandcastleBuilder.Utils.Conversion..::.ConvertFromShfbFile

See Also

ConvertFromShfbFile Members
SandcastleBuilder.Utils.Conversion Namespace


ConvertFromShfbFile Members

[image] [image]

Sandcastle Help File Builder Documentation
ConvertFromShfbFile Members
ConvertFromShfbFile Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ConvertFromShfbFile type exposes the following members.

Constructors

Name | Description
ConvertFromShfbFile | Constructor

Methods

Name | Description
ConvertProject | This is used to perform the actual conversion (Overrides ConvertToMSBuildFormat..::.ConvertProject()()().)
CreateFolderItems | This can be called after all additional content has been added to create the Folder build items in the project. (Inherited from ConvertToMSBuildFormat.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FullPath | This converts a relative path to a full path using the old project's folder. (Inherited from ConvertToMSBuildFormat.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetProperty | This is used to set the named property to the specified value using Reflection. (Inherited from ConvertToMSBuildFormat.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
OldFolder | Get the old project folder (Inherited from ConvertToMSBuildFormat.)
OldProjectFile | Get the old project filename (Inherited from ConvertToMSBuildFormat.)
Project | Get the new project (Inherited from ConvertToMSBuildFormat.)
ProjectFolder | Get the new project folder (Inherited from ConvertToMSBuildFormat.)
Reader | Get the XML text reader used for the conversion (Inherited from ConvertToMSBuildFormat.)

See Also

ConvertFromShfbFile Class
SandcastleBuilder.Utils.Conversion Namespace


ConvertFromShfbFile Constructor

[image]

Sandcastle Help File Builder Documentation
ConvertFromShfbFile Constructor
ConvertFromShfbFile Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Utils.Conversion
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public ConvertFromShfbFile(
    string oldProjectFile,
    string folder
)
Visual Basic (Declaration)
Public Sub New ( _
    oldProjectFile As String, _
    folder As String _
)

Parameters

oldProjectFile
Type: System..::.String
The old project filename
folder
Type: System..::.String
The folder in which to place the new project and its related files. This cannot be the same folder as the old project file.

See Also

ConvertFromShfbFile Class
SandcastleBuilder.Utils.Conversion Namespace


ConvertFromShfbFile Methods

[image] [image]

Sandcastle Help File Builder Documentation
ConvertFromShfbFile Methods
ConvertFromShfbFile Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ConvertFromShfbFile type exposes the following members.

Methods

Name | Description
ConvertProject | This is used to perform the actual conversion (Overrides ConvertToMSBuildFormat..::.ConvertProject()()().)
CreateFolderItems | This can be called after all additional content has been added to create the Folder build items in the project. (Inherited from ConvertToMSBuildFormat.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FullPath | This converts a relative path to a full path using the old project's folder. (Inherited from ConvertToMSBuildFormat.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetProperty | This is used to set the named property to the specified value using Reflection. (Inherited from ConvertToMSBuildFormat.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConvertFromShfbFile Class
SandcastleBuilder.Utils.Conversion Namespace


ConvertProject Method

[image]

Sandcastle Help File Builder Documentation
ConvertFromShfbFile..::.ConvertProject Method
ConvertFromShfbFile Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to perform the actual conversion

Namespace: SandcastleBuilder.Utils.Conversion
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public override string ConvertProject()
Visual Basic (Declaration)
Public Overrides Function ConvertProject As String

Return Value

The new project filename on success. An exception is thrown if the conversion fails.

See Also

ConvertFromShfbFile Class
SandcastleBuilder.Utils.Conversion Namespace


ConvertFromShfbFile Properties

[image] [image]

Sandcastle Help File Builder Documentation
ConvertFromShfbFile Properties
ConvertFromShfbFile Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ConvertFromShfbFile type exposes the following members.

Properties

Name | Description
OldFolder | Get the old project folder (Inherited from ConvertToMSBuildFormat.)
OldProjectFile | Get the old project filename (Inherited from ConvertToMSBuildFormat.)
Project | Get the new project (Inherited from ConvertToMSBuildFormat.)
ProjectFolder | Get the new project folder (Inherited from ConvertToMSBuildFormat.)
Reader | Get the XML text reader used for the conversion (Inherited from ConvertToMSBuildFormat.)

See Also

ConvertFromShfbFile Class
SandcastleBuilder.Utils.Conversion Namespace


ConvertToMSBuildFormat Class

[image]

Sandcastle Help File Builder Documentation
ConvertToMSBuildFormat Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This class is an abstract base class used to convert a project in another format to the new MSBuild format project files used by SHFB 1.8.0.0 and later.

Namespace: SandcastleBuilder.Utils.Conversion
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public abstract class ConvertToMSBuildFormat
Visual Basic (Declaration)
Public MustInherit Class ConvertToMSBuildFormat

Inheritance Hierarchy

System..::.Object
SandcastleBuilder.Utils.Conversion..::.ConvertToMSBuildFormat
SandcastleBuilder.Utils.Conversion..::.ConvertFromDocProject
SandcastleBuilder.Utils.Conversion..::.ConvertFromMSExampleGui
SandcastleBuilder.Utils.Conversion..::.ConvertFromNDoc
SandcastleBuilder.Utils.Conversion..::.ConvertFromSandcastleGui
SandcastleBuilder.Utils.Conversion..::.ConvertFromShfbFile

See Also

ConvertToMSBuildFormat Members
SandcastleBuilder.Utils.Conversion Namespace


ConvertToMSBuildFormat Members

[image] [image]

Sandcastle Help File Builder Documentation
ConvertToMSBuildFormat Members
ConvertToMSBuildFormat Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ConvertToMSBuildFormat type exposes the following members.

Constructors

Name | Description
ConvertToMSBuildFormat | Constructor

Methods

Name | Description
ConvertProject | This is used to perform the actual conversion
CreateFolderItems | This can be called after all additional content has been added to create the Folder build items in the project.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExpandWildcard | This is used to expand a wildcard into all matching files
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FullPath | This converts a relative path to a full path using the old project's folder.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetProperty | This is used to set the named property to the specified value using Reflection.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
OldFolder | Get the old project folder
OldProjectFile | Get the old project filename
Project | Get the new project
ProjectFolder | Get the new project folder
Reader | Get the XML text reader used for the conversion

See Also

ConvertToMSBuildFormat Class
SandcastleBuilder.Utils.Conversion Namespace


ConvertToMSBuildFormat Constructor

[image]

Sandcastle Help File Builder Documentation
ConvertToMSBuildFormat Constructor
ConvertToMSBuildFormat Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Utils.Conversion
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected ConvertToMSBuildFormat(
    string oldProjectFile,
    string folder
)
Visual Basic (Declaration)
Protected Sub New ( _
    oldProjectFile As String, _
    folder As String _
)

Parameters

oldProjectFile
Type: System..::.String
The old project filename
folder
Type: System..::.String
The folder in which to place the new project and its related files. This cannot be the same folder as the old project file.

See Also

ConvertToMSBuildFormat Class
SandcastleBuilder.Utils.Conversion Namespace


ConvertToMSBuildFormat Methods

[image] [image]

Sandcastle Help File Builder Documentation
ConvertToMSBuildFormat Methods
ConvertToMSBuildFormat Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ConvertToMSBuildFormat type exposes the following members.

Methods

Name | Description
ConvertProject | This is used to perform the actual conversion
CreateFolderItems | This can be called after all additional content has been added to create the Folder build items in the project.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExpandWildcard | This is used to expand a wildcard into all matching files
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FullPath | This converts a relative path to a full path using the old project's folder.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetProperty | This is used to set the named property to the specified value using Reflection.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConvertToMSBuildFormat Class
SandcastleBuilder.Utils.Conversion Namespace


ConvertProject Method

[image]

Sandcastle Help File Builder Documentation
ConvertToMSBuildFormat..::.ConvertProject Method
ConvertToMSBuildFormat Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to perform the actual conversion

Namespace: SandcastleBuilder.Utils.Conversion
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public abstract string ConvertProject()
Visual Basic (Declaration)
Public MustOverride Function ConvertProject As String

Return Value

The new project filename on success. An exception is thrown if the conversion fails.

See Also

ConvertToMSBuildFormat Class
SandcastleBuilder.Utils.Conversion Namespace


CreateFolderItems Method

[image]

Sandcastle Help File Builder Documentation
ConvertToMSBuildFormat..::.CreateFolderItems Method
ConvertToMSBuildFormat Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This can be called after all additional content has been added to create the Folder build items in the project.

Namespace: SandcastleBuilder.Utils.Conversion
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected void CreateFolderItems()
Visual Basic (Declaration)
Protected Sub CreateFolderItems

See Also

ConvertToMSBuildFormat Class
SandcastleBuilder.Utils.Conversion Namespace


ExpandWildcard Method

[image]

Sandcastle Help File Builder Documentation
ConvertToMSBuildFormat..::.ExpandWildcard Method
ConvertToMSBuildFormat Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to expand a wildcard into all matching files

Namespace: SandcastleBuilder.Utils.Conversion
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected static string[] ExpandWildcard(
    string wildcard,
    bool includeSubFolders
)
Visual Basic (Declaration)
Protected Shared Function ExpandWildcard ( _
    wildcard As String, _
    includeSubFolders As Boolean _
) As String()

Parameters

wildcard
Type: System..::.String
The wildcard to expand.
includeSubFolders
Type: System..::.Boolean
True to include subfolders, false to only include the given folder.

Return Value

The list of matching files.

See Also

ConvertToMSBuildFormat Class
SandcastleBuilder.Utils.Conversion Namespace


FullPath Method

[image]

Sandcastle Help File Builder Documentation
ConvertToMSBuildFormat..::.FullPath Method
ConvertToMSBuildFormat Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This converts a relative path to a full path using the old project's folder.

Namespace: SandcastleBuilder.Utils.Conversion
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected internal string FullPath(
    string path
)
Visual Basic (Declaration)
Protected Friend Function FullPath ( _
    path As String _
) As String

Parameters

path
Type: System..::.String
The path to convert

Return Value

The fully qualified path

See Also

ConvertToMSBuildFormat Class
SandcastleBuilder.Utils.Conversion Namespace


SetProperty Method

[image]

Sandcastle Help File Builder Documentation
ConvertToMSBuildFormat..::.SetProperty Method
ConvertToMSBuildFormat Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to set the named property to the specified value using Reflection.

Namespace: SandcastleBuilder.Utils.Conversion
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected Object SetProperty(
    string name,
    string value
)
Visual Basic (Declaration)
Protected Function SetProperty ( _
    name As String, _
    value As String _
) As Object

Parameters

name
Type: System..::.String
The name of the property to set
value
Type: System..::.String
The value to which it is set

Return Value

The parsed object value to which the property was set.

Remarks

Property name matching is case insensitive as are the values themselves. This is used to allow setting of simple project properties (non-collection) using command line parameters in the console mode builder.

Exceptions

Exception | Condition
System..::.ArgumentNullException | This is thrown if the name parameter is null or an empty string.
SandcastleBuilder.Utils..::.BuilderException | This is thrown if an error occurs while trying to set the named property.

See Also

ConvertToMSBuildFormat Class
SandcastleBuilder.Utils.Conversion Namespace


ConvertToMSBuildFormat Properties

[image] [image]

Sandcastle Help File Builder Documentation
ConvertToMSBuildFormat Properties
ConvertToMSBuildFormat Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ConvertToMSBuildFormat type exposes the following members.

Properties

Name | Description
OldFolder | Get the old project folder
OldProjectFile | Get the old project filename
Project | Get the new project
ProjectFolder | Get the new project folder
Reader | Get the XML text reader used for the conversion

See Also

ConvertToMSBuildFormat Class
SandcastleBuilder.Utils.Conversion Namespace


OldFolder Property

[image]

Sandcastle Help File Builder Documentation
ConvertToMSBuildFormat..::.OldFolder Property
ConvertToMSBuildFormat Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Get the old project folder

Namespace: SandcastleBuilder.Utils.Conversion
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected internal string OldFolder { get; }
Visual Basic (Declaration)
Protected Friend ReadOnly Property OldFolder As String

See Also

ConvertToMSBuildFormat Class
SandcastleBuilder.Utils.Conversion Namespace


OldProjectFile Property

[image]

Sandcastle Help File Builder Documentation
ConvertToMSBuildFormat..::.OldProjectFile Property
ConvertToMSBuildFormat Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Get the old project filename

Namespace: SandcastleBuilder.Utils.Conversion
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected internal string OldProjectFile { get; }
Visual Basic (Declaration)
Protected Friend ReadOnly Property OldProjectFile As String

See Also

ConvertToMSBuildFormat Class
SandcastleBuilder.Utils.Conversion Namespace


Project Property

[image]

Sandcastle Help File Builder Documentation
ConvertToMSBuildFormat..::.Project Property
ConvertToMSBuildFormat Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Get the new project

Namespace: SandcastleBuilder.Utils.Conversion
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected internal SandcastleProject Project { get; }
Visual Basic (Declaration)
Protected Friend ReadOnly Property Project As SandcastleProject

See Also

ConvertToMSBuildFormat Class
SandcastleBuilder.Utils.Conversion Namespace


ProjectFolder Property

[image]

Sandcastle Help File Builder Documentation
ConvertToMSBuildFormat..::.ProjectFolder Property
ConvertToMSBuildFormat Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Get the new project folder

Namespace: SandcastleBuilder.Utils.Conversion
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected internal string ProjectFolder { get; }
Visual Basic (Declaration)
Protected Friend ReadOnly Property ProjectFolder As String

See Also

ConvertToMSBuildFormat Class
SandcastleBuilder.Utils.Conversion Namespace


Reader Property

[image]

Sandcastle Help File Builder Documentation
ConvertToMSBuildFormat..::.Reader Property
ConvertToMSBuildFormat Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Get the XML text reader used for the conversion

Namespace: SandcastleBuilder.Utils.Conversion
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected internal abstract XmlTextReader Reader { get; }
Visual Basic (Declaration)
Protected Friend MustOverride ReadOnly Property Reader As XmlTextReader

See Also

ConvertToMSBuildFormat Class
SandcastleBuilder.Utils.Conversion Namespace


SandcastleBuilder.Utils.Design Namespace

[image]

Sandcastle Help File Builder Documentation
SandcastleBuilder.Utils.Design Namespace
Send Feedback

[This is preliminary documentation and is subject to change.]

This namespace contains various designer classes.

Classes

Class | Description
ContentFileEditor | This class represents an external application that is used to edit an additional content file.
ContentFileEditorCollection | This collection class is used to hold the additional content file editor definitions.
DynamicReadOnlyPropertyDescriptor | This property descriptor can be used to alter the read-only state of a property in a property grid at runtime based on other conditions.
EscapeValueAttribute | This is used to mark a property that needs its value escaped when stored in an MSBuild project file.
FileDialogAttribute | This attribute is used to associate file dialog parameters with a class property for use in editing it in a property grid.
FilePathObjectEditor | This is a type editor that can display a file dialog to allow selection of a file path at design time for a FilePath object.
FilePathStringEditor | This is a type editor that can display a file dialog to allow selection of a file path at design time for a string object.
FilePathTypeConverter | This type converter is used to convert a FilePath object to and from a string so that it can be edited in a PropertyGrid.
FlagsEnumEditor | This is a type editor that displays a checked list box as the drop-down editor for an enumerated data type that represents a set of flags. This makes it easy to select multiple values with the drop-down.
FolderDialogAttribute | This attribute is used to associate folder dialog parameters with a class property for use in editing it in a property grid.
FolderPathObjectEditor | This is a type editor that can display a folder browser dialog to allow selection of a folder path at design time.
FolderPathStringEditor | This is a type editor that can display a folder browser dialog to allow selection of a folder path at design time.
FolderPathTypeConverter | This type converter is used to convert a FolderPath object to and from a string so that it can be edited in a PropertyGrid.
FrameworkVersionTypeConverter | This type converter allows you to select a .NET Framework version from those currently installed on the system.
NamespaceSummaryItemEditorDlg | This form is used to edit namespace summaries and to indicate which namespaces should appear in the help file.
ProjectSummaryEditorDlg | This form is used to edit the project summary comments.
VersionTypeConverter | This type converter converts between a string and a Version object and vice versa.

Enumerations

Enumeration | Description
FileDialogType | The type of file dialog to display


ContentFileEditor Class

[image]

Sandcastle Help File Builder Documentation
ContentFileEditor Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This class represents an external application that is used to edit an additional content file.

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
[SerializableAttribute]
public class ContentFileEditor : ICloneable
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class ContentFileEditor _
    Implements ICloneable

Inheritance Hierarchy

System..::.Object
SandcastleBuilder.Utils.Design..::.ContentFileEditor

See Also

ContentFileEditor Members
SandcastleBuilder.Utils.Design Namespace


ContentFileEditor Members

[image] [image]

Sandcastle Help File Builder Documentation
ContentFileEditor Members
ContentFileEditor Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ContentFileEditor type exposes the following members.

Constructors

Name | Description
ContentFileEditor | Constructor

Methods

Name | Description
ActualArguments | Substitute actual values for the macro place holders
Clone | Clone this object
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsEditorFor | See if the given extension is a match for this file editor.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ApplicationPath | This is used to get or set the source path to the editor application.
ApplicationPathSerializable | This property is used to serialize the application path
Arguments | This is used to get or set the parameters to pass to the application.
Description | This is used to get or set a description of the editor application
EditorDescription | This returns a description of the entry suitable for display in a bound list control.
Extensions | This is used to get or set the filename extensions for which this content file editor will be used.
StartupFolder | This is used to set or get the startup folder used when launching the content file editor.
StartupFolderSerializable | This property is used to serialize the startup folder

See Also

ContentFileEditor Class
SandcastleBuilder.Utils.Design Namespace


ContentFileEditor Constructor

[image]

Sandcastle Help File Builder Documentation
ContentFileEditor Constructor
ContentFileEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public ContentFileEditor()
Visual Basic (Declaration)
Public Sub New

See Also

ContentFileEditor Class
SandcastleBuilder.Utils.Design Namespace


ContentFileEditor Methods

[image] [image]

Sandcastle Help File Builder Documentation
ContentFileEditor Methods
ContentFileEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ContentFileEditor type exposes the following members.

Methods

Name | Description
ActualArguments | Substitute actual values for the macro place holders
Clone | Clone this object
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsEditorFor | See if the given extension is a match for this file editor.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ContentFileEditor Class
SandcastleBuilder.Utils.Design Namespace


ActualArguments Method

[image]

Sandcastle Help File Builder Documentation
ContentFileEditor..::.ActualArguments Method
ContentFileEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Substitute actual values for the macro place holders

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string ActualArguments(
    string contentItem,
    string projectFile
)
Visual Basic (Declaration)
Public Function ActualArguments ( _
    contentItem As String, _
    projectFile As String _
) As String

Parameters

contentItem
Type: System..::.String
The content item
projectFile
Type: System..::.String
The current project file

Return Value

A string containing the actual arguments to pass to the editor application.

See Also

ContentFileEditor Class
SandcastleBuilder.Utils.Design Namespace


Clone Method

[image]

Sandcastle Help File Builder Documentation
ContentFileEditor..::.Clone Method
ContentFileEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clone this object

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public Object Clone()
Visual Basic (Declaration)
Public Function Clone As Object

Return Value

A clone of the object

Implements

ICloneable..::.Clone()()()

See Also

ContentFileEditor Class
SandcastleBuilder.Utils.Design Namespace


IsEditorFor Method

[image]

Sandcastle Help File Builder Documentation
ContentFileEditor..::.IsEditorFor Method
ContentFileEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

See if the given extension is a match for this file editor.

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool IsEditorFor(
    string extension
)
Visual Basic (Declaration)
Public Function IsEditorFor ( _
    extension As String _
) As Boolean

Parameters

extension
Type: System..::.String
The extension to check

Return Value

True if this is the editor for the given file extension or false if not.

See Also

ContentFileEditor Class
SandcastleBuilder.Utils.Design Namespace


ContentFileEditor Properties

[image] [image]

Sandcastle Help File Builder Documentation
ContentFileEditor Properties
ContentFileEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ContentFileEditor type exposes the following members.

Properties

Name | Description
ApplicationPath | This is used to get or set the source path to the editor application.
ApplicationPathSerializable | This property is used to serialize the application path
Arguments | This is used to get or set the parameters to pass to the application.
Description | This is used to get or set a description of the editor application
EditorDescription | This returns a description of the entry suitable for display in a bound list control.
Extensions | This is used to get or set the filename extensions for which this content file editor will be used.
StartupFolder | This is used to set or get the startup folder used when launching the content file editor.
StartupFolderSerializable | This property is used to serialize the startup folder

See Also

ContentFileEditor Class
SandcastleBuilder.Utils.Design Namespace


ApplicationPath Property

[image]

Sandcastle Help File Builder Documentation
ContentFileEditor..::.ApplicationPath Property
ContentFileEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set the source path to the editor application.

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public FilePath ApplicationPath { get; set; }
Visual Basic (Declaration)
Public Property ApplicationPath As FilePath

See Also

ContentFileEditor Class
SandcastleBuilder.Utils.Design Namespace


ApplicationPathSerializable Property

[image]

Sandcastle Help File Builder Documentation
ContentFileEditor..::.ApplicationPathSerializable Property
ContentFileEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This property is used to serialize the application path

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string ApplicationPathSerializable { get; set; }
Visual Basic (Declaration)
Public Property ApplicationPathSerializable As String

Remarks

FilePath is not serializable because it does not have a parameterless constructor. This stands in for the ApplicationPath property when this class is serialized.

See Also

ContentFileEditor Class
SandcastleBuilder.Utils.Design Namespace


Arguments Property

[image]

Sandcastle Help File Builder Documentation
ContentFileEditor..::.Arguments Property
ContentFileEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set the parameters to pass to the application.

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string Arguments { get; set; }
Visual Basic (Declaration)
Public Property Arguments As String

Remarks

The following macros can be used to subsitute item and path values into the argument string.
Macro Name | Value Used
$ContentItem | The full path to the content item to be edited
$ProjectFile | The fully qualified path and filename of the current project.
$ProjectFolder | The fully qualified path to the current project.

The macro names are case-insensitive. Enclose arguments in double quotes if they may contain spaces.

See Also

ContentFileEditor Class
SandcastleBuilder.Utils.Design Namespace


Description Property

[image]

Sandcastle Help File Builder Documentation
ContentFileEditor..::.Description Property
ContentFileEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set a description of the editor application

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String

See Also

ContentFileEditor Class
SandcastleBuilder.Utils.Design Namespace


EditorDescription Property

[image]

Sandcastle Help File Builder Documentation
ContentFileEditor..::.EditorDescription Property
ContentFileEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This returns a description of the entry suitable for display in a bound list control.

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string EditorDescription { get; }
Visual Basic (Declaration)
Public ReadOnly Property EditorDescription As String

See Also

ContentFileEditor Class
SandcastleBuilder.Utils.Design Namespace


Extensions Property

[image]

Sandcastle Help File Builder Documentation
ContentFileEditor..::.Extensions Property
ContentFileEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set the filename extensions for which this content file editor will be used.

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string Extensions { get; set; }
Visual Basic (Declaration)
Public Property Extensions As String

Field Value

Separate the extensions with space, semi-colon, or a comma

See Also

ContentFileEditor Class
SandcastleBuilder.Utils.Design Namespace


StartupFolder Property

[image]

Sandcastle Help File Builder Documentation
ContentFileEditor..::.StartupFolder Property
ContentFileEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to set or get the startup folder used when launching the content file editor.

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public FolderPath StartupFolder { get; set; }
Visual Basic (Declaration)
Public Property StartupFolder As FolderPath

Field Value

If not set, the current project's path is used.

See Also

ContentFileEditor Class
SandcastleBuilder.Utils.Design Namespace


StartupFolderSerializable Property

[image]

Sandcastle Help File Builder Documentation
ContentFileEditor..::.StartupFolderSerializable Property
ContentFileEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This property is used to serialize the startup folder

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string StartupFolderSerializable { get; set; }
Visual Basic (Declaration)
Public Property StartupFolderSerializable As String

Remarks

FolderPath is not serializable because it does not have a parameterless constructor. This stands in for the StartupFolder property when this class is serialized.

See Also

ContentFileEditor Class
SandcastleBuilder.Utils.Design Namespace


ContentFileEditorCollection Class

[image]

Sandcastle Help File Builder Documentation
ContentFileEditorCollection Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This collection class is used to hold the additional content file editor definitions.

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
[SerializableAttribute]
public class ContentFileEditorCollection : BindingList<ContentFileEditor>
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class ContentFileEditorCollection _
    Inherits BindingList(Of ContentFileEditor)

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection <(Of <( ContentFileEditor >)>)
System.ComponentModel..::.BindingList <(Of <( ContentFileEditor >)>)
SandcastleBuilder.Utils.Design..::.ContentFileEditorCollection

See Also

ContentFileEditorCollection Members
SandcastleBuilder.Utils.Design Namespace


ContentFileEditorCollection Members

[image] [image]

Sandcastle Help File Builder Documentation
ContentFileEditorCollection Members
ContentFileEditorCollection Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ContentFileEditorCollection type exposes the following members.

Constructors

Name | Description
ContentFileEditorCollection | Overloaded. There are two overloads for the constructor

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ContentFileEditor >)>).)
AddNew | Adds a new item to the collection. (Inherited from BindingList <(Of <( ContentFileEditor >)>).)
AddNewCore | Adds a new item to the end of the collection. (Inherited from BindingList <(Of <( ContentFileEditor >)>).)
AddRange | Add a range of items from another collection
ApplySortCore | Sorts the items if overridden in a derived class; otherwise, throws a NotSupportedException. (Inherited from BindingList <(Of <( ContentFileEditor >)>).)
CancelNew | Discards a pending new item. (Inherited from BindingList <(Of <( ContentFileEditor >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ContentFileEditor >)>).)
ClearItems | Removes all elements from the collection. (Inherited from BindingList <(Of <( ContentFileEditor >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ContentFileEditor >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <( ContentFileEditor >)>).)
EndNew | Commits a pending new item to the collection. (Inherited from BindingList <(Of <( ContentFileEditor >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindCore | Searches for the index of the item that has the specified property descriptor with the specified value, if searching is implemented in a derived class; otherwise, a NotSupportedException. (Inherited from BindingList <(Of <( ContentFileEditor >)>).)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ContentFileEditor >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ContentFileEditor >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( ContentFileEditor >)>).)
InsertItem | Inserts the specified item in the list at the specified index. (Inherited from BindingList <(Of <( ContentFileEditor >)>).)
LaunchEditorFor | Search the list of content file editors and launch the appropriate one for the specified file.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnAddingNew | Raises the AddingNew event. (Inherited from BindingList <(Of <( ContentFileEditor >)>).)
OnListChanged | Raises the ListChanged event. (Inherited from BindingList <(Of <( ContentFileEditor >)>).)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ContentFileEditor >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ContentFileEditor >)>).)
RemoveItem | Removes the item at the specified index. (Inherited from BindingList <(Of <( ContentFileEditor >)>).)
RemoveSortCore | Removes any sort applied with ApplySortCore(PropertyDescriptor, ListSortDirection) if sorting is implemented in a derived class; otherwise, raises NotSupportedException. (Inherited from BindingList <(Of <( ContentFileEditor >)>).)
ResetBindings | Raises a ListChanged event of type Reset. (Inherited from BindingList <(Of <( ContentFileEditor >)>).)
ResetItem | Raises a ListChanged event of type ItemChanged for the item at the specified position. (Inherited from BindingList <(Of <( ContentFileEditor >)>).)
SetItem | Replaces the item at the specified index with the specified item. (Inherited from BindingList <(Of <( ContentFileEditor >)>).)
Sort | Sort the collection by editor description
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AllowEdit | Gets or sets a value indicating whether items in the list can be edited. (Inherited from BindingList <(Of <( ContentFileEditor >)>).)
AllowNew | Gets or sets a value indicating whether you can add items to the list using the AddNew()()() method. (Inherited from BindingList <(Of <( ContentFileEditor >)>).)
AllowRemove | Gets or sets a value indicating whether you can remove items from the collection. (Inherited from BindingList <(Of <( ContentFileEditor >)>).)
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ContentFileEditor >)>).)
GlobalEditors | This returns the reference to the global content file editor collection.
IsSortedCore | Gets a value indicating whether the list is sorted. (Inherited from BindingList <(Of <( ContentFileEditor >)>).)
Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <( ContentFileEditor >)>).)
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ContentFileEditor >)>).)
LastError | If LaunchEditorFor(String, String) returns false, this can be used to retrieve the exception describing why it failed.
RaiseListChangedEvents | Gets or sets a value indicating whether adding or removing items within the list raises ListChanged events. (Inherited from BindingList <(Of <( ContentFileEditor >)>).)
SortDirectionCore | Gets the direction the list is sorted. (Inherited from BindingList <(Of <( ContentFileEditor >)>).)
SortPropertyCore | Gets the property descriptor that is used for sorting the list if sorting is implemented in a derived class; otherwise, returns null. (Inherited from BindingList <(Of <( ContentFileEditor >)>).)
SupportsChangeNotificationCore | Gets a value indicating whether ListChanged events are enabled. (Inherited from BindingList <(Of <( ContentFileEditor >)>).)
SupportsSearchingCore | Gets a value indicating whether the list supports searching. (Inherited from BindingList <(Of <( ContentFileEditor >)>).)
SupportsSortingCore | Gets a value indicating whether the list supports sorting. (Inherited from BindingList <(Of <( ContentFileEditor >)>).)

Events

Name | Description
AddingNew | Occurs before an item is added to the list. (Inherited from BindingList <(Of <( ContentFileEditor >)>).)
ListChanged | Occurs when the list or an item in the list changes. (Inherited from BindingList <(Of <( ContentFileEditor >)>).)

See Also

ContentFileEditorCollection Class
SandcastleBuilder.Utils.Design Namespace


ContentFileEditorCollection Constructor

[image] [image]

Sandcastle Help File Builder Documentation
ContentFileEditorCollection Constructor
ContentFileEditorCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

There are two overloads for the constructor

Overload List

Name | Description
ContentFileEditorCollection()()() | Constructor
ContentFileEditorCollection(ContentFileEditorCollection) | Clone the items in another collection to create this one.

See Also

ContentFileEditorCollection Class
ContentFileEditorCollection Members
SandcastleBuilder.Utils.Design Namespace


ContentFileEditorCollection Constructor

[image]

Sandcastle Help File Builder Documentation
ContentFileEditorCollection Constructor
ContentFileEditorCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public ContentFileEditorCollection()
Visual Basic (Declaration)
Public Sub New

See Also

ContentFileEditorCollection Class
ContentFileEditorCollection Overload
SandcastleBuilder.Utils.Design Namespace


ContentFileEditorCollection Constructor (ContentFileEditorCollection)

[image]

Sandcastle Help File Builder Documentation
ContentFileEditorCollection Constructor (ContentFileEditorCollection)
ContentFileEditorCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clone the items in another collection to create this one.

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public ContentFileEditorCollection(
    ContentFileEditorCollection editors
)
Visual Basic (Declaration)
Public Sub New ( _
    editors As ContentFileEditorCollection _
)

Parameters

editors
Type: SandcastleBuilder.Utils.Design..::.ContentFileEditorCollection
The collection to clone

See Also

ContentFileEditorCollection Class
ContentFileEditorCollection Overload
SandcastleBuilder.Utils.Design Namespace


ContentFileEditorCollection Methods

[image] [image]

Sandcastle Help File Builder Documentation
ContentFileEditorCollection Methods
ContentFileEditorCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ContentFileEditorCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ContentFileEditor >)>).)
AddNew | Adds a new item to the collection. (Inherited from BindingList <(Of <( ContentFileEditor >)>).)
AddNewCore | Adds a new item to the end of the collection. (Inherited from BindingList <(Of <( ContentFileEditor >)>).)
AddRange | Add a range of items from another collection
ApplySortCore | Sorts the items if overridden in a derived class; otherwise, throws a NotSupportedException. (Inherited from BindingList <(Of <( ContentFileEditor >)>).)
CancelNew | Discards a pending new item. (Inherited from BindingList <(Of <( ContentFileEditor >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ContentFileEditor >)>).)
ClearItems | Removes all elements from the collection. (Inherited from BindingList <(Of <( ContentFileEditor >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ContentFileEditor >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <( ContentFileEditor >)>).)
EndNew | Commits a pending new item to the collection. (Inherited from BindingList <(Of <( ContentFileEditor >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindCore | Searches for the index of the item that has the specified property descriptor with the specified value, if searching is implemented in a derived class; otherwise, a NotSupportedException. (Inherited from BindingList <(Of <( ContentFileEditor >)>).)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ContentFileEditor >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ContentFileEditor >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( ContentFileEditor >)>).)
InsertItem | Inserts the specified item in the list at the specified index. (Inherited from BindingList <(Of <( ContentFileEditor >)>).)
LaunchEditorFor | Search the list of content file editors and launch the appropriate one for the specified file.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnAddingNew | Raises the AddingNew event. (Inherited from BindingList <(Of <( ContentFileEditor >)>).)
OnListChanged | Raises the ListChanged event. (Inherited from BindingList <(Of <( ContentFileEditor >)>).)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ContentFileEditor >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ContentFileEditor >)>).)
RemoveItem | Removes the item at the specified index. (Inherited from BindingList <(Of <( ContentFileEditor >)>).)
RemoveSortCore | Removes any sort applied with ApplySortCore(PropertyDescriptor, ListSortDirection) if sorting is implemented in a derived class; otherwise, raises NotSupportedException. (Inherited from BindingList <(Of <( ContentFileEditor >)>).)
ResetBindings | Raises a ListChanged event of type Reset. (Inherited from BindingList <(Of <( ContentFileEditor >)>).)
ResetItem | Raises a ListChanged event of type ItemChanged for the item at the specified position. (Inherited from BindingList <(Of <( ContentFileEditor >)>).)
SetItem | Replaces the item at the specified index with the specified item. (Inherited from BindingList <(Of <( ContentFileEditor >)>).)
Sort | Sort the collection by editor description
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ContentFileEditorCollection Class
SandcastleBuilder.Utils.Design Namespace


AddRange Method

[image]

Sandcastle Help File Builder Documentation
ContentFileEditorCollection..::.AddRange Method
ContentFileEditorCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Add a range of items from another collection

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public void AddRange(
    ContentFileEditorCollection range
)
Visual Basic (Declaration)
Public Sub AddRange ( _
    range As ContentFileEditorCollection _
)

Parameters

range
Type: SandcastleBuilder.Utils.Design..::.ContentFileEditorCollection
The range of items to add

Remarks

The entries are not cloned.

See Also

ContentFileEditorCollection Class
SandcastleBuilder.Utils.Design Namespace


LaunchEditorFor Method

[image]

Sandcastle Help File Builder Documentation
ContentFileEditorCollection..::.LaunchEditorFor Method
ContentFileEditorCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Search the list of content file editors and launch the appropriate one for the specified file.

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool LaunchEditorFor(
    string filename,
    string projectFile
)
Visual Basic (Declaration)
Public Function LaunchEditorFor ( _
    filename As String, _
    projectFile As String _
) As Boolean

Parameters

filename
Type: System..::.String
The filename to edit
projectFile
Type: System..::.String
The fully qualified name of the current project file.

Return Value

True if successful, false if not. LastError can be used to obtain details if it does fail.

Remarks

If an editor is not defined, an attempt is made to launch the file using the OS shell with the Edit verb.

See Also

ContentFileEditorCollection Class
SandcastleBuilder.Utils.Design Namespace


Sort Method

[image]

Sandcastle Help File Builder Documentation
ContentFileEditorCollection..::.Sort Method
ContentFileEditorCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Sort the collection by editor description

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public void Sort()
Visual Basic (Declaration)
Public Sub Sort

See Also

ContentFileEditorCollection Class
SandcastleBuilder.Utils.Design Namespace


ContentFileEditorCollection Properties

[image] [image]

Sandcastle Help File Builder Documentation
ContentFileEditorCollection Properties
ContentFileEditorCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ContentFileEditorCollection type exposes the following members.

Properties

Name | Description
AllowEdit | Gets or sets a value indicating whether items in the list can be edited. (Inherited from BindingList <(Of <( ContentFileEditor >)>).)
AllowNew | Gets or sets a value indicating whether you can add items to the list using the AddNew()()() method. (Inherited from BindingList <(Of <( ContentFileEditor >)>).)
AllowRemove | Gets or sets a value indicating whether you can remove items from the collection. (Inherited from BindingList <(Of <( ContentFileEditor >)>).)
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ContentFileEditor >)>).)
GlobalEditors | This returns the reference to the global content file editor collection.
IsSortedCore | Gets a value indicating whether the list is sorted. (Inherited from BindingList <(Of <( ContentFileEditor >)>).)
Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <( ContentFileEditor >)>).)
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ContentFileEditor >)>).)
LastError | If LaunchEditorFor(String, String) returns false, this can be used to retrieve the exception describing why it failed.
RaiseListChangedEvents | Gets or sets a value indicating whether adding or removing items within the list raises ListChanged events. (Inherited from BindingList <(Of <( ContentFileEditor >)>).)
SortDirectionCore | Gets the direction the list is sorted. (Inherited from BindingList <(Of <( ContentFileEditor >)>).)
SortPropertyCore | Gets the property descriptor that is used for sorting the list if sorting is implemented in a derived class; otherwise, returns null. (Inherited from BindingList <(Of <( ContentFileEditor >)>).)
SupportsChangeNotificationCore | Gets a value indicating whether ListChanged events are enabled. (Inherited from BindingList <(Of <( ContentFileEditor >)>).)
SupportsSearchingCore | Gets a value indicating whether the list supports searching. (Inherited from BindingList <(Of <( ContentFileEditor >)>).)
SupportsSortingCore | Gets a value indicating whether the list supports sorting. (Inherited from BindingList <(Of <( ContentFileEditor >)>).)

See Also

ContentFileEditorCollection Class
SandcastleBuilder.Utils.Design Namespace


GlobalEditors Property

[image]

Sandcastle Help File Builder Documentation
ContentFileEditorCollection..::.GlobalEditors Property
ContentFileEditorCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This returns the reference to the global content file editor collection.

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public static ContentFileEditorCollection GlobalEditors { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property GlobalEditors As ContentFileEditorCollection

See Also

ContentFileEditorCollection Class
SandcastleBuilder.Utils.Design Namespace


LastError Property

[image]

Sandcastle Help File Builder Documentation
ContentFileEditorCollection..::.LastError Property
ContentFileEditorCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

If LaunchEditorFor(String, String) returns false, this can be used to retrieve the exception describing why it failed.

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public Exception LastError { get; }
Visual Basic (Declaration)
Public ReadOnly Property LastError As Exception

See Also

ContentFileEditorCollection Class
SandcastleBuilder.Utils.Design Namespace


ContentFileEditorCollection Events

[image] [image]

Sandcastle Help File Builder Documentation
ContentFileEditorCollection Events
ContentFileEditorCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ContentFileEditorCollection type exposes the following members.

Events

Name | Description
AddingNew | Occurs before an item is added to the list. (Inherited from BindingList <(Of <( ContentFileEditor >)>).)
ListChanged | Occurs when the list or an item in the list changes. (Inherited from BindingList <(Of <( ContentFileEditor >)>).)

See Also

ContentFileEditorCollection Class
SandcastleBuilder.Utils.Design Namespace


DynamicReadOnlyPropertyDescriptor Class

[image]

Sandcastle Help File Builder Documentation
DynamicReadOnlyPropertyDescriptor Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This property descriptor can be used to alter the read-only state of a property in a property grid at runtime based on other conditions.

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public class DynamicReadOnlyPropertyDescriptor : PropertyDescriptor
Visual Basic (Declaration)
Public Class DynamicReadOnlyPropertyDescriptor _
    Inherits PropertyDescriptor

Remarks

To use it, derive a new class and override the IsReadOnly property.

Inheritance Hierarchy

System..::.Object
System.ComponentModel..::.MemberDescriptor
System.ComponentModel..::.PropertyDescriptor
SandcastleBuilder.Utils.Design..::.DynamicReadOnlyPropertyDescriptor

See Also

DynamicReadOnlyPropertyDescriptor Members
SandcastleBuilder.Utils.Design Namespace


DynamicReadOnlyPropertyDescriptor Members

[image] [image]

Sandcastle Help File Builder Documentation
DynamicReadOnlyPropertyDescriptor Members
DynamicReadOnlyPropertyDescriptor Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DynamicReadOnlyPropertyDescriptor type exposes the following members.

Constructors

Name | Description
DynamicReadOnlyPropertyDescriptor | Constructor

Methods

Name | Description
AddValueChanged | Enables other objects to be notified when this property changes. (Inherited from PropertyDescriptor.)
CanResetValue | When overridden in a derived class, returns whether resetting an object changes its value. (Overrides PropertyDescriptor..::.CanResetValue(Object).)
CreateAttributeCollection | Creates a collection of attributes using the array of attributes passed to the constructor. (Inherited from MemberDescriptor.)
CreateInstance | Creates an instance of the specified type. (Inherited from PropertyDescriptor.)
Equals | Compares this to another object to see if they are equivalent. (Inherited from PropertyDescriptor.)
FillAttributes | Adds the attributes of the PropertyDescriptor to the specified list of attributes in the parent class. (Inherited from PropertyDescriptor.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetChildProperties | Overloaded.
GetEditor | Gets an editor of the specified type. (Inherited from PropertyDescriptor.)
GetHashCode | Returns the hash code for this object. (Inherited from PropertyDescriptor.)
GetInvocationTarget | This method returns the object that should be used during invocation of members. (Inherited from PropertyDescriptor.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeFromName | Returns a type using its name. (Inherited from PropertyDescriptor.)
GetValue | When overridden in a derived class, gets the current value of the property on a component. (Overrides PropertyDescriptor..::.GetValue(Object).)
GetValueChangedHandler | Retrieves the current set of ValueChanged event handlers for a specific component (Inherited from PropertyDescriptor.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnValueChanged | Raises the ValueChanged event that you implemented. (Inherited from PropertyDescriptor.)
RemoveValueChanged | Enables other objects to be notified when this property changes. (Inherited from PropertyDescriptor.)
ResetValue | When overridden in a derived class, resets the value for this property of the component to the default value. (Overrides PropertyDescriptor..::.ResetValue(Object).)
SetValue | When overridden in a derived class, sets the value of the component to a different value. (Overrides PropertyDescriptor..::.SetValue(Object, Object).)
ShouldSerializeValue | When overridden in a derived class, determines a value indicating whether the value of this property needs to be persisted. (Overrides PropertyDescriptor..::.ShouldSerializeValue(Object).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AttributeArray | Gets or sets an array of attributes. (Inherited from MemberDescriptor.)
Attributes | Gets the collection of attributes for this member. (Inherited from MemberDescriptor.)
Category | Gets the name of the category to which the member belongs, as specified in the CategoryAttribute. (Inherited from MemberDescriptor.)
ComponentType | When overridden in a derived class, gets the type of the component this property is bound to. (Overrides PropertyDescriptor..::.ComponentType.)
Converter | Gets the type converter for this property. (Inherited from PropertyDescriptor.)
Description | Gets the description of the member, as specified in the DescriptionAttribute. (Inherited from MemberDescriptor.)
DesignTimeOnly | Gets whether this member should be set only at design time, as specified in the DesignOnlyAttribute. (Inherited from MemberDescriptor.)
DisplayName | Gets the name that can be displayed in a window, such as a Properties window. (Inherited from MemberDescriptor.)
IsBrowsable | Gets a value indicating whether the member is browsable, as specified in the BrowsableAttribute. (Inherited from MemberDescriptor.)
IsLocalizable | Gets a value indicating whether this property should be localized, as specified in the LocalizableAttribute. (Inherited from PropertyDescriptor.)
IsReadOnly | When overridden in a derived class, gets a value indicating whether this property is read-only. (Overrides PropertyDescriptor..::.IsReadOnly.)
Name | Gets the name of the member. (Inherited from MemberDescriptor.)
NameHashCode | Gets the hash code for the name of the member, as specified in GetHashCode()()(). (Inherited from MemberDescriptor.)
PropertyDescriptor | This is used to get the property descriptor wrapped by this class
PropertyType | When overridden in a derived class, gets the type of the property. (Overrides PropertyDescriptor..::.PropertyType.)
SerializationVisibility | Gets a value indicating whether this property should be serialized, as specified in the DesignerSerializationVisibilityAttribute. (Inherited from PropertyDescriptor.)
SupportsChangeEvents | Gets a value indicating whether value change notifications for this property may originate from outside the property descriptor. (Inherited from PropertyDescriptor.)
TypeDescriptor | This is used to get the associated type descriptor

See Also

DynamicReadOnlyPropertyDescriptor Class
SandcastleBuilder.Utils.Design Namespace


DynamicReadOnlyPropertyDescriptor Constructor

[image]

Sandcastle Help File Builder Documentation
DynamicReadOnlyPropertyDescriptor Constructor
DynamicReadOnlyPropertyDescriptor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public DynamicReadOnlyPropertyDescriptor(
    ICustomTypeDescriptor typeDescriptor,
    PropertyDescriptor propertyDescriptor
)
Visual Basic (Declaration)
Public Sub New ( _
    typeDescriptor As ICustomTypeDescriptor, _
    propertyDescriptor As PropertyDescriptor _
)

Parameters

typeDescriptor
Type: System.ComponentModel..::.ICustomTypeDescriptor
The type descriptor
propertyDescriptor
Type: System.ComponentModel..::.PropertyDescriptor
The property descriptor

See Also

DynamicReadOnlyPropertyDescriptor Class
SandcastleBuilder.Utils.Design Namespace


DynamicReadOnlyPropertyDescriptor Methods

[image] [image]

Sandcastle Help File Builder Documentation
DynamicReadOnlyPropertyDescriptor Methods
DynamicReadOnlyPropertyDescriptor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DynamicReadOnlyPropertyDescriptor type exposes the following members.

Methods

Name | Description
AddValueChanged | Enables other objects to be notified when this property changes. (Inherited from PropertyDescriptor.)
CanResetValue | When overridden in a derived class, returns whether resetting an object changes its value. (Overrides PropertyDescriptor..::.CanResetValue(Object).)
CreateAttributeCollection | Creates a collection of attributes using the array of attributes passed to the constructor. (Inherited from MemberDescriptor.)
CreateInstance | Creates an instance of the specified type. (Inherited from PropertyDescriptor.)
Equals | Compares this to another object to see if they are equivalent. (Inherited from PropertyDescriptor.)
FillAttributes | Adds the attributes of the PropertyDescriptor to the specified list of attributes in the parent class. (Inherited from PropertyDescriptor.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetChildProperties | Overloaded.
GetEditor | Gets an editor of the specified type. (Inherited from PropertyDescriptor.)
GetHashCode | Returns the hash code for this object. (Inherited from PropertyDescriptor.)
GetInvocationTarget | This method returns the object that should be used during invocation of members. (Inherited from PropertyDescriptor.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeFromName | Returns a type using its name. (Inherited from PropertyDescriptor.)
GetValue | When overridden in a derived class, gets the current value of the property on a component. (Overrides PropertyDescriptor..::.GetValue(Object).)
GetValueChangedHandler | Retrieves the current set of ValueChanged event handlers for a specific component (Inherited from PropertyDescriptor.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnValueChanged | Raises the ValueChanged event that you implemented. (Inherited from PropertyDescriptor.)
RemoveValueChanged | Enables other objects to be notified when this property changes. (Inherited from PropertyDescriptor.)
ResetValue | When overridden in a derived class, resets the value for this property of the component to the default value. (Overrides PropertyDescriptor..::.ResetValue(Object).)
SetValue | When overridden in a derived class, sets the value of the component to a different value. (Overrides PropertyDescriptor..::.SetValue(Object, Object).)
ShouldSerializeValue | When overridden in a derived class, determines a value indicating whether the value of this property needs to be persisted. (Overrides PropertyDescriptor..::.ShouldSerializeValue(Object).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DynamicReadOnlyPropertyDescriptor Class
SandcastleBuilder.Utils.Design Namespace


CanResetValue Method

[image]

Sandcastle Help File Builder Documentation
DynamicReadOnlyPropertyDescriptor..::.CanResetValue Method
DynamicReadOnlyPropertyDescriptor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

When overridden in a derived class, returns whether resetting an object changes its value.

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public override bool CanResetValue(
    Object component
)
Visual Basic (Declaration)
Public Overrides Function CanResetValue ( _
    component As Object _
) As Boolean

Parameters

component
Type: System..::.Object
The component to test for reset capability.

Return Value

true if resetting the component changes its value; otherwise, false.

See Also

DynamicReadOnlyPropertyDescriptor Class
SandcastleBuilder.Utils.Design Namespace


GetChildProperties Method

[image] [image]

Sandcastle Help File Builder Documentation
DynamicReadOnlyPropertyDescriptor..::.GetChildProperties Method
DynamicReadOnlyPropertyDescriptor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildProperties()()() | Returns the default PropertyDescriptorCollection. (Inherited from PropertyDescriptor.)
GetChildProperties(array<Attribute>[]()[]) | Returns a PropertyDescriptorCollection using a specified array of attributes as a filter. (Inherited from PropertyDescriptor.)
GetChildProperties(Object) | Returns a PropertyDescriptorCollection for a given object. (Inherited from PropertyDescriptor.)
GetChildProperties(Object, array<Attribute>[]()[]) | Returns a PropertyDescriptorCollection for a given object using a specified array of attributes as a filter. (Inherited from PropertyDescriptor.)

See Also

DynamicReadOnlyPropertyDescriptor Class
DynamicReadOnlyPropertyDescriptor Members
SandcastleBuilder.Utils.Design Namespace


GetValue Method

[image]

Sandcastle Help File Builder Documentation
DynamicReadOnlyPropertyDescriptor..::.GetValue Method
DynamicReadOnlyPropertyDescriptor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

When overridden in a derived class, gets the current value of the property on a component.

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public override Object GetValue(
    Object component
)
Visual Basic (Declaration)
Public Overrides Function GetValue ( _
    component As Object _
) As Object

Parameters

component
Type: System..::.Object
The component with the property for which to retrieve the value.

Return Value

The value of a property for a given component.

See Also

DynamicReadOnlyPropertyDescriptor Class
SandcastleBuilder.Utils.Design Namespace


ResetValue Method

[image]

Sandcastle Help File Builder Documentation
DynamicReadOnlyPropertyDescriptor..::.ResetValue Method
DynamicReadOnlyPropertyDescriptor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

When overridden in a derived class, resets the value for this property of the component to the default value.

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public override void ResetValue(
    Object component
)
Visual Basic (Declaration)
Public Overrides Sub ResetValue ( _
    component As Object _
)

Parameters

component
Type: System..::.Object
The component with the property value that is to be reset to the default value.

See Also

DynamicReadOnlyPropertyDescriptor Class
SandcastleBuilder.Utils.Design Namespace


SetValue Method

[image]

Sandcastle Help File Builder Documentation
DynamicReadOnlyPropertyDescriptor..::.SetValue Method
DynamicReadOnlyPropertyDescriptor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

When overridden in a derived class, sets the value of the component to a different value.

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public override void SetValue(
    Object component,
    Object value
)
Visual Basic (Declaration)
Public Overrides Sub SetValue ( _
    component As Object, _
    value As Object _
)

Parameters

component
Type: System..::.Object
The component with the property value that is to be set.
value
Type: System..::.Object
The new value.

See Also

DynamicReadOnlyPropertyDescriptor Class
SandcastleBuilder.Utils.Design Namespace


ShouldSerializeValue Method

[image]

Sandcastle Help File Builder Documentation
DynamicReadOnlyPropertyDescriptor..::.ShouldSerializeValue Method
DynamicReadOnlyPropertyDescriptor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

When overridden in a derived class, determines a value indicating whether the value of this property needs to be persisted.

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public override bool ShouldSerializeValue(
    Object component
)
Visual Basic (Declaration)
Public Overrides Function ShouldSerializeValue ( _
    component As Object _
) As Boolean

Parameters

component
Type: System..::.Object
The component with the property to be examined for persistence.

Return Value

true if the property should be persisted; otherwise, false.

See Also

DynamicReadOnlyPropertyDescriptor Class
SandcastleBuilder.Utils.Design Namespace


DynamicReadOnlyPropertyDescriptor Properties

[image] [image]

Sandcastle Help File Builder Documentation
DynamicReadOnlyPropertyDescriptor Properties
DynamicReadOnlyPropertyDescriptor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DynamicReadOnlyPropertyDescriptor type exposes the following members.

Properties

Name | Description
AttributeArray | Gets or sets an array of attributes. (Inherited from MemberDescriptor.)
Attributes | Gets the collection of attributes for this member. (Inherited from MemberDescriptor.)
Category | Gets the name of the category to which the member belongs, as specified in the CategoryAttribute. (Inherited from MemberDescriptor.)
ComponentType | When overridden in a derived class, gets the type of the component this property is bound to. (Overrides PropertyDescriptor..::.ComponentType.)
Converter | Gets the type converter for this property. (Inherited from PropertyDescriptor.)
Description | Gets the description of the member, as specified in the DescriptionAttribute. (Inherited from MemberDescriptor.)
DesignTimeOnly | Gets whether this member should be set only at design time, as specified in the DesignOnlyAttribute. (Inherited from MemberDescriptor.)
DisplayName | Gets the name that can be displayed in a window, such as a Properties window. (Inherited from MemberDescriptor.)
IsBrowsable | Gets a value indicating whether the member is browsable, as specified in the BrowsableAttribute. (Inherited from MemberDescriptor.)
IsLocalizable | Gets a value indicating whether this property should be localized, as specified in the LocalizableAttribute. (Inherited from PropertyDescriptor.)
IsReadOnly | When overridden in a derived class, gets a value indicating whether this property is read-only. (Overrides PropertyDescriptor..::.IsReadOnly.)
Name | Gets the name of the member. (Inherited from MemberDescriptor.)
NameHashCode | Gets the hash code for the name of the member, as specified in GetHashCode()()(). (Inherited from MemberDescriptor.)
PropertyDescriptor | This is used to get the property descriptor wrapped by this class
PropertyType | When overridden in a derived class, gets the type of the property. (Overrides PropertyDescriptor..::.PropertyType.)
SerializationVisibility | Gets a value indicating whether this property should be serialized, as specified in the DesignerSerializationVisibilityAttribute. (Inherited from PropertyDescriptor.)
SupportsChangeEvents | Gets a value indicating whether value change notifications for this property may originate from outside the property descriptor. (Inherited from PropertyDescriptor.)
TypeDescriptor | This is used to get the associated type descriptor

See Also

DynamicReadOnlyPropertyDescriptor Class
SandcastleBuilder.Utils.Design Namespace


ComponentType Property

[image]

Sandcastle Help File Builder Documentation
DynamicReadOnlyPropertyDescriptor..::.ComponentType Property
DynamicReadOnlyPropertyDescriptor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

When overridden in a derived class, gets the type of the component this property is bound to.

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public override Type ComponentType { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property ComponentType As Type

Return Value

A Type that represents the type of component this property is bound to. When the GetValue(Object) or SetValue(Object, Object) methods are invoked, the object specified might be an instance of this type.

See Also

DynamicReadOnlyPropertyDescriptor Class
SandcastleBuilder.Utils.Design Namespace


IsReadOnly Property

[image]

Sandcastle Help File Builder Documentation
DynamicReadOnlyPropertyDescriptor..::.IsReadOnly Property
DynamicReadOnlyPropertyDescriptor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

When overridden in a derived class, gets a value indicating whether this property is read-only.

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public override bool IsReadOnly { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property IsReadOnly As Boolean

Return Value

true if the property is read-only; otherwise, false.

Remarks

Derived classes must override this method

See Also

DynamicReadOnlyPropertyDescriptor Class
SandcastleBuilder.Utils.Design Namespace


PropertyDescriptor Property

[image]

Sandcastle Help File Builder Documentation
DynamicReadOnlyPropertyDescriptor..::.PropertyDescriptor Property
DynamicReadOnlyPropertyDescriptor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get the property descriptor wrapped by this class

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public PropertyDescriptor PropertyDescriptor { get; }
Visual Basic (Declaration)
Public ReadOnly Property PropertyDescriptor As PropertyDescriptor

See Also

DynamicReadOnlyPropertyDescriptor Class
SandcastleBuilder.Utils.Design Namespace


PropertyType Property

[image]

Sandcastle Help File Builder Documentation
DynamicReadOnlyPropertyDescriptor..::.PropertyType Property
DynamicReadOnlyPropertyDescriptor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

When overridden in a derived class, gets the type of the property.

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public override Type PropertyType { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property PropertyType As Type

Return Value

A Type that represents the type of the property.

See Also

DynamicReadOnlyPropertyDescriptor Class
SandcastleBuilder.Utils.Design Namespace


TypeDescriptor Property

[image]

Sandcastle Help File Builder Documentation
DynamicReadOnlyPropertyDescriptor..::.TypeDescriptor Property
DynamicReadOnlyPropertyDescriptor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get the associated type descriptor

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public ICustomTypeDescriptor TypeDescriptor { get; }
Visual Basic (Declaration)
Public ReadOnly Property TypeDescriptor As ICustomTypeDescriptor

See Also

DynamicReadOnlyPropertyDescriptor Class
SandcastleBuilder.Utils.Design Namespace


EscapeValueAttribute Class

[image]

Sandcastle Help File Builder Documentation
EscapeValueAttribute Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to mark a property that needs its value escaped when stored in an MSBuild project file.

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public sealed class EscapeValueAttribute : Attribute
Visual Basic (Declaration)
Public NotInheritable Class EscapeValueAttribute _
    Inherits Attribute

Remarks

MSBuild requires that the following characters be escaped in property values unless they are intended to be interpreted by the build engine: % * ? @ $ ( ) ; '. In addition, this attribute will cause the values to be HTML encoded so that any HTML characters, especially tag delimiters are not interpreted. MSBuild tends to add XML namespaces to things it thinks are XML elements.

Inheritance Hierarchy

System..::.Object
System..::.Attribute
SandcastleBuilder.Utils.Design..::.EscapeValueAttribute

See Also

EscapeValueAttribute Members
SandcastleBuilder.Utils.Design Namespace


EscapeValueAttribute Members

[image] [image]

Sandcastle Help File Builder Documentation
EscapeValueAttribute Members
EscapeValueAttribute Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The EscapeValueAttribute type exposes the following members.

Constructors

Name | Description
EscapeValueAttribute | Initializes a new instance of the EscapeValueAttribute class

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Escape | This is used to HTML encode and escape an MSBuild property value.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Unescape | This is used to return an unescaped and HTML decoded MSBuild value

Properties

Name | Description
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

EscapeValueAttribute Class
SandcastleBuilder.Utils.Design Namespace


EscapeValueAttribute Constructor

[image]

Sandcastle Help File Builder Documentation
EscapeValueAttribute Constructor
EscapeValueAttribute Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the EscapeValueAttribute class

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public EscapeValueAttribute()
Visual Basic (Declaration)
Public Sub New

See Also

EscapeValueAttribute Class
SandcastleBuilder.Utils.Design Namespace


EscapeValueAttribute Methods

[image] [image]

Sandcastle Help File Builder Documentation
EscapeValueAttribute Methods
EscapeValueAttribute Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The EscapeValueAttribute type exposes the following members.

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Escape | This is used to HTML encode and escape an MSBuild property value.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Unescape | This is used to return an unescaped and HTML decoded MSBuild value

See Also

EscapeValueAttribute Class
SandcastleBuilder.Utils.Design Namespace


Escape Method

[image]

Sandcastle Help File Builder Documentation
EscapeValueAttribute..::.Escape Method
EscapeValueAttribute Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to HTML encode and escape an MSBuild property value.

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public static string Escape(
    string unescapedValue
)
Visual Basic (Declaration)
Public Shared Function Escape ( _
    unescapedValue As String _
) As String

Parameters

unescapedValue
Type: System..::.String
The unescaped value

Return Value

The HTML encoded escaped value

See Also

EscapeValueAttribute Class
SandcastleBuilder.Utils.Design Namespace


Unescape Method

[image]

Sandcastle Help File Builder Documentation
EscapeValueAttribute..::.Unescape Method
EscapeValueAttribute Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to return an unescaped and HTML decoded MSBuild value

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public static string Unescape(
    string escapedValue
)
Visual Basic (Declaration)
Public Shared Function Unescape ( _
    escapedValue As String _
) As String

Parameters

escapedValue
Type: System..::.String
The escaped value

Return Value

The unescaped and HTML decoded value

Remarks

MSBuild provides an escape method but no unescape method. Go figure.

See Also

EscapeValueAttribute Class
SandcastleBuilder.Utils.Design Namespace


EscapeValueAttribute Properties

[image] [image]

Sandcastle Help File Builder Documentation
EscapeValueAttribute Properties
EscapeValueAttribute Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The EscapeValueAttribute type exposes the following members.

Properties

Name | Description
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

EscapeValueAttribute Class
SandcastleBuilder.Utils.Design Namespace


FileDialogAttribute Class

[image]

Sandcastle Help File Builder Documentation
FileDialogAttribute Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This attribute is used to associate file dialog parameters with a class property for use in editing it in a property grid.

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public sealed class FileDialogAttribute : Attribute
Visual Basic (Declaration)
Public NotInheritable Class FileDialogAttribute _
    Inherits Attribute

Inheritance Hierarchy

System..::.Object
System..::.Attribute
SandcastleBuilder.Utils.Design..::.FileDialogAttribute

See Also

FileDialogAttribute Members
SandcastleBuilder.Utils.Design Namespace
SandcastleBuilder.Utils.Design..::.FilePathStringEditor
SandcastleBuilder.Utils.Design..::.FilePathObjectEditor


FileDialogAttribute Members

[image] [image]

Sandcastle Help File Builder Documentation
FileDialogAttribute Members
FileDialogAttribute Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FileDialogAttribute type exposes the following members.

Constructors

Name | Description
FileDialogAttribute | Overloaded. There are two overloads for the constructor.

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DialogType | This is used to get the file dialog type
Filter | This is used to get the file dialog filter
Title | This is used to get the file dialog title
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

FileDialogAttribute Class
SandcastleBuilder.Utils.Design Namespace


FileDialogAttribute Constructor

[image] [image]

Sandcastle Help File Builder Documentation
FileDialogAttribute Constructor
FileDialogAttribute Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

There are two overloads for the constructor.

Overload List

Name | Description
FileDialogAttribute(String) | Constructor
FileDialogAttribute(String, String, FileDialogType) | Constructor

See Also

FileDialogAttribute Class
FileDialogAttribute Members
SandcastleBuilder.Utils.Design Namespace


FileDialogAttribute Constructor (String)

[image]

Sandcastle Help File Builder Documentation
FileDialogAttribute Constructor (String)
FileDialogAttribute Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public FileDialogAttribute(
    string title
)
Visual Basic (Declaration)
Public Sub New ( _
    title As String _
)

Parameters

title
Type: System..::.String
The title for the file dialog

Remarks

The filter defaults to "All Files (*.*)|*.*" and the dialog type defaults to FileOpen

See Also

FileDialogAttribute Class
FileDialogAttribute Overload
SandcastleBuilder.Utils.Design Namespace


FileDialogAttribute Constructor (String, String, FileDialogType)

[image]

Sandcastle Help File Builder Documentation
FileDialogAttribute Constructor (String, String, FileDialogType)
FileDialogAttribute Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public FileDialogAttribute(
    string title,
    string filter,
    FileDialogType dialogType
)
Visual Basic (Declaration)
Public Sub New ( _
    title As String, _
    filter As String, _
    dialogType As FileDialogType _
)

Parameters

title
Type: System..::.String
The title for the file dialog
filter
Type: System..::.String
The filter to use for the file dialog
dialogType
Type: SandcastleBuilder.Utils.Design..::.FileDialogType
The type of file dialog to display

See Also

FileDialogAttribute Class
FileDialogAttribute Overload
SandcastleBuilder.Utils.Design Namespace


FileDialogAttribute Methods

[image] [image]

Sandcastle Help File Builder Documentation
FileDialogAttribute Methods
FileDialogAttribute Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FileDialogAttribute type exposes the following members.

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FileDialogAttribute Class
SandcastleBuilder.Utils.Design Namespace


FileDialogAttribute Properties

[image] [image]

Sandcastle Help File Builder Documentation
FileDialogAttribute Properties
FileDialogAttribute Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FileDialogAttribute type exposes the following members.

Properties

Name | Description
DialogType | This is used to get the file dialog type
Filter | This is used to get the file dialog filter
Title | This is used to get the file dialog title
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

FileDialogAttribute Class
SandcastleBuilder.Utils.Design Namespace


DialogType Property

[image]

Sandcastle Help File Builder Documentation
FileDialogAttribute..::.DialogType Property
FileDialogAttribute Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get the file dialog type

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public FileDialogType DialogType { get; }
Visual Basic (Declaration)
Public ReadOnly Property DialogType As FileDialogType

See Also

FileDialogAttribute Class
SandcastleBuilder.Utils.Design Namespace


Filter Property

[image]

Sandcastle Help File Builder Documentation
FileDialogAttribute..::.Filter Property
FileDialogAttribute Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get the file dialog filter

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string Filter { get; }
Visual Basic (Declaration)
Public ReadOnly Property Filter As String

See Also

FileDialogAttribute Class
SandcastleBuilder.Utils.Design Namespace


Title Property

[image]

Sandcastle Help File Builder Documentation
FileDialogAttribute..::.Title Property
FileDialogAttribute Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get the file dialog title

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string Title { get; }
Visual Basic (Declaration)
Public ReadOnly Property Title As String

See Also

FileDialogAttribute Class
SandcastleBuilder.Utils.Design Namespace


FileDialogType Enumeration

[image]

Sandcastle Help File Builder Documentation
FileDialogType Enumeration
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The type of file dialog to display

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public enum FileDialogType
Visual Basic (Declaration)
Public Enumeration FileDialogType

Members

Member name | Description
FileOpen | Display a File Open dialog box
FileSave | Display a File Save dialog box

See Also

SandcastleBuilder.Utils.Design Namespace


FilePathObjectEditor Class

[image]

Sandcastle Help File Builder Documentation
FilePathObjectEditor Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is a type editor that can display a file dialog to allow selection of a file path at design time for a FilePath object.

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public class FilePathObjectEditor : FilePathStringEditor
Visual Basic (Declaration)
Public Class FilePathObjectEditor _
    Inherits FilePathStringEditor

Remarks

It is used in conjunction with the FileDialogAttribute to specify the file dialog title, filter, and type

Inheritance Hierarchy

System..::.Object
System.Drawing.Design..::.UITypeEditor
SandcastleBuilder.Utils.Design..::.FilePathStringEditor
SandcastleBuilder.Utils.Design..::.FilePathObjectEditor

See Also

FilePathObjectEditor Members
SandcastleBuilder.Utils.Design Namespace


FilePathObjectEditor Members

[image] [image]

Sandcastle Help File Builder Documentation
FilePathObjectEditor Members
FilePathObjectEditor Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FilePathObjectEditor type exposes the following members.

Constructors

Name | Description
FilePathObjectEditor | Initializes a new instance of the FilePathObjectEditor class

Methods

Name | Description
EditValue | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEditStyle | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPaintValueSupported | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PaintValue | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from UITypeEditor.)

See Also

FilePathObjectEditor Class
SandcastleBuilder.Utils.Design Namespace


FilePathObjectEditor Constructor

[image]

Sandcastle Help File Builder Documentation
FilePathObjectEditor Constructor
FilePathObjectEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the FilePathObjectEditor class

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public FilePathObjectEditor()
Visual Basic (Declaration)
Public Sub New

See Also

FilePathObjectEditor Class
SandcastleBuilder.Utils.Design Namespace


FilePathObjectEditor Methods

[image] [image]

Sandcastle Help File Builder Documentation
FilePathObjectEditor Methods
FilePathObjectEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FilePathObjectEditor type exposes the following members.

Methods

Name | Description
EditValue | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEditStyle | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPaintValueSupported | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PaintValue | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilePathObjectEditor Class
SandcastleBuilder.Utils.Design Namespace


EditValue Method

[image] [image]

Sandcastle Help File Builder Documentation
FilePathObjectEditor..::.EditValue Method
FilePathObjectEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
EditValue(IServiceProvider, Object) | Edits the value of the specified object using the editor style indicated by the GetEditStyle()()() method. (Inherited from UITypeEditor.)
EditValue(ITypeDescriptorContext, IServiceProvider, Object) | This is overridden to edit the value using a file dialog. (Overrides FilePathStringEditor..::.EditValue(ITypeDescriptorContext, IServiceProvider, Object).)

See Also

FilePathObjectEditor Class
FilePathObjectEditor Members
SandcastleBuilder.Utils.Design Namespace


EditValue Method (ITypeDescriptorContext, IServiceProvider, Object)

[image]

Sandcastle Help File Builder Documentation
FilePathObjectEditor..::.EditValue Method (ITypeDescriptorContext, IServiceProvider, Object)
FilePathObjectEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is overridden to edit the value using a file dialog.

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public override Object EditValue(
    ITypeDescriptorContext context,
    IServiceProvider provider,
    Object value
)
Visual Basic (Declaration)
Public Overrides Function EditValue ( _
    context As ITypeDescriptorContext, _
    provider As IServiceProvider, _
    value As Object _
) As Object

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
The descriptor context
provider
Type: System..::.IServiceProvider
The provider
value
Type: System..::.Object
The file path as an object

Return Value

The selected file path as an object

See Also

FilePathObjectEditor Class
EditValue Overload
SandcastleBuilder.Utils.Design Namespace


GetEditStyle Method

[image] [image]

Sandcastle Help File Builder Documentation
FilePathObjectEditor..::.GetEditStyle Method
FilePathObjectEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetEditStyle()()() | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Inherited from UITypeEditor.)
GetEditStyle(ITypeDescriptorContext) | This is overridden to specify the editor's edit style (Inherited from FilePathStringEditor.)

See Also

FilePathObjectEditor Class
FilePathObjectEditor Members
SandcastleBuilder.Utils.Design Namespace


GetPaintValueSupported Method

[image] [image]

Sandcastle Help File Builder Documentation
FilePathObjectEditor..::.GetPaintValueSupported Method
FilePathObjectEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetPaintValueSupported()()() | Indicates whether this editor supports painting a representation of an object's value. (Inherited from UITypeEditor.)
GetPaintValueSupported(ITypeDescriptorContext) | Indicates whether the specified context supports painting a representation of an object's value within the specified context. (Inherited from UITypeEditor.)

See Also

FilePathObjectEditor Class
FilePathObjectEditor Members
SandcastleBuilder.Utils.Design Namespace


PaintValue Method

[image] [image]

Sandcastle Help File Builder Documentation
FilePathObjectEditor..::.PaintValue Method
FilePathObjectEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PaintValue(PaintValueEventArgs) | Paints a representation of the value of an object using the specified PaintValueEventArgs. (Inherited from UITypeEditor.)
PaintValue(Object, Graphics, Rectangle) | Paints a representation of the value of the specified object to the specified canvas. (Inherited from UITypeEditor.)

See Also

FilePathObjectEditor Class
FilePathObjectEditor Members
SandcastleBuilder.Utils.Design Namespace


FilePathObjectEditor Properties

[image] [image]

Sandcastle Help File Builder Documentation
FilePathObjectEditor Properties
FilePathObjectEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FilePathObjectEditor type exposes the following members.

Properties

Name | Description
IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from UITypeEditor.)

See Also

FilePathObjectEditor Class
SandcastleBuilder.Utils.Design Namespace


FilePathStringEditor Class

[image]

Sandcastle Help File Builder Documentation
FilePathStringEditor Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is a type editor that can display a file dialog to allow selection of a file path at design time for a string object.

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public class FilePathStringEditor : UITypeEditor
Visual Basic (Declaration)
Public Class FilePathStringEditor _
    Inherits UITypeEditor

Remarks

It is used in conjunction with the FileDialogAttribute to specify the file dialog title, filter, and type

Inheritance Hierarchy

System..::.Object
System.Drawing.Design..::.UITypeEditor
SandcastleBuilder.Utils.Design..::.FilePathStringEditor
SandcastleBuilder.Utils.Design..::.FilePathObjectEditor

See Also

FilePathStringEditor Members
SandcastleBuilder.Utils.Design Namespace


FilePathStringEditor Members

[image] [image]

Sandcastle Help File Builder Documentation
FilePathStringEditor Members
FilePathStringEditor Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FilePathStringEditor type exposes the following members.

Constructors

Name | Description
FilePathStringEditor | Initializes a new instance of the FilePathStringEditor class

Methods

Name | Description
EditValue | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEditStyle | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPaintValueSupported | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PaintValue | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from UITypeEditor.)

See Also

FilePathStringEditor Class
SandcastleBuilder.Utils.Design Namespace


FilePathStringEditor Constructor

[image]

Sandcastle Help File Builder Documentation
FilePathStringEditor Constructor
FilePathStringEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the FilePathStringEditor class

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public FilePathStringEditor()
Visual Basic (Declaration)
Public Sub New

See Also

FilePathStringEditor Class
SandcastleBuilder.Utils.Design Namespace


FilePathStringEditor Methods

[image] [image]

Sandcastle Help File Builder Documentation
FilePathStringEditor Methods
FilePathStringEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FilePathStringEditor type exposes the following members.

Methods

Name | Description
EditValue | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEditStyle | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPaintValueSupported | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PaintValue | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilePathStringEditor Class
SandcastleBuilder.Utils.Design Namespace


EditValue Method

[image] [image]

Sandcastle Help File Builder Documentation
FilePathStringEditor..::.EditValue Method
FilePathStringEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
EditValue(IServiceProvider, Object) | Edits the value of the specified object using the editor style indicated by the GetEditStyle()()() method. (Inherited from UITypeEditor.)
EditValue(ITypeDescriptorContext, IServiceProvider, Object) | This is overridden to edit the value using a file dialog. (Overrides UITypeEditor..::.EditValue(ITypeDescriptorContext, IServiceProvider, Object).)

See Also

FilePathStringEditor Class
FilePathStringEditor Members
SandcastleBuilder.Utils.Design Namespace


EditValue Method (ITypeDescriptorContext, IServiceProvider, Object)

[image]

Sandcastle Help File Builder Documentation
FilePathStringEditor..::.EditValue Method (ITypeDescriptorContext, IServiceProvider, Object)
FilePathStringEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is overridden to edit the value using a file dialog.

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public override Object EditValue(
    ITypeDescriptorContext context,
    IServiceProvider provider,
    Object value
)
Visual Basic (Declaration)
Public Overrides Function EditValue ( _
    context As ITypeDescriptorContext, _
    provider As IServiceProvider, _
    value As Object _
) As Object

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
The descriptor context
provider
Type: System..::.IServiceProvider
The provider
value
Type: System..::.Object
The file path as an object

Return Value

The selected file path as an object

See Also

FilePathStringEditor Class
EditValue Overload
SandcastleBuilder.Utils.Design Namespace


GetEditStyle Method

[image] [image]

Sandcastle Help File Builder Documentation
FilePathStringEditor..::.GetEditStyle Method
FilePathStringEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetEditStyle()()() | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Inherited from UITypeEditor.)
GetEditStyle(ITypeDescriptorContext) | This is overridden to specify the editor's edit style (Overrides UITypeEditor..::.GetEditStyle(ITypeDescriptorContext).)

See Also

FilePathStringEditor Class
FilePathStringEditor Members
SandcastleBuilder.Utils.Design Namespace


GetEditStyle Method (ITypeDescriptorContext)

[image]

Sandcastle Help File Builder Documentation
FilePathStringEditor..::.GetEditStyle Method (ITypeDescriptorContext)
FilePathStringEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is overridden to specify the editor's edit style

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public override UITypeEditorEditStyle GetEditStyle(
    ITypeDescriptorContext context
)
Visual Basic (Declaration)
Public Overrides Function GetEditStyle ( _
    context As ITypeDescriptorContext _
) As UITypeEditorEditStyle

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
The descriptor context

Return Value

Always returns Modal as long as there is a context and an instance. Otherwise, it returns None.

See Also

FilePathStringEditor Class
GetEditStyle Overload
SandcastleBuilder.Utils.Design Namespace


GetPaintValueSupported Method

[image] [image]

Sandcastle Help File Builder Documentation
FilePathStringEditor..::.GetPaintValueSupported Method
FilePathStringEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetPaintValueSupported()()() | Indicates whether this editor supports painting a representation of an object's value. (Inherited from UITypeEditor.)
GetPaintValueSupported(ITypeDescriptorContext) | Indicates whether the specified context supports painting a representation of an object's value within the specified context. (Inherited from UITypeEditor.)

See Also

FilePathStringEditor Class
FilePathStringEditor Members
SandcastleBuilder.Utils.Design Namespace


PaintValue Method

[image] [image]

Sandcastle Help File Builder Documentation
FilePathStringEditor..::.PaintValue Method
FilePathStringEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PaintValue(PaintValueEventArgs) | Paints a representation of the value of an object using the specified PaintValueEventArgs. (Inherited from UITypeEditor.)
PaintValue(Object, Graphics, Rectangle) | Paints a representation of the value of the specified object to the specified canvas. (Inherited from UITypeEditor.)

See Also

FilePathStringEditor Class
FilePathStringEditor Members
SandcastleBuilder.Utils.Design Namespace


FilePathStringEditor Properties

[image] [image]

Sandcastle Help File Builder Documentation
FilePathStringEditor Properties
FilePathStringEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FilePathStringEditor type exposes the following members.

Properties

Name | Description
IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from UITypeEditor.)

See Also

FilePathStringEditor Class
SandcastleBuilder.Utils.Design Namespace


FilePathTypeConverter Class

[image]

Sandcastle Help File Builder Documentation
FilePathTypeConverter Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This type converter is used to convert a FilePath object to and from a string so that it can be edited in a PropertyGrid.

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public class FilePathTypeConverter : ExpandableObjectConverter
Visual Basic (Declaration)
Public Class FilePathTypeConverter _
    Inherits ExpandableObjectConverter

Inheritance Hierarchy

System..::.Object
System.ComponentModel..::.TypeConverter
System.ComponentModel..::.ExpandableObjectConverter
SandcastleBuilder.Utils.Design..::.FilePathTypeConverter

See Also

FilePathTypeConverter Members
SandcastleBuilder.Utils.Design Namespace


FilePathTypeConverter Members

[image] [image]

Sandcastle Help File Builder Documentation
FilePathTypeConverter Members
FilePathTypeConverter Class Constructors Methods See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FilePathTypeConverter type exposes the following members.

Constructors

Name | Description
FilePathTypeConverter | Initializes a new instance of the FilePathTypeConverter class

Methods

Name | Description
CanConvertFrom | Overloaded.
CanConvertTo | Overloaded.
ConvertFrom | Overloaded.
ConvertFromInvariantString | Overloaded.
ConvertFromString | Overloaded.
ConvertTo | Overloaded.
ConvertToInvariantString | Overloaded.
ConvertToString | Overloaded.
CreateInstance | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
GetCreateInstanceSupported | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetProperties | Overloaded.
GetPropertiesSupported | Overloaded.
GetStandardValues | Overloaded.
GetStandardValuesExclusive | Overloaded.
GetStandardValuesSupported | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilePathTypeConverter Class
SandcastleBuilder.Utils.Design Namespace


FilePathTypeConverter Constructor

[image]

Sandcastle Help File Builder Documentation
FilePathTypeConverter Constructor
FilePathTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the FilePathTypeConverter class

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public FilePathTypeConverter()
Visual Basic (Declaration)
Public Sub New

See Also

FilePathTypeConverter Class
SandcastleBuilder.Utils.Design Namespace


FilePathTypeConverter Methods

[image] [image]

Sandcastle Help File Builder Documentation
FilePathTypeConverter Methods
FilePathTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FilePathTypeConverter type exposes the following members.

Methods

Name | Description
CanConvertFrom | Overloaded.
CanConvertTo | Overloaded.
ConvertFrom | Overloaded.
ConvertFromInvariantString | Overloaded.
ConvertFromString | Overloaded.
ConvertTo | Overloaded.
ConvertToInvariantString | Overloaded.
ConvertToString | Overloaded.
CreateInstance | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
GetCreateInstanceSupported | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetProperties | Overloaded.
GetPropertiesSupported | Overloaded.
GetStandardValues | Overloaded.
GetStandardValuesExclusive | Overloaded.
GetStandardValuesSupported | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilePathTypeConverter Class
SandcastleBuilder.Utils.Design Namespace


CanConvertFrom Method

[image] [image]

Sandcastle Help File Builder Documentation
FilePathTypeConverter..::.CanConvertFrom Method
FilePathTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context. (Overrides TypeConverter..::.CanConvertFrom(ITypeDescriptorContext, Type).)

See Also

FilePathTypeConverter Class
FilePathTypeConverter Members
SandcastleBuilder.Utils.Design Namespace


CanConvertFrom Method (ITypeDescriptorContext, Type)

[image]

Sandcastle Help File Builder Documentation
FilePathTypeConverter..::.CanConvertFrom Method (ITypeDescriptorContext, Type)
FilePathTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context.

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public override bool CanConvertFrom(
    ITypeDescriptorContext context,
    Type sourceType
)
Visual Basic (Declaration)
Public Overrides Function CanConvertFrom ( _
    context As ITypeDescriptorContext, _
    sourceType As Type _
) As Boolean

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
sourceType
Type: System..::.Type
A Type that represents the type you want to convert from.

Return Value

true if this converter can perform the conversion; otherwise, false.

See Also

FilePathTypeConverter Class
CanConvertFrom Overload
SandcastleBuilder.Utils.Design Namespace


CanConvertTo Method

[image] [image]

Sandcastle Help File Builder Documentation
FilePathTypeConverter..::.CanConvertTo Method
FilePathTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Inherited from TypeConverter.)

See Also

FilePathTypeConverter Class
FilePathTypeConverter Members
SandcastleBuilder.Utils.Design Namespace


ConvertFrom Method

[image] [image]

Sandcastle Help File Builder Documentation
FilePathTypeConverter..::.ConvertFrom Method
FilePathTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the given object to the type of this converter, using the specified context and culture information. (Overrides TypeConverter..::.ConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)

See Also

FilePathTypeConverter Class
FilePathTypeConverter Members
SandcastleBuilder.Utils.Design Namespace


ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

[image]

Sandcastle Help File Builder Documentation
FilePathTypeConverter..::.ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)
FilePathTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Converts the given object to the type of this converter, using the specified context and culture information.

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public override Object ConvertFrom(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value
)
Visual Basic (Declaration)
Public Overrides Function ConvertFrom ( _
    context As ITypeDescriptorContext, _
    culture As CultureInfo, _
    value As Object _
) As Object

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
culture
Type: System.Globalization..::.CultureInfo
The CultureInfo to use as the current culture.
value
Type: System..::.Object
The Object to convert.

Return Value

An Object that represents the converted value.

Exceptions

Exception | Condition
System..::.NotSupportedException | The conversion cannot be performed.

See Also

FilePathTypeConverter Class
ConvertFrom Overload
SandcastleBuilder.Utils.Design Namespace


ConvertFromInvariantString Method

[image] [image]

Sandcastle Help File Builder Documentation
FilePathTypeConverter..::.ConvertFromInvariantString Method
FilePathTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)

See Also

FilePathTypeConverter Class
FilePathTypeConverter Members
SandcastleBuilder.Utils.Design Namespace


ConvertFromString Method

[image] [image]

Sandcastle Help File Builder Documentation
FilePathTypeConverter..::.ConvertFromString Method
FilePathTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)

See Also

FilePathTypeConverter Class
FilePathTypeConverter Members
SandcastleBuilder.Utils.Design Namespace


ConvertTo Method

[image] [image]

Sandcastle Help File Builder Documentation
FilePathTypeConverter..::.ConvertTo Method
FilePathTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Overrides TypeConverter..::.ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)

See Also

FilePathTypeConverter Class
FilePathTypeConverter Members
SandcastleBuilder.Utils.Design Namespace


ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

[image]

Sandcastle Help File Builder Documentation
FilePathTypeConverter..::.ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)
FilePathTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Converts the given value object to the specified type, using the specified context and culture information.

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public override Object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value,
    Type destinationType
)
Visual Basic (Declaration)
Public Overrides Function ConvertTo ( _
    context As ITypeDescriptorContext, _
    culture As CultureInfo, _
    value As Object, _
    destinationType As Type _
) As Object

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
culture
Type: System.Globalization..::.CultureInfo
A CultureInfo. If null is passed, the current culture is assumed.
value
Type: System..::.Object
The Object to convert.
destinationType
Type: System..::.Type
The Type to convert the value parameter to.

Return Value

An Object that represents the converted value.

Exceptions

Exception | Condition
System..::.ArgumentNullException | The destinationType parameter is null.
System..::.NotSupportedException | The conversion cannot be performed.

See Also

FilePathTypeConverter Class
ConvertTo Overload
SandcastleBuilder.Utils.Design Namespace


ConvertToInvariantString Method

[image] [image]

Sandcastle Help File Builder Documentation
FilePathTypeConverter..::.ConvertToInvariantString Method
FilePathTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)

See Also

FilePathTypeConverter Class
FilePathTypeConverter Members
SandcastleBuilder.Utils.Design Namespace


ConvertToString Method

[image] [image]

Sandcastle Help File Builder Documentation
FilePathTypeConverter..::.ConvertToString Method
FilePathTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)

See Also

FilePathTypeConverter Class
FilePathTypeConverter Members
SandcastleBuilder.Utils.Design Namespace


CreateInstance Method

[image] [image]

Sandcastle Help File Builder Documentation
FilePathTypeConverter..::.CreateInstance Method
FilePathTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)

See Also

FilePathTypeConverter Class
FilePathTypeConverter Members
SandcastleBuilder.Utils.Design Namespace


GetCreateInstanceSupported Method

[image] [image]

Sandcastle Help File Builder Documentation
FilePathTypeConverter..::.GetCreateInstanceSupported Method
FilePathTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetCreateInstanceSupported()()() | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)

See Also

FilePathTypeConverter Class
FilePathTypeConverter Members
SandcastleBuilder.Utils.Design Namespace


GetProperties Method

[image] [image]

Sandcastle Help File Builder Documentation
FilePathTypeConverter..::.GetProperties Method
FilePathTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
GetProperties(ITypeDescriptorContext, Object, array<Attribute>[]()[]) | Gets a collection of properties for the type of object specified by the value parameter. (Inherited from ExpandableObjectConverter.)

See Also

FilePathTypeConverter Class
FilePathTypeConverter Members
SandcastleBuilder.Utils.Design Namespace


GetPropertiesSupported Method

[image] [image]

Sandcastle Help File Builder Documentation
FilePathTypeConverter..::.GetPropertiesSupported Method
FilePathTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetPropertiesSupported()()() | Returns whether this object supports properties. (Inherited from TypeConverter.)
GetPropertiesSupported(ITypeDescriptorContext) | Gets a value indicating whether this object supports properties using the specified context. (Inherited from ExpandableObjectConverter.)

See Also

FilePathTypeConverter Class
FilePathTypeConverter Members
SandcastleBuilder.Utils.Design Namespace


GetStandardValues Method

[image] [image]

Sandcastle Help File Builder Documentation
FilePathTypeConverter..::.GetStandardValues Method
FilePathTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetStandardValues()()() | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)

See Also

FilePathTypeConverter Class
FilePathTypeConverter Members
SandcastleBuilder.Utils.Design Namespace


GetStandardValuesExclusive Method

[image] [image]

Sandcastle Help File Builder Documentation
FilePathTypeConverter..::.GetStandardValuesExclusive Method
FilePathTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetStandardValuesExclusive()()() | Returns whether the collection of standard values returned from GetStandardValues()()() is an exclusive list. (Inherited from TypeConverter.)
GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues()()() is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)

See Also

FilePathTypeConverter Class
FilePathTypeConverter Members
SandcastleBuilder.Utils.Design Namespace


GetStandardValuesSupported Method

[image] [image]

Sandcastle Help File Builder Documentation
FilePathTypeConverter..::.GetStandardValuesSupported Method
FilePathTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetStandardValuesSupported()()() | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)

See Also

FilePathTypeConverter Class
FilePathTypeConverter Members
SandcastleBuilder.Utils.Design Namespace


IsValid Method

[image] [image]

Sandcastle Help File Builder Documentation
FilePathTypeConverter..::.IsValid Method
FilePathTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)

See Also

FilePathTypeConverter Class
FilePathTypeConverter Members
SandcastleBuilder.Utils.Design Namespace


FlagsEnumEditor Class

[image]

Sandcastle Help File Builder Documentation
FlagsEnumEditor Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is a type editor that displays a checked list box as the drop-down editor for an enumerated data type that represents a set of flags. This makes it easy to select multiple values with the drop-down.

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public class FlagsEnumEditor : UITypeEditor
Visual Basic (Declaration)
Public Class FlagsEnumEditor _
    Inherits UITypeEditor

Inheritance Hierarchy

System..::.Object
System.Drawing.Design..::.UITypeEditor
SandcastleBuilder.Utils.Design..::.FlagsEnumEditor

See Also

FlagsEnumEditor Members
SandcastleBuilder.Utils.Design Namespace


FlagsEnumEditor Members

[image] [image]

Sandcastle Help File Builder Documentation
FlagsEnumEditor Members
FlagsEnumEditor Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FlagsEnumEditor type exposes the following members.

Constructors

Name | Description
FlagsEnumEditor | Initializes a new instance of the FlagsEnumEditor class

Methods

Name | Description
EditValue | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEditStyle | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPaintValueSupported | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PaintValue | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from UITypeEditor.)

See Also

FlagsEnumEditor Class
SandcastleBuilder.Utils.Design Namespace


FlagsEnumEditor Constructor

[image]

Sandcastle Help File Builder Documentation
FlagsEnumEditor Constructor
FlagsEnumEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the FlagsEnumEditor class

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public FlagsEnumEditor()
Visual Basic (Declaration)
Public Sub New

See Also

FlagsEnumEditor Class
SandcastleBuilder.Utils.Design Namespace


FlagsEnumEditor Methods

[image] [image]

Sandcastle Help File Builder Documentation
FlagsEnumEditor Methods
FlagsEnumEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FlagsEnumEditor type exposes the following members.

Methods

Name | Description
EditValue | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEditStyle | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPaintValueSupported | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PaintValue | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FlagsEnumEditor Class
SandcastleBuilder.Utils.Design Namespace


EditValue Method

[image] [image]

Sandcastle Help File Builder Documentation
FlagsEnumEditor..::.EditValue Method
FlagsEnumEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
EditValue(IServiceProvider, Object) | Edits the value of the specified object using the editor style indicated by the GetEditStyle()()() method. (Inherited from UITypeEditor.)
EditValue(ITypeDescriptorContext, IServiceProvider, Object) | This is overridden to edit the value using a checked list box control as the drop-down editor. (Overrides UITypeEditor..::.EditValue(ITypeDescriptorContext, IServiceProvider, Object).)

See Also

FlagsEnumEditor Class
FlagsEnumEditor Members
SandcastleBuilder.Utils.Design Namespace


EditValue Method (ITypeDescriptorContext, IServiceProvider, Object)

[image]

Sandcastle Help File Builder Documentation
FlagsEnumEditor..::.EditValue Method (ITypeDescriptorContext, IServiceProvider, Object)
FlagsEnumEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is overridden to edit the value using a checked list box control as the drop-down editor.

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public override Object EditValue(
    ITypeDescriptorContext context,
    IServiceProvider provider,
    Object value
)
Visual Basic (Declaration)
Public Overrides Function EditValue ( _
    context As ITypeDescriptorContext, _
    provider As IServiceProvider, _
    value As Object _
) As Object

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
The descriptor context
provider
Type: System..::.IServiceProvider
The provider
value
Type: System..::.Object
The enumerated type object to edit

Return Value

The edited enumerated type object

See Also

FlagsEnumEditor Class
EditValue Overload
SandcastleBuilder.Utils.Design Namespace


GetEditStyle Method

[image] [image]

Sandcastle Help File Builder Documentation
FlagsEnumEditor..::.GetEditStyle Method
FlagsEnumEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetEditStyle()()() | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Inherited from UITypeEditor.)
GetEditStyle(ITypeDescriptorContext) | This is overridden to specify the editor's edit style (Overrides UITypeEditor..::.GetEditStyle(ITypeDescriptorContext).)

See Also

FlagsEnumEditor Class
FlagsEnumEditor Members
SandcastleBuilder.Utils.Design Namespace


GetEditStyle Method (ITypeDescriptorContext)

[image]

Sandcastle Help File Builder Documentation
FlagsEnumEditor..::.GetEditStyle Method (ITypeDescriptorContext)
FlagsEnumEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is overridden to specify the editor's edit style

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public override UITypeEditorEditStyle GetEditStyle(
    ITypeDescriptorContext context
)
Visual Basic (Declaration)
Public Overrides Function GetEditStyle ( _
    context As ITypeDescriptorContext _
) As UITypeEditorEditStyle

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
The descriptor context

Return Value

Always returns DropDown as long as there is a context and an instance. Otherwise, it returns None.

See Also

FlagsEnumEditor Class
GetEditStyle Overload
SandcastleBuilder.Utils.Design Namespace


GetPaintValueSupported Method

[image] [image]

Sandcastle Help File Builder Documentation
FlagsEnumEditor..::.GetPaintValueSupported Method
FlagsEnumEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetPaintValueSupported()()() | Indicates whether this editor supports painting a representation of an object's value. (Inherited from UITypeEditor.)
GetPaintValueSupported(ITypeDescriptorContext) | Indicates whether the specified context supports painting a representation of an object's value within the specified context. (Inherited from UITypeEditor.)

See Also

FlagsEnumEditor Class
FlagsEnumEditor Members
SandcastleBuilder.Utils.Design Namespace


PaintValue Method

[image] [image]

Sandcastle Help File Builder Documentation
FlagsEnumEditor..::.PaintValue Method
FlagsEnumEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PaintValue(PaintValueEventArgs) | Paints a representation of the value of an object using the specified PaintValueEventArgs. (Inherited from UITypeEditor.)
PaintValue(Object, Graphics, Rectangle) | Paints a representation of the value of the specified object to the specified canvas. (Inherited from UITypeEditor.)

See Also

FlagsEnumEditor Class
FlagsEnumEditor Members
SandcastleBuilder.Utils.Design Namespace


FlagsEnumEditor Properties

[image] [image]

Sandcastle Help File Builder Documentation
FlagsEnumEditor Properties
FlagsEnumEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FlagsEnumEditor type exposes the following members.

Properties

Name | Description
IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from UITypeEditor.)

See Also

FlagsEnumEditor Class
SandcastleBuilder.Utils.Design Namespace


FolderDialogAttribute Class

[image]

Sandcastle Help File Builder Documentation
FolderDialogAttribute Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This attribute is used to associate folder dialog parameters with a class property for use in editing it in a property grid.

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public sealed class FolderDialogAttribute : Attribute
Visual Basic (Declaration)
Public NotInheritable Class FolderDialogAttribute _
    Inherits Attribute

Inheritance Hierarchy

System..::.Object
System..::.Attribute
SandcastleBuilder.Utils.Design..::.FolderDialogAttribute

See Also

FolderDialogAttribute Members
SandcastleBuilder.Utils.Design Namespace
SandcastleBuilder.Utils.Design..::.FolderPathStringEditor
SandcastleBuilder.Utils.Design..::.FolderPathObjectEditor


FolderDialogAttribute Members

[image] [image]

Sandcastle Help File Builder Documentation
FolderDialogAttribute Members
FolderDialogAttribute Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FolderDialogAttribute type exposes the following members.

Constructors

Name | Description
FolderDialogAttribute | Overloaded. There are three overloads for the constructor.

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DefaultFolder | This is used to get the default folder from which to start browsing
Description | This is used to get the folder dialog description
RootFolder | This is used to get the root folder used to limit browsing
ShowNewFolderButton | This is used to get whether or not to show the New Folder button
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

FolderDialogAttribute Class
SandcastleBuilder.Utils.Design Namespace


FolderDialogAttribute Constructor

[image] [image]

Sandcastle Help File Builder Documentation
FolderDialogAttribute Constructor
FolderDialogAttribute Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

There are three overloads for the constructor.

Overload List

Name | Description
FolderDialogAttribute(String) | Constructor
FolderDialogAttribute(String, Environment..::.SpecialFolder) | Constructor
FolderDialogAttribute(String, Boolean, Environment..::.SpecialFolder, Environment..::.SpecialFolder) | Constructor

See Also

FolderDialogAttribute Class
FolderDialogAttribute Members
SandcastleBuilder.Utils.Design Namespace


FolderDialogAttribute Constructor (String)

[image]

Sandcastle Help File Builder Documentation
FolderDialogAttribute Constructor (String)
FolderDialogAttribute Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public FolderDialogAttribute(
    string description
)
Visual Basic (Declaration)
Public Sub New ( _
    description As String _
)

Parameters

description
Type: System..::.String
The description for the folder dialog

Remarks

The New Folder button is hidden and browsing starts at the desktop.

See Also

FolderDialogAttribute Class
FolderDialogAttribute Overload
SandcastleBuilder.Utils.Design Namespace


FolderDialogAttribute Constructor (String, Environment.SpecialFolder)

[image]

Sandcastle Help File Builder Documentation
FolderDialogAttribute Constructor (String, Environment..::.SpecialFolder)
FolderDialogAttribute Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public FolderDialogAttribute(
    string description,
    Environment..::.SpecialFolder defaultFolder
)
Visual Basic (Declaration)
Public Sub New ( _
    description As String, _
    defaultFolder As Environment..::.SpecialFolder _
)

Parameters

description
Type: System..::.String
The description for the folder dialog
defaultFolder
Type: System..::.Environment..::.SpecialFolder
The default folder from which to start browsing.

Remarks

The New Folder button is hidden and browsing starts at the desktop.

See Also

FolderDialogAttribute Class
FolderDialogAttribute Overload
SandcastleBuilder.Utils.Design Namespace


FolderDialogAttribute Constructor (String, Boolean, Environment.SpecialFolder, Environment.SpecialFolder)

[image]

Sandcastle Help File Builder Documentation
FolderDialogAttribute Constructor (String, Boolean, Environment..::.SpecialFolder, Environment..::.SpecialFolder)
FolderDialogAttribute Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public FolderDialogAttribute(
    string description,
    bool showNewFolderButton,
    Environment..::.SpecialFolder rootFolder,
    Environment..::.SpecialFolder defaultFolder
)
Visual Basic (Declaration)
Public Sub New ( _
    description As String, _
    showNewFolderButton As Boolean, _
    rootFolder As Environment..::.SpecialFolder, _
    defaultFolder As Environment..::.SpecialFolder _
)

Parameters

description
Type: System..::.String
The description for the folder dialog
showNewFolderButton
Type: System..::.Boolean
True to show the New Folder button or false to hide it.
rootFolder
Type: System..::.Environment..::.SpecialFolder
The root folder used to limit browsing.
defaultFolder
Type: System..::.Environment..::.SpecialFolder
The default folder from which to start browsing.

See Also

FolderDialogAttribute Class
FolderDialogAttribute Overload
SandcastleBuilder.Utils.Design Namespace


FolderDialogAttribute Methods

[image] [image]

Sandcastle Help File Builder Documentation
FolderDialogAttribute Methods
FolderDialogAttribute Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FolderDialogAttribute type exposes the following members.

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FolderDialogAttribute Class
SandcastleBuilder.Utils.Design Namespace


FolderDialogAttribute Properties

[image] [image]

Sandcastle Help File Builder Documentation
FolderDialogAttribute Properties
FolderDialogAttribute Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FolderDialogAttribute type exposes the following members.

Properties

Name | Description
DefaultFolder | This is used to get the default folder from which to start browsing
Description | This is used to get the folder dialog description
RootFolder | This is used to get the root folder used to limit browsing
ShowNewFolderButton | This is used to get whether or not to show the New Folder button
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

FolderDialogAttribute Class
SandcastleBuilder.Utils.Design Namespace


DefaultFolder Property

[image]

Sandcastle Help File Builder Documentation
FolderDialogAttribute..::.DefaultFolder Property
FolderDialogAttribute Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get the default folder from which to start browsing

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public Environment..::.SpecialFolder DefaultFolder { get; }
Visual Basic (Declaration)
Public ReadOnly Property DefaultFolder As Environment..::.SpecialFolder

See Also

FolderDialogAttribute Class
SandcastleBuilder.Utils.Design Namespace


Description Property

[image]

Sandcastle Help File Builder Documentation
FolderDialogAttribute..::.Description Property
FolderDialogAttribute Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get the folder dialog description

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string Description { get; }
Visual Basic (Declaration)
Public ReadOnly Property Description As String

See Also

FolderDialogAttribute Class
SandcastleBuilder.Utils.Design Namespace


RootFolder Property

[image]

Sandcastle Help File Builder Documentation
FolderDialogAttribute..::.RootFolder Property
FolderDialogAttribute Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get the root folder used to limit browsing

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public Environment..::.SpecialFolder RootFolder { get; }
Visual Basic (Declaration)
Public ReadOnly Property RootFolder As Environment..::.SpecialFolder

See Also

FolderDialogAttribute Class
SandcastleBuilder.Utils.Design Namespace


ShowNewFolderButton Property

[image]

Sandcastle Help File Builder Documentation
FolderDialogAttribute..::.ShowNewFolderButton Property
FolderDialogAttribute Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get whether or not to show the New Folder button

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool ShowNewFolderButton { get; }
Visual Basic (Declaration)
Public ReadOnly Property ShowNewFolderButton As Boolean

See Also

FolderDialogAttribute Class
SandcastleBuilder.Utils.Design Namespace


FolderPathObjectEditor Class

[image]

Sandcastle Help File Builder Documentation
FolderPathObjectEditor Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is a type editor that can display a folder browser dialog to allow selection of a folder path at design time.

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public class FolderPathObjectEditor : FolderPathStringEditor
Visual Basic (Declaration)
Public Class FolderPathObjectEditor _
    Inherits FolderPathStringEditor

Remarks

This can be used in conjunction with the FolderDialogAttribute to specify the folder browser dialog's properties.

Inheritance Hierarchy

System..::.Object
System.Drawing.Design..::.UITypeEditor
SandcastleBuilder.Utils.Design..::.FolderPathStringEditor
SandcastleBuilder.Utils.Design..::.FolderPathObjectEditor

See Also

FolderPathObjectEditor Members
SandcastleBuilder.Utils.Design Namespace


FolderPathObjectEditor Members

[image] [image]

Sandcastle Help File Builder Documentation
FolderPathObjectEditor Members
FolderPathObjectEditor Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FolderPathObjectEditor type exposes the following members.

Constructors

Name | Description
FolderPathObjectEditor | Initializes a new instance of the FolderPathObjectEditor class

Methods

Name | Description
EditValue | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEditStyle | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPaintValueSupported | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PaintValue | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from UITypeEditor.)

See Also

FolderPathObjectEditor Class
SandcastleBuilder.Utils.Design Namespace


FolderPathObjectEditor Constructor

[image]

Sandcastle Help File Builder Documentation
FolderPathObjectEditor Constructor
FolderPathObjectEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the FolderPathObjectEditor class

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public FolderPathObjectEditor()
Visual Basic (Declaration)
Public Sub New

See Also

FolderPathObjectEditor Class
SandcastleBuilder.Utils.Design Namespace


FolderPathObjectEditor Methods

[image] [image]

Sandcastle Help File Builder Documentation
FolderPathObjectEditor Methods
FolderPathObjectEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FolderPathObjectEditor type exposes the following members.

Methods

Name | Description
EditValue | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEditStyle | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPaintValueSupported | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PaintValue | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FolderPathObjectEditor Class
SandcastleBuilder.Utils.Design Namespace


EditValue Method

[image] [image]

Sandcastle Help File Builder Documentation
FolderPathObjectEditor..::.EditValue Method
FolderPathObjectEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
EditValue(IServiceProvider, Object) | Edits the value of the specified object using the editor style indicated by the GetEditStyle()()() method. (Inherited from UITypeEditor.)
EditValue(ITypeDescriptorContext, IServiceProvider, Object) | This is overridden to edit the value using a folder browser dialog. (Overrides FolderPathStringEditor..::.EditValue(ITypeDescriptorContext, IServiceProvider, Object).)

See Also

FolderPathObjectEditor Class
FolderPathObjectEditor Members
SandcastleBuilder.Utils.Design Namespace


EditValue Method (ITypeDescriptorContext, IServiceProvider, Object)

[image]

Sandcastle Help File Builder Documentation
FolderPathObjectEditor..::.EditValue Method (ITypeDescriptorContext, IServiceProvider, Object)
FolderPathObjectEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is overridden to edit the value using a folder browser dialog.

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public override Object EditValue(
    ITypeDescriptorContext context,
    IServiceProvider provider,
    Object value
)
Visual Basic (Declaration)
Public Overrides Function EditValue ( _
    context As ITypeDescriptorContext, _
    provider As IServiceProvider, _
    value As Object _
) As Object

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
The descriptor context
provider
Type: System..::.IServiceProvider
The provider
value
Type: System..::.Object
The folder path as an object

Return Value

The selected folder path as an object

See Also

FolderPathObjectEditor Class
EditValue Overload
SandcastleBuilder.Utils.Design Namespace


GetEditStyle Method

[image] [image]

Sandcastle Help File Builder Documentation
FolderPathObjectEditor..::.GetEditStyle Method
FolderPathObjectEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetEditStyle()()() | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Inherited from UITypeEditor.)
GetEditStyle(ITypeDescriptorContext) | This is overridden to specify the editor's edit style (Inherited from FolderPathStringEditor.)

See Also

FolderPathObjectEditor Class
FolderPathObjectEditor Members
SandcastleBuilder.Utils.Design Namespace


GetPaintValueSupported Method

[image] [image]

Sandcastle Help File Builder Documentation
FolderPathObjectEditor..::.GetPaintValueSupported Method
FolderPathObjectEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetPaintValueSupported()()() | Indicates whether this editor supports painting a representation of an object's value. (Inherited from UITypeEditor.)
GetPaintValueSupported(ITypeDescriptorContext) | Indicates whether the specified context supports painting a representation of an object's value within the specified context. (Inherited from UITypeEditor.)

See Also

FolderPathObjectEditor Class
FolderPathObjectEditor Members
SandcastleBuilder.Utils.Design Namespace


PaintValue Method

[image] [image]

Sandcastle Help File Builder Documentation
FolderPathObjectEditor..::.PaintValue Method
FolderPathObjectEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PaintValue(PaintValueEventArgs) | Paints a representation of the value of an object using the specified PaintValueEventArgs. (Inherited from UITypeEditor.)
PaintValue(Object, Graphics, Rectangle) | Paints a representation of the value of the specified object to the specified canvas. (Inherited from UITypeEditor.)

See Also

FolderPathObjectEditor Class
FolderPathObjectEditor Members
SandcastleBuilder.Utils.Design Namespace


FolderPathObjectEditor Properties

[image] [image]

Sandcastle Help File Builder Documentation
FolderPathObjectEditor Properties
FolderPathObjectEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FolderPathObjectEditor type exposes the following members.

Properties

Name | Description
IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from UITypeEditor.)

See Also

FolderPathObjectEditor Class
SandcastleBuilder.Utils.Design Namespace


FolderPathStringEditor Class

[image]

Sandcastle Help File Builder Documentation
FolderPathStringEditor Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is a type editor that can display a folder browser dialog to allow selection of a folder path at design time.

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public class FolderPathStringEditor : UITypeEditor
Visual Basic (Declaration)
Public Class FolderPathStringEditor _
    Inherits UITypeEditor

Remarks

This can be used in conjunction with the FolderDialogAttribute to specify the folder browser dialog's properties.

Inheritance Hierarchy

System..::.Object
System.Drawing.Design..::.UITypeEditor
SandcastleBuilder.Utils.Design..::.FolderPathStringEditor
SandcastleBuilder.Utils.Design..::.FolderPathObjectEditor

See Also

FolderPathStringEditor Members
SandcastleBuilder.Utils.Design Namespace


FolderPathStringEditor Members

[image] [image]

Sandcastle Help File Builder Documentation
FolderPathStringEditor Members
FolderPathStringEditor Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FolderPathStringEditor type exposes the following members.

Constructors

Name | Description
FolderPathStringEditor | Initializes a new instance of the FolderPathStringEditor class

Methods

Name | Description
EditValue | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEditStyle | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPaintValueSupported | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PaintValue | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from UITypeEditor.)

See Also

FolderPathStringEditor Class
SandcastleBuilder.Utils.Design Namespace


FolderPathStringEditor Constructor

[image]

Sandcastle Help File Builder Documentation
FolderPathStringEditor Constructor
FolderPathStringEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the FolderPathStringEditor class

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public FolderPathStringEditor()
Visual Basic (Declaration)
Public Sub New

See Also

FolderPathStringEditor Class
SandcastleBuilder.Utils.Design Namespace


FolderPathStringEditor Methods

[image] [image]

Sandcastle Help File Builder Documentation
FolderPathStringEditor Methods
FolderPathStringEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FolderPathStringEditor type exposes the following members.

Methods

Name | Description
EditValue | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEditStyle | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPaintValueSupported | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PaintValue | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FolderPathStringEditor Class
SandcastleBuilder.Utils.Design Namespace


EditValue Method

[image] [image]

Sandcastle Help File Builder Documentation
FolderPathStringEditor..::.EditValue Method
FolderPathStringEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
EditValue(IServiceProvider, Object) | Edits the value of the specified object using the editor style indicated by the GetEditStyle()()() method. (Inherited from UITypeEditor.)
EditValue(ITypeDescriptorContext, IServiceProvider, Object) | This is overridden to edit the value using a folder browser dialog. (Overrides UITypeEditor..::.EditValue(ITypeDescriptorContext, IServiceProvider, Object).)

See Also

FolderPathStringEditor Class
FolderPathStringEditor Members
SandcastleBuilder.Utils.Design Namespace


EditValue Method (ITypeDescriptorContext, IServiceProvider, Object)

[image]

Sandcastle Help File Builder Documentation
FolderPathStringEditor..::.EditValue Method (ITypeDescriptorContext, IServiceProvider, Object)
FolderPathStringEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is overridden to edit the value using a folder browser dialog.

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public override Object EditValue(
    ITypeDescriptorContext context,
    IServiceProvider provider,
    Object value
)
Visual Basic (Declaration)
Public Overrides Function EditValue ( _
    context As ITypeDescriptorContext, _
    provider As IServiceProvider, _
    value As Object _
) As Object

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
The descriptor context
provider
Type: System..::.IServiceProvider
The provider
value
Type: System..::.Object
The folder path as an object

Return Value

The selected folder path as an object

See Also

FolderPathStringEditor Class
EditValue Overload
SandcastleBuilder.Utils.Design Namespace


GetEditStyle Method

[image] [image]

Sandcastle Help File Builder Documentation
FolderPathStringEditor..::.GetEditStyle Method
FolderPathStringEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetEditStyle()()() | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Inherited from UITypeEditor.)
GetEditStyle(ITypeDescriptorContext) | This is overridden to specify the editor's edit style (Overrides UITypeEditor..::.GetEditStyle(ITypeDescriptorContext).)

See Also

FolderPathStringEditor Class
FolderPathStringEditor Members
SandcastleBuilder.Utils.Design Namespace


GetEditStyle Method (ITypeDescriptorContext)

[image]

Sandcastle Help File Builder Documentation
FolderPathStringEditor..::.GetEditStyle Method (ITypeDescriptorContext)
FolderPathStringEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is overridden to specify the editor's edit style

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public override UITypeEditorEditStyle GetEditStyle(
    ITypeDescriptorContext context
)
Visual Basic (Declaration)
Public Overrides Function GetEditStyle ( _
    context As ITypeDescriptorContext _
) As UITypeEditorEditStyle

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
The descriptor context

Return Value

Always returns Modal as long as there is a context and an instance. Otherwise, it returns None.

See Also

FolderPathStringEditor Class
GetEditStyle Overload
SandcastleBuilder.Utils.Design Namespace


GetPaintValueSupported Method

[image] [image]

Sandcastle Help File Builder Documentation
FolderPathStringEditor..::.GetPaintValueSupported Method
FolderPathStringEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetPaintValueSupported()()() | Indicates whether this editor supports painting a representation of an object's value. (Inherited from UITypeEditor.)
GetPaintValueSupported(ITypeDescriptorContext) | Indicates whether the specified context supports painting a representation of an object's value within the specified context. (Inherited from UITypeEditor.)

See Also

FolderPathStringEditor Class
FolderPathStringEditor Members
SandcastleBuilder.Utils.Design Namespace


PaintValue Method

[image] [image]

Sandcastle Help File Builder Documentation
FolderPathStringEditor..::.PaintValue Method
FolderPathStringEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PaintValue(PaintValueEventArgs) | Paints a representation of the value of an object using the specified PaintValueEventArgs. (Inherited from UITypeEditor.)
PaintValue(Object, Graphics, Rectangle) | Paints a representation of the value of the specified object to the specified canvas. (Inherited from UITypeEditor.)

See Also

FolderPathStringEditor Class
FolderPathStringEditor Members
SandcastleBuilder.Utils.Design Namespace


FolderPathStringEditor Properties

[image] [image]

Sandcastle Help File Builder Documentation
FolderPathStringEditor Properties
FolderPathStringEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FolderPathStringEditor type exposes the following members.

Properties

Name | Description
IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from UITypeEditor.)

See Also

FolderPathStringEditor Class
SandcastleBuilder.Utils.Design Namespace


FolderPathTypeConverter Class

[image]

Sandcastle Help File Builder Documentation
FolderPathTypeConverter Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This type converter is used to convert a FolderPath object to and from a string so that it can be edited in a PropertyGrid.

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public sealed class FolderPathTypeConverter : ExpandableObjectConverter
Visual Basic (Declaration)
Public NotInheritable Class FolderPathTypeConverter _
    Inherits ExpandableObjectConverter

Inheritance Hierarchy

System..::.Object
System.ComponentModel..::.TypeConverter
System.ComponentModel..::.ExpandableObjectConverter
SandcastleBuilder.Utils.Design..::.FolderPathTypeConverter

See Also

FolderPathTypeConverter Members
SandcastleBuilder.Utils.Design Namespace


FolderPathTypeConverter Members

[image] [image]

Sandcastle Help File Builder Documentation
FolderPathTypeConverter Members
FolderPathTypeConverter Class Constructors Methods See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FolderPathTypeConverter type exposes the following members.

Constructors

Name | Description
FolderPathTypeConverter | Initializes a new instance of the FolderPathTypeConverter class

Methods

Name | Description
CanConvertFrom | Overloaded.
CanConvertTo | Overloaded.
ConvertFrom | Overloaded.
ConvertFromInvariantString | Overloaded.
ConvertFromString | Overloaded.
ConvertTo | Overloaded.
ConvertToInvariantString | Overloaded.
ConvertToString | Overloaded.
CreateInstance | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
GetCreateInstanceSupported | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetProperties | Overloaded.
GetPropertiesSupported | Overloaded.
GetStandardValues | Overloaded.
GetStandardValuesExclusive | Overloaded.
GetStandardValuesSupported | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FolderPathTypeConverter Class
SandcastleBuilder.Utils.Design Namespace


FolderPathTypeConverter Constructor

[image]

Sandcastle Help File Builder Documentation
FolderPathTypeConverter Constructor
FolderPathTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the FolderPathTypeConverter class

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public FolderPathTypeConverter()
Visual Basic (Declaration)
Public Sub New

See Also

FolderPathTypeConverter Class
SandcastleBuilder.Utils.Design Namespace


FolderPathTypeConverter Methods

[image] [image]

Sandcastle Help File Builder Documentation
FolderPathTypeConverter Methods
FolderPathTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FolderPathTypeConverter type exposes the following members.

Methods

Name | Description
CanConvertFrom | Overloaded.
CanConvertTo | Overloaded.
ConvertFrom | Overloaded.
ConvertFromInvariantString | Overloaded.
ConvertFromString | Overloaded.
ConvertTo | Overloaded.
ConvertToInvariantString | Overloaded.
ConvertToString | Overloaded.
CreateInstance | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
GetCreateInstanceSupported | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetProperties | Overloaded.
GetPropertiesSupported | Overloaded.
GetStandardValues | Overloaded.
GetStandardValuesExclusive | Overloaded.
GetStandardValuesSupported | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FolderPathTypeConverter Class
SandcastleBuilder.Utils.Design Namespace


CanConvertFrom Method

[image] [image]

Sandcastle Help File Builder Documentation
FolderPathTypeConverter..::.CanConvertFrom Method
FolderPathTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context. (Overrides TypeConverter..::.CanConvertFrom(ITypeDescriptorContext, Type).)

See Also

FolderPathTypeConverter Class
FolderPathTypeConverter Members
SandcastleBuilder.Utils.Design Namespace


CanConvertFrom Method (ITypeDescriptorContext, Type)

[image]

Sandcastle Help File Builder Documentation
FolderPathTypeConverter..::.CanConvertFrom Method (ITypeDescriptorContext, Type)
FolderPathTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context.

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public override bool CanConvertFrom(
    ITypeDescriptorContext context,
    Type sourceType
)
Visual Basic (Declaration)
Public Overrides Function CanConvertFrom ( _
    context As ITypeDescriptorContext, _
    sourceType As Type _
) As Boolean

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
sourceType
Type: System..::.Type
A Type that represents the type you want to convert from.

Return Value

true if this converter can perform the conversion; otherwise, false.

See Also

FolderPathTypeConverter Class
CanConvertFrom Overload
SandcastleBuilder.Utils.Design Namespace


CanConvertTo Method

[image] [image]

Sandcastle Help File Builder Documentation
FolderPathTypeConverter..::.CanConvertTo Method
FolderPathTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Inherited from TypeConverter.)

See Also

FolderPathTypeConverter Class
FolderPathTypeConverter Members
SandcastleBuilder.Utils.Design Namespace


ConvertFrom Method

[image] [image]

Sandcastle Help File Builder Documentation
FolderPathTypeConverter..::.ConvertFrom Method
FolderPathTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the given object to the type of this converter, using the specified context and culture information. (Overrides TypeConverter..::.ConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)

See Also

FolderPathTypeConverter Class
FolderPathTypeConverter Members
SandcastleBuilder.Utils.Design Namespace


ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

[image]

Sandcastle Help File Builder Documentation
FolderPathTypeConverter..::.ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)
FolderPathTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Converts the given object to the type of this converter, using the specified context and culture information.

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public override Object ConvertFrom(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value
)
Visual Basic (Declaration)
Public Overrides Function ConvertFrom ( _
    context As ITypeDescriptorContext, _
    culture As CultureInfo, _
    value As Object _
) As Object

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
culture
Type: System.Globalization..::.CultureInfo
The CultureInfo to use as the current culture.
value
Type: System..::.Object
The Object to convert.

Return Value

An Object that represents the converted value.

Exceptions

Exception | Condition
System..::.NotSupportedException | The conversion cannot be performed.

See Also

FolderPathTypeConverter Class
ConvertFrom Overload
SandcastleBuilder.Utils.Design Namespace


ConvertFromInvariantString Method

[image] [image]

Sandcastle Help File Builder Documentation
FolderPathTypeConverter..::.ConvertFromInvariantString Method
FolderPathTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)

See Also

FolderPathTypeConverter Class
FolderPathTypeConverter Members
SandcastleBuilder.Utils.Design Namespace


ConvertFromString Method

[image] [image]

Sandcastle Help File Builder Documentation
FolderPathTypeConverter..::.ConvertFromString Method
FolderPathTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)

See Also

FolderPathTypeConverter Class
FolderPathTypeConverter Members
SandcastleBuilder.Utils.Design Namespace


ConvertTo Method

[image] [image]

Sandcastle Help File Builder Documentation
FolderPathTypeConverter..::.ConvertTo Method
FolderPathTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Overrides TypeConverter..::.ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)

See Also

FolderPathTypeConverter Class
FolderPathTypeConverter Members
SandcastleBuilder.Utils.Design Namespace


ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

[image]

Sandcastle Help File Builder Documentation
FolderPathTypeConverter..::.ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)
FolderPathTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Converts the given value object to the specified type, using the specified context and culture information.

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public override Object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value,
    Type destinationType
)
Visual Basic (Declaration)
Public Overrides Function ConvertTo ( _
    context As ITypeDescriptorContext, _
    culture As CultureInfo, _
    value As Object, _
    destinationType As Type _
) As Object

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
culture
Type: System.Globalization..::.CultureInfo
A CultureInfo. If null is passed, the current culture is assumed.
value
Type: System..::.Object
The Object to convert.
destinationType
Type: System..::.Type
The Type to convert the value parameter to.

Return Value

An Object that represents the converted value.

Exceptions

Exception | Condition
System..::.ArgumentNullException | The destinationType parameter is null.
System..::.NotSupportedException | The conversion cannot be performed.

See Also

FolderPathTypeConverter Class
ConvertTo Overload
SandcastleBuilder.Utils.Design Namespace


ConvertToInvariantString Method

[image] [image]

Sandcastle Help File Builder Documentation
FolderPathTypeConverter..::.ConvertToInvariantString Method
FolderPathTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)

See Also

FolderPathTypeConverter Class
FolderPathTypeConverter Members
SandcastleBuilder.Utils.Design Namespace


ConvertToString Method

[image] [image]

Sandcastle Help File Builder Documentation
FolderPathTypeConverter..::.ConvertToString Method
FolderPathTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)

See Also

FolderPathTypeConverter Class
FolderPathTypeConverter Members
SandcastleBuilder.Utils.Design Namespace


CreateInstance Method

[image] [image]

Sandcastle Help File Builder Documentation
FolderPathTypeConverter..::.CreateInstance Method
FolderPathTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)

See Also

FolderPathTypeConverter Class
FolderPathTypeConverter Members
SandcastleBuilder.Utils.Design Namespace


GetCreateInstanceSupported Method

[image] [image]

Sandcastle Help File Builder Documentation
FolderPathTypeConverter..::.GetCreateInstanceSupported Method
FolderPathTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetCreateInstanceSupported()()() | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)

See Also

FolderPathTypeConverter Class
FolderPathTypeConverter Members
SandcastleBuilder.Utils.Design Namespace


GetProperties Method

[image] [image]

Sandcastle Help File Builder Documentation
FolderPathTypeConverter..::.GetProperties Method
FolderPathTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
GetProperties(ITypeDescriptorContext, Object, array<Attribute>[]()[]) | Gets a collection of properties for the type of object specified by the value parameter. (Inherited from ExpandableObjectConverter.)

See Also

FolderPathTypeConverter Class
FolderPathTypeConverter Members
SandcastleBuilder.Utils.Design Namespace


GetPropertiesSupported Method

[image] [image]

Sandcastle Help File Builder Documentation
FolderPathTypeConverter..::.GetPropertiesSupported Method
FolderPathTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetPropertiesSupported()()() | Returns whether this object supports properties. (Inherited from TypeConverter.)
GetPropertiesSupported(ITypeDescriptorContext) | Gets a value indicating whether this object supports properties using the specified context. (Inherited from ExpandableObjectConverter.)

See Also

FolderPathTypeConverter Class
FolderPathTypeConverter Members
SandcastleBuilder.Utils.Design Namespace


GetStandardValues Method

[image] [image]

Sandcastle Help File Builder Documentation
FolderPathTypeConverter..::.GetStandardValues Method
FolderPathTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetStandardValues()()() | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)

See Also

FolderPathTypeConverter Class
FolderPathTypeConverter Members
SandcastleBuilder.Utils.Design Namespace


GetStandardValuesExclusive Method

[image] [image]

Sandcastle Help File Builder Documentation
FolderPathTypeConverter..::.GetStandardValuesExclusive Method
FolderPathTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetStandardValuesExclusive()()() | Returns whether the collection of standard values returned from GetStandardValues()()() is an exclusive list. (Inherited from TypeConverter.)
GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues()()() is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)

See Also

FolderPathTypeConverter Class
FolderPathTypeConverter Members
SandcastleBuilder.Utils.Design Namespace


GetStandardValuesSupported Method

[image] [image]

Sandcastle Help File Builder Documentation
FolderPathTypeConverter..::.GetStandardValuesSupported Method
FolderPathTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetStandardValuesSupported()()() | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)

See Also

FolderPathTypeConverter Class
FolderPathTypeConverter Members
SandcastleBuilder.Utils.Design Namespace


IsValid Method

[image] [image]

Sandcastle Help File Builder Documentation
FolderPathTypeConverter..::.IsValid Method
FolderPathTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)

See Also

FolderPathTypeConverter Class
FolderPathTypeConverter Members
SandcastleBuilder.Utils.Design Namespace


FrameworkVersionTypeConverter Class

[image]

Sandcastle Help File Builder Documentation
FrameworkVersionTypeConverter Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This type converter allows you to select a .NET Framework version from those currently installed on the system.

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public class FrameworkVersionTypeConverter : StringConverter
Visual Basic (Declaration)
Public Class FrameworkVersionTypeConverter _
    Inherits StringConverter

Inheritance Hierarchy

System..::.Object
System.ComponentModel..::.TypeConverter
System.ComponentModel..::.StringConverter
SandcastleBuilder.Utils.Design..::.FrameworkVersionTypeConverter

See Also

FrameworkVersionTypeConverter Members
SandcastleBuilder.Utils.Design Namespace


FrameworkVersionTypeConverter Members

[image] [image]

Sandcastle Help File Builder Documentation
FrameworkVersionTypeConverter Members
FrameworkVersionTypeConverter Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FrameworkVersionTypeConverter type exposes the following members.

Constructors

Name | Description
FrameworkVersionTypeConverter | Initializes a new instance of the FrameworkVersionTypeConverter class

Methods

Name | Description
CanConvertFrom | Overloaded.
CanConvertTo | Overloaded.
ConvertFrom | Overloaded.
ConvertFromInvariantString | Overloaded.
ConvertFromString | Overloaded.
ConvertTo | Overloaded.
ConvertToInvariantString | Overloaded.
ConvertToString | Overloaded.
CreateInstance | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
GetCreateInstanceSupported | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetProperties | Overloaded.
GetPropertiesSupported | Overloaded.
GetStandardValues | Overloaded.
GetStandardValuesExclusive | Overloaded.
GetStandardValuesSupported | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsPresent | This is used to find out if the specified version of the .NET Framework is present on the system.
IsValid | Overloaded.
LatestMatching | This is used to get the latest version that starts with the given value.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MostRecentVersion | This read-only property returns the version number of the most recent copy of the .NET Framework installed on the system.

See Also

FrameworkVersionTypeConverter Class
SandcastleBuilder.Utils.Design Namespace


FrameworkVersionTypeConverter Constructor

[image]

Sandcastle Help File Builder Documentation
FrameworkVersionTypeConverter Constructor
FrameworkVersionTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the FrameworkVersionTypeConverter class

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public FrameworkVersionTypeConverter()
Visual Basic (Declaration)
Public Sub New

See Also

FrameworkVersionTypeConverter Class
SandcastleBuilder.Utils.Design Namespace


FrameworkVersionTypeConverter Methods

[image] [image]

Sandcastle Help File Builder Documentation
FrameworkVersionTypeConverter Methods
FrameworkVersionTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FrameworkVersionTypeConverter type exposes the following members.

Methods

Name | Description
CanConvertFrom | Overloaded.
CanConvertTo | Overloaded.
ConvertFrom | Overloaded.
ConvertFromInvariantString | Overloaded.
ConvertFromString | Overloaded.
ConvertTo | Overloaded.
ConvertToInvariantString | Overloaded.
ConvertToString | Overloaded.
CreateInstance | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
GetCreateInstanceSupported | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetProperties | Overloaded.
GetPropertiesSupported | Overloaded.
GetStandardValues | Overloaded.
GetStandardValuesExclusive | Overloaded.
GetStandardValuesSupported | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsPresent | This is used to find out if the specified version of the .NET Framework is present on the system.
IsValid | Overloaded.
LatestMatching | This is used to get the latest version that starts with the given value.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FrameworkVersionTypeConverter Class
SandcastleBuilder.Utils.Design Namespace


CanConvertFrom Method

[image] [image]

Sandcastle Help File Builder Documentation
FrameworkVersionTypeConverter..::.CanConvertFrom Method
FrameworkVersionTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
CanConvertFrom(ITypeDescriptorContext, Type) | Gets a value indicating whether this converter can convert an object in the given source type to a string using the specified context. (Inherited from StringConverter.)

See Also

FrameworkVersionTypeConverter Class
FrameworkVersionTypeConverter Members
SandcastleBuilder.Utils.Design Namespace


CanConvertTo Method

[image] [image]

Sandcastle Help File Builder Documentation
FrameworkVersionTypeConverter..::.CanConvertTo Method
FrameworkVersionTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Inherited from TypeConverter.)

See Also

FrameworkVersionTypeConverter Class
FrameworkVersionTypeConverter Members
SandcastleBuilder.Utils.Design Namespace


ConvertFrom Method

[image] [image]

Sandcastle Help File Builder Documentation
FrameworkVersionTypeConverter..::.ConvertFrom Method
FrameworkVersionTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the specified value object to a String object. (Inherited from StringConverter.)

See Also

FrameworkVersionTypeConverter Class
FrameworkVersionTypeConverter Members
SandcastleBuilder.Utils.Design Namespace


ConvertFromInvariantString Method

[image] [image]

Sandcastle Help File Builder Documentation
FrameworkVersionTypeConverter..::.ConvertFromInvariantString Method
FrameworkVersionTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)

See Also

FrameworkVersionTypeConverter Class
FrameworkVersionTypeConverter Members
SandcastleBuilder.Utils.Design Namespace


ConvertFromString Method

[image] [image]

Sandcastle Help File Builder Documentation
FrameworkVersionTypeConverter..::.ConvertFromString Method
FrameworkVersionTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)

See Also

FrameworkVersionTypeConverter Class
FrameworkVersionTypeConverter Members
SandcastleBuilder.Utils.Design Namespace


ConvertTo Method

[image] [image]

Sandcastle Help File Builder Documentation
FrameworkVersionTypeConverter..::.ConvertTo Method
FrameworkVersionTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Inherited from TypeConverter.)

See Also

FrameworkVersionTypeConverter Class
FrameworkVersionTypeConverter Members
SandcastleBuilder.Utils.Design Namespace


ConvertToInvariantString Method

[image] [image]

Sandcastle Help File Builder Documentation
FrameworkVersionTypeConverter..::.ConvertToInvariantString Method
FrameworkVersionTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)

See Also

FrameworkVersionTypeConverter Class
FrameworkVersionTypeConverter Members
SandcastleBuilder.Utils.Design Namespace


ConvertToString Method

[image] [image]

Sandcastle Help File Builder Documentation
FrameworkVersionTypeConverter..::.ConvertToString Method
FrameworkVersionTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)

See Also

FrameworkVersionTypeConverter Class
FrameworkVersionTypeConverter Members
SandcastleBuilder.Utils.Design Namespace


CreateInstance Method

[image] [image]

Sandcastle Help File Builder Documentation
FrameworkVersionTypeConverter..::.CreateInstance Method
FrameworkVersionTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)

See Also

FrameworkVersionTypeConverter Class
FrameworkVersionTypeConverter Members
SandcastleBuilder.Utils.Design Namespace


GetCreateInstanceSupported Method

[image] [image]

Sandcastle Help File Builder Documentation
FrameworkVersionTypeConverter..::.GetCreateInstanceSupported Method
FrameworkVersionTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetCreateInstanceSupported()()() | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)

See Also

FrameworkVersionTypeConverter Class
FrameworkVersionTypeConverter Members
SandcastleBuilder.Utils.Design Namespace


GetProperties Method

[image] [image]

Sandcastle Help File Builder Documentation
FrameworkVersionTypeConverter..::.GetProperties Method
FrameworkVersionTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
GetProperties(ITypeDescriptorContext, Object, array<Attribute>[]()[]) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Inherited from TypeConverter.)

See Also

FrameworkVersionTypeConverter Class
FrameworkVersionTypeConverter Members
SandcastleBuilder.Utils.Design Namespace


GetPropertiesSupported Method

[image] [image]

Sandcastle Help File Builder Documentation
FrameworkVersionTypeConverter..::.GetPropertiesSupported Method
FrameworkVersionTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetPropertiesSupported()()() | Returns whether this object supports properties. (Inherited from TypeConverter.)
GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the specified context. (Inherited from TypeConverter.)

See Also

FrameworkVersionTypeConverter Class
FrameworkVersionTypeConverter Members
SandcastleBuilder.Utils.Design Namespace


GetStandardValues Method

[image] [image]

Sandcastle Help File Builder Documentation
FrameworkVersionTypeConverter..::.GetStandardValues Method
FrameworkVersionTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetStandardValues()()() | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
GetStandardValues(ITypeDescriptorContext) | This is overridden to return the values for the type converter's dropdown list. (Overrides TypeConverter..::.GetStandardValues(ITypeDescriptorContext).)

See Also

FrameworkVersionTypeConverter Class
FrameworkVersionTypeConverter Members
SandcastleBuilder.Utils.Design Namespace


GetStandardValues Method (ITypeDescriptorContext)

[image]

Sandcastle Help File Builder Documentation
FrameworkVersionTypeConverter..::.GetStandardValues Method (ITypeDescriptorContext)
FrameworkVersionTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is overridden to return the values for the type converter's dropdown list.

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public override TypeConverter..::.StandardValuesCollection GetStandardValues(
    ITypeDescriptorContext context
)
Visual Basic (Declaration)
Public Overrides Function GetStandardValues ( _
    context As ITypeDescriptorContext _
) As TypeConverter..::.StandardValuesCollection

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
The format context object

Return Value

Returns the standard values for the type

See Also

FrameworkVersionTypeConverter Class
GetStandardValues Overload
SandcastleBuilder.Utils.Design Namespace


GetStandardValuesExclusive Method

[image] [image]

Sandcastle Help File Builder Documentation
FrameworkVersionTypeConverter..::.GetStandardValuesExclusive Method
FrameworkVersionTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetStandardValuesExclusive()()() | Returns whether the collection of standard values returned from GetStandardValues()()() is an exclusive list. (Inherited from TypeConverter.)
GetStandardValuesExclusive(ITypeDescriptorContext) | This is overridden to indicate that the values are exclusive and values outside the list cannot be entered. (Overrides TypeConverter..::.GetStandardValuesExclusive(ITypeDescriptorContext).)

See Also

FrameworkVersionTypeConverter Class
FrameworkVersionTypeConverter Members
SandcastleBuilder.Utils.Design Namespace


GetStandardValuesExclusive Method (ITypeDescriptorContext)

[image]

Sandcastle Help File Builder Documentation
FrameworkVersionTypeConverter..::.GetStandardValuesExclusive Method (ITypeDescriptorContext)
FrameworkVersionTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is overridden to indicate that the values are exclusive and values outside the list cannot be entered.

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public override bool GetStandardValuesExclusive(
    ITypeDescriptorContext context
)
Visual Basic (Declaration)
Public Overrides Function GetStandardValuesExclusive ( _
    context As ITypeDescriptorContext _
) As Boolean

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
The format context object

Return Value

Always returns true

See Also

FrameworkVersionTypeConverter Class
GetStandardValuesExclusive Overload
SandcastleBuilder.Utils.Design Namespace


GetStandardValuesSupported Method

[image] [image]

Sandcastle Help File Builder Documentation
FrameworkVersionTypeConverter..::.GetStandardValuesSupported Method
FrameworkVersionTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetStandardValuesSupported()()() | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
GetStandardValuesSupported(ITypeDescriptorContext) | This is overridden to indicate that standard values are supported and can be chosen from a list. (Overrides TypeConverter..::.GetStandardValuesSupported(ITypeDescriptorContext).)

See Also

FrameworkVersionTypeConverter Class
FrameworkVersionTypeConverter Members
SandcastleBuilder.Utils.Design Namespace


GetStandardValuesSupported Method (ITypeDescriptorContext)

[image]

Sandcastle Help File Builder Documentation
FrameworkVersionTypeConverter..::.GetStandardValuesSupported Method (ITypeDescriptorContext)
FrameworkVersionTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is overridden to indicate that standard values are supported and can be chosen from a list.

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public override bool GetStandardValuesSupported(
    ITypeDescriptorContext context
)
Visual Basic (Declaration)
Public Overrides Function GetStandardValuesSupported ( _
    context As ITypeDescriptorContext _
) As Boolean

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
The format context object

Return Value

Always returns true

See Also

FrameworkVersionTypeConverter Class
GetStandardValuesSupported Overload
SandcastleBuilder.Utils.Design Namespace


IsPresent Method

[image]

Sandcastle Help File Builder Documentation
FrameworkVersionTypeConverter..::.IsPresent Method
FrameworkVersionTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to find out if the specified version of the .NET Framework is present on the system.

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public static bool IsPresent(
    string version
)
Visual Basic (Declaration)
Public Shared Function IsPresent ( _
    version As String _
) As Boolean

Parameters

version
Type: System..::.String
The version for which to look

Return Value

True if present, false if not found

See Also

FrameworkVersionTypeConverter Class
SandcastleBuilder.Utils.Design Namespace


IsValid Method

[image] [image]

Sandcastle Help File Builder Documentation
FrameworkVersionTypeConverter..::.IsValid Method
FrameworkVersionTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)

See Also

FrameworkVersionTypeConverter Class
FrameworkVersionTypeConverter Members
SandcastleBuilder.Utils.Design Namespace


LatestMatching Method

[image]

Sandcastle Help File Builder Documentation
FrameworkVersionTypeConverter..::.LatestMatching Method
FrameworkVersionTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get the latest version that starts with the given value.

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public static string LatestMatching(
    string version
)
Visual Basic (Declaration)
Public Shared Function LatestMatching ( _
    version As String _
) As String

Parameters

version
Type: System..::.String
The version for which to look

Return Value

The latest version starting with the specified value or the most recent version if not found.

See Also

FrameworkVersionTypeConverter Class
SandcastleBuilder.Utils.Design Namespace


FrameworkVersionTypeConverter Properties

[image] [image]

Sandcastle Help File Builder Documentation
FrameworkVersionTypeConverter Properties
FrameworkVersionTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FrameworkVersionTypeConverter type exposes the following members.

Properties

Name | Description
MostRecentVersion | This read-only property returns the version number of the most recent copy of the .NET Framework installed on the system.

See Also

FrameworkVersionTypeConverter Class
SandcastleBuilder.Utils.Design Namespace


MostRecentVersion Property

[image]

Sandcastle Help File Builder Documentation
FrameworkVersionTypeConverter..::.MostRecentVersion Property
FrameworkVersionTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns the version number of the most recent copy of the .NET Framework installed on the system.

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public static string MostRecentVersion { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property MostRecentVersion As String

See Also

FrameworkVersionTypeConverter Class
SandcastleBuilder.Utils.Design Namespace


NamespaceSummaryItemEditorDlg Class

[image]

Sandcastle Help File Builder Documentation
NamespaceSummaryItemEditorDlg Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This form is used to edit namespace summaries and to indicate which namespaces should appear in the help file.

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public class NamespaceSummaryItemEditorDlg : Form
Visual Basic (Declaration)
Public Class NamespaceSummaryItemEditorDlg _
    Inherits Form

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
SandcastleBuilder.Utils.Design..::.NamespaceSummaryItemEditorDlg

See Also

NamespaceSummaryItemEditorDlg Members
SandcastleBuilder.Utils.Design Namespace


NamespaceSummaryItemEditorDlg Members

[image] [image]

Sandcastle Help File Builder Documentation
NamespaceSummaryItemEditorDlg Members
NamespaceSummaryItemEditorDlg Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The NamespaceSummaryItemEditorDlg type exposes the following members.

Constructors

Name | Description
NamespaceSummaryItemEditorDlg | Constructor

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

NamespaceSummaryItemEditorDlg Class
SandcastleBuilder.Utils.Design Namespace


NamespaceSummaryItemEditorDlg Constructor

[image]

Sandcastle Help File Builder Documentation
NamespaceSummaryItemEditorDlg Constructor
NamespaceSummaryItemEditorDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public NamespaceSummaryItemEditorDlg(
    NamespaceSummaryItemCollection items
)
Visual Basic (Declaration)
Public Sub New ( _
    items As NamespaceSummaryItemCollection _
)

Parameters

items
Type: SandcastleBuilder.Utils..::.NamespaceSummaryItemCollection
The namespace summary item collection to edit

See Also

NamespaceSummaryItemEditorDlg Class
SandcastleBuilder.Utils.Design Namespace


NamespaceSummaryItemEditorDlg Methods

[image] [image]

Sandcastle Help File Builder Documentation
NamespaceSummaryItemEditorDlg Methods
NamespaceSummaryItemEditorDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The NamespaceSummaryItemEditorDlg type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

See Also

NamespaceSummaryItemEditorDlg Class
SandcastleBuilder.Utils.Design Namespace


AccessibilityNotifyClients Method

[image] [image]

Sandcastle Help File Builder Documentation
NamespaceSummaryItemEditorDlg..::.AccessibilityNotifyClients Method
NamespaceSummaryItemEditorDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

NamespaceSummaryItemEditorDlg Class
NamespaceSummaryItemEditorDlg Members
SandcastleBuilder.Utils.Design Namespace


BeginInvoke Method

[image] [image]

Sandcastle Help File Builder Documentation
NamespaceSummaryItemEditorDlg..::.BeginInvoke Method
NamespaceSummaryItemEditorDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

NamespaceSummaryItemEditorDlg Class
NamespaceSummaryItemEditorDlg Members
SandcastleBuilder.Utils.Design Namespace


Dispose Method

[image] [image]

Sandcastle Help File Builder Documentation
NamespaceSummaryItemEditorDlg..::.Dispose Method
NamespaceSummaryItemEditorDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides Form..::.Dispose(Boolean).)

See Also

NamespaceSummaryItemEditorDlg Class
NamespaceSummaryItemEditorDlg Members
SandcastleBuilder.Utils.Design Namespace


Dispose Method (Boolean)

[image]

Sandcastle Help File Builder Documentation
NamespaceSummaryItemEditorDlg..::.Dispose Method (Boolean)
NamespaceSummaryItemEditorDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

NamespaceSummaryItemEditorDlg Class
Dispose Overload
SandcastleBuilder.Utils.Design Namespace


GetChildAtPoint Method

[image] [image]

Sandcastle Help File Builder Documentation
NamespaceSummaryItemEditorDlg..::.GetChildAtPoint Method
NamespaceSummaryItemEditorDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

NamespaceSummaryItemEditorDlg Class
NamespaceSummaryItemEditorDlg Members
SandcastleBuilder.Utils.Design Namespace


Invalidate Method

[image] [image]

Sandcastle Help File Builder Documentation
NamespaceSummaryItemEditorDlg..::.Invalidate Method
NamespaceSummaryItemEditorDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

NamespaceSummaryItemEditorDlg Class
NamespaceSummaryItemEditorDlg Members
SandcastleBuilder.Utils.Design Namespace


Invoke Method

[image] [image]

Sandcastle Help File Builder Documentation
NamespaceSummaryItemEditorDlg..::.Invoke Method
NamespaceSummaryItemEditorDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

NamespaceSummaryItemEditorDlg Class
NamespaceSummaryItemEditorDlg Members
SandcastleBuilder.Utils.Design Namespace


MemberwiseClone Method

[image] [image]

Sandcastle Help File Builder Documentation
NamespaceSummaryItemEditorDlg..::.MemberwiseClone Method
NamespaceSummaryItemEditorDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

NamespaceSummaryItemEditorDlg Class
NamespaceSummaryItemEditorDlg Members
SandcastleBuilder.Utils.Design Namespace


PerformLayout Method

[image] [image]

Sandcastle Help File Builder Documentation
NamespaceSummaryItemEditorDlg..::.PerformLayout Method
NamespaceSummaryItemEditorDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

NamespaceSummaryItemEditorDlg Class
NamespaceSummaryItemEditorDlg Members
SandcastleBuilder.Utils.Design Namespace


ResumeLayout Method

[image] [image]

Sandcastle Help File Builder Documentation
NamespaceSummaryItemEditorDlg..::.ResumeLayout Method
NamespaceSummaryItemEditorDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

NamespaceSummaryItemEditorDlg Class
NamespaceSummaryItemEditorDlg Members
SandcastleBuilder.Utils.Design Namespace


RtlTranslateAlignment Method

[image] [image]

Sandcastle Help File Builder Documentation
NamespaceSummaryItemEditorDlg..::.RtlTranslateAlignment Method
NamespaceSummaryItemEditorDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

NamespaceSummaryItemEditorDlg Class
NamespaceSummaryItemEditorDlg Members
SandcastleBuilder.Utils.Design Namespace


Scale Method

[image] [image]

Sandcastle Help File Builder Documentation
NamespaceSummaryItemEditorDlg..::.Scale Method
NamespaceSummaryItemEditorDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

NamespaceSummaryItemEditorDlg Class
NamespaceSummaryItemEditorDlg Members
SandcastleBuilder.Utils.Design Namespace


Select Method

[image] [image]

Sandcastle Help File Builder Documentation
NamespaceSummaryItemEditorDlg..::.Select Method
NamespaceSummaryItemEditorDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)

See Also

NamespaceSummaryItemEditorDlg Class
NamespaceSummaryItemEditorDlg Members
SandcastleBuilder.Utils.Design Namespace


SetBounds Method

[image] [image]

Sandcastle Help File Builder Documentation
NamespaceSummaryItemEditorDlg..::.SetBounds Method
NamespaceSummaryItemEditorDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

NamespaceSummaryItemEditorDlg Class
NamespaceSummaryItemEditorDlg Members
SandcastleBuilder.Utils.Design Namespace


Show Method

[image] [image]

Sandcastle Help File Builder Documentation
NamespaceSummaryItemEditorDlg..::.Show Method
NamespaceSummaryItemEditorDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Show()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

NamespaceSummaryItemEditorDlg Class
NamespaceSummaryItemEditorDlg Members
SandcastleBuilder.Utils.Design Namespace


ShowDialog Method

[image] [image]

Sandcastle Help File Builder Documentation
NamespaceSummaryItemEditorDlg..::.ShowDialog Method
NamespaceSummaryItemEditorDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)

See Also

NamespaceSummaryItemEditorDlg Class
NamespaceSummaryItemEditorDlg Members
SandcastleBuilder.Utils.Design Namespace


UpdateBounds Method

[image] [image]

Sandcastle Help File Builder Documentation
NamespaceSummaryItemEditorDlg..::.UpdateBounds Method
NamespaceSummaryItemEditorDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

NamespaceSummaryItemEditorDlg Class
NamespaceSummaryItemEditorDlg Members
SandcastleBuilder.Utils.Design Namespace


Validate Method

[image] [image]

Sandcastle Help File Builder Documentation
NamespaceSummaryItemEditorDlg..::.Validate Method
NamespaceSummaryItemEditorDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

NamespaceSummaryItemEditorDlg Class
NamespaceSummaryItemEditorDlg Members
SandcastleBuilder.Utils.Design Namespace


ValidateChildren Method

[image] [image]

Sandcastle Help File Builder Documentation
NamespaceSummaryItemEditorDlg..::.ValidateChildren Method
NamespaceSummaryItemEditorDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

NamespaceSummaryItemEditorDlg Class
NamespaceSummaryItemEditorDlg Members
SandcastleBuilder.Utils.Design Namespace


NamespaceSummaryItemEditorDlg Properties

[image] [image]

Sandcastle Help File Builder Documentation
NamespaceSummaryItemEditorDlg Properties
NamespaceSummaryItemEditorDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The NamespaceSummaryItemEditorDlg type exposes the following members.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

NamespaceSummaryItemEditorDlg Class
SandcastleBuilder.Utils.Design Namespace


NamespaceSummaryItemEditorDlg Events

[image] [image]

Sandcastle Help File Builder Documentation
NamespaceSummaryItemEditorDlg Events
NamespaceSummaryItemEditorDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The NamespaceSummaryItemEditorDlg type exposes the following members.

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

NamespaceSummaryItemEditorDlg Class
SandcastleBuilder.Utils.Design Namespace


ProjectSummaryEditorDlg Class

[image]

Sandcastle Help File Builder Documentation
ProjectSummaryEditorDlg Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This form is used to edit the project summary comments.

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public class ProjectSummaryEditorDlg : Form
Visual Basic (Declaration)
Public Class ProjectSummaryEditorDlg _
    Inherits Form

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
SandcastleBuilder.Utils.Design..::.ProjectSummaryEditorDlg

See Also

ProjectSummaryEditorDlg Members
SandcastleBuilder.Utils.Design Namespace


ProjectSummaryEditorDlg Members

[image] [image]

Sandcastle Help File Builder Documentation
ProjectSummaryEditorDlg Members
ProjectSummaryEditorDlg Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ProjectSummaryEditorDlg type exposes the following members.

Constructors

Name | Description
ProjectSummaryEditorDlg | Constructor

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Summary | Get or set the project summary comments
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

ProjectSummaryEditorDlg Class
SandcastleBuilder.Utils.Design Namespace


ProjectSummaryEditorDlg Constructor

[image]

Sandcastle Help File Builder Documentation
ProjectSummaryEditorDlg Constructor
ProjectSummaryEditorDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public ProjectSummaryEditorDlg()
Visual Basic (Declaration)
Public Sub New

See Also

ProjectSummaryEditorDlg Class
SandcastleBuilder.Utils.Design Namespace


ProjectSummaryEditorDlg Methods

[image] [image]

Sandcastle Help File Builder Documentation
ProjectSummaryEditorDlg Methods
ProjectSummaryEditorDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ProjectSummaryEditorDlg type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

See Also

ProjectSummaryEditorDlg Class
SandcastleBuilder.Utils.Design Namespace


AccessibilityNotifyClients Method

[image] [image]

Sandcastle Help File Builder Documentation
ProjectSummaryEditorDlg..::.AccessibilityNotifyClients Method
ProjectSummaryEditorDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

ProjectSummaryEditorDlg Class
ProjectSummaryEditorDlg Members
SandcastleBuilder.Utils.Design Namespace


BeginInvoke Method

[image] [image]

Sandcastle Help File Builder Documentation
ProjectSummaryEditorDlg..::.BeginInvoke Method
ProjectSummaryEditorDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

ProjectSummaryEditorDlg Class
ProjectSummaryEditorDlg Members
SandcastleBuilder.Utils.Design Namespace


Dispose Method

[image] [image]

Sandcastle Help File Builder Documentation
ProjectSummaryEditorDlg..::.Dispose Method
ProjectSummaryEditorDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides Form..::.Dispose(Boolean).)

See Also

ProjectSummaryEditorDlg Class
ProjectSummaryEditorDlg Members
SandcastleBuilder.Utils.Design Namespace


Dispose Method (Boolean)

[image]

Sandcastle Help File Builder Documentation
ProjectSummaryEditorDlg..::.Dispose Method (Boolean)
ProjectSummaryEditorDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

ProjectSummaryEditorDlg Class
Dispose Overload
SandcastleBuilder.Utils.Design Namespace


GetChildAtPoint Method

[image] [image]

Sandcastle Help File Builder Documentation
ProjectSummaryEditorDlg..::.GetChildAtPoint Method
ProjectSummaryEditorDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

ProjectSummaryEditorDlg Class
ProjectSummaryEditorDlg Members
SandcastleBuilder.Utils.Design Namespace


Invalidate Method

[image] [image]

Sandcastle Help File Builder Documentation
ProjectSummaryEditorDlg..::.Invalidate Method
ProjectSummaryEditorDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

ProjectSummaryEditorDlg Class
ProjectSummaryEditorDlg Members
SandcastleBuilder.Utils.Design Namespace


Invoke Method

[image] [image]

Sandcastle Help File Builder Documentation
ProjectSummaryEditorDlg..::.Invoke Method
ProjectSummaryEditorDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

ProjectSummaryEditorDlg Class
ProjectSummaryEditorDlg Members
SandcastleBuilder.Utils.Design Namespace


MemberwiseClone Method

[image] [image]

Sandcastle Help File Builder Documentation
ProjectSummaryEditorDlg..::.MemberwiseClone Method
ProjectSummaryEditorDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ProjectSummaryEditorDlg Class
ProjectSummaryEditorDlg Members
SandcastleBuilder.Utils.Design Namespace


PerformLayout Method

[image] [image]

Sandcastle Help File Builder Documentation
ProjectSummaryEditorDlg..::.PerformLayout Method
ProjectSummaryEditorDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

ProjectSummaryEditorDlg Class
ProjectSummaryEditorDlg Members
SandcastleBuilder.Utils.Design Namespace


ResumeLayout Method

[image] [image]

Sandcastle Help File Builder Documentation
ProjectSummaryEditorDlg..::.ResumeLayout Method
ProjectSummaryEditorDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

ProjectSummaryEditorDlg Class
ProjectSummaryEditorDlg Members
SandcastleBuilder.Utils.Design Namespace


RtlTranslateAlignment Method

[image] [image]

Sandcastle Help File Builder Documentation
ProjectSummaryEditorDlg..::.RtlTranslateAlignment Method
ProjectSummaryEditorDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

ProjectSummaryEditorDlg Class
ProjectSummaryEditorDlg Members
SandcastleBuilder.Utils.Design Namespace


Scale Method

[image] [image]

Sandcastle Help File Builder Documentation
ProjectSummaryEditorDlg..::.Scale Method
ProjectSummaryEditorDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

ProjectSummaryEditorDlg Class
ProjectSummaryEditorDlg Members
SandcastleBuilder.Utils.Design Namespace


Select Method

[image] [image]

Sandcastle Help File Builder Documentation
ProjectSummaryEditorDlg..::.Select Method
ProjectSummaryEditorDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)

See Also

ProjectSummaryEditorDlg Class
ProjectSummaryEditorDlg Members
SandcastleBuilder.Utils.Design Namespace


SetBounds Method

[image] [image]

Sandcastle Help File Builder Documentation
ProjectSummaryEditorDlg..::.SetBounds Method
ProjectSummaryEditorDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

ProjectSummaryEditorDlg Class
ProjectSummaryEditorDlg Members
SandcastleBuilder.Utils.Design Namespace


Show Method

[image] [image]

Sandcastle Help File Builder Documentation
ProjectSummaryEditorDlg..::.Show Method
ProjectSummaryEditorDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Show()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

ProjectSummaryEditorDlg Class
ProjectSummaryEditorDlg Members
SandcastleBuilder.Utils.Design Namespace


ShowDialog Method

[image] [image]

Sandcastle Help File Builder Documentation
ProjectSummaryEditorDlg..::.ShowDialog Method
ProjectSummaryEditorDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)

See Also

ProjectSummaryEditorDlg Class
ProjectSummaryEditorDlg Members
SandcastleBuilder.Utils.Design Namespace


UpdateBounds Method

[image] [image]

Sandcastle Help File Builder Documentation
ProjectSummaryEditorDlg..::.UpdateBounds Method
ProjectSummaryEditorDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

ProjectSummaryEditorDlg Class
ProjectSummaryEditorDlg Members
SandcastleBuilder.Utils.Design Namespace


Validate Method

[image] [image]

Sandcastle Help File Builder Documentation
ProjectSummaryEditorDlg..::.Validate Method
ProjectSummaryEditorDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

ProjectSummaryEditorDlg Class
ProjectSummaryEditorDlg Members
SandcastleBuilder.Utils.Design Namespace


ValidateChildren Method

[image] [image]

Sandcastle Help File Builder Documentation
ProjectSummaryEditorDlg..::.ValidateChildren Method
ProjectSummaryEditorDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

ProjectSummaryEditorDlg Class
ProjectSummaryEditorDlg Members
SandcastleBuilder.Utils.Design Namespace


ProjectSummaryEditorDlg Properties

[image] [image]

Sandcastle Help File Builder Documentation
ProjectSummaryEditorDlg Properties
ProjectSummaryEditorDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ProjectSummaryEditorDlg type exposes the following members.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Summary | Get or set the project summary comments
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

ProjectSummaryEditorDlg Class
SandcastleBuilder.Utils.Design Namespace


Summary Property

[image]

Sandcastle Help File Builder Documentation
ProjectSummaryEditorDlg..::.Summary Property
ProjectSummaryEditorDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Get or set the project summary comments

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string Summary { get; set; }
Visual Basic (Declaration)
Public Property Summary As String

See Also

ProjectSummaryEditorDlg Class
SandcastleBuilder.Utils.Design Namespace


ProjectSummaryEditorDlg Events

[image] [image]

Sandcastle Help File Builder Documentation
ProjectSummaryEditorDlg Events
ProjectSummaryEditorDlg Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ProjectSummaryEditorDlg type exposes the following members.

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

ProjectSummaryEditorDlg Class
SandcastleBuilder.Utils.Design Namespace


VersionTypeConverter Class

[image]

Sandcastle Help File Builder Documentation
VersionTypeConverter Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This type converter converts between a string and a Version object and vice versa.

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public class VersionTypeConverter : TypeConverter
Visual Basic (Declaration)
Public Class VersionTypeConverter _
    Inherits TypeConverter

Inheritance Hierarchy

System..::.Object
System.ComponentModel..::.TypeConverter
SandcastleBuilder.Utils.Design..::.VersionTypeConverter

See Also

VersionTypeConverter Members
SandcastleBuilder.Utils.Design Namespace


VersionTypeConverter Members

[image] [image]

Sandcastle Help File Builder Documentation
VersionTypeConverter Members
VersionTypeConverter Class Constructors Methods See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The VersionTypeConverter type exposes the following members.

Constructors

Name | Description
VersionTypeConverter | Initializes a new instance of the VersionTypeConverter class

Methods

Name | Description
CanConvertFrom | Overloaded.
CanConvertTo | Overloaded.
ConvertFrom | Overloaded.
ConvertFromInvariantString | Overloaded.
ConvertFromString | Overloaded.
ConvertTo | Overloaded.
ConvertToInvariantString | Overloaded.
ConvertToString | Overloaded.
CreateInstance | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
GetCreateInstanceSupported | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetProperties | Overloaded.
GetPropertiesSupported | Overloaded.
GetStandardValues | Overloaded.
GetStandardValuesExclusive | Overloaded.
GetStandardValuesSupported | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VersionTypeConverter Class
SandcastleBuilder.Utils.Design Namespace


VersionTypeConverter Constructor

[image]

Sandcastle Help File Builder Documentation
VersionTypeConverter Constructor
VersionTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the VersionTypeConverter class

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public VersionTypeConverter()
Visual Basic (Declaration)
Public Sub New

See Also

VersionTypeConverter Class
SandcastleBuilder.Utils.Design Namespace


VersionTypeConverter Methods

[image] [image]

Sandcastle Help File Builder Documentation
VersionTypeConverter Methods
VersionTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The VersionTypeConverter type exposes the following members.

Methods

Name | Description
CanConvertFrom | Overloaded.
CanConvertTo | Overloaded.
ConvertFrom | Overloaded.
ConvertFromInvariantString | Overloaded.
ConvertFromString | Overloaded.
ConvertTo | Overloaded.
ConvertToInvariantString | Overloaded.
ConvertToString | Overloaded.
CreateInstance | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
GetCreateInstanceSupported | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetProperties | Overloaded.
GetPropertiesSupported | Overloaded.
GetStandardValues | Overloaded.
GetStandardValuesExclusive | Overloaded.
GetStandardValuesSupported | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VersionTypeConverter Class
SandcastleBuilder.Utils.Design Namespace


CanConvertFrom Method

[image] [image]

Sandcastle Help File Builder Documentation
VersionTypeConverter..::.CanConvertFrom Method
VersionTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context. (Overrides TypeConverter..::.CanConvertFrom(ITypeDescriptorContext, Type).)

See Also

VersionTypeConverter Class
VersionTypeConverter Members
SandcastleBuilder.Utils.Design Namespace


CanConvertFrom Method (ITypeDescriptorContext, Type)

[image]

Sandcastle Help File Builder Documentation
VersionTypeConverter..::.CanConvertFrom Method (ITypeDescriptorContext, Type)
VersionTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context.

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public override bool CanConvertFrom(
    ITypeDescriptorContext context,
    Type sourceType
)
Visual Basic (Declaration)
Public Overrides Function CanConvertFrom ( _
    context As ITypeDescriptorContext, _
    sourceType As Type _
) As Boolean

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
sourceType
Type: System..::.Type
A Type that represents the type you want to convert from.

Return Value

true if this converter can perform the conversion; otherwise, false.

See Also

VersionTypeConverter Class
CanConvertFrom Overload
SandcastleBuilder.Utils.Design Namespace


CanConvertTo Method

[image] [image]

Sandcastle Help File Builder Documentation
VersionTypeConverter..::.CanConvertTo Method
VersionTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Inherited from TypeConverter.)

See Also

VersionTypeConverter Class
VersionTypeConverter Members
SandcastleBuilder.Utils.Design Namespace


ConvertFrom Method

[image] [image]

Sandcastle Help File Builder Documentation
VersionTypeConverter..::.ConvertFrom Method
VersionTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the given object to the type of this converter, using the specified context and culture information. (Overrides TypeConverter..::.ConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)

See Also

VersionTypeConverter Class
VersionTypeConverter Members
SandcastleBuilder.Utils.Design Namespace


ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

[image]

Sandcastle Help File Builder Documentation
VersionTypeConverter..::.ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)
VersionTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Converts the given object to the type of this converter, using the specified context and culture information.

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public override Object ConvertFrom(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value
)
Visual Basic (Declaration)
Public Overrides Function ConvertFrom ( _
    context As ITypeDescriptorContext, _
    culture As CultureInfo, _
    value As Object _
) As Object

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
culture
Type: System.Globalization..::.CultureInfo
The CultureInfo to use as the current culture.
value
Type: System..::.Object
The Object to convert.

Return Value

A Version object. The value is always a four-part version number with any unused parts defaulted to zero. If the new value is null or an empty string, null is returned.

Exceptions

Exception | Condition
System..::.NotSupportedException | The conversion cannot be performed.

See Also

VersionTypeConverter Class
ConvertFrom Overload
SandcastleBuilder.Utils.Design Namespace


ConvertFromInvariantString Method

[image] [image]

Sandcastle Help File Builder Documentation
VersionTypeConverter..::.ConvertFromInvariantString Method
VersionTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)

See Also

VersionTypeConverter Class
VersionTypeConverter Members
SandcastleBuilder.Utils.Design Namespace


ConvertFromString Method

[image] [image]

Sandcastle Help File Builder Documentation
VersionTypeConverter..::.ConvertFromString Method
VersionTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)

See Also

VersionTypeConverter Class
VersionTypeConverter Members
SandcastleBuilder.Utils.Design Namespace


ConvertTo Method

[image] [image]

Sandcastle Help File Builder Documentation
VersionTypeConverter..::.ConvertTo Method
VersionTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Overrides TypeConverter..::.ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)

See Also

VersionTypeConverter Class
VersionTypeConverter Members
SandcastleBuilder.Utils.Design Namespace


ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

[image]

Sandcastle Help File Builder Documentation
VersionTypeConverter..::.ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)
VersionTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Converts the given value object to the specified type, using the specified context and culture information.

Namespace: SandcastleBuilder.Utils.Design
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public override Object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value,
    Type destinationType
)
Visual Basic (Declaration)
Public Overrides Function ConvertTo ( _
    context As ITypeDescriptorContext, _
    culture As CultureInfo, _
    value As Object, _
    destinationType As Type _
) As Object

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
culture
Type: System.Globalization..::.CultureInfo
A CultureInfo. If null is passed, the current culture is assumed.
value
Type: System..::.Object
The Object to convert.
destinationType
Type: System..::.Type
The Type to convert the value parameter to.

Return Value

An Object that represents the converted value.

Exceptions

Exception | Condition
System..::.ArgumentNullException | The destinationType parameter is null.
System..::.NotSupportedException | The conversion cannot be performed.

See Also

VersionTypeConverter Class
ConvertTo Overload
SandcastleBuilder.Utils.Design Namespace


ConvertToInvariantString Method

[image] [image]

Sandcastle Help File Builder Documentation
VersionTypeConverter..::.ConvertToInvariantString Method
VersionTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)

See Also

VersionTypeConverter Class
VersionTypeConverter Members
SandcastleBuilder.Utils.Design Namespace


ConvertToString Method

[image] [image]

Sandcastle Help File Builder Documentation
VersionTypeConverter..::.ConvertToString Method
VersionTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)

See Also

VersionTypeConverter Class
VersionTypeConverter Members
SandcastleBuilder.Utils.Design Namespace


CreateInstance Method

[image] [image]

Sandcastle Help File Builder Documentation
VersionTypeConverter..::.CreateInstance Method
VersionTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)

See Also

VersionTypeConverter Class
VersionTypeConverter Members
SandcastleBuilder.Utils.Design Namespace


GetCreateInstanceSupported Method

[image] [image]

Sandcastle Help File Builder Documentation
VersionTypeConverter..::.GetCreateInstanceSupported Method
VersionTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetCreateInstanceSupported()()() | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)

See Also

VersionTypeConverter Class
VersionTypeConverter Members
SandcastleBuilder.Utils.Design Namespace


GetProperties Method

[image] [image]

Sandcastle Help File Builder Documentation
VersionTypeConverter..::.GetProperties Method
VersionTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
GetProperties(ITypeDescriptorContext, Object, array<Attribute>[]()[]) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Inherited from TypeConverter.)

See Also

VersionTypeConverter Class
VersionTypeConverter Members
SandcastleBuilder.Utils.Design Namespace


GetPropertiesSupported Method

[image] [image]

Sandcastle Help File Builder Documentation
VersionTypeConverter..::.GetPropertiesSupported Method
VersionTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetPropertiesSupported()()() | Returns whether this object supports properties. (Inherited from TypeConverter.)
GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the specified context. (Inherited from TypeConverter.)

See Also

VersionTypeConverter Class
VersionTypeConverter Members
SandcastleBuilder.Utils.Design Namespace


GetStandardValues Method

[image] [image]

Sandcastle Help File Builder Documentation
VersionTypeConverter..::.GetStandardValues Method
VersionTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetStandardValues()()() | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)

See Also

VersionTypeConverter Class
VersionTypeConverter Members
SandcastleBuilder.Utils.Design Namespace


GetStandardValuesExclusive Method

[image] [image]

Sandcastle Help File Builder Documentation
VersionTypeConverter..::.GetStandardValuesExclusive Method
VersionTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetStandardValuesExclusive()()() | Returns whether the collection of standard values returned from GetStandardValues()()() is an exclusive list. (Inherited from TypeConverter.)
GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues()()() is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)

See Also

VersionTypeConverter Class
VersionTypeConverter Members
SandcastleBuilder.Utils.Design Namespace


GetStandardValuesSupported Method

[image] [image]

Sandcastle Help File Builder Documentation
VersionTypeConverter..::.GetStandardValuesSupported Method
VersionTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetStandardValuesSupported()()() | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)

See Also

VersionTypeConverter Class
VersionTypeConverter Members
SandcastleBuilder.Utils.Design Namespace


IsValid Method

[image] [image]

Sandcastle Help File Builder Documentation
VersionTypeConverter..::.IsValid Method
VersionTypeConverter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)

See Also

VersionTypeConverter Class
VersionTypeConverter Members
SandcastleBuilder.Utils.Design Namespace


SandcastleBuilder.Utils.Gac Namespace

[image]

Sandcastle Help File Builder Documentation
SandcastleBuilder.Utils.Gac Namespace
Send Feedback

[This is preliminary documentation and is subject to change.]

This namespace contains a couple of classes used to interact with the GAC and to load assemblies in an alternate application domain.

Classes

Class | Description
GacEnumerator | This class is used to get a list of assemblies in the Global Assembly Cache (GAC).


GacEnumerator Class

[image]

Sandcastle Help File Builder Documentation
GacEnumerator Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This class is used to get a list of assemblies in the Global Assembly Cache (GAC).

Namespace: SandcastleBuilder.Utils.Gac
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public static class GacEnumerator
Visual Basic (Declaration)
Public NotInheritable Class GacEnumerator

Inheritance Hierarchy

System..::.Object
SandcastleBuilder.Utils.Gac..::.GacEnumerator

See Also

GacEnumerator Members
SandcastleBuilder.Utils.Gac Namespace


GacEnumerator Members

[image] [image]

Sandcastle Help File Builder Documentation
GacEnumerator Members
GacEnumerator Class Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The GacEnumerator type exposes the following members.

Properties

Name | Description
GacList | This static property is used to obtain a list containing the fully qualified names of all assemblies in the GAC.

See Also

GacEnumerator Class
SandcastleBuilder.Utils.Gac Namespace


GacEnumerator Properties

[image] [image]

Sandcastle Help File Builder Documentation
GacEnumerator Properties
GacEnumerator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The GacEnumerator type exposes the following members.

Properties

Name | Description
GacList | This static property is used to obtain a list containing the fully qualified names of all assemblies in the GAC.

See Also

GacEnumerator Class
SandcastleBuilder.Utils.Gac Namespace


GacList Property

[image]

Sandcastle Help File Builder Documentation
GacEnumerator..::.GacList Property
GacEnumerator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This static property is used to obtain a list containing the fully qualified names of all assemblies in the GAC.

Namespace: SandcastleBuilder.Utils.Gac
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public static Collection<string> GacList { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property GacList As Collection(Of String)

See Also

GacEnumerator Class
SandcastleBuilder.Utils.Gac Namespace


SandcastleBuilder.Utils.InheritedDocumentation Namespace

[image]

Sandcastle Help File Builder Documentation
SandcastleBuilder.Utils.InheritedDocumentation Namespace
Send Feedback

[This is preliminary documentation and is subject to change.]

This namespace contains classes related to indexing comments files used when generating inherited documentation.

Classes

Class | Description
CommentsCacheEventArgs | This is used by the comments cache to report a warning message
IndexedCommentsCache | This is used to cache indexed XML comments files
IndexedCommentsFile | This represents an indexed XML comments file
InheritedDocsException | This exception class is thrown by the application if it encounters an unrecoverable error.


CommentsCacheEventArgs Class

[image]

Sandcastle Help File Builder Documentation
CommentsCacheEventArgs Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used by the comments cache to report a warning message

Namespace: SandcastleBuilder.Utils.InheritedDocumentation
Assemblies: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2
GenerateInheritedDocs (in GenerateInheritedDocs.exe) Version: 1.8.0.2

Syntax

C#
public class CommentsCacheEventArgs : EventArgs
Visual Basic (Declaration)
Public Class CommentsCacheEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
SandcastleBuilder.Utils.InheritedDocumentation..::.CommentsCacheEventArgs

See Also

CommentsCacheEventArgs Members
SandcastleBuilder.Utils.InheritedDocumentation Namespace


CommentsCacheEventArgs Members

[image] [image]

Sandcastle Help File Builder Documentation
CommentsCacheEventArgs Members
CommentsCacheEventArgs Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The CommentsCacheEventArgs type exposes the following members.

Constructors

Name | Description
CommentsCacheEventArgs | Constructor

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Message | The message to report

See Also

CommentsCacheEventArgs Class
SandcastleBuilder.Utils.InheritedDocumentation Namespace


CommentsCacheEventArgs Constructor

[image]

Sandcastle Help File Builder Documentation
CommentsCacheEventArgs Constructor
CommentsCacheEventArgs Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Utils.InheritedDocumentation
Assemblies: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2
GenerateInheritedDocs (in GenerateInheritedDocs.exe) Version: 1.8.0.2

Syntax

C#
public CommentsCacheEventArgs(
    string text
)
Visual Basic (Declaration)
Public Sub New ( _
    text As String _
)

Parameters

text
Type: System..::.String
The message text

See Also

CommentsCacheEventArgs Class
SandcastleBuilder.Utils.InheritedDocumentation Namespace


CommentsCacheEventArgs Methods

[image] [image]

Sandcastle Help File Builder Documentation
CommentsCacheEventArgs Methods
CommentsCacheEventArgs Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The CommentsCacheEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CommentsCacheEventArgs Class
SandcastleBuilder.Utils.InheritedDocumentation Namespace


CommentsCacheEventArgs Properties

[image] [image]

Sandcastle Help File Builder Documentation
CommentsCacheEventArgs Properties
CommentsCacheEventArgs Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The CommentsCacheEventArgs type exposes the following members.

Properties

Name | Description
Message | The message to report

See Also

CommentsCacheEventArgs Class
SandcastleBuilder.Utils.InheritedDocumentation Namespace


Message Property

[image]

Sandcastle Help File Builder Documentation
CommentsCacheEventArgs..::.Message Property
CommentsCacheEventArgs Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The message to report

Namespace: SandcastleBuilder.Utils.InheritedDocumentation
Assemblies: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2
GenerateInheritedDocs (in GenerateInheritedDocs.exe) Version: 1.8.0.2

Syntax

C#
public string Message { get; }
Visual Basic (Declaration)
Public ReadOnly Property Message As String

See Also

CommentsCacheEventArgs Class
SandcastleBuilder.Utils.InheritedDocumentation Namespace


IndexedCommentsCache Class

[image]

Sandcastle Help File Builder Documentation
IndexedCommentsCache Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to cache indexed XML comments files

Namespace: SandcastleBuilder.Utils.InheritedDocumentation
Assemblies: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2
GenerateInheritedDocs (in GenerateInheritedDocs.exe) Version: 1.8.0.2

Syntax

C#
public class IndexedCommentsCache
Visual Basic (Declaration)
Public Class IndexedCommentsCache

Inheritance Hierarchy

System..::.Object
SandcastleBuilder.Utils.InheritedDocumentation..::.IndexedCommentsCache

See Also

IndexedCommentsCache Members
SandcastleBuilder.Utils.InheritedDocumentation Namespace


IndexedCommentsCache Members

[image] [image]

Sandcastle Help File Builder Documentation
IndexedCommentsCache Members
IndexedCommentsCache Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IndexedCommentsCache type exposes the following members.

Constructors

Name | Description
IndexedCommentsCache | Constructor

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetComments | Get the comments for the specified key
GetCommentsFile | Get the comments file from the index cache that contains the given key.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetKeys | Return all keys in this index
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexCommentsFiles | Index all comments files found in the specified folder.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnReportWarning | This is used to raise the ReportWarning event
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
FilesIndexed | This read-only property returns the number of comments files that were indexed.
IndexCount | This read-only property returns the number of items indexed

Events

Name | Description
ReportWarning | This is used by the cache to report duplicate key warnings

See Also

IndexedCommentsCache Class
SandcastleBuilder.Utils.InheritedDocumentation Namespace


IndexedCommentsCache Constructor

[image]

Sandcastle Help File Builder Documentation
IndexedCommentsCache Constructor
IndexedCommentsCache Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Utils.InheritedDocumentation
Assemblies: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2
GenerateInheritedDocs (in GenerateInheritedDocs.exe) Version: 1.8.0.2

Syntax

C#
public IndexedCommentsCache(
    int size
)
Visual Basic (Declaration)
Public Sub New ( _
    size As Integer _
)

Parameters

size
Type: System..::.Int32
The maximum size of the cache

See Also

IndexedCommentsCache Class
SandcastleBuilder.Utils.InheritedDocumentation Namespace


IndexedCommentsCache Methods

[image] [image]

Sandcastle Help File Builder Documentation
IndexedCommentsCache Methods
IndexedCommentsCache Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IndexedCommentsCache type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetComments | Get the comments for the specified key
GetCommentsFile | Get the comments file from the index cache that contains the given key.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetKeys | Return all keys in this index
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexCommentsFiles | Index all comments files found in the specified folder.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnReportWarning | This is used to raise the ReportWarning event
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IndexedCommentsCache Class
SandcastleBuilder.Utils.InheritedDocumentation Namespace


GetComments Method

[image]

Sandcastle Help File Builder Documentation
IndexedCommentsCache..::.GetComments Method
IndexedCommentsCache Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Get the comments for the specified key

Namespace: SandcastleBuilder.Utils.InheritedDocumentation
Assemblies: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2
GenerateInheritedDocs (in GenerateInheritedDocs.exe) Version: 1.8.0.2

Syntax

C#
public XPathNavigator GetComments(
    string key
)
Visual Basic (Declaration)
Public Function GetComments ( _
    key As String _
) As XPathNavigator

Parameters

key
Type: System..::.String
The key for which to retrieve comments

Return Value

An XPathNavigator for the comments or null if not found.

See Also

IndexedCommentsCache Class
SandcastleBuilder.Utils.InheritedDocumentation Namespace


GetCommentsFile Method

[image]

Sandcastle Help File Builder Documentation
IndexedCommentsCache..::.GetCommentsFile Method
IndexedCommentsCache Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Get the comments file from the index cache that contains the given key.

Namespace: SandcastleBuilder.Utils.InheritedDocumentation
Assemblies: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2
GenerateInheritedDocs (in GenerateInheritedDocs.exe) Version: 1.8.0.2

Syntax

C#
public IndexedCommentsFile GetCommentsFile(
    string key
)
Visual Basic (Declaration)
Public Function GetCommentsFile ( _
    key As String _
) As IndexedCommentsFile

Parameters

key
Type: System..::.String
The key for which to retrieve the file

Return Value

The indexed comments file or null if not found

See Also

IndexedCommentsCache Class
SandcastleBuilder.Utils.InheritedDocumentation Namespace


GetKeys Method

[image]

Sandcastle Help File Builder Documentation
IndexedCommentsCache..::.GetKeys Method
IndexedCommentsCache Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Return all keys in this index

Namespace: SandcastleBuilder.Utils.InheritedDocumentation
Assemblies: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2
GenerateInheritedDocs (in GenerateInheritedDocs.exe) Version: 1.8.0.2

Syntax

C#
public string[] GetKeys()
Visual Basic (Declaration)
Public Function GetKeys As String()

Return Value

A string array containing the keys

See Also

IndexedCommentsCache Class
SandcastleBuilder.Utils.InheritedDocumentation Namespace


IndexCommentsFiles Method

[image]

Sandcastle Help File Builder Documentation
IndexedCommentsCache..::.IndexCommentsFiles Method
IndexedCommentsCache Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Index all comments files found in the specified folder.

Namespace: SandcastleBuilder.Utils.InheritedDocumentation
Assemblies: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2
GenerateInheritedDocs (in GenerateInheritedDocs.exe) Version: 1.8.0.2

Syntax

C#
public void IndexCommentsFiles(
    string path,
    string wildcard,
    bool recurse,
    Collection<XPathNavigator> commentsFiles
)
Visual Basic (Declaration)
Public Sub IndexCommentsFiles ( _
    path As String, _
    wildcard As String, _
    recurse As Boolean, _
    commentsFiles As Collection(Of XPathNavigator) _
)

Parameters

path
Type: System..::.String
The path to search. If null or empty, the current directory is assumed.
wildcard
Type: System..::.String
The wildcard to use. If null or empty, "*.xml" is assumed.
recurse
Type: System..::.Boolean
True to recurse subfolders or false to only use the given folder.
commentsFiles
Type: System.Collections.ObjectModel..::.Collection <(Of <( XPathNavigator >)>)
Optional. If not null, an XPathDocument is added to the collection for each file indexed.

See Also

IndexedCommentsCache Class
SandcastleBuilder.Utils.InheritedDocumentation Namespace


OnReportWarning Method

[image]

Sandcastle Help File Builder Documentation
IndexedCommentsCache..::.OnReportWarning Method
IndexedCommentsCache Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to raise the ReportWarning event

Namespace: SandcastleBuilder.Utils.InheritedDocumentation
Assemblies: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2
GenerateInheritedDocs (in GenerateInheritedDocs.exe) Version: 1.8.0.2

Syntax

C#
protected virtual void OnReportWarning(
    CommentsCacheEventArgs args
)
Visual Basic (Declaration)
Protected Overridable Sub OnReportWarning ( _
    args As CommentsCacheEventArgs _
)

Parameters

args
Type: SandcastleBuilder.Utils.InheritedDocumentation..::.CommentsCacheEventArgs
The event arguments

See Also

IndexedCommentsCache Class
SandcastleBuilder.Utils.InheritedDocumentation Namespace


IndexedCommentsCache Properties

[image] [image]

Sandcastle Help File Builder Documentation
IndexedCommentsCache Properties
IndexedCommentsCache Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IndexedCommentsCache type exposes the following members.

Properties

Name | Description
FilesIndexed | This read-only property returns the number of comments files that were indexed.
IndexCount | This read-only property returns the number of items indexed

See Also

IndexedCommentsCache Class
SandcastleBuilder.Utils.InheritedDocumentation Namespace


FilesIndexed Property

[image]

Sandcastle Help File Builder Documentation
IndexedCommentsCache..::.FilesIndexed Property
IndexedCommentsCache Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns the number of comments files that were indexed.

Namespace: SandcastleBuilder.Utils.InheritedDocumentation
Assemblies: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2
GenerateInheritedDocs (in GenerateInheritedDocs.exe) Version: 1.8.0.2

Syntax

C#
public int FilesIndexed { get; }
Visual Basic (Declaration)
Public ReadOnly Property FilesIndexed As Integer

See Also

IndexedCommentsCache Class
SandcastleBuilder.Utils.InheritedDocumentation Namespace


IndexCount Property

[image]

Sandcastle Help File Builder Documentation
IndexedCommentsCache..::.IndexCount Property
IndexedCommentsCache Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns the number of items indexed

Namespace: SandcastleBuilder.Utils.InheritedDocumentation
Assemblies: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2
GenerateInheritedDocs (in GenerateInheritedDocs.exe) Version: 1.8.0.2

Syntax

C#
public int IndexCount { get; }
Visual Basic (Declaration)
Public ReadOnly Property IndexCount As Integer

See Also

IndexedCommentsCache Class
SandcastleBuilder.Utils.InheritedDocumentation Namespace


IndexedCommentsCache Events

[image] [image]

Sandcastle Help File Builder Documentation
IndexedCommentsCache Events
IndexedCommentsCache Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IndexedCommentsCache type exposes the following members.

Events

Name | Description
ReportWarning | This is used by the cache to report duplicate key warnings

See Also

IndexedCommentsCache Class
SandcastleBuilder.Utils.InheritedDocumentation Namespace


ReportWarning Event

[image]

Sandcastle Help File Builder Documentation
IndexedCommentsCache..::.ReportWarning Event
IndexedCommentsCache Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used by the cache to report duplicate key warnings

Namespace: SandcastleBuilder.Utils.InheritedDocumentation
Assemblies: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2
GenerateInheritedDocs (in GenerateInheritedDocs.exe) Version: 1.8.0.2

Syntax

C#
public event EventHandler<CommentsCacheEventArgs> ReportWarning
Visual Basic (Declaration)
Public Event ReportWarning As EventHandler(Of CommentsCacheEventArgs)

See Also

IndexedCommentsCache Class
SandcastleBuilder.Utils.InheritedDocumentation Namespace


IndexedCommentsFile Class

[image]

Sandcastle Help File Builder Documentation
IndexedCommentsFile Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This represents an indexed XML comments file

Namespace: SandcastleBuilder.Utils.InheritedDocumentation
Assemblies: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2
GenerateInheritedDocs (in GenerateInheritedDocs.exe) Version: 1.8.0.2

Syntax

C#
public class IndexedCommentsFile
Visual Basic (Declaration)
Public Class IndexedCommentsFile

Inheritance Hierarchy

System..::.Object
SandcastleBuilder.Utils.InheritedDocumentation..::.IndexedCommentsFile

See Also

IndexedCommentsFile Members
SandcastleBuilder.Utils.InheritedDocumentation Namespace


IndexedCommentsFile Members

[image] [image]

Sandcastle Help File Builder Documentation
IndexedCommentsFile Members
IndexedCommentsFile Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IndexedCommentsFile type exposes the following members.

Constructors

Name | Description
IndexedCommentsFile | Constructor

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetContent | Get the XML comments for the given key
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetKeys | Return all keys in this file
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Count | This read-only property returns the number of items in the index
Filename | This read-only property returns the comments filename

See Also

IndexedCommentsFile Class
SandcastleBuilder.Utils.InheritedDocumentation Namespace


IndexedCommentsFile Constructor

[image]

Sandcastle Help File Builder Documentation
IndexedCommentsFile Constructor
IndexedCommentsFile Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Utils.InheritedDocumentation
Assemblies: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2
GenerateInheritedDocs (in GenerateInheritedDocs.exe) Version: 1.8.0.2

Syntax

C#
public IndexedCommentsFile(
    string filename
)
Visual Basic (Declaration)
Public Sub New ( _
    filename As String _
)

Parameters

filename
Type: System..::.String
The name of the XML comments file to index

See Also

IndexedCommentsFile Class
SandcastleBuilder.Utils.InheritedDocumentation Namespace


IndexedCommentsFile Methods

[image] [image]

Sandcastle Help File Builder Documentation
IndexedCommentsFile Methods
IndexedCommentsFile Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IndexedCommentsFile type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetContent | Get the XML comments for the given key
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetKeys | Return all keys in this file
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IndexedCommentsFile Class
SandcastleBuilder.Utils.InheritedDocumentation Namespace


GetContent Method

[image]

Sandcastle Help File Builder Documentation
IndexedCommentsFile..::.GetContent Method
IndexedCommentsFile Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Get the XML comments for the given key

Namespace: SandcastleBuilder.Utils.InheritedDocumentation
Assemblies: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2
GenerateInheritedDocs (in GenerateInheritedDocs.exe) Version: 1.8.0.2

Syntax

C#
public XPathNavigator GetContent(
    string key
)
Visual Basic (Declaration)
Public Function GetContent ( _
    key As String _
) As XPathNavigator

Parameters

key
Type: System..::.String
The key for the comments

Return Value

An XPathNavigator for the comments or null if not found.

See Also

IndexedCommentsFile Class
SandcastleBuilder.Utils.InheritedDocumentation Namespace


GetKeys Method

[image]

Sandcastle Help File Builder Documentation
IndexedCommentsFile..::.GetKeys Method
IndexedCommentsFile Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Return all keys in this file

Namespace: SandcastleBuilder.Utils.InheritedDocumentation
Assemblies: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2
GenerateInheritedDocs (in GenerateInheritedDocs.exe) Version: 1.8.0.2

Syntax

C#
public string[] GetKeys()
Visual Basic (Declaration)
Public Function GetKeys As String()

Return Value

A string array containing the keys

See Also

IndexedCommentsFile Class
SandcastleBuilder.Utils.InheritedDocumentation Namespace


IndexedCommentsFile Properties

[image] [image]

Sandcastle Help File Builder Documentation
IndexedCommentsFile Properties
IndexedCommentsFile Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IndexedCommentsFile type exposes the following members.

Properties

Name | Description
Count | This read-only property returns the number of items in the index
Filename | This read-only property returns the comments filename

See Also

IndexedCommentsFile Class
SandcastleBuilder.Utils.InheritedDocumentation Namespace


Count Property

[image]

Sandcastle Help File Builder Documentation
IndexedCommentsFile..::.Count Property
IndexedCommentsFile Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns the number of items in the index

Namespace: SandcastleBuilder.Utils.InheritedDocumentation
Assemblies: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2
GenerateInheritedDocs (in GenerateInheritedDocs.exe) Version: 1.8.0.2

Syntax

C#
public int Count { get; }
Visual Basic (Declaration)
Public ReadOnly Property Count As Integer

See Also

IndexedCommentsFile Class
SandcastleBuilder.Utils.InheritedDocumentation Namespace


Filename Property

[image]

Sandcastle Help File Builder Documentation
IndexedCommentsFile..::.Filename Property
IndexedCommentsFile Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns the comments filename

Namespace: SandcastleBuilder.Utils.InheritedDocumentation
Assemblies: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2
GenerateInheritedDocs (in GenerateInheritedDocs.exe) Version: 1.8.0.2

Syntax

C#
public string Filename { get; }
Visual Basic (Declaration)
Public ReadOnly Property Filename As String

See Also

IndexedCommentsFile Class
SandcastleBuilder.Utils.InheritedDocumentation Namespace


InheritedDocsException Class

[image]

Sandcastle Help File Builder Documentation
InheritedDocsException Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This exception class is thrown by the application if it encounters an unrecoverable error.

Namespace: SandcastleBuilder.Utils.InheritedDocumentation
Assemblies: GenerateInheritedDocs (in GenerateInheritedDocs.exe) Version: 1.8.0.2
SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
[SerializableAttribute]
public class InheritedDocsException : Exception
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class InheritedDocsException _
    Inherits Exception

Inheritance Hierarchy

System..::.Object
System..::.Exception
SandcastleBuilder.Utils.InheritedDocumentation..::.InheritedDocsException

See Also

InheritedDocsException Members
SandcastleBuilder.Utils.InheritedDocumentation Namespace


InheritedDocsException Members

[image] [image]

Sandcastle Help File Builder Documentation
InheritedDocsException Members
InheritedDocsException Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The InheritedDocsException type exposes the following members.

Constructors

Name | Description
InheritedDocsException | Overloaded. There are three overloads for the constructor

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InheritedDocsException Class
SandcastleBuilder.Utils.InheritedDocumentation Namespace


InheritedDocsException Constructor

[image] [image]

Sandcastle Help File Builder Documentation
InheritedDocsException Constructor
InheritedDocsException Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

There are three overloads for the constructor

Overload List

Name | Description
InheritedDocsException()()() | Default constructor.
InheritedDocsException(String) | Initializes a new instance of the Exception class with a specified error message.
InheritedDocsException(SerializationInfo, StreamingContext) | Initializes a new instance of the Exception class with serialized data.
InheritedDocsException(String, Exception) | Initializes a new instance of the Exception class with a specified error message and a reference to the inner exception that is the cause of this exception.

See Also

InheritedDocsException Class
InheritedDocsException Members
SandcastleBuilder.Utils.InheritedDocumentation Namespace


InheritedDocsException Constructor

[image]

Sandcastle Help File Builder Documentation
InheritedDocsException Constructor
InheritedDocsException Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Default constructor.

Namespace: SandcastleBuilder.Utils.InheritedDocumentation
Assemblies: GenerateInheritedDocs (in GenerateInheritedDocs.exe) Version: 1.8.0.2
SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public InheritedDocsException()
Visual Basic (Declaration)
Public Sub New

See Also

InheritedDocsException Class
InheritedDocsException Overload
SandcastleBuilder.Utils.InheritedDocumentation Namespace


InheritedDocsException Constructor (String)

[image]

Sandcastle Help File Builder Documentation
InheritedDocsException Constructor (String)
InheritedDocsException Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Exception class with a specified error message.

Namespace: SandcastleBuilder.Utils.InheritedDocumentation
Assemblies: GenerateInheritedDocs (in GenerateInheritedDocs.exe) Version: 1.8.0.2
SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public InheritedDocsException(
    string message
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)

Parameters

message
Type: System..::.String
The message that describes the error.

See Also

InheritedDocsException Class
InheritedDocsException Overload
SandcastleBuilder.Utils.InheritedDocumentation Namespace


InheritedDocsException Constructor (SerializationInfo, StreamingContext)

[image]

Sandcastle Help File Builder Documentation
InheritedDocsException Constructor (SerializationInfo, StreamingContext)
InheritedDocsException Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Exception class with serialized data.

Namespace: SandcastleBuilder.Utils.InheritedDocumentation
Assemblies: GenerateInheritedDocs (in GenerateInheritedDocs.exe) Version: 1.8.0.2
SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected InheritedDocsException(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.Serialization..::.StreamingContext
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Condition
System..::.ArgumentNullException | The info parameter is null.
System.Runtime.Serialization..::.SerializationException | The class name is null or HResult is zero (0).

See Also

InheritedDocsException Class
InheritedDocsException Overload
SandcastleBuilder.Utils.InheritedDocumentation Namespace


InheritedDocsException Constructor (String, Exception)

[image]

Sandcastle Help File Builder Documentation
InheritedDocsException Constructor (String, Exception)
InheritedDocsException Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Exception class with a specified error message and a reference to the inner exception that is the cause of this exception.

Namespace: SandcastleBuilder.Utils.InheritedDocumentation
Assemblies: GenerateInheritedDocs (in GenerateInheritedDocs.exe) Version: 1.8.0.2
SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public InheritedDocsException(
    string message,
    Exception innerException
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    innerException As Exception _
)

Parameters

message
Type: System..::.String
The error message that explains the reason for the exception.
innerException
Type: System..::.Exception
The exception that is the cause of the current exception, or a null reference (Nothing in Visual Basic) if no inner exception is specified.

See Also

InheritedDocsException Class
InheritedDocsException Overload
SandcastleBuilder.Utils.InheritedDocumentation Namespace


InheritedDocsException Methods

[image] [image]

Sandcastle Help File Builder Documentation
InheritedDocsException Methods
InheritedDocsException Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The InheritedDocsException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

InheritedDocsException Class
SandcastleBuilder.Utils.InheritedDocumentation Namespace


InheritedDocsException Properties

[image] [image]

Sandcastle Help File Builder Documentation
InheritedDocsException Properties
InheritedDocsException Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The InheritedDocsException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InheritedDocsException Class
SandcastleBuilder.Utils.InheritedDocumentation Namespace


SandcastleBuilder.Utils.MSBuild Namespace

[image]

Sandcastle Help File Builder Documentation
SandcastleBuilder.Utils.MSBuild Namespace
Send Feedback

[This is preliminary documentation and is subject to change.]

This namespace contains MSBuild related classes such as tasks and project file wrappers.

Classes

Class | Description
Build1xHelpFile | This task is used to run HHC.EXE which is used to compile a Help 1 (CHM) help file.
Build2xHelpFile | This task is used to run HXCOMP.EXE which is used to compile a Help 2 (HxS) help file.
BuildAssembler | This task is used to run BuildAssembler.exe which is used to generate help topics.
BuildHelp | This task is used to build help file output using the Sandcastle Help File Builder.
CleanHelp | This task is used to clean (remove) help file output from the last build.
MRefBuilder | This task is used to generate the MRefBuilder response file and run MRefBuilder.exe.
MSBuildProject | This is a simple wrapper around an MSBuild project that is used to extract information from it during a help file build.
XslTransform | This task is used to run XslTransform.exe which is used to run various XSL transformations on the Sandcastle data files.


Build1xHelpFile Class

[image]

Sandcastle Help File Builder Documentation
Build1xHelpFile Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This task is used to run HHC.EXE which is used to compile a Help 1 (CHM) help file.

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public class Build1xHelpFile : ToolTask
Visual Basic (Declaration)
Public Class Build1xHelpFile _
    Inherits ToolTask

Remarks

Support is provided for wrapping the tool in a call to an application such as SBAppLocale.exe to workaround encoding issues with the Help 1 compiler.

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
Microsoft.Build.Utilities..::.ToolTask
SandcastleBuilder.Utils.MSBuild..::.Build1xHelpFile

See Also

Build1xHelpFile Members
SandcastleBuilder.Utils.MSBuild Namespace


Build1xHelpFile Members

[image] [image]

Sandcastle Help File Builder Documentation
Build1xHelpFile Members
Build1xHelpFile Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Build1xHelpFile type exposes the following members.

Constructors

Name | Description
Build1xHelpFile | Initializes a new instance of the Build1xHelpFile class

Methods

Name | Description
CallHostObjectToExecute | Calls the host object to perform the work of the task. (Inherited from ToolTask.)
DeleteTempFile | Deletes the specified temporary file. (Inherited from ToolTask.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | This is overridden to set the working folder before executing the task and to invert the result returned from the help compiler. (Overrides ToolTask..::.Execute()()().)
ExecuteTool | Creates a temporoary response (.rsp) file and runs the executable file. (Inherited from ToolTask.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GenerateCommandLineCommands | Generate the command line parameters (Overrides ToolTask..::.GenerateCommandLineCommands()()().)
GenerateFullPathToTool | This returns the full path to the tool (Overrides ToolTask..::.GenerateFullPathToTool()()().)
GenerateResponseFileCommands | Returns a string value containing the command line arguments to add to the response (.rsp) file before running the executable file. (Inherited from ToolTask.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetResponseFileSwitch | Returns the command line switch used by the executable file to specifiy a response (.rsp) file. (Inherited from ToolTask.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetWorkingDirectory | Returns the directory in which to run the executable file. (Inherited from ToolTask.)
HandleTaskExecutionErrors | This is overridden to invert the result of the HHC exit code (Overrides ToolTask..::.HandleTaskExecutionErrors()()().)
InitializeHostObject | Initializes the host object of the task. (Inherited from ToolTask.)
LogEventsFromTextOutput | Parses a single line of text to identify any errors or warnings in canonical format. (Inherited from ToolTask.)
LogPathToTool | Logs the tool name and path to all registered loggers. (Inherited from ToolTask.)
LogToolCommand | Logs the starting point of the run to all registered loggers. (Inherited from ToolTask.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SkipTaskExecution | Indicates whether task execution should be skipped. (Inherited from ToolTask.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ValidateParameters | Validate the parameters (Overrides ToolTask..::.ValidateParameters()()().)

Properties

Name | Description
BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (Inherited from Task.)
BuildEngine2 | (Inherited from Task.)
EnvironmentOverride | Gets the override value of the PATH environment variable. (Inherited from ToolTask.)
ExitCode | Gets the returned exit code of the executable file. (Inherited from ToolTask.)
HasLoggedErrors | (Inherited from ToolTask.)
HelpCompilerFolder | This is used to pass in the path to the help compiler
HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (Inherited from Task.)
HelpProjectName | This is used to pass in the help project filename
HostObject | Gets or sets the host object associated with the task. (Inherited from Task.)
LanguageId | This is used to get or set the language ID for the localization tool (see cref="LocalizeApp" />).
LocalizeApp | This is used to pass in the name of the application to use as the localization wrapper.
Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (Inherited from Task.)
ResponseFileEncoding | Gets the Encoding of the response file. (Inherited from ToolTask.)
StandardErrorEncoding | Gets the Encoding of the standard error stream of the task. (Inherited from ToolTask.)
StandardErrorImportance | (Inherited from ToolTask.)
StandardErrorLoggingImportance | This is overridden to force all standard error info to be logged (Overrides ToolTask..::.StandardErrorLoggingImportance.)
StandardOutputEncoding | Gets the Encoding of the standard output stream of the task. (Inherited from ToolTask.)
StandardOutputImportance | (Inherited from ToolTask.)
StandardOutputLoggingImportance | This is overridden to force all standard output info to be logged (Overrides ToolTask..::.StandardOutputLoggingImportance.)
TaskResources | Gets or sets the culture-specific resources associated with the task. (Inherited from Task.)
Timeout | Gets or sets the amount of time after which the task executable is terminated. (Inherited from ToolTask.)
ToolExe | (Inherited from ToolTask.)
ToolName | This read-only property returns the tool name (HHC.EXE or the value of LocalizeApp if specified). (Overrides ToolTask..::.ToolName.)
ToolPath | Gets or sets the path of the executable file to run. (Inherited from ToolTask.)
WorkingFolder | This is used to pass in the working folder where the files are located.

See Also

Build1xHelpFile Class
SandcastleBuilder.Utils.MSBuild Namespace


Build1xHelpFile Constructor

[image]

Sandcastle Help File Builder Documentation
Build1xHelpFile Constructor
Build1xHelpFile Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Build1xHelpFile class

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public Build1xHelpFile()
Visual Basic (Declaration)
Public Sub New

See Also

Build1xHelpFile Class
SandcastleBuilder.Utils.MSBuild Namespace


Build1xHelpFile Methods

[image] [image]

Sandcastle Help File Builder Documentation
Build1xHelpFile Methods
Build1xHelpFile Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Build1xHelpFile type exposes the following members.

Methods

Name | Description
CallHostObjectToExecute | Calls the host object to perform the work of the task. (Inherited from ToolTask.)
DeleteTempFile | Deletes the specified temporary file. (Inherited from ToolTask.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | This is overridden to set the working folder before executing the task and to invert the result returned from the help compiler. (Overrides ToolTask..::.Execute()()().)
ExecuteTool | Creates a temporoary response (.rsp) file and runs the executable file. (Inherited from ToolTask.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GenerateCommandLineCommands | Generate the command line parameters (Overrides ToolTask..::.GenerateCommandLineCommands()()().)
GenerateFullPathToTool | This returns the full path to the tool (Overrides ToolTask..::.GenerateFullPathToTool()()().)
GenerateResponseFileCommands | Returns a string value containing the command line arguments to add to the response (.rsp) file before running the executable file. (Inherited from ToolTask.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetResponseFileSwitch | Returns the command line switch used by the executable file to specifiy a response (.rsp) file. (Inherited from ToolTask.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetWorkingDirectory | Returns the directory in which to run the executable file. (Inherited from ToolTask.)
HandleTaskExecutionErrors | This is overridden to invert the result of the HHC exit code (Overrides ToolTask..::.HandleTaskExecutionErrors()()().)
InitializeHostObject | Initializes the host object of the task. (Inherited from ToolTask.)
LogEventsFromTextOutput | Parses a single line of text to identify any errors or warnings in canonical format. (Inherited from ToolTask.)
LogPathToTool | Logs the tool name and path to all registered loggers. (Inherited from ToolTask.)
LogToolCommand | Logs the starting point of the run to all registered loggers. (Inherited from ToolTask.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SkipTaskExecution | Indicates whether task execution should be skipped. (Inherited from ToolTask.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ValidateParameters | Validate the parameters (Overrides ToolTask..::.ValidateParameters()()().)

See Also

Build1xHelpFile Class
SandcastleBuilder.Utils.MSBuild Namespace


Execute Method

[image]

Sandcastle Help File Builder Documentation
Build1xHelpFile..::.Execute Method
Build1xHelpFile Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is overridden to set the working folder before executing the task and to invert the result returned from the help compiler.

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public override bool Execute()
Visual Basic (Declaration)
Public Overrides Function Execute As Boolean

Return Value

True if successful or false on failure

Implements

ITask..::.Execute()()()

See Also

Build1xHelpFile Class
SandcastleBuilder.Utils.MSBuild Namespace


GenerateCommandLineCommands Method

[image]

Sandcastle Help File Builder Documentation
Build1xHelpFile..::.GenerateCommandLineCommands Method
Build1xHelpFile Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Generate the command line parameters

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected override string GenerateCommandLineCommands()
Visual Basic (Declaration)
Protected Overrides Function GenerateCommandLineCommands As String

Return Value

The command line parameters

See Also

Build1xHelpFile Class
SandcastleBuilder.Utils.MSBuild Namespace


GenerateFullPathToTool Method

[image]

Sandcastle Help File Builder Documentation
Build1xHelpFile..::.GenerateFullPathToTool Method
Build1xHelpFile Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This returns the full path to the tool

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected override string GenerateFullPathToTool()
Visual Basic (Declaration)
Protected Overrides Function GenerateFullPathToTool As String

Return Value

The full path to the tool

See Also

Build1xHelpFile Class
SandcastleBuilder.Utils.MSBuild Namespace


HandleTaskExecutionErrors Method

[image]

Sandcastle Help File Builder Documentation
Build1xHelpFile..::.HandleTaskExecutionErrors Method
Build1xHelpFile Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is overridden to invert the result of the HHC exit code

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected override bool HandleTaskExecutionErrors()
Visual Basic (Declaration)
Protected Overrides Function HandleTaskExecutionErrors As Boolean

Return Value

True on success, false on failure. HXCOMP is backwards and returns 0 on failures and 1 on success. We invert the result to be consistent with other tasks.

See Also

Build1xHelpFile Class
SandcastleBuilder.Utils.MSBuild Namespace


ValidateParameters Method

[image]

Sandcastle Help File Builder Documentation
Build1xHelpFile..::.ValidateParameters Method
Build1xHelpFile Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Validate the parameters

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected override bool ValidateParameters()
Visual Basic (Declaration)
Protected Overrides Function ValidateParameters As Boolean

Return Value

True if the parameters are valid, false if not

See Also

Build1xHelpFile Class
SandcastleBuilder.Utils.MSBuild Namespace


Build1xHelpFile Properties

[image] [image]

Sandcastle Help File Builder Documentation
Build1xHelpFile Properties
Build1xHelpFile Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Build1xHelpFile type exposes the following members.

Properties

Name | Description
BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (Inherited from Task.)
BuildEngine2 | (Inherited from Task.)
EnvironmentOverride | Gets the override value of the PATH environment variable. (Inherited from ToolTask.)
ExitCode | Gets the returned exit code of the executable file. (Inherited from ToolTask.)
HasLoggedErrors | (Inherited from ToolTask.)
HelpCompilerFolder | This is used to pass in the path to the help compiler
HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (Inherited from Task.)
HelpProjectName | This is used to pass in the help project filename
HostObject | Gets or sets the host object associated with the task. (Inherited from Task.)
LanguageId | This is used to get or set the language ID for the localization tool (see cref="LocalizeApp" />).
LocalizeApp | This is used to pass in the name of the application to use as the localization wrapper.
Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (Inherited from Task.)
ResponseFileEncoding | Gets the Encoding of the response file. (Inherited from ToolTask.)
StandardErrorEncoding | Gets the Encoding of the standard error stream of the task. (Inherited from ToolTask.)
StandardErrorImportance | (Inherited from ToolTask.)
StandardErrorLoggingImportance | This is overridden to force all standard error info to be logged (Overrides ToolTask..::.StandardErrorLoggingImportance.)
StandardOutputEncoding | Gets the Encoding of the standard output stream of the task. (Inherited from ToolTask.)
StandardOutputImportance | (Inherited from ToolTask.)
StandardOutputLoggingImportance | This is overridden to force all standard output info to be logged (Overrides ToolTask..::.StandardOutputLoggingImportance.)
TaskResources | Gets or sets the culture-specific resources associated with the task. (Inherited from Task.)
Timeout | Gets or sets the amount of time after which the task executable is terminated. (Inherited from ToolTask.)
ToolExe | (Inherited from ToolTask.)
ToolName | This read-only property returns the tool name (HHC.EXE or the value of LocalizeApp if specified). (Overrides ToolTask..::.ToolName.)
ToolPath | Gets or sets the path of the executable file to run. (Inherited from ToolTask.)
WorkingFolder | This is used to pass in the working folder where the files are located.

See Also

Build1xHelpFile Class
SandcastleBuilder.Utils.MSBuild Namespace


HelpCompilerFolder Property

[image]

Sandcastle Help File Builder Documentation
Build1xHelpFile..::.HelpCompilerFolder Property
Build1xHelpFile Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to pass in the path to the help compiler

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string HelpCompilerFolder { get; set; }
Visual Basic (Declaration)
Public Property HelpCompilerFolder As String

See Also

Build1xHelpFile Class
SandcastleBuilder.Utils.MSBuild Namespace


HelpProjectName Property

[image]

Sandcastle Help File Builder Documentation
Build1xHelpFile..::.HelpProjectName Property
Build1xHelpFile Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to pass in the help project filename

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string HelpProjectName { get; set; }
Visual Basic (Declaration)
Public Property HelpProjectName As String

See Also

Build1xHelpFile Class
SandcastleBuilder.Utils.MSBuild Namespace


LanguageId Property

[image]

Sandcastle Help File Builder Documentation
Build1xHelpFile..::.LanguageId Property
Build1xHelpFile Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set the language ID for the localization tool (see cref="LocalizeApp" />).

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public int LanguageId { get; set; }
Visual Basic (Declaration)
Public Property LanguageId As Integer

Remarks

This is optional. If not specified, it defaults to 1033. It is ignored if LocalizeApp is not set.

See Also

Build1xHelpFile Class
SandcastleBuilder.Utils.MSBuild Namespace


LocalizeApp Property

[image]

Sandcastle Help File Builder Documentation
Build1xHelpFile..::.LocalizeApp Property
Build1xHelpFile Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to pass in the name of the application to use as the localization wrapper.

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string LocalizeApp { get; set; }
Visual Basic (Declaration)
Public Property LocalizeApp As String

Remarks

This is optional. If specified, it will be used to run the help compiler to work around encoding issues.

See Also

Build1xHelpFile Class
SandcastleBuilder.Utils.MSBuild Namespace


StandardErrorLoggingImportance Property

[image]

Sandcastle Help File Builder Documentation
Build1xHelpFile..::.StandardErrorLoggingImportance Property
Build1xHelpFile Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is overridden to force all standard error info to be logged

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected override MessageImportance StandardErrorLoggingImportance { get; }
Visual Basic (Declaration)
Protected Overrides ReadOnly Property StandardErrorLoggingImportance As MessageImportance

See Also

Build1xHelpFile Class
SandcastleBuilder.Utils.MSBuild Namespace


StandardOutputLoggingImportance Property

[image]

Sandcastle Help File Builder Documentation
Build1xHelpFile..::.StandardOutputLoggingImportance Property
Build1xHelpFile Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is overridden to force all standard output info to be logged

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected override MessageImportance StandardOutputLoggingImportance { get; }
Visual Basic (Declaration)
Protected Overrides ReadOnly Property StandardOutputLoggingImportance As MessageImportance

See Also

Build1xHelpFile Class
SandcastleBuilder.Utils.MSBuild Namespace


ToolName Property

[image]

Sandcastle Help File Builder Documentation
Build1xHelpFile..::.ToolName Property
Build1xHelpFile Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns the tool name (HHC.EXE or the value of LocalizeApp if specified).

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected override string ToolName { get; }
Visual Basic (Declaration)
Protected Overrides ReadOnly Property ToolName As String

See Also

Build1xHelpFile Class
SandcastleBuilder.Utils.MSBuild Namespace


WorkingFolder Property

[image]

Sandcastle Help File Builder Documentation
Build1xHelpFile..::.WorkingFolder Property
Build1xHelpFile Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to pass in the working folder where the files are located.

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string WorkingFolder { get; set; }
Visual Basic (Declaration)
Public Property WorkingFolder As String

See Also

Build1xHelpFile Class
SandcastleBuilder.Utils.MSBuild Namespace


Build2xHelpFile Class

[image]

Sandcastle Help File Builder Documentation
Build2xHelpFile Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This task is used to run HXCOMP.EXE which is used to compile a Help 2 (HxS) help file.

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public class Build2xHelpFile : ToolTask
Visual Basic (Declaration)
Public Class Build2xHelpFile _
    Inherits ToolTask

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
Microsoft.Build.Utilities..::.ToolTask
SandcastleBuilder.Utils.MSBuild..::.Build2xHelpFile

See Also

Build2xHelpFile Members
SandcastleBuilder.Utils.MSBuild Namespace


Build2xHelpFile Members

[image] [image]

Sandcastle Help File Builder Documentation
Build2xHelpFile Members
Build2xHelpFile Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Build2xHelpFile type exposes the following members.

Constructors

Name | Description
Build2xHelpFile | Initializes a new instance of the Build2xHelpFile class

Methods

Name | Description
CallHostObjectToExecute | Calls the host object to perform the work of the task. (Inherited from ToolTask.)
DeleteTempFile | Deletes the specified temporary file. (Inherited from ToolTask.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | This is overridden to set the working folder before executing the task and to dump the compiler log file after the build. (Overrides ToolTask..::.Execute()()().)
ExecuteTool | Creates a temporoary response (.rsp) file and runs the executable file. (Inherited from ToolTask.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GenerateCommandLineCommands | Generate the command line parameters (Overrides ToolTask..::.GenerateCommandLineCommands()()().)
GenerateFullPathToTool | This returns the full path to the tool (Overrides ToolTask..::.GenerateFullPathToTool()()().)
GenerateResponseFileCommands | Returns a string value containing the command line arguments to add to the response (.rsp) file before running the executable file. (Inherited from ToolTask.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetResponseFileSwitch | Returns the command line switch used by the executable file to specifiy a response (.rsp) file. (Inherited from ToolTask.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetWorkingDirectory | Returns the directory in which to run the executable file. (Inherited from ToolTask.)
HandleTaskExecutionErrors | This is overridden to invert the result of the HXCOMP exit code (Overrides ToolTask..::.HandleTaskExecutionErrors()()().)
InitializeHostObject | Initializes the host object of the task. (Inherited from ToolTask.)
LogEventsFromTextOutput | Parses a single line of text to identify any errors or warnings in canonical format. (Inherited from ToolTask.)
LogPathToTool | Logs the tool name and path to all registered loggers. (Inherited from ToolTask.)
LogToolCommand | Logs the starting point of the run to all registered loggers. (Inherited from ToolTask.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SkipTaskExecution | Indicates whether task execution should be skipped. (Inherited from ToolTask.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ValidateParameters | Validate the parameters (Overrides ToolTask..::.ValidateParameters()()().)

Properties

Name | Description
BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (Inherited from Task.)
BuildEngine2 | (Inherited from Task.)
EnvironmentOverride | Gets the override value of the PATH environment variable. (Inherited from ToolTask.)
ExitCode | Gets the returned exit code of the executable file. (Inherited from ToolTask.)
HasLoggedErrors | (Inherited from ToolTask.)
HelpCompilerFolder | This is used to pass in the path to the help compiler
HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (Inherited from Task.)
HostObject | Gets or sets the host object associated with the task. (Inherited from Task.)
HtmlHelpName | This is used to pass in the name of the help file (no path or extension).
Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (Inherited from Task.)
ResponseFileEncoding | Gets the Encoding of the response file. (Inherited from ToolTask.)
StandardErrorEncoding | Gets the Encoding of the standard error stream of the task. (Inherited from ToolTask.)
StandardErrorImportance | (Inherited from ToolTask.)
StandardErrorLoggingImportance | This is overridden to force all standard error info to be logged (Overrides ToolTask..::.StandardErrorLoggingImportance.)
StandardOutputEncoding | Gets the Encoding of the standard output stream of the task. (Inherited from ToolTask.)
StandardOutputImportance | (Inherited from ToolTask.)
StandardOutputLoggingImportance | This is overridden to force all standard output info to be logged (Overrides ToolTask..::.StandardOutputLoggingImportance.)
TaskResources | Gets or sets the culture-specific resources associated with the task. (Inherited from Task.)
Timeout | Gets or sets the amount of time after which the task executable is terminated. (Inherited from ToolTask.)
ToolExe | (Inherited from ToolTask.)
ToolName | This read-only property returns the tool name (HXCOMP.EXE) (Overrides ToolTask..::.ToolName.)
ToolPath | Gets or sets the path of the executable file to run. (Inherited from ToolTask.)
WorkingFolder | This is used to pass in the working folder where the files are located.

See Also

Build2xHelpFile Class
SandcastleBuilder.Utils.MSBuild Namespace


Build2xHelpFile Constructor

[image]

Sandcastle Help File Builder Documentation
Build2xHelpFile Constructor
Build2xHelpFile Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Build2xHelpFile class

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public Build2xHelpFile()
Visual Basic (Declaration)
Public Sub New

See Also

Build2xHelpFile Class
SandcastleBuilder.Utils.MSBuild Namespace


Build2xHelpFile Methods

[image] [image]

Sandcastle Help File Builder Documentation
Build2xHelpFile Methods
Build2xHelpFile Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Build2xHelpFile type exposes the following members.

Methods

Name | Description
CallHostObjectToExecute | Calls the host object to perform the work of the task. (Inherited from ToolTask.)
DeleteTempFile | Deletes the specified temporary file. (Inherited from ToolTask.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | This is overridden to set the working folder before executing the task and to dump the compiler log file after the build. (Overrides ToolTask..::.Execute()()().)
ExecuteTool | Creates a temporoary response (.rsp) file and runs the executable file. (Inherited from ToolTask.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GenerateCommandLineCommands | Generate the command line parameters (Overrides ToolTask..::.GenerateCommandLineCommands()()().)
GenerateFullPathToTool | This returns the full path to the tool (Overrides ToolTask..::.GenerateFullPathToTool()()().)
GenerateResponseFileCommands | Returns a string value containing the command line arguments to add to the response (.rsp) file before running the executable file. (Inherited from ToolTask.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetResponseFileSwitch | Returns the command line switch used by the executable file to specifiy a response (.rsp) file. (Inherited from ToolTask.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetWorkingDirectory | Returns the directory in which to run the executable file. (Inherited from ToolTask.)
HandleTaskExecutionErrors | This is overridden to invert the result of the HXCOMP exit code (Overrides ToolTask..::.HandleTaskExecutionErrors()()().)
InitializeHostObject | Initializes the host object of the task. (Inherited from ToolTask.)
LogEventsFromTextOutput | Parses a single line of text to identify any errors or warnings in canonical format. (Inherited from ToolTask.)
LogPathToTool | Logs the tool name and path to all registered loggers. (Inherited from ToolTask.)
LogToolCommand | Logs the starting point of the run to all registered loggers. (Inherited from ToolTask.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SkipTaskExecution | Indicates whether task execution should be skipped. (Inherited from ToolTask.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ValidateParameters | Validate the parameters (Overrides ToolTask..::.ValidateParameters()()().)

See Also

Build2xHelpFile Class
SandcastleBuilder.Utils.MSBuild Namespace


Execute Method

[image]

Sandcastle Help File Builder Documentation
Build2xHelpFile..::.Execute Method
Build2xHelpFile Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is overridden to set the working folder before executing the task and to dump the compiler log file after the build.

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public override bool Execute()
Visual Basic (Declaration)
Public Overrides Function Execute As Boolean

Return Value

True if successful or false on failure

Implements

ITask..::.Execute()()()

See Also

Build2xHelpFile Class
SandcastleBuilder.Utils.MSBuild Namespace


GenerateCommandLineCommands Method

[image]

Sandcastle Help File Builder Documentation
Build2xHelpFile..::.GenerateCommandLineCommands Method
Build2xHelpFile Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Generate the command line parameters

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected override string GenerateCommandLineCommands()
Visual Basic (Declaration)
Protected Overrides Function GenerateCommandLineCommands As String

Return Value

The command line parameters

See Also

Build2xHelpFile Class
SandcastleBuilder.Utils.MSBuild Namespace


GenerateFullPathToTool Method

[image]

Sandcastle Help File Builder Documentation
Build2xHelpFile..::.GenerateFullPathToTool Method
Build2xHelpFile Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This returns the full path to the tool

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected override string GenerateFullPathToTool()
Visual Basic (Declaration)
Protected Overrides Function GenerateFullPathToTool As String

Return Value

The full path to the tool

See Also

Build2xHelpFile Class
SandcastleBuilder.Utils.MSBuild Namespace


HandleTaskExecutionErrors Method

[image]

Sandcastle Help File Builder Documentation
Build2xHelpFile..::.HandleTaskExecutionErrors Method
Build2xHelpFile Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is overridden to invert the result of the HXCOMP exit code

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected override bool HandleTaskExecutionErrors()
Visual Basic (Declaration)
Protected Overrides Function HandleTaskExecutionErrors As Boolean

Return Value

True on success, false on failure. HXCOMP returns 0 on success, 1 if warnings were issued (which is okay), and another non-zero value for failures. We ignore the warning return code and treat it as successful.

See Also

Build2xHelpFile Class
SandcastleBuilder.Utils.MSBuild Namespace


ValidateParameters Method

[image]

Sandcastle Help File Builder Documentation
Build2xHelpFile..::.ValidateParameters Method
Build2xHelpFile Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Validate the parameters

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected override bool ValidateParameters()
Visual Basic (Declaration)
Protected Overrides Function ValidateParameters As Boolean

Return Value

True if the parameters are valid, false if not

See Also

Build2xHelpFile Class
SandcastleBuilder.Utils.MSBuild Namespace


Build2xHelpFile Properties

[image] [image]

Sandcastle Help File Builder Documentation
Build2xHelpFile Properties
Build2xHelpFile Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Build2xHelpFile type exposes the following members.

Properties

Name | Description
BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (Inherited from Task.)
BuildEngine2 | (Inherited from Task.)
EnvironmentOverride | Gets the override value of the PATH environment variable. (Inherited from ToolTask.)
ExitCode | Gets the returned exit code of the executable file. (Inherited from ToolTask.)
HasLoggedErrors | (Inherited from ToolTask.)
HelpCompilerFolder | This is used to pass in the path to the help compiler
HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (Inherited from Task.)
HostObject | Gets or sets the host object associated with the task. (Inherited from Task.)
HtmlHelpName | This is used to pass in the name of the help file (no path or extension).
Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (Inherited from Task.)
ResponseFileEncoding | Gets the Encoding of the response file. (Inherited from ToolTask.)
StandardErrorEncoding | Gets the Encoding of the standard error stream of the task. (Inherited from ToolTask.)
StandardErrorImportance | (Inherited from ToolTask.)
StandardErrorLoggingImportance | This is overridden to force all standard error info to be logged (Overrides ToolTask..::.StandardErrorLoggingImportance.)
StandardOutputEncoding | Gets the Encoding of the standard output stream of the task. (Inherited from ToolTask.)
StandardOutputImportance | (Inherited from ToolTask.)
StandardOutputLoggingImportance | This is overridden to force all standard output info to be logged (Overrides ToolTask..::.StandardOutputLoggingImportance.)
TaskResources | Gets or sets the culture-specific resources associated with the task. (Inherited from Task.)
Timeout | Gets or sets the amount of time after which the task executable is terminated. (Inherited from ToolTask.)
ToolExe | (Inherited from ToolTask.)
ToolName | This read-only property returns the tool name (HXCOMP.EXE) (Overrides ToolTask..::.ToolName.)
ToolPath | Gets or sets the path of the executable file to run. (Inherited from ToolTask.)
WorkingFolder | This is used to pass in the working folder where the files are located.

See Also

Build2xHelpFile Class
SandcastleBuilder.Utils.MSBuild Namespace


HelpCompilerFolder Property

[image]

Sandcastle Help File Builder Documentation
Build2xHelpFile..::.HelpCompilerFolder Property
Build2xHelpFile Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to pass in the path to the help compiler

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string HelpCompilerFolder { get; set; }
Visual Basic (Declaration)
Public Property HelpCompilerFolder As String

See Also

Build2xHelpFile Class
SandcastleBuilder.Utils.MSBuild Namespace


HtmlHelpName Property

[image]

Sandcastle Help File Builder Documentation
Build2xHelpFile..::.HtmlHelpName Property
Build2xHelpFile Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to pass in the name of the help file (no path or extension).

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string HtmlHelpName { get; set; }
Visual Basic (Declaration)
Public Property HtmlHelpName As String

See Also

Build2xHelpFile Class
SandcastleBuilder.Utils.MSBuild Namespace


StandardErrorLoggingImportance Property

[image]

Sandcastle Help File Builder Documentation
Build2xHelpFile..::.StandardErrorLoggingImportance Property
Build2xHelpFile Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is overridden to force all standard error info to be logged

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected override MessageImportance StandardErrorLoggingImportance { get; }
Visual Basic (Declaration)
Protected Overrides ReadOnly Property StandardErrorLoggingImportance As MessageImportance

See Also

Build2xHelpFile Class
SandcastleBuilder.Utils.MSBuild Namespace


StandardOutputLoggingImportance Property

[image]

Sandcastle Help File Builder Documentation
Build2xHelpFile..::.StandardOutputLoggingImportance Property
Build2xHelpFile Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is overridden to force all standard output info to be logged

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected override MessageImportance StandardOutputLoggingImportance { get; }
Visual Basic (Declaration)
Protected Overrides ReadOnly Property StandardOutputLoggingImportance As MessageImportance

See Also

Build2xHelpFile Class
SandcastleBuilder.Utils.MSBuild Namespace


ToolName Property

[image]

Sandcastle Help File Builder Documentation
Build2xHelpFile..::.ToolName Property
Build2xHelpFile Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns the tool name (HXCOMP.EXE)

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected override string ToolName { get; }
Visual Basic (Declaration)
Protected Overrides ReadOnly Property ToolName As String

See Also

Build2xHelpFile Class
SandcastleBuilder.Utils.MSBuild Namespace


WorkingFolder Property

[image]

Sandcastle Help File Builder Documentation
Build2xHelpFile..::.WorkingFolder Property
Build2xHelpFile Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to pass in the working folder where the files are located.

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string WorkingFolder { get; set; }
Visual Basic (Declaration)
Public Property WorkingFolder As String

See Also

Build2xHelpFile Class
SandcastleBuilder.Utils.MSBuild Namespace


BuildAssembler Class

[image]

Sandcastle Help File Builder Documentation
BuildAssembler Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This task is used to run BuildAssembler.exe which is used to generate help topics.

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public class BuildAssembler : ToolTask
Visual Basic (Declaration)
Public Class BuildAssembler _
    Inherits ToolTask

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
Microsoft.Build.Utilities..::.ToolTask
SandcastleBuilder.Utils.MSBuild..::.BuildAssembler

See Also

BuildAssembler Members
SandcastleBuilder.Utils.MSBuild Namespace


BuildAssembler Members

[image] [image]

Sandcastle Help File Builder Documentation
BuildAssembler Members
BuildAssembler Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BuildAssembler type exposes the following members.

Constructors

Name | Description
BuildAssembler | Initializes a new instance of the BuildAssembler class

Methods

Name | Description
CallHostObjectToExecute | Calls the host object to perform the work of the task. (Inherited from ToolTask.)
DeleteTempFile | Deletes the specified temporary file. (Inherited from ToolTask.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | Runs the exectuable file with the specified task parameters. (Inherited from ToolTask.)
ExecuteTool | Creates a temporoary response (.rsp) file and runs the executable file. (Inherited from ToolTask.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GenerateCommandLineCommands | Generate the command line parameters (Overrides ToolTask..::.GenerateCommandLineCommands()()().)
GenerateFullPathToTool | This returns the full path to the tool (Overrides ToolTask..::.GenerateFullPathToTool()()().)
GenerateResponseFileCommands | Returns a string value containing the command line arguments to add to the response (.rsp) file before running the executable file. (Inherited from ToolTask.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetResponseFileSwitch | Returns the command line switch used by the executable file to specifiy a response (.rsp) file. (Inherited from ToolTask.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetWorkingDirectory | This is overridden to return the working folder for the build (Overrides ToolTask..::.GetWorkingDirectory()()().)
HandleTaskExecutionErrors | Handles execution errors raised by the executable file. (Inherited from ToolTask.)
InitializeHostObject | Initializes the host object of the task. (Inherited from ToolTask.)
LogEventsFromTextOutput | Parses a single line of text to identify any errors or warnings in canonical format. (Inherited from ToolTask.)
LogPathToTool | Logs the tool name and path to all registered loggers. (Inherited from ToolTask.)
LogToolCommand | Logs the starting point of the run to all registered loggers. (Inherited from ToolTask.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SkipTaskExecution | Indicates whether task execution should be skipped. (Inherited from ToolTask.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ValidateParameters | Validate the parameters (Overrides ToolTask..::.ValidateParameters()()().)

Properties

Name | Description
BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (Inherited from Task.)
BuildEngine2 | (Inherited from Task.)
ConfigurationFile | This is used to pass in the configuration filename
EnvironmentOverride | Gets the override value of the PATH environment variable. (Inherited from ToolTask.)
ExitCode | Gets the returned exit code of the executable file. (Inherited from ToolTask.)
HasLoggedErrors | (Inherited from ToolTask.)
HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (Inherited from Task.)
HostObject | Gets or sets the host object associated with the task. (Inherited from Task.)
Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (Inherited from Task.)
ManifestFile | This is used to pass in the manifest filename
ResponseFileEncoding | Gets the Encoding of the response file. (Inherited from ToolTask.)
SandcastlePath | This is used to pass in the path to the Sandcastle tools
StandardErrorEncoding | Gets the Encoding of the standard error stream of the task. (Inherited from ToolTask.)
StandardErrorImportance | (Inherited from ToolTask.)
StandardErrorLoggingImportance | This is overridden to force all standard error info to be logged (Overrides ToolTask..::.StandardErrorLoggingImportance.)
StandardOutputEncoding | Gets the Encoding of the standard output stream of the task. (Inherited from ToolTask.)
StandardOutputImportance | (Inherited from ToolTask.)
StandardOutputLoggingImportance | This is overridden to force all standard output info to be logged (Overrides ToolTask..::.StandardOutputLoggingImportance.)
TaskResources | Gets or sets the culture-specific resources associated with the task. (Inherited from Task.)
Timeout | Gets or sets the amount of time after which the task executable is terminated. (Inherited from ToolTask.)
ToolExe | (Inherited from ToolTask.)
ToolName | This read-only property returns the tool name (BuildAssembler.exe) (Overrides ToolTask..::.ToolName.)
ToolPath | Gets or sets the path of the executable file to run. (Inherited from ToolTask.)
WorkingFolder | This is used to pass in the working folder where the files are located.

See Also

BuildAssembler Class
SandcastleBuilder.Utils.MSBuild Namespace


BuildAssembler Constructor

[image]

Sandcastle Help File Builder Documentation
BuildAssembler Constructor
BuildAssembler Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the BuildAssembler class

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public BuildAssembler()
Visual Basic (Declaration)
Public Sub New

See Also

BuildAssembler Class
SandcastleBuilder.Utils.MSBuild Namespace


BuildAssembler Methods

[image] [image]

Sandcastle Help File Builder Documentation
BuildAssembler Methods
BuildAssembler Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BuildAssembler type exposes the following members.

Methods

Name | Description
CallHostObjectToExecute | Calls the host object to perform the work of the task. (Inherited from ToolTask.)
DeleteTempFile | Deletes the specified temporary file. (Inherited from ToolTask.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | Runs the exectuable file with the specified task parameters. (Inherited from ToolTask.)
ExecuteTool | Creates a temporoary response (.rsp) file and runs the executable file. (Inherited from ToolTask.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GenerateCommandLineCommands | Generate the command line parameters (Overrides ToolTask..::.GenerateCommandLineCommands()()().)
GenerateFullPathToTool | This returns the full path to the tool (Overrides ToolTask..::.GenerateFullPathToTool()()().)
GenerateResponseFileCommands | Returns a string value containing the command line arguments to add to the response (.rsp) file before running the executable file. (Inherited from ToolTask.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetResponseFileSwitch | Returns the command line switch used by the executable file to specifiy a response (.rsp) file. (Inherited from ToolTask.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetWorkingDirectory | This is overridden to return the working folder for the build (Overrides ToolTask..::.GetWorkingDirectory()()().)
HandleTaskExecutionErrors | Handles execution errors raised by the executable file. (Inherited from ToolTask.)
InitializeHostObject | Initializes the host object of the task. (Inherited from ToolTask.)
LogEventsFromTextOutput | Parses a single line of text to identify any errors or warnings in canonical format. (Inherited from ToolTask.)
LogPathToTool | Logs the tool name and path to all registered loggers. (Inherited from ToolTask.)
LogToolCommand | Logs the starting point of the run to all registered loggers. (Inherited from ToolTask.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SkipTaskExecution | Indicates whether task execution should be skipped. (Inherited from ToolTask.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ValidateParameters | Validate the parameters (Overrides ToolTask..::.ValidateParameters()()().)

See Also

BuildAssembler Class
SandcastleBuilder.Utils.MSBuild Namespace


GenerateCommandLineCommands Method

[image]

Sandcastle Help File Builder Documentation
BuildAssembler..::.GenerateCommandLineCommands Method
BuildAssembler Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Generate the command line parameters

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected override string GenerateCommandLineCommands()
Visual Basic (Declaration)
Protected Overrides Function GenerateCommandLineCommands As String

Return Value

The command line parameters

See Also

BuildAssembler Class
SandcastleBuilder.Utils.MSBuild Namespace


GenerateFullPathToTool Method

[image]

Sandcastle Help File Builder Documentation
BuildAssembler..::.GenerateFullPathToTool Method
BuildAssembler Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This returns the full path to the tool

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected override string GenerateFullPathToTool()
Visual Basic (Declaration)
Protected Overrides Function GenerateFullPathToTool As String

Return Value

The full path to the tool

See Also

BuildAssembler Class
SandcastleBuilder.Utils.MSBuild Namespace


GetWorkingDirectory Method

[image]

Sandcastle Help File Builder Documentation
BuildAssembler..::.GetWorkingDirectory Method
BuildAssembler Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is overridden to return the working folder for the build

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected override string GetWorkingDirectory()
Visual Basic (Declaration)
Protected Overrides Function GetWorkingDirectory As String

Return Value

The working folder for the build

See Also

BuildAssembler Class
SandcastleBuilder.Utils.MSBuild Namespace


ValidateParameters Method

[image]

Sandcastle Help File Builder Documentation
BuildAssembler..::.ValidateParameters Method
BuildAssembler Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Validate the parameters

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected override bool ValidateParameters()
Visual Basic (Declaration)
Protected Overrides Function ValidateParameters As Boolean

Return Value

True if the parameters are valid, false if not

See Also

BuildAssembler Class
SandcastleBuilder.Utils.MSBuild Namespace


BuildAssembler Properties

[image] [image]

Sandcastle Help File Builder Documentation
BuildAssembler Properties
BuildAssembler Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BuildAssembler type exposes the following members.

Properties

Name | Description
BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (Inherited from Task.)
BuildEngine2 | (Inherited from Task.)
ConfigurationFile | This is used to pass in the configuration filename
EnvironmentOverride | Gets the override value of the PATH environment variable. (Inherited from ToolTask.)
ExitCode | Gets the returned exit code of the executable file. (Inherited from ToolTask.)
HasLoggedErrors | (Inherited from ToolTask.)
HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (Inherited from Task.)
HostObject | Gets or sets the host object associated with the task. (Inherited from Task.)
Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (Inherited from Task.)
ManifestFile | This is used to pass in the manifest filename
ResponseFileEncoding | Gets the Encoding of the response file. (Inherited from ToolTask.)
SandcastlePath | This is used to pass in the path to the Sandcastle tools
StandardErrorEncoding | Gets the Encoding of the standard error stream of the task. (Inherited from ToolTask.)
StandardErrorImportance | (Inherited from ToolTask.)
StandardErrorLoggingImportance | This is overridden to force all standard error info to be logged (Overrides ToolTask..::.StandardErrorLoggingImportance.)
StandardOutputEncoding | Gets the Encoding of the standard output stream of the task. (Inherited from ToolTask.)
StandardOutputImportance | (Inherited from ToolTask.)
StandardOutputLoggingImportance | This is overridden to force all standard output info to be logged (Overrides ToolTask..::.StandardOutputLoggingImportance.)
TaskResources | Gets or sets the culture-specific resources associated with the task. (Inherited from Task.)
Timeout | Gets or sets the amount of time after which the task executable is terminated. (Inherited from ToolTask.)
ToolExe | (Inherited from ToolTask.)
ToolName | This read-only property returns the tool name (BuildAssembler.exe) (Overrides ToolTask..::.ToolName.)
ToolPath | Gets or sets the path of the executable file to run. (Inherited from ToolTask.)
WorkingFolder | This is used to pass in the working folder where the files are located.

See Also

BuildAssembler Class
SandcastleBuilder.Utils.MSBuild Namespace


ConfigurationFile Property

[image]

Sandcastle Help File Builder Documentation
BuildAssembler..::.ConfigurationFile Property
BuildAssembler Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to pass in the configuration filename

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string ConfigurationFile { get; set; }
Visual Basic (Declaration)
Public Property ConfigurationFile As String

See Also

BuildAssembler Class
SandcastleBuilder.Utils.MSBuild Namespace


ManifestFile Property

[image]

Sandcastle Help File Builder Documentation
BuildAssembler..::.ManifestFile Property
BuildAssembler Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to pass in the manifest filename

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string ManifestFile { get; set; }
Visual Basic (Declaration)
Public Property ManifestFile As String

See Also

BuildAssembler Class
SandcastleBuilder.Utils.MSBuild Namespace


SandcastlePath Property

[image]

Sandcastle Help File Builder Documentation
BuildAssembler..::.SandcastlePath Property
BuildAssembler Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to pass in the path to the Sandcastle tools

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string SandcastlePath { get; set; }
Visual Basic (Declaration)
Public Property SandcastlePath As String

See Also

BuildAssembler Class
SandcastleBuilder.Utils.MSBuild Namespace


StandardErrorLoggingImportance Property

[image]

Sandcastle Help File Builder Documentation
BuildAssembler..::.StandardErrorLoggingImportance Property
BuildAssembler Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is overridden to force all standard error info to be logged

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected override MessageImportance StandardErrorLoggingImportance { get; }
Visual Basic (Declaration)
Protected Overrides ReadOnly Property StandardErrorLoggingImportance As MessageImportance

See Also

BuildAssembler Class
SandcastleBuilder.Utils.MSBuild Namespace


StandardOutputLoggingImportance Property

[image]

Sandcastle Help File Builder Documentation
BuildAssembler..::.StandardOutputLoggingImportance Property
BuildAssembler Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is overridden to force all standard output info to be logged

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected override MessageImportance StandardOutputLoggingImportance { get; }
Visual Basic (Declaration)
Protected Overrides ReadOnly Property StandardOutputLoggingImportance As MessageImportance

See Also

BuildAssembler Class
SandcastleBuilder.Utils.MSBuild Namespace


ToolName Property

[image]

Sandcastle Help File Builder Documentation
BuildAssembler..::.ToolName Property
BuildAssembler Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns the tool name (BuildAssembler.exe)

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected override string ToolName { get; }
Visual Basic (Declaration)
Protected Overrides ReadOnly Property ToolName As String

See Also

BuildAssembler Class
SandcastleBuilder.Utils.MSBuild Namespace


WorkingFolder Property

[image]

Sandcastle Help File Builder Documentation
BuildAssembler..::.WorkingFolder Property
BuildAssembler Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to pass in the working folder where the files are located.

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string WorkingFolder { get; set; }
Visual Basic (Declaration)
Public Property WorkingFolder As String

See Also

BuildAssembler Class
SandcastleBuilder.Utils.MSBuild Namespace


BuildHelp Class

[image]

Sandcastle Help File Builder Documentation
BuildHelp Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This task is used to build help file output using the Sandcastle Help File Builder.

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public class BuildHelp : Task
Visual Basic (Declaration)
Public Class BuildHelp _
    Inherits Task

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
SandcastleBuilder.Utils.MSBuild..::.BuildHelp

See Also

BuildHelp Members
SandcastleBuilder.Utils.MSBuild Namespace


BuildHelp Members

[image] [image]

Sandcastle Help File Builder Documentation
BuildHelp Members
BuildHelp Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BuildHelp type exposes the following members.

Constructors

Name | Description
BuildHelp | Initializes a new instance of the BuildHelp class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | This is used to execute the task and perform the build (Overrides Task..::.Execute()()().)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AllHelpFiles | This is used to return a list of all files that resulted from the build (all help formats).
AlwaysLoadProject | This is used to specify whether or not to load the specified ProjectFile rather than use the executing project.
BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (Inherited from Task.)
BuildEngine2 | (Inherited from Task.)
Configuration | This is used to pass in the configuration to use for the build
DumpLogOnFailure | This is used to set or get whether the log file is dumped to the task log if the help file project build fails.
Help1Files | This is used to return a list of the Help 1 (CHM) files that resulted from the build.
Help2Files | This is used to return a list of the Help 2 (HxS) files that resulted from the build.
HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (Inherited from Task.)
HostObject | Gets or sets the host object associated with the task. (Inherited from Task.)
Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (Inherited from Task.)
OutDir | This is used to specify the output directory containing the build output for solution and project documentation sources when using Team Build.
Platform | This is used to pass in the platform to use for the build
ProjectFile | This is used to pass in the project filename
TaskResources | Gets or sets the culture-specific resources associated with the task. (Inherited from Task.)
Verbose | This is used to set or get the output logging verbosity flag
WebsiteFiles | This is used to return a list of the website files that resulted from the build.

See Also

BuildHelp Class
SandcastleBuilder.Utils.MSBuild Namespace


BuildHelp Constructor

[image]

Sandcastle Help File Builder Documentation
BuildHelp Constructor
BuildHelp Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the BuildHelp class

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public BuildHelp()
Visual Basic (Declaration)
Public Sub New

See Also

BuildHelp Class
SandcastleBuilder.Utils.MSBuild Namespace


BuildHelp Methods

[image] [image]

Sandcastle Help File Builder Documentation
BuildHelp Methods
BuildHelp Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BuildHelp type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | This is used to execute the task and perform the build (Overrides Task..::.Execute()()().)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BuildHelp Class
SandcastleBuilder.Utils.MSBuild Namespace


Execute Method

[image]

Sandcastle Help File Builder Documentation
BuildHelp..::.Execute Method
BuildHelp Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to execute the task and perform the build

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public override bool Execute()
Visual Basic (Declaration)
Public Overrides Function Execute As Boolean

Return Value

True on success or false on failure.

Implements

ITask..::.Execute()()()

See Also

BuildHelp Class
SandcastleBuilder.Utils.MSBuild Namespace


BuildHelp Properties

[image] [image]

Sandcastle Help File Builder Documentation
BuildHelp Properties
BuildHelp Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BuildHelp type exposes the following members.

Properties

Name | Description
AllHelpFiles | This is used to return a list of all files that resulted from the build (all help formats).
AlwaysLoadProject | This is used to specify whether or not to load the specified ProjectFile rather than use the executing project.
BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (Inherited from Task.)
BuildEngine2 | (Inherited from Task.)
Configuration | This is used to pass in the configuration to use for the build
DumpLogOnFailure | This is used to set or get whether the log file is dumped to the task log if the help file project build fails.
Help1Files | This is used to return a list of the Help 1 (CHM) files that resulted from the build.
Help2Files | This is used to return a list of the Help 2 (HxS) files that resulted from the build.
HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (Inherited from Task.)
HostObject | Gets or sets the host object associated with the task. (Inherited from Task.)
Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (Inherited from Task.)
OutDir | This is used to specify the output directory containing the build output for solution and project documentation sources when using Team Build.
Platform | This is used to pass in the platform to use for the build
ProjectFile | This is used to pass in the project filename
TaskResources | Gets or sets the culture-specific resources associated with the task. (Inherited from Task.)
Verbose | This is used to set or get the output logging verbosity flag
WebsiteFiles | This is used to return a list of the website files that resulted from the build.

See Also

BuildHelp Class
SandcastleBuilder.Utils.MSBuild Namespace


AllHelpFiles Property

[image]

Sandcastle Help File Builder Documentation
BuildHelp..::.AllHelpFiles Property
BuildHelp Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to return a list of all files that resulted from the build (all help formats).

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public ITaskItem[] AllHelpFiles { get; }
Visual Basic (Declaration)
Public ReadOnly Property AllHelpFiles As ITaskItem()

See Also

BuildHelp Class
SandcastleBuilder.Utils.MSBuild Namespace


AlwaysLoadProject Property

[image]

Sandcastle Help File Builder Documentation
BuildHelp..::.AlwaysLoadProject Property
BuildHelp Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to specify whether or not to load the specified ProjectFile rather than use the executing project.

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool AlwaysLoadProject { get; set; }
Visual Basic (Declaration)
Public Property AlwaysLoadProject As Boolean

Field Value

This property is optional. If set to false, the default, the executing project is used as the Sandcastle project to build. If set to true, the specified ProjectFile is loaded. In such cases, command line property overrides are ignored.

See Also

BuildHelp Class
SandcastleBuilder.Utils.MSBuild Namespace


Configuration Property

[image]

Sandcastle Help File Builder Documentation
BuildHelp..::.Configuration Property
BuildHelp Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to pass in the configuration to use for the build

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string Configuration { get; set; }
Visual Basic (Declaration)
Public Property Configuration As String

See Also

BuildHelp Class
SandcastleBuilder.Utils.MSBuild Namespace


DumpLogOnFailure Property

[image]

Sandcastle Help File Builder Documentation
BuildHelp..::.DumpLogOnFailure Property
BuildHelp Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to set or get whether the log file is dumped to the task log if the help file project build fails.

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool DumpLogOnFailure { get; set; }
Visual Basic (Declaration)
Public Property DumpLogOnFailure As Boolean

Field Value

This property is optional. If set to false (the default), the log is not dumped if the build fails. If set to true, all output from the build process is written to the task log if the build fails.

See Also

BuildHelp Class
SandcastleBuilder.Utils.MSBuild Namespace


Help1Files Property

[image]

Sandcastle Help File Builder Documentation
BuildHelp..::.Help1Files Property
BuildHelp Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to return a list of the Help 1 (CHM) files that resulted from the build.

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public ITaskItem[] Help1Files { get; }
Visual Basic (Declaration)
Public ReadOnly Property Help1Files As ITaskItem()

See Also

BuildHelp Class
SandcastleBuilder.Utils.MSBuild Namespace


Help2Files Property

[image]

Sandcastle Help File Builder Documentation
BuildHelp..::.Help2Files Property
BuildHelp Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to return a list of the Help 2 (HxS) files that resulted from the build.

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public ITaskItem[] Help2Files { get; }
Visual Basic (Declaration)
Public ReadOnly Property Help2Files As ITaskItem()

See Also

BuildHelp Class
SandcastleBuilder.Utils.MSBuild Namespace


OutDir Property

[image]

Sandcastle Help File Builder Documentation
BuildHelp..::.OutDir Property
BuildHelp Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to specify the output directory containing the build output for solution and project documentation sources when using Team Build.

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string OutDir { get; set; }
Visual Basic (Declaration)
Public Property OutDir As String

Field Value

This property is optional. If not specified, the default output path in project file documentation sources will be used.

See Also

BuildHelp Class
SandcastleBuilder.Utils.MSBuild Namespace


Platform Property

[image]

Sandcastle Help File Builder Documentation
BuildHelp..::.Platform Property
BuildHelp Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to pass in the platform to use for the build

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string Platform { get; set; }
Visual Basic (Declaration)
Public Property Platform As String

See Also

BuildHelp Class
SandcastleBuilder.Utils.MSBuild Namespace


ProjectFile Property

[image]

Sandcastle Help File Builder Documentation
BuildHelp..::.ProjectFile Property
BuildHelp Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to pass in the project filename

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string ProjectFile { get; set; }
Visual Basic (Declaration)
Public Property ProjectFile As String

Remarks

Since SandcastleProject already wraps the MSBuild project, it seemed redundant to define each and every property on this task and map them to the project properties. As such, this task will attempt to use the executing project to create the Sandcastle project instance. If that fails or AlwaysLoadProject is true, this file will be loaded instead. The downside is that property overrides on the command line will be ignored.

See Also

BuildHelp Class
SandcastleBuilder.Utils.MSBuild Namespace


Verbose Property

[image]

Sandcastle Help File Builder Documentation
BuildHelp..::.Verbose Property
BuildHelp Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to set or get the output logging verbosity flag

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool Verbose { get; set; }
Visual Basic (Declaration)
Public Property Verbose As Boolean

Field Value

This property is optional. If set to false (the default), only build steps are written to the task log. If set to true, all output from the build process is written to the task log.

See Also

BuildHelp Class
SandcastleBuilder.Utils.MSBuild Namespace


WebsiteFiles Property

[image]

Sandcastle Help File Builder Documentation
BuildHelp..::.WebsiteFiles Property
BuildHelp Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to return a list of the website files that resulted from the build.

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public ITaskItem[] WebsiteFiles { get; }
Visual Basic (Declaration)
Public ReadOnly Property WebsiteFiles As ITaskItem()

See Also

BuildHelp Class
SandcastleBuilder.Utils.MSBuild Namespace


CleanHelp Class

[image]

Sandcastle Help File Builder Documentation
CleanHelp Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This task is used to clean (remove) help file output from the last build.

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public class CleanHelp : Task
Visual Basic (Declaration)
Public Class CleanHelp _
    Inherits Task

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
SandcastleBuilder.Utils.MSBuild..::.CleanHelp

See Also

CleanHelp Members
SandcastleBuilder.Utils.MSBuild Namespace


CleanHelp Members

[image] [image]

Sandcastle Help File Builder Documentation
CleanHelp Members
CleanHelp Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The CleanHelp type exposes the following members.

Constructors

Name | Description
CleanHelp | Initializes a new instance of the CleanHelp class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | This is used to execute the task and clean the output folder (Overrides Task..::.Execute()()().)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (Inherited from Task.)
BuildEngine2 | (Inherited from Task.)
HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (Inherited from Task.)
HostObject | Gets or sets the host object associated with the task. (Inherited from Task.)
Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (Inherited from Task.)
LogFileLocation | This is used to pass in the optional log file location that needs to be cleaned.
OutputPath | This is used to pass in the output path that needs to be cleaned
ProjectFile | This is used to pass in the project filename
TaskResources | Gets or sets the culture-specific resources associated with the task. (Inherited from Task.)
WorkingPath | This is used to pass in the optional working path that needs to be cleaned.

See Also

CleanHelp Class
SandcastleBuilder.Utils.MSBuild Namespace


CleanHelp Constructor

[image]

Sandcastle Help File Builder Documentation
CleanHelp Constructor
CleanHelp Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the CleanHelp class

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public CleanHelp()
Visual Basic (Declaration)
Public Sub New

See Also

CleanHelp Class
SandcastleBuilder.Utils.MSBuild Namespace


CleanHelp Methods

[image] [image]

Sandcastle Help File Builder Documentation
CleanHelp Methods
CleanHelp Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The CleanHelp type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | This is used to execute the task and clean the output folder (Overrides Task..::.Execute()()().)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CleanHelp Class
SandcastleBuilder.Utils.MSBuild Namespace


Execute Method

[image]

Sandcastle Help File Builder Documentation
CleanHelp..::.Execute Method
CleanHelp Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to execute the task and clean the output folder

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public override bool Execute()
Visual Basic (Declaration)
Public Overrides Function Execute As Boolean

Return Value

True on success or false on failure.

Implements

ITask..::.Execute()()()

See Also

CleanHelp Class
SandcastleBuilder.Utils.MSBuild Namespace


CleanHelp Properties

[image] [image]

Sandcastle Help File Builder Documentation
CleanHelp Properties
CleanHelp Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The CleanHelp type exposes the following members.

Properties

Name | Description
BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (Inherited from Task.)
BuildEngine2 | (Inherited from Task.)
HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (Inherited from Task.)
HostObject | Gets or sets the host object associated with the task. (Inherited from Task.)
Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (Inherited from Task.)
LogFileLocation | This is used to pass in the optional log file location that needs to be cleaned.
OutputPath | This is used to pass in the output path that needs to be cleaned
ProjectFile | This is used to pass in the project filename
TaskResources | Gets or sets the culture-specific resources associated with the task. (Inherited from Task.)
WorkingPath | This is used to pass in the optional working path that needs to be cleaned.

See Also

CleanHelp Class
SandcastleBuilder.Utils.MSBuild Namespace


LogFileLocation Property

[image]

Sandcastle Help File Builder Documentation
CleanHelp..::.LogFileLocation Property
CleanHelp Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to pass in the optional log file location that needs to be cleaned.

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string LogFileLocation { get; set; }
Visual Basic (Declaration)
Public Property LogFileLocation As String

See Also

CleanHelp Class
SandcastleBuilder.Utils.MSBuild Namespace


OutputPath Property

[image]

Sandcastle Help File Builder Documentation
CleanHelp..::.OutputPath Property
CleanHelp Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to pass in the output path that needs to be cleaned

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string OutputPath { get; set; }
Visual Basic (Declaration)
Public Property OutputPath As String

See Also

CleanHelp Class
SandcastleBuilder.Utils.MSBuild Namespace


ProjectFile Property

[image]

Sandcastle Help File Builder Documentation
CleanHelp..::.ProjectFile Property
CleanHelp Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to pass in the project filename

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string ProjectFile { get; set; }
Visual Basic (Declaration)
Public Property ProjectFile As String

Remarks

Since SandcastleProject already wraps the MSBuild project, it made sense to just load it in the task and build it that way rather than have one or more other structures to hold passed in project properties that then got passed to the build process.

See Also

CleanHelp Class
SandcastleBuilder.Utils.MSBuild Namespace


WorkingPath Property

[image]

Sandcastle Help File Builder Documentation
CleanHelp..::.WorkingPath Property
CleanHelp Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to pass in the optional working path that needs to be cleaned.

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string WorkingPath { get; set; }
Visual Basic (Declaration)
Public Property WorkingPath As String

See Also

CleanHelp Class
SandcastleBuilder.Utils.MSBuild Namespace


MRefBuilder Class

[image]

Sandcastle Help File Builder Documentation
MRefBuilder Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This task is used to generate the MRefBuilder response file and run MRefBuilder.exe.

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public class MRefBuilder : ToolTask
Visual Basic (Declaration)
Public Class MRefBuilder _
    Inherits ToolTask

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
Microsoft.Build.Utilities..::.ToolTask
SandcastleBuilder.Utils.MSBuild..::.MRefBuilder

See Also

MRefBuilder Members
SandcastleBuilder.Utils.MSBuild Namespace


MRefBuilder Members

[image] [image]

Sandcastle Help File Builder Documentation
MRefBuilder Members
MRefBuilder Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The MRefBuilder type exposes the following members.

Constructors

Name | Description
MRefBuilder | Initializes a new instance of the MRefBuilder class

Methods

Name | Description
CallHostObjectToExecute | Calls the host object to perform the work of the task. (Inherited from ToolTask.)
DeleteTempFile | Deletes the specified temporary file. (Inherited from ToolTask.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | Runs the exectuable file with the specified task parameters. (Inherited from ToolTask.)
ExecuteTool | Creates a temporoary response (.rsp) file and runs the executable file. (Inherited from ToolTask.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GenerateCommandLineCommands | Generate the command line parameters (Overrides ToolTask..::.GenerateCommandLineCommands()()().)
GenerateFullPathToTool | This returns the full path to the tool (Overrides ToolTask..::.GenerateFullPathToTool()()().)
GenerateResponseFileCommands | Generate the response file commands (Overrides ToolTask..::.GenerateResponseFileCommands()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetResponseFileSwitch | Returns the command line switch used by the executable file to specifiy a response (.rsp) file. (Inherited from ToolTask.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetWorkingDirectory | This is overridden to return the working folder for the build (Overrides ToolTask..::.GetWorkingDirectory()()().)
HandleTaskExecutionErrors | Handles execution errors raised by the executable file. (Inherited from ToolTask.)
InitializeHostObject | Initializes the host object of the task. (Inherited from ToolTask.)
LogEventsFromTextOutput | Parses a single line of text to identify any errors or warnings in canonical format. (Inherited from ToolTask.)
LogPathToTool | Logs the tool name and path to all registered loggers. (Inherited from ToolTask.)
LogToolCommand | Logs the starting point of the run to all registered loggers. (Inherited from ToolTask.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SkipTaskExecution | Indicates whether task execution should be skipped. (Inherited from ToolTask.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ValidateParameters | Validate the parameters (Overrides ToolTask..::.ValidateParameters()()().)

Properties

Name | Description
Assemblies | This is used to pass in the assemblies to reflect over
BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (Inherited from Task.)
BuildEngine2 | (Inherited from Task.)
DocumentInternals | This is used to pass in the Document Internals flag setting
EnvironmentOverride | Gets the override value of the PATH environment variable. (Inherited from ToolTask.)
ExitCode | Gets the returned exit code of the executable file. (Inherited from ToolTask.)
HasLoggedErrors | (Inherited from ToolTask.)
HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (Inherited from Task.)
HostObject | Gets or sets the host object associated with the task. (Inherited from Task.)
Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (Inherited from Task.)
References | This is used to pass in the resolved references
ResponseFileEncoding | Gets the Encoding of the response file. (Inherited from ToolTask.)
SandcastlePath | This is used to pass in the path to the Sandcastle tools
StandardErrorEncoding | Gets the Encoding of the standard error stream of the task. (Inherited from ToolTask.)
StandardErrorImportance | (Inherited from ToolTask.)
StandardErrorLoggingImportance | This is overridden to force all standard error info to be logged (Overrides ToolTask..::.StandardErrorLoggingImportance.)
StandardOutputEncoding | Gets the Encoding of the standard output stream of the task. (Inherited from ToolTask.)
StandardOutputImportance | (Inherited from ToolTask.)
StandardOutputLoggingImportance | This is overridden to force all standard output info to be logged (Overrides ToolTask..::.StandardOutputLoggingImportance.)
TaskResources | Gets or sets the culture-specific resources associated with the task. (Inherited from Task.)
Timeout | Gets or sets the amount of time after which the task executable is terminated. (Inherited from ToolTask.)
ToolExe | (Inherited from ToolTask.)
ToolName | This read-only property returns the tool name (MRefBuilder.exe) (Overrides ToolTask..::.ToolName.)
ToolPath | Gets or sets the path of the executable file to run. (Inherited from ToolTask.)
WorkingFolder | This is used to pass in the working folder where the files are located.

See Also

MRefBuilder Class
SandcastleBuilder.Utils.MSBuild Namespace


MRefBuilder Constructor

[image]

Sandcastle Help File Builder Documentation
MRefBuilder Constructor
MRefBuilder Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the MRefBuilder class

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public MRefBuilder()
Visual Basic (Declaration)
Public Sub New

See Also

MRefBuilder Class
SandcastleBuilder.Utils.MSBuild Namespace


MRefBuilder Methods

[image] [image]

Sandcastle Help File Builder Documentation
MRefBuilder Methods
MRefBuilder Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The MRefBuilder type exposes the following members.

Methods

Name | Description
CallHostObjectToExecute | Calls the host object to perform the work of the task. (Inherited from ToolTask.)
DeleteTempFile | Deletes the specified temporary file. (Inherited from ToolTask.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | Runs the exectuable file with the specified task parameters. (Inherited from ToolTask.)
ExecuteTool | Creates a temporoary response (.rsp) file and runs the executable file. (Inherited from ToolTask.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GenerateCommandLineCommands | Generate the command line parameters (Overrides ToolTask..::.GenerateCommandLineCommands()()().)
GenerateFullPathToTool | This returns the full path to the tool (Overrides ToolTask..::.GenerateFullPathToTool()()().)
GenerateResponseFileCommands | Generate the response file commands (Overrides ToolTask..::.GenerateResponseFileCommands()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetResponseFileSwitch | Returns the command line switch used by the executable file to specifiy a response (.rsp) file. (Inherited from ToolTask.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetWorkingDirectory | This is overridden to return the working folder for the build (Overrides ToolTask..::.GetWorkingDirectory()()().)
HandleTaskExecutionErrors | Handles execution errors raised by the executable file. (Inherited from ToolTask.)
InitializeHostObject | Initializes the host object of the task. (Inherited from ToolTask.)
LogEventsFromTextOutput | Parses a single line of text to identify any errors or warnings in canonical format. (Inherited from ToolTask.)
LogPathToTool | Logs the tool name and path to all registered loggers. (Inherited from ToolTask.)
LogToolCommand | Logs the starting point of the run to all registered loggers. (Inherited from ToolTask.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SkipTaskExecution | Indicates whether task execution should be skipped. (Inherited from ToolTask.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ValidateParameters | Validate the parameters (Overrides ToolTask..::.ValidateParameters()()().)

See Also

MRefBuilder Class
SandcastleBuilder.Utils.MSBuild Namespace


GenerateCommandLineCommands Method

[image]

Sandcastle Help File Builder Documentation
MRefBuilder..::.GenerateCommandLineCommands Method
MRefBuilder Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Generate the command line parameters

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected override string GenerateCommandLineCommands()
Visual Basic (Declaration)
Protected Overrides Function GenerateCommandLineCommands As String

Return Value

The command line parameters

See Also

MRefBuilder Class
SandcastleBuilder.Utils.MSBuild Namespace


GenerateFullPathToTool Method

[image]

Sandcastle Help File Builder Documentation
MRefBuilder..::.GenerateFullPathToTool Method
MRefBuilder Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This returns the full path to the tool

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected override string GenerateFullPathToTool()
Visual Basic (Declaration)
Protected Overrides Function GenerateFullPathToTool As String

Return Value

The full path to the tool

See Also

MRefBuilder Class
SandcastleBuilder.Utils.MSBuild Namespace


GenerateResponseFileCommands Method

[image]

Sandcastle Help File Builder Documentation
MRefBuilder..::.GenerateResponseFileCommands Method
MRefBuilder Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Generate the response file commands

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected override string GenerateResponseFileCommands()
Visual Basic (Declaration)
Protected Overrides Function GenerateResponseFileCommands As String

Return Value

An empty string

Remarks

Rather than letting the tool task create the response file, we'll create it ourself in the working folder so that we can look at it if the build fails.

See Also

MRefBuilder Class
SandcastleBuilder.Utils.MSBuild Namespace


GetWorkingDirectory Method

[image]

Sandcastle Help File Builder Documentation
MRefBuilder..::.GetWorkingDirectory Method
MRefBuilder Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is overridden to return the working folder for the build

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected override string GetWorkingDirectory()
Visual Basic (Declaration)
Protected Overrides Function GetWorkingDirectory As String

Return Value

The working folder for the build

See Also

MRefBuilder Class
SandcastleBuilder.Utils.MSBuild Namespace


ValidateParameters Method

[image]

Sandcastle Help File Builder Documentation
MRefBuilder..::.ValidateParameters Method
MRefBuilder Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Validate the parameters

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected override bool ValidateParameters()
Visual Basic (Declaration)
Protected Overrides Function ValidateParameters As Boolean

Return Value

True if the parameters are valid, false if not

See Also

MRefBuilder Class
SandcastleBuilder.Utils.MSBuild Namespace


MRefBuilder Properties

[image] [image]

Sandcastle Help File Builder Documentation
MRefBuilder Properties
MRefBuilder Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The MRefBuilder type exposes the following members.

Properties

Name | Description
Assemblies | This is used to pass in the assemblies to reflect over
BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (Inherited from Task.)
BuildEngine2 | (Inherited from Task.)
DocumentInternals | This is used to pass in the Document Internals flag setting
EnvironmentOverride | Gets the override value of the PATH environment variable. (Inherited from ToolTask.)
ExitCode | Gets the returned exit code of the executable file. (Inherited from ToolTask.)
HasLoggedErrors | (Inherited from ToolTask.)
HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (Inherited from Task.)
HostObject | Gets or sets the host object associated with the task. (Inherited from Task.)
Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (Inherited from Task.)
References | This is used to pass in the resolved references
ResponseFileEncoding | Gets the Encoding of the response file. (Inherited from ToolTask.)
SandcastlePath | This is used to pass in the path to the Sandcastle tools
StandardErrorEncoding | Gets the Encoding of the standard error stream of the task. (Inherited from ToolTask.)
StandardErrorImportance | (Inherited from ToolTask.)
StandardErrorLoggingImportance | This is overridden to force all standard error info to be logged (Overrides ToolTask..::.StandardErrorLoggingImportance.)
StandardOutputEncoding | Gets the Encoding of the standard output stream of the task. (Inherited from ToolTask.)
StandardOutputImportance | (Inherited from ToolTask.)
StandardOutputLoggingImportance | This is overridden to force all standard output info to be logged (Overrides ToolTask..::.StandardOutputLoggingImportance.)
TaskResources | Gets or sets the culture-specific resources associated with the task. (Inherited from Task.)
Timeout | Gets or sets the amount of time after which the task executable is terminated. (Inherited from ToolTask.)
ToolExe | (Inherited from ToolTask.)
ToolName | This read-only property returns the tool name (MRefBuilder.exe) (Overrides ToolTask..::.ToolName.)
ToolPath | Gets or sets the path of the executable file to run. (Inherited from ToolTask.)
WorkingFolder | This is used to pass in the working folder where the files are located.

See Also

MRefBuilder Class
SandcastleBuilder.Utils.MSBuild Namespace


Assemblies Property

[image]

Sandcastle Help File Builder Documentation
MRefBuilder..::.Assemblies Property
MRefBuilder Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to pass in the assemblies to reflect over

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public ITaskItem[] Assemblies { get; set; }
Visual Basic (Declaration)
Public Property Assemblies As ITaskItem()

See Also

MRefBuilder Class
SandcastleBuilder.Utils.MSBuild Namespace


DocumentInternals Property

[image]

Sandcastle Help File Builder Documentation
MRefBuilder..::.DocumentInternals Property
MRefBuilder Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to pass in the Document Internals flag setting

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool DocumentInternals { get; set; }
Visual Basic (Declaration)
Public Property DocumentInternals As Boolean

See Also

MRefBuilder Class
SandcastleBuilder.Utils.MSBuild Namespace


References Property

[image]

Sandcastle Help File Builder Documentation
MRefBuilder..::.References Property
MRefBuilder Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to pass in the resolved references

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public ITaskItem[] References { get; set; }
Visual Basic (Declaration)
Public Property References As ITaskItem()

Field Value

References are optional.

See Also

MRefBuilder Class
SandcastleBuilder.Utils.MSBuild Namespace


SandcastlePath Property

[image]

Sandcastle Help File Builder Documentation
MRefBuilder..::.SandcastlePath Property
MRefBuilder Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to pass in the path to the Sandcastle tools

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string SandcastlePath { get; set; }
Visual Basic (Declaration)
Public Property SandcastlePath As String

See Also

MRefBuilder Class
SandcastleBuilder.Utils.MSBuild Namespace


StandardErrorLoggingImportance Property

[image]

Sandcastle Help File Builder Documentation
MRefBuilder..::.StandardErrorLoggingImportance Property
MRefBuilder Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is overridden to force all standard error info to be logged

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected override MessageImportance StandardErrorLoggingImportance { get; }
Visual Basic (Declaration)
Protected Overrides ReadOnly Property StandardErrorLoggingImportance As MessageImportance

See Also

MRefBuilder Class
SandcastleBuilder.Utils.MSBuild Namespace


StandardOutputLoggingImportance Property

[image]

Sandcastle Help File Builder Documentation
MRefBuilder..::.StandardOutputLoggingImportance Property
MRefBuilder Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is overridden to force all standard output info to be logged

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected override MessageImportance StandardOutputLoggingImportance { get; }
Visual Basic (Declaration)
Protected Overrides ReadOnly Property StandardOutputLoggingImportance As MessageImportance

See Also

MRefBuilder Class
SandcastleBuilder.Utils.MSBuild Namespace


ToolName Property

[image]

Sandcastle Help File Builder Documentation
MRefBuilder..::.ToolName Property
MRefBuilder Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns the tool name (MRefBuilder.exe)

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected override string ToolName { get; }
Visual Basic (Declaration)
Protected Overrides ReadOnly Property ToolName As String

See Also

MRefBuilder Class
SandcastleBuilder.Utils.MSBuild Namespace


WorkingFolder Property

[image]

Sandcastle Help File Builder Documentation
MRefBuilder..::.WorkingFolder Property
MRefBuilder Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to pass in the working folder where the files are located.

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string WorkingFolder { get; set; }
Visual Basic (Declaration)
Public Property WorkingFolder As String

See Also

MRefBuilder Class
SandcastleBuilder.Utils.MSBuild Namespace


MSBuildProject Class

[image]

Sandcastle Help File Builder Documentation
MSBuildProject Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is a simple wrapper around an MSBuild project that is used to extract information from it during a help file build.

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public class MSBuildProject
Visual Basic (Declaration)
Public Class MSBuildProject

Inheritance Hierarchy

System..::.Object
SandcastleBuilder.Utils.MSBuild..::.MSBuildProject

See Also

MSBuildProject Members
SandcastleBuilder.Utils.MSBuild Namespace


MSBuildProject Members

[image] [image]

Sandcastle Help File Builder Documentation
MSBuildProject Members
MSBuildProject Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The MSBuildProject type exposes the following members.

Constructors

Name | Description
MSBuildProject | Constructor

Methods

Name | Description
CloneReferences | Clone the project's references and add them to the dictionary
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetConfiguration | This is used to set the active configuration and platform used when evaluating the properties.
SetSolutionMacros | This is used to set the Visual Studio solution macros based on the specified project name.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AssemblyName | This is used to get the assembly name
ProjectFile | This is used to get the underlying MSBuild project file reference
ProjectGuid | This is used to get the project GUID
TargetFrameworkVersion | This is used to get the target framework version
XmlCommentsFile | This is used to get the XML comments file name

See Also

MSBuildProject Class
SandcastleBuilder.Utils.MSBuild Namespace


MSBuildProject Constructor

[image]

Sandcastle Help File Builder Documentation
MSBuildProject Constructor
MSBuildProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public MSBuildProject(
    string projectFile
)
Visual Basic (Declaration)
Public Sub New ( _
    projectFile As String _
)

Parameters

projectFile
Type: System..::.String
The MSBuild project to load

See Also

MSBuildProject Class
SandcastleBuilder.Utils.MSBuild Namespace


MSBuildProject Methods

[image] [image]

Sandcastle Help File Builder Documentation
MSBuildProject Methods
MSBuildProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The MSBuildProject type exposes the following members.

Methods

Name | Description
CloneReferences | Clone the project's references and add them to the dictionary
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetConfiguration | This is used to set the active configuration and platform used when evaluating the properties.
SetSolutionMacros | This is used to set the Visual Studio solution macros based on the specified project name.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MSBuildProject Class
SandcastleBuilder.Utils.MSBuild Namespace


CloneReferences Method

[image]

Sandcastle Help File Builder Documentation
MSBuildProject..::.CloneReferences Method
MSBuildProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clone the project's references and add them to the dictionary

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public void CloneReferences(
    Dictionary<string, BuildItem> references
)
Visual Basic (Declaration)
Public Sub CloneReferences ( _
    references As Dictionary(Of String, BuildItem) _
)

Parameters

references
Type: System.Collections.Generic..::.Dictionary <(Of <( String, BuildItem >)>)
The dictionary used to contain the cloned references

See Also

MSBuildProject Class
SandcastleBuilder.Utils.MSBuild Namespace


SetConfiguration Method

[image]

Sandcastle Help File Builder Documentation
MSBuildProject..::.SetConfiguration Method
MSBuildProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to set the active configuration and platform used when evaluating the properties.

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public void SetConfiguration(
    string configuration,
    string platform,
    string outDir
)
Visual Basic (Declaration)
Public Sub SetConfiguration ( _
    configuration As String, _
    platform As String, _
    outDir As String _
)

Parameters

configuration
Type: System..::.String
The active configuration
platform
Type: System..::.String
The active platform
outDir
Type: System..::.String
The output directory

Remarks

If the platform is set to any variation of "Any CPU" and it isn't found in the project, it will be converted to "AnyCPU" (no space). This works around an issue with Team Build that includes the space even though it should not be present.

See Also

MSBuildProject Class
SandcastleBuilder.Utils.MSBuild Namespace


SetSolutionMacros Method

[image]

Sandcastle Help File Builder Documentation
MSBuildProject..::.SetSolutionMacros Method
MSBuildProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to set the Visual Studio solution macros based on the specified project name.

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public void SetSolutionMacros(
    string solutionName
)
Visual Basic (Declaration)
Public Sub SetSolutionMacros ( _
    solutionName As String _
)

Parameters

solutionName
Type: System..::.String
The solution name to use

See Also

MSBuildProject Class
SandcastleBuilder.Utils.MSBuild Namespace


MSBuildProject Properties

[image] [image]

Sandcastle Help File Builder Documentation
MSBuildProject Properties
MSBuildProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The MSBuildProject type exposes the following members.

Properties

Name | Description
AssemblyName | This is used to get the assembly name
ProjectFile | This is used to get the underlying MSBuild project file reference
ProjectGuid | This is used to get the project GUID
TargetFrameworkVersion | This is used to get the target framework version
XmlCommentsFile | This is used to get the XML comments file name

See Also

MSBuildProject Class
SandcastleBuilder.Utils.MSBuild Namespace


AssemblyName Property

[image]

Sandcastle Help File Builder Documentation
MSBuildProject..::.AssemblyName Property
MSBuildProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get the assembly name

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string AssemblyName { get; }
Visual Basic (Declaration)
Public ReadOnly Property AssemblyName As String

See Also

MSBuildProject Class
SandcastleBuilder.Utils.MSBuild Namespace


ProjectFile Property

[image]

Sandcastle Help File Builder Documentation
MSBuildProject..::.ProjectFile Property
MSBuildProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get the underlying MSBuild project file reference

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public Project ProjectFile { get; }
Visual Basic (Declaration)
Public ReadOnly Property ProjectFile As Project

See Also

MSBuildProject Class
SandcastleBuilder.Utils.MSBuild Namespace


ProjectGuid Property

[image]

Sandcastle Help File Builder Documentation
MSBuildProject..::.ProjectGuid Property
MSBuildProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get the project GUID

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string ProjectGuid { get; }
Visual Basic (Declaration)
Public ReadOnly Property ProjectGuid As String

See Also

MSBuildProject Class
SandcastleBuilder.Utils.MSBuild Namespace


TargetFrameworkVersion Property

[image]

Sandcastle Help File Builder Documentation
MSBuildProject..::.TargetFrameworkVersion Property
MSBuildProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get the target framework version

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string TargetFrameworkVersion { get; }
Visual Basic (Declaration)
Public ReadOnly Property TargetFrameworkVersion As String

See Also

MSBuildProject Class
SandcastleBuilder.Utils.MSBuild Namespace


XmlCommentsFile Property

[image]

Sandcastle Help File Builder Documentation
MSBuildProject..::.XmlCommentsFile Property
MSBuildProject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get the XML comments file name

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string XmlCommentsFile { get; }
Visual Basic (Declaration)
Public ReadOnly Property XmlCommentsFile As String

See Also

MSBuildProject Class
SandcastleBuilder.Utils.MSBuild Namespace


XslTransform Class

[image]

Sandcastle Help File Builder Documentation
XslTransform Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This task is used to run XslTransform.exe which is used to run various XSL transformations on the Sandcastle data files.

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public class XslTransform : ToolTask
Visual Basic (Declaration)
Public Class XslTransform _
    Inherits ToolTask

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
Microsoft.Build.Utilities..::.ToolTask
SandcastleBuilder.Utils.MSBuild..::.XslTransform

See Also

XslTransform Members
SandcastleBuilder.Utils.MSBuild Namespace


XslTransform Members

[image] [image]

Sandcastle Help File Builder Documentation
XslTransform Members
XslTransform Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The XslTransform type exposes the following members.

Constructors

Name | Description
XslTransform | Initializes a new instance of the XslTransform class

Methods

Name | Description
CallHostObjectToExecute | Calls the host object to perform the work of the task. (Inherited from ToolTask.)
DeleteTempFile | Deletes the specified temporary file. (Inherited from ToolTask.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | Runs the exectuable file with the specified task parameters. (Inherited from ToolTask.)
ExecuteTool | Creates a temporoary response (.rsp) file and runs the executable file. (Inherited from ToolTask.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GenerateCommandLineCommands | Generate the command line parameters (Overrides ToolTask..::.GenerateCommandLineCommands()()().)
GenerateFullPathToTool | This returns the full path to the tool (Overrides ToolTask..::.GenerateFullPathToTool()()().)
GenerateResponseFileCommands | Returns a string value containing the command line arguments to add to the response (.rsp) file before running the executable file. (Inherited from ToolTask.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetResponseFileSwitch | Returns the command line switch used by the executable file to specifiy a response (.rsp) file. (Inherited from ToolTask.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetWorkingDirectory | This is overridden to return the working folder for the build (Overrides ToolTask..::.GetWorkingDirectory()()().)
HandleTaskExecutionErrors | Handles execution errors raised by the executable file. (Inherited from ToolTask.)
InitializeHostObject | Initializes the host object of the task. (Inherited from ToolTask.)
LogEventsFromTextOutput | Parses a single line of text to identify any errors or warnings in canonical format. (Inherited from ToolTask.)
LogPathToTool | Logs the tool name and path to all registered loggers. (Inherited from ToolTask.)
LogToolCommand | Logs the starting point of the run to all registered loggers. (Inherited from ToolTask.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SkipTaskExecution | Indicates whether task execution should be skipped. (Inherited from ToolTask.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ValidateParameters | Validate the parameters (Overrides ToolTask..::.ValidateParameters()()().)

Properties

Name | Description
Arguments | This is used to pass in any optional XSL transform arguments
BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (Inherited from Task.)
BuildEngine2 | (Inherited from Task.)
EnvironmentOverride | Gets the override value of the PATH environment variable. (Inherited from ToolTask.)
ExitCode | Gets the returned exit code of the executable file. (Inherited from ToolTask.)
HasLoggedErrors | (Inherited from ToolTask.)
HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (Inherited from Task.)
HostObject | Gets or sets the host object associated with the task. (Inherited from Task.)
InputFile | This is used to pass in the input filename
Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (Inherited from Task.)
OutputFile | This is used to pass in the output filename
ResponseFileEncoding | Gets the Encoding of the response file. (Inherited from ToolTask.)
SandcastlePath | This is used to pass in the path to the Sandcastle tools
StandardErrorEncoding | Gets the Encoding of the standard error stream of the task. (Inherited from ToolTask.)
StandardErrorImportance | (Inherited from ToolTask.)
StandardErrorLoggingImportance | This is overridden to force all standard error info to be logged (Overrides ToolTask..::.StandardErrorLoggingImportance.)
StandardOutputEncoding | Gets the Encoding of the standard output stream of the task. (Inherited from ToolTask.)
StandardOutputImportance | (Inherited from ToolTask.)
StandardOutputLoggingImportance | This is overridden to force all standard output info to be logged (Overrides ToolTask..::.StandardOutputLoggingImportance.)
TaskResources | Gets or sets the culture-specific resources associated with the task. (Inherited from Task.)
Timeout | Gets or sets the amount of time after which the task executable is terminated. (Inherited from ToolTask.)
ToolExe | (Inherited from ToolTask.)
ToolName | This read-only property returns the tool name (XslTransform.exe) (Overrides ToolTask..::.ToolName.)
ToolPath | Gets or sets the path of the executable file to run. (Inherited from ToolTask.)
Transformations | This is used to pass in the list of transformations to run
WorkingFolder | This is used to pass in the working folder where the files are located.

See Also

XslTransform Class
SandcastleBuilder.Utils.MSBuild Namespace


XslTransform Constructor

[image]

Sandcastle Help File Builder Documentation
XslTransform Constructor
XslTransform Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the XslTransform class

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public XslTransform()
Visual Basic (Declaration)
Public Sub New

See Also

XslTransform Class
SandcastleBuilder.Utils.MSBuild Namespace


XslTransform Methods

[image] [image]

Sandcastle Help File Builder Documentation
XslTransform Methods
XslTransform Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The XslTransform type exposes the following members.

Methods

Name | Description
CallHostObjectToExecute | Calls the host object to perform the work of the task. (Inherited from ToolTask.)
DeleteTempFile | Deletes the specified temporary file. (Inherited from ToolTask.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | Runs the exectuable file with the specified task parameters. (Inherited from ToolTask.)
ExecuteTool | Creates a temporoary response (.rsp) file and runs the executable file. (Inherited from ToolTask.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GenerateCommandLineCommands | Generate the command line parameters (Overrides ToolTask..::.GenerateCommandLineCommands()()().)
GenerateFullPathToTool | This returns the full path to the tool (Overrides ToolTask..::.GenerateFullPathToTool()()().)
GenerateResponseFileCommands | Returns a string value containing the command line arguments to add to the response (.rsp) file before running the executable file. (Inherited from ToolTask.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetResponseFileSwitch | Returns the command line switch used by the executable file to specifiy a response (.rsp) file. (Inherited from ToolTask.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetWorkingDirectory | This is overridden to return the working folder for the build (Overrides ToolTask..::.GetWorkingDirectory()()().)
HandleTaskExecutionErrors | Handles execution errors raised by the executable file. (Inherited from ToolTask.)
InitializeHostObject | Initializes the host object of the task. (Inherited from ToolTask.)
LogEventsFromTextOutput | Parses a single line of text to identify any errors or warnings in canonical format. (Inherited from ToolTask.)
LogPathToTool | Logs the tool name and path to all registered loggers. (Inherited from ToolTask.)
LogToolCommand | Logs the starting point of the run to all registered loggers. (Inherited from ToolTask.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SkipTaskExecution | Indicates whether task execution should be skipped. (Inherited from ToolTask.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ValidateParameters | Validate the parameters (Overrides ToolTask..::.ValidateParameters()()().)

See Also

XslTransform Class
SandcastleBuilder.Utils.MSBuild Namespace


GenerateCommandLineCommands Method

[image]

Sandcastle Help File Builder Documentation
XslTransform..::.GenerateCommandLineCommands Method
XslTransform Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Generate the command line parameters

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected override string GenerateCommandLineCommands()
Visual Basic (Declaration)
Protected Overrides Function GenerateCommandLineCommands As String

Return Value

The command line parameters

See Also

XslTransform Class
SandcastleBuilder.Utils.MSBuild Namespace


GenerateFullPathToTool Method

[image]

Sandcastle Help File Builder Documentation
XslTransform..::.GenerateFullPathToTool Method
XslTransform Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This returns the full path to the tool

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected override string GenerateFullPathToTool()
Visual Basic (Declaration)
Protected Overrides Function GenerateFullPathToTool As String

Return Value

The full path to the tool

See Also

XslTransform Class
SandcastleBuilder.Utils.MSBuild Namespace


GetWorkingDirectory Method

[image]

Sandcastle Help File Builder Documentation
XslTransform..::.GetWorkingDirectory Method
XslTransform Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is overridden to return the working folder for the build

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected override string GetWorkingDirectory()
Visual Basic (Declaration)
Protected Overrides Function GetWorkingDirectory As String

Return Value

The working folder for the build

See Also

XslTransform Class
SandcastleBuilder.Utils.MSBuild Namespace


ValidateParameters Method

[image]

Sandcastle Help File Builder Documentation
XslTransform..::.ValidateParameters Method
XslTransform Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Validate the parameters

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected override bool ValidateParameters()
Visual Basic (Declaration)
Protected Overrides Function ValidateParameters As Boolean

Return Value

True if the parameters are valid, false if not

See Also

XslTransform Class
SandcastleBuilder.Utils.MSBuild Namespace


XslTransform Properties

[image] [image]

Sandcastle Help File Builder Documentation
XslTransform Properties
XslTransform Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The XslTransform type exposes the following members.

Properties

Name | Description
Arguments | This is used to pass in any optional XSL transform arguments
BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (Inherited from Task.)
BuildEngine2 | (Inherited from Task.)
EnvironmentOverride | Gets the override value of the PATH environment variable. (Inherited from ToolTask.)
ExitCode | Gets the returned exit code of the executable file. (Inherited from ToolTask.)
HasLoggedErrors | (Inherited from ToolTask.)
HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (Inherited from Task.)
HostObject | Gets or sets the host object associated with the task. (Inherited from Task.)
InputFile | This is used to pass in the input filename
Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (Inherited from Task.)
OutputFile | This is used to pass in the output filename
ResponseFileEncoding | Gets the Encoding of the response file. (Inherited from ToolTask.)
SandcastlePath | This is used to pass in the path to the Sandcastle tools
StandardErrorEncoding | Gets the Encoding of the standard error stream of the task. (Inherited from ToolTask.)
StandardErrorImportance | (Inherited from ToolTask.)
StandardErrorLoggingImportance | This is overridden to force all standard error info to be logged (Overrides ToolTask..::.StandardErrorLoggingImportance.)
StandardOutputEncoding | Gets the Encoding of the standard output stream of the task. (Inherited from ToolTask.)
StandardOutputImportance | (Inherited from ToolTask.)
StandardOutputLoggingImportance | This is overridden to force all standard output info to be logged (Overrides ToolTask..::.StandardOutputLoggingImportance.)
TaskResources | Gets or sets the culture-specific resources associated with the task. (Inherited from Task.)
Timeout | Gets or sets the amount of time after which the task executable is terminated. (Inherited from ToolTask.)
ToolExe | (Inherited from ToolTask.)
ToolName | This read-only property returns the tool name (XslTransform.exe) (Overrides ToolTask..::.ToolName.)
ToolPath | Gets or sets the path of the executable file to run. (Inherited from ToolTask.)
Transformations | This is used to pass in the list of transformations to run
WorkingFolder | This is used to pass in the working folder where the files are located.

See Also

XslTransform Class
SandcastleBuilder.Utils.MSBuild Namespace


Arguments Property

[image]

Sandcastle Help File Builder Documentation
XslTransform..::.Arguments Property
XslTransform Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to pass in any optional XSL transform arguments

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string[] Arguments { get; set; }
Visual Basic (Declaration)
Public Property Arguments As String()

Field Value

The optional XSL transform arguments in the form "argName=argValue". Separate multiple arguments with a semi-colon.

See Also

XslTransform Class
SandcastleBuilder.Utils.MSBuild Namespace


InputFile Property

[image]

Sandcastle Help File Builder Documentation
XslTransform..::.InputFile Property
XslTransform Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to pass in the input filename

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string InputFile { get; set; }
Visual Basic (Declaration)
Public Property InputFile As String

See Also

XslTransform Class
SandcastleBuilder.Utils.MSBuild Namespace


OutputFile Property

[image]

Sandcastle Help File Builder Documentation
XslTransform..::.OutputFile Property
XslTransform Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to pass in the output filename

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string OutputFile { get; set; }
Visual Basic (Declaration)
Public Property OutputFile As String

See Also

XslTransform Class
SandcastleBuilder.Utils.MSBuild Namespace


SandcastlePath Property

[image]

Sandcastle Help File Builder Documentation
XslTransform..::.SandcastlePath Property
XslTransform Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to pass in the path to the Sandcastle tools

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string SandcastlePath { get; set; }
Visual Basic (Declaration)
Public Property SandcastlePath As String

See Also

XslTransform Class
SandcastleBuilder.Utils.MSBuild Namespace


StandardErrorLoggingImportance Property

[image]

Sandcastle Help File Builder Documentation
XslTransform..::.StandardErrorLoggingImportance Property
XslTransform Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is overridden to force all standard error info to be logged

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected override MessageImportance StandardErrorLoggingImportance { get; }
Visual Basic (Declaration)
Protected Overrides ReadOnly Property StandardErrorLoggingImportance As MessageImportance

See Also

XslTransform Class
SandcastleBuilder.Utils.MSBuild Namespace


StandardOutputLoggingImportance Property

[image]

Sandcastle Help File Builder Documentation
XslTransform..::.StandardOutputLoggingImportance Property
XslTransform Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is overridden to force all standard output info to be logged

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected override MessageImportance StandardOutputLoggingImportance { get; }
Visual Basic (Declaration)
Protected Overrides ReadOnly Property StandardOutputLoggingImportance As MessageImportance

See Also

XslTransform Class
SandcastleBuilder.Utils.MSBuild Namespace


ToolName Property

[image]

Sandcastle Help File Builder Documentation
XslTransform..::.ToolName Property
XslTransform Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns the tool name (XslTransform.exe)

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
protected override string ToolName { get; }
Visual Basic (Declaration)
Protected Overrides ReadOnly Property ToolName As String

See Also

XslTransform Class
SandcastleBuilder.Utils.MSBuild Namespace


Transformations Property

[image]

Sandcastle Help File Builder Documentation
XslTransform..::.Transformations Property
XslTransform Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to pass in the list of transformations to run

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string[] Transformations { get; set; }
Visual Basic (Declaration)
Public Property Transformations As String()

Remarks

Separate multiple transforms with a semi-colon. Relative paths are assumed to refer to Sandcastle transformations and will be fully qualified with the SandcastlePath value. Absolute paths are assumed to be custom transforms and the path is not modified.

See Also

XslTransform Class
SandcastleBuilder.Utils.MSBuild Namespace


WorkingFolder Property

[image]

Sandcastle Help File Builder Documentation
XslTransform..::.WorkingFolder Property
XslTransform Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to pass in the working folder where the files are located.

Namespace: SandcastleBuilder.Utils.MSBuild
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string WorkingFolder { get; set; }
Visual Basic (Declaration)
Public Property WorkingFolder As String

See Also

XslTransform Class
SandcastleBuilder.Utils.MSBuild Namespace


SandcastleBuilder.Utils.PlugIn Namespace

[image]

Sandcastle Help File Builder Documentation
SandcastleBuilder.Utils.PlugIn Namespace
Send Feedback

[This is preliminary documentation and is subject to change.]

This namespace contains the classes used to create plug-ins for use with the Sandcastle Help File Builder build process.

Classes

Class | Description
ExecutionContext | This class defines the execution context in which the plug-in is being called during the build process.
ExecutionPoint | This class defines when a plug-in gets executed during the build process.
ExecutionPointCollection | This collection class holds execution point information for a plug-in process.
PlugInConfiguration | This collection class is used to hold a plug-in's configuration and enabled state.
PlugInConfigurationDictionary | This collection class is used to hold the configurations for third party build process plug-ins such as the AjaxDoc plug-in.
PlugInInfo | This class contains information about the loaded plug-ins
PlugInManager | This class is used to manage the set of known plug-ins.

Interfaces

Interface | Description
IPlugIn | This interface defines the methods required to implement a build process plug-in for the Sandcastle Help File Builder.

Enumerations

Enumeration | Description
ExecutionBehaviors | This public enumerated type defines the execution behavior of a build process plug-in.


ExecutionBehaviors Enumeration

[image]

Sandcastle Help File Builder Documentation
ExecutionBehaviors Enumeration
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This public enumerated type defines the execution behavior of a build process plug-in.

Namespace: SandcastleBuilder.Utils.PlugIn
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
[SerializableAttribute]
[FlagsAttribute]
public enum ExecutionBehaviors
Visual Basic (Declaration)
<SerializableAttribute> _
<FlagsAttribute> _
Public Enumeration ExecutionBehaviors

Members

Member name | Description
Before | Execute before the help file builder's normal processing.
After | Execute after the help file builder's normal processing.
BeforeAndAfter | Execute both before and after the help file builder's normal processing.
InsteadOf | Execute instead of the help file builder's normal processing. If this flag is set, Before and After are ignored.

See Also

SandcastleBuilder.Utils.PlugIn Namespace


ExecutionContext Class

[image]

Sandcastle Help File Builder Documentation
ExecutionContext Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This class defines the execution context in which the plug-in is being called during the build process.

Namespace: SandcastleBuilder.Utils.PlugIn
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public class ExecutionContext
Visual Basic (Declaration)
Public Class ExecutionContext

Inheritance Hierarchy

System..::.Object
SandcastleBuilder.Utils.PlugIn..::.ExecutionContext

See Also

ExecutionContext Members
SandcastleBuilder.Utils.PlugIn Namespace


ExecutionContext Members

[image] [image]

Sandcastle Help File Builder Documentation
ExecutionContext Members
ExecutionContext Class Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ExecutionContext type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Behavior | This read-only property returns the execution behavior for the plug-in in the current context.
BuildStep | This read-only property returns the current build step
Executed | This property is used to set or get whether or not the plug-in actually executed.

See Also

ExecutionContext Class
SandcastleBuilder.Utils.PlugIn Namespace


ExecutionContext Methods

[image] [image]

Sandcastle Help File Builder Documentation
ExecutionContext Methods
ExecutionContext Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ExecutionContext type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExecutionContext Class
SandcastleBuilder.Utils.PlugIn Namespace


ExecutionContext Properties

[image] [image]

Sandcastle Help File Builder Documentation
ExecutionContext Properties
ExecutionContext Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ExecutionContext type exposes the following members.

Properties

Name | Description
Behavior | This read-only property returns the execution behavior for the plug-in in the current context.
BuildStep | This read-only property returns the current build step
Executed | This property is used to set or get whether or not the plug-in actually executed.

See Also

ExecutionContext Class
SandcastleBuilder.Utils.PlugIn Namespace


Behavior Property

[image]

Sandcastle Help File Builder Documentation
ExecutionContext..::.Behavior Property
ExecutionContext Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns the execution behavior for the plug-in in the current context.

Namespace: SandcastleBuilder.Utils.PlugIn
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public ExecutionBehaviors Behavior { get; }
Visual Basic (Declaration)
Public ReadOnly Property Behavior As ExecutionBehaviors

Field Value

Before indicates that it is being called before the normal help file builder processing. After indicates that it is being called after the normal help file builder processing. InsteadOf indicates that it is being called instead of the normal help file builder processing.

See Also

ExecutionContext Class
SandcastleBuilder.Utils.PlugIn Namespace


BuildStep Property

[image]

Sandcastle Help File Builder Documentation
ExecutionContext..::.BuildStep Property
ExecutionContext Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns the current build step

Namespace: SandcastleBuilder.Utils.PlugIn
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public BuildStep BuildStep { get; }
Visual Basic (Declaration)
Public ReadOnly Property BuildStep As BuildStep

See Also

ExecutionContext Class
SandcastleBuilder.Utils.PlugIn Namespace


Executed Property

[image]

Sandcastle Help File Builder Documentation
ExecutionContext..::.Executed Property
ExecutionContext Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This property is used to set or get whether or not the plug-in actually executed.

Namespace: SandcastleBuilder.Utils.PlugIn
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool Executed { get; set; }
Visual Basic (Declaration)
Public Property Executed As Boolean

Field Value

It is true by default. Set it to false if the plug-in did not execute.

See Also

ExecutionContext Class
SandcastleBuilder.Utils.PlugIn Namespace


ExecutionPoint Class

[image]

Sandcastle Help File Builder Documentation
ExecutionPoint Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This class defines when a plug-in gets executed during the build process.

Namespace: SandcastleBuilder.Utils.PlugIn
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public class ExecutionPoint
Visual Basic (Declaration)
Public Class ExecutionPoint

Inheritance Hierarchy

System..::.Object
SandcastleBuilder.Utils.PlugIn..::.ExecutionPoint

See Also

ExecutionPoint Members
SandcastleBuilder.Utils.PlugIn Namespace


ExecutionPoint Members

[image] [image]

Sandcastle Help File Builder Documentation
ExecutionPoint Members
ExecutionPoint Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ExecutionPoint type exposes the following members.

Constructors

Name | Description
ExecutionPoint | Overloaded. There are two overloads for the constructor.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Behavior | This read-only property returns the execution behavior of the plug-in.
BuildStep | This read-only property returns the build step in which the plug-in will run.
Priority | This read-only property returns the execution priority of the plug-in.

See Also

ExecutionPoint Class
SandcastleBuilder.Utils.PlugIn Namespace


ExecutionPoint Constructor

[image] [image]

Sandcastle Help File Builder Documentation
ExecutionPoint Constructor
ExecutionPoint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

There are two overloads for the constructor.

Overload List

Name | Description
ExecutionPoint(BuildStep, ExecutionBehaviors) | Constructor
ExecutionPoint(BuildStep, ExecutionBehaviors, Int32) | This constructor is used to set a specific execution priority.

See Also

ExecutionPoint Class
ExecutionPoint Members
SandcastleBuilder.Utils.PlugIn Namespace


ExecutionPoint Constructor (BuildStep, ExecutionBehaviors)

[image]

Sandcastle Help File Builder Documentation
ExecutionPoint Constructor (BuildStep, ExecutionBehaviors)
ExecutionPoint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: SandcastleBuilder.Utils.PlugIn
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public ExecutionPoint(
    BuildStep plugInBuildStep,
    ExecutionBehaviors plugInBehavior
)
Visual Basic (Declaration)
Public Sub New ( _
    plugInBuildStep As BuildStep, _
    plugInBehavior As ExecutionBehaviors _
)

Parameters

plugInBuildStep
Type: SandcastleBuilder.Utils.BuildEngine..::.BuildStep
The step in which the plug-in should run.
plugInBehavior
Type: SandcastleBuilder.Utils.PlugIn..::.ExecutionBehaviors
The behavior of the plug-in when it is ran.

Exceptions

Exception | Condition
System..::.ArgumentException | This is thrown if an attempt is made to set the Before or After behavior with the InsteadOf behavior. It is also thrown for invalid combinations of build step and behavior, i.e. Initializing with Before or InsteadOf. See the help file for a full list.

See Also

ExecutionPoint Class
ExecutionPoint Overload
SandcastleBuilder.Utils.PlugIn Namespace


ExecutionPoint Constructor (BuildStep, ExecutionBehaviors, Int32)

[image]

Sandcastle Help File Builder Documentation
ExecutionPoint Constructor (BuildStep, ExecutionBehaviors, Int32)
ExecutionPoint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This constructor is used to set a specific execution priority.

Namespace: SandcastleBuilder.Utils.PlugIn
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public ExecutionPoint(
    BuildStep plugInBuildStep,
    ExecutionBehaviors plugInBehavior,
    int plugInPriority
)
Visual Basic (Declaration)
Public Sub New ( _
    plugInBuildStep As BuildStep, _
    plugInBehavior As ExecutionBehaviors, _
    plugInPriority As Integer _
)

Parameters

plugInBuildStep
Type: SandcastleBuilder.Utils.BuildEngine..::.BuildStep
The step in which the plug-in should run.
plugInBehavior
Type: SandcastleBuilder.Utils.PlugIn..::.ExecutionBehaviors
The behavior of the plug-in when it is ran.
plugInPriority
Type: System..::.Int32
The execution priority for the plug-in.

See Also

ExecutionPoint Class
ExecutionPoint Overload
SandcastleBuilder.Utils.PlugIn Namespace


ExecutionPoint Methods

[image] [image]

Sandcastle Help File Builder Documentation
ExecutionPoint Methods
ExecutionPoint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ExecutionPoint type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExecutionPoint Class
SandcastleBuilder.Utils.PlugIn Namespace


ExecutionPoint Properties

[image] [image]

Sandcastle Help File Builder Documentation
ExecutionPoint Properties
ExecutionPoint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ExecutionPoint type exposes the following members.

Properties

Name | Description
Behavior | This read-only property returns the execution behavior of the plug-in.
BuildStep | This read-only property returns the build step in which the plug-in will run.
Priority | This read-only property returns the execution priority of the plug-in.

See Also

ExecutionPoint Class
SandcastleBuilder.Utils.PlugIn Namespace


Behavior Property

[image]

Sandcastle Help File Builder Documentation
ExecutionPoint..::.Behavior Property
ExecutionPoint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns the execution behavior of the plug-in.

Namespace: SandcastleBuilder.Utils.PlugIn
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public ExecutionBehaviors Behavior { get; }
Visual Basic (Declaration)
Public ReadOnly Property Behavior As ExecutionBehaviors

See Also

ExecutionPoint Class
SandcastleBuilder.Utils.PlugIn Namespace


BuildStep Property

[image]

Sandcastle Help File Builder Documentation
ExecutionPoint..::.BuildStep Property
ExecutionPoint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns the build step in which the plug-in will run.

Namespace: SandcastleBuilder.Utils.PlugIn
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public BuildStep BuildStep { get; }
Visual Basic (Declaration)
Public ReadOnly Property BuildStep As BuildStep

See Also

ExecutionPoint Class
SandcastleBuilder.Utils.PlugIn Namespace


Priority Property

[image]

Sandcastle Help File Builder Documentation
ExecutionPoint..::.Priority Property
ExecutionPoint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns the execution priority of the plug-in.

Namespace: SandcastleBuilder.Utils.PlugIn
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public int Priority { get; }
Visual Basic (Declaration)
Public ReadOnly Property Priority As Integer

Field Value

Plug-ins with a higher priority value will execute before those with a lower priority value. If not specified, the default is 1,000.

See Also

ExecutionPoint Class
SandcastleBuilder.Utils.PlugIn Namespace


ExecutionPointCollection Class

[image]

Sandcastle Help File Builder Documentation
ExecutionPointCollection Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This collection class holds execution point information for a plug-in process.

Namespace: SandcastleBuilder.Utils.PlugIn
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public class ExecutionPointCollection : Collection<ExecutionPoint>
Visual Basic (Declaration)
Public Class ExecutionPointCollection _
    Inherits Collection(Of ExecutionPoint)

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection <(Of <( ExecutionPoint >)>)
SandcastleBuilder.Utils.PlugIn..::.ExecutionPointCollection

See Also

ExecutionPointCollection Members
SandcastleBuilder.Utils.PlugIn Namespace


ExecutionPointCollection Members

[image] [image]

Sandcastle Help File Builder Documentation
ExecutionPointCollection Members
ExecutionPointCollection Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ExecutionPointCollection type exposes the following members.

Constructors

Name | Description
ExecutionPointCollection | Initializes a new instance of the ExecutionPointCollection class

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ExecutionPoint >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ExecutionPoint >)>).)
ClearItems | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ExecutionPoint >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ExecutionPoint >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <( ExecutionPoint >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ExecutionPoint >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ExecutionPoint >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( ExecutionPoint >)>).)
InsertItem | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( ExecutionPoint >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PriorityFor | This is used to obtain the execution priority for a plug-in in the given build step and behavior.
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ExecutionPoint >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ExecutionPoint >)>).)
RemoveItem | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ExecutionPoint >)>).)
RunsAt | This is used to determine if the collection contains an entry for the specified build step and behavior.
SetItem | Replaces the element at the specified index. (Inherited from Collection <(Of <( ExecutionPoint >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ExecutionPoint >)>).)
Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <( ExecutionPoint >)>).)
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ExecutionPoint >)>).)

See Also

ExecutionPointCollection Class
SandcastleBuilder.Utils.PlugIn Namespace


ExecutionPointCollection Constructor

[image]

Sandcastle Help File Builder Documentation
ExecutionPointCollection Constructor
ExecutionPointCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ExecutionPointCollection class

Namespace: SandcastleBuilder.Utils.PlugIn
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public ExecutionPointCollection()
Visual Basic (Declaration)
Public Sub New

See Also

ExecutionPointCollection Class
SandcastleBuilder.Utils.PlugIn Namespace


ExecutionPointCollection Methods

[image] [image]

Sandcastle Help File Builder Documentation
ExecutionPointCollection Methods
ExecutionPointCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ExecutionPointCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ExecutionPoint >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ExecutionPoint >)>).)
ClearItems | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ExecutionPoint >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ExecutionPoint >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <( ExecutionPoint >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ExecutionPoint >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ExecutionPoint >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( ExecutionPoint >)>).)
InsertItem | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( ExecutionPoint >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PriorityFor | This is used to obtain the execution priority for a plug-in in the given build step and behavior.
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ExecutionPoint >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ExecutionPoint >)>).)
RemoveItem | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ExecutionPoint >)>).)
RunsAt | This is used to determine if the collection contains an entry for the specified build step and behavior.
SetItem | Replaces the element at the specified index. (Inherited from Collection <(Of <( ExecutionPoint >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExecutionPointCollection Class
SandcastleBuilder.Utils.PlugIn Namespace


PriorityFor Method

[image]

Sandcastle Help File Builder Documentation
ExecutionPointCollection..::.PriorityFor Method
ExecutionPointCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to obtain the execution priority for a plug-in in the given build step and behavior.

Namespace: SandcastleBuilder.Utils.PlugIn
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public int PriorityFor(
    BuildStep step,
    ExecutionBehaviors behavior
)
Visual Basic (Declaration)
Public Function PriorityFor ( _
    step As BuildStep, _
    behavior As ExecutionBehaviors _
) As Integer

Parameters

step
Type: SandcastleBuilder.Utils.BuildEngine..::.BuildStep
The build step
behavior
Type: SandcastleBuilder.Utils.PlugIn..::.ExecutionBehaviors
The behavior

Return Value

The execution priority is used to determine the order in which the plug-ins will be executed. Those with a higher priority value will be executed before those with a lower value. Those with an identical priority may be executed in any order within their group.

See Also

ExecutionPointCollection Class
SandcastleBuilder.Utils.PlugIn Namespace


RunsAt Method

[image]

Sandcastle Help File Builder Documentation
ExecutionPointCollection..::.RunsAt Method
ExecutionPointCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to determine if the collection contains an entry for the specified build step and behavior.

Namespace: SandcastleBuilder.Utils.PlugIn
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool RunsAt(
    BuildStep step,
    ExecutionBehaviors behavior
)
Visual Basic (Declaration)
Public Function RunsAt ( _
    step As BuildStep, _
    behavior As ExecutionBehaviors _
) As Boolean

Parameters

step
Type: SandcastleBuilder.Utils.BuildEngine..::.BuildStep
The build step
behavior
Type: SandcastleBuilder.Utils.PlugIn..::.ExecutionBehaviors
The behavior

Return Value

True if the collection contains an entry for the specified build step and behavior or false if it does not.

See Also

ExecutionPointCollection Class
SandcastleBuilder.Utils.PlugIn Namespace


ExecutionPointCollection Properties

[image] [image]

Sandcastle Help File Builder Documentation
ExecutionPointCollection Properties
ExecutionPointCollection Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ExecutionPointCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ExecutionPoint >)>).)
Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <( ExecutionPoint >)>).)
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( ExecutionPoint >)>).)

See Also

ExecutionPointCollection Class
SandcastleBuilder.Utils.PlugIn Namespace


IPlugIn Interface

[image]

Sandcastle Help File Builder Documentation
IPlugIn Interface
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This interface defines the methods required to implement a build process plug-in for the Sandcastle Help File Builder.

Namespace: SandcastleBuilder.Utils.PlugIn
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public interface IPlugIn : IDisposable
Visual Basic (Declaration)
Public Interface IPlugIn _
    Implements IDisposable

Remarks

Derived classes must also implement the IDisposable methods.

See Also

IPlugIn Members
SandcastleBuilder.Utils.PlugIn Namespace


IPlugIn Members

[image] [image]

Sandcastle Help File Builder Documentation
IPlugIn Members
IPlugIn Interface Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IPlugIn type exposes the following members.

Methods

Name | Description
ConfigurePlugIn | This method is used by the Sandcastle Help File Builder to let the plug-in perform its own configuration.
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Execute | This method is used to execute the plug-in during the build process
Initialize | This method is used to initialize the plug-in at the start of the build process.

Properties

Name | Description
Copyright | This read-only property returns the copyright information for the plug-in.
Description | This read-only property returns a brief description of the plug-in
ExecutionPoints | This read-only property returns a collection of execution points that define when the plug-in should be invoked during the build process.
Name | This read-only property returns a friendly name for the plug-in
RunsInPartialBuild | This read-only property returns true if the plug-in should run in a partial build or false if it should not.
Version | This read-only property returns the version of the plug-in

See Also

IPlugIn Interface
SandcastleBuilder.Utils.PlugIn Namespace


IPlugIn Methods

[image] [image]

Sandcastle Help File Builder Documentation
IPlugIn Methods
IPlugIn Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IPlugIn type exposes the following members.

Methods

Name | Description
ConfigurePlugIn | This method is used by the Sandcastle Help File Builder to let the plug-in perform its own configuration.
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Execute | This method is used to execute the plug-in during the build process
Initialize | This method is used to initialize the plug-in at the start of the build process.

See Also

IPlugIn Interface
SandcastleBuilder.Utils.PlugIn Namespace


ConfigurePlugIn Method

[image]

Sandcastle Help File Builder Documentation
IPlugIn..::.ConfigurePlugIn Method
IPlugIn Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This method is used by the Sandcastle Help File Builder to let the plug-in perform its own configuration.

Namespace: SandcastleBuilder.Utils.PlugIn
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
string ConfigurePlugIn(
    SandcastleProject project,
    string currentConfig
)
Visual Basic (Declaration)
Function ConfigurePlugIn ( _
    project As SandcastleProject, _
    currentConfig As String _
) As String

Parameters

project
Type: SandcastleBuilder.Utils..::.SandcastleProject
A reference to the active project
currentConfig
Type: System..::.String
The current configuration XML fragment

Return Value

A string containing the new configuration XML fragment

Remarks

The configuration data will be stored in the help file builder project.

See Also

IPlugIn Interface
SandcastleBuilder.Utils.PlugIn Namespace


Execute Method

[image]

Sandcastle Help File Builder Documentation
IPlugIn..::.Execute Method
IPlugIn Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This method is used to execute the plug-in during the build process

Namespace: SandcastleBuilder.Utils.PlugIn
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
void Execute(
    ExecutionContext context
)
Visual Basic (Declaration)
Sub Execute ( _
    context As ExecutionContext _
)

Parameters

context
Type: SandcastleBuilder.Utils.PlugIn..::.ExecutionContext
The current execution context

See Also

IPlugIn Interface
SandcastleBuilder.Utils.PlugIn Namespace


Initialize Method

[image]

Sandcastle Help File Builder Documentation
IPlugIn..::.Initialize Method
IPlugIn Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This method is used to initialize the plug-in at the start of the build process.

Namespace: SandcastleBuilder.Utils.PlugIn
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
void Initialize(
    BuildProcess buildProcess,
    XPathNavigator configuration
)
Visual Basic (Declaration)
Sub Initialize ( _
    buildProcess As BuildProcess, _
    configuration As XPathNavigator _
)

Parameters

buildProcess
Type: SandcastleBuilder.Utils.BuildEngine..::.BuildProcess
A reference to the current build process.
configuration
Type: System.Xml.XPath..::.XPathNavigator
The configuration data that the plug-in should use to initialize itself.

See Also

IPlugIn Interface
SandcastleBuilder.Utils.PlugIn Namespace


IPlugIn Properties

[image] [image]

Sandcastle Help File Builder Documentation
IPlugIn Properties
IPlugIn Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IPlugIn type exposes the following members.

Properties

Name | Description
Copyright | This read-only property returns the copyright information for the plug-in.
Description | This read-only property returns a brief description of the plug-in
ExecutionPoints | This read-only property returns a collection of execution points that define when the plug-in should be invoked during the build process.
Name | This read-only property returns a friendly name for the plug-in
RunsInPartialBuild | This read-only property returns true if the plug-in should run in a partial build or false if it should not.
Version | This read-only property returns the version of the plug-in

See Also

IPlugIn Interface
SandcastleBuilder.Utils.PlugIn Namespace


Copyright Property

[image]

Sandcastle Help File Builder Documentation
IPlugIn..::.Copyright Property
IPlugIn Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns the copyright information for the plug-in.

Namespace: SandcastleBuilder.Utils.PlugIn
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
string Copyright { get; }
Visual Basic (Declaration)
ReadOnly Property Copyright As String

See Also

IPlugIn Interface
SandcastleBuilder.Utils.PlugIn Namespace


Description Property

[image]

Sandcastle Help File Builder Documentation
IPlugIn..::.Description Property
IPlugIn Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns a brief description of the plug-in

Namespace: SandcastleBuilder.Utils.PlugIn
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
string Description { get; }
Visual Basic (Declaration)
ReadOnly Property Description As String

See Also

IPlugIn Interface
SandcastleBuilder.Utils.PlugIn Namespace


ExecutionPoints Property

[image]

Sandcastle Help File Builder Documentation
IPlugIn..::.ExecutionPoints Property
IPlugIn Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns a collection of execution points that define when the plug-in should be invoked during the build process.

Namespace: SandcastleBuilder.Utils.PlugIn
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
ExecutionPointCollection ExecutionPoints { get; }
Visual Basic (Declaration)
ReadOnly Property ExecutionPoints As ExecutionPointCollection

See Also

IPlugIn Interface
SandcastleBuilder.Utils.PlugIn Namespace


Name Property

[image]

Sandcastle Help File Builder Documentation
IPlugIn..::.Name Property
IPlugIn Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns a friendly name for the plug-in

Namespace: SandcastleBuilder.Utils.PlugIn
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
string Name { get; }
Visual Basic (Declaration)
ReadOnly Property Name As String

See Also

IPlugIn Interface
SandcastleBuilder.Utils.PlugIn Namespace


RunsInPartialBuild Property

[image]

Sandcastle Help File Builder Documentation
IPlugIn..::.RunsInPartialBuild Property
IPlugIn Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns true if the plug-in should run in a partial build or false if it should not.

Namespace: SandcastleBuilder.Utils.PlugIn
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
bool RunsInPartialBuild { get; }
Visual Basic (Declaration)
ReadOnly Property RunsInPartialBuild As Boolean

Field Value

If this returns false, the plug-in will not be loaded when a partial build is performed.

See Also

IPlugIn Interface
SandcastleBuilder.Utils.PlugIn Namespace


Version Property

[image]

Sandcastle Help File Builder Documentation
IPlugIn..::.Version Property
IPlugIn Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns the version of the plug-in

Namespace: SandcastleBuilder.Utils.PlugIn
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
Version Version { get; }
Visual Basic (Declaration)
ReadOnly Property Version As Version

See Also

IPlugIn Interface
SandcastleBuilder.Utils.PlugIn Namespace


PlugInConfiguration Class

[image]

Sandcastle Help File Builder Documentation
PlugInConfiguration Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This collection class is used to hold a plug-in's configuration and enabled state.

Namespace: SandcastleBuilder.Utils.PlugIn
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public class PlugInConfiguration : PropertyBasedCollectionItem
Visual Basic (Declaration)
Public Class PlugInConfiguration _
    Inherits PropertyBasedCollectionItem

Inheritance Hierarchy

System..::.Object
SandcastleBuilder.Utils..::.PropertyBasedCollectionItem
SandcastleBuilder.Utils.PlugIn..::.PlugInConfiguration

See Also

PlugInConfiguration Members
SandcastleBuilder.Utils.PlugIn Namespace


PlugInConfiguration Members

[image] [image]

Sandcastle Help File Builder Documentation
PlugInConfiguration Members
PlugInConfiguration Class Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PlugInConfiguration type exposes the following members.

Methods

Name | Description
CheckProjectIsEditable | This is used to see if the project can be edited. If not, abort the change by throwing an exception. (Inherited from PropertyBasedCollectionItem.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Configuration | This is used to get or set the plug-in's configuration information
Enabled | This is used to get or set the plug-in's enabled state
IsDirty | This is used to get or set the dirty state of the item (Inherited from PropertyBasedCollectionItem.)
ProjectFile | This is used to get the owning project file (Inherited from PropertyBasedCollectionItem.)

See Also

PlugInConfiguration Class
SandcastleBuilder.Utils.PlugIn Namespace


PlugInConfiguration Methods

[image] [image]

Sandcastle Help File Builder Documentation
PlugInConfiguration Methods
PlugInConfiguration Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PlugInConfiguration type exposes the following members.

Methods

Name | Description
CheckProjectIsEditable | This is used to see if the project can be edited. If not, abort the change by throwing an exception. (Inherited from PropertyBasedCollectionItem.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PlugInConfiguration Class
SandcastleBuilder.Utils.PlugIn Namespace


PlugInConfiguration Properties

[image] [image]

Sandcastle Help File Builder Documentation
PlugInConfiguration Properties
PlugInConfiguration Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PlugInConfiguration type exposes the following members.

Properties

Name | Description
Configuration | This is used to get or set the plug-in's configuration information
Enabled | This is used to get or set the plug-in's enabled state
IsDirty | This is used to get or set the dirty state of the item (Inherited from PropertyBasedCollectionItem.)
ProjectFile | This is used to get the owning project file (Inherited from PropertyBasedCollectionItem.)

See Also

PlugInConfiguration Class
SandcastleBuilder.Utils.PlugIn Namespace


Configuration Property

[image]

Sandcastle Help File Builder Documentation
PlugInConfiguration..::.Configuration Property
PlugInConfiguration Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set the plug-in's configuration information

Namespace: SandcastleBuilder.Utils.PlugIn
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string Configuration { get; set; }
Visual Basic (Declaration)
Public Property Configuration As String

Field Value

This should be an XML fragment. The root node should be named configuration.

See Also

PlugInConfiguration Class
SandcastleBuilder.Utils.PlugIn Namespace


Enabled Property

[image]

Sandcastle Help File Builder Documentation
PlugInConfiguration..::.Enabled Property
PlugInConfiguration Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set the plug-in's enabled state

Namespace: SandcastleBuilder.Utils.PlugIn
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool Enabled { get; set; }
Visual Basic (Declaration)
Public Property Enabled As Boolean

Field Value

If set to false, the plug-in will not be used in the build

See Also

PlugInConfiguration Class
SandcastleBuilder.Utils.PlugIn Namespace


PlugInConfigurationDictionary Class

[image]

Sandcastle Help File Builder Documentation
PlugInConfigurationDictionary Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This collection class is used to hold the configurations for third party build process plug-ins such as the AjaxDoc plug-in.

Namespace: SandcastleBuilder.Utils.PlugIn
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
[SerializableAttribute]
public class PlugInConfigurationDictionary : Dictionary<string, PlugInConfiguration>
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class PlugInConfigurationDictionary _
    Inherits Dictionary(Of String, PlugInConfiguration)

Inheritance Hierarchy

System..::.Object
System.Collections.Generic..::.Dictionary <(Of <( String, PlugInConfiguration >)>)
SandcastleBuilder.Utils.PlugIn..::.PlugInConfigurationDictionary

See Also

PlugInConfigurationDictionary Members
SandcastleBuilder.Utils.PlugIn Namespace


PlugInConfigurationDictionary Members

[image] [image]

Sandcastle Help File Builder Documentation
PlugInConfigurationDictionary Members
PlugInConfigurationDictionary Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PlugInConfigurationDictionary type exposes the following members.

Constructors

Name | Description
PlugInConfigurationDictionary | Default constructor

Methods

Name | Description
Add | Overloaded.
Clear | Removes all keys and values from the Dictionary<(Of <(TKey, TValue>)>). (Inherited from Dictionary <(Of <( String, PlugInConfiguration >)>).)
ContainsKey | Determines whether the Dictionary<(Of <(TKey, TValue>)>) contains the specified key. (Inherited from Dictionary <(Of <( String, PlugInConfiguration >)>).)
ContainsValue | Determines whether the Dictionary<(Of <(TKey, TValue>)>) contains a specific value. (Inherited from Dictionary <(Of <( String, PlugInConfiguration >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(TKey, TValue>)>). (Inherited from Dictionary <(Of <( String, PlugInConfiguration >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(TKey, TValue>)>) instance. (Inherited from Dictionary <(Of <( String, PlugInConfiguration >)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <( String, PlugInConfiguration >)>).)
Remove | Removes the value with the specified key from the Dictionary<(Of <(TKey, TValue>)>). (Inherited from Dictionary <(Of <( String, PlugInConfiguration >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <( String, PlugInConfiguration >)>).)

Properties

Name | Description
Comparer | Gets the IEqualityComparer<(Of <(T>)>) that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <( String, PlugInConfiguration >)>).)
Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(TKey, TValue>)>). (Inherited from Dictionary <(Of <( String, PlugInConfiguration >)>).)
IsDirty | This is used to get or set the dirty state of the collection
Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <( String, PlugInConfiguration >)>).)
Keys | Gets a collection containing the keys in the Dictionary<(Of <(TKey, TValue>)>). (Inherited from Dictionary <(Of <( String, PlugInConfiguration >)>).)
ProjectFile | This returns a reference to the owning project file
Values | Gets a collection containing the values in the Dictionary<(Of <(TKey, TValue>)>). (Inherited from Dictionary <(Of <( String, PlugInConfiguration >)>).)

Events

Name | Description
DictionaryChanged | This event is raised when the dictionary is modified

See Also

PlugInConfigurationDictionary Class
SandcastleBuilder.Utils.PlugIn Namespace


PlugInConfigurationDictionary Constructor

[image]

Sandcastle Help File Builder Documentation
PlugInConfigurationDictionary Constructor
PlugInConfigurationDictionary Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Default constructor

Namespace: SandcastleBuilder.Utils.PlugIn
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public PlugInConfigurationDictionary(
    SandcastleProject project
)
Visual Basic (Declaration)
Public Sub New ( _
    project As SandcastleProject _
)

Parameters

project
Type: SandcastleBuilder.Utils..::.SandcastleProject
The project that owns the collection

See Also

PlugInConfigurationDictionary Class
SandcastleBuilder.Utils.PlugIn Namespace


PlugInConfigurationDictionary Methods

[image] [image]

Sandcastle Help File Builder Documentation
PlugInConfigurationDictionary Methods
PlugInConfigurationDictionary Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PlugInConfigurationDictionary type exposes the following members.

Methods

Name | Description
Add | Overloaded.
Clear | Removes all keys and values from the Dictionary<(Of <(TKey, TValue>)>). (Inherited from Dictionary <(Of <( String, PlugInConfiguration >)>).)
ContainsKey | Determines whether the Dictionary<(Of <(TKey, TValue>)>) contains the specified key. (Inherited from Dictionary <(Of <( String, PlugInConfiguration >)>).)
ContainsValue | Determines whether the Dictionary<(Of <(TKey, TValue>)>) contains a specific value. (Inherited from Dictionary <(Of <( String, PlugInConfiguration >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(TKey, TValue>)>). (Inherited from Dictionary <(Of <( String, PlugInConfiguration >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(TKey, TValue>)>) instance. (Inherited from Dictionary <(Of <( String, PlugInConfiguration >)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <( String, PlugInConfiguration >)>).)
Remove | Removes the value with the specified key from the Dictionary<(Of <(TKey, TValue>)>). (Inherited from Dictionary <(Of <( String, PlugInConfiguration >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <( String, PlugInConfiguration >)>).)

See Also

PlugInConfigurationDictionary Class
SandcastleBuilder.Utils.PlugIn Namespace


Add Method

[image] [image]

Sandcastle Help File Builder Documentation
PlugInConfigurationDictionary..::.Add Method
PlugInConfigurationDictionary Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Add(TKey, TValue) | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <( String, PlugInConfiguration >)>).)
Add(String, Boolean, String) | Add a new item to the dictionary

See Also

PlugInConfigurationDictionary Class
PlugInConfigurationDictionary Members
SandcastleBuilder.Utils.PlugIn Namespace


Add Method (String, Boolean, String)

[image]

Sandcastle Help File Builder Documentation
PlugInConfigurationDictionary..::.Add Method (String, Boolean, String)
PlugInConfigurationDictionary Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Add a new item to the dictionary

Namespace: SandcastleBuilder.Utils.PlugIn
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public PlugInConfiguration Add(
    string id,
    bool enabled,
    string config
)
Visual Basic (Declaration)
Public Function Add ( _
    id As String, _
    enabled As Boolean, _
    config As String _
) As PlugInConfiguration

Parameters

id
Type: System..::.String
The plug-in ID
enabled
Type: System..::.Boolean
True for enabled, false disabled
config
Type: System..::.String
The plug-in configuration

Return Value

The PlugInConfiguration added to the project. If the ID already exists in the collection, the existing item is returned.

Remarks

The PlugInConfiguration constructor is internal so that we control creation of the items and can associate them with the project.

See Also

PlugInConfigurationDictionary Class
Add Overload
SandcastleBuilder.Utils.PlugIn Namespace


PlugInConfigurationDictionary Properties

[image] [image]

Sandcastle Help File Builder Documentation
PlugInConfigurationDictionary Properties
PlugInConfigurationDictionary Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PlugInConfigurationDictionary type exposes the following members.

Properties

Name | Description
Comparer | Gets the IEqualityComparer<(Of <(T>)>) that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <( String, PlugInConfiguration >)>).)
Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(TKey, TValue>)>). (Inherited from Dictionary <(Of <( String, PlugInConfiguration >)>).)
IsDirty | This is used to get or set the dirty state of the collection
Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <( String, PlugInConfiguration >)>).)
Keys | Gets a collection containing the keys in the Dictionary<(Of <(TKey, TValue>)>). (Inherited from Dictionary <(Of <( String, PlugInConfiguration >)>).)
ProjectFile | This returns a reference to the owning project file
Values | Gets a collection containing the values in the Dictionary<(Of <(TKey, TValue>)>). (Inherited from Dictionary <(Of <( String, PlugInConfiguration >)>).)

See Also

PlugInConfigurationDictionary Class
SandcastleBuilder.Utils.PlugIn Namespace


IsDirty Property

[image]

Sandcastle Help File Builder Documentation
PlugInConfigurationDictionary..::.IsDirty Property
PlugInConfigurationDictionary Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to get or set the dirty state of the collection

Namespace: SandcastleBuilder.Utils.PlugIn
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public bool IsDirty { get; set; }
Visual Basic (Declaration)
Public Property IsDirty As Boolean

See Also

PlugInConfigurationDictionary Class
SandcastleBuilder.Utils.PlugIn Namespace


ProjectFile Property

[image]

Sandcastle Help File Builder Documentation
PlugInConfigurationDictionary..::.ProjectFile Property
PlugInConfigurationDictionary Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This returns a reference to the owning project file

Namespace: SandcastleBuilder.Utils.PlugIn
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public SandcastleProject ProjectFile { get; }
Visual Basic (Declaration)
Public ReadOnly Property ProjectFile As SandcastleProject

See Also

PlugInConfigurationDictionary Class
SandcastleBuilder.Utils.PlugIn Namespace


PlugInConfigurationDictionary Events

[image] [image]

Sandcastle Help File Builder Documentation
PlugInConfigurationDictionary Events
PlugInConfigurationDictionary Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PlugInConfigurationDictionary type exposes the following members.

Events

Name | Description
DictionaryChanged | This event is raised when the dictionary is modified

See Also

PlugInConfigurationDictionary Class
SandcastleBuilder.Utils.PlugIn Namespace


DictionaryChanged Event

[image]

Sandcastle Help File Builder Documentation
PlugInConfigurationDictionary..::.DictionaryChanged Event
PlugInConfigurationDictionary Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This event is raised when the dictionary is modified

Namespace: SandcastleBuilder.Utils.PlugIn
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public event ListChangedEventHandler DictionaryChanged
Visual Basic (Declaration)
Public Event DictionaryChanged As ListChangedEventHandler

See Also

PlugInConfigurationDictionary Class
SandcastleBuilder.Utils.PlugIn Namespace


PlugInInfo Class

[image]

Sandcastle Help File Builder Documentation
PlugInInfo Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This class contains information about the loaded plug-ins

Namespace: SandcastleBuilder.Utils.PlugIn
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public class PlugInInfo
Visual Basic (Declaration)
Public Class PlugInInfo

Inheritance Hierarchy

System..::.Object
SandcastleBuilder.Utils.PlugIn..::.PlugInInfo

See Also

PlugInInfo Members
SandcastleBuilder.Utils.PlugIn Namespace


PlugInInfo Members

[image] [image]

Sandcastle Help File Builder Documentation
PlugInInfo Members
PlugInInfo Class Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PlugInInfo type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NewInstance | Get a new instance of the plug-in
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Copyright | This read-only property returns the copyright information for the plug-in.
Description | This read-only property returns a description of the plug-in
Name | This read-only property returns the name of the plug-in
PlugInType | This read-only property returns type information for the plug-in
Version | This read-only property returns the version number of the plug-in

See Also

PlugInInfo Class
SandcastleBuilder.Utils.PlugIn Namespace


PlugInInfo Methods

[image] [image]

Sandcastle Help File Builder Documentation
PlugInInfo Methods
PlugInInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PlugInInfo type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NewInstance | Get a new instance of the plug-in
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PlugInInfo Class
SandcastleBuilder.Utils.PlugIn Namespace


NewInstance Method

[image]

Sandcastle Help File Builder Documentation
PlugInInfo..::.NewInstance Method
PlugInInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Get a new instance of the plug-in

Namespace: SandcastleBuilder.Utils.PlugIn
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public IPlugIn NewInstance()
Visual Basic (Declaration)
Public Function NewInstance As IPlugIn

Return Value

A new instance of the plug-in

See Also

PlugInInfo Class
SandcastleBuilder.Utils.PlugIn Namespace


PlugInInfo Properties

[image] [image]

Sandcastle Help File Builder Documentation
PlugInInfo Properties
PlugInInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PlugInInfo type exposes the following members.

Properties

Name | Description
Copyright | This read-only property returns the copyright information for the plug-in.
Description | This read-only property returns a description of the plug-in
Name | This read-only property returns the name of the plug-in
PlugInType | This read-only property returns type information for the plug-in
Version | This read-only property returns the version number of the plug-in

See Also

PlugInInfo Class
SandcastleBuilder.Utils.PlugIn Namespace


Copyright Property

[image]

Sandcastle Help File Builder Documentation
PlugInInfo..::.Copyright Property
PlugInInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns the copyright information for the plug-in.

Namespace: SandcastleBuilder.Utils.PlugIn
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string Copyright { get; }
Visual Basic (Declaration)
Public ReadOnly Property Copyright As String

See Also

PlugInInfo Class
SandcastleBuilder.Utils.PlugIn Namespace


Description Property

[image]

Sandcastle Help File Builder Documentation
PlugInInfo..::.Description Property
PlugInInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns a description of the plug-in

Namespace: SandcastleBuilder.Utils.PlugIn
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string Description { get; }
Visual Basic (Declaration)
Public ReadOnly Property Description As String

See Also

PlugInInfo Class
SandcastleBuilder.Utils.PlugIn Namespace


Name Property

[image]

Sandcastle Help File Builder Documentation
PlugInInfo..::.Name Property
PlugInInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns the name of the plug-in

Namespace: SandcastleBuilder.Utils.PlugIn
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String

See Also

PlugInInfo Class
SandcastleBuilder.Utils.PlugIn Namespace


PlugInType Property

[image]

Sandcastle Help File Builder Documentation
PlugInInfo..::.PlugInType Property
PlugInInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns type information for the plug-in

Namespace: SandcastleBuilder.Utils.PlugIn
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public Type PlugInType { get; }
Visual Basic (Declaration)
Public ReadOnly Property PlugInType As Type

See Also

PlugInInfo Class
SandcastleBuilder.Utils.PlugIn Namespace


Version Property

[image]

Sandcastle Help File Builder Documentation
PlugInInfo..::.Version Property
PlugInInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This read-only property returns the version number of the plug-in

Namespace: SandcastleBuilder.Utils.PlugIn
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public Version Version { get; }
Visual Basic (Declaration)
Public ReadOnly Property Version As Version

See Also

PlugInInfo Class
SandcastleBuilder.Utils.PlugIn Namespace


PlugInManager Class

[image]

Sandcastle Help File Builder Documentation
PlugInManager Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This class is used to manage the set of known plug-ins.

Namespace: SandcastleBuilder.Utils.PlugIn
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public static class PlugInManager
Visual Basic (Declaration)
Public NotInheritable Class PlugInManager

Inheritance Hierarchy

System..::.Object
SandcastleBuilder.Utils.PlugIn..::.PlugInManager

See Also

PlugInManager Members
SandcastleBuilder.Utils.PlugIn Namespace


PlugInManager Members

[image] [image]

Sandcastle Help File Builder Documentation
PlugInManager Members
PlugInManager Class Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PlugInManager type exposes the following members.

Methods

Name | Description
IsSupported | This is used to determine if a plug-in exists with the specified key and can be used.

Properties

Name | Description
PlugIns | This returns a dictionary containing the loaded plug-ins.

See Also

PlugInManager Class
SandcastleBuilder.Utils.PlugIn Namespace


PlugInManager Methods

[image] [image]

Sandcastle Help File Builder Documentation
PlugInManager Methods
PlugInManager Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PlugInManager type exposes the following members.

Methods

Name | Description
IsSupported | This is used to determine if a plug-in exists with the specified key and can be used.

See Also

PlugInManager Class
SandcastleBuilder.Utils.PlugIn Namespace


IsSupported Method

[image]

Sandcastle Help File Builder Documentation
PlugInManager..::.IsSupported Method
PlugInManager Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is used to determine if a plug-in exists with the specified key and can be used.

Namespace: SandcastleBuilder.Utils.PlugIn
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public static bool IsSupported(
    string key
)
Visual Basic (Declaration)
Public Shared Function IsSupported ( _
    key As String _
) As Boolean

Parameters

key
Type: System..::.String
The key for the plug-in

Return Value

True if the plug-in exits and can be used.

See Also

PlugInManager Class
SandcastleBuilder.Utils.PlugIn Namespace


PlugInManager Properties

[image] [image]

Sandcastle Help File Builder Documentation
PlugInManager Properties
PlugInManager Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PlugInManager type exposes the following members.

Properties

Name | Description
PlugIns | This returns a dictionary containing the loaded plug-ins.

See Also

PlugInManager Class
SandcastleBuilder.Utils.PlugIn Namespace


PlugIns Property

[image]

Sandcastle Help File Builder Documentation
PlugInManager..::.PlugIns Property
PlugInManager Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This returns a dictionary containing the loaded plug-ins.

Namespace: SandcastleBuilder.Utils.PlugIn
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public static Dictionary<string, PlugInInfo> PlugIns { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property PlugIns As Dictionary(Of String, PlugInInfo)

Field Value

The dictionary keys are the plug-in names.

See Also

PlugInManager Class
SandcastleBuilder.Utils.PlugIn Namespace


SandcastleBuilder.Utils.XPath Namespace

[image]

Sandcastle Help File Builder Documentation
SandcastleBuilder.Utils.XPath Namespace
Send Feedback

[This is preliminary documentation and is subject to change.]

This namespace contains some classes that extend XPath queries with some custom functions used in the API filter editor.

Classes

Class | Description
XPathFunctionContext | This class is used to provide a custom regular expression search function to XPath queries using an XSLT context.


XPathFunctionContext Class

[image]

Sandcastle Help File Builder Documentation
XPathFunctionContext Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This class is used to provide a custom regular expression search function to XPath queries using an XSLT context.

Namespace: SandcastleBuilder.Utils.XPath
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public class XPathFunctionContext : XsltContext
Visual Basic (Declaration)
Public Class XPathFunctionContext _
    Inherits XsltContext

Inheritance Hierarchy

System..::.Object
System.Xml..::.XmlNamespaceManager
System.Xml.Xsl..::.XsltContext
SandcastleBuilder.Utils.XPath..::.XPathFunctionContext

See Also

XPathFunctionContext Members
SandcastleBuilder.Utils.XPath Namespace


XPathFunctionContext Members

[image] [image]

Sandcastle Help File Builder Documentation
XPathFunctionContext Members
XPathFunctionContext Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The XPathFunctionContext type exposes the following members.

Constructors

Name | Description
XPathFunctionContext | Initializes a new instance of the XPathFunctionContext class

Methods

Name | Description
AddNamespace | Adds the given namespace to the collection. (Inherited from XmlNamespaceManager.)
CompareDocument | This is not used by this class. (Overrides XsltContext..::.CompareDocument(String, String).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator to use to iterate through the namespaces in the XmlNamespaceManager. (Inherited from XmlNamespaceManager.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetNamespacesInScope | Gets a collection of namespace names keyed by prefix which can be used to enumerate the namespaces currently in scope. (Inherited from XmlNamespaceManager.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasNamespace | Gets a value indicating whether the supplied prefix has a namespace defined for the current pushed scope. (Inherited from XmlNamespaceManager.)
LookupNamespace | Gets the namespace URI for the specified prefix. (Inherited from XmlNamespaceManager.)
LookupPrefix | Finds the prefix declared for the given namespace URI. (Inherited from XmlNamespaceManager.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PopScope | Pops a namespace scope off the stack. (Inherited from XmlNamespaceManager.)
PreserveWhitespace | This is not used by this class. (Overrides XsltContext..::.PreserveWhitespace(XPathNavigator).)
PushScope | Pushes a namespace scope onto the stack. (Inherited from XmlNamespaceManager.)
RemoveNamespace | Removes the given namespace for the given prefix. (Inherited from XmlNamespaceManager.)
ResolveFunction | Resolves a function reference and return an IXsltContextFunction representing the function. The IXsltContextFunction is used at execution time to get the return value of the function. (Overrides XsltContext..::.ResolveFunction(String, String, array<XPathResultType>[]()[]).)
ResolveVariable | This is not used by this class. (Overrides XsltContext..::.ResolveVariable(String, String).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DefaultNamespace | Gets the namespace URI for the default namespace. (Inherited from XmlNamespaceManager.)
NameTable | Gets the XmlNameTable associated with this object. (Inherited from XmlNamespaceManager.)
Whitespace | This is not used by this class. (Overrides XsltContext..::.Whitespace.)

See Also

XPathFunctionContext Class
SandcastleBuilder.Utils.XPath Namespace


XPathFunctionContext Constructor

[image]

Sandcastle Help File Builder Documentation
XPathFunctionContext Constructor
XPathFunctionContext Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the XPathFunctionContext class

Namespace: SandcastleBuilder.Utils.XPath
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public XPathFunctionContext()
Visual Basic (Declaration)
Public Sub New

See Also

XPathFunctionContext Class
SandcastleBuilder.Utils.XPath Namespace


XPathFunctionContext Methods

[image] [image]

Sandcastle Help File Builder Documentation
XPathFunctionContext Methods
XPathFunctionContext Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The XPathFunctionContext type exposes the following members.

Methods

Name | Description
AddNamespace | Adds the given namespace to the collection. (Inherited from XmlNamespaceManager.)
CompareDocument | This is not used by this class. (Overrides XsltContext..::.CompareDocument(String, String).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator to use to iterate through the namespaces in the XmlNamespaceManager. (Inherited from XmlNamespaceManager.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetNamespacesInScope | Gets a collection of namespace names keyed by prefix which can be used to enumerate the namespaces currently in scope. (Inherited from XmlNamespaceManager.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasNamespace | Gets a value indicating whether the supplied prefix has a namespace defined for the current pushed scope. (Inherited from XmlNamespaceManager.)
LookupNamespace | Gets the namespace URI for the specified prefix. (Inherited from XmlNamespaceManager.)
LookupPrefix | Finds the prefix declared for the given namespace URI. (Inherited from XmlNamespaceManager.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PopScope | Pops a namespace scope off the stack. (Inherited from XmlNamespaceManager.)
PreserveWhitespace | This is not used by this class. (Overrides XsltContext..::.PreserveWhitespace(XPathNavigator).)
PushScope | Pushes a namespace scope onto the stack. (Inherited from XmlNamespaceManager.)
RemoveNamespace | Removes the given namespace for the given prefix. (Inherited from XmlNamespaceManager.)
ResolveFunction | Resolves a function reference and return an IXsltContextFunction representing the function. The IXsltContextFunction is used at execution time to get the return value of the function. (Overrides XsltContext..::.ResolveFunction(String, String, array<XPathResultType>[]()[]).)
ResolveVariable | This is not used by this class. (Overrides XsltContext..::.ResolveVariable(String, String).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

XPathFunctionContext Class
SandcastleBuilder.Utils.XPath Namespace


CompareDocument Method

[image]

Sandcastle Help File Builder Documentation
XPathFunctionContext..::.CompareDocument Method
XPathFunctionContext Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is not used by this class.

Namespace: SandcastleBuilder.Utils.XPath
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public override int CompareDocument(
    string baseUri,
    string nextbaseUri
)
Visual Basic (Declaration)
Public Overrides Function CompareDocument ( _
    baseUri As String, _
    nextbaseUri As String _
) As Integer

Parameters

baseUri
Type: System..::.String
The base URI of the first document to compare
nextbaseUri
Type: System..::.String
The base URI of the second document to compare

Return Value

Always returns zero (equal).

See Also

XPathFunctionContext Class
SandcastleBuilder.Utils.XPath Namespace


PreserveWhitespace Method

[image]

Sandcastle Help File Builder Documentation
XPathFunctionContext..::.PreserveWhitespace Method
XPathFunctionContext Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is not used by this class.

Namespace: SandcastleBuilder.Utils.XPath
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public override bool PreserveWhitespace(
    XPathNavigator node
)
Visual Basic (Declaration)
Public Overrides Function PreserveWhitespace ( _
    node As XPathNavigator _
) As Boolean

Parameters

node
Type: System.Xml.XPath..::.XPathNavigator
The whitespace node to preserve or strip

Return Value

For this class, this always returns true to preserve whitespace.

See Also

XPathFunctionContext Class
SandcastleBuilder.Utils.XPath Namespace


ResolveFunction Method

[image]

Sandcastle Help File Builder Documentation
XPathFunctionContext..::.ResolveFunction Method
XPathFunctionContext Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Resolves a function reference and return an IXsltContextFunction representing the function. The IXsltContextFunction is used at execution time to get the return value of the function.

Namespace: SandcastleBuilder.Utils.XPath
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public override IXsltContextFunction ResolveFunction(
    string prefix,
    string name,
    XPathResultType[] ArgTypes
)
Visual Basic (Declaration)
Public Overrides Function ResolveFunction ( _
    prefix As String, _
    name As String, _
    ArgTypes As XPathResultType() _
) As IXsltContextFunction

Parameters

prefix
Type: System..::.String
The prefix of the function as it appears in the XPath expression
name
Type: System..::.String
The name of the function
ArgTypes
Type: array< System.Xml.XPath..::.XPathResultType >[]()[]
An array of argument types for the function being resolved. This allows you to select between methods with the same name (for example, overloaded methods).

Return Value

An IXsltContextFunction representing the function

See Also

XPathFunctionContext Class
SandcastleBuilder.Utils.XPath Namespace


ResolveVariable Method

[image]

Sandcastle Help File Builder Documentation
XPathFunctionContext..::.ResolveVariable Method
XPathFunctionContext Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is not used by this class.

Namespace: SandcastleBuilder.Utils.XPath
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public override IXsltContextVariable ResolveVariable(
    string prefix,
    string name
)
Visual Basic (Declaration)
Public Overrides Function ResolveVariable ( _
    prefix As String, _
    name As String _
) As IXsltContextVariable

Parameters

prefix
Type: System..::.String
The prefix of the variable as it appears in the expression
name
Type: System..::.String
The name of the variable

Return Value

Always returns null

See Also

XPathFunctionContext Class
SandcastleBuilder.Utils.XPath Namespace


XPathFunctionContext Properties

[image] [image]

Sandcastle Help File Builder Documentation
XPathFunctionContext Properties
XPathFunctionContext Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The XPathFunctionContext type exposes the following members.

Properties

Name | Description
DefaultNamespace | Gets the namespace URI for the default namespace. (Inherited from XmlNamespaceManager.)
NameTable | Gets the XmlNameTable associated with this object. (Inherited from XmlNamespaceManager.)
Whitespace | This is not used by this class. (Overrides XsltContext..::.Whitespace.)

See Also

XPathFunctionContext Class
SandcastleBuilder.Utils.XPath Namespace


Whitespace Property

[image]

Sandcastle Help File Builder Documentation
XPathFunctionContext..::.Whitespace Property
XPathFunctionContext Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This is not used by this class.

Namespace: SandcastleBuilder.Utils.XPath
Assembly: SandcastleBuilder.Utils (in SandcastleBuilder.Utils.dll) Version: 1.8.0.2

Syntax

C#
public override bool Whitespace { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Whitespace As Boolean

Field Value

Always returns true to include whitespace in the output

See Also

XPathFunctionContext Class
SandcastleBuilder.Utils.XPath Namespace