MSBuild Community Tasks Project

The MSBuild Community Tasks Project

Mission

The MSBuild Community Tasks Project is an open source project for MSBuild tasks. The goal of the project is to provide a collection of open source tasks for MSBuild.

Join Project

Please join the MSBuild Community Tasks Project and help contribute in building the tasks.

http://msbuildtasks.tigris.org/

Current Community Tasks

Task | Description
AppPoolController | Allows control for an application pool on a local or remote machine with IIS installed.
AppPoolCreate | Creates a new application pool on a local or remote machine.
AppPoolDelete | Deletes an existing application pool on a local or remote machine.
AssemblyInfo | Generates an AssemblyInfo file using the attributes given.
Attrib | Changes the attributes of files and/or directories
ExecuteDDL | Executes SqlServer batch scripts.
FileUpdate | Replace text in file(s) using a Regular Expression.
FtpUpload | Uploads a file using File Transfer Protocol (FTP).
FxCop | Uses FxCop to analyze managed code assemblies and reports on their design best-practice compliance.
GetSolutionProjects | Returns a list of projects within a solution
InstallAspNet | Installs and register script mappings for ASP.NET
InstallAssembly | Uses InstallUtil.exe to execute the Install method on Installer classes within assemblies.
JSCompress | Compresses JavaScript source files by removing comments and unnecessary whitespace, which typically reduces the size by half and results in faster downloads and code that is harder to read.
Mail | Sends an email message.
Math.Add | Add numbers.
Math.Divide | Divide numbers.
Math.Modulo | Performs the modulo operation on numbers.
Math.Multiple | Multiple numbers.
Math.Subtract | Subtract numbers.
Move | Moves files on the filesystem to a new location.
NDoc | Runs NDoc to create documentation.
NUnit | Runs tests using the NUnit.
Prompt | Displays a message on the console and waits for user input.
RegexMatch | Filters an item group with a regular expression
RegexReplace | Replaces strings within items from an item group with a regular expression
RegistryRead | Reads a value from the Registry.
RegistryWrite | Writes a value to the Registry.
Script | Executes code contained within the task.
ServiceController | Task that can control a Windows service.
ServiceQuery | Task that can determine the status of a service.
Sleep | A task for sleeping for a specified period of time.
SqlExecute | Executes a SQL command
SvnCheckout | Checkout files from Subversion
SvnClient | Subversion Client
SvnCommit | Commit files to Subversion
SvnCopy | Copies a file or path within Subversion
SvnExport | Export files from Subversion
SvnInfo | Get Subversion information for a file or directory.
SvnUpdate | Update files from Subversion
SvnVersion | Get Subversion revision number of a local copy
TaskSchema | Generates a XSD schema of the MSBuild tasks in an assembly.
TemplateFile | Replaces tokens in a file.
TfsVersion | Determines the changeset in a local Team Foundation Server workspace (In progress)
Time | Gets the current date and time.
UninstallAssembly | Uses InstallUtil.exe to execute the Uninstall method on Installer classes within assemblies.
Unzip | Unzip a file to a target directory.
Version | Generates version information based on various algorithms
VssAdd | Adds files to a Visual SourceSafe database.
VssCheckin | Checks in files to a Visual SourceSafe database.
VssCheckout | Checks out files from a Visual SourceSafe database.
VssClean | Removes Visual SourceSafe binding information and status files from a Visual Studio solution tree.
VssDiff | Generates a diff between two versions of an item in a Visual SourceSafe database.
VssGet | Gets the latest version of a file or project from a Visual SourceSafe database.
VssHistory | Generates an XML file containing the history of an item in a Visual SourceSafe database between two dates or labels.
VssLabel | Labels an item in a Visual SourceSafe database.
VssUndoCheckout | Cancels a checkout of an item from a Visual SourceSafe database.
WebDirectoryCreate | Creates a new web directory on a local or remote machine.
WebDirectoryDelete | Deletes a web directory on a local or remote machine
WebDirectoryScriptMap | Sets an application mapping for a filename extension on an existing web directory.
WebDirectorySetting | Reads or modifies a configuration setting on an existing web directory
WebDownload | Downloads a resource with the specified URI to a local file.
Xml.XmlMassUpdate | Performs multiple updates on an XML file
Xml.XmlQuery | Reads a value or values from lines of XML
XmlRead | Reads a value from a XML document using a XPath.
XmlWrite | Updates a XML document using a XPath.
Xslt | Merge and transform a set of xml files.
Zip | Create a zip file with the files specified.

Getting Started

In order to use the tasks in this project, you need to import the MSBuild.Community.Tasks.Targets files. If you installed the project with the msi installer, you can use the following.

<Import Project="$(MSBuildExtensionsPath)\MSBuildCommunityTasks\MSBuild.Community.Tasks.Targets"/>

Related resources

  • MSBuild Community Tasks - http://msbuildtasks.tigris.org/
  • MSBuild Tasks - http://msbuildtasks.com/default.aspx
  • MSBuild Team Blog - http://blogs.msdn.com/msbuild/default.aspx
  • MSBuild Reference - http://msdn2.microsoft.com/en-us/library/0k6kkbsd.aspx

License

Copyright © 2005-2007 Paul Welter. All rights reserved.

Redistribution and use in source and binary forms, with or without
modification, are permitted provided that the following conditions
are met:

1. Redistributions of source code must retain the above copyright
   notice, this list of conditions and the following disclaimer.
2. Redistributions in binary form must reproduce the above copyright
   notice, this list of conditions and the following disclaimer in the
   documentation and/or other materials provided with the distribution.
3. The name of the author may not be used to endorse or promote products
   derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR
IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES
OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.
IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT,
INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT
NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF
THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.


MSBuild.Community.Tasks
MSBuild.Community.Tasks Namespace
See Also Hierarchy

Tasks for MSBuild

Classes

 | Class | Description
Public class | AssemblyInfo | Generates an AssemblyInfo files
Public class | Attrib | Changes the attributes of files and/or directories
Public class | FileUpdate | Replace text in file(s) using a Regular Expression.
Public class | FtpUpload | Uploads a file using File Transfer Protocol (FTP).
Public class | FxCop | Uses FxCop to analyse managed code assemblies and reports on their design best-practice compliance.
Public class | GacUtil | MSBuild task to install and uninstall asseblies into the GAC
Public class | GetSolutionProjects | Task to get paths to projects and project names from VS2005 solution file
Public class | ILMerge | A wrapper for the ILMerge tool.
Public class | Mail | Sends an email message
Public class | Move | Moves files on the filesystem to a new location.
Public class | NDoc | Runs the NDoc application.
Public class | NUnit | Run NUnit on a group of assemblies.
Public class | Prompt | Displays a message on the console and waits for user input.
Public class | RegexBase | Base class for Regex tasks Handles public properties for Input, Expression, Options and Output This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | RegexMatch | Task to filter an Input list with a Regex expression. Output list contains items from Input list that matched given expression
Public class | RegexReplace | Task to replace portions of strings within the Input list Output list contains all the elements of the Input list after performing the Regex Replace.
Public class | RegistryRead | Reads a value from the Registry
Public class | RegistryWrite | Writes a value to the Registry
Public class | Script | Executes code contained within the task.
Public class | ServiceController | Task that can control a Windows service.
Public class | ServiceQuery | Task that can determine the status of a specified service on a target server.
Public class | Sleep | A task for sleeping for a specified period of time.
Public class | SqlExecute | Executes a SQL command.
Public class | TemplateFile | MSBuild task that replaces tokens in a template file and writes out a new file.
Public class | Time | Gets the current date and time.
Public class | Unzip | Unzip a file to a target directory.
Public class | Version | Generates version information based on various algorithms
Public class | WebDownload | Downloads a resource with the specified URI to a local file.
Public class | XmlRead | Reads a value from a XML document using a XPath.
Public class | XmlUpdate | Updates a XML document using a XPath.
Public class | Xslt | A task to merge and transform a set of xml files.
Public class | Zip | Create a zip file with the files specified.

Enumerations

 | Enumeration | Description
Public enumeration | GacUtilCommands | The list of the commans available to the GacUtil Task
Public enumeration | ServiceActions | Defines the actions that can be performed on a service.

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

http://msbuildtasks.tigris.org/


AssemblyInfo Class

MSBuild Community Tasks
AssemblyInfo Class
See Also Example Members
[image]

Generates an AssemblyInfo files

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class AssemblyInfo
Inherits Task
C#
public class AssemblyInfo : Task
C++
ref class AssemblyInfo : Task
J#
public class AssemblyInfo extends Task
JScript
public class AssemblyInfo extends Task

Example

Generates a common version file.

Copy Code
            <AssemblyInfo CodeLanguage="CS"
                OutputFile="VersionInfo.cs"
                AssemblyVersion="1.0.0.0"
                AssemblyFileVersion="1.0.0.0" />

Generates a complete version file.

Copy Code
            <AssemblyInfo CodeLanguage="CS"
                OutputFile="$(MSBuildProjectDirectory)\Test\GlobalInfo.cs"
                AssemblyTitle="AssemblyInfoTask"
                AssemblyDescription="AssemblyInfo Description"
                AssemblyConfiguration=""
                AssemblyCompany="Company Name, LLC"
                AssemblyProduct="AssemblyInfoTask"
                AssemblyCopyright="Copyright (c) Company Name, LLC 2006"
                AssemblyTrademark=""
                ComVisible="false"
                CLSCompliant="true"
                Guid="d038566a-1937-478a-b5c5-b79c4afb253d"
                AssemblyVersion="1.0.0.0"
                AssemblyFileVersion="1.0.0.0" />

Inheritance Hierarchy

System.Object
Microsoft.Build.Utilities.Task
MSBuild.Community.Tasks.AssemblyInfo

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

AssemblyInfo Members
MSBuild.Community.Tasks Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

http://msbuildtasks.tigris.org/

Generated from assembly MSBuild.Community.Tasks [1.2.0.306]


AssemblyInfo Members

AssemblyInfo Members
See Also Example Constructors Fields Properties Methods
[image]

Generates an AssemblyInfo files

The following tables list the members exposed by AssemblyInfo.

Public Constructors

 | Name | Description
Public method | AssemblyInfo | Initializes a new instance of the T:AssemblyInfo class.
Top

Public Fields

Name | Description
DEFAULT_OUTPUT_FILE | The default value of OutputFile. The value is "AssemblyInfo.cs". This field is constant and read-only.
Top

Public Properties

 | Name | Description
Public property | AssemblyCompany | Gets or sets the assembly company.
Public property | AssemblyConfiguration | Gets or sets the assembly configuration.
Public property | AssemblyCopyright | Gets or sets the assembly copyright.
Public property | AssemblyCulture | Gets or sets the assembly culture.
Public property | AssemblyDelaySign | Gets or sets the assembly delay sign value.
Public property | AssemblyDescription | Gets or sets the assembly description.
Public property | AssemblyFileVersion | Gets or sets the assembly file version.
Public property | AssemblyInformationalVersion | Gets or sets the assembly informational version.
Public property | AssemblyKeyFile | Gets or sets the assembly key file.
Public property | AssemblyKeyName | Gets or sets the assembly key name.
Public property | AssemblyProduct | Gets or sets the assembly product.
Public property | AssemblyTitle | Gets or sets the assembly title.
Public property | AssemblyTrademark | Gets or sets the assembly trademark.
Public property | AssemblyVersion | Gets or sets the assembly version.
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | CLSCompliant | Gets or sets a value indicating whether [CLSCompliant].
Public property | CodeLanguage | Gets or sets the code language.
Public property | ComVisible | Gets or sets a value indicating whether [COMVisible].
Public property | GenerateClass | Gets or sets a value indicating whether to generate the ThisAssmebly class.
Public property | Guid | Gets or sets the GUID.
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | OutputFile | Gets or sets the output file.
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. When overridden in a derived class, executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

AssemblyInfo Class
AssemblyInfo Members
MSBuild.Community.Tasks Namespace


AssemblyInfo Constructor

AssemblyInfo Constructor
See Also
[image]

Initializes a new instance of the T:AssemblyInfo class.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public AssemblyInfo()
C++
public:
AssemblyInfo() sealed
J#
public AssemblyInfo()
JScript
public function AssemblyInfo()

See Also

AssemblyInfo Class
AssemblyInfo Members
MSBuild.Community.Tasks Namespace


Fields

AssemblyInfo Fields
See Also Example
[image]

Public Fields

Name | Description
DEFAULT_OUTPUT_FILE | The default value of OutputFile. The value is "AssemblyInfo.cs". This field is constant and read-only.
Top

See Also

AssemblyInfo Class
AssemblyInfo Members
MSBuild.Community.Tasks Namespace


DEFAULT_OUTPUT_FILE Field

AssemblyInfo.DEFAULT_OUTPUT_FILE Field
[image]

The default value of OutputFile. The value is "AssemblyInfo.cs". This field is constant and read-only.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public const DEFAULT_OUTPUT_FILE As String = "AssemblyInfo.cs"
C#
public const string DEFAULT_OUTPUT_FILE = "AssemblyInfo.cs";
C++
public:
const String DEFAULT_OUTPUT_FILE = L"AssemblyInfo.cs";
J#
public const string DEFAULT_OUTPUT_FILE = "AssemblyInfo.cs"
JScript
public const DEFAULT_OUTPUT_FILE : String = "AssemblyInfo.cs";

See Also

AssemblyInfo Class
AssemblyInfo Members
MSBuild.Community.Tasks Namespace


Properties

AssemblyInfo Properties
See Also Example
[image]

Public Properties

 | Name | Description
Public property | AssemblyCompany | Gets or sets the assembly company.
Public property | AssemblyConfiguration | Gets or sets the assembly configuration.
Public property | AssemblyCopyright | Gets or sets the assembly copyright.
Public property | AssemblyCulture | Gets or sets the assembly culture.
Public property | AssemblyDelaySign | Gets or sets the assembly delay sign value.
Public property | AssemblyDescription | Gets or sets the assembly description.
Public property | AssemblyFileVersion | Gets or sets the assembly file version.
Public property | AssemblyInformationalVersion | Gets or sets the assembly informational version.
Public property | AssemblyKeyFile | Gets or sets the assembly key file.
Public property | AssemblyKeyName | Gets or sets the assembly key name.
Public property | AssemblyProduct | Gets or sets the assembly product.
Public property | AssemblyTitle | Gets or sets the assembly title.
Public property | AssemblyTrademark | Gets or sets the assembly trademark.
Public property | AssemblyVersion | Gets or sets the assembly version.
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | CLSCompliant | Gets or sets a value indicating whether [CLSCompliant].
Public property | CodeLanguage | Gets or sets the code language.
Public property | ComVisible | Gets or sets a value indicating whether [COMVisible].
Public property | GenerateClass | Gets or sets a value indicating whether to generate the ThisAssmebly class.
Public property | Guid | Gets or sets the GUID.
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | OutputFile | Gets or sets the output file.
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

See Also

AssemblyInfo Class
AssemblyInfo Members
MSBuild.Community.Tasks Namespace


AssemblyCompany Property

AssemblyInfo.AssemblyCompany Property
[image]

Gets or sets the assembly company.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AssemblyCompany As String
C#
public string AssemblyCompany { get; set; }
C++
public property string AssemblyCompany sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_AssemblyCompany();

/** property */
public void set_AssemblyCompany(string value);
JScript
public function get AssemblyCompany() : String

public function set AssemblyCompany(value : String);

Property Value

The assembly company.

See Also

AssemblyInfo Class
AssemblyInfo Members
MSBuild.Community.Tasks Namespace


AssemblyConfiguration Property

AssemblyInfo.AssemblyConfiguration Property
[image]

Gets or sets the assembly configuration.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AssemblyConfiguration As String
C#
public string AssemblyConfiguration { get; set; }
C++
public property string AssemblyConfiguration sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_AssemblyConfiguration();

/** property */
public void set_AssemblyConfiguration(string value);
JScript
public function get AssemblyConfiguration() : String

public function set AssemblyConfiguration(value : String);

Property Value

The assembly configuration.

See Also

AssemblyInfo Class
AssemblyInfo Members
MSBuild.Community.Tasks Namespace


AssemblyCopyright Property

AssemblyInfo.AssemblyCopyright Property
[image]

Gets or sets the assembly copyright.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AssemblyCopyright As String
C#
public string AssemblyCopyright { get; set; }
C++
public property string AssemblyCopyright sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_AssemblyCopyright();

/** property */
public void set_AssemblyCopyright(string value);
JScript
public function get AssemblyCopyright() : String

public function set AssemblyCopyright(value : String);

Property Value

The assembly copyright.

See Also

AssemblyInfo Class
AssemblyInfo Members
MSBuild.Community.Tasks Namespace


AssemblyCulture Property

AssemblyInfo.AssemblyCulture Property
[image]

Gets or sets the assembly culture.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AssemblyCulture As String
C#
public string AssemblyCulture { get; set; }
C++
public property string AssemblyCulture sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_AssemblyCulture();

/** property */
public void set_AssemblyCulture(string value);
JScript
public function get AssemblyCulture() : String

public function set AssemblyCulture(value : String);

Property Value

The assembly culture.

See Also

AssemblyInfo Class
AssemblyInfo Members
MSBuild.Community.Tasks Namespace


AssemblyDelaySign Property

AssemblyInfo.AssemblyDelaySign Property
[image]

Gets or sets the assembly delay sign value.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AssemblyDelaySign As Boolean
C#
public bool AssemblyDelaySign { get; set; }
C++
public property bool AssemblyDelaySign sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_AssemblyDelaySign();

/** property */
public void set_AssemblyDelaySign(bool value);
JScript
public function get AssemblyDelaySign() : bool

public function set AssemblyDelaySign(value : bool);

See Also

AssemblyInfo Class
AssemblyInfo Members
MSBuild.Community.Tasks Namespace


AssemblyDescription Property

AssemblyInfo.AssemblyDescription Property
[image]

Gets or sets the assembly description.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AssemblyDescription As String
C#
public string AssemblyDescription { get; set; }
C++
public property string AssemblyDescription sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_AssemblyDescription();

/** property */
public void set_AssemblyDescription(string value);
JScript
public function get AssemblyDescription() : String

public function set AssemblyDescription(value : String);

Property Value

The assembly description.

See Also

AssemblyInfo Class
AssemblyInfo Members
MSBuild.Community.Tasks Namespace


AssemblyFileVersion Property

AssemblyInfo.AssemblyFileVersion Property
[image]

Gets or sets the assembly file version.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AssemblyFileVersion As String
C#
public string AssemblyFileVersion { get; set; }
C++
public property string AssemblyFileVersion sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_AssemblyFileVersion();

/** property */
public void set_AssemblyFileVersion(string value);
JScript
public function get AssemblyFileVersion() : String

public function set AssemblyFileVersion(value : String);

Property Value

The assembly file version.

See Also

AssemblyInfo Class
AssemblyInfo Members
MSBuild.Community.Tasks Namespace


AssemblyInformationalVersion Property

AssemblyInfo.AssemblyInformationalVersion Property
[image]

Gets or sets the assembly informational version.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AssemblyInformationalVersion As String
C#
public string AssemblyInformationalVersion { get; set; }
C++
public property string AssemblyInformationalVersion sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_AssemblyInformationalVersion();

/** property */
public void set_AssemblyInformationalVersion(string value);
JScript
public function get AssemblyInformationalVersion() : String

public function set AssemblyInformationalVersion(value : String);

Property Value

The assembly informational version.

See Also

AssemblyInfo Class
AssemblyInfo Members
MSBuild.Community.Tasks Namespace


AssemblyKeyFile Property

AssemblyInfo.AssemblyKeyFile Property
[image]

Gets or sets the assembly key file.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AssemblyKeyFile As String
C#
public string AssemblyKeyFile { get; set; }
C++
public property string AssemblyKeyFile sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_AssemblyKeyFile();

/** property */
public void set_AssemblyKeyFile(string value);
JScript
public function get AssemblyKeyFile() : String

public function set AssemblyKeyFile(value : String);

See Also

AssemblyInfo Class
AssemblyInfo Members
MSBuild.Community.Tasks Namespace


AssemblyKeyName Property

AssemblyInfo.AssemblyKeyName Property
[image]

Gets or sets the assembly key name.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AssemblyKeyName As String
C#
public string AssemblyKeyName { get; set; }
C++
public property string AssemblyKeyName sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_AssemblyKeyName();

/** property */
public void set_AssemblyKeyName(string value);
JScript
public function get AssemblyKeyName() : String

public function set AssemblyKeyName(value : String);

See Also

AssemblyInfo Class
AssemblyInfo Members
MSBuild.Community.Tasks Namespace


AssemblyProduct Property

AssemblyInfo.AssemblyProduct Property
[image]

Gets or sets the assembly product.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AssemblyProduct As String
C#
public string AssemblyProduct { get; set; }
C++
public property string AssemblyProduct sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_AssemblyProduct();

/** property */
public void set_AssemblyProduct(string value);
JScript
public function get AssemblyProduct() : String

public function set AssemblyProduct(value : String);

Property Value

The assembly product.

See Also

AssemblyInfo Class
AssemblyInfo Members
MSBuild.Community.Tasks Namespace


AssemblyTitle Property

AssemblyInfo.AssemblyTitle Property
[image]

Gets or sets the assembly title.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AssemblyTitle As String
C#
public string AssemblyTitle { get; set; }
C++
public property string AssemblyTitle sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_AssemblyTitle();

/** property */
public void set_AssemblyTitle(string value);
JScript
public function get AssemblyTitle() : String

public function set AssemblyTitle(value : String);

Property Value

The assembly title.

See Also

AssemblyInfo Class
AssemblyInfo Members
MSBuild.Community.Tasks Namespace


AssemblyTrademark Property

AssemblyInfo.AssemblyTrademark Property
[image]

Gets or sets the assembly trademark.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AssemblyTrademark As String
C#
public string AssemblyTrademark { get; set; }
C++
public property string AssemblyTrademark sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_AssemblyTrademark();

/** property */
public void set_AssemblyTrademark(string value);
JScript
public function get AssemblyTrademark() : String

public function set AssemblyTrademark(value : String);

Property Value

The assembly trademark.

See Also

AssemblyInfo Class
AssemblyInfo Members
MSBuild.Community.Tasks Namespace


AssemblyVersion Property

AssemblyInfo.AssemblyVersion Property
[image]

Gets or sets the assembly version.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AssemblyVersion As String
C#
public string AssemblyVersion { get; set; }
C++
public property string AssemblyVersion sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_AssemblyVersion();

/** property */
public void set_AssemblyVersion(string value);
JScript
public function get AssemblyVersion() : String

public function set AssemblyVersion(value : String);

Property Value

The assembly version.

See Also

AssemblyInfo Class
AssemblyInfo Members
MSBuild.Community.Tasks Namespace


CLSCompliant Property

AssemblyInfo.CLSCompliant Property
[image]

Gets or sets a value indicating whether [CLSCompliant].

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property CLSCompliant As Boolean
C#
public bool CLSCompliant { get; set; }
C++
public property bool CLSCompliant sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_CLSCompliant();

/** property */
public void set_CLSCompliant(bool value);
JScript
public function get CLSCompliant() : bool

public function set CLSCompliant(value : bool);

Property Value

true if [CLSCompliant]; otherwise, false.

See Also

AssemblyInfo Class
AssemblyInfo Members
MSBuild.Community.Tasks Namespace


CodeLanguage Property

AssemblyInfo.CodeLanguage Property
[image]

Gets or sets the code language.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Required>
Public Property CodeLanguage As String
C#
[Required]
public string CodeLanguage { get; set; }
C++
[Required]
public property string CodeLanguage sealed {
String get();
void set(String value);
}
J#
/** @attribute Required() */
/** property */
public string get_CodeLanguage();

/** property */
public void set_CodeLanguage(string value);
JScript
public function get CodeLanguage() : String

public function set CodeLanguage(value : String);

Property Value

The code language.

See Also

AssemblyInfo Class
AssemblyInfo Members
MSBuild.Community.Tasks Namespace


ComVisible Property

AssemblyInfo.ComVisible Property
[image]

Gets or sets a value indicating whether [COMVisible].

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property ComVisible As Boolean
C#
public bool ComVisible { get; set; }
C++
public property bool ComVisible sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_ComVisible();

/** property */
public void set_ComVisible(bool value);
JScript
public function get ComVisible() : bool

public function set ComVisible(value : bool);

Property Value

true if [COMVisible]; otherwise, false.

See Also

AssemblyInfo Class
AssemblyInfo Members
MSBuild.Community.Tasks Namespace


GenerateClass Property

AssemblyInfo.GenerateClass Property
[image]

Gets or sets a value indicating whether to generate the ThisAssmebly class.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property GenerateClass As Boolean
C#
public bool GenerateClass { get; set; }
C++
public property bool GenerateClass sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_GenerateClass();

/** property */
public void set_GenerateClass(bool value);
JScript
public function get GenerateClass() : bool

public function set GenerateClass(value : bool);

See Also

AssemblyInfo Class
AssemblyInfo Members
MSBuild.Community.Tasks Namespace


Guid Property

AssemblyInfo.Guid Property
[image]

Gets or sets the GUID.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Guid As String
C#
public string Guid { get; set; }
C++
public property string Guid sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Guid();

/** property */
public void set_Guid(string value);
JScript
public function get Guid() : String

public function set Guid(value : String);

Property Value

The GUID.

See Also

AssemblyInfo Class
AssemblyInfo Members
MSBuild.Community.Tasks Namespace


OutputFile Property

AssemblyInfo.OutputFile Property
[image]

Gets or sets the output file.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Output>
Public Property OutputFile As String
C#
[Output]
public string OutputFile { get; set; }
C++
[Output]
public property string OutputFile sealed {
String get();
void set(String value);
}
J#
/** @attribute Output() */
/** property */
public string get_OutputFile();

/** property */
public void set_OutputFile(string value);
JScript
public function get OutputFile() : String

public function set OutputFile(value : String);

Property Value

The output file.

See Also

AssemblyInfo Class
AssemblyInfo Members
MSBuild.Community.Tasks Namespace


Methods

AssemblyInfo Methods
See Also Example
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. When overridden in a derived class, executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

AssemblyInfo Class
AssemblyInfo Members
MSBuild.Community.Tasks Namespace


Execute Method

AssemblyInfo.Execute Method
[image]

When overridden in a derived class, executes the task.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute() As Boolean _
Implements ITask.Execute
C#
public override bool Execute()
C++
public:
virtual bool Execute() override
J#
public override bool Execute()
JScript
public override function Execute() : bool

Return Value

true if the task successfully executed; otherwise, false.

Implements

ITask.Execute

See Also

AssemblyInfo Class
AssemblyInfo Members
MSBuild.Community.Tasks Namespace


Attrib Class

Attrib Class
See Also Example Members
[image]

Changes the attributes of files and/or directories

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class Attrib
Inherits Task
C#
public class Attrib : Task
C++
ref class Attrib : Task
J#
public class Attrib extends Task
JScript
public class Attrib extends Task

Example

Make file Readonly, Hidden and System.

Copy Code
            <Attrib Files="Test\version.txt"
                ReadOnly="true" Hidden="true" System="true"/>

Clear Hidden and System attributes.

Copy Code
            <Attrib Files="Test\version.txt"
                Hidden="false" System="false"/>

Make file Normal.

Copy Code
            <Attrib Files="Test\version.txt"
                Normal="true"/>

Inheritance Hierarchy

System.Object
Microsoft.Build.Utilities.Task
MSBuild.Community.Tasks.Attrib

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

Attrib Members
MSBuild.Community.Tasks Namespace


Attrib Members

Attrib Members
See Also Example Constructors Properties Methods
[image]

Changes the attributes of files and/or directories

The following tables list the members exposed by Attrib.

Public Constructors

 | Name | Description
Public method | Attrib | Initializes a new instance of the Attrib class.
Top

Public Properties

 | Name | Description
Public property | Archive | Gets or sets file's archive status.
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | Compressed | Gets or sets a value indicating file is compressed.
Public property | Directories | Gets or sets the list of directories to change attributes on.
Public property | Encrypted | Gets or sets a value indicating file is encrypted.
Public property | Files | Gets or sets the list of files to change attributes on.
Public property | Hidden | Gets or sets a value indicating file is hidden, and thus is not included in an ordinary directory listing.
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Normal | Gets or sets a value indicating file is normal and has no other attributes set.
Public property | ReadOnly | Gets or sets a value indicating file is read-only.
Public property | System | Gets or sets a value indicating file is a system file.
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. Executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

Attrib Class
Attrib Members
MSBuild.Community.Tasks Namespace


Attrib Constructor

Attrib Constructor
[image]

Initializes a new instance of the Attrib class.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public Attrib()
C++
public:
Attrib() sealed
J#
public Attrib()
JScript
public function Attrib()

See Also

Attrib Class
Attrib Members
MSBuild.Community.Tasks Namespace


Properties

Attrib Properties
See Also Example
[image]

Public Properties

 | Name | Description
Public property | Archive | Gets or sets file's archive status.
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | Compressed | Gets or sets a value indicating file is compressed.
Public property | Directories | Gets or sets the list of directories to change attributes on.
Public property | Encrypted | Gets or sets a value indicating file is encrypted.
Public property | Files | Gets or sets the list of files to change attributes on.
Public property | Hidden | Gets or sets a value indicating file is hidden, and thus is not included in an ordinary directory listing.
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Normal | Gets or sets a value indicating file is normal and has no other attributes set.
Public property | ReadOnly | Gets or sets a value indicating file is read-only.
Public property | System | Gets or sets a value indicating file is a system file.
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

See Also

Attrib Class
Attrib Members
MSBuild.Community.Tasks Namespace


Archive Property

Attrib.Archive Property
[image]

Gets or sets file's archive status.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Archive As Boolean
C#
public bool Archive { get; set; }
C++
public property bool Archive sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_Archive();

/** property */
public void set_Archive(bool value);
JScript
public function get Archive() : bool

public function set Archive(value : bool);

Property Value

true if archive; otherwise, false.

See Also

Attrib Class
Attrib Members
MSBuild.Community.Tasks Namespace


Compressed Property

Attrib.Compressed Property
[image]

Gets or sets a value indicating file is compressed.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Compressed As Boolean
C#
public bool Compressed { get; set; }
C++
public property bool Compressed sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_Compressed();

/** property */
public void set_Compressed(bool value);
JScript
public function get Compressed() : bool

public function set Compressed(value : bool);

Property Value

true if compressed; otherwise, false.

See Also

Attrib Class
Attrib Members
MSBuild.Community.Tasks Namespace


Directories Property

Attrib.Directories Property
[image]

Gets or sets the list of directories to change attributes on.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Directories As ITaskItem[]
C#
public ITaskItem[] Directories { get; set; }
C++
public property ITaskItem[] Directories sealed {
array<ITaskItem>^ get();
void set(array<ITaskItem>^ value);
}
J#
/** property */
public ITaskItem[] get_Directories();

/** property */
public void set_Directories(ITaskItem[] value);
JScript
public function get Directories() : ITaskItem[]

public function set Directories(value : ITaskItem[]);

Property Value

The directories to change attributes on.

See Also

Attrib Class
Attrib Members
MSBuild.Community.Tasks Namespace


Encrypted Property

Attrib.Encrypted Property
[image]

Gets or sets a value indicating file is encrypted.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Encrypted As Boolean
C#
public bool Encrypted { get; set; }
C++
public property bool Encrypted sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_Encrypted();

/** property */
public void set_Encrypted(bool value);
JScript
public function get Encrypted() : bool

public function set Encrypted(value : bool);

Property Value

true if encrypted; otherwise, false.

See Also

Attrib Class
Attrib Members
MSBuild.Community.Tasks Namespace


Files Property

Attrib.Files Property
[image]

Gets or sets the list of files to change attributes on.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Files As ITaskItem[]
C#
public ITaskItem[] Files { get; set; }
C++
public property ITaskItem[] Files sealed {
array<ITaskItem>^ get();
void set(array<ITaskItem>^ value);
}
J#
/** property */
public ITaskItem[] get_Files();

/** property */
public void set_Files(ITaskItem[] value);
JScript
public function get Files() : ITaskItem[]

public function set Files(value : ITaskItem[]);

Property Value

The files to change attributes on.

See Also

Attrib Class
Attrib Members
MSBuild.Community.Tasks Namespace


Hidden Property

Attrib.Hidden Property
[image]

Gets or sets a value indicating file is hidden, and thus is not included in an ordinary directory listing.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Hidden As Boolean
C#
public bool Hidden { get; set; }
C++
public property bool Hidden sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_Hidden();

/** property */
public void set_Hidden(bool value);
JScript
public function get Hidden() : bool

public function set Hidden(value : bool);

Property Value

true if hidden; otherwise, false.

See Also

Attrib Class
Attrib Members
MSBuild.Community.Tasks Namespace


Normal Property

Attrib.Normal Property
[image]

Gets or sets a value indicating file is normal and has no other attributes set.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Normal As Boolean
C#
public bool Normal { get; set; }
C++
public property bool Normal sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_Normal();

/** property */
public void set_Normal(bool value);
JScript
public function get Normal() : bool

public function set Normal(value : bool);

Property Value

true if normal; otherwise, false.

See Also

Attrib Class
Attrib Members
MSBuild.Community.Tasks Namespace


ReadOnly Property

Attrib.ReadOnly Property
[image]

Gets or sets a value indicating file is read-only.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property ReadOnly As Boolean
C#
public bool ReadOnly { get; set; }
C++
public property bool ReadOnly sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_ReadOnly();

/** property */
public void set_ReadOnly(bool value);
JScript
public function get ReadOnly() : bool

public function set ReadOnly(value : bool);

Property Value

true if read-only; otherwise, false.

See Also

Attrib Class
Attrib Members
MSBuild.Community.Tasks Namespace


System Property

Attrib.System Property
[image]

Gets or sets a value indicating file is a system file.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property System As Boolean
C#
public bool System { get; set; }
C++
public property bool System sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_System();

/** property */
public void set_System(bool value);
JScript
public function get System() : bool

public function set System(value : bool);

Property Value

true if system; otherwise, false.

See Also

Attrib Class
Attrib Members
MSBuild.Community.Tasks Namespace


Methods

Attrib Methods
See Also Example
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. Executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

Attrib Class
Attrib Members
MSBuild.Community.Tasks Namespace


Execute Method

Attrib.Execute Method
[image]

Executes the task.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute() As Boolean _
Implements ITask.Execute
C#
public override bool Execute()
C++
public:
virtual bool Execute() override
J#
public override bool Execute()
JScript
public override function Execute() : bool

Return Value

true if the task ran successfully; otherwise false.

Implements

ITask.Execute

See Also

Attrib Class
Attrib Members
MSBuild.Community.Tasks Namespace


FileUpdate Class

FileUpdate Class
See Also Example Members
[image]

Replace text in file(s) using a Regular Expression.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class FileUpdate
Inherits Task
C#
public class FileUpdate : Task
C++
ref class FileUpdate : Task
J#
public class FileUpdate extends Task
JScript
public class FileUpdate extends Task

Example

Search for a version number and update the revision.

Copy Code
            <FileUpdate Files="version.txt"
                Regex="(\d+)\.(\d+)\.(\d+)\.(\d+)"
                ReplacementText="$1.$2.$3.123" />

Inheritance Hierarchy

System.Object
Microsoft.Build.Utilities.Task
MSBuild.Community.Tasks.FileUpdate

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

FileUpdate Members
MSBuild.Community.Tasks Namespace


FileUpdate Members

FileUpdate Members
See Also Example Constructors Properties Methods
[image]

Replace text in file(s) using a Regular Expression.

The following tables list the members exposed by FileUpdate.

Public Constructors

 | Name | Description
Public method | FileUpdate | Initializes a new instance of the T:FileUpdate class.
Top

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | Encoding | The character encoding used to read and write the file.
Public property | Files | Gets or sets the files to update.
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | IgnoreCase | Gets or sets a value specifies case-insensitive matching. .
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Multiline | Gets or sets a value changing the meaning of ^ and $ so they match at the beginning and end, respectively, of any line, and not just the beginning and end of the entire string.
Public property | Regex | Gets or sets the regex.
Public property | ReplacementCount | Gets or sets the maximum number of times the replacement can occur.
Public property | ReplacementText | Gets or sets the replacement text.
Public property | Singleline | Gets or sets a value changing the meaning of the dot (.) so it matches every character (instead of every character except \n).
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. When overridden in a derived class, executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

FileUpdate Class
FileUpdate Members
MSBuild.Community.Tasks Namespace


FileUpdate Constructor

FileUpdate Constructor
[image]

Initializes a new instance of the T:FileUpdate class.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public FileUpdate()
C++
public:
FileUpdate() sealed
J#
public FileUpdate()
JScript
public function FileUpdate()

See Also

FileUpdate Class
FileUpdate Members
MSBuild.Community.Tasks Namespace


Properties

FileUpdate Properties
See Also Example
[image]

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | Encoding | The character encoding used to read and write the file.
Public property | Files | Gets or sets the files to update.
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | IgnoreCase | Gets or sets a value specifies case-insensitive matching. .
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Multiline | Gets or sets a value changing the meaning of ^ and $ so they match at the beginning and end, respectively, of any line, and not just the beginning and end of the entire string.
Public property | Regex | Gets or sets the regex.
Public property | ReplacementCount | Gets or sets the maximum number of times the replacement can occur.
Public property | ReplacementText | Gets or sets the replacement text.
Public property | Singleline | Gets or sets a value changing the meaning of the dot (.) so it matches every character (instead of every character except \n).
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

See Also

FileUpdate Class
FileUpdate Members
MSBuild.Community.Tasks Namespace


Encoding Property

FileUpdate.Encoding Property
[image]

The character encoding used to read and write the file.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Encoding As String
C#
public string Encoding { get; set; }
C++
public property string Encoding sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Encoding();

/** property */
public void set_Encoding(string value);
JScript
public function get Encoding() : String

public function set Encoding(value : String);

Remarks

Any value returned by WebName is valid input.

The default is utf-8

See Also

FileUpdate Class
FileUpdate Members
MSBuild.Community.Tasks Namespace


Files Property

FileUpdate.Files Property
[image]

Gets or sets the files to update.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Files As ITaskItem[]
C#
public ITaskItem[] Files { get; set; }
C++
public property ITaskItem[] Files sealed {
array<ITaskItem>^ get();
void set(array<ITaskItem>^ value);
}
J#
/** property */
public ITaskItem[] get_Files();

/** property */
public void set_Files(ITaskItem[] value);
JScript
public function get Files() : ITaskItem[]

public function set Files(value : ITaskItem[]);

Property Value

The files.

See Also

FileUpdate Class
FileUpdate Members
MSBuild.Community.Tasks Namespace


IgnoreCase Property

FileUpdate.IgnoreCase Property
[image]

Gets or sets a value specifies case-insensitive matching. .

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property IgnoreCase As Boolean
C#
public bool IgnoreCase { get; set; }
C++
public property bool IgnoreCase sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_IgnoreCase();

/** property */
public void set_IgnoreCase(bool value);
JScript
public function get IgnoreCase() : bool

public function set IgnoreCase(value : bool);

Property Value

true if [ignore case]; otherwise, false.

See Also

FileUpdate Class
FileUpdate Members
MSBuild.Community.Tasks Namespace


Multiline Property

FileUpdate.Multiline Property
[image]

Gets or sets a value changing the meaning of ^ and $ so they match at the beginning and end, respectively, of any line, and not just the beginning and end of the entire string.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Multiline As Boolean
C#
public bool Multiline { get; set; }
C++
public property bool Multiline sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_Multiline();

/** property */
public void set_Multiline(bool value);
JScript
public function get Multiline() : bool

public function set Multiline(value : bool);

Property Value

true if multiline; otherwise, false.

See Also

FileUpdate Class
FileUpdate Members
MSBuild.Community.Tasks Namespace


Regex Property

FileUpdate.Regex Property
[image]

Gets or sets the regex.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Regex As String
C#
public string Regex { get; set; }
C++
public property string Regex sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Regex();

/** property */
public void set_Regex(string value);
JScript
public function get Regex() : String

public function set Regex(value : String);

Property Value

The regex.

See Also

FileUpdate Class
FileUpdate Members
MSBuild.Community.Tasks Namespace


ReplacementCount Property

FileUpdate.ReplacementCount Property
[image]

Gets or sets the maximum number of times the replacement can occur.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property ReplacementCount As Integer
C#
public int ReplacementCount { get; set; }
C++
public property int ReplacementCount sealed {
int get();
void set(int value);
}
J#
/** property */
public int get_ReplacementCount();

/** property */
public void set_ReplacementCount(int value);
JScript
public function get ReplacementCount() : int

public function set ReplacementCount(value : int);

Property Value

The replacement count.

See Also

FileUpdate Class
FileUpdate Members
MSBuild.Community.Tasks Namespace


ReplacementText Property

FileUpdate.ReplacementText Property
[image]

Gets or sets the replacement text.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property ReplacementText As String
C#
public string ReplacementText { get; set; }
C++
public property string ReplacementText sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_ReplacementText();

/** property */
public void set_ReplacementText(string value);
JScript
public function get ReplacementText() : String

public function set ReplacementText(value : String);

Property Value

The replacement text.

See Also

FileUpdate Class
FileUpdate Members
MSBuild.Community.Tasks Namespace


Singleline Property

FileUpdate.Singleline Property
[image]

Gets or sets a value changing the meaning of the dot (.) so it matches every character (instead of every character except \n).

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Singleline As Boolean
C#
public bool Singleline { get; set; }
C++
public property bool Singleline sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_Singleline();

/** property */
public void set_Singleline(bool value);
JScript
public function get Singleline() : bool

public function set Singleline(value : bool);

Property Value

true if singleline; otherwise, false.

See Also

FileUpdate Class
FileUpdate Members
MSBuild.Community.Tasks Namespace


Methods

FileUpdate Methods
See Also Example
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. When overridden in a derived class, executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

FileUpdate Class
FileUpdate Members
MSBuild.Community.Tasks Namespace


Execute Method

FileUpdate.Execute Method
[image]

When overridden in a derived class, executes the task.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute() As Boolean _
Implements ITask.Execute
C#
public override bool Execute()
C++
public:
virtual bool Execute() override
J#
public override bool Execute()
JScript
public override function Execute() : bool

Return Value

true if the task successfully executed; otherwise, false.

Implements

ITask.Execute

See Also

FileUpdate Class
FileUpdate Members
MSBuild.Community.Tasks Namespace


FtpUpload Class

FtpUpload Class
See Also Example Members
[image]

Uploads a file using File Transfer Protocol (FTP).

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class FtpUpload
Inherits Task
C#
public class FtpUpload : Task
C++
ref class FtpUpload : Task
J#
public class FtpUpload extends Task
JScript
public class FtpUpload extends Task

Example

Upload a file.

Copy Code
            <FtpUpload
                LocalFile="MSBuild.Community.Tasks.zip"
                RemoteUri="ftp://localhost/MSBuild.Community.Tasks.zip" />

Inheritance Hierarchy

System.Object
Microsoft.Build.Utilities.Task
MSBuild.Community.Tasks.FtpUpload

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

FtpUpload Members
MSBuild.Community.Tasks Namespace


FtpUpload Members

FtpUpload Members
See Also Example Constructors Properties Methods
[image]

Uploads a file using File Transfer Protocol (FTP).

The following tables list the members exposed by FtpUpload.

Public Constructors

 | Name | Description
Public method | FtpUpload | Initializes a new instance of the T:FtpUpload class.
Top

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | LocalFile | Gets or sets the local file to upload.
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Password | Gets or sets the password.
Public property | RemoteUri | Gets or sets the remote URI to upload.
Public property | UsePassive | Gets or sets the behavior of a client application's data transfer process.
Public property | Username | Gets or sets the username.
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. When overridden in a derived class, executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

FtpUpload Class
FtpUpload Members
MSBuild.Community.Tasks Namespace


FtpUpload Constructor

FtpUpload Constructor
[image]

Initializes a new instance of the T:FtpUpload class.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public FtpUpload()
C++
public:
FtpUpload() sealed
J#
public FtpUpload()
JScript
public function FtpUpload()

See Also

FtpUpload Class
FtpUpload Members
MSBuild.Community.Tasks Namespace


Properties

FtpUpload Properties
See Also Example
[image]

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | LocalFile | Gets or sets the local file to upload.
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Password | Gets or sets the password.
Public property | RemoteUri | Gets or sets the remote URI to upload.
Public property | UsePassive | Gets or sets the behavior of a client application's data transfer process.
Public property | Username | Gets or sets the username.
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

See Also

FtpUpload Class
FtpUpload Members
MSBuild.Community.Tasks Namespace


LocalFile Property

FtpUpload.LocalFile Property
[image]

Gets or sets the local file to upload.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Required>
Public Property LocalFile As String
C#
[Required]
public string LocalFile { get; set; }
C++
[Required]
public property string LocalFile sealed {
String get();
void set(String value);
}
J#
/** @attribute Required() */
/** property */
public string get_LocalFile();

/** property */
public void set_LocalFile(string value);
JScript
public function get LocalFile() : String

public function set LocalFile(value : String);

Property Value

The local file.

See Also

FtpUpload Class
FtpUpload Members
MSBuild.Community.Tasks Namespace


Password Property

FtpUpload.Password Property
[image]

Gets or sets the password.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Password As String
C#
public string Password { get; set; }
C++
public property string Password sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Password();

/** property */
public void set_Password(string value);
JScript
public function get Password() : String

public function set Password(value : String);

Property Value

The password.

See Also

FtpUpload Class
FtpUpload Members
MSBuild.Community.Tasks Namespace


RemoteUri Property

FtpUpload.RemoteUri Property
[image]

Gets or sets the remote URI to upload.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Required>
Public Property RemoteUri As String
C#
[Required]
public string RemoteUri { get; set; }
C++
[Required]
public property string RemoteUri sealed {
String get();
void set(String value);
}
J#
/** @attribute Required() */
/** property */
public string get_RemoteUri();

/** property */
public void set_RemoteUri(string value);
JScript
public function get RemoteUri() : String

public function set RemoteUri(value : String);

Property Value

The remote URI.

See Also

FtpUpload Class
FtpUpload Members
MSBuild.Community.Tasks Namespace


UsePassive Property

FtpUpload.UsePassive Property
[image]

Gets or sets the behavior of a client application's data transfer process.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property UsePassive As Boolean
C#
public bool UsePassive { get; set; }
C++
public property bool UsePassive sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_UsePassive();

/** property */
public void set_UsePassive(bool value);
JScript
public function get UsePassive() : bool

public function set UsePassive(value : bool);

Property Value

true if [use passive]; otherwise, false.

See Also

FtpUpload Class
FtpUpload Members
MSBuild.Community.Tasks Namespace


Username Property

FtpUpload.Username Property
[image]

Gets or sets the username.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Username As String
C#
public string Username { get; set; }
C++
public property string Username sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Username();

/** property */
public void set_Username(string value);
JScript
public function get Username() : String

public function set Username(value : String);

Property Value

The username.

See Also

FtpUpload Class
FtpUpload Members
MSBuild.Community.Tasks Namespace


Methods

FtpUpload Methods
See Also Example
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. When overridden in a derived class, executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

FtpUpload Class
FtpUpload Members
MSBuild.Community.Tasks Namespace


Execute Method

FtpUpload.Execute Method
[image]

When overridden in a derived class, executes the task.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute() As Boolean _
Implements ITask.Execute
C#
public override bool Execute()
C++
public:
virtual bool Execute() override
J#
public override bool Execute()
JScript
public override function Execute() : bool

Return Value

true if the task successfully executed; otherwise, false.

Implements

ITask.Execute

See Also

FtpUpload Class
FtpUpload Members
MSBuild.Community.Tasks Namespace


FxCop Class

FxCop Class
See Also Example Members
[image]

Uses FxCop to analyse managed code assemblies and reports on their design best-practice compliance.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class FxCop
Inherits ToolTask
C#
public class FxCop : ToolTask
C++
ref class FxCop : ToolTask
J#
public class FxCop extends ToolTask
JScript
public class FxCop extends ToolTask

Example

Shows how to analyse an assembly and use an XSLT stylesheet to present the report as an HTML file. If the static anlysis fails, the build does not stop - this is controlled with the FailOnError parameter.

Copy Code
            <FxCop
              TargetAssemblies="$(MSBuildCommunityTasksPath)\MSBuild.Community.Tasks.dll"
              RuleLibraries="@(FxCopRuleAssemblies)"
              Rules="Microsoft.Design#CA1012;-Microsoft.Performance#CA1805"
              AnalysisReportFileName="Test.html"
              DependencyDirectories="$(MSBuildCommunityTasksPath)"
              FailOnError="False"
              ApplyOutXsl="True"
              OutputXslFileName="C:\Program Files\Microsoft FxCop 1.32\Xml\FxCopReport.xsl"
            />

Remarks

If you include the MSBuild.Community.Tasks.Targets file in you build project, the ItemGroup @(FxCopRuleAssemblies) is defined with the standard FxCop Rules Assemblies.

Inheritance Hierarchy

System.Object
Microsoft.Build.Utilities.Task
Microsoft.Build.Utilities.ToolTask
MSBuild.Community.Tasks.FxCop

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

FxCop Members
MSBuild.Community.Tasks Namespace


FxCop Members

FxCop Members
See Also Example Constructors Properties Methods
[image]

Uses FxCop to analyse managed code assemblies and reports on their design best-practice compliance.

The following tables list the members exposed by FxCop.

Public Constructors

 | Name | Description
Public method | FxCop | Initializes a new instance of the FxCop class.
Top

Public Properties

 | Name | Description
Public property | AnalysisReportFileName | Specifies the file name for the analysis report.
Public property | ApplyOutXsl | Applies the XSL transformation specified in /outXsl to the analysis report before saving the file.
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | ConsoleXslFileName | Specifies the XSL or XSLT file that contains a transformation to be applied to the analysis output before it is displayed in the console.
Public property | DependencyDirectories | Specifies additional directories to search for assembly dependencies. FxCopCmd always searches the target assembly directory and the current working directory.
Public property | DirectOutputToConsole | Directs analysis output to the console or to the Output window in Visual Studio .NET. By default, the XSL file FxCopConsoleOutput.xsl is applied to the output before it is displayed.
Public property | ExitCode | Gets the returned exit code of the executable file. (inherited from ToolTask)
Public property | FailOnError | Gets or sets a value indicating whether the build should fail if static code analysis reports errors. Defaults to true.
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | ImportFiles | Specifies the name of an analysis report or project file to import. Any messages in the imported file that are marked as excluded are not included in the analysis results.
Public property | IncludeSummaryReport | Includes a summary report with the informational messages returned by FxCopCmd.
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | OutputXslFileName | Specifies the XSL or XSLT file that is referenced by the xml-stylesheet processing instruction in the analysis report.
Public property | PlatformDirectory | Specifies the location of the version of Mscorlib.dll that was used when building the target assemblies if this version is not installed on the computer running FxCopCmd.
Public property | ProjectFile | Specifies the filename of FxCop project file.
Public property | RuleLibraries | Specifies the filename(s) of FxCop rule assemblies
Public property | Rules | The list of rules to run
Public property | SaveResults | Saves the results of the analysis in the project file.
Public property | TargetAssemblies | Specifies the target assembly to analyze.
Public property | Timeout | Gets or sets the amount of time after which the task executable is terminated. (inherited from ToolTask)
Public property | ToolPath | Gets or sets the path of the executable file to run. (inherited from ToolTask)
Public property | TypeList | Comma-separated list of type names to analyze. This option disables analysis of assemblies, namespaces, and resources; only the specified types and their members are included in the analysis. Use the wildcard character '*' at the end of the name to select multiple types.
Public property | Verbose | Gets or sets a value indicating whether the output is verbose.
Public property | WorkingDirectory | Gets or sets the working directory.
Top

Protected Properties

 | Name | Description
Family property | EnvironmentOverride | Gets the override value of the PATH environment variable. (inherited from ToolTask)
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | ResponseFileEncoding | Gets the Encoding of the response file. (inherited from ToolTask)
Family property | StandardErrorEncoding | Gets the Encoding of the standard error stream of the task. (inherited from ToolTask)
Family property | StandardErrorLoggingImportance | Gets the MessageImportance with which to log errors. (inherited from ToolTask)
Family property | StandardOutputEncoding | Gets the Encoding of the standard output stream of the task. (inherited from ToolTask)
Family property | StandardOutputLoggingImportance | Gets the MessageImportance with which to log errors. (inherited from ToolTask)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Family property | ToolName | Overidden. Gets the name of the executable file to run.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. Executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | CallHostObjectToExecute | Calls the host object to perform the work of the task. (inherited from ToolTask)
Family method | ExecuteTool | Creates a temporoary response (.rsp) file and runs the executable file. (inherited from ToolTask)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GenerateCommandLineCommands | Overidden. Returns a string value containing the command line arguments to pass directly to the executable file.
Family method | GenerateFullPathToTool | Overidden. Returns the fully qualified path to the executable file.
Family method | GenerateResponseFileCommands | Returns a string value containing the command line arguments to add to the response (.rsp) file before running the executable file. (inherited from ToolTask)
Family method | GetResponseFileSwitch | Returns the command line switch used by the executable file to specifiy a response (.rsp) file. (inherited from ToolTask)
Family method | GetWorkingDirectory | Overidden. Returns the directory in which to run the executable file.
Family method | HandleTaskExecutionErrors | Handles execution errors raised by the executable file. (inherited from ToolTask)
Family method | InitializeHostObject | Initializes the host object of the task. (inherited from ToolTask)
Family method | LogEventsFromTextOutput | (inherited from ToolTask)
Family method | LogPathToTool | Logs the tool name and path to all registered loggers. (inherited from ToolTask)
Family method | LogToolCommand | Logs the starting point of the run to all registered loggers. (inherited from ToolTask)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | SkipTaskExecution | Indicates whether task execution should be skipped. (inherited from ToolTask)
Family method | ValidateParameters | Overidden. Indicates whether all task paratmeters are valid.
Top

See Also

FxCop Class
FxCop Members
MSBuild.Community.Tasks Namespace


FxCop Constructor

FxCop Constructor
[image]

Initializes a new instance of the FxCop class.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public FxCop()
C++
public:
FxCop() sealed
J#
public FxCop()
JScript
public function FxCop()

See Also

FxCop Class
FxCop Members
MSBuild.Community.Tasks Namespace


Properties

FxCop Properties
See Also Example
[image]

Public Properties

 | Name | Description
Public property | AnalysisReportFileName | Specifies the file name for the analysis report.
Public property | ApplyOutXsl | Applies the XSL transformation specified in /outXsl to the analysis report before saving the file.
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | ConsoleXslFileName | Specifies the XSL or XSLT file that contains a transformation to be applied to the analysis output before it is displayed in the console.
Public property | DependencyDirectories | Specifies additional directories to search for assembly dependencies. FxCopCmd always searches the target assembly directory and the current working directory.
Public property | DirectOutputToConsole | Directs analysis output to the console or to the Output window in Visual Studio .NET. By default, the XSL file FxCopConsoleOutput.xsl is applied to the output before it is displayed.
Public property | ExitCode | Gets the returned exit code of the executable file. (inherited from ToolTask)
Public property | FailOnError | Gets or sets a value indicating whether the build should fail if static code analysis reports errors. Defaults to true.
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | ImportFiles | Specifies the name of an analysis report or project file to import. Any messages in the imported file that are marked as excluded are not included in the analysis results.
Public property | IncludeSummaryReport | Includes a summary report with the informational messages returned by FxCopCmd.
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | OutputXslFileName | Specifies the XSL or XSLT file that is referenced by the xml-stylesheet processing instruction in the analysis report.
Public property | PlatformDirectory | Specifies the location of the version of Mscorlib.dll that was used when building the target assemblies if this version is not installed on the computer running FxCopCmd.
Public property | ProjectFile | Specifies the filename of FxCop project file.
Public property | RuleLibraries | Specifies the filename(s) of FxCop rule assemblies
Public property | Rules | The list of rules to run
Public property | SaveResults | Saves the results of the analysis in the project file.
Public property | TargetAssemblies | Specifies the target assembly to analyze.
Public property | Timeout | Gets or sets the amount of time after which the task executable is terminated. (inherited from ToolTask)
Public property | ToolPath | Gets or sets the path of the executable file to run. (inherited from ToolTask)
Public property | TypeList | Comma-separated list of type names to analyze. This option disables analysis of assemblies, namespaces, and resources; only the specified types and their members are included in the analysis. Use the wildcard character '*' at the end of the name to select multiple types.
Public property | Verbose | Gets or sets a value indicating whether the output is verbose.
Public property | WorkingDirectory | Gets or sets the working directory.
Top

Protected Properties

 | Name | Description
Family property | EnvironmentOverride | Gets the override value of the PATH environment variable. (inherited from ToolTask)
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | ResponseFileEncoding | Gets the Encoding of the response file. (inherited from ToolTask)
Family property | StandardErrorEncoding | Gets the Encoding of the standard error stream of the task. (inherited from ToolTask)
Family property | StandardErrorLoggingImportance | Gets the MessageImportance with which to log errors. (inherited from ToolTask)
Family property | StandardOutputEncoding | Gets the Encoding of the standard output stream of the task. (inherited from ToolTask)
Family property | StandardOutputLoggingImportance | Gets the MessageImportance with which to log errors. (inherited from ToolTask)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Family property | ToolName | Overidden. Gets the name of the executable file to run.
Top

See Also

FxCop Class
FxCop Members
MSBuild.Community.Tasks Namespace


AnalysisReportFileName Property

FxCop.AnalysisReportFileName Property
[image]

Specifies the file name for the analysis report.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AnalysisReportFileName As String
C#
public string AnalysisReportFileName { get; set; }
C++
public property string AnalysisReportFileName sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_AnalysisReportFileName();

/** property */
public void set_AnalysisReportFileName(string value);
JScript
public function get AnalysisReportFileName() : String

public function set AnalysisReportFileName(value : String);

See Also

FxCop Class
FxCop Members
MSBuild.Community.Tasks Namespace


ApplyOutXsl Property

FxCop.ApplyOutXsl Property
[image]

Applies the XSL transformation specified in /outXsl to the analysis report before saving the file.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property ApplyOutXsl As Boolean
C#
public bool ApplyOutXsl { get; set; }
C++
public property bool ApplyOutXsl sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_ApplyOutXsl();

/** property */
public void set_ApplyOutXsl(bool value);
JScript
public function get ApplyOutXsl() : bool

public function set ApplyOutXsl(value : bool);

See Also

FxCop Class
FxCop Members
MSBuild.Community.Tasks Namespace


ConsoleXslFileName Property

FxCop.ConsoleXslFileName Property
[image]

Specifies the XSL or XSLT file that contains a transformation to be applied to the analysis output before it is displayed in the console.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property ConsoleXslFileName As String
C#
public string ConsoleXslFileName { get; set; }
C++
public property string ConsoleXslFileName sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_ConsoleXslFileName();

/** property */
public void set_ConsoleXslFileName(string value);
JScript
public function get ConsoleXslFileName() : String

public function set ConsoleXslFileName(value : String);

See Also

FxCop Class
FxCop Members
MSBuild.Community.Tasks Namespace


DependencyDirectories Property

FxCop.DependencyDirectories Property
[image]

Specifies additional directories to search for assembly dependencies. FxCopCmd always searches the target assembly directory and the current working directory.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property DependencyDirectories As ITaskItem[]
C#
public ITaskItem[] DependencyDirectories { get; set; }
C++
public property ITaskItem[] DependencyDirectories sealed {
array<ITaskItem>^ get();
void set(array<ITaskItem>^ value);
}
J#
/** property */
public ITaskItem[] get_DependencyDirectories();

/** property */
public void set_DependencyDirectories(ITaskItem[] value);
JScript
public function get DependencyDirectories() : ITaskItem[]

public function set DependencyDirectories(value : ITaskItem[]);

See Also

FxCop Class
FxCop Members
MSBuild.Community.Tasks Namespace


DirectOutputToConsole Property

FxCop.DirectOutputToConsole Property
[image]

Directs analysis output to the console or to the Output window in Visual Studio .NET. By default, the XSL file FxCopConsoleOutput.xsl is applied to the output before it is displayed.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property DirectOutputToConsole As Boolean
C#
public bool DirectOutputToConsole { get; set; }
C++
public property bool DirectOutputToConsole sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_DirectOutputToConsole();

/** property */
public void set_DirectOutputToConsole(bool value);
JScript
public function get DirectOutputToConsole() : bool

public function set DirectOutputToConsole(value : bool);

See Also

FxCop Class
FxCop Members
MSBuild.Community.Tasks Namespace


FailOnError Property

FxCop.FailOnError Property
[image]

Gets or sets a value indicating whether the build should fail if static code analysis reports errors. Defaults to true.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property FailOnError As Boolean
C#
public bool FailOnError { get; set; }
C++
public property bool FailOnError sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_FailOnError();

/** property */
public void set_FailOnError(bool value);
JScript
public function get FailOnError() : bool

public function set FailOnError(value : bool);

Property Value

true if verbose; otherwise, false.

See Also

FxCop Class
FxCop Members
MSBuild.Community.Tasks Namespace


ImportFiles Property

FxCop.ImportFiles Property
[image]

Specifies the name of an analysis report or project file to import. Any messages in the imported file that are marked as excluded are not included in the analysis results.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property ImportFiles As ITaskItem[]
C#
public ITaskItem[] ImportFiles { get; set; }
C++
public property ITaskItem[] ImportFiles sealed {
array<ITaskItem>^ get();
void set(array<ITaskItem>^ value);
}
J#
/** property */
public ITaskItem[] get_ImportFiles();

/** property */
public void set_ImportFiles(ITaskItem[] value);
JScript
public function get ImportFiles() : ITaskItem[]

public function set ImportFiles(value : ITaskItem[]);

See Also

FxCop Class
FxCop Members
MSBuild.Community.Tasks Namespace


IncludeSummaryReport Property

FxCop.IncludeSummaryReport Property
[image]

Includes a summary report with the informational messages returned by FxCopCmd.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property IncludeSummaryReport As Boolean
C#
public bool IncludeSummaryReport { get; set; }
C++
public property bool IncludeSummaryReport sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_IncludeSummaryReport();

/** property */
public void set_IncludeSummaryReport(bool value);
JScript
public function get IncludeSummaryReport() : bool

public function set IncludeSummaryReport(value : bool);

See Also

FxCop Class
FxCop Members
MSBuild.Community.Tasks Namespace


OutputXslFileName Property

FxCop.OutputXslFileName Property
[image]

Specifies the XSL or XSLT file that is referenced by the xml-stylesheet processing instruction in the analysis report.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property OutputXslFileName As String
C#
public string OutputXslFileName { get; set; }
C++
public property string OutputXslFileName sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_OutputXslFileName();

/** property */
public void set_OutputXslFileName(string value);
JScript
public function get OutputXslFileName() : String

public function set OutputXslFileName(value : String);

See Also

FxCop Class
FxCop Members
MSBuild.Community.Tasks Namespace


PlatformDirectory Property

FxCop.PlatformDirectory Property
[image]

Specifies the location of the version of Mscorlib.dll that was used when building the target assemblies if this version is not installed on the computer running FxCopCmd.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property PlatformDirectory As String
C#
public string PlatformDirectory { get; set; }
C++
public property string PlatformDirectory sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_PlatformDirectory();

/** property */
public void set_PlatformDirectory(string value);
JScript
public function get PlatformDirectory() : String

public function set PlatformDirectory(value : String);

See Also

FxCop Class
FxCop Members
MSBuild.Community.Tasks Namespace


ProjectFile Property

FxCop.ProjectFile Property
[image]

Specifies the filename of FxCop project file.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property ProjectFile As String
C#
public string ProjectFile { get; set; }
C++
public property string ProjectFile sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_ProjectFile();

/** property */
public void set_ProjectFile(string value);
JScript
public function get ProjectFile() : String

public function set ProjectFile(value : String);

See Also

FxCop Class
FxCop Members
MSBuild.Community.Tasks Namespace


RuleLibraries Property

FxCop.RuleLibraries Property
[image]

Specifies the filename(s) of FxCop rule assemblies

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property RuleLibraries As ITaskItem[]
C#
public ITaskItem[] RuleLibraries { get; set; }
C++
public property ITaskItem[] RuleLibraries sealed {
array<ITaskItem>^ get();
void set(array<ITaskItem>^ value);
}
J#
/** property */
public ITaskItem[] get_RuleLibraries();

/** property */
public void set_RuleLibraries(ITaskItem[] value);
JScript
public function get RuleLibraries() : ITaskItem[]

public function set RuleLibraries(value : ITaskItem[]);

See Also

FxCop Class
FxCop Members
MSBuild.Community.Tasks Namespace


Rules Property

FxCop.Rules Property
[image]

The list of rules to run

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Rules As ITaskItem[]
C#
public ITaskItem[] Rules { get; set; }
C++
public property ITaskItem[] Rules sealed {
array<ITaskItem>^ get();
void set(array<ITaskItem>^ value);
}
J#
/** property */
public ITaskItem[] get_Rules();

/** property */
public void set_Rules(ITaskItem[] value);
JScript
public function get Rules() : ITaskItem[]

public function set Rules(value : ITaskItem[]);

Remarks

Rule names should be provided using the format Library#RuleNumber. For example Microsoft.Design#CA1012

Place a single hyphen (-) in front of the rule name to exclude it. For example -Microsoft.Performance#CA1805

See Also

FxCop Class
FxCop Members
MSBuild.Community.Tasks Namespace


SaveResults Property

FxCop.SaveResults Property
[image]

Saves the results of the analysis in the project file.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property SaveResults As Boolean
C#
public bool SaveResults { get; set; }
C++
public property bool SaveResults sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_SaveResults();

/** property */
public void set_SaveResults(bool value);
JScript
public function get SaveResults() : bool

public function set SaveResults(value : bool);

See Also

FxCop Class
FxCop Members
MSBuild.Community.Tasks Namespace


TargetAssemblies Property

FxCop.TargetAssemblies Property
[image]

Specifies the target assembly to analyze.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property TargetAssemblies As ITaskItem[]
C#
public ITaskItem[] TargetAssemblies { get; set; }
C++
public property ITaskItem[] TargetAssemblies sealed {
array<ITaskItem>^ get();
void set(array<ITaskItem>^ value);
}
J#
/** property */
public ITaskItem[] get_TargetAssemblies();

/** property */
public void set_TargetAssemblies(ITaskItem[] value);
JScript
public function get TargetAssemblies() : ITaskItem[]

public function set TargetAssemblies(value : ITaskItem[]);

See Also

FxCop Class
FxCop Members
MSBuild.Community.Tasks Namespace


ToolName Property

FxCop.ToolName Property
[image]

Gets the name of the executable file to run.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property ToolName As String
C#
protected override string ToolName { get; }
C++
protected override property string ToolName override {
String get();
}
J#
/** property */
protected string get_ToolName();
JScript
protected function get ToolName() : String

Property Value

The name of the executable file to run.

See Also

FxCop Class
FxCop Members
MSBuild.Community.Tasks Namespace


TypeList Property

FxCop.TypeList Property
[image]

Comma-separated list of type names to analyze. This option disables analysis of assemblies, namespaces, and resources; only the specified types and their members are included in the analysis. Use the wildcard character '*' at the end of the name to select multiple types.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property TypeList As String
C#
public string TypeList { get; set; }
C++
public property string TypeList sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_TypeList();

/** property */
public void set_TypeList(string value);
JScript
public function get TypeList() : String

public function set TypeList(value : String);

See Also

FxCop Class
FxCop Members
MSBuild.Community.Tasks Namespace


Verbose Property

FxCop.Verbose Property
[image]

Gets or sets a value indicating whether the output is verbose.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Verbose As Boolean
C#
public bool Verbose { get; set; }
C++
public property bool Verbose sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_Verbose();

/** property */
public void set_Verbose(bool value);
JScript
public function get Verbose() : bool

public function set Verbose(value : bool);

Property Value

true if verbose; otherwise, false.

See Also

FxCop Class
FxCop Members
MSBuild.Community.Tasks Namespace


WorkingDirectory Property

FxCop.WorkingDirectory Property
[image]

Gets or sets the working directory.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property WorkingDirectory As String
C#
public string WorkingDirectory { get; set; }
C++
public property string WorkingDirectory sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_WorkingDirectory();

/** property */
public void set_WorkingDirectory(string value);
JScript
public function get WorkingDirectory() : String

public function set WorkingDirectory(value : String);

Property Value

The directory in which to run the executable file, or a null reference (Nothing in Visual Basic) if the executable file should be run in the current directory.

See Also

FxCop Class
FxCop Members
MSBuild.Community.Tasks Namespace


Methods

FxCop Methods
See Also Example
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. Executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | CallHostObjectToExecute | Calls the host object to perform the work of the task. (inherited from ToolTask)
Family method | ExecuteTool | Creates a temporoary response (.rsp) file and runs the executable file. (inherited from ToolTask)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GenerateCommandLineCommands | Overidden. Returns a string value containing the command line arguments to pass directly to the executable file.
Family method | GenerateFullPathToTool | Overidden. Returns the fully qualified path to the executable file.
Family method | GenerateResponseFileCommands | Returns a string value containing the command line arguments to add to the response (.rsp) file before running the executable file. (inherited from ToolTask)
Family method | GetResponseFileSwitch | Returns the command line switch used by the executable file to specifiy a response (.rsp) file. (inherited from ToolTask)
Family method | GetWorkingDirectory | Overidden. Returns the directory in which to run the executable file.
Family method | HandleTaskExecutionErrors | Handles execution errors raised by the executable file. (inherited from ToolTask)
Family method | InitializeHostObject | Initializes the host object of the task. (inherited from ToolTask)
Family method | LogEventsFromTextOutput | (inherited from ToolTask)
Family method | LogPathToTool | Logs the tool name and path to all registered loggers. (inherited from ToolTask)
Family method | LogToolCommand | Logs the starting point of the run to all registered loggers. (inherited from ToolTask)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | SkipTaskExecution | Indicates whether task execution should be skipped. (inherited from ToolTask)
Family method | ValidateParameters | Overidden. Indicates whether all task paratmeters are valid.
Top

See Also

FxCop Class
FxCop Members
MSBuild.Community.Tasks Namespace


Execute Method

FxCop.Execute Method
[image]

Executes the task.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute() As Boolean _
Implements ITask.Execute
C#
public override bool Execute()
C++
public:
virtual bool Execute() override
J#
public override bool Execute()
JScript
public override function Execute() : bool

Return Value

true if the task ran successfully; otherwise false.

Implements

ITask.Execute

See Also

FxCop Class
FxCop Members
MSBuild.Community.Tasks Namespace


GenerateCommandLineCommands Method

FxCop.GenerateCommandLineCommands Method
[image]

Returns a string value containing the command line arguments to pass directly to the executable file.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GenerateCommandLineCommands() As String
C#
protected override string GenerateCommandLineCommands()
C++
protected:
virtual String GenerateCommandLineCommands() override
J#
protected override string GenerateCommandLineCommands()
JScript
protected override function GenerateCommandLineCommands() : String

Return Value

A string value containing the command line arguments to pass directly to the executable file.

See Also

FxCop Class
FxCop Members
MSBuild.Community.Tasks Namespace


GenerateFullPathToTool Method

FxCop.GenerateFullPathToTool Method
[image]

Returns the fully qualified path to the executable file.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GenerateFullPathToTool() As String
C#
protected override string GenerateFullPathToTool()
C++
protected:
virtual String GenerateFullPathToTool() override
J#
protected override string GenerateFullPathToTool()
JScript
protected override function GenerateFullPathToTool() : String

Return Value

The fully qualified path to the executable file.

See Also

FxCop Class
FxCop Members
MSBuild.Community.Tasks Namespace


GetWorkingDirectory Method

FxCop.GetWorkingDirectory Method
[image]

Returns the directory in which to run the executable file.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetWorkingDirectory() As String
C#
protected override string GetWorkingDirectory()
C++
protected:
virtual String GetWorkingDirectory() override
J#
protected override string GetWorkingDirectory()
JScript
protected override function GetWorkingDirectory() : String

Return Value

The directory in which to run the executable file, or a null reference (Nothing in Visual Basic) if the executable file should be run in the current directory.

See Also

FxCop Class
FxCop Members
MSBuild.Community.Tasks Namespace


ValidateParameters Method

FxCop.ValidateParameters Method
[image]

Indicates whether all task paratmeters are valid.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function ValidateParameters() As Boolean
C#
protected override bool ValidateParameters()
C++
protected:
virtual bool ValidateParameters() override
J#
protected override bool ValidateParameters()
JScript
protected override function ValidateParameters() : bool

Return Value

true if all task parameters are valid; otherwise, false

See Also

FxCop Class
FxCop Members
MSBuild.Community.Tasks Namespace


GacUtil Class

GacUtil Class
See Also Example Members
[image]

MSBuild task to install and uninstall asseblies into the GAC

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class GacUtil
Inherits ToolTask
C#
public class GacUtil : ToolTask
C++
ref class GacUtil : ToolTask
J#
public class GacUtil extends ToolTask
JScript
public class GacUtil extends ToolTask

Example

Install a dll into the GAC.

Copy Code
                <GacUtil
                    Command="Install"
                    Assemblies="MSBuild.Community.Tasks.dll"
                    Force="true" />
Uninstall a dll from the GAC.
Copy Code
                <GacUtil
                    Command="Uninstall"
                    Assemblies="MSBuild.Community.Tasks"
                    Force="true" />

Inheritance Hierarchy

System.Object
Microsoft.Build.Utilities.Task
Microsoft.Build.Utilities.ToolTask
MSBuild.Community.Tasks.GacUtil

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

GacUtil Members
MSBuild.Community.Tasks Namespace


GacUtil Members

GacUtil Members
See Also Example Constructors Properties Methods
[image]

MSBuild task to install and uninstall asseblies into the GAC

The following tables list the members exposed by GacUtil.

Public Constructors

 | Name | Description
Public method | GacUtil | Initializes a new instance of the GacUtil class.
Top

Public Properties

 | Name | Description
Public property | Assemblies | Gets or sets the assembly.
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | Command | Gets or sets the command.
Public property | ExitCode | Gets the returned exit code of the executable file. (inherited from ToolTask)
Public property | Force | Gets or sets a value indicating whether to force reinstall of an assembly.
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Timeout | Gets or sets the amount of time after which the task executable is terminated. (inherited from ToolTask)
Public property | ToolPath | Gets or sets the path of the executable file to run. (inherited from ToolTask)
Top

Protected Properties

 | Name | Description
Family property | EnvironmentOverride | Gets the override value of the PATH environment variable. (inherited from ToolTask)
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | ResponseFileEncoding | Gets the Encoding of the response file. (inherited from ToolTask)
Family property | StandardErrorEncoding | Gets the Encoding of the standard error stream of the task. (inherited from ToolTask)
Family property | StandardErrorLoggingImportance | Gets the MessageImportance with which to log errors. (inherited from ToolTask)
Family property | StandardOutputEncoding | Gets the Encoding of the standard output stream of the task. (inherited from ToolTask)
Family property | StandardOutputLoggingImportance | Overidden. Gets the MessageImportance with which to log errors.
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Family property | ToolName | Overidden. Gets the name of the executable file to run.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. Runs the exectuable file with the specified task parameters.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | CallHostObjectToExecute | Calls the host object to perform the work of the task. (inherited from ToolTask)
Family method | ExecuteTool | Creates a temporoary response (.rsp) file and runs the executable file. (inherited from ToolTask)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GenerateCommandLineCommands | Overidden. Returns a string value containing the command line arguments to pass directly to the executable file.
Family method | GenerateFullPathToTool | Overidden. Returns the fully qualified path to the executable file.
Family method | GenerateResponseFileCommands | Returns a string value containing the command line arguments to add to the response (.rsp) file before running the executable file. (inherited from ToolTask)
Family method | GetResponseFileSwitch | Returns the command line switch used by the executable file to specifiy a response (.rsp) file. (inherited from ToolTask)
Family method | GetWorkingDirectory | Returns the directory in which to run the executable file. (inherited from ToolTask)
Family method | HandleTaskExecutionErrors | Handles execution errors raised by the executable file. (inherited from ToolTask)
Family method | InitializeHostObject | Initializes the host object of the task. (inherited from ToolTask)
Family method | LogEventsFromTextOutput | (inherited from ToolTask)
Family method | LogPathToTool | Logs the tool name and path to all registered loggers. (inherited from ToolTask)
Family method | LogToolCommand | Overidden. Logs the starting point of the run to all registered loggers.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | SkipTaskExecution | Indicates whether task execution should be skipped. (inherited from ToolTask)
Family method | ValidateParameters | Indicates whether all task paratmeters are valid. (inherited from ToolTask)
Top

See Also

GacUtil Class
GacUtil Members
MSBuild.Community.Tasks Namespace


GacUtil Constructor

GacUtil Constructor
[image]

Initializes a new instance of the GacUtil class.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public GacUtil()
C++
public:
GacUtil() sealed
J#
public GacUtil()
JScript
public function GacUtil()

See Also

GacUtil Class
GacUtil Members
MSBuild.Community.Tasks Namespace


Properties

GacUtil Properties
See Also Example
[image]

Public Properties

 | Name | Description
Public property | Assemblies | Gets or sets the assembly.
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | Command | Gets or sets the command.
Public property | ExitCode | Gets the returned exit code of the executable file. (inherited from ToolTask)
Public property | Force | Gets or sets a value indicating whether to force reinstall of an assembly.
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Timeout | Gets or sets the amount of time after which the task executable is terminated. (inherited from ToolTask)
Public property | ToolPath | Gets or sets the path of the executable file to run. (inherited from ToolTask)
Top

Protected Properties

 | Name | Description
Family property | EnvironmentOverride | Gets the override value of the PATH environment variable. (inherited from ToolTask)
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | ResponseFileEncoding | Gets the Encoding of the response file. (inherited from ToolTask)
Family property | StandardErrorEncoding | Gets the Encoding of the standard error stream of the task. (inherited from ToolTask)
Family property | StandardErrorLoggingImportance | Gets the MessageImportance with which to log errors. (inherited from ToolTask)
Family property | StandardOutputEncoding | Gets the Encoding of the standard output stream of the task. (inherited from ToolTask)
Family property | StandardOutputLoggingImportance | Overidden. Gets the MessageImportance with which to log errors.
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Family property | ToolName | Overidden. Gets the name of the executable file to run.
Top

See Also

GacUtil Class
GacUtil Members
MSBuild.Community.Tasks Namespace


Assemblies Property

GacUtil.Assemblies Property
[image]

Gets or sets the assembly.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Required>
Public Property Assemblies As String[]
C#
[Required]
public string[] Assemblies { get; set; }
C++
[Required]
public property string[] Assemblies sealed {
array<String>^ get();
void set(array<String>^ value);
}
J#
/** @attribute Required() */
/** property */
public string[] get_Assemblies();

/** property */
public void set_Assemblies(string[] value);
JScript
public function get Assemblies() : String[]

public function set Assemblies(value : String[]);

Property Value

The assembly.

See Also

GacUtil Class
GacUtil Members
MSBuild.Community.Tasks Namespace


Command Property

GacUtil.Command Property
[image]

Gets or sets the command.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Command As String
C#
public string Command { get; set; }
C++
public property string Command sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Command();

/** property */
public void set_Command(string value);
JScript
public function get Command() : String

public function set Command(value : String);

Property Value

The command.

See Also

GacUtil Class
GacUtil Members
MSBuild.Community.Tasks Namespace


Force Property

GacUtil.Force Property
[image]

Gets or sets a value indicating whether to force reinstall of an assembly.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Force As Boolean
C#
public bool Force { get; set; }
C++
public property bool Force sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_Force();

/** property */
public void set_Force(bool value);
JScript
public function get Force() : bool

public function set Force(value : bool);

Property Value

true if force; otherwise, false.

See Also

GacUtil Class
GacUtil Members
MSBuild.Community.Tasks Namespace


StandardOutputLoggingImportance Property

GacUtil.StandardOutputLoggingImportance Property
[image]

Gets the MessageImportance with which to log errors.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property StandardOutputLoggingImportance As MessageImportance
C#
protected override MessageImportance StandardOutputLoggingImportance { get; }
C++
protected override property MessageImportance StandardOutputLoggingImportance override {
MessageImportance get();
}
J#
/** property */
protected MessageImportance get_StandardOutputLoggingImportance();
JScript
protected function get StandardOutputLoggingImportance() : MessageImportance

Property Value

The MessageImportance with which to log errors.

See Also

GacUtil Class
GacUtil Members
MSBuild.Community.Tasks Namespace


ToolName Property

GacUtil.ToolName Property
[image]

Gets the name of the executable file to run.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property ToolName As String
C#
protected override string ToolName { get; }
C++
protected override property string ToolName override {
String get();
}
J#
/** property */
protected string get_ToolName();
JScript
protected function get ToolName() : String

Property Value

The name of the executable file to run.

See Also

GacUtil Class
GacUtil Members
MSBuild.Community.Tasks Namespace


Methods

GacUtil Methods
See Also Example
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. Runs the exectuable file with the specified task parameters.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | CallHostObjectToExecute | Calls the host object to perform the work of the task. (inherited from ToolTask)
Family method | ExecuteTool | Creates a temporoary response (.rsp) file and runs the executable file. (inherited from ToolTask)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GenerateCommandLineCommands | Overidden. Returns a string value containing the command line arguments to pass directly to the executable file.
Family method | GenerateFullPathToTool | Overidden. Returns the fully qualified path to the executable file.
Family method | GenerateResponseFileCommands | Returns a string value containing the command line arguments to add to the response (.rsp) file before running the executable file. (inherited from ToolTask)
Family method | GetResponseFileSwitch | Returns the command line switch used by the executable file to specifiy a response (.rsp) file. (inherited from ToolTask)
Family method | GetWorkingDirectory | Returns the directory in which to run the executable file. (inherited from ToolTask)
Family method | HandleTaskExecutionErrors | Handles execution errors raised by the executable file. (inherited from ToolTask)
Family method | InitializeHostObject | Initializes the host object of the task. (inherited from ToolTask)
Family method | LogEventsFromTextOutput | (inherited from ToolTask)
Family method | LogPathToTool | Logs the tool name and path to all registered loggers. (inherited from ToolTask)
Family method | LogToolCommand | Overidden. Logs the starting point of the run to all registered loggers.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | SkipTaskExecution | Indicates whether task execution should be skipped. (inherited from ToolTask)
Family method | ValidateParameters | Indicates whether all task paratmeters are valid. (inherited from ToolTask)
Top

See Also

GacUtil Class
GacUtil Members
MSBuild.Community.Tasks Namespace


Execute Method

GacUtil.Execute Method
[image]

Runs the exectuable file with the specified task parameters.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute() As Boolean _
Implements ITask.Execute
C#
public override bool Execute()
C++
public:
virtual bool Execute() override
J#
public override bool Execute()
JScript
public override function Execute() : bool

Return Value

true if the task runs successfully; otherwise, false.

Implements

ITask.Execute

See Also

GacUtil Class
GacUtil Members
MSBuild.Community.Tasks Namespace


GenerateCommandLineCommands Method

GacUtil.GenerateCommandLineCommands Method
[image]

Returns a string value containing the command line arguments to pass directly to the executable file.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GenerateCommandLineCommands() As String
C#
protected override string GenerateCommandLineCommands()
C++
protected:
virtual String GenerateCommandLineCommands() override
J#
protected override string GenerateCommandLineCommands()
JScript
protected override function GenerateCommandLineCommands() : String

Return Value

A string value containing the command line arguments to pass directly to the executable file.

See Also

GacUtil Class
GacUtil Members
MSBuild.Community.Tasks Namespace


GenerateFullPathToTool Method

GacUtil.GenerateFullPathToTool Method
[image]

Returns the fully qualified path to the executable file.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GenerateFullPathToTool() As String
C#
protected override string GenerateFullPathToTool()
C++
protected:
virtual String GenerateFullPathToTool() override
J#
protected override string GenerateFullPathToTool()
JScript
protected override function GenerateFullPathToTool() : String

Return Value

The fully qualified path to the executable file.

See Also

GacUtil Class
GacUtil Members
MSBuild.Community.Tasks Namespace


LogToolCommand Method

GacUtil.LogToolCommand Method
[image]

Logs the starting point of the run to all registered loggers.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub LogToolCommand( _
ByVal message As String _
)
C#
protected override void LogToolCommand(
string message
)
C++
protected:
virtual void LogToolCommand(
String message
) override
J#
protected override void LogToolCommand(
string message
)
JScript
protected override function LogToolCommand(
message : String
)

Parameters

message
A descriptive message to provide loggers, usually the command line and switches.

See Also

GacUtil Class
GacUtil Members
MSBuild.Community.Tasks Namespace


GacUtilCommands Enumeration

GacUtilCommands Enumeration
[image]

The list of the commans available to the GacUtil Task

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Enum GacUtilCommands
C#
public enum GacUtilCommands
C++
public enum class GacUtilCommands
J#
public enum GacUtilCommands
JScript
public enum GacUtilCommands

Members

Member Name | Description
Install | Install the list of assemblies into the GAC.
Uninstall | Uninstall the list of assembly names from the GAC.

See Also

GacUtilCommands Members
MSBuild.Community.Tasks Namespace


GetSolutionProjects Class

GetSolutionProjects Class
See Also Example Members
[image]

Task to get paths to projects and project names from VS2005 solution file

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class GetSolutionProjects
Inherits Task
C#
public class GetSolutionProjects : Task
C++
ref class GetSolutionProjects : Task
J#
public class GetSolutionProjects extends Task
JScript
public class GetSolutionProjects extends Task

Example

Returns project name and relative path from test solution

Copy Code
              <Target Name="Test">
                  <GetSolutionProjects Solution="TestSolution.sln">
                      <Output ItemName="ProjectFiles" TaskParameter="Output"/>
                  </GetSolutionProjects>

                <Message Text="Solution Project paths:" />
                <Message Text="%(ProjectFiles.ProjectName) : @(ProjectFiles)" />
              </Target>

Inheritance Hierarchy

System.Object
Microsoft.Build.Utilities.Task
MSBuild.Community.Tasks.GetSolutionProjects

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

GetSolutionProjects Members
MSBuild.Community.Tasks Namespace


GetSolutionProjects Members

GetSolutionProjects Members
See Also Example Constructors Properties Methods
[image]

Task to get paths to projects and project names from VS2005 solution file

The following tables list the members exposed by GetSolutionProjects.

Public Constructors

 | Name | Description
Public method | GetSolutionProjects | Initializes a new instance of the GetSolutionProjects class.
Top

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Output | Output list contains TaskItems of project filenames contained within the given solution. Metadata tag "ProjectName" contains name of project.
Public property | Solution | Name of Solution to get Projects from
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. Perform task
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

GetSolutionProjects Class
GetSolutionProjects Members
MSBuild.Community.Tasks Namespace


GetSolutionProjects Constructor

GetSolutionProjects Constructor
[image]

Initializes a new instance of the GetSolutionProjects class.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public GetSolutionProjects()
C++
public:
GetSolutionProjects() sealed
J#
public GetSolutionProjects()
JScript
public function GetSolutionProjects()

See Also

GetSolutionProjects Class
GetSolutionProjects Members
MSBuild.Community.Tasks Namespace


Properties

GetSolutionProjects Properties
See Also Example
[image]

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Output | Output list contains TaskItems of project filenames contained within the given solution. Metadata tag "ProjectName" contains name of project.
Public property | Solution | Name of Solution to get Projects from
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

See Also

GetSolutionProjects Class
GetSolutionProjects Members
MSBuild.Community.Tasks Namespace


Output Property

GetSolutionProjects.Output Property
[image]

Output list contains TaskItems of project filenames contained within the given solution. Metadata tag "ProjectName" contains name of project.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Output>
Public Property Output As ITaskItem[]
C#
[Output]
public ITaskItem[] Output { get; set; }
C++
[Output]
public property ITaskItem[] Output sealed {
array<ITaskItem>^ get();
void set(array<ITaskItem>^ value);
}
J#
/** @attribute Output() */
/** property */
public ITaskItem[] get_Output();

/** property */
public void set_Output(ITaskItem[] value);
JScript
public function get Output() : ITaskItem[]

public function set Output(value : ITaskItem[]);

See Also

GetSolutionProjects Class
GetSolutionProjects Members
MSBuild.Community.Tasks Namespace


Solution Property

GetSolutionProjects.Solution Property
[image]

Name of Solution to get Projects from

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Required>
Public Property Solution As String
C#
[Required]
public string Solution { get; set; }
C++
[Required]
public property string Solution sealed {
String get();
void set(String value);
}
J#
/** @attribute Required() */
/** property */
public string get_Solution();

/** property */
public void set_Solution(string value);
JScript
public function get Solution() : String

public function set Solution(value : String);

See Also

GetSolutionProjects Class
GetSolutionProjects Members
MSBuild.Community.Tasks Namespace


Methods

GetSolutionProjects Methods
See Also Example
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. Perform task
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

GetSolutionProjects Class
GetSolutionProjects Members
MSBuild.Community.Tasks Namespace


Execute Method

GetSolutionProjects.Execute Method
[image]

Perform task

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute() As Boolean _
Implements ITask.Execute
C#
public override bool Execute()
C++
public:
virtual bool Execute() override
J#
public override bool Execute()
JScript
public override function Execute() : bool

Return Value

true on success

Implements

ITask.Execute

See Also

GetSolutionProjects Class
GetSolutionProjects Members
MSBuild.Community.Tasks Namespace


ILMerge Class

ILMerge Class
See Also Example Members
[image]

A wrapper for the ILMerge tool.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class ILMerge
Inherits ToolTask
C#
public class ILMerge : ToolTask
C++
ref class ILMerge : ToolTask
J#
public class ILMerge extends ToolTask
JScript
public class ILMerge extends ToolTask

Example

This example merges two assemblies A.dll and B.dll into one:

Copy Code
             <PropertyGroup>
                 <outputFile>$(testDir)\ilmergetest.dll</outputFile>
                 <keyFile>$(testDir)\keypair.snk</keyFile>
                 <excludeFile>$(testDir)\ExcludeTypes.txt</excludeFile>
                 <logFile>$(testDir)\ilmergetest.log</logFile>
             </PropertyGroup>

             <ItemGroup>
                 <inputAssemblies Include="$(testDir)\A.dll" />
                 <inputAssemblies Include="$(testDir)\B.dll" />

                 <allowDuplicates Include="ClassAB" />
             </ItemGroup>

             <Target Name="merge" >
                <ILMerge InputAssemblies="@(inputAssemblies)"
                    AllowDuplicateTypes="@(allowDuplicates)"
                    ExcludeFile="$(excludeFile)"
                    OutputFile="$(outputFile)" LogFile="$(logFile)"
                    DebugInfo="true" XmlDocumentation="true"
                    KeyFile="$(keyFile)" DelaySign="true" />
             </Target>

Remarks

The ILMerge tool itself must be installed separately. It is available here.

The command line options "/wildcards" and "/lib" of ILMerge are not supported, because MSBuild is in charge of expanding wildcards for item groups.

Inheritance Hierarchy

System.Object
Microsoft.Build.Utilities.Task
Microsoft.Build.Utilities.ToolTask
MSBuild.Community.Tasks.ILMerge

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ILMerge Members
MSBuild.Community.Tasks Namespace


ILMerge Members

ILMerge Members
See Also Example Constructors Properties Methods
[image]

A wrapper for the ILMerge tool.

The following tables list the members exposed by ILMerge.

Public Constructors

 | Name | Description
Public method | ILMerge | Initializes a new instance of the ILMerge class.
Top

Public Properties

 | Name | Description
Public property | AllowDuplicateTypes | Gets or sets the names of public types to be renamed when they are duplicates.
Public property | AllowZeroPeKind | Gets or sets the flag to treat an assembly with a zero PeKind flag (this is the value of the field listed as .corflags in the Manifest) as if it was ILonly.
Public property | AttributeFile | Gets or sets the attribute assembly from whre to get all of the assembly-level attributes such as Culture, Version, etc. It will also be used to get the Win32 Resources from.
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | Closed | Gets or sets the flag to indicate whether to augment the list of input assemblies to its "transitive closure".
Public property | CopyAttributes | Gets or sets the flag to indicate whether to copy the assembly level attributes of each input assembly over into the target assembly.
Public property | DebugInfo | Gets or sets the flag to indicate whether to preserve any .pdb files that are found for the input assemblies into a .pdb file for the target assembly.
Public property | DelaySign | Gets or sets the flag to indicate whether the target assembly will be delay signed.
Public property | ExcludeFile | Gets or sets the file that will be used to identify types that are not to have their visibility modified.
Public property | ExitCode | Gets the returned exit code of the executable file. (inherited from ToolTask)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | InputAssemblies | Gets or sets the input assemblies to merge.
Public property | KeyFile | Gets or sets the .snk file to sign the target assembly.
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | LogFile | Gets or sets a log file to write log messages to.
Public property | OutputFile | Gets or sets the target assembly.
Public property | PublicKeyTokens | Gets or sets the flag to indicate whether external assembly references in the manifest of the target assembly will use public keys (false) or public key tokens (true).
Public property | TargetKind | Gets or sets the indicator whether the target assembly is created as a library (Dll), a console application (Exe) or as a Windows application (WinExe).
Public property | TargetPlatformDirectory | Gets or sets the directory in which mscorlib.dll is to be found.
Public property | TargetPlatformVersion | Gets or sets the .NET framework version for the target assembly.
Public property | Timeout | Gets or sets the amount of time after which the task executable is terminated. (inherited from ToolTask)
Public property | ToolPath | Gets or sets the path of the executable file to run. (inherited from ToolTask)
Public property | Version | Gets or sets the version number of the target assembly.
Public property | XmlDocumentation | Gets or sets the flag to indicate whether to merge XML documentation files into one for the target assembly.
Top

Protected Properties

 | Name | Description
Family property | EnvironmentOverride | Gets the override value of the PATH environment variable. (inherited from ToolTask)
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | ResponseFileEncoding | Gets the Encoding of the response file. (inherited from ToolTask)
Family property | StandardErrorEncoding | Gets the Encoding of the standard error stream of the task. (inherited from ToolTask)
Family property | StandardErrorLoggingImportance | Gets the MessageImportance with which to log errors. (inherited from ToolTask)
Family property | StandardOutputEncoding | Gets the Encoding of the standard output stream of the task. (inherited from ToolTask)
Family property | StandardOutputLoggingImportance | Gets the MessageImportance with which to log errors. (inherited from ToolTask)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Family property | ToolName | Overidden. Gets the name of the executable file to run.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Runs the exectuable file with the specified task parameters. (inherited from ToolTask)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | CallHostObjectToExecute | Calls the host object to perform the work of the task. (inherited from ToolTask)
Family method | ExecuteTool | Creates a temporoary response (.rsp) file and runs the executable file. (inherited from ToolTask)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GenerateCommandLineCommands | Overidden. Returns a string value containing the command line arguments to pass directly to the executable file.
Family method | GenerateFullPathToTool | Overidden. Gets the standard installation path of ILMerge.exe.
Family method | GenerateResponseFileCommands | Returns a string value containing the command line arguments to add to the response (.rsp) file before running the executable file. (inherited from ToolTask)
Family method | GetResponseFileSwitch | Returns the command line switch used by the executable file to specifiy a response (.rsp) file. (inherited from ToolTask)
Family method | GetWorkingDirectory | Returns the directory in which to run the executable file. (inherited from ToolTask)
Family method | HandleTaskExecutionErrors | Handles execution errors raised by the executable file. (inherited from ToolTask)
Family method | InitializeHostObject | Initializes the host object of the task. (inherited from ToolTask)
Family method | LogEventsFromTextOutput | (inherited from ToolTask)
Family method | LogPathToTool | Logs the tool name and path to all registered loggers. (inherited from ToolTask)
Family method | LogToolCommand | Logs the starting point of the run to all registered loggers. (inherited from ToolTask)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | SkipTaskExecution | Indicates whether task execution should be skipped. (inherited from ToolTask)
Family method | ValidateParameters | Indicates whether all task paratmeters are valid. (inherited from ToolTask)
Top

See Also

ILMerge Class
ILMerge Members
MSBuild.Community.Tasks Namespace


ILMerge Constructor

ILMerge Constructor
[image]

Initializes a new instance of the ILMerge class.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ILMerge()
C++
public:
ILMerge() sealed
J#
public ILMerge()
JScript
public function ILMerge()

See Also

ILMerge Class
ILMerge Members
MSBuild.Community.Tasks Namespace


Properties

ILMerge Properties
See Also Example
[image]

Public Properties

 | Name | Description
Public property | AllowDuplicateTypes | Gets or sets the names of public types to be renamed when they are duplicates.
Public property | AllowZeroPeKind | Gets or sets the flag to treat an assembly with a zero PeKind flag (this is the value of the field listed as .corflags in the Manifest) as if it was ILonly.
Public property | AttributeFile | Gets or sets the attribute assembly from whre to get all of the assembly-level attributes such as Culture, Version, etc. It will also be used to get the Win32 Resources from.
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | Closed | Gets or sets the flag to indicate whether to augment the list of input assemblies to its "transitive closure".
Public property | CopyAttributes | Gets or sets the flag to indicate whether to copy the assembly level attributes of each input assembly over into the target assembly.
Public property | DebugInfo | Gets or sets the flag to indicate whether to preserve any .pdb files that are found for the input assemblies into a .pdb file for the target assembly.
Public property | DelaySign | Gets or sets the flag to indicate whether the target assembly will be delay signed.
Public property | ExcludeFile | Gets or sets the file that will be used to identify types that are not to have their visibility modified.
Public property | ExitCode | Gets the returned exit code of the executable file. (inherited from ToolTask)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | InputAssemblies | Gets or sets the input assemblies to merge.
Public property | KeyFile | Gets or sets the .snk file to sign the target assembly.
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | LogFile | Gets or sets a log file to write log messages to.
Public property | OutputFile | Gets or sets the target assembly.
Public property | PublicKeyTokens | Gets or sets the flag to indicate whether external assembly references in the manifest of the target assembly will use public keys (false) or public key tokens (true).
Public property | TargetKind | Gets or sets the indicator whether the target assembly is created as a library (Dll), a console application (Exe) or as a Windows application (WinExe).
Public property | TargetPlatformDirectory | Gets or sets the directory in which mscorlib.dll is to be found.
Public property | TargetPlatformVersion | Gets or sets the .NET framework version for the target assembly.
Public property | Timeout | Gets or sets the amount of time after which the task executable is terminated. (inherited from ToolTask)
Public property | ToolPath | Gets or sets the path of the executable file to run. (inherited from ToolTask)
Public property | Version | Gets or sets the version number of the target assembly.
Public property | XmlDocumentation | Gets or sets the flag to indicate whether to merge XML documentation files into one for the target assembly.
Top

Protected Properties

 | Name | Description
Family property | EnvironmentOverride | Gets the override value of the PATH environment variable. (inherited from ToolTask)
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | ResponseFileEncoding | Gets the Encoding of the response file. (inherited from ToolTask)
Family property | StandardErrorEncoding | Gets the Encoding of the standard error stream of the task. (inherited from ToolTask)
Family property | StandardErrorLoggingImportance | Gets the MessageImportance with which to log errors. (inherited from ToolTask)
Family property | StandardOutputEncoding | Gets the Encoding of the standard output stream of the task. (inherited from ToolTask)
Family property | StandardOutputLoggingImportance | Gets the MessageImportance with which to log errors. (inherited from ToolTask)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Family property | ToolName | Overidden. Gets the name of the executable file to run.
Top

See Also

ILMerge Class
ILMerge Members
MSBuild.Community.Tasks Namespace


AllowDuplicateTypes Property

ILMerge.AllowDuplicateTypes Property
[image]

Gets or sets the names of public types to be renamed when they are duplicates.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AllowDuplicateTypes As ITaskItem[]
C#
public ITaskItem[] AllowDuplicateTypes { get; set; }
C++
public property ITaskItem[] AllowDuplicateTypes sealed {
array<ITaskItem>^ get();
void set(array<ITaskItem>^ value);
}
J#
/** property */
public ITaskItem[] get_AllowDuplicateTypes();

/** property */
public void set_AllowDuplicateTypes(ITaskItem[] value);
JScript
public function get AllowDuplicateTypes() : ITaskItem[]

public function set AllowDuplicateTypes(value : ITaskItem[]);

Remarks

Set to an empty item group to allow all public types to be renamed.

Don't provide this parameter if no duplicates of public types are allowed.

Corresponds to command line option "/allowDup".

The default value is null.

See Also

ILMerge Class
ILMerge Members
MSBuild.Community.Tasks Namespace


AllowZeroPeKind Property

ILMerge.AllowZeroPeKind Property
[image]

Gets or sets the flag to treat an assembly with a zero PeKind flag (this is the value of the field listed as .corflags in the Manifest) as if it was ILonly.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AllowZeroPeKind As Boolean
C#
public bool AllowZeroPeKind { get; set; }
C++
public property bool AllowZeroPeKind sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_AllowZeroPeKind();

/** property */
public void set_AllowZeroPeKind(bool value);
JScript
public function get AllowZeroPeKind() : bool

public function set AllowZeroPeKind(value : bool);

Remarks

Corresponds to command line option "/zeroPeKind".

The default value is false.

See Also

ILMerge Class
ILMerge Members
MSBuild.Community.Tasks Namespace


AttributeFile Property

ILMerge.AttributeFile Property
[image]

Gets or sets the attribute assembly from whre to get all of the assembly-level attributes such as Culture, Version, etc. It will also be used to get the Win32 Resources from.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AttributeFile As ITaskItem
C#
public ITaskItem AttributeFile { get; set; }
C++
public property ITaskItem AttributeFile sealed {
ITaskItem get();
void set(ITaskItem value);
}
J#
/** property */
public ITaskItem get_AttributeFile();

/** property */
public void set_AttributeFile(ITaskItem value);
JScript
public function get AttributeFile() : ITaskItem

public function set AttributeFile(value : ITaskItem);

Remarks

This property is mutually exclusive with CopyAttributes.

When not specified, then the Win32 Resources from the primary assembly are copied over into the target assembly.

Corresponds to command line option "/attr".

The default value is null.

See Also

ILMerge Class
ILMerge Members
MSBuild.Community.Tasks Namespace


Closed Property

ILMerge.Closed Property
[image]

Gets or sets the flag to indicate whether to augment the list of input assemblies to its "transitive closure".

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Closed As Boolean
C#
public bool Closed { get; set; }
C++
public property bool Closed sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_Closed();

/** property */
public void set_Closed(bool value);
JScript
public function get Closed() : bool

public function set Closed(value : bool);

Remarks

An assembly is considered part of the transitive closure if it is referenced, either directly or indirectly, from one of the originally specified input assemblies and it has an external reference to one of the input assemblies, or one of the assemblies that has such a reference.

Corresponds to command line option "/closed".

The default value is false.

See Also

ILMerge Class
ILMerge Members
MSBuild.Community.Tasks Namespace


CopyAttributes Property

ILMerge.CopyAttributes Property
[image]

Gets or sets the flag to indicate whether to copy the assembly level attributes of each input assembly over into the target assembly.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property CopyAttributes As Boolean
C#
public bool CopyAttributes { get; set; }
C++
public property bool CopyAttributes sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_CopyAttributes();

/** property */
public void set_CopyAttributes(bool value);
JScript
public function get CopyAttributes() : bool

public function set CopyAttributes(value : bool);

Remarks

Any duplicate attribute overwrites a previously copied attribute. The input assemblies are processed in the order they are specified.

This parameter is mutually exclusive with AttributeFile.

Corresponds to command line option "/copyattrs".

The default value is false.

See Also

ILMerge Class
ILMerge Members
MSBuild.Community.Tasks Namespace


DebugInfo Property

ILMerge.DebugInfo Property
[image]

Gets or sets the flag to indicate whether to preserve any .pdb files that are found for the input assemblies into a .pdb file for the target assembly.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property DebugInfo As Boolean
C#
public bool DebugInfo { get; set; }
C++
public property bool DebugInfo sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_DebugInfo();

/** property */
public void set_DebugInfo(bool value);
JScript
public function get DebugInfo() : bool

public function set DebugInfo(value : bool);

Remarks

Corresponds to command line option "/ndebug".

The default value is true.

See Also

ILMerge Class
ILMerge Members
MSBuild.Community.Tasks Namespace


DelaySign Property

ILMerge.DelaySign Property
[image]

Gets or sets the flag to indicate whether the target assembly will be delay signed.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property DelaySign As Boolean
C#
public bool DelaySign { get; set; }
C++
public property bool DelaySign sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_DelaySign();

/** property */
public void set_DelaySign(bool value);
JScript
public function get DelaySign() : bool

public function set DelaySign(value : bool);

Remarks

This property can be set only in conjunction with KeyFile.

Corresponds to command line option "/delaysign".

The default value is false.

See Also

ILMerge Class
ILMerge Members
MSBuild.Community.Tasks Namespace


ExcludeFile Property

ILMerge.ExcludeFile Property
[image]

Gets or sets the file that will be used to identify types that are not to have their visibility modified.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property ExcludeFile As ITaskItem
C#
public ITaskItem ExcludeFile { get; set; }
C++
public property ITaskItem ExcludeFile sealed {
ITaskItem get();
void set(ITaskItem value);
}
J#
/** property */
public ITaskItem get_ExcludeFile();

/** property */
public void set_ExcludeFile(ITaskItem value);
JScript
public function get ExcludeFile() : ITaskItem

public function set ExcludeFile(value : ITaskItem);

Remarks

If an empty item group is provided, then all types in any assembly other than the primary assembly are made non-public.

Omit this parameter to prevent ILMerge from modifying the visibility of any types.

The contents of the file should be one Regex per line. The regular expressions are matched against each type's full name, e.g., System.Collections.IList. If the match fails, it is tried again with the assembly name (surrounded by square brackets) prepended to the type name. Thus, the pattern \[A\].* excludes all types in assembly A from being made non-public. The pattern N.T will match all types named T in the namespace named N no matter what assembly they are defined in.

Corresponds to command line option "/internalize".

The default value is null.

See Also

ILMerge Class
ILMerge Members
MSBuild.Community.Tasks Namespace


InputAssemblies Property

ILMerge.InputAssemblies Property
[image]

Gets or sets the input assemblies to merge.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Required>
Public Property InputAssemblies As ITaskItem[]
C#
[Required]
public ITaskItem[] InputAssemblies { get; set; }
C++
[Required]
public property ITaskItem[] InputAssemblies sealed {
array<ITaskItem>^ get();
void set(array<ITaskItem>^ value);
}
J#
/** @attribute Required() */
/** property */
public ITaskItem[] get_InputAssemblies();

/** property */
public void set_InputAssemblies(ITaskItem[] value);
JScript
public function get InputAssemblies() : ITaskItem[]

public function set InputAssemblies(value : ITaskItem[]);

See Also

ILMerge Class
ILMerge Members
MSBuild.Community.Tasks Namespace


KeyFile Property

ILMerge.KeyFile Property
[image]

Gets or sets the .snk file to sign the target assembly.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property KeyFile As ITaskItem
C#
public ITaskItem KeyFile { get; set; }
C++
public property ITaskItem KeyFile sealed {
ITaskItem get();
void set(ITaskItem value);
}
J#
/** property */
public ITaskItem get_KeyFile();

/** property */
public void set_KeyFile(ITaskItem value);
JScript
public function get KeyFile() : ITaskItem

public function set KeyFile(value : ITaskItem);

Remarks

Can be used with DelaySign.

Corresponds to command line option "/keyfile".

The default value is null.

See Also

ILMerge Class
ILMerge Members
MSBuild.Community.Tasks Namespace


LogFile Property

ILMerge.LogFile Property
[image]

Gets or sets a log file to write log messages to.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property LogFile As ITaskItem
C#
public ITaskItem LogFile { get; set; }
C++
public property ITaskItem LogFile sealed {
ITaskItem get();
void set(ITaskItem value);
}
J#
/** property */
public ITaskItem get_LogFile();

/** property */
public void set_LogFile(ITaskItem value);
JScript
public function get LogFile() : ITaskItem

public function set LogFile(value : ITaskItem);

Remarks

If an empty item group is provided, then log messages are writte to Out.

Corresponds to command line option "/log".

The default value is null.

See Also

ILMerge Class
ILMerge Members
MSBuild.Community.Tasks Namespace


OutputFile Property

ILMerge.OutputFile Property
[image]

Gets or sets the target assembly.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Required>
Public Property OutputFile As ITaskItem
C#
[Required]
public ITaskItem OutputFile { get; set; }
C++
[Required]
public property ITaskItem OutputFile sealed {
ITaskItem get();
void set(ITaskItem value);
}
J#
/** @attribute Required() */
/** property */
public ITaskItem get_OutputFile();

/** property */
public void set_OutputFile(ITaskItem value);
JScript
public function get OutputFile() : ITaskItem

public function set OutputFile(value : ITaskItem);

Remarks

Corresponds to command line option "/out".

See Also

ILMerge Class
ILMerge Members
MSBuild.Community.Tasks Namespace


PublicKeyTokens Property

ILMerge.PublicKeyTokens Property
[image]

Gets or sets the flag to indicate whether external assembly references in the manifest of the target assembly will use public keys (false) or public key tokens (true).

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property PublicKeyTokens As Boolean
C#
public bool PublicKeyTokens { get; set; }
C++
public property bool PublicKeyTokens sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_PublicKeyTokens();

/** property */
public void set_PublicKeyTokens(bool value);
JScript
public function get PublicKeyTokens() : bool

public function set PublicKeyTokens(value : bool);

Remarks

Corresponds to command line option "/publickeytokens".

The default value is false.

See Also

ILMerge Class
ILMerge Members
MSBuild.Community.Tasks Namespace


TargetKind Property

ILMerge.TargetKind Property
[image]

Gets or sets the indicator whether the target assembly is created as a library (Dll), a console application (Exe) or as a Windows application (WinExe).

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property TargetKind As String
C#
public string TargetKind { get; set; }
C++
public property string TargetKind sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_TargetKind();

/** property */
public void set_TargetKind(string value);
JScript
public function get TargetKind() : String

public function set TargetKind(value : String);

Remarks

Corresponds to command line option "/target".

The default value is the same kind as that of the primary assembly.

See Also

ILMerge Class
ILMerge Members
MSBuild.Community.Tasks Namespace


TargetPlatformDirectory Property

ILMerge.TargetPlatformDirectory Property
[image]

Gets or sets the directory in which mscorlib.dll is to be found.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property TargetPlatformDirectory As ITaskItem
C#
public ITaskItem TargetPlatformDirectory { get; set; }
C++
public property ITaskItem TargetPlatformDirectory sealed {
ITaskItem get();
void set(ITaskItem value);
}
J#
/** property */
public ITaskItem get_TargetPlatformDirectory();

/** property */
public void set_TargetPlatformDirectory(ITaskItem value);
JScript
public function get TargetPlatformDirectory() : ITaskItem

public function set TargetPlatformDirectory(value : ITaskItem);

Remarks

Can only be used in conjunction with TargetPlatformVersion.

Corresponds to the second part of command line option "/targetplatform".

The default value is null.

See Also

ILMerge Class
ILMerge Members
MSBuild.Community.Tasks Namespace


TargetPlatformVersion Property

ILMerge.TargetPlatformVersion Property
[image]

Gets or sets the .NET framework version for the target assembly.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property TargetPlatformVersion As String
C#
public string TargetPlatformVersion { get; set; }
C++
public property string TargetPlatformVersion sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_TargetPlatformVersion();

/** property */
public void set_TargetPlatformVersion(string value);
JScript
public function get TargetPlatformVersion() : String

public function set TargetPlatformVersion(value : String);

Remarks

Valid values are "v1", "v1.1", "v2".

Corresponds to the first part of command line option "/targetplatform".

The default value is null.

See Also

ILMerge Class
ILMerge Members
MSBuild.Community.Tasks Namespace


ToolName Property

ILMerge.ToolName Property
[image]

Gets the name of the executable file to run.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property ToolName As String
C#
protected override string ToolName { get; }
C++
protected override property string ToolName override {
String get();
}
J#
/** property */
protected string get_ToolName();
JScript
protected function get ToolName() : String

See Also

ILMerge Class
ILMerge Members
MSBuild.Community.Tasks Namespace


Version Property

ILMerge.Version Property
[image]

Gets or sets the version number of the target assembly.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Version As String
C#
public string Version { get; set; }
C++
public property string Version sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Version();

/** property */
public void set_Version(string value);
JScript
public function get Version() : String

public function set Version(value : String);

Remarks

The parameter should look like 6.2.1.3.

Corresponds to command line option "/ver".

The default value is null.

See Also

ILMerge Class
ILMerge Members
MSBuild.Community.Tasks Namespace


XmlDocumentation Property

ILMerge.XmlDocumentation Property
[image]

Gets or sets the flag to indicate whether to merge XML documentation files into one for the target assembly.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property XmlDocumentation As Boolean
C#
public bool XmlDocumentation { get; set; }
C++
public property bool XmlDocumentation sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_XmlDocumentation();

/** property */
public void set_XmlDocumentation(bool value);
JScript
public function get XmlDocumentation() : bool

public function set XmlDocumentation(value : bool);

Remarks

Corresponds to command line option "/xmldocs".

The default value is false.

See Also

ILMerge Class
ILMerge Members
MSBuild.Community.Tasks Namespace


Methods

ILMerge Methods
See Also Example
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Runs the exectuable file with the specified task parameters. (inherited from ToolTask)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | CallHostObjectToExecute | Calls the host object to perform the work of the task. (inherited from ToolTask)
Family method | ExecuteTool | Creates a temporoary response (.rsp) file and runs the executable file. (inherited from ToolTask)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GenerateCommandLineCommands | Overidden. Returns a string value containing the command line arguments to pass directly to the executable file.
Family method | GenerateFullPathToTool | Overidden. Gets the standard installation path of ILMerge.exe.
Family method | GenerateResponseFileCommands | Returns a string value containing the command line arguments to add to the response (.rsp) file before running the executable file. (inherited from ToolTask)
Family method | GetResponseFileSwitch | Returns the command line switch used by the executable file to specifiy a response (.rsp) file. (inherited from ToolTask)
Family method | GetWorkingDirectory | Returns the directory in which to run the executable file. (inherited from ToolTask)
Family method | HandleTaskExecutionErrors | Handles execution errors raised by the executable file. (inherited from ToolTask)
Family method | InitializeHostObject | Initializes the host object of the task. (inherited from ToolTask)
Family method | LogEventsFromTextOutput | (inherited from ToolTask)
Family method | LogPathToTool | Logs the tool name and path to all registered loggers. (inherited from ToolTask)
Family method | LogToolCommand | Logs the starting point of the run to all registered loggers. (inherited from ToolTask)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | SkipTaskExecution | Indicates whether task execution should be skipped. (inherited from ToolTask)
Family method | ValidateParameters | Indicates whether all task paratmeters are valid. (inherited from ToolTask)
Top

See Also

ILMerge Class
ILMerge Members
MSBuild.Community.Tasks Namespace


GenerateCommandLineCommands Method

ILMerge.GenerateCommandLineCommands Method
[image]

Returns a string value containing the command line arguments to pass directly to the executable file.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GenerateCommandLineCommands() As String
C#
protected override string GenerateCommandLineCommands()
C++
protected:
virtual String GenerateCommandLineCommands() override
J#
protected override string GenerateCommandLineCommands()
JScript
protected override function GenerateCommandLineCommands() : String

Return Value

Returns a string value containing the command line arguments to pass directly to the executable file.

See Also

ILMerge Class
ILMerge Members
MSBuild.Community.Tasks Namespace


GenerateFullPathToTool Method

ILMerge.GenerateFullPathToTool Method
[image]

Gets the standard installation path of ILMerge.exe.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GenerateFullPathToTool() As String
C#
protected override string GenerateFullPathToTool()
C++
protected:
virtual String GenerateFullPathToTool() override
J#
protected override string GenerateFullPathToTool()
JScript
protected override function GenerateFullPathToTool() : String

Return Value

Returns [ProgramFiles]\Microsoft\ILMerge.exe.

Remarks

If ILMerge is not installed at its standard installation path, provide its location to ToolPath.

See Also

ILMerge Class
ILMerge Members
MSBuild.Community.Tasks Namespace


Mail Class

Mail Class
See Also Example Members
[image]

Sends an email message

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class Mail
Inherits Task
C#
public class Mail : Task
C++
ref class Mail : Task
J#
public class Mail extends Task
JScript
public class Mail extends Task

Example

Example of sending an email.

Copy Code
            <Target Name="Mail">
                <Mail SmtpServer="localhost"
                    To="user@email.com"
                    From="from@email.com"
                    Subject="Test Mail Task"
                    Body="This is a test of the mail task." />
            </Target>

Inheritance Hierarchy

System.Object
Microsoft.Build.Utilities.Task
MSBuild.Community.Tasks.Mail

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

Mail Members
MSBuild.Community.Tasks Namespace


Mail Members

Mail Members
See Also Example Constructors Properties Methods
[image]

Sends an email message

The following tables list the members exposed by Mail.

Public Constructors

 | Name | Description
Public method | Mail | Initializes a new instance of the T:Mail class.
Top

Public Properties

 | Name | Description
Public property | Attachments | List of files to attach to message
Public property | Bcc | List of addresss that contains the blind carbon copy (BCC) recipients for this e-mail message
Public property | Body | The email message body
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | CC | List of addresss that contains the carbon copy (CC) recipients for this e-mail message
Public property | From | The from address for this e-mail message
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | IsBodyHtml | A value indicating whether the mail message body is in Html
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Password | Gets or sets the password.
Public property | Priority | The priority of this e-mail message
Public property | SmtpServer | The name or IP address of the host used for SMTP transactions
Public property | Subject | The subject line for this e-mail message
Public property | To | List of addresss that contains the recipients of this e-mail message
Public property | Username | Gets or sets the username.
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. Sends an email message
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

Mail Class
Mail Members
MSBuild.Community.Tasks Namespace


Mail Constructor

Mail Constructor
[image]

Initializes a new instance of the T:Mail class.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public Mail()
C++
public:
Mail() sealed
J#
public Mail()
JScript
public function Mail()

See Also

Mail Class
Mail Members
MSBuild.Community.Tasks Namespace


Properties

Mail Properties
See Also Example
[image]

Public Properties

 | Name | Description
Public property | Attachments | List of files to attach to message
Public property | Bcc | List of addresss that contains the blind carbon copy (BCC) recipients for this e-mail message
Public property | Body | The email message body
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | CC | List of addresss that contains the carbon copy (CC) recipients for this e-mail message
Public property | From | The from address for this e-mail message
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | IsBodyHtml | A value indicating whether the mail message body is in Html
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Password | Gets or sets the password.
Public property | Priority | The priority of this e-mail message
Public property | SmtpServer | The name or IP address of the host used for SMTP transactions
Public property | Subject | The subject line for this e-mail message
Public property | To | List of addresss that contains the recipients of this e-mail message
Public property | Username | Gets or sets the username.
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

See Also

Mail Class
Mail Members
MSBuild.Community.Tasks Namespace


Attachments Property

Mail.Attachments Property
[image]

List of files to attach to message

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Attachments As String[]
C#
public string[] Attachments { get; set; }
C++
public property string[] Attachments sealed {
array<String>^ get();
void set(array<String>^ value);
}
J#
/** property */
public string[] get_Attachments();

/** property */
public void set_Attachments(string[] value);
JScript
public function get Attachments() : String[]

public function set Attachments(value : String[]);

See Also

Mail Class
Mail Members
MSBuild.Community.Tasks Namespace


Bcc Property

Mail.Bcc Property
[image]

List of addresss that contains the blind carbon copy (BCC) recipients for this e-mail message

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Bcc As String[]
C#
public string[] Bcc { get; set; }
C++
public property string[] Bcc sealed {
array<String>^ get();
void set(array<String>^ value);
}
J#
/** property */
public string[] get_Bcc();

/** property */
public void set_Bcc(string[] value);
JScript
public function get Bcc() : String[]

public function set Bcc(value : String[]);

See Also

Mail Class
Mail Members
MSBuild.Community.Tasks Namespace


Body Property

Mail.Body Property
[image]

The email message body

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Body As String
C#
public string Body { get; set; }
C++
public property string Body sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Body();

/** property */
public void set_Body(string value);
JScript
public function get Body() : String

public function set Body(value : String);

See Also

Mail Class
Mail Members
MSBuild.Community.Tasks Namespace


CC Property

Mail.CC Property
[image]

List of addresss that contains the carbon copy (CC) recipients for this e-mail message

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property CC As String[]
C#
public string[] CC { get; set; }
C++
public property string[] CC sealed {
array<String>^ get();
void set(array<String>^ value);
}
J#
/** property */
public string[] get_CC();

/** property */
public void set_CC(string[] value);
JScript
public function get CC() : String[]

public function set CC(value : String[]);

See Also

Mail Class
Mail Members
MSBuild.Community.Tasks Namespace


From Property

Mail.From Property
[image]

The from address for this e-mail message

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Required>
Public Property From As String
C#
[Required]
public string From { get; set; }
C++
[Required]
public property string From sealed {
String get();
void set(String value);
}
J#
/** @attribute Required() */
/** property */
public string get_From();

/** property */
public void set_From(string value);
JScript
public function get From() : String

public function set From(value : String);

Remarks

This property is required.

See Also

Mail Class
Mail Members
MSBuild.Community.Tasks Namespace


IsBodyHtml Property

Mail.IsBodyHtml Property
[image]

A value indicating whether the mail message body is in Html

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property IsBodyHtml As Boolean
C#
public bool IsBodyHtml { get; set; }
C++
public property bool IsBodyHtml sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_IsBodyHtml();

/** property */
public void set_IsBodyHtml(bool value);
JScript
public function get IsBodyHtml() : bool

public function set IsBodyHtml(value : bool);

See Also

Mail Class
Mail Members
MSBuild.Community.Tasks Namespace


Password Property

Mail.Password Property
[image]

Gets or sets the password.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Password As String
C#
public string Password { get; set; }
C++
public property string Password sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Password();

/** property */
public void set_Password(string value);
JScript
public function get Password() : String

public function set Password(value : String);

Property Value

The password.

See Also

Mail Class
Mail Members
MSBuild.Community.Tasks Namespace


Priority Property

Mail.Priority Property
[image]

The priority of this e-mail message

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Priority As String
C#
public string Priority { get; set; }
C++
public property string Priority sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Priority();

/** property */
public void set_Priority(string value);
JScript
public function get Priority() : String

public function set Priority(value : String);

Remarks

Possible values are High, Normal, and Low

See Also

Mail Class
Mail Members
MSBuild.Community.Tasks Namespace


SmtpServer Property

Mail.SmtpServer Property
[image]

The name or IP address of the host used for SMTP transactions

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Required>
Public Property SmtpServer As String
C#
[Required]
public string SmtpServer { get; set; }
C++
[Required]
public property string SmtpServer sealed {
String get();
void set(String value);
}
J#
/** @attribute Required() */
/** property */
public string get_SmtpServer();

/** property */
public void set_SmtpServer(string value);
JScript
public function get SmtpServer() : String

public function set SmtpServer(value : String);

Remarks

This property is required.

See Also

Mail Class
Mail Members
MSBuild.Community.Tasks Namespace


Subject Property

Mail.Subject Property
[image]

The subject line for this e-mail message

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Required>
Public Property Subject As String
C#
[Required]
public string Subject { get; set; }
C++
[Required]
public property string Subject sealed {
String get();
void set(String value);
}
J#
/** @attribute Required() */
/** property */
public string get_Subject();

/** property */
public void set_Subject(string value);
JScript
public function get Subject() : String

public function set Subject(value : String);

Remarks

This property is required.

See Also

Mail Class
Mail Members
MSBuild.Community.Tasks Namespace


To Property

Mail.To Property
[image]

List of addresss that contains the recipients of this e-mail message

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Required>
Public Property To As String[]
C#
[Required]
public string[] To { get; set; }
C++
[Required]
public property string[] To sealed {
array<String>^ get();
void set(array<String>^ value);
}
J#
/** @attribute Required() */
/** property */
public string[] get_To();

/** property */
public void set_To(string[] value);
JScript
public function get To() : String[]

public function set To(value : String[]);

Remarks

This property is required.

See Also

Mail Class
Mail Members
MSBuild.Community.Tasks Namespace


Username Property

Mail.Username Property
[image]

Gets or sets the username.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Username As String
C#
public string Username { get; set; }
C++
public property string Username sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Username();

/** property */
public void set_Username(string value);
JScript
public function get Username() : String

public function set Username(value : String);

Property Value

The username.

See Also

Mail Class
Mail Members
MSBuild.Community.Tasks Namespace


Methods

Mail Methods
See Also Example
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. Sends an email message
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

Mail Class
Mail Members
MSBuild.Community.Tasks Namespace


Execute Method

Mail.Execute Method
[image]

Sends an email message

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute() As Boolean _
Implements ITask.Execute
C#
public override bool Execute()
C++
public:
virtual bool Execute() override
J#
public override bool Execute()
JScript
public override function Execute() : bool

Return Value

Returns true if successful

Implements

ITask.Execute

See Also

Mail Class
Mail Members
MSBuild.Community.Tasks Namespace


Move Class

Move Class
See Also Example Members
[image]

Moves files on the filesystem to a new location.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class Move
Inherits Task
C#
public class Move : Task
C++
ref class Move : Task
J#
public class Move extends Task
JScript
public class Move extends Task

Example

Move a file to another folder

Copy Code
            <Move SourceFiles="Test\MoveMe.txt"
                DestinationFolder="Test\Move" />

Rename a file

Copy Code
            <Move SourceFiles="Test\Move\MoveMe.txt"
                DestinationFiles="Test\Move\Renamed.txt" />

Inheritance Hierarchy

System.Object
Microsoft.Build.Utilities.Task
MSBuild.Community.Tasks.Move

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

Move Members
MSBuild.Community.Tasks Namespace


Move Members

Move Members
See Also Example Constructors Properties Methods
[image]

Moves files on the filesystem to a new location.

The following tables list the members exposed by Move.

Public Constructors

 | Name | Description
Public method | Move | Initializes a new instance of the Move class.
Top

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | DestinationFiles | Gets or sets the list of files to moved the source files to.
Public property | DestinationFolder | Gets or sets the directory to which you want to move the files.
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | MovedFiles | Gets the items that were successfully moved.
Public property | SourceFiles | Gets or sets the source files to move.
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. When overridden in a derived class, executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

Move Class
Move Members
MSBuild.Community.Tasks Namespace


Move Constructor

Move Constructor
[image]

Initializes a new instance of the Move class.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public Move()
C++
public:
Move() sealed
J#
public Move()
JScript
public function Move()

See Also

Move Class
Move Members
MSBuild.Community.Tasks Namespace


Properties

Move Properties
See Also Example
[image]

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | DestinationFiles | Gets or sets the list of files to moved the source files to.
Public property | DestinationFolder | Gets or sets the directory to which you want to move the files.
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | MovedFiles | Gets the items that were successfully moved.
Public property | SourceFiles | Gets or sets the source files to move.
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

See Also

Move Class
Move Members
MSBuild.Community.Tasks Namespace


DestinationFiles Property

Move.DestinationFiles Property
[image]

Gets or sets the list of files to moved the source files to.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Output>
Public Property DestinationFiles As ITaskItem[]
C#
[Output]
public ITaskItem[] DestinationFiles { get; set; }
C++
[Output]
public property ITaskItem[] DestinationFiles sealed {
array<ITaskItem>^ get();
void set(array<ITaskItem>^ value);
}
J#
/** @attribute Output() */
/** property */
public ITaskItem[] get_DestinationFiles();

/** property */
public void set_DestinationFiles(ITaskItem[] value);
JScript
public function get DestinationFiles() : ITaskItem[]

public function set DestinationFiles(value : ITaskItem[]);

Property Value

The destination files.

Remarks

This list is expected to be a one-to-one mapping with the list specified in the SourceFiles parameter. That is, the first file specified in SourceFiles will be moved to the first location specified in DestinationFiles, and so forth.

See Also

Move Class
Move Members
MSBuild.Community.Tasks Namespace


DestinationFolder Property

Move.DestinationFolder Property
[image]

Gets or sets the directory to which you want to move the files.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property DestinationFolder As ITaskItem
C#
public ITaskItem DestinationFolder { get; set; }
C++
public property ITaskItem DestinationFolder sealed {
ITaskItem get();
void set(ITaskItem value);
}
J#
/** property */
public ITaskItem get_DestinationFolder();

/** property */
public void set_DestinationFolder(ITaskItem value);
JScript
public function get DestinationFolder() : ITaskItem

public function set DestinationFolder(value : ITaskItem);

Property Value

The destination folder.

See Also

Move Class
Move Members
MSBuild.Community.Tasks Namespace


MovedFiles Property

Move.MovedFiles Property
[image]

Gets the items that were successfully moved.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Output>
Public ReadOnly Property MovedFiles As ITaskItem[]
C#
[Output]
public ITaskItem[] MovedFiles { get; }
C++
[Output]
public property ITaskItem[] MovedFiles sealed {
array<ITaskItem>^ get();
}
J#
/** @attribute Output() */
/** property */
public ITaskItem[] get_MovedFiles();
JScript
public function get MovedFiles() : ITaskItem[]

Property Value

The moved files.

See Also

Move Class
Move Members
MSBuild.Community.Tasks Namespace


SourceFiles Property

Move.SourceFiles Property
[image]

Gets or sets the source files to move.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Required>
Public Property SourceFiles As ITaskItem[]
C#
[Required]
public ITaskItem[] SourceFiles { get; set; }
C++
[Required]
public property ITaskItem[] SourceFiles sealed {
array<ITaskItem>^ get();
void set(array<ITaskItem>^ value);
}
J#
/** @attribute Required() */
/** property */
public ITaskItem[] get_SourceFiles();

/** property */
public void set_SourceFiles(ITaskItem[] value);
JScript
public function get SourceFiles() : ITaskItem[]

public function set SourceFiles(value : ITaskItem[]);

Property Value

The source files to move.

See Also

Move Class
Move Members
MSBuild.Community.Tasks Namespace


Methods

Move Methods
See Also Example
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. When overridden in a derived class, executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

Move Class
Move Members
MSBuild.Community.Tasks Namespace


Execute Method

Move.Execute Method
[image]

When overridden in a derived class, executes the task.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute() As Boolean _
Implements ITask.Execute
C#
public override bool Execute()
C++
public:
virtual bool Execute() override
J#
public override bool Execute()
JScript
public override function Execute() : bool

Return Value

true if the task successfully executed; otherwise, false.

Implements

ITask.Execute

See Also

Move Class
Move Members
MSBuild.Community.Tasks Namespace


NDoc Class

NDoc Class
See Also Example Members
[image]

Runs the NDoc application.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class NDoc
Inherits ToolTask
C#
public class NDoc : ToolTask
C++
ref class NDoc : ToolTask
J#
public class NDoc extends ToolTask
JScript
public class NDoc extends ToolTask

Example

Generated html help file.

Copy Code
            <NDoc Documenter="MSDN"
                ProjectFilePath="MSBuild.Community.Tasks.ndoc" />

Inheritance Hierarchy

System.Object
Microsoft.Build.Utilities.Task
Microsoft.Build.Utilities.ToolTask
MSBuild.Community.Tasks.NDoc

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NDoc Members
MSBuild.Community.Tasks Namespace


NDoc Members

NDoc Members
See Also Example Constructors Properties Methods
[image]

Runs the NDoc application.

The following tables list the members exposed by NDoc.

Public Constructors

 | Name | Description
Public method | NDoc | Initializes a new instance of the T:NDoc class.
Top

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | Documenter | Gets or sets the documenter.
Public property | ExitCode | Gets the returned exit code of the executable file. (inherited from ToolTask)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | ProjectFilePath | Gets or sets the project file path.
Public property | Timeout | Gets or sets the amount of time after which the task executable is terminated. (inherited from ToolTask)
Public property | ToolPath | Gets or sets the path of the executable file to run. (inherited from ToolTask)
Public property | Verbose | Gets or sets a value indicating whether the output is verbose.
Public property | WorkingDirectory | Gets or sets the working directory.
Top

Protected Properties

 | Name | Description
Family property | EnvironmentOverride | Gets the override value of the PATH environment variable. (inherited from ToolTask)
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | ResponseFileEncoding | Gets the Encoding of the response file. (inherited from ToolTask)
Family property | StandardErrorEncoding | Gets the Encoding of the standard error stream of the task. (inherited from ToolTask)
Family property | StandardErrorLoggingImportance | Gets the MessageImportance with which to log errors. (inherited from ToolTask)
Family property | StandardOutputEncoding | Gets the Encoding of the standard output stream of the task. (inherited from ToolTask)
Family property | StandardOutputLoggingImportance | Overidden. Gets the MessageImportance with which to log errors.
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Family property | ToolName | Overidden. Gets the name of the executable file to run.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Runs the exectuable file with the specified task parameters. (inherited from ToolTask)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | CallHostObjectToExecute | Calls the host object to perform the work of the task. (inherited from ToolTask)
Family method | ExecuteTool | Creates a temporoary response (.rsp) file and runs the executable file. (inherited from ToolTask)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GenerateCommandLineCommands | Overidden. Returns a string value containing the command line arguments to pass directly to the executable file.
Family method | GenerateFullPathToTool | Overidden. Returns the fully qualified path to the executable file.
Family method | GenerateResponseFileCommands | Returns a string value containing the command line arguments to add to the response (.rsp) file before running the executable file. (inherited from ToolTask)
Family method | GetResponseFileSwitch | Returns the command line switch used by the executable file to specifiy a response (.rsp) file. (inherited from ToolTask)
Family method | GetWorkingDirectory | Overidden. Returns the directory in which to run the executable file.
Family method | HandleTaskExecutionErrors | Handles execution errors raised by the executable file. (inherited from ToolTask)
Family method | InitializeHostObject | Initializes the host object of the task. (inherited from ToolTask)
Family method | LogEventsFromTextOutput | (inherited from ToolTask)
Family method | LogPathToTool | Logs the tool name and path to all registered loggers. (inherited from ToolTask)
Family method | LogToolCommand | Overidden. Logs the starting point of the run to all registered loggers.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | SkipTaskExecution | Indicates whether task execution should be skipped. (inherited from ToolTask)
Family method | ValidateParameters | Indicates whether all task paratmeters are valid. (inherited from ToolTask)
Top

See Also

NDoc Class
NDoc Members
MSBuild.Community.Tasks Namespace


NDoc Constructor

NDoc Constructor
[image]

Initializes a new instance of the T:NDoc class.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NDoc()
C++
public:
NDoc() sealed
J#
public NDoc()
JScript
public function NDoc()

See Also

NDoc Class
NDoc Members
MSBuild.Community.Tasks Namespace


Properties

NDoc Properties
See Also Example
[image]

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | Documenter | Gets or sets the documenter.
Public property | ExitCode | Gets the returned exit code of the executable file. (inherited from ToolTask)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | ProjectFilePath | Gets or sets the project file path.
Public property | Timeout | Gets or sets the amount of time after which the task executable is terminated. (inherited from ToolTask)
Public property | ToolPath | Gets or sets the path of the executable file to run. (inherited from ToolTask)
Public property | Verbose | Gets or sets a value indicating whether the output is verbose.
Public property | WorkingDirectory | Gets or sets the working directory.
Top

Protected Properties

 | Name | Description
Family property | EnvironmentOverride | Gets the override value of the PATH environment variable. (inherited from ToolTask)
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | ResponseFileEncoding | Gets the Encoding of the response file. (inherited from ToolTask)
Family property | StandardErrorEncoding | Gets the Encoding of the standard error stream of the task. (inherited from ToolTask)
Family property | StandardErrorLoggingImportance | Gets the MessageImportance with which to log errors. (inherited from ToolTask)
Family property | StandardOutputEncoding | Gets the Encoding of the standard output stream of the task. (inherited from ToolTask)
Family property | StandardOutputLoggingImportance | Overidden. Gets the MessageImportance with which to log errors.
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Family property | ToolName | Overidden. Gets the name of the executable file to run.
Top

See Also

NDoc Class
NDoc Members
MSBuild.Community.Tasks Namespace


Documenter Property

NDoc.Documenter Property
[image]

Gets or sets the documenter.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Required>
Public Property Documenter As String
C#
[Required]
public string Documenter { get; set; }
C++
[Required]
public property string Documenter sealed {
String get();
void set(String value);
}
J#
/** @attribute Required() */
/** property */
public string get_Documenter();

/** property */
public void set_Documenter(string value);
JScript
public function get Documenter() : String

public function set Documenter(value : String);

Property Value

The documenter.

Remarks

Available documenters are VS.NET_2003, JavaDoc, LaTeX, LinearHtml, MSDN, XML.

See Also

NDoc Class
NDoc Members
MSBuild.Community.Tasks Namespace


ProjectFilePath Property

NDoc.ProjectFilePath Property
[image]

Gets or sets the project file path.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Required>
Public Property ProjectFilePath As String
C#
[Required]
public string ProjectFilePath { get; set; }
C++
[Required]
public property string ProjectFilePath sealed {
String get();
void set(String value);
}
J#
/** @attribute Required() */
/** property */
public string get_ProjectFilePath();

/** property */
public void set_ProjectFilePath(string value);
JScript
public function get ProjectFilePath() : String

public function set ProjectFilePath(value : String);

Property Value

The project file path.

See Also

NDoc Class
NDoc Members
MSBuild.Community.Tasks Namespace


StandardOutputLoggingImportance Property

NDoc.StandardOutputLoggingImportance Property
[image]

Gets the MessageImportance with which to log errors.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property StandardOutputLoggingImportance As MessageImportance
C#
protected override MessageImportance StandardOutputLoggingImportance { get; }
C++
protected override property MessageImportance StandardOutputLoggingImportance override {
MessageImportance get();
}
J#
/** property */
protected MessageImportance get_StandardOutputLoggingImportance();
JScript
protected function get StandardOutputLoggingImportance() : MessageImportance

Property Value

The MessageImportance with which to log errors.

See Also

NDoc Class
NDoc Members
MSBuild.Community.Tasks Namespace


ToolName Property

NDoc.ToolName Property
[image]

Gets the name of the executable file to run.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property ToolName As String
C#
protected override string ToolName { get; }
C++
protected override property string ToolName override {
String get();
}
J#
/** property */
protected string get_ToolName();
JScript
protected function get ToolName() : String

Property Value

The name of the executable file to run.

See Also

NDoc Class
NDoc Members
MSBuild.Community.Tasks Namespace


Verbose Property

NDoc.Verbose Property
[image]

Gets or sets a value indicating whether the output is verbose.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Verbose As Boolean
C#
public bool Verbose { get; set; }
C++
public property bool Verbose sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_Verbose();

/** property */
public void set_Verbose(bool value);
JScript
public function get Verbose() : bool

public function set Verbose(value : bool);

Property Value

true if verbose; otherwise, false.

See Also

NDoc Class
NDoc Members
MSBuild.Community.Tasks Namespace


WorkingDirectory Property

NDoc.WorkingDirectory Property
[image]

Gets or sets the working directory.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property WorkingDirectory As String
C#
public string WorkingDirectory { get; set; }
C++
public property string WorkingDirectory sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_WorkingDirectory();

/** property */
public void set_WorkingDirectory(string value);
JScript
public function get WorkingDirectory() : String

public function set WorkingDirectory(value : String);

Property Value

The directory in which to run the executable file, or a null reference (Nothing in Visual Basic) if the executable file should be run in the current directory.

See Also

NDoc Class
NDoc Members
MSBuild.Community.Tasks Namespace


Methods

NDoc Methods
See Also Example
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Runs the exectuable file with the specified task parameters. (inherited from ToolTask)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | CallHostObjectToExecute | Calls the host object to perform the work of the task. (inherited from ToolTask)
Family method | ExecuteTool | Creates a temporoary response (.rsp) file and runs the executable file. (inherited from ToolTask)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GenerateCommandLineCommands | Overidden. Returns a string value containing the command line arguments to pass directly to the executable file.
Family method | GenerateFullPathToTool | Overidden. Returns the fully qualified path to the executable file.
Family method | GenerateResponseFileCommands | Returns a string value containing the command line arguments to add to the response (.rsp) file before running the executable file. (inherited from ToolTask)
Family method | GetResponseFileSwitch | Returns the command line switch used by the executable file to specifiy a response (.rsp) file. (inherited from ToolTask)
Family method | GetWorkingDirectory | Overidden. Returns the directory in which to run the executable file.
Family method | HandleTaskExecutionErrors | Handles execution errors raised by the executable file. (inherited from ToolTask)
Family method | InitializeHostObject | Initializes the host object of the task. (inherited from ToolTask)
Family method | LogEventsFromTextOutput | (inherited from ToolTask)
Family method | LogPathToTool | Logs the tool name and path to all registered loggers. (inherited from ToolTask)
Family method | LogToolCommand | Overidden. Logs the starting point of the run to all registered loggers.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | SkipTaskExecution | Indicates whether task execution should be skipped. (inherited from ToolTask)
Family method | ValidateParameters | Indicates whether all task paratmeters are valid. (inherited from ToolTask)
Top

See Also

NDoc Class
NDoc Members
MSBuild.Community.Tasks Namespace


GenerateCommandLineCommands Method

NDoc.GenerateCommandLineCommands Method
[image]

Returns a string value containing the command line arguments to pass directly to the executable file.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GenerateCommandLineCommands() As String
C#
protected override string GenerateCommandLineCommands()
C++
protected:
virtual String GenerateCommandLineCommands() override
J#
protected override string GenerateCommandLineCommands()
JScript
protected override function GenerateCommandLineCommands() : String

Return Value

A string value containing the command line arguments to pass directly to the executable file.

See Also

NDoc Class
NDoc Members
MSBuild.Community.Tasks Namespace


GenerateFullPathToTool Method

NDoc.GenerateFullPathToTool Method
[image]

Returns the fully qualified path to the executable file.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GenerateFullPathToTool() As String
C#
protected override string GenerateFullPathToTool()
C++
protected:
virtual String GenerateFullPathToTool() override
J#
protected override string GenerateFullPathToTool()
JScript
protected override function GenerateFullPathToTool() : String

Return Value

The fully qualified path to the executable file.

See Also

NDoc Class
NDoc Members
MSBuild.Community.Tasks Namespace


GetWorkingDirectory Method

NDoc.GetWorkingDirectory Method
[image]

Returns the directory in which to run the executable file.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetWorkingDirectory() As String
C#
protected override string GetWorkingDirectory()
C++
protected:
virtual String GetWorkingDirectory() override
J#
protected override string GetWorkingDirectory()
JScript
protected override function GetWorkingDirectory() : String

Return Value

The directory in which to run the executable file, or a null reference (Nothing in Visual Basic) if the executable file should be run in the current directory.

See Also

NDoc Class
NDoc Members
MSBuild.Community.Tasks Namespace


LogToolCommand Method

NDoc.LogToolCommand Method
[image]

Logs the starting point of the run to all registered loggers.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub LogToolCommand( _
ByVal message As String _
)
C#
protected override void LogToolCommand(
string message
)
C++
protected:
virtual void LogToolCommand(
String message
) override
J#
protected override void LogToolCommand(
string message
)
JScript
protected override function LogToolCommand(
message : String
)

Parameters

message
A descriptive message to provide loggers, usually the command line and switches.

See Also

NDoc Class
NDoc Members
MSBuild.Community.Tasks Namespace


NUnit Class

NUnit Class
See Also Example Members
[image]

Run NUnit on a group of assemblies.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class NUnit
Inherits ToolTask
C#
public class NUnit : ToolTask
C++
ref class NUnit : ToolTask
J#
public class NUnit extends ToolTask
JScript
public class NUnit extends ToolTask

Example

Run NUnit tests.

Copy Code
            <ItemGroup>
                <TestAssembly Include="C:\Program Files\NUnit 2.2.7\bin\*.tests.dll" />
            </ItemGroup>
            <Target Name="NUnit">
                <NUnit Assemblies="@(TestAssembly)" />
            </Target>

Inheritance Hierarchy

System.Object
Microsoft.Build.Utilities.Task
Microsoft.Build.Utilities.ToolTask
MSBuild.Community.Tasks.NUnit

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NUnit Members
MSBuild.Community.Tasks Namespace


NUnit Members

NUnit Members
See Also Example Constructors Fields Properties Methods
[image]

Run NUnit on a group of assemblies.

The following tables list the members exposed by NUnit.

Public Constructors

 | Name | Description
Public method | NUnit | Initializes a new instance of the T:NUnit class.
Top

Public Fields

Name | Description
DEFAULT_NUNIT_DIRECTORY | The default relative path of the NUnit installation. The value is @"NUnit-Net-2.0 2.2.7\bin". This field is constant and read-only.
Top

Public Properties

 | Name | Description
Public property | Assemblies | Gets or sets the assemblies.
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | DisableShadowCopy | Determines whether assemblies are copied to a shadow folder during testing.
Public property | ErrorOutputFile | The file to receive test error details.
Public property | ExcludeCategory | Gets or sets the categories to exclude.
Public property | ExitCode | Gets the returned exit code of the executable file. (inherited from ToolTask)
Public property | Fixture | Gets or sets the fixture.
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | IncludeCategory | Gets or sets the categories to include.
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | OutputXmlFile | Gets or sets the output XML file.
Public property | ProjectConfiguration | The project configuration to run.
Public property | TestInNewThread | Allows tests to be run in a new thread, allowing you to take advantage of ApartmentState and ThreadPriority settings in the config file.
Public property | Timeout | Gets or sets the amount of time after which the task executable is terminated. (inherited from ToolTask)
Public property | ToolPath | Gets or sets the path of the executable file to run. (inherited from ToolTask)
Public property | WorkingDirectory | Gets or sets the working directory.
Public property | XsltTransformFile | Gets or sets the XSLT transform file.
Top

Protected Properties

 | Name | Description
Family property | EnvironmentOverride | Gets the override value of the PATH environment variable. (inherited from ToolTask)
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | ResponseFileEncoding | Gets the Encoding of the response file. (inherited from ToolTask)
Family property | StandardErrorEncoding | Gets the Encoding of the standard error stream of the task. (inherited from ToolTask)
Family property | StandardErrorLoggingImportance | Gets the MessageImportance with which to log errors. (inherited from ToolTask)
Family property | StandardOutputEncoding | Gets the Encoding of the standard output stream of the task. (inherited from ToolTask)
Family property | StandardOutputLoggingImportance | Overidden. Gets the MessageImportance with which to log errors.
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Family property | ToolName | Overidden. Gets the name of the executable file to run.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Runs the exectuable file with the specified task parameters. (inherited from ToolTask)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | CallHostObjectToExecute | Calls the host object to perform the work of the task. (inherited from ToolTask)
Family method | ExecuteTool | Creates a temporoary response (.rsp) file and runs the executable file. (inherited from ToolTask)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GenerateCommandLineCommands | Overidden. Returns a string value containing the command line arguments to pass directly to the executable file.
Family method | GenerateFullPathToTool | Overidden. Returns the fully qualified path to the executable file.
Family method | GenerateResponseFileCommands | Returns a string value containing the command line arguments to add to the response (.rsp) file before running the executable file. (inherited from ToolTask)
Family method | GetResponseFileSwitch | Returns the command line switch used by the executable file to specifiy a response (.rsp) file. (inherited from ToolTask)
Family method | GetWorkingDirectory | Overidden. Returns the directory in which to run the executable file.
Family method | HandleTaskExecutionErrors | Handles execution errors raised by the executable file. (inherited from ToolTask)
Family method | InitializeHostObject | Initializes the host object of the task. (inherited from ToolTask)
Family method | LogEventsFromTextOutput | (inherited from ToolTask)
Family method | LogPathToTool | Logs the tool name and path to all registered loggers. (inherited from ToolTask)
Family method | LogToolCommand | Overidden. Logs the starting point of the run to all registered loggers.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | SkipTaskExecution | Indicates whether task execution should be skipped. (inherited from ToolTask)
Family method | ValidateParameters | Indicates whether all task paratmeters are valid. (inherited from ToolTask)
Top

See Also

NUnit Class
NUnit Members
MSBuild.Community.Tasks Namespace


NUnit Constructor

NUnit Constructor
[image]

Initializes a new instance of the T:NUnit class.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NUnit()
C++
public:
NUnit() sealed
J#
public NUnit()
JScript
public function NUnit()

See Also

NUnit Class
NUnit Members
MSBuild.Community.Tasks Namespace


Fields

NUnit Fields
See Also Example
[image]

Public Fields

Name | Description
DEFAULT_NUNIT_DIRECTORY | The default relative path of the NUnit installation. The value is @"NUnit-Net-2.0 2.2.7\bin". This field is constant and read-only.
Top

See Also

NUnit Class
NUnit Members
MSBuild.Community.Tasks Namespace


DEFAULT_NUNIT_DIRECTORY Field

NUnit.DEFAULT_NUNIT_DIRECTORY Field
[image]

The default relative path of the NUnit installation. The value is @"NUnit-Net-2.0 2.2.7\bin". This field is constant and read-only.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public const DEFAULT_NUNIT_DIRECTORY As String = "NUnit-Net-2.0 2.2.7\bin"
C#
public const string DEFAULT_NUNIT_DIRECTORY = "NUnit-Net-2.0 2.2.7\bin";
C++
public:
const String DEFAULT_NUNIT_DIRECTORY = L"NUnit-Net-2.0 2.2.7\bin";
J#
public const string DEFAULT_NUNIT_DIRECTORY = "NUnit-Net-2.0 2.2.7\bin"
JScript
public const DEFAULT_NUNIT_DIRECTORY : String = "NUnit-Net-2.0 2.2.7\bin";

See Also

NUnit Class
NUnit Members
MSBuild.Community.Tasks Namespace


Properties

NUnit Properties
See Also Example
[image]

Public Properties

 | Name | Description
Public property | Assemblies | Gets or sets the assemblies.
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | DisableShadowCopy | Determines whether assemblies are copied to a shadow folder during testing.
Public property | ErrorOutputFile | The file to receive test error details.
Public property | ExcludeCategory | Gets or sets the categories to exclude.
Public property | ExitCode | Gets the returned exit code of the executable file. (inherited from ToolTask)
Public property | Fixture | Gets or sets the fixture.
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | IncludeCategory | Gets or sets the categories to include.
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | OutputXmlFile | Gets or sets the output XML file.
Public property | ProjectConfiguration | The project configuration to run.
Public property | TestInNewThread | Allows tests to be run in a new thread, allowing you to take advantage of ApartmentState and ThreadPriority settings in the config file.
Public property | Timeout | Gets or sets the amount of time after which the task executable is terminated. (inherited from ToolTask)
Public property | ToolPath | Gets or sets the path of the executable file to run. (inherited from ToolTask)
Public property | WorkingDirectory | Gets or sets the working directory.
Public property | XsltTransformFile | Gets or sets the XSLT transform file.
Top

Protected Properties

 | Name | Description
Family property | EnvironmentOverride | Gets the override value of the PATH environment variable. (inherited from ToolTask)
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | ResponseFileEncoding | Gets the Encoding of the response file. (inherited from ToolTask)
Family property | StandardErrorEncoding | Gets the Encoding of the standard error stream of the task. (inherited from ToolTask)
Family property | StandardErrorLoggingImportance | Gets the MessageImportance with which to log errors. (inherited from ToolTask)
Family property | StandardOutputEncoding | Gets the Encoding of the standard output stream of the task. (inherited from ToolTask)
Family property | StandardOutputLoggingImportance | Overidden. Gets the MessageImportance with which to log errors.
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Family property | ToolName | Overidden. Gets the name of the executable file to run.
Top

See Also

NUnit Class
NUnit Members
MSBuild.Community.Tasks Namespace


Assemblies Property

NUnit.Assemblies Property
[image]

Gets or sets the assemblies.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Required>
Public Property Assemblies As ITaskItem[]
C#
[Required]
public ITaskItem[] Assemblies { get; set; }
C++
[Required]
public property ITaskItem[] Assemblies sealed {
array<ITaskItem>^ get();
void set(array<ITaskItem>^ value);
}
J#
/** @attribute Required() */
/** property */
public ITaskItem[] get_Assemblies();

/** property */
public void set_Assemblies(ITaskItem[] value);
JScript
public function get Assemblies() : ITaskItem[]

public function set Assemblies(value : ITaskItem[]);

Property Value

The assemblies.

See Also

NUnit Class
NUnit Members
MSBuild.Community.Tasks Namespace


DisableShadowCopy Property

NUnit.DisableShadowCopy Property
[image]

Determines whether assemblies are copied to a shadow folder during testing.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property DisableShadowCopy As Boolean
C#
public bool DisableShadowCopy { get; set; }
C++
public property bool DisableShadowCopy sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_DisableShadowCopy();

/** property */
public void set_DisableShadowCopy(bool value);
JScript
public function get DisableShadowCopy() : bool

public function set DisableShadowCopy(value : bool);

Remarks

Shadow copying is enabled by default. If you want to test the assemblies "in place", you must set this property to True.

See Also

NUnit Class
NUnit Members
MSBuild.Community.Tasks Namespace


ErrorOutputFile Property

NUnit.ErrorOutputFile Property
[image]

The file to receive test error details.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property ErrorOutputFile As String
C#
public string ErrorOutputFile { get; set; }
C++
public property string ErrorOutputFile sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_ErrorOutputFile();

/** property */
public void set_ErrorOutputFile(string value);
JScript
public function get ErrorOutputFile() : String

public function set ErrorOutputFile(value : String);

See Also

NUnit Class
NUnit Members
MSBuild.Community.Tasks Namespace


ExcludeCategory Property

NUnit.ExcludeCategory Property
[image]

Gets or sets the categories to exclude.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property ExcludeCategory As String
C#
public string ExcludeCategory { get; set; }
C++
public property string ExcludeCategory sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_ExcludeCategory();

/** property */
public void set_ExcludeCategory(string value);
JScript
public function get ExcludeCategory() : String

public function set ExcludeCategory(value : String);

Remarks

Multiple values must be separated by a comma ","

See Also

NUnit Class
NUnit Members
MSBuild.Community.Tasks Namespace


Fixture Property

NUnit.Fixture Property
[image]

Gets or sets the fixture.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Fixture As String
C#
public string Fixture { get; set; }
C++
public property string Fixture sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Fixture();

/** property */
public void set_Fixture(string value);
JScript
public function get Fixture() : String

public function set Fixture(value : String);

Property Value

The fixture.

See Also

NUnit Class
NUnit Members
MSBuild.Community.Tasks Namespace


IncludeCategory Property

NUnit.IncludeCategory Property
[image]

Gets or sets the categories to include.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property IncludeCategory As String
C#
public string IncludeCategory { get; set; }
C++
public property string IncludeCategory sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_IncludeCategory();

/** property */
public void set_IncludeCategory(string value);
JScript
public function get IncludeCategory() : String

public function set IncludeCategory(value : String);

Remarks

Multiple values must be separated by a comma ","

See Also

NUnit Class
NUnit Members
MSBuild.Community.Tasks Namespace


OutputXmlFile Property

NUnit.OutputXmlFile Property
[image]

Gets or sets the output XML file.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property OutputXmlFile As String
C#
public string OutputXmlFile { get; set; }
C++
public property string OutputXmlFile sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_OutputXmlFile();

/** property */
public void set_OutputXmlFile(string value);
JScript
public function get OutputXmlFile() : String

public function set OutputXmlFile(value : String);

Property Value

The output XML file.

See Also

NUnit Class
NUnit Members
MSBuild.Community.Tasks Namespace


ProjectConfiguration Property

NUnit.ProjectConfiguration Property
[image]

The project configuration to run.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property ProjectConfiguration As String
C#
public string ProjectConfiguration { get; set; }
C++
public property string ProjectConfiguration sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_ProjectConfiguration();

/** property */
public void set_ProjectConfiguration(string value);
JScript
public function get ProjectConfiguration() : String

public function set ProjectConfiguration(value : String);

Remarks

Only applies when a project file is used. The default is the first configuration, usually Debug.

See Also

NUnit Class
NUnit Members
MSBuild.Community.Tasks Namespace


StandardOutputLoggingImportance Property

NUnit.StandardOutputLoggingImportance Property
[image]

Gets the MessageImportance with which to log errors.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property StandardOutputLoggingImportance As MessageImportance
C#
protected override MessageImportance StandardOutputLoggingImportance { get; }
C++
protected override property MessageImportance StandardOutputLoggingImportance override {
MessageImportance get();
}
J#
/** property */
protected MessageImportance get_StandardOutputLoggingImportance();
JScript
protected function get StandardOutputLoggingImportance() : MessageImportance

Property Value

The MessageImportance with which to log errors.

See Also

NUnit Class
NUnit Members
MSBuild.Community.Tasks Namespace


TestInNewThread Property

NUnit.TestInNewThread Property
[image]

Allows tests to be run in a new thread, allowing you to take advantage of ApartmentState and ThreadPriority settings in the config file.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property TestInNewThread As Boolean
C#
public bool TestInNewThread { get; set; }
C++
public property bool TestInNewThread sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_TestInNewThread();

/** property */
public void set_TestInNewThread(bool value);
JScript
public function get TestInNewThread() : bool

public function set TestInNewThread(value : bool);

See Also

NUnit Class
NUnit Members
MSBuild.Community.Tasks Namespace


ToolName Property

NUnit.ToolName Property
[image]

Gets the name of the executable file to run.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property ToolName As String
C#
protected override string ToolName { get; }
C++
protected override property string ToolName override {
String get();
}
J#
/** property */
protected string get_ToolName();
JScript
protected function get ToolName() : String

Property Value

The name of the executable file to run.

See Also

NUnit Class
NUnit Members
MSBuild.Community.Tasks Namespace


WorkingDirectory Property

NUnit.WorkingDirectory Property
[image]

Gets or sets the working directory.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property WorkingDirectory As String
C#
public string WorkingDirectory { get; set; }
C++
public property string WorkingDirectory sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_WorkingDirectory();

/** property */
public void set_WorkingDirectory(string value);
JScript
public function get WorkingDirectory() : String

public function set WorkingDirectory(value : String);

Property Value

The directory in which to run the executable file, or a null reference (Nothing in Visual Basic) if the executable file should be run in the current directory.

See Also

NUnit Class
NUnit Members
MSBuild.Community.Tasks Namespace


XsltTransformFile Property

NUnit.XsltTransformFile Property
[image]

Gets or sets the XSLT transform file.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property XsltTransformFile As String
C#
public string XsltTransformFile { get; set; }
C++
public property string XsltTransformFile sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_XsltTransformFile();

/** property */
public void set_XsltTransformFile(string value);
JScript
public function get XsltTransformFile() : String

public function set XsltTransformFile(value : String);

Property Value

The XSLT transform file.

See Also

NUnit Class
NUnit Members
MSBuild.Community.Tasks Namespace


Methods

NUnit Methods
See Also Example
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Runs the exectuable file with the specified task parameters. (inherited from ToolTask)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | CallHostObjectToExecute | Calls the host object to perform the work of the task. (inherited from ToolTask)
Family method | ExecuteTool | Creates a temporoary response (.rsp) file and runs the executable file. (inherited from ToolTask)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GenerateCommandLineCommands | Overidden. Returns a string value containing the command line arguments to pass directly to the executable file.
Family method | GenerateFullPathToTool | Overidden. Returns the fully qualified path to the executable file.
Family method | GenerateResponseFileCommands | Returns a string value containing the command line arguments to add to the response (.rsp) file before running the executable file. (inherited from ToolTask)
Family method | GetResponseFileSwitch | Returns the command line switch used by the executable file to specifiy a response (.rsp) file. (inherited from ToolTask)
Family method | GetWorkingDirectory | Overidden. Returns the directory in which to run the executable file.
Family method | HandleTaskExecutionErrors | Handles execution errors raised by the executable file. (inherited from ToolTask)
Family method | InitializeHostObject | Initializes the host object of the task. (inherited from ToolTask)
Family method | LogEventsFromTextOutput | (inherited from ToolTask)
Family method | LogPathToTool | Logs the tool name and path to all registered loggers. (inherited from ToolTask)
Family method | LogToolCommand | Overidden. Logs the starting point of the run to all registered loggers.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | SkipTaskExecution | Indicates whether task execution should be skipped. (inherited from ToolTask)
Family method | ValidateParameters | Indicates whether all task paratmeters are valid. (inherited from ToolTask)
Top

See Also

NUnit Class
NUnit Members
MSBuild.Community.Tasks Namespace


GenerateCommandLineCommands Method

NUnit.GenerateCommandLineCommands Method
[image]

Returns a string value containing the command line arguments to pass directly to the executable file.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GenerateCommandLineCommands() As String
C#
protected override string GenerateCommandLineCommands()
C++
protected:
virtual String GenerateCommandLineCommands() override
J#
protected override string GenerateCommandLineCommands()
JScript
protected override function GenerateCommandLineCommands() : String

Return Value

A string value containing the command line arguments to pass directly to the executable file.

See Also

NUnit Class
NUnit Members
MSBuild.Community.Tasks Namespace


GenerateFullPathToTool Method

NUnit.GenerateFullPathToTool Method
[image]

Returns the fully qualified path to the executable file.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GenerateFullPathToTool() As String
C#
protected override string GenerateFullPathToTool()
C++
protected:
virtual String GenerateFullPathToTool() override
J#
protected override string GenerateFullPathToTool()
JScript
protected override function GenerateFullPathToTool() : String

Return Value

The fully qualified path to the executable file.

See Also

NUnit Class
NUnit Members
MSBuild.Community.Tasks Namespace


GetWorkingDirectory Method

NUnit.GetWorkingDirectory Method
[image]

Returns the directory in which to run the executable file.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetWorkingDirectory() As String
C#
protected override string GetWorkingDirectory()
C++
protected:
virtual String GetWorkingDirectory() override
J#
protected override string GetWorkingDirectory()
JScript
protected override function GetWorkingDirectory() : String

Return Value

The directory in which to run the executable file, or a null reference (Nothing in Visual Basic) if the executable file should be run in the current directory.

See Also

NUnit Class
NUnit Members
MSBuild.Community.Tasks Namespace


LogToolCommand Method

NUnit.LogToolCommand Method
[image]

Logs the starting point of the run to all registered loggers.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub LogToolCommand( _
ByVal message As String _
)
C#
protected override void LogToolCommand(
string message
)
C++
protected:
virtual void LogToolCommand(
String message
) override
J#
protected override void LogToolCommand(
string message
)
JScript
protected override function LogToolCommand(
message : String
)

Parameters

message
A descriptive message to provide loggers, usually the command line and switches.

See Also

NUnit Class
NUnit Members
MSBuild.Community.Tasks Namespace


Prompt Class

Prompt Class
See Also Example Members
[image]

Displays a message on the console and waits for user input.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class Prompt
Inherits Task
C#
public class Prompt : Task
C++
ref class Prompt : Task
J#
public class Prompt extends Task
JScript
public class Prompt extends Task

Example

Pause the build if the interactive property is set:

Copy Code
            <!-- Pause when invoked with the interactive property: msbuild myproject.proj /property:interactive=true -->

            <Prompt Text="You can now attach the debugger to the msbuild.exe process..." Condition="'$(Interactive)' == 'True'" />
Obtain user input during the build: (Note: in most cases, it is recommended that users instead provide custom values to your build through the /property argument of msbuild.exe)
Copy Code
            <Prompt Text="Tell me your name:" Condition="'$(Interactive)' == 'True'" >
              <Output TaskParameter="UserInput" PropertyName="PersonName" />
            </Prompt>
            <Message Text="Hello $(PersonName)" />

Remarks

It is important to note that the message is not written to the MSBuild logger, it is always written to the console, no matter which logger is configured.

This task requires user input from the console. Do not use this task for projects that will be executed unattended. It is recommended that you always add a Condtion so that this task is only enabled when a custom property is set through the command line. This will ensure that the other users do not attempt to execute the task in unattended mode.

Inheritance Hierarchy

System.Object
Microsoft.Build.Utilities.Task
MSBuild.Community.Tasks.Prompt

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

Prompt Members
MSBuild.Community.Tasks Namespace


Prompt Members

Prompt Members
See Also Example Constructors Properties Methods
[image]

Displays a message on the console and waits for user input.

The following tables list the members exposed by Prompt.

Public Constructors

 | Name | Description
Public method | Prompt | Initializes a new instance of the Prompt class.
Top

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Text | The message to display in the console.
Public property | UserInput | The text entered at the console.
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. When overridden in a derived class, executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

Prompt Class
Prompt Members
MSBuild.Community.Tasks Namespace


Prompt Constructor

Prompt Constructor
[image]

Initializes a new instance of the Prompt class.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public Prompt()
C++
public:
Prompt() sealed
J#
public Prompt()
JScript
public function Prompt()

See Also

Prompt Class
Prompt Members
MSBuild.Community.Tasks Namespace


Properties

Prompt Properties
See Also Example
[image]

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Text | The message to display in the console.
Public property | UserInput | The text entered at the console.
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

See Also

Prompt Class
Prompt Members
MSBuild.Community.Tasks Namespace


Text Property

Prompt.Text Property
[image]

The message to display in the console.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Text As String
C#
public string Text { get; set; }
C++
public property string Text sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Text();

/** property */
public void set_Text(string value);
JScript
public function get Text() : String

public function set Text(value : String);

See Also

Prompt Class
Prompt Members
MSBuild.Community.Tasks Namespace


UserInput Property

Prompt.UserInput Property
[image]

The text entered at the console.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Output>
Public ReadOnly Property UserInput As String
C#
[Output]
public string UserInput { get; }
C++
[Output]
public property string UserInput sealed {
String get();
}
J#
/** @attribute Output() */
/** property */
public string get_UserInput();
JScript
public function get UserInput() : String

See Also

Prompt Class
Prompt Members
MSBuild.Community.Tasks Namespace


Methods

Prompt Methods
See Also Example
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. When overridden in a derived class, executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

Prompt Class
Prompt Members
MSBuild.Community.Tasks Namespace


Execute Method

Prompt.Execute Method
[image]

When overridden in a derived class, executes the task.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute() As Boolean _
Implements ITask.Execute
C#
public override bool Execute()
C++
public:
virtual bool Execute() override
J#
public override bool Execute()
JScript
public override function Execute() : bool

Return Value

true if the task successfully executed; otherwise, false.

Implements

ITask.Execute

See Also

Prompt Class
Prompt Members
MSBuild.Community.Tasks Namespace


RegexBase Class

RegexBase Class
See Also Members
[image]

Base class for Regex tasks Handles public properties for Input, Expression, Options and Output This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class RegexBase
Inherits Task
C#
public abstract class RegexBase : Task
C++
ref class RegexBase abstract : Task
J#
public class RegexBase extends Task
JScript
public class RegexBase extends Task

Inheritance Hierarchy

System.Object
Microsoft.Build.Utilities.Task
MSBuild.Community.Tasks.RegexBase
MSBuild.Community.Tasks.RegexMatch
MSBuild.Community.Tasks.RegexReplace

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

RegexBase Members
MSBuild.Community.Tasks Namespace


RegexBase Members

RegexBase Members
See Also Constructors Properties Methods
[image]

Base class for Regex tasks Handles public properties for Input, Expression, Options and Output This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by RegexBase.

Protected Constructors

 | Name | Description
Family method | RegexBase | Initializes a new instance of the RegexBase class.
Top

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | Expression | Regex expression
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Input | Input, list of items to perform the regex on
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Options | Regex options as strings corresponding to the RegexOptions enum: Compiled CultureInvariant ECMAScript ExplicitCapture IgnoreCase IgnorePatternWhitespace Multiline None RightToLeft Singleline
Public property | Output | Results of the Regex transformation.
Top

Protected Properties

 | Name | Description
Family property | ExpressionOptions | Options converted to RegexOptions enum
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | When overridden in a derived class, executes the task. (inherited from Task)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

RegexBase Class
RegexBase Members
MSBuild.Community.Tasks Namespace


RegexBase Constructor

RegexBase Constructor
[image]

Initializes a new instance of the RegexBase class.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New()
C#
protected RegexBase()
C++
protected:
RegexBase() sealed
J#
protected RegexBase()
JScript
protected function RegexBase()

See Also

RegexBase Class
RegexBase Members
MSBuild.Community.Tasks Namespace


Properties

RegexBase Properties
[image]

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | Expression | Regex expression
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Input | Input, list of items to perform the regex on
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Options | Regex options as strings corresponding to the RegexOptions enum: Compiled CultureInvariant ECMAScript ExplicitCapture IgnoreCase IgnorePatternWhitespace Multiline None RightToLeft Singleline
Public property | Output | Results of the Regex transformation.
Top

Protected Properties

 | Name | Description
Family property | ExpressionOptions | Options converted to RegexOptions enum
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

See Also

RegexBase Class
RegexBase Members
MSBuild.Community.Tasks Namespace


Expression Property

RegexBase.Expression Property
[image]

Regex expression

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Required>
Public Property Expression As ITaskItem
C#
[Required]
public ITaskItem Expression { get; set; }
C++
[Required]
public property ITaskItem Expression sealed {
ITaskItem get();
void set(ITaskItem value);
}
J#
/** @attribute Required() */
/** property */
public ITaskItem get_Expression();

/** property */
public void set_Expression(ITaskItem value);
JScript
public function get Expression() : ITaskItem

public function set Expression(value : ITaskItem);

See Also

RegexBase Class
RegexBase Members
MSBuild.Community.Tasks Namespace


ExpressionOptions Property

RegexBase.ExpressionOptions Property
[image]

Options converted to RegexOptions enum

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property ExpressionOptions As RegexOptions
C#
protected RegexOptions ExpressionOptions { get; }
C++
protected property RegexOptions ExpressionOptions sealed {
RegexOptions get();
}
J#
/** property */
protected RegexOptions get_ExpressionOptions();
JScript
protected function get ExpressionOptions() : RegexOptions

See Also

RegexBase Class
RegexBase Members
MSBuild.Community.Tasks Namespace


Input Property

RegexBase.Input Property
[image]

Input, list of items to perform the regex on

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Required>
Public Property Input As ITaskItem[]
C#
[Required]
public ITaskItem[] Input { get; set; }
C++
[Required]
public property ITaskItem[] Input sealed {
array<ITaskItem>^ get();
void set(array<ITaskItem>^ value);
}
J#
/** @attribute Required() */
/** property */
public ITaskItem[] get_Input();

/** property */
public void set_Input(ITaskItem[] value);
JScript
public function get Input() : ITaskItem[]

public function set Input(value : ITaskItem[]);

See Also

RegexBase Class
RegexBase Members
MSBuild.Community.Tasks Namespace


Options Property

RegexBase.Options Property
[image]

Regex options as strings corresponding to the RegexOptions enum: Compiled CultureInvariant ECMAScript ExplicitCapture IgnoreCase IgnorePatternWhitespace Multiline None RightToLeft Singleline

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Options As ITaskItem[]
C#
public ITaskItem[] Options { get; set; }
C++
public property ITaskItem[] Options sealed {
array<ITaskItem>^ get();
void set(array<ITaskItem>^ value);
}
J#
/** property */
public ITaskItem[] get_Options();

/** property */
public void set_Options(ITaskItem[] value);
JScript
public function get Options() : ITaskItem[]

public function set Options(value : ITaskItem[]);

See Also

RegexBase Class
RegexBase Members
MSBuild.Community.Tasks Namespace


Output Property

RegexBase.Output Property
[image]

Results of the Regex transformation.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Output>
Public Property Output As ITaskItem[]
C#
[Output]
public ITaskItem[] Output { get; set; }
C++
[Output]
public property ITaskItem[] Output sealed {
array<ITaskItem>^ get();
void set(array<ITaskItem>^ value);
}
J#
/** @attribute Output() */
/** property */
public ITaskItem[] get_Output();

/** property */
public void set_Output(ITaskItem[] value);
JScript
public function get Output() : ITaskItem[]

public function set Output(value : ITaskItem[]);

See Also

RegexBase Class
RegexBase Members
MSBuild.Community.Tasks Namespace


RegexMatch Class

RegexMatch Class
See Also Example Members
[image]

Task to filter an Input list with a Regex expression. Output list contains items from Input list that matched given expression

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class RegexMatch
Inherits RegexBase
C#
public class RegexMatch : RegexBase
C++
ref class RegexMatch : RegexBase
J#
public class RegexMatch extends RegexBase
JScript
public class RegexMatch extends RegexBase

Example

Matches from TestGroup those names ending in a, b or c

Copy Code
            <ItemGroup>
               <TestGroup Include="foo.my.foo.foo.test.o" />
               <TestGroup Include="foo.my.faa.foo.test.a" />
               <TestGroup Include="foo.my.fbb.foo.test.b" />
               <TestGroup Include="foo.my.fcc.foo.test.c" />
               <TestGroup Include="foo.my.fdd.foo.test.d" />
               <TestGroup Include="foo.my.fee.foo.test.e" />
               <TestGroup Include="foo.my.fff.foo.test.f" />
            </ItemGroup>
            <Target Name="Test">
               <!-- Outputs only items that end with a, b or c -->
               <RegexMatch Input="@(TestGroup)" Expression="[a-c]$">
                  <Output ItemName ="MatchReturn" TaskParameter="Output" />
               </RegexMatch>
               <Message Text="&#xA;Output Match:&#xA;@(MatchReturn, '&#xA;')" />
            </Target>

Inheritance Hierarchy

System.Object
Microsoft.Build.Utilities.Task
MSBuild.Community.Tasks.RegexBase
MSBuild.Community.Tasks.RegexMatch

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

RegexMatch Members
MSBuild.Community.Tasks Namespace


RegexMatch Members

RegexMatch Members
See Also Example Constructors Properties Methods
[image]

Task to filter an Input list with a Regex expression. Output list contains items from Input list that matched given expression

The following tables list the members exposed by RegexMatch.

Public Constructors

 | Name | Description
Public method | RegexMatch | Initializes a new instance of the RegexMatch class.
Top

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | Expression | Regex expression (inherited from RegexBase)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Input | Input, list of items to perform the regex on (inherited from RegexBase)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Options | Regex options as strings corresponding to the RegexOptions enum: Compiled CultureInvariant ECMAScript ExplicitCapture IgnoreCase IgnorePatternWhitespace Multiline None RightToLeft Singleline (inherited from RegexBase)
Public property | Output | Results of the Regex transformation. (inherited from RegexBase)
Top

Protected Properties

 | Name | Description
Family property | ExpressionOptions | Options converted to RegexOptions enum (inherited from RegexBase)
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. Performs the Match task
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

RegexMatch Class
RegexMatch Members
MSBuild.Community.Tasks Namespace


RegexMatch Constructor

RegexMatch Constructor
[image]

Initializes a new instance of the RegexMatch class.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public RegexMatch()
C++
public:
RegexMatch() sealed
J#
public RegexMatch()
JScript
public function RegexMatch()

See Also

RegexMatch Class
RegexMatch Members
MSBuild.Community.Tasks Namespace


Methods

RegexMatch Methods
See Also Example
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. Performs the Match task
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

RegexMatch Class
RegexMatch Members
MSBuild.Community.Tasks Namespace


Execute Method

RegexMatch.Execute Method
[image]

Performs the Match task

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute() As Boolean _
Implements ITask.Execute
C#
public override bool Execute()
C++
public:
virtual bool Execute() override
J#
public override bool Execute()
JScript
public override function Execute() : bool

Return Value

true if the task ran successfully; otherwise false.

Implements

ITask.Execute

See Also

RegexMatch Class
RegexMatch Members
MSBuild.Community.Tasks Namespace


RegexReplace Class

RegexReplace Class
See Also Example Members
[image]

Task to replace portions of strings within the Input list Output list contains all the elements of the Input list after performing the Regex Replace.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class RegexReplace
Inherits RegexBase
C#
public class RegexReplace : RegexBase
C++
ref class RegexReplace : RegexBase
J#
public class RegexReplace extends RegexBase
JScript
public class RegexReplace extends RegexBase

Example

1st example replaces first occurance of "foo." with empty string 2nd example replaces occurance of "foo." after character 6 with "oop." string

Copy Code
            <ItemGroup>
               <TestGroup Include="foo.my.foo.foo.test.o" />
               <TestGroup Include="foo.my.faa.foo.test.a" />
               <TestGroup Include="foo.my.fbb.foo.test.b" />
               <TestGroup Include="foo.my.fcc.foo.test.c" />
               <TestGroup Include="foo.my.fdd.foo.test.d" />
               <TestGroup Include="foo.my.fee.foo.test.e" />
               <TestGroup Include="foo.my.fff.foo.test.f" />
            </ItemGroup>
            <Target Name="Test">
               <Message Text="Input:&#xA;@(TestGroup, '&#xA;')"/>
               <!-- Replaces first occurance of "foo." with empty string-->
               <RegexReplace Input="@(TestGroup)" Expression="foo\." Replacement="" Count="1">
                  <Output ItemName ="ReplaceReturn1" TaskParameter="Output" />
               </RegexReplace>
               <Message Text="&#xA;Output Replace 1:&#xA;@(ReplaceReturn1, '&#xA;')" />
               <!-- Replaces occurance of "foo." after character 6 with "oop." string-->
               <RegexReplace Input="@(TestGroup)" Expression="foo\." Replacement="oop" Startat="6">
                  <Output ItemName ="ReplaceReturn2" TaskParameter="Output" />
               </RegexReplace>
               <Message Text="&#xA;Output Replace 2:&#xA;@(ReplaceReturn2, '&#xA;')" />
            </Target>

Inheritance Hierarchy

System.Object
Microsoft.Build.Utilities.Task
MSBuild.Community.Tasks.RegexBase
MSBuild.Community.Tasks.RegexReplace

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

RegexReplace Members
MSBuild.Community.Tasks Namespace


RegexReplace Members

RegexReplace Members
See Also Example Constructors Properties Methods
[image]

Task to replace portions of strings within the Input list Output list contains all the elements of the Input list after performing the Regex Replace.

The following tables list the members exposed by RegexReplace.

Public Constructors

 | Name | Description
Public method | RegexReplace | Initializes a new instance of the RegexReplace class.
Top

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | Count | Number of matches to allow on each input item. -1 indicates to perform matches on all matches within input item
Public property | Expression | Regex expression (inherited from RegexBase)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Input | Input, list of items to perform the regex on (inherited from RegexBase)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Options | Regex options as strings corresponding to the RegexOptions enum: Compiled CultureInvariant ECMAScript ExplicitCapture IgnoreCase IgnorePatternWhitespace Multiline None RightToLeft Singleline (inherited from RegexBase)
Public property | Output | Results of the Regex transformation. (inherited from RegexBase)
Public property | Replacement | String replacing matching expression strings in input list. If left empty matches in the input list are removed (replaced with empty string)
Public property | StartAt | Position within the input item to start matching
Top

Protected Properties

 | Name | Description
Family property | ExpressionOptions | Options converted to RegexOptions enum (inherited from RegexBase)
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. Performs the Replace task
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

RegexReplace Class
RegexReplace Members
MSBuild.Community.Tasks Namespace


RegexReplace Constructor

RegexReplace Constructor
[image]

Initializes a new instance of the RegexReplace class.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public RegexReplace()
C++
public:
RegexReplace() sealed
J#
public RegexReplace()
JScript
public function RegexReplace()

See Also

RegexReplace Class
RegexReplace Members
MSBuild.Community.Tasks Namespace


Properties

RegexReplace Properties
See Also Example
[image]

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | Count | Number of matches to allow on each input item. -1 indicates to perform matches on all matches within input item
Public property | Expression | Regex expression (inherited from RegexBase)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Input | Input, list of items to perform the regex on (inherited from RegexBase)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Options | Regex options as strings corresponding to the RegexOptions enum: Compiled CultureInvariant ECMAScript ExplicitCapture IgnoreCase IgnorePatternWhitespace Multiline None RightToLeft Singleline (inherited from RegexBase)
Public property | Output | Results of the Regex transformation. (inherited from RegexBase)
Public property | Replacement | String replacing matching expression strings in input list. If left empty matches in the input list are removed (replaced with empty string)
Public property | StartAt | Position within the input item to start matching
Top

Protected Properties

 | Name | Description
Family property | ExpressionOptions | Options converted to RegexOptions enum (inherited from RegexBase)
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

See Also

RegexReplace Class
RegexReplace Members
MSBuild.Community.Tasks Namespace


Count Property

RegexReplace.Count Property
[image]

Number of matches to allow on each input item. -1 indicates to perform matches on all matches within input item

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Count As ITaskItem
C#
public ITaskItem Count { get; set; }
C++
public property ITaskItem Count sealed {
ITaskItem get();
void set(ITaskItem value);
}
J#
/** property */
public ITaskItem get_Count();

/** property */
public void set_Count(ITaskItem value);
JScript
public function get Count() : ITaskItem

public function set Count(value : ITaskItem);

See Also

RegexReplace Class
RegexReplace Members
MSBuild.Community.Tasks Namespace


Replacement Property

RegexReplace.Replacement Property
[image]

String replacing matching expression strings in input list. If left empty matches in the input list are removed (replaced with empty string)

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Replacement As ITaskItem
C#
public ITaskItem Replacement { get; set; }
C++
public property ITaskItem Replacement sealed {
ITaskItem get();
void set(ITaskItem value);
}
J#
/** property */
public ITaskItem get_Replacement();

/** property */
public void set_Replacement(ITaskItem value);
JScript
public function get Replacement() : ITaskItem

public function set Replacement(value : ITaskItem);

See Also

RegexReplace Class
RegexReplace Members
MSBuild.Community.Tasks Namespace


StartAt Property

RegexReplace.StartAt Property
[image]

Position within the input item to start matching

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property StartAt As ITaskItem
C#
public ITaskItem StartAt { get; set; }
C++
public property ITaskItem StartAt sealed {
ITaskItem get();
void set(ITaskItem value);
}
J#
/** property */
public ITaskItem get_StartAt();

/** property */
public void set_StartAt(ITaskItem value);
JScript
public function get StartAt() : ITaskItem

public function set StartAt(value : ITaskItem);

See Also

RegexReplace Class
RegexReplace Members
MSBuild.Community.Tasks Namespace


Methods

RegexReplace Methods
See Also Example
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. Performs the Replace task
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

RegexReplace Class
RegexReplace Members
MSBuild.Community.Tasks Namespace


Execute Method

RegexReplace.Execute Method
[image]

Performs the Replace task

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute() As Boolean _
Implements ITask.Execute
C#
public override bool Execute()
C++
public:
virtual bool Execute() override
J#
public override bool Execute()
JScript
public override function Execute() : bool

Return Value

true if the task ran successfully; otherwise false.

Implements

ITask.Execute

See Also

RegexReplace Class
RegexReplace Members
MSBuild.Community.Tasks Namespace


RegistryRead Class

RegistryRead Class
See Also Example Members
[image]

Reads a value from the Registry

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class RegistryRead
Inherits Task
C#
public class RegistryRead : Task
C++
ref class RegistryRead : Task
J#
public class RegistryRead extends Task
JScript
public class RegistryRead extends Task

Example

Read .NET Framework install root from Registry.

Copy Code
            <RegistryRead
                KeyName="HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework"
                ValueName="InstallRoot">
                <Output TaskParameter="Value" PropertyName="InstallRoot" />
            </RegistryRead>
            <Message Text="InstallRoot: $(InstallRoot)"/>

Remarks

The Value parameter is set according to the following rules:
If a DefaultValue is provided, it will be used if the KeyName or ValueName does not exist.
If a DefaultValue is not provided, the KeyName exists, but the ValueName does not exist, Value will be set to an empty string.
If a DefaultValue is not provided, and the KeyName does not exist, the task will fail.

Inheritance Hierarchy

System.Object
Microsoft.Build.Utilities.Task
MSBuild.Community.Tasks.RegistryRead

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

RegistryRead Members
MSBuild.Community.Tasks Namespace


RegistryRead Members

RegistryRead Members
See Also Example Constructors Properties Methods
[image]

Reads a value from the Registry

The following tables list the members exposed by RegistryRead.

Public Constructors

 | Name | Description
Public method | RegistryRead | Initializes a new instance of the T:RegistryRead class.
Top

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | DefaultValue | Gets or sets the default value.
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | KeyName | Gets or sets the full registry path of the key, beginning with a valid registry root, such as "HKEY_CURRENT_USER".
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Value | Gets the stored value.
Public property | ValueName | Gets or sets the name of the name/value pair.
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. When overridden in a derived class, executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

RegistryRead Class
RegistryRead Members
MSBuild.Community.Tasks Namespace


RegistryRead Constructor

RegistryRead Constructor
[image]

Initializes a new instance of the T:RegistryRead class.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public RegistryRead()
C++
public:
RegistryRead() sealed
J#
public RegistryRead()
JScript
public function RegistryRead()

See Also

RegistryRead Class
RegistryRead Members
MSBuild.Community.Tasks Namespace


Properties

RegistryRead Properties
See Also Example
[image]

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | DefaultValue | Gets or sets the default value.
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | KeyName | Gets or sets the full registry path of the key, beginning with a valid registry root, such as "HKEY_CURRENT_USER".
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Value | Gets the stored value.
Public property | ValueName | Gets or sets the name of the name/value pair.
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

See Also

RegistryRead Class
RegistryRead Members
MSBuild.Community.Tasks Namespace


DefaultValue Property

RegistryRead.DefaultValue Property
[image]

Gets or sets the default value.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property DefaultValue As String
C#
public string DefaultValue { get; set; }
C++
public property string DefaultValue sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_DefaultValue();

/** property */
public void set_DefaultValue(string value);
JScript
public function get DefaultValue() : String

public function set DefaultValue(value : String);

Property Value

The default value.

See Also

RegistryRead Class
RegistryRead Members
MSBuild.Community.Tasks Namespace


KeyName Property

RegistryRead.KeyName Property
[image]

Gets or sets the full registry path of the key, beginning with a valid registry root, such as "HKEY_CURRENT_USER".

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Required>
Public Property KeyName As String
C#
[Required]
public string KeyName { get; set; }
C++
[Required]
public property string KeyName sealed {
String get();
void set(String value);
}
J#
/** @attribute Required() */
/** property */
public string get_KeyName();

/** property */
public void set_KeyName(string value);
JScript
public function get KeyName() : String

public function set KeyName(value : String);

Property Value

The name of the key.

See Also

RegistryRead Class
RegistryRead Members
MSBuild.Community.Tasks Namespace


Value Property

RegistryRead.Value Property
[image]

Gets the stored value.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Output>
Public ReadOnly Property Value As String
C#
[Output]
public string Value { get; }
C++
[Output]
public property string Value sealed {
String get();
}
J#
/** @attribute Output() */
/** property */
public string get_Value();
JScript
public function get Value() : String

Property Value

The value.

See Also

RegistryRead Class
RegistryRead Members
MSBuild.Community.Tasks Namespace


ValueName Property

RegistryRead.ValueName Property
[image]

Gets or sets the name of the name/value pair.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property ValueName As String
C#
public string ValueName { get; set; }
C++
public property string ValueName sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_ValueName();

/** property */
public void set_ValueName(string value);
JScript
public function get ValueName() : String

public function set ValueName(value : String);

Property Value

The name of the value.

See Also

RegistryRead Class
RegistryRead Members
MSBuild.Community.Tasks Namespace


Methods

RegistryRead Methods
See Also Example
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. When overridden in a derived class, executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

RegistryRead Class
RegistryRead Members
MSBuild.Community.Tasks Namespace


Execute Method

RegistryRead.Execute Method
[image]

When overridden in a derived class, executes the task.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute() As Boolean _
Implements ITask.Execute
C#
public override bool Execute()
C++
public:
virtual bool Execute() override
J#
public override bool Execute()
JScript
public override function Execute() : bool

Return Value

true if the task successfully executed; otherwise, false.

Implements

ITask.Execute

See Also

RegistryRead Class
RegistryRead Members
MSBuild.Community.Tasks Namespace


RegistryWrite Class

RegistryWrite Class
See Also Example Members
[image]

Writes a value to the Registry

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class RegistryWrite
Inherits Task
C#
public class RegistryWrite : Task
C++
ref class RegistryWrite : Task
J#
public class RegistryWrite extends Task
JScript
public class RegistryWrite extends Task

Example

Write a value to Registry

Copy Code
            <RegistryWrite
                KeyName="HKEY_CURRENT_USER\SOFTWARE\MSBuildTasks"
                ValueName="RegistryWrite"
                Value="Test Write" />

Inheritance Hierarchy

System.Object
Microsoft.Build.Utilities.Task
MSBuild.Community.Tasks.RegistryWrite

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

RegistryWrite Members
MSBuild.Community.Tasks Namespace


RegistryWrite Members

RegistryWrite Members
See Also Example Constructors Properties Methods
[image]

Writes a value to the Registry

The following tables list the members exposed by RegistryWrite.

Public Constructors

 | Name | Description
Public method | RegistryWrite | Initializes a new instance of the T:RegistryWrite class.
Top

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | KeyName | Gets or sets the full registry path of the key, beginning with a valid registry root, such as "HKEY_CURRENT_USER".
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Value | Gets or sets the value to be stored.
Public property | ValueName | Gets or sets the name of the name/value pair.
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. When overridden in a derived class, executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

RegistryWrite Class
RegistryWrite Members
MSBuild.Community.Tasks Namespace


RegistryWrite Constructor

RegistryWrite Constructor
[image]

Initializes a new instance of the T:RegistryWrite class.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public RegistryWrite()
C++
public:
RegistryWrite() sealed
J#
public RegistryWrite()
JScript
public function RegistryWrite()

See Also

RegistryWrite Class
RegistryWrite Members
MSBuild.Community.Tasks Namespace


Properties

RegistryWrite Properties
See Also Example
[image]

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | KeyName | Gets or sets the full registry path of the key, beginning with a valid registry root, such as "HKEY_CURRENT_USER".
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Value | Gets or sets the value to be stored.
Public property | ValueName | Gets or sets the name of the name/value pair.
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

See Also

RegistryWrite Class
RegistryWrite Members
MSBuild.Community.Tasks Namespace


KeyName Property

RegistryWrite.KeyName Property
[image]

Gets or sets the full registry path of the key, beginning with a valid registry root, such as "HKEY_CURRENT_USER".

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Required>
Public Property KeyName As String
C#
[Required]
public string KeyName { get; set; }
C++
[Required]
public property string KeyName sealed {
String get();
void set(String value);
}
J#
/** @attribute Required() */
/** property */
public string get_KeyName();

/** property */
public void set_KeyName(string value);
JScript
public function get KeyName() : String

public function set KeyName(value : String);

Property Value

The name of the key.

See Also

RegistryWrite Class
RegistryWrite Members
MSBuild.Community.Tasks Namespace


Value Property

RegistryWrite.Value Property
[image]

Gets or sets the value to be stored.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Required>
Public Property Value As String
C#
[Required]
public string Value { get; set; }
C++
[Required]
public property string Value sealed {
String get();
void set(String value);
}
J#
/** @attribute Required() */
/** property */
public string get_Value();

/** property */
public void set_Value(string value);
JScript
public function get Value() : String

public function set Value(value : String);

Property Value

The value.

See Also

RegistryWrite Class
RegistryWrite Members
MSBuild.Community.Tasks Namespace


ValueName Property

RegistryWrite.ValueName Property
[image]

Gets or sets the name of the name/value pair.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property ValueName As String
C#
public string ValueName { get; set; }
C++
public property string ValueName sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_ValueName();

/** property */
public void set_ValueName(string value);
JScript
public function get ValueName() : String

public function set ValueName(value : String);

Property Value

The name of the value.

See Also

RegistryWrite Class
RegistryWrite Members
MSBuild.Community.Tasks Namespace


Methods

RegistryWrite Methods
See Also Example
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. When overridden in a derived class, executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

RegistryWrite Class
RegistryWrite Members
MSBuild.Community.Tasks Namespace


Execute Method

RegistryWrite.Execute Method
[image]

When overridden in a derived class, executes the task.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute() As Boolean _
Implements ITask.Execute
C#
public override bool Execute()
C++
public:
virtual bool Execute() override
J#
public override bool Execute()
JScript
public override function Execute() : bool

Return Value

true if the task successfully executed; otherwise, false.

Implements

ITask.Execute

See Also

RegistryWrite Class
RegistryWrite Members
MSBuild.Community.Tasks Namespace


Script Class

Script Class
See Also Example Members
[image]

Executes code contained within the task.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class Script
Inherits Task
C#
public class Script : Task
C++
ref class Script : Task
J#
public class Script extends Task
JScript
public class Script extends Task

Example

Simple script that writes to the console

Copy Code
<PropertyGroup>
    <HelloCode>
        <![CDATA[
        public static void ScriptMain() {
            Console.WriteLine("Hello MSBuild Community Scripting World.");
        }
        ]] >
    </HelloCode>
</PropertyGroup>
<Target Name="Hello">
    <Script Language="C#" Code="$(HelloCode)" Imports="System" />
</Target>

Script that returns a value.

Copy Code
<PropertyGroup>
    <GetProgramFilesCode>
        <![CDATA[
        public static string ScriptMain() {
            return Environment.GetFolderPath(Environment.SpecialFolder.ProgramFiles);
        }
        ]] >
    </GetProgramFilesCode>
</PropertyGroup>
<Target Name="GetProgramFilesFolder">
    <Script Language="C#" Code="$(GetProgramFilesCode)">
        <Output TaskParameter="ReturnValue" PropertyName="ProgramFilesFolder" />
    </Script>
    <Message Text="Program files are in: $(ProgramFilesFolder)" />
</Target>

Inheritance Hierarchy

System.Object
Microsoft.Build.Utilities.Task
MSBuild.Community.Tasks.Script

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

Script Members
MSBuild.Community.Tasks Namespace


Script Members

Script Members
See Also Example Constructors Properties Methods
[image]

Executes code contained within the task.

The following tables list the members exposed by Script.

Public Constructors

 | Name | Description
Public method | Script | Initializes a new instance of the Script class.
Top

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | Code | The code to compile and execute
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Imports | The namespaces to import.
Public property | Language | The language of the script block (defaults to C#).
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | MainClass | The name of the main class containing the static ScriptMain entry point.
Public property | References | The required references
Public property | ReturnValue | The string returned from the custom ScriptMain method.
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. Executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

Script Class
Script Members
MSBuild.Community.Tasks Namespace


Script Constructor

Script Constructor
[image]

Initializes a new instance of the Script class.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public Script()
C++
public:
Script() sealed
J#
public Script()
JScript
public function Script()

See Also

Script Class
Script Members
MSBuild.Community.Tasks Namespace


Properties

Script Properties
See Also Example
[image]

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | Code | The code to compile and execute
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Imports | The namespaces to import.
Public property | Language | The language of the script block (defaults to C#).
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | MainClass | The name of the main class containing the static ScriptMain entry point.
Public property | References | The required references
Public property | ReturnValue | The string returned from the custom ScriptMain method.
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

See Also

Script Class
Script Members
MSBuild.Community.Tasks Namespace


Code Property

Script.Code Property
[image]

The code to compile and execute

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Code As String
C#
public string Code { get; set; }
C++
public property string Code sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Code();

/** property */
public void set_Code(string value);
JScript
public function get Code() : String

public function set Code(value : String);

Remarks

The code must include a static (Shared in VB) method named ScriptMain. It cannot accept any parameters. If you define the method return a String, the returned value will be available in the ReturnValue output property.

See Also

Script Class
Script Members
MSBuild.Community.Tasks Namespace


Imports Property

Script.Imports Property
[image]

The namespaces to import.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Imports As ITaskItem[]
C#
public ITaskItem[] Imports { get; set; }
C++
public property ITaskItem[] Imports sealed {
array<ITaskItem>^ get();
void set(array<ITaskItem>^ value);
}
J#
/** property */
public ITaskItem[] get_Imports();

/** property */
public void set_Imports(ITaskItem[] value);
JScript
public function get Imports() : ITaskItem[]

public function set Imports(value : ITaskItem[]);

See Also

Script Class
Script Members
MSBuild.Community.Tasks Namespace


Language Property

Script.Language Property
[image]

The language of the script block (defaults to C#).

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Required>
Public Property Language As String
C#
[Required]
public string Language { get; set; }
C++
[Required]
public property string Language sealed {
String get();
void set(String value);
}
J#
/** @attribute Required() */
/** property */
public string get_Language();

/** property */
public void set_Language(string value);
JScript
public function get Language() : String

public function set Language(value : String);

Remarks

The supported languages are:

  • Visual Basic.NET (VB, vb, VISUALBASIC)
  • C# (C#, c#, CSHARP)
  • JavaScript (JS, js, JSCRIPT)
  • J# (VJS, vjs, JSHARP)
or, proviude the fully-qualified name for a class implementing CodeDomProvider.

See Also

Script Class
Script Members
MSBuild.Community.Tasks Namespace


MainClass Property

Script.MainClass Property
[image]

The name of the main class containing the static ScriptMain entry point.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property MainClass As String
C#
public string MainClass { get; set; }
C++
public property string MainClass sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_MainClass();

/** property */
public void set_MainClass(string value);
JScript
public function get MainClass() : String

public function set MainClass(value : String);

See Also

Script Class
Script Members
MSBuild.Community.Tasks Namespace


References Property

Script.References Property
[image]

The required references

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property References As ITaskItem[]
C#
public ITaskItem[] References { get; set; }
C++
public property ITaskItem[] References sealed {
array<ITaskItem>^ get();
void set(array<ITaskItem>^ value);
}
J#
/** property */
public ITaskItem[] get_References();

/** property */
public void set_References(ITaskItem[] value);
JScript
public function get References() : ITaskItem[]

public function set References(value : ITaskItem[]);

See Also

Script Class
Script Members
MSBuild.Community.Tasks Namespace


ReturnValue Property

Script.ReturnValue Property
[image]

The string returned from the custom ScriptMain method.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Output>
Public ReadOnly Property ReturnValue As String
C#
[Output]
public string ReturnValue { get; }
C++
[Output]
public property string ReturnValue sealed {
String get();
}
J#
/** @attribute Output() */
/** property */
public string get_ReturnValue();
JScript
public function get ReturnValue() : String

See Also

Script Class
Script Members
MSBuild.Community.Tasks Namespace


Methods

Script Methods
See Also Example
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. Executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

Script Class
Script Members
MSBuild.Community.Tasks Namespace


Execute Method

Script.Execute Method
[image]

Executes the task.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute() As Boolean _
Implements ITask.Execute
C#
public override bool Execute()
C++
public:
virtual bool Execute() override
J#
public override bool Execute()
JScript
public override function Execute() : bool

Return Value

true if the task ran successfully; otherwise false.

Implements

ITask.Execute

See Also

Script Class
Script Members
MSBuild.Community.Tasks Namespace


ServiceActions Enumeration

ServiceActions Enumeration
[image]

Defines the actions that can be performed on a service.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Enum ServiceActions
C#
public enum ServiceActions
C++
public enum class ServiceActions
J#
public enum ServiceActions
JScript
public enum ServiceActions

Members

Member Name | Description
Start | Starts a service.
Stop | Stops a service.
Restart | Restarts a service.
Pause | Pauses a running service.
Continue | Continues a paused service.

See Also

ServiceActions Members
MSBuild.Community.Tasks Namespace


ServiceController Class

ServiceController Class
See Also Example Members
[image]

Task that can control a Windows service.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class ServiceController
Inherits ServiceQuery
C#
public class ServiceController : ServiceQuery
C++
ref class ServiceController : ServiceQuery
J#
public class ServiceController extends ServiceQuery
JScript
public class ServiceController extends ServiceQuery

Example

Restart Web Server

Copy Code
            <ServiceController ServiceName="w3svc" Action="Restart" />

Inheritance Hierarchy

System.Object
Microsoft.Build.Utilities.Task
MSBuild.Community.Tasks.ServiceQuery
MSBuild.Community.Tasks.ServiceController

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ServiceController Members
MSBuild.Community.Tasks Namespace


ServiceController Members

ServiceController Members
See Also Example Constructors Properties Methods
[image]

Task that can control a Windows service.

The following tables list the members exposed by ServiceController.

Public Constructors

 | Name | Description
Public method | ServiceController | Initializes a new instance of the T:ServiceController class.
Top

Public Properties

 | Name | Description
Public property | Action | Gets or sets the T:ServiceActions to perform on the service.
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | CanPauseAndContinue | Gets a value indicating whether the service can be paused and resumed. (inherited from ServiceQuery)
Public property | CanShutdown | Gets a value indicating whether the service should be notified when the system is shutting down. (inherited from ServiceQuery)
Public property | CanStop | Gets a value indicating whether the service can be stopped after it has started. (inherited from ServiceQuery)
Public property | DisplayName | Gets a friendly name for the service. (inherited from ServiceQuery)
Public property | Exists | Gets a value indicating whether the service exists. (inherited from ServiceQuery)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | MachineName | Gets or sets the name of the machine. (inherited from ServiceQuery)
Public property | ServiceName | Gets or sets the name of the service. (inherited from ServiceQuery)
Public property | Status | Gets or sets the status. (inherited from ServiceQuery)
Public property | Timeout | Gets or sets the timeout for the command. The default is one minute.
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. Executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetServiceController | Gets the service controller. (inherited from ServiceQuery)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

ServiceController Class
ServiceController Members
MSBuild.Community.Tasks Namespace


ServiceController Constructor

ServiceController Constructor
[image]

Initializes a new instance of the T:ServiceController class.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ServiceController()
C++
public:
ServiceController() sealed
J#
public ServiceController()
JScript
public function ServiceController()

See Also

ServiceController Class
ServiceController Members
MSBuild.Community.Tasks Namespace


Properties

ServiceController Properties
See Also Example
[image]

Public Properties

 | Name | Description
Public property | Action | Gets or sets the T:ServiceActions to perform on the service.
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | CanPauseAndContinue | Gets a value indicating whether the service can be paused and resumed. (inherited from ServiceQuery)
Public property | CanShutdown | Gets a value indicating whether the service should be notified when the system is shutting down. (inherited from ServiceQuery)
Public property | CanStop | Gets a value indicating whether the service can be stopped after it has started. (inherited from ServiceQuery)
Public property | DisplayName | Gets a friendly name for the service. (inherited from ServiceQuery)
Public property | Exists | Gets a value indicating whether the service exists. (inherited from ServiceQuery)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | MachineName | Gets or sets the name of the machine. (inherited from ServiceQuery)
Public property | ServiceName | Gets or sets the name of the service. (inherited from ServiceQuery)
Public property | Status | Gets or sets the status. (inherited from ServiceQuery)
Public property | Timeout | Gets or sets the timeout for the command. The default is one minute.
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

See Also

ServiceController Class
ServiceController Members
MSBuild.Community.Tasks Namespace


Action Property

ServiceController.Action Property
[image]

Gets or sets the T:ServiceActions to perform on the service.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Required>
Public Property Action As String
C#
[Required]
public string Action { get; set; }
C++
[Required]
public property string Action sealed {
String get();
void set(String value);
}
J#
/** @attribute Required() */
/** property */
public string get_Action();

/** property */
public void set_Action(string value);
JScript
public function get Action() : String

public function set Action(value : String);

Property Value

The action to perform on the service.

See Also

ServiceController Class
ServiceController Members
MSBuild.Community.Tasks Namespace


Timeout Property

ServiceController.Timeout Property
[image]

Gets or sets the timeout for the command. The default is one minute.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Timeout As Double
C#
public double Timeout { get; set; }
C++
public property double Timeout sealed {
double get();
void set(double value);
}
J#
/** property */
public double get_Timeout();

/** property */
public void set_Timeout(double value);
JScript
public function get Timeout() : double

public function set Timeout(value : double);

Property Value

The timeout for the command.

See Also

ServiceController Class
ServiceController Members
MSBuild.Community.Tasks Namespace


Methods

ServiceController Methods
See Also Example
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. Executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetServiceController | Gets the service controller. (inherited from ServiceQuery)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

ServiceController Class
ServiceController Members
MSBuild.Community.Tasks Namespace


Execute Method

ServiceController.Execute Method
[image]

Executes the task.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute() As Boolean _
Implements ITask.Execute
C#
public override bool Execute()
C++
public:
virtual bool Execute() override
J#
public override bool Execute()
JScript
public override function Execute() : bool

Return Value

true if the task ran successfully; otherwise false.

Implements

ITask.Execute

See Also

ServiceController Class
ServiceController Members
MSBuild.Community.Tasks Namespace


ServiceQuery Class

ServiceQuery Class
See Also Example Members
[image]

Task that can determine the status of a specified service on a target server.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class ServiceQuery
Inherits Task
C#
public class ServiceQuery : Task
C++
ref class ServiceQuery : Task
J#
public class ServiceQuery extends Task
JScript
public class ServiceQuery extends Task

Example

Check status of SQL Server

Copy Code
            <ServiceQuery ServiceName="MSSQLServer">
                <Output TaskParameter="Status" PropertyName="ResultStatus" />
            </ServiceQuery>
            <Message Text="MSSQLServer Service Status: $(ResultStatus)"/>

Inheritance Hierarchy

System.Object
Microsoft.Build.Utilities.Task
MSBuild.Community.Tasks.ServiceQuery
MSBuild.Community.Tasks.ServiceController

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ServiceQuery Members
MSBuild.Community.Tasks Namespace


ServiceQuery Members

ServiceQuery Members
See Also Example Constructors Fields Properties Methods
[image]

Task that can determine the status of a specified service on a target server.

The following tables list the members exposed by ServiceQuery.

Public Constructors

 | Name | Description
Public method | ServiceQuery | Initializes a new instance of the T:ServiceQuery class.
Top

Public Fields

Name | Description
UNKNOWN_STATUS | The unknown Status returned when the service does not exist. The value is "Unknown". This field is constant and read-only.
Top

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | CanPauseAndContinue | Gets a value indicating whether the service can be paused and resumed.
Public property | CanShutdown | Gets a value indicating whether the service should be notified when the system is shutting down.
Public property | CanStop | Gets a value indicating whether the service can be stopped after it has started.
Public property | DisplayName | Gets a friendly name for the service.
Public property | Exists | Gets a value indicating whether the service exists.
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | MachineName | Gets or sets the name of the machine.
Public property | ServiceName | Gets or sets the name of the service.
Public property | Status | Gets or sets the status.
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. Executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetServiceController | Gets the service controller.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

ServiceQuery Class
ServiceQuery Members
MSBuild.Community.Tasks Namespace


ServiceQuery Constructor

ServiceQuery Constructor
[image]

Initializes a new instance of the T:ServiceQuery class.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ServiceQuery()
C++
public:
ServiceQuery() sealed
J#
public ServiceQuery()
JScript
public function ServiceQuery()

See Also

ServiceQuery Class
ServiceQuery Members
MSBuild.Community.Tasks Namespace


Fields

ServiceQuery Fields
See Also Example
[image]

Public Fields

Name | Description
UNKNOWN_STATUS | The unknown Status returned when the service does not exist. The value is "Unknown". This field is constant and read-only.
Top

See Also

ServiceQuery Class
ServiceQuery Members
MSBuild.Community.Tasks Namespace


UNKNOWN_STATUS Field

ServiceQuery.UNKNOWN_STATUS Field
[image]

The unknown Status returned when the service does not exist. The value is "Unknown". This field is constant and read-only.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public const UNKNOWN_STATUS As String = "Unknown"
C#
public const string UNKNOWN_STATUS = "Unknown";
C++
public:
const String UNKNOWN_STATUS = L"Unknown";
J#
public const string UNKNOWN_STATUS = "Unknown"
JScript
public const UNKNOWN_STATUS : String = "Unknown";

See Also

ServiceQuery Class
ServiceQuery Members
MSBuild.Community.Tasks Namespace


Properties

ServiceQuery Properties
See Also Example
[image]

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | CanPauseAndContinue | Gets a value indicating whether the service can be paused and resumed.
Public property | CanShutdown | Gets a value indicating whether the service should be notified when the system is shutting down.
Public property | CanStop | Gets a value indicating whether the service can be stopped after it has started.
Public property | DisplayName | Gets a friendly name for the service.
Public property | Exists | Gets a value indicating whether the service exists.
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | MachineName | Gets or sets the name of the machine.
Public property | ServiceName | Gets or sets the name of the service.
Public property | Status | Gets or sets the status.
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

See Also

ServiceQuery Class
ServiceQuery Members
MSBuild.Community.Tasks Namespace


CanPauseAndContinue Property

ServiceQuery.CanPauseAndContinue Property
[image]

Gets a value indicating whether the service can be paused and resumed.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Output>
Public ReadOnly Property CanPauseAndContinue As Boolean
C#
[Output]
public bool CanPauseAndContinue { get; }
C++
[Output]
public property bool CanPauseAndContinue sealed {
bool get();
}
J#
/** @attribute Output() */
/** property */
public bool get_CanPauseAndContinue();
JScript
public function get CanPauseAndContinue() : bool

Property Value

true if this instance can pause and continue; otherwise, false.

See Also

ServiceQuery Class
ServiceQuery Members
MSBuild.Community.Tasks Namespace


CanShutdown Property

ServiceQuery.CanShutdown Property
[image]

Gets a value indicating whether the service should be notified when the system is shutting down.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Output>
Public ReadOnly Property CanShutdown As Boolean
C#
[Output]
public bool CanShutdown { get; }
C++
[Output]
public property bool CanShutdown sealed {
bool get();
}
J#
/** @attribute Output() */
/** property */
public bool get_CanShutdown();
JScript
public function get CanShutdown() : bool

Property Value

true if this instance can shutdown; otherwise, false.

See Also

ServiceQuery Class
ServiceQuery Members
MSBuild.Community.Tasks Namespace


CanStop Property

ServiceQuery.CanStop Property
[image]

Gets a value indicating whether the service can be stopped after it has started.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Output>
Public ReadOnly Property CanStop As Boolean
C#
[Output]
public bool CanStop { get; }
C++
[Output]
public property bool CanStop sealed {
bool get();
}
J#
/** @attribute Output() */
/** property */
public bool get_CanStop();
JScript
public function get CanStop() : bool

Property Value

true if this instance can stop; otherwise, false.

See Also

ServiceQuery Class
ServiceQuery Members
MSBuild.Community.Tasks Namespace


DisplayName Property

ServiceQuery.DisplayName Property
[image]

Gets a friendly name for the service.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Output>
Public ReadOnly Property DisplayName As String
C#
[Output]
public string DisplayName { get; }
C++
[Output]
public property string DisplayName sealed {
String get();
}
J#
/** @attribute Output() */
/** property */
public string get_DisplayName();
JScript
public function get DisplayName() : String

Property Value

The name of the display.

See Also

ServiceQuery Class
ServiceQuery Members
MSBuild.Community.Tasks Namespace


Exists Property

ServiceQuery.Exists Property
[image]

Gets a value indicating whether the service exists.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Output>
Public ReadOnly Property Exists As Boolean
C#
[Output]
public bool Exists { get; }
C++
[Output]
public property bool Exists sealed {
bool get();
}
J#
/** @attribute Output() */
/** property */
public bool get_Exists();
JScript
public function get Exists() : bool

Property Value

true if the service exists; otherwise, false.

See Also

ServiceQuery Class
ServiceQuery Members
MSBuild.Community.Tasks Namespace


MachineName Property

ServiceQuery.MachineName Property
[image]

Gets or sets the name of the machine.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property MachineName As String
C#
public string MachineName { get; set; }
C++
public property string MachineName sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_MachineName();

/** property */
public void set_MachineName(string value);
JScript
public function get MachineName() : String

public function set MachineName(value : String);

Property Value

The name of the machine.

See Also

ServiceQuery Class
ServiceQuery Members
MSBuild.Community.Tasks Namespace


ServiceName Property

ServiceQuery.ServiceName Property
[image]

Gets or sets the name of the service.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Required>
Public Property ServiceName As String
C#
[Required]
public string ServiceName { get; set; }
C++
[Required]
public property string ServiceName sealed {
String get();
void set(String value);
}
J#
/** @attribute Required() */
/** property */
public string get_ServiceName();

/** property */
public void set_ServiceName(string value);
JScript
public function get ServiceName() : String

public function set ServiceName(value : String);

Property Value

The name of the service.

See Also

ServiceQuery Class
ServiceQuery Members
MSBuild.Community.Tasks Namespace


Status Property

ServiceQuery.Status Property
[image]

Gets or sets the status.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Output>
Public Property Status As String
C#
[Output]
public string Status { get; set; }
C++
[Output]
public property string Status sealed {
String get();
void set(String value);
}
J#
/** @attribute Output() */
/** property */
public string get_Status();

/** property */
public void set_Status(string value);
JScript
public function get Status() : String

public function set Status(value : String);

Property Value

The status of the service.

See Also

ServiceQuery Class
ServiceQuery Members
MSBuild.Community.Tasks Namespace


Methods

ServiceQuery Methods
See Also Example
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. Executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetServiceController | Gets the service controller.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

ServiceQuery Class
ServiceQuery Members
MSBuild.Community.Tasks Namespace


Execute Method

ServiceQuery.Execute Method
[image]

Executes the task.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute() As Boolean _
Implements ITask.Execute
C#
public override bool Execute()
C++
public:
virtual bool Execute() override
J#
public override bool Execute()
JScript
public override function Execute() : bool

Return Value

true if the task ran successfully; otherwise false.

Implements

ITask.Execute

See Also

ServiceQuery Class
ServiceQuery Members
MSBuild.Community.Tasks Namespace


GetServiceController Method

ServiceQuery.GetServiceController Method
[image]

Gets the service controller.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Function GetServiceController() As ServiceController
C#
protected ServiceController GetServiceController()
C++
protected:
ServiceController GetServiceController() sealed
J#
protected ServiceController GetServiceController()
JScript
protected function GetServiceController() : ServiceController

See Also

ServiceQuery Class
ServiceQuery Members
MSBuild.Community.Tasks Namespace


Sleep Class

Sleep Class
See Also Example Members
[image]

A task for sleeping for a specified period of time.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class Sleep
Inherits Task
C#
public class Sleep : Task
C++
ref class Sleep : Task
J#
public class Sleep extends Task
JScript
public class Sleep extends Task

Example

Causes the build to sleep for 300 milliseconds.

Copy Code
            <Sleep Milliseconds="300" />

Inheritance Hierarchy

System.Object
Microsoft.Build.Utilities.Task
MSBuild.Community.Tasks.Sleep

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

Sleep Members
MSBuild.Community.Tasks Namespace


Sleep Members

Sleep Members
See Also Example Constructors Properties Methods
[image]

A task for sleeping for a specified period of time.

The following tables list the members exposed by Sleep.

Public Constructors

 | Name | Description
Public method | Sleep | Initializes a new instance of the Sleep class.
Top

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Hours | The number of hours to add to the time to sleep.
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Milliseconds | The number of milliseconds to add to the time to sleep.
Public property | Minutes | The number of minutes to add to the time to sleep.
Public property | Seconds | The number of seconds to add to the time to sleep.
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. Executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

Sleep Class
Sleep Members
MSBuild.Community.Tasks Namespace


Sleep Constructor

Sleep Constructor
[image]

Initializes a new instance of the Sleep class.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public Sleep()
C++
public:
Sleep() sealed
J#
public Sleep()
JScript
public function Sleep()

See Also

Sleep Class
Sleep Members
MSBuild.Community.Tasks Namespace


Properties

Sleep Properties
See Also Example
[image]

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Hours | The number of hours to add to the time to sleep.
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Milliseconds | The number of milliseconds to add to the time to sleep.
Public property | Minutes | The number of minutes to add to the time to sleep.
Public property | Seconds | The number of seconds to add to the time to sleep.
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

See Also

Sleep Class
Sleep Members
MSBuild.Community.Tasks Namespace


Hours Property

Sleep.Hours Property
[image]

The number of hours to add to the time to sleep.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Hours As Integer
C#
public int Hours { get; set; }
C++
public property int Hours sealed {
int get();
void set(int value);
}
J#
/** property */
public int get_Hours();

/** property */
public void set_Hours(int value);
JScript
public function get Hours() : int

public function set Hours(value : int);

See Also

Sleep Class
Sleep Members
MSBuild.Community.Tasks Namespace


Milliseconds Property

Sleep.Milliseconds Property
[image]

The number of milliseconds to add to the time to sleep.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Milliseconds As Integer
C#
public int Milliseconds { get; set; }
C++
public property int Milliseconds sealed {
int get();
void set(int value);
}
J#
/** property */
public int get_Milliseconds();

/** property */
public void set_Milliseconds(int value);
JScript
public function get Milliseconds() : int

public function set Milliseconds(value : int);

See Also

Sleep Class
Sleep Members
MSBuild.Community.Tasks Namespace


Minutes Property

Sleep.Minutes Property
[image]

The number of minutes to add to the time to sleep.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Minutes As Integer
C#
public int Minutes { get; set; }
C++
public property int Minutes sealed {
int get();
void set(int value);
}
J#
/** property */
public int get_Minutes();

/** property */
public void set_Minutes(int value);
JScript
public function get Minutes() : int

public function set Minutes(value : int);

See Also

Sleep Class
Sleep Members
MSBuild.Community.Tasks Namespace


Seconds Property

Sleep.Seconds Property
[image]

The number of seconds to add to the time to sleep.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Seconds As Integer
C#
public int Seconds { get; set; }
C++
public property int Seconds sealed {
int get();
void set(int value);
}
J#
/** property */
public int get_Seconds();

/** property */
public void set_Seconds(int value);
JScript
public function get Seconds() : int

public function set Seconds(value : int);

See Also

Sleep Class
Sleep Members
MSBuild.Community.Tasks Namespace


Methods

Sleep Methods
See Also Example
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. Executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

Sleep Class
Sleep Members
MSBuild.Community.Tasks Namespace


Execute Method

Sleep.Execute Method
[image]

Executes the task.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute() As Boolean _
Implements ITask.Execute
C#
public override bool Execute()
C++
public:
virtual bool Execute() override
J#
public override bool Execute()
JScript
public override function Execute() : bool

Return Value

true if the task ran successfully; otherwise false.

Implements

ITask.Execute

See Also

Sleep Class
Sleep Members
MSBuild.Community.Tasks Namespace


SqlExecute Class

SqlExecute Class
See Also Members
[image]

Executes a SQL command.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class SqlExecute
Inherits Task
C#
public class SqlExecute : Task
C++
ref class SqlExecute : Task
J#
public class SqlExecute extends Task
JScript
public class SqlExecute extends Task

Inheritance Hierarchy

System.Object
Microsoft.Build.Utilities.Task
MSBuild.Community.Tasks.SqlExecute

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SqlExecute Members
MSBuild.Community.Tasks Namespace


SqlExecute Members

SqlExecute Members
See Also Constructors Properties Methods
[image]

Executes a SQL command.

The following tables list the members exposed by SqlExecute.

Public Constructors

 | Name | Description
Public method | SqlExecute | Initializes a new instance of the SqlExecute class.
Top

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | Command | The command to execute
Public property | ConnectionString | The connection string
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Result | Output the return count/value
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. When overridden in a derived class, executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

SqlExecute Class
SqlExecute Members
MSBuild.Community.Tasks Namespace


SqlExecute Constructor

SqlExecute Constructor
[image]

Initializes a new instance of the SqlExecute class.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SqlExecute()
C++
public:
SqlExecute() sealed
J#
public SqlExecute()
JScript
public function SqlExecute()

See Also

SqlExecute Class
SqlExecute Members
MSBuild.Community.Tasks Namespace


Properties

SqlExecute Properties
[image]

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | Command | The command to execute
Public property | ConnectionString | The connection string
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Result | Output the return count/value
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

See Also

SqlExecute Class
SqlExecute Members
MSBuild.Community.Tasks Namespace


Command Property

SqlExecute.Command Property
[image]

The command to execute

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Required>
Public Property Command As String
C#
[Required]
public string Command { get; set; }
C++
[Required]
public property string Command sealed {
String get();
void set(String value);
}
J#
/** @attribute Required() */
/** property */
public string get_Command();

/** property */
public void set_Command(string value);
JScript
public function get Command() : String

public function set Command(value : String);

See Also

SqlExecute Class
SqlExecute Members
MSBuild.Community.Tasks Namespace


ConnectionString Property

SqlExecute.ConnectionString Property
[image]

The connection string

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Required>
Public Property ConnectionString As String
C#
[Required]
public string ConnectionString { get; set; }
C++
[Required]
public property string ConnectionString sealed {
String get();
void set(String value);
}
J#
/** @attribute Required() */
/** property */
public string get_ConnectionString();

/** property */
public void set_ConnectionString(string value);
JScript
public function get ConnectionString() : String

public function set ConnectionString(value : String);

See Also

SqlExecute Class
SqlExecute Members
MSBuild.Community.Tasks Namespace


Result Property

SqlExecute.Result Property
[image]

Output the return count/value

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Output>
Public ReadOnly Property Result As Integer
C#
[Output]
public int Result { get; }
C++
[Output]
public property int Result sealed {
int get();
}
J#
/** @attribute Output() */
/** property */
public int get_Result();
JScript
public function get Result() : int

See Also

SqlExecute Class
SqlExecute Members
MSBuild.Community.Tasks Namespace


Methods

SqlExecute Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. When overridden in a derived class, executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

SqlExecute Class
SqlExecute Members
MSBuild.Community.Tasks Namespace


Execute Method

SqlExecute.Execute Method
[image]

When overridden in a derived class, executes the task.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute() As Boolean _
Implements ITask.Execute
C#
public override bool Execute()
C++
public:
virtual bool Execute() override
J#
public override bool Execute()
JScript
public override function Execute() : bool

Return Value

true if the task successfully executed; otherwise, false.

Implements

ITask.Execute

See Also

SqlExecute Class
SqlExecute Members
MSBuild.Community.Tasks Namespace


TemplateFile Class

TemplateFile Class
See Also Example Members
[image]

MSBuild task that replaces tokens in a template file and writes out a new file.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class TemplateFile
Inherits Task
C#
public class TemplateFile : Task
C++
ref class TemplateFile : Task
J#
public class TemplateFile extends Task
JScript
public class TemplateFile extends Task

Example

Copy Code
            <ItemGroup>
                <Tokens Include="Name">
                    <ReplacementValue>MSBuild Community Tasks</ReplacementValue>
                </Tokens>
            </ItemGroup>

            <TemplateFile TemplateFile="ATemplateFile.template" OutputFile="ReplacedFile.txt" Tokens="@(Tokens)" />

Remarks

Tokens in the template file are formatted using ${var} syntax and names are not case-sensitive, so ${Token} and ${TOKEN} are equivalent.

Inheritance Hierarchy

System.Object
Microsoft.Build.Utilities.Task
MSBuild.Community.Tasks.TemplateFile

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

TemplateFile Members
MSBuild.Community.Tasks Namespace


TemplateFile Members

TemplateFile Members
See Also Example Constructors Fields Properties Methods
[image]

MSBuild task that replaces tokens in a template file and writes out a new file.

The following tables list the members exposed by TemplateFile.

Public Constructors

 | Name | Description
Public method | TemplateFile | Default constructor. Creates a new TemplateFile task.
Top

Public Fields

Name | Description
MetadataValueTag | Meta data tag used for token replacement This field is read-only.
Top

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | OutputFile | The token replaced template file.
Public property | OutputFilename | The full path to the output file name. If no filename is specified (the default) the output file will be the Template filename with a .out extension.
Public property | Template | The template file used. Tokens with values of ${Name} are replaced by name.
Public property | Tokens | List of tokens to replace in the template. Token name is taken from the TaskItem.ItemSpec and the replacement value comes from the ReplacementValue metadata of the item.
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. Executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

TemplateFile Class
TemplateFile Members
MSBuild.Community.Tasks Namespace


TemplateFile Constructor

TemplateFile Constructor
[image]

Default constructor. Creates a new TemplateFile task.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public TemplateFile()
C++
public:
TemplateFile() sealed
J#
public TemplateFile()
JScript
public function TemplateFile()

See Also

TemplateFile Class
TemplateFile Members
MSBuild.Community.Tasks Namespace


Fields

TemplateFile Fields
See Also Example
[image]

Public Fields

Name | Description
MetadataValueTag | Meta data tag used for token replacement This field is read-only.
Top

See Also

TemplateFile Class
TemplateFile Members
MSBuild.Community.Tasks Namespace


MetadataValueTag Field

TemplateFile.MetadataValueTag Field
[image]

Meta data tag used for token replacement This field is read-only.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MetadataValueTag As String
C#
public static readonly string MetadataValueTag;
C++
public:
static const String MetadataValueTag;
J#
public static final string MetadataValueTag
JScript
public static const var MetadataValueTag : String;

See Also

TemplateFile Class
TemplateFile Members
MSBuild.Community.Tasks Namespace


Properties

TemplateFile Properties
See Also Example
[image]

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | OutputFile | The token replaced template file.
Public property | OutputFilename | The full path to the output file name. If no filename is specified (the default) the output file will be the Template filename with a .out extension.
Public property | Template | The template file used. Tokens with values of ${Name} are replaced by name.
Public property | Tokens | List of tokens to replace in the template. Token name is taken from the TaskItem.ItemSpec and the replacement value comes from the ReplacementValue metadata of the item.
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

See Also

TemplateFile Class
TemplateFile Members
MSBuild.Community.Tasks Namespace


OutputFile Property

TemplateFile.OutputFile Property
[image]

The token replaced template file.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Output>
Public Property OutputFile As ITaskItem
C#
[Output]
public ITaskItem OutputFile { get; set; }
C++
[Output]
public property ITaskItem OutputFile sealed {
ITaskItem get();
void set(ITaskItem value);
}
J#
/** @attribute Output() */
/** property */
public ITaskItem get_OutputFile();

/** property */
public void set_OutputFile(ITaskItem value);
JScript
public function get OutputFile() : ITaskItem

public function set OutputFile(value : ITaskItem);

See Also

TemplateFile Class
TemplateFile Members
MSBuild.Community.Tasks Namespace


OutputFilename Property

TemplateFile.OutputFilename Property
[image]

The full path to the output file name. If no filename is specified (the default) the output file will be the Template filename with a .out extension.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property OutputFilename As String
C#
public string OutputFilename { get; set; }
C++
public property string OutputFilename sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_OutputFilename();

/** property */
public void set_OutputFilename(string value);
JScript
public function get OutputFilename() : String

public function set OutputFilename(value : String);

See Also

TemplateFile Class
TemplateFile Members
MSBuild.Community.Tasks Namespace


Template Property

TemplateFile.Template Property
[image]

The template file used. Tokens with values of ${Name} are replaced by name.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Required>
Public Property Template As ITaskItem
C#
[Required]
public ITaskItem Template { get; set; }
C++
[Required]
public property ITaskItem Template sealed {
ITaskItem get();
void set(ITaskItem value);
}
J#
/** @attribute Required() */
/** property */
public ITaskItem get_Template();

/** property */
public void set_Template(ITaskItem value);
JScript
public function get Template() : ITaskItem

public function set Template(value : ITaskItem);

See Also

TemplateFile Class
TemplateFile Members
MSBuild.Community.Tasks Namespace


Tokens Property

TemplateFile.Tokens Property
[image]

List of tokens to replace in the template. Token name is taken from the TaskItem.ItemSpec and the replacement value comes from the ReplacementValue metadata of the item.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Tokens As ITaskItem[]
C#
public ITaskItem[] Tokens { get; set; }
C++
public property ITaskItem[] Tokens sealed {
array<ITaskItem>^ get();
void set(array<ITaskItem>^ value);
}
J#
/** property */
public ITaskItem[] get_Tokens();

/** property */
public void set_Tokens(ITaskItem[] value);
JScript
public function get Tokens() : ITaskItem[]

public function set Tokens(value : ITaskItem[]);

See Also

TemplateFile Class
TemplateFile Members
MSBuild.Community.Tasks Namespace


Methods

TemplateFile Methods
See Also Example
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. Executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

TemplateFile Class
TemplateFile Members
MSBuild.Community.Tasks Namespace


Execute Method

TemplateFile.Execute Method
[image]

Executes the task.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute() As Boolean _
Implements ITask.Execute
C#
public override bool Execute()
C++
public:
virtual bool Execute() override
J#
public override bool Execute()
JScript
public override function Execute() : bool

Return Value

Success or failure of the task.

Implements

ITask.Execute

See Also

TemplateFile Class
TemplateFile Members
MSBuild.Community.Tasks Namespace


Time Class

Time Class
See Also Example Members
[image]

Gets the current date and time.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class Time
Inherits Task
C#
public class Time : Task
C++
ref class Time : Task
J#
public class Time extends Task
JScript
public class Time extends Task

Example

Using the Time task to get the Month, Day, Year, Hour, Minute, and Second:

Copy Code
            <Time>
              <Output TaskParameter="Month" PropertyName="Month" />
              <Output TaskParameter="Day" PropertyName="Day" />
              <Output TaskParameter="Year" PropertyName="Year" />
              <Output TaskParameter="Hour" PropertyName="Hour" />
              <Output TaskParameter="Minute" PropertyName="Minute" />
              <Output TaskParameter="Second" PropertyName="Second" />
            </Time>
            <Message Text="Current Date and Time: $(Month)/$(Day)/$(Year) $(Hour):$(Minute):$(Second)" />
Set property "BuildDate" to the current date and time:
Copy Code
            <Time Format="yyyyMMddHHmmss">
                <Output TaskParameter="FormattedTime" PropertyName="buildDate" />
            </Time>

Remarks

See DateTimeFormatInfo for the syntax of the format string.

Inheritance Hierarchy

System.Object
Microsoft.Build.Utilities.Task
MSBuild.Community.Tasks.Time

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

Time Members
MSBuild.Community.Tasks Namespace


Time Members

Time Members
See Also Example Constructors Properties Methods
[image]

Gets the current date and time.

The following tables list the members exposed by Time.

Public Constructors

 | Name | Description
Public method | Time | Initializes a new instance of the Time class.
Top

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | DateTimeValue | Gets the internal time value.
Public property | Day | Gets the day of the month represented by this instance.
Public property | DayOfWeek | Gets the day of the week represented by this instance.
Public property | DayOfYear | Gets the day of the year represented by this instance.
Public property | Format | Gets or sets the format string for output parameter FormattedTime.
Public property | FormattedTime | Gets the value of this instance to its equivalent string representation. If input parameter Format is provided, the value is formatted according to it.
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Hour | Gets the hour component of the date represented by this instance.
Public property | Kind | Gets or sets a value that indicates whether the time represented by this instance is based on local time, Coordinated Universal Time (UTC), or neither.
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | LongDate | Gets the value of this instance to its equivalent long date string representation.
Public property | LongTime | Gets the value of this instance to its equivalent long time string representation.
Public property | Millisecond | Gets the milliseconds component of the date represented by this instance.
Public property | Minute | Gets the minute component of the date represented by this instance.
Public property | Month | Gets the month component of the date represented by this instance.
Public property | Second | Gets the seconds component of the date represented by this instance.
Public property | ShortDate | Gets the value of this instance to its equivalent short date string representation.
Public property | ShortTime | Gets the value of this instance to its equivalent short time string representation.
Public property | Ticks | Gets the number of ticks that represent the date and time of this instance.
Public property | TimeOfDay | Gets the time of day for this instance.
Public property | Year | Gets the year component of the date represented by this instance.
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. When overridden in a derived class, executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

Time Class
Time Members
MSBuild.Community.Tasks Namespace


Time Constructor

Time Constructor
[image]

Initializes a new instance of the Time class.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public Time()
C++
public:
Time() sealed
J#
public Time()
JScript
public function Time()

See Also

Time Class
Time Members
MSBuild.Community.Tasks Namespace


Properties

Time Properties
See Also Example
[image]

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | DateTimeValue | Gets the internal time value.
Public property | Day | Gets the day of the month represented by this instance.
Public property | DayOfWeek | Gets the day of the week represented by this instance.
Public property | DayOfYear | Gets the day of the year represented by this instance.
Public property | Format | Gets or sets the format string for output parameter FormattedTime.
Public property | FormattedTime | Gets the value of this instance to its equivalent string representation. If input parameter Format is provided, the value is formatted according to it.
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Hour | Gets the hour component of the date represented by this instance.
Public property | Kind | Gets or sets a value that indicates whether the time represented by this instance is based on local time, Coordinated Universal Time (UTC), or neither.
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | LongDate | Gets the value of this instance to its equivalent long date string representation.
Public property | LongTime | Gets the value of this instance to its equivalent long time string representation.
Public property | Millisecond | Gets the milliseconds component of the date represented by this instance.
Public property | Minute | Gets the minute component of the date represented by this instance.
Public property | Month | Gets the month component of the date represented by this instance.
Public property | Second | Gets the seconds component of the date represented by this instance.
Public property | ShortDate | Gets the value of this instance to its equivalent short date string representation.
Public property | ShortTime | Gets the value of this instance to its equivalent short time string representation.
Public property | Ticks | Gets the number of ticks that represent the date and time of this instance.
Public property | TimeOfDay | Gets the time of day for this instance.
Public property | Year | Gets the year component of the date represented by this instance.
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

See Also

Time Class
Time Members
MSBuild.Community.Tasks Namespace


DateTimeValue Property

Time.DateTimeValue Property
[image]

Gets the internal time value.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DateTimeValue As Date
C#
public DateTime DateTimeValue { get; }
C++
public property DateTime DateTimeValue sealed {
DateTime get();
}
J#
/** property */
public DateTime get_DateTimeValue();
JScript
public function get DateTimeValue() : DateTime

See Also

Time Class
Time Members
MSBuild.Community.Tasks Namespace


Day Property

Time.Day Property
[image]

Gets the day of the month represented by this instance.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Output>
Public ReadOnly Property Day As String
C#
[Output]
public string Day { get; }
C++
[Output]
public property string Day sealed {
String get();
}
J#
/** @attribute Output() */
/** property */
public string get_Day();
JScript
public function get Day() : String

See Also

Time Class
Time Members
MSBuild.Community.Tasks Namespace


DayOfWeek Property

Time.DayOfWeek Property
[image]

Gets the day of the week represented by this instance.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Output>
Public ReadOnly Property DayOfWeek As String
C#
[Output]
public string DayOfWeek { get; }
C++
[Output]
public property string DayOfWeek sealed {
String get();
}
J#
/** @attribute Output() */
/** property */
public string get_DayOfWeek();
JScript
public function get DayOfWeek() : String

See Also

Time Class
Time Members
MSBuild.Community.Tasks Namespace


DayOfYear Property

Time.DayOfYear Property
[image]

Gets the day of the year represented by this instance.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Output>
Public ReadOnly Property DayOfYear As String
C#
[Output]
public string DayOfYear { get; }
C++
[Output]
public property string DayOfYear sealed {
String get();
}
J#
/** @attribute Output() */
/** property */
public string get_DayOfYear();
JScript
public function get DayOfYear() : String

See Also

Time Class
Time Members
MSBuild.Community.Tasks Namespace


Format Property

Time.Format Property
[image]

Gets or sets the format string for output parameter FormattedTime.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Format As String
C#
public string Format { get; set; }
C++
public property string Format sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Format();

/** property */
public void set_Format(string value);
JScript
public function get Format() : String

public function set Format(value : String);

Remarks

See DateTimeFormatInfo for the syntax of the format string.

See Also

Time Class
Time Members
MSBuild.Community.Tasks Namespace


FormattedTime Property

Time.FormattedTime Property
[image]

Gets the value of this instance to its equivalent string representation. If input parameter Format is provided, the value is formatted according to it.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Output>
Public ReadOnly Property FormattedTime As String
C#
[Output]
public string FormattedTime { get; }
C++
[Output]
public property string FormattedTime sealed {
String get();
}
J#
/** @attribute Output() */
/** property */
public string get_FormattedTime();
JScript
public function get FormattedTime() : String

See Also

Time Class
Time Members
MSBuild.Community.Tasks Namespace


Hour Property

Time.Hour Property
[image]

Gets the hour component of the date represented by this instance.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Output>
Public ReadOnly Property Hour As String
C#
[Output]
public string Hour { get; }
C++
[Output]
public property string Hour sealed {
String get();
}
J#
/** @attribute Output() */
/** property */
public string get_Hour();
JScript
public function get Hour() : String

See Also

Time Class
Time Members
MSBuild.Community.Tasks Namespace


Kind Property

Time.Kind Property
[image]

Gets or sets a value that indicates whether the time represented by this instance is based on local time, Coordinated Universal Time (UTC), or neither.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Output>
Public Property Kind As String
C#
[Output]
public string Kind { get; set; }
C++
[Output]
public property string Kind sealed {
String get();
void set(String value);
}
J#
/** @attribute Output() */
/** property */
public string get_Kind();

/** property */
public void set_Kind(string value);
JScript
public function get Kind() : String

public function set Kind(value : String);

Remarks

Possible values are: Local (default), Utc, Unspecified

See Also

Time Class
Time Members
MSBuild.Community.Tasks Namespace


LongDate Property

Time.LongDate Property
[image]

Gets the value of this instance to its equivalent long date string representation.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Output>
Public ReadOnly Property LongDate As String
C#
[Output]
public string LongDate { get; }
C++
[Output]
public property string LongDate sealed {
String get();
}
J#
/** @attribute Output() */
/** property */
public string get_LongDate();
JScript
public function get LongDate() : String

See Also

Time Class
Time Members
MSBuild.Community.Tasks Namespace


LongTime Property

Time.LongTime Property
[image]

Gets the value of this instance to its equivalent long time string representation.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Output>
Public ReadOnly Property LongTime As String
C#
[Output]
public string LongTime { get; }
C++
[Output]
public property string LongTime sealed {
String get();
}
J#
/** @attribute Output() */
/** property */
public string get_LongTime();
JScript
public function get LongTime() : String

See Also

Time Class
Time Members
MSBuild.Community.Tasks Namespace


Millisecond Property

Time.Millisecond Property
[image]

Gets the milliseconds component of the date represented by this instance.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Output>
Public ReadOnly Property Millisecond As String
C#
[Output]
public string Millisecond { get; }
C++
[Output]
public property string Millisecond sealed {
String get();
}
J#
/** @attribute Output() */
/** property */
public string get_Millisecond();
JScript
public function get Millisecond() : String

See Also

Time Class
Time Members
MSBuild.Community.Tasks Namespace


Minute Property

Time.Minute Property
[image]

Gets the minute component of the date represented by this instance.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Output>
Public ReadOnly Property Minute As String
C#
[Output]
public string Minute { get; }
C++
[Output]
public property string Minute sealed {
String get();
}
J#
/** @attribute Output() */
/** property */
public string get_Minute();
JScript
public function get Minute() : String

See Also

Time Class
Time Members
MSBuild.Community.Tasks Namespace


Month Property

Time.Month Property
[image]

Gets the month component of the date represented by this instance.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Output>
Public ReadOnly Property Month As String
C#
[Output]
public string Month { get; }
C++
[Output]
public property string Month sealed {
String get();
}
J#
/** @attribute Output() */
/** property */
public string get_Month();
JScript
public function get Month() : String

See Also

Time Class
Time Members
MSBuild.Community.Tasks Namespace


Second Property

Time.Second Property
[image]

Gets the seconds component of the date represented by this instance.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Output>
Public ReadOnly Property Second As String
C#
[Output]
public string Second { get; }
C++
[Output]
public property string Second sealed {
String get();
}
J#
/** @attribute Output() */
/** property */
public string get_Second();
JScript
public function get Second() : String

See Also

Time Class
Time Members
MSBuild.Community.Tasks Namespace


ShortDate Property

Time.ShortDate Property
[image]

Gets the value of this instance to its equivalent short date string representation.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Output>
Public ReadOnly Property ShortDate As String
C#
[Output]
public string ShortDate { get; }
C++
[Output]
public property string ShortDate sealed {
String get();
}
J#
/** @attribute Output() */
/** property */
public string get_ShortDate();
JScript
public function get ShortDate() : String

See Also

Time Class
Time Members
MSBuild.Community.Tasks Namespace


ShortTime Property

Time.ShortTime Property
[image]

Gets the value of this instance to its equivalent short time string representation.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Output>
Public ReadOnly Property ShortTime As String
C#
[Output]
public string ShortTime { get; }
C++
[Output]
public property string ShortTime sealed {
String get();
}
J#
/** @attribute Output() */
/** property */
public string get_ShortTime();
JScript
public function get ShortTime() : String

See Also

Time Class
Time Members
MSBuild.Community.Tasks Namespace


Ticks Property

Time.Ticks Property
[image]

Gets the number of ticks that represent the date and time of this instance.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Output>
Public ReadOnly Property Ticks As String
C#
[Output]
public string Ticks { get; }
C++
[Output]
public property string Ticks sealed {
String get();
}
J#
/** @attribute Output() */
/** property */
public string get_Ticks();
JScript
public function get Ticks() : String

See Also

Time Class
Time Members
MSBuild.Community.Tasks Namespace


TimeOfDay Property

Time.TimeOfDay Property
[image]

Gets the time of day for this instance.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Output>
Public ReadOnly Property TimeOfDay As String
C#
[Output]
public string TimeOfDay { get; }
C++
[Output]
public property string TimeOfDay sealed {
String get();
}
J#
/** @attribute Output() */
/** property */
public string get_TimeOfDay();
JScript
public function get TimeOfDay() : String

See Also

Time Class
Time Members
MSBuild.Community.Tasks Namespace


Year Property

Time.Year Property
[image]

Gets the year component of the date represented by this instance.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Output>
Public ReadOnly Property Year As String
C#
[Output]
public string Year { get; }
C++
[Output]
public property string Year sealed {
String get();
}
J#
/** @attribute Output() */
/** property */
public string get_Year();
JScript
public function get Year() : String

See Also

Time Class
Time Members
MSBuild.Community.Tasks Namespace


Methods

Time Methods
See Also Example
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. When overridden in a derived class, executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

Time Class
Time Members
MSBuild.Community.Tasks Namespace


Execute Method

Time.Execute Method
[image]

When overridden in a derived class, executes the task.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute() As Boolean _
Implements ITask.Execute
C#
public override bool Execute()
C++
public:
virtual bool Execute() override
J#
public override bool Execute()
JScript
public override function Execute() : bool

Return Value

True if the task successfully executed; otherwise, false.

Implements

ITask.Execute

See Also

Time Class
Time Members
MSBuild.Community.Tasks Namespace


Unzip Class

Unzip Class
See Also Example Members
[image]

Unzip a file to a target directory.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class Unzip
Inherits Task
C#
public class Unzip : Task
C++
ref class Unzip : Task
J#
public class Unzip extends Task
JScript
public class Unzip extends Task

Example

Unzip file tasks

Copy Code
            <Unzip ZipFileName="MSBuild.Community.Tasks.zip"
                TargetDirectory="Backup"/>

Inheritance Hierarchy

System.Object
Microsoft.Build.Utilities.Task
MSBuild.Community.Tasks.Unzip

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

Unzip Members
MSBuild.Community.Tasks Namespace


Unzip Members

Unzip Members
See Also Example Constructors Properties Methods
[image]

Unzip a file to a target directory.

The following tables list the members exposed by Unzip.

Public Constructors

 | Name | Description
Public method | Unzip | Initializes a new instance of the T:Unzip class.
Top

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | TargetDirectory | Gets or sets the target directory.
Public property | ZipFileName | Gets or sets the name of the zip file.
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. When overridden in a derived class, executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

Unzip Class
Unzip Members
MSBuild.Community.Tasks Namespace


Unzip Constructor

Unzip Constructor
[image]

Initializes a new instance of the T:Unzip class.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public Unzip()
C++
public:
Unzip() sealed
J#
public Unzip()
JScript
public function Unzip()

See Also

Unzip Class
Unzip Members
MSBuild.Community.Tasks Namespace


Properties

Unzip Properties
See Also Example
[image]

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | TargetDirectory | Gets or sets the target directory.
Public property | ZipFileName | Gets or sets the name of the zip file.
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

See Also

Unzip Class
Unzip Members
MSBuild.Community.Tasks Namespace


TargetDirectory Property

Unzip.TargetDirectory Property
[image]

Gets or sets the target directory.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Required>
Public Property TargetDirectory As String
C#
[Required]
public string TargetDirectory { get; set; }
C++
[Required]
public property string TargetDirectory sealed {
String get();
void set(String value);
}
J#
/** @attribute Required() */
/** property */
public string get_TargetDirectory();

/** property */
public void set_TargetDirectory(string value);
JScript
public function get TargetDirectory() : String

public function set TargetDirectory(value : String);

Property Value

The target directory.

See Also

Unzip Class
Unzip Members
MSBuild.Community.Tasks Namespace


ZipFileName Property

Unzip.ZipFileName Property
[image]

Gets or sets the name of the zip file.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Required>
Public Property ZipFileName As String
C#
[Required]
public string ZipFileName { get; set; }
C++
[Required]
public property string ZipFileName sealed {
String get();
void set(String value);
}
J#
/** @attribute Required() */
/** property */
public string get_ZipFileName();

/** property */
public void set_ZipFileName(string value);
JScript
public function get ZipFileName() : String

public function set ZipFileName(value : String);

Property Value

The name of the zip file.

See Also

Unzip Class
Unzip Members
MSBuild.Community.Tasks Namespace


Methods

Unzip Methods
See Also Example
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. When overridden in a derived class, executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

Unzip Class
Unzip Members
MSBuild.Community.Tasks Namespace


Execute Method

Unzip.Execute Method
[image]

When overridden in a derived class, executes the task.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute() As Boolean _
Implements ITask.Execute
C#
public override bool Execute()
C++
public:
virtual bool Execute() override
J#
public override bool Execute()
JScript
public override function Execute() : bool

Return Value

true if the task successfully executed; otherwise, false.

Implements

ITask.Execute

See Also

Unzip Class
Unzip Members
MSBuild.Community.Tasks Namespace


Version Class

Version Class
See Also Example Members
[image]

Generates version information based on various algorithms

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class Version
Inherits Task
C#
public class Version : Task
C++
ref class Version : Task
J#
public class Version extends Task
JScript
public class Version extends Task

Example

Get version information from file and increment revision.

Copy Code
            <Version VersionFile="number.txt" BuildType="Automatic" RevisionType="Increment">
                <Output TaskParameter="Major" PropertyName="Major" />
                <Output TaskParameter="Minor" PropertyName="Minor" />
                <Output TaskParameter="Build" PropertyName="Build" />
                <Output TaskParameter="Revision" PropertyName="Revision" />
            </Version>
            <Message Text="Version: $(Major).$(Minor).$(Build).$(Revision)"/>
Specify Major and Minor version information and generate Build and Revision.
Copy Code
            <Version BuildType="Automatic" RevisionType="Automatic" Major="1" Minor="3" >
                <Output TaskParameter="Major" PropertyName="Major" />
                <Output TaskParameter="Minor" PropertyName="Minor" />
                <Output TaskParameter="Build" PropertyName="Build" />
                <Output TaskParameter="Revision" PropertyName="Revision" />
            </Version>
            <Message Text="Version: $(Major).$(Minor).$(Build).$(Revision)"/>

Inheritance Hierarchy

System.Object
Microsoft.Build.Utilities.Task
MSBuild.Community.Tasks.Version

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

Version Members
MSBuild.Community.Tasks Namespace


Version Members

Version Members
See Also Example Constructors Properties Methods
[image]

Generates version information based on various algorithms

The following tables list the members exposed by Version.

Public Constructors

 | Name | Description
Public method | Version | Initializes a new instance of the T:Version class.
Top

Public Properties

 | Name | Description
Public property | Build | Gets or sets the build version number.
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | BuildType | Gets or sets the method used to generate a Build number
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Major | Gets or sets the major version number.
Public property | Minor | Gets or sets the minor version number.
Public property | Revision | Gets or sets the revision version number.
Public property | RevisionType | Gets or sets the method used to generate a Revision number
Public property | StartDate | Gets or sets the starting date used to calculate the Build number when BuildType is Automatic.
Public property | VersionFile | Gets or sets the file used to initialize and persist the version.
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. When overridden in a derived class, executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

Version Class
Version Members
MSBuild.Community.Tasks Namespace


Version Constructor

Version Constructor
[image]

Initializes a new instance of the T:Version class.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public Version()
C++
public:
Version() sealed
J#
public Version()
JScript
public function Version()

See Also

Version Class
Version Members
MSBuild.Community.Tasks Namespace


Properties

Version Properties
See Also Example
[image]

Public Properties

 | Name | Description
Public property | Build | Gets or sets the build version number.
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | BuildType | Gets or sets the method used to generate a Build number
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Major | Gets or sets the major version number.
Public property | Minor | Gets or sets the minor version number.
Public property | Revision | Gets or sets the revision version number.
Public property | RevisionType | Gets or sets the method used to generate a Revision number
Public property | StartDate | Gets or sets the starting date used to calculate the Build number when BuildType is Automatic.
Public property | VersionFile | Gets or sets the file used to initialize and persist the version.
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

See Also

Version Class
Version Members
MSBuild.Community.Tasks Namespace


Build Property

Version.Build Property
[image]

Gets or sets the build version number.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Output>
Public Property Build As Integer
C#
[Output]
public int Build { get; set; }
C++
[Output]
public property int Build sealed {
int get();
void set(int value);
}
J#
/** @attribute Output() */
/** property */
public int get_Build();

/** property */
public void set_Build(int value);
JScript
public function get Build() : int

public function set Build(value : int);

Property Value

The build version number.

See Also

Version Class
Version Members
MSBuild.Community.Tasks Namespace
BuildType


BuildType Property

Version.BuildType Property
[image]

Gets or sets the method used to generate a Build number

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property BuildType As String
C#
public string BuildType { get; set; }
C++
public property string BuildType sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_BuildType();

/** property */
public void set_BuildType(string value);
JScript
public function get BuildType() : String

public function set BuildType(value : String);

Remarks

If value is not provided, None is assumed. The Build number is set according to the following table:
BuildType | Description
None | The number is not modified.
Automatic | The number of days since StartDate.
Increment | Increases the previous Build value by 1.

See Also

Version Class
Version Members
MSBuild.Community.Tasks Namespace


Major Property

Version.Major Property
[image]

Gets or sets the major version number.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Output>
Public Property Major As Integer
C#
[Output]
public int Major { get; set; }
C++
[Output]
public property int Major sealed {
int get();
void set(int value);
}
J#
/** @attribute Output() */
/** property */
public int get_Major();

/** property */
public void set_Major(int value);
JScript
public function get Major() : int

public function set Major(value : int);

Property Value

The major version number.

See Also

Version Class
Version Members
MSBuild.Community.Tasks Namespace


Minor Property

Version.Minor Property
[image]

Gets or sets the minor version number.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Output>
Public Property Minor As Integer
C#
[Output]
public int Minor { get; set; }
C++
[Output]
public property int Minor sealed {
int get();
void set(int value);
}
J#
/** @attribute Output() */
/** property */
public int get_Minor();

/** property */
public void set_Minor(int value);
JScript
public function get Minor() : int

public function set Minor(value : int);

Property Value

The minor version number.

See Also

Version Class
Version Members
MSBuild.Community.Tasks Namespace


Revision Property

Version.Revision Property
[image]

Gets or sets the revision version number.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Output>
Public Property Revision As Integer
C#
[Output]
public int Revision { get; set; }
C++
[Output]
public property int Revision sealed {
int get();
void set(int value);
}
J#
/** @attribute Output() */
/** property */
public int get_Revision();

/** property */
public void set_Revision(int value);
JScript
public function get Revision() : int

public function set Revision(value : int);

Property Value

The revision version number.

See Also

Version Class
Version Members
MSBuild.Community.Tasks Namespace
RevisionType


RevisionType Property

Version.RevisionType Property
[image]

Gets or sets the method used to generate a Revision number

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property RevisionType As String
C#
public string RevisionType { get; set; }
C++
public property string RevisionType sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_RevisionType();

/** property */
public void set_RevisionType(string value);
JScript
public function get RevisionType() : String

public function set RevisionType(value : String);

Remarks

If value is not provided, None is assumed. The Revision number is set according to the following table:
RevisionType | Description
None | The number is not modified.
Automatic | A number that starts at 0 at midnight, and constantly increases throughout the day (changing roughly every 1.3 seconds). Guaranteed to be safe for components of the AssemblyVersion attribute.
Increment | Increases the previous Revision value by 1.
BuildIncrement | Increases the previous Revision value by 1 when the value of Build is unchanged. If the value of Build has changed, Revision is reset to zero.

See Also

Version Class
Version Members
MSBuild.Community.Tasks Namespace


StartDate Property

Version.StartDate Property
[image]

Gets or sets the starting date used to calculate the Build number when BuildType is Automatic.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property StartDate As String
C#
public string StartDate { get; set; }
C++
public property string StartDate sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_StartDate();

/** property */
public void set_StartDate(string value);
JScript
public function get StartDate() : String

public function set StartDate(value : String);

Property Value

The starting date for calculation of the build number.

Remarks

This value is only used when the BuildType is Automatic.

This default value is January 1, 2000.

See Also

Version Class
Version Members
MSBuild.Community.Tasks Namespace


VersionFile Property

Version.VersionFile Property
[image]

Gets or sets the file used to initialize and persist the version.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property VersionFile As String
C#
public string VersionFile { get; set; }
C++
public property string VersionFile sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_VersionFile();

/** property */
public void set_VersionFile(string value);
JScript
public function get VersionFile() : String

public function set VersionFile(value : String);

Property Value

The version file.

Remarks

When specified, the task will attempt to load the previous version information from the file. After updating the version, the new value will be saved to the file.

If you do not specify a value for this property, the version will be calculated based on the values passed to the Major, Minor, Build, and Revision properties. The new version will not be persisted.

See Also

Version Class
Version Members
MSBuild.Community.Tasks Namespace


Methods

Version Methods
See Also Example
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. When overridden in a derived class, executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

Version Class
Version Members
MSBuild.Community.Tasks Namespace


Execute Method

Version.Execute Method
[image]

When overridden in a derived class, executes the task.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute() As Boolean _
Implements ITask.Execute
C#
public override bool Execute()
C++
public:
virtual bool Execute() override
J#
public override bool Execute()
JScript
public override function Execute() : bool

Return Value

true if the task successfully executed; otherwise, false.

Implements

ITask.Execute

See Also

Version Class
Version Members
MSBuild.Community.Tasks Namespace


WebDownload Class

WebDownload Class
See Also Example Members
[image]

Downloads a resource with the specified URI to a local file.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class WebDownload
Inherits Task
C#
public class WebDownload : Task
C++
ref class WebDownload : Task
J#
public class WebDownload extends Task
JScript
public class WebDownload extends Task

Example

Download the Microsoft.com home page.

Copy Code
            <WebDownload FileUri="http://www.microsoft.com/default.aspx"
                FileName="microsoft.html" />

Inheritance Hierarchy

System.Object
Microsoft.Build.Utilities.Task
MSBuild.Community.Tasks.WebDownload

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

WebDownload Members
MSBuild.Community.Tasks Namespace


WebDownload Members

WebDownload Members
See Also Example Constructors Properties Methods
[image]

Downloads a resource with the specified URI to a local file.

The following tables list the members exposed by WebDownload.

Public Constructors

 | Name | Description
Public method | WebDownload | Initializes a new instance of the T:WebDownload class.
Top

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | FileName | Gets or sets the name of the local file that is to receive the data.
Public property | FileUri | Gets or sets the URI from which to download data.
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. When overridden in a derived class, executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

WebDownload Class
WebDownload Members
MSBuild.Community.Tasks Namespace


WebDownload Constructor

WebDownload Constructor
[image]

Initializes a new instance of the T:WebDownload class.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public WebDownload()
C++
public:
WebDownload() sealed
J#
public WebDownload()
JScript
public function WebDownload()

See Also

WebDownload Class
WebDownload Members
MSBuild.Community.Tasks Namespace


Properties

WebDownload Properties
See Also Example
[image]

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | FileName | Gets or sets the name of the local file that is to receive the data.
Public property | FileUri | Gets or sets the URI from which to download data.
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

See Also

WebDownload Class
WebDownload Members
MSBuild.Community.Tasks Namespace


FileName Property

WebDownload.FileName Property
[image]

Gets or sets the name of the local file that is to receive the data.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Required>
Public Property FileName As String
C#
[Required]
public string FileName { get; set; }
C++
[Required]
public property string FileName sealed {
String get();
void set(String value);
}
J#
/** @attribute Required() */
/** property */
public string get_FileName();

/** property */
public void set_FileName(string value);
JScript
public function get FileName() : String

public function set FileName(value : String);

Property Value

The name of the file.

See Also

WebDownload Class
WebDownload Members
MSBuild.Community.Tasks Namespace


FileUri Property

WebDownload.FileUri Property
[image]

Gets or sets the URI from which to download data.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Required>
Public Property FileUri As String
C#
[Required]
public string FileUri { get; set; }
C++
[Required]
public property string FileUri sealed {
String get();
void set(String value);
}
J#
/** @attribute Required() */
/** property */
public string get_FileUri();

/** property */
public void set_FileUri(string value);
JScript
public function get FileUri() : String

public function set FileUri(value : String);

Property Value

The file URI.

See Also

WebDownload Class
WebDownload Members
MSBuild.Community.Tasks Namespace


Methods

WebDownload Methods
See Also Example
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. When overridden in a derived class, executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

WebDownload Class
WebDownload Members
MSBuild.Community.Tasks Namespace


Execute Method

WebDownload.Execute Method
[image]

When overridden in a derived class, executes the task.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute() As Boolean _
Implements ITask.Execute
C#
public override bool Execute()
C++
public:
virtual bool Execute() override
J#
public override bool Execute()
JScript
public override function Execute() : bool

Return Value

true if the task successfully executed; otherwise, false.

Implements

ITask.Execute

See Also

WebDownload Class
WebDownload Members
MSBuild.Community.Tasks Namespace


XmlRead Class

XmlRead Class
See Also Example Members
[image]

Reads a value from a XML document using a XPath.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class XmlRead
Inherits Task
C#
public class XmlRead : Task
C++
ref class XmlRead : Task
J#
public class XmlRead extends Task
JScript
public class XmlRead extends Task

Example

Read all targest from a build project.

Copy Code
            <XmlRead Prefix="n"
                Namespace="http://schemas.microsoft.com/developer/msbuild/2003"
                XPath="/n:Project/n:Target/@Name"
                XmlFileName="Subversion.proj">
                <Output TaskParameter="Value" PropertyName="BuildTargets" />
            </XmlRead>
            <Message Text="Build Targets: $(BuildTargets)"/>

Remarks

If the XPath returns multiple nodes, the Value will be a semicolon delimited list of the nodes text.

Inheritance Hierarchy

System.Object
Microsoft.Build.Utilities.Task
MSBuild.Community.Tasks.XmlRead

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

XmlRead Members
MSBuild.Community.Tasks Namespace


XmlRead Members

XmlRead Members
See Also Example Constructors Properties Methods
[image]

Reads a value from a XML document using a XPath.

The following tables list the members exposed by XmlRead.

Public Constructors

 | Name | Description
Public method | XmlRead | Initializes a new instance of the T:XmlRead class.
Top

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Namespace | Gets or sets the default namespace.
Public property | Prefix | Gets or sets the prefix to associate with the namespace being added.
Public property | Value | Gets the value read from file.
Public property | XmlFileName | Gets or sets the name of the XML file.
Public property | XPath | Gets or sets the XPath.
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. When overridden in a derived class, executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

XmlRead Class
XmlRead Members
MSBuild.Community.Tasks Namespace


XmlRead Constructor

XmlRead Constructor
[image]

Initializes a new instance of the T:XmlRead class.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public XmlRead()
C++
public:
XmlRead() sealed
J#
public XmlRead()
JScript
public function XmlRead()

See Also

XmlRead Class
XmlRead Members
MSBuild.Community.Tasks Namespace


Properties

XmlRead Properties
See Also Example
[image]

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Namespace | Gets or sets the default namespace.
Public property | Prefix | Gets or sets the prefix to associate with the namespace being added.
Public property | Value | Gets the value read from file.
Public property | XmlFileName | Gets or sets the name of the XML file.
Public property | XPath | Gets or sets the XPath.
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

See Also

XmlRead Class
XmlRead Members
MSBuild.Community.Tasks Namespace


Namespace Property

XmlRead.Namespace Property
[image]

Gets or sets the default namespace.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Namespace As String
C#
public string Namespace { get; set; }
C++
public property string Namespace sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Namespace();

/** property */
public void set_Namespace(string value);
JScript
public function get Namespace() : String

public function set Namespace(value : String);

Property Value

The namespace.

See Also

XmlRead Class
XmlRead Members
MSBuild.Community.Tasks Namespace


Prefix Property

XmlRead.Prefix Property
[image]

Gets or sets the prefix to associate with the namespace being added.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Prefix As String
C#
public string Prefix { get; set; }
C++
public property string Prefix sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Prefix();

/** property */
public void set_Prefix(string value);
JScript
public function get Prefix() : String

public function set Prefix(value : String);

Property Value

The namespace prefix.

See Also

XmlRead Class
XmlRead Members
MSBuild.Community.Tasks Namespace


Value Property

XmlRead.Value Property
[image]

Gets the value read from file.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Output>
Public ReadOnly Property Value As String
C#
[Output]
public string Value { get; }
C++
[Output]
public property string Value sealed {
String get();
}
J#
/** @attribute Output() */
/** property */
public string get_Value();
JScript
public function get Value() : String

Property Value

The value.

Remarks

If the XPath returns multiple nodes, the values will be semicolon delimited.

See Also

XmlRead Class
XmlRead Members
MSBuild.Community.Tasks Namespace


XmlFileName Property

XmlRead.XmlFileName Property
[image]

Gets or sets the name of the XML file.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Required>
Public Property XmlFileName As String
C#
[Required]
public string XmlFileName { get; set; }
C++
[Required]
public property string XmlFileName sealed {
String get();
void set(String value);
}
J#
/** @attribute Required() */
/** property */
public string get_XmlFileName();

/** property */
public void set_XmlFileName(string value);
JScript
public function get XmlFileName() : String

public function set XmlFileName(value : String);

Property Value

The name of the XML file.

See Also

XmlRead Class
XmlRead Members
MSBuild.Community.Tasks Namespace


XPath Property

XmlRead.XPath Property
[image]

Gets or sets the XPath.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Required>
Public Property XPath As String
C#
[Required]
public string XPath { get; set; }
C++
[Required]
public property string XPath sealed {
String get();
void set(String value);
}
J#
/** @attribute Required() */
/** property */
public string get_XPath();

/** property */
public void set_XPath(string value);
JScript
public function get XPath() : String

public function set XPath(value : String);

Property Value

The XPath.

See Also

XmlRead Class
XmlRead Members
MSBuild.Community.Tasks Namespace


Methods

XmlRead Methods
See Also Example
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. When overridden in a derived class, executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

XmlRead Class
XmlRead Members
MSBuild.Community.Tasks Namespace


Execute Method

XmlRead.Execute Method
[image]

When overridden in a derived class, executes the task.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute() As Boolean _
Implements ITask.Execute
C#
public override bool Execute()
C++
public:
virtual bool Execute() override
J#
public override bool Execute()
JScript
public override function Execute() : bool

Return Value

true if the task successfully executed; otherwise, false.

Implements

ITask.Execute

See Also

XmlRead Class
XmlRead Members
MSBuild.Community.Tasks Namespace


XmlUpdate Class

XmlUpdate Class
See Also Example Members
[image]

Updates a XML document using a XPath.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class XmlUpdate
Inherits Task
C#
public class XmlUpdate : Task
C++
ref class XmlUpdate : Task
J#
public class XmlUpdate extends Task
JScript
public class XmlUpdate extends Task

Example

Update a XML element.

Copy Code
            <XmlUpdate Prefix="n"
                Namespace="http://schemas.microsoft.com/developer/msbuild/2003"
                XPath="/n:Project/n:PropertyGroup/n:TestUpdate"
                XmlFileName="Subversion.proj"
                Value="Test from $(MSBuildProjectFile)"/>

Remarks

The XML node being updated must exist before using the XmlUpdate task.

Inheritance Hierarchy

System.Object
Microsoft.Build.Utilities.Task
MSBuild.Community.Tasks.XmlUpdate

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

XmlUpdate Members
MSBuild.Community.Tasks Namespace


XmlUpdate Members

XmlUpdate Members
See Also Example Constructors Properties Methods
[image]

Updates a XML document using a XPath.

The following tables list the members exposed by XmlUpdate.

Public Constructors

 | Name | Description
Public method | XmlUpdate | Initializes a new instance of the T:XmlUpdate class.
Top

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Namespace | Gets or sets the default namespace.
Public property | Prefix | Gets or sets the prefix to associate with the namespace being added.
Public property | Value | Gets or sets the value to write.
Public property | XmlFileName | Gets or sets the name of the XML file.
Public property | XPath | Gets or sets the XPath.
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. When overridden in a derived class, executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

XmlUpdate Class
XmlUpdate Members
MSBuild.Community.Tasks Namespace


XmlUpdate Constructor

XmlUpdate Constructor
[image]

Initializes a new instance of the T:XmlUpdate class.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public XmlUpdate()
C++
public:
XmlUpdate() sealed
J#
public XmlUpdate()
JScript
public function XmlUpdate()

See Also

XmlUpdate Class
XmlUpdate Members
MSBuild.Community.Tasks Namespace


Properties

XmlUpdate Properties
See Also Example
[image]

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Namespace | Gets or sets the default namespace.
Public property | Prefix | Gets or sets the prefix to associate with the namespace being added.
Public property | Value | Gets or sets the value to write.
Public property | XmlFileName | Gets or sets the name of the XML file.
Public property | XPath | Gets or sets the XPath.
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

See Also

XmlUpdate Class
XmlUpdate Members
MSBuild.Community.Tasks Namespace


Namespace Property

XmlUpdate.Namespace Property
[image]

Gets or sets the default namespace.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Namespace As String
C#
public string Namespace { get; set; }
C++
public property string Namespace sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Namespace();

/** property */
public void set_Namespace(string value);
JScript
public function get Namespace() : String

public function set Namespace(value : String);

Property Value

The namespace.

See Also

XmlUpdate Class
XmlUpdate Members
MSBuild.Community.Tasks Namespace


Prefix Property

XmlUpdate.Prefix Property
[image]

Gets or sets the prefix to associate with the namespace being added.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Prefix As String
C#
public string Prefix { get; set; }
C++
public property string Prefix sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Prefix();

/** property */
public void set_Prefix(string value);
JScript
public function get Prefix() : String

public function set Prefix(value : String);

Property Value

The namespace prefix.

See Also

XmlUpdate Class
XmlUpdate Members
MSBuild.Community.Tasks Namespace


Value Property

XmlUpdate.Value Property
[image]

Gets or sets the value to write.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Required>
Public Property Value As String
C#
[Required]
public string Value { get; set; }
C++
[Required]
public property string Value sealed {
String get();
void set(String value);
}
J#
/** @attribute Required() */
/** property */
public string get_Value();

/** property */
public void set_Value(string value);
JScript
public function get Value() : String

public function set Value(value : String);

Property Value

The value.

See Also

XmlUpdate Class
XmlUpdate Members
MSBuild.Community.Tasks Namespace


XmlFileName Property

XmlUpdate.XmlFileName Property
[image]

Gets or sets the name of the XML file.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Required>
Public Property XmlFileName As String
C#
[Required]
public string XmlFileName { get; set; }
C++
[Required]
public property string XmlFileName sealed {
String get();
void set(String value);
}
J#
/** @attribute Required() */
/** property */
public string get_XmlFileName();

/** property */
public void set_XmlFileName(string value);
JScript
public function get XmlFileName() : String

public function set XmlFileName(value : String);

Property Value

The name of the XML file.

See Also

XmlUpdate Class
XmlUpdate Members
MSBuild.Community.Tasks Namespace


XPath Property

XmlUpdate.XPath Property
[image]

Gets or sets the XPath.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Required>
Public Property XPath As String
C#
[Required]
public string XPath { get; set; }
C++
[Required]
public property string XPath sealed {
String get();
void set(String value);
}
J#
/** @attribute Required() */
/** property */
public string get_XPath();

/** property */
public void set_XPath(string value);
JScript
public function get XPath() : String

public function set XPath(value : String);

Property Value

The XPath.

See Also

XmlUpdate Class
XmlUpdate Members
MSBuild.Community.Tasks Namespace


Methods

XmlUpdate Methods
See Also Example
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. When overridden in a derived class, executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

XmlUpdate Class
XmlUpdate Members
MSBuild.Community.Tasks Namespace


Execute Method

XmlUpdate.Execute Method
[image]

When overridden in a derived class, executes the task.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute() As Boolean _
Implements ITask.Execute
C#
public override bool Execute()
C++
public:
virtual bool Execute() override
J#
public override bool Execute()
JScript
public override function Execute() : bool

Return Value

true if the task successfully executed; otherwise, false.

Implements

ITask.Execute

See Also

XmlUpdate Class
XmlUpdate Members
MSBuild.Community.Tasks Namespace


Xslt Class

Xslt Class
See Also Example Members
[image]

A task to merge and transform a set of xml files.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class Xslt
Inherits Task
C#
public class Xslt : Task
C++
ref class Xslt : Task
J#
public class Xslt extends Task
JScript
public class Xslt extends Task

Example

This example for generating a report from a set of NUnit xml results:

Copy Code
<ItemGroup>
    <nunitReportXslFile Include="$(MSBuildCommunityTasksPath)\$(nunitReportXsl)">
        <project>$(project)</project>
        <configuration>$(configuration)</configuration>
        <msbuildFilename>$(MSBuildProjectFullPath)</msbuildFilename>
        <msbuildBinpath>$(MSBuildBinPath)</msbuildBinpath>
        <xslFile>$(MSBuildCommunityTasksPath)\$(nunitReportXsl)</xslFile>
    </nunitReportXslFile>
</ItemGroup>

<Target Name="test-report" >
    <Xslt Inputs="@(nunitFiles)"
        RootTag="mergedroot"
        Xsl="@(nunitReportXslFile)"
        Output="$(testDir)\TestReport.html" />
</Target>
This examples shows all available task attributes:
Copy Code
<Time Format="yyyyMMddHHmmss">
    <Output TaskParameter="LocalTimestamp" PropertyName="buildDate" />
</Time>

<Xslt
     Inputs="@(xmlfiles)"
     RootTag="mergedroot"
     RootAttributes="foo=bar;date=$(buildDate)"
     Xsl="transformation.xsl"
     Output="report.html"
/>

Remarks

The xml files of parameter Inputs are merged into one xml document, wrapped with a root tag RootTag

If only one input file is provided, merging and wrapping can be omitted by setting RootTag to an empty string.

The root tag can be given any number of attributes by providing a list of semicolon-delimited name/value pairs to parameter RootAttributes. For example:

Copy Code
RootAttributes="foo=bar;date=$(buildDate)"

Parameter RootAttributes defaults to one attribute with a name specified by CREATED_ATTRIBUTE, and a local time stamp as value. To suppress the default value, an empty parameter

Copy Code
RootAttributes=""
must be specified explicitely.

The xsl transformation file specified by parameter Xsl is applied on the input.

The ITaskItemXsl can be given any number of metadata, which will be handed to the xsl transformation as parameters.

The output is written to the file specified by parameter Output.

Inheritance Hierarchy

System.Object
Microsoft.Build.Utilities.Task
MSBuild.Community.Tasks.Xslt

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

Xslt Members
MSBuild.Community.Tasks Namespace


Xslt Members

Xslt Members
See Also Example Constructors Fields Properties Methods
[image]

A task to merge and transform a set of xml files.

The following tables list the members exposed by Xslt.

Public Constructors

 | Name | Description
Public method | Xslt | Initializes a new instance of the Xslt class.
Top

Public Fields

Name | Description
CREATED_ATTRIBUTE | The name of the default attribute of the RootTag. The value is "created", and the attribute will contain a local time stamp. This field is constant and read-only.
Top

Public Properties

Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Inputs | Gets or sets the xml input files.
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Output | Gets or sets the path of the output file.
Public property RootAttributes Gets or sets the list of semicolon-delimited name/value pairs of the RootTag. For example:
Copy Code
RootAttributes="foo=bar;date=$(buildDate)"
Public property | RootTag | Gets or sets the xml tag name of the root tag wrapped around the merged xml input files.
Public property | Xsl | Gets or sets the path of the xsl transformation file to apply.
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. When overridden in a derived class, executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

Xslt Class
Xslt Members
MSBuild.Community.Tasks Namespace


Xslt Constructor

Xslt Constructor
[image]

Initializes a new instance of the Xslt class.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public Xslt()
C++
public:
Xslt() sealed
J#
public Xslt()
JScript
public function Xslt()

See Also

Xslt Class
Xslt Members
MSBuild.Community.Tasks Namespace


Fields

Xslt Fields
See Also Example
[image]

Public Fields

Name | Description
CREATED_ATTRIBUTE | The name of the default attribute of the RootTag. The value is "created", and the attribute will contain a local time stamp. This field is constant and read-only.
Top

See Also

Xslt Class
Xslt Members
MSBuild.Community.Tasks Namespace


CREATED_ATTRIBUTE Field

Xslt.CREATED_ATTRIBUTE Field
[image]

The name of the default attribute of the RootTag. The value is "created", and the attribute will contain a local time stamp. This field is constant and read-only.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public const CREATED_ATTRIBUTE As String = "created"
C#
public const string CREATED_ATTRIBUTE = "created";
C++
public:
const String CREATED_ATTRIBUTE = L"created";
J#
public const string CREATED_ATTRIBUTE = "created"
JScript
public const CREATED_ATTRIBUTE : String = "created";

See Also

Xslt Class
Xslt Members
MSBuild.Community.Tasks Namespace


Properties

Xslt Properties
See Also Example
[image]

Public Properties

Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Inputs | Gets or sets the xml input files.
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Output | Gets or sets the path of the output file.
Public property RootAttributes Gets or sets the list of semicolon-delimited name/value pairs of the RootTag. For example:
Copy Code
RootAttributes="foo=bar;date=$(buildDate)"
Public property | RootTag | Gets or sets the xml tag name of the root tag wrapped around the merged xml input files.
Public property | Xsl | Gets or sets the path of the xsl transformation file to apply.
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

See Also

Xslt Class
Xslt Members
MSBuild.Community.Tasks Namespace


Inputs Property

Xslt.Inputs Property
[image]

Gets or sets the xml input files.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Required>
Public Property Inputs As ITaskItem[]
C#
[Required]
public ITaskItem[] Inputs { get; set; }
C++
[Required]
public property ITaskItem[] Inputs sealed {
array<ITaskItem>^ get();
void set(array<ITaskItem>^ value);
}
J#
/** @attribute Required() */
/** property */
public ITaskItem[] get_Inputs();

/** property */
public void set_Inputs(ITaskItem[] value);
JScript
public function get Inputs() : ITaskItem[]

public function set Inputs(value : ITaskItem[]);

See Also

Xslt Class
Xslt Members
MSBuild.Community.Tasks Namespace


Output Property

Xslt.Output Property
[image]

Gets or sets the path of the output file.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Required>
Public Property Output As String
C#
[Required]
public string Output { get; set; }
C++
[Required]
public property string Output sealed {
String get();
void set(String value);
}
J#
/** @attribute Required() */
/** property */
public string get_Output();

/** property */
public void set_Output(string value);
JScript
public function get Output() : String

public function set Output(value : String);

See Also

Xslt Class
Xslt Members
MSBuild.Community.Tasks Namespace


RootAttributes Property

Xslt.RootAttributes Property
[image]

Gets or sets the list of semicolon-delimited name/value pairs of the RootTag. For example:

Copy Code
RootAttributes="foo=bar;date=$(buildDate)"

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property RootAttributes As String
C#
public string RootAttributes { get; set; }
C++
public property string RootAttributes sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_RootAttributes();

/** property */
public void set_RootAttributes(string value);
JScript
public function get RootAttributes() : String

public function set RootAttributes(value : String);

See Also

Xslt Class
Xslt Members
MSBuild.Community.Tasks Namespace


RootTag Property

Xslt.RootTag Property
[image]

Gets or sets the xml tag name of the root tag wrapped around the merged xml input files.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property RootTag As String
C#
public string RootTag { get; set; }
C++
public property string RootTag sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_RootTag();

/** property */
public void set_RootTag(string value);
JScript
public function get RootTag() : String

public function set RootTag(value : String);

See Also

Xslt Class
Xslt Members
MSBuild.Community.Tasks Namespace


Xsl Property

Xslt.Xsl Property
[image]

Gets or sets the path of the xsl transformation file to apply.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Required>
Public Property Xsl As ITaskItem
C#
[Required]
public ITaskItem Xsl { get; set; }
C++
[Required]
public property ITaskItem Xsl sealed {
ITaskItem get();
void set(ITaskItem value);
}
J#
/** @attribute Required() */
/** property */
public ITaskItem get_Xsl();

/** property */
public void set_Xsl(ITaskItem value);
JScript
public function get Xsl() : ITaskItem

public function set Xsl(value : ITaskItem);

Remarks

The property can be given any number of metadata, which will be handed to the xsl transformation as parameters.

See Also

Xslt Class
Xslt Members
MSBuild.Community.Tasks Namespace


Methods

Xslt Methods
See Also Example
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. When overridden in a derived class, executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

Xslt Class
Xslt Members
MSBuild.Community.Tasks Namespace


Execute Method

Xslt.Execute Method
[image]

When overridden in a derived class, executes the task.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute() As Boolean _
Implements ITask.Execute
C#
public override bool Execute()
C++
public:
virtual bool Execute() override
J#
public override bool Execute()
JScript
public override function Execute() : bool

Return Value

Returns true if the task successfully executed; otherwise, false.

Implements

ITask.Execute

See Also

Xslt Class
Xslt Members
MSBuild.Community.Tasks Namespace


Zip Class

Zip Class
See Also Example Members
[image]

Create a zip file with the files specified.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class Zip
Inherits Task
C#
public class Zip : Task
C++
ref class Zip : Task
J#
public class Zip extends Task
JScript
public class Zip extends Task

Example

Create a zip file

Copy Code
            <ItemGroup>
                <ZipFiles Include="**\*.*" Exclude="*.zip" />
            </ItemGroup>
            <Target Name="Zip">
                <Zip Files="@(ZipFiles)"
                    ZipFileName="MSBuild.Community.Tasks.zip" />
            </Target>
Create a zip file using a working directory.
Copy Code
            <ItemGroup>
                <RepoFiles Include="D:\svn\repo\**\*.*" />
            </ItemGroup>
            <Target Name="Zip">
                <Zip Files="@(RepoFiles)"
                    WorkingDirectory="D:\svn\repo"
                    ZipFileName="D:\svn\repo.zip" />
            </Target>

Inheritance Hierarchy

System.Object
Microsoft.Build.Utilities.Task
MSBuild.Community.Tasks.Zip

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

Zip Members
MSBuild.Community.Tasks Namespace


Zip Members

Zip Members
See Also Example Constructors Properties Methods
[image]

Create a zip file with the files specified.

The following tables list the members exposed by Zip.

Public Constructors

 | Name | Description
Public method | Zip | Initializes a new instance of the T:Zip class.
Top

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | Comment | Gets or sets the comment.
Public property | Files | Gets or sets the files to zip.
Public property | Flatten | Gets or sets a value indicating whether this T:Zip is flatten.
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | WorkingDirectory | Gets or sets the working directory for the zip file.
Public property | ZipFileName | Gets or sets the name of the zip file.
Public property | ZipLevel | Gets or sets the zip level.
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. When overridden in a derived class, executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

Zip Class
Zip Members
MSBuild.Community.Tasks Namespace


Zip Constructor

Zip Constructor
[image]

Initializes a new instance of the T:Zip class.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public Zip()
C++
public:
Zip() sealed
J#
public Zip()
JScript
public function Zip()

See Also

Zip Class
Zip Members
MSBuild.Community.Tasks Namespace


Properties

Zip Properties
See Also Example
[image]

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | Comment | Gets or sets the comment.
Public property | Files | Gets or sets the files to zip.
Public property | Flatten | Gets or sets a value indicating whether this T:Zip is flatten.
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | WorkingDirectory | Gets or sets the working directory for the zip file.
Public property | ZipFileName | Gets or sets the name of the zip file.
Public property | ZipLevel | Gets or sets the zip level.
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

See Also

Zip Class
Zip Members
MSBuild.Community.Tasks Namespace


Comment Property

Zip.Comment Property
[image]

Gets or sets the comment.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Comment As String
C#
public string Comment { get; set; }
C++
public property string Comment sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Comment();

/** property */
public void set_Comment(string value);
JScript
public function get Comment() : String

public function set Comment(value : String);

Property Value

The comment.

See Also

Zip Class
Zip Members
MSBuild.Community.Tasks Namespace


Files Property

Zip.Files Property
[image]

Gets or sets the files to zip.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Required>
Public Property Files As ITaskItem[]
C#
[Required]
public ITaskItem[] Files { get; set; }
C++
[Required]
public property ITaskItem[] Files sealed {
array<ITaskItem>^ get();
void set(array<ITaskItem>^ value);
}
J#
/** @attribute Required() */
/** property */
public ITaskItem[] get_Files();

/** property */
public void set_Files(ITaskItem[] value);
JScript
public function get Files() : ITaskItem[]

public function set Files(value : ITaskItem[]);

Property Value

The files to zip.

See Also

Zip Class
Zip Members
MSBuild.Community.Tasks Namespace


Flatten Property

Zip.Flatten Property
[image]

Gets or sets a value indicating whether this T:Zip is flatten.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Flatten As Boolean
C#
public bool Flatten { get; set; }
C++
public property bool Flatten sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_Flatten();

/** property */
public void set_Flatten(bool value);
JScript
public function get Flatten() : bool

public function set Flatten(value : bool);

Property Value

true if flatten; otherwise, false.

Remarks

Flattening the zip means that all directories will be removed and the files will be place at the root of the zip file

See Also

Zip Class
Zip Members
MSBuild.Community.Tasks Namespace


WorkingDirectory Property

Zip.WorkingDirectory Property
[image]

Gets or sets the working directory for the zip file.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property WorkingDirectory As String
C#
public string WorkingDirectory { get; set; }
C++
public property string WorkingDirectory sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_WorkingDirectory();

/** property */
public void set_WorkingDirectory(string value);
JScript
public function get WorkingDirectory() : String

public function set WorkingDirectory(value : String);

Property Value

The working directory.

Remarks

The working directory is the base of the zip file. All files will be made relative from the working directory.

See Also

Zip Class
Zip Members
MSBuild.Community.Tasks Namespace


ZipFileName Property

Zip.ZipFileName Property
[image]

Gets or sets the name of the zip file.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Required>
Public Property ZipFileName As String
C#
[Required]
public string ZipFileName { get; set; }
C++
[Required]
public property string ZipFileName sealed {
String get();
void set(String value);
}
J#
/** @attribute Required() */
/** property */
public string get_ZipFileName();

/** property */
public void set_ZipFileName(string value);
JScript
public function get ZipFileName() : String

public function set ZipFileName(value : String);

Property Value

The name of the zip file.

See Also

Zip Class
Zip Members
MSBuild.Community.Tasks Namespace


ZipLevel Property

Zip.ZipLevel Property
[image]

Gets or sets the zip level.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property ZipLevel As Integer
C#
public int ZipLevel { get; set; }
C++
public property int ZipLevel sealed {
int get();
void set(int value);
}
J#
/** property */
public int get_ZipLevel();

/** property */
public void set_ZipLevel(int value);
JScript
public function get ZipLevel() : int

public function set ZipLevel(value : int);

Property Value

The zip level.

Remarks

0 - store only to 9 - means best compression

See Also

Zip Class
Zip Members
MSBuild.Community.Tasks Namespace


Methods

Zip Methods
See Also Example
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. When overridden in a derived class, executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

Zip Class
Zip Members
MSBuild.Community.Tasks Namespace


Execute Method

Zip.Execute Method
[image]

When overridden in a derived class, executes the task.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute() As Boolean _
Implements ITask.Execute
C#
public override bool Execute()
C++
public:
virtual bool Execute() override
J#
public override bool Execute()
JScript
public override function Execute() : bool

Return Value

true if the task successfully executed; otherwise, false.

Implements

ITask.Execute

See Also

Zip Class
Zip Members
MSBuild.Community.Tasks Namespace


MSBuild.Community.Tasks.AspNet

MSBuild.Community.Tasks.AspNet Namespace
See Also Hierarchy

Classes

 | Class | Description
Public class | InstallAspNet | Installs and register script mappings for ASP.NET


InstallAspNet Class

InstallAspNet Class
See Also Example Members
[image]

Installs and register script mappings for ASP.NET

Namespace: MSBuild.Community.Tasks.AspNet
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class InstallAspNet
Inherits ToolTask
C#
public class InstallAspNet : ToolTask
C++
ref class InstallAspNet : ToolTask
J#
public class InstallAspNet extends ToolTask
JScript
public class InstallAspNet extends ToolTask

Example

Install the latest version of ASP.NET on the server:

Copy Code
 <InstallAspNet />
Install the latest version of ASP.NET on the server, but do not update script maps:
Copy Code
 <InstallAspNet ApplyScriptMaps="Never" />
Install the script maps for ASP.NET 2.0 on a web directory on the default website:
Copy Code
 <InstallAspNet Path="MyApplication" Version="Version20" />
Install the script maps for ASP.NET 1.1 on a web directory on a non-default website:
Copy Code
 <InstallAspNet Path="MyApplication" Version="W3SVC/3/Root/Version11" />
Install client side script only for the latest version:
Copy Code
 <InstallAspNet ClientScriptsOnly="True" />

Remarks

Uses the aspnet_regiis.exe tool included with the .NET Framework.

Inheritance Hierarchy

System.Object
Microsoft.Build.Utilities.Task
Microsoft.Build.Utilities.ToolTask
MSBuild.Community.Tasks.AspNet.InstallAspNet

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

InstallAspNet Members
MSBuild.Community.Tasks.AspNet Namespace


InstallAspNet Members

InstallAspNet Members
See Also Example Constructors Properties Methods
[image]

Installs and register script mappings for ASP.NET

The following tables list the members exposed by InstallAspNet.

Public Constructors

 | Name | Description
Public method | InstallAspNet | Initializes a new instance of the InstallAspNet class.
Top

Public Properties

 | Name | Description
Public property | ApplyScriptMaps | The method used to determine if ASP.NET script mappings should be applied
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | ClientScriptsOnly | When true, the aspnet_client scripts will be installed. No script mappings will be updated.
Public property | ExitCode | Gets the returned exit code of the executable file. (inherited from ToolTask)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Path | The web application that should have its script maps updated.
Public property | Recursive | When true, script maps are applied recursively under Path.
Public property | Timeout | Gets or sets the amount of time after which the task executable is terminated. (inherited from ToolTask)
Public property | ToolPath | Gets or sets the path of the executable file to run. (inherited from ToolTask)
Public property | Version | The version of ASP.NET to install
Top

Protected Properties

 | Name | Description
Family property | EnvironmentOverride | Gets the override value of the PATH environment variable. (inherited from ToolTask)
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | ResponseFileEncoding | Gets the Encoding of the response file. (inherited from ToolTask)
Family property | StandardErrorEncoding | Gets the Encoding of the standard error stream of the task. (inherited from ToolTask)
Family property | StandardErrorLoggingImportance | Gets the MessageImportance with which to log errors. (inherited from ToolTask)
Family property | StandardOutputEncoding | Gets the Encoding of the standard output stream of the task. (inherited from ToolTask)
Family property | StandardOutputLoggingImportance | Gets the MessageImportance with which to log errors. (inherited from ToolTask)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Family property | ToolName | Overidden. Gets the name of the executable file to run.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. When overridden in a derived class, executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsValidPropertyCombinations | Determines if the current property values can be used together
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | CallHostObjectToExecute | Calls the host object to perform the work of the task. (inherited from ToolTask)
Family method | ExecuteTool | Creates a temporoary response (.rsp) file and runs the executable file. (inherited from ToolTask)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GenerateCommandLineCommands | Overidden. Returns a string value containing the command line arguments to pass directly to the executable file.
Family method | GenerateFullPathToTool | Overidden. Returns the fully qualified path to the executable file.
Family method | GenerateResponseFileCommands | Returns a string value containing the command line arguments to add to the response (.rsp) file before running the executable file. (inherited from ToolTask)
Family method | GetResponseFileSwitch | Returns the command line switch used by the executable file to specifiy a response (.rsp) file. (inherited from ToolTask)
Family method | GetWorkingDirectory | Returns the directory in which to run the executable file. (inherited from ToolTask)
Family method | HandleTaskExecutionErrors | Handles execution errors raised by the executable file. (inherited from ToolTask)
Family method | InitializeHostObject | Initializes the host object of the task. (inherited from ToolTask)
Family method | LogEventsFromTextOutput | (inherited from ToolTask)
Family method | LogPathToTool | Logs the tool name and path to all registered loggers. (inherited from ToolTask)
Family method | LogToolCommand | Logs the starting point of the run to all registered loggers. (inherited from ToolTask)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | SkipTaskExecution | Indicates whether task execution should be skipped. (inherited from ToolTask)
Family method | ValidateParameters | Indicates whether all task paratmeters are valid. (inherited from ToolTask)
Top

See Also

InstallAspNet Class
InstallAspNet Members
MSBuild.Community.Tasks.AspNet Namespace


InstallAspNet Constructor

InstallAspNet Constructor
[image]

Initializes a new instance of the InstallAspNet class.

Namespace: MSBuild.Community.Tasks.AspNet
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public InstallAspNet()
C++
public:
InstallAspNet() sealed
J#
public InstallAspNet()
JScript
public function InstallAspNet()

See Also

InstallAspNet Class
InstallAspNet Members
MSBuild.Community.Tasks.AspNet Namespace


Properties

InstallAspNet Properties
See Also Example
[image]

Public Properties

 | Name | Description
Public property | ApplyScriptMaps | The method used to determine if ASP.NET script mappings should be applied
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | ClientScriptsOnly | When true, the aspnet_client scripts will be installed. No script mappings will be updated.
Public property | ExitCode | Gets the returned exit code of the executable file. (inherited from ToolTask)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Path | The web application that should have its script maps updated.
Public property | Recursive | When true, script maps are applied recursively under Path.
Public property | Timeout | Gets or sets the amount of time after which the task executable is terminated. (inherited from ToolTask)
Public property | ToolPath | Gets or sets the path of the executable file to run. (inherited from ToolTask)
Public property | Version | The version of ASP.NET to install
Top

Protected Properties

 | Name | Description
Family property | EnvironmentOverride | Gets the override value of the PATH environment variable. (inherited from ToolTask)
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | ResponseFileEncoding | Gets the Encoding of the response file. (inherited from ToolTask)
Family property | StandardErrorEncoding | Gets the Encoding of the standard error stream of the task. (inherited from ToolTask)
Family property | StandardErrorLoggingImportance | Gets the MessageImportance with which to log errors. (inherited from ToolTask)
Family property | StandardOutputEncoding | Gets the Encoding of the standard output stream of the task. (inherited from ToolTask)
Family property | StandardOutputLoggingImportance | Gets the MessageImportance with which to log errors. (inherited from ToolTask)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Family property | ToolName | Overidden. Gets the name of the executable file to run.
Top

See Also

InstallAspNet Class
InstallAspNet Members
MSBuild.Community.Tasks.AspNet Namespace


ApplyScriptMaps Property

InstallAspNet.ApplyScriptMaps Property
[image]

The method used to determine if ASP.NET script mappings should be applied

Namespace: MSBuild.Community.Tasks.AspNet
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property ApplyScriptMaps As String
C#
public string ApplyScriptMaps { get; set; }
C++
public property string ApplyScriptMaps sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_ApplyScriptMaps();

/** property */
public void set_ApplyScriptMaps(string value);
JScript
public function get ApplyScriptMaps() : String

public function set ApplyScriptMaps(value : String);

Remarks

The default behavior is to register script mappings on all sites except those with a newer version of ASP.NET.
Value
Never | Register ASP.NET on the computer without updating any script mappings.
IfNoneExist | Register script mappings only on for sites that do not have any existing ASP.NET script mappings (not available for ASP.NET v1.1)
UnlessNewerExist | Register script mappings on all sites except those with a newer version of ASP.NET.
Always | Register script mappings on all sites, even if they already have a newer version of ASP.NET.

See Also

InstallAspNet Class
InstallAspNet Members
MSBuild.Community.Tasks.AspNet Namespace


ClientScriptsOnly Property

InstallAspNet.ClientScriptsOnly Property
[image]

When true, the aspnet_client scripts will be installed. No script mappings will be updated.

Namespace: MSBuild.Community.Tasks.AspNet
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property ClientScriptsOnly As Boolean
C#
public bool ClientScriptsOnly { get; set; }
C++
public property bool ClientScriptsOnly sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_ClientScriptsOnly();

/** property */
public void set_ClientScriptsOnly(bool value);
JScript
public function get ClientScriptsOnly() : bool

public function set ClientScriptsOnly(value : bool);

Remarks

This cannot be true if a value for Path or ApplyScriptMaps has been specified.

See Also

InstallAspNet Class
InstallAspNet Members
MSBuild.Community.Tasks.AspNet Namespace


Path Property

InstallAspNet.Path Property
[image]

The web application that should have its script maps updated.

Namespace: MSBuild.Community.Tasks.AspNet
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Path As String
C#
public string Path { get; set; }
C++
public property string Path sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Path();

/** property */
public void set_Path(string value);
JScript
public function get Path() : String

public function set Path(value : String);

Remarks

The path must be of the form W3SVC/[instance]/Root/[webdirectory], for example W3SVC/1/Root/SampleApp1. As a shortcut, you can specify just the web directory name, if the web directory is installed in the default website instance (W3SVC/1/Root).

You should not specify a value for ApplyScriptMaps when specifying a path.

See Also

InstallAspNet Class
InstallAspNet Members
MSBuild.Community.Tasks.AspNet Namespace


Recursive Property

InstallAspNet.Recursive Property
[image]

When true, script maps are applied recursively under Path.

Namespace: MSBuild.Community.Tasks.AspNet
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Recursive As Boolean
C#
public bool Recursive { get; set; }
C++
public property bool Recursive sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_Recursive();

/** property */
public void set_Recursive(bool value);
JScript
public function get Recursive() : bool

public function set Recursive(value : bool);

Remarks

This property is only valid when specifying a value for Path. It is true by default.

See Also

InstallAspNet Class
InstallAspNet Members
MSBuild.Community.Tasks.AspNet Namespace


ToolName Property

InstallAspNet.ToolName Property
[image]

Gets the name of the executable file to run.

Namespace: MSBuild.Community.Tasks.AspNet
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property ToolName As String
C#
protected override string ToolName { get; }
C++
protected override property string ToolName override {
String get();
}
J#
/** property */
protected string get_ToolName();
JScript
protected function get ToolName() : String

Property Value

The name of the executable file to run.

See Also

InstallAspNet Class
InstallAspNet Members
MSBuild.Community.Tasks.AspNet Namespace


Version Property

InstallAspNet.Version Property
[image]

The version of ASP.NET to install

Namespace: MSBuild.Community.Tasks.AspNet
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Version As String
C#
public string Version { get; set; }
C++
public property string Version sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Version();

/** property */
public void set_Version(string value);
JScript
public function get Version() : String

public function set Version(value : String);

Remarks

The default behavior is to use the latest version of ASP.NET available on the computer.
Version
Version11 | ASP.NET v1.1
Version20 | ASP.NET v2.0
VersionLatest | The latest version of ASP.NET available

See Also

InstallAspNet Class
InstallAspNet Members
MSBuild.Community.Tasks.AspNet Namespace


Methods

InstallAspNet Methods
See Also Example
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. When overridden in a derived class, executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsValidPropertyCombinations | Determines if the current property values can be used together
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | CallHostObjectToExecute | Calls the host object to perform the work of the task. (inherited from ToolTask)
Family method | ExecuteTool | Creates a temporoary response (.rsp) file and runs the executable file. (inherited from ToolTask)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GenerateCommandLineCommands | Overidden. Returns a string value containing the command line arguments to pass directly to the executable file.
Family method | GenerateFullPathToTool | Overidden. Returns the fully qualified path to the executable file.
Family method | GenerateResponseFileCommands | Returns a string value containing the command line arguments to add to the response (.rsp) file before running the executable file. (inherited from ToolTask)
Family method | GetResponseFileSwitch | Returns the command line switch used by the executable file to specifiy a response (.rsp) file. (inherited from ToolTask)
Family method | GetWorkingDirectory | Returns the directory in which to run the executable file. (inherited from ToolTask)
Family method | HandleTaskExecutionErrors | Handles execution errors raised by the executable file. (inherited from ToolTask)
Family method | InitializeHostObject | Initializes the host object of the task. (inherited from ToolTask)
Family method | LogEventsFromTextOutput | (inherited from ToolTask)
Family method | LogPathToTool | Logs the tool name and path to all registered loggers. (inherited from ToolTask)
Family method | LogToolCommand | Logs the starting point of the run to all registered loggers. (inherited from ToolTask)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | SkipTaskExecution | Indicates whether task execution should be skipped. (inherited from ToolTask)
Family method | ValidateParameters | Indicates whether all task paratmeters are valid. (inherited from ToolTask)
Top

See Also

InstallAspNet Class
InstallAspNet Members
MSBuild.Community.Tasks.AspNet Namespace


Execute Method

InstallAspNet.Execute Method
[image]

When overridden in a derived class, executes the task.

Namespace: MSBuild.Community.Tasks.AspNet
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute() As Boolean _
Implements ITask.Execute
C#
public override bool Execute()
C++
public:
virtual bool Execute() override
J#
public override bool Execute()
JScript
public override function Execute() : bool

Return Value

True if the task successfully executed; otherwise, false.

Implements

ITask.Execute

See Also

InstallAspNet Class
InstallAspNet Members
MSBuild.Community.Tasks.AspNet Namespace


GenerateCommandLineCommands Method

InstallAspNet.GenerateCommandLineCommands Method
[image]

Returns a string value containing the command line arguments to pass directly to the executable file.

Namespace: MSBuild.Community.Tasks.AspNet
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GenerateCommandLineCommands() As String
C#
protected override string GenerateCommandLineCommands()
C++
protected:
virtual String GenerateCommandLineCommands() override
J#
protected override string GenerateCommandLineCommands()
JScript
protected override function GenerateCommandLineCommands() : String

Return Value

A string value containing the command line arguments to pass directly to the executable file.

See Also

InstallAspNet Class
InstallAspNet Members
MSBuild.Community.Tasks.AspNet Namespace


GenerateFullPathToTool Method

InstallAspNet.GenerateFullPathToTool Method
[image]

Returns the fully qualified path to the executable file.

Namespace: MSBuild.Community.Tasks.AspNet
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GenerateFullPathToTool() As String
C#
protected override string GenerateFullPathToTool()
C++
protected:
virtual String GenerateFullPathToTool() override
J#
protected override string GenerateFullPathToTool()
JScript
protected override function GenerateFullPathToTool() : String

Return Value

The fully qualified path to the executable file.

See Also

InstallAspNet Class
InstallAspNet Members
MSBuild.Community.Tasks.AspNet Namespace


IsValidPropertyCombinations Method

InstallAspNet.IsValidPropertyCombinations Method
[image]

Determines if the current property values can be used together

Namespace: MSBuild.Community.Tasks.AspNet
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Function IsValidPropertyCombinations() As Boolean
C#
public bool IsValidPropertyCombinations()
C++
public:
bool IsValidPropertyCombinations() sealed
J#
public bool IsValidPropertyCombinations()
JScript
public function IsValidPropertyCombinations() : bool

Return Value

true when properties can be used together.

See Also

InstallAspNet Class
InstallAspNet Members
MSBuild.Community.Tasks.AspNet Namespace


MSBuild.Community.Tasks.IIS

MSBuild.Community.Tasks.IIS Namespace
See Also Hierarchy

Classes

 | Class | Description
Public class | AppPoolController | Allows control for an application pool on a local or remote machine with IIS installed. The default is to control the application pool on the local machine. If connecting to a remote machine, you can specify the Username and Password for the task to run under.
Public class | AppPoolCreate | Creates a new application pool on a local or remote machine with IIS installed. The default is to create the new application pool on the local machine. If connecting to a remote machine, you can specify the Username and Password for the task to run under.
Public class | AppPoolDelete | Deletes an existing application pool on a local or remote machine with IIS installed. The default is to delete an existing application pool on the local machine. If connecting to a remote machine, you can specify the Username and Password for the task to run under.
Public class | WebBase | Base task for any IIS-related task. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | WebDirectoryCreate | Creates a new web directory on a local or remote machine with IIS installed. The default is to create the new web directory on the local machine. The physical path is required to already exist on the target machine. If connecting to a remote machine, you can specify the Username and Password for the task to run under.
Public class | WebDirectoryDelete | Deletes a web directory on a local or remote machine with IIS installed. The default is to delete the web directory on the local machine. If connecting to a remote machine, you can specify the Username and Password for the task to run under.
Public class | WebDirectoryScriptMap | Sets an application mapping for a filename extension on an existing web directory.
Public class | WebDirectorySetting | Reads and modifies a web directory configuration setting.

Enumerations

 | Enumeration | Description
Public enumeration | AppPoolControllerActions | Actions the AppPoolController can do.
NestedPublic enumeration | WebBase.ApplicationPoolAction | Defines the possible application pool actions to be performed.
NestedFamily enumeration | WebBase.ApplicationPoolState | Defines the current application pool state.
NestedFamily enumeration | WebBase.IISVersion | Defines the possible IIS versions supported by the task.


AppPoolController Class

AppPoolController Class
See Also Example Members
[image]

Allows control for an application pool on a local or remote machine with IIS installed. The default is to control the application pool on the local machine. If connecting to a remote machine, you can specify the Username and Password for the task to run under.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class AppPoolController
Inherits WebBase
C#
public class AppPoolController : WebBase
C++
ref class AppPoolController : WebBase
J#
public class AppPoolController extends WebBase
JScript
public class AppPoolController extends WebBase

Example

Restart an application pool on the local machine.

Copy Code
            <AppPoolController AppPoolName="MyAppPool" Action="Restart" />

Inheritance Hierarchy

System.Object
Microsoft.Build.Utilities.Task
MSBuild.Community.Tasks.IIS.WebBase
MSBuild.Community.Tasks.IIS.AppPoolController

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

AppPoolController Members
MSBuild.Community.Tasks.IIS Namespace


AppPoolController Members

AppPoolController Members
See Also Example Constructors Fields Properties Methods
[image]

Allows control for an application pool on a local or remote machine with IIS installed. The default is to control the application pool on the local machine. If connecting to a remote machine, you can specify the Username and Password for the task to run under.

The following tables list the members exposed by AppPoolController.

Public Constructors

 | Name | Description
Public method | AppPoolController | Initializes a new instance of the AppPoolController class.
Top

Protected Fields

 | Name | Description
Family field | mIISVersion | IIS version. (inherited from WebBase)
Top

Public Properties

 | Name | Description
Public property | Action | Gets or sets the application pool action.
Public property | ApplicationPoolName | Gets or sets the name of the app pool.
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Password | Gets or sets the password for the account the task will run under. This property is needed if you specified a ServerName for a remote machine. (inherited from WebBase)
Public property | ServerName | Gets or sets the name of the server. The default value is 'localhost'. (inherited from WebBase)
Public property | ServerPort | Gets or sets the server port. (inherited from WebBase)
Public property | Username | Gets or sets the username for the account the task will run under. This property is needed if you specified a ServerName for a remote machine. (inherited from WebBase)
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | IISApplicationPath | Gets or sets the application path. (inherited from WebBase)
Family property | IISAppPoolPath | Gets or sets the IIS application pool path. (inherited from WebBase)
Family property | IISServerPath | Gets or sets the IIS server path. (inherited from WebBase)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. When overridden in a derived class, executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

AppPoolController Class
AppPoolController Members
MSBuild.Community.Tasks.IIS Namespace


AppPoolController Constructor

AppPoolController Constructor
[image]

Initializes a new instance of the AppPoolController class.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public AppPoolController()
C++
public:
AppPoolController() sealed
J#
public AppPoolController()
JScript
public function AppPoolController()

See Also

AppPoolController Class
AppPoolController Members
MSBuild.Community.Tasks.IIS Namespace


Properties

AppPoolController Properties
See Also Example
[image]

Public Properties

 | Name | Description
Public property | Action | Gets or sets the application pool action.
Public property | ApplicationPoolName | Gets or sets the name of the app pool.
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Password | Gets or sets the password for the account the task will run under. This property is needed if you specified a ServerName for a remote machine. (inherited from WebBase)
Public property | ServerName | Gets or sets the name of the server. The default value is 'localhost'. (inherited from WebBase)
Public property | ServerPort | Gets or sets the server port. (inherited from WebBase)
Public property | Username | Gets or sets the username for the account the task will run under. This property is needed if you specified a ServerName for a remote machine. (inherited from WebBase)
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | IISApplicationPath | Gets or sets the application path. (inherited from WebBase)
Family property | IISAppPoolPath | Gets or sets the IIS application pool path. (inherited from WebBase)
Family property | IISServerPath | Gets or sets the IIS server path. (inherited from WebBase)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

See Also

AppPoolController Class
AppPoolController Members
MSBuild.Community.Tasks.IIS Namespace


Action Property

AppPoolController.Action Property
[image]

Gets or sets the application pool action.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Required>
Public Property Action As String
C#
[Required]
public string Action { get; set; }
C++
[Required]
public property string Action sealed {
String get();
void set(String value);
}
J#
/** @attribute Required() */
/** property */
public string get_Action();

/** property */
public void set_Action(string value);
JScript
public function get Action() : String

public function set Action(value : String);

Property Value

The application pool action.

See Also

AppPoolController Class
AppPoolController Members
MSBuild.Community.Tasks.IIS Namespace


ApplicationPoolName Property

AppPoolController.ApplicationPoolName Property
[image]

Gets or sets the name of the app pool.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Required>
Public Property ApplicationPoolName As String
C#
[Required]
public string ApplicationPoolName { get; set; }
C++
[Required]
public property string ApplicationPoolName sealed {
String get();
void set(String value);
}
J#
/** @attribute Required() */
/** property */
public string get_ApplicationPoolName();

/** property */
public void set_ApplicationPoolName(string value);
JScript
public function get ApplicationPoolName() : String

public function set ApplicationPoolName(value : String);

Property Value

The name of the app pool.

See Also

AppPoolController Class
AppPoolController Members
MSBuild.Community.Tasks.IIS Namespace


Methods

AppPoolController Methods
See Also Example
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. When overridden in a derived class, executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

AppPoolController Class
AppPoolController Members
MSBuild.Community.Tasks.IIS Namespace


Execute Method

AppPoolController.Execute Method
[image]

When overridden in a derived class, executes the task.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute() As Boolean _
Implements ITask.Execute
C#
public override bool Execute()
C++
public:
virtual bool Execute() override
J#
public override bool Execute()
JScript
public override function Execute() : bool

Return Value

True if the task successfully executed; otherwise, false.

Implements

ITask.Execute

See Also

AppPoolController Class
AppPoolController Members
MSBuild.Community.Tasks.IIS Namespace


AppPoolControllerActions Enumeration

AppPoolControllerActions Enumeration
[image]

Actions the AppPoolController can do.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Enum AppPoolControllerActions
C#
public enum AppPoolControllerActions
C++
public enum class AppPoolControllerActions
J#
public enum AppPoolControllerActions
JScript
public enum AppPoolControllerActions

Members

Member Name | Description
Start | Start the applicaiton pool
Stop | Stop the applicaiton pool
Restart | Restart the applicaiton pool
Recycle | Recycle the applicaiton pool

See Also

AppPoolControllerActions Members
MSBuild.Community.Tasks.IIS Namespace


AppPoolCreate Class

AppPoolCreate Class
See Also Example Members
[image]

Creates a new application pool on a local or remote machine with IIS installed. The default is to create the new application pool on the local machine. If connecting to a remote machine, you can specify the Username and Password for the task to run under.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class AppPoolCreate
Inherits WebBase
C#
public class AppPoolCreate : WebBase
C++
ref class AppPoolCreate : WebBase
J#
public class AppPoolCreate extends WebBase
JScript
public class AppPoolCreate extends WebBase

Example

Create a new application pool on the local machine.

Copy Code
            <AppPoolCreate AppPoolName="MyAppPool" />

Inheritance Hierarchy

System.Object
Microsoft.Build.Utilities.Task
MSBuild.Community.Tasks.IIS.WebBase
MSBuild.Community.Tasks.IIS.AppPoolCreate

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

AppPoolCreate Members
MSBuild.Community.Tasks.IIS Namespace


AppPoolCreate Members

AppPoolCreate Members
See Also Example Constructors Fields Properties Methods
[image]

Creates a new application pool on a local or remote machine with IIS installed. The default is to create the new application pool on the local machine. If connecting to a remote machine, you can specify the Username and Password for the task to run under.

The following tables list the members exposed by AppPoolCreate.

Public Constructors

 | Name | Description
Public method | AppPoolCreate | Initializes a new instance of the AppPoolCreate class.
Top

Protected Fields

 | Name | Description
Family field | mIISVersion | IIS version. (inherited from WebBase)
Top

Public Properties

 | Name | Description
Public property | ApplicationPoolName | Gets or sets the name of the application pool.
Public property | AppPoolAutoStart | The AppPoolAutoStart property indicates to the World Wide Web Publishing Service (WWW service) to automatically start an application pool when the application pool is created or when IIS is started, if the value of this property is set to true.
Public property | AppPoolIdentityType | The AppPoolIdentityType property allows application pools to run as a specific user account: 0 - The application pool runs as NT AUTHORITY\SYSTEM. 1 - The application pool runs as NT AUTHORITY\LOCAL SERVICE. 2 - The application pool runs as NT AUTHORITY\NETWORK SERVICE. 3 - The application pool runs as a specific user account, defined by the WAMUserName property.
Public property | AppPoolQueueLength | The AppPoolQueueLength property indicates to the Universal Listener how many requests to queue up for an application pool before rejecting future requests. When the limit for this property is exceeded, IIS rejects the additional requests with a 503 error.
Public property | AutoShutdownAppPoolExe | The AutoShutdownAppPoolExe property specifies an executable to run when the World Wide Web Publishing Service (WWW service) shuts down an application pool for rapid fail protection. You can use the AutoShutdownAppPoolParams property to send parameters to the executable.
Public property | AutoShutdownAppPoolParams | The AutoShutdownAppPoolParams property specifies any command-line parameters for the executable that is specified in the AutoShutdownAppPoolExe property. You can use these two properties in the following way to send e-mail, for example, when the World Wide Web Publishing Service (WWW service) shuts down an application pool for rapid fail protection: AutoShutdownAppPoolExe = "C:\LogAndSendMail.bat" AutoShutdownAppPoolParams = "-AppPoolName %1%" where %1% represents the application pool name.
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | CPUAction | The CPUAction property configures the action(s) that IIS takes when Microsoft Windows NT ® job objects run. Only one Windows NT job object exists per application pool, therefore the CPUAction property is configured on a per application pool basis. Possible values: 0 - No action is taken except that a warning is written to the event log when the CPU limit is exceeded. 1 - Application pool worker processes that exceed their CPU limit will be forced to shut down.
Public property | CPULimit | The CPULimit property configures the maximum percentage of CPU resources that worker processes in an application pool are allowed to consume over a period of time, as indicated by the CPUResetInterval property. Set this property by specifying a percentage of CPU usage, multiplied by 1000. For example, if you want the CPU usage limit to be 50%, set CPULimit to 50,000.
Public property | CPUResetInterval | The CPUResetInterval property specifies the reset period (in minutes) for CPU monitoring and throttling limits on the application pool. When the number of minutes elapsed since the last process accounting reset equals the number specified by this property, IIS will reset the CPU timers for both the logging and limit intervals. Setting the value of this property to 0 disables CPU monitoring.
Public property | DisallowOverlappingRotation | The DisallowOverlappingRotation property specifies whether or not the World Wide Web Publishing Service (WWW Service) should start up another worker process to replace the existing worker process while it is shutting down.
Public property | DisallowRotationOnConfigChange | The DisallowRotationOnConfigChange property specifies whether or not the World Wide Web Publishing Service (WWW Service) should rotate worker processes in an application pool when the configuration has changed. This means that the worker processes will not pick up application pool changes to values passed to the worker process, such as IdleTimeout and PeriodicRestartRequests.
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | IdleTimeout | The IdleTimeout property specifies how long (in minutes) a worker process should run idle if no new requests are received and the worker process is not processing requests. After the allotted time passes, the worker process should request to be shut down by the World Wide Web Publishing Service (WWW Service).
Public property | LoadBalancerCapabilities | The LoadBalancerCapabilities property specifies behavior when a service is unavailable. A setting of 1 terminates the connection. A setting of 2 sends error code 503.
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | LogEventOnRecycle | The LogEventOnRecycle property specifies that IIS should log an event when an application pool is recycled. Application pools recycle for a variety of reasons. In order for IIS to log the event, the LogEventOnRecycle property must have a bit set corresponding to the reason for the recycle.
Public property | LogonMethod | The LogonMethod property contains an integer that specifies the logon method for cleartext logons. Valid settings are: 0 for interactive logon. 1 for batch logon. 2 for network logon. 3 for cleartext logon.
Public property | MaxProcesses | The MaxProcesses property determines the maximum number of worker processes an application pool allows to service requests for an application pool. This property cannot be set to 0 because there are no unmanaged pools.
Public property | OrphanActionExe | The OrphanActionExe property specifies an executable to run when the World Wide Web Publishing Service (WWW service) orphans a worker process. You can use the OrphanActionParams property to send parameters to the executable.
Public property | OrphanActionParams | The OrphanActionParams property specifies command-line parameters for the executable specified by the OrphanActionExe property.
Public property | OrphanWorkerProcess | The OrphanWorkerProcess property, when set to true, notifies the World Wide Web Publishing Service (WWW Service) not to terminate a worker process that fails to respond to pings, but to instead orphan the worker process in the application pool if the worker process suffers fatal errors.
Public property | Password | Gets or sets the password for the account the task will run under. This property is needed if you specified a ServerName for a remote machine. (inherited from WebBase)
Public property | PeriodicRestartMemory | The PeriodicRestartMemory property specifies the amount of virtual memory (in KB) that a worker process can use before the worker process recycles. The maximum value supported for this property is 4,294,967 KB.
Public property | PeriodicRestartPrivateMemory | The PeriodicRestartPrivateMemory property specifies the amount of private memory (in KB) that a worker process can use before the worker process recycles. The maximum value supported for this property is 4,294,967 KB.
Public property | PeriodicRestartRequests | The PeriodicRestartRequests property indicates the number of requests the OOP application should process, after which it is recycled.
Public property | PeriodicRestartSchedule | The PeriodicRestartSchedule property specifies the time (in 24 hour format) that the application will be rotated. Each time is in local time and is specified in the following format: PeriodicRestartSchedule="hh:mm,hh:mm,hh:mm"
Public property | PeriodicRestartTime | The PeriodicRestartTime property specifies the period of time, in minutes, after which IIS rotates an isolated OOP application. Setting the value of this property to 0 disables the property. The maximum supported value for this property is 71,582.
Public property | PingingEnabled | The PingingEnabled property specifies whether the World Wide Web Publishing Service (WWW Service) should periodically monitor the health of a worker process. Setting the value of this property to true indicates to the WWW service to monitor the worker processes to ensure that the they are running and healthy.
Public property | PingInterval | The PingInterval property specifies the period of time (in seconds) between health-monitoring pings that the World Wide Web Publishing Service (WWW Service) sends to a worker process.
Public property | PingResponseTime | The PingResponseTime property specifies the amount of time (in seconds) that a worker process is given to respond to a health monitoring ping. After the time limit is exceeded, the World Wide Web Publishing Service (WWW Service) terminates the worker process.
Public property | RapidFailProtection | Setting the RapidFailProtection property to true instructs the World Wide Web Publishing Service (WWW service) to put all applications in an application pool out of service if the number of worker process crashes has reached the maximum specified by the RapidFailProtectionMaxCrashes property, within the number of minutes specified by the RapidFailProtectionInterval property.
Public property | RapidFailProtectionInterval | The RapidFailProtectionInterval property specifies the number of minutes before the failure count for a process is reset. See RapidFailProtection.
Public property | RapidFailProtectionMaxCrashes | The RapidFailProtectionMaxCrashes property specifies the maximum number of failures allowed within the number of minutes specified by the RapidFailProtectionInterval property. See RapidFailProtection.
Public property | ServerName | Gets or sets the name of the server. The default value is 'localhost'. (inherited from WebBase)
Public property | ServerPort | Gets or sets the server port. (inherited from WebBase)
Public property | ShutdownTimeLimit | The ShutdownTimeLimit property specifies the amount of time (in seconds) after a recycle threshold has been reached that IIS waits for all old requests to finish running in a worker process before terminating the worker process.
Public property | SMPAffinitized | Setting the SMPAffinitized property to true indicates that a particular worker process assigned to an application pool should be assigned to a given CPU. This property is used in conjunction with the SMPProcessorAffinityMask property to configure a particular processor a worker process will be assigned to.
Public property | SMPProcessorAffinityMask | The SMPProcessorAffinityMask property configures the hexadecimal processor mask. The hexadecimal processor mask indicates to which CPU the worker processes in an application pool should be bound. Before this property takes affect, the SMPAffinitized property must be set to true for the application pool. These properties cannot be set through IIS Manager. Do not set this property to zero. Doing so causes no SMP affinity to be configured, creating an error condition. The default DWORD value is 4294967295 (or -1), which is represented in hexadecimal as 0xFFFFFFFF. A value of 0xFFFFFFFF in SMPProcessorAffinityMask indicates that all processors are enabled.
Public property | StartupTimeLimit | The value of the StartupTimeLimit property specifies the amount of time (in seconds) that the World Wide Web Publishing Service (WWW Service) should wait for a worker process to finish starting up and reporting to the WWW Service.
Public property | Username | Gets or sets the username for the account the task will run under. This property is needed if you specified a ServerName for a remote machine. (inherited from WebBase)
Public property | WAMUserName | The WAMUserName property specifies the account user name that IIS uses by default as the COM+ application identity for newly created IIS out-of-process applications. The values of this property and its companion property, WAMUserPass, are set when IIS is installed, and match the user name and password values in the Microsoft Windows user account, which is established at the same time. Changing the value of this property is not recommended. If you do, change it to a valid Windows user account, and change WAMUserPass to the corresponding password for the new account. Important: Changes to WAMUserName and WAMUserPass may disrupt the operation of existing IIS out-of-process applications. You can synchronize application identities using Component Services to edit the user name and password values, found on the Identity tab of the property sheet for each package. In-process applications are not affected by these property values.
Public property | WAMUserPass | The WAMUserPass property specifies the password for the account that IIS uses by default as the COM+ application identity for newly created IIS out-of-process applications. The values of this property and its companion property, WAMUserName, are set when IIS is installed, and match the password and user name values in the Microsoft Windows user account (IWAM_ MachineName, where MachineName is the name of the machine on which IIS is installed) established at the same time. Important: Changing the value of this property is not recommended. If you do, you must change the Windows account password to the identical value. You must also synchronize existing IIS out-of-process application identities, using Component Services to edit the user name and password values, which are found on the Identity tab of the property sheet for each package. In-process applications are not affected by these property values.
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | IISApplicationPath | Gets or sets the application path. (inherited from WebBase)
Family property | IISAppPoolPath | Gets or sets the IIS application pool path. (inherited from WebBase)
Family property | IISServerPath | Gets or sets the IIS server path. (inherited from WebBase)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. When overridden in a derived class, executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

AppPoolCreate Class
AppPoolCreate Members
MSBuild.Community.Tasks.IIS Namespace


AppPoolCreate Constructor

AppPoolCreate Constructor
[image]

Initializes a new instance of the AppPoolCreate class.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public AppPoolCreate()
C++
public:
AppPoolCreate() sealed
J#
public AppPoolCreate()
JScript
public function AppPoolCreate()

See Also

AppPoolCreate Class
AppPoolCreate Members
MSBuild.Community.Tasks.IIS Namespace


Properties

AppPoolCreate Properties
See Also Example
[image]

Public Properties

 | Name | Description
Public property | ApplicationPoolName | Gets or sets the name of the application pool.
Public property | AppPoolAutoStart | The AppPoolAutoStart property indicates to the World Wide Web Publishing Service (WWW service) to automatically start an application pool when the application pool is created or when IIS is started, if the value of this property is set to true.
Public property | AppPoolIdentityType | The AppPoolIdentityType property allows application pools to run as a specific user account: 0 - The application pool runs as NT AUTHORITY\SYSTEM. 1 - The application pool runs as NT AUTHORITY\LOCAL SERVICE. 2 - The application pool runs as NT AUTHORITY\NETWORK SERVICE. 3 - The application pool runs as a specific user account, defined by the WAMUserName property.
Public property | AppPoolQueueLength | The AppPoolQueueLength property indicates to the Universal Listener how many requests to queue up for an application pool before rejecting future requests. When the limit for this property is exceeded, IIS rejects the additional requests with a 503 error.
Public property | AutoShutdownAppPoolExe | The AutoShutdownAppPoolExe property specifies an executable to run when the World Wide Web Publishing Service (WWW service) shuts down an application pool for rapid fail protection. You can use the AutoShutdownAppPoolParams property to send parameters to the executable.
Public property | AutoShutdownAppPoolParams | The AutoShutdownAppPoolParams property specifies any command-line parameters for the executable that is specified in the AutoShutdownAppPoolExe property. You can use these two properties in the following way to send e-mail, for example, when the World Wide Web Publishing Service (WWW service) shuts down an application pool for rapid fail protection: AutoShutdownAppPoolExe = "C:\LogAndSendMail.bat" AutoShutdownAppPoolParams = "-AppPoolName %1%" where %1% represents the application pool name.
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | CPUAction | The CPUAction property configures the action(s) that IIS takes when Microsoft Windows NT ® job objects run. Only one Windows NT job object exists per application pool, therefore the CPUAction property is configured on a per application pool basis. Possible values: 0 - No action is taken except that a warning is written to the event log when the CPU limit is exceeded. 1 - Application pool worker processes that exceed their CPU limit will be forced to shut down.
Public property | CPULimit | The CPULimit property configures the maximum percentage of CPU resources that worker processes in an application pool are allowed to consume over a period of time, as indicated by the CPUResetInterval property. Set this property by specifying a percentage of CPU usage, multiplied by 1000. For example, if you want the CPU usage limit to be 50%, set CPULimit to 50,000.
Public property | CPUResetInterval | The CPUResetInterval property specifies the reset period (in minutes) for CPU monitoring and throttling limits on the application pool. When the number of minutes elapsed since the last process accounting reset equals the number specified by this property, IIS will reset the CPU timers for both the logging and limit intervals. Setting the value of this property to 0 disables CPU monitoring.
Public property | DisallowOverlappingRotation | The DisallowOverlappingRotation property specifies whether or not the World Wide Web Publishing Service (WWW Service) should start up another worker process to replace the existing worker process while it is shutting down.
Public property | DisallowRotationOnConfigChange | The DisallowRotationOnConfigChange property specifies whether or not the World Wide Web Publishing Service (WWW Service) should rotate worker processes in an application pool when the configuration has changed. This means that the worker processes will not pick up application pool changes to values passed to the worker process, such as IdleTimeout and PeriodicRestartRequests.
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | IdleTimeout | The IdleTimeout property specifies how long (in minutes) a worker process should run idle if no new requests are received and the worker process is not processing requests. After the allotted time passes, the worker process should request to be shut down by the World Wide Web Publishing Service (WWW Service).
Public property | LoadBalancerCapabilities | The LoadBalancerCapabilities property specifies behavior when a service is unavailable. A setting of 1 terminates the connection. A setting of 2 sends error code 503.
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | LogEventOnRecycle | The LogEventOnRecycle property specifies that IIS should log an event when an application pool is recycled. Application pools recycle for a variety of reasons. In order for IIS to log the event, the LogEventOnRecycle property must have a bit set corresponding to the reason for the recycle.
Public property | LogonMethod | The LogonMethod property contains an integer that specifies the logon method for cleartext logons. Valid settings are: 0 for interactive logon. 1 for batch logon. 2 for network logon. 3 for cleartext logon.
Public property | MaxProcesses | The MaxProcesses property determines the maximum number of worker processes an application pool allows to service requests for an application pool. This property cannot be set to 0 because there are no unmanaged pools.
Public property | OrphanActionExe | The OrphanActionExe property specifies an executable to run when the World Wide Web Publishing Service (WWW service) orphans a worker process. You can use the OrphanActionParams property to send parameters to the executable.
Public property | OrphanActionParams | The OrphanActionParams property specifies command-line parameters for the executable specified by the OrphanActionExe property.
Public property | OrphanWorkerProcess | The OrphanWorkerProcess property, when set to true, notifies the World Wide Web Publishing Service (WWW Service) not to terminate a worker process that fails to respond to pings, but to instead orphan the worker process in the application pool if the worker process suffers fatal errors.
Public property | Password | Gets or sets the password for the account the task will run under. This property is needed if you specified a ServerName for a remote machine. (inherited from WebBase)
Public property | PeriodicRestartMemory | The PeriodicRestartMemory property specifies the amount of virtual memory (in KB) that a worker process can use before the worker process recycles. The maximum value supported for this property is 4,294,967 KB.
Public property | PeriodicRestartPrivateMemory | The PeriodicRestartPrivateMemory property specifies the amount of private memory (in KB) that a worker process can use before the worker process recycles. The maximum value supported for this property is 4,294,967 KB.
Public property | PeriodicRestartRequests | The PeriodicRestartRequests property indicates the number of requests the OOP application should process, after which it is recycled.
Public property | PeriodicRestartSchedule | The PeriodicRestartSchedule property specifies the time (in 24 hour format) that the application will be rotated. Each time is in local time and is specified in the following format: PeriodicRestartSchedule="hh:mm,hh:mm,hh:mm"
Public property | PeriodicRestartTime | The PeriodicRestartTime property specifies the period of time, in minutes, after which IIS rotates an isolated OOP application. Setting the value of this property to 0 disables the property. The maximum supported value for this property is 71,582.
Public property | PingingEnabled | The PingingEnabled property specifies whether the World Wide Web Publishing Service (WWW Service) should periodically monitor the health of a worker process. Setting the value of this property to true indicates to the WWW service to monitor the worker processes to ensure that the they are running and healthy.
Public property | PingInterval | The PingInterval property specifies the period of time (in seconds) between health-monitoring pings that the World Wide Web Publishing Service (WWW Service) sends to a worker process.
Public property | PingResponseTime | The PingResponseTime property specifies the amount of time (in seconds) that a worker process is given to respond to a health monitoring ping. After the time limit is exceeded, the World Wide Web Publishing Service (WWW Service) terminates the worker process.
Public property | RapidFailProtection | Setting the RapidFailProtection property to true instructs the World Wide Web Publishing Service (WWW service) to put all applications in an application pool out of service if the number of worker process crashes has reached the maximum specified by the RapidFailProtectionMaxCrashes property, within the number of minutes specified by the RapidFailProtectionInterval property.
Public property | RapidFailProtectionInterval | The RapidFailProtectionInterval property specifies the number of minutes before the failure count for a process is reset. See RapidFailProtection.
Public property | RapidFailProtectionMaxCrashes | The RapidFailProtectionMaxCrashes property specifies the maximum number of failures allowed within the number of minutes specified by the RapidFailProtectionInterval property. See RapidFailProtection.
Public property | ServerName | Gets or sets the name of the server. The default value is 'localhost'. (inherited from WebBase)
Public property | ServerPort | Gets or sets the server port. (inherited from WebBase)
Public property | ShutdownTimeLimit | The ShutdownTimeLimit property specifies the amount of time (in seconds) after a recycle threshold has been reached that IIS waits for all old requests to finish running in a worker process before terminating the worker process.
Public property | SMPAffinitized | Setting the SMPAffinitized property to true indicates that a particular worker process assigned to an application pool should be assigned to a given CPU. This property is used in conjunction with the SMPProcessorAffinityMask property to configure a particular processor a worker process will be assigned to.
Public property | SMPProcessorAffinityMask | The SMPProcessorAffinityMask property configures the hexadecimal processor mask. The hexadecimal processor mask indicates to which CPU the worker processes in an application pool should be bound. Before this property takes affect, the SMPAffinitized property must be set to true for the application pool. These properties cannot be set through IIS Manager. Do not set this property to zero. Doing so causes no SMP affinity to be configured, creating an error condition. The default DWORD value is 4294967295 (or -1), which is represented in hexadecimal as 0xFFFFFFFF. A value of 0xFFFFFFFF in SMPProcessorAffinityMask indicates that all processors are enabled.
Public property | StartupTimeLimit | The value of the StartupTimeLimit property specifies the amount of time (in seconds) that the World Wide Web Publishing Service (WWW Service) should wait for a worker process to finish starting up and reporting to the WWW Service.
Public property | Username | Gets or sets the username for the account the task will run under. This property is needed if you specified a ServerName for a remote machine. (inherited from WebBase)
Public property | WAMUserName | The WAMUserName property specifies the account user name that IIS uses by default as the COM+ application identity for newly created IIS out-of-process applications. The values of this property and its companion property, WAMUserPass, are set when IIS is installed, and match the user name and password values in the Microsoft Windows user account, which is established at the same time. Changing the value of this property is not recommended. If you do, change it to a valid Windows user account, and change WAMUserPass to the corresponding password for the new account. Important: Changes to WAMUserName and WAMUserPass may disrupt the operation of existing IIS out-of-process applications. You can synchronize application identities using Component Services to edit the user name and password values, found on the Identity tab of the property sheet for each package. In-process applications are not affected by these property values.
Public property | WAMUserPass | The WAMUserPass property specifies the password for the account that IIS uses by default as the COM+ application identity for newly created IIS out-of-process applications. The values of this property and its companion property, WAMUserName, are set when IIS is installed, and match the password and user name values in the Microsoft Windows user account (IWAM_ MachineName, where MachineName is the name of the machine on which IIS is installed) established at the same time. Important: Changing the value of this property is not recommended. If you do, you must change the Windows account password to the identical value. You must also synchronize existing IIS out-of-process application identities, using Component Services to edit the user name and password values, which are found on the Identity tab of the property sheet for each package. In-process applications are not affected by these property values.
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | IISApplicationPath | Gets or sets the application path. (inherited from WebBase)
Family property | IISAppPoolPath | Gets or sets the IIS application pool path. (inherited from WebBase)
Family property | IISServerPath | Gets or sets the IIS server path. (inherited from WebBase)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

See Also

AppPoolCreate Class
AppPoolCreate Members
MSBuild.Community.Tasks.IIS Namespace


ApplicationPoolName Property

AppPoolCreate.ApplicationPoolName Property
[image]

Gets or sets the name of the application pool.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Required>
Public Property ApplicationPoolName As String
C#
[Required]
public string ApplicationPoolName { get; set; }
C++
[Required]
public property string ApplicationPoolName sealed {
String get();
void set(String value);
}
J#
/** @attribute Required() */
/** property */
public string get_ApplicationPoolName();

/** property */
public void set_ApplicationPoolName(string value);
JScript
public function get ApplicationPoolName() : String

public function set ApplicationPoolName(value : String);

Property Value

The name of the application pool.

See Also

AppPoolCreate Class
AppPoolCreate Members
MSBuild.Community.Tasks.IIS Namespace


AppPoolAutoStart Property

AppPoolCreate.AppPoolAutoStart Property
[image]

The AppPoolAutoStart property indicates to the World Wide Web Publishing Service (WWW service) to automatically start an application pool when the application pool is created or when IIS is started, if the value of this property is set to true.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AppPoolAutoStart As Boolean
C#
public bool AppPoolAutoStart { get; set; }
C++
public property bool AppPoolAutoStart sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_AppPoolAutoStart();

/** property */
public void set_AppPoolAutoStart(bool value);
JScript
public function get AppPoolAutoStart() : bool

public function set AppPoolAutoStart(value : bool);

Property Value

Value indicating if AppPoolAutoStart is enabled or disabled.

See Also

AppPoolCreate Class
AppPoolCreate Members
MSBuild.Community.Tasks.IIS Namespace


AppPoolIdentityType Property

AppPoolCreate.AppPoolIdentityType Property
[image]

The AppPoolIdentityType property allows application pools to run as a specific user account: 0 - The application pool runs as NT AUTHORITY\SYSTEM. 1 - The application pool runs as NT AUTHORITY\LOCAL SERVICE. 2 - The application pool runs as NT AUTHORITY\NETWORK SERVICE. 3 - The application pool runs as a specific user account, defined by the WAMUserName property.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AppPoolIdentityType As Integer
C#
public int AppPoolIdentityType { get; set; }
C++
public property int AppPoolIdentityType sealed {
int get();
void set(int value);
}
J#
/** property */
public int get_AppPoolIdentityType();

/** property */
public void set_AppPoolIdentityType(int value);
JScript
public function get AppPoolIdentityType() : int

public function set AppPoolIdentityType(value : int);

Property Value

Value indicating the application pool identity type.

See Also

AppPoolCreate Class
AppPoolCreate Members
MSBuild.Community.Tasks.IIS Namespace


AppPoolQueueLength Property

AppPoolCreate.AppPoolQueueLength Property
[image]

The AppPoolQueueLength property indicates to the Universal Listener how many requests to queue up for an application pool before rejecting future requests. When the limit for this property is exceeded, IIS rejects the additional requests with a 503 error.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AppPoolQueueLength As Integer
C#
public int AppPoolQueueLength { get; set; }
C++
public property int AppPoolQueueLength sealed {
int get();
void set(int value);
}
J#
/** property */
public int get_AppPoolQueueLength();

/** property */
public void set_AppPoolQueueLength(int value);
JScript
public function get AppPoolQueueLength() : int

public function set AppPoolQueueLength(value : int);

Property Value

Value indicating the application pool queue length.

See Also

AppPoolCreate Class
AppPoolCreate Members
MSBuild.Community.Tasks.IIS Namespace


AutoShutdownAppPoolExe Property

AppPoolCreate.AutoShutdownAppPoolExe Property
[image]

The AutoShutdownAppPoolExe property specifies an executable to run when the World Wide Web Publishing Service (WWW service) shuts down an application pool for rapid fail protection. You can use the AutoShutdownAppPoolParams property to send parameters to the executable.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AutoShutdownAppPoolExe As String
C#
public string AutoShutdownAppPoolExe { get; set; }
C++
public property string AutoShutdownAppPoolExe sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_AutoShutdownAppPoolExe();

/** property */
public void set_AutoShutdownAppPoolExe(string value);
JScript
public function get AutoShutdownAppPoolExe() : String

public function set AutoShutdownAppPoolExe(value : String);

Property Value

Value indicating the application pool auto shutdown executable.

See Also

AppPoolCreate Class
AppPoolCreate Members
MSBuild.Community.Tasks.IIS Namespace


AutoShutdownAppPoolParams Property

AppPoolCreate.AutoShutdownAppPoolParams Property
[image]

The AutoShutdownAppPoolParams property specifies any command-line parameters for the executable that is specified in the AutoShutdownAppPoolExe property. You can use these two properties in the following way to send e-mail, for example, when the World Wide Web Publishing Service (WWW service) shuts down an application pool for rapid fail protection: AutoShutdownAppPoolExe = "C:\LogAndSendMail.bat" AutoShutdownAppPoolParams = "-AppPoolName %1%" where %1% represents the application pool name.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AutoShutdownAppPoolParams As String
C#
public string AutoShutdownAppPoolParams { get; set; }
C++
public property string AutoShutdownAppPoolParams sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_AutoShutdownAppPoolParams();

/** property */
public void set_AutoShutdownAppPoolParams(string value);
JScript
public function get AutoShutdownAppPoolParams() : String

public function set AutoShutdownAppPoolParams(value : String);

Property Value

Value indicating the parameters for the application pool auto shutdown executable.

See Also

AppPoolCreate Class
AppPoolCreate Members
MSBuild.Community.Tasks.IIS Namespace


CPUAction Property

AppPoolCreate.CPUAction Property
[image]

The CPUAction property configures the action(s) that IIS takes when Microsoft Windows NT ® job objects run. Only one Windows NT job object exists per application pool, therefore the CPUAction property is configured on a per application pool basis. Possible values: 0 - No action is taken except that a warning is written to the event log when the CPU limit is exceeded. 1 - Application pool worker processes that exceed their CPU limit will be forced to shut down.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property CPUAction As Integer
C#
public int CPUAction { get; set; }
C++
public property int CPUAction sealed {
int get();
void set(int value);
}
J#
/** property */
public int get_CPUAction();

/** property */
public void set_CPUAction(int value);
JScript
public function get CPUAction() : int

public function set CPUAction(value : int);

Property Value

Value indicating the CPU action.

See Also

AppPoolCreate Class
AppPoolCreate Members
MSBuild.Community.Tasks.IIS Namespace


CPULimit Property

AppPoolCreate.CPULimit Property
[image]

The CPULimit property configures the maximum percentage of CPU resources that worker processes in an application pool are allowed to consume over a period of time, as indicated by the CPUResetInterval property. Set this property by specifying a percentage of CPU usage, multiplied by 1000. For example, if you want the CPU usage limit to be 50%, set CPULimit to 50,000.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property CPULimit As Integer
C#
public int CPULimit { get; set; }
C++
public property int CPULimit sealed {
int get();
void set(int value);
}
J#
/** property */
public int get_CPULimit();

/** property */
public void set_CPULimit(int value);
JScript
public function get CPULimit() : int

public function set CPULimit(value : int);

Property Value

Value indicating the CPU limit.

See Also

AppPoolCreate Class
AppPoolCreate Members
MSBuild.Community.Tasks.IIS Namespace


CPUResetInterval Property

AppPoolCreate.CPUResetInterval Property
[image]

The CPUResetInterval property specifies the reset period (in minutes) for CPU monitoring and throttling limits on the application pool. When the number of minutes elapsed since the last process accounting reset equals the number specified by this property, IIS will reset the CPU timers for both the logging and limit intervals. Setting the value of this property to 0 disables CPU monitoring.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property CPUResetInterval As Integer
C#
public int CPUResetInterval { get; set; }
C++
public property int CPUResetInterval sealed {
int get();
void set(int value);
}
J#
/** property */
public int get_CPUResetInterval();

/** property */
public void set_CPUResetInterval(int value);
JScript
public function get CPUResetInterval() : int

public function set CPUResetInterval(value : int);

Property Value

Value indicating the CPU reset interval.

See Also

AppPoolCreate Class
AppPoolCreate Members
MSBuild.Community.Tasks.IIS Namespace


DisallowOverlappingRotation Property

AppPoolCreate.DisallowOverlappingRotation Property
[image]

The DisallowOverlappingRotation property specifies whether or not the World Wide Web Publishing Service (WWW Service) should start up another worker process to replace the existing worker process while it is shutting down.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property DisallowOverlappingRotation As Boolean
C#
public bool DisallowOverlappingRotation { get; set; }
C++
public property bool DisallowOverlappingRotation sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_DisallowOverlappingRotation();

/** property */
public void set_DisallowOverlappingRotation(bool value);
JScript
public function get DisallowOverlappingRotation() : bool

public function set DisallowOverlappingRotation(value : bool);

Property Value

Value indicating the DisallowOverlappingRotation.

See Also

AppPoolCreate Class
AppPoolCreate Members
MSBuild.Community.Tasks.IIS Namespace


DisallowRotationOnConfigChange Property

AppPoolCreate.DisallowRotationOnConfigChange Property
[image]

The DisallowRotationOnConfigChange property specifies whether or not the World Wide Web Publishing Service (WWW Service) should rotate worker processes in an application pool when the configuration has changed. This means that the worker processes will not pick up application pool changes to values passed to the worker process, such as IdleTimeout and PeriodicRestartRequests.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property DisallowRotationOnConfigChange As Boolean
C#
public bool DisallowRotationOnConfigChange { get; set; }
C++
public property bool DisallowRotationOnConfigChange sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_DisallowRotationOnConfigChange();

/** property */
public void set_DisallowRotationOnConfigChange(bool value);
JScript
public function get DisallowRotationOnConfigChange() : bool

public function set DisallowRotationOnConfigChange(value : bool);

Property Value

Value indicating the DisallowRotationOnConfigChange.

See Also

AppPoolCreate Class
AppPoolCreate Members
MSBuild.Community.Tasks.IIS Namespace


IdleTimeout Property

AppPoolCreate.IdleTimeout Property
[image]

The IdleTimeout property specifies how long (in minutes) a worker process should run idle if no new requests are received and the worker process is not processing requests. After the allotted time passes, the worker process should request to be shut down by the World Wide Web Publishing Service (WWW Service).

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property IdleTimeout As Integer
C#
public int IdleTimeout { get; set; }
C++
public property int IdleTimeout sealed {
int get();
void set(int value);
}
J#
/** property */
public int get_IdleTimeout();

/** property */
public void set_IdleTimeout(int value);
JScript
public function get IdleTimeout() : int

public function set IdleTimeout(value : int);

Property Value

Value indicating the idle timeout.

See Also

AppPoolCreate Class
AppPoolCreate Members
MSBuild.Community.Tasks.IIS Namespace


LoadBalancerCapabilities Property

AppPoolCreate.LoadBalancerCapabilities Property
[image]

The LoadBalancerCapabilities property specifies behavior when a service is unavailable. A setting of 1 terminates the connection. A setting of 2 sends error code 503.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property LoadBalancerCapabilities As Integer
C#
public int LoadBalancerCapabilities { get; set; }
C++
public property int LoadBalancerCapabilities sealed {
int get();
void set(int value);
}
J#
/** property */
public int get_LoadBalancerCapabilities();

/** property */
public void set_LoadBalancerCapabilities(int value);
JScript
public function get LoadBalancerCapabilities() : int

public function set LoadBalancerCapabilities(value : int);

Property Value

Value indicating the load balancer capabilities.

See Also

AppPoolCreate Class
AppPoolCreate Members
MSBuild.Community.Tasks.IIS Namespace


LogEventOnRecycle Property

AppPoolCreate.LogEventOnRecycle Property
[image]

The LogEventOnRecycle property specifies that IIS should log an event when an application pool is recycled. Application pools recycle for a variety of reasons. In order for IIS to log the event, the LogEventOnRecycle property must have a bit set corresponding to the reason for the recycle.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property LogEventOnRecycle As Integer
C#
public int LogEventOnRecycle { get; set; }
C++
public property int LogEventOnRecycle sealed {
int get();
void set(int value);
}
J#
/** property */
public int get_LogEventOnRecycle();

/** property */
public void set_LogEventOnRecycle(int value);
JScript
public function get LogEventOnRecycle() : int

public function set LogEventOnRecycle(value : int);

Property Value

Value indicating which recycle events to log.

See Also

AppPoolCreate Class
AppPoolCreate Members
MSBuild.Community.Tasks.IIS Namespace


LogonMethod Property

AppPoolCreate.LogonMethod Property
[image]

The LogonMethod property contains an integer that specifies the logon method for cleartext logons. Valid settings are: 0 for interactive logon. 1 for batch logon. 2 for network logon. 3 for cleartext logon.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property LogonMethod As Integer
C#
public int LogonMethod { get; set; }
C++
public property int LogonMethod sealed {
int get();
void set(int value);
}
J#
/** property */
public int get_LogonMethod();

/** property */
public void set_LogonMethod(int value);
JScript
public function get LogonMethod() : int

public function set LogonMethod(value : int);

Property Value

Value indicating the logon method.

See Also

AppPoolCreate Class
AppPoolCreate Members
MSBuild.Community.Tasks.IIS Namespace


MaxProcesses Property

AppPoolCreate.MaxProcesses Property
[image]

The MaxProcesses property determines the maximum number of worker processes an application pool allows to service requests for an application pool. This property cannot be set to 0 because there are no unmanaged pools.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property MaxProcesses As Integer
C#
public int MaxProcesses { get; set; }
C++
public property int MaxProcesses sealed {
int get();
void set(int value);
}
J#
/** property */
public int get_MaxProcesses();

/** property */
public void set_MaxProcesses(int value);
JScript
public function get MaxProcesses() : int

public function set MaxProcesses(value : int);

Property Value

Value indicating the maximum number of worker processes allowed by the application pool.

See Also

AppPoolCreate Class
AppPoolCreate Members
MSBuild.Community.Tasks.IIS Namespace


OrphanActionExe Property

AppPoolCreate.OrphanActionExe Property
[image]

The OrphanActionExe property specifies an executable to run when the World Wide Web Publishing Service (WWW service) orphans a worker process. You can use the OrphanActionParams property to send parameters to the executable.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property OrphanActionExe As String
C#
public string OrphanActionExe { get; set; }
C++
public property string OrphanActionExe sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_OrphanActionExe();

/** property */
public void set_OrphanActionExe(string value);
JScript
public function get OrphanActionExe() : String

public function set OrphanActionExe(value : String);

Property Value

The value for the orphan action executable.

See Also

AppPoolCreate Class
AppPoolCreate Members
MSBuild.Community.Tasks.IIS Namespace


OrphanActionParams Property

AppPoolCreate.OrphanActionParams Property
[image]

The OrphanActionParams property specifies command-line parameters for the executable specified by the OrphanActionExe property.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property OrphanActionParams As String
C#
public string OrphanActionParams { get; set; }
C++
public property string OrphanActionParams sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_OrphanActionParams();

/** property */
public void set_OrphanActionParams(string value);
JScript
public function get OrphanActionParams() : String

public function set OrphanActionParams(value : String);

Property Value

Value indicating the orphan action parameters.

See Also

AppPoolCreate Class
AppPoolCreate Members
MSBuild.Community.Tasks.IIS Namespace


OrphanWorkerProcess Property

AppPoolCreate.OrphanWorkerProcess Property
[image]

The OrphanWorkerProcess property, when set to true, notifies the World Wide Web Publishing Service (WWW Service) not to terminate a worker process that fails to respond to pings, but to instead orphan the worker process in the application pool if the worker process suffers fatal errors.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property OrphanWorkerProcess As Boolean
C#
public bool OrphanWorkerProcess { get; set; }
C++
public property bool OrphanWorkerProcess sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_OrphanWorkerProcess();

/** property */
public void set_OrphanWorkerProcess(bool value);
JScript
public function get OrphanWorkerProcess() : bool

public function set OrphanWorkerProcess(value : bool);

Property Value

Value indicating the orphan worker process.

See Also

AppPoolCreate Class
AppPoolCreate Members
MSBuild.Community.Tasks.IIS Namespace


PeriodicRestartMemory Property

AppPoolCreate.PeriodicRestartMemory Property
[image]

The PeriodicRestartMemory property specifies the amount of virtual memory (in KB) that a worker process can use before the worker process recycles. The maximum value supported for this property is 4,294,967 KB.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property PeriodicRestartMemory As Integer
C#
public int PeriodicRestartMemory { get; set; }
C++
public property int PeriodicRestartMemory sealed {
int get();
void set(int value);
}
J#
/** property */
public int get_PeriodicRestartMemory();

/** property */
public void set_PeriodicRestartMemory(int value);
JScript
public function get PeriodicRestartMemory() : int

public function set PeriodicRestartMemory(value : int);

Property Value

Value indicating the amount of memory.

See Also

AppPoolCreate Class
AppPoolCreate Members
MSBuild.Community.Tasks.IIS Namespace


PeriodicRestartPrivateMemory Property

AppPoolCreate.PeriodicRestartPrivateMemory Property
[image]

The PeriodicRestartPrivateMemory property specifies the amount of private memory (in KB) that a worker process can use before the worker process recycles. The maximum value supported for this property is 4,294,967 KB.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property PeriodicRestartPrivateMemory As Integer
C#
public int PeriodicRestartPrivateMemory { get; set; }
C++
public property int PeriodicRestartPrivateMemory sealed {
int get();
void set(int value);
}
J#
/** property */
public int get_PeriodicRestartPrivateMemory();

/** property */
public void set_PeriodicRestartPrivateMemory(int value);
JScript
public function get PeriodicRestartPrivateMemory() : int

public function set PeriodicRestartPrivateMemory(value : int);

Property Value

Value indicating the amount of memory.

See Also

AppPoolCreate Class
AppPoolCreate Members
MSBuild.Community.Tasks.IIS Namespace


PeriodicRestartRequests Property

AppPoolCreate.PeriodicRestartRequests Property
[image]

The PeriodicRestartRequests property indicates the number of requests the OOP application should process, after which it is recycled.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property PeriodicRestartRequests As Integer
C#
public int PeriodicRestartRequests { get; set; }
C++
public property int PeriodicRestartRequests sealed {
int get();
void set(int value);
}
J#
/** property */
public int get_PeriodicRestartRequests();

/** property */
public void set_PeriodicRestartRequests(int value);
JScript
public function get PeriodicRestartRequests() : int

public function set PeriodicRestartRequests(value : int);

Property Value

Value indicating the number of requests.

See Also

AppPoolCreate Class
AppPoolCreate Members
MSBuild.Community.Tasks.IIS Namespace


PeriodicRestartSchedule Property

AppPoolCreate.PeriodicRestartSchedule Property
[image]

The PeriodicRestartSchedule property specifies the time (in 24 hour format) that the application will be rotated. Each time is in local time and is specified in the following format: PeriodicRestartSchedule="hh:mm,hh:mm,hh:mm"

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property PeriodicRestartSchedule As String
C#
public string PeriodicRestartSchedule { get; set; }
C++
public property string PeriodicRestartSchedule sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_PeriodicRestartSchedule();

/** property */
public void set_PeriodicRestartSchedule(string value);
JScript
public function get PeriodicRestartSchedule() : String

public function set PeriodicRestartSchedule(value : String);

Property Value

Value indicating the restart schedule.

See Also

AppPoolCreate Class
AppPoolCreate Members
MSBuild.Community.Tasks.IIS Namespace


PeriodicRestartTime Property

AppPoolCreate.PeriodicRestartTime Property
[image]

The PeriodicRestartTime property specifies the period of time, in minutes, after which IIS rotates an isolated OOP application. Setting the value of this property to 0 disables the property. The maximum supported value for this property is 71,582.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property PeriodicRestartTime As Integer
C#
public int PeriodicRestartTime { get; set; }
C++
public property int PeriodicRestartTime sealed {
int get();
void set(int value);
}
J#
/** property */
public int get_PeriodicRestartTime();

/** property */
public void set_PeriodicRestartTime(int value);
JScript
public function get PeriodicRestartTime() : int

public function set PeriodicRestartTime(value : int);

Property Value

Value indicating the restart time period.

See Also

AppPoolCreate Class
AppPoolCreate Members
MSBuild.Community.Tasks.IIS Namespace


PingingEnabled Property

AppPoolCreate.PingingEnabled Property
[image]

The PingingEnabled property specifies whether the World Wide Web Publishing Service (WWW Service) should periodically monitor the health of a worker process. Setting the value of this property to true indicates to the WWW service to monitor the worker processes to ensure that the they are running and healthy.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property PingingEnabled As Boolean
C#
public bool PingingEnabled { get; set; }
C++
public property bool PingingEnabled sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_PingingEnabled();

/** property */
public void set_PingingEnabled(bool value);
JScript
public function get PingingEnabled() : bool

public function set PingingEnabled(value : bool);

Property Value

Value indicating if pinging is enabled or disabled.

See Also

AppPoolCreate Class
AppPoolCreate Members
MSBuild.Community.Tasks.IIS Namespace


PingInterval Property

AppPoolCreate.PingInterval Property
[image]

The PingInterval property specifies the period of time (in seconds) between health-monitoring pings that the World Wide Web Publishing Service (WWW Service) sends to a worker process.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property PingInterval As Integer
C#
public int PingInterval { get; set; }
C++
public property int PingInterval sealed {
int get();
void set(int value);
}
J#
/** property */
public int get_PingInterval();

/** property */
public void set_PingInterval(int value);
JScript
public function get PingInterval() : int

public function set PingInterval(value : int);

Property Value

Value indicating the ping interval.

See Also

AppPoolCreate Class
AppPoolCreate Members
MSBuild.Community.Tasks.IIS Namespace


PingResponseTime Property

AppPoolCreate.PingResponseTime Property
[image]

The PingResponseTime property specifies the amount of time (in seconds) that a worker process is given to respond to a health monitoring ping. After the time limit is exceeded, the World Wide Web Publishing Service (WWW Service) terminates the worker process.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property PingResponseTime As Integer
C#
public int PingResponseTime { get; set; }
C++
public property int PingResponseTime sealed {
int get();
void set(int value);
}
J#
/** property */
public int get_PingResponseTime();

/** property */
public void set_PingResponseTime(int value);
JScript
public function get PingResponseTime() : int

public function set PingResponseTime(value : int);

Property Value

Value indicating the ping response time.

See Also

AppPoolCreate Class
AppPoolCreate Members
MSBuild.Community.Tasks.IIS Namespace


RapidFailProtection Property

AppPoolCreate.RapidFailProtection Property
[image]

Setting the RapidFailProtection property to true instructs the World Wide Web Publishing Service (WWW service) to put all applications in an application pool out of service if the number of worker process crashes has reached the maximum specified by the RapidFailProtectionMaxCrashes property, within the number of minutes specified by the RapidFailProtectionInterval property.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property RapidFailProtection As Boolean
C#
public bool RapidFailProtection { get; set; }
C++
public property bool RapidFailProtection sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_RapidFailProtection();

/** property */
public void set_RapidFailProtection(bool value);
JScript
public function get RapidFailProtection() : bool

public function set RapidFailProtection(value : bool);

Property Value

Value indicating if rapid fail protection is enabled or disabled.

See Also

AppPoolCreate Class
AppPoolCreate Members
MSBuild.Community.Tasks.IIS Namespace


RapidFailProtectionInterval Property

AppPoolCreate.RapidFailProtectionInterval Property
[image]

The RapidFailProtectionInterval property specifies the number of minutes before the failure count for a process is reset. See RapidFailProtection.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property RapidFailProtectionInterval As Integer
C#
public int RapidFailProtectionInterval { get; set; }
C++
public property int RapidFailProtectionInterval sealed {
int get();
void set(int value);
}
J#
/** property */
public int get_RapidFailProtectionInterval();

/** property */
public void set_RapidFailProtectionInterval(int value);
JScript
public function get RapidFailProtectionInterval() : int

public function set RapidFailProtectionInterval(value : int);

Property Value

Value indicating the rapid fail protection interval.

See Also

AppPoolCreate Class
AppPoolCreate Members
MSBuild.Community.Tasks.IIS Namespace


RapidFailProtectionMaxCrashes Property

AppPoolCreate.RapidFailProtectionMaxCrashes Property
[image]

The RapidFailProtectionMaxCrashes property specifies the maximum number of failures allowed within the number of minutes specified by the RapidFailProtectionInterval property. See RapidFailProtection.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property RapidFailProtectionMaxCrashes As Integer
C#
public int RapidFailProtectionMaxCrashes { get; set; }
C++
public property int RapidFailProtectionMaxCrashes sealed {
int get();
void set(int value);
}
J#
/** property */
public int get_RapidFailProtectionMaxCrashes();

/** property */
public void set_RapidFailProtectionMaxCrashes(int value);
JScript
public function get RapidFailProtectionMaxCrashes() : int

public function set RapidFailProtectionMaxCrashes(value : int);

Property Value

Value indicating the maximum number of crashes.

See Also

AppPoolCreate Class
AppPoolCreate Members
MSBuild.Community.Tasks.IIS Namespace


ShutdownTimeLimit Property

AppPoolCreate.ShutdownTimeLimit Property
[image]

The ShutdownTimeLimit property specifies the amount of time (in seconds) after a recycle threshold has been reached that IIS waits for all old requests to finish running in a worker process before terminating the worker process.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property ShutdownTimeLimit As Integer
C#
public int ShutdownTimeLimit { get; set; }
C++
public property int ShutdownTimeLimit sealed {
int get();
void set(int value);
}
J#
/** property */
public int get_ShutdownTimeLimit();

/** property */
public void set_ShutdownTimeLimit(int value);
JScript
public function get ShutdownTimeLimit() : int

public function set ShutdownTimeLimit(value : int);

Property Value

Value indicating the shutdown time limit.

See Also

AppPoolCreate Class
AppPoolCreate Members
MSBuild.Community.Tasks.IIS Namespace


SMPAffinitized Property

AppPoolCreate.SMPAffinitized Property
[image]

Setting the SMPAffinitized property to true indicates that a particular worker process assigned to an application pool should be assigned to a given CPU. This property is used in conjunction with the SMPProcessorAffinityMask property to configure a particular processor a worker process will be assigned to.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property SMPAffinitized As Boolean
C#
public bool SMPAffinitized { get; set; }
C++
public property bool SMPAffinitized sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_SMPAffinitized();

/** property */
public void set_SMPAffinitized(bool value);
JScript
public function get SMPAffinitized() : bool

public function set SMPAffinitized(value : bool);

Property Value

Value indicating if SMPAffinitized is enabled or disabled.

See Also

AppPoolCreate Class
AppPoolCreate Members
MSBuild.Community.Tasks.IIS Namespace


SMPProcessorAffinityMask Property

AppPoolCreate.SMPProcessorAffinityMask Property
[image]

The SMPProcessorAffinityMask property configures the hexadecimal processor mask. The hexadecimal processor mask indicates to which CPU the worker processes in an application pool should be bound. Before this property takes affect, the SMPAffinitized property must be set to true for the application pool. These properties cannot be set through IIS Manager. Do not set this property to zero. Doing so causes no SMP affinity to be configured, creating an error condition. The default DWORD value is 4294967295 (or -1), which is represented in hexadecimal as 0xFFFFFFFF. A value of 0xFFFFFFFF in SMPProcessorAffinityMask indicates that all processors are enabled.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property SMPProcessorAffinityMask As Long
C#
public long SMPProcessorAffinityMask { get; set; }
C++
public property long SMPProcessorAffinityMask sealed {
__int64 get();
void set(__int64 value);
}
J#
/** property */
public long get_SMPProcessorAffinityMask();

/** property */
public void set_SMPProcessorAffinityMask(long value);
JScript
public function get SMPProcessorAffinityMask() : long

public function set SMPProcessorAffinityMask(value : long);

Property Value

Value indicating the SMP processor affinity bit mask.

See Also

AppPoolCreate Class
AppPoolCreate Members
MSBuild.Community.Tasks.IIS Namespace


StartupTimeLimit Property

AppPoolCreate.StartupTimeLimit Property
[image]

The value of the StartupTimeLimit property specifies the amount of time (in seconds) that the World Wide Web Publishing Service (WWW Service) should wait for a worker process to finish starting up and reporting to the WWW Service.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property StartupTimeLimit As Integer
C#
public int StartupTimeLimit { get; set; }
C++
public property int StartupTimeLimit sealed {
int get();
void set(int value);
}
J#
/** property */
public int get_StartupTimeLimit();

/** property */
public void set_StartupTimeLimit(int value);
JScript
public function get StartupTimeLimit() : int

public function set StartupTimeLimit(value : int);

Property Value

Value indicating the startup time limit.

See Also

AppPoolCreate Class
AppPoolCreate Members
MSBuild.Community.Tasks.IIS Namespace


WAMUserName Property

AppPoolCreate.WAMUserName Property
[image]

The WAMUserName property specifies the account user name that IIS uses by default as the COM+ application identity for newly created IIS out-of-process applications. The values of this property and its companion property, WAMUserPass, are set when IIS is installed, and match the user name and password values in the Microsoft Windows user account, which is established at the same time. Changing the value of this property is not recommended. If you do, change it to a valid Windows user account, and change WAMUserPass to the corresponding password for the new account. Important: Changes to WAMUserName and WAMUserPass may disrupt the operation of existing IIS out-of-process applications. You can synchronize application identities using Component Services to edit the user name and password values, found on the Identity tab of the property sheet for each package. In-process applications are not affected by these property values.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property WAMUserName As String
C#
public string WAMUserName { get; set; }
C++
public property string WAMUserName sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_WAMUserName();

/** property */
public void set_WAMUserName(string value);
JScript
public function get WAMUserName() : String

public function set WAMUserName(value : String);

Property Value

Value indicating the username.

See Also

AppPoolCreate Class
AppPoolCreate Members
MSBuild.Community.Tasks.IIS Namespace


WAMUserPass Property

AppPoolCreate.WAMUserPass Property
[image]

The WAMUserPass property specifies the password for the account that IIS uses by default as the COM+ application identity for newly created IIS out-of-process applications. The values of this property and its companion property, WAMUserName, are set when IIS is installed, and match the password and user name values in the Microsoft Windows user account (IWAM_ MachineName, where MachineName is the name of the machine on which IIS is installed) established at the same time. Important: Changing the value of this property is not recommended. If you do, you must change the Windows account password to the identical value. You must also synchronize existing IIS out-of-process application identities, using Component Services to edit the user name and password values, which are found on the Identity tab of the property sheet for each package. In-process applications are not affected by these property values.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property WAMUserPass As String
C#
public string WAMUserPass { get; set; }
C++
public property string WAMUserPass sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_WAMUserPass();

/** property */
public void set_WAMUserPass(string value);
JScript
public function get WAMUserPass() : String

public function set WAMUserPass(value : String);

Property Value

Value indicating the password.

See Also

AppPoolCreate Class
AppPoolCreate Members
MSBuild.Community.Tasks.IIS Namespace


Methods

AppPoolCreate Methods
See Also Example
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. When overridden in a derived class, executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

AppPoolCreate Class
AppPoolCreate Members
MSBuild.Community.Tasks.IIS Namespace


Execute Method

AppPoolCreate.Execute Method
[image]

When overridden in a derived class, executes the task.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute() As Boolean _
Implements ITask.Execute
C#
public override bool Execute()
C++
public:
virtual bool Execute() override
J#
public override bool Execute()
JScript
public override function Execute() : bool

Return Value

True if the task successfully executed; otherwise, false.

Implements

ITask.Execute

See Also

AppPoolCreate Class
AppPoolCreate Members
MSBuild.Community.Tasks.IIS Namespace


AppPoolDelete Class

AppPoolDelete Class
See Also Example Members
[image]

Deletes an existing application pool on a local or remote machine with IIS installed. The default is to delete an existing application pool on the local machine. If connecting to a remote machine, you can specify the Username and Password for the task to run under.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class AppPoolDelete
Inherits WebBase
C#
public class AppPoolDelete : WebBase
C++
ref class AppPoolDelete : WebBase
J#
public class AppPoolDelete extends WebBase
JScript
public class AppPoolDelete extends WebBase

Example

Delete an existing application pool on the local machine.

Copy Code
            <AppPoolDelete AppPoolName="MyAppPool" />

Inheritance Hierarchy

System.Object
Microsoft.Build.Utilities.Task
MSBuild.Community.Tasks.IIS.WebBase
MSBuild.Community.Tasks.IIS.AppPoolDelete

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

AppPoolDelete Members
MSBuild.Community.Tasks.IIS Namespace


AppPoolDelete Members

AppPoolDelete Members
See Also Example Constructors Fields Properties Methods
[image]

Deletes an existing application pool on a local or remote machine with IIS installed. The default is to delete an existing application pool on the local machine. If connecting to a remote machine, you can specify the Username and Password for the task to run under.

The following tables list the members exposed by AppPoolDelete.

Public Constructors

 | Name | Description
Public method | AppPoolDelete | Initializes a new instance of the AppPoolDelete class.
Top

Protected Fields

 | Name | Description
Family field | mIISVersion | IIS version. (inherited from WebBase)
Top

Public Properties

 | Name | Description
Public property | ApplicationPoolName | Gets or sets the name of the application pool.
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Password | Gets or sets the password for the account the task will run under. This property is needed if you specified a ServerName for a remote machine. (inherited from WebBase)
Public property | ServerName | Gets or sets the name of the server. The default value is 'localhost'. (inherited from WebBase)
Public property | ServerPort | Gets or sets the server port. (inherited from WebBase)
Public property | Username | Gets or sets the username for the account the task will run under. This property is needed if you specified a ServerName for a remote machine. (inherited from WebBase)
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | IISApplicationPath | Gets or sets the application path. (inherited from WebBase)
Family property | IISAppPoolPath | Gets or sets the IIS application pool path. (inherited from WebBase)
Family property | IISServerPath | Gets or sets the IIS server path. (inherited from WebBase)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. When overridden in a derived class, executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

AppPoolDelete Class
AppPoolDelete Members
MSBuild.Community.Tasks.IIS Namespace


AppPoolDelete Constructor

AppPoolDelete Constructor
[image]

Initializes a new instance of the AppPoolDelete class.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public AppPoolDelete()
C++
public:
AppPoolDelete() sealed
J#
public AppPoolDelete()
JScript
public function AppPoolDelete()

See Also

AppPoolDelete Class
AppPoolDelete Members
MSBuild.Community.Tasks.IIS Namespace


Properties

AppPoolDelete Properties
See Also Example
[image]

Public Properties

 | Name | Description
Public property | ApplicationPoolName | Gets or sets the name of the application pool.
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Password | Gets or sets the password for the account the task will run under. This property is needed if you specified a ServerName for a remote machine. (inherited from WebBase)
Public property | ServerName | Gets or sets the name of the server. The default value is 'localhost'. (inherited from WebBase)
Public property | ServerPort | Gets or sets the server port. (inherited from WebBase)
Public property | Username | Gets or sets the username for the account the task will run under. This property is needed if you specified a ServerName for a remote machine. (inherited from WebBase)
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | IISApplicationPath | Gets or sets the application path. (inherited from WebBase)
Family property | IISAppPoolPath | Gets or sets the IIS application pool path. (inherited from WebBase)
Family property | IISServerPath | Gets or sets the IIS server path. (inherited from WebBase)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

See Also

AppPoolDelete Class
AppPoolDelete Members
MSBuild.Community.Tasks.IIS Namespace


ApplicationPoolName Property

AppPoolDelete.ApplicationPoolName Property
[image]

Gets or sets the name of the application pool.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Required>
Public Property ApplicationPoolName As String
C#
[Required]
public string ApplicationPoolName { get; set; }
C++
[Required]
public property string ApplicationPoolName sealed {
String get();
void set(String value);
}
J#
/** @attribute Required() */
/** property */
public string get_ApplicationPoolName();

/** property */
public void set_ApplicationPoolName(string value);
JScript
public function get ApplicationPoolName() : String

public function set ApplicationPoolName(value : String);

Property Value

The name of the application pool.

See Also

AppPoolDelete Class
AppPoolDelete Members
MSBuild.Community.Tasks.IIS Namespace


Methods

AppPoolDelete Methods
See Also Example
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. When overridden in a derived class, executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

AppPoolDelete Class
AppPoolDelete Members
MSBuild.Community.Tasks.IIS Namespace


Execute Method

AppPoolDelete.Execute Method
[image]

When overridden in a derived class, executes the task.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute() As Boolean _
Implements ITask.Execute
C#
public override bool Execute()
C++
public:
virtual bool Execute() override
J#
public override bool Execute()
JScript
public override function Execute() : bool

Return Value

True if the task successfully executed; otherwise, false.

Implements

ITask.Execute

See Also

AppPoolDelete Class
AppPoolDelete Members
MSBuild.Community.Tasks.IIS Namespace


WebBase Class

WebBase Class
See Also Members
[image]

Base task for any IIS-related task. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class WebBase
Inherits Task
C#
public abstract class WebBase : Task
C++
ref class WebBase abstract : Task
J#
public class WebBase extends Task
JScript
public class WebBase extends Task

Remarks

Stores the base logic for gathering the IIS version and server and port checking. This base task also stores common properties for other related tasks.

Inheritance Hierarchy

System.Object
Microsoft.Build.Utilities.Task
MSBuild.Community.Tasks.IIS.WebBase
Derived types

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

WebBase Members
MSBuild.Community.Tasks.IIS Namespace


WebBase Members

WebBase Members
See Also Constructors Fields Properties Methods
[image]

Base task for any IIS-related task. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by WebBase.

Protected Constructors

 | Name | Description
Family method | WebBase | Initializes a new instance of the WebBase class.
Top

Protected Fields

 | Name | Description
Family field | mIISVersion | IIS version.
Top

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Password | Gets or sets the password for the account the task will run under. This property is needed if you specified a ServerName for a remote machine.
Public property | ServerName | Gets or sets the name of the server. The default value is 'localhost'.
Public property | ServerPort | Gets or sets the server port.
Public property | Username | Gets or sets the username for the account the task will run under. This property is needed if you specified a ServerName for a remote machine.
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | IISApplicationPath | Gets or sets the application path.
Family property | IISAppPoolPath | Gets or sets the IIS application pool path.
Family property | IISServerPath | Gets or sets the IIS server path.
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | When overridden in a derived class, executes the task. (inherited from Task)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

WebBase Class
WebBase Members
MSBuild.Community.Tasks.IIS Namespace


WebBase Constructor

WebBase Constructor
[image]

Initializes a new instance of the WebBase class.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New()
C#
protected WebBase()
C++
protected:
WebBase() sealed
J#
protected WebBase()
JScript
protected function WebBase()

See Also

WebBase Class
WebBase Members
MSBuild.Community.Tasks.IIS Namespace


Fields

WebBase Fields
[image]

Protected Fields

 | Name | Description
Family field | mIISVersion | IIS version.
Top

See Also

WebBase Class
WebBase Members
MSBuild.Community.Tasks.IIS Namespace


mIISVersion Field

WebBase.mIISVersion Field
[image]

IIS version.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected mIISVersion As WebBase.IISVersion
C#
protected WebBase.IISVersion mIISVersion;
C++
protected:
WebBase.IISVersion mIISVersion sealed ;
J#
protected WebBase.IISVersion mIISVersion
JScript
protected mIISVersion : WebBase.IISVersion;

See Also

WebBase Class
WebBase Members
MSBuild.Community.Tasks.IIS Namespace


Properties

WebBase Properties
[image]

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Password | Gets or sets the password for the account the task will run under. This property is needed if you specified a ServerName for a remote machine.
Public property | ServerName | Gets or sets the name of the server. The default value is 'localhost'.
Public property | ServerPort | Gets or sets the server port.
Public property | Username | Gets or sets the username for the account the task will run under. This property is needed if you specified a ServerName for a remote machine.
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | IISApplicationPath | Gets or sets the application path.
Family property | IISAppPoolPath | Gets or sets the IIS application pool path.
Family property | IISServerPath | Gets or sets the IIS server path.
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

See Also

WebBase Class
WebBase Members
MSBuild.Community.Tasks.IIS Namespace


IISApplicationPath Property

WebBase.IISApplicationPath Property
[image]

Gets or sets the application path.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Property IISApplicationPath As String
C#
protected string IISApplicationPath { get; set; }
C++
protected property string IISApplicationPath sealed {
String get();
void set(String value);
}
J#
/** property */
protected string get_IISApplicationPath();

/** property */
protected void set_IISApplicationPath(string value);
JScript
protected function get IISApplicationPath() : String

protected function set IISApplicationPath(value : String);

Property Value

The application path.

Remarks

Is in the form '/LM/W3SVC/1/Root'.

See Also

WebBase Class
WebBase Members
MSBuild.Community.Tasks.IIS Namespace


IISAppPoolPath Property

WebBase.IISAppPoolPath Property
[image]

Gets or sets the IIS application pool path.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Property IISAppPoolPath As String
C#
protected string IISAppPoolPath { get; set; }
C++
protected property string IISAppPoolPath sealed {
String get();
void set(String value);
}
J#
/** property */
protected string get_IISAppPoolPath();

/** property */
protected void set_IISAppPoolPath(string value);
JScript
protected function get IISAppPoolPath() : String

protected function set IISAppPoolPath(value : String);

Property Value

The IIS application pool path.

Remarks

Is in the form 'IIS://localhost/W3SVC/AppPools'.

See Also

WebBase Class
WebBase Members
MSBuild.Community.Tasks.IIS Namespace


IISServerPath Property

WebBase.IISServerPath Property
[image]

Gets or sets the IIS server path.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Property IISServerPath As String
C#
protected string IISServerPath { get; set; }
C++
protected property string IISServerPath sealed {
String get();
void set(String value);
}
J#
/** property */
protected string get_IISServerPath();

/** property */
protected void set_IISServerPath(string value);
JScript
protected function get IISServerPath() : String

protected function set IISServerPath(value : String);

Property Value

The IIS server path.

Remarks

Is in the form 'IIS://localhost/W3SVC/1/Root'.

See Also

WebBase Class
WebBase Members
MSBuild.Community.Tasks.IIS Namespace


Password Property

WebBase.Password Property
[image]

Gets or sets the password for the account the task will run under. This property is needed if you specified a ServerName for a remote machine.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Password As String
C#
public string Password { get; set; }
C++
public property string Password sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Password();

/** property */
public void set_Password(string value);
JScript
public function get Password() : String

public function set Password(value : String);

Property Value

The password of the account.

See Also

WebBase Class
WebBase Members
MSBuild.Community.Tasks.IIS Namespace


ServerName Property

WebBase.ServerName Property
[image]

Gets or sets the name of the server. The default value is 'localhost'.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property ServerName As String
C#
public string ServerName { get; set; }
C++
public property string ServerName sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_ServerName();

/** property */
public void set_ServerName(string value);
JScript
public function get ServerName() : String

public function set ServerName(value : String);

Property Value

The name of the server.

See Also

WebBase Class
WebBase Members
MSBuild.Community.Tasks.IIS Namespace


ServerPort Property

WebBase.ServerPort Property
[image]

Gets or sets the server port.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property ServerPort As Integer
C#
public int ServerPort { get; set; }
C++
public property int ServerPort sealed {
int get();
void set(int value);
}
J#
/** property */
public int get_ServerPort();

/** property */
public void set_ServerPort(int value);
JScript
public function get ServerPort() : int

public function set ServerPort(value : int);

Property Value

The server port.

See Also

WebBase Class
WebBase Members
MSBuild.Community.Tasks.IIS Namespace


Username Property

WebBase.Username Property
[image]

Gets or sets the username for the account the task will run under. This property is needed if you specified a ServerName for a remote machine.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Username As String
C#
public string Username { get; set; }
C++
public property string Username sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Username();

/** property */
public void set_Username(string value);
JScript
public function get Username() : String

public function set Username(value : String);

Property Value

The username of the account.

See Also

WebBase Class
WebBase Members
MSBuild.Community.Tasks.IIS Namespace


WebBase.ApplicationPoolAction Enumeration

WebBase.ApplicationPoolAction Enumeration
[image]

Defines the possible application pool actions to be performed.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Enum WebBase.ApplicationPoolAction
C#
public enum WebBase.ApplicationPoolAction
C++
public enum class WebBase.ApplicationPoolAction
J#
public enum WebBase.ApplicationPoolAction
JScript
public enum WebBase.ApplicationPoolAction

Members

Member Name | Description
Recycle | Recycles an application pool.
Restart | Stops and restarts the application pool.
Start | Starts the application pool.
Stop | Stops the application pool.

See Also

WebBase.ApplicationPoolAction Members
MSBuild.Community.Tasks.IIS Namespace


WebBase.ApplicationPoolState Enumeration

WebBase.ApplicationPoolState Enumeration
[image]

Defines the current application pool state.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Enum WebBase.ApplicationPoolState
C#
protected enum WebBase.ApplicationPoolState
C++
protected enum class WebBase.ApplicationPoolState
J#
protected enum WebBase.ApplicationPoolState
JScript
protected enum WebBase.ApplicationPoolState

Members

Member Name | Description
Starting | The application pool is starting.
Started | The application pool has started.
Stopping | The application pool is stopping.
Stopped | The application pool has stopped.

See Also

WebBase.ApplicationPoolState Members
MSBuild.Community.Tasks.IIS Namespace


WebBase.IISVersion Enumeration

WebBase.IISVersion Enumeration
[image]

Defines the possible IIS versions supported by the task.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Enum WebBase.IISVersion
C#
protected enum WebBase.IISVersion
C++
protected enum class WebBase.IISVersion
J#
protected enum WebBase.IISVersion
JScript
protected enum WebBase.IISVersion

Members

Member Name | Description
Four | IIS version 4.x
Five | IIS version 5.x
Six | IIS version 6.x

See Also

WebBase.IISVersion Members
MSBuild.Community.Tasks.IIS Namespace


WebDirectoryCreate Class

WebDirectoryCreate Class
See Also Example Members
[image]

Creates a new web directory on a local or remote machine with IIS installed. The default is to create the new web directory on the local machine. The physical path is required to already exist on the target machine. If connecting to a remote machine, you can specify the Username and Password for the task to run under.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class WebDirectoryCreate
Inherits WebBase
C#
public class WebDirectoryCreate : WebBase
C++
ref class WebDirectoryCreate : WebBase
J#
public class WebDirectoryCreate extends WebBase
JScript
public class WebDirectoryCreate extends WebBase

Example

Create a new web directory on the local machine.

Copy Code
            <WebDirectoryCreate VirtualDirectoryName="MyVirDir"
                VirtualDirectoryPhysicalPath="C:\Inetpub\MyWebDir" />

Inheritance Hierarchy

System.Object
Microsoft.Build.Utilities.Task
MSBuild.Community.Tasks.IIS.WebBase
MSBuild.Community.Tasks.IIS.WebDirectoryCreate

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

WebDirectoryCreate Members
MSBuild.Community.Tasks.IIS Namespace


WebDirectoryCreate Members

WebDirectoryCreate Members
See Also Example Constructors Fields Properties Methods
[image]

Creates a new web directory on a local or remote machine with IIS installed. The default is to create the new web directory on the local machine. The physical path is required to already exist on the target machine. If connecting to a remote machine, you can specify the Username and Password for the task to run under.

The following tables list the members exposed by WebDirectoryCreate.

Public Constructors

 | Name | Description
Public method | WebDirectoryCreate | Initializes a new instance of the WebDirectoryCreate class.
Top

Protected Fields

 | Name | Description
Family field | mIISVersion | IIS version. (inherited from WebBase)
Top

Public Properties

 | Name | Description
Public property | AccessExecute | Gets or sets a value that indicates if the file or the contents of the folder may be executed, regardless of file type.
Public property | AccessNoRemoteExecute | A value of true indicates that remote requests to execute applications are denied; only requests from the same computer as the IIS server succeed if the AccessExecute property is set to true. You cannot set AccessNoRemoteExecute to false to enable remote requests, and set AccessExecute to false to disable local requests.
Public property | AccessNoRemoteRead | A value of true indicates that remote requests to view files are denied; only requests from the same computer as the IIS server succeed if the AccessRead property is set to true. You cannot set AccessNoRemoteRead to false to enable remote requests, and set AccessRead to false to disable local requests.
Public property | AccessNoRemoteScript | A value of true indicates that remote requests to view dynamic content are denied; only requests from the same computer as the IIS server succeed if the AccessScript property is set to true. You cannot set AccessNoRemoteScript to false to enable remote requests, and set AccessScript to false to disable local requests.
Public property | AccessNoRemoteWrite | A value of true indicates that remote requests to create or change files are denied; only requests from the same computer as the IIS server succeed if the AccessWrite property is set to true. You cannot set AccessNoRemoteWrite to false to enable remote requests, and set AccessWrite to false to disable local requests.
Public property | AccessRead | A value of true indicates that the file or the contents of the folder may be read through Microsoft Internet Explorer.
Public property | AccessScript | A value of true indicates that the file or the contents of the folder may be executed if they are script files or static content. A value of false only allows static files, such as HTML files, to be served.
Public property | AccessSource | A value of true indicates that users are allowed to access source code if either Read or Write permissions are set. Source code includes scripts in Microsoft ® Active Server Pages (ASP) applications.
Public property | AccessSsl | A value of true indicates that file access requires SSL file permission processing, with or without a client certificate.
Public property | AccessSsl128 | A value of true indicates that file access requires SSL file permission processing with a minimum key size of 128 bits, with or without a client certificate.
Public property | AccessSslMapCert | A value of true indicates that SSL file permission processing maps a client certificate to a Microsoft Windows ® operating system user-account. The AccessSslNegotiateCert property must also be set to true for the mapping to occur.
Public property | AccessSslNegotiateCert | A value of true indicates that SSL file access processing requests a certificate from the client. A value of false indicates that access continues if the client does not have a certificate. Some versions of Internet Explorer will close the connection if the server requests a certificate and a certificate is not available (even if AccessSslRequireCert is also set to true).
Public property | AccessSslRequireCert | A value of true indicates that SSL file access processing requests a certificate from the client. If the client provides no certificate, the connection is closed. AccessSslNegotiateCert must also be set to true when using AccessSSLRequireCert.
Public property | AccessWrite | A value of true indicates that users are allowed to upload files and their associated properties to the enabled directory on your server or to change content in a Write-enabled file. Write can be implemented only with a browser that supports the PUT feature of the HTTP 1.1 protocol standard.
Public property | AnonymousPasswordSync | The AnonymousPasswordSync property indicates whether IIS should handle the user password for anonymous users attempting to access resources.
Public property | AppAllowClientDebug | The AppAllowClientDebug property specifies whether ASP client-side debugging is enabled. This property is independent of AppAllowDebugging, which applies to server-side debugging.
Public property | AppAllowDebugging | The AppAllowDebugging property specifies whether ASP debugging is enabled on the server. This property is independent of the AppAllowClientDebug property, which applies to client-side debugging.
Public property | AspAllowSessionState | The AspAllowSessionState property enables session state persistence for the ASP application.
Public property | AspBufferingOn | The AspBufferingOn property specifies whether output from an ASP application will be buffered.
Public property | AspEnableApplicationRestart | The AspEnableApplicationRestart determines whether an ASP application can be automatically restarted. When changes are made to Global.asa or metabase properties that affect an application, the application will not restart unless the AspEnableApplicationRestart property is set to true.
Public property | AspEnableAspHtmlFallback | The AspEnableAspHtmlFallback property controls the behavior of ASP when a new request is to be rejected due to a full request queue.
Public property | AspEnableChunkedEncoding | The AspEnableChunkedEncoding property specifies whether HTTP 1.1 chunked transfer encoding is enabled for the World Wide Web Publishing Service (WWW service).
Public property | AspEnableParentPaths | The AspEnableParentPaths property specifies whether an ASP page allows paths relative to the current directory (using the ..\ notation) or above the current directory.
Public property | AspEnableTypelibCache | The AspEnableTypelibCache property specifies whether type libraries are cached on the server. The World Wide Web Publishing Service (WWW service) setting for this property is applicable to all in-process and pooled out-of-process application nodes, at all levels. Metabase settings at the Web server level or lower are ignored for in-process and pooled out-of-process applications. However, settings at the Web server level or lower are used if that node is an isolated out-of-process application.
Public property | AspErrorsToNTLog | The AspErrorsToNTLog property specifies which ASP errors are written to the Windows event log. ASP errors are written to the client browser and to the IIS log files by default.
Public property | AspExceptionCatchEnable | The AspExceptionCatchEnable property specifies whether ASP pages trap exceptions thrown by components.
Public property | AspLogErrorRequests | The AspLogErrorRequests property controls whether the Web server writes ASP errors to the application section of the Windows event log. ASP errors are written to the client browser and to the IIS log files by default.
Public property | AspScriptErrorMessage | The AspScriptErrorMessage property specifies the error message to send to the browser if specific debugging errors are not sent to the client (if AspScriptErrorSentToBrowser is set to false).
Public property | AspScriptErrorSentToBrowser | The AspScriptErrorSentToBrowser property specifies whether the Web server writes debugging specifics (file name, error, line number, description) to the client browser, in addition to logging them to the Windows Event Log. The AspScriptErrorMessage property provides the error message to be sent if this property is set to false.
Public property | AspTrackThreadingModel | The AspTrackThreadingModel property specifies whether IIS checks the threading model of any components (COM objects) that your application creates. The preferred setting of this metabase property is false.
Public property | AuthAnonymous | Specifies Anonymous authentication as one of the possible Windows authentication schemes returned to clients as being available.
Public property | AuthBasic | Specifies Basic authentication as one of the possible Windows authentication schemes returned to clients as being available.
Public property | AuthNtlm | Specifies Integrated Windows authentication (also known as Challenge/Response or NTLM authentication) as one of the possible Windows authentication schemes returned to clients as being available.
Public property | AuthPersistSingleRequest | Setting this flag to true specifies that authentication persists only for a single request on a connection. IIS resets the authentication at the end of each request, and forces re-authentication on the next request of the session.
Public property | AuthPersistSingleRequestAlwaysIfProxy | Setting this flag to true specifies that authentication is valid for a single request if by proxy. IIS will reset the authentication at the end of the request and force re-authentication on the next request if the current authenticated request is by proxy of any type.
Public property | AuthPersistSingleRequestIfProxy | Setting this flag to true specifies authentication will persist only across single requests on a connection if the connection is by proxy. IIS will reset the authentication at the end of the request if the current authenticated request is by proxy and it is not the special case where IIS is running MSPROXY.
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | CacheControlNoCache | The CacheControlNoCache property specifies the HTTP 1.1 directive to prevent caching of content.
Public property | CacheIsapi | The CacheISAPI property indicates whether ISAPI extensions are cached in memory after first use.
Public property | ContentIndexed | The ContentIndexed property specifies whether the installed content indexer should index content under this directory tree.
Public property | CpuAppEnabled | This property specifies whether process accounting and throttling should be performed for ISAPI extensions and ASP applications. To perform process accounting on CGI applications, use the property CpuCgiEnabled.
Public property | CpuCgiEnabled | This property indicates whether IIS should perform process accounting for CGI applications. To effectively throttle CGI applications, use the CgiTimeout property. To use process accounting for ISAPI and ASP applications, use CpuAppEnabled.
Public property | CreateCgiWithNewConsole | The CreateCGIWithNewConsole property indicates whether a CGI application runs in its own console.
Public property | CreateProcessAsUser | The CreateProcessAsUser property specifies whether a CGI process is created in the system context or in the context of the requesting user.
Public property | DefaultDoc | The DefaultDoc contains one or more file names of default documents that will be returned to the client if no file name is included in the client's request. The default document will be returned if the EnableDefaultDoc flag of the DirBrowseFlags property is set to true for the directory. This property can contain a list of default document file names separated by a comma and a space, for example Default.htm, Default.asp.
Public property | DirBrowseShowDate | When set to true, date information is displayed when browsing directories.
Public property | DirBrowseShowExtension | When set to true, file name extensions are displayed when browsing directories.
Public property | DirBrowseShowLongDate | When set to true, date information is displayed in extended format when displaying directories.
Public property | DirBrowseShowSize | When set to true, file size information is displayed when browsing directories.
Public property | DirBrowseShowTime | When set to true, file time information is displayed when displaying directories.
Public property | DontLog | The DontLog property specifies whether client requests are written to the IIS log files.
Public property | EnableDefaultDoc | When set to true, the default document (specified by the DefaultDoc property) for a directory is loaded when the directory is browsed.
Public property | EnableDirBrowsing | When set to true, directory browsing is enabled.
Public property | EnableDocFooter | The EnableDocFooter property enables or disables custom footers specified by the DefaultDocFooter property.
Public property | EnableReverseDns | The EnableReverseDns property enables or disables reverse Domain Name Server (DNS) lookups for the World Wide Web Publishing Service (WWW service). Reverse lookups involve looking up the domain name when the IP address is known. Reverse DNS lookups can use significant resources and time.
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Password | Gets or sets the password for the account the task will run under. This property is needed if you specified a ServerName for a remote machine. (inherited from WebBase)
Public property | ServerName | Gets or sets the name of the server. The default value is 'localhost'. (inherited from WebBase)
Public property | ServerPort | Gets or sets the server port. (inherited from WebBase)
Public property | SsiExecDisable | The SSIExecDisable property specifies whether server-side include (SSI) #exec directives are disabled under this path.
Public property | UncAuthenticationPassthrough | The UNCAuthenticationPassthrough property enables user authentication passthrough for Universal Naming Convention (UNC) virtual root access (for authentication schemes that support delegation).
Public property | Username | Gets or sets the username for the account the task will run under. This property is needed if you specified a ServerName for a remote machine. (inherited from WebBase)
Public property | VirtualDirectoryName | Gets or sets the name of the virtual directory.
Public property | VirtualDirectoryPhysicalPath | Gets or sets the virtual directory physical path. The physical directory must exist before this task executes.
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | IISApplicationPath | Gets or sets the application path. (inherited from WebBase)
Family property | IISAppPoolPath | Gets or sets the IIS application pool path. (inherited from WebBase)
Family property | IISServerPath | Gets or sets the IIS server path. (inherited from WebBase)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. When overridden in a derived class, executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

WebDirectoryCreate Class
WebDirectoryCreate Members
MSBuild.Community.Tasks.IIS Namespace


WebDirectoryCreate Constructor

WebDirectoryCreate Constructor
[image]

Initializes a new instance of the WebDirectoryCreate class.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public WebDirectoryCreate()
C++
public:
WebDirectoryCreate() sealed
J#
public WebDirectoryCreate()
JScript
public function WebDirectoryCreate()

See Also

WebDirectoryCreate Class
WebDirectoryCreate Members
MSBuild.Community.Tasks.IIS Namespace


Properties

WebDirectoryCreate Properties
See Also Example
[image]

Public Properties

 | Name | Description
Public property | AccessExecute | Gets or sets a value that indicates if the file or the contents of the folder may be executed, regardless of file type.
Public property | AccessNoRemoteExecute | A value of true indicates that remote requests to execute applications are denied; only requests from the same computer as the IIS server succeed if the AccessExecute property is set to true. You cannot set AccessNoRemoteExecute to false to enable remote requests, and set AccessExecute to false to disable local requests.
Public property | AccessNoRemoteRead | A value of true indicates that remote requests to view files are denied; only requests from the same computer as the IIS server succeed if the AccessRead property is set to true. You cannot set AccessNoRemoteRead to false to enable remote requests, and set AccessRead to false to disable local requests.
Public property | AccessNoRemoteScript | A value of true indicates that remote requests to view dynamic content are denied; only requests from the same computer as the IIS server succeed if the AccessScript property is set to true. You cannot set AccessNoRemoteScript to false to enable remote requests, and set AccessScript to false to disable local requests.
Public property | AccessNoRemoteWrite | A value of true indicates that remote requests to create or change files are denied; only requests from the same computer as the IIS server succeed if the AccessWrite property is set to true. You cannot set AccessNoRemoteWrite to false to enable remote requests, and set AccessWrite to false to disable local requests.
Public property | AccessRead | A value of true indicates that the file or the contents of the folder may be read through Microsoft Internet Explorer.
Public property | AccessScript | A value of true indicates that the file or the contents of the folder may be executed if they are script files or static content. A value of false only allows static files, such as HTML files, to be served.
Public property | AccessSource | A value of true indicates that users are allowed to access source code if either Read or Write permissions are set. Source code includes scripts in Microsoft ® Active Server Pages (ASP) applications.
Public property | AccessSsl | A value of true indicates that file access requires SSL file permission processing, with or without a client certificate.
Public property | AccessSsl128 | A value of true indicates that file access requires SSL file permission processing with a minimum key size of 128 bits, with or without a client certificate.
Public property | AccessSslMapCert | A value of true indicates that SSL file permission processing maps a client certificate to a Microsoft Windows ® operating system user-account. The AccessSslNegotiateCert property must also be set to true for the mapping to occur.
Public property | AccessSslNegotiateCert | A value of true indicates that SSL file access processing requests a certificate from the client. A value of false indicates that access continues if the client does not have a certificate. Some versions of Internet Explorer will close the connection if the server requests a certificate and a certificate is not available (even if AccessSslRequireCert is also set to true).
Public property | AccessSslRequireCert | A value of true indicates that SSL file access processing requests a certificate from the client. If the client provides no certificate, the connection is closed. AccessSslNegotiateCert must also be set to true when using AccessSSLRequireCert.
Public property | AccessWrite | A value of true indicates that users are allowed to upload files and their associated properties to the enabled directory on your server or to change content in a Write-enabled file. Write can be implemented only with a browser that supports the PUT feature of the HTTP 1.1 protocol standard.
Public property | AnonymousPasswordSync | The AnonymousPasswordSync property indicates whether IIS should handle the user password for anonymous users attempting to access resources.
Public property | AppAllowClientDebug | The AppAllowClientDebug property specifies whether ASP client-side debugging is enabled. This property is independent of AppAllowDebugging, which applies to server-side debugging.
Public property | AppAllowDebugging | The AppAllowDebugging property specifies whether ASP debugging is enabled on the server. This property is independent of the AppAllowClientDebug property, which applies to client-side debugging.
Public property | AspAllowSessionState | The AspAllowSessionState property enables session state persistence for the ASP application.
Public property | AspBufferingOn | The AspBufferingOn property specifies whether output from an ASP application will be buffered.
Public property | AspEnableApplicationRestart | The AspEnableApplicationRestart determines whether an ASP application can be automatically restarted. When changes are made to Global.asa or metabase properties that affect an application, the application will not restart unless the AspEnableApplicationRestart property is set to true.
Public property | AspEnableAspHtmlFallback | The AspEnableAspHtmlFallback property controls the behavior of ASP when a new request is to be rejected due to a full request queue.
Public property | AspEnableChunkedEncoding | The AspEnableChunkedEncoding property specifies whether HTTP 1.1 chunked transfer encoding is enabled for the World Wide Web Publishing Service (WWW service).
Public property | AspEnableParentPaths | The AspEnableParentPaths property specifies whether an ASP page allows paths relative to the current directory (using the ..\ notation) or above the current directory.
Public property | AspEnableTypelibCache | The AspEnableTypelibCache property specifies whether type libraries are cached on the server. The World Wide Web Publishing Service (WWW service) setting for this property is applicable to all in-process and pooled out-of-process application nodes, at all levels. Metabase settings at the Web server level or lower are ignored for in-process and pooled out-of-process applications. However, settings at the Web server level or lower are used if that node is an isolated out-of-process application.
Public property | AspErrorsToNTLog | The AspErrorsToNTLog property specifies which ASP errors are written to the Windows event log. ASP errors are written to the client browser and to the IIS log files by default.
Public property | AspExceptionCatchEnable | The AspExceptionCatchEnable property specifies whether ASP pages trap exceptions thrown by components.
Public property | AspLogErrorRequests | The AspLogErrorRequests property controls whether the Web server writes ASP errors to the application section of the Windows event log. ASP errors are written to the client browser and to the IIS log files by default.
Public property | AspScriptErrorMessage | The AspScriptErrorMessage property specifies the error message to send to the browser if specific debugging errors are not sent to the client (if AspScriptErrorSentToBrowser is set to false).
Public property | AspScriptErrorSentToBrowser | The AspScriptErrorSentToBrowser property specifies whether the Web server writes debugging specifics (file name, error, line number, description) to the client browser, in addition to logging them to the Windows Event Log. The AspScriptErrorMessage property provides the error message to be sent if this property is set to false.
Public property | AspTrackThreadingModel | The AspTrackThreadingModel property specifies whether IIS checks the threading model of any components (COM objects) that your application creates. The preferred setting of this metabase property is false.
Public property | AuthAnonymous | Specifies Anonymous authentication as one of the possible Windows authentication schemes returned to clients as being available.
Public property | AuthBasic | Specifies Basic authentication as one of the possible Windows authentication schemes returned to clients as being available.
Public property | AuthNtlm | Specifies Integrated Windows authentication (also known as Challenge/Response or NTLM authentication) as one of the possible Windows authentication schemes returned to clients as being available.
Public property | AuthPersistSingleRequest | Setting this flag to true specifies that authentication persists only for a single request on a connection. IIS resets the authentication at the end of each request, and forces re-authentication on the next request of the session.
Public property | AuthPersistSingleRequestAlwaysIfProxy | Setting this flag to true specifies that authentication is valid for a single request if by proxy. IIS will reset the authentication at the end of the request and force re-authentication on the next request if the current authenticated request is by proxy of any type.
Public property | AuthPersistSingleRequestIfProxy | Setting this flag to true specifies authentication will persist only across single requests on a connection if the connection is by proxy. IIS will reset the authentication at the end of the request if the current authenticated request is by proxy and it is not the special case where IIS is running MSPROXY.
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | CacheControlNoCache | The CacheControlNoCache property specifies the HTTP 1.1 directive to prevent caching of content.
Public property | CacheIsapi | The CacheISAPI property indicates whether ISAPI extensions are cached in memory after first use.
Public property | ContentIndexed | The ContentIndexed property specifies whether the installed content indexer should index content under this directory tree.
Public property | CpuAppEnabled | This property specifies whether process accounting and throttling should be performed for ISAPI extensions and ASP applications. To perform process accounting on CGI applications, use the property CpuCgiEnabled.
Public property | CpuCgiEnabled | This property indicates whether IIS should perform process accounting for CGI applications. To effectively throttle CGI applications, use the CgiTimeout property. To use process accounting for ISAPI and ASP applications, use CpuAppEnabled.
Public property | CreateCgiWithNewConsole | The CreateCGIWithNewConsole property indicates whether a CGI application runs in its own console.
Public property | CreateProcessAsUser | The CreateProcessAsUser property specifies whether a CGI process is created in the system context or in the context of the requesting user.
Public property | DefaultDoc | The DefaultDoc contains one or more file names of default documents that will be returned to the client if no file name is included in the client's request. The default document will be returned if the EnableDefaultDoc flag of the DirBrowseFlags property is set to true for the directory. This property can contain a list of default document file names separated by a comma and a space, for example Default.htm, Default.asp.
Public property | DirBrowseShowDate | When set to true, date information is displayed when browsing directories.
Public property | DirBrowseShowExtension | When set to true, file name extensions are displayed when browsing directories.
Public property | DirBrowseShowLongDate | When set to true, date information is displayed in extended format when displaying directories.
Public property | DirBrowseShowSize | When set to true, file size information is displayed when browsing directories.
Public property | DirBrowseShowTime | When set to true, file time information is displayed when displaying directories.
Public property | DontLog | The DontLog property specifies whether client requests are written to the IIS log files.
Public property | EnableDefaultDoc | When set to true, the default document (specified by the DefaultDoc property) for a directory is loaded when the directory is browsed.
Public property | EnableDirBrowsing | When set to true, directory browsing is enabled.
Public property | EnableDocFooter | The EnableDocFooter property enables or disables custom footers specified by the DefaultDocFooter property.
Public property | EnableReverseDns | The EnableReverseDns property enables or disables reverse Domain Name Server (DNS) lookups for the World Wide Web Publishing Service (WWW service). Reverse lookups involve looking up the domain name when the IP address is known. Reverse DNS lookups can use significant resources and time.
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Password | Gets or sets the password for the account the task will run under. This property is needed if you specified a ServerName for a remote machine. (inherited from WebBase)
Public property | ServerName | Gets or sets the name of the server. The default value is 'localhost'. (inherited from WebBase)
Public property | ServerPort | Gets or sets the server port. (inherited from WebBase)
Public property | SsiExecDisable | The SSIExecDisable property specifies whether server-side include (SSI) #exec directives are disabled under this path.
Public property | UncAuthenticationPassthrough | The UNCAuthenticationPassthrough property enables user authentication passthrough for Universal Naming Convention (UNC) virtual root access (for authentication schemes that support delegation).
Public property | Username | Gets or sets the username for the account the task will run under. This property is needed if you specified a ServerName for a remote machine. (inherited from WebBase)
Public property | VirtualDirectoryName | Gets or sets the name of the virtual directory.
Public property | VirtualDirectoryPhysicalPath | Gets or sets the virtual directory physical path. The physical directory must exist before this task executes.
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | IISApplicationPath | Gets or sets the application path. (inherited from WebBase)
Family property | IISAppPoolPath | Gets or sets the IIS application pool path. (inherited from WebBase)
Family property | IISServerPath | Gets or sets the IIS server path. (inherited from WebBase)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

See Also

WebDirectoryCreate Class
WebDirectoryCreate Members
MSBuild.Community.Tasks.IIS Namespace


AccessExecute Property

WebDirectoryCreate.AccessExecute Property
[image]

Gets or sets a value that indicates if the file or the contents of the folder may be executed, regardless of file type.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AccessExecute As Boolean
C#
public bool AccessExecute { get; set; }
C++
public property bool AccessExecute sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_AccessExecute();

/** property */
public void set_AccessExecute(bool value);
JScript
public function get AccessExecute() : bool

public function set AccessExecute(value : bool);

Property Value

A value indicating if AccessExecute is enabled or disabled.

See Also

WebDirectoryCreate Class
WebDirectoryCreate Members
MSBuild.Community.Tasks.IIS Namespace


AccessNoRemoteExecute Property

WebDirectoryCreate.AccessNoRemoteExecute Property
[image]

A value of true indicates that remote requests to execute applications are denied; only requests from the same computer as the IIS server succeed if the AccessExecute property is set to true. You cannot set AccessNoRemoteExecute to false to enable remote requests, and set AccessExecute to false to disable local requests.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AccessNoRemoteExecute As Boolean
C#
public bool AccessNoRemoteExecute { get; set; }
C++
public property bool AccessNoRemoteExecute sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_AccessNoRemoteExecute();

/** property */
public void set_AccessNoRemoteExecute(bool value);
JScript
public function get AccessNoRemoteExecute() : bool

public function set AccessNoRemoteExecute(value : bool);

Property Value

Value indicating if AccessNoRemoteExecute is enabled or disabled.

See Also

WebDirectoryCreate Class
WebDirectoryCreate Members
MSBuild.Community.Tasks.IIS Namespace


AccessNoRemoteRead Property

WebDirectoryCreate.AccessNoRemoteRead Property
[image]

A value of true indicates that remote requests to view files are denied; only requests from the same computer as the IIS server succeed if the AccessRead property is set to true. You cannot set AccessNoRemoteRead to false to enable remote requests, and set AccessRead to false to disable local requests.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AccessNoRemoteRead As Boolean
C#
public bool AccessNoRemoteRead { get; set; }
C++
public property bool AccessNoRemoteRead sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_AccessNoRemoteRead();

/** property */
public void set_AccessNoRemoteRead(bool value);
JScript
public function get AccessNoRemoteRead() : bool

public function set AccessNoRemoteRead(value : bool);

Property Value

Value indicating if AccessNoRemoteRead is enabled or disabled.

See Also

WebDirectoryCreate Class
WebDirectoryCreate Members
MSBuild.Community.Tasks.IIS Namespace


AccessNoRemoteScript Property

WebDirectoryCreate.AccessNoRemoteScript Property
[image]

A value of true indicates that remote requests to view dynamic content are denied; only requests from the same computer as the IIS server succeed if the AccessScript property is set to true. You cannot set AccessNoRemoteScript to false to enable remote requests, and set AccessScript to false to disable local requests.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AccessNoRemoteScript As Boolean
C#
public bool AccessNoRemoteScript { get; set; }
C++
public property bool AccessNoRemoteScript sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_AccessNoRemoteScript();

/** property */
public void set_AccessNoRemoteScript(bool value);
JScript
public function get AccessNoRemoteScript() : bool

public function set AccessNoRemoteScript(value : bool);

Property Value

Value indicating if AccessNoRemoteScript is enabled or disabled.

See Also

WebDirectoryCreate Class
WebDirectoryCreate Members
MSBuild.Community.Tasks.IIS Namespace


AccessNoRemoteWrite Property

WebDirectoryCreate.AccessNoRemoteWrite Property
[image]

A value of true indicates that remote requests to create or change files are denied; only requests from the same computer as the IIS server succeed if the AccessWrite property is set to true. You cannot set AccessNoRemoteWrite to false to enable remote requests, and set AccessWrite to false to disable local requests.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AccessNoRemoteWrite As Boolean
C#
public bool AccessNoRemoteWrite { get; set; }
C++
public property bool AccessNoRemoteWrite sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_AccessNoRemoteWrite();

/** property */
public void set_AccessNoRemoteWrite(bool value);
JScript
public function get AccessNoRemoteWrite() : bool

public function set AccessNoRemoteWrite(value : bool);

Property Value

Value indicating if AccessNoRemoteWrite is enabled or disabled.

See Also

WebDirectoryCreate Class
WebDirectoryCreate Members
MSBuild.Community.Tasks.IIS Namespace


AccessRead Property

WebDirectoryCreate.AccessRead Property
[image]

A value of true indicates that the file or the contents of the folder may be read through Microsoft Internet Explorer.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AccessRead As Boolean
C#
public bool AccessRead { get; set; }
C++
public property bool AccessRead sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_AccessRead();

/** property */
public void set_AccessRead(bool value);
JScript
public function get AccessRead() : bool

public function set AccessRead(value : bool);

Property Value

Value indicating if AccessRead is enabled or disabled.

See Also

WebDirectoryCreate Class
WebDirectoryCreate Members
MSBuild.Community.Tasks.IIS Namespace


AccessScript Property

WebDirectoryCreate.AccessScript Property
[image]

A value of true indicates that the file or the contents of the folder may be executed if they are script files or static content. A value of false only allows static files, such as HTML files, to be served.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AccessScript As Boolean
C#
public bool AccessScript { get; set; }
C++
public property bool AccessScript sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_AccessScript();

/** property */
public void set_AccessScript(bool value);
JScript
public function get AccessScript() : bool

public function set AccessScript(value : bool);

Property Value

Value indicating if AccessScript is enabled or disabled.

See Also

WebDirectoryCreate Class
WebDirectoryCreate Members
MSBuild.Community.Tasks.IIS Namespace


AccessSource Property

WebDirectoryCreate.AccessSource Property
[image]

A value of true indicates that users are allowed to access source code if either Read or Write permissions are set. Source code includes scripts in Microsoft ® Active Server Pages (ASP) applications.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AccessSource As Boolean
C#
public bool AccessSource { get; set; }
C++
public property bool AccessSource sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_AccessSource();

/** property */
public void set_AccessSource(bool value);
JScript
public function get AccessSource() : bool

public function set AccessSource(value : bool);

Property Value

Value indicating if AccessSource is enabled or disabled.

See Also

WebDirectoryCreate Class
WebDirectoryCreate Members
MSBuild.Community.Tasks.IIS Namespace


AccessSsl Property

WebDirectoryCreate.AccessSsl Property
[image]

A value of true indicates that file access requires SSL file permission processing, with or without a client certificate.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AccessSsl As Boolean
C#
public bool AccessSsl { get; set; }
C++
public property bool AccessSsl sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_AccessSsl();

/** property */
public void set_AccessSsl(bool value);
JScript
public function get AccessSsl() : bool

public function set AccessSsl(value : bool);

Property Value

Value indicating if AccessSsl is enabled or disabled.

See Also

WebDirectoryCreate Class
WebDirectoryCreate Members
MSBuild.Community.Tasks.IIS Namespace


AccessSsl128 Property

WebDirectoryCreate.AccessSsl128 Property
[image]

A value of true indicates that file access requires SSL file permission processing with a minimum key size of 128 bits, with or without a client certificate.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AccessSsl128 As Boolean
C#
public bool AccessSsl128 { get; set; }
C++
public property bool AccessSsl128 sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_AccessSsl128();

/** property */
public void set_AccessSsl128(bool value);
JScript
public function get AccessSsl128() : bool

public function set AccessSsl128(value : bool);

Property Value

Value indicating if AccessSsl128 is enabled or disabled.

See Also

WebDirectoryCreate Class
WebDirectoryCreate Members
MSBuild.Community.Tasks.IIS Namespace


AccessSslMapCert Property

WebDirectoryCreate.AccessSslMapCert Property
[image]

A value of true indicates that SSL file permission processing maps a client certificate to a Microsoft Windows ® operating system user-account. The AccessSslNegotiateCert property must also be set to true for the mapping to occur.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AccessSslMapCert As Boolean
C#
public bool AccessSslMapCert { get; set; }
C++
public property bool AccessSslMapCert sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_AccessSslMapCert();

/** property */
public void set_AccessSslMapCert(bool value);
JScript
public function get AccessSslMapCert() : bool

public function set AccessSslMapCert(value : bool);

Property Value

Value indicating if AccessSslMapCert is enabled or disabled.

See Also

WebDirectoryCreate Class
WebDirectoryCreate Members
MSBuild.Community.Tasks.IIS Namespace


AccessSslNegotiateCert Property

WebDirectoryCreate.AccessSslNegotiateCert Property
[image]

A value of true indicates that SSL file access processing requests a certificate from the client. A value of false indicates that access continues if the client does not have a certificate. Some versions of Internet Explorer will close the connection if the server requests a certificate and a certificate is not available (even if AccessSslRequireCert is also set to true).

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AccessSslNegotiateCert As Boolean
C#
public bool AccessSslNegotiateCert { get; set; }
C++
public property bool AccessSslNegotiateCert sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_AccessSslNegotiateCert();

/** property */
public void set_AccessSslNegotiateCert(bool value);
JScript
public function get AccessSslNegotiateCert() : bool

public function set AccessSslNegotiateCert(value : bool);

Property Value

Value indicating if AccessSslNegotiateCert is enabled or disabled.

See Also

WebDirectoryCreate Class
WebDirectoryCreate Members
MSBuild.Community.Tasks.IIS Namespace


AccessSslRequireCert Property

WebDirectoryCreate.AccessSslRequireCert Property
[image]

A value of true indicates that SSL file access processing requests a certificate from the client. If the client provides no certificate, the connection is closed. AccessSslNegotiateCert must also be set to true when using AccessSSLRequireCert.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AccessSslRequireCert As Boolean
C#
public bool AccessSslRequireCert { get; set; }
C++
public property bool AccessSslRequireCert sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_AccessSslRequireCert();

/** property */
public void set_AccessSslRequireCert(bool value);
JScript
public function get AccessSslRequireCert() : bool

public function set AccessSslRequireCert(value : bool);

Property Value

Value indicating if AccessSslRequireCert is enabled or disabled.

See Also

WebDirectoryCreate Class
WebDirectoryCreate Members
MSBuild.Community.Tasks.IIS Namespace


AccessWrite Property

WebDirectoryCreate.AccessWrite Property
[image]

A value of true indicates that users are allowed to upload files and their associated properties to the enabled directory on your server or to change content in a Write-enabled file. Write can be implemented only with a browser that supports the PUT feature of the HTTP 1.1 protocol standard.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AccessWrite As Boolean
C#
public bool AccessWrite { get; set; }
C++
public property bool AccessWrite sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_AccessWrite();

/** property */
public void set_AccessWrite(bool value);
JScript
public function get AccessWrite() : bool

public function set AccessWrite(value : bool);

Property Value

Value indicating if AccessWrite is enabled or disabled.

See Also

WebDirectoryCreate Class
WebDirectoryCreate Members
MSBuild.Community.Tasks.IIS Namespace


AnonymousPasswordSync Property

WebDirectoryCreate.AnonymousPasswordSync Property
[image]

The AnonymousPasswordSync property indicates whether IIS should handle the user password for anonymous users attempting to access resources.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AnonymousPasswordSync As Boolean
C#
public bool AnonymousPasswordSync { get; set; }
C++
public property bool AnonymousPasswordSync sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_AnonymousPasswordSync();

/** property */
public void set_AnonymousPasswordSync(bool value);
JScript
public function get AnonymousPasswordSync() : bool

public function set AnonymousPasswordSync(value : bool);

Property Value

Value indicating if AnonymousPasswordSync is enabled or disabled.

See Also

WebDirectoryCreate Class
WebDirectoryCreate Members
MSBuild.Community.Tasks.IIS Namespace


AppAllowClientDebug Property

WebDirectoryCreate.AppAllowClientDebug Property
[image]

The AppAllowClientDebug property specifies whether ASP client-side debugging is enabled. This property is independent of AppAllowDebugging, which applies to server-side debugging.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AppAllowClientDebug As Boolean
C#
public bool AppAllowClientDebug { get; set; }
C++
public property bool AppAllowClientDebug sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_AppAllowClientDebug();

/** property */
public void set_AppAllowClientDebug(bool value);
JScript
public function get AppAllowClientDebug() : bool

public function set AppAllowClientDebug(value : bool);

Property Value

Value indicating if AppAllowClientDebug is enabled or disabled.

See Also

WebDirectoryCreate Class
WebDirectoryCreate Members
MSBuild.Community.Tasks.IIS Namespace


AppAllowDebugging Property

WebDirectoryCreate.AppAllowDebugging Property
[image]

The AppAllowDebugging property specifies whether ASP debugging is enabled on the server. This property is independent of the AppAllowClientDebug property, which applies to client-side debugging.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AppAllowDebugging As Boolean
C#
public bool AppAllowDebugging { get; set; }
C++
public property bool AppAllowDebugging sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_AppAllowDebugging();

/** property */
public void set_AppAllowDebugging(bool value);
JScript
public function get AppAllowDebugging() : bool

public function set AppAllowDebugging(value : bool);

Property Value

Value indicating if AppAllowDebugging is enabled or disabled.

See Also

WebDirectoryCreate Class
WebDirectoryCreate Members
MSBuild.Community.Tasks.IIS Namespace


AspAllowSessionState Property

WebDirectoryCreate.AspAllowSessionState Property
[image]

The AspAllowSessionState property enables session state persistence for the ASP application.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AspAllowSessionState As Boolean
C#
public bool AspAllowSessionState { get; set; }
C++
public property bool AspAllowSessionState sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_AspAllowSessionState();

/** property */
public void set_AspAllowSessionState(bool value);
JScript
public function get AspAllowSessionState() : bool

public function set AspAllowSessionState(value : bool);

Property Value

Value indicating if the AspAllowSessionState is enabled or disabled.

See Also

WebDirectoryCreate Class
WebDirectoryCreate Members
MSBuild.Community.Tasks.IIS Namespace


AspBufferingOn Property

WebDirectoryCreate.AspBufferingOn Property
[image]

The AspBufferingOn property specifies whether output from an ASP application will be buffered.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AspBufferingOn As Boolean
C#
public bool AspBufferingOn { get; set; }
C++
public property bool AspBufferingOn sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_AspBufferingOn();

/** property */
public void set_AspBufferingOn(bool value);
JScript
public function get AspBufferingOn() : bool

public function set AspBufferingOn(value : bool);

Property Value

Value indicating if the AspBufferingOn is enabled or disabled.

See Also

WebDirectoryCreate Class
WebDirectoryCreate Members
MSBuild.Community.Tasks.IIS Namespace


AspEnableApplicationRestart Property

WebDirectoryCreate.AspEnableApplicationRestart Property
[image]

The AspEnableApplicationRestart determines whether an ASP application can be automatically restarted. When changes are made to Global.asa or metabase properties that affect an application, the application will not restart unless the AspEnableApplicationRestart property is set to true.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AspEnableApplicationRestart As Boolean
C#
public bool AspEnableApplicationRestart { get; set; }
C++
public property bool AspEnableApplicationRestart sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_AspEnableApplicationRestart();

/** property */
public void set_AspEnableApplicationRestart(bool value);
JScript
public function get AspEnableApplicationRestart() : bool

public function set AspEnableApplicationRestart(value : bool);

Property Value

Value indicating if AspEnableApplicationRestart is enabled or disabled.

See Also

WebDirectoryCreate Class
WebDirectoryCreate Members
MSBuild.Community.Tasks.IIS Namespace


AspEnableAspHtmlFallback Property

WebDirectoryCreate.AspEnableAspHtmlFallback Property
[image]

The AspEnableAspHtmlFallback property controls the behavior of ASP when a new request is to be rejected due to a full request queue.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AspEnableAspHtmlFallback As Boolean
C#
public bool AspEnableAspHtmlFallback { get; set; }
C++
public property bool AspEnableAspHtmlFallback sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_AspEnableAspHtmlFallback();

/** property */
public void set_AspEnableAspHtmlFallback(bool value);
JScript
public function get AspEnableAspHtmlFallback() : bool

public function set AspEnableAspHtmlFallback(value : bool);

Property Value

Value indicating if AspEnableAspHtmlFallback is enabled or disabled.

See Also

WebDirectoryCreate Class
WebDirectoryCreate Members
MSBuild.Community.Tasks.IIS Namespace


AspEnableChunkedEncoding Property

WebDirectoryCreate.AspEnableChunkedEncoding Property
[image]

The AspEnableChunkedEncoding property specifies whether HTTP 1.1 chunked transfer encoding is enabled for the World Wide Web Publishing Service (WWW service).

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AspEnableChunkedEncoding As Boolean
C#
public bool AspEnableChunkedEncoding { get; set; }
C++
public property bool AspEnableChunkedEncoding sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_AspEnableChunkedEncoding();

/** property */
public void set_AspEnableChunkedEncoding(bool value);
JScript
public function get AspEnableChunkedEncoding() : bool

public function set AspEnableChunkedEncoding(value : bool);

Property Value

Value indicating if AspEnableChunkedEncoding is enabled or disabled.

See Also

WebDirectoryCreate Class
WebDirectoryCreate Members
MSBuild.Community.Tasks.IIS Namespace


AspEnableParentPaths Property

WebDirectoryCreate.AspEnableParentPaths Property
[image]

The AspEnableParentPaths property specifies whether an ASP page allows paths relative to the current directory (using the ..\ notation) or above the current directory.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AspEnableParentPaths As Boolean
C#
public bool AspEnableParentPaths { get; set; }
C++
public property bool AspEnableParentPaths sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_AspEnableParentPaths();

/** property */
public void set_AspEnableParentPaths(bool value);
JScript
public function get AspEnableParentPaths() : bool

public function set AspEnableParentPaths(value : bool);

Property Value

Value indicating if AspEnableParentPaths is enabled or disabled.

See Also

WebDirectoryCreate Class
WebDirectoryCreate Members
MSBuild.Community.Tasks.IIS Namespace


AspEnableTypelibCache Property

WebDirectoryCreate.AspEnableTypelibCache Property
[image]

The AspEnableTypelibCache property specifies whether type libraries are cached on the server. The World Wide Web Publishing Service (WWW service) setting for this property is applicable to all in-process and pooled out-of-process application nodes, at all levels. Metabase settings at the Web server level or lower are ignored for in-process and pooled out-of-process applications. However, settings at the Web server level or lower are used if that node is an isolated out-of-process application.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AspEnableTypelibCache As Boolean
C#
public bool AspEnableTypelibCache { get; set; }
C++
public property bool AspEnableTypelibCache sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_AspEnableTypelibCache();

/** property */
public void set_AspEnableTypelibCache(bool value);
JScript
public function get AspEnableTypelibCache() : bool

public function set AspEnableTypelibCache(value : bool);

Property Value

Value indicating if AspEnableTypelibCache is enabled or disabled.

See Also

WebDirectoryCreate Class
WebDirectoryCreate Members
MSBuild.Community.Tasks.IIS Namespace


AspErrorsToNTLog Property

WebDirectoryCreate.AspErrorsToNTLog Property
[image]

The AspErrorsToNTLog property specifies which ASP errors are written to the Windows event log. ASP errors are written to the client browser and to the IIS log files by default.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AspErrorsToNTLog As Boolean
C#
public bool AspErrorsToNTLog { get; set; }
C++
public property bool AspErrorsToNTLog sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_AspErrorsToNTLog();

/** property */
public void set_AspErrorsToNTLog(bool value);
JScript
public function get AspErrorsToNTLog() : bool

public function set AspErrorsToNTLog(value : bool);

Property Value

Value indicating if AspErrorsToNTLog is enabled or disabled.

See Also

WebDirectoryCreate Class
WebDirectoryCreate Members
MSBuild.Community.Tasks.IIS Namespace


AspExceptionCatchEnable Property

WebDirectoryCreate.AspExceptionCatchEnable Property
[image]

The AspExceptionCatchEnable property specifies whether ASP pages trap exceptions thrown by components.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AspExceptionCatchEnable As Boolean
C#
public bool AspExceptionCatchEnable { get; set; }
C++
public property bool AspExceptionCatchEnable sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_AspExceptionCatchEnable();

/** property */
public void set_AspExceptionCatchEnable(bool value);
JScript
public function get AspExceptionCatchEnable() : bool

public function set AspExceptionCatchEnable(value : bool);

Property Value

Value indicating if AspExceptionCatchEnable is enabled or disabled.

See Also

WebDirectoryCreate Class
WebDirectoryCreate Members
MSBuild.Community.Tasks.IIS Namespace


AspLogErrorRequests Property

WebDirectoryCreate.AspLogErrorRequests Property
[image]

The AspLogErrorRequests property controls whether the Web server writes ASP errors to the application section of the Windows event log. ASP errors are written to the client browser and to the IIS log files by default.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AspLogErrorRequests As Boolean
C#
public bool AspLogErrorRequests { get; set; }
C++
public property bool AspLogErrorRequests sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_AspLogErrorRequests();

/** property */
public void set_AspLogErrorRequests(bool value);
JScript
public function get AspLogErrorRequests() : bool

public function set AspLogErrorRequests(value : bool);

Property Value

Value indicating if AspLogErrorRequests is enabled or disabled.

See Also

WebDirectoryCreate Class
WebDirectoryCreate Members
MSBuild.Community.Tasks.IIS Namespace


AspScriptErrorMessage Property

WebDirectoryCreate.AspScriptErrorMessage Property
[image]

The AspScriptErrorMessage property specifies the error message to send to the browser if specific debugging errors are not sent to the client (if AspScriptErrorSentToBrowser is set to false).

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AspScriptErrorMessage As String
C#
public string AspScriptErrorMessage { get; set; }
C++
public property string AspScriptErrorMessage sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_AspScriptErrorMessage();

/** property */
public void set_AspScriptErrorMessage(string value);
JScript
public function get AspScriptErrorMessage() : String

public function set AspScriptErrorMessage(value : String);

Property Value

Value indicating if AspScriptErrorMessage is enabled or disabled.

See Also

WebDirectoryCreate Class
WebDirectoryCreate Members
MSBuild.Community.Tasks.IIS Namespace


AspScriptErrorSentToBrowser Property

WebDirectoryCreate.AspScriptErrorSentToBrowser Property
[image]

The AspScriptErrorSentToBrowser property specifies whether the Web server writes debugging specifics (file name, error, line number, description) to the client browser, in addition to logging them to the Windows Event Log. The AspScriptErrorMessage property provides the error message to be sent if this property is set to false.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AspScriptErrorSentToBrowser As Boolean
C#
public bool AspScriptErrorSentToBrowser { get; set; }
C++
public property bool AspScriptErrorSentToBrowser sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_AspScriptErrorSentToBrowser();

/** property */
public void set_AspScriptErrorSentToBrowser(bool value);
JScript
public function get AspScriptErrorSentToBrowser() : bool

public function set AspScriptErrorSentToBrowser(value : bool);

Property Value

Value indicating if AspScriptErrorSentToBrowser is enabled or disabled.

See Also

WebDirectoryCreate Class
WebDirectoryCreate Members
MSBuild.Community.Tasks.IIS Namespace


AspTrackThreadingModel Property

WebDirectoryCreate.AspTrackThreadingModel Property
[image]

The AspTrackThreadingModel property specifies whether IIS checks the threading model of any components (COM objects) that your application creates. The preferred setting of this metabase property is false.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AspTrackThreadingModel As Boolean
C#
public bool AspTrackThreadingModel { get; set; }
C++
public property bool AspTrackThreadingModel sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_AspTrackThreadingModel();

/** property */
public void set_AspTrackThreadingModel(bool value);
JScript
public function get AspTrackThreadingModel() : bool

public function set AspTrackThreadingModel(value : bool);

Property Value

Value indicating if AspTrackThreadingModel is enabled or disabled.

See Also

WebDirectoryCreate Class
WebDirectoryCreate Members
MSBuild.Community.Tasks.IIS Namespace


AuthAnonymous Property

WebDirectoryCreate.AuthAnonymous Property
[image]

Specifies Anonymous authentication as one of the possible Windows authentication schemes returned to clients as being available.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AuthAnonymous As Boolean
C#
public bool AuthAnonymous { get; set; }
C++
public property bool AuthAnonymous sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_AuthAnonymous();

/** property */
public void set_AuthAnonymous(bool value);
JScript
public function get AuthAnonymous() : bool

public function set AuthAnonymous(value : bool);

Property Value

Value indicating if AuthAnonymous is enabled or disabled.

See Also

WebDirectoryCreate Class
WebDirectoryCreate Members
MSBuild.Community.Tasks.IIS Namespace


AuthBasic Property

WebDirectoryCreate.AuthBasic Property
[image]

Specifies Basic authentication as one of the possible Windows authentication schemes returned to clients as being available.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AuthBasic As Boolean
C#
public bool AuthBasic { get; set; }
C++
public property bool AuthBasic sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_AuthBasic();

/** property */
public void set_AuthBasic(bool value);
JScript
public function get AuthBasic() : bool

public function set AuthBasic(value : bool);

Property Value

Value indicating if AuthBasic is enabled or disabled.

See Also

WebDirectoryCreate Class
WebDirectoryCreate Members
MSBuild.Community.Tasks.IIS Namespace


AuthNtlm Property

WebDirectoryCreate.AuthNtlm Property
[image]

Specifies Integrated Windows authentication (also known as Challenge/Response or NTLM authentication) as one of the possible Windows authentication schemes returned to clients as being available.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AuthNtlm As Boolean
C#
public bool AuthNtlm { get; set; }
C++
public property bool AuthNtlm sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_AuthNtlm();

/** property */
public void set_AuthNtlm(bool value);
JScript
public function get AuthNtlm() : bool

public function set AuthNtlm(value : bool);

Property Value

Value indicating if AuthNtlm is enabled or disabled.

See Also

WebDirectoryCreate Class
WebDirectoryCreate Members
MSBuild.Community.Tasks.IIS Namespace


AuthPersistSingleRequest Property

WebDirectoryCreate.AuthPersistSingleRequest Property
[image]

Setting this flag to true specifies that authentication persists only for a single request on a connection. IIS resets the authentication at the end of each request, and forces re-authentication on the next request of the session.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AuthPersistSingleRequest As Boolean
C#
public bool AuthPersistSingleRequest { get; set; }
C++
public property bool AuthPersistSingleRequest sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_AuthPersistSingleRequest();

/** property */
public void set_AuthPersistSingleRequest(bool value);
JScript
public function get AuthPersistSingleRequest() : bool

public function set AuthPersistSingleRequest(value : bool);

Property Value

Value indicating if AuthPersistSingleRequest is enabled or disabled.

See Also

WebDirectoryCreate Class
WebDirectoryCreate Members
MSBuild.Community.Tasks.IIS Namespace


AuthPersistSingleRequestAlwaysIfProxy Property

WebDirectoryCreate.AuthPersistSingleRequestAlwaysIfProxy Property
See Also
[image]

Setting this flag to true specifies that authentication is valid for a single request if by proxy. IIS will reset the authentication at the end of the request and force re-authentication on the next request if the current authenticated request is by proxy of any type.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AuthPersistSingleRequestAlwaysIfProxy As Boolean
C#
public bool AuthPersistSingleRequestAlwaysIfProxy { get; set; }
C++
public property bool AuthPersistSingleRequestAlwaysIfProxy sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_AuthPersistSingleRequestAlwaysIfProxy();

/** property */
public void set_AuthPersistSingleRequestAlwaysIfProxy(bool value);
JScript
public function get AuthPersistSingleRequestAlwaysIfProxy() : bool

public function set AuthPersistSingleRequestAlwaysIfProxy(value : bool);

Property Value

Value indicating if AuthPersistSingleRequestAlwaysIfProxy is enabled or disabled.

See Also

WebDirectoryCreate Class
WebDirectoryCreate Members
MSBuild.Community.Tasks.IIS Namespace


AuthPersistSingleRequestIfProxy Property

WebDirectoryCreate.AuthPersistSingleRequestIfProxy Property
[image]

Setting this flag to true specifies authentication will persist only across single requests on a connection if the connection is by proxy. IIS will reset the authentication at the end of the request if the current authenticated request is by proxy and it is not the special case where IIS is running MSPROXY.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AuthPersistSingleRequestIfProxy As Boolean
C#
public bool AuthPersistSingleRequestIfProxy { get; set; }
C++
public property bool AuthPersistSingleRequestIfProxy sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_AuthPersistSingleRequestIfProxy();

/** property */
public void set_AuthPersistSingleRequestIfProxy(bool value);
JScript
public function get AuthPersistSingleRequestIfProxy() : bool

public function set AuthPersistSingleRequestIfProxy(value : bool);

Property Value

Value indicating if AuthPersistSingleRequestIfProxy is enabled or disabled.

See Also

WebDirectoryCreate Class
WebDirectoryCreate Members
MSBuild.Community.Tasks.IIS Namespace


CacheControlNoCache Property

WebDirectoryCreate.CacheControlNoCache Property
[image]

The CacheControlNoCache property specifies the HTTP 1.1 directive to prevent caching of content.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property CacheControlNoCache As Boolean
C#
public bool CacheControlNoCache { get; set; }
C++
public property bool CacheControlNoCache sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_CacheControlNoCache();

/** property */
public void set_CacheControlNoCache(bool value);
JScript
public function get CacheControlNoCache() : bool

public function set CacheControlNoCache(value : bool);

Property Value

Value indicating if CacheControlNoCache is enabled or disabled.

See Also

WebDirectoryCreate Class
WebDirectoryCreate Members
MSBuild.Community.Tasks.IIS Namespace


CacheIsapi Property

WebDirectoryCreate.CacheIsapi Property
[image]

The CacheISAPI property indicates whether ISAPI extensions are cached in memory after first use.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property CacheIsapi As Boolean
C#
public bool CacheIsapi { get; set; }
C++
public property bool CacheIsapi sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_CacheIsapi();

/** property */
public void set_CacheIsapi(bool value);
JScript
public function get CacheIsapi() : bool

public function set CacheIsapi(value : bool);

Property Value

Value indicating if CacheIsapi is enabled or disabled.

See Also

WebDirectoryCreate Class
WebDirectoryCreate Members
MSBuild.Community.Tasks.IIS Namespace


ContentIndexed Property

WebDirectoryCreate.ContentIndexed Property
[image]

The ContentIndexed property specifies whether the installed content indexer should index content under this directory tree.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property ContentIndexed As Boolean
C#
public bool ContentIndexed { get; set; }
C++
public property bool ContentIndexed sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_ContentIndexed();

/** property */
public void set_ContentIndexed(bool value);
JScript
public function get ContentIndexed() : bool

public function set ContentIndexed(value : bool);

Property Value

Value indicating if ContentIndexed is enabled or disabled.

See Also

WebDirectoryCreate Class
WebDirectoryCreate Members
MSBuild.Community.Tasks.IIS Namespace


CpuAppEnabled Property

WebDirectoryCreate.CpuAppEnabled Property
[image]

This property specifies whether process accounting and throttling should be performed for ISAPI extensions and ASP applications. To perform process accounting on CGI applications, use the property CpuCgiEnabled.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property CpuAppEnabled As Boolean
C#
public bool CpuAppEnabled { get; set; }
C++
public property bool CpuAppEnabled sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_CpuAppEnabled();

/** property */
public void set_CpuAppEnabled(bool value);
JScript
public function get CpuAppEnabled() : bool

public function set CpuAppEnabled(value : bool);

Property Value

Value indicating if CpuAppEnabled is enabled or disabled.

See Also

WebDirectoryCreate Class
WebDirectoryCreate Members
MSBuild.Community.Tasks.IIS Namespace


CpuCgiEnabled Property

WebDirectoryCreate.CpuCgiEnabled Property
[image]

This property indicates whether IIS should perform process accounting for CGI applications. To effectively throttle CGI applications, use the CgiTimeout property. To use process accounting for ISAPI and ASP applications, use CpuAppEnabled.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property CpuCgiEnabled As Boolean
C#
public bool CpuCgiEnabled { get; set; }
C++
public property bool CpuCgiEnabled sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_CpuCgiEnabled();

/** property */
public void set_CpuCgiEnabled(bool value);
JScript
public function get CpuCgiEnabled() : bool

public function set CpuCgiEnabled(value : bool);

Property Value

Value indicating if CpuCgiEnabled is enabled or disabled.

See Also

WebDirectoryCreate Class
WebDirectoryCreate Members
MSBuild.Community.Tasks.IIS Namespace


CreateCgiWithNewConsole Property

WebDirectoryCreate.CreateCgiWithNewConsole Property
[image]

The CreateCGIWithNewConsole property indicates whether a CGI application runs in its own console.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property CreateCgiWithNewConsole As Boolean
C#
public bool CreateCgiWithNewConsole { get; set; }
C++
public property bool CreateCgiWithNewConsole sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_CreateCgiWithNewConsole();

/** property */
public void set_CreateCgiWithNewConsole(bool value);
JScript
public function get CreateCgiWithNewConsole() : bool

public function set CreateCgiWithNewConsole(value : bool);

Property Value

Value indicating if CreateCgiWithNewConsole is enabled or disabled.

See Also

WebDirectoryCreate Class
WebDirectoryCreate Members
MSBuild.Community.Tasks.IIS Namespace


CreateProcessAsUser Property

WebDirectoryCreate.CreateProcessAsUser Property
[image]

The CreateProcessAsUser property specifies whether a CGI process is created in the system context or in the context of the requesting user.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property CreateProcessAsUser As Boolean
C#
public bool CreateProcessAsUser { get; set; }
C++
public property bool CreateProcessAsUser sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_CreateProcessAsUser();

/** property */
public void set_CreateProcessAsUser(bool value);
JScript
public function get CreateProcessAsUser() : bool

public function set CreateProcessAsUser(value : bool);

Property Value

Value indicating if CreateProcessAsUser is enabled or disabled.

See Also

WebDirectoryCreate Class
WebDirectoryCreate Members
MSBuild.Community.Tasks.IIS Namespace


DefaultDoc Property

WebDirectoryCreate.DefaultDoc Property
[image]

The DefaultDoc contains one or more file names of default documents that will be returned to the client if no file name is included in the client's request. The default document will be returned if the EnableDefaultDoc flag of the DirBrowseFlags property is set to true for the directory. This property can contain a list of default document file names separated by a comma and a space, for example Default.htm, Default.asp.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property DefaultDoc As String
C#
public string DefaultDoc { get; set; }
C++
public property string DefaultDoc sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_DefaultDoc();

/** property */
public void set_DefaultDoc(string value);
JScript
public function get DefaultDoc() : String

public function set DefaultDoc(value : String);

Property Value

Listing of the default documents for the web application.

See Also

WebDirectoryCreate Class
WebDirectoryCreate Members
MSBuild.Community.Tasks.IIS Namespace


DirBrowseShowDate Property

WebDirectoryCreate.DirBrowseShowDate Property
[image]

When set to true, date information is displayed when browsing directories.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property DirBrowseShowDate As Boolean
C#
public bool DirBrowseShowDate { get; set; }
C++
public property bool DirBrowseShowDate sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_DirBrowseShowDate();

/** property */
public void set_DirBrowseShowDate(bool value);
JScript
public function get DirBrowseShowDate() : bool

public function set DirBrowseShowDate(value : bool);

Property Value

Value indicating if DirBrowseShowDate is enabled or disabled.

See Also

WebDirectoryCreate Class
WebDirectoryCreate Members
MSBuild.Community.Tasks.IIS Namespace


DirBrowseShowExtension Property

WebDirectoryCreate.DirBrowseShowExtension Property
[image]

When set to true, file name extensions are displayed when browsing directories.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property DirBrowseShowExtension As Boolean
C#
public bool DirBrowseShowExtension { get; set; }
C++
public property bool DirBrowseShowExtension sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_DirBrowseShowExtension();

/** property */
public void set_DirBrowseShowExtension(bool value);
JScript
public function get DirBrowseShowExtension() : bool

public function set DirBrowseShowExtension(value : bool);

Property Value

Value indicating if DirBrowseShowExtension is enabled or disabled.

See Also

WebDirectoryCreate Class
WebDirectoryCreate Members
MSBuild.Community.Tasks.IIS Namespace


DirBrowseShowLongDate Property

WebDirectoryCreate.DirBrowseShowLongDate Property
[image]

When set to true, date information is displayed in extended format when displaying directories.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property DirBrowseShowLongDate As Boolean
C#
public bool DirBrowseShowLongDate { get; set; }
C++
public property bool DirBrowseShowLongDate sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_DirBrowseShowLongDate();

/** property */
public void set_DirBrowseShowLongDate(bool value);
JScript
public function get DirBrowseShowLongDate() : bool

public function set DirBrowseShowLongDate(value : bool);

Property Value

Value indicating if DirBrowseShowLongDate is enabled or disabled.

See Also

WebDirectoryCreate Class
WebDirectoryCreate Members
MSBuild.Community.Tasks.IIS Namespace


DirBrowseShowSize Property

WebDirectoryCreate.DirBrowseShowSize Property
[image]

When set to true, file size information is displayed when browsing directories.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property DirBrowseShowSize As Boolean
C#
public bool DirBrowseShowSize { get; set; }
C++
public property bool DirBrowseShowSize sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_DirBrowseShowSize();

/** property */
public void set_DirBrowseShowSize(bool value);
JScript
public function get DirBrowseShowSize() : bool

public function set DirBrowseShowSize(value : bool);

Property Value

Value indicating if DirBrowseShowSize is enabled or disabled.

See Also

WebDirectoryCreate Class
WebDirectoryCreate Members
MSBuild.Community.Tasks.IIS Namespace


DirBrowseShowTime Property

WebDirectoryCreate.DirBrowseShowTime Property
[image]

When set to true, file time information is displayed when displaying directories.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property DirBrowseShowTime As Boolean
C#
public bool DirBrowseShowTime { get; set; }
C++
public property bool DirBrowseShowTime sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_DirBrowseShowTime();

/** property */
public void set_DirBrowseShowTime(bool value);
JScript
public function get DirBrowseShowTime() : bool

public function set DirBrowseShowTime(value : bool);

Property Value

Value indicating if DirBrowseShowTime is enabled or disabled.

See Also

WebDirectoryCreate Class
WebDirectoryCreate Members
MSBuild.Community.Tasks.IIS Namespace


DontLog Property

WebDirectoryCreate.DontLog Property
[image]

The DontLog property specifies whether client requests are written to the IIS log files.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property DontLog As Boolean
C#
public bool DontLog { get; set; }
C++
public property bool DontLog sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_DontLog();

/** property */
public void set_DontLog(bool value);
JScript
public function get DontLog() : bool

public function set DontLog(value : bool);

Property Value

Value indicating if DontLog is enabled or disabled.

See Also

WebDirectoryCreate Class
WebDirectoryCreate Members
MSBuild.Community.Tasks.IIS Namespace


EnableDefaultDoc Property

WebDirectoryCreate.EnableDefaultDoc Property
[image]

When set to true, the default document (specified by the DefaultDoc property) for a directory is loaded when the directory is browsed.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property EnableDefaultDoc As Boolean
C#
public bool EnableDefaultDoc { get; set; }
C++
public property bool EnableDefaultDoc sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_EnableDefaultDoc();

/** property */
public void set_EnableDefaultDoc(bool value);
JScript
public function get EnableDefaultDoc() : bool

public function set EnableDefaultDoc(value : bool);

Property Value

Value indicating if EnableDefaultDoc is enabled or disabled.

See Also

WebDirectoryCreate Class
WebDirectoryCreate Members
MSBuild.Community.Tasks.IIS Namespace


EnableDirBrowsing Property

WebDirectoryCreate.EnableDirBrowsing Property
[image]

When set to true, directory browsing is enabled.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property EnableDirBrowsing As Boolean
C#
public bool EnableDirBrowsing { get; set; }
C++
public property bool EnableDirBrowsing sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_EnableDirBrowsing();

/** property */
public void set_EnableDirBrowsing(bool value);
JScript
public function get EnableDirBrowsing() : bool

public function set EnableDirBrowsing(value : bool);

Property Value

Value indicating if EnableDirBrowsing is enabled or disabled.

See Also

WebDirectoryCreate Class
WebDirectoryCreate Members
MSBuild.Community.Tasks.IIS Namespace


EnableDocFooter Property

WebDirectoryCreate.EnableDocFooter Property
[image]

The EnableDocFooter property enables or disables custom footers specified by the DefaultDocFooter property.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property EnableDocFooter As Boolean
C#
public bool EnableDocFooter { get; set; }
C++
public property bool EnableDocFooter sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_EnableDocFooter();

/** property */
public void set_EnableDocFooter(bool value);
JScript
public function get EnableDocFooter() : bool

public function set EnableDocFooter(value : bool);

Property Value

Value indicating if EnableDocFooter is enabled or disabled.

See Also

WebDirectoryCreate Class
WebDirectoryCreate Members
MSBuild.Community.Tasks.IIS Namespace


EnableReverseDns Property

WebDirectoryCreate.EnableReverseDns Property
[image]

The EnableReverseDns property enables or disables reverse Domain Name Server (DNS) lookups for the World Wide Web Publishing Service (WWW service). Reverse lookups involve looking up the domain name when the IP address is known. Reverse DNS lookups can use significant resources and time.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property EnableReverseDns As Boolean
C#
public bool EnableReverseDns { get; set; }
C++
public property bool EnableReverseDns sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_EnableReverseDns();

/** property */
public void set_EnableReverseDns(bool value);
JScript
public function get EnableReverseDns() : bool

public function set EnableReverseDns(value : bool);

Property Value

Value indicating if EnableReverseDns is enabled or disabled.

See Also

WebDirectoryCreate Class
WebDirectoryCreate Members
MSBuild.Community.Tasks.IIS Namespace


SsiExecDisable Property

WebDirectoryCreate.SsiExecDisable Property
[image]

The SSIExecDisable property specifies whether server-side include (SSI) #exec directives are disabled under this path.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property SsiExecDisable As Boolean
C#
public bool SsiExecDisable { get; set; }
C++
public property bool SsiExecDisable sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_SsiExecDisable();

/** property */
public void set_SsiExecDisable(bool value);
JScript
public function get SsiExecDisable() : bool

public function set SsiExecDisable(value : bool);

Property Value

Value indicating if SsiExecDisable is enabled or disabled.

See Also

WebDirectoryCreate Class
WebDirectoryCreate Members
MSBuild.Community.Tasks.IIS Namespace


UncAuthenticationPassthrough Property

WebDirectoryCreate.UncAuthenticationPassthrough Property
[image]

The UNCAuthenticationPassthrough property enables user authentication passthrough for Universal Naming Convention (UNC) virtual root access (for authentication schemes that support delegation).

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property UncAuthenticationPassthrough As Boolean
C#
public bool UncAuthenticationPassthrough { get; set; }
C++
public property bool UncAuthenticationPassthrough sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_UncAuthenticationPassthrough();

/** property */
public void set_UncAuthenticationPassthrough(bool value);
JScript
public function get UncAuthenticationPassthrough() : bool

public function set UncAuthenticationPassthrough(value : bool);

Property Value

Value indicating if UncAuthenticationPassthrough is enabled or disabled.

See Also

WebDirectoryCreate Class
WebDirectoryCreate Members
MSBuild.Community.Tasks.IIS Namespace


VirtualDirectoryName Property

WebDirectoryCreate.VirtualDirectoryName Property
[image]

Gets or sets the name of the virtual directory.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Required>
Public Property VirtualDirectoryName As String
C#
[Required]
public string VirtualDirectoryName { get; set; }
C++
[Required]
public property string VirtualDirectoryName sealed {
String get();
void set(String value);
}
J#
/** @attribute Required() */
/** property */
public string get_VirtualDirectoryName();

/** property */
public void set_VirtualDirectoryName(string value);
JScript
public function get VirtualDirectoryName() : String

public function set VirtualDirectoryName(value : String);

Property Value

The name of the virtual directory.

See Also

WebDirectoryCreate Class
WebDirectoryCreate Members
MSBuild.Community.Tasks.IIS Namespace


VirtualDirectoryPhysicalPath Property

WebDirectoryCreate.VirtualDirectoryPhysicalPath Property
[image]

Gets or sets the virtual directory physical path. The physical directory must exist before this task executes.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Required>
Public Property VirtualDirectoryPhysicalPath As String
C#
[Required]
public string VirtualDirectoryPhysicalPath { get; set; }
C++
[Required]
public property string VirtualDirectoryPhysicalPath sealed {
String get();
void set(String value);
}
J#
/** @attribute Required() */
/** property */
public string get_VirtualDirectoryPhysicalPath();

/** property */
public void set_VirtualDirectoryPhysicalPath(string value);
JScript
public function get VirtualDirectoryPhysicalPath() : String

public function set VirtualDirectoryPhysicalPath(value : String);

Property Value

The virtual directory physical path.

See Also

WebDirectoryCreate Class
WebDirectoryCreate Members
MSBuild.Community.Tasks.IIS Namespace


Methods

WebDirectoryCreate Methods
See Also Example
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. When overridden in a derived class, executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

WebDirectoryCreate Class
WebDirectoryCreate Members
MSBuild.Community.Tasks.IIS Namespace


Execute Method

WebDirectoryCreate.Execute Method
[image]

When overridden in a derived class, executes the task.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute() As Boolean _
Implements ITask.Execute
C#
public override bool Execute()
C++
public:
virtual bool Execute() override
J#
public override bool Execute()
JScript
public override function Execute() : bool

Return Value

True if the task successfully executed; otherwise, false.

Implements

ITask.Execute

See Also

WebDirectoryCreate Class
WebDirectoryCreate Members
MSBuild.Community.Tasks.IIS Namespace


WebDirectoryDelete Class

WebDirectoryDelete Class
See Also Example Members
[image]

Deletes a web directory on a local or remote machine with IIS installed. The default is to delete the web directory on the local machine. If connecting to a remote machine, you can specify the Username and Password for the task to run under.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class WebDirectoryDelete
Inherits WebBase
C#
public class WebDirectoryDelete : WebBase
C++
ref class WebDirectoryDelete : WebBase
J#
public class WebDirectoryDelete extends WebBase
JScript
public class WebDirectoryDelete extends WebBase

Example

Deletes a web directory on the local machine.

Copy Code
            <WebDirectoryDelete VirtualDirectoryName="MyVirDir" />

Inheritance Hierarchy

System.Object
Microsoft.Build.Utilities.Task
MSBuild.Community.Tasks.IIS.WebBase
MSBuild.Community.Tasks.IIS.WebDirectoryDelete

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

WebDirectoryDelete Members
MSBuild.Community.Tasks.IIS Namespace


WebDirectoryDelete Members

WebDirectoryDelete Members
See Also Example Constructors Fields Properties Methods
[image]

Deletes a web directory on a local or remote machine with IIS installed. The default is to delete the web directory on the local machine. If connecting to a remote machine, you can specify the Username and Password for the task to run under.

The following tables list the members exposed by WebDirectoryDelete.

Public Constructors

 | Name | Description
Public method | WebDirectoryDelete | Initializes a new instance of the WebDirectoryDelete class.
Top

Protected Fields

 | Name | Description
Family field | mIISVersion | IIS version. (inherited from WebBase)
Top

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Password | Gets or sets the password for the account the task will run under. This property is needed if you specified a ServerName for a remote machine. (inherited from WebBase)
Public property | ServerName | Gets or sets the name of the server. The default value is 'localhost'. (inherited from WebBase)
Public property | ServerPort | Gets or sets the server port. (inherited from WebBase)
Public property | Username | Gets or sets the username for the account the task will run under. This property is needed if you specified a ServerName for a remote machine. (inherited from WebBase)
Public property | VirtualDirectoryName | Gets or sets the name of the virtual directory.
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | IISApplicationPath | Gets or sets the application path. (inherited from WebBase)
Family property | IISAppPoolPath | Gets or sets the IIS application pool path. (inherited from WebBase)
Family property | IISServerPath | Gets or sets the IIS server path. (inherited from WebBase)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. When overridden in a derived class, executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

WebDirectoryDelete Class
WebDirectoryDelete Members
MSBuild.Community.Tasks.IIS Namespace


WebDirectoryDelete Constructor

WebDirectoryDelete Constructor
[image]

Initializes a new instance of the WebDirectoryDelete class.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public WebDirectoryDelete()
C++
public:
WebDirectoryDelete() sealed
J#
public WebDirectoryDelete()
JScript
public function WebDirectoryDelete()

See Also

WebDirectoryDelete Class
WebDirectoryDelete Members
MSBuild.Community.Tasks.IIS Namespace


Properties

WebDirectoryDelete Properties
See Also Example
[image]

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Password | Gets or sets the password for the account the task will run under. This property is needed if you specified a ServerName for a remote machine. (inherited from WebBase)
Public property | ServerName | Gets or sets the name of the server. The default value is 'localhost'. (inherited from WebBase)
Public property | ServerPort | Gets or sets the server port. (inherited from WebBase)
Public property | Username | Gets or sets the username for the account the task will run under. This property is needed if you specified a ServerName for a remote machine. (inherited from WebBase)
Public property | VirtualDirectoryName | Gets or sets the name of the virtual directory.
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | IISApplicationPath | Gets or sets the application path. (inherited from WebBase)
Family property | IISAppPoolPath | Gets or sets the IIS application pool path. (inherited from WebBase)
Family property | IISServerPath | Gets or sets the IIS server path. (inherited from WebBase)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

See Also

WebDirectoryDelete Class
WebDirectoryDelete Members
MSBuild.Community.Tasks.IIS Namespace


VirtualDirectoryName Property

WebDirectoryDelete.VirtualDirectoryName Property
[image]

Gets or sets the name of the virtual directory.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Required>
Public Property VirtualDirectoryName As String
C#
[Required]
public string VirtualDirectoryName { get; set; }
C++
[Required]
public property string VirtualDirectoryName sealed {
String get();
void set(String value);
}
J#
/** @attribute Required() */
/** property */
public string get_VirtualDirectoryName();

/** property */
public void set_VirtualDirectoryName(string value);
JScript
public function get VirtualDirectoryName() : String

public function set VirtualDirectoryName(value : String);

Property Value

The name of the virtual directory.

See Also

WebDirectoryDelete Class
WebDirectoryDelete Members
MSBuild.Community.Tasks.IIS Namespace


Methods

WebDirectoryDelete Methods
See Also Example
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. When overridden in a derived class, executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

WebDirectoryDelete Class
WebDirectoryDelete Members
MSBuild.Community.Tasks.IIS Namespace


Execute Method

WebDirectoryDelete.Execute Method
[image]

When overridden in a derived class, executes the task.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute() As Boolean _
Implements ITask.Execute
C#
public override bool Execute()
C++
public:
virtual bool Execute() override
J#
public override bool Execute()
JScript
public override function Execute() : bool

Return Value

True if the task successfully executed; otherwise, false.

Implements

ITask.Execute

See Also

WebDirectoryDelete Class
WebDirectoryDelete Members
MSBuild.Community.Tasks.IIS Namespace


WebDirectoryScriptMap Class

WebDirectoryScriptMap Class
See Also Example Members
[image]

Sets an application mapping for a filename extension on an existing web directory.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class WebDirectoryScriptMap
Inherits WebBase
C#
public class WebDirectoryScriptMap : WebBase
C++
ref class WebDirectoryScriptMap : WebBase
J#
public class WebDirectoryScriptMap extends WebBase
JScript
public class WebDirectoryScriptMap extends WebBase

Example

Map the .axd extension to the lastest version of ASP.NET:

Copy Code
            <WebDirectoryScriptMap VirtualDirectoryName="MyWeb" Extension=".axd" MapToAspNet="True" VerifyFileExists="False" />
Map GET requests to the .rss extension to a specific executable:
Copy Code
            <WebDirectoryScriptMap VirtualDirectoryName="MyWeb" Extension=".rss" Verbs="GET" ExecutablePath="$(WINDIR)\Microsoft.Net\Framework\1.0.3705\aspnet_isapi.dll" />

Inheritance Hierarchy

System.Object
Microsoft.Build.Utilities.Task
MSBuild.Community.Tasks.IIS.WebBase
MSBuild.Community.Tasks.IIS.WebDirectoryScriptMap

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

WebDirectoryScriptMap Members
MSBuild.Community.Tasks.IIS Namespace


WebDirectoryScriptMap Members

WebDirectoryScriptMap Members
See Also Example Constructors Fields Properties Methods
[image]

Sets an application mapping for a filename extension on an existing web directory.

The following tables list the members exposed by WebDirectoryScriptMap.

Public Constructors

 | Name | Description
Public method | WebDirectoryScriptMap | Initializes a new instance of the WebDirectoryScriptMap class.
Top

Protected Fields

 | Name | Description
Family field | mIISVersion | IIS version. (inherited from WebBase)
Top

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | EnableScriptEngine | Set to true when you want the application to run in a directory without Execute permissions.
Public property | ExecutablePath | The full path to the executable used to respond to requests for a Uri ending with Extension
Public property | Extension | The filename extension that will be mapped to an executable.
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | MapToAspNet | Indicates whether Extension should be mapped to the ASP.NET runtime.
Public property | Password | Gets or sets the password for the account the task will run under. This property is needed if you specified a ServerName for a remote machine. (inherited from WebBase)
Public property | ServerName | Gets or sets the name of the server. The default value is 'localhost'. (inherited from WebBase)
Public property | ServerPort | Gets or sets the server port. (inherited from WebBase)
Public property | Username | Gets or sets the username for the account the task will run under. This property is needed if you specified a ServerName for a remote machine. (inherited from WebBase)
Public property | Verbs | A comma-separated list of the HTTP verbs to include in the application mapping.
Public property | VerifyFileExists | Set to true to instruct the Web server to verify the existence of the requested script file and to ensure that the requesting user has access permission for that script file.
Public property | VirtualDirectoryName | Gets or sets the name of the virtual directory.
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | IISApplicationPath | Gets or sets the application path. (inherited from WebBase)
Family property | IISAppPoolPath | Gets or sets the IIS application pool path. (inherited from WebBase)
Family property | IISServerPath | Gets or sets the IIS server path. (inherited from WebBase)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. When overridden in a derived class, executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

WebDirectoryScriptMap Class
WebDirectoryScriptMap Members
MSBuild.Community.Tasks.IIS Namespace


WebDirectoryScriptMap Constructor

WebDirectoryScriptMap Constructor
[image]

Initializes a new instance of the WebDirectoryScriptMap class.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public WebDirectoryScriptMap()
C++
public:
WebDirectoryScriptMap() sealed
J#
public WebDirectoryScriptMap()
JScript
public function WebDirectoryScriptMap()

See Also

WebDirectoryScriptMap Class
WebDirectoryScriptMap Members
MSBuild.Community.Tasks.IIS Namespace


Properties

WebDirectoryScriptMap Properties
See Also Example
[image]

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | EnableScriptEngine | Set to true when you want the application to run in a directory without Execute permissions.
Public property | ExecutablePath | The full path to the executable used to respond to requests for a Uri ending with Extension
Public property | Extension | The filename extension that will be mapped to an executable.
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | MapToAspNet | Indicates whether Extension should be mapped to the ASP.NET runtime.
Public property | Password | Gets or sets the password for the account the task will run under. This property is needed if you specified a ServerName for a remote machine. (inherited from WebBase)
Public property | ServerName | Gets or sets the name of the server. The default value is 'localhost'. (inherited from WebBase)
Public property | ServerPort | Gets or sets the server port. (inherited from WebBase)
Public property | Username | Gets or sets the username for the account the task will run under. This property is needed if you specified a ServerName for a remote machine. (inherited from WebBase)
Public property | Verbs | A comma-separated list of the HTTP verbs to include in the application mapping.
Public property | VerifyFileExists | Set to true to instruct the Web server to verify the existence of the requested script file and to ensure that the requesting user has access permission for that script file.
Public property | VirtualDirectoryName | Gets or sets the name of the virtual directory.
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | IISApplicationPath | Gets or sets the application path. (inherited from WebBase)
Family property | IISAppPoolPath | Gets or sets the IIS application pool path. (inherited from WebBase)
Family property | IISServerPath | Gets or sets the IIS server path. (inherited from WebBase)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

See Also

WebDirectoryScriptMap Class
WebDirectoryScriptMap Members
MSBuild.Community.Tasks.IIS Namespace


EnableScriptEngine Property

WebDirectoryScriptMap.EnableScriptEngine Property
[image]

Set to true when you want the application to run in a directory without Execute permissions.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property EnableScriptEngine As Boolean
C#
public bool EnableScriptEngine { get; set; }
C++
public property bool EnableScriptEngine sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_EnableScriptEngine();

/** property */
public void set_EnableScriptEngine(bool value);
JScript
public function get EnableScriptEngine() : bool

public function set EnableScriptEngine(value : bool);

See Also

WebDirectoryScriptMap Class
WebDirectoryScriptMap Members
MSBuild.Community.Tasks.IIS Namespace


ExecutablePath Property

WebDirectoryScriptMap.ExecutablePath Property
[image]

The full path to the executable used to respond to requests for a Uri ending with Extension

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property ExecutablePath As String
C#
public string ExecutablePath { get; set; }
C++
public property string ExecutablePath sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_ExecutablePath();

/** property */
public void set_ExecutablePath(string value);
JScript
public function get ExecutablePath() : String

public function set ExecutablePath(value : String);

Remarks

This property is required when MapToAspNet is false (the default).

See Also

WebDirectoryScriptMap Class
WebDirectoryScriptMap Members
MSBuild.Community.Tasks.IIS Namespace


Extension Property

WebDirectoryScriptMap.Extension Property
[image]

The filename extension that will be mapped to an executable.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Required>
Public Property Extension As String
C#
[Required]
public string Extension { get; set; }
C++
[Required]
public property string Extension sealed {
String get();
void set(String value);
}
J#
/** @attribute Required() */
/** property */
public string get_Extension();

/** property */
public void set_Extension(string value);
JScript
public function get Extension() : String

public function set Extension(value : String);

See Also

WebDirectoryScriptMap Class
WebDirectoryScriptMap Members
MSBuild.Community.Tasks.IIS Namespace


MapToAspNet Property

WebDirectoryScriptMap.MapToAspNet Property
[image]

Indicates whether Extension should be mapped to the ASP.NET runtime.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property MapToAspNet As Boolean
C#
public bool MapToAspNet { get; set; }
C++
public property bool MapToAspNet sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_MapToAspNet();

/** property */
public void set_MapToAspNet(bool value);
JScript
public function get MapToAspNet() : bool

public function set MapToAspNet(value : bool);

Remarks

When true, ExecutablePath is set to aspnet_isapi.dll in the installation folder of the latest version of the .NET Framework.

See Also

WebDirectoryScriptMap Class
WebDirectoryScriptMap Members
MSBuild.Community.Tasks.IIS Namespace


Verbs Property

WebDirectoryScriptMap.Verbs Property
[image]

A comma-separated list of the HTTP verbs to include in the application mapping.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Verbs As String
C#
public string Verbs { get; set; }
C++
public property string Verbs sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Verbs();

/** property */
public void set_Verbs(string value);
JScript
public function get Verbs() : String

public function set Verbs(value : String);

Remarks

The default behavior (when this property is empty or unspecified) is to map all verbs.

A semi-colon-separated list will also be recognized, allowing you to use an MSBuild Item.

See Also

WebDirectoryScriptMap Class
WebDirectoryScriptMap Members
MSBuild.Community.Tasks.IIS Namespace


VerifyFileExists Property

WebDirectoryScriptMap.VerifyFileExists Property
[image]

Set to true to instruct the Web server to verify the existence of the requested script file and to ensure that the requesting user has access permission for that script file.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property VerifyFileExists As Boolean
C#
public bool VerifyFileExists { get; set; }
C++
public property bool VerifyFileExists sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_VerifyFileExists();

/** property */
public void set_VerifyFileExists(bool value);
JScript
public function get VerifyFileExists() : bool

public function set VerifyFileExists(value : bool);

See Also

WebDirectoryScriptMap Class
WebDirectoryScriptMap Members
MSBuild.Community.Tasks.IIS Namespace


VirtualDirectoryName Property

WebDirectoryScriptMap.VirtualDirectoryName Property
[image]

Gets or sets the name of the virtual directory.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Required>
Public Property VirtualDirectoryName As String
C#
[Required]
public string VirtualDirectoryName { get; set; }
C++
[Required]
public property string VirtualDirectoryName sealed {
String get();
void set(String value);
}
J#
/** @attribute Required() */
/** property */
public string get_VirtualDirectoryName();

/** property */
public void set_VirtualDirectoryName(string value);
JScript
public function get VirtualDirectoryName() : String

public function set VirtualDirectoryName(value : String);

Property Value

The name of the virtual directory.

See Also

WebDirectoryScriptMap Class
WebDirectoryScriptMap Members
MSBuild.Community.Tasks.IIS Namespace


Methods

WebDirectoryScriptMap Methods
See Also Example
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. When overridden in a derived class, executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

WebDirectoryScriptMap Class
WebDirectoryScriptMap Members
MSBuild.Community.Tasks.IIS Namespace


Execute Method

WebDirectoryScriptMap.Execute Method
[image]

When overridden in a derived class, executes the task.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute() As Boolean _
Implements ITask.Execute
C#
public override bool Execute()
C++
public:
virtual bool Execute() override
J#
public override bool Execute()
JScript
public override function Execute() : bool

Return Value

True if the task successfully executed; otherwise, false.

Implements

ITask.Execute

See Also

WebDirectoryScriptMap Class
WebDirectoryScriptMap Members
MSBuild.Community.Tasks.IIS Namespace


WebDirectorySetting Class

WebDirectorySetting Class
See Also Example Members
[image]

Reads and modifies a web directory configuration setting.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class WebDirectorySetting
Inherits WebBase
C#
public class WebDirectorySetting : WebBase
C++
ref class WebDirectorySetting : WebBase
J#
public class WebDirectorySetting extends WebBase
JScript
public class WebDirectorySetting extends WebBase

Example

Display the file system path of the MyWeb web directory:

Copy Code
            <WebDirectorySetting VirtualDirectoryName="MyWeb" SettingName="Path">
                <Output TaskParameter="SettingValue" PropertyName="LocalPath" />
            </WebDirectorySetting>
            <Message Text="MyWeb is located at $(LocalPath)" />
Set the default document for the MyWeb directory to Default.aspx:
Copy Code
            <WebDirectorySetting VirtualDirectoryName="MyWeb" SettingName="DefaultDoc" SettingValue="Default.aspx" />
            <WebDirectorySetting VirtualDirectoryName="MyWeb" SettingName="EnableDefaultDoc" SettingValue="True" />

Inheritance Hierarchy

System.Object
Microsoft.Build.Utilities.Task
MSBuild.Community.Tasks.IIS.WebBase
MSBuild.Community.Tasks.IIS.WebDirectorySetting

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

WebDirectorySetting Members
MSBuild.Community.Tasks.IIS Namespace


WebDirectorySetting Members

WebDirectorySetting Members
See Also Example Constructors Fields Properties Methods
[image]

Reads and modifies a web directory configuration setting.

The following tables list the members exposed by WebDirectorySetting.

Public Constructors

 | Name | Description
Public method | WebDirectorySetting | Initializes a new instance of the WebDirectorySetting class.
Top

Protected Fields

 | Name | Description
Family field | mIISVersion | IIS version. (inherited from WebBase)
Top

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Password | Gets or sets the password for the account the task will run under. This property is needed if you specified a ServerName for a remote machine. (inherited from WebBase)
Public property | ServerName | Gets or sets the name of the server. The default value is 'localhost'. (inherited from WebBase)
Public property | ServerPort | Gets or sets the server port. (inherited from WebBase)
Public property | SettingName | Gets or sets the configuration setting to read or modify.
Public property | SettingValue | Gets or sets the value of SettingName on the web directory
Public property | Username | Gets or sets the username for the account the task will run under. This property is needed if you specified a ServerName for a remote machine. (inherited from WebBase)
Public property | VirtualDirectoryName | Gets or sets the name of the virtual directory.
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | IISApplicationPath | Gets or sets the application path. (inherited from WebBase)
Family property | IISAppPoolPath | Gets or sets the IIS application pool path. (inherited from WebBase)
Family property | IISServerPath | Gets or sets the IIS server path. (inherited from WebBase)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. When overridden in a derived class, executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

WebDirectorySetting Class
WebDirectorySetting Members
MSBuild.Community.Tasks.IIS Namespace


WebDirectorySetting Constructor

WebDirectorySetting Constructor
[image]

Initializes a new instance of the WebDirectorySetting class.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public WebDirectorySetting()
C++
public:
WebDirectorySetting() sealed
J#
public WebDirectorySetting()
JScript
public function WebDirectorySetting()

See Also

WebDirectorySetting Class
WebDirectorySetting Members
MSBuild.Community.Tasks.IIS Namespace


Properties

WebDirectorySetting Properties
See Also Example
[image]

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Password | Gets or sets the password for the account the task will run under. This property is needed if you specified a ServerName for a remote machine. (inherited from WebBase)
Public property | ServerName | Gets or sets the name of the server. The default value is 'localhost'. (inherited from WebBase)
Public property | ServerPort | Gets or sets the server port. (inherited from WebBase)
Public property | SettingName | Gets or sets the configuration setting to read or modify.
Public property | SettingValue | Gets or sets the value of SettingName on the web directory
Public property | Username | Gets or sets the username for the account the task will run under. This property is needed if you specified a ServerName for a remote machine. (inherited from WebBase)
Public property | VirtualDirectoryName | Gets or sets the name of the virtual directory.
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | IISApplicationPath | Gets or sets the application path. (inherited from WebBase)
Family property | IISAppPoolPath | Gets or sets the IIS application pool path. (inherited from WebBase)
Family property | IISServerPath | Gets or sets the IIS server path. (inherited from WebBase)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

See Also

WebDirectorySetting Class
WebDirectorySetting Members
MSBuild.Community.Tasks.IIS Namespace


SettingName Property

WebDirectorySetting.SettingName Property
[image]

Gets or sets the configuration setting to read or modify.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Required>
Public Property SettingName As String
C#
[Required]
public string SettingName { get; set; }
C++
[Required]
public property string SettingName sealed {
String get();
void set(String value);
}
J#
/** @attribute Required() */
/** property */
public string get_SettingName();

/** property */
public void set_SettingName(string value);
JScript
public function get SettingName() : String

public function set SettingName(value : String);

See Also

WebDirectorySetting Class
WebDirectorySetting Members
MSBuild.Community.Tasks.IIS Namespace


SettingValue Property

WebDirectorySetting.SettingValue Property
[image]

Gets or sets the value of SettingName on the web directory

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Output>
Public Property SettingValue As String
C#
[Output]
public string SettingValue { get; set; }
C++
[Output]
public property string SettingValue sealed {
String get();
void set(String value);
}
J#
/** @attribute Output() */
/** property */
public string get_SettingValue();

/** property */
public void set_SettingValue(string value);
JScript
public function get SettingValue() : String

public function set SettingValue(value : String);

See Also

WebDirectorySetting Class
WebDirectorySetting Members
MSBuild.Community.Tasks.IIS Namespace


VirtualDirectoryName Property

WebDirectorySetting.VirtualDirectoryName Property
[image]

Gets or sets the name of the virtual directory.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Required>
Public Property VirtualDirectoryName As String
C#
[Required]
public string VirtualDirectoryName { get; set; }
C++
[Required]
public property string VirtualDirectoryName sealed {
String get();
void set(String value);
}
J#
/** @attribute Required() */
/** property */
public string get_VirtualDirectoryName();

/** property */
public void set_VirtualDirectoryName(string value);
JScript
public function get VirtualDirectoryName() : String

public function set VirtualDirectoryName(value : String);

Property Value

The name of the virtual directory.

See Also

WebDirectorySetting Class
WebDirectorySetting Members
MSBuild.Community.Tasks.IIS Namespace


Methods

WebDirectorySetting Methods
See Also Example
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. When overridden in a derived class, executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

WebDirectorySetting Class
WebDirectorySetting Members
MSBuild.Community.Tasks.IIS Namespace


Execute Method

WebDirectorySetting.Execute Method
[image]

When overridden in a derived class, executes the task.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute() As Boolean _
Implements ITask.Execute
C#
public override bool Execute()
C++
public:
virtual bool Execute() override
J#
public override bool Execute()
JScript
public override function Execute() : bool

Return Value

True if the task successfully executed; otherwise, false.

Implements

ITask.Execute

See Also

WebDirectorySetting Class
WebDirectorySetting Members
MSBuild.Community.Tasks.IIS Namespace


MSBuild.Community.Tasks.Install

MSBuild.Community.Tasks.Install Namespace
See Also Hierarchy

Classes

 | Class | Description
Public class | InstallAssembly | Installs assemblies.
Public class | UninstallAssembly | Uninstalls assemblies.


InstallAssembly Class

InstallAssembly Class
See Also Example Members
[image]

Installs assemblies.

Namespace: MSBuild.Community.Tasks.Install
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class InstallAssembly
Inherits ToolTask
C#
public class InstallAssembly : ToolTask
C++
ref class InstallAssembly : ToolTask
J#
public class InstallAssembly extends ToolTask
JScript
public class InstallAssembly extends ToolTask

Example

Install multiple assemblies by specifying the file names:

Copy Code
<InstallAssembly AssemblyFiles="Engine.dll;Presenter.dll" />
Install an assembly using the assembly name. Also disable the log file by setting it to a single space:
Copy Code
<InstallAssembly AssemblyNames="Engine,Version=1.5.0.0,Culture=neutral" LogFile=" "/>
You can easily chain an install to the result of a build:
Copy Code
<MSBuild Projects="Project1.csproj;Project2.csproj">
 <Output TaskParameter="TargetOutputs" ItemName="ProjectBinaries" />
</MSBuild>
<InstallAssembly AssemblyFiles="@(ProjectBinaries)" />

Remarks

Uses InstallUtil.exe to execute the Install method of Installer classes contained within specified assemblies.

Inheritance Hierarchy

System.Object
Microsoft.Build.Utilities.Task
Microsoft.Build.Utilities.ToolTask
MSBuild.Community.Tasks.Install.InstallAssembly
MSBuild.Community.Tasks.Install.UninstallAssembly

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

InstallAssembly Members
MSBuild.Community.Tasks.Install Namespace


InstallAssembly Members

InstallAssembly Members
See Also Example Constructors Properties Methods
[image]

Installs assemblies.

The following tables list the members exposed by InstallAssembly.

Public Constructors

 | Name | Description
Public method | InstallAssembly | Initializes a new instance of the InstallAssembly class.
Top

Public Properties

 | Name | Description
Public property | AssemblyFiles | The assemblies to process, identified by their filename.
Public property | AssemblyNames | The assemblies to process, identified by their assembly name.
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | ExitCode | Gets the returned exit code of the executable file. (inherited from ToolTask)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | LogFile | The file to write installation progress to.
Public property | ShowCallStack | If an exception occurs at any point during installation, the call stack will be printed to the log.
Public property | Timeout | Gets or sets the amount of time after which the task executable is terminated. (inherited from ToolTask)
Public property | ToolPath | Gets or sets the path of the executable file to run. (inherited from ToolTask)
Top

Protected Properties

 | Name | Description
Family property | EnvironmentOverride | Gets the override value of the PATH environment variable. (inherited from ToolTask)
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | IsUninstall | Determines whether assemblies are installed or uninstalled.
Family property | ResponseFileEncoding | Gets the Encoding of the response file. (inherited from ToolTask)
Family property | StandardErrorEncoding | Gets the Encoding of the standard error stream of the task. (inherited from ToolTask)
Family property | StandardErrorLoggingImportance | Gets the MessageImportance with which to log errors. (inherited from ToolTask)
Family property | StandardOutputEncoding | Gets the Encoding of the standard output stream of the task. (inherited from ToolTask)
Family property | StandardOutputLoggingImportance | Gets the MessageImportance with which to log errors. (inherited from ToolTask)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Family property | ToolName | Overidden. Gets the name of the executable file to run.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Runs the exectuable file with the specified task parameters. (inherited from ToolTask)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | CallHostObjectToExecute | Calls the host object to perform the work of the task. (inherited from ToolTask)
Family method | ExecuteTool | Creates a temporoary response (.rsp) file and runs the executable file. (inherited from ToolTask)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GenerateCommandLineCommands | Overidden. Returns a string value containing the command line arguments to pass directly to the executable file.
Family method | GenerateFullPathToTool | Overidden. Returns the fully qualified path to the executable file.
Family method | GenerateResponseFileCommands | Returns a string value containing the command line arguments to add to the response (.rsp) file before running the executable file. (inherited from ToolTask)
Family method | GetResponseFileSwitch | Returns the command line switch used by the executable file to specifiy a response (.rsp) file. (inherited from ToolTask)
Family method | GetWorkingDirectory | Returns the directory in which to run the executable file. (inherited from ToolTask)
Family method | HandleTaskExecutionErrors | Handles execution errors raised by the executable file. (inherited from ToolTask)
Family method | InitializeHostObject | Initializes the host object of the task. (inherited from ToolTask)
Family method | LogEventsFromTextOutput | (inherited from ToolTask)
Family method | LogPathToTool | Logs the tool name and path to all registered loggers. (inherited from ToolTask)
Family method | LogToolCommand | Logs the starting point of the run to all registered loggers. (inherited from ToolTask)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | SkipTaskExecution | Indicates whether task execution should be skipped. (inherited from ToolTask)
Family method | ValidateParameters | Indicates whether all task paratmeters are valid. (inherited from ToolTask)
Top

See Also

InstallAssembly Class
InstallAssembly Members
MSBuild.Community.Tasks.Install Namespace


InstallAssembly Constructor

InstallAssembly Constructor
[image]

Initializes a new instance of the InstallAssembly class.

Namespace: MSBuild.Community.Tasks.Install
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public InstallAssembly()
C++
public:
InstallAssembly() sealed
J#
public InstallAssembly()
JScript
public function InstallAssembly()

See Also

InstallAssembly Class
InstallAssembly Members
MSBuild.Community.Tasks.Install Namespace


Properties

InstallAssembly Properties
See Also Example
[image]

Public Properties

 | Name | Description
Public property | AssemblyFiles | The assemblies to process, identified by their filename.
Public property | AssemblyNames | The assemblies to process, identified by their assembly name.
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | ExitCode | Gets the returned exit code of the executable file. (inherited from ToolTask)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | LogFile | The file to write installation progress to.
Public property | ShowCallStack | If an exception occurs at any point during installation, the call stack will be printed to the log.
Public property | Timeout | Gets or sets the amount of time after which the task executable is terminated. (inherited from ToolTask)
Public property | ToolPath | Gets or sets the path of the executable file to run. (inherited from ToolTask)
Top

Protected Properties

 | Name | Description
Family property | EnvironmentOverride | Gets the override value of the PATH environment variable. (inherited from ToolTask)
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | IsUninstall | Determines whether assemblies are installed or uninstalled.
Family property | ResponseFileEncoding | Gets the Encoding of the response file. (inherited from ToolTask)
Family property | StandardErrorEncoding | Gets the Encoding of the standard error stream of the task. (inherited from ToolTask)
Family property | StandardErrorLoggingImportance | Gets the MessageImportance with which to log errors. (inherited from ToolTask)
Family property | StandardOutputEncoding | Gets the Encoding of the standard output stream of the task. (inherited from ToolTask)
Family property | StandardOutputLoggingImportance | Gets the MessageImportance with which to log errors. (inherited from ToolTask)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Family property | ToolName | Overidden. Gets the name of the executable file to run.
Top

See Also

InstallAssembly Class
InstallAssembly Members
MSBuild.Community.Tasks.Install Namespace


AssemblyFiles Property

InstallAssembly.AssemblyFiles Property
[image]

The assemblies to process, identified by their filename.

Namespace: MSBuild.Community.Tasks.Install
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AssemblyFiles As ITaskItem[]
C#
public ITaskItem[] AssemblyFiles { get; set; }
C++
public property ITaskItem[] AssemblyFiles sealed {
array<ITaskItem>^ get();
void set(array<ITaskItem>^ value);
}
J#
/** property */
public ITaskItem[] get_AssemblyFiles();

/** property */
public void set_AssemblyFiles(ITaskItem[] value);
JScript
public function get AssemblyFiles() : ITaskItem[]

public function set AssemblyFiles(value : ITaskItem[]);

See Also

InstallAssembly Class
InstallAssembly Members
MSBuild.Community.Tasks.Install Namespace


AssemblyNames Property

InstallAssembly.AssemblyNames Property
[image]

The assemblies to process, identified by their assembly name.

Namespace: MSBuild.Community.Tasks.Install
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AssemblyNames As ITaskItem[]
C#
public ITaskItem[] AssemblyNames { get; set; }
C++
public property ITaskItem[] AssemblyNames sealed {
array<ITaskItem>^ get();
void set(array<ITaskItem>^ value);
}
J#
/** property */
public ITaskItem[] get_AssemblyNames();

/** property */
public void set_AssemblyNames(ITaskItem[] value);
JScript
public function get AssemblyNames() : ITaskItem[]

public function set AssemblyNames(value : ITaskItem[]);

See Also

InstallAssembly Class
InstallAssembly Members
MSBuild.Community.Tasks.Install Namespace


IsUninstall Property

InstallAssembly.IsUninstall Property
[image]

Determines whether assemblies are installed or uninstalled.

Namespace: MSBuild.Community.Tasks.Install
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property IsUninstall As Boolean
C#
protected virtual bool IsUninstall { get; }
C++
protected virtual property bool IsUninstall {
bool get();
}
J#
/** property */
protected bool get_IsUninstall();
JScript
protected function get IsUninstall() : bool

See Also

InstallAssembly Class
InstallAssembly Members
MSBuild.Community.Tasks.Install Namespace


LogFile Property

InstallAssembly.LogFile Property
[image]

The file to write installation progress to.

Namespace: MSBuild.Community.Tasks.Install
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property LogFile As String
C#
public string LogFile { get; set; }
C++
public property string LogFile sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_LogFile();

/** property */
public void set_LogFile(string value);
JScript
public function get LogFile() : String

public function set LogFile(value : String);

Remarks

Set to a single space to disable logging to a file.

If not specified, the default is to log to [assemblyname].installLog

See Also

InstallAssembly Class
InstallAssembly Members
MSBuild.Community.Tasks.Install Namespace


ShowCallStack Property

InstallAssembly.ShowCallStack Property
[image]

If an exception occurs at any point during installation, the call stack will be printed to the log.

Namespace: MSBuild.Community.Tasks.Install
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property ShowCallStack As Boolean
C#
public bool ShowCallStack { get; set; }
C++
public property bool ShowCallStack sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_ShowCallStack();

/** property */
public void set_ShowCallStack(bool value);
JScript
public function get ShowCallStack() : bool

public function set ShowCallStack(value : bool);

See Also

InstallAssembly Class
InstallAssembly Members
MSBuild.Community.Tasks.Install Namespace


ToolName Property

InstallAssembly.ToolName Property
[image]

Gets the name of the executable file to run.

Namespace: MSBuild.Community.Tasks.Install
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property ToolName As String
C#
protected override string ToolName { get; }
C++
protected override property string ToolName override {
String get();
}
J#
/** property */
protected string get_ToolName();
JScript
protected function get ToolName() : String

Property Value

The name of the executable file to run.

See Also

InstallAssembly Class
InstallAssembly Members
MSBuild.Community.Tasks.Install Namespace


Methods

InstallAssembly Methods
See Also Example
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Runs the exectuable file with the specified task parameters. (inherited from ToolTask)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | CallHostObjectToExecute | Calls the host object to perform the work of the task. (inherited from ToolTask)
Family method | ExecuteTool | Creates a temporoary response (.rsp) file and runs the executable file. (inherited from ToolTask)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GenerateCommandLineCommands | Overidden. Returns a string value containing the command line arguments to pass directly to the executable file.
Family method | GenerateFullPathToTool | Overidden. Returns the fully qualified path to the executable file.
Family method | GenerateResponseFileCommands | Returns a string value containing the command line arguments to add to the response (.rsp) file before running the executable file. (inherited from ToolTask)
Family method | GetResponseFileSwitch | Returns the command line switch used by the executable file to specifiy a response (.rsp) file. (inherited from ToolTask)
Family method | GetWorkingDirectory | Returns the directory in which to run the executable file. (inherited from ToolTask)
Family method | HandleTaskExecutionErrors | Handles execution errors raised by the executable file. (inherited from ToolTask)
Family method | InitializeHostObject | Initializes the host object of the task. (inherited from ToolTask)
Family method | LogEventsFromTextOutput | (inherited from ToolTask)
Family method | LogPathToTool | Logs the tool name and path to all registered loggers. (inherited from ToolTask)
Family method | LogToolCommand | Logs the starting point of the run to all registered loggers. (inherited from ToolTask)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | SkipTaskExecution | Indicates whether task execution should be skipped. (inherited from ToolTask)
Family method | ValidateParameters | Indicates whether all task paratmeters are valid. (inherited from ToolTask)
Top

See Also

InstallAssembly Class
InstallAssembly Members
MSBuild.Community.Tasks.Install Namespace


GenerateCommandLineCommands Method

InstallAssembly.GenerateCommandLineCommands Method
[image]

Returns a string value containing the command line arguments to pass directly to the executable file.

Namespace: MSBuild.Community.Tasks.Install
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GenerateCommandLineCommands() As String
C#
protected override string GenerateCommandLineCommands()
C++
protected:
virtual String GenerateCommandLineCommands() override
J#
protected override string GenerateCommandLineCommands()
JScript
protected override function GenerateCommandLineCommands() : String

Return Value

A string value containing the command line arguments to pass directly to the executable file.

See Also

InstallAssembly Class
InstallAssembly Members
MSBuild.Community.Tasks.Install Namespace


GenerateFullPathToTool Method

InstallAssembly.GenerateFullPathToTool Method
[image]

Returns the fully qualified path to the executable file.

Namespace: MSBuild.Community.Tasks.Install
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GenerateFullPathToTool() As String
C#
protected override string GenerateFullPathToTool()
C++
protected:
virtual String GenerateFullPathToTool() override
J#
protected override string GenerateFullPathToTool()
JScript
protected override function GenerateFullPathToTool() : String

Return Value

The fully qualified path to the executable file.

See Also

InstallAssembly Class
InstallAssembly Members
MSBuild.Community.Tasks.Install Namespace


UninstallAssembly Class

UninstallAssembly Class
See Also Example Members
[image]

Uninstalls assemblies.

Namespace: MSBuild.Community.Tasks.Install
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class UninstallAssembly
Inherits InstallAssembly
C#
public class UninstallAssembly : InstallAssembly
C++
ref class UninstallAssembly : InstallAssembly
J#
public class UninstallAssembly extends InstallAssembly
JScript
public class UninstallAssembly extends InstallAssembly

Example

Uninstall multiple assemblies by specifying the file names:

Copy Code
            <UninstallAssembly AssemblyFiles="Engine.dll;Presenter.dll" />
Unnstall an assembly using the assembly name. Also disable the log file by setting it to a single space:
Copy Code
            <UninstallAssembly AssemblyNames="Engine,Version=1.5.0.0,Culture=neutral" LogFile=" "/>

Remarks

Uses InstallUtil.exe to execute the Uninstall method of Installer classes contained within specified assemblies.

Inheritance Hierarchy

System.Object
Microsoft.Build.Utilities.Task
Microsoft.Build.Utilities.ToolTask
MSBuild.Community.Tasks.Install.InstallAssembly
MSBuild.Community.Tasks.Install.UninstallAssembly

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

UninstallAssembly Members
MSBuild.Community.Tasks.Install Namespace


UninstallAssembly Members

UninstallAssembly Members
See Also Example Constructors Properties Methods
[image]

Uninstalls assemblies.

The following tables list the members exposed by UninstallAssembly.

Public Constructors

 | Name | Description
Public method | UninstallAssembly | Initializes a new instance of the UninstallAssembly class.
Top

Public Properties

 | Name | Description
Public property | AssemblyFiles | The assemblies to process, identified by their filename. (inherited from InstallAssembly)
Public property | AssemblyNames | The assemblies to process, identified by their assembly name. (inherited from InstallAssembly)
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | ExitCode | Gets the returned exit code of the executable file. (inherited from ToolTask)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | LogFile | The file to write installation progress to. (inherited from InstallAssembly)
Public property | ShowCallStack | If an exception occurs at any point during installation, the call stack will be printed to the log. (inherited from InstallAssembly)
Public property | Timeout | Gets or sets the amount of time after which the task executable is terminated. (inherited from ToolTask)
Public property | ToolPath | Gets or sets the path of the executable file to run. (inherited from ToolTask)
Top

Protected Properties

 | Name | Description
Family property | EnvironmentOverride | Gets the override value of the PATH environment variable. (inherited from ToolTask)
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | IsUninstall | Overidden. Determines whether assemblies are installed or uninstalled.
Family property | ResponseFileEncoding | Gets the Encoding of the response file. (inherited from ToolTask)
Family property | StandardErrorEncoding | Gets the Encoding of the standard error stream of the task. (inherited from ToolTask)
Family property | StandardErrorLoggingImportance | Gets the MessageImportance with which to log errors. (inherited from ToolTask)
Family property | StandardOutputEncoding | Gets the Encoding of the standard output stream of the task. (inherited from ToolTask)
Family property | StandardOutputLoggingImportance | Gets the MessageImportance with which to log errors. (inherited from ToolTask)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Family property | ToolName | Gets the name of the executable file to run. (inherited from InstallAssembly)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Runs the exectuable file with the specified task parameters. (inherited from ToolTask)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | CallHostObjectToExecute | Calls the host object to perform the work of the task. (inherited from ToolTask)
Family method | ExecuteTool | Creates a temporoary response (.rsp) file and runs the executable file. (inherited from ToolTask)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GenerateCommandLineCommands | Returns a string value containing the command line arguments to pass directly to the executable file. (inherited from InstallAssembly)
Family method | GenerateFullPathToTool | Returns the fully qualified path to the executable file. (inherited from InstallAssembly)
Family method | GenerateResponseFileCommands | Returns a string value containing the command line arguments to add to the response (.rsp) file before running the executable file. (inherited from ToolTask)
Family method | GetResponseFileSwitch | Returns the command line switch used by the executable file to specifiy a response (.rsp) file. (inherited from ToolTask)
Family method | GetWorkingDirectory | Returns the directory in which to run the executable file. (inherited from ToolTask)
Family method | HandleTaskExecutionErrors | Handles execution errors raised by the executable file. (inherited from ToolTask)
Family method | InitializeHostObject | Initializes the host object of the task. (inherited from ToolTask)
Family method | LogEventsFromTextOutput | (inherited from ToolTask)
Family method | LogPathToTool | Logs the tool name and path to all registered loggers. (inherited from ToolTask)
Family method | LogToolCommand | Logs the starting point of the run to all registered loggers. (inherited from ToolTask)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | SkipTaskExecution | Indicates whether task execution should be skipped. (inherited from ToolTask)
Family method | ValidateParameters | Indicates whether all task paratmeters are valid. (inherited from ToolTask)
Top

See Also

UninstallAssembly Class
UninstallAssembly Members
MSBuild.Community.Tasks.Install Namespace


UninstallAssembly Constructor

UninstallAssembly Constructor
[image]

Initializes a new instance of the UninstallAssembly class.

Namespace: MSBuild.Community.Tasks.Install
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public UninstallAssembly()
C++
public:
UninstallAssembly() sealed
J#
public UninstallAssembly()
JScript
public function UninstallAssembly()

See Also

UninstallAssembly Class
UninstallAssembly Members
MSBuild.Community.Tasks.Install Namespace


Properties

UninstallAssembly Properties
See Also Example
[image]

Public Properties

 | Name | Description
Public property | AssemblyFiles | The assemblies to process, identified by their filename. (inherited from InstallAssembly)
Public property | AssemblyNames | The assemblies to process, identified by their assembly name. (inherited from InstallAssembly)
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | ExitCode | Gets the returned exit code of the executable file. (inherited from ToolTask)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | LogFile | The file to write installation progress to. (inherited from InstallAssembly)
Public property | ShowCallStack | If an exception occurs at any point during installation, the call stack will be printed to the log. (inherited from InstallAssembly)
Public property | Timeout | Gets or sets the amount of time after which the task executable is terminated. (inherited from ToolTask)
Public property | ToolPath | Gets or sets the path of the executable file to run. (inherited from ToolTask)
Top

Protected Properties

 | Name | Description
Family property | EnvironmentOverride | Gets the override value of the PATH environment variable. (inherited from ToolTask)
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | IsUninstall | Overidden. Determines whether assemblies are installed or uninstalled.
Family property | ResponseFileEncoding | Gets the Encoding of the response file. (inherited from ToolTask)
Family property | StandardErrorEncoding | Gets the Encoding of the standard error stream of the task. (inherited from ToolTask)
Family property | StandardErrorLoggingImportance | Gets the MessageImportance with which to log errors. (inherited from ToolTask)
Family property | StandardOutputEncoding | Gets the Encoding of the standard output stream of the task. (inherited from ToolTask)
Family property | StandardOutputLoggingImportance | Gets the MessageImportance with which to log errors. (inherited from ToolTask)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Family property | ToolName | Gets the name of the executable file to run. (inherited from InstallAssembly)
Top

See Also

UninstallAssembly Class
UninstallAssembly Members
MSBuild.Community.Tasks.Install Namespace


IsUninstall Property

UninstallAssembly.IsUninstall Property
[image]

Determines whether assemblies are installed or uninstalled.

Namespace: MSBuild.Community.Tasks.Install
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property IsUninstall As Boolean
C#
protected override bool IsUninstall { get; }
C++
protected override property bool IsUninstall override {
bool get();
}
J#
/** property */
protected bool get_IsUninstall();
JScript
protected function get IsUninstall() : bool

See Also

UninstallAssembly Class
UninstallAssembly Members
MSBuild.Community.Tasks.Install Namespace


MSBuild.Community.Tasks.JavaScript

MSBuild.Community.Tasks.JavaScript Namespace
See Also Hierarchy

Classes

 | Class | Description
Public class | JSCompress | Compresses JavaScript source by removing comments and unnecessary whitespace. It typically reduces the size of the script by half, resulting in faster downloads and code that is harder to read.


JSCompress Class

JSCompress Class
See Also Members
[image]

Compresses JavaScript source by removing comments and unnecessary whitespace. It typically reduces the size of the script by half, resulting in faster downloads and code that is harder to read.

Namespace: MSBuild.Community.Tasks.JavaScript
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class JSCompress
Inherits Task
C#
public class JSCompress : Task
C++
ref class JSCompress : Task
J#
public class JSCompress extends Task
JScript
public class JSCompress extends Task

Remarks

This task does not change the behavior of the program that it is compressing. The resulting code will be harder to debug as well as harder to read.

Inheritance Hierarchy

System.Object
Microsoft.Build.Utilities.Task
MSBuild.Community.Tasks.JavaScript.JSCompress

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

JSCompress Members
MSBuild.Community.Tasks.JavaScript Namespace


JSCompress Members

JSCompress Members
See Also Constructors Properties Methods
[image]

Compresses JavaScript source by removing comments and unnecessary whitespace. It typically reduces the size of the script by half, resulting in faster downloads and code that is harder to read.

The following tables list the members exposed by JSCompress.

Public Constructors

 | Name | Description
Public method | JSCompress | Initializes a new instance of the JSCompress class.
Top

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | CompressedFiles | Gets the files that were successfully source-compressed.
Public property | Encoding | Encoding to use to read and write files.
Public property | Files | Gets or sets the files to source-compress.
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. When overridden in a derived class, executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

JSCompress Class
JSCompress Members
MSBuild.Community.Tasks.JavaScript Namespace


JSCompress Constructor

JSCompress Constructor
[image]

Initializes a new instance of the JSCompress class.

Namespace: MSBuild.Community.Tasks.JavaScript
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public JSCompress()
C++
public:
JSCompress() sealed
J#
public JSCompress()
JScript
public function JSCompress()

See Also

JSCompress Class
JSCompress Members
MSBuild.Community.Tasks.JavaScript Namespace


Properties

JSCompress Properties
[image]

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | CompressedFiles | Gets the files that were successfully source-compressed.
Public property | Encoding | Encoding to use to read and write files.
Public property | Files | Gets or sets the files to source-compress.
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

See Also

JSCompress Class
JSCompress Members
MSBuild.Community.Tasks.JavaScript Namespace


CompressedFiles Property

JSCompress.CompressedFiles Property
[image]

Gets the files that were successfully source-compressed.

Namespace: MSBuild.Community.Tasks.JavaScript
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Output>
Public ReadOnly Property CompressedFiles As ITaskItem[]
C#
[Output]
public ITaskItem[] CompressedFiles { get; }
C++
[Output]
public property ITaskItem[] CompressedFiles sealed {
array<ITaskItem>^ get();
}
J#
/** @attribute Output() */
/** property */
public ITaskItem[] get_CompressedFiles();
JScript
public function get CompressedFiles() : ITaskItem[]

See Also

JSCompress Class
JSCompress Members
MSBuild.Community.Tasks.JavaScript Namespace


Encoding Property

JSCompress.Encoding Property
[image]

Encoding to use to read and write files.

Namespace: MSBuild.Community.Tasks.JavaScript
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Encoding As String
C#
public string Encoding { get; set; }
C++
public property string Encoding sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Encoding();

/** property */
public void set_Encoding(string value);
JScript
public function get Encoding() : String

public function set Encoding(value : String);

See Also

JSCompress Class
JSCompress Members
MSBuild.Community.Tasks.JavaScript Namespace


Files Property

JSCompress.Files Property
[image]

Gets or sets the files to source-compress.

Namespace: MSBuild.Community.Tasks.JavaScript
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Required>
Public Property Files As ITaskItem[]
C#
[Required]
public ITaskItem[] Files { get; set; }
C++
[Required]
public property ITaskItem[] Files sealed {
array<ITaskItem>^ get();
void set(array<ITaskItem>^ value);
}
J#
/** @attribute Required() */
/** property */
public ITaskItem[] get_Files();

/** property */
public void set_Files(ITaskItem[] value);
JScript
public function get Files() : ITaskItem[]

public function set Files(value : ITaskItem[]);

See Also

JSCompress Class
JSCompress Members
MSBuild.Community.Tasks.JavaScript Namespace


Methods

JSCompress Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. When overridden in a derived class, executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

JSCompress Class
JSCompress Members
MSBuild.Community.Tasks.JavaScript Namespace


Execute Method

JSCompress.Execute Method
[image]

When overridden in a derived class, executes the task.

Namespace: MSBuild.Community.Tasks.JavaScript
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute() As Boolean _
Implements ITask.Execute
C#
public override bool Execute()
C++
public:
virtual bool Execute() override
J#
public override bool Execute()
JScript
public override function Execute() : bool

Return Value

true if the task successfully executed; otherwise, false.

Implements

ITask.Execute

See Also

JSCompress Class
JSCompress Members
MSBuild.Community.Tasks.JavaScript Namespace


MSBuild.Community.Tasks.Math

MSBuild.Community.Tasks.Math Namespace
See Also Hierarchy

Math Tasks for MSBuild

Classes

 | Class | Description
Public class | Add | Add numbers
Public class | Divide | Divide numbers
Public class | MathBase | Math task base class This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | Modulo | Performs the modulo operation on numbers.
Public class | Multiple | Multiple numbers
Public class | Subtract | Subtract numbers


Add Class

Add Class
See Also Example Members
[image]

Add numbers

Namespace: MSBuild.Community.Tasks.Math
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class Add
Inherits MathBase
C#
public class Add : MathBase
C++
ref class Add : MathBase
J#
public class Add extends MathBase
JScript
public class Add extends MathBase

Example

Adding numbers:

Copy Code
            <Math.Add Numbers="4;3">
                <Output TaskParameter="Result" PropertyName="Result" />
            </Math.Add>
            <Message Text="Add 4+3= $(Result)"/>

Inheritance Hierarchy

System.Object
Microsoft.Build.Utilities.Task
MSBuild.Community.Tasks.Math.MathBase
MSBuild.Community.Tasks.Math.Add

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

Add Members
MSBuild.Community.Tasks.Math Namespace


Add Members

Add Members
See Also Example Constructors Properties Methods
[image]

Add numbers

The following tables list the members exposed by Add.

Public Constructors

 | Name | Description
Public method | Add | Initializes a new instance of the Add class.
Top

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Numbers | Gets or sets the numbers to work with. (inherited from MathBase)
Public property | NumericFormat | Gets or sets the numeric format. (inherited from MathBase)
Public property | Result | Gets or sets the result. (inherited from MathBase)
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. When overridden in a derived class, executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | StringArrayToDecimalArray | Strings array to decimal array. (inherited from MathBase)
Top

See Also

Add Class
Add Members
MSBuild.Community.Tasks.Math Namespace


Add Constructor

Add Constructor
[image]

Initializes a new instance of the Add class.

Namespace: MSBuild.Community.Tasks.Math
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public Add()
C++
public:
Add() sealed
J#
public Add()
JScript
public function Add()

See Also

Add Class
Add Members
MSBuild.Community.Tasks.Math Namespace


Methods

Add Methods
See Also Example
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. When overridden in a derived class, executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | StringArrayToDecimalArray | Strings array to decimal array. (inherited from MathBase)
Top

See Also

Add Class
Add Members
MSBuild.Community.Tasks.Math Namespace


Execute Method

Add.Execute Method
[image]

When overridden in a derived class, executes the task.

Namespace: MSBuild.Community.Tasks.Math
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute() As Boolean _
Implements ITask.Execute
C#
public override bool Execute()
C++
public:
virtual bool Execute() override
J#
public override bool Execute()
JScript
public override function Execute() : bool

Return Value

true if the task successfully executed; otherwise, false.

Implements

ITask.Execute

See Also

Add Class
Add Members
MSBuild.Community.Tasks.Math Namespace


Divide Class

Divide Class
See Also Example Members
[image]

Divide numbers

Namespace: MSBuild.Community.Tasks.Math
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class Divide
Inherits MathBase
C#
public class Divide : MathBase
C++
ref class Divide : MathBase
J#
public class Divide extends MathBase
JScript
public class Divide extends MathBase

Example

Copy Code
<Math.Divide Numbers="1;2">
    <Output TaskParameter="Result" PropertyName="Result" />
</Math.Divide>
<Message Text="Divide 1/2= $(Result)"/>
Above example will display:
Copy Code
Divide 1/2= 0.5
Truncate the result to always return an integer:
Copy Code
<Math.Divide Numbers="7;3" TruncateResult="true">
    <Output TaskParameter="Result" PropertyName="Result" />
</Math.Divide>
<Message Text="Divide 7/3= $(Result)"/>
Above example will display:
Copy Code
Divide 7/3= 2

Inheritance Hierarchy

System.Object
Microsoft.Build.Utilities.Task
MSBuild.Community.Tasks.Math.MathBase
MSBuild.Community.Tasks.Math.Divide

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

Divide Members
MSBuild.Community.Tasks.Math Namespace


Divide Members

Divide Members
See Also Example Constructors Properties Methods
[image]

Divide numbers

The following tables list the members exposed by Divide.

Public Constructors

 | Name | Description
Public method | Divide | Initializes a new instance of the Divide class.
Top

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Numbers | Gets or sets the numbers to work with. (inherited from MathBase)
Public property | NumericFormat | Gets or sets the numeric format. (inherited from MathBase)
Public property | Result | Gets or sets the result. (inherited from MathBase)
Public property | TruncateResult | When true, uses integer division to truncate the result. Default is false
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. When overridden in a derived class, executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | StringArrayToDecimalArray | Strings array to decimal array. (inherited from MathBase)
Top

See Also

Divide Class
Divide Members
MSBuild.Community.Tasks.Math Namespace


Divide Constructor

Divide Constructor
[image]

Initializes a new instance of the Divide class.

Namespace: MSBuild.Community.Tasks.Math
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public Divide()
C++
public:
Divide() sealed
J#
public Divide()
JScript
public function Divide()

See Also

Divide Class
Divide Members
MSBuild.Community.Tasks.Math Namespace


Properties

Divide Properties
See Also Example
[image]

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Numbers | Gets or sets the numbers to work with. (inherited from MathBase)
Public property | NumericFormat | Gets or sets the numeric format. (inherited from MathBase)
Public property | Result | Gets or sets the result. (inherited from MathBase)
Public property | TruncateResult | When true, uses integer division to truncate the result. Default is false
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

See Also

Divide Class
Divide Members
MSBuild.Community.Tasks.Math Namespace


TruncateResult Property

Divide.TruncateResult Property
[image]

When true, uses integer division to truncate the result. Default is false

Namespace: MSBuild.Community.Tasks.Math
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property TruncateResult As Boolean
C#
public bool TruncateResult { get; set; }
C++
public property bool TruncateResult sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_TruncateResult();

/** property */
public void set_TruncateResult(bool value);
JScript
public function get TruncateResult() : bool

public function set TruncateResult(value : bool);

Remarks

Any remainder in the result is dropped, and the closest integer to zero is returned.

Refer to the documentation for the \ Operator for more information about integer division.

See Also

Divide Class
Divide Members
MSBuild.Community.Tasks.Math Namespace


Methods

Divide Methods
See Also Example
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. When overridden in a derived class, executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | StringArrayToDecimalArray | Strings array to decimal array. (inherited from MathBase)
Top

See Also

Divide Class
Divide Members
MSBuild.Community.Tasks.Math Namespace


Execute Method

Divide.Execute Method
[image]

When overridden in a derived class, executes the task.

Namespace: MSBuild.Community.Tasks.Math
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute() As Boolean _
Implements ITask.Execute
C#
public override bool Execute()
C++
public:
virtual bool Execute() override
J#
public override bool Execute()
JScript
public override function Execute() : bool

Return Value

true if the task successfully executed; otherwise, false.

Implements

ITask.Execute

See Also

Divide Class
Divide Members
MSBuild.Community.Tasks.Math Namespace


MathBase Class

MathBase Class
See Also Members
[image]

Math task base class This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: MSBuild.Community.Tasks.Math
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class MathBase
Inherits Task
C#
public abstract class MathBase : Task
C++
ref class MathBase abstract : Task
J#
public class MathBase extends Task
JScript
public class MathBase extends Task

Inheritance Hierarchy

System.Object
Microsoft.Build.Utilities.Task
MSBuild.Community.Tasks.Math.MathBase
MSBuild.Community.Tasks.Math.Add
MSBuild.Community.Tasks.Math.Divide
MSBuild.Community.Tasks.Math.Modulo
MSBuild.Community.Tasks.Math.Multiple
MSBuild.Community.Tasks.Math.Subtract

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

MathBase Members
MSBuild.Community.Tasks.Math Namespace


MathBase Members

MathBase Members
See Also Constructors Properties Methods
[image]

Math task base class This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by MathBase.

Protected Constructors

 | Name | Description
Family method | MathBase | Initializes a new instance of the MathBase class.
Top

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Numbers | Gets or sets the numbers to work with.
Public property | NumericFormat | Gets or sets the numeric format.
Public property | Result | Gets or sets the result.
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. When overridden in a derived class, executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | StringArrayToDecimalArray | Strings array to decimal array.
Top

See Also

MathBase Class
MathBase Members
MSBuild.Community.Tasks.Math Namespace


MathBase Constructor

MathBase Constructor
[image]

Initializes a new instance of the MathBase class.

Namespace: MSBuild.Community.Tasks.Math
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New()
C#
protected MathBase()
C++
protected:
MathBase() sealed
J#
protected MathBase()
JScript
protected function MathBase()

See Also

MathBase Class
MathBase Members
MSBuild.Community.Tasks.Math Namespace


Properties

MathBase Properties
[image]

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Numbers | Gets or sets the numbers to work with.
Public property | NumericFormat | Gets or sets the numeric format.
Public property | Result | Gets or sets the result.
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

See Also

MathBase Class
MathBase Members
MSBuild.Community.Tasks.Math Namespace


Numbers Property

MathBase.Numbers Property
[image]

Gets or sets the numbers to work with.

Namespace: MSBuild.Community.Tasks.Math
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Required>
Public Property Numbers As String[]
C#
[Required]
public string[] Numbers { get; set; }
C++
[Required]
public property string[] Numbers sealed {
array<String>^ get();
void set(array<String>^ value);
}
J#
/** @attribute Required() */
/** property */
public string[] get_Numbers();

/** property */
public void set_Numbers(string[] value);
JScript
public function get Numbers() : String[]

public function set Numbers(value : String[]);

Property Value

The numbers.

See Also

MathBase Class
MathBase Members
MSBuild.Community.Tasks.Math Namespace


NumericFormat Property

MathBase.NumericFormat Property
[image]

Gets or sets the numeric format.

Namespace: MSBuild.Community.Tasks.Math
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property NumericFormat As String
C#
public string NumericFormat { get; set; }
C++
public property string NumericFormat sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_NumericFormat();

/** property */
public void set_NumericFormat(string value);
JScript
public function get NumericFormat() : String

public function set NumericFormat(value : String);

Property Value

The numeric format.

See Also

MathBase Class
MathBase Members
MSBuild.Community.Tasks.Math Namespace


Result Property

MathBase.Result Property
[image]

Gets or sets the result.

Namespace: MSBuild.Community.Tasks.Math
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Output>
Public Property Result As String
C#
[Output]
public string Result { get; set; }
C++
[Output]
public property string Result sealed {
String get();
void set(String value);
}
J#
/** @attribute Output() */
/** property */
public string get_Result();

/** property */
public void set_Result(string value);
JScript
public function get Result() : String

public function set Result(value : String);

Property Value

The result.

See Also

MathBase Class
MathBase Members
MSBuild.Community.Tasks.Math Namespace


Methods

MathBase Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. When overridden in a derived class, executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | StringArrayToDecimalArray | Strings array to decimal array.
Top

See Also

MathBase Class
MathBase Members
MSBuild.Community.Tasks.Math Namespace


Execute Method

MathBase.Execute Method
[image]

When overridden in a derived class, executes the task.

Namespace: MSBuild.Community.Tasks.Math
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute() As Boolean _
Implements ITask.Execute
C#
public override bool Execute()
C++
public:
virtual bool Execute() override
J#
public override bool Execute()
JScript
public override function Execute() : bool

Return Value

true if the task successfully executed; otherwise, false.

Implements

ITask.Execute

See Also

MathBase Class
MathBase Members
MSBuild.Community.Tasks.Math Namespace


StringArrayToDecimalArray Method

MathBase.StringArrayToDecimalArray Method
[image]

Strings array to decimal array.

Namespace: MSBuild.Community.Tasks.Math
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Function StringArrayToDecimalArray( _
ByVal numbers As String[] _
) As Decimal[]
C#
protected decimal[] StringArrayToDecimalArray(
string[] numbers
)
C++
protected:
array<decimal>^ StringArrayToDecimalArray(
array<String>^ numbers
) sealed
J#
protected decimal[] StringArrayToDecimalArray(
string[] numbers
)
JScript
protected function StringArrayToDecimalArray(
numbers : String[]
) : Decimal[]

Parameters

numbers
The numbers.

See Also

MathBase Class
MathBase Members
MSBuild.Community.Tasks.Math Namespace


Modulo Class

Modulo Class
See Also Example Members
[image]

Performs the modulo operation on numbers.

Namespace: MSBuild.Community.Tasks.Math
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class Modulo
Inherits MathBase
C#
public class Modulo : MathBase
C++
ref class Modulo : MathBase
J#
public class Modulo extends MathBase
JScript
public class Modulo extends MathBase

Example

Numbers evenly divide:

Copy Code
<Math.Modulo Numbers="12;4">
    <Output TaskParameter="Result" PropertyName="Result" />
</Math.Modulo>
<Message Text="12 modulo 4 = $(Result)"/>
Above example will display:
Copy Code
12 modulo 4 = 0
Division on the numbers produces a remainder:
Copy Code
<Math.Modulo Numbers="14;4">
    <Output TaskParameter="Result" PropertyName="Result" />
</Math.Modulo>
<Message Text="14 modulo 4 = $(Result)"/>
Above example will display:
Copy Code
14 modulo 4 = 2
Modulus is a fractional value:
Copy Code
<Math.Modulo Numbers="12;3.5">
    <Output TaskParameter="Result" PropertyName="Result" />
</Math.Modulo>
<Message Text="12 modulo 3.5 = $(Result)"/>
Above example will display:
Copy Code
12 modulo 3.5 = 1.5

Remarks

The modulo operation finds the remainder of the division of one number by another.

When the second number (modulus) is a fractional value, the result can be a fractional value.

Equivalent to the % operator in C# or the Mod operator in Visual Basic.

Inheritance Hierarchy

System.Object
Microsoft.Build.Utilities.Task
MSBuild.Community.Tasks.Math.MathBase
MSBuild.Community.Tasks.Math.Modulo

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

Modulo Members
MSBuild.Community.Tasks.Math Namespace


Modulo Members

Modulo Members
See Also Example Constructors Properties Methods
[image]

Performs the modulo operation on numbers.

The following tables list the members exposed by Modulo.

Public Constructors

 | Name | Description
Public method | Modulo | Initializes a new instance of the Modulo class.
Top

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Numbers | Gets or sets the numbers to work with. (inherited from MathBase)
Public property | NumericFormat | Gets or sets the numeric format. (inherited from MathBase)
Public property | Result | Gets or sets the result. (inherited from MathBase)
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. When overridden in a derived class, executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | StringArrayToDecimalArray | Strings array to decimal array. (inherited from MathBase)
Top

See Also

Modulo Class
Modulo Members
MSBuild.Community.Tasks.Math Namespace


Modulo Constructor

Modulo Constructor
[image]

Initializes a new instance of the Modulo class.

Namespace: MSBuild.Community.Tasks.Math
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public Modulo()
C++
public:
Modulo() sealed
J#
public Modulo()
JScript
public function Modulo()

See Also

Modulo Class
Modulo Members
MSBuild.Community.Tasks.Math Namespace


Methods

Modulo Methods
See Also Example
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. When overridden in a derived class, executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | StringArrayToDecimalArray | Strings array to decimal array. (inherited from MathBase)
Top

See Also

Modulo Class
Modulo Members
MSBuild.Community.Tasks.Math Namespace


Execute Method

Modulo.Execute Method
[image]

When overridden in a derived class, executes the task.

Namespace: MSBuild.Community.Tasks.Math
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute() As Boolean _
Implements ITask.Execute
C#
public override bool Execute()
C++
public:
virtual bool Execute() override
J#
public override bool Execute()
JScript
public override function Execute() : bool

Return Value

true if the task successfully executed; otherwise, false.

Implements

ITask.Execute

See Also

Modulo Class
Modulo Members
MSBuild.Community.Tasks.Math Namespace


Multiple Class

Multiple Class
See Also Example Members
[image]

Multiple numbers

Namespace: MSBuild.Community.Tasks.Math
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class Multiple
Inherits MathBase
C#
public class Multiple : MathBase
C++
ref class Multiple : MathBase
J#
public class Multiple extends MathBase
JScript
public class Multiple extends MathBase

Example

Copy Code
            <Math.Multiple Numbers="10;3">
                <Output TaskParameter="Result" PropertyName="Result" />
            </Math.Multiple>
            <Message Text="Multiple 10*3= $(Result)"/>

Inheritance Hierarchy

System.Object
Microsoft.Build.Utilities.Task
MSBuild.Community.Tasks.Math.MathBase
MSBuild.Community.Tasks.Math.Multiple

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

Multiple Members
MSBuild.Community.Tasks.Math Namespace


Multiple Members

Multiple Members
See Also Example Constructors Properties Methods
[image]

Multiple numbers

The following tables list the members exposed by Multiple.

Public Constructors

 | Name | Description
Public method | Multiple | Initializes a new instance of the Multiple class.
Top

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Numbers | Gets or sets the numbers to work with. (inherited from MathBase)
Public property | NumericFormat | Gets or sets the numeric format. (inherited from MathBase)
Public property | Result | Gets or sets the result. (inherited from MathBase)
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. When overridden in a derived class, executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | StringArrayToDecimalArray | Strings array to decimal array. (inherited from MathBase)
Top

See Also

Multiple Class
Multiple Members
MSBuild.Community.Tasks.Math Namespace


Multiple Constructor

Multiple Constructor
[image]

Initializes a new instance of the Multiple class.

Namespace: MSBuild.Community.Tasks.Math
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public Multiple()
C++
public:
Multiple() sealed
J#
public Multiple()
JScript
public function Multiple()

See Also

Multiple Class
Multiple Members
MSBuild.Community.Tasks.Math Namespace


Methods

Multiple Methods
See Also Example
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. When overridden in a derived class, executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | StringArrayToDecimalArray | Strings array to decimal array. (inherited from MathBase)
Top

See Also

Multiple Class
Multiple Members
MSBuild.Community.Tasks.Math Namespace


Execute Method

Multiple.Execute Method
[image]

When overridden in a derived class, executes the task.

Namespace: MSBuild.Community.Tasks.Math
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute() As Boolean _
Implements ITask.Execute
C#
public override bool Execute()
C++
public:
virtual bool Execute() override
J#
public override bool Execute()
JScript
public override function Execute() : bool

Return Value

true if the task successfully executed; otherwise, false.

Implements

ITask.Execute

See Also

Multiple Class
Multiple Members
MSBuild.Community.Tasks.Math Namespace


Subtract Class

Subtract Class
See Also Example Members
[image]

Subtract numbers

Namespace: MSBuild.Community.Tasks.Math
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class Subtract
Inherits MathBase
C#
public class Subtract : MathBase
C++
ref class Subtract : MathBase
J#
public class Subtract extends MathBase
JScript
public class Subtract extends MathBase

Example

Copy Code
            <Math.Subtract Numbers="10;3">
                <Output TaskParameter="Result" PropertyName="Result" />
            </Math.Subtract>
            <Message Text="Subtract 10-3= $(Result)"/>

Inheritance Hierarchy

System.Object
Microsoft.Build.Utilities.Task
MSBuild.Community.Tasks.Math.MathBase
MSBuild.Community.Tasks.Math.Subtract

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

Subtract Members
MSBuild.Community.Tasks.Math Namespace


Subtract Members

Subtract Members
See Also Example Constructors Properties Methods
[image]

Subtract numbers

The following tables list the members exposed by Subtract.

Public Constructors

 | Name | Description
Public method | Subtract | Initializes a new instance of the Subtract class.
Top

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Numbers | Gets or sets the numbers to work with. (inherited from MathBase)
Public property | NumericFormat | Gets or sets the numeric format. (inherited from MathBase)
Public property | Result | Gets or sets the result. (inherited from MathBase)
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. When overridden in a derived class, executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | StringArrayToDecimalArray | Strings array to decimal array. (inherited from MathBase)
Top

See Also

Subtract Class
Subtract Members
MSBuild.Community.Tasks.Math Namespace


Subtract Constructor

Subtract Constructor
[image]

Initializes a new instance of the Subtract class.

Namespace: MSBuild.Community.Tasks.Math
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public Subtract()
C++
public:
Subtract() sealed
J#
public Subtract()
JScript
public function Subtract()

See Also

Subtract Class
Subtract Members
MSBuild.Community.Tasks.Math Namespace


Methods

Subtract Methods
See Also Example
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. When overridden in a derived class, executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | StringArrayToDecimalArray | Strings array to decimal array. (inherited from MathBase)
Top

See Also

Subtract Class
Subtract Members
MSBuild.Community.Tasks.Math Namespace


Execute Method

Subtract.Execute Method
[image]

When overridden in a derived class, executes the task.

Namespace: MSBuild.Community.Tasks.Math
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute() As Boolean _
Implements ITask.Execute
C#
public override bool Execute()
C++
public:
virtual bool Execute() override
J#
public override bool Execute()
JScript
public override function Execute() : bool

Return Value

true if the task successfully executed; otherwise, false.

Implements

ITask.Execute

See Also

Subtract Class
Subtract Members
MSBuild.Community.Tasks.Math Namespace


MSBuild.Community.Tasks.Schema

MSBuild.Community.Tasks.Schema Namespace
See Also Hierarchy

Classes

 | Class | Description
Public class | TaskSchema | A Task that generates a XSD schema of the tasks in an assembly.

Enumerations

 | Enumeration | Description
Public enumeration | TaskListAssemblyFormatType | Different ways to specify the assembly in a UsingTask element.


TaskListAssemblyFormatType Enumeration

TaskListAssemblyFormatType Enumeration
[image]

Different ways to specify the assembly in a UsingTask element.

Namespace: MSBuild.Community.Tasks.Schema
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Enum TaskListAssemblyFormatType
C#
public enum TaskListAssemblyFormatType
C++
public enum class TaskListAssemblyFormatType
J#
public enum TaskListAssemblyFormatType
JScript
public enum TaskListAssemblyFormatType

Members

Member Name | Description
AssemblyFileName | Assembly file name (Default): <UsingTask AssemblyFile="foo.dll" />
AssemblyFileFullPath | Assembly location: <UsingTask AssemblyName="foo" />
AssemblyName | Assembly Name: <UsingTask AssemblyFile="bin\debug\foo.dll" />
AssemblyFullName | Assembly fully qualified name: <UsingTask AssemblyName="foo.dll,version ...." />

See Also

TaskListAssemblyFormatType Members
MSBuild.Community.Tasks.Schema Namespace


TaskSchema Class

TaskSchema Class
See Also Example Members
[image]

A Task that generates a XSD schema of the tasks in an assembly.

Namespace: MSBuild.Community.Tasks.Schema
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class TaskSchema
Inherits Task
C#
public class TaskSchema : Task
C++
ref class TaskSchema : Task
J#
public class TaskSchema extends Task
JScript
public class TaskSchema extends Task

Example

Creates schema for MSBuild Community Task project

Copy Code
            <TaskSchema Assemblies="Build\MSBuild.Community.Tasks.dll"
                OutputPath="Build"
                CreateTaskList="true"
                IgnoreMsBuildSchema="true"
                Includes="Microsoft.Build.Commontypes.xsd"/>

Inheritance Hierarchy

System.Object
Microsoft.Build.Utilities.Task
MSBuild.Community.Tasks.Schema.TaskSchema

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

TaskSchema Members
MSBuild.Community.Tasks.Schema Namespace


TaskSchema Members

TaskSchema Members
See Also Example Constructors Properties Methods
[image]

A Task that generates a XSD schema of the tasks in an assembly.

The following tables list the members exposed by TaskSchema.

Public Constructors

 | Name | Description
Public method | TaskSchema | Initializes a new instance of the TaskSchema class.
Top

Public Properties

 | Name | Description
Public property | Assemblies | Gets or sets the list of Assembly path to analyse.
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | CreateTaskList | Gets or sets a value indicating if the task list (using UsingTask) has to be genereted.
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | IgnoreDocumentation | Gets or sets a value indicating wheter documentation should be ignored even if available (Default is false).
Public property | IgnoreMsBuildSchema | Gets or sets a value indicating if the MsBuild schema inclusing should be ignored
Public property | Includes | Gets or sets a list of included schemas
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | OutputPath | Gets or sets the output path for the generated files.
Public property | Schemas | Gets the list of path to the generated XSD schema.
Public property | TaskListAssemblyFormat | Gets or sets a value indicating how the assembly is specified in the UsingTask element.
Public property | TaskLists | Gets the path to the task list if it was generated.
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. When overridden in a derived class, executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

TaskSchema Class
TaskSchema Members
MSBuild.Community.Tasks.Schema Namespace


TaskSchema Constructor

TaskSchema Constructor
[image]

Initializes a new instance of the TaskSchema class.

Namespace: MSBuild.Community.Tasks.Schema
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public TaskSchema()
C++
public:
TaskSchema() sealed
J#
public TaskSchema()
JScript
public function TaskSchema()

See Also

TaskSchema Class
TaskSchema Members
MSBuild.Community.Tasks.Schema Namespace


Properties

TaskSchema Properties
See Also Example
[image]

Public Properties

 | Name | Description
Public property | Assemblies | Gets or sets the list of Assembly path to analyse.
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | CreateTaskList | Gets or sets a value indicating if the task list (using UsingTask) has to be genereted.
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | IgnoreDocumentation | Gets or sets a value indicating wheter documentation should be ignored even if available (Default is false).
Public property | IgnoreMsBuildSchema | Gets or sets a value indicating if the MsBuild schema inclusing should be ignored
Public property | Includes | Gets or sets a list of included schemas
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | OutputPath | Gets or sets the output path for the generated files.
Public property | Schemas | Gets the list of path to the generated XSD schema.
Public property | TaskListAssemblyFormat | Gets or sets a value indicating how the assembly is specified in the UsingTask element.
Public property | TaskLists | Gets the path to the task list if it was generated.
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

See Also

TaskSchema Class
TaskSchema Members
MSBuild.Community.Tasks.Schema Namespace


Assemblies Property

TaskSchema.Assemblies Property
[image]

Gets or sets the list of Assembly path to analyse.

Namespace: MSBuild.Community.Tasks.Schema
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Required>
Public Property Assemblies As ITaskItem[]
C#
[Required]
public ITaskItem[] Assemblies { get; set; }
C++
[Required]
public property ITaskItem[] Assemblies sealed {
array<ITaskItem>^ get();
void set(array<ITaskItem>^ value);
}
J#
/** @attribute Required() */
/** property */
public ITaskItem[] get_Assemblies();

/** property */
public void set_Assemblies(ITaskItem[] value);
JScript
public function get Assemblies() : ITaskItem[]

public function set Assemblies(value : ITaskItem[]);

See Also

TaskSchema Class
TaskSchema Members
MSBuild.Community.Tasks.Schema Namespace


CreateTaskList Property

TaskSchema.CreateTaskList Property
[image]

Gets or sets a value indicating if the task list (using UsingTask) has to be genereted.

Namespace: MSBuild.Community.Tasks.Schema
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property CreateTaskList As Boolean
C#
public bool CreateTaskList { get; set; }
C++
public property bool CreateTaskList sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_CreateTaskList();

/** property */
public void set_CreateTaskList(bool value);
JScript
public function get CreateTaskList() : bool

public function set CreateTaskList(value : bool);

See Also

TaskSchema Class
TaskSchema Members
MSBuild.Community.Tasks.Schema Namespace


IgnoreDocumentation Property

TaskSchema.IgnoreDocumentation Property
[image]

Gets or sets a value indicating wheter documentation should be ignored even if available (Default is false).

Namespace: MSBuild.Community.Tasks.Schema
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property IgnoreDocumentation As Boolean
C#
public bool IgnoreDocumentation { get; set; }
C++
public property bool IgnoreDocumentation sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_IgnoreDocumentation();

/** property */
public void set_IgnoreDocumentation(bool value);
JScript
public function get IgnoreDocumentation() : bool

public function set IgnoreDocumentation(value : bool);

See Also

TaskSchema Class
TaskSchema Members
MSBuild.Community.Tasks.Schema Namespace


IgnoreMsBuildSchema Property

TaskSchema.IgnoreMsBuildSchema Property
[image]

Gets or sets a value indicating if the MsBuild schema inclusing should be ignored

Namespace: MSBuild.Community.Tasks.Schema
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property IgnoreMsBuildSchema As Boolean
C#
public bool IgnoreMsBuildSchema { get; set; }
C++
public property bool IgnoreMsBuildSchema sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_IgnoreMsBuildSchema();

/** property */
public void set_IgnoreMsBuildSchema(bool value);
JScript
public function get IgnoreMsBuildSchema() : bool

public function set IgnoreMsBuildSchema(value : bool);

See Also

TaskSchema Class
TaskSchema Members
MSBuild.Community.Tasks.Schema Namespace


Includes Property

TaskSchema.Includes Property
[image]

Gets or sets a list of included schemas

Namespace: MSBuild.Community.Tasks.Schema
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Includes As ITaskItem[]
C#
public ITaskItem[] Includes { get; set; }
C++
public property ITaskItem[] Includes sealed {
array<ITaskItem>^ get();
void set(array<ITaskItem>^ value);
}
J#
/** property */
public ITaskItem[] get_Includes();

/** property */
public void set_Includes(ITaskItem[] value);
JScript
public function get Includes() : ITaskItem[]

public function set Includes(value : ITaskItem[]);

See Also

TaskSchema Class
TaskSchema Members
MSBuild.Community.Tasks.Schema Namespace


OutputPath Property

TaskSchema.OutputPath Property
[image]

Gets or sets the output path for the generated files.

Namespace: MSBuild.Community.Tasks.Schema
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property OutputPath As String
C#
public string OutputPath { get; set; }
C++
public property string OutputPath sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_OutputPath();

/** property */
public void set_OutputPath(string value);
JScript
public function get OutputPath() : String

public function set OutputPath(value : String);

See Also

TaskSchema Class
TaskSchema Members
MSBuild.Community.Tasks.Schema Namespace


Schemas Property

TaskSchema.Schemas Property
[image]

Gets the list of path to the generated XSD schema.

Namespace: MSBuild.Community.Tasks.Schema
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Output>
Public ReadOnly Property Schemas As ITaskItem[]
C#
[Output]
public ITaskItem[] Schemas { get; }
C++
[Output]
public property ITaskItem[] Schemas sealed {
array<ITaskItem>^ get();
}
J#
/** @attribute Output() */
/** property */
public ITaskItem[] get_Schemas();
JScript
public function get Schemas() : ITaskItem[]

See Also

TaskSchema Class
TaskSchema Members
MSBuild.Community.Tasks.Schema Namespace


TaskListAssemblyFormat Property

TaskSchema.TaskListAssemblyFormat Property
[image]

Gets or sets a value indicating how the assembly is specified in the UsingTask element.

Namespace: MSBuild.Community.Tasks.Schema
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property TaskListAssemblyFormat As String
C#
public string TaskListAssemblyFormat { get; set; }
C++
public property string TaskListAssemblyFormat sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_TaskListAssemblyFormat();

/** property */
public void set_TaskListAssemblyFormat(string value);
JScript
public function get TaskListAssemblyFormat() : String

public function set TaskListAssemblyFormat(value : String);

See Also

TaskSchema Class
TaskSchema Members
MSBuild.Community.Tasks.Schema Namespace


TaskLists Property

TaskSchema.TaskLists Property
[image]

Gets the path to the task list if it was generated.

Namespace: MSBuild.Community.Tasks.Schema
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Output>
Public ReadOnly Property TaskLists As ITaskItem[]
C#
[Output]
public ITaskItem[] TaskLists { get; }
C++
[Output]
public property ITaskItem[] TaskLists sealed {
array<ITaskItem>^ get();
}
J#
/** @attribute Output() */
/** property */
public ITaskItem[] get_TaskLists();
JScript
public function get TaskLists() : ITaskItem[]

See Also

TaskSchema Class
TaskSchema Members
MSBuild.Community.Tasks.Schema Namespace


Methods

TaskSchema Methods
See Also Example
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. When overridden in a derived class, executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

TaskSchema Class
TaskSchema Members
MSBuild.Community.Tasks.Schema Namespace


Execute Method

TaskSchema.Execute Method
[image]

When overridden in a derived class, executes the task.

Namespace: MSBuild.Community.Tasks.Schema
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute() As Boolean _
Implements ITask.Execute
C#
public override bool Execute()
C++
public:
virtual bool Execute() override
J#
public override bool Execute()
JScript
public override function Execute() : bool

Return Value

true if the task successfully executed; otherwise, false.

Implements

ITask.Execute

See Also

TaskSchema Class
TaskSchema Members
MSBuild.Community.Tasks.Schema Namespace


MSBuild.Community.Tasks.SourceSafe

MSBuild.Community.Tasks.SourceSafe Namespace
See Also Hierarchy

Classes

 | Class | Description
Public class | VssAdd | Task that adds files to a Visual SourceSafe database.
Public class | VssBase | Base class for all of the Visual SourceSafe tasks. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | VssCheckin | Task that executes a checkin against a VSS Database.
Public class | VssCheckout | Task that executes a checkout of files or projects against a Visual SourceSafe database.
Public class | VssClean | Task that can strip the source control information from a Visual Studio Solution and subprojects.
Public class | VssDiff | Task that records differences between the latest version of all the items in a Visual SourceSafe project and another version or label to a file.
Public class | VssGet | Task that retireves an item or project from a Visual SourceSafe database.
Public class | VssHistory | Generates an XML file containing details of all changes made to a Visual SourceSafe project or file between specified labels or dates.
Public class | VssLabel | Task that applies a label to a Visual SourceSafe item.
Public class | VssRecursiveBase | Base class for VSS tasks that can act recursively. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | VssUndoCheckout | Task that undoes a checkout of files or projects against a Visual SourceSafe database.


VssAdd Class

VssAdd Class
See Also Members
[image]

Task that adds files to a Visual SourceSafe database.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class VssAdd
Inherits VssBase
C#
public class VssAdd : VssBase
C++
ref class VssAdd : VssBase
J#
public class VssAdd extends VssBase
JScript
public class VssAdd extends VssBase

Inheritance Hierarchy

System.Object
Microsoft.Build.Utilities.Task
MSBuild.Community.Tasks.SourceSafe.VssBase
MSBuild.Community.Tasks.SourceSafe.VssAdd

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

VssAdd Members
MSBuild.Community.Tasks.SourceSafe Namespace


VssAdd Members

VssAdd Members
See Also Constructors Properties Methods
[image]

Task that adds files to a Visual SourceSafe database.

The following tables list the members exposed by VssAdd.

Public Constructors

 | Name | Description
Public method | VssAdd | Initializes a new instance of the VssAdd class.
Top

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | Comment | The comment to be applied to the newly added file.
Public property | DatabasePath | The path to the folder that contains the srcsafe.ini file. (inherited from VssBase)
Public property | Files | List of files that should be added to SourceSafe.
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Password | The password to use to log in to SourceSafe. (inherited from VssBase)
Public property | Path | The Visual SourceSafe project or file to perform the action on (starts with "$/"). (inherited from VssBase)
Public property | UserName | The name of the user accessing the SourceSafe database. (inherited from VssBase)
Public property | Version | A version of the Path to reference. (inherited from VssBase)
Top

Protected Properties

 | Name | Description
Family property | Database | Represents the VSS Database (inherited from VssBase)
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | Item | Represents the VSS item selected (file or project). (inherited from VssBase)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. Executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | ConnectToDatabase | Attempts to connect to the SourceSafe Database and load the specified item, or version of the item, if specified. (inherited from VssBase)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | LogErrorFromException | Logs an exception using the MSBuild logging framework. (inherited from VssBase)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

VssAdd Class
VssAdd Members
MSBuild.Community.Tasks.SourceSafe Namespace


VssAdd Constructor

VssAdd Constructor
[image]

Initializes a new instance of the VssAdd class.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public VssAdd()
C++
public:
VssAdd() sealed
J#
public VssAdd()
JScript
public function VssAdd()

See Also

VssAdd Class
VssAdd Members
MSBuild.Community.Tasks.SourceSafe Namespace


Properties

VssAdd Properties
[image]

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | Comment | The comment to be applied to the newly added file.
Public property | DatabasePath | The path to the folder that contains the srcsafe.ini file. (inherited from VssBase)
Public property | Files | List of files that should be added to SourceSafe.
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Password | The password to use to log in to SourceSafe. (inherited from VssBase)
Public property | Path | The Visual SourceSafe project or file to perform the action on (starts with "$/"). (inherited from VssBase)
Public property | UserName | The name of the user accessing the SourceSafe database. (inherited from VssBase)
Public property | Version | A version of the Path to reference. (inherited from VssBase)
Top

Protected Properties

 | Name | Description
Family property | Database | Represents the VSS Database (inherited from VssBase)
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | Item | Represents the VSS item selected (file or project). (inherited from VssBase)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

See Also

VssAdd Class
VssAdd Members
MSBuild.Community.Tasks.SourceSafe Namespace


Comment Property

VssAdd.Comment Property
[image]

The comment to be applied to the newly added file.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Comment As String
C#
public string Comment { get; set; }
C++
public property string Comment sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Comment();

/** property */
public void set_Comment(string value);
JScript
public function get Comment() : String

public function set Comment(value : String);

See Also

VssAdd Class
VssAdd Members
MSBuild.Community.Tasks.SourceSafe Namespace


Files Property

VssAdd.Files Property
[image]

List of files that should be added to SourceSafe.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Required>
Public Property Files As ITaskItem[]
C#
[Required]
public ITaskItem[] Files { get; set; }
C++
[Required]
public property ITaskItem[] Files sealed {
array<ITaskItem>^ get();
void set(array<ITaskItem>^ value);
}
J#
/** @attribute Required() */
/** property */
public ITaskItem[] get_Files();

/** property */
public void set_Files(ITaskItem[] value);
JScript
public function get Files() : ITaskItem[]

public function set Files(value : ITaskItem[]);

See Also

VssAdd Class
VssAdd Members
MSBuild.Community.Tasks.SourceSafe Namespace


Methods

VssAdd Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. Executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | ConnectToDatabase | Attempts to connect to the SourceSafe Database and load the specified item, or version of the item, if specified. (inherited from VssBase)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | LogErrorFromException | Logs an exception using the MSBuild logging framework. (inherited from VssBase)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

VssAdd Class
VssAdd Members
MSBuild.Community.Tasks.SourceSafe Namespace


Execute Method

VssAdd.Execute Method
[image]

Executes the task.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute() As Boolean _
Implements ITask.Execute
C#
public override bool Execute()
C++
public:
virtual bool Execute() override
J#
public override bool Execute()
JScript
public override function Execute() : bool

Return Value

true if the task ran successfully; otherwise false.

Implements

ITask.Execute

See Also

VssAdd Class
VssAdd Members
MSBuild.Community.Tasks.SourceSafe Namespace


VssBase Class

VssBase Class
See Also Members
[image]

Base class for all of the Visual SourceSafe tasks. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class VssBase
Inherits Task
C#
public abstract class VssBase : Task
C++
ref class VssBase abstract : Task
J#
public class VssBase extends Task
JScript
public class VssBase extends Task

Inheritance Hierarchy

System.Object
Microsoft.Build.Utilities.Task
MSBuild.Community.Tasks.SourceSafe.VssBase
MSBuild.Community.Tasks.SourceSafe.VssAdd
MSBuild.Community.Tasks.SourceSafe.VssDiff
MSBuild.Community.Tasks.SourceSafe.VssRecursiveBase

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

VssBase Members
MSBuild.Community.Tasks.SourceSafe Namespace


VssBase Members

VssBase Members
See Also Constructors Properties Methods
[image]

Base class for all of the Visual SourceSafe tasks. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by VssBase.

Protected Constructors

 | Name | Description
Family method | VssBase | Initializes a new instance of the VssBase class.
Top

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | DatabasePath | The path to the folder that contains the srcsafe.ini file.
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Password | The password to use to log in to SourceSafe.
Public property | Path | The Visual SourceSafe project or file to perform the action on (starts with "$/").
Public property | UserName | The name of the user accessing the SourceSafe database.
Public property | Version | A version of the Path to reference.
Top

Protected Properties

 | Name | Description
Family property | Database | Represents the VSS Database
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | Item | Represents the VSS item selected (file or project).
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. Reserved.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | ConnectToDatabase | Attempts to connect to the SourceSafe Database and load the specified item, or version of the item, if specified.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | LogErrorFromException | Logs an exception using the MSBuild logging framework.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

VssBase Class
VssBase Members
MSBuild.Community.Tasks.SourceSafe Namespace


VssBase Constructor

VssBase Constructor
[image]

Initializes a new instance of the VssBase class.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New()
C#
protected VssBase()
C++
protected:
VssBase() sealed
J#
protected VssBase()
JScript
protected function VssBase()

See Also

VssBase Class
VssBase Members
MSBuild.Community.Tasks.SourceSafe Namespace


Properties

VssBase Properties
[image]

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | DatabasePath | The path to the folder that contains the srcsafe.ini file.
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Password | The password to use to log in to SourceSafe.
Public property | Path | The Visual SourceSafe project or file to perform the action on (starts with "$/").
Public property | UserName | The name of the user accessing the SourceSafe database.
Public property | Version | A version of the Path to reference.
Top

Protected Properties

 | Name | Description
Family property | Database | Represents the VSS Database
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | Item | Represents the VSS item selected (file or project).
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

See Also

VssBase Class
VssBase Members
MSBuild.Community.Tasks.SourceSafe Namespace


Database Property

VssBase.Database Property
[image]

Represents the VSS Database

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Property Database As VSSDatabase
C#
protected VSSDatabase Database { get; set; }
C++
protected property VSSDatabase Database sealed {
VSSDatabase get();
void set(VSSDatabase value);
}
J#
/** property */
protected VSSDatabase get_Database();

/** property */
protected void set_Database(VSSDatabase value);
JScript
protected function get Database() : VSSDatabase

protected function set Database(value : VSSDatabase);

See Also

VssBase Class
VssBase Members
MSBuild.Community.Tasks.SourceSafe Namespace


DatabasePath Property

VssBase.DatabasePath Property
[image]

The path to the folder that contains the srcsafe.ini file.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Required>
Public Property DatabasePath As String
C#
[Required]
public string DatabasePath { get; set; }
C++
[Required]
public property string DatabasePath sealed {
String get();
void set(String value);
}
J#
/** @attribute Required() */
/** property */
public string get_DatabasePath();

/** property */
public void set_DatabasePath(string value);
JScript
public function get DatabasePath() : String

public function set DatabasePath(value : String);

See Also

VssBase Class
VssBase Members
MSBuild.Community.Tasks.SourceSafe Namespace


Item Property

VssBase.Item Property
[image]

Represents the VSS item selected (file or project).

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Property Item As IVSSItem
C#
protected IVSSItem Item { get; set; }
C++
protected property IVSSItem Item sealed {
IVSSItem get();
void set(IVSSItem value);
}
J#
/** property */
protected IVSSItem get_Item();

/** property */
protected void set_Item(IVSSItem value);
JScript
protected function get Item() : IVSSItem

protected function set Item(value : IVSSItem);

See Also

VssBase Class
VssBase Members
MSBuild.Community.Tasks.SourceSafe Namespace


Password Property

VssBase.Password Property
[image]

The password to use to log in to SourceSafe.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Password As String
C#
public string Password { get; set; }
C++
public property string Password sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Password();

/** property */
public void set_Password(string value);
JScript
public function get Password() : String

public function set Password(value : String);

See Also

VssBase Class
VssBase Members
MSBuild.Community.Tasks.SourceSafe Namespace


Path Property

VssBase.Path Property
[image]

The Visual SourceSafe project or file to perform the action on (starts with "$/").

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Required>
Public Property Path As String
C#
[Required]
public string Path { get; set; }
C++
[Required]
public property string Path sealed {
String get();
void set(String value);
}
J#
/** @attribute Required() */
/** property */
public string get_Path();

/** property */
public void set_Path(string value);
JScript
public function get Path() : String

public function set Path(value : String);

See Also

VssBase Class
VssBase Members
MSBuild.Community.Tasks.SourceSafe Namespace


UserName Property

VssBase.UserName Property
[image]

The name of the user accessing the SourceSafe database.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Required>
Public Property UserName As String
C#
[Required]
public string UserName { get; set; }
C++
[Required]
public property string UserName sealed {
String get();
void set(String value);
}
J#
/** @attribute Required() */
/** property */
public string get_UserName();

/** property */
public void set_UserName(string value);
JScript
public function get UserName() : String

public function set UserName(value : String);

See Also

VssBase Class
VssBase Members
MSBuild.Community.Tasks.SourceSafe Namespace


Version Property

VssBase.Version Property
[image]

A version of the Path to reference.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Version As String
C#
public string Version { get; set; }
C++
public property string Version sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Version();

/** property */
public void set_Version(string value);
JScript
public function get Version() : String

public function set Version(value : String);

See Also

VssBase Class
VssBase Members
MSBuild.Community.Tasks.SourceSafe Namespace


Methods

VssBase Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. Reserved.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | ConnectToDatabase | Attempts to connect to the SourceSafe Database and load the specified item, or version of the item, if specified.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | LogErrorFromException | Logs an exception using the MSBuild logging framework.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

VssBase Class
VssBase Members
MSBuild.Community.Tasks.SourceSafe Namespace


ConnectToDatabase Method

VssBase.ConnectToDatabase Method
[image]

Attempts to connect to the SourceSafe Database and load the specified item, or version of the item, if specified.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Sub ConnectToDatabase()
C#
protected void ConnectToDatabase()
C++
protected:
void ConnectToDatabase() sealed
J#
protected void ConnectToDatabase()
JScript
protected function ConnectToDatabase()

See Also

VssBase Class
VssBase Members
MSBuild.Community.Tasks.SourceSafe Namespace


Execute Method

VssBase.Execute Method
[image]

Reserved.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute() As Boolean _
Implements ITask.Execute
C#
public override bool Execute()
C++
public:
virtual bool Execute() override
J#
public override bool Execute()
JScript
public override function Execute() : bool

Return Value

Reserved.

Implements

ITask.Execute

See Also

VssBase Class
VssBase Members
MSBuild.Community.Tasks.SourceSafe Namespace


LogErrorFromException Method

VssBase.LogErrorFromException Method
[image]

Logs an exception using the MSBuild logging framework.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Sub LogErrorFromException( _
ByVal e As Exception _
)
C#
protected void LogErrorFromException(
Exception e
)
C++
protected:
void LogErrorFromException(
Exception e
) sealed
J#
protected void LogErrorFromException(
Exception e
)
JScript
protected function LogErrorFromException(
e : Exception
)

Parameters

e
The Exception to log.

See Also

VssBase Class
VssBase Members
MSBuild.Community.Tasks.SourceSafe Namespace


VssCheckin Class

VssCheckin Class
See Also Example Members
[image]

Task that executes a checkin against a VSS Database.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class VssCheckin
Inherits VssRecursiveBase
C#
public class VssCheckin : VssRecursiveBase
C++
ref class VssCheckin : VssRecursiveBase
J#
public class VssCheckin extends VssRecursiveBase
JScript
public class VssCheckin extends VssRecursiveBase

Example

Copy Code
<VssCheckin UserName="ccnet_build"
              Password="build"
              LocalPath="C:\Dev\MyProjects\Project\TestFile.cs"
              Recursive="False"
              DatabasePath="\\VSSServer\VSS\srcsafe.ini"
              Path="$/Test/TestFile.cs"
            />

Inheritance Hierarchy

System.Object
Microsoft.Build.Utilities.Task
MSBuild.Community.Tasks.SourceSafe.VssBase
MSBuild.Community.Tasks.SourceSafe.VssRecursiveBase
MSBuild.Community.Tasks.SourceSafe.VssCheckin

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

VssCheckin Members
MSBuild.Community.Tasks.SourceSafe Namespace


VssCheckin Members

VssCheckin Members
See Also Example Constructors Properties Methods
[image]

Task that executes a checkin against a VSS Database.

The following tables list the members exposed by VssCheckin.

Public Constructors

 | Name | Description
Public method | VssCheckin | Initializes a new instance of the VssCheckin class.
Top

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | Comment | The checkin comment.
Public property | DatabasePath | The path to the folder that contains the srcsafe.ini file. (inherited from VssBase)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | LocalPath | The path to the local working directory.
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Password | The password to use to log in to SourceSafe. (inherited from VssBase)
Public property | Path | The Visual SourceSafe project or file to perform the action on (starts with "$/"). (inherited from VssBase)
Public property | Recursive | Determines whether to perform the SourceSafe operation recursively. The default is true. (inherited from VssRecursiveBase)
Public property | UserName | The name of the user accessing the SourceSafe database. (inherited from VssBase)
Public property | Version | A version of the Path to reference. (inherited from VssBase)
Public property | Writable | Determines whether to leave the file(s) as writable once the checkin is complete. The default is false.
Top

Protected Properties

 | Name | Description
Family property | Database | Represents the VSS Database (inherited from VssBase)
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | Item | Represents the VSS item selected (file or project). (inherited from VssBase)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. Executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | ConnectToDatabase | Attempts to connect to the SourceSafe Database and load the specified item, or version of the item, if specified. (inherited from VssBase)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | LogErrorFromException | Logs an exception using the MSBuild logging framework. (inherited from VssBase)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

VssCheckin Class
VssCheckin Members
MSBuild.Community.Tasks.SourceSafe Namespace


VssCheckin Constructor

VssCheckin Constructor
[image]

Initializes a new instance of the VssCheckin class.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public VssCheckin()
C++
public:
VssCheckin() sealed
J#
public VssCheckin()
JScript
public function VssCheckin()

See Also

VssCheckin Class
VssCheckin Members
MSBuild.Community.Tasks.SourceSafe Namespace


Properties

VssCheckin Properties
See Also Example
[image]

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | Comment | The checkin comment.
Public property | DatabasePath | The path to the folder that contains the srcsafe.ini file. (inherited from VssBase)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | LocalPath | The path to the local working directory.
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Password | The password to use to log in to SourceSafe. (inherited from VssBase)
Public property | Path | The Visual SourceSafe project or file to perform the action on (starts with "$/"). (inherited from VssBase)
Public property | Recursive | Determines whether to perform the SourceSafe operation recursively. The default is true. (inherited from VssRecursiveBase)
Public property | UserName | The name of the user accessing the SourceSafe database. (inherited from VssBase)
Public property | Version | A version of the Path to reference. (inherited from VssBase)
Public property | Writable | Determines whether to leave the file(s) as writable once the checkin is complete. The default is false.
Top

Protected Properties

 | Name | Description
Family property | Database | Represents the VSS Database (inherited from VssBase)
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | Item | Represents the VSS item selected (file or project). (inherited from VssBase)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

See Also

VssCheckin Class
VssCheckin Members
MSBuild.Community.Tasks.SourceSafe Namespace


Comment Property

VssCheckin.Comment Property
[image]

The checkin comment.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Comment As String
C#
public string Comment { get; set; }
C++
public property string Comment sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Comment();

/** property */
public void set_Comment(string value);
JScript
public function get Comment() : String

public function set Comment(value : String);

See Also

VssCheckin Class
VssCheckin Members
MSBuild.Community.Tasks.SourceSafe Namespace


LocalPath Property

VssCheckin.LocalPath Property
[image]

The path to the local working directory.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Required>
Public Property LocalPath As String
C#
[Required]
public string LocalPath { get; set; }
C++
[Required]
public property string LocalPath sealed {
String get();
void set(String value);
}
J#
/** @attribute Required() */
/** property */
public string get_LocalPath();

/** property */
public void set_LocalPath(string value);
JScript
public function get LocalPath() : String

public function set LocalPath(value : String);

See Also

VssCheckin Class
VssCheckin Members
MSBuild.Community.Tasks.SourceSafe Namespace


Writable Property

VssCheckin.Writable Property
[image]

Determines whether to leave the file(s) as writable once the checkin is complete. The default is false.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Writable As Boolean
C#
public bool Writable { get; set; }
C++
public property bool Writable sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_Writable();

/** property */
public void set_Writable(bool value);
JScript
public function get Writable() : bool

public function set Writable(value : bool);

See Also

VssCheckin Class
VssCheckin Members
MSBuild.Community.Tasks.SourceSafe Namespace


Methods

VssCheckin Methods
See Also Example
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. Executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | ConnectToDatabase | Attempts to connect to the SourceSafe Database and load the specified item, or version of the item, if specified. (inherited from VssBase)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | LogErrorFromException | Logs an exception using the MSBuild logging framework. (inherited from VssBase)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

VssCheckin Class
VssCheckin Members
MSBuild.Community.Tasks.SourceSafe Namespace


Execute Method

VssCheckin.Execute Method
[image]

Executes the task.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute() As Boolean _
Implements ITask.Execute
C#
public override bool Execute()
C++
public:
virtual bool Execute() override
J#
public override bool Execute()
JScript
public override function Execute() : bool

Return Value

true if the task ran successfully; otherwise false.

Implements

ITask.Execute

See Also

VssCheckin Class
VssCheckin Members
MSBuild.Community.Tasks.SourceSafe Namespace


VssCheckout Class

VssCheckout Class
See Also Example Members
[image]

Task that executes a checkout of files or projects against a Visual SourceSafe database.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class VssCheckout
Inherits VssRecursiveBase
C#
public class VssCheckout : VssRecursiveBase
C++
ref class VssCheckout : VssRecursiveBase
J#
public class VssCheckout extends VssRecursiveBase
JScript
public class VssCheckout extends VssRecursiveBase

Example

Copy Code
<VssCheckout UserName="ccnet_build"
              Password="build"
              LocalPath="C:\Dev\MyProjects\Project"
              Recursive="False"
              DatabasePath="\\VSSServer\VSS\srcsafe.ini"
              Path="$/Test/TestFile.cs"
            />

Inheritance Hierarchy

System.Object
Microsoft.Build.Utilities.Task
MSBuild.Community.Tasks.SourceSafe.VssBase
MSBuild.Community.Tasks.SourceSafe.VssRecursiveBase
MSBuild.Community.Tasks.SourceSafe.VssCheckout

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

VssCheckout Members
MSBuild.Community.Tasks.SourceSafe Namespace


VssCheckout Members

VssCheckout Members
See Also Example Constructors Properties Methods
[image]

Task that executes a checkout of files or projects against a Visual SourceSafe database.

The following tables list the members exposed by VssCheckout.

Public Constructors

 | Name | Description
Public method | VssCheckout | Initializes a new instance of the VssCheckout class.
Top

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | DatabasePath | The path to the folder that contains the srcsafe.ini file. (inherited from VssBase)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | LocalPath | The path to the local working directory.
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Password | The password to use to log in to SourceSafe. (inherited from VssBase)
Public property | Path | The Visual SourceSafe project or file to perform the action on (starts with "$/"). (inherited from VssBase)
Public property | Recursive | Determines whether to perform the SourceSafe operation recursively. The default is true. (inherited from VssRecursiveBase)
Public property | UserName | The name of the user accessing the SourceSafe database. (inherited from VssBase)
Public property | Version | A version of the Path to reference. (inherited from VssBase)
Public property | Writable | Determines whether files will be writable once retrieved from the repository. The default is false.
Top

Protected Properties

 | Name | Description
Family property | Database | Represents the VSS Database (inherited from VssBase)
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | Item | Represents the VSS item selected (file or project). (inherited from VssBase)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. Executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | ConnectToDatabase | Attempts to connect to the SourceSafe Database and load the specified item, or version of the item, if specified. (inherited from VssBase)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | LogErrorFromException | Logs an exception using the MSBuild logging framework. (inherited from VssBase)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

VssCheckout Class
VssCheckout Members
MSBuild.Community.Tasks.SourceSafe Namespace


VssCheckout Constructor

VssCheckout Constructor
[image]

Initializes a new instance of the VssCheckout class.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public VssCheckout()
C++
public:
VssCheckout() sealed
J#
public VssCheckout()
JScript
public function VssCheckout()

See Also

VssCheckout Class
VssCheckout Members
MSBuild.Community.Tasks.SourceSafe Namespace


Properties

VssCheckout Properties
See Also Example
[image]

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | DatabasePath | The path to the folder that contains the srcsafe.ini file. (inherited from VssBase)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | LocalPath | The path to the local working directory.
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Password | The password to use to log in to SourceSafe. (inherited from VssBase)
Public property | Path | The Visual SourceSafe project or file to perform the action on (starts with "$/"). (inherited from VssBase)
Public property | Recursive | Determines whether to perform the SourceSafe operation recursively. The default is true. (inherited from VssRecursiveBase)
Public property | UserName | The name of the user accessing the SourceSafe database. (inherited from VssBase)
Public property | Version | A version of the Path to reference. (inherited from VssBase)
Public property | Writable | Determines whether files will be writable once retrieved from the repository. The default is false.
Top

Protected Properties

 | Name | Description
Family property | Database | Represents the VSS Database (inherited from VssBase)
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | Item | Represents the VSS item selected (file or project). (inherited from VssBase)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

See Also

VssCheckout Class
VssCheckout Members
MSBuild.Community.Tasks.SourceSafe Namespace


LocalPath Property

VssCheckout.LocalPath Property
[image]

The path to the local working directory.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Required>
Public Property LocalPath As String
C#
[Required]
public string LocalPath { get; set; }
C++
[Required]
public property string LocalPath sealed {
String get();
void set(String value);
}
J#
/** @attribute Required() */
/** property */
public string get_LocalPath();

/** property */
public void set_LocalPath(string value);
JScript
public function get LocalPath() : String

public function set LocalPath(value : String);

See Also

VssCheckout Class
VssCheckout Members
MSBuild.Community.Tasks.SourceSafe Namespace


Writable Property

VssCheckout.Writable Property
[image]

Determines whether files will be writable once retrieved from the repository. The default is false.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Writable As Boolean
C#
public bool Writable { get; set; }
C++
public property bool Writable sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_Writable();

/** property */
public void set_Writable(bool value);
JScript
public function get Writable() : bool

public function set Writable(value : bool);

See Also

VssCheckout Class
VssCheckout Members
MSBuild.Community.Tasks.SourceSafe Namespace


Methods

VssCheckout Methods
See Also Example
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. Executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | ConnectToDatabase | Attempts to connect to the SourceSafe Database and load the specified item, or version of the item, if specified. (inherited from VssBase)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | LogErrorFromException | Logs an exception using the MSBuild logging framework. (inherited from VssBase)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

VssCheckout Class
VssCheckout Members
MSBuild.Community.Tasks.SourceSafe Namespace


Execute Method

VssCheckout.Execute Method
[image]

Executes the task.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute() As Boolean _
Implements ITask.Execute
C#
public override bool Execute()
C++
public:
virtual bool Execute() override
J#
public override bool Execute()
JScript
public override function Execute() : bool

Return Value

true if the task ran successfully; otherwise false.

Implements

ITask.Execute

See Also

VssCheckout Class
VssCheckout Members
MSBuild.Community.Tasks.SourceSafe Namespace


VssClean Class

VssClean Class
See Also Members
[image]

Task that can strip the source control information from a Visual Studio Solution and subprojects.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class VssClean
Inherits Task
C#
public class VssClean : Task
C++
ref class VssClean : Task
J#
public class VssClean extends Task
JScript
public class VssClean extends Task

Remarks

This task is useful if you keep an archive of the source tree at each build milestone, because it's irritating to have to remove source control binding manually once you've copied a version of the code from your archive.

Inheritance Hierarchy

System.Object
Microsoft.Build.Utilities.Task
MSBuild.Community.Tasks.SourceSafe.VssClean

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

VssClean Members
MSBuild.Community.Tasks.SourceSafe Namespace


VssClean Members

VssClean Members
See Also Constructors Properties Methods
[image]

Task that can strip the source control information from a Visual Studio Solution and subprojects.

The following tables list the members exposed by VssClean.

Public Constructors

 | Name | Description
Public method | VssClean | Initializes a new instance of the VssClean class.
Top

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. Executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

VssClean Class
VssClean Members
MSBuild.Community.Tasks.SourceSafe Namespace


VssClean Constructor

VssClean Constructor
[image]

Initializes a new instance of the VssClean class.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public VssClean()
C++
public:
VssClean() sealed
J#
public VssClean()
JScript
public function VssClean()

See Also

VssClean Class
VssClean Members
MSBuild.Community.Tasks.SourceSafe Namespace


Methods

VssClean Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. Executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

VssClean Class
VssClean Members
MSBuild.Community.Tasks.SourceSafe Namespace


Execute Method

VssClean.Execute Method
[image]

Executes the task.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute() As Boolean _
Implements ITask.Execute
C#
public override bool Execute()
C++
public:
virtual bool Execute() override
J#
public override bool Execute()
JScript
public override function Execute() : bool

Return Value

true if the task ran successfully; otherwise false.

Implements

ITask.Execute

See Also

VssClean Class
VssClean Members
MSBuild.Community.Tasks.SourceSafe Namespace


VssDiff Class

VssDiff Class
See Also Example Members
[image]

Task that records differences between the latest version of all the items in a Visual SourceSafe project and another version or label to a file.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class VssDiff
Inherits VssBase
C#
public class VssDiff : VssBase
C++
ref class VssDiff : VssBase
J#
public class VssDiff extends VssBase
JScript
public class VssDiff extends VssBase

Example

Generates a file containing all of the differences between the current version and the label "Test Label"

Copy Code
<VssDiff UserName="uid"
             Password="pwd"
             DatabasePath="\\VSSServer\VSS2\srcsafe.ini"
             Path="$/Test"
             OutputFile="Diff.xml"
             Label="Test Label"
            />

Inheritance Hierarchy

System.Object
Microsoft.Build.Utilities.Task
MSBuild.Community.Tasks.SourceSafe.VssBase
MSBuild.Community.Tasks.SourceSafe.VssDiff

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

VssDiff Members
MSBuild.Community.Tasks.SourceSafe Namespace


VssDiff Members

VssDiff Members
See Also Example Constructors Properties Methods
[image]

Task that records differences between the latest version of all the items in a Visual SourceSafe project and another version or label to a file.

The following tables list the members exposed by VssDiff.

Public Constructors

 | Name | Description
Public method | VssDiff | Initializes a new instance of the VssDiff class.
Top

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | DatabasePath | The path to the folder that contains the srcsafe.ini file. (inherited from VssBase)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Label | The value of the label to compare to.
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | OutputFile | The name of the file to send the output to.
Public property | Password | The password to use to log in to SourceSafe. (inherited from VssBase)
Public property | Path | The Visual SourceSafe project or file to perform the action on (starts with "$/"). (inherited from VssBase)
Public property | UserName | The name of the user accessing the SourceSafe database. (inherited from VssBase)
Public property | Version | A version of the Path to reference. (inherited from VssBase)
Top

Protected Properties

 | Name | Description
Family property | Database | Represents the VSS Database (inherited from VssBase)
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | Item | Represents the VSS item selected (file or project). (inherited from VssBase)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. Executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | ConnectToDatabase | Attempts to connect to the SourceSafe Database and load the specified item, or version of the item, if specified. (inherited from VssBase)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | LogErrorFromException | Logs an exception using the MSBuild logging framework. (inherited from VssBase)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

VssDiff Class
VssDiff Members
MSBuild.Community.Tasks.SourceSafe Namespace


VssDiff Constructor

VssDiff Constructor
[image]

Initializes a new instance of the VssDiff class.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public VssDiff()
C++
public:
VssDiff() sealed
J#
public VssDiff()
JScript
public function VssDiff()

See Also

VssDiff Class
VssDiff Members
MSBuild.Community.Tasks.SourceSafe Namespace


Properties

VssDiff Properties
See Also Example
[image]

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | DatabasePath | The path to the folder that contains the srcsafe.ini file. (inherited from VssBase)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Label | The value of the label to compare to.
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | OutputFile | The name of the file to send the output to.
Public property | Password | The password to use to log in to SourceSafe. (inherited from VssBase)
Public property | Path | The Visual SourceSafe project or file to perform the action on (starts with "$/"). (inherited from VssBase)
Public property | UserName | The name of the user accessing the SourceSafe database. (inherited from VssBase)
Public property | Version | A version of the Path to reference. (inherited from VssBase)
Top

Protected Properties

 | Name | Description
Family property | Database | Represents the VSS Database (inherited from VssBase)
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | Item | Represents the VSS item selected (file or project). (inherited from VssBase)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

See Also

VssDiff Class
VssDiff Members
MSBuild.Community.Tasks.SourceSafe Namespace


Label Property

VssDiff.Label Property
[image]

The value of the label to compare to.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Required>
Public Property Label As String
C#
[Required]
public string Label { get; set; }
C++
[Required]
public property string Label sealed {
String get();
void set(String value);
}
J#
/** @attribute Required() */
/** property */
public string get_Label();

/** property */
public void set_Label(string value);
JScript
public function get Label() : String

public function set Label(value : String);

See Also

VssDiff Class
VssDiff Members
MSBuild.Community.Tasks.SourceSafe Namespace


OutputFile Property

VssDiff.OutputFile Property
[image]

The name of the file to send the output to.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Required>
Public Property OutputFile As String
C#
[Required]
public string OutputFile { get; set; }
C++
[Required]
public property string OutputFile sealed {
String get();
void set(String value);
}
J#
/** @attribute Required() */
/** property */
public string get_OutputFile();

/** property */
public void set_OutputFile(string value);
JScript
public function get OutputFile() : String

public function set OutputFile(value : String);

See Also

VssDiff Class
VssDiff Members
MSBuild.Community.Tasks.SourceSafe Namespace


Methods

VssDiff Methods
See Also Example
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. Executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | ConnectToDatabase | Attempts to connect to the SourceSafe Database and load the specified item, or version of the item, if specified. (inherited from VssBase)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | LogErrorFromException | Logs an exception using the MSBuild logging framework. (inherited from VssBase)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

VssDiff Class
VssDiff Members
MSBuild.Community.Tasks.SourceSafe Namespace


Execute Method

VssDiff.Execute Method
[image]

Executes the task.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute() As Boolean _
Implements ITask.Execute
C#
public override bool Execute()
C++
public:
virtual bool Execute() override
J#
public override bool Execute()
JScript
public override function Execute() : bool

Return Value

true if the task ran successfully; otherwise false.

Implements

ITask.Execute

See Also

VssDiff Class
VssDiff Members
MSBuild.Community.Tasks.SourceSafe Namespace


VssGet Class

VssGet Class
See Also Example Members
[image]

Task that retireves an item or project from a Visual SourceSafe database.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class VssGet
Inherits VssRecursiveBase
C#
public class VssGet : VssRecursiveBase
C++
ref class VssGet : VssRecursiveBase
J#
public class VssGet extends VssRecursiveBase
JScript
public class VssGet extends VssRecursiveBase

Example

Get the latest version (recursive) of a file from a VSS database and place in the specified local folder.

Copy Code
            <VssGet UserName="user"
                Password="password"
                LocalPath="C:\Dev\MyProjects\Project"
                Recursive="True"
                DatabasePath="\\VSSServer\VSS\srcsafe.ini"
                Path="$/Project"

Inheritance Hierarchy

System.Object
Microsoft.Build.Utilities.Task
MSBuild.Community.Tasks.SourceSafe.VssBase
MSBuild.Community.Tasks.SourceSafe.VssRecursiveBase
MSBuild.Community.Tasks.SourceSafe.VssGet

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

VssGet Members
MSBuild.Community.Tasks.SourceSafe Namespace


VssGet Members

VssGet Members
See Also Example Constructors Properties Methods
[image]

Task that retireves an item or project from a Visual SourceSafe database.

The following tables list the members exposed by VssGet.

Public Constructors

 | Name | Description
Public method | VssGet | Initializes a new instance of the VssGet class.
Top

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | DatabasePath | The path to the folder that contains the srcsafe.ini file. (inherited from VssBase)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | LocalPath | The path to the local working directory.
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Password | The password to use to log in to SourceSafe. (inherited from VssBase)
Public property | Path | The Visual SourceSafe project or file to perform the action on (starts with "$/"). (inherited from VssBase)
Public property | Recursive | Determines whether to perform the SourceSafe operation recursively. The default is true. (inherited from VssRecursiveBase)
Public property | Replace | Determines whether to replace writable files. The default is false.
Public property | UserName | The name of the user accessing the SourceSafe database. (inherited from VssBase)
Public property | Version | A version of the Path to reference. (inherited from VssBase)
Public property | Writable | Determines whether files will be writable once retrieved from the repository. The default is false.
Top

Protected Properties

 | Name | Description
Family property | Database | Represents the VSS Database (inherited from VssBase)
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | Item | Represents the VSS item selected (file or project). (inherited from VssBase)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. Runs the task using the specified parameters.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | ConnectToDatabase | Attempts to connect to the SourceSafe Database and load the specified item, or version of the item, if specified. (inherited from VssBase)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | LogErrorFromException | Logs an exception using the MSBuild logging framework. (inherited from VssBase)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

VssGet Class
VssGet Members
MSBuild.Community.Tasks.SourceSafe Namespace


VssGet Constructor

VssGet Constructor
[image]

Initializes a new instance of the VssGet class.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public VssGet()
C++
public:
VssGet() sealed
J#
public VssGet()
JScript
public function VssGet()

See Also

VssGet Class
VssGet Members
MSBuild.Community.Tasks.SourceSafe Namespace


Properties

VssGet Properties
See Also Example
[image]

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | DatabasePath | The path to the folder that contains the srcsafe.ini file. (inherited from VssBase)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | LocalPath | The path to the local working directory.
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Password | The password to use to log in to SourceSafe. (inherited from VssBase)
Public property | Path | The Visual SourceSafe project or file to perform the action on (starts with "$/"). (inherited from VssBase)
Public property | Recursive | Determines whether to perform the SourceSafe operation recursively. The default is true. (inherited from VssRecursiveBase)
Public property | Replace | Determines whether to replace writable files. The default is false.
Public property | UserName | The name of the user accessing the SourceSafe database. (inherited from VssBase)
Public property | Version | A version of the Path to reference. (inherited from VssBase)
Public property | Writable | Determines whether files will be writable once retrieved from the repository. The default is false.
Top

Protected Properties

 | Name | Description
Family property | Database | Represents the VSS Database (inherited from VssBase)
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | Item | Represents the VSS item selected (file or project). (inherited from VssBase)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

See Also

VssGet Class
VssGet Members
MSBuild.Community.Tasks.SourceSafe Namespace


LocalPath Property

VssGet.LocalPath Property
[image]

The path to the local working directory.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Required>
Public Property LocalPath As String
C#
[Required]
public string LocalPath { get; set; }
C++
[Required]
public property string LocalPath sealed {
String get();
void set(String value);
}
J#
/** @attribute Required() */
/** property */
public string get_LocalPath();

/** property */
public void set_LocalPath(string value);
JScript
public function get LocalPath() : String

public function set LocalPath(value : String);

See Also

VssGet Class
VssGet Members
MSBuild.Community.Tasks.SourceSafe Namespace


Replace Property

VssGet.Replace Property
[image]

Determines whether to replace writable files. The default is false.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Replace As Boolean
C#
public bool Replace { get; set; }
C++
public property bool Replace sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_Replace();

/** property */
public void set_Replace(bool value);
JScript
public function get Replace() : bool

public function set Replace(value : bool);

See Also

VssGet Class
VssGet Members
MSBuild.Community.Tasks.SourceSafe Namespace


Writable Property

VssGet.Writable Property
[image]

Determines whether files will be writable once retrieved from the repository. The default is false.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Writable As Boolean
C#
public bool Writable { get; set; }
C++
public property bool Writable sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_Writable();

/** property */
public void set_Writable(bool value);
JScript
public function get Writable() : bool

public function set Writable(value : bool);

See Also

VssGet Class
VssGet Members
MSBuild.Community.Tasks.SourceSafe Namespace


Methods

VssGet Methods
See Also Example
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. Runs the task using the specified parameters.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | ConnectToDatabase | Attempts to connect to the SourceSafe Database and load the specified item, or version of the item, if specified. (inherited from VssBase)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | LogErrorFromException | Logs an exception using the MSBuild logging framework. (inherited from VssBase)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

VssGet Class
VssGet Members
MSBuild.Community.Tasks.SourceSafe Namespace


Execute Method

VssGet.Execute Method
[image]

Runs the task using the specified parameters.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute() As Boolean _
Implements ITask.Execute
C#
public override bool Execute()
C++
public:
virtual bool Execute() override
J#
public override bool Execute()
JScript
public override function Execute() : bool

Return Value

true if the task ran successfully; otherwise false.

Implements

ITask.Execute

See Also

VssGet Class
VssGet Members
MSBuild.Community.Tasks.SourceSafe Namespace


VssHistory Class

VssHistory Class
See Also Example Members
[image]

Generates an XML file containing details of all changes made to a Visual SourceSafe project or file between specified labels or dates.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class VssHistory
Inherits VssRecursiveBase
C#
public class VssHistory : VssRecursiveBase
C++
ref class VssHistory : VssRecursiveBase
J#
public class VssHistory extends VssRecursiveBase
JScript
public class VssHistory extends VssRecursiveBase

Example

Generates a file containing details of all the changes made to the $/Test project by a user called joe.bloggs

Copy Code
<VssHistory UserName="uid"
             Password="pwd"
             DatabasePath="\\VSSServer\VSS\srcsafe.ini"
             Path="$/Test"
             User="joe.bloggs"
             OutputFile="History.xml"
             Recursive="True"
            />

Generates a file containing details of all the changes made between the labels Build1 and Build2 in the $/Test project.

Copy Code
<VssHistory UserName="uid"
             Password="pwd"
             DatabasePath="\\VSSServer\VSS\srcsafe.ini"
             Path="$/Test"
             FromLabel="Build1"
             ToLabel="Build2"
             OutputFile="History.xml"
             Recursive="True"
            />

Generates a file containing details of all the changes made between the 1st December 2005 and 10th December 2005in the $/Test project.

Copy Code
<VssHistory UserName="uid"
             Password="pwd"
             DatabasePath="\\VSSServer\VSS\srcsafe.ini"
             Path="$/Test"
             FromDate="2005-12-01 00:00"
             ToDate="2005-12-10 00:00"
             OutputFile="History.xml"
             Recursive="True"
            />

Inheritance Hierarchy

System.Object
Microsoft.Build.Utilities.Task
MSBuild.Community.Tasks.SourceSafe.VssBase
MSBuild.Community.Tasks.SourceSafe.VssRecursiveBase
MSBuild.Community.Tasks.SourceSafe.VssHistory

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

VssHistory Members
MSBuild.Community.Tasks.SourceSafe Namespace


VssHistory Members

VssHistory Members
See Also Example Constructors Properties Methods
[image]

Generates an XML file containing details of all changes made to a Visual SourceSafe project or file between specified labels or dates.

The following tables list the members exposed by VssHistory.

Public Constructors

 | Name | Description
Public method | VssHistory | Initializes a new instance of the VssHistory class.
Top

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | DatabasePath | The path to the folder that contains the srcsafe.ini file. (inherited from VssBase)
Public property | FromDate | The End Date for the history.
Public property | FromLabel | The label to compare up to.
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | OutputFile | The name and path of the XML output file.
Public property | Password | The password to use to log in to SourceSafe. (inherited from VssBase)
Public property | Path | The Visual SourceSafe project or file to perform the action on (starts with "$/"). (inherited from VssBase)
Public property | Recursive | Determines whether to perform the SourceSafe operation recursively. The default is true. (inherited from VssRecursiveBase)
Public property | ToDate | The Start Date for the history.
Public property | ToLabel | The label to start comparing to.
Public property | User | The name of the user whose changes should be listed in the history.
Public property | UserName | The name of the user accessing the SourceSafe database. (inherited from VssBase)
Public property | Version | A version of the Path to reference. (inherited from VssBase)
Top

Protected Properties

 | Name | Description
Family property | Database | Represents the VSS Database (inherited from VssBase)
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | Item | Represents the VSS item selected (file or project). (inherited from VssBase)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. Executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | ConnectToDatabase | Attempts to connect to the SourceSafe Database and load the specified item, or version of the item, if specified. (inherited from VssBase)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | LogErrorFromException | Logs an exception using the MSBuild logging framework. (inherited from VssBase)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

VssHistory Class
VssHistory Members
MSBuild.Community.Tasks.SourceSafe Namespace


VssHistory Constructor

VssHistory Constructor
[image]

Initializes a new instance of the VssHistory class.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public VssHistory()
C++
public:
VssHistory() sealed
J#
public VssHistory()
JScript
public function VssHistory()

See Also

VssHistory Class
VssHistory Members
MSBuild.Community.Tasks.SourceSafe Namespace


Properties

VssHistory Properties
See Also Example
[image]

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | DatabasePath | The path to the folder that contains the srcsafe.ini file. (inherited from VssBase)
Public property | FromDate | The End Date for the history.
Public property | FromLabel | The label to compare up to.
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | OutputFile | The name and path of the XML output file.
Public property | Password | The password to use to log in to SourceSafe. (inherited from VssBase)
Public property | Path | The Visual SourceSafe project or file to perform the action on (starts with "$/"). (inherited from VssBase)
Public property | Recursive | Determines whether to perform the SourceSafe operation recursively. The default is true. (inherited from VssRecursiveBase)
Public property | ToDate | The Start Date for the history.
Public property | ToLabel | The label to start comparing to.
Public property | User | The name of the user whose changes should be listed in the history.
Public property | UserName | The name of the user accessing the SourceSafe database. (inherited from VssBase)
Public property | Version | A version of the Path to reference. (inherited from VssBase)
Top

Protected Properties

 | Name | Description
Family property | Database | Represents the VSS Database (inherited from VssBase)
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | Item | Represents the VSS item selected (file or project). (inherited from VssBase)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

See Also

VssHistory Class
VssHistory Members
MSBuild.Community.Tasks.SourceSafe Namespace


FromDate Property

VssHistory.FromDate Property
[image]

The End Date for the history.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property FromDate As Date
C#
public DateTime FromDate { get; set; }
C++
public property DateTime FromDate sealed {
DateTime get();
void set(DateTime value);
}
J#
/** property */
public DateTime get_FromDate();

/** property */
public void set_FromDate(DateTime value);
JScript
public function get FromDate() : DateTime

public function set FromDate(value : DateTime);

See Also

VssHistory Class
VssHistory Members
MSBuild.Community.Tasks.SourceSafe Namespace


FromLabel Property

VssHistory.FromLabel Property
[image]

The label to compare up to.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property FromLabel As String
C#
public string FromLabel { get; set; }
C++
public property string FromLabel sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_FromLabel();

/** property */
public void set_FromLabel(string value);
JScript
public function get FromLabel() : String

public function set FromLabel(value : String);

See Also

VssHistory Class
VssHistory Members
MSBuild.Community.Tasks.SourceSafe Namespace


OutputFile Property

VssHistory.OutputFile Property
[image]

The name and path of the XML output file.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Required>
Public Property OutputFile As String
C#
[Required]
public string OutputFile { get; set; }
C++
[Required]
public property string OutputFile sealed {
String get();
void set(String value);
}
J#
/** @attribute Required() */
/** property */
public string get_OutputFile();

/** property */
public void set_OutputFile(string value);
JScript
public function get OutputFile() : String

public function set OutputFile(value : String);

See Also

VssHistory Class
VssHistory Members
MSBuild.Community.Tasks.SourceSafe Namespace


ToDate Property

VssHistory.ToDate Property
[image]

The Start Date for the history.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property ToDate As Date
C#
public DateTime ToDate { get; set; }
C++
public property DateTime ToDate sealed {
DateTime get();
void set(DateTime value);
}
J#
/** property */
public DateTime get_ToDate();

/** property */
public void set_ToDate(DateTime value);
JScript
public function get ToDate() : DateTime

public function set ToDate(value : DateTime);

See Also

VssHistory Class
VssHistory Members
MSBuild.Community.Tasks.SourceSafe Namespace


ToLabel Property

VssHistory.ToLabel Property
[image]

The label to start comparing to.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property ToLabel As String
C#
public string ToLabel { get; set; }
C++
public property string ToLabel sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_ToLabel();

/** property */
public void set_ToLabel(string value);
JScript
public function get ToLabel() : String

public function set ToLabel(value : String);

See Also

VssHistory Class
VssHistory Members
MSBuild.Community.Tasks.SourceSafe Namespace


User Property

VssHistory.User Property
[image]

The name of the user whose changes should be listed in the history.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property User As String
C#
public string User { get; set; }
C++
public property string User sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_User();

/** property */
public void set_User(string value);
JScript
public function get User() : String

public function set User(value : String);

See Also

VssHistory Class
VssHistory Members
MSBuild.Community.Tasks.SourceSafe Namespace


Methods

VssHistory Methods
See Also Example
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. Executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | ConnectToDatabase | Attempts to connect to the SourceSafe Database and load the specified item, or version of the item, if specified. (inherited from VssBase)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | LogErrorFromException | Logs an exception using the MSBuild logging framework. (inherited from VssBase)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

VssHistory Class
VssHistory Members
MSBuild.Community.Tasks.SourceSafe Namespace


Execute Method

VssHistory.Execute Method
[image]

Executes the task.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute() As Boolean _
Implements ITask.Execute
C#
public override bool Execute()
C++
public:
virtual bool Execute() override
J#
public override bool Execute()
JScript
public override function Execute() : bool

Return Value

true if the task ran successfully; otherwise false.

Implements

ITask.Execute

See Also

VssHistory Class
VssHistory Members
MSBuild.Community.Tasks.SourceSafe Namespace


VssLabel Class

VssLabel Class
See Also Members
[image]

Task that applies a label to a Visual SourceSafe item.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class VssLabel
Inherits VssRecursiveBase
C#
public class VssLabel : VssRecursiveBase
C++
ref class VssLabel : VssRecursiveBase
J#
public class VssLabel extends VssRecursiveBase
JScript
public class VssLabel extends VssRecursiveBase

Inheritance Hierarchy

System.Object
Microsoft.Build.Utilities.Task
MSBuild.Community.Tasks.SourceSafe.VssBase
MSBuild.Community.Tasks.SourceSafe.VssRecursiveBase
MSBuild.Community.Tasks.SourceSafe.VssLabel

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

VssLabel Members
MSBuild.Community.Tasks.SourceSafe Namespace


VssLabel Members

VssLabel Members
See Also Constructors Properties Methods
[image]

Task that applies a label to a Visual SourceSafe item.

The following tables list the members exposed by VssLabel.

Public Constructors

 | Name | Description
Public method | VssLabel | Initializes a new instance of the VssLabel class.
Top

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | Comment | An optional comment.
Public property | DatabasePath | The path to the folder that contains the srcsafe.ini file. (inherited from VssBase)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Label | The text of the label.
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Password | The password to use to log in to SourceSafe. (inherited from VssBase)
Public property | Path | The Visual SourceSafe project or file to perform the action on (starts with "$/"). (inherited from VssBase)
Public property | Recursive | Determines whether to perform the SourceSafe operation recursively. The default is true. (inherited from VssRecursiveBase)
Public property | UserName | The name of the user accessing the SourceSafe database. (inherited from VssBase)
Public property | Version | A version of the Path to reference. (inherited from VssBase)
Top

Protected Properties

 | Name | Description
Family property | Database | Represents the VSS Database (inherited from VssBase)
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | Item | Represents the VSS item selected (file or project). (inherited from VssBase)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. Executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | ConnectToDatabase | Attempts to connect to the SourceSafe Database and load the specified item, or version of the item, if specified. (inherited from VssBase)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | LogErrorFromException | Logs an exception using the MSBuild logging framework. (inherited from VssBase)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

VssLabel Class
VssLabel Members
MSBuild.Community.Tasks.SourceSafe Namespace


VssLabel Constructor

VssLabel Constructor
[image]

Initializes a new instance of the VssLabel class.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public VssLabel()
C++
public:
VssLabel() sealed
J#
public VssLabel()
JScript
public function VssLabel()

See Also

VssLabel Class
VssLabel Members
MSBuild.Community.Tasks.SourceSafe Namespace


Properties

VssLabel Properties
[image]

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | Comment | An optional comment.
Public property | DatabasePath | The path to the folder that contains the srcsafe.ini file. (inherited from VssBase)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Label | The text of the label.
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Password | The password to use to log in to SourceSafe. (inherited from VssBase)
Public property | Path | The Visual SourceSafe project or file to perform the action on (starts with "$/"). (inherited from VssBase)
Public property | Recursive | Determines whether to perform the SourceSafe operation recursively. The default is true. (inherited from VssRecursiveBase)
Public property | UserName | The name of the user accessing the SourceSafe database. (inherited from VssBase)
Public property | Version | A version of the Path to reference. (inherited from VssBase)
Top

Protected Properties

 | Name | Description
Family property | Database | Represents the VSS Database (inherited from VssBase)
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | Item | Represents the VSS item selected (file or project). (inherited from VssBase)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

See Also

VssLabel Class
VssLabel Members
MSBuild.Community.Tasks.SourceSafe Namespace


Comment Property

VssLabel.Comment Property
[image]

An optional comment.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Comment As String
C#
public string Comment { get; set; }
C++
public property string Comment sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Comment();

/** property */
public void set_Comment(string value);
JScript
public function get Comment() : String

public function set Comment(value : String);

See Also

VssLabel Class
VssLabel Members
MSBuild.Community.Tasks.SourceSafe Namespace


Label Property

VssLabel.Label Property
[image]

The text of the label.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Required>
Public Property Label As String
C#
[Required]
public string Label { get; set; }
C++
[Required]
public property string Label sealed {
String get();
void set(String value);
}
J#
/** @attribute Required() */
/** property */
public string get_Label();

/** property */
public void set_Label(string value);
JScript
public function get Label() : String

public function set Label(value : String);

See Also

VssLabel Class
VssLabel Members
MSBuild.Community.Tasks.SourceSafe Namespace


Methods

VssLabel Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. Executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | ConnectToDatabase | Attempts to connect to the SourceSafe Database and load the specified item, or version of the item, if specified. (inherited from VssBase)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | LogErrorFromException | Logs an exception using the MSBuild logging framework. (inherited from VssBase)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

VssLabel Class
VssLabel Members
MSBuild.Community.Tasks.SourceSafe Namespace


Execute Method

VssLabel.Execute Method
[image]

Executes the task.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute() As Boolean _
Implements ITask.Execute
C#
public override bool Execute()
C++
public:
virtual bool Execute() override
J#
public override bool Execute()
JScript
public override function Execute() : bool

Return Value

true if the task ran successfully; otherwise false.

Implements

ITask.Execute

See Also

VssLabel Class
VssLabel Members
MSBuild.Community.Tasks.SourceSafe Namespace


VssRecursiveBase Class

VssRecursiveBase Class
See Also Members
[image]

Base class for VSS tasks that can act recursively. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class VssRecursiveBase
Inherits VssBase
C#
public abstract class VssRecursiveBase : VssBase
C++
ref class VssRecursiveBase abstract : VssBase
J#
public class VssRecursiveBase extends VssBase
JScript
public class VssRecursiveBase extends VssBase

Inheritance Hierarchy

System.Object
Microsoft.Build.Utilities.Task
MSBuild.Community.Tasks.SourceSafe.VssBase
MSBuild.Community.Tasks.SourceSafe.VssRecursiveBase
Derived types

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

VssRecursiveBase Members
MSBuild.Community.Tasks.SourceSafe Namespace


VssRecursiveBase Members

VssRecursiveBase Members
See Also Constructors Properties Methods
[image]

Base class for VSS tasks that can act recursively. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by VssRecursiveBase.

Protected Constructors

 | Name | Description
Family method | VssRecursiveBase | Initializes a new instance of the VssRecursiveBase class.
Top

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | DatabasePath | The path to the folder that contains the srcsafe.ini file. (inherited from VssBase)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Password | The password to use to log in to SourceSafe. (inherited from VssBase)
Public property | Path | The Visual SourceSafe project or file to perform the action on (starts with "$/"). (inherited from VssBase)
Public property | Recursive | Determines whether to perform the SourceSafe operation recursively. The default is true.
Public property | UserName | The name of the user accessing the SourceSafe database. (inherited from VssBase)
Public property | Version | A version of the Path to reference. (inherited from VssBase)
Top

Protected Properties

 | Name | Description
Family property | Database | Represents the VSS Database (inherited from VssBase)
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | Item | Represents the VSS item selected (file or project). (inherited from VssBase)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. Reserved.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | ConnectToDatabase | Attempts to connect to the SourceSafe Database and load the specified item, or version of the item, if specified. (inherited from VssBase)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | LogErrorFromException | Logs an exception using the MSBuild logging framework. (inherited from VssBase)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

VssRecursiveBase Class
VssRecursiveBase Members
MSBuild.Community.Tasks.SourceSafe Namespace


VssRecursiveBase Constructor

VssRecursiveBase Constructor
[image]

Initializes a new instance of the VssRecursiveBase class.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New()
C#
protected VssRecursiveBase()
C++
protected:
VssRecursiveBase() sealed
J#
protected VssRecursiveBase()
JScript
protected function VssRecursiveBase()

See Also

VssRecursiveBase Class
VssRecursiveBase Members
MSBuild.Community.Tasks.SourceSafe Namespace


Properties

VssRecursiveBase Properties
[image]

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | DatabasePath | The path to the folder that contains the srcsafe.ini file. (inherited from VssBase)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Password | The password to use to log in to SourceSafe. (inherited from VssBase)
Public property | Path | The Visual SourceSafe project or file to perform the action on (starts with "$/"). (inherited from VssBase)
Public property | Recursive | Determines whether to perform the SourceSafe operation recursively. The default is true.
Public property | UserName | The name of the user accessing the SourceSafe database. (inherited from VssBase)
Public property | Version | A version of the Path to reference. (inherited from VssBase)
Top

Protected Properties

 | Name | Description
Family property | Database | Represents the VSS Database (inherited from VssBase)
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | Item | Represents the VSS item selected (file or project). (inherited from VssBase)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

See Also

VssRecursiveBase Class
VssRecursiveBase Members
MSBuild.Community.Tasks.SourceSafe Namespace


Recursive Property

VssRecursiveBase.Recursive Property
[image]

Determines whether to perform the SourceSafe operation recursively. The default is true.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Recursive As Boolean
C#
public bool Recursive { get; set; }
C++
public property bool Recursive sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_Recursive();

/** property */
public void set_Recursive(bool value);
JScript
public function get Recursive() : bool

public function set Recursive(value : bool);

See Also

VssRecursiveBase Class
VssRecursiveBase Members
MSBuild.Community.Tasks.SourceSafe Namespace


Methods

VssRecursiveBase Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. Reserved.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | ConnectToDatabase | Attempts to connect to the SourceSafe Database and load the specified item, or version of the item, if specified. (inherited from VssBase)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | LogErrorFromException | Logs an exception using the MSBuild logging framework. (inherited from VssBase)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

VssRecursiveBase Class
VssRecursiveBase Members
MSBuild.Community.Tasks.SourceSafe Namespace


Execute Method

VssRecursiveBase.Execute Method
[image]

Reserved.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute() As Boolean _
Implements ITask.Execute
C#
public override bool Execute()
C++
public:
virtual bool Execute() override
J#
public override bool Execute()
JScript
public override function Execute() : bool

Return Value

Reserved.

Implements

ITask.Execute

See Also

VssRecursiveBase Class
VssRecursiveBase Members
MSBuild.Community.Tasks.SourceSafe Namespace


VssUndoCheckout Class

VssUndoCheckout Class
See Also Example Members
[image]

Task that undoes a checkout of files or projects against a Visual SourceSafe database.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class VssUndoCheckout
Inherits VssRecursiveBase
C#
public class VssUndoCheckout : VssRecursiveBase
C++
ref class VssUndoCheckout : VssRecursiveBase
J#
public class VssUndoCheckout extends VssRecursiveBase
JScript
public class VssUndoCheckout extends VssRecursiveBase

Example

Copy Code
<VssUndoCheckout UserName="ccnet_build"
              Password="build"
              LocalPath="C:\Dev\MyProjects\Project"
              Recursive="False"
              DatabasePath="\\VSSServer\VSS\srcsafe.ini"
              Path="$/Test/TestFile.cs"
            />

Inheritance Hierarchy

System.Object
Microsoft.Build.Utilities.Task
MSBuild.Community.Tasks.SourceSafe.VssBase
MSBuild.Community.Tasks.SourceSafe.VssRecursiveBase
MSBuild.Community.Tasks.SourceSafe.VssUndoCheckout

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

VssUndoCheckout Members
MSBuild.Community.Tasks.SourceSafe Namespace


VssUndoCheckout Members

VssUndoCheckout Members
See Also Example Constructors Properties Methods
[image]

Task that undoes a checkout of files or projects against a Visual SourceSafe database.

The following tables list the members exposed by VssUndoCheckout.

Public Constructors

 | Name | Description
Public method | VssUndoCheckout | Initializes a new instance of the VssUndoCheckout class.
Top

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | DatabasePath | The path to the folder that contains the srcsafe.ini file. (inherited from VssBase)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | LocalPath | The path to the local working directory.
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Password | The password to use to log in to SourceSafe. (inherited from VssBase)
Public property | Path | The Visual SourceSafe project or file to perform the action on (starts with "$/"). (inherited from VssBase)
Public property | Recursive | Determines whether to perform the SourceSafe operation recursively. The default is true. (inherited from VssRecursiveBase)
Public property | UserName | The name of the user accessing the SourceSafe database. (inherited from VssBase)
Public property | Version | A version of the Path to reference. (inherited from VssBase)
Top

Protected Properties

 | Name | Description
Family property | Database | Represents the VSS Database (inherited from VssBase)
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | Item | Represents the VSS item selected (file or project). (inherited from VssBase)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. Executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | ConnectToDatabase | Attempts to connect to the SourceSafe Database and load the specified item, or version of the item, if specified. (inherited from VssBase)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | LogErrorFromException | Logs an exception using the MSBuild logging framework. (inherited from VssBase)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

VssUndoCheckout Class
VssUndoCheckout Members
MSBuild.Community.Tasks.SourceSafe Namespace


VssUndoCheckout Constructor

VssUndoCheckout Constructor
[image]

Initializes a new instance of the VssUndoCheckout class.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public VssUndoCheckout()
C++
public:
VssUndoCheckout() sealed
J#
public VssUndoCheckout()
JScript
public function VssUndoCheckout()

See Also

VssUndoCheckout Class
VssUndoCheckout Members
MSBuild.Community.Tasks.SourceSafe Namespace


Properties

VssUndoCheckout Properties
See Also Example
[image]

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | DatabasePath | The path to the folder that contains the srcsafe.ini file. (inherited from VssBase)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | LocalPath | The path to the local working directory.
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Password | The password to use to log in to SourceSafe. (inherited from VssBase)
Public property | Path | The Visual SourceSafe project or file to perform the action on (starts with "$/"). (inherited from VssBase)
Public property | Recursive | Determines whether to perform the SourceSafe operation recursively. The default is true. (inherited from VssRecursiveBase)
Public property | UserName | The name of the user accessing the SourceSafe database. (inherited from VssBase)
Public property | Version | A version of the Path to reference. (inherited from VssBase)
Top

Protected Properties

 | Name | Description
Family property | Database | Represents the VSS Database (inherited from VssBase)
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | Item | Represents the VSS item selected (file or project). (inherited from VssBase)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

See Also

VssUndoCheckout Class
VssUndoCheckout Members
MSBuild.Community.Tasks.SourceSafe Namespace


LocalPath Property

VssUndoCheckout.LocalPath Property
[image]

The path to the local working directory.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Required>
Public Property LocalPath As String
C#
[Required]
public string LocalPath { get; set; }
C++
[Required]
public property string LocalPath sealed {
String get();
void set(String value);
}
J#
/** @attribute Required() */
/** property */
public string get_LocalPath();

/** property */
public void set_LocalPath(string value);
JScript
public function get LocalPath() : String

public function set LocalPath(value : String);

See Also

VssUndoCheckout Class
VssUndoCheckout Members
MSBuild.Community.Tasks.SourceSafe Namespace


Methods

VssUndoCheckout Methods
See Also Example
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. Executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | ConnectToDatabase | Attempts to connect to the SourceSafe Database and load the specified item, or version of the item, if specified. (inherited from VssBase)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | LogErrorFromException | Logs an exception using the MSBuild logging framework. (inherited from VssBase)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

VssUndoCheckout Class
VssUndoCheckout Members
MSBuild.Community.Tasks.SourceSafe Namespace


Execute Method

VssUndoCheckout.Execute Method
[image]

Executes the task.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute() As Boolean _
Implements ITask.Execute
C#
public override bool Execute()
C++
public:
virtual bool Execute() override
J#
public override bool Execute()
JScript
public override function Execute() : bool

Return Value

true if the task ran successfully; otherwise false.

Implements

ITask.Execute

See Also

VssUndoCheckout Class
VssUndoCheckout Members
MSBuild.Community.Tasks.SourceSafe Namespace


MSBuild.Community.Tasks.SqlServer

MSBuild.Community.Tasks.SqlServer Namespace
See Also Hierarchy

Classes

 | Class | Description
Public class | ExecuteDDL | MSBuild task to execute DDL and SQL statements.


ExecuteDDL Class

ExecuteDDL Class
See Also Example Members
[image]

MSBuild task to execute DDL and SQL statements.

Namespace: MSBuild.Community.Tasks.SqlServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class ExecuteDDL
Inherits Task
C#
public class ExecuteDDL : Task
C++
ref class ExecuteDDL : Task
J#
public class ExecuteDDL extends Task
JScript
public class ExecuteDDL extends Task

Example

Copy Code
             <PropertyGroup>
                    <ConnectionString>Server=localhost;Integrated Security=True</ConnectionString>
                </PropertyGroup>

             <Target Name="ExecuteDDL">
                    <ExecuteDDL ConnectionString="$(ConnectionString)" Files="SqlBatchScript.sql" ContinueOnError="false" />
             </Target>

Remarks

Requires the the SQL Server libraries and dynamically loads the required Microsoft.SqlServer.ConnectionInfo assembly.

Inheritance Hierarchy

System.Object
Microsoft.Build.Utilities.Task
MSBuild.Community.Tasks.SqlServer.ExecuteDDL

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ExecuteDDL Members
MSBuild.Community.Tasks.SqlServer Namespace


ExecuteDDL Members

ExecuteDDL Members
See Also Example Constructors Properties Methods
[image]

MSBuild task to execute DDL and SQL statements.

The following tables list the members exposed by ExecuteDDL.

Public Constructors

 | Name | Description
Public method | ExecuteDDL | Initializes a new instance of the ExecuteDDL class.
Top

Public Properties

 | Name | Description
Public property | BatchSeparator | Gets or sets the batch delimter string.
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | ConnectionString | The connection string
Public property | Files | Gets or sets the DDL/SQL files.
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Results | Output the return count/values
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. Executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

ExecuteDDL Class
ExecuteDDL Members
MSBuild.Community.Tasks.SqlServer Namespace


ExecuteDDL Constructor

ExecuteDDL Constructor
[image]

Initializes a new instance of the ExecuteDDL class.

Namespace: MSBuild.Community.Tasks.SqlServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ExecuteDDL()
C++
public:
ExecuteDDL() sealed
J#
public ExecuteDDL()
JScript
public function ExecuteDDL()

See Also

ExecuteDDL Class
ExecuteDDL Members
MSBuild.Community.Tasks.SqlServer Namespace


Properties

ExecuteDDL Properties
See Also Example
[image]

Public Properties

 | Name | Description
Public property | BatchSeparator | Gets or sets the batch delimter string.
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | ConnectionString | The connection string
Public property | Files | Gets or sets the DDL/SQL files.
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Results | Output the return count/values
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

See Also

ExecuteDDL Class
ExecuteDDL Members
MSBuild.Community.Tasks.SqlServer Namespace


BatchSeparator Property

ExecuteDDL.BatchSeparator Property
[image]

Gets or sets the batch delimter string.

Namespace: MSBuild.Community.Tasks.SqlServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property BatchSeparator As String
C#
public string BatchSeparator { get; set; }
C++
public property string BatchSeparator sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_BatchSeparator();

/** property */
public void set_BatchSeparator(string value);
JScript
public function get BatchSeparator() : String

public function set BatchSeparator(value : String);

Remarks

Default is "GO" for T-SQL.

See Also

ExecuteDDL Class
ExecuteDDL Members
MSBuild.Community.Tasks.SqlServer Namespace


ConnectionString Property

ExecuteDDL.ConnectionString Property
[image]

The connection string

Namespace: MSBuild.Community.Tasks.SqlServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Required>
Public Property ConnectionString As String
C#
[Required]
public string ConnectionString { get; set; }
C++
[Required]
public property string ConnectionString sealed {
String get();
void set(String value);
}
J#
/** @attribute Required() */
/** property */
public string get_ConnectionString();

/** property */
public void set_ConnectionString(string value);
JScript
public function get ConnectionString() : String

public function set ConnectionString(value : String);

See Also

ExecuteDDL Class
ExecuteDDL Members
MSBuild.Community.Tasks.SqlServer Namespace


Files Property

ExecuteDDL.Files Property
[image]

Gets or sets the DDL/SQL files.

Namespace: MSBuild.Community.Tasks.SqlServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Required>
Public Property Files As ITaskItem[]
C#
[Required]
public ITaskItem[] Files { get; set; }
C++
[Required]
public property ITaskItem[] Files sealed {
array<ITaskItem>^ get();
void set(array<ITaskItem>^ value);
}
J#
/** @attribute Required() */
/** property */
public ITaskItem[] get_Files();

/** property */
public void set_Files(ITaskItem[] value);
JScript
public function get Files() : ITaskItem[]

public function set Files(value : ITaskItem[]);

Property Value

The assemblies.

See Also

ExecuteDDL Class
ExecuteDDL Members
MSBuild.Community.Tasks.SqlServer Namespace


Results Property

ExecuteDDL.Results Property
[image]

Output the return count/values

Namespace: MSBuild.Community.Tasks.SqlServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Output>
Public ReadOnly Property Results As Integer[]
C#
[Output]
public int[] Results { get; }
C++
[Output]
public property int[] Results sealed {
array<int>^ get();
}
J#
/** @attribute Output() */
/** property */
public int[] get_Results();
JScript
public function get Results() : int[]

See Also

ExecuteDDL Class
ExecuteDDL Members
MSBuild.Community.Tasks.SqlServer Namespace


Methods

ExecuteDDL Methods
See Also Example
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. Executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

ExecuteDDL Class
ExecuteDDL Members
MSBuild.Community.Tasks.SqlServer Namespace


Execute Method

ExecuteDDL.Execute Method
[image]

Executes the task.

Namespace: MSBuild.Community.Tasks.SqlServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute() As Boolean _
Implements ITask.Execute
C#
public override bool Execute()
C++
public:
virtual bool Execute() override
J#
public override bool Execute()
JScript
public override function Execute() : bool

Return Value

true if the task successfully executed; otherwise, false.

Implements

ITask.Execute

See Also

ExecuteDDL Class
ExecuteDDL Members
MSBuild.Community.Tasks.SqlServer Namespace


MSBuild.Community.Tasks.Subversion

MSBuild.Community.Tasks.Subversion Namespace
See Also Hierarchy

Subversion Tasks for MSBuild

Classes

 | Class | Description
Public class | SvnCheckout | Checkout a local working copy of a Subversion repository.
Public class | SvnClient | Subversion client base class
Public class | SvnCommit | Subversion Commit command
Public class | SvnCopy | Copy a file or folder in Subversion
Public class | SvnExport | Export a folder from a Subversion repository
Public class | SvnInfo | Run the "svn info" command and parse the output
Public class | SvnUpdate | Subversion Update command
Public class | SvnVersion | Summarize the local revision(s) of a working copy.

Enumerations

 | Enumeration | Description
Public enumeration | NodeKind | The kind of Subversion node. The names match the text output by "svn info".
Public enumeration | Schedule | The Subversion schedule type.


NodeKind Enumeration

NodeKind Enumeration
[image]

The kind of Subversion node. The names match the text output by "svn info".

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Enum NodeKind
C#
public enum NodeKind
C++
public enum class NodeKind
J#
public enum NodeKind
JScript
public enum NodeKind

Members

Member Name | Description
file | Node is a file
dir | Node is a directory
unknown | Unknown node type

See Also

NodeKind Members
MSBuild.Community.Tasks.Subversion Namespace


Schedule Enumeration

Schedule Enumeration
[image]

The Subversion schedule type.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Enum Schedule
C#
public enum Schedule
C++
public enum class Schedule
J#
public enum Schedule
JScript
public enum Schedule

Members

Member Name | Description
normal | Normal schedule
unknown | Unknown schedule.

See Also

Schedule Members
MSBuild.Community.Tasks.Subversion Namespace


SvnCheckout Class

SvnCheckout Class
See Also Example Members
[image]

Checkout a local working copy of a Subversion repository.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class SvnCheckout
Inherits SvnClient
C#
public class SvnCheckout : SvnClient
C++
ref class SvnCheckout : SvnClient
J#
public class SvnCheckout extends SvnClient
JScript
public class SvnCheckout extends SvnClient

Example

Checkout a working copy

Copy Code
            <Target Name="Checkout">
              <RemoveDir Directories="$(MSBuildProjectDirectory)\Test\Checkout" />
              <SvnCheckout RepositoryPath="file:///d:/svn/repo/Test/trunk"
                           LocalPath="$(MSBuildProjectDirectory)\Test\Checkout">
                <Output TaskParameter="Revision" PropertyName="Revision" />
              </SvnCheckout>
              <Message Text="Revision: $(Revision)"/>
            </Target>

Inheritance Hierarchy

System.Object
Microsoft.Build.Utilities.Task
Microsoft.Build.Utilities.ToolTask
MSBuild.Community.Tasks.Subversion.SvnClient
MSBuild.Community.Tasks.Subversion.SvnCheckout

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SvnCheckout Members
MSBuild.Community.Tasks.Subversion Namespace


SvnCheckout Members

SvnCheckout Members
See Also Example Constructors Properties Methods
[image]

Checkout a local working copy of a Subversion repository.

The following tables list the members exposed by SvnCheckout.

Public Constructors

 | Name | Description
Public method | SvnCheckout | Initializes a new instance of the T:SvnCheckout class.
Top

Public Properties

 | Name | Description
Public property | Arguments | Gets or sets the arguments. (inherited from SvnClient)
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | Command | Gets or sets the command. (inherited from SvnClient)
Public property | ExitCode | Gets the returned exit code of the executable file. (inherited from ToolTask)
Public property | Force | Gets or sets the force. (inherited from SvnClient)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | LocalPath | Gets or sets the local path. (inherited from SvnClient)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Message | Gets or sets the message. (inherited from SvnClient)
Public property | Password | Gets or sets the password. (inherited from SvnClient)
Public property | RepositoryPath | Gets or sets the repository path. (inherited from SvnClient)
Public property | Revision | Gets or sets the revision. (inherited from SvnClient)
Public property | Targets | Gets or sets the targets. (inherited from SvnClient)
Public property | Timeout | Gets or sets the amount of time after which the task executable is terminated. (inherited from ToolTask)
Public property | ToolPath | Gets or sets the path of the executable file to run. (inherited from ToolTask)
Public property | Username | Gets or sets the username. (inherited from SvnClient)
Public property | Verbose | Gets or sets the verbose. (inherited from SvnClient)
Top

Protected Properties

 | Name | Description
Family property | EnvironmentOverride | Gets the override value of the PATH environment variable. (inherited from ToolTask)
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | ResponseFileEncoding | Gets the Encoding of the response file. (inherited from ToolTask)
Family property | StandardErrorEncoding | Gets the Encoding of the standard error stream of the task. (inherited from ToolTask)
Family property | StandardErrorLoggingImportance | Gets the MessageImportance with which to log errors. (inherited from ToolTask)
Family property | StandardOutputEncoding | Gets the Encoding of the standard output stream of the task. (inherited from ToolTask)
Family property | StandardOutputLoggingImportance | Gets the MessageImportance with which to log errors. (inherited from SvnClient)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Family property | ToolName | Gets the name of the executable file to run. (inherited from SvnClient)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Runs the exectuable file with the specified task parameters. (inherited from ToolTask)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | CallHostObjectToExecute | Calls the host object to perform the work of the task. (inherited from ToolTask)
Family method | ExecuteTool | Creates a temporoary response (.rsp) file and runs the executable file. (inherited from ToolTask)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GenerateCommandLineCommands | Returns a string value containing the command line arguments to pass directly to the executable file. (inherited from SvnClient)
Family method | GenerateFullPathToTool | Returns the fully qualified path to the executable file. (inherited from SvnClient)
Family method | GenerateResponseFileCommands | Returns a string value containing the command line arguments to add to the response (.rsp) file before running the executable file. (inherited from ToolTask)
Family method | GenerateSvnArguments | Generates the SVN arguments. (inherited from SvnClient)
Family method | GenerateSvnCommand | Generates the SVN command. (inherited from SvnClient)
Family method | GetResponseFileSwitch | Returns the command line switch used by the executable file to specifiy a response (.rsp) file. (inherited from ToolTask)
Family method | GetWorkingDirectory | Returns the directory in which to run the executable file. (inherited from ToolTask)
Family method | HandleTaskExecutionErrors | Handles execution errors raised by the executable file. (inherited from ToolTask)
Family method | InitializeHostObject | Initializes the host object of the task. (inherited from ToolTask)
Family method | LogEventsFromTextOutput | Logs the events from text output. (inherited from SvnClient)
Family method | LogPathToTool | Logs the tool name and path to all registered loggers. (inherited from ToolTask)
Family method | LogToolCommand | Logs the starting point of the run to all registered loggers. (inherited from SvnClient)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | SkipTaskExecution | Indicates whether task execution should be skipped. (inherited from ToolTask)
Family method | ValidateParameters | Overidden. Indicates whether all task paratmeters are valid.
Top

See Also

SvnCheckout Class
SvnCheckout Members
MSBuild.Community.Tasks.Subversion Namespace


SvnCheckout Constructor

SvnCheckout Constructor
[image]

Initializes a new instance of the T:SvnCheckout class.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SvnCheckout()
C++
public:
SvnCheckout() sealed
J#
public SvnCheckout()
JScript
public function SvnCheckout()

See Also

SvnCheckout Class
SvnCheckout Members
MSBuild.Community.Tasks.Subversion Namespace


Methods

SvnCheckout Methods
See Also Example
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Runs the exectuable file with the specified task parameters. (inherited from ToolTask)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | CallHostObjectToExecute | Calls the host object to perform the work of the task. (inherited from ToolTask)
Family method | ExecuteTool | Creates a temporoary response (.rsp) file and runs the executable file. (inherited from ToolTask)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GenerateCommandLineCommands | Returns a string value containing the command line arguments to pass directly to the executable file. (inherited from SvnClient)
Family method | GenerateFullPathToTool | Returns the fully qualified path to the executable file. (inherited from SvnClient)
Family method | GenerateResponseFileCommands | Returns a string value containing the command line arguments to add to the response (.rsp) file before running the executable file. (inherited from ToolTask)
Family method | GenerateSvnArguments | Generates the SVN arguments. (inherited from SvnClient)
Family method | GenerateSvnCommand | Generates the SVN command. (inherited from SvnClient)
Family method | GetResponseFileSwitch | Returns the command line switch used by the executable file to specifiy a response (.rsp) file. (inherited from ToolTask)
Family method | GetWorkingDirectory | Returns the directory in which to run the executable file. (inherited from ToolTask)
Family method | HandleTaskExecutionErrors | Handles execution errors raised by the executable file. (inherited from ToolTask)
Family method | InitializeHostObject | Initializes the host object of the task. (inherited from ToolTask)
Family method | LogEventsFromTextOutput | Logs the events from text output. (inherited from SvnClient)
Family method | LogPathToTool | Logs the tool name and path to all registered loggers. (inherited from ToolTask)
Family method | LogToolCommand | Logs the starting point of the run to all registered loggers. (inherited from SvnClient)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | SkipTaskExecution | Indicates whether task execution should be skipped. (inherited from ToolTask)
Family method | ValidateParameters | Overidden. Indicates whether all task paratmeters are valid.
Top

See Also

SvnCheckout Class
SvnCheckout Members
MSBuild.Community.Tasks.Subversion Namespace


ValidateParameters Method

SvnCheckout.ValidateParameters Method
[image]

Indicates whether all task paratmeters are valid.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function ValidateParameters() As Boolean
C#
protected override bool ValidateParameters()
C++
protected:
virtual bool ValidateParameters() override
J#
protected override bool ValidateParameters()
JScript
protected override function ValidateParameters() : bool

Return Value

true if all task parameters are valid; otherwise, false.

See Also

SvnCheckout Class
SvnCheckout Members
MSBuild.Community.Tasks.Subversion Namespace


SvnClient Class

SvnClient Class
See Also Members
[image]

Subversion client base class

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class SvnClient
Inherits ToolTask
C#
public class SvnClient : ToolTask
C++
ref class SvnClient : ToolTask
J#
public class SvnClient extends ToolTask
JScript
public class SvnClient extends ToolTask

Inheritance Hierarchy

System.Object
Microsoft.Build.Utilities.Task
Microsoft.Build.Utilities.ToolTask
MSBuild.Community.Tasks.Subversion.SvnClient
Derived types

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SvnClient Members
MSBuild.Community.Tasks.Subversion Namespace


SvnClient Members

SvnClient Members
See Also Constructors Properties Methods
[image]

Subversion client base class

The following tables list the members exposed by SvnClient.

Public Constructors

 | Name | Description
Public method | SvnClient | Initializes a new instance of the SvnClient class.
Top

Public Properties

 | Name | Description
Public property | Arguments | Gets or sets the arguments.
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | Command | Gets or sets the command.
Public property | ExitCode | Gets the returned exit code of the executable file. (inherited from ToolTask)
Public property | Force | Gets or sets the force.
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | LocalPath | Gets or sets the local path.
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Message | Gets or sets the message.
Public property | Password | Gets or sets the password.
Public property | RepositoryPath | Gets or sets the repository path.
Public property | Revision | Gets or sets the revision.
Public property | Targets | Gets or sets the targets.
Public property | Timeout | Gets or sets the amount of time after which the task executable is terminated. (inherited from ToolTask)
Public property | ToolPath | Gets or sets the path of the executable file to run. (inherited from ToolTask)
Public property | Username | Gets or sets the username.
Public property | Verbose | Gets or sets the verbose.
Top

Protected Properties

 | Name | Description
Family property | EnvironmentOverride | Gets the override value of the PATH environment variable. (inherited from ToolTask)
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | ResponseFileEncoding | Gets the Encoding of the response file. (inherited from ToolTask)
Family property | StandardErrorEncoding | Gets the Encoding of the standard error stream of the task. (inherited from ToolTask)
Family property | StandardErrorLoggingImportance | Gets the MessageImportance with which to log errors. (inherited from ToolTask)
Family property | StandardOutputEncoding | Gets the Encoding of the standard output stream of the task. (inherited from ToolTask)
Family property | StandardOutputLoggingImportance | Overidden. Gets the MessageImportance with which to log errors.
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Family property | ToolName | Overidden. Gets the name of the executable file to run.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Runs the exectuable file with the specified task parameters. (inherited from ToolTask)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | CallHostObjectToExecute | Calls the host object to perform the work of the task. (inherited from ToolTask)
Family method | ExecuteTool | Creates a temporoary response (.rsp) file and runs the executable file. (inherited from ToolTask)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GenerateCommandLineCommands | Overidden. Returns a string value containing the command line arguments to pass directly to the executable file.
Family method | GenerateFullPathToTool | Overidden. Returns the fully qualified path to the executable file.
Family method | GenerateResponseFileCommands | Returns a string value containing the command line arguments to add to the response (.rsp) file before running the executable file. (inherited from ToolTask)
Family method | GenerateSvnArguments | Generates the SVN arguments.
Family method | GenerateSvnCommand | Generates the SVN command.
Family method | GetResponseFileSwitch | Returns the command line switch used by the executable file to specifiy a response (.rsp) file. (inherited from ToolTask)
Family method | GetWorkingDirectory | Returns the directory in which to run the executable file. (inherited from ToolTask)
Family method | HandleTaskExecutionErrors | Handles execution errors raised by the executable file. (inherited from ToolTask)
Family method | InitializeHostObject | Initializes the host object of the task. (inherited from ToolTask)
Family method | LogEventsFromTextOutput | Overidden. Logs the events from text output.
Family method | LogPathToTool | Logs the tool name and path to all registered loggers. (inherited from ToolTask)
Family method | LogToolCommand | Overidden. Logs the starting point of the run to all registered loggers.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | SkipTaskExecution | Indicates whether task execution should be skipped. (inherited from ToolTask)
Family method | ValidateParameters | Overidden. Indicates whether all task paratmeters are valid.
Top

See Also

SvnClient Class
SvnClient Members
MSBuild.Community.Tasks.Subversion Namespace


SvnClient Constructor

SvnClient Constructor
[image]

Initializes a new instance of the SvnClient class.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SvnClient()
C++
public:
SvnClient() sealed
J#
public SvnClient()
JScript
public function SvnClient()

See Also

SvnClient Class
SvnClient Members
MSBuild.Community.Tasks.Subversion Namespace


Properties

SvnClient Properties
[image]

Public Properties

 | Name | Description
Public property | Arguments | Gets or sets the arguments.
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | Command | Gets or sets the command.
Public property | ExitCode | Gets the returned exit code of the executable file. (inherited from ToolTask)
Public property | Force | Gets or sets the force.
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | LocalPath | Gets or sets the local path.
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Message | Gets or sets the message.
Public property | Password | Gets or sets the password.
Public property | RepositoryPath | Gets or sets the repository path.
Public property | Revision | Gets or sets the revision.
Public property | Targets | Gets or sets the targets.
Public property | Timeout | Gets or sets the amount of time after which the task executable is terminated. (inherited from ToolTask)
Public property | ToolPath | Gets or sets the path of the executable file to run. (inherited from ToolTask)
Public property | Username | Gets or sets the username.
Public property | Verbose | Gets or sets the verbose.
Top

Protected Properties

 | Name | Description
Family property | EnvironmentOverride | Gets the override value of the PATH environment variable. (inherited from ToolTask)
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | ResponseFileEncoding | Gets the Encoding of the response file. (inherited from ToolTask)
Family property | StandardErrorEncoding | Gets the Encoding of the standard error stream of the task. (inherited from ToolTask)
Family property | StandardErrorLoggingImportance | Gets the MessageImportance with which to log errors. (inherited from ToolTask)
Family property | StandardOutputEncoding | Gets the Encoding of the standard output stream of the task. (inherited from ToolTask)
Family property | StandardOutputLoggingImportance | Overidden. Gets the MessageImportance with which to log errors.
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Family property | ToolName | Overidden. Gets the name of the executable file to run.
Top

See Also

SvnClient Class
SvnClient Members
MSBuild.Community.Tasks.Subversion Namespace


Arguments Property

SvnClient.Arguments Property
[image]

Gets or sets the arguments.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Arguments As String
C#
public string Arguments { get; set; }
C++
public property string Arguments sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Arguments();

/** property */
public void set_Arguments(string value);
JScript
public function get Arguments() : String

public function set Arguments(value : String);

Property Value

The arguments.

See Also

SvnClient Class
SvnClient Members
MSBuild.Community.Tasks.Subversion Namespace


Command Property

SvnClient.Command Property
[image]

Gets or sets the command.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Command As String
C#
public string Command { get; set; }
C++
public property string Command sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Command();

/** property */
public void set_Command(string value);
JScript
public function get Command() : String

public function set Command(value : String);

Property Value

The command.

See Also

SvnClient Class
SvnClient Members
MSBuild.Community.Tasks.Subversion Namespace


Force Property

SvnClient.Force Property
[image]

Gets or sets the force.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Force As Nullable(Of Boolean)
C#
public Nullable<bool> Force { get; set; }
C++
public property Nullable<bool> Force sealed {
Nullable<bool> get();
void set(Nullable<bool> value);
}
J#
/** property */
public Nullable<bool> get_Force();

/** property */
public void set_Force(Nullable<bool> value);
JScript
public function get Force() : Nullable<bool>

public function set Force(value : Nullable<bool>);

Property Value

The force.

See Also

SvnClient Class
SvnClient Members
MSBuild.Community.Tasks.Subversion Namespace


LocalPath Property

SvnClient.LocalPath Property
[image]

Gets or sets the local path.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property LocalPath As String
C#
public string LocalPath { get; set; }
C++
public property string LocalPath sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_LocalPath();

/** property */
public void set_LocalPath(string value);
JScript
public function get LocalPath() : String

public function set LocalPath(value : String);

Property Value

The local path.

See Also

SvnClient Class
SvnClient Members
MSBuild.Community.Tasks.Subversion Namespace


Message Property

SvnClient.Message Property
[image]

Gets or sets the message.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Message As String
C#
public string Message { get; set; }
C++
public property string Message sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Message();

/** property */
public void set_Message(string value);
JScript
public function get Message() : String

public function set Message(value : String);

Property Value

The message.

See Also

SvnClient Class
SvnClient Members
MSBuild.Community.Tasks.Subversion Namespace


Password Property

SvnClient.Password Property
[image]

Gets or sets the password.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Password As String
C#
public string Password { get; set; }
C++
public property string Password sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Password();

/** property */
public void set_Password(string value);
JScript
public function get Password() : String

public function set Password(value : String);

Property Value

The password.

See Also

SvnClient Class
SvnClient Members
MSBuild.Community.Tasks.Subversion Namespace


RepositoryPath Property

SvnClient.RepositoryPath Property
[image]

Gets or sets the repository path.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Output>
Public Property RepositoryPath As String
C#
[Output]
public string RepositoryPath { get; set; }
C++
[Output]
public property string RepositoryPath sealed {
String get();
void set(String value);
}
J#
/** @attribute Output() */
/** property */
public string get_RepositoryPath();

/** property */
public void set_RepositoryPath(string value);
JScript
public function get RepositoryPath() : String

public function set RepositoryPath(value : String);

Property Value

The repository path.

See Also

SvnClient Class
SvnClient Members
MSBuild.Community.Tasks.Subversion Namespace


Revision Property

SvnClient.Revision Property
[image]

Gets or sets the revision.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Output>
Public Property Revision As Integer
C#
[Output]
public int Revision { get; set; }
C++
[Output]
public property int Revision sealed {
int get();
void set(int value);
}
J#
/** @attribute Output() */
/** property */
public int get_Revision();

/** property */
public void set_Revision(int value);
JScript
public function get Revision() : int

public function set Revision(value : int);

Property Value

The revision.

See Also

SvnClient Class
SvnClient Members
MSBuild.Community.Tasks.Subversion Namespace


StandardOutputLoggingImportance Property

SvnClient.StandardOutputLoggingImportance Property
[image]

Gets the MessageImportance with which to log errors.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property StandardOutputLoggingImportance As MessageImportance
C#
protected override MessageImportance StandardOutputLoggingImportance { get; }
C++
protected override property MessageImportance StandardOutputLoggingImportance override {
MessageImportance get();
}
J#
/** property */
protected MessageImportance get_StandardOutputLoggingImportance();
JScript
protected function get StandardOutputLoggingImportance() : MessageImportance

Property Value

The MessageImportance with which to log errors.

See Also

SvnClient Class
SvnClient Members
MSBuild.Community.Tasks.Subversion Namespace


Targets Property

SvnClient.Targets Property
[image]

Gets or sets the targets.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Targets As ITaskItem[]
C#
public ITaskItem[] Targets { get; set; }
C++
public property ITaskItem[] Targets sealed {
array<ITaskItem>^ get();
void set(array<ITaskItem>^ value);
}
J#
/** property */
public ITaskItem[] get_Targets();

/** property */
public void set_Targets(ITaskItem[] value);
JScript
public function get Targets() : ITaskItem[]

public function set Targets(value : ITaskItem[]);

Property Value

The targets.

See Also

SvnClient Class
SvnClient Members
MSBuild.Community.Tasks.Subversion Namespace


ToolName Property

SvnClient.ToolName Property
[image]

Gets the name of the executable file to run.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property ToolName As String
C#
protected override string ToolName { get; }
C++
protected override property string ToolName override {
String get();
}
J#
/** property */
protected string get_ToolName();
JScript
protected function get ToolName() : String

Property Value

The name of the executable file to run.

See Also

SvnClient Class
SvnClient Members
MSBuild.Community.Tasks.Subversion Namespace


Username Property

SvnClient.Username Property
[image]

Gets or sets the username.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Username As String
C#
public string Username { get; set; }
C++
public property string Username sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Username();

/** property */
public void set_Username(string value);
JScript
public function get Username() : String

public function set Username(value : String);

Property Value

The username.

See Also

SvnClient Class
SvnClient Members
MSBuild.Community.Tasks.Subversion Namespace


Verbose Property

SvnClient.Verbose Property
[image]

Gets or sets the verbose.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Verbose As Nullable(Of Boolean)
C#
public Nullable<bool> Verbose { get; set; }
C++
public property Nullable<bool> Verbose sealed {
Nullable<bool> get();
void set(Nullable<bool> value);
}
J#
/** property */
public Nullable<bool> get_Verbose();

/** property */
public void set_Verbose(Nullable<bool> value);
JScript
public function get Verbose() : Nullable<bool>

public function set Verbose(value : Nullable<bool>);

Property Value

The verbose.

See Also

SvnClient Class
SvnClient Members
MSBuild.Community.Tasks.Subversion Namespace


Methods

SvnClient Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Runs the exectuable file with the specified task parameters. (inherited from ToolTask)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | CallHostObjectToExecute | Calls the host object to perform the work of the task. (inherited from ToolTask)
Family method | ExecuteTool | Creates a temporoary response (.rsp) file and runs the executable file. (inherited from ToolTask)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GenerateCommandLineCommands | Overidden. Returns a string value containing the command line arguments to pass directly to the executable file.
Family method | GenerateFullPathToTool | Overidden. Returns the fully qualified path to the executable file.
Family method | GenerateResponseFileCommands | Returns a string value containing the command line arguments to add to the response (.rsp) file before running the executable file. (inherited from ToolTask)
Family method | GenerateSvnArguments | Generates the SVN arguments.
Family method | GenerateSvnCommand | Generates the SVN command.
Family method | GetResponseFileSwitch | Returns the command line switch used by the executable file to specifiy a response (.rsp) file. (inherited from ToolTask)
Family method | GetWorkingDirectory | Returns the directory in which to run the executable file. (inherited from ToolTask)
Family method | HandleTaskExecutionErrors | Handles execution errors raised by the executable file. (inherited from ToolTask)
Family method | InitializeHostObject | Initializes the host object of the task. (inherited from ToolTask)
Family method | LogEventsFromTextOutput | Overidden. Logs the events from text output.
Family method | LogPathToTool | Logs the tool name and path to all registered loggers. (inherited from ToolTask)
Family method | LogToolCommand | Overidden. Logs the starting point of the run to all registered loggers.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | SkipTaskExecution | Indicates whether task execution should be skipped. (inherited from ToolTask)
Family method | ValidateParameters | Overidden. Indicates whether all task paratmeters are valid.
Top

See Also

SvnClient Class
SvnClient Members
MSBuild.Community.Tasks.Subversion Namespace


GenerateCommandLineCommands Method

SvnClient.GenerateCommandLineCommands Method
[image]

Returns a string value containing the command line arguments to pass directly to the executable file.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GenerateCommandLineCommands() As String
C#
protected override string GenerateCommandLineCommands()
C++
protected:
virtual String GenerateCommandLineCommands() override
J#
protected override string GenerateCommandLineCommands()
JScript
protected override function GenerateCommandLineCommands() : String

Return Value

A string value containing the command line arguments to pass directly to the executable file.

See Also

SvnClient Class
SvnClient Members
MSBuild.Community.Tasks.Subversion Namespace


GenerateFullPathToTool Method

SvnClient.GenerateFullPathToTool Method
[image]

Returns the fully qualified path to the executable file.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GenerateFullPathToTool() As String
C#
protected override string GenerateFullPathToTool()
C++
protected:
virtual String GenerateFullPathToTool() override
J#
protected override string GenerateFullPathToTool()
JScript
protected override function GenerateFullPathToTool() : String

Return Value

The fully qualified path to the executable file.

See Also

SvnClient Class
SvnClient Members
MSBuild.Community.Tasks.Subversion Namespace


GenerateSvnArguments Method

SvnClient.GenerateSvnArguments Method
[image]

Generates the SVN arguments.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function GenerateSvnArguments() As String
C#
protected virtual string GenerateSvnArguments()
C++
protected:
virtual String GenerateSvnArguments()
J#
protected virtual string GenerateSvnArguments()
JScript
protected virtual function GenerateSvnArguments() : String

See Also

SvnClient Class
SvnClient Members
MSBuild.Community.Tasks.Subversion Namespace


GenerateSvnCommand Method

SvnClient.GenerateSvnCommand Method
[image]

Generates the SVN command.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function GenerateSvnCommand() As String
C#
protected virtual string GenerateSvnCommand()
C++
protected:
virtual String GenerateSvnCommand()
J#
protected virtual string GenerateSvnCommand()
JScript
protected virtual function GenerateSvnCommand() : String

See Also

SvnClient Class
SvnClient Members
MSBuild.Community.Tasks.Subversion Namespace


LogEventsFromTextOutput Method

SvnClient.LogEventsFromTextOutput Method
[image]

Logs the events from text output.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub LogEventsFromTextOutput( _
ByVal singleLine As String, _
ByVal messageImportance As MessageImportance _
)
C#
protected override void LogEventsFromTextOutput(
string singleLine,
MessageImportance messageImportance
)
C++
protected:
virtual void LogEventsFromTextOutput(
String singleLine,
MessageImportance messageImportance
) override
J#
protected override void LogEventsFromTextOutput(
string singleLine,
MessageImportance messageImportance
)
JScript
protected override function LogEventsFromTextOutput(
singleLine : String,
messageImportance : MessageImportance
)

Parameters

singleLine
The single line.
messageImportance
The message importance.

See Also

SvnClient Class
SvnClient Members
MSBuild.Community.Tasks.Subversion Namespace


LogToolCommand Method

SvnClient.LogToolCommand Method
[image]

Logs the starting point of the run to all registered loggers.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub LogToolCommand( _
ByVal message As String _
)
C#
protected override void LogToolCommand(
string message
)
C++
protected:
virtual void LogToolCommand(
String message
) override
J#
protected override void LogToolCommand(
string message
)
JScript
protected override function LogToolCommand(
message : String
)

Parameters

message
A descriptive message to provide loggers, usually the command line and switches.

See Also

SvnClient Class
SvnClient Members
MSBuild.Community.Tasks.Subversion Namespace


ValidateParameters Method

SvnClient.ValidateParameters Method
[image]

Indicates whether all task paratmeters are valid.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function ValidateParameters() As Boolean
C#
protected override bool ValidateParameters()
C++
protected:
virtual bool ValidateParameters() override
J#
protected override bool ValidateParameters()
JScript
protected override function ValidateParameters() : bool

Return Value

true if all task parameters are valid; otherwise, false.

See Also

SvnClient Class
SvnClient Members
MSBuild.Community.Tasks.Subversion Namespace


SvnCommit Class

SvnCommit Class
See Also Members
[image]

Subversion Commit command

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class SvnCommit
Inherits SvnClient
C#
public class SvnCommit : SvnClient
C++
ref class SvnCommit : SvnClient
J#
public class SvnCommit extends SvnClient
JScript
public class SvnCommit extends SvnClient

Inheritance Hierarchy

System.Object
Microsoft.Build.Utilities.Task
Microsoft.Build.Utilities.ToolTask
MSBuild.Community.Tasks.Subversion.SvnClient
MSBuild.Community.Tasks.Subversion.SvnCommit

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SvnCommit Members
MSBuild.Community.Tasks.Subversion Namespace


SvnCommit Members

SvnCommit Members
See Also Constructors Properties Methods
[image]

Subversion Commit command

The following tables list the members exposed by SvnCommit.

Public Constructors

 | Name | Description
Public method | SvnCommit | Initializes a new instance of the T:SvnCommit class.
Top

Public Properties

 | Name | Description
Public property | Arguments | Gets or sets the arguments. (inherited from SvnClient)
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | Command | Gets or sets the command. (inherited from SvnClient)
Public property | ExitCode | Gets the returned exit code of the executable file. (inherited from ToolTask)
Public property | Force | Gets or sets the force. (inherited from SvnClient)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | LocalPath | Gets or sets the local path. (inherited from SvnClient)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Message | Gets or sets the message. (inherited from SvnClient)
Public property | Password | Gets or sets the password. (inherited from SvnClient)
Public property | RepositoryPath | Gets or sets the repository path. (inherited from SvnClient)
Public property | Revision | Gets or sets the revision. (inherited from SvnClient)
Public property | Targets | Gets or sets the targets. (inherited from SvnClient)
Public property | Timeout | Gets or sets the amount of time after which the task executable is terminated. (inherited from ToolTask)
Public property | ToolPath | Gets or sets the path of the executable file to run. (inherited from ToolTask)
Public property | Username | Gets or sets the username. (inherited from SvnClient)
Public property | Verbose | Gets or sets the verbose. (inherited from SvnClient)
Top

Protected Properties

 | Name | Description
Family property | EnvironmentOverride | Gets the override value of the PATH environment variable. (inherited from ToolTask)
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | ResponseFileEncoding | Gets the Encoding of the response file. (inherited from ToolTask)
Family property | StandardErrorEncoding | Gets the Encoding of the standard error stream of the task. (inherited from ToolTask)
Family property | StandardErrorLoggingImportance | Gets the MessageImportance with which to log errors. (inherited from ToolTask)
Family property | StandardOutputEncoding | Gets the Encoding of the standard output stream of the task. (inherited from ToolTask)
Family property | StandardOutputLoggingImportance | Gets the MessageImportance with which to log errors. (inherited from SvnClient)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Family property | ToolName | Gets the name of the executable file to run. (inherited from SvnClient)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Runs the exectuable file with the specified task parameters. (inherited from ToolTask)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | CallHostObjectToExecute | Calls the host object to perform the work of the task. (inherited from ToolTask)
Family method | ExecuteTool | Creates a temporoary response (.rsp) file and runs the executable file. (inherited from ToolTask)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GenerateCommandLineCommands | Returns a string value containing the command line arguments to pass directly to the executable file. (inherited from SvnClient)
Family method | GenerateFullPathToTool | Returns the fully qualified path to the executable file. (inherited from SvnClient)
Family method | GenerateResponseFileCommands | Returns a string value containing the command line arguments to add to the response (.rsp) file before running the executable file. (inherited from ToolTask)
Family method | GenerateSvnArguments | Generates the SVN arguments. (inherited from SvnClient)
Family method | GenerateSvnCommand | Generates the SVN command. (inherited from SvnClient)
Family method | GetResponseFileSwitch | Returns the command line switch used by the executable file to specifiy a response (.rsp) file. (inherited from ToolTask)
Family method | GetWorkingDirectory | Returns the directory in which to run the executable file. (inherited from ToolTask)
Family method | HandleTaskExecutionErrors | Handles execution errors raised by the executable file. (inherited from ToolTask)
Family method | InitializeHostObject | Initializes the host object of the task. (inherited from ToolTask)
Family method | LogEventsFromTextOutput | Logs the events from text output. (inherited from SvnClient)
Family method | LogPathToTool | Logs the tool name and path to all registered loggers. (inherited from ToolTask)
Family method | LogToolCommand | Logs the starting point of the run to all registered loggers. (inherited from SvnClient)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | SkipTaskExecution | Indicates whether task execution should be skipped. (inherited from ToolTask)
Family method | ValidateParameters | Overidden. Indicates whether all task paratmeters are valid.
Top

See Also

SvnCommit Class
SvnCommit Members
MSBuild.Community.Tasks.Subversion Namespace


SvnCommit Constructor

SvnCommit Constructor
[image]

Initializes a new instance of the T:SvnCommit class.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SvnCommit()
C++
public:
SvnCommit() sealed
J#
public SvnCommit()
JScript
public function SvnCommit()

See Also

SvnCommit Class
SvnCommit Members
MSBuild.Community.Tasks.Subversion Namespace


Methods

SvnCommit Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Runs the exectuable file with the specified task parameters. (inherited from ToolTask)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | CallHostObjectToExecute | Calls the host object to perform the work of the task. (inherited from ToolTask)
Family method | ExecuteTool | Creates a temporoary response (.rsp) file and runs the executable file. (inherited from ToolTask)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GenerateCommandLineCommands | Returns a string value containing the command line arguments to pass directly to the executable file. (inherited from SvnClient)
Family method | GenerateFullPathToTool | Returns the fully qualified path to the executable file. (inherited from SvnClient)
Family method | GenerateResponseFileCommands | Returns a string value containing the command line arguments to add to the response (.rsp) file before running the executable file. (inherited from ToolTask)
Family method | GenerateSvnArguments | Generates the SVN arguments. (inherited from SvnClient)
Family method | GenerateSvnCommand | Generates the SVN command. (inherited from SvnClient)
Family method | GetResponseFileSwitch | Returns the command line switch used by the executable file to specifiy a response (.rsp) file. (inherited from ToolTask)
Family method | GetWorkingDirectory | Returns the directory in which to run the executable file. (inherited from ToolTask)
Family method | HandleTaskExecutionErrors | Handles execution errors raised by the executable file. (inherited from ToolTask)
Family method | InitializeHostObject | Initializes the host object of the task. (inherited from ToolTask)
Family method | LogEventsFromTextOutput | Logs the events from text output. (inherited from SvnClient)
Family method | LogPathToTool | Logs the tool name and path to all registered loggers. (inherited from ToolTask)
Family method | LogToolCommand | Logs the starting point of the run to all registered loggers. (inherited from SvnClient)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | SkipTaskExecution | Indicates whether task execution should be skipped. (inherited from ToolTask)
Family method | ValidateParameters | Overidden. Indicates whether all task paratmeters are valid.
Top

See Also

SvnCommit Class
SvnCommit Members
MSBuild.Community.Tasks.Subversion Namespace


ValidateParameters Method

SvnCommit.ValidateParameters Method
[image]

Indicates whether all task paratmeters are valid.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function ValidateParameters() As Boolean
C#
protected override bool ValidateParameters()
C++
protected:
virtual bool ValidateParameters() override
J#
protected override bool ValidateParameters()
JScript
protected override function ValidateParameters() : bool

Return Value

true if all task parameters are valid; otherwise, false.

See Also

SvnCommit Class
SvnCommit Members
MSBuild.Community.Tasks.Subversion Namespace


SvnCopy Class

SvnCopy Class
See Also Example Members
[image]

Copy a file or folder in Subversion

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class SvnCopy
Inherits SvnClient
C#
public class SvnCopy : SvnClient
C++
ref class SvnCopy : SvnClient
J#
public class SvnCopy extends SvnClient
JScript
public class SvnCopy extends SvnClient

Example

Create a tag of the trunk with the current Cruise Control build number:

Copy Code
            <Target Name="TagTheBuild">
              <SvnCopy SourcePath="file:///d:/svn/repo/Test/trunk"
                       DestinationPath="file:///d:/svn/repo/Test/tags/BUILD-$(CCNetLabel)"
                       Message="Automatic build of $(CCNetProject)" />
            </Target>

Remarks

This is most useful for automatically tagging your source code during a build. You can create a tag by copying a path from one server location to another.

Inheritance Hierarchy

System.Object
Microsoft.Build.Utilities.Task
Microsoft.Build.Utilities.ToolTask
MSBuild.Community.Tasks.Subversion.SvnClient
MSBuild.Community.Tasks.Subversion.SvnCopy

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SvnCopy Members
MSBuild.Community.Tasks.Subversion Namespace


SvnCopy Members

SvnCopy Members
See Also Example Constructors Properties Methods
[image]

Copy a file or folder in Subversion

The following tables list the members exposed by SvnCopy.

Public Constructors

 | Name | Description
Public method | SvnCopy | Initializes a new instance of the SvnCopy class.
Top

Public Properties

 | Name | Description
Public property | Arguments | Gets or sets the arguments. (inherited from SvnClient)
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | Command | Gets or sets the command. (inherited from SvnClient)
Public property | DestinationPath | The path to which the SourcePath should be copied
Public property | ExitCode | Gets the returned exit code of the executable file. (inherited from ToolTask)
Public property | Force | Gets or sets the force. (inherited from SvnClient)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | LocalPath | Gets or sets the local path. (inherited from SvnClient)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Message | Gets or sets the message. (inherited from SvnClient)
Public property | Password | Gets or sets the password. (inherited from SvnClient)
Public property | RepositoryPath | Gets or sets the repository path. (inherited from SvnClient)
Public property | Revision | Gets or sets the revision. (inherited from SvnClient)
Public property | SourcePath | The path of the source file or folder that should be copied
Public property | Targets | Gets or sets the targets. (inherited from SvnClient)
Public property | Timeout | Gets or sets the amount of time after which the task executable is terminated. (inherited from ToolTask)
Public property | ToolPath | Gets or sets the path of the executable file to run. (inherited from ToolTask)
Public property | Username | Gets or sets the username. (inherited from SvnClient)
Public property | Verbose | Gets or sets the verbose. (inherited from SvnClient)
Top

Protected Properties

 | Name | Description
Family property | EnvironmentOverride | Gets the override value of the PATH environment variable. (inherited from ToolTask)
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | ResponseFileEncoding | Gets the Encoding of the response file. (inherited from ToolTask)
Family property | StandardErrorEncoding | Gets the Encoding of the standard error stream of the task. (inherited from ToolTask)
Family property | StandardErrorLoggingImportance | Gets the MessageImportance with which to log errors. (inherited from ToolTask)
Family property | StandardOutputEncoding | Gets the Encoding of the standard output stream of the task. (inherited from ToolTask)
Family property | StandardOutputLoggingImportance | Gets the MessageImportance with which to log errors. (inherited from SvnClient)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Family property | ToolName | Gets the name of the executable file to run. (inherited from SvnClient)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Runs the exectuable file with the specified task parameters. (inherited from ToolTask)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | CallHostObjectToExecute | Calls the host object to perform the work of the task. (inherited from ToolTask)
Family method | ExecuteTool | Creates a temporoary response (.rsp) file and runs the executable file. (inherited from ToolTask)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GenerateCommandLineCommands | Returns a string value containing the command line arguments to pass directly to the executable file. (inherited from SvnClient)
Family method | GenerateFullPathToTool | Returns the fully qualified path to the executable file. (inherited from SvnClient)
Family method | GenerateResponseFileCommands | Returns a string value containing the command line arguments to add to the response (.rsp) file before running the executable file. (inherited from ToolTask)
Family method | GenerateSvnArguments | Generates the SVN arguments. (inherited from SvnClient)
Family method | GenerateSvnCommand | Overidden. Generates the SVN command.
Family method | GetResponseFileSwitch | Returns the command line switch used by the executable file to specifiy a response (.rsp) file. (inherited from ToolTask)
Family method | GetWorkingDirectory | Returns the directory in which to run the executable file. (inherited from ToolTask)
Family method | HandleTaskExecutionErrors | Handles execution errors raised by the executable file. (inherited from ToolTask)
Family method | InitializeHostObject | Initializes the host object of the task. (inherited from ToolTask)
Family method | LogEventsFromTextOutput | Logs the events from text output. (inherited from SvnClient)
Family method | LogPathToTool | Logs the tool name and path to all registered loggers. (inherited from ToolTask)
Family method | LogToolCommand | Logs the starting point of the run to all registered loggers. (inherited from SvnClient)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | SkipTaskExecution | Indicates whether task execution should be skipped. (inherited from ToolTask)
Family method | ValidateParameters | Overidden. Indicates whether all task paratmeters are valid.
Top

See Also

SvnCopy Class
SvnCopy Members
MSBuild.Community.Tasks.Subversion Namespace


SvnCopy Constructor

SvnCopy Constructor
[image]

Initializes a new instance of the SvnCopy class.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SvnCopy()
C++
public:
SvnCopy() sealed
J#
public SvnCopy()
JScript
public function SvnCopy()

See Also

SvnCopy Class
SvnCopy Members
MSBuild.Community.Tasks.Subversion Namespace


Properties

SvnCopy Properties
See Also Example
[image]

Public Properties

 | Name | Description
Public property | Arguments | Gets or sets the arguments. (inherited from SvnClient)
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | Command | Gets or sets the command. (inherited from SvnClient)
Public property | DestinationPath | The path to which the SourcePath should be copied
Public property | ExitCode | Gets the returned exit code of the executable file. (inherited from ToolTask)
Public property | Force | Gets or sets the force. (inherited from SvnClient)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | LocalPath | Gets or sets the local path. (inherited from SvnClient)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Message | Gets or sets the message. (inherited from SvnClient)
Public property | Password | Gets or sets the password. (inherited from SvnClient)
Public property | RepositoryPath | Gets or sets the repository path. (inherited from SvnClient)
Public property | Revision | Gets or sets the revision. (inherited from SvnClient)
Public property | SourcePath | The path of the source file or folder that should be copied
Public property | Targets | Gets or sets the targets. (inherited from SvnClient)
Public property | Timeout | Gets or sets the amount of time after which the task executable is terminated. (inherited from ToolTask)
Public property | ToolPath | Gets or sets the path of the executable file to run. (inherited from ToolTask)
Public property | Username | Gets or sets the username. (inherited from SvnClient)
Public property | Verbose | Gets or sets the verbose. (inherited from SvnClient)
Top

Protected Properties

 | Name | Description
Family property | EnvironmentOverride | Gets the override value of the PATH environment variable. (inherited from ToolTask)
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | ResponseFileEncoding | Gets the Encoding of the response file. (inherited from ToolTask)
Family property | StandardErrorEncoding | Gets the Encoding of the standard error stream of the task. (inherited from ToolTask)
Family property | StandardErrorLoggingImportance | Gets the MessageImportance with which to log errors. (inherited from ToolTask)
Family property | StandardOutputEncoding | Gets the Encoding of the standard output stream of the task. (inherited from ToolTask)
Family property | StandardOutputLoggingImportance | Gets the MessageImportance with which to log errors. (inherited from SvnClient)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Family property | ToolName | Gets the name of the executable file to run. (inherited from SvnClient)
Top

See Also

SvnCopy Class
SvnCopy Members
MSBuild.Community.Tasks.Subversion Namespace


DestinationPath Property

SvnCopy.DestinationPath Property
[image]

The path to which the SourcePath should be copied

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property DestinationPath As String
C#
public string DestinationPath { get; set; }
C++
public property string DestinationPath sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_DestinationPath();

/** property */
public void set_DestinationPath(string value);
JScript
public function get DestinationPath() : String

public function set DestinationPath(value : String);

See Also

SvnCopy Class
SvnCopy Members
MSBuild.Community.Tasks.Subversion Namespace


SourcePath Property

SvnCopy.SourcePath Property
[image]

The path of the source file or folder that should be copied

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property SourcePath As String
C#
public string SourcePath { get; set; }
C++
public property string SourcePath sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_SourcePath();

/** property */
public void set_SourcePath(string value);
JScript
public function get SourcePath() : String

public function set SourcePath(value : String);

See Also

SvnCopy Class
SvnCopy Members
MSBuild.Community.Tasks.Subversion Namespace


Methods

SvnCopy Methods
See Also Example
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Runs the exectuable file with the specified task parameters. (inherited from ToolTask)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | CallHostObjectToExecute | Calls the host object to perform the work of the task. (inherited from ToolTask)
Family method | ExecuteTool | Creates a temporoary response (.rsp) file and runs the executable file. (inherited from ToolTask)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GenerateCommandLineCommands | Returns a string value containing the command line arguments to pass directly to the executable file. (inherited from SvnClient)
Family method | GenerateFullPathToTool | Returns the fully qualified path to the executable file. (inherited from SvnClient)
Family method | GenerateResponseFileCommands | Returns a string value containing the command line arguments to add to the response (.rsp) file before running the executable file. (inherited from ToolTask)
Family method | GenerateSvnArguments | Generates the SVN arguments. (inherited from SvnClient)
Family method | GenerateSvnCommand | Overidden. Generates the SVN command.
Family method | GetResponseFileSwitch | Returns the command line switch used by the executable file to specifiy a response (.rsp) file. (inherited from ToolTask)
Family method | GetWorkingDirectory | Returns the directory in which to run the executable file. (inherited from ToolTask)
Family method | HandleTaskExecutionErrors | Handles execution errors raised by the executable file. (inherited from ToolTask)
Family method | InitializeHostObject | Initializes the host object of the task. (inherited from ToolTask)
Family method | LogEventsFromTextOutput | Logs the events from text output. (inherited from SvnClient)
Family method | LogPathToTool | Logs the tool name and path to all registered loggers. (inherited from ToolTask)
Family method | LogToolCommand | Logs the starting point of the run to all registered loggers. (inherited from SvnClient)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | SkipTaskExecution | Indicates whether task execution should be skipped. (inherited from ToolTask)
Family method | ValidateParameters | Overidden. Indicates whether all task paratmeters are valid.
Top

See Also

SvnCopy Class
SvnCopy Members
MSBuild.Community.Tasks.Subversion Namespace


GenerateSvnCommand Method

SvnCopy.GenerateSvnCommand Method
[image]

Generates the SVN command.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GenerateSvnCommand() As String
C#
protected override string GenerateSvnCommand()
C++
protected:
virtual String GenerateSvnCommand() override
J#
protected override string GenerateSvnCommand()
JScript
protected override function GenerateSvnCommand() : String

See Also

SvnCopy Class
SvnCopy Members
MSBuild.Community.Tasks.Subversion Namespace


ValidateParameters Method

SvnCopy.ValidateParameters Method
[image]

Indicates whether all task paratmeters are valid.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function ValidateParameters() As Boolean
C#
protected override bool ValidateParameters()
C++
protected:
virtual bool ValidateParameters() override
J#
protected override bool ValidateParameters()
JScript
protected override function ValidateParameters() : bool

Return Value

true if all task parameters are valid; otherwise, false.

See Also

SvnCopy Class
SvnCopy Members
MSBuild.Community.Tasks.Subversion Namespace


SvnExport Class

SvnExport Class
See Also Example Members
[image]

Export a folder from a Subversion repository

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class SvnExport
Inherits SvnClient
C#
public class SvnExport : SvnClient
C++
ref class SvnExport : SvnClient
J#
public class SvnExport extends SvnClient
JScript
public class SvnExport extends SvnClient

Example

Export from repository

Copy Code
            <Target Name="Export">
              <MakeDir Directories="$(MSBuildProjectDirectory)\Test" />
              <RemoveDir Directories="$(MSBuildProjectDirectory)\Test\Export" />
              <SvnExport RepositoryPath="file:///d:/svn/repo/Test/trunk"
                LocalPath="$(MSBuildProjectDirectory)\Test\Export">
                <Output TaskParameter="Revision" PropertyName="Revision" />
              </SvnExport>
              <Message Text="Revision: $(Revision)"/>
            </Target>

Inheritance Hierarchy

System.Object
Microsoft.Build.Utilities.Task
Microsoft.Build.Utilities.ToolTask
MSBuild.Community.Tasks.Subversion.SvnClient
MSBuild.Community.Tasks.Subversion.SvnExport

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SvnExport Members
MSBuild.Community.Tasks.Subversion Namespace


SvnExport Members

SvnExport Members
See Also Example Constructors Properties Methods
[image]

Export a folder from a Subversion repository

The following tables list the members exposed by SvnExport.

Public Constructors

 | Name | Description
Public method | SvnExport | Initializes a new instance of the T:SvnExport class.
Top

Public Properties

 | Name | Description
Public property | Arguments | Gets or sets the arguments. (inherited from SvnClient)
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | Command | Gets or sets the command. (inherited from SvnClient)
Public property | ExitCode | Gets the returned exit code of the executable file. (inherited from ToolTask)
Public property | Force | Gets or sets the force. (inherited from SvnClient)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | LocalPath | Gets or sets the local path. (inherited from SvnClient)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Message | Gets or sets the message. (inherited from SvnClient)
Public property | Password | Gets or sets the password. (inherited from SvnClient)
Public property | RepositoryPath | Gets or sets the repository path. (inherited from SvnClient)
Public property | Revision | Gets or sets the revision. (inherited from SvnClient)
Public property | Targets | Gets or sets the targets. (inherited from SvnClient)
Public property | Timeout | Gets or sets the amount of time after which the task executable is terminated. (inherited from ToolTask)
Public property | ToolPath | Gets or sets the path of the executable file to run. (inherited from ToolTask)
Public property | Username | Gets or sets the username. (inherited from SvnClient)
Public property | Verbose | Gets or sets the verbose. (inherited from SvnClient)
Top

Protected Properties

 | Name | Description
Family property | EnvironmentOverride | Gets the override value of the PATH environment variable. (inherited from ToolTask)
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | ResponseFileEncoding | Gets the Encoding of the response file. (inherited from ToolTask)
Family property | StandardErrorEncoding | Gets the Encoding of the standard error stream of the task. (inherited from ToolTask)
Family property | StandardErrorLoggingImportance | Gets the MessageImportance with which to log errors. (inherited from ToolTask)
Family property | StandardOutputEncoding | Gets the Encoding of the standard output stream of the task. (inherited from ToolTask)
Family property | StandardOutputLoggingImportance | Gets the MessageImportance with which to log errors. (inherited from SvnClient)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Family property | ToolName | Gets the name of the executable file to run. (inherited from SvnClient)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Runs the exectuable file with the specified task parameters. (inherited from ToolTask)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | CallHostObjectToExecute | Calls the host object to perform the work of the task. (inherited from ToolTask)
Family method | ExecuteTool | Creates a temporoary response (.rsp) file and runs the executable file. (inherited from ToolTask)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GenerateCommandLineCommands | Returns a string value containing the command line arguments to pass directly to the executable file. (inherited from SvnClient)
Family method | GenerateFullPathToTool | Returns the fully qualified path to the executable file. (inherited from SvnClient)
Family method | GenerateResponseFileCommands | Returns a string value containing the command line arguments to add to the response (.rsp) file before running the executable file. (inherited from ToolTask)
Family method | GenerateSvnArguments | Generates the SVN arguments. (inherited from SvnClient)
Family method | GenerateSvnCommand | Generates the SVN command. (inherited from SvnClient)
Family method | GetResponseFileSwitch | Returns the command line switch used by the executable file to specifiy a response (.rsp) file. (inherited from ToolTask)
Family method | GetWorkingDirectory | Returns the directory in which to run the executable file. (inherited from ToolTask)
Family method | HandleTaskExecutionErrors | Handles execution errors raised by the executable file. (inherited from ToolTask)
Family method | InitializeHostObject | Initializes the host object of the task. (inherited from ToolTask)
Family method | LogEventsFromTextOutput | Logs the events from text output. (inherited from SvnClient)
Family method | LogPathToTool | Logs the tool name and path to all registered loggers. (inherited from ToolTask)
Family method | LogToolCommand | Logs the starting point of the run to all registered loggers. (inherited from SvnClient)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | SkipTaskExecution | Indicates whether task execution should be skipped. (inherited from ToolTask)
Family method | ValidateParameters | Overidden. Indicates whether all task paratmeters are valid.
Top

See Also

SvnExport Class
SvnExport Members
MSBuild.Community.Tasks.Subversion Namespace


SvnExport Constructor

SvnExport Constructor
[image]

Initializes a new instance of the T:SvnExport class.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SvnExport()
C++
public:
SvnExport() sealed
J#
public SvnExport()
JScript
public function SvnExport()

See Also

SvnExport Class
SvnExport Members
MSBuild.Community.Tasks.Subversion Namespace


Methods

SvnExport Methods
See Also Example
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Runs the exectuable file with the specified task parameters. (inherited from ToolTask)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | CallHostObjectToExecute | Calls the host object to perform the work of the task. (inherited from ToolTask)
Family method | ExecuteTool | Creates a temporoary response (.rsp) file and runs the executable file. (inherited from ToolTask)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GenerateCommandLineCommands | Returns a string value containing the command line arguments to pass directly to the executable file. (inherited from SvnClient)
Family method | GenerateFullPathToTool | Returns the fully qualified path to the executable file. (inherited from SvnClient)
Family method | GenerateResponseFileCommands | Returns a string value containing the command line arguments to add to the response (.rsp) file before running the executable file. (inherited from ToolTask)
Family method | GenerateSvnArguments | Generates the SVN arguments. (inherited from SvnClient)
Family method | GenerateSvnCommand | Generates the SVN command. (inherited from SvnClient)
Family method | GetResponseFileSwitch | Returns the command line switch used by the executable file to specifiy a response (.rsp) file. (inherited from ToolTask)
Family method | GetWorkingDirectory | Returns the directory in which to run the executable file. (inherited from ToolTask)
Family method | HandleTaskExecutionErrors | Handles execution errors raised by the executable file. (inherited from ToolTask)
Family method | InitializeHostObject | Initializes the host object of the task. (inherited from ToolTask)
Family method | LogEventsFromTextOutput | Logs the events from text output. (inherited from SvnClient)
Family method | LogPathToTool | Logs the tool name and path to all registered loggers. (inherited from ToolTask)
Family method | LogToolCommand | Logs the starting point of the run to all registered loggers. (inherited from SvnClient)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | SkipTaskExecution | Indicates whether task execution should be skipped. (inherited from ToolTask)
Family method | ValidateParameters | Overidden. Indicates whether all task paratmeters are valid.
Top

See Also

SvnExport Class
SvnExport Members
MSBuild.Community.Tasks.Subversion Namespace


ValidateParameters Method

SvnExport.ValidateParameters Method
[image]

Indicates whether all task paratmeters are valid.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function ValidateParameters() As Boolean
C#
protected override bool ValidateParameters()
C++
protected:
virtual bool ValidateParameters() override
J#
protected override bool ValidateParameters()
JScript
protected override function ValidateParameters() : bool

Return Value

true if all task parameters are valid; otherwise, false.

See Also

SvnExport Class
SvnExport Members
MSBuild.Community.Tasks.Subversion Namespace


SvnInfo Class

SvnInfo Class
See Also Example Members
[image]

Run the "svn info" command and parse the output

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class SvnInfo
Inherits SvnClient
C#
public class SvnInfo : SvnClient
C++
ref class SvnInfo : SvnClient
J#
public class SvnInfo extends SvnClient
JScript
public class SvnInfo extends SvnClient

Example

This example will determine the Subversion repository root for a working directory and print it out.

Copy Code
            <Target Name="printinfo">
              <SvnInfo LocalPath="c:\code\myapp">
                <Output TaskParameter="RepositoryRoot" PropertyName="root" />
              </SvnInfo>
              <Message Text="root: $(root)" />
            </Target>

Remarks

You can retrieve Subversion information for a LocalPath or RepositoryPath. If you do not provide a value for LocalPath or RepositoryPath, the current directory is assumed.

Inheritance Hierarchy

System.Object
Microsoft.Build.Utilities.Task
Microsoft.Build.Utilities.ToolTask
MSBuild.Community.Tasks.Subversion.SvnClient
MSBuild.Community.Tasks.Subversion.SvnInfo

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SvnInfo Members
MSBuild.Community.Tasks.Subversion Namespace


SvnInfo Members

SvnInfo Members
See Also Example Constructors Properties Methods
[image]

Run the "svn info" command and parse the output

The following tables list the members exposed by SvnInfo.

Public Constructors

 | Name | Description
Public method | SvnInfo | Initializes a new instance of the T:SvnInfo class.
Top

Public Properties

 | Name | Description
Public property | Arguments | Gets or sets the arguments. (inherited from SvnClient)
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | Command | Gets or sets the command. (inherited from SvnClient)
Public property | ExitCode | Gets the returned exit code of the executable file. (inherited from ToolTask)
Public property | Force | Gets or sets the force. (inherited from SvnClient)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | LastChangedAuthor | The author who last changed this node.
Public property | LastChangedDate | The date this node was last changed.
Public property | LastChangedRevision | The last changed revision number.
Public property | LocalPath | Gets or sets the local path. (inherited from SvnClient)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Message | Gets or sets the message. (inherited from SvnClient)
Public property | NodeKind | The Subversion node kind.
Public property | Password | Gets or sets the password. (inherited from SvnClient)
Public property | RepositoryPath | Gets or sets the repository path. (inherited from SvnClient)
Public property | RepositoryRoot | Return the repository root or null if not set by Subversion.
Public property | RepositoryUuid | Return the repository UUID value from Subversion.
Public property | Revision | Gets or sets the revision. (inherited from SvnClient)
Public property | Schedule | The Subversion schedule type.
Public property | Targets | Gets or sets the targets. (inherited from SvnClient)
Public property | Timeout | Gets or sets the amount of time after which the task executable is terminated. (inherited from ToolTask)
Public property | ToolPath | Gets or sets the path of the executable file to run. (inherited from ToolTask)
Public property | Username | Gets or sets the username. (inherited from SvnClient)
Public property | Verbose | Gets or sets the verbose. (inherited from SvnClient)
Top

Protected Properties

 | Name | Description
Family property | EnvironmentOverride | Gets the override value of the PATH environment variable. (inherited from ToolTask)
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | ResponseFileEncoding | Gets the Encoding of the response file. (inherited from ToolTask)
Family property | StandardErrorEncoding | Gets the Encoding of the standard error stream of the task. (inherited from ToolTask)
Family property | StandardErrorLoggingImportance | Gets the MessageImportance with which to log errors. (inherited from ToolTask)
Family property | StandardOutputEncoding | Gets the Encoding of the standard output stream of the task. (inherited from ToolTask)
Family property | StandardOutputLoggingImportance | Gets the MessageImportance with which to log errors. (inherited from SvnClient)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Family property | ToolName | Gets the name of the executable file to run. (inherited from SvnClient)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. Execute the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | CallHostObjectToExecute | Calls the host object to perform the work of the task. (inherited from ToolTask)
Family method | ExecuteTool | Creates a temporoary response (.rsp) file and runs the executable file. (inherited from ToolTask)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GenerateCommandLineCommands | Returns a string value containing the command line arguments to pass directly to the executable file. (inherited from SvnClient)
Family method | GenerateFullPathToTool | Returns the fully qualified path to the executable file. (inherited from SvnClient)
Family method | GenerateResponseFileCommands | Returns a string value containing the command line arguments to add to the response (.rsp) file before running the executable file. (inherited from ToolTask)
Family method | GenerateSvnArguments | Generates the SVN arguments. (inherited from SvnClient)
Family method | GenerateSvnCommand | Generates the SVN command. (inherited from SvnClient)
Family method | GetResponseFileSwitch | Returns the command line switch used by the executable file to specifiy a response (.rsp) file. (inherited from ToolTask)
Family method | GetWorkingDirectory | Returns the directory in which to run the executable file. (inherited from ToolTask)
Family method | HandleTaskExecutionErrors | Handles execution errors raised by the executable file. (inherited from ToolTask)
Family method | InitializeHostObject | Initializes the host object of the task. (inherited from ToolTask)
Family method | LogEventsFromTextOutput | Overidden. Logs the events from text output.
Family method | LogPathToTool | Logs the tool name and path to all registered loggers. (inherited from ToolTask)
Family method | LogToolCommand | Logs the starting point of the run to all registered loggers. (inherited from SvnClient)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | SkipTaskExecution | Indicates whether task execution should be skipped. (inherited from ToolTask)
Family method | ValidateParameters | Indicates whether all task paratmeters are valid. (inherited from SvnClient)
Top

See Also

SvnInfo Class
SvnInfo Members
MSBuild.Community.Tasks.Subversion Namespace


SvnInfo Constructor

SvnInfo Constructor
[image]

Initializes a new instance of the T:SvnInfo class.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SvnInfo()
C++
public:
SvnInfo() sealed
J#
public SvnInfo()
JScript
public function SvnInfo()

See Also

SvnInfo Class
SvnInfo Members
MSBuild.Community.Tasks.Subversion Namespace


Properties

SvnInfo Properties
See Also Example
[image]

Public Properties

 | Name | Description
Public property | Arguments | Gets or sets the arguments. (inherited from SvnClient)
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | Command | Gets or sets the command. (inherited from SvnClient)
Public property | ExitCode | Gets the returned exit code of the executable file. (inherited from ToolTask)
Public property | Force | Gets or sets the force. (inherited from SvnClient)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | LastChangedAuthor | The author who last changed this node.
Public property | LastChangedDate | The date this node was last changed.
Public property | LastChangedRevision | The last changed revision number.
Public property | LocalPath | Gets or sets the local path. (inherited from SvnClient)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Message | Gets or sets the message. (inherited from SvnClient)
Public property | NodeKind | The Subversion node kind.
Public property | Password | Gets or sets the password. (inherited from SvnClient)
Public property | RepositoryPath | Gets or sets the repository path. (inherited from SvnClient)
Public property | RepositoryRoot | Return the repository root or null if not set by Subversion.
Public property | RepositoryUuid | Return the repository UUID value from Subversion.
Public property | Revision | Gets or sets the revision. (inherited from SvnClient)
Public property | Schedule | The Subversion schedule type.
Public property | Targets | Gets or sets the targets. (inherited from SvnClient)
Public property | Timeout | Gets or sets the amount of time after which the task executable is terminated. (inherited from ToolTask)
Public property | ToolPath | Gets or sets the path of the executable file to run. (inherited from ToolTask)
Public property | Username | Gets or sets the username. (inherited from SvnClient)
Public property | Verbose | Gets or sets the verbose. (inherited from SvnClient)
Top

Protected Properties

 | Name | Description
Family property | EnvironmentOverride | Gets the override value of the PATH environment variable. (inherited from ToolTask)
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | ResponseFileEncoding | Gets the Encoding of the response file. (inherited from ToolTask)
Family property | StandardErrorEncoding | Gets the Encoding of the standard error stream of the task. (inherited from ToolTask)
Family property | StandardErrorLoggingImportance | Gets the MessageImportance with which to log errors. (inherited from ToolTask)
Family property | StandardOutputEncoding | Gets the Encoding of the standard output stream of the task. (inherited from ToolTask)
Family property | StandardOutputLoggingImportance | Gets the MessageImportance with which to log errors. (inherited from SvnClient)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Family property | ToolName | Gets the name of the executable file to run. (inherited from SvnClient)
Top

See Also

SvnInfo Class
SvnInfo Members
MSBuild.Community.Tasks.Subversion Namespace


LastChangedAuthor Property

SvnInfo.LastChangedAuthor Property
[image]

The author who last changed this node.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Output>
Public ReadOnly Property LastChangedAuthor As String
C#
[Output]
public string LastChangedAuthor { get; }
C++
[Output]
public property string LastChangedAuthor sealed {
String get();
}
J#
/** @attribute Output() */
/** property */
public string get_LastChangedAuthor();
JScript
public function get LastChangedAuthor() : String

See Also

SvnInfo Class
SvnInfo Members
MSBuild.Community.Tasks.Subversion Namespace


LastChangedDate Property

SvnInfo.LastChangedDate Property
[image]

The date this node was last changed.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Output>
Public ReadOnly Property LastChangedDate As String
C#
[Output]
public string LastChangedDate { get; }
C++
[Output]
public property string LastChangedDate sealed {
String get();
}
J#
/** @attribute Output() */
/** property */
public string get_LastChangedDate();
JScript
public function get LastChangedDate() : String

See Also

SvnInfo Class
SvnInfo Members
MSBuild.Community.Tasks.Subversion Namespace


LastChangedRevision Property

SvnInfo.LastChangedRevision Property
[image]

The last changed revision number.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Output>
Public ReadOnly Property LastChangedRevision As Integer
C#
[Output]
public int LastChangedRevision { get; }
C++
[Output]
public property int LastChangedRevision sealed {
int get();
}
J#
/** @attribute Output() */
/** property */
public int get_LastChangedRevision();
JScript
public function get LastChangedRevision() : int

See Also

SvnInfo Class
SvnInfo Members
MSBuild.Community.Tasks.Subversion Namespace


NodeKind Property

SvnInfo.NodeKind Property
[image]

The Subversion node kind.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Output>
Public ReadOnly Property NodeKind As String
C#
[Output]
public string NodeKind { get; }
C++
[Output]
public property string NodeKind sealed {
String get();
}
J#
/** @attribute Output() */
/** property */
public string get_NodeKind();
JScript
public function get NodeKind() : String

See Also

SvnInfo Class
SvnInfo Members
MSBuild.Community.Tasks.Subversion Namespace


RepositoryRoot Property

SvnInfo.RepositoryRoot Property
[image]

Return the repository root or null if not set by Subversion.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Output>
Public ReadOnly Property RepositoryRoot As String
C#
[Output]
public string RepositoryRoot { get; }
C++
[Output]
public property string RepositoryRoot sealed {
String get();
}
J#
/** @attribute Output() */
/** property */
public string get_RepositoryRoot();
JScript
public function get RepositoryRoot() : String

See Also

SvnInfo Class
SvnInfo Members
MSBuild.Community.Tasks.Subversion Namespace


RepositoryUuid Property

SvnInfo.RepositoryUuid Property
[image]

Return the repository UUID value from Subversion.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Output>
Public ReadOnly Property RepositoryUuid As String
C#
[Output]
public string RepositoryUuid { get; }
C++
[Output]
public property string RepositoryUuid sealed {
String get();
}
J#
/** @attribute Output() */
/** property */
public string get_RepositoryUuid();
JScript
public function get RepositoryUuid() : String

See Also

SvnInfo Class
SvnInfo Members
MSBuild.Community.Tasks.Subversion Namespace


Schedule Property

SvnInfo.Schedule Property
[image]

The Subversion schedule type.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Output>
Public ReadOnly Property Schedule As String
C#
[Output]
public string Schedule { get; }
C++
[Output]
public property string Schedule sealed {
String get();
}
J#
/** @attribute Output() */
/** property */
public string get_Schedule();
JScript
public function get Schedule() : String

See Also

SvnInfo Class
SvnInfo Members
MSBuild.Community.Tasks.Subversion Namespace


Methods

SvnInfo Methods
See Also Example
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. Execute the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | CallHostObjectToExecute | Calls the host object to perform the work of the task. (inherited from ToolTask)
Family method | ExecuteTool | Creates a temporoary response (.rsp) file and runs the executable file. (inherited from ToolTask)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GenerateCommandLineCommands | Returns a string value containing the command line arguments to pass directly to the executable file. (inherited from SvnClient)
Family method | GenerateFullPathToTool | Returns the fully qualified path to the executable file. (inherited from SvnClient)
Family method | GenerateResponseFileCommands | Returns a string value containing the command line arguments to add to the response (.rsp) file before running the executable file. (inherited from ToolTask)
Family method | GenerateSvnArguments | Generates the SVN arguments. (inherited from SvnClient)
Family method | GenerateSvnCommand | Generates the SVN command. (inherited from SvnClient)
Family method | GetResponseFileSwitch | Returns the command line switch used by the executable file to specifiy a response (.rsp) file. (inherited from ToolTask)
Family method | GetWorkingDirectory | Returns the directory in which to run the executable file. (inherited from ToolTask)
Family method | HandleTaskExecutionErrors | Handles execution errors raised by the executable file. (inherited from ToolTask)
Family method | InitializeHostObject | Initializes the host object of the task. (inherited from ToolTask)
Family method | LogEventsFromTextOutput | Overidden. Logs the events from text output.
Family method | LogPathToTool | Logs the tool name and path to all registered loggers. (inherited from ToolTask)
Family method | LogToolCommand | Logs the starting point of the run to all registered loggers. (inherited from SvnClient)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | SkipTaskExecution | Indicates whether task execution should be skipped. (inherited from ToolTask)
Family method | ValidateParameters | Indicates whether all task paratmeters are valid. (inherited from SvnClient)
Top

See Also

SvnInfo Class
SvnInfo Members
MSBuild.Community.Tasks.Subversion Namespace


Execute Method

SvnInfo.Execute Method
[image]

Execute the task.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute() As Boolean _
Implements ITask.Execute
C#
public override bool Execute()
C++
public:
virtual bool Execute() override
J#
public override bool Execute()
JScript
public override function Execute() : bool

Return Value

true if execution is successful, false if not.

Implements

ITask.Execute

See Also

SvnInfo Class
SvnInfo Members
MSBuild.Community.Tasks.Subversion Namespace


LogEventsFromTextOutput Method

SvnInfo.LogEventsFromTextOutput Method
[image]

Logs the events from text output.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub LogEventsFromTextOutput( _
ByVal singleLine As String, _
ByVal messageImportance As MessageImportance _
)
C#
protected override void LogEventsFromTextOutput(
string singleLine,
MessageImportance messageImportance
)
C++
protected:
virtual void LogEventsFromTextOutput(
String singleLine,
MessageImportance messageImportance
) override
J#
protected override void LogEventsFromTextOutput(
string singleLine,
MessageImportance messageImportance
)
JScript
protected override function LogEventsFromTextOutput(
singleLine : String,
messageImportance : MessageImportance
)

Parameters

singleLine
The single line.
messageImportance
The message importance.

See Also

SvnInfo Class
SvnInfo Members
MSBuild.Community.Tasks.Subversion Namespace


SvnUpdate Class

SvnUpdate Class
See Also Members
[image]

Subversion Update command

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class SvnUpdate
Inherits SvnClient
C#
public class SvnUpdate : SvnClient
C++
ref class SvnUpdate : SvnClient
J#
public class SvnUpdate extends SvnClient
JScript
public class SvnUpdate extends SvnClient

Inheritance Hierarchy

System.Object
Microsoft.Build.Utilities.Task
Microsoft.Build.Utilities.ToolTask
MSBuild.Community.Tasks.Subversion.SvnClient
MSBuild.Community.Tasks.Subversion.SvnUpdate

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SvnUpdate Members
MSBuild.Community.Tasks.Subversion Namespace


SvnUpdate Members

SvnUpdate Members
See Also Constructors Properties Methods
[image]

Subversion Update command

The following tables list the members exposed by SvnUpdate.

Public Constructors

 | Name | Description
Public method | SvnUpdate | Initializes a new instance of the T:SvnUpdate class.
Top

Public Properties

 | Name | Description
Public property | Arguments | Gets or sets the arguments. (inherited from SvnClient)
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | Command | Gets or sets the command. (inherited from SvnClient)
Public property | ExitCode | Gets the returned exit code of the executable file. (inherited from ToolTask)
Public property | Force | Gets or sets the force. (inherited from SvnClient)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | LocalPath | Gets or sets the local path. (inherited from SvnClient)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Message | Gets or sets the message. (inherited from SvnClient)
Public property | Password | Gets or sets the password. (inherited from SvnClient)
Public property | RepositoryPath | Gets or sets the repository path. (inherited from SvnClient)
Public property | Revision | Gets or sets the revision. (inherited from SvnClient)
Public property | Targets | Gets or sets the targets. (inherited from SvnClient)
Public property | Timeout | Gets or sets the amount of time after which the task executable is terminated. (inherited from ToolTask)
Public property | ToolPath | Gets or sets the path of the executable file to run. (inherited from ToolTask)
Public property | Username | Gets or sets the username. (inherited from SvnClient)
Public property | Verbose | Gets or sets the verbose. (inherited from SvnClient)
Top

Protected Properties

 | Name | Description
Family property | EnvironmentOverride | Gets the override value of the PATH environment variable. (inherited from ToolTask)
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | ResponseFileEncoding | Gets the Encoding of the response file. (inherited from ToolTask)
Family property | StandardErrorEncoding | Gets the Encoding of the standard error stream of the task. (inherited from ToolTask)
Family property | StandardErrorLoggingImportance | Gets the MessageImportance with which to log errors. (inherited from ToolTask)
Family property | StandardOutputEncoding | Gets the Encoding of the standard output stream of the task. (inherited from ToolTask)
Family property | StandardOutputLoggingImportance | Gets the MessageImportance with which to log errors. (inherited from SvnClient)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Family property | ToolName | Gets the name of the executable file to run. (inherited from SvnClient)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Runs the exectuable file with the specified task parameters. (inherited from ToolTask)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | CallHostObjectToExecute | Calls the host object to perform the work of the task. (inherited from ToolTask)
Family method | ExecuteTool | Creates a temporoary response (.rsp) file and runs the executable file. (inherited from ToolTask)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GenerateCommandLineCommands | Returns a string value containing the command line arguments to pass directly to the executable file. (inherited from SvnClient)
Family method | GenerateFullPathToTool | Returns the fully qualified path to the executable file. (inherited from SvnClient)
Family method | GenerateResponseFileCommands | Returns a string value containing the command line arguments to add to the response (.rsp) file before running the executable file. (inherited from ToolTask)
Family method | GenerateSvnArguments | Generates the SVN arguments. (inherited from SvnClient)
Family method | GenerateSvnCommand | Generates the SVN command. (inherited from SvnClient)
Family method | GetResponseFileSwitch | Returns the command line switch used by the executable file to specifiy a response (.rsp) file. (inherited from ToolTask)
Family method | GetWorkingDirectory | Returns the directory in which to run the executable file. (inherited from ToolTask)
Family method | HandleTaskExecutionErrors | Handles execution errors raised by the executable file. (inherited from ToolTask)
Family method | InitializeHostObject | Initializes the host object of the task. (inherited from ToolTask)
Family method | LogEventsFromTextOutput | Logs the events from text output. (inherited from SvnClient)
Family method | LogPathToTool | Logs the tool name and path to all registered loggers. (inherited from ToolTask)
Family method | LogToolCommand | Logs the starting point of the run to all registered loggers. (inherited from SvnClient)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | SkipTaskExecution | Indicates whether task execution should be skipped. (inherited from ToolTask)
Family method | ValidateParameters | Overidden. Indicates whether all task paratmeters are valid.
Top

See Also

SvnUpdate Class
SvnUpdate Members
MSBuild.Community.Tasks.Subversion Namespace


SvnUpdate Constructor

SvnUpdate Constructor
[image]

Initializes a new instance of the T:SvnUpdate class.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SvnUpdate()
C++
public:
SvnUpdate() sealed
J#
public SvnUpdate()
JScript
public function SvnUpdate()

See Also

SvnUpdate Class
SvnUpdate Members
MSBuild.Community.Tasks.Subversion Namespace


Methods

SvnUpdate Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Runs the exectuable file with the specified task parameters. (inherited from ToolTask)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | CallHostObjectToExecute | Calls the host object to perform the work of the task. (inherited from ToolTask)
Family method | ExecuteTool | Creates a temporoary response (.rsp) file and runs the executable file. (inherited from ToolTask)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GenerateCommandLineCommands | Returns a string value containing the command line arguments to pass directly to the executable file. (inherited from SvnClient)
Family method | GenerateFullPathToTool | Returns the fully qualified path to the executable file. (inherited from SvnClient)
Family method | GenerateResponseFileCommands | Returns a string value containing the command line arguments to add to the response (.rsp) file before running the executable file. (inherited from ToolTask)
Family method | GenerateSvnArguments | Generates the SVN arguments. (inherited from SvnClient)
Family method | GenerateSvnCommand | Generates the SVN command. (inherited from SvnClient)
Family method | GetResponseFileSwitch | Returns the command line switch used by the executable file to specifiy a response (.rsp) file. (inherited from ToolTask)
Family method | GetWorkingDirectory | Returns the directory in which to run the executable file. (inherited from ToolTask)
Family method | HandleTaskExecutionErrors | Handles execution errors raised by the executable file. (inherited from ToolTask)
Family method | InitializeHostObject | Initializes the host object of the task. (inherited from ToolTask)
Family method | LogEventsFromTextOutput | Logs the events from text output. (inherited from SvnClient)
Family method | LogPathToTool | Logs the tool name and path to all registered loggers. (inherited from ToolTask)
Family method | LogToolCommand | Logs the starting point of the run to all registered loggers. (inherited from SvnClient)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | SkipTaskExecution | Indicates whether task execution should be skipped. (inherited from ToolTask)
Family method | ValidateParameters | Overidden. Indicates whether all task paratmeters are valid.
Top

See Also

SvnUpdate Class
SvnUpdate Members
MSBuild.Community.Tasks.Subversion Namespace


ValidateParameters Method

SvnUpdate.ValidateParameters Method
[image]

Indicates whether all task paratmeters are valid.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function ValidateParameters() As Boolean
C#
protected override bool ValidateParameters()
C++
protected:
virtual bool ValidateParameters() override
J#
protected override bool ValidateParameters()
JScript
protected override function ValidateParameters() : bool

Return Value

true if all task parameters are valid; otherwise, false.

See Also

SvnUpdate Class
SvnUpdate Members
MSBuild.Community.Tasks.Subversion Namespace


SvnVersion Class

SvnVersion Class
See Also Example Members
[image]

Summarize the local revision(s) of a working copy.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class SvnVersion
Inherits ToolTask
C#
public class SvnVersion : ToolTask
C++
ref class SvnVersion : ToolTask
J#
public class SvnVersion extends ToolTask
JScript
public class SvnVersion extends ToolTask

Example

The following example gets the revision of the current folder.

Copy Code
            <Target Name="Version">
              <SvnVersion LocalPath=".">
                <Output TaskParameter="Revision" PropertyName="Revision" />
              </SvnVersion>
              <Message Text="Revision: $(Revision)"/>
            </Target>

Inheritance Hierarchy

System.Object
Microsoft.Build.Utilities.Task
Microsoft.Build.Utilities.ToolTask
MSBuild.Community.Tasks.Subversion.SvnVersion

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SvnVersion Members
MSBuild.Community.Tasks.Subversion Namespace


SvnVersion Members

SvnVersion Members
See Also Example Constructors Properties Methods
[image]

Summarize the local revision(s) of a working copy.

The following tables list the members exposed by SvnVersion.

Public Constructors

 | Name | Description
Public method | SvnVersion | Initializes a new instance of the T:SvnVersion class.
Top

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | ExitCode | Gets the returned exit code of the executable file. (inherited from ToolTask)
Public property | Exported | True if invoked on a directory that is not a working copy, svnversion assumes it is an exported working copy and prints "exported".
Public property | HighRevision | High revision number of the local working repository revision range.
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | LocalPath | Path to local working copy.
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | LowRevision | Low revision number of the local working repository revision range.
Public property | Modifications | True if working copy contains modifications.
Public property | Revision | Revision number of the local working repository.
Public property | Switched | True if working copy is switched.
Public property | Timeout | Gets or sets the amount of time after which the task executable is terminated. (inherited from ToolTask)
Public property | ToolPath | Gets or sets the path of the executable file to run. (inherited from ToolTask)
Top

Protected Properties

 | Name | Description
Family property | EnvironmentOverride | Gets the override value of the PATH environment variable. (inherited from ToolTask)
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | ResponseFileEncoding | Gets the Encoding of the response file. (inherited from ToolTask)
Family property | StandardErrorEncoding | Gets the Encoding of the standard error stream of the task. (inherited from ToolTask)
Family property | StandardErrorLoggingImportance | Gets the MessageImportance with which to log errors. (inherited from ToolTask)
Family property | StandardOutputEncoding | Gets the Encoding of the standard output stream of the task. (inherited from ToolTask)
Family property | StandardOutputLoggingImportance | Overidden. Gets the MessageImportance with which to log errors.
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Family property | ToolName | Overidden. Gets the name of the executable file to run.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. Runs the exectuable file with the specified task parameters.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | CallHostObjectToExecute | Calls the host object to perform the work of the task. (inherited from ToolTask)
Family method | ExecuteTool | Creates a temporoary response (.rsp) file and runs the executable file. (inherited from ToolTask)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GenerateCommandLineCommands | Overidden. Returns a string value containing the command line arguments to pass directly to the executable file.
Family method | GenerateFullPathToTool | Overidden. Returns the fully qualified path to the executable file.
Family method | GenerateResponseFileCommands | Returns a string value containing the command line arguments to add to the response (.rsp) file before running the executable file. (inherited from ToolTask)
Family method | GetResponseFileSwitch | Returns the command line switch used by the executable file to specifiy a response (.rsp) file. (inherited from ToolTask)
Family method | GetWorkingDirectory | Returns the directory in which to run the executable file. (inherited from ToolTask)
Family method | HandleTaskExecutionErrors | Handles execution errors raised by the executable file. (inherited from ToolTask)
Family method | InitializeHostObject | Initializes the host object of the task. (inherited from ToolTask)
Family method | LogEventsFromTextOutput | Overidden. Logs the events from text output.
Family method | LogPathToTool | Logs the tool name and path to all registered loggers. (inherited from ToolTask)
Family method | LogToolCommand | Overidden. Logs the starting point of the run to all registered loggers.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | SkipTaskExecution | Indicates whether task execution should be skipped. (inherited from ToolTask)
Family method | ValidateParameters | Indicates whether all task paratmeters are valid. (inherited from ToolTask)
Top

See Also

SvnVersion Class
SvnVersion Members
MSBuild.Community.Tasks.Subversion Namespace


SvnVersion Constructor

SvnVersion Constructor
[image]

Initializes a new instance of the T:SvnVersion class.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SvnVersion()
C++
public:
SvnVersion() sealed
J#
public SvnVersion()
JScript
public function SvnVersion()

See Also

SvnVersion Class
SvnVersion Members
MSBuild.Community.Tasks.Subversion Namespace


Properties

SvnVersion Properties
See Also Example
[image]

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | ExitCode | Gets the returned exit code of the executable file. (inherited from ToolTask)
Public property | Exported | True if invoked on a directory that is not a working copy, svnversion assumes it is an exported working copy and prints "exported".
Public property | HighRevision | High revision number of the local working repository revision range.
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | LocalPath | Path to local working copy.
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | LowRevision | Low revision number of the local working repository revision range.
Public property | Modifications | True if working copy contains modifications.
Public property | Revision | Revision number of the local working repository.
Public property | Switched | True if working copy is switched.
Public property | Timeout | Gets or sets the amount of time after which the task executable is terminated. (inherited from ToolTask)
Public property | ToolPath | Gets or sets the path of the executable file to run. (inherited from ToolTask)
Top

Protected Properties

 | Name | Description
Family property | EnvironmentOverride | Gets the override value of the PATH environment variable. (inherited from ToolTask)
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | ResponseFileEncoding | Gets the Encoding of the response file. (inherited from ToolTask)
Family property | StandardErrorEncoding | Gets the Encoding of the standard error stream of the task. (inherited from ToolTask)
Family property | StandardErrorLoggingImportance | Gets the MessageImportance with which to log errors. (inherited from ToolTask)
Family property | StandardOutputEncoding | Gets the Encoding of the standard output stream of the task. (inherited from ToolTask)
Family property | StandardOutputLoggingImportance | Overidden. Gets the MessageImportance with which to log errors.
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Family property | ToolName | Overidden. Gets the name of the executable file to run.
Top

See Also

SvnVersion Class
SvnVersion Members
MSBuild.Community.Tasks.Subversion Namespace


Exported Property

SvnVersion.Exported Property
[image]

True if invoked on a directory that is not a working copy, svnversion assumes it is an exported working copy and prints "exported".

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Output>
Public Property Exported As Boolean
C#
[Output]
public bool Exported { get; set; }
C++
[Output]
public property bool Exported sealed {
bool get();
void set(bool value);
}
J#
/** @attribute Output() */
/** property */
public bool get_Exported();

/** property */
public void set_Exported(bool value);
JScript
public function get Exported() : bool

public function set Exported(value : bool);

See Also

SvnVersion Class
SvnVersion Members
MSBuild.Community.Tasks.Subversion Namespace


HighRevision Property

SvnVersion.HighRevision Property
[image]

High revision number of the local working repository revision range.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Output>
Public Property HighRevision As Integer
C#
[Output]
public int HighRevision { get; set; }
C++
[Output]
public property int HighRevision sealed {
int get();
void set(int value);
}
J#
/** @attribute Output() */
/** property */
public int get_HighRevision();

/** property */
public void set_HighRevision(int value);
JScript
public function get HighRevision() : int

public function set HighRevision(value : int);

See Also

SvnVersion Class
SvnVersion Members
MSBuild.Community.Tasks.Subversion Namespace


LocalPath Property

SvnVersion.LocalPath Property
[image]

Path to local working copy.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Required>
Public Property LocalPath As String
C#
[Required]
public string LocalPath { get; set; }
C++
[Required]
public property string LocalPath sealed {
String get();
void set(String value);
}
J#
/** @attribute Required() */
/** property */
public string get_LocalPath();

/** property */
public void set_LocalPath(string value);
JScript
public function get LocalPath() : String

public function set LocalPath(value : String);

See Also

SvnVersion Class
SvnVersion Members
MSBuild.Community.Tasks.Subversion Namespace


LowRevision Property

SvnVersion.LowRevision Property
[image]

Low revision number of the local working repository revision range.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Output>
Public Property LowRevision As Integer
C#
[Output]
public int LowRevision { get; set; }
C++
[Output]
public property int LowRevision sealed {
int get();
void set(int value);
}
J#
/** @attribute Output() */
/** property */
public int get_LowRevision();

/** property */
public void set_LowRevision(int value);
JScript
public function get LowRevision() : int

public function set LowRevision(value : int);

See Also

SvnVersion Class
SvnVersion Members
MSBuild.Community.Tasks.Subversion Namespace


Modifications Property

SvnVersion.Modifications Property
[image]

True if working copy contains modifications.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Output>
Public Property Modifications As Boolean
C#
[Output]
public bool Modifications { get; set; }
C++
[Output]
public property bool Modifications sealed {
bool get();
void set(bool value);
}
J#
/** @attribute Output() */
/** property */
public bool get_Modifications();

/** property */
public void set_Modifications(bool value);
JScript
public function get Modifications() : bool

public function set Modifications(value : bool);

See Also

SvnVersion Class
SvnVersion Members
MSBuild.Community.Tasks.Subversion Namespace


Revision Property

SvnVersion.Revision Property
[image]

Revision number of the local working repository.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Output>
Public Property Revision As Integer
C#
[Output]
public int Revision { get; set; }
C++
[Output]
public property int Revision sealed {
int get();
void set(int value);
}
J#
/** @attribute Output() */
/** property */
public int get_Revision();

/** property */
public void set_Revision(int value);
JScript
public function get Revision() : int

public function set Revision(value : int);

See Also

SvnVersion Class
SvnVersion Members
MSBuild.Community.Tasks.Subversion Namespace


StandardOutputLoggingImportance Property

SvnVersion.StandardOutputLoggingImportance Property
[image]

Gets the MessageImportance with which to log errors.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property StandardOutputLoggingImportance As MessageImportance
C#
protected override MessageImportance StandardOutputLoggingImportance { get; }
C++
protected override property MessageImportance StandardOutputLoggingImportance override {
MessageImportance get();
}
J#
/** property */
protected MessageImportance get_StandardOutputLoggingImportance();
JScript
protected function get StandardOutputLoggingImportance() : MessageImportance

Property Value

The MessageImportance with which to log errors.

See Also

SvnVersion Class
SvnVersion Members
MSBuild.Community.Tasks.Subversion Namespace


Switched Property

SvnVersion.Switched Property
[image]

True if working copy is switched.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Output>
Public Property Switched As Boolean
C#
[Output]
public bool Switched { get; set; }
C++
[Output]
public property bool Switched sealed {
bool get();
void set(bool value);
}
J#
/** @attribute Output() */
/** property */
public bool get_Switched();

/** property */
public void set_Switched(bool value);
JScript
public function get Switched() : bool

public function set Switched(value : bool);

See Also

SvnVersion Class
SvnVersion Members
MSBuild.Community.Tasks.Subversion Namespace


ToolName Property

SvnVersion.ToolName Property
[image]

Gets the name of the executable file to run.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property ToolName As String
C#
protected override string ToolName { get; }
C++
protected override property string ToolName override {
String get();
}
J#
/** property */
protected string get_ToolName();
JScript
protected function get ToolName() : String

Property Value

The name of the executable file to run.

See Also

SvnVersion Class
SvnVersion Members
MSBuild.Community.Tasks.Subversion Namespace


Methods

SvnVersion Methods
See Also Example
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. Runs the exectuable file with the specified task parameters.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | CallHostObjectToExecute | Calls the host object to perform the work of the task. (inherited from ToolTask)
Family method | ExecuteTool | Creates a temporoary response (.rsp) file and runs the executable file. (inherited from ToolTask)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GenerateCommandLineCommands | Overidden. Returns a string value containing the command line arguments to pass directly to the executable file.
Family method | GenerateFullPathToTool | Overidden. Returns the fully qualified path to the executable file.
Family method | GenerateResponseFileCommands | Returns a string value containing the command line arguments to add to the response (.rsp) file before running the executable file. (inherited from ToolTask)
Family method | GetResponseFileSwitch | Returns the command line switch used by the executable file to specifiy a response (.rsp) file. (inherited from ToolTask)
Family method | GetWorkingDirectory | Returns the directory in which to run the executable file. (inherited from ToolTask)
Family method | HandleTaskExecutionErrors | Handles execution errors raised by the executable file. (inherited from ToolTask)
Family method | InitializeHostObject | Initializes the host object of the task. (inherited from ToolTask)
Family method | LogEventsFromTextOutput | Overidden. Logs the events from text output.
Family method | LogPathToTool | Logs the tool name and path to all registered loggers. (inherited from ToolTask)
Family method | LogToolCommand | Overidden. Logs the starting point of the run to all registered loggers.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | SkipTaskExecution | Indicates whether task execution should be skipped. (inherited from ToolTask)
Family method | ValidateParameters | Indicates whether all task paratmeters are valid. (inherited from ToolTask)
Top

See Also

SvnVersion Class
SvnVersion Members
MSBuild.Community.Tasks.Subversion Namespace


Execute Method

SvnVersion.Execute Method
[image]

Runs the exectuable file with the specified task parameters.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute() As Boolean _
Implements ITask.Execute
C#
public override bool Execute()
C++
public:
virtual bool Execute() override
J#
public override bool Execute()
JScript
public override function Execute() : bool

Return Value

true if the task runs successfully; otherwise, false.

Implements

ITask.Execute

See Also

SvnVersion Class
SvnVersion Members
MSBuild.Community.Tasks.Subversion Namespace


GenerateCommandLineCommands Method

SvnVersion.GenerateCommandLineCommands Method
[image]

Returns a string value containing the command line arguments to pass directly to the executable file.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GenerateCommandLineCommands() As String
C#
protected override string GenerateCommandLineCommands()
C++
protected:
virtual String GenerateCommandLineCommands() override
J#
protected override string GenerateCommandLineCommands()
JScript
protected override function GenerateCommandLineCommands() : String

Return Value

A string value containing the command line arguments to pass directly to the executable file.

See Also

SvnVersion Class
SvnVersion Members
MSBuild.Community.Tasks.Subversion Namespace


GenerateFullPathToTool Method

SvnVersion.GenerateFullPathToTool Method
[image]

Returns the fully qualified path to the executable file.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GenerateFullPathToTool() As String
C#
protected override string GenerateFullPathToTool()
C++
protected:
virtual String GenerateFullPathToTool() override
J#
protected override string GenerateFullPathToTool()
JScript
protected override function GenerateFullPathToTool() : String

Return Value

The fully qualified path to the executable file.

See Also

SvnVersion Class
SvnVersion Members
MSBuild.Community.Tasks.Subversion Namespace


LogEventsFromTextOutput Method

SvnVersion.LogEventsFromTextOutput Method
[image]

Logs the events from text output.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub LogEventsFromTextOutput( _
ByVal singleLine As String, _
ByVal messageImportance As MessageImportance _
)
C#
protected override void LogEventsFromTextOutput(
string singleLine,
MessageImportance messageImportance
)
C++
protected:
virtual void LogEventsFromTextOutput(
String singleLine,
MessageImportance messageImportance
) override
J#
protected override void LogEventsFromTextOutput(
string singleLine,
MessageImportance messageImportance
)
JScript
protected override function LogEventsFromTextOutput(
singleLine : String,
messageImportance : MessageImportance
)

Parameters

singleLine
The single line.
messageImportance
The message importance.

See Also

SvnVersion Class
SvnVersion Members
MSBuild.Community.Tasks.Subversion Namespace


LogToolCommand Method

SvnVersion.LogToolCommand Method
[image]

Logs the starting point of the run to all registered loggers.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub LogToolCommand( _
ByVal message As String _
)
C#
protected override void LogToolCommand(
string message
)
C++
protected:
virtual void LogToolCommand(
String message
) override
J#
protected override void LogToolCommand(
string message
)
JScript
protected override function LogToolCommand(
message : String
)

Parameters

message
A descriptive message to provide loggers, usually the command line and switches.

See Also

SvnVersion Class
SvnVersion Members
MSBuild.Community.Tasks.Subversion Namespace


MSBuild.Community.Tasks.Tfs

MSBuild.Community.Tasks.Tfs Namespace
See Also Hierarchy

Classes

 | Class | Description
Public class | TeamFoundationServerException | Exceptions returned by the Team Foundation Server
Public class | TfsVersion | Determines the changeset in a local Team Foundation Server workspace

Interfaces

 | Interface | Description
Public interface | IServer | Describes the behavior of a Team Foundation Server


IServer Interface

IServer Interface
See Also Members
[image]

Describes the behavior of a Team Foundation Server

Namespace: MSBuild.Community.Tasks.Tfs
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Interface IServer
C#
public interface IServer
C++
interface class IServer
J#
public interface IServer
JScript
public interface IServer

See Also

IServer Members
MSBuild.Community.Tasks.Tfs Namespace


IServer Members

IServer Members
See Also Methods
[image]

Describes the behavior of a Team Foundation Server

The following tables list the members exposed by IServer.

Public Methods

 | Name | Description
Public method | GetLatestChangesetId | Retrieves the latest changeset ID associated with a path
Top

See Also

IServer Interface
IServer Members
MSBuild.Community.Tasks.Tfs Namespace


Methods

IServer Methods
[image]

Public Methods

 | Name | Description
Public method | GetLatestChangesetId | Retrieves the latest changeset ID associated with a path
Top

See Also

IServer Interface
IServer Members
MSBuild.Community.Tasks.Tfs Namespace


GetLatestChangesetId Method

IServer.GetLatestChangesetId Method
[image]

Retrieves the latest changeset ID associated with a path

Namespace: MSBuild.Community.Tasks.Tfs
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Function GetLatestChangesetId( _
ByVal localPath As String, _
ByVal credentials As ICredentials _
) As Integer
C#
int GetLatestChangesetId(
string localPath,
ICredentials credentials
)
C++
int GetLatestChangesetId(
String localPath,
ICredentials credentials
) abstract
J#
int GetLatestChangesetId(
string localPath,
ICredentials credentials
)
JScript
function GetLatestChangesetId(
localPath : String,
credentials : ICredentials
) : int

Parameters

localPath
A path on the local filesystem
credentials
Credentials used to authenticate against the serer

See Also

IServer Interface
IServer Members
MSBuild.Community.Tasks.Tfs Namespace


TeamFoundationServerException Class

TeamFoundationServerException Class
See Also Members
[image]

Exceptions returned by the Team Foundation Server

Namespace: MSBuild.Community.Tasks.Tfs
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class TeamFoundationServerException
Inherits Exception
C#
public class TeamFoundationServerException : Exception
C++
ref class TeamFoundationServerException : Exception
J#
public class TeamFoundationServerException extends Exception
JScript
public class TeamFoundationServerException extends Exception

Inheritance Hierarchy

System.Object
System.Exception
MSBuild.Community.Tasks.Tfs.TeamFoundationServerException

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

TeamFoundationServerException Members
MSBuild.Community.Tasks.Tfs Namespace


TeamFoundationServerException Members

TeamFoundationServerException Members
See Also Properties Methods Explicit Inteface Implementations
[image]

Exceptions returned by the Team Foundation Server

The following tables list the members exposed by TeamFoundationServerException.

Public Constructors

Name | Description
TeamFoundationServerException | Overloaded. Initializes a new instance of the TeamFoundationServerException class.
Top

Public Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (inherited from Exception)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception)
Top

Protected Properties

 | Name | Description
Family property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception)
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception)
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
TeamFoundationServerException | Overloaded. Initializes a new instance of the TeamFoundationServerException class.
Top

See Also

TeamFoundationServerException Class
TeamFoundationServerException Members
MSBuild.Community.Tasks.Tfs Namespace


TeamFoundationServerException Constructor

TeamFoundationServerException Constructor

Initializes a new instance of the TeamFoundationServerException class.

Overload List

 | Name | Description
Public method | TeamFoundationServerException | Creates a new instance of the exception
Public method | TeamFoundationServerException (String) | Creates a new instance of the exception

See Also

TeamFoundationServerException Class
TeamFoundationServerException Members
MSBuild.Community.Tasks.Tfs Namespace


TeamFoundationServerException Constructor ()

TeamFoundationServerException Constructor ()
See Also
[image]

Creates a new instance of the exception

Namespace: MSBuild.Community.Tasks.Tfs
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public TeamFoundationServerException()
C++
public:
TeamFoundationServerException() sealed
J#
public TeamFoundationServerException()
JScript
public function TeamFoundationServerException()

See Also

TeamFoundationServerException Class
TeamFoundationServerException Members
MSBuild.Community.Tasks.Tfs Namespace
TeamFoundationServerException Constructor Overload List


TeamFoundationServerException Constructor (String)

TeamFoundationServerException Constructor (String)
See Also
[image]

Creates a new instance of the exception

Namespace: MSBuild.Community.Tasks.Tfs
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal message As String _
)
C#
public TeamFoundationServerException(
string message
)
C++
public:
TeamFoundationServerException(
String message
) sealed
J#
public TeamFoundationServerException(
string message
)
JScript
public function TeamFoundationServerException(
message : String
)

Parameters

message
A description of the exception

See Also

TeamFoundationServerException Class
TeamFoundationServerException Members
MSBuild.Community.Tasks.Tfs Namespace
TeamFoundationServerException Constructor Overload List


TfsVersion Class

TfsVersion Class
See Also Members
[image]

Determines the changeset in a local Team Foundation Server workspace

Namespace: MSBuild.Community.Tasks.Tfs
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class TfsVersion
Inherits Task
C#
public class TfsVersion : Task
C++
ref class TfsVersion : Task
J#
public class TfsVersion extends Task
JScript
public class TfsVersion extends Task

Inheritance Hierarchy

System.Object
Microsoft.Build.Utilities.Task
MSBuild.Community.Tasks.Tfs.TfsVersion

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

TfsVersion Members
MSBuild.Community.Tasks.Tfs Namespace


TfsVersion Members

TfsVersion Members
See Also Constructors Properties Methods
[image]

Determines the changeset in a local Team Foundation Server workspace

The following tables list the members exposed by TfsVersion.

Public Constructors

 | Name | Description
Public method | TfsVersion | Initializes a new instance of the TfsVersion class.
Top

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | Changeset | The latest changeset ID in the local path
Public property | Domain | The domain of the user to authenticate on the server
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | LocalPath | Path to local working copy.
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Password | The password for the user to authenticate on the server
Public property | TfsLibraryLocation | The location of the Team Foundation Server client assemblies. Leave empty when the client is installed in the Global Assembly Cache.
Public property | Username | The user to authenticate on the server
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. Runs the exectuable file with the specified task parameters.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

TfsVersion Class
TfsVersion Members
MSBuild.Community.Tasks.Tfs Namespace


TfsVersion Constructor

TfsVersion Constructor
[image]

Initializes a new instance of the TfsVersion class.

Namespace: MSBuild.Community.Tasks.Tfs
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public TfsVersion()
C++
public:
TfsVersion() sealed
J#
public TfsVersion()
JScript
public function TfsVersion()

See Also

TfsVersion Class
TfsVersion Members
MSBuild.Community.Tasks.Tfs Namespace


Properties

TfsVersion Properties
[image]

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | Changeset | The latest changeset ID in the local path
Public property | Domain | The domain of the user to authenticate on the server
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | LocalPath | Path to local working copy.
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | Password | The password for the user to authenticate on the server
Public property | TfsLibraryLocation | The location of the Team Foundation Server client assemblies. Leave empty when the client is installed in the Global Assembly Cache.
Public property | Username | The user to authenticate on the server
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

See Also

TfsVersion Class
TfsVersion Members
MSBuild.Community.Tasks.Tfs Namespace


Changeset Property

TfsVersion.Changeset Property
[image]

The latest changeset ID in the local path

Namespace: MSBuild.Community.Tasks.Tfs
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Output>
Public ReadOnly Property Changeset As Integer
C#
[Output]
public int Changeset { get; }
C++
[Output]
public property int Changeset sealed {
int get();
}
J#
/** @attribute Output() */
/** property */
public int get_Changeset();
JScript
public function get Changeset() : int

See Also

TfsVersion Class
TfsVersion Members
MSBuild.Community.Tasks.Tfs Namespace


Domain Property

TfsVersion.Domain Property
[image]

The domain of the user to authenticate on the server

Namespace: MSBuild.Community.Tasks.Tfs
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Domain As String
C#
public string Domain { get; set; }
C++
public property string Domain sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Domain();

/** property */
public void set_Domain(string value);
JScript
public function get Domain() : String

public function set Domain(value : String);

Remarks

Leave empty to use the credentials of the current user.

See Also

TfsVersion Class
TfsVersion Members
MSBuild.Community.Tasks.Tfs Namespace


LocalPath Property

TfsVersion.LocalPath Property
[image]

Path to local working copy.

Namespace: MSBuild.Community.Tasks.Tfs
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Required>
Public Property LocalPath As String
C#
[Required]
public string LocalPath { get; set; }
C++
[Required]
public property string LocalPath sealed {
String get();
void set(String value);
}
J#
/** @attribute Required() */
/** property */
public string get_LocalPath();

/** property */
public void set_LocalPath(string value);
JScript
public function get LocalPath() : String

public function set LocalPath(value : String);

See Also

TfsVersion Class
TfsVersion Members
MSBuild.Community.Tasks.Tfs Namespace


Password Property

TfsVersion.Password Property
[image]

The password for the user to authenticate on the server

Namespace: MSBuild.Community.Tasks.Tfs
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Password As String
C#
public string Password { get; set; }
C++
public property string Password sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Password();

/** property */
public void set_Password(string value);
JScript
public function get Password() : String

public function set Password(value : String);

Remarks

Leave empty to use the credentials of the current user.

See Also

TfsVersion Class
TfsVersion Members
MSBuild.Community.Tasks.Tfs Namespace


TfsLibraryLocation Property

TfsVersion.TfsLibraryLocation Property
[image]

The location of the Team Foundation Server client assemblies. Leave empty when the client is installed in the Global Assembly Cache.

Namespace: MSBuild.Community.Tasks.Tfs
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property TfsLibraryLocation As String
C#
public string TfsLibraryLocation { get; set; }
C++
public property string TfsLibraryLocation sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_TfsLibraryLocation();

/** property */
public void set_TfsLibraryLocation(string value);
JScript
public function get TfsLibraryLocation() : String

public function set TfsLibraryLocation(value : String);

See Also

TfsVersion Class
TfsVersion Members
MSBuild.Community.Tasks.Tfs Namespace


Username Property

TfsVersion.Username Property
[image]

The user to authenticate on the server

Namespace: MSBuild.Community.Tasks.Tfs
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Username As String
C#
public string Username { get; set; }
C++
public property string Username sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Username();

/** property */
public void set_Username(string value);
JScript
public function get Username() : String

public function set Username(value : String);

Remarks

Leave empty to use the credentials of the current user.

See Also

TfsVersion Class
TfsVersion Members
MSBuild.Community.Tasks.Tfs Namespace


Methods

TfsVersion Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. Runs the exectuable file with the specified task parameters.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

TfsVersion Class
TfsVersion Members
MSBuild.Community.Tasks.Tfs Namespace


Execute Method

TfsVersion.Execute Method
[image]

Runs the exectuable file with the specified task parameters.

Namespace: MSBuild.Community.Tasks.Tfs
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute() As Boolean _
Implements ITask.Execute
C#
public override bool Execute()
C++
public:
virtual bool Execute() override
J#
public override bool Execute()
JScript
public override function Execute() : bool

Return Value

true if the task runs successfully; otherwise, false.

Implements

ITask.Execute

See Also

TfsVersion Class
TfsVersion Members
MSBuild.Community.Tasks.Tfs Namespace


MSBuild.Community.Tasks.Xml

MSBuild.Community.Tasks.Xml Namespace
See Also Hierarchy

Classes

 | Class | Description
Public class | XmlMassUpdate | Performs multiple updates on an XML file
Public class | XmlNodeTaskItem | Represents a single XmlNode selected using an XML task.
Public class | XmlQuery | Reads a value or values from lines of XML
Public class | XmlTaskHelper | Provides methods used by all of the XML tasks


XmlMassUpdate Class

XmlMassUpdate Class
See Also Example Members
[image]

Performs multiple updates on an XML file

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class XmlMassUpdate
Inherits Task
C#
public class XmlMassUpdate : Task
C++
ref class XmlMassUpdate : Task
J#
public class XmlMassUpdate extends Task
JScript
public class XmlMassUpdate extends Task

Example

These examples will demonstrate how to make multiple updates to a XML file named web.config. It looks like:

Copy Code
<?xml version="1.0" encoding="utf-8" ?>
<configuration>
    <appSettings>
        <add key="ItemsPerPage" value="10" />
        <add key="EnableCaching" value="true" />
        <add key="DefaultServer" value="TIGRIS" />
    </appSettings>
    <system.web>
        <compilation defaultLanguage="c#" debug="true" />
        <customErrors mode="Off" />
        <trace enabled="true" requestLimit="10" pageOutput="true" />
        <globalization requestEncoding="utf-8" responseEncoding="utf-8" />
    </system.web>
</configuration>
You can update the file using instructions from an external file (specified as the SubstitutionsFile):
Copy Code
<XmlMassUpdate ContentFile="web.config" SubstitutionsFile="changes.xml" ContentRoot="/configuration/system.web" SubstitutionsRoot="/system.web" />
The SubstitutionsFile is named changes.xml and contains:
Copy Code
<system.web>
        <compilation debug="false" />
        <customErrors mode="RemoteOnly" defaultRedirect="Error.htm">
          <error statusCode="401" redirect="AccessDenied.aspx" />
        </customErrors>
        <trace enabled="false" />
      </system.web>
You can also provide the update instructions within the MSBuild project file itself. It takes advantage of the MSBuild ProjectExtensions element which allows you to add XML to a project file that will be ignored by the MSBuild engine. This example also demonstrates how to use NamespaceDefinitions:
Copy Code
<ProjectExtensions>
  <system.web>
    <compilation debug="false" />
    <trace enabled="false" />
  </system.web>
</ProjectExtensions>
<Target Name="SubstituteFromProj">
  <XmlMassUpdate ContentFile="web.config" ContentRoot="/configuration/system.web"
    NamespaceDefinitions="msb=http://schemas.microsoft.com/developer/msbuild/2003"
    SubstitutionsFile="$(MSBuildProjectFullPath)"
    SubstitutionsRoot="/msb:Project/msb:ProjectExtensions/msb:system.web" />
</Target>
The following example demonstrates how to deal with "keyed" elements. When you need to update an element, and multiple elements exist with the same name, it must be be differentied by one of its attributes. You designate the differentiating attribute using the "key" attribute declared in the UpdateControlNamespace. If an element matching the keyed attribute is not found, a new element will be created (DefaultSort in the example). This example also demonstrates creating a new file with the merged changes instead of modifying the original file.
Copy Code
 <XmlMassUpdate ContentFile="web.config" SubstitutionsFile="changes.xml" MergedFile="web.config.keyed.xml"  />
Using a changes.xml file with the following contents:
Copy Code
<configuration xmlns:xmu="urn:msbuildcommunitytasks-xmlmassupdate">
  <appSettings>
        <add xmu:key="key" key="EnableCaching" value="false" />
        <add xmu:key="key" key="DefaultSort" value="LastName" />
  </appSettings>
</configuration>
Use a changes.xml file with the following contents to demonstrate how to remove an element from the updated file:
Copy Code
<configuration xmlns:xmu="urn:msbuildcommunitytasks-xmlmassupdate">
  <appSettings>
        <add xmu:key="key" key="ItemsPerPage" xmu:action="remove" />
        <trace xmu:action="remove" />
  </appSettings>
</configuration>
You can also specify the changes to apply from within the target document. By making use of the SubstitutionsRoot property, you can store multiple sets of changes to apply based on runtime conditions. Consider the following source web.config file:
Copy Code
<?xml version="1.0" encoding="utf-8" ?>
<configuration>
    <system.web>
        <compilation defaultLanguage="c#" debug="true" />
        <customErrors mode="Off" />
        <trace enabled="true" requestLimit="10" pageOutput="true" />
        <globalization requestEncoding="utf-8" responseEncoding="utf-8" />
    </system.web>
    <substitutions>
      <test>
        <system.web>
          <compilation debug="false" />
          <trace enabled="true" />
        </system.web>
      </test>
      <prod>
        <system.web>
          <compilation debug="false" />
          <trace enabled="false" />
        </system.web>
      </prod>
    </substitutions>
</configuration>
You could use the following task definition, which relies on a property "TargetEnvironment" to determine which set of changes to apply:
Copy Code
 <XmlMassUpdate ContentFile="web.config" ContentRoot="/configuration" SubstitutionsRoot="/configuration/substitutions/$(TargetEnvironment)" />
You will need to provide a value of "test" or "prod" to the TargetEnvironment property. The property can be defined in a PropertyGroup section of the MSBuild file, or passed as a command-line parameter.
Copy Code
 msbuild build.proj /p:TargetEnvironment=prod

Remarks

XmlMassUpdate allows to to specify multiple changes to make to an XML file (the ContentFile. By default, the changes are applied to the ContentFile, but you can create a new file by providing the MergedFile attribute. The change instructions are specified using XML in the SubstitutionsFile. If the SubstitutionsFile does not mirror the structure of the ContentFile exactly, you can specify the ContentRoot and SubstitutionsRoot XPath expressions which determine how the files should be mapped to each other.

Any element within the SubstitutionsRoot will find the corresponding element in the ContentRoot. If it does not exist, it will be created with all of its attributes. If it does exist, the attributes will be added or updated as specified.

Any attribute declared within the UpdateControlNamespace will not be copied to the modified file. Valid attributes are key and action. The key attribute allows you to define an attribute to use as the identifying attribute when you only want to update a single element, and multiple elements with the same name exist. You can also use the action="remove" attribute to specify that an element should be deleted instead of updated.

Inheritance Hierarchy

System.Object
Microsoft.Build.Utilities.Task
MSBuild.Community.Tasks.Xml.XmlMassUpdate

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

XmlMassUpdate Members
MSBuild.Community.Tasks.Xml Namespace


XmlMassUpdate Members

XmlMassUpdate Members
See Also Example Constructors Properties Methods
[image]

Performs multiple updates on an XML file

The following tables list the members exposed by XmlMassUpdate.

Public Constructors

 | Name | Description
Public method | XmlMassUpdate | Initializes a new instance of the XmlMassUpdate class.
Top

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | ContentFile | The original file whose content is to be updated
Public property | ContentPathUsedByTask | The full path of the file containing content updated by the task
Public property | ContentRoot | The XPath expression identifying root node that substitions are relative to
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | MergedFile | The file created after performing the updates
Public property | MergedPathUsedByTask | The full path of the file containing the results of the task
Public property | NamespaceDefinitions | A collection of prefix=namespace definitions used to query the XML documents
Public property | SubstitutionsFile | The file containing the list of updates to perform
Public property | SubstitutionsPathUsedByTask | The full path of the file containing substitutions used by the task
Public property | SubstitutionsRoot | The XPath expression used to locate the list of substitutions to perform
Public property | UpdateControlNamespace | The namespace used for XmlMassUpdate pre-defined attributes
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. When overridden in a derived class, executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | LoadContentDocument | Returns ContentFile as an XmlDocument.
Family method | LoadSubstitutionsDocument | Returns SubstitutionsFile as an XmlDocument.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | SaveMergedDocument | Creates MergedFile from the specified XmlDocument
Top

See Also

XmlMassUpdate Class
XmlMassUpdate Members
MSBuild.Community.Tasks.Xml Namespace


XmlMassUpdate Constructor

XmlMassUpdate Constructor
[image]

Initializes a new instance of the XmlMassUpdate class.

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public XmlMassUpdate()
C++
public:
XmlMassUpdate() sealed
J#
public XmlMassUpdate()
JScript
public function XmlMassUpdate()

See Also

XmlMassUpdate Class
XmlMassUpdate Members
MSBuild.Community.Tasks.Xml Namespace


Properties

XmlMassUpdate Properties
See Also Example
[image]

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | ContentFile | The original file whose content is to be updated
Public property | ContentPathUsedByTask | The full path of the file containing content updated by the task
Public property | ContentRoot | The XPath expression identifying root node that substitions are relative to
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | MergedFile | The file created after performing the updates
Public property | MergedPathUsedByTask | The full path of the file containing the results of the task
Public property | NamespaceDefinitions | A collection of prefix=namespace definitions used to query the XML documents
Public property | SubstitutionsFile | The file containing the list of updates to perform
Public property | SubstitutionsPathUsedByTask | The full path of the file containing substitutions used by the task
Public property | SubstitutionsRoot | The XPath expression used to locate the list of substitutions to perform
Public property | UpdateControlNamespace | The namespace used for XmlMassUpdate pre-defined attributes
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

See Also

XmlMassUpdate Class
XmlMassUpdate Members
MSBuild.Community.Tasks.Xml Namespace


ContentFile Property

XmlMassUpdate.ContentFile Property
[image]

The original file whose content is to be updated

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Required>
Public Property ContentFile As ITaskItem
C#
[Required]
public ITaskItem ContentFile { get; set; }
C++
[Required]
public property ITaskItem ContentFile sealed {
ITaskItem get();
void set(ITaskItem value);
}
J#
/** @attribute Required() */
/** property */
public ITaskItem get_ContentFile();

/** property */
public void set_ContentFile(ITaskItem value);
JScript
public function get ContentFile() : ITaskItem

public function set ContentFile(value : ITaskItem);

Remarks

This task is currently under construction and not necessarily feature complete.

See Also

XmlMassUpdate Class
XmlMassUpdate Members
MSBuild.Community.Tasks.Xml Namespace


ContentPathUsedByTask Property

XmlMassUpdate.ContentPathUsedByTask Property
[image]

The full path of the file containing content updated by the task

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Output>
Public ReadOnly Property ContentPathUsedByTask As String
C#
[Output]
public string ContentPathUsedByTask { get; }
C++
[Output]
public property string ContentPathUsedByTask sealed {
String get();
}
J#
/** @attribute Output() */
/** property */
public string get_ContentPathUsedByTask();
JScript
public function get ContentPathUsedByTask() : String

See Also

XmlMassUpdate Class
XmlMassUpdate Members
MSBuild.Community.Tasks.Xml Namespace


ContentRoot Property

XmlMassUpdate.ContentRoot Property
[image]

The XPath expression identifying root node that substitions are relative to

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property ContentRoot As String
C#
public string ContentRoot { get; set; }
C++
public property string ContentRoot sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_ContentRoot();

/** property */
public void set_ContentRoot(string value);
JScript
public function get ContentRoot() : String

public function set ContentRoot(value : String);

Remarks

When not specified, the default is the document root: /

See Also

XmlMassUpdate Class
XmlMassUpdate Members
MSBuild.Community.Tasks.Xml Namespace


MergedFile Property

XmlMassUpdate.MergedFile Property
[image]

The file created after performing the updates

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property MergedFile As ITaskItem
C#
public ITaskItem MergedFile { get; set; }
C++
public property ITaskItem MergedFile sealed {
ITaskItem get();
void set(ITaskItem value);
}
J#
/** property */
public ITaskItem get_MergedFile();

/** property */
public void set_MergedFile(ITaskItem value);
JScript
public function get MergedFile() : ITaskItem

public function set MergedFile(value : ITaskItem);

See Also

XmlMassUpdate Class
XmlMassUpdate Members
MSBuild.Community.Tasks.Xml Namespace


MergedPathUsedByTask Property

XmlMassUpdate.MergedPathUsedByTask Property
[image]

The full path of the file containing the results of the task

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Output>
Public ReadOnly Property MergedPathUsedByTask As String
C#
[Output]
public string MergedPathUsedByTask { get; }
C++
[Output]
public property string MergedPathUsedByTask sealed {
String get();
}
J#
/** @attribute Output() */
/** property */
public string get_MergedPathUsedByTask();
JScript
public function get MergedPathUsedByTask() : String

See Also

XmlMassUpdate Class
XmlMassUpdate Members
MSBuild.Community.Tasks.Xml Namespace


NamespaceDefinitions Property

XmlMassUpdate.NamespaceDefinitions Property
See Also Example
[image]

A collection of prefix=namespace definitions used to query the XML documents

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property NamespaceDefinitions As ITaskItem[]
C#
public ITaskItem[] NamespaceDefinitions { get; set; }
C++
public property ITaskItem[] NamespaceDefinitions sealed {
array<ITaskItem>^ get();
void set(array<ITaskItem>^ value);
}
J#
/** property */
public ITaskItem[] get_NamespaceDefinitions();

/** property */
public void set_NamespaceDefinitions(ITaskItem[] value);
JScript
public function get NamespaceDefinitions() : ITaskItem[]

public function set NamespaceDefinitions(value : ITaskItem[]);

Example

Defining multiple namespaces:

Copy Code
<XmlMassUpdate ContentFile="web.config"
  SubstitutionsRoot="/configuration/substitutions"
     NamespaceDefinitions = "soap=http://www.w3.org/2001/12/soap-envelope;x=http://www.w3.org/1999/XSL/Transform">
/>

See Also

XmlMassUpdate Class
XmlMassUpdate Members
MSBuild.Community.Tasks.Xml Namespace


SubstitutionsFile Property

XmlMassUpdate.SubstitutionsFile Property
[image]

The file containing the list of updates to perform

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property SubstitutionsFile As ITaskItem
C#
public ITaskItem SubstitutionsFile { get; set; }
C++
public property ITaskItem SubstitutionsFile sealed {
ITaskItem get();
void set(ITaskItem value);
}
J#
/** property */
public ITaskItem get_SubstitutionsFile();

/** property */
public void set_SubstitutionsFile(ITaskItem value);
JScript
public function get SubstitutionsFile() : ITaskItem

public function set SubstitutionsFile(value : ITaskItem);

See Also

XmlMassUpdate Class
XmlMassUpdate Members
MSBuild.Community.Tasks.Xml Namespace


SubstitutionsPathUsedByTask Property

XmlMassUpdate.SubstitutionsPathUsedByTask Property
[image]

The full path of the file containing substitutions used by the task

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Output>
Public ReadOnly Property SubstitutionsPathUsedByTask As String
C#
[Output]
public string SubstitutionsPathUsedByTask { get; }
C++
[Output]
public property string SubstitutionsPathUsedByTask sealed {
String get();
}
J#
/** @attribute Output() */
/** property */
public string get_SubstitutionsPathUsedByTask();
JScript
public function get SubstitutionsPathUsedByTask() : String

See Also

XmlMassUpdate Class
XmlMassUpdate Members
MSBuild.Community.Tasks.Xml Namespace


SubstitutionsRoot Property

XmlMassUpdate.SubstitutionsRoot Property
[image]

The XPath expression used to locate the list of substitutions to perform

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property SubstitutionsRoot As String
C#
public string SubstitutionsRoot { get; set; }
C++
public property string SubstitutionsRoot sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_SubstitutionsRoot();

/** property */
public void set_SubstitutionsRoot(string value);
JScript
public function get SubstitutionsRoot() : String

public function set SubstitutionsRoot(value : String);

Remarks

When not specified, the default is the document root: /

When there is a set of elements with the same name, and you want to update a single element which can be identified by one of its attributes, you need to include an attribute named 'key' in the namespace urn:msbuildcommunitytasks-xmlmassupdate. The value of the attribute is the name of the attribute that should be used as the unique identifier.

See Also

XmlMassUpdate Class
XmlMassUpdate Members
MSBuild.Community.Tasks.Xml Namespace


UpdateControlNamespace Property

XmlMassUpdate.UpdateControlNamespace Property
[image]

The namespace used for XmlMassUpdate pre-defined attributes

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property UpdateControlNamespace As String
C#
public string UpdateControlNamespace { get; }
C++
public property string UpdateControlNamespace sealed {
String get();
}
J#
/** property */
public string get_UpdateControlNamespace();
JScript
public function get UpdateControlNamespace() : String

Remarks

Evaluates to: urn:msbuildcommunitytasks-xmlmassupdate

Attributes decorated with this namespace are used to control how a substitutions element or attribute is handled during the update. For example, the key attribute is used to identify the attribute on an element that uniquely identifies the element in a set.

See Also

XmlMassUpdate Class
XmlMassUpdate Members
MSBuild.Community.Tasks.Xml Namespace


Methods

XmlMassUpdate Methods
See Also Example
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. When overridden in a derived class, executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | LoadContentDocument | Returns ContentFile as an XmlDocument.
Family method | LoadSubstitutionsDocument | Returns SubstitutionsFile as an XmlDocument.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | SaveMergedDocument | Creates MergedFile from the specified XmlDocument
Top

See Also

XmlMassUpdate Class
XmlMassUpdate Members
MSBuild.Community.Tasks.Xml Namespace


Execute Method

XmlMassUpdate.Execute Method
[image]

When overridden in a derived class, executes the task.

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute() As Boolean _
Implements ITask.Execute
C#
public override bool Execute()
C++
public:
virtual bool Execute() override
J#
public override bool Execute()
JScript
public override function Execute() : bool

Return Value

True if the task successfully executed; otherwise, false.

Implements

ITask.Execute

See Also

XmlMassUpdate Class
XmlMassUpdate Members
MSBuild.Community.Tasks.Xml Namespace


LoadContentDocument Method

XmlMassUpdate.LoadContentDocument Method
[image]

Returns ContentFile as an XmlDocument.

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function LoadContentDocument() As XmlDocument
C#
protected virtual XmlDocument LoadContentDocument()
C++
protected:
virtual XmlDocument LoadContentDocument()
J#
protected virtual XmlDocument LoadContentDocument()
JScript
protected virtual function LoadContentDocument() : XmlDocument

Remarks

This method is not intended for use by consumers. It is exposed for testing purposes.

See Also

XmlMassUpdate Class
XmlMassUpdate Members
MSBuild.Community.Tasks.Xml Namespace


LoadSubstitutionsDocument Method

XmlMassUpdate.LoadSubstitutionsDocument Method
[image]

Returns SubstitutionsFile as an XmlDocument.

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function LoadSubstitutionsDocument() As XmlDocument
C#
protected virtual XmlDocument LoadSubstitutionsDocument()
C++
protected:
virtual XmlDocument LoadSubstitutionsDocument()
J#
protected virtual XmlDocument LoadSubstitutionsDocument()
JScript
protected virtual function LoadSubstitutionsDocument() : XmlDocument

Remarks

This method is not intended for use by consumers. It is exposed for testing purposes.

See Also

XmlMassUpdate Class
XmlMassUpdate Members
MSBuild.Community.Tasks.Xml Namespace


SaveMergedDocument Method

XmlMassUpdate.SaveMergedDocument Method
[image]

Creates MergedFile from the specified XmlDocument

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function SaveMergedDocument( _
ByVal mergedDocument As XmlDocument _
) As Boolean
C#
protected virtual bool SaveMergedDocument(
XmlDocument mergedDocument
)
C++
protected:
virtual bool SaveMergedDocument(
XmlDocument mergedDocument
)
J#
protected virtual bool SaveMergedDocument(
XmlDocument mergedDocument
)
JScript
protected virtual function SaveMergedDocument(
mergedDocument : XmlDocument
) : bool

Parameters

mergedDocument
The XML to save to a file

Remarks

This method is not intended for use by consumers. It is exposed for testing purposes.

See Also

XmlMassUpdate Class
XmlMassUpdate Members
MSBuild.Community.Tasks.Xml Namespace


XmlNodeTaskItem Class

XmlNodeTaskItem Class
See Also Members
[image]

Represents a single XmlNode selected using an XML task.

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class XmlNodeTaskItem
Implements ITaskItem
C#
public class XmlNodeTaskItem : ITaskItem
C++
ref class XmlNodeTaskItem : ITaskItem
J#
public class XmlNodeTaskItem implements ITaskItem
JScript
public class XmlNodeTaskItem extends ITaskItem

Inheritance Hierarchy

System.Object
MSBuild.Community.Tasks.Xml.XmlNodeTaskItem

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

XmlNodeTaskItem Members
MSBuild.Community.Tasks.Xml Namespace


XmlNodeTaskItem Members

XmlNodeTaskItem Members
See Also Constructors Properties Methods
[image]

Represents a single XmlNode selected using an XML task.

The following tables list the members exposed by XmlNodeTaskItem.

Public Constructors

 | Name | Description
Public method | XmlNodeTaskItem | Initializes a new instance of an XmlNodeTaskItem
Top

Public Properties

 | Name | Description
Public property | ItemSpec |
Public property | MetadataCount |
Public property | MetadataNames |
Top

Public Methods

 | Name | Description
Public method | CloneCustomMetadata |
Public method | CopyMetadataTo |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetMetadata |
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
 | op_Explicit | Returns the ItemSpec when the XmlNodeTaskItem is explicitly cast as a String
Public method | RemoveMetadata |
Public method | SetMetadata |
Public method | ToString | Overidden. Returns a string representation of the XmlNodeTaskItem.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

XmlNodeTaskItem Class
XmlNodeTaskItem Members
MSBuild.Community.Tasks.Xml Namespace


XmlNodeTaskItem Constructor

XmlNodeTaskItem Constructor
[image]

Initializes a new instance of an XmlNodeTaskItem

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal xpathNavigator As XPathNavigator, _
ByVal reservedMetaDataPrefix As String _
)
C#
public XmlNodeTaskItem(
XPathNavigator xpathNavigator,
string reservedMetaDataPrefix
)
C++
public:
XmlNodeTaskItem(
XPathNavigator xpathNavigator,
String reservedMetaDataPrefix
) sealed
J#
public XmlNodeTaskItem(
XPathNavigator xpathNavigator,
string reservedMetaDataPrefix
)
JScript
public function XmlNodeTaskItem(
xpathNavigator : XPathNavigator,
reservedMetaDataPrefix : String
)

Parameters

xpathNavigator
The selected XmlNode
reservedMetaDataPrefix
The prefix to attach to the reserved metadata properties.

See Also

XmlNodeTaskItem Class
XmlNodeTaskItem Members
MSBuild.Community.Tasks.Xml Namespace


Properties

XmlNodeTaskItem Properties
[image]

Public Properties

 | Name | Description
Public property | ItemSpec |
Public property | MetadataCount |
Public property | MetadataNames |
Top

See Also

XmlNodeTaskItem Class
XmlNodeTaskItem Members
MSBuild.Community.Tasks.Xml Namespace


ItemSpec Property

XmlNodeTaskItem.ItemSpec Property
[image]

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property ItemSpec As String _
Implements ITaskItem.ItemSpec
C#
public string ItemSpec { get; set; }
C++
public property string ItemSpec sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_ItemSpec();

/** property */
public void set_ItemSpec(string value);
JScript
public function get ItemSpec() : String

public function set ItemSpec(value : String);

Implements

ITaskItem.ItemSpec

See Also

XmlNodeTaskItem Class
XmlNodeTaskItem Members
MSBuild.Community.Tasks.Xml Namespace


MetadataCount Property

XmlNodeTaskItem.MetadataCount Property
[image]

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MetadataCount As Integer _
Implements ITaskItem.MetadataCount
C#
public int MetadataCount { get; }
C++
public property int MetadataCount sealed {
int get();
}
J#
/** property */
public int get_MetadataCount();
JScript
public function get MetadataCount() : int

Implements

ITaskItem.MetadataCount

See Also

XmlNodeTaskItem Class
XmlNodeTaskItem Members
MSBuild.Community.Tasks.Xml Namespace


MetadataNames Property

XmlNodeTaskItem.MetadataNames Property
[image]

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MetadataNames As ICollection _
Implements ITaskItem.MetadataNames
C#
public ICollection MetadataNames { get; }
C++
public property ICollection MetadataNames sealed {
ICollection get();
}
J#
/** property */
public ICollection get_MetadataNames();
JScript
public function get MetadataNames() : ICollection

Implements

ITaskItem.MetadataNames

See Also

XmlNodeTaskItem Class
XmlNodeTaskItem Members
MSBuild.Community.Tasks.Xml Namespace


Methods

XmlNodeTaskItem Methods
[image]

Public Methods

 | Name | Description
Public method | CloneCustomMetadata |
Public method | CopyMetadataTo |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetMetadata |
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
 | op_Explicit | Returns the ItemSpec when the XmlNodeTaskItem is explicitly cast as a String
Public method | RemoveMetadata |
Public method | SetMetadata |
Public method | ToString | Overidden. Returns a string representation of the XmlNodeTaskItem.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

XmlNodeTaskItem Class
XmlNodeTaskItem Members
MSBuild.Community.Tasks.Xml Namespace


CloneCustomMetadata Method

XmlNodeTaskItem.CloneCustomMetadata Method
[image]

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Function CloneCustomMetadata() As IDictionary _
Implements ITaskItem.CloneCustomMetadata
C#
public IDictionary CloneCustomMetadata()
C++
public:
IDictionary CloneCustomMetadata() sealed
J#
public IDictionary CloneCustomMetadata()
JScript
public function CloneCustomMetadata() : IDictionary

Implements

ITaskItem.CloneCustomMetadata

See Also

XmlNodeTaskItem Class
XmlNodeTaskItem Members
MSBuild.Community.Tasks.Xml Namespace


CopyMetadataTo Method

XmlNodeTaskItem.CopyMetadataTo Method
[image]

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub CopyMetadataTo( _
ByVal destinationItem As ITaskItem _
) _
Implements ITaskItem.CopyMetadataTo
C#
public void CopyMetadataTo(
ITaskItem destinationItem
)
C++
public:
void CopyMetadataTo(
ITaskItem destinationItem
) sealed
J#
public void CopyMetadataTo(
ITaskItem destinationItem
)
JScript
public function CopyMetadataTo(
destinationItem : ITaskItem
)

Parameters

destinationItem

Implements

ITaskItem.CopyMetadataTo

See Also

XmlNodeTaskItem Class
XmlNodeTaskItem Members
MSBuild.Community.Tasks.Xml Namespace


GetMetadata Method

XmlNodeTaskItem.GetMetadata Method
[image]

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Function GetMetadata( _
ByVal metadataName As String _
) As String _
Implements ITaskItem.GetMetadata
C#
public string GetMetadata(
string metadataName
)
C++
public:
String GetMetadata(
String metadataName
) sealed
J#
public string GetMetadata(
string metadataName
)
JScript
public function GetMetadata(
metadataName : String
) : String

Parameters

metadataName

Implements

ITaskItem.GetMetadata

See Also

XmlNodeTaskItem Class
XmlNodeTaskItem Members
MSBuild.Community.Tasks.Xml Namespace


op_Explicit Operator

XmlNodeTaskItem.op_Explicit Operator
[image]

Returns the ItemSpec when the XmlNodeTaskItem is explicitly cast as a String

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Shared Narrowing Operator CType( _
ByVal taskItemToCast As XmlNodeTaskItem _
) As String
C#
public static string op_Explicit(
XmlNodeTaskItem taskItemToCast
)
C++
public:
static String op_Explicit(
XmlNodeTaskItem taskItemToCast
)
J#
JSharp does not support overloaded operators.
JScript
JScript supports the use of overloaded operators, but not the declaration of new ones.

Parameters

taskItemToCast
The XmlNodeTaskItem

See Also

XmlNodeTaskItem Class
XmlNodeTaskItem Members
MSBuild.Community.Tasks.Xml Namespace


RemoveMetadata Method

XmlNodeTaskItem.RemoveMetadata Method
[image]

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub RemoveMetadata( _
ByVal metadataName As String _
) _
Implements ITaskItem.RemoveMetadata
C#
public void RemoveMetadata(
string metadataName
)
C++
public:
void RemoveMetadata(
String metadataName
) sealed
J#
public void RemoveMetadata(
string metadataName
)
JScript
public function RemoveMetadata(
metadataName : String
)

Parameters

metadataName

Implements

ITaskItem.RemoveMetadata

See Also

XmlNodeTaskItem Class
XmlNodeTaskItem Members
MSBuild.Community.Tasks.Xml Namespace


SetMetadata Method

XmlNodeTaskItem.SetMetadata Method
[image]

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetMetadata( _
ByVal metadataName As String, _
ByVal metadataValue As String _
) _
Implements ITaskItem.SetMetadata
C#
public void SetMetadata(
string metadataName,
string metadataValue
)
C++
public:
void SetMetadata(
String metadataName,
String metadataValue
) sealed
J#
public void SetMetadata(
string metadataName,
string metadataValue
)
JScript
public function SetMetadata(
metadataName : String,
metadataValue : String
)

Parameters

metadataName
metadataValue

Implements

ITaskItem.SetMetadata

See Also

XmlNodeTaskItem Class
XmlNodeTaskItem Members
MSBuild.Community.Tasks.Xml Namespace


ToString Method

XmlNodeTaskItem.ToString Method
[image]

Returns a string representation of the XmlNodeTaskItem.

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()
C++
public:
virtual String ToString() override
J#
public override string ToString()
JScript
public override function ToString() : String

See Also

XmlNodeTaskItem Class
XmlNodeTaskItem Members
MSBuild.Community.Tasks.Xml Namespace


XmlQuery Class

XmlQuery Class
See Also Example Members
[image]

Reads a value or values from lines of XML

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class XmlQuery
Inherits Task
C#
public class XmlQuery : Task
C++
ref class XmlQuery : Task
J#
public class XmlQuery extends Task
JScript
public class XmlQuery extends Task

Example

Read an attribute value by selecting it with an XPath expression:

Copy Code
<ReadLinesFromFile File="web.config">
    <Output TaskParameter="Lines" ItemName="FileContents" />
</ReadLinesFromFile>

<XmlQuery Lines="@(FileContents)"
    XPath = "/configuration/system.web/compilation/@defaultLanguage">
    <Output TaskParameter="Values" PropertyName="CompilationLanguage" />
</XmlQuery>

<Message Text="The default language is $(CompilationLanguage)." />
Read attribute values (from an XML file) using item metadata on a selected element node:
Copy Code
<XmlQuery XmlFileName="$(MSBuildProjectDirectory)\web.config"
    XPath = "/configuration/system.web/compilation">
    <Output TaskParameter="Values" ItemName="CompilationElement" />
</XmlQuery>

<Message Text="The default language is: $(CompilationElement.defaultLanguage)." />
<Message Text="Debug is enabled: $(CompilationElement.debug)." />
Read an element value (requires use of the reserved metadata property "_value"):
Copy Code
<ReadLinesFromFile File="web.config">
    <Output TaskParameter="Lines" ItemName="FileContents" />
</ReadLinesFromFile>

<XmlQuery Lines="@(FileContents)"
    XPath = "/configuration/singleValue/LastName">
    <Output TaskParameter="Values" PropertyName="LastNameElement" />
</XmlQuery>

<Message Text="The last name is %(LastNameElement._value)" />

Remarks

Use the Lines property (possibly populated from the the ReadLinesFromFile task) if you want to perform multiple queries against some XML in memory. Use the XmlFileName property to query a large XML file.

An XPath expression can return multiple nodes in the Values collection. The number of nodes returned is availabe in the ValuesCount output TaskParameter.

When the XPath expression resolves to an element node, all of the attributes of the element are added as metadata to the returned ITaskItem. In addition, some reserved metadata properties are available on all element nodes. They are all prefixed with the ReservedMetaDataPrefix, which is a single underscore (_) by default.
Reserved Property
_value | The value of the node (non-xml text between the opening and closing tags).
_innerXml | The markup representing the children of this node.
_outerXml | The markup representing this node and all its child nodes.

Inheritance Hierarchy

System.Object
Microsoft.Build.Utilities.Task
MSBuild.Community.Tasks.Xml.XmlQuery

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

XmlQuery Members
MSBuild.Community.Tasks.Xml Namespace


XmlQuery Members

XmlQuery Members
See Also Example Constructors Properties Methods
[image]

Reads a value or values from lines of XML

The following tables list the members exposed by XmlQuery.

Public Constructors

 | Name | Description
Public method | XmlQuery | Initializes a new instance of the XmlQuery class.
Top

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Lines | The lines of a valid XML document
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | NamespaceDefinitions | A collection of prefix=namespace definitions used to query the XML document
Public property | ReservedMetaDataPrefix | The string that is prepended to all reserved metadata properties.
Public property | Values | The values selected by XPath
Public property | ValuesCount | The number of values returned in Values
Public property | XmlFileName | Gets or sets the name of an XML file to query
Public property | XPath | The query used to identify the values in the XML document
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. When overridden in a derived class, executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

XmlQuery Class
XmlQuery Members
MSBuild.Community.Tasks.Xml Namespace


XmlQuery Constructor

XmlQuery Constructor
[image]

Initializes a new instance of the XmlQuery class.

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public XmlQuery()
C++
public:
XmlQuery() sealed
J#
public XmlQuery()
JScript
public function XmlQuery()

See Also

XmlQuery Class
XmlQuery Members
MSBuild.Community.Tasks.Xml Namespace


Properties

XmlQuery Properties
See Also Example
[image]

Public Properties

 | Name | Description
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | Lines | The lines of a valid XML document
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | NamespaceDefinitions | A collection of prefix=namespace definitions used to query the XML document
Public property | ReservedMetaDataPrefix | The string that is prepended to all reserved metadata properties.
Public property | Values | The values selected by XPath
Public property | ValuesCount | The number of values returned in Values
Public property | XmlFileName | Gets or sets the name of an XML file to query
Public property | XPath | The query used to identify the values in the XML document
Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

See Also

XmlQuery Class
XmlQuery Members
MSBuild.Community.Tasks.Xml Namespace


Lines Property

XmlQuery.Lines Property
[image]

The lines of a valid XML document

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Lines As ITaskItem[]
C#
public ITaskItem[] Lines { get; set; }
C++
public property ITaskItem[] Lines sealed {
array<ITaskItem>^ get();
void set(array<ITaskItem>^ value);
}
J#
/** property */
public ITaskItem[] get_Lines();

/** property */
public void set_Lines(ITaskItem[] value);
JScript
public function get Lines() : ITaskItem[]

public function set Lines(value : ITaskItem[]);

See Also

XmlQuery Class
XmlQuery Members
MSBuild.Community.Tasks.Xml Namespace


NamespaceDefinitions Property

XmlQuery.NamespaceDefinitions Property
See Also Example
[image]

A collection of prefix=namespace definitions used to query the XML document

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property NamespaceDefinitions As ITaskItem[]
C#
public ITaskItem[] NamespaceDefinitions { get; set; }
C++
public property ITaskItem[] NamespaceDefinitions sealed {
array<ITaskItem>^ get();
void set(array<ITaskItem>^ value);
}
J#
/** property */
public ITaskItem[] get_NamespaceDefinitions();

/** property */
public void set_NamespaceDefinitions(ITaskItem[] value);
JScript
public function get NamespaceDefinitions() : ITaskItem[]

public function set NamespaceDefinitions(value : ITaskItem[]);

Example

Defining multiple namespaces:

Copy Code
<XmlMassUpdate ContentFile="web.config"
  SubstitutionsRoot="/configuration/substitutions"
     NamespaceDefinitions = "soap=http://www.w3.org/2001/12/soap-envelope;x=http://www.w3.org/1999/XSL/Transform">
/>

See Also

XmlQuery Class
XmlQuery Members
MSBuild.Community.Tasks.Xml Namespace


ReservedMetaDataPrefix Property

XmlQuery.ReservedMetaDataPrefix Property
[image]

The string that is prepended to all reserved metadata properties.

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property ReservedMetaDataPrefix As String
C#
public string ReservedMetaDataPrefix { get; set; }
C++
public property string ReservedMetaDataPrefix sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_ReservedMetaDataPrefix();

/** property */
public void set_ReservedMetaDataPrefix(string value);
JScript
public function get ReservedMetaDataPrefix() : String

public function set ReservedMetaDataPrefix(value : String);

Remarks

The default value is a single underscore: '_'

All attributes of an element node are added as metadata to the returned ITaskItem, so this property can be used to avoid clashes with the reserved properties. For example, if you selected the following node:

Copy Code
 <SomeNode _name="x" _value="y" />
the _value attribute would clash with the value reserved property, when using the default prefix. If you set the ReservedMetaDataPrefix to another value (two underscores '__') there would be no clash. You would be able to select the attribute using %(item._value) and the value of the node using %(item.__value).

See Also

XmlQuery Class
XmlQuery Members
MSBuild.Community.Tasks.Xml Namespace


Values Property

XmlQuery.Values Property
[image]

The values selected by XPath

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Output>
Public ReadOnly Property Values As ITaskItem[]
C#
[Output]
public ITaskItem[] Values { get; }
C++
[Output]
public property ITaskItem[] Values sealed {
array<ITaskItem>^ get();
}
J#
/** @attribute Output() */
/** property */
public ITaskItem[] get_Values();
JScript
public function get Values() : ITaskItem[]

See Also

XmlQuery Class
XmlQuery Members
MSBuild.Community.Tasks.Xml Namespace


ValuesCount Property

XmlQuery.ValuesCount Property
[image]

The number of values returned in Values

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Output>
Public ReadOnly Property ValuesCount As Integer
C#
[Output]
public int ValuesCount { get; }
C++
[Output]
public property int ValuesCount sealed {
int get();
}
J#
/** @attribute Output() */
/** property */
public int get_ValuesCount();
JScript
public function get ValuesCount() : int

See Also

XmlQuery Class
XmlQuery Members
MSBuild.Community.Tasks.Xml Namespace


XmlFileName Property

XmlQuery.XmlFileName Property
[image]

Gets or sets the name of an XML file to query

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property XmlFileName As String
C#
public string XmlFileName { get; set; }
C++
public property string XmlFileName sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_XmlFileName();

/** property */
public void set_XmlFileName(string value);
JScript
public function get XmlFileName() : String

public function set XmlFileName(value : String);

Property Value

The full path of the XML file.

See Also

XmlQuery Class
XmlQuery Members
MSBuild.Community.Tasks.Xml Namespace


XPath Property

XmlQuery.XPath Property
[image]

The query used to identify the values in the XML document

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<Required>
Public Property XPath As String
C#
[Required]
public string XPath { get; set; }
C++
[Required]
public property string XPath sealed {
String get();
void set(String value);
}
J#
/** @attribute Required() */
/** property */
public string get_XPath();

/** property */
public void set_XPath(string value);
JScript
public function get XPath() : String

public function set XPath(value : String);

See Also

XmlQuery Class
XmlQuery Members
MSBuild.Community.Tasks.Xml Namespace


Methods

XmlQuery Methods
See Also Example
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overidden. When overridden in a derived class, executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

XmlQuery Class
XmlQuery Members
MSBuild.Community.Tasks.Xml Namespace


Execute Method

XmlQuery.Execute Method
[image]

When overridden in a derived class, executes the task.

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute() As Boolean _
Implements ITask.Execute
C#
public override bool Execute()
C++
public:
virtual bool Execute() override
J#
public override bool Execute()
JScript
public override function Execute() : bool

Return Value

True if the task successfully executed; otherwise, false.

Implements

ITask.Execute

See Also

XmlQuery Class
XmlQuery Members
MSBuild.Community.Tasks.Xml Namespace


XmlTaskHelper Class

XmlTaskHelper Class
See Also Members
[image]

Provides methods used by all of the XML tasks

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class XmlTaskHelper
C#
public class XmlTaskHelper
C++
ref class XmlTaskHelper
J#
public class XmlTaskHelper
JScript
public class XmlTaskHelper

Inheritance Hierarchy

System.Object
MSBuild.Community.Tasks.Xml.XmlTaskHelper

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

XmlTaskHelper Members
MSBuild.Community.Tasks.Xml Namespace


XmlTaskHelper Members

XmlTaskHelper Members
See Also Constructors Methods
[image]

Provides methods used by all of the XML tasks

The following tables list the members exposed by XmlTaskHelper.

Public Constructors

 | Name | Description
Public method | XmlTaskHelper | Initializes a new instance of the XmlTaskHelper class.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
 | JoinItems | Concatenates the string value of a list of ITaskItems into a single string
 | LoadNamespaceDefinitionItems | Uses the prefix=namespace definitions in definitions to populate namespaceManager
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

XmlTaskHelper Class
XmlTaskHelper Members
MSBuild.Community.Tasks.Xml Namespace


XmlTaskHelper Constructor

XmlTaskHelper Constructor
[image]

Initializes a new instance of the XmlTaskHelper class.

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public XmlTaskHelper()
C++
public:
XmlTaskHelper() sealed
J#
public XmlTaskHelper()
JScript
public function XmlTaskHelper()

See Also

XmlTaskHelper Class
XmlTaskHelper Members
MSBuild.Community.Tasks.Xml Namespace


Methods

XmlTaskHelper Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
 | JoinItems | Concatenates the string value of a list of ITaskItems into a single string
 | LoadNamespaceDefinitionItems | Uses the prefix=namespace definitions in definitions to populate namespaceManager
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

XmlTaskHelper Class
XmlTaskHelper Members
MSBuild.Community.Tasks.Xml Namespace


JoinItems Method

XmlTaskHelper.JoinItems Method
[image]

Concatenates the string value of a list of ITaskItems into a single string

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function JoinItems( _
ByVal items As ITaskItem[] _
) As String
C#
public static string JoinItems(
ITaskItem[] items
)
C++
public:
static String JoinItems(
array<ITaskItem>^ items
)
J#
public static string JoinItems(
ITaskItem[] items
)
JScript
public static function JoinItems(
items : ITaskItem[]
) : String

Parameters

items
The items to concatenate

Return Value

A single string containing the values from all of the items

See Also

XmlTaskHelper Class
XmlTaskHelper Members
MSBuild.Community.Tasks.Xml Namespace


LoadNamespaceDefinitionItems Method

XmlTaskHelper.LoadNamespaceDefinitionItems Method
[image]

Uses the prefix=namespace definitions in definitions to populate namespaceManager

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub LoadNamespaceDefinitionItems( _
ByVal namespaceManager As XmlNamespaceManager, _
ByVal definitions As ITaskItem[] _
)
C#
public static void LoadNamespaceDefinitionItems(
XmlNamespaceManager namespaceManager,
ITaskItem[] definitions
)
C++
public:
static void LoadNamespaceDefinitionItems(
XmlNamespaceManager namespaceManager,
array<ITaskItem>^ definitions
)
J#
public static void LoadNamespaceDefinitionItems(
XmlNamespaceManager namespaceManager,
ITaskItem[] definitions
)
JScript
public static function LoadNamespaceDefinitionItems(
namespaceManager : XmlNamespaceManager,
definitions : ITaskItem[]
)

Parameters

namespaceManager
The XmlNamespaceManager to populate.
definitions
The prefix=namespace definitions.

See Also

XmlTaskHelper Class
XmlTaskHelper Members
MSBuild.Community.Tasks.Xml Namespace


MSBuild.Community.Tasks Hierarchy

MSBuild.Community.Tasks Hierarchy
System.Object
Microsoft.Build.Utilities.Task ---- Microsoft.Build.Framework.ITask
Microsoft.Build.Utilities.ToolTask
MSBuild.Community.Tasks.FxCop
MSBuild.Community.Tasks.GacUtil
MSBuild.Community.Tasks.ILMerge
MSBuild.Community.Tasks.NDoc
MSBuild.Community.Tasks.NUnit
MSBuild.Community.Tasks.AssemblyInfo
MSBuild.Community.Tasks.Attrib
MSBuild.Community.Tasks.FileUpdate
MSBuild.Community.Tasks.FtpUpload
MSBuild.Community.Tasks.GetSolutionProjects
MSBuild.Community.Tasks.Mail
MSBuild.Community.Tasks.Move
MSBuild.Community.Tasks.Prompt
MSBuild.Community.Tasks.RegexBase
MSBuild.Community.Tasks.RegexMatch
MSBuild.Community.Tasks.RegexReplace
MSBuild.Community.Tasks.RegistryRead
MSBuild.Community.Tasks.RegistryWrite
MSBuild.Community.Tasks.Script
MSBuild.Community.Tasks.ServiceQuery
MSBuild.Community.Tasks.ServiceController
MSBuild.Community.Tasks.Sleep
MSBuild.Community.Tasks.SqlExecute
MSBuild.Community.Tasks.TemplateFile
MSBuild.Community.Tasks.Time
MSBuild.Community.Tasks.Unzip
MSBuild.Community.Tasks.Version
MSBuild.Community.Tasks.WebDownload
MSBuild.Community.Tasks.XmlRead
MSBuild.Community.Tasks.XmlUpdate
MSBuild.Community.Tasks.Xslt
MSBuild.Community.Tasks.Zip
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
MSBuild.Community.Tasks.GacUtilCommands
MSBuild.Community.Tasks.ServiceActions

See Also

MSBuild.Community.Tasks Namespace


MSBuild.Community.Tasks.AspNet Hierarchy

MSBuild.Community.Tasks.AspNet Hierarchy
System.Object
Microsoft.Build.Utilities.Task ---- Microsoft.Build.Framework.ITask
Microsoft.Build.Utilities.ToolTask
MSBuild.Community.Tasks.AspNet.InstallAspNet

See Also

MSBuild.Community.Tasks.AspNet Namespace


MSBuild.Community.Tasks.IIS Hierarchy

MSBuild.Community.Tasks.IIS Hierarchy
System.Object
Microsoft.Build.Utilities.Task ---- Microsoft.Build.Framework.ITask
MSBuild.Community.Tasks.IIS.WebBase
MSBuild.Community.Tasks.IIS.AppPoolController
MSBuild.Community.Tasks.IIS.AppPoolCreate
MSBuild.Community.Tasks.IIS.AppPoolDelete
MSBuild.Community.Tasks.IIS.WebDirectoryCreate
MSBuild.Community.Tasks.IIS.WebDirectoryDelete
MSBuild.Community.Tasks.IIS.WebDirectoryScriptMap
MSBuild.Community.Tasks.IIS.WebDirectorySetting
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
MSBuild.Community.Tasks.IIS.AppPoolControllerActions
MSBuild.Community.Tasks.IIS.WebBase.ApplicationPoolAction
MSBuild.Community.Tasks.IIS.WebBase.ApplicationPoolState
MSBuild.Community.Tasks.IIS.WebBase.IISVersion

See Also

MSBuild.Community.Tasks.IIS Namespace


MSBuild.Community.Tasks.Install Hierarchy

MSBuild.Community.Tasks.Install Hierarchy
System.Object
Microsoft.Build.Utilities.Task ---- Microsoft.Build.Framework.ITask
Microsoft.Build.Utilities.ToolTask
MSBuild.Community.Tasks.Install.InstallAssembly
MSBuild.Community.Tasks.Install.UninstallAssembly

See Also

MSBuild.Community.Tasks.Install Namespace


MSBuild.Community.Tasks.JavaScript Hierarchy

MSBuild.Community.Tasks.JavaScript Hierarchy
System.Object
Microsoft.Build.Utilities.Task ---- Microsoft.Build.Framework.ITask
MSBuild.Community.Tasks.JavaScript.JSCompress

See Also

MSBuild.Community.Tasks.JavaScript Namespace


MSBuild.Community.Tasks.Math Hierarchy

MSBuild.Community.Tasks.Math Hierarchy
System.Object
Microsoft.Build.Utilities.Task ---- Microsoft.Build.Framework.ITask
MSBuild.Community.Tasks.Math.MathBase
MSBuild.Community.Tasks.Math.Add
MSBuild.Community.Tasks.Math.Divide
MSBuild.Community.Tasks.Math.Modulo
MSBuild.Community.Tasks.Math.Multiple
MSBuild.Community.Tasks.Math.Subtract

See Also

MSBuild.Community.Tasks.Math Namespace


MSBuild.Community.Tasks.Schema Hierarchy

MSBuild.Community.Tasks.Schema Hierarchy
System.Object
Microsoft.Build.Utilities.Task ---- Microsoft.Build.Framework.ITask
MSBuild.Community.Tasks.Schema.TaskSchema
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
MSBuild.Community.Tasks.Schema.TaskListAssemblyFormatType

See Also

MSBuild.Community.Tasks.Schema Namespace


MSBuild.Community.Tasks.SourceSafe Hierarchy

MSBuild.Community.Tasks.SourceSafe Hierarchy
System.Object
Microsoft.Build.Utilities.Task ---- Microsoft.Build.Framework.ITask
MSBuild.Community.Tasks.SourceSafe.VssBase
MSBuild.Community.Tasks.SourceSafe.VssAdd
MSBuild.Community.Tasks.SourceSafe.VssDiff
MSBuild.Community.Tasks.SourceSafe.VssRecursiveBase
MSBuild.Community.Tasks.SourceSafe.VssCheckin
MSBuild.Community.Tasks.SourceSafe.VssCheckout
MSBuild.Community.Tasks.SourceSafe.VssGet
MSBuild.Community.Tasks.SourceSafe.VssHistory
MSBuild.Community.Tasks.SourceSafe.VssLabel
MSBuild.Community.Tasks.SourceSafe.VssUndoCheckout
MSBuild.Community.Tasks.SourceSafe.VssClean

See Also

MSBuild.Community.Tasks.SourceSafe Namespace


MSBuild.Community.Tasks.SqlServer Hierarchy

MSBuild.Community.Tasks.SqlServer Hierarchy
System.Object
Microsoft.Build.Utilities.Task ---- Microsoft.Build.Framework.ITask
MSBuild.Community.Tasks.SqlServer.ExecuteDDL

See Also

MSBuild.Community.Tasks.SqlServer Namespace


MSBuild.Community.Tasks.Subversion Hierarchy

MSBuild.Community.Tasks.Subversion Hierarchy
System.Object
Microsoft.Build.Utilities.Task ---- Microsoft.Build.Framework.ITask
Microsoft.Build.Utilities.ToolTask
MSBuild.Community.Tasks.Subversion.SvnClient
MSBuild.Community.Tasks.Subversion.SvnCheckout
MSBuild.Community.Tasks.Subversion.SvnCommit
MSBuild.Community.Tasks.Subversion.SvnCopy
MSBuild.Community.Tasks.Subversion.SvnExport
MSBuild.Community.Tasks.Subversion.SvnInfo
MSBuild.Community.Tasks.Subversion.SvnUpdate
MSBuild.Community.Tasks.Subversion.SvnVersion
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
MSBuild.Community.Tasks.Subversion.NodeKind
MSBuild.Community.Tasks.Subversion.Schedule

See Also

MSBuild.Community.Tasks.Subversion Namespace


MSBuild.Community.Tasks.Tfs Hierarchy

MSBuild.Community.Tasks.Tfs Hierarchy
System.Object
Microsoft.Build.Utilities.Task ---- Microsoft.Build.Framework.ITask
MSBuild.Community.Tasks.Tfs.TfsVersion
MSBuild.Community.Tasks.Tfs.IServer
System.Exception ---- System.Runtime.Serialization.ISerializable
MSBuild.Community.Tasks.Tfs.TeamFoundationServerException

See Also

MSBuild.Community.Tasks.Tfs Namespace


MSBuild.Community.Tasks.Xml Hierarchy

MSBuild.Community.Tasks.Xml Hierarchy
System.Object
Microsoft.Build.Utilities.Task ---- Microsoft.Build.Framework.ITask
MSBuild.Community.Tasks.Xml.XmlMassUpdate
MSBuild.Community.Tasks.Xml.XmlQuery
MSBuild.Community.Tasks.Xml.XmlNodeTaskItem ---- Microsoft.Build.Framework.ITaskItem
MSBuild.Community.Tasks.Xml.XmlTaskHelper

See Also

MSBuild.Community.Tasks.Xml Namespace


SDK Link Manager

NDoc Utilities
SDK Link Manager

SDK Link Namespace


WebBase Class Hierarchy

WebBase Hierarchy

The following table lists the types derived from WebBase .

Derived Types

Type | Description
AppPoolController | Allows control for an application pool on a local or remote machine with IIS installed. The default is to control the application pool on the local machine. If connecting to a remote machine, you can specify the Username and Password for the task to run under.
AppPoolCreate | Creates a new application pool on a local or remote machine with IIS installed. The default is to create the new application pool on the local machine. If connecting to a remote machine, you can specify the Username and Password for the task to run under.
AppPoolDelete | Deletes an existing application pool on a local or remote machine with IIS installed. The default is to delete an existing application pool on the local machine. If connecting to a remote machine, you can specify the Username and Password for the task to run under.
WebDirectoryCreate | Creates a new web directory on a local or remote machine with IIS installed. The default is to create the new web directory on the local machine. The physical path is required to already exist on the target machine. If connecting to a remote machine, you can specify the Username and Password for the task to run under.
WebDirectoryDelete | Deletes a web directory on a local or remote machine with IIS installed. The default is to delete the web directory on the local machine. If connecting to a remote machine, you can specify the Username and Password for the task to run under.
WebDirectoryScriptMap | Sets an application mapping for a filename extension on an existing web directory.
WebDirectorySetting | Reads and modifies a web directory configuration setting.

See Also

WebBase Class
WebBase Members
MSBuild.Community.Tasks.IIS Namespace


VssRecursiveBase Class Hierarchy

VssRecursiveBase Hierarchy

The following table lists the types derived from VssRecursiveBase .

Derived Types

Type | Description
VssCheckin | Task that executes a checkin against a VSS Database.
VssCheckout | Task that executes a checkout of files or projects against a Visual SourceSafe database.
VssGet | Task that retireves an item or project from a Visual SourceSafe database.
VssHistory | Generates an XML file containing details of all changes made to a Visual SourceSafe project or file between specified labels or dates.
VssLabel | Task that applies a label to a Visual SourceSafe item.
VssUndoCheckout | Task that undoes a checkout of files or projects against a Visual SourceSafe database.

See Also

VssRecursiveBase Class
VssRecursiveBase Members
MSBuild.Community.Tasks.SourceSafe Namespace


SvnClient Class Hierarchy

SvnClient Hierarchy

The following table lists the types derived from SvnClient .

Derived Types

Type | Description
SvnCheckout | Checkout a local working copy of a Subversion repository.
SvnCommit | Subversion Commit command
SvnCopy | Copy a file or folder in Subversion
SvnExport | Export a folder from a Subversion repository
SvnInfo | Run the "svn info" command and parse the output
SvnUpdate | Subversion Update command

See Also

SvnClient Class
SvnClient Members
MSBuild.Community.Tasks.Subversion Namespace